Animgif Help

Anim_Gif .OCX
V1.0

Description

Animgif is an animated gif viewer that allows VB6, C++ etc.Programmers to use animated gifs in their programs. There are frame change events as well as the ability to pause, play, automatically play and check a gif for animation as a hidden control as well as loading the standard BMP, JPG, GIF, WMF, ICO file types. This OCX does not store the graphic into the source code so all needed gifs must be included with your application.


animgifProperties

Properties:

.File_name

The full path and filename to the graphics file. Valid formats are BMP, GIF, JPG, WMF, ICO, CUR.

* Note: The ocx does not embed the graphic into your executable, it refers to the actual file on disk.

.Autostart

Starts playing the animated gif in runtime once it's loaded

.checkonly

Doesn't show a graphic but the value of isanimated property is updated

.isanimated

Return a boolean value if the graphic is an animation or not.

.maxframe

Read-Only, Returns the maximum frame number in an animation. 0 is the first.

.Speed_adj

Adjusts the animation speed from 1 to 400 % of the normal speed.

.busy

Boolean read only which is set to true while it is loading a gif.


Events

FrameChange(framenumber As Long)

This event fires when the frame in an animated gif changes and returns the current frame number

The remaining events are as per the usual controls.


Methods

.play (frame number)

If the frame number is omitted or has a value of -1 then the animation starts playing from the current frame.

If the frame number has a valid frame value it will only play that frame.

If the frame number is -2 then the animation will step through the frames.

.pause

Pauses the animation at the currently displayed frame


Bug Fixes

Bug Reports:

Fixed an error in individual frame positioning

Fixed an error in background color masking.

To report a bug please email us at cawevb@yahoo.com


Registration:

Registration for this software is $15.00 CDN Funds. This allows the user royalty free use of this software with full distribution rights.

To request to register this software please email us at cawevb@yahoo.com