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Introduction
Cross-Stitch  Designer  is  a  Windows program that  allows you  to  create  and edit  cross-stitch
patterns.  The goal of this program is to display your pattern design on a computer so that you
can see how the stitched pattern will appear before any stitching is done.   

Features
This program supports full, half, quarter, and back stitches.   Many of the standard thread colors
are provided in a list from which you chose when creating a pattern.  Complete printing capability
is provided.  You can print a pattern using symbols for representing thread types and colors on a
standard single-color printer, or print a pattern using stitches and actual colors on a color printer. 

All pattern editing is done using the mouse.  You use the mouse to select the type of  stitch, the
thread color, and the location of each stitch.  The mouse can also be used to select a region of a
pattern.  Regions can be moved to another location on the pattern, copied to the clipboard, cut
from the pattern, cleared, or flipped. 

Cross-Stitch Designer also supports the conversion of bitmaps into a pattern region.  This very
powerful feature allows you to create patterns using existing graphics files.   These bitmaps can
be created using graphics programs such as the Windows Paintbrush program or any program
that can create Windows bitmaps.   

Cross-Stitch Designer supports the 256 color VGA mode, as well as the standard VGA mode.
This capability allows patterns to be displayed in a more true-to-life manner since a wider range
of thread colors can be represented.   

Hardware and Software Requirements
Cross-Stitch Designer must be used with Windows 3.1 or later.  This implies that the computer
used must be capable of running Windows.  This computer should have a VGA graphics display
and adapter, and a mouse or other pointing device.  To use the hardcopy print-out capability of
this program, a Windows-supported printer is required.
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Chapter 1 -  Getting Started
This chapter covers how to get Cross-Stitch Designer installed, how to run and exit the program,
and how to activate the on-line help feature.

Installation
Please follow these steps to install Cross-Stitch Designer.
1. Create a directory on your harddisk called 'XSTITCH'.  This can be done either at the DOS

prompt or from within the Windows File Manager.   For the DOS prompt case,  the following
command can be used:

md \xstitch

This will create a directory called 'XSTITCH' in the root directory of the current drive.  For
more information on how to create directories, please see the DOS manual or File Manager
documentation.

2. Copy all  of the files that came with your copy of Cross-Stitch Designer into the directory
created in step 1.

3. Add a program item for Cross-Stitch Designer to one of your Program Manager groups.  This
is done by selecting the 'File' menu of Program Manger, followed by the 'New' item, and then
the 'Program Item' option of the dialog box that is displayed.   At this point, another dialog box
will be displayed where you can specify the following:

Description:  Cross-Stitch Designer
Command Line:  c:\xstitch\xstitch.exe
Working Directory: c:\xstitch

The other fields of this box can be left as is. Note that your drive letter for the Command Line
field may be different.  Press the 'Ok' button to save your new program item.   At this point,
you should have a program icon displayed for Cross-Stitch Designer.  The icon looks like a
small piece of cloth with a needle through it.

Starting and Exiting 
To run Cross-Stitch Designer, simply double-click the Cross-Stitch Designer icon.  The program
banner  will  then  be  displayed  for  a  few seconds  or  until  you  click  the  mouse  on  it.   After
acknowledging the notice, the program will be ready for your commands.

You can exit Cross-Stitch Designer simply by selecting the 'Exit' item of the 'File' menu.

Getting Help
Cross-Stitch Designer provides on-line help.  To access this help, select the 'Index' item of the
'Help' menu.  You will be given an index of topics from which you can chose.  You may also
search for information.  Please refer to the Windows manual for more information on how to use
the help system.  

To make the best use of this help information, please explore its contents when you have an
opportunity.    
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Chapter 2 - Basics
This chapter explains basic how-to steps.  These should be understood before proceeding to the
following chapters.  Specifically, this chapter describes the window layout, how to draw stitches,
how to select colors into a pattern, and how to select an edit region.  This chapter assumes that
you are familiar with basic windowing steps such as moving, sizing, minimizing, and maximizing
windows, as well as, using menus.  If you are new to Windows and need to know more about
basic windowing, please refer to the Microsoft Windows manual. 

Window Layout
The Cross-Stitch Designer window is organized into several areas.  Some of these are standard
to windows of all  programs.  Those that  are not  standard window areas,  or are particular to
Cross-Stitch Designer are described in the following sections.

Title Bar
The title bar is standard for all windows.  The content, however, varies between applications.  For
this program, the title bar displays the name of the program and the name of the current pattern
that is open.  The pattern name is actually the filename of the pattern with the complete file path
shown as well.  

Menu Bar
The menu bar, which is located below the title bar, consists of menus that are specific to this
program. 

Tool Bar
The tool  bar  consists  of  icons that  are  located below the menu bar.   These icons represent
drawing tools that are used when drawing stitches, deleting stitches, or when selecting portions of
the pattern.  The following describes the icons starting from the left-most icon:

Full-stitch icon -  Used to draw/delete full stitches
Half-stitch icons (2 icons) - Used to draw/delete one-half stitches
Quarter-stitch icons (4 icons) - Used to draw/delete one-quarter stitches
Back-stitch icon - Used to draw/delete back stitches
Select icon - Used to select a region of the pattern for editing

Pattern Area
The pattern area, as its name implies, is the area where the current pattern is displayed.  This
area comprises the majority of the window so that as much of the pattern as possible can be seen
at one time.  All drawing is done in this part of the window.  Depending on the size of the pattern
and the current viewing options, only a portion of the current pattern may fit in this area.  To allow
other areas of the pattern to be viewed in this case, scroll bars are provided on the bottom and/or
right sides of the pattern.  

Thread Palette
The thread palette consists of 30 boxes at the bottom of the window.  Each box can be set to a
particular color.  These boxes are used to select a thread color when drawing stitches.   Only one
of these boxes can be selected at any given time.  The currently selected box is indicated by a
dashed border.  As will be described in following sections, a thread box can be double-clicked to
open the Select Thread dialog box.  The thread boxes can also be clicked and moved on top of
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other boxes to allow you to combine colors that you no longer want to be distinct.
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Status Bar
The status bar is located at the bottom of the window.  The status bar displays the following:

- The mouse coordinates
- The selected region size (if any)
- The currently selected color; color number and description
- The color used in the square pointed-to by the cursor

Please note that the used color information in the status bar only corresponds to the currently
selected  type  of  tool.   For  example,  if  the  full-stitch  tool  is  selected,  then  the  used  color
information will only be displayed for those squares which contain a full stitch.   

Drawing and Erasing Stitches
Follow these steps to draw a stitch on the current pattern.

1. Select the color to be used by clicking one of the thread boxes at the bottom of the screen.

2. Select the stitch type by clicking on one of the tool icons.

3. Move the mouse pointer to the location on the pattern where you want to add a stitch.  Press
the left mouse button to drop the stitch.

4. Continue drawing with the current color and stitch type or select a new type and/or color.

Note that you can draw continuously by holding the left mouse button down and dragging it over
the pattern.  A stitch will be drawn in every square that the mouse touches.  Any time that you
draw over another stitch, the new stitch will replace the current stitch.

To erase a stitch, follow these steps.

1. Select the stitch type by clicking on one of the tool icons.

2. Put the mouse pointer on top of the stitch to be erased.  Press the right mouse button.  

Note that you can erase continuously by holding the left mouse button down and dragging it over
the pattern.  Only the currently selected type of stitch will erased.

Drawing and Erasing Back Stitches
Back stitches are drawn differently than the other types of stitches.  To draw a back stitch, follow
these steps.

1. Select the color to be used by clicking one of the thread boxes at the bottom of the screen.

2. Select  the back stitch icon of the tool menu by clicking it with the mouse.

3. Enable grid lines if they are not already enabled by selecting the 'Grid'  item of the 'View'
menu.

4. Put the mouse pointer at the crossing of two grid lines where you want the back stitch to
begin. 
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5. Press and hold the left mouse button.

6. Move the mouse pointer to the location where the back stitch should end.
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7. Release the mouse button.

Back  stitches  can  only  be  drawn in  the  vertical,  horizontal,  or  45-degree  diagonal  direction.
While drawing a back stitch, a dotted line will appear.  This dotted line shows where the back
stitch will be drawn when the mouse button is released.

A  cross-stitch square can have several back stitches passing through it.  However, the color of all
back stitches passing through a given square must be the same.

To delete a back stitch, follow the same instructions above except use the right mouse button
instead of the left mouse button.   Note that you can delete all or only part of a series of back
stitches that were originally drawn together as one line.  

Selecting Regions
Some editing operations require that a block of squares of the pattern be specified.  Such a block
is called a region.  Follow these steps to select a region.

1. Select the 'Select' icon of the tool menu.

2. Move the mouse to one corner of the desired region.

3. Press and hold down the left mouse button.

4. While holding the left mouse button down, move the mouse to the opposite corner of the
region.

5. Release the mouse button.

When a region is selected, a dotted box is displayed around it, and the size of the region is shown
in the status window.  To cancel a selection, simply click outside of the region on the pattern or
click the 'Select' icon again.
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Chapter 3 -  Creating a Pattern
This  chapters  takes a  step-by-step approach at  describing  how to  create  a  new pattern.   It
assumes that you understand the procedures described in Chapter 2.

Opening a New Pattern
The first step in creating a new pattern is creating a blank pattern of the desired size.  This is
done by selecting the 'New' item of the 'File' menu.  When 'New' is selected, a dialog box will
appear.  In this box, you specify the width and height of the new pattern.  The maximum size is
999 by 999.  Note that the larger the pattern, the more memory that will be necessary in your PC.
If you try to select a size that is too large, the program will inform you.  After pressing the 'Ok'
button of the New dialog box,  the pattern area of the window will be cleared and redrawn to the
new size.

Saving the Pattern
It is a good idea to immediately save the new pattern after creating it.  Since your new pattern has
not been saved before, you will need to use the 'Save As' item of the 'File' menu.  This menu item
should be used the first time a pattern is to be saved and whenever you want to save a pattern
using a different filename.

When you select the 'Save As' item, a dialog box will be displayed.  This is a standard Windows
dialog box that allows you to specify the filename and location.  The pattern will be saved when
you press the 'Ok' button.

It is a good idea to save the pattern every so often while you are drawing in addition to when you
are  finished.   This  helps  to  prevent  a  power  failure  or  other  unfortunate  circumstance  from
causing your work to be lost.  To save your pattern using the current filename, select the 'Save'
item of the 'File' menu or the function key F2. 

When a file is saved, the following information is saved with it:
Stitches
Thread Palette
Definitions of all threads listed in the palette
Pattern Information
Font and font size used for symbolic mode
Font and font size used for the pattern information print-out
Symbol used for each thread of the palette

Note that the thread definitions of all threads used in a pattern are saved in the pattern file.  When
a pattern is opened, a check is made to make sure that all of the threads required for the pattern
are listed in the full thread list.  If a thread is not found, the thread definition is automatically
added.  If the thread is available but its color is not exactly the same, then the user is prompted to
choose between the color in the pattern and the color in the thread list.  This feature makes it
easier to share pattern designs among users.

Setting-Up the Thread Palette
The thread palette, located at the bottom of the screen, contains the thread colors that have been
selected for the current pattern.  A default thread palette is automatically setup when you run the
program.  Very likely you will want to select different colors for your particular pattern.  To do this,
follow these steps.
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1. Double-click the box of the thread palette that you want to change.  This will cause the Select
Thread dialog box to open.
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2. Select the thread type that you want to use; i.e. DMC, ANC, or custom.  Currently, only DMC
colors are provided with Cross-Stitch Designer.

3. Select one of the threads shown in the list of threads by clicking it with the mouse.   You may
have to scroll the list to find the color that you want.

4. Press the 'Use' button to use it in your pattern.

5. Select the 'Select Symbol' item of the 'Threads' menu to choose a symbol to be used for the
color when viewing the pattern in the symbolic display mode.  

If the thread that you want to use is not shown in the thread list, then you can define the thread if
you know its color and number.  See chapter 5 for more information. 
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You can repeat the above steps as many times as needed to select enough threads for your
pattern.   Remember, you can change the colors in the thread palette at any time.  When you
change a thread selection, the corresponding threads that are in the pattern will be updated to
reflect the new color.  Also note that it is okay to initially have too many shades of a particular
color used in your pattern since you can always reduce the number of threads in the palette by
merging two thread colors together.   See the section in this chapter on Editing Patterns for more
information.

Drawing the Pattern
After setting-up a blank pattern of the desired size and choosing a set of thread colors, it is now
time to draw your pattern.  Drawing is done as described in chapter 2.  Please review that chapter
if you need a refresher.

Changing the Fabric Type
You can change the way that a pattern is displayed at any time.  A pattern can be displayed on
either Aida 11, 14, or 18 with either a white or ivory fabric color.  Use the 'Fabric' menu to change
the fabric display.  

You can also view a pattern using a non-standard stitch size.  To view most or all of a pattern,
select the 'Zoom out' item of the 'Fabric' menu.  The zoom-out mode is useful when you want to
select a large region for importing a large bitmap.  In the zoom-out mode, the pattern can be
zoomed-out to the point where one stitch square equals one pixel on the display.  In most cases
the complete pattern is visible when zoomed-out.

To take a close-up view of a region of a pattern, select a region and then the 'Zoom-in' item of the
'Fabric' menu.  The zoom-in mode is useful for taking a close look at areas where one-quarter
stitches are used or when you are drawing letters.

Editing the Pattern
The following sections discuss various ways to edit a pattern.  For some of these methods, a
pattern region must first be selected.  If necessary, please refer to chapter 2 for details on how to
select a pattern region.

Moving Regions
Often it is necessary to adjust the position of part of a pattern.  To move a selected region, move
the mouse pointer into the region and then press and hold the left mouse button.  While holding
the mouse button, move the mouse to position the dotted selection box in the desired location.
When the selection box is where you want it, release the mouse button.  The region will then be
moved to the new location.

Deleting Regions
To delete a selected region, select the 'Clear' item of the 'Edit' menu.  

Erasing Stitches
Please see chapter 2 for instructions on how to erase stitches.

Changing Thread Colors
To replace a thread currently selected for a pattern,  double-click on the corresponding thread box
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at the bottom of the window.  This will cause the Select Thread dialog box to be displayed.  At that
point, select the thread type and thread color to be used.  Next, press the 'Use' button to use the
selected color.  This will cause the pattern display to be updated as necessary.
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Merging Thread Colors
Sometimes you may find it desirable to combine two threads of the palette into the same thread.
For example, assume that you have a light green thread and a very-light green thread in the
palette and that you have drawn stitches using both colors.  Now assume that you want to use
light green for both cases.  The hard way to make this change would be to manually redraw all
very-light green stitches as light green stitches.  The easy way to make this change is to drag the
very-light green color box that you no longer want over the light green color box, and then drop it
(i.e. release the mouse button).  When you do this, a dialog box is displayed to allow you to
confirm your decision.  Press 'Ok' to merge the colors or 'Cancel' to keep the threads distinct.

Deleting a Thread 
All threads of a particular color can be deleted from a pattern by selecting the color in the palette
and then selecting the 'Delete thread'  item of  the 'Threads'  menu.  When this  menu item is
chosen, a dialog box will be opened.  This dialog box allows you to choose whether the selected
thread is deleted just where used in the pattern or also from the thread palette.

Flipping a Region
To flip a selected region of a pattern, select the 'Flip horizontally' or 'Flip vertically' menu item of
the 'Edit' menu.

Changing the Size of a Pattern
To change the size of a pattern, select the 'Change size' item of the 'File' menu.  This will cause
the 'Change Pattern Size' dialog box to be opened.  This dialog box gives you three options.
First,  you can specify a particular horizontal and vertical size by entering the desired counts.
Second, you can specify that the pattern size be changed so that only the used portion of the
existing size be used. The used portion is defined to be the smallest rectangular area of the
pattern that contains all stitches of the pattern.  This option also allows you to specify a margin
around the used portion.  Third, you can specify the new size of the pattern to be the currently
selected region (if any) of the pattern. 
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Chapter 4 - Printing a Pattern
To print the current pattern, select the 'Print' item of the 'File' menu.  This will cause the Print
dialog box to open.  This dialog box allows you to specify what portion of the pattern is printed, as
well as, change the printer setup.   In specifying what to print, you can choose to have all of the
pattern printed, only the selected region (if any), or only certain page numbers.

You can also open the Printer Setup dialog box from within Cross-Stitch Designer.  This dialog
box allows you to choose another printer, as well as, adjust the settings of the printer.  To open
this dialog box, select the 'Printer setup' item of the 'File' menu.

When a pattern is printed, the name of the pattern is printed at the top of each page.  Page
numbers are printed in the upper, left corner of each page when it takes more than one page to
represent a pattern.   To help in pasting together print-outs that take multiple pages, each corner
of a page shows in parenthesis the page number of the adjacent page.  

The format of the print-out depends upon the current viewing mode and fabric selection.  The
fabric selection controls the size of the stitch square and the fabric color.  The viewing mode
determines whether stitches are displayed, whether symbols are used in place of stitches, or
whether solid squares are used for each stitch.  

Stitch Format
When the stitch viewing mode is currently selected and the 'Print' menu item is selected, a print-
out showing cross-stitches will be produced.  If a color printer is used, the print-out will be in color.
In this mode, the objective is to produce a print-out that is as close to the stitched pattern as
possible. 

Symbolic Format
When the symbolic viewing mode is currently selected and the 'Print' menu item is selected, a
print-out using symbols will be produced.  The objective of this mode is to produce a print-out that
can be used as a guide when stitching the pattern.

The symbol used for each thread color can be individually selected via the 'Select Symbol' item of
the 'Threads' menu.  The symbol set listed, as well as its size, can be selected via the 'Symbol
font' item of the 'Threads' menu.  

Solid Format
When the solid viewing mode is currently selected and the 'Print' menu item is selected, a print-
out using a solid square for each stitch will be produced.

Pattern Information
When the symbolic viewing mode is used, the symbol legend and pattern information are also
printed.    The symbol  legend lists  the threads used in  the pattern and the symbols used to
represent the threads.  The pattern information includes the following information:

Name of the pattern
Name of the designer
Size of the pattern in counts and inches
Fabric used
General notes
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Most of this information may be editted by selecting the 'Information' item of the 'File'  menu.
When this menu item is selected, the Pattern Information dialog box is opened.  The font used
when the pattern information is printed is selected by pressing the 'Fonts' button of this dialog
box.
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Chapter 5 - Thread List
The thread list  is  used to define all  thread colors available for use in patterns.   Threads are
chosen from the thread list when setting-up the thread palette for a pattern.  Since the list that
comes  with  Cross-Stitch  Designer  does  not  include  all  available  threads,  you  can  add  new
threads, as well as edit existing ones.

Adding New Threads
To add a new thread color, open the Select Thread dialog box.  This can be done by double-
clicking on one of  the color boxes at  the bottom of  the Cross-Stitch Designer window, or by
selecting the 'Select/edit thread' item of the 'Threads' menu.  When the dialog box opens, first
select the thread type.   Then press the 'New' button.  This will cause another dialog box to open.
In this dialog box, enter the description of the thread and its color number, and then adjust the
red, green, and blue amounts until the desired color is shown in the example box.  When you are
satisfied with the color, press the 'Ok' button.  

Editing Existing Threads
To edit an existing thread, open the Select Thread dialog box.  Next, select the thread type and
color, and then press the 'Edit' button.  This will open the 'Edit Thread Attributes' dialog box which
will allow you to edit the description of the thread and/or actual displayed color.  Press the 'Ok'
button to save the changes or press 'Cancel' to keep the previous settings. 

Deleting Threads
To delete a thread from the thread list, open the Select Thread dialog box.  Next, select the thread
type and color, and then press the 'Delete' button.  This will remove the thread from the list.
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Chapter 6 - Importing Bitmaps
A Windows bitmap can be converted into a pattern and pasted into a region of the current pattern.
This feature is very useful for 'roughing-in' a pattern design.  Follow these steps to convert and
paste a bitmap into a pattern region:

1. Copy a bitmap onto the Clipboard from another program, such as Windows Paintbrush. 

2. Select the region in the current pattern that should be filled with the converted bitmap.

3. Select the 'Paste Bitmap' item of the 'Edit' menu.  

4. Wait for the conversion to complete.

5. Reposition the region as desired.

The quality of the bitmap conversion depends upon several factors.  First, the more stitch squares
used for the bitmap the better the result will be.  Also, the more unused positions in the thread
palette  prior  to  importing  the  bitmap,  the  more  accurate  the  color  conversion.   It  is  highly
recommended that you clear  the thread palette  by deleting threads or  by opening the
'empty.pal' palette file before actually importing the bitmap.  Sometimes it may be necessary
to repeat the procedure several times to get the most desirable results.

In general, this feature is meant to allow you to get at least a rough translation of an existing
bitmap so that you don't have to start drawing the pattern from scratch.
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Chapter 7 - Reusing Designs
At times, you may want to use part of an existing pattern in a new pattern that you are drawing.
Follow these steps to copy all or part of one pattern into another pattern:

1. Open the pattern that is to be copied by using the 'Open' item of the 'File' menu.

2. Select the region of the pattern to be copied.

3. Select the 'Copy' item of the 'Edit' menu.

4. Open the pattern to receive the copied pattern.

5. Select 'Paste' item of the 'Edit' menu.  The pasted region will be positioned in the upper left
corner.

6. Position the copied region to the desired location.

Note that the thread colors used for the copied pattern are also used in the second pattern if
possible.  That is, if the same thread colors are already selected in the second pattern or if  there
is room in the thread list for the new thread colors, then exact colors are maintained in the copied
region.  However, if a copied thread does not already exist in the palette and there is not room in
the thread palette for a new thread, then the closest thread color of the palette is used.
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Appendix

Short-cut Keys
The following keys can be used to directly select certain menu items or tool icons.

F1 Opens help window
F2 Saves the pattern
F3  Selects previous thread in the thread palette
F4  Selects next thread in the thread palette
F5  Selects the full-stitch icon 
F6  Selects the half-stitch icons
F7  Selects the quarter-stitch icons
F8  Selects the back stitch icon
F9  Selects the select icon
Ctrl-I Zooms in
Ctrl-O  Zooms out
Ctrl-P Previous view
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