
Setting Message Tasks

If you want to schedule a new task, choose New Task from the Task menu.

If you want to edit or delete an existing task, double-click on it, or choose Properties from the Task menu.

Tip: If the NC Scheduler's overview pane is open, you can drag applications (or any file associated with that application) into the 
pane. The Set Schedule dialog box will automatically appear.

To set a message task:

1 Choose New Task from the Task menu. A requester appears, asking whether you want to run a program or see a message at the 
scheduled time. Choose Message and click on OK or press Enter.

2 The Set Schedule dialog box appears. The dialog has six tabs: What, When, Advanced, Sounds, Semaphores, and Run After. 
The What tab will always appear first.

3 Type your message in the Message textbox.

4 The first 28 characters of your message are taken as the default description.

6 There are seven option checkboxes on the What tab. You can use them for greater flexibility in launching your tasks:

Option Result
Notify if task does not start Check this if you want the NC Scheduler to warn you if the scheduled task does 

not occur.
Disable task after execution Check this if you want to disable the task (but not delete it) after one occurrence.
Delete task after execution Check this if you want the NC Scheduler to delete the task after one occurrence.
Skip next scheduled time Check this if you want to disable the next scheduled occurrence only. Following 

occurrences will be launched as scheduled.
Disable task Check this if you want to wait before deciding to allow the scheduled task to 

occur.
Insert program icon in taskbar tray Check this if you want the Norton Commander to place the program’s icon in the 

Windows taskbar tray. Putting the icon in the taskbar tray will make the program 
available every time you start Windows. The icon appears in the tray throughout 
each Windows session.

6 Click on a Run Program radio button to choose how to run your program: Normal (default), Maximized (full screen), Minimized 
(icon in view on the taskbar) or Hidden (icon not visible).

7 Proceed to the When tab to schedule your task.

Click here {button ,AL("task;schedule;advanced")} for related information.



Setting Program Tasks

If you want to schedule a new task, choose New Task from the Task menu.

If you want to edit or delete an existing task, double-click on it, or choose Properties from the Task menu.

Tip: If the NC Scheduler's overview pane is open, you can drag applications (or any file associated with that application) into the 
pane. The Set Schedule dialog box will automatically appear.

To set a program task

1 Choose New Task from the Task menu. A requester appears, asking whether you want to run a program or see a message at the 
scheduled time. Program is the default.

2 Click on OK or press Enter.

3 The Set Schedule dialog box appears. The dialog has six tabs: What, When, Advanced, Sounds, Semaphores, and Run After. 
The What tab will always appear first.

4 Type the path to the desired program in the textbox, or locate it by clicking on the directory icon.

5 Locate the programs’ directory and click on the desired program. When you do this, the NC Scheduler automatically enters the 
program's name in the Description textbox, and the program's directory in the Working directory textbox.

If you want a different description, type it in the Description textbox.

If you want a different working directory, type it in the Working Directory textbox.

6 There are seven option checkboxes on the What tab. You can use them for greater flexibility in launching your tasks:

Option Result
Confirm task execution The NC Scheduler asks you if you want the scheduled task to occur. A 

confirmation dialog will appear before the scheduled task.
Notify if task does not start Check this if you want the NC Scheduler to warn you if the scheduled task does 

not occur.
Disable task after execution Check this if you want to disable the task (but not delete it) after one occurrence.
Delete task after execution Check this if you want the NC Scheduler to delete the task after one occurrence.
Skip next scheduled time Check this if you want to disable the next scheduled occurrence only. Following 

occurrences will be launched as scheduled.
Disable task Check this if you want to wait before deciding to allow the scheduled task to 

occur.
Insert program icon in taskbar tray Check this if you want the Norton Commander to place the program’s icon in the 

Windows taskbar tray. Putting the icon in the taskbar tray will make the program 
available every time you start Windows. The icon appears in the tray throughout 
each Windows session.

7 Click on a Run Program radio button to choose how to run your program: Normal (default), Maximized (full screen), Minimized 
(icon in view on the taskbar) or Hidden (icon not visible).

8 Proceed to the When tab to schedule your task.

Click here {button ,AL("task;schedule;advanced")} for related information.



Choosing a Schedule

If you want to make launching the task conditional upon another event, use a semaphore (a user-defined flag). Choose the 
Semaphore from the If Semaphore [YOUR SEMAPHORE] is on pull-down listbox.

Note: If you want the task to be conditional upon a semaphore, use the If Semaphore is On drop-down listbox. You must first set a 
semaphore before you can use it.

Choose how often you want your task to be launched. The left-hand side of the dialog box shows different frequencies for your task 
to occur: Once, Hourly, Daily, Weekly, Monthly, Variable, and Boot. Once is the default value.

Tip: Once you have set the What and When tabs, you can click on OK and your task is ready to go. The other four tabs are optional.

Click here {button ,AL("schedule;advanced")} for related information.



Setting a Task to Run Once

1 A 24-hour clock and a calendar appears in the dialog box. Type the time and click on the date you want the task to start at.

2 Use the slide control to change the month.

3 Check the Launch task every year checkbox if you want the task to occur yearly.

Click here {button ,AL("schedule")} for related information.



Setting a Task to Run Hourly

1 Click on the Hourly radio button. A slide control appears in the dialog box.

2 Set the number of minutes after the hour you want the task to occur.

Click here {button ,AL("schedule")} for related information.



Setting a Task to Run Daily

1 Click on the Daily radio button.

2 Type the time you want the task to start at. The Which days checkbox allows you to have the task occur only on certain days, 
e.g., Monday to Friday.

Click here {button ,AL("schedule")} for related information.



Setting a Task to Run Weekly

1 Click on the Weekly radio button.

2 Type the time you want the task to start at. The Which day checkbox sets the day of the week the task is to occur on.

Click here {button ,AL("schedule")} for related information.



Setting a Task to Run Monthly

1 Click on the Monthly radio button.

2 Type the time and click on the date you want the task to start at.

3 If you want the task to occur on the last day of every month, click on: #.

Click here {button ,AL("schedule")} for related information.



Setting a Task to Run in Boot Mode

1 Click on the Boot radio button.

2 Boot tasks can be configured four ways: At Startup, At First Startup, At End of Session, and Continually. Check the radio button of
your preferred choice.

Warning: A continual task must be flagged with a semaphore, otherwise it will launch continually or not at all.

If you want the task to be conditional upon a semaphore, use the If Semaphore is On drop-down listbox. You must first set a 
semaphore before you can use it.

Click here {button ,AL("schedule")} for related information.



Setting a Task to Run at Variable Intervals

1 Click on the Variable radio button. Tasks can be launched at regular or irregular times, configured by the user.

2 Set the slide controls for Minute(s) and Hour(s), and choose Day(s), and Month(s) with the calendar.

To set more than one occurrence, insert a comma between entries. You can also use the wildcard * to launch a task every hour or 
every minute.

Click here {button ,AL("schedule")} for related information.



Using Advanced Options

Advanced options give you more control in configuring your task. You can set early warnings of tasks, as well as deadlines and 
conditions based on the state of your computer.

To set Advance options:

Click on the Advanced options tab.

The three options in Task Start are:
 Display reminder - x minutes before the task is scheduled to launch
 Launch only if the computer has been idle for x minutes
 Don't start if the computer is running on batteries and not mains power

If you want to use these options, use the checkboxes beside the ones you want, and (where appropriate) set the slide controls to the
desired number of minutes.

If the task is unable to be launched, you can also instruct the NC Scheduler to keep trying for x minutes before it stops. Type the 
variable in the Task deadline textbox.

Click here {button ,AL("advanced")} for related information.



Setting Sounds

The NC Scheduler will play a sound in the event of tasks being launched, launched successfully or unsuccessfully, and/or failing to 
run. You can also limit the sound to play at certain events and not others, for example, only on successful launches. These are 
configured with pull-down listboxes.

To choose a sound to play:

Click on the Sounds tab.

The default sounds are set to run. You can:
 Choose another sound using the drop-down listbox.
 Configure a new sound by typing in a new name.
 Set no sound by entering a blank string.

Your default sounds choices are:
 Sunrise chimes
 Sunset chimes
 On launch
 On success
 On failure (if the NC Scheduler tries but cannot launch the task)
 If task does not run (if the NC Scheduler or your computer is not running)

Go to Sounds Properties in the Windows Control Panel to select the particular sound you want. Scroll the Events list to NC 
Scheduler, and configure sounds for the events listed.

Note: If you want to change or delete a sound, choose Customize from the Options menu and click on the Sounds tab.

Click here {button ,AL("sounds;advanced")} for related information.



Setting Semaphores

Semaphores can be used to control the order in which a group of tasks may be launched, or control whether a task or group of tasks
is launched at all. Semaphores can be switched on or off at three intervals: at the start of a task, on the successful completion of a 
task, and on the failure of a task. Semaphores are user-defined.

You can use any alphanumeric character in semaphores, including spaces. It is recommended that you use words that have some 
relation to the semaphore's function. For example, a semaphore to stop disk backups in certain conditions could be called “Stop 
Backup”.

To set semaphores:

1 Click on the Semaphores tab.

2 Type the name of a semaphore in the pull-down listbox at the interval you want. The NC Scheduler will then remember this and all
semaphores for any future task.

3 Set the flag to On or Off.

Note: If you want to edit or delete a semaphore, choose Customize from the Options menu and click on the Semaphores tab.

Click here {button ,AL("semaphores;advanced")} for related information.



Launching Tasks on a Conditional Basis

You can set other tasks to launch x number of minutes after another task has either succeeded or failed.

To use the Run After options:

1 Click the Run After tab. 

All existing tasks that are in the NC Scheduler, enabled or disabled, are listed in two pull-down listboxes, On Success and On 
Failure.

2 Choose a task from either listbox, depending on whether you want the new task to run if the previous task was successfully 
completed, or if it was not.

3 Set the interval that the new task should launch after the event by using the slide controls at the right.

Tip: On Failure could mean either an unsuccessful launch or that the task did not run. If you anticipate that the first task might not 
be able to be launched, you can click on the Advanced tab and set a Task Deadline to keep trying to launch the second task for x 
minutes.

Click here {button ,AL("advanced")} for related information.



Customizing the NC Scheduler

You can customize the look and feel of the NC Scheduler. You can also use customization to remove sounds and semaphores you 
no longer need.

To customize the NC Scheduler:

Choose Customize from the Options menu.

This Customize dialog box appears. There are four tabs: Display, Chimes, Semaphores and Sounds. The Display tab is the default.

Click here {button ,AL("customize")} for related information.



Customizing the Display
Customizing the display

On the Display tab, you can configure:

Grid Settings - change the intervals in Day/Week view with the slide control.

Maximum Entries per Task - limit the number of entries per task in Day/Week View with the slide controls. This limits the number of 
times you see the same task displayed. The default is 60.

Activate Tray Programs - choose to run programs in the tray by single- or double-clicking.

Click here {button ,AL("customize")} for related information.



Customizing the Chimes

Customizing the chimes

The NC Scheduler plays chimes on every hour. There are two chimes, one for daytime and one for night-time. Uncheck the Chimes 
Enabled checkbox if you don’t want to hear the chimes.

The NC Scheduler icon in the taskbar tray also changes between daytime and night-time. If you don’t want the icon to change, 
uncheck the Icon Animation checkbox.

You can change the daytime period. To set the Daytime period, enter the Sunrise and Sunset times in the Daylight Hours boxes, or 
use the slide controls.

Click here {button ,AL("customize;sounds")} for related information.



Customizing Semaphores
Customizing semaphores

You can add, edit or delete semaphores on the Semaphores tab in the Customize dialog box.

Note: The New Semaphore dialog is for programmers only. If you have written an external application that uses semaphores, you 
can add those semaphores to the NC Scheduler.

To edit a semaphore, double-click on it or highlight it and click on Edit.

To delete a semaphore, highlight it and click on Delete.

Click here {button ,AL("customize;semaphores")} for related information.



Customizing Sounds
Customizing sounds

You can add, edit or delete sounds on the Sounds tab in the Customize dialog box.

To edit a sound, double-click on it or highlight it and click on Edit.

To delete a sound, highlight it and click on Delete.

Click here {button ,AL("copy;files;folders;link;disks;networks;compress")} for related information.



Editing Tasks

Double-click on the task you want to edit, or choose Properties from the Task menu to edit the currently highlighted task. Then 
change the message/program, times, sounds and conditions as you wish.

Click here {button ,AL("task")} for related information.



Deleting Tasks

Highlight the task you want to delete, and select Delete from the Task menu or click on the Delete icon on the Toolbar.

Click here {button ,AL("task")} for related information.



Closing the NC Scheduler

Disabling the NC Scheduler

You can disable all NC Scheduler functions, either temporarily or permanently. Both options are available from the Options menu.

Click here {button ,AL("shutdown")} for related information.



Using Suspend/Resume Mode

Suspending the NC Scheduler temporarily is useful if you will be away from your computer and do not want tasks to be launched 
while you are absent. The NC Scheduler continues to run, but launches no tasks.

To suspend the NC Scheduler: 

Choose Suspend Scheduler from the Options menu, or click on the Suspend/ Resume icon on the toolbar.

To Re-enable the NC Scheduler: 

Choose Resume Scheduler from the Options menu, or click on the Suspend/ Resume icon on the toolbar.

Click here {button ,AL("shutdown")} for related information.



Shutting Down the NC Scheduler

You can also shut down the NC Scheduler so that it does not run at Startup. This removes the NC Scheduler icon from the taskbar 
tray.

To shut down the NC Scheduler:

Choose Shut Down Scheduler from the Options menu. A requester will appear, asking you if you really want to shut down. Click on 
Yes.

Note: To re-launch the NC Scheduler, you must again choose Schedule from the Norton Commander Commands menu or the 
Windows Program menu.

Click here {button ,AL("shutdown")} for related information.



Suspending the NC Scheduler

Suspending the NC Scheduler temporarily is useful if you will be away from your computer and do not want tasks to be launched 
while you are absent. The NC Scheduler continues to run, but launches no tasks.

To suspend the NC Scheduler: 

Choose Suspend Scheduler from the Options menu, or click on the Suspend/ Resume icon on the toolbar.

Click here {button ,AL("shutdown")} for related information.



Resuming the NC Scheduler

To Re-enable the NC Scheduler: 

Choose Resume Scheduler from the Options menu, or click on the Suspend/ Resume icon on the toolbar.

Click here {button ,AL("shutdown")} for related information.



Viewing Scheduled Tasks

The NC Scheduler provides three type of panes: Overview (default), Day View, and Week View. Day View and Week View can be 
displayed as a list or as a grid (array).

To view tasks by day or week:

Choose Day View or Week View from the View menu, or click their respective icons on the toolbar.

The Day/Week View for the current day/week is displayed in grid form, showing any tasks and their times.

The default interval in the grid is 30 minutes.

To view another day or week, click on the calendar. To see another month, use the slide control.

To view a simple list of the day’s or week’s tasks, in the View menu toggle Grid to Off (no checkmark). To restore the array, toggle 
Grid again.

Click here {button ,AL("task")} for related information.





Welcome to the NC Scheduler

The Norton Commander Scheduler can launch programs, perform tasks and remind you of important meetings and appointments at 
predetermined times.

You can schedule tasks to run once, at regular intervals or at specific, irregular times. The NC Scheduler handles minor tasks 
quickly and easily, such as reminders or running timesheets, as well as more complicated or conditional tasks.

After being opened for the first time, the NC Scheduler runs every time you start up your computer, unless you decide to shut it 
down. The icon resides in the Windows taskbar tray.

Click here {button ,AL("task;schedule;customize")} for related information.



Getting Started with the NC Scheduler

You can open the NC Scheduler from the Commands menu or from the Windows Programs menu.

To open the NC Scheduler:

1 Choose Schedule from the Commands menu

—Or—

1 Click on Start in the Windows taskbar.

2 Choose the Programs menu.

3 Choose the Norton Commander.

4 Choose the Norton Commander Scheduler.

The main Scheduler pane is called the NC Scheduler Overview. You can see all scheduled tasks in this pane.

Note: Once you have started the Scheduler for the first time, you can call it again by single-clicking on the icon in the taskbar tray. If 
you choose Schedule from the Commands menu, the Scheduler will appear minimized on the Windows taskbar.

The NC Scheduler's interface integrates a command menu with Windows features such as a toolbar, radio buttons and drag & drop. 
The toolbar covers every item on the menus.

Setting the NC Scheduler

1 If you want to schedule a new task, choose New Task from the Task menu.

2 If you want to edit or delete an existing task, double-click on it, or choose Properties from the Task menu.

The Set Schedule dialog box appears.

Tip: If the NC Scheduler's overview pane is open, you can drag applications (or any file associated with that application) into the 
pane. The Set Schedule dialog box will automatically appear.

Click here {button ,AL("task;schedule;customize")} for related information.



About the When Tab

These are the available frequencies for setting tasks:
Frequency Procedure
Once A 24-hour clock and a calendar appear in the dialog box. Type the time and click on the date you want the task to 

start at. Use the slide control to change the month. Check the Launch task every year checkbox if you want the task
to occur yearly.

Hourly Click on the Hourly radio button. A slide control appears in the dialog box. Set the number of minutes after the hour 
you want the task to occur.

Daily Click on the Daily radio button. Type the time you want the task to start at. The Which days checkbox allows you to 
have the task occur only on certain days, for example, Monday to Friday.

Weekly Click on the Weekly radio button. Type the time you want the task to start at. The Which day checkbox sets the day 
of the week the task is to occur on.

Monthly Click on the Monthly radio button. Type the time and click on the date you want the task to start at. If you want the 
task to occur on the last day of every month, click on: #.

Variable Click on the Variable radio button. Tasks can be launched at regular or irregular times, configured by the user.
Set the slide controls for Minute(s) and Hour(s), and choose Day(s), and Month(s) with the calendar. To set more 
than one occurrence, insert a comma between entries. You can also use the wildcard * to launch a task every hour 
or every minute.

Boot Click on the Boot dependent radio button. Boot    tasks can be configured four ways: At Startup, At First Startup, At 
End of Session, and Continually (see Warning below). Check the radio button of your preferred choice.

Warning: A continual task must be flagged with a semaphore, otherwise it will launch continually or not at all.

Click here {button ,AL("schedule")} for related information.



NC Scheduler: Troubleshooting
Error Message:
A task that was scheduled to run at the end of your Windows session is still 
running. You cannot end your session until it has completed.
Problem:

The task may be taking too long and thus preventing Windows from shutting down. Either remove the task from the Scheduler or re-
schedule it.

Error Message:
A Task X, which was scheduled to run, did not start on time. Would you like to
run it now?
Problem:

There may have been a conflict with another program, or your computer and/or network may have been down at the scheduled 
time.

Error Message:
The data on the When tab is incorrect.
Problem:

Using the current data on the When tab will cause the task not to run. Re-check the data to resolve the problem.

Click here {button ,AL("trouble;task")} for related information.





Write your message here.



Check these options if you want them to be enabled.



Type a description of the task, the path to the program, and the directory you want the program to begin with in the textboxes. You 
can use the browse icon to find the application you want.



Check these options if you want them to be enabled.



Choose how you want your program to run.



Check this checkbox to place the program task in the Windows taskbar tray.



Choose how often you want your task to run.



Choose a semaphore if you want your task to be launched conditionally upon another task.



Choose the time and date for your task to be launched. Check the Launch task every year checkbox to run it every year.



Choose the minute of the hour you want the task to be launched.



Choose the time you want your task to be launched.



Choose the days of the week you want your task to be launched.



Choose the time you want your task to be launched.



Choose the day of the week you want your task to be launched.



Choose the time you want your task to be launched.



Choose the day(s) of the month you want your task to be launched.



Choose the minute(s) you want your task to be launched.



Choose the hour(s) you want your task to be launched.



Choose the day(s) of the month you want your task to be launched.



Choose the month(s) of the year you want your task to be launched.



Check the options (at least one) to launch your task.



Check these options if you want them to be enabled.



Your computer will play a sound on these four conditions. You can choose an alternative sound from the drop-down listbox, or 
choose no sound at all.



You can set semaphores to switch on or off on these three conditions.



You can set another task to be launch on these two conditions. Type in the task's name and set a time interval.



Choose the grid interval.



Limit the number of times an oft-repeated task appears in the grid.



Choose how to activate programs in the taskbar tray.



Check whether you want the chimes enabled and/or the Scheduler icon to be animated.



Choose the times for your sunrise and sunset chimes. The Scheduler icon will change from day to night and vice-versa at these 
times.



Programmers can call external semaphores to be used with the NC Scheduler.



Type a description of the semaphore and its External Name.



You can add new sounds to the NC Scheduler, or change existing ones.



Type a description of the sound and its path and name, or locate it using the browse icon.



Choose to schedule either a program or a message.



Choose the day(s) of the week you want your task to be launched.



Choose the day of the month you want to view.






