
 Alarm Help Index
Alarm is an easy-to-use but full-featured alarm system for Windows. It allows the user to set an unlimited 
number of alarms with reminder notes attached to them.    Alarms may be scheduled to recur at pre-
defined intervals.

The program also features a SNOOZE interval function, and the ability to modify an existing alarm.    It 
uses Windows multimedia capabilities to play customizable sounds for alarms.

How To ...

Get started

Add an alarm
Edit an existing alarm
Delete an existing alarm

Register

Don't remind if more than x minutes have passed

Commands

File menu
Alarm menu
View menu

Help menu



File menu commands

The File menu offers the following commands:

New Creates a new document.
Open Opens an existing document.
Save Saves an opened document using the same file name.
Save As Saves an opened document to a specified file name.
Always on 
Top

Toggles the window to stay on top.

More 
Options

Edit initial snooze time and register your copy of Alarm

1, 2, 3, 4 
command

Use the numbers and filenames listed at the bottom of the File menu 
to open the last four documents you closed.

Exit Exits Alarm.



Alarm menu commands

The Alarm menu offers the following commands:

Edit Edits an existing alarm.
Add Adds an alarm.

Delete Deletes an existing alarm



View menu commands

The View menu offers the following commands:

Toolbar Shows or hides the toolbar.
                       
Status Bar

Shows or hides the status bar.

Help menu commands

The Help menu offers the following commands, which provide you assistance with this 
application: 

Index Offers you an index to topics on which you can get help.
Using 
Help

Provides general instructions on using help.

About Displays the version number of this application.



New command (File menu)

Use this command to create a new collection of alarms.

You can open an existing collection of alarms with the Open command.

Shortcuts

Toolbar:
Keys: CTRL+N



File New dialog box

Use this command to create a new collection of alarms.

Shortcuts

Toolbar:
Keys: CTRL+N



Open command (File menu)

Use this command to open an existing collection of alarms.

You can create new collections of alarms with the New command.

Shortcuts

Toolbar:
Keys: CTRL+O



File Open dialog box

The following options allow you to specify which file to open:
File Name

Type or select the filename you want to open.    This box lists files with the extension you 
select in the List Files of Type box. 

List Files of Type
Select the type of file you want to open:
Alarm files (*.alm)

Drives
Select the drive in which youve saved the collection of alarms you want to open. 

Directories
Select the directory in which Alarm stores the file that you want to open.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 



Save command (File menu)

Use this command to save the active collection of alarms to its current name and directory.    
When you save a document for the first time, Alarm displays the Save As dialog box so you 
can name your collection of alarms.    If you want to change the name and directory of an 
existing collection of alarms before you save it, choose the Save As command.

Shortcuts

Toolbar:
Keys: CTRL+S



Save As command (File menu)

Use this command to save and name the active collection of alarms.    Alarm displays the 
Save As dialog box so you can name your collection of alarms.

To save a collection of alarms with its existing name and directory, use the Save command.



File Save As dialog box

The following options allow you to specify the name and location of the file you're about to 
save:
File Name

Type a new filename to save a collection of alarms with a different name.    A filename 
can contain up to eight characters and an extension of up to three characters.    Alarm 
adds the extension you specify in the Save File As Type box.

Drives
Select the drive in which you want to store the collection of alarms.

Directories
Select the directory in which you want to store the collection of alarms.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 



Always on Top command (File menu)

Use this command to keep the Alarm application above all other (non-topmost) windows, 
even when it is not the active window.    One advantage of this is that alarms themselves 
stay on top as well.

Shortcuts
Mouse: Click the application's File, Always on Top menu item.

Or Click the toolbar Always on Top button.



More Options command (File menu)

Use this command to bring up the More Options dialogue box.    Here you can edit the initial 
snooze time and enter registration information.



1, 2, 3, 4 command (File menu)

Use the numbers and filenames listed at the bottom of the File menu to open the last four 
collection of alarms you closed.    Choose the number that corresponds with the collection of 
alarms you want to open.



Exit command (File menu)

Use this command to end your Alarm session.    You can also use the Close command on the 
application Control menu.    Alarm prompts you to save documents with unsaved changes.

Shortcuts
Mouse: Double-click the application's Control menu button.

Keys: ALT+F4



Add command (Alarm menu)

Use this command to add an alarm to a collection of alarms.

Shortcuts
Mouse: Click the application's Alarm, Add menu item.

Or Click the toolbar add alarm button.

Keys: CTRL+A

A dialogue box will appear, with which the characteristics of the particular alarm can be 
selected.



Edit command (Alarm menu)

Use this command to edit an alarm in a collection of alarms.    From the listbox, highlight the 
alarm you would like to edit.

Shortcuts
Mouse: Double click the alarm you would like to edit in the listbox.    Or click on the 

Alarm, Edit menu item.

Or Click the toolbar edit alarm button.

Keys: CTRL+E

A dialogue box will appear, with which the characteristics of the particular alarm can be 
edited.



Delete command (Alarm menu)

Use this command to delete an alarm from a collection of alarms.    From the listbox, 
highlight the alarm you would like to delete.

Shortcuts
Mouse: Click on the Alarm, Delete menu item.

Or Click the toolbar delete alarm button.

Keys: CTRL+D

A dialogue box will appear, with which you can confirm the deletion of the alarm.



Toolbar command (View menu)

Use this command to display and hide the Toolbar, which includes buttons for some of the 
most common commands in Alarm, such as File Open.    A check mark appears next to the 
menu item when the Toolbar is displayed.

See Toolbar for help on using the toolbar.



Toolbar

The toolbar is displayed across the top of the application window, below the menu bar.    The 
toolbar provides quick mouse access to many tools used in Alarm,

To hide or display the Toolbar, choose Toolbar from the View menu (ALT, V, T).

Click To

Open a new document.

Open an existing document.    Alarm displays the Open dialog box, in which you can 
locate and open the desired file.

Save the active document or template with its current name.    If you have not named
the document, Alarm displays the Save As dialog box.

About

Add Alarm

Edit Alarm

Delete Alarm

Always on Top

Context Help



Status Bar command (View menu)

Use this command to display and hide the Status Bar, which describes the action to be 
executed by the selected menu item or depressed toolbar button.. A check mark appears 
next to the menu item when the Status Bar is displayed.

See Status Bar for help on using the status bar.



Status Bar

The status bar is displayed at the bottom of the Alarm window.    To display or hide the status
bar, use the Status Bar command in the View menu.

The status bar describes actions of menu items as you use the arrow keys to navigate 
through menus.    This area similarly shows messages that describe the actions of toolbar 
buttons as you depress them, before releasing them.    If after viewing the description of the 
toolbar button command you wish not to execute the command, then release the mouse 
button while the pointer is off the toolbar button.



Index command (Help menu)

Use this command to display the opening screen of Help.    From the opening screen, you can
jump to step-by-step instructions for using Alarm and various types of reference information. 

Once you open Help, you can click the Contents button whenever you want to return to the 
opening screen.



Using Help command (Help menu)

Use this command for instructions about using Help.



About command (Help menu)

Displays information about your copy of Alarm, including the version number; the copyright, 
legal, and licensing notices; and some system information for your computer.

Shortcut

Mouse: Click the toolbar about button.



Context Help command 

Use the Context Help command to obtain help on some portion of Alarm.    When you choose 
the Toolbar's Context Help button, the mouse pointer will change to an arrow and question 
mark.    Then click somewhere in the Alarm window, such as another Toolbar button.    The 
Help topic will be shown for the item you clicked.

Shortcut
Keys: SHIFT+F1



Title Bar

The title bar is located along the top of a window.    It contains the name of the application 
and document.

To move the window, drag the title bar.    Note: You can also move dialog boxes by dragging 
their title bars.

A title bar may contain the following elements:
Application Control-menu button
Document Control-menu button
Maximize button
Minimize button
Name of the application
Name of the document
Restore button



Scroll bars

Displayed at the right and bottom edges of the document window.    The scroll boxes inside 
the scroll bars indicate your vertical and horizontal location in the document.    You can use 
the mouse to scroll to other parts of the document.



Size command (System menu)

Use this command to display a four-headed arrow so you can size the active window with the
arrow keys.

After the pointer changes to the four-headed arrow:
1. Press one of the DIRECTION keys (left, right, up, or down arrow key) to move the pointer 

to the border you want to move.    
2. Press a DIRECTION key to move the border.
3. Press ENTER when the window is the size you want.

Note:    This command is unavailable if you maximize the window.

Shortcut
Mouse: Drag the size bars at the corners or edges of the window.



Move command (Control menu)

Use this command to display a four-headed arrow so you can move the active window or 
dialog box with the arrow keys.

Note:    This command is unavailable if you maximize the window.

Shortcut
Keys: CTRL+F7



Minimize command (application Control menu)

Use this command to reduce the Alarm window to an icon.

Shortcut

Mouse: Click the minimize icon  on the title bar.
Keys: ALT+F9



Maximize command (System menu)

Use this command to enlarge the active window to fill the available space.

Shortcut

Mouse: Click the maximize icon  on the title bar; or double-click the title bar.
Keys: CTRL+F10 enlarges a document window.



Close command (Control menus)

Use this command to exit the program.

Double-clicking a Control-menu box is the same as choosing the Close command.

Shortcuts
Keys: ALT+F4 closes the Alarm window



Restore command (Control menu)

Use this command to return the active window to its size and position before you chose the 
Maximize or Minimize command.



Switch to command (application Control menu)

Use this command to display a list of all open applications.    Use this "Task List" to switch to 
or close an application on the list.

Shortcut
Keys: CTRL+ESC

Dialog Box Options
When you choose the Switch To command, you will be presented with a dialog box with the 
following options:
Task List

Select the application you want to switch to or close.
Switch To

Makes the selected application active.
End Task

Closes the selected application.
Cancel

Closes the Task List box.
Cascade

Arranges open applications so they overlap and you can see each title bar.    This option 
does not affect applications reduced to icons.

Tile
Arranges open applications into windows that do not overlap.    This option does not 
affect applications reduced to icons.

Arrange Icons
Arranges the icons of all minimized applications across the bottom of the screen.



Choose Font dialog box

Choose a font for your alarm note.



Choose Color dialog box

Choose a background color for your alarm note.



Find command (Edit menu)

To be written.



Find dialog box

To be written.



Replace command (Edit menu)

To be written.



Replace dialog box

To be written.



Modifying the Document

To be written.



No Help Available

No help is available for this area of the window.



No Help Available

No help is available for this message box.



Don't remind if more than x minutes have passed

If your computer is always on, and you are always sitting in front of it, you will never miss an
alarm.    Most of us, however, lead slightly richer, fuller lives, and on occasion, aren't in front 
of, or even turn off, our computers.    Some of us have even taken vacations.

So, what do to about alarms that are scheduled to fire when the computer happens to be 
turned off?

Some alarms you'll want to have fire the next time you boot up your computer.    For 
example, if you have an alarm set to remind you to send a card for your mother's up-coming
birthday, you'll still want to be reminded so you can get that card in the mail.

Other alarms, you would just as soon not appear if you have missed them by enough time.    
For example, you may have a weekly alarm set to remind you of your favorite TV show.    But 
if your computer is off when that alarm was set to fire, and you don't turn on your computer 
until the next day, you really don't need to be reminded about your TV show.    You missed it. 
It's over.    (And that's the one that'll win the Emmy, but that's another story.)    Instead of 
reminding you, it would be nice if that alarm would just quietly reset itself for next week.

But how many minutes should pass before an alarm doesn't need to remind you?    10?    20? 
30?    60?    No one can really say but you.    And most likely it will differ from alarm to alarm.   
If your TV show is a 30-minute sitcom, after 30-minutes, you probably don't need the 
reminder.    But if it's a 60-minute show, you might want to be reminded even if there are 
only a couple of minutes left to catch.

This is why Alarm allows you to custom configure this information when you set (or edit) 
your alarm (range: 0 to 999 minutes).    On the setup screen, you will see an edit box 
labeled, "Don't remind if more than [edit box] minutes have passed."    If you fill in the edit 
box with a zero (0), the next time you run Alarm, it will remind you of your alarm, and your 
mother will get her birthday card.    Any number entered that is greater than zero (0) will 
cause Alarm to check how much time has passed since the alarm's scheduled firing time.    If 
the alarm is still within range, it will fire.    Otherwise, it will not.    If it is a recurring alarm, it 
will reset itself.



Registration

The unregistered version of Alarm is limited to a 30-day trial period.    Use it freely.    As you 
approach 30 days you should be getting a pretty good sense of whether or not this is 
software you'd like to continue using.

The registered version of Alarm does not load the help file every time it is launched.

The registered version also allows creation of an unlimited number of alarms per file.    (The 
unregistered version does not allow creation of more than 10 alarms per file.)

Shareware

This program is shareware; you are given a free, 30-day trial period to determine if Alarm is 
useful for your purposes.    If you decide to keep the program, you must register it by 
sending $15.00 to:

Jeff Parker
1915 Mill Road
South Pasadena, CA    91030

When registering, please supply your User Name.    This is usually your own name or a 
business name, provided it is between ten and twenty-three characters, including spaces.    
User Names are case-sensitive, so be sure to print yours exactly as you would like it to 
appear.

A key number will be sent back to you.    From a menu, select File/More Options.    The "More 
Options" dialogue box will appear.    There you will find two edit boxes marked "User Name" 
and "Key".

When you type your user name and key number into the appropriate edit boxes, your copy 
of Alarm will be registered.    Alarm may be freely distributed as long as no fee is charged for 
it other than a nominal fee for the media (not to exceed $7.00).    Alarm is copyrighted 
software and as such may not be altered in any way, and must be distributed with all files 
intact.    Alarm consists of at least the following files:

Alarm.exe
Alarm.hlp

Even if you decide not to keep Alarm, please send me any comments, questions, gripes, or 
suggestions that you may have.    I am especially interested in the discovery of any bugs or 
inaccuracies, and suggestions for features you would like to see in future versions.

INTERNET (e-mail only): MrJeffrey@aol.com
or:    JeffreyP28@aol.com

Alarm, version 1.6 (32-bit version), April 1995.    © 1995 by Jeff Parker.

Warrantee

What, are you kidding?



Alarm is provided AS IS without any warranty, express or implied.    This includes without 
limitation the fitness for a particular purpose or application and any warranties of salability.

While every attempt was made to be as thorough as possible while debugging Alarm, Jeff 
Parker shall not be liable for any damages, whether direct, indirect, special, or consequential
arising from a failure of this program or accompanying files to operate in a manner desired 
by the user.    Jeff Parker shall not be liable for any damage to data or property which may by 
caused directly or indirectly by use of this program.

In no event will Jeff Parker be liable to you for any damages, including any lost profits, lost 
savings or other incidental or consequential damages arising out of your use or inability to 
use the program, or for any claim by any other party.

Simply put, don't even THINK about pinning any kind of responsibility on me.    But I hope 
you enjoy it anyway.

Alarm.hlp © 1995, Jeff Parker.    All Rights Reserved.



Getting Started

Automatic Installation:
If Windows is not running, start Windows.    Insert disk in drive A.    In the Program Manager Window, 
choose Run from the File Menu.    Type a:\install and press enter.

Alarm will install itself into your Startup program group.    This way, Alarm will launch every time you begin 
a new Windows session.

Some of the features in Alarm that may be of interest include:

* Recurring alarms:    Once, daily, weekdays, weekly, monthly, annually, and custom 
recurrence
* Recurring alarms can have a termination date ("Repeat until:")
* Per alarm customizable "Don't remind after x minutes"    (Range: 0-999)
* Day of week display when setting alarms
* Customizable alarm note fonts and colors
* Calendar control for selecting dates
* An unlimited number of alarms
* An unlimited number of collections of alarms (files)
* WAV, MID, and AVI alarms sounds (and images), which can be individually set for each 
alarm; select via Browse Button or drop down listbox.
* Alarms always editable
* Configurable snooze time, determined per alarm, after alarm has fired
* Snooze for up to 999 minutes, hours or days
* Large alarm note field:    up to 2,147,483,647 characters
* Note field is always editable
* Always-on-Top option
* Status bar and dockable toolbar
* Context-sensitive help
* Screen location memory
* It's not interpreted (like Visual Basic code); it's compiled.    On most systems, there will be a
perceivable speed difference.

If you are not running a 32-bit version of Windows (i.e., Win NT, Win 95), download the 16-bit
version of Alarm.

History

1.0 Initial release
1.1 Recurring alarm termination date ("Repeat until:")
1.2 Day of Week indicator when setting alarms, installation program 

(Thanks Bob Dolan!)
1.3 3d main window, revised window size and location memory (including 

if iconic), Toolbar Tips, and FlyBy Status Bar updating.
1.4 Added "Don't remind if x minutes have passed" feature; drop down 

"sounds" listbox now remembers location of sound directories other 
than \Windows.

1.4 (32-bit 
version) Rebuilt with VC++ 2.0 running on WinNT 3.5.    Dockable toolbar.
1.5    (32- Added cut, copy and paste buttons above notes edit boxes.    Also, font



bit) mania!!
1.5b (16-
bit)

Catching up the 16-bit version, added cut, copy and paste buttons 
above notes edit boxes.    Also, font mania!!    (Font colors and 
background color not yet working.)

1.6    (32-
bit)

User-selectable notes edit box background color.    Calendar control for 
selecting dates.    Some cosmetic changes with new fonts in dialog 
boxes.    Alarms now fire WAV, MID, and AVI files.

1.5c    (16-
bit)

Added calendar control, on-idle processing.

1.6a    (32-
bit)

Greater Win 95 compatibility (and, naturally, all-new Win NT bugs!).    In
addition to WAV, MID, and AVI files, Alarms can now launch programs.    
Daily and weekdays "roll-over" bug fixed. "Save" now disables if there's
nothing new to save.






