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File

This file contains additional information for Microsoft Project for Windows, version 3.0.
The following information is included:

- Files included with Microsoft Project
- Custom edit forms included with Microsoft Project
- Sample Microsoft Excel, Microsoft Visual Basic, and Microsoft Word macros
- Setting your default view, colors, and other options
- Additional printing information
- International Notes 
- Notes for Microsoft Project version 1.0 users
- Receiving "Badly formed setup script" messages during installation

Files Included with Microsoft Project
When you run Setup from the Setup disk, all the files you need to run Microsoft 
Project for Windows are copied. Several sample projects and view files have been 
included. To look at a sample project, choose Open from the File menu and select one
of the .MPP files. To open a sample view file, choose Define Views from the View 
menu, choose the Open button, and then select one of the .MPV files.

The following table lists additional documentation files included with Microsoft Project
for Windows. When you run the Setup program, the files are installed in the WINPROJ 
directory, unless you specify another name. All files can be opened in Microsoft Write.

For information about See Disk or directory
-----------------------------------------------------------------------------------------------------------------------
---------
All files included with Microsoft Project PACKING.LST Setup disk

for Windows 
Setting up Microsoft Project on a network NETWORK.WRI Setup disk
Common questions and answers about Microsoft Q&A.WRI

WINPROJ directory
Project

Commands used in macros COMMANDS.WRI WINPROJ directory
Writing macros MACROS.WRI WINPROJ directory
Using DDE in macros DDEINFO.WRI WINPROJ directory
Setting up plotters to work with Microsoft Project PLOTTERS.WRI

WINPROJ directory
All task, resource, and resource assignment fields FIELDS.WRI

WINPROJ directory
MPX file format MPXFILE.WRI WINPROJ directory
Sample macros from other Microsoft products SAMPLES.WRI

SAMPLES.DDE directory
Microsoft Project for MS-DOS version 3.0 CONVERT.WRI WINPROJ directory

and 4.0 file conversion
Sample view files included with Microsoft Project SAMPVIEW.WRI Library
directory
Sample projects included with Microsoft Project SAMPPROJ.WRI Library
directory



To save space on the disks, many files shipped with Microsoft Project are compressed.
Compressed files are identified by a "$" in the file extension. These files cannot be 
used directly with Microsoft Windows or Microsoft Project; they must be 
decompressed before use. When you run Setup from the Setup disk, these files are 
automatically decompressed. For additional information about file compression, see 
the file PACKING.LST on your Setup disk. 

Custom Edit Forms Included with Microsoft Project
Several custom edit forms are included with Microsoft Project in VIEW.MPV. These 
custom edit forms are listed in the Custom Forms dialog box. To display one of these 
forms, choose Custom Forms from the Options menu, select the form in the Forms 
box, and choose the Set button.

The following custom edit forms for tasks are included with Microsoft Project.

- Cost Tracking can be used to enter and view cost information, as well as task 
completion information.

- Earned Value displays the schedule variance, cost variance, and variance at 
completion in terms of earned value. To understand the abbreviations used in the 
dialog box, see the "Costs" topic in the Microsoft Project User's Reference.

- Entry can be used to enter task information, including duration, start and finish 
dates, and to mark a task to be rolled up to its summary task.

- Schedule Tracking lists the resources and the planned and scheduled start and 
finish dates for a task, as well as the variance between those dates. You can 
change the duration or enter a percent complete.

- Task Relationships has boxes so you can enter or view the predecessors and 
successors to a task.

- Tracking is for entering actual start and finish dates, actual, scheduled and 
remaining duration, and percent complete. You can display this form by clicking 
the tracking form button on the tool bar.

- Work Tracking is used to enter work information for tasks. You can enter total, 
actual, planned, remaining, and percent complete work. You can also enter the 
duration and % complete duration.

The following custom edit forms for resources are included with Microsoft Project.

- Cost Tracking can be used to view cost information, as well as task completion 
information.

- Entry can be used to enter resource information, including initials, group, 
maximum units and standard rate.

- Summary displays peak usage, percent complete, and work and cost information 
including variance. It includes a box for you to enter notes for the selected 
resources. 

- Work Tracking can be used to view work information for the resource.

Sample Microsoft Excel, Microsoft Visual Basic, and Microsoft 
Word Macros
To help you use Microsoft applications together, sample macros from other Microsoft 
products are included with Microsoft Project. These are located in the SAMPLES.DDE 
directory in the directory where you installed Microsoft Project. For more information 
about running these macros, see the file called SAMPLES.WRI in the SAMPLES.DDE 



directory.

Microsoft Excel macros:
- INFLATE.XLA lets you enter and calculate inflation factors and pass the increased 

costs back to Microsoft Project as fixed task costs.
- PROJPERT.XLM helps you estimate durations for tasks using the PERT method of 

averaging the best, worst, and expected durations.
- PROJXTAB.XLM creates a "crosstab" report listing either each task followed by its 

resources, or each resource followed by its tasks.
- TRACKING.XLM is similar to PROJXTAB.XLM but focuses on tracking resource work 

on a task-by-task basis. You can update actual work in Microsoft Excel and send it 
back to Microsoft Project.

Microsoft Visual Basic applications:
- ANALYZER.EXE finds and displays the task most behind schedule, the resource 

most over budget, and the resource most over worked in an open project.
- LATEDATE.EXE helps you determine the cause of the Microsoft Project message 

that a task cannot be completed in the time available.

Microsoft Word template:
- PRJTABLE.DOT contains a macro called CreateTableFromProject that creates a table 

in Microsoft Word filled with Microsoft Project data. Because the information is 
linked back to Microsoft Project, when you change information in Microsoft Project, 
the table in Microsoft Word is also updated.

Setting Your Default View, Colors, and Other Options
Many of the preferences, including colors, default date and time formats, and default 
duration units, can be set by running the PlanningWizards. To use the 
PlanningWizards, choose PlanningWizards from the Help menu and then select what 
you want to do.

Setting the default view -- When you first start Microsoft Project for Windows, you 
see the Task Entry view, a combination view consisting of the Gantt Chart over the 
Task Form. You can easily customize Microsoft Project to start with whatever view you
want. For example, you can set up Microsoft Project to start with a full screen Gantt 
Chart or PERT Chart. To do this, choose the Preferences command from the Options 
menu. Select the Default View option, and specify the view you want. You can either 
type the view name, or click the entry bar arrow or press ALT+DOWN ARROW to select a 
view from a list of available views. After you change this option, any project you open
or create will use this view initially. Included with Microsoft Project is a macro called 
Change Startup View. This macro asks if you want the Gantt Chart or the Task Entry 
view as the default view for Microsoft Project. It displays the view and then changes it
in the Preferences dialog box. For more information about using views, see the 
Microsoft Project Tutorial, the Microsoft Project Feature Guide, and the "Views" topic 
in the Microsoft Project User's Reference.

Setting other default values -- Choose the Preferences command from the 
Options menu to set other options, such as default values, date, time, and number 
formatting. For information about these options, see the "Preferences" topic in the 
Microsoft Project User's Reference.

Additional Printing Information



Because of the graphical nature of Microsoft Project for Windows, you should not print
using the generic (TTY.DRV) text driver.

If you are using a two-pen plotter or a two-color (black and white) printer, you may 
want to create views that use only those colors available for your device.

International Notes
Using Microsoft Graph and settings in the Preferences dialog box - Microsoft 
Graph takes its country settings from the Control Panel in Microsoft Windows. In 
Microsoft Project, if you use the Preferences command on the Options menu to 
change information such as number formats or currency, the settings in the 
Preferences dialog box may conflict with the Control Panel settings for Microsoft 
Graph. Microsoft Graph displays a message if the settings conflict. To ensure that the 
settings are the same, change the settings in the Preferences dialog box to match the
country set in the Control Panel.

Writing macros in different languages - For information about writing macros 
that can be used with different language versions of Microsoft Project, or with 
different country settings, see the MACROS.WRI file. 

Controlling the day on which a week starts - The weeks on the timescale start 
on Sunday or Monday, depending on the country for which your system is set. If you 
want to change this, change the "Start Week On" line in the WINPROJ.INI file. To start 
on Sunday, type 0 following Start Week On; to start on Monday, type 1 following Start
Week On. For more information, see the "Preferences" topic in the Microsoft Project 
User's Reference.

Notes for Microsoft Project Version 1.0 Users
All of the changes to version 1.0 are described in the Microsoft Project Version 3.0 
Update book. This book is part of the package if you purchased an update to version 
1.0.

The Task Form in Microsoft Project version 3.0 is simpler than in version 1.0. If you 
want to display the version 1.0 Task Form in the bottom of the Task Entry view, 
choose Define Views from the View menu, select Task Entry, and choose the Edit 
button. In the Bottom box, select Task Details Form and choose the OK button. This 
form will be displayed each time you use the Task Entry view.

You can open all of your .MPP, .MPV, .MPC, and .MPX files in Microsoft Project version 
3.0. If you installed Microsoft Project version 3.0 in the same directory as Microsoft 
Project version 1.0, your default view file (VIEW.MPV) was renamed OLDVIEW.MPV. To 
use your views in version 3.0, open the OLDVIEW.MPV file. To do this, choose Define 
Views from the View menu, choose the Open button, and then select OLDVIEW.MPV.

If you have version 1.0 files that use resource sharing, you should disconnect all links 
between files and save them in version 1.0, before opening them in version 3.0.

Receiving "Badly Formed Setup Script" Messages During 
Installation



Badly Formed Setup Script C:\\WINDOWS\MSAPPS

The Microsoft Project Setup program expects Microsoft Windows to be in a 
subdirectory on a hard drive.  If Windows is located in the root directory of a drive, 
you may receive this message while installing Microsoft Project.  This situation usually
occurs when a MAPROOT or SUBST command has been used to substitute a drive 
letter for the drive and directory where the Windows directory is located: for 
example, when X:\ has been substituted for the F:\USER\WINDOWS directory.

There are two ways to work around this situation.

1. Remove the MAPROOT or SUBST command from your AUTOEXEC.BAT file or 
network login script, so that the system recognizes the Windows directory to be in a 
subdirectory on a hard drive.  The MAPROOT or SUBST command can be replaced 
after Microsoft Project is installed. See your network documentation for more 
information on the format of your network login script.

2. If you are running Windows from a network, install a user copy of Windows in a 
subdirectory of a hard drive, such as X:\WINDOWS.  Run Windows from this 
subdirectory when you install Microsoft Project.  When the installation is complete, 
follow the necessary steps in the NETWORK.WRI file (located in the directory where 
Project was installed) to complete the network installation.

Badly Formed Setup Script C:\windowsNOCOPY

When this message is received, the Setup program has received incorrect information
during a step in the installation where it checks the versions of the currently installed 
Spelling and MS Graph files.  These files are located in subdirectories of the \
windows_dir\MSAPPS directory.

If this message is encountered, removing certain files from this directory should solve
the problem and allow the Setup program to continue without interruption.  The files 
to remove are:

\windows_dir\MSAPPS\MSGRAPH\GRAPH.EXE
\windows_dir\MSAPPS\PROOF\MSSPELL.DLL

Once these files are removed, the Setup program should continue normally.


