
Macro Commands
The following list summarizes the syntax of the commands used in macros as they 
are pasted into the Macro Definition dialog box. Following this list are all the 
commands used in macros along with their arguments and what type of value is 
expected. This information is the same as what you see in the Commands Used in 
Macros topics in online Help. For more information about writing and understanding 
macros, see the file MACROS.WRI. MACROS.WRI also contains a quick reference 
guide to all the commands.

-    When you paste a command when creating a macro, the format is as follows:
FileOpen .Name=[ ] // .ReadOnly=[ ]
FileOpen is the command name, .Name=[ ] is a required argument, 
and .ReadOnly=[ ] is an optional argument.

-    Argument names are preceded with a period.  For example, .Name= is an 
argument for the FileOpen command; it specifies the name of the file to open. 
You type the name of the file after the equal sign.

-   If an argument value has more than one word or contains the list separator 
character, you must include the value in brackets ([ ]) or quotation marks.  
When you paste the command with arguments, the brackets are included. If you
want to include quotation marks in a message, type ""text"", and replace text 
with the text you want in quotes. 

-    Required arguments are to the left of the two slashes (//); optional arguments 
are to the right.  Everything to the right of the slashes is considered a comment.

-    To use an optional argument, select the argument name, move it to the left of 
the slashes, and then type the value in the brackets after the equal sign.  You 
can also delete the two slashes and all optional arguments except for those you 
want to use.  You do not have to include all the preceding optional arguments or
include placeholders for optional arguments because the argument name tells 
Microsoft Project what the argument value is for.

-    Arguments are separated by a space. You can also use the list separator 
character, usually a comma or semicolon, specified in the Preferences dialog 
box to separate arguments.

-    For argument values that are Yes or No, you can type Yes, Y, or 1 for Yes and 
No, N, or 0 for No.

-    For commands that normally display a dialog box in Microsoft Project, if you 
don't include the required arguments, the dialog box is displayed.

-    For commands that don't have a dialog box but do have required arguments, 
such as the CheckField or SendKeys command, the required arguments must be
included. If you leave out a required argument, a message will appear that tells 
you to include the required arguments.

Alerts 
Turns Microsoft Project messages on or off.  When the messages are off, the default 
response is accepted without the message being displayed.  This command is used 
only in macros.

Alerts // .Show=[Yes]
.Show=[Yes]

Optional; default is Yes.  Replace Yes with No if you don't want to display 
messages.
Turns on or off the display of messages.

AppExecute 



Specifies the window and the pane that you want to be active.
AppExecute // .Window=[ ] .Command=[ ] .Minimize=[No] .Activate=[Yes]

.Window=[ ]
Optional.
Specifies the name of an application window to make active.  If the window exists, 
the window is activated and the Command argument is ignored.
In the brackets, type the exact text in the window title bar.

.Command=[ ]
Optional; used only if the Window argument is not used or the window does not 
exist.
Specifies the command line to start an application. If you don't include a path, 
looks in the current directory, the Windows directory, and the path line in the 
WIN.INI file.
In the brackets, type the command line.

.Minimize=[No]
Optional; default is No.  Replace No with Yes if you want the application minimized.
Specifies whether the application is opened and then minimized.

.Activate=[Yes]
Optional; default is Yes.  Replace Yes with No if you don't want the application 
activated.
Specifies whether the application is activated.

AppMaximize
Equivalent to the Maximize command on the application Control menu.  Enlarges the
Microsoft Project window.

AppMinimize
Equivalent to the Minimize command on the application Control menu.  Shrinks the 
Microsoft Project window to an icon.

AppMove
Equivalent to the Move command on the application Control menu.  Moves the 
Microsoft Project window.  If you don't include the arguments, the position is 
unchanged.

AppMove // .Xpos=[ ] .Ypos=[ ]
.Xpos=[ ]

Optional.
Specifies the horizontal position of the Microsoft Project window measured in 
pixels from the left edge of the screen to the left side of the window.  
In the brackets, type the measurement.

.Ypos=[ ]
Optional.
Specifies the vertical position of the Microsoft Project window measured in pixels 
from the top edge of the screen to the top of the window.  
In the brackets, type the measurement.

AppRestore
Equivalent to the Restore command on the application Control menu.  Restores the 
Microsoft Project window to its previous size and location.

AppSize
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Equivalent to the Size command on the application Control menu.  Changes the size 
of the Microsoft Project window.   If you don't include the arguments, the size is 
unchanged.

AppSize // .Width=[ ] .Height=[ ]
.Width=[ ]

Optional.
Specifies the width of the Microsoft Project window in pixels.  
In the brackets, type the width.

.Height=[ ]
Optional.
Specifies the height of the Microsoft Project window in pixels.  
In the brackets, type the height.

CheckField
Checks the selected tasks or resources to see if they all meet the criterion you 
specify.  If all selected tasks or resources meet the criterion, the command returns 
TRUE; if not all meet the criterion, the command returns FALSE.

CheckField .Field=[ ] .Value=[ ] // .Test=[Equals] .Op=[And] .Field2=[ ] .Value2=[ ] 
.Test2=[ ]

.Field=[ ]
Required.
Specifies the name of the field you want to search.  
In the brackets, type the name of the field.

.Value=[ ] 
Required.
Specifies the number or text you want to compare to the value in each field.  
In the brackets, type the value you want to use.

.Test=[Equals]
Optional; default is Equals. Replace Equals with the test you want to use.
Specifies the test you want to use when comparing the value in the field with the 
value in the Value argument.  
In the brackets, type a test: equals, not equals, greater, gtr or equal, less, less or 
equal, within, not within, contains, doesn't contain.

.Op=[And]
Optional; default is And. Replace And with Or if you want the command to return 
TRUE if either criterion is true. 
Specifies the operator, AND or OR, to use to connect the two sets of criterion.  Use
only if you plan to use the Field2, Test2, and Value2 arguments.

.Field2=[ ]
Optional.
Specifies the name of the second field you want to search.  
In the brackets, type the name of the field.

.Value2=[ ] 
Optional.
Specifies the number or text you want to compare to the value in each field.  
In the brackets, type the value you want to use.

.Test2=[ ]
Optional.
Specifies the test you want to use when comparing the value in the field in Field2 
with the value in the Value2 argument.  
In the brackets, type a test: equals, not equals, greater, gtr or equal, less, less or 
equal, within, not within, contains, doesn't contain.
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ColumnBestFit
Equivalent to double-clicking a column border or choosing the Best Fit button in the 
Column Definition dialog box.  Changes the width of the column so it best fits the 
information in the column.

ColumnBestFit // .Column=[ ]
.Column=[ ]

Optional.
Specifies the column whose width you want to change.  
In the brackets, type the number of the column.  For example, in the Entry table, 
the ID column is column 1, the Name column is 2, and so on.

ColumnEdit
Equivalent to double-clicking a column title or pressing ALT+F3 to display the Column 
Definition dialog box.  

ColumnEdit // .Column=[ ]
.Column=[ ]

Optional.
Specifies the column whose definition you want to change.  
In the brackets, type the number of the column.  For example, in the Entry table, 
the ID column is column 1, the Name column is 2, and so on.

CreateMSGraph
Equivalent to clicking the graph button on the tool bar or pressing CTRL+F11.  Displays
the Create Graph Object dialog box.  

CreateMSGraph // .Name=[ ] .Data=[ ] .ID=[ ] .Task=[ ]
.Name=[ ]

Optional.
Specifies the name of the graph.  
In the brackets, type the name.

.Data=[ ]
Optional.
Specifies the data you want to include in the graph, using the format used when 
you create a link to another application in Microsoft Project.  For a description of 
the syntax, see the Define Link dialog box Help topic or the "Transferring 
Information" topic in the Microsoft Project User's Reference.  
In the brackets, type the data.

.ID=[ ]
Optional.
Specifies the ID number of the task or resource to which you want to attach the 
graph.  
In the brackets, type the ID number.

.Task=[ ]
Optional.
Specifies whether you want to attach the graph to a task or resource.  
In the brackets, type 0 for a resource or 1 for a task.

DDEExecute
Sends a command to another application. You must first use the DDEInitiate 
command to start a DDE conversation with the other application.

DDEExecute .Command=[ ] // .TimeOut=[5]
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.Command=[ ]
Required.
Specifies the command you want to carry out in the other application.  
In the brackets, type the command.

.TimeOut=[5]
Optional; default is 5. Replace 5 with the number of seconds Microsoft Project 
should wait.
Maximum time in seconds that Microsoft Project will wait for another application to
complete the command before Microsoft Project decides it failed.  If your macro 
causes a message to be displayed in the other application, use a large timeout 
value.  For most commands, however, the default will be fine.

DDEInitiate
Starts a DDE conversation with another application.

DDEInitiate .Application=[ ] .Topic=[ ]
.Application=[ ]

Required.
Specifies the application with which you want to start a conversation.  
In the brackets, type the name of the application.

.Topic=[ ]
Required.
Specifies the filename to use in the other application.
In the brackets, type the filename, including the path, or the topic, such as 
"system" if you want to connect to the system topic.

DDETerminate
Ends the active DDE conversation. If you don't include this command, Microsoft 
Project will terminate the DDE conversation when the macro ends.

DocClose
Equivalent to the Close command on the project Control menu.  Closes the active 
window.  

DocMaximize
Equivalent to the Maximize command on the project Control menu.  Enlarges the 
active project to fit the Microsoft Project window.

DocMove 
Equivalent to the Move command on the project Control menu.  Moves the project 
window.  If you don't include the arguments, the position is unchanged.

DocMove // .Xpos=[ ] .Ypos=[ ]
.Xpos=[ ]

Optional.
Specifies the horizontal position of the project window measured in pixels from the
left edge of the Microsoft Project window to the left edge of the project window. 
In the brackets, type the measurement.

.Ypos=[ ]
Optional.
Specifies the vertical position of the project window measured in pixels from the 
top edge of the Microsoft Project window to the top of the project window.  
In the brackets, type the measurement.
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DocRestore
Equivalent to the Restore command on the project Control menu.  Restores the 
project window to its previous size and location.

DocSize
Equivalent to the Size command on the project Control menu.  Changes the size of 
the project window.  If you don't include the arguments, the size is unchanged.

DocSize // .Width=[ ] .Height=[ ]
.Width=[ ]

Optional.
Specifies the width of the project window in pixels.  
In the brackets, type the width.

.Height=[ ]
Optional.
Specifies the height of the project window in pixels.  
In the brackets, type the height.

EditAssignment 
Equivalent to the Assignment command on the Edit menu.  Adds, replaces, or 
removes resource assignments.

EditAssignment .Resources=[ ] // .Op=[0] .With=[ ]
.Resources=[ ]

Required.
Specifies the names of the resources you want to add, remove, or replace.  If the 
resource name includes a space or you specify more than one resource, you must 
include quotation marks or brackets ([ ]) around the list of resources.
In the brackets, type the names of the resources.  If you type more than one 
name, separate the names with the list separator character, usually a comma or 
semicolon.

.Op=[0]
Optional; default is 0 for Add.
Specifies whether you want to add, remove, or replace this assignment.  
Equivalent to the buttons in the Resource Assignment dialog box.
0 = Add
1 = Remove
2 = Replace

.With=[ ]
Optional; used only when replacing a resource.
Specifies the name of the new resource.  Equivalent to using the Replace Resource
dialog box.
In the brackets, type the name of the resource.  

EditClear
Equivalent to the Clear command on the Edit menu.  Clears the information in the 
selected fields.

EditCopy 
Equivalent to the Copy command on the Edit menu.  Copies the selected information
and stores it on the Clipboard.  The arguments apply to the Resource Usage view 
only.
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EditCopy // .FromDate=[ ] .ToDate=[ ] .TableOnly=[ ]
.FromDate=[ ]

Optional; applies to the Resource Usage view only.
Specifies the beginning date for the information to be copied.  
In the brackets, type the beginning date in any acceptable date format. If there is 
a chance that when the macro is run, the date format settings in the Preferences 
dialog box will be different from the date format you use here, precede the date 
with "@". 

.ToDate=[ ]
Optional; applies to the Resource Usage view only.
Specifies the ending date for the information to be copied.  
In the brackets, type the ending date in any acceptable date format. If there is a 
chance that when the macro is run, the date format settings in the Preferences 
dialog box will be different from the date format you use here, precede the date 
with "@". 

.TableOnly=[ ]
Optional; applies to the Resource Usage view only.  
Specifies whether to copy table information only from the Resource Usage view, or
table and usage information.
In the brackets, type Yes to copy table information only or No to copy usage 
information and table information.

EditCopyPicture
Equivalent to the Copy Picture command on the Edit menu.  Copies the view as an 
object or the selected information as a static picture.

EditCopyPicture .Object=[ ] // .ForPrinter=[No]
.Object=[ ]

Required.
Specifies whether the information is copied as an object or as a static picture.
0 = Copies selected information as a static picture; equivalent to selecting the 

Static Picture option button in the Copy Picture dialog box.
1 = Copies view as an object; equivalent to selecting the Linked Or Embedded 

Object option button in the Copy Picture dialog box.
.ForPrinter=[No]

Optional; used when copying information as a static picture; default is No.  
Replace No with Yes to copy the picture for the printer.
Specifies whether selected information is copied for the screen or for the printer; 
equivalent to the For Printer check box in the Copy Picture dialog box.

EditCut
Equivalent to the Cut command on the Edit menu.  Deletes the selected information 
and places it on the Clipboard.

EditDelete 
Equivalent to the Delete command on the Edit menu.  Deletes the selected 
information or object.

EditFillDown
Equivalent to the Fill Down command on the Edit menu.  Copies the information in 
the top selected field to the remaining selected fields.
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EditFind 
Equivalent to the Find command on the Edit menu.  Finds the next task or resource 
that meets the criterion you specify.

EditFind .Field=[ ] .Test=[ ] .Value=[ ] // .Next=[ ]
.Field=[ ]

Required.
Specifies the name of the field you want to search.  
In the brackets, type the name of the field.

.Test=[ ]
Required.
Specifies the test you want to use when comparing the value in the field with the 
value in the Value argument.  
In the brackets, type a test: equals, not equals, greater, gtr or equal, less, less or 
equal, within, not within, contains, doesn't contain.

.Value=[ ]
Required.
Specifies the number or text you want to compare to the value in each field.  
In the brackets, type the value you want to use.

.Next=[ ]
Optional.
Specifies whether to find the next task or resource that meets the criterion or the 
previous task or resource; equivalent to choosing the Next button or Previous 
button in the Find dialog box.
In the bracket, type Yes for the Next button or No for the Previous button.

EditForm
Equivalent to the Form command on the Edit menu.  Displays the Task Edit Form or 
Resource Edit Form, depending on whether a task or resource is selected when you 
use the command.

EditGoto 
Equivalent to the Go To command on the Edit menu.  Moves to the ID number or date
you specify.  

EditGoto // .ID=[ ] .Date=[ ]
.ID=[ ]

Optional.
Specifies the ID number to go to.  
In the brackets, type the number of the task or resource.

.Date=[ ]
Optional.
Specifies the date to go to.  
In the brackets, type the date in any acceptable date format. If there is a chance 
that when the macro is run, the date format settings in the Preferences dialog box 
will be different from the date format you use here, precede the date with "@". 

EditInsert
Equivalent to the Insert command on the Edit menu.  Inserts a blank row into a table 
or a node into the PERT Chart. If a column is selected, inserts a new column.

EditInsertObject
Equivalent to the Insert Object command on the Edit menu.  Creates an object in the 
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application you specify and attaches it to the selected task or resource.
EditInsertObject // .Name=[ ]

.Name=[ ]
Optional.
Specifies the type of object you want to insert.
In the brackets, type the object type--either the name shown in the Insert Object 
dialog box or the class name.

EditLinkTasks
Equivalent to the Link Tasks command on the Edit menu.  Links the selected tasks 
with finish-to-start relationships.

EditObject
Equivalent to the Object command on the Edit menu. If there is more than one action
you can perform on the object, specifies the action you want.  

EditObject // .Verb=[ ]
.Verb=[ ]

Optional.
Specifies the type of action you want to take on the object.  When you choose this 
command in Microsoft Project, a dialog box appears if there is more than one 
action that you can take.  The number you type matches the order of the actions 
listed in the dialog box, starting with 1 as the first action.  
In the brackets, type a number.

EditPaste
Equivalent to the Paste command on the Edit menu.  Inserts the information on the 
Clipboard into the project.

EditPasteLink
Equivalent to the Paste Link command on the Edit menu.  Inserts the information on 
the Clipboard such that it is linked to the original information.

EditUndo
Equivalent to the Undo command on the Edit menu.  Reverses the most recent 
command.

EditUnlinkTasks
Equivalent to the Unlink Tasks command on the Edit menu.  Unlinks the selected 
tasks.

Error 
Tells the macro how to handle an error message.

Error // .Halt=[ ]
.Halt=[ ]

Optional.
Specifies whether the macro continues or is halted when an error occurs. Type one
of the following:
No = When an error occurs, accept the default value and continue running the 

macro.
Yes = When an error occurs, halt the macro and display a message.
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ExtendSelection 
Equivalent to pressing F8 to turn on or off Extend Selection mode.  Extends the 
selection from the current location to the new location.

ExtendSelection // .On=[No] 
.On=[No]

Optional; default is No.  Replace No with Yes to turn on Extend Selection mode.
Specifies whether Extend Selection mode is on or off.

FileClose
Equivalent to the Close command on the File menu.  Closes the active project.

FileClose // .Save=[2]
.Save=[2]

Optional; default is 2 for prompt for save.
Specifies whether a project with unsaved changes is saved or not saved.
0 = Don't save unsaved changes
1 = Save unsaved changes
2 = Prompt for save

FileCloseAll
Equivalent to the Close All command on the File menu.  Closes all open projects.

FileCloseAll // .Save=[2]
.Save=[2]

Optional; default is 2 for prompt for save.
Specifies whether projects with unsaved changes are saved or not saved.
0 = Don't save unsaved changes
1 = Save unsaved changes
2 = Prompt for save

FileLinks
Equivalent to the Links command on the File menu.  Displays the Links dialog box 
where you can create, update, and delete links, and open linked files and 
applications.

FileLoadLast  
Equivalent to opening one of the files listed at the bottom of the File menu.  Opens 
an existing project.

FileLoadLast // .Num=[1]
.Num=[1]

Optional; default is 1 to open the first file in the list.  Replace 1 with 2 to open the 
second file, 3 to open the third file, or 4 to open the fourth file.  The numbers 
match the order of the files listed at the bottom of the File menu.
Specifies the file to open.  

FileNew
Equivalent to the New command on the File menu.  Creates a new project.

FileOpen
Equivalent to the Open command on the File menu.  Opens an existing project.

FileOpen .Name=[ ] // .ReadOnly=[No]
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.Name=[ ]
Required.
Specifies the file to open.  
In the brackets, type the name of the file, including the path if appropriate.

.ReadOnly=[No]
Optional; default is No.  Replace No with Yes to open the file with read-only access.
Specifies whether the file is opened with read-only access.

FilePageSetup
Equivalent to the Page Setup command on the File menu.  Specifies page formatting 
including headers, footers, margins, and legends.  This command always displays 
the dialog box so you can select the options that are appropriate for your view or 
report.

FilePrint
Equivalent to the Print command on the File menu.  Prints the active view.

FilePrint // .FromPage=[ ] .ToPage=[ ] .AllColumns=[No] .PageBreaks=[Yes] .Draft=
[No] .Copies=[1] .FromDate=[ ] .ToDate=[ ] .OnePageWide=[No] .Preview=[No] .C
olor=[ ]

.FromPage=[ ] 
Optional.
Specifies the first page to print.
In the brackets, type the first page number.

.ToPage=[ ]
Optional, unless you have entered a value for the FromPage argument.
Specifies the last page to print.
In the brackets, type the last page number.

.AllColumns=[No]
Optional; default is No.  Change No to Yes to print all columns.
Specifies whether all columns are printed or only those visible on screen.  Same as
the Print All Sheet Columns check box in the Print dialog box.

.PageBreaks=[Yes]
Optional; default is Yes.  Change Yes to No to ignore manual page breaks.
Specifies whether manual page breaks are used or ignored when printing.  Same 
as the Manual Page Breaks check box in the Print dialog box.

.Draft=[No]
Optional; default is No.  Change No to Yes to print in draft mode.
Specifies whether you want to print in draft mode.  Same as the Draft Quality 
check box in the Print dialog box.

.Copies=[1]
Optional; default is 1.  Replace 1 with the number of copies you want to print.
Specifies the number of copies to print.  Same as the Copies box in the Print dialog
box.

.FromDate=[ ]
Optional.
Specifies the first date to print.
In the brackets, type the starting date in any acceptable date format. If there is a 
chance that when the macro is run, the date format settings in the Preferences 
dialog box will be different from the date format you use here, precede the date 
with "@". 

.ToDate=[ ]
Optional, unless you have entered a value for the FromDate argument.
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Specifies the last date to print.
In the brackets, type the ending date in any acceptable date format. If there is a 
chance that when the macro is run, the date format settings in the Preferences 
dialog box will be different from the date format you use here, precede the date 
with "@". 

.OnePageWide=[No]
Optional; default is No.  Replace No with Yes to print one page width of the view.
Indicates you want to print one page width of the view.  Same as the One Page 
Wide check box under Timescale in the Print dialog box.

.Preview=[No]
Optional; default is No.  Replace No with Yes to preview the pages in the view.
Specifies that you want to preview the pages instead of printing the view.  Same 
as the Preview button in the Print dialog box.

.Color=[ ]
Optional.
In Microsoft Project for the Macintosh, specifies that you want to print in color on a 
color output device; has no effect in Microsoft Project for Windows.  Same as the 
Print Using Color check box in the Print dialog box. 
In the brackets, type Yes to print in color or No to print in black and white.

FilePrintPreview
Equivalent to the Print Preview command on the File menu.  Displays a view as it will 
appear when printed.

FilePrintPreviewReport
Equivalent to selecting a report in the Print Report dialog box and then choosing the 
Preview button.  Displays a report as it will appear when printed.

FilePrintPreviewReport .Name=[ ]
.Name=[ ]

Required.
Specifies the report to preview.  
In the brackets, type the name of the report as it appears in the Print Report dialog
box.

FilePrintReport
Equivalent to printing a report using the Print Report dialog box and the Print dialog 
box.

FilePrintReport .Name=[ ] // .FromPage=[ ] .ToPage=[ ] .PageBreaks=[Yes] .Draft=[
No] .Copies=[1] .FromDate=[ ] .ToDate=[ ] .Preview=[No] .Color=[ ]

.Name=[ ]
Required.
Specifies the name of the report to print.  
In the brackets, type the name of the report as it appears in the Print Report dialog
box.

.FromPage=[ ]
Optional.
Specifies the first page to print.
In the brackets, type the first page number.

.ToPage=[ ]
Optional, unless you have entered a value for the FromPage argument.
Specifies the last page to print.
In the brackets, type the last page number.
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.PageBreaks=[Yes]
Optional; default is Yes.  Change Yes to No to ignore manual page breaks.
Specifies whether manual page breaks are used or ignored when printing.  Same 
as the Manual Page Breaks check box in the Print dialog box.

.Draft=[No]
Optional; default is No.  Change No to Yes to print in draft mode.
Specifies whether you want to print in draft mode.  Same as the Draft Quality 
check box in the Print dialog box.

.Copies=[1]
Optional; default is 1.  Replace 1 with the number of copies you want to print.
Specifies the number of copies to print.  Same as the Copies box in the Print dialog
box.

.FromDate=[ ]
Optional.
Specifies the first date to print.
In the brackets, type the starting date in any acceptable date format. If there is a 
chance that when the macro is run, the date format settings in the Preferences 
dialog box will be different from the date format you use here, precede the date 
with "@". 

.ToDate=[ ]
Optional, unless you have entered a value for the FromDate argument.
Specifies the last date to print.
In the brackets, type the ending date in any acceptable date format. If there is a 
chance that when the macro is run, the date format settings in the Preferences 
dialog box will be different from the date format you use here, precede the date 
with "@". 

.Preview=[No]
Optional; default is No.  Replace No with Yes to preview the pages in the report.
Specifies that you want to preview the pages instead of printing the report.  Same 
as the Preview button in the Print dialog box.

.Color=[ ]
Optional.
In Microsoft Project for the Macintosh, specifies that you want to print in color on a 
color output device; has no effect in Microsoft Project for Windows.  Same as the 
Print Using Color check box in the Print dialog box. 
In the brackets, type Yes to print in color or No to print in black and white.

FilePrintSetup
Equivalent to the Print Setup command on the File menu.  Lists printers and options 
for the selected printer.

FilePrintSetup .Printer=[ ]
.Printer=[ ] 

Required.
Specifies the printer, using the exact text that appears in the Print Setup dialog 
box.  You must enclose the text in either quotation marks or brackets ([ ]).  For 
example, FilePrinterSetup .Printer=[HP LaserJet+ on COM1:].  
In the brackets, type the exact text.  

FileResources
Equivalent to the Resources command on the File menu.  Specifies whether the 
project should use its own resources or the resources stored in another project.

FileResources // .Share=[ ] .Name=[ ] .Pool=[ ]
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.Share=[ ]
Optional.
Specifies whether the project should use its own resources or the resources stored 
in another project.  
In the brackets, type No if the project should use its own resources, or Yes to use 
the resources stored in another project.

.Name=[ ] 
Optional, unless the argument for Share is Yes.  If you enter a name, Share is set 
to Yes.
In the brackets, type the name of the project containing the resources. 

.Pool=[ ]
Optional.
Specifies whether the resource information in the project or in the resource pool 
takes precedence when the information is different. Equivalent to the Pool Takes 
Precedence On Conflict check box in the Resource Sharing dialog box.
In the brackets, type 0 if the information in the individual project takes precedence
over the pool or 1 if the pool should take precedence.

FileSave
Equivalent to the Save command on the File menu.  Saves the active project on the 
disk.

FileSaveAs
Equivalent to the Save As command on the File menu.  Names or renames an 
existing project and saves it on the disk.

FileSaveAs .Name=[ ] // .Format=[0] .Backup=[No] .ReadOnly=[No]
.Name=[ ]

Required.
Specifies the name of the file to save.  
In the brackets, type the name of the file, including the path if needed.

.Format=[0]
Optional; default is 0 for MPP.
Specifies a format for the file if you want to save it in other than normal MPP 
format.  Same as the Save File As Type box in the Save As dialog box.
To change the format, type one of the following numbers:
0 = MPP
1 = MPX
2 = TXT
3 = CSV
4 = XLS
5 = WKS
6 = WK1
7 = WK3
8 = DB3
9 = DB4

.Backup=[No]
Optional; default is No.  Replace No with Yes to make a backup each time you 
save.
Specifies whether a backup is made of the file each time you save it.  Same as the
Create Backup File check box in the expanded Save As dialog box.

.ReadOnly=[No]
Optional; default is No.  Replace No with Yes to open the file with read-only access.
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Specifies whether, when the file is opened, Microsoft Project displays a message 
recommending that the file be opened with read-only access.  Same as the Read 
Only Recommended check box in the expanded Save As dialog box.

FileSaveWorkspace
Equivalent to the Save Workspace command on the File menu.  Saves a list of the 
open files and the preferences in the Preferences dialog box as a workspace file on 
the disk.

FileSaveWorkspace .Name=[ ]
.Name=[ ]

Required.
Specifies the name of the file to save.  
In the brackets, type the name of the file, including the path if needed.

Filter
Equivalent to using the Define Filters command to apply a filter.  Applies an existing 
filter.  If the filter is not in the open view file, applies the All Tasks or All Resources 
filter.  To make sure the filter is available, include a ViewFileOpen command to open 
the appropriate view file before using this command.  

Filter .Name=[ ] // .Highlight=[No] .Value1=[ ] .Value2=[ ]
.Name=[ ]

Required.
Specifies the filter to apply.
In the brackets, type the name of the filter.

.Highlight=[No]
Optional; default is No.  Replace No with Yes to apply the filter as a highlighting 
filter.
Specifies whether the filter is applied as a highlighting filter.

.Value1=[ ]
Optional.
Specifies the value to use when applying an interactive filter.
In the brackets, type the value.

.Value2=[ ]
Optional.
Specifies the second value to use when applying an interactive range filter.
In the brackets, type the value.

FilterDefineFilters
Equivalent to the Define Filters command on the Filter menu.  Displays the Define 
Filters dialog box so you can apply, create, copy, or edit a filter.

FindNext
Equivalent to choosing the Next button in the Find dialog box or pressing F7.  Finds 
the next task or resource that contains information meeting the test and value 
specified in the Find dialog box.

FindPrevious
Equivalent to choosing the Previous button in the Find dialog box or pressing 
SHIFT+F7.  Finds the previous task or resource that contains information meeting the 
test and value specified in the Find dialog box.
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Form
Equivalent to using the Custom Forms command on the Options menu to display a 
form.  Displays an existing form.  To make sure the form is available, include a 
ViewFileOpen command to open the appropriate view file before using this 
command.  
There is also a Form command for every form in the view file.  The form name 
follows Form, for example, Form [Tracking].

Form .Name=[ ] 
.Name=[ ]

Required.
Specifies the form to display.
In the brackets, type the name of the form.

FormatAvailability
Equivalent to the Availability command on the Format menu for the Resource Graph 
or Resource Usage view.  Displays the amount of work for which a resource is 
available.

FormatBorders
Equivalent to the Borders command on the Format menu for the PERT Chart.  
Displays the Borders dialog box so you can change the borders on the PERT nodes.

FormatCost
Equivalent to the Cost command on the Format menu for the Resource Form, 
Resource Graph, or Resource Usage view.  Shows cost information for resources.

FormatCumulativeCost
Equivalent to the Cumulative Cost command on the Format menu for the Resource 
Graph or Resource Usage view.  Displays the cumulative cost for resources.

FormatCumulativeWork
Equivalent to the Cumulative Work command on the Format menu for the Resource 
Graph or Resource Usage view.  Displays the cumulative work for resources.

FormatGridlines
Equivalent to the Gridlines command on the Format menu.  Displays the Gridlines 
dialog box so you can change the gridlines in the active view.

FormatLayout
Equivalent to the Layout command on the Format menu for the PERT Chart.  Displays
the Layout dialog box so you can change the lines, arrows, and page-break 
sensitivity in the PERT Chart.

FormatLayoutNow
Equivalent to the Layout Now command on the Format menu for the PERT Chart.  
Arranges the PERT nodes.

FormatNotes
Equivalent to the Notes command on the Format menu for the Resource Form or Task

16



Form.  Displays the Notes box at the bottom of the form.

FormatObjects
Equivalent to the Objects command on the Format menu for the Resource Form or 
Task Form.  Displays the Objects box at the bottom of the form.

FormatOutline
Equivalent to the Outline command on the Format menu for the Gantt Chart or Task 
Sheet.  Displays the Outline dialog box so you can change the outline format in the 
active view.

FormatOverallocation
Equivalent to the Overallocation command on the Format menu for the Resource 
Graph or Resource Usage view.  Displays the amount of work for which a resource is 
allocated to work over capacity.

FormatPageBreaks
Equivalent to the Page Breaks command on the Format menu for the PERT Chart.  
Displays the page breaks on the PERT Chart.

FormatPageBreaks // .Show=[ ]
.Show=[ ]

Optional.
Specifies whether page breaks are shown or not shown.
In the brackets, type Yes to show the page breaks or No to hide them.

FormatPalette
Equivalent to the Palette command on the Format menu for the Gantt Chart, PERT 
Chart, or Resource Graph.  Displays the Palette dialog box so you can change the 
format, placement, alignment, and color of information.

FormatPeakUnits
Equivalent to the Peak Units command on the Format menu for the Resource Graph 
or Resource Usage view.  Displays the peak units for resources during the time 
period.

FormatPercentAllocation
Equivalent to the Percent Allocation command on the Format menu for the Resource 
Graph or Resource Usage view.  Displays the percentage that a resource is allocated 
for the time period.

FormatPredecessorsSuccessors
Equivalent to the Predecessors & Successors command on the Format menu for the 
Task Form.  Displays the predecessors and successors fields at the bottom of the 
form.

FormatRemoveAllPageBreaks
Equivalent to the Remove All Page Breaks command on the Format menu.  Removes 
all manual page breaks in the project.  
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FormatRemovePageBreak
Equivalent to the Remove Page Break command on the Format menu.  Removes the 
manual page breaks above the selected task or resource.  

FormatResourceCost
Equivalent to the Resource Cost command on the Format menu for the Task Form.  
Displays the resource cost fields at the bottom of the form.

FormatResourceSchedule
Equivalent to the Resource Schedule command on the Format menu for the Task 
Form.  Displays the resource schedule fields at the bottom of the form.

FormatResourcesPredecessors
Equivalent to the Resources & Predecessors command on the Format menu for the 
Task Form.  Displays the resources and predecessors fields at the bottom of the form.

FormatResourcesSuccessors
Equivalent to the Resources & Successors command on the Format menu for the 
Task Form.  Displays the resources and successors fields at the bottom of the form.

FormatResourceWork
Equivalent to the Resource Work command on the Format menu for the Task Form.  
Displays the resource work fields at the bottom of the form.

FormatSchedule
Equivalent to the Schedule command on the Format menu for the Resource Form.  
Displays the schedule fields at the bottom of the form.

FormatSelectedTasks
Equivalent to the Selected Tasks Only command on the Format menu for the 
Resource Usage view.  When the Resource Usage view is on the bottom of a 
combination view, displays usage information for just the tasks selected in the top 
view.

FormatSelectedTasks // .Show=[ ]
.Show=[ ]

Optional.
Specifies whether resource information is shown for all tasks or for selected tasks 
only.
In the brackets, type Yes to show information for the selected tasks only or No to 
show information for all tasks to which the resource is assigned.

FormatSetPageBreak
Equivalent to the Set Page Break command on the Format menu.  Inserts a manual 
page break above the selected task or resource.  

FormatSort
Equivalent to the Sort command on the Format menu.  Displays the Sort dialog box 
so you can sort the tasks or resources in the active view.

FormatSort .Key1=[ ] // .Ascending1=[Yes] .Key2=[ ] .Ascending2=[Yes] .Key3=[ ] .
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Ascending3=[Yes] .Renumber=[No] .Outline=[Yes] 
.Key1=[ ]

Required.
Specifies the field on which you want to sort.
In the brackets, type the field name.

.Ascending1=[Yes]
Optional; default is Yes.  Replace Yes with No to sort in descending order.
Specifies whether you sort in ascending or descending order.

.Key2=[ ]
Optional.
Specifies the second field on which you want to sort.
In the brackets, type the field name.

.Ascending2=[Yes]
Optional; default is Yes.  Replace Yes with No to sort in descending order.
Specifies whether you sort in ascending or descending order.

.Key3=[ ]
Optional.
Specifies the third field on which you want to sort.
In the brackets, type the field name.

.Ascending3=[Yes]
Optional; default is Yes.  Replace Yes with No to sort in descending order.
Specifies whether you sort in ascending or descending order.

.Renumber=[No]
Optional; default is No.  Replace No with Yes to renumber.
Sorts and sequentially renumbers tasks or resources based on the new sort order.

.Outline=[Yes]
Optional; default is Yes. Replace Yes with No if you don't want to maintain the 
outline structure.
Specifies whether the outline structure is maintained.

FormatText
Equivalent to the Text command on the Format menu.  Displays the Text dialog box 
so you can change the text in the active view.

FormatTimescale
Equivalent to the Timescale command on the Format menu.  Displays the Timescale 
dialog box so you can change the timescale in the active view.

FormatWork
Equivalent to the Work command on the Format menu for the Resource Form.  
Displays the work fields at the bottom of the form.

FormatZoom
Equivalent to the Zoom commands on the Format menu for the PERT Chart.  Zooms 
the PERT Chart in or out.

FormatZoom // .In=[ ]
.In=[ ]

Optional.
Specifies either full-sized nodes or small nodes.
In the brackets, type No to zoom out or Yes to zoom in.
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GotoNextOverAllocation
Equivalent to clicking the go to next overallocation button on the tool bar or pressing
ALT+F5.  Moves to the next overallocation on a view with a timescale.  

GotoTaskDates
Equivalent to scrolling the timescale to display the selected task.  

HelpIndex
Equivalent to the Index command on the Help menu.  Displays the Help index.

HelpPlanningWizards
Equivalent to the PlanningWizards command on the Help menu.  Starts 
PlanningWizards.

HelpPlanningWizards // .Wizard=[ ]
.Wizard=[ ]

Optional.
Specifies the name of the lesson you want.
In the brackets, type the lesson number.

HelpTutorial
Equivalent to the Tutorial command on the Help menu.  Starts the Tutorial.

Macro
Equivalent to selecting a macro in the Define Macro dialog box and then choosing 
the Run button.  Runs an existing macro.  To make sure the macro is available, 
include a ViewFileOpen command to open the appropriate view file before using this 
command.  
There is also a Macro command for every macro in the view file.  The macro name 
follows Macro, for example, Macro [Search Notes].

Macro .Name=[ ] 
.Name=[ ] 

Required.
Specifies the macro to run.  
In the brackets, type the name of the macro.

MacroDefineMacros
Equivalent to the Define Macros command on the Macro menu.  Displays the Define 
Macros dialog box.

Message 
Displays a message.

Message .Message=[ ] // .Type=[0] .YesText=[Yes] .NoText=[No]
.Message=[ ]

Required.
Specifies the message to display.  If the message is more than one word, it must 
be enclosed in quotation marks or brackets ([ ]).
In the brackets, type the message.  To indicate a new line in the message when 
the message is displayed, type ^n

.Type=[0]
Optional; default is 0 for OK button only. 
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Specifies the buttons to include in the message dialog box.
0 = OK button only
1 = OK and Cancel buttons
2 = Yes and No buttons
3 = Yes, No, and Cancel buttons

.YesText=[Yes]
Optional; use only if used 2 or 3 as the Type argument value. Default is "Yes".
Specifies the text on the Yes button.
In the brackets, replace Yes with whatever text you want on the button.

.NoText=[No]
Optional; use only if used 2 or 3 as the Type argument value. Default is "No".
Specifies the text on the No button.
In the brackets, replace No with whatever text you want on the button.

OptionsBaseCalendars
Equivalent to the Base Calendars command on the Options menu.  Displays the Base
Calendars dialog box so you can change the working days and hours in the base 
calendar you select.

OptionsCalculateNow
Equivalent to the Calculate Now command on the Options menu.  Calculates the 
open projects.

OptionsCalculateProject
Equivalent to the Calculate Project command on the Options menu.  Calculates the 
active project.

OptionsCalculation 
Equivalent to the Calculation command on the Options menu.  Specifies automatic or
manual calculation of the schedule.

OptionsCalculation .Auto=[ ]
.Auto=[ ]

Required.
Specifies whether calculation is automatic or manual.
In the brackets, type 0 for manual or 1 for automatic.

OptionsCustomForms
Equivalent to the Custom Forms command on the Options menu.  Displays the 
Custom Forms dialog box.

OptionsLeveling
Equivalent to the Leveling command on the Options menu.  Specifies automatic or 
manual leveling and other leveling options.

OptionsLeveling // .Auto=[ ] .DelayInSlack=[ ] .RemoveDelay=[ ] .Order=[ ]
.Auto=[ ]

Optional.
Specifies automatic or manual leveling.
In the brackets, type Yes to use automatic leveling or No to use automatic 
leveling.

.DelayInSlack=[ ]
Optional.
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Specifies whether the project can be slipped out beyond the finish date or if it 
should be delayed only within the slack time available.
In the brackets, type Yes to specify that the finish date can slip or No if the finish 
date cannot slip.

.RemoveDelay=[ ]
Optional.
Specifies whether delay is removed before leveling.
In the brackets, type Yes to remove delay before leveling or No to specify that 
delay not be removed.

.Order=[ ]
Optional.
Specifies the criteria Microsoft Project uses to determine which task it should level 
to resolve a resource conflict.
0 = ID only
1 = Standard
2 = Priority, Standard.

OptionsLevelNow 
Equivalent to the Level Now command on the Options menu.  Levels resources to 
resolve resource conflicts.

OptionsLevelNow // .All=[Yes]
.All=[Yes]

Optional; used only when a resource view is active; default is Yes, all resources are
leveled.  Replace Yes with No to level selected resources.
Specifies whether all resources or selected resources are leveled.

OptionsPreferences 
Equivalent to the Preferences command on the Options menu.  

OptionsPreferences // .DurationUnits=[ ] .FixedDuration=[ ] .WorkUnits=[ ] .Hours/
Day=[ ] 
.Hours/Week=[ ] .StandardRate=[ ] .OvertimeRate=[ ] .DefaultView=[ ] .StartOnCu
rrentDate=[ ] .DialogColor=[ ] .FormColor=[ ] .StatusBar=[ ] .EntryBar=[ ] .Toolbar
=[ ] .ScrollBar=[ ] .CriticalSlack=[ ] .GanttBarRounding=[ ] .ScheduleMessages=[ ]
.AutoAddResources=[ ] .AutoTrackResources=[ ] .AutoLink=[ ] .AutoSplit=[ ] .LastF
ile=[ ] .CalendarFile=[ ] .ViewFile=[ ] .StartYearIn=[ ] .DateOrder=[ ] .DateFormat
=[ ] .BarTextDateFormat=[ ] .12HourTimeFormat=[ ] .DefaultTime=[ ] .DateSepara
tor=[ ] .TimeSeparator=[ ] .AMText=[ ] .PMText=[ ] .CurrencySymbol=[ ] .SymbolB
efore=[ ] .CurrencyDigits=[ ] .ThousandsSeparator=[ ] .DecimalSeparator=[ ] .List
Separator=[ ] .EnterMovesDown=[ ]

.DurationUnits=[ ]
Optional.
Specifies the unit of time used if you do not type a unit when typing a duration.
In the brackets, type 0 for minutes, 1 for hours, 2 for days, or 3 for weeks.

.FixedDuration=[ ] 
Optional.
Specifies whether the default task duration is fixed or resource-driven.
In the brackets, type 0 for no or 1 for yes.

.WorkUnits=[ ]
Optional.
Specifies the unit of time used if you do not type a unit when typing work.
In the brackets, type 0 for minutes, 1 for hours, 2 for days, or 3 for weeks.

.Hours/Day=[ ]
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Optional.
Specifies the work hours in each day.  
In the brackets, type the number of hours per day.

.Hours/Week=[ ]
Optional.
Specifies the work hours in each week.  
In the brackets, type the number of hours per week.

.StandardRate=[ ]
Optional.
Specifies the standard rate used if you do not enter a rate.  
In the brackets, type a valid rate including currency and time period, such as 
$10/h.

.OvertimeRate=[ ]
Optional.
Specifies the overtime rate used if you do not enter a rate.  
In the brackets, type a valid rate including currency and time period, such as 
$10/h.

.DefaultView=[ ]
Optional.
Specifies the view displayed when you start a new project.  
In the brackets, type the name of a view.

.StartOnCurrentDate=[ ]
Optional.
Specifies whether new tasks start on the project start date or on the current date. 
If tasks start on the current date, they are given a Start No Earlier Than constraint 
with the current date as the constraint date.
In the brackets, type 0 for tasks start on project start date or 1 for tasks start on 
current date.

.DialogColor=[ ]
Optional.
Specifies the color for the dialog box background.  
In the brackets, type the name of an available color.

.FormColor=[ ]
Optional.
Specifies the color for the form background.  
In the brackets, type the name of an available color.

.StatusBar=[ ]
Optional.
Specifies whether the status bar is displayed or not.
In the brackets, type 0 for not displayed or 1 for displayed.

.EntryBar=[ ]
Optional.
Specifies whether the entry bar is displayed or not.
In the brackets, type 0 for not displayed or 1 for displayed.

.ToolBar=[ ]
Optional.
Specifies whether the tool bar is displayed or not.
In the brackets, type 0 for not displayed or 1 for displayed.

.ScrollBar=[ ]
Optional.
Specifies whether the scroll bars are displayed or not.
In the brackets, type 0 for not displayed or 1 for displayed.

.CriticalSlack=[ ]
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Optional.
Specifies the number of days of slack that make a task critical.  
In the brackets, type the number of days.

.GanttBarRounding=[ ] 
Optional.
Specifies whether durations as shown by Gantt bars are rounded (either to days, if
the minor timescale is one day or greater, or to the minor timescale unit if less 
than one day) or not rounded.
In the brackets, type 0 for not rounded or 1 for rounded.

.ScheduleMessages=[ ]
Optional.
Specifies whether scheduling messages are displayed when Microsoft Project finds
inconsistencies in the schedule.
In the brackets, type 0 for no messages or 1 for messages.

.AutoAddResources=[ ]
Optional.
Specifies whether Microsoft Project adds a new resource to the resource pool 
without first asking if you want to add it and then displaying the Resource Edit 
Form dialog box.
In the brackets, type 0 for ask or 1 for add resource without asking.

.AutoTrackResources=[ ]
Optional.
Specifies whether the duration tracking fields determine the values in the resource
work and cost tracking fields.
In the brackets, type 0 for no, changes in percent duration complete do not 
change actual and remaining work and cost, or 1 for yes, changes in percent 
duration complete do change actual and remaining work and cost.

.AutoLink=[ ]
Optional.
Specifies whether tasks are automatically linked after moving or copying.
In the brackets, type 0 for no or 1 for yes.

.AutoSplit=[ ]
Optional.
Specifies whether remaining duration is automatically rescheduled after progress 
is posted and actual information shows the task behind schedule.
In the brackets, type 0 for no or 1 for yes.

.LastFile=[ ]
Optional.
Specifies whether the last file used should be opened when you start Microsoft 
Project.
In the brackets, type 0 for no or 1 for yes.

.CalendarFile=[ ]
Optional.
Specifies whether changes made to the default calendar file are automatically 
saved.
In the brackets, type 0 for don't save, 1 for save, or 2 for prompt for save.

.ViewFile=[ ]
Optional.
Specifies whether changes made to the default view file are automatically saved.
In the brackets, type 0 for don't save, 1 for save, or 2 for prompt for save.

.StartYearIn=[ ]
Optional.
Specifies the month in which the fiscal year should start.
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In the brackets, type the name of the month in any acceptable format.
.DateOrder=[ ]

Optional.
Specifies the order of the day, month, and year in dates and in date list boxes.
In the brackets, type 0 for month/day/year, 1 for day/month/year, or 2 for 
year/month/day.

.DateFormat=[ ]
Optional.
Specifies the format for the date.  The options change depending on the format 
selected for the DateOrder argument.  In the list below, the order of dates in each 
option corresponds to DateOrder 0, 1, and 2, respectively.
In the brackets, type the number for the format you want:
0 =1/31/92 12:33pm or 31/1/92 12:33pm or 92/1/31 12:33pm1 =1/31/92 or 

31/1/92 or 92/1/31
2 =January 31,1992 12:33pm or 31 January 1992 12:33pm or 1992 January 31 

12:33pm
3 =January 31,1992 or 31 January 1992 or 1992 January 31 
4 =Jan 31 12:33pm or 31 Jan 12:33pm or Jan 31 12:33pm
5 =Jan 31 '92 or 31 Jan '92 or '92 Jan 31 
6 =January 31 or 31 January or January 31
7 =Jan 31 or 31 Jan or Jan 31
8 =Fri 1/31/92 12:33pm or Fri 31/1/92 12:33pm or Fri 92/1/31 12:33pm
9 =Fri 1/31/92 or Fri 31/1/92 or Fri 92/1/31 
10 = Fri Jan 31, '92 or Fri 31 Jan, '92 or Fri '92 Jan 31
11 = Fri 12:33pm
12 = 1/31 or 31/1 or 1/31
13 = 31
14 = 12:33pm

.BarTextDateFormat=[ ]
Optional.
Specifies the format for dates on the Gantt bar chart.  The options change 
depending on the format selected for the DateOrder argument.  In the list below, 
the order of dates in each option corresponds to DateOrder 0, 1, and 2, 
respectively.
In the brackets, type the number for the format you want:
0 = 1/31/92 12:33pm or 31/1/92 12:33pm or 92/1/31 12:33pm
1 = 1/31/92 or 31/1/92 or 92/1/31
2 = January 31,1992 12:33pm or 31 January 1992 12:33pm or 1992 January 31 

12:33pm
3 = January 31,1992 or 31 January 1992 or 1992 January 31 
4 = Jan 31 12:33pm or 31 Jan 12:33pm or Jan 31 12:33pm
5 = Jan 31 '92 or 31 Jan '92 or '92 Jan 31 
6 = January 31 or 31 January or January 31
7 = Jan 31 or 31 Jan or Jan 31
8 = Fri 1/31/92 12:33pm or Fri 31/1/92 12:33pm or Fri 92/1/31 12:33pm
9 = Fri 1/31/92 or Fri 31/1/92 or Fri 92/1/31 
10 = Fri Jan 31, '92 or Fri 31 Jan, '92 or Fri '92 Jan 31
11 = Fri 12:33pm
12 = 1/31 or 31/1 or 1/31
13 = 31
14 = 12:33pm

.12HourTimeFormat=[ ]
Optional.
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Specifies whether times are shown in 12-hour or 24-hour format.
In the brackets, type 0 for no (24-hour format) or 1 for yes (12-hour format).

.DefaultTime=[ ]
Optional.
Specifies the time used when you do not enter a time.
In the brackets, type the number of minutes after midnight.

.DateSeparator=[ ] 
Optional.
Specifies the character used to separate the day, month, and year in abbreviated 
date formats.  
In the brackets, type the character.

.TimeSeparator=[ ]
Optional.
Specifies the character used to separate the hours from the minutes.  
In the brackets, type the character.

.AMText=[ ] 
Optional.
Specifies the text used to indicate morning hours when you are using the 12-hour 
format.  
In the brackets, type the text.

.PMText=[ ]
Optional.
Specifies the text used to indicate evening hours when you are using the 12-hour 
format.  
In the brackets, type the text.

.CurrencySymbol=[ ] 
Optional.
Specifies the symbol used to indicate units of currency.  
In the brackets, type the symbol.

.SymbolBefore=[ ] 
Optional.
Specifies whether the currency symbol goes before or after the amount of money.
In the brackets, type 0 for no (after) or 1 for yes (before).

.CurrencyDigits=[ ]
Optional.
Specifies the number of digits displayed after the decimal separator.
In the brackets, type 0 for zero digits, 1 for one digit, or 2 for two digits.

.ThousandsSeparator=[ ]
Optional.
Specifies the character used to separate the hundreds, thousands, and millions 
digits.  
In the brackets, type the character.

.DecimalSeparator=[ ] 
Optional.
Specifies the character used to separate the whole number from the fractional 
part of a decimal number.  
In the brackets, type the character.

.ListSeparator=[ ]
Optional.
Specifies the character used to separate entries in a list, such as in the 
Predecessors field or Resource Names field.  
In the brackets, type the character.

.EnterMovesDown=[ ]
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Optional.
Specifies whether the same field stays active after you press ENTER or if the field 
below becomes active.
In the brackets, type 0 for same field stays active or 1 for field below becomes 
active.

OptionsProjectInfo
Equivalent to the Project Info command on the Options menu.  Specifies general 
information about the project.

OptionsProjectInfo // .Project=[ ] .Company=[ ] .Manager=[ ] .Calendar=[ ] .Curren
t=[ ] .Start=[ ] .Finish=[ ] .Notes=[ ]

.Project=[ ]
Optional.
Equivalent to the Project box in the Project Information dialog box.
In the brackets, type the name of the project.  

.Company=[ ]
Optional.
Equivalent to the Company box in the Project Information dialog box.
In the brackets, type the name of the company.  

.Manager=[ ]
Optional.
Equivalent to the Manager box in the Project Information dialog box.
In the brackets, type the name of the manager.  

.Calendar=[ ]
Optional.
Equivalent to the Calendar box in the Project Information dialog box.  If the 
calendar isn't found, Standard is used.  To make sure that the calendar is 
available, include a FileOpen command to open the appropriate calendar file 
before this command.
In the brackets, type the name of the project calendar.  

.Current=[ ]
Optional.
Equivalent to the Current Date box in the Project Information dialog box.
In the brackets, type the current date if you want to use a date other than the 
system date.  

.Start=[ ]
Optional.
Equivalent to the Start box in the Project Information dialog box.  If you enter a 
start date, the project is scheduled from start.  If neither a start date nor finish 
date is entered, the project is scheduled from start.
In the brackets, type the start date for the project.  

.Finish=[ ]
Optional.
Equivalent to the Finish box in the Project Information dialog box.  If you enter a 
finish date, the project is scheduled from finish.  
In the brackets, type the finish date for the project.  

.Notes=[ ]
Optional.
Equivalent to the Notes box in the Project Information dialog box.  
In the brackets, type notes about the project.  

OptionsProjectStatus
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Equivalent to the Project Status command on the Options menu.  Displays the 
scheduled, planned, and actual start and finish dates; the duration, work, and cost 
totals; and the duration and work percent complete for the project.

OptionsRemoveDelay
Equivalent to the Remove Delay command on the Options menu.  Removes the delay
from all tasks or selected tasks.

OptionsRemoveDelay .All=[ ] 
.All=[ ]

Required.
Specifies whether delay is removed for selected tasks or all tasks.
In the brackets, type Yes to remove delay for all tasks or No to remove delay for 
selected tasks.

OptionsResourceCalendars
Equivalent to the Resource Calendars command on the Options menu.  Opens the 
Resource Calendars dialog box so you can change the working days and hours in a 
resource calendar you select.

OptionsSetActual
Equivalent to the Set Actual command on the Options menu.  Records progress on 
specified tasks.

OptionsSetActual // .All=[ ] .UpdateDate=[ ] .Action=[ ]
.All=[ ]

Optional.
Specifies whether actual information is recorded for all tasks or selected tasks.
In the brackets, type Yes to set actual information for all tasks or No to set actual 
information for selected tasks.

.UpdateDate=[ ]
Optional.
Specifies the update date to use to indicate progress.
In the brackets, type the date in any acceptable date format. If there is a chance 
that when the macro is run, the date format settings in the Preferences dialog box 
will be different from the date format you use here, precede the date with "@". 

.Action=[ ]
Optional.
Specifies the actual information you want to record.  These options correspond to 
the options under For Tasks Before Update Date in the Set Actual dialog box.
0 = Set actual start and finish dates only
1 = Set percent complete to update date
2 = Schedule remainder to start on update date

OptionsSetPlan
Equivalent to the Set Plan command on the Options menu.  Creates a baseline plan 
using current dates for selected tasks or all tasks.

OptionsSetPlan // .All=[ ] .Copy=[ ] .Into=[ ]
.All=[ ]

Optional.
Specifies whether the plan is set for all tasks or selected tasks.
In the brackets, type Yes to set the plan for all tasks or No to set the plan for 
selected tasks only.

.Copy=[ ]
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Optional.
Specifies the set of schedule information you want to copy.
To indicate the information you want to copy, type one of the following numbers in
the brackets:
0 = Scheduled Start/Finish
1 = Planned Start/Finish
2 = Start1/Finish1
3 = Start2/Finish2
4 = Start3/Finish3
5 = Start4/Finish4
6 = Start5/Finish5

.Into=[ ]
Optional.
Specifies the set of plan or interim plan dates where you want the schedule 
information transferred.
To indicate the fields into which you want the information transferred, type one of 
the following numbers in the brackets:
0 = Planned Start/Finish
1 = Start1/Finish1
2 = Start2/Finish2
3 = Start3/Finish3
4 = Start4/Finish4
5 = Start5/Finish5

OptionsSpelling 
Equivalent to the Spelling command on the Options menu.  Starts the spelling 
checker.

OptionsSpellingOptions
Equivalent to the Spelling Options command on the Options menu.  Displays the 
Spelling Options dialog box so you can change the options used when checking 
spelling.

OutlineCollapse
Equivalent to clicking the collapse button on the entry bar or pressing 
ALT+SHIFT+MINUS SIGN (on the numeric keypad).  Collapses the selected summary 
tasks.

OutlineDemote
Equivalent to clicking the demote button on the entry bar or pressing ALT+SHIFT+RIGHT 
ARROW.  Demotes the selected tasks.

OutlineExpand
Equivalent to clicking the expand button on the entry bar or pressing ALT+SHIFT+PLUS 
SIGN (on the numeric keypad).  Expands the selected summary tasks.

OutlineExpandAll
Equivalent to clicking the expand all button on the entry bar or pressing ALT+SHIFT+* 
(asterisk on the numeric keypad).  Expands all the summary tasks.
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OutlinePromote
Equivalent to clicking the promote button on the entry bar or pressing ALT+SHIFT+LEFT 
ARROW.  Promotes the selected summary tasks.

PaneClose
Equivalent to double-clicking the split box or pressing SHIFT+F4.  Closes the bottom 
pane in a combination view.

PaneCreate
Equivalent to splitting a single-pane window.  The Task Form is placed in the bottom 
view if the original view was a task view.  The Resource Form is placed in the bottom 
view if the original view was a resource view.  

PaneNext
Equivalent to clicking the pane that is not active or pressing F6.  Moves to the next 
pane.

SelectAll
Selects all the tasks or resources in the project.

SelectBeginning
Equivalent to pressing CTRL+HOME.  Moves to the first unlocked column in the first row
of the view.  

SelectBeginning // .Extend=[No]
.Extend=[No]

Optional; default is No.  Replace No with Yes to extend the selection.
Specifies whether everything is selected between the active field and the 
beginning of the project.

SelectCellDown 
Selects a field below the active field.

SelectCellDown // .NumCells=[1] .Extend=[No]
.NumCells=[1]

Optional; default is 1. 
Specifies the field to be selected by indicating the number of fields below the 
currently selected field.  If the value you enter is greater than the number of fields
available below the active field, then Microsoft Project selects the bottom field in 
the column.

.Extend=[No]
Optional; default is No.  Replace No with Yes to extend the selection.
Specifies whether everything is selected between the active field and the field 
specified in NumCells.

SelectCellLeft
Selects a field to the left of the active field.

SelectCellLeft // .NumCells=[1] .Extend=[No]
.NumCells=[1]

Optional; default is 1.
Specifies the field to be selected by indicating how far to the left it is of the 
currently selected field.  If the value you enter is greater than the number of fields
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available to the left, then Microsoft Project selects the first unlocked field.
.Extend=[No]

Optional; default is No.  Replace No with Yes to extend the selection.
Specifies whether everything is selected between the active field and the field 
specified in NumCells.

SelectCellRight 
Selects a field to the right of the active field.

SelectCellRight // .NumCells=[1] .Extend=[No]
.NumCells=[1]

Optional; default is 1.
Specifies the field to be selected by indicating how far to the right it is of the 
currently selected field.  If the value you enter is greater than the number of fields
available to the right, then Microsoft Project selects the last unlocked field.

.Extend=[No]
Optional; default is No.  Replace No with Yes to extend the selection.
Specifies whether everything is selected between the active field and the field 
specified in NumCells.

SelectCellUp 
Selects the field above the active field.

SelectCellUp // .NumCells=[1] .Extend=[No]
.NumCells=[1]

Optional; default is 1.
Specifies the field to be selected by indicating the number of fields above the 
currently selected field.  If the value you enter is greater than the number of fields
available above the active field, then Microsoft Project selects the top field in the 
column.

.Extend=[No]
Optional; default is No.  Replace No with Yes to extend the selection.
Specifies whether everything is selected between the active field and the field 
specified in NumCells.

SelectColumn 
Equivalent to pressing CTRL+SPACE.  Selects the column containing the active field.  

SelectEnd 
Equivalent to pressing CTRL+END.  Moves to the last field in the last row that contains 
information.  

SelectEnd // .Extend=[No]
.Extend=[No]

Optional; default is No.  Replace No with Yes to extend the selection.
Specifies whether everything is selected between the active field and the end of 
the information.

SelectRow  
Equivalent to pressing SHIFT+SPACE.  Selects the row containing the active field.  

SelectRowEnd
Equivalent to pressing END.  Moves to the last field in the current row.  

SelectRowEnd // .Extend=[No]
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.Extend=[No]
Optional; default is No.  Replace No with Yes to extend the selection.
Specifies whether everything is selected between the active field and the last field
in the row.

SelectRowStart 
Equivalent to pressing HOME.  Moves to the first field in the current row.  

SelectRowStart // .Extend=[No]
.Extend=[No]

Optional; default is No.  Replace No with Yes to extend the selection.
Specifies whether everything is selected between the current field and the first 
field in the row.

SendKey
Equivalent to pressing a key on the keyboard. Specifies keys to send to Microsoft 
Project. 

SendKey .Keys=[ ] 
.Keys=[ ]

Required.
Specifies the key or key combination to send to Microsoft Project.   
In the brackets, type the keys.  You can also specify characters that aren't 
displayed when you press the key. The keys you can use are listed below. Be sure 
to type them as indicated, including the brackets ({ }).
{BACKSPACE} or {BS}
{BREAK}
{CAPSLOCK}
{CLEAR}
{DELETE} or {DEL}
{DOWN}
{END}
{ENTER} or {RETURN} or ~ (tilde)
{ESCAPE} or {ESC}
{HELP}
{HOME}
{INSERT}
{LEFT}
{NUMLOCK}
{PAGEDOWN} or {PGDN}
{PAGEUP} or {PGUP}
{PRINTSCREEN} or {PRTSC}
{RIGHT}
{TAB}
{UP}
{F1} through {F16}
To specify a key combination that begins with SHIFT, precede the key code with + 
(plus sign).  For example, type .keys=+{f1} to send the key combination for 
SHIFT+F1 to start Help so you can click what you want help on.
To specify a key combination that begins with CTRL, precede the key code with ^ 
(carat).  For example, type .keys=^c to use the Copy command to copy the 
selection.
To specify a key combination that begins with ALT, precede the key code with % 
(percent).  For example, to choose the FormatOutline command and select or clear
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the Outline Number check box, type .keys=[%ron{return}].  The "%ro" displays
the Outline dialog box, "n" selects or clears the Outline Number check box, and 
"{return}" closes the dialog box and carries out the command.
To repeat a key sequence, type the number of times you want the sequence 
repeated following the key code.  For example, type .keys=[{right 3}] to move 
right three fields.

SetField 
Used to enter a value in the field you specify.

SetField .Field=[ ] .Value=[ ] // .Create=[No]
.Field=[ ]

Required.
Specifies the name of the field for which you want to specify a value.
In the brackets, type the name of the field.

.Value=[ ]
Required.
Specifies the value to place in the field.
In the brackets, type the value.

.Create=[No]
Optional; default is No. Replace No with Yes to create new tasks or resources.
Allows a task or resource to be created by entering a value in a blank task or 
resource row. 

SetMatchingField 
Equivalent to the combination of filtering the tasks or resources, selecting the 
filtered list, and then setting a field in these tasks or resources to a certain value. 

SetMatchingField .Field=[ ] .Value=[ ] .CheckField=[ ] .CheckValue=[ ] // .CheckTes
t=[Equals] .CheckOp=[And] .CheckField2=[ ] .CheckValue2=[ ] .CheckTest2=[ ]

.Field=[ ]
Required.
Specifies the name of the field for which you want to specify a value.
In the brackets, type the name of the field.

.Value=[ ]
Required
Specifies the value to place in the field.
In the brackets, type the value.

.CheckField=[ ]
Required.
Specifies the name of the field you want to search.  
In the brackets, type the name of the field.

.CheckValue=[ ]
Required.
Specifies the number or text you want to compare to the value in each field.  
In the brackets, type the value you want to use.

.CheckTest=[Equals]
Optional; default is Equals. Replace "Equals" with the test you want to use.
Specifies the test you want to use when comparing the value in the field with the 
value in the CheckValue argument.  
In the brackets, type a test: equals, not equals, greater, gtr or equal, less, less or 
equal, within, not within, contains, doesn't contain.

.CheckOp=[And]
Optional; default is And.  Replace And with Or.if you want the command to return 
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TRUE if either criterion is true.
Specifies the operator, AND or OR, to use to connect the two sets of criterion.  Use
only if you plan to use the CheckField2, CheckTest2, and CheckValue2 arguments.

.CheckField2=[ ]
Optional.
Specifies the name of the second field you want to search.  
In the brackets, type the name of the field.

.CheckTest2=[ ]
Optional.
Specifies the test you want to use when comparing the value in the field in 
CheckField2 with the value in the CheckValue2 argument.  
In the brackets, type a test: equals, not equals, greater, gtr or equal, less, less or 
equal, within, not within, contains, doesn't contain.

.CheckValue2=[ ] 
Optional.
Specifies the number or text you want to compare to the value in each field.  
In the brackets, type the value you want to use.

Table
Equivalent to applying a table by using the Define Tables command on the Table 
menu.  Applies an existing table.  If the table is not in the open view file, applies the 
default table.  To make sure that the table is available, include a ViewFileOpen 
command to open the appropriate view file before using this command.  

Table .Name=[ ] 
.Name=[ ]

Required.
Specifies the table to apply.  
In the brackets, type the name of the table.

TableDefineTables
Equivalent to the Define Tables command on the Table menu.  Displays the Define 
Tables dialog box.

TimescaleZoomIn
Equivalent to clicking the timescale zoom in button on the tool bar or pressing CTRL+/
(slash on the numeric keypad).  Shows more detail by displaying a smaller period of 
time on the timescale.

TimescaleZoomOut
Equivalent to clicking the timescale zoom out button on the tool bar or pressing 
CTRL+* (asterisk on the numeric keypad).  Shows less detail by displaying a greater 
period of time on the timescale.

UpdateDDELinks
Equivalent to choosing the Update button in the Links dialog box. Updates all links.  

View
Equivalent to displaying a view by using the Define Views command on the View 
menu.  Displays an existing view.  If the view is not in the open view file, displays the
view listed in the Default View option in the Preferences dialog box.  To make sure 
that the view is available, include a ViewFileOpen command to open the appropriate 
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view file before using this command.  
View .Name=[ ] // .SinglePane=[No] .Toggle=[No] 

.Name=[ ]
Required.
Specifies the view to display.  
In the brackets, type the name of the view.

.SinglePane=[No]
Optional; default is No.  Replace No with Yes if you want a single-pane view.
Specifies whether the view is displayed as a single-pane view.

.Toggle=[No]
Optional; default is No.  Replace No with Yes if you are displaying a single-pane 
view and want replace it with a combination view or vice versa. 
Equivalent to holding down SHIFT as you choose a view from the View menu.

ViewDefineViews
Equivalent to the Define Views command on the View menu.  Displays the Define 
Views dialog box.

ViewFileOpen
Equivalent to choosing a view file to open using the Define Views command on the 
View menu.  Opens a new view file.

ViewFileOpen .Name=[ ] // .Merge=[No] .Views=[ ] .Tables=[ ] .Filters=[ ] .Reports
=[ ] .Macros=[ ] .Toolbar=[ ]

.Name=[ ]
Required.
Specifies the view file to open.
In the brackets, type the name of the view file to open.

.Merge=[No]
Optional; default is No.  Replace No with Yes to merge the two view files.  
Specifies whether the view file you are opening should replace the existing view 
file or if the two files should be merged.

.Views=[ ]
Optional.
Specifies whether the views in the two files should be merged.
In the brackets, type Yes to merge the views or No to use the original views. 

.Tables=[ ]
Optional.
Specifies whether the tables in the two files should be merged.
In the brackets, type Yes to merge the tables or No to use the original tables. 

.Filters=[ ]
Optional.
Specifies whether the filters in the two files should be merged.
In the brackets, type Yes to merge the filters or No to use the original filters. 

.Reports=[ ]
Optional.
Specifies whether the reports in the two files should be merged.
In the brackets, type Yes to merge the reports or No to use the original reports. 

.Macros=[ ]
Optional.
Specifies whether the macros and custom edit forms in the two files should be 
merged.
In the brackets, type Yes to merge the macros and custom edit forms or No to use 

35



the original macros and custom edit forms. 
.Toolbar=[ ]

Optional.
Specifies whether the tool bar should come from the current file or the new file.
In the brackets, type Yes to use the tool bar in the new file or No to keep the 
original tool bar. 

ViewFileSave
Equivalent to saving a view file with the same name using the Define Views 
command on the View menu.  

ViewFileSaveAs
Equivalent to saving a view file using the Define Views command on the View menu. 
Saves a view file with the name you specify.

ViewFileSaveAs .Name=[ ] 
.Name=[ ]

Required.
Specifies the name of the view file to save.
In the brackets, type a name for the view file.

WindowActivate 
Specifies the window and the pane you want to be active.

WindowActivate // .WindowName=[ ] .TopPane=[ ]
.WindowName=[ ]

Optional.
Specifies the window to make active. 
In the brackets, type the exact text in the window title bar.

.TopPane=[ ]
Optional.
Specifies which pane in the active view should be active.
In the brackets, type Yes if you want the top pane to be active or No if you want 
the bottom pane active.

WindowArrangeAll
Equivalent to the Arrange All command on the Window menu.  Resizes and 
rearranges the open windows so all are visible.

WindowHide
Equivalent to the Hide command on the Window menu.  Hides the active window.

WindowMoreWindows
Equivalent to the More Windows command on the Window menu.  Displays the 
Window Activate dialog box so you can select the window you want to be the active 
window.

WindowNewWindow 
Equivalent to the New Window command on the Window menu.  Opens another 
window on the active project or combines multiple projects in one window.

WindowNewWindow // .Projects=[ ] .View=[ ] .AllProjects=[No]
.Projects=[ ]
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Optional.
Specifies the projects to place in the new window.  If you specify more than one 
project, you must include quotation marks or brackets ([ ]) around the project 
names.
In the brackets, type the names of the projects. If you type more than one project 
name, separate the projects with the list separator character.  If you include a 
project that is not open, it is skipped.

.View=[ ]
Optional; default is Task Sheet.
Specifies the view to be used.  
In the brackets, type the name of the view.  If the view is not in the active view 
file, the default view is used.

.AllProjects=[No]
Optional; default is No.  Replace No with Yes if you want to place all projects in the 
new window.
Specifies that all open projects are placed in the new window.  

WindowNext
Equivalent to pressing CTRL+F6 when more than one window is open. Moves to the 
next window.

WindowNext // .NoWrap=[ ] 
.NoWrap=[ ]

Optional.
Specifies whether, when you reach the last window, you next move to the starting 
window.
In the brackets, type Yes if you don't want to wrap or No if you do.

WindowPrev
Moves to the previous window.

WindowPrev // .NoWrap=[ ] 
.NoWrap=[ ]

Optional.
Specifies whether, when you reach the last window, you next move to the starting 
window.
In the brackets, type Yes if you don't want to wrap or No if you do.

WindowUnhide 
Equivalent to the Unhide command on the Window menu.  Makes a hidden window 
visible.

WindowUnhide .Name=[ ]
.Name=[ ]

Required.
Specifies the window to make visible.  
In the brackets, type the name of the hidden window.
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