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Overview of Ascend's Calendar Sharing
Ascend allows users on a local area network to share calendars and to schedule meetings 
for groups.    With Ascend's networking features you can:

- View appointments of other Ascend users on your network.
- Add, edit or delete appointments for others.
- Use passwords to restrict who can view and/or edit your calendar.

Ascend can share calendars across any network as long as each user has access to a 
"network directory" on a shared network drive.    An individual's data can be stored on 
either their local hard drive or the network drive.



Installing Ascend on the Network
To install the networking options of Ascend, do the following steps.

1. Be sure you have loaded Ascend version 3.12 (or later) onto your hard drive.
2. Start Ascend
3. Click on the network icon (a cable with two ends).
4. Select Network Options from the Options menu.

Follow the instructions on the network options dialog box.    Once you complete this 
information, you will be ready to use Ascend on the network.

NOTE:    Setting up each user on the network MUST BE don on the users workstation from 
within their own copy of Ascend.    You cannot add other users while running your copy of 
Ascend.

NOTE:    Ascend will automatically create the necessary directories and files for you.    You 
must, therefore, have read/write and directory create rights for the network.    If 
you are not sure if you have the proper rights, see your in-house network administrator for 
assistance.



Using Calendar Sharing
Once you have entered the network options, Ascend will display each individual on the 
network that has also set up their copy of Ascend to work via the network.

In order to view or change another user's appointments, you must first "connect" to that 
user    This is required since there may be dozens of users on the network using Ascend, 
and if you were connected to everyone of them, it would take Ascend a long time to read 
and display each of their appointments.    Therefore, you can simply connect to those users 
that you are currently interested in.    Ascend will save your connection status if you leave 
the network window or even quit Ascend.

If the user you wish to connect to has their data stored on their local hard drive as 
explained in the Network Options section of the program, you cannot connect to this user 
unless he or she is currently running Ascend from within Windows.    (The user can be in a 
different application, but must have Ascend running under Windows.)    If a red button 
appears to the left of a user's name, this means that the user's data is on a local hard drive
and that they are not running Ascend.    Therefore, you cannot be connected.

Once you have connected to a user, Ascend will display that user's appointments for the 
current page date in the time graph to the right of their name.    To view other dates, simply
change the page date the same way you change days for your prioritized daily task list.

To the left of each user will appear a colored button.    Here are the meanings of the 
different colored buttons.

GRAY - NOT CONNECTED

These are the users that you are not connected to but that are available to be 
connected to.

RED - CANNOT CONNECT

As explained above, these are users that have their data stored on a local hard 
drive and are not running Ascend and cannot, therefore, be connected to.

GREEN - CONNECTED

These are users that you are currently connected to.

YELLOW - WAITING FOR RESPONSE

Ascend will temporarily show a yellow button as it waits to receive information 
from users whom you have connected to who have their data stored on their local
hard drives.

If you are connected to a user that stores their data on a local hard drive and that user 
stops running Ascend, their button will change from Green to Red, thus prohibiting you 
from viewing their appointments or connecting to them.



Connecting / Disconnecting from Users
There are three ways to connect or disconnect from a users.    They are:

1. Double click on the user's name in the list box.
2. Select a user's name in the list box and click the C or D buttons next to the name.
3. Select a user's name in the list box and select the Connect or Disconnect menu 

option.

Once you have connected to a user, Ascend will read their data files and display a chart of 
their appointments next to their name.



Network Options
From the network options dialog, you set up the network control information for your 
version of Ascend.    Each of the fields will be explained below.

User Name

Enter your name and/or title.    This is the name other Ascend users will see when 
they are accessing your calendar across the network.    (Examples: John Doe, 
Sandy Smith/VP Marketing, etc.)

Network Directory

Ascend must store certain files and user information in a directory on the network
drive.    This directory is called the "network directory".    Enter the network 
directory where everyone's network information will be stored on the network.    
For example, "J:\ASCNDNET".

For each group that wishes to share information across the network, each Ascend 
user in the group should enter the same directory in this field.

If you are the first Ascend user to use the directory entered, when you close the 
dialog box, Ascend will tell you that the directory specified was not found and will 
ask you if you wish Ascend to automatically create the directory for you and copy 
the necessary files into the new directory.

If you are not the first user, simply enter the drive letter and name of the 
directory which previous users have used.

Path Name

For each Ascend user on the network, Ascend will create a sub-directory under 
the network directory (entered above).    Ascend uses these directories to store 
certain files (messaging, user information, data files, etc.) about each user.    Enter
an 8 character, unique name for this path.    If the path is a new one, when you 
close the dialog box, Ascend will tell you that the path does not exist and ask you 
if you wish Ascend to automatically create the sub-directory and copy the 
necessary files to it.

Data Location

Ascend allows users to have their data files on either their local hard drive or the 
network drive.    Unless users take their data with them (portable computer, home 
use, etc.), it is recommended that they store their data on the network drive.    
Storing data on the network drive has two main advantages:

1. Other users will be able to access your calendar even if you are not running 
Ascend.    (If your data is stored somewhere besides in the network directory, 
you must be running Ascend within Windows in order for others to look at or 
change your data.)

2. Other users can access your calendar faster if your data is stored on the 
network drive.



Select whether you will have your data on your local hard drive or on your 
network drive.    If you specify On Network Drive, Ascend will look for your data 
files in the directory and path specified as the network directory and path as 
explained above.

If your data files are NOT stored in the network directory and path as explained 
above (even if your data is on the network drive in some other directory), you 
should specify On Local Drive, and Ascend will look for your data files in the 
directory where you started Ascend from (the directory specified in your Program 
Manager).    Remember, even if your data is stored on a network drive, if it is not 
in the network directory and path specified in this dialog box, you must specify 
On Local Drive.

The first time you set up your Ascend's network options, this field will default to 
On Local Drive, since that is where your data would be the first time you set up 
the network options.    If you change your selection, after you close this dialog 
box, Ascend will automatically move your data for you.    For example, if you 
change your selection from On Local Drive to On Network Drive, Ascend will 
automatically copy the files from your local drive to the network drive and then 
erase the files from your local drive.

Network Check Rate

Since Ascend supports any network (not just Novell, Lan Manager, Etc.), Ascend 
must use its own proprietary messaging system from within Windows.    This field 
allows you to specify how often (in seconds) you wish Ascend to poll the network 
for messages.

Usually you will enter a 1 in this field.    Entering a 1 will tell Ascend to check for 
new meetings, messages, etc., every 1 second.    However, if you are connected 
to several users on the network (10 or more), or if you have slower hardware, you 
may wish to increase this field to 5, 10 or 15.

The higher the number, the faster your system will run but the longer it will take 
to be notified of appointment changes and additions.    Try setting this field to 1 at 
first and if your system slows down too much, gradually increase the number until
adequate performance is reached.    The maximum value for this field is 60 
(seconds).

Passwords - Change / View Appointments

Ascend allows you to have two different passwords.    You can give the View 
Appointments Password to individuals that you wish to be able to only look at 
your appointments but not make changes.    You can give the Change 
Appointments Password to individuals that you wish to be able to both view 
and edit your appointments.    When a user connects to you over the network, 
they will be required to enter one of these passwords to connect with you.    If you 
do not wish to have a password (thus letting anyone connect with you and change
your appointments), simply leave these fields blank.

Notify of Changes

Check this box if you wish to receive a warning message whenever another user 
changes one of your existing appointments or adds a new appointment to your 
Ascend calendar.



OK

Once you have entered the appropriate fields, select the OK button.    Ascend will 
then save your network options.    If necessary, Ascend will ask you if you wish to 
create the network directory and/or path as described above.



Editing Appointments
To view specific information about an appointment, simply hold down the left mouse button
while the cursor is positioned on the desired appointment's bar.

If you have password clearance, you can change another user's appointments.    Here are 
some options that you have:

You can change an appointment's name, notes, etc. by double clicking on the 
desired appointment's bar.    (Or highlight an appointment's bar and use the Edit 
Appointment option from the options menu.)

You can move an appointment by dragging the appointment's bar while holding 
down the left mouse button.

You can make an appointment longer or shorter by dragging either side of the 
appointment bar with the mouse.

If you change an appointment, Ascend will notify the user who's appointment you changed 
as well as all other users connected to that user on the network.



Adding and Deleting Appointments
Use the Add Appointment or Delete Appointment options from the Options menu to add or 
delete appointments to one or more users on the network.

When you select the Add Appointment option, you will first be prompted to enter in the 
appointment information, (description, time, etc.), and then you will be presented with a 
list of available users to add the appointment for.    Once you have selected the users, 
Ascend will automatically add the appointments for each of the specified users and notify 
all users of the appointment changes.



Find Vacant Time
Use the Find Vacant Time option from the Options menu to help you find available time 
slots for meetings with groups.

Users

Select the users that you would like to scan for a vacant time for.    Only those 
users that you are currently connect to will be in this list box.

Starting Time

Select the time that you would like the scanning function to start at.

Ending Time

Select the time that you do not want to exceed when scanning.    For example, if 
you select 5:00 pm as the ending time, Ascend will not scan for a appointment 
time slot that will exceed 5:00 pm.

Duration

Enter the duration (in time blocks) that you desire to scan for.    1 time block is 
equal to 15 minutes.

Find

Press the Find button once you have selected the users whom you want to scan 
for.    Ascend will then list all of the available starting times that you can select 
from.

Once you have found a suitable time, select the OK and you can add the appointment for 
the people specified.



User Information
Select the User Information option from the View menu to see detailed information about a 
particular user, such as the user's data location, permission level, login date and time, etc.  
If you have a user highlighted in the network window when you select this option, Ascend 
will display the user information for the highlighted user.    If you do not have a user 
highlighted, Ascend will present you with a list of users to choose from.



Show All Users
If you only wish to see those user's that you are currently connected to, simply select the 
Show All Users option from the View menu.    If this option is checked, all users in the 
network directory will be displayed.    If this option is not checked, only those users that you
are connected to will be displayed.


