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Chapter 1

MWM

1.1 MWM.guide/Contenuti

+--- - - - - ---+--- - - - ←↩
- ---+

| ! Benvenuto nel primo generatore di file HTML facile-da-usare! |

+--- - - - - ---+--- - - - - ---+

M W M

-->* Magic WWW (World-Wide Web) files Maker *<--
_______________________________________

|
|
|

Versione 1.08
___________________________________
| |
| from an idea of Maurizio Fabiani |
| developed by Massimo Baglione |
|___________________________________|

Di cosa si tratta ?

La finestra principale
-->
Tasti speciali

La finestra per la singola linea

La finestra di aiuto

La finestra ’’ What is ? ’’

Il menu

Cosa puo’ fare MWM ?
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Informazioni generali

Ringraziamenti

Storia di MWM

1.2 MWM.guide/Di cosa si tratta?

DI COSA SI TRATTA ?

Un giorno il mio amico Maurizio mi chiese: "Hey Max, pensi sia possibile
scrivere un programma per la creazione di file in formato HTML che dia la
possibilita’ all’ utente di caricare normali file ASCII e trasformarli in
HTML selezionando parti di testo utilizzando il mouse ?"

Gli feci capire che non ero in grado di operare miracoli, ma lui insistette.

Bene, ora ci sono quasi riuscito.

MWM infatti consente di caricare un normale file di testo e tramite il mouse
si puo’ applicare alle righe o alle singole parole selezionate le immagini, i
testi e tutto quello che consente il formato HTML.

L’ interfaccia grafica e’ composta essenzialmente da :

- Finestra principale, che mostrera’ il normale file di testo caricato.
Se al testo e’ stata applicata qualche particolare azione, allora verra’
evidenziato con un colore diverso dal resto del testo.
Come molti programmi grafici e word processor, questa finestra contiene
delle piccole immagini associate a delle azioni.

- Finestra per editare una singola linea di testo.

- Finestra delle etichette, che mostrera’ le etichette contenute in un
file HTML da linkare. (vedere in seguito)

- Finestra di aiuto, che informa l’ utente su tutto cio’ che sta’
facendo o succedendo.

- Finestra "What is?", che associa ad ogni riga del testo una piccola
stringa per poter riconoscere "al volo" ogni oggetto.

1.3 MWM.guide/La finestra principale

LA FINESTRA PRINCIPALE.

Una volta caricato il file di testo, lo si potra’ vedere chiaramente in una
delle finestre: la finestra principale.

Con il tasto sinistro del mouse si seleziona una porzione di testo e con



MWM 3 / 24

uno dei gadget degli strumenti gli si puo’ assegnare un’ azione che puo’
essere una immagine, un riferimento ad altro testo, una lista e tutte
quelle belle cosette che consente il formato HTML.

Se avete la necessita’ di applicare azioni a singole parole all’ interno di
una riga e’ sufficiente selezionare tale riga con un doppio click.

Una piccola finestra si aprira’ con l’intera riga del testo messa a vostra
disposizione: la finestra per la singola linea.

Il motivo per il quale non ho implementato tale possibilita’ direttamente nella
finestra principale e’ dovuto al fatto che ho voluto semplificare al massimo
l’ uso del programma e che comunque il tipo di gestione del testo di MWM
renderebbe troppo lenta la visualizzazione in caso di scroll.

Applicando diverse azioni al testo si creano degli oggetti che saranno
visualizzati con colori diversi per poterli distinguere con facilita’.

L’ oggetto viene numerato in base all’ ordine di creazione e selezionandolo
si avra’ la possibilita’ di controllarne i dati essenziali nella finestra di
aiuto.

Partendo dal primo gadget a sinistra troviamo:

TEXT

IMAGE

LIST

FORM

MORE

HEAD

SIZE

VIEW

PREFS

1.4 MWM.guide/Primo gadget TEXT

TEXT gadget

Si intende definire per le linee selezionate un particolare tipo di
testo.

Se si sta lavorando sulla finestra dedicata all’ editing di una singola
linea, MWM ci dara’ le seguenti possibilita’:

- E’ un link ad una etichetta gia’ creata all’ interno del
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documento corrente.

- E’ un link ad un altro documento.

In questo caso programmi tipo Mosaic evidenzieranno questa
parte di testo e, se l’ utente selezionera’ col mouse questa
porzione, allora verra’ chiamato il nuovo testo definito da
questa azione.

Scelto il file da chiamare, MWM vi chiedera’ se, oltre al nome
di tale file, avete bisogno anche del nome di una etichetta
contenuta in esso.

In caso di risposta affermativa, MWM vi dara’ la lista
completa delle etichette contenute in quel file.
E’ sufficiente un doppio click con il tasto sinistro del mouse
per operare la scelta.

- E’ un link ad un sito in cui si desidera entrare.

MWM vi aprira’ requester per sapere dove andare a leggere il
nome del sito. Le possibili risposte sono:

- Selected line.

Il nome del sito e’ il testo attualmente selezionato.
In questo caso MWM ridurra’ ad una le linee selezionate.

- Keyboard.

Il nome del sito verra’ definito manualmente tramite tastiera.

- PATH:file.

Il nome del sito e’ contenuto nel file specificato
precedentemente definendo la configurazione.

La lista DEVE essere simile a questo esempio:

www.vol.it
agnus.livewire.com
www.lycos.com
www.yahoo.com
...

Se non diversamente specificato, MWM cerchera’ la lista dei
siti nel file "PROGDIR:MWM.sites".
E’ possibile specificare una diversa locazione del suddetto
file usando la funzione del gadget "PREFS" alla voce
"Sites list".

MWM dara’ la seguente lista:

file://localhost/
http://
ftp://
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mailto:
news:
gopher:
telnet:

Effettuata la scelta, si dovra’ aggiungere il nome completo del
sito.

- E’ un semplice testo.

Tutto il testo selezionato verra’ trattato da Mosaic come del
semplice testo, formattato secondo lo standard.

Se invece si sta lavorando nella finestra principale con una o piu’ linee
selezionate, allora MWM ci dara’, oltre alle precedenti, anche queste
possibilita’:

- E’ un testo preformattato.

Programmi tipo Mosaic sono "obbligati" a formattare il testo
che devono visualizzare seguendo gli standard in vigore.
Con tale azione si intende specificare che tutto il testo
selezionato non dovra’ assolutamente essere influenzato da
tale formattazione.
E’ molto utile per quei testi che perderebbero di significato
se venisse modificata l’ impaginazione originale, ad esempio i
listati dei programmi.

- E’ un paragrafo.

Il testo selezionato sara’ racchiuso tra <P> e </P>, ovvero faranno
parte di un paragrafo.
MWM vi chiedera’ il tipo di allineamento:

DEFAULT, LEFT, RIGHT, JUSTIFY.

- Sono dati riguardanti l’ autore.

Con questa azione MWM inserira’ le linee selezionate nell’ area
dedicata alle informazioni dell’ autore del documento, ovvero fara’
parte del <ADDRESS> del documento HTML.
Programmi tipo Mosaic evidenzieranno questo testo.

1.5 MWM.guide/Secondo gadget IMAGE

IMAGE gadget

Con questa azione si intende _SOSTITUIRE_ il testo selezionato con una
immagine.

MWM vi chiedera’ subito di scegliere il file grafico tramite un requester.
In seguito, si dovra’ scegliere il tipo di allineamento dell’ immagine che
potra’ essere uno dei seguendi:

- BOTTOM
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- MIDDLE
- TOP

Tali allineamenti devono informare Mosaic sul modo di allineare il testo
prima e/o dopo l’ immagine.

Fatto cio’, vi verra’ chiesto che tipo di immagine dovra’ diventare:

- E’ un link ad una etichetta gia’ creata all’ interno
del documento corrente.

- E’ un link ad un altro documento. (vedi voce alla parte TESTO)

Questa opzione rendera’ capace l’ immagine di chiamare altri
testi diventando una specie di gadget, come per l’ azione TESTO.

- E’ un link ad un sito. (vedi stessa voce alla parte TESTO)

- E’ una "mappa".

L’ immagine desiderata avra’ la funzione di diventare essa
stessa una specie di interfaccia grafica.
L’ utente potra’ selezionare con il mouse qualunque posizione
all’ interno di questa immagine e programmi tipo Mosaic
penseranno al resto.

- E’ una semplice immagine.

In questo caso l’immagine che si desidera sostituire al testo
non avra’ particolari funzioni se non quella di farsi vedere.

1.6 MWM.guide/Terzo gadget LIST

LIST gadget

Questa azione vi permette di trasformare il testo selezionato in una lista.

Le liste sono essenzialmente di tre tipi:

- Semplice (unnumbered), del tipo:

* fa caldo

* fa freddo

* piove

- Numerata (numbered), del tipo:

1- Non bere se devi guidare
2- Non guidare se hai bevuto
3- Il cappuccino e’ piu’ buono della birra
4- Il latte e’ finito, datemi una birra!

- Definita (definition), del tipo:

Colori
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rosso
verde
blu

Planetario

Mercurio
Marte
Terra
Giove
...

Dopo aver operato la scelta del tipo di lista, MWM vi chiedera’ se
aggiungere altre informazioni per ogni elemento della lista.

Se la scelta e’ negativa, allora il testo diventera’ una semplice lista di
parole e’ l’ impaginazione sara’ quasi certamente diversa da quella
originale del normale file di testo a causa della formattazione del testo e
del tipo di visualizzazione delle liste da parte dei programmi tipo il
Mosaic.

Se la scelta e’ positiva, MWM vi mostrera’ linea per linea il testo
selezionato chiedendo cosa dovra’ diventare:

- E’ un link ad una etichetta gia’ definita all’ interno
del documento corrente.

- E’ un link ad un altro documento.(vedi stessa voce alla parte TESTO)

- E’ un link ad un sito. (vedi stessa voce alla parte TESTO)

- E’ un semplice testo.

Con l’ azione "Preview" si potra’ vedere in qualunque momento il risultato
finale.

1.7 MWM.guide/Quarto gadget FORM

FORM gadget

Questa azione e’ composta da due passi:

nel primo si dovra’ definire la parte di testo che fara’ parte del form.
MWM chiedera’ il tipo. Le risposte possibili sono:

- GET
- POST
- Cancel

Deciso il tipo, MWM vorra’ sapere l’ azione (Action) che e’ una specifica
URL. L’ azione sara’ del tipo: "http://x/y/sample".

Dopo questo primo passo noterete che il testo cambia colore ma e’ ancora
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possibile (a differenza di tutti gli altri tipi di oggetti) selezionare una
o piu’ linee all’ interno del blocco del form.

Nel secondo passo sara’ possibile definire i vari componenti del form.
La stessa azione ora avra’ le seguenti possibili risposte:

- e’ un semplice testo

Il testo selezionato sara’ interpretato come un semplice testo,
utile per inserire descrizioni agli oggetti piu’ importanti.

- e’ un INPUT

questa scelta fara’ aprire un requester per definire il tipo di
INPUT:

1. Text 7. file
2. Password 8. Hidden
3. Checkbox 9. Submit
4. Radio 10. Image
5. Range 11. Reset
6. Scribble

Scegliendo il numero 4 (RADIO), MWM controllera’ se le linee
selezionate sono piu’ di una, nel qual caso vi chiedera’ se dovra’
definirle nello stesso RADIO group o no.

Rispondendo affermativamente, il gruppo di INPUT del tipo RADIO che
si stanno creando avranno lo stesso campo e quindi, una volta creato
il file HTML, Mosaic (o chi per lui) costruira’ i gadget di tipo
RADIO accertandosi che uno e solo uno possa essere selezionato dallo
user.

- e’ una lista di INPUT:

Non funzionante se si sta lavorando con la finestra per la
singola linea.

Tutti gli INPUT da definire saranno inclusi in una lista.

Ogni elemento del form (esclusi quelli inseriti in una lista) sara’ salvato
nel file HTML prefissato con la stringa <P> che serve a separare il testo
riga per riga.

Per inserire due o piu’ elementi del form nella stessa linea e’ possibile
fare un doppio click su una linea ed editarla con la finestra per la
singola linea.

1.8 MWM.guide/Quinto gadget MORE

MORE gadget

Questa azione cambia se si lavora con la finestra principale o con la
finestra per la singola linea.
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Se si sta lavorando con la finestra principale:

Se parte del testo e’ stato selezionato e se a tale testo non e’
stata applicata nessuna particolare azione, MWM automaticamente
ridurra’ a una le righe selezionate e chiedera’ cosa si desidera
fare con tale linea.

Le risposte possibili sono:

- Inserire in quel punto un’ etichetta (<ID>) per futuri richiami;
- Inserire in quel punto un commento (<!-- -->);
- Definire il titolo del documento (<TITLE>).
- Definire l’ immagine del background (<BODY BACKGROUND>).
- Inserire una linea vuota.
- Inserire una linea grafica orizzontale (<HR>).

Lo stesso vale per le righe inizializzate che pero’ non verranno
ridotte a una, l’ azione cadra’ su tutto l’ oggetto e si avranno
anche le seguenti possibilita’ in piu (escluso il testo definito
come HEAD):

- E’ una citazione. (CITE)
In questo caso la porzione di testo verra’ evidenziata in corsivo.

- E’ un’ enfasi. (EM)
simile alla citazione, sta’ al browser interpretarlo.

- E’ una forte enfasi. (STRONG)
La porzione di testo sara’ evidenziata con piu’ forza.

- E’ un codice. (CODE)
Ottimo per specificare a Mosaic che il testo dell’ oggetto
selezionato e’ una stringa da non formattare.
Ad esempio: x = x + 1.

- E’ il nome di un autore. (AU)
- E’ una persona generica. (PERSON)
- E’ una sequenza di caratteri. (SAMP)
- E’ un testo inserito manualmente. (KBD)
- E’ un nome di variabile. (VAR)
- E’ una definizione . (DFN)
- E’ una piccola citazione. (Q)
- E’ un acronimo. (ACRONYM)
- E’ una abbreviazione. (ABBREV)
- E’ un testo inserito. (INS)
- E’ un testo cancellato. (DEL)
- E’ un testo in neretto. (B)
- E’ un testo in corsivo. (I)
- E’ un testo in modo typewriter. (TT)
- E’ un testo sottolineato. (U)
- E’ un testo con una linea. (S)
- E’ un testo scritto in grande. (BIG)
- E’ un testo scritto in piccolo. (SMALL)
- Ancora lo devo capire (;-)). (SUB)
- Ancora lo devo capire (;-)) (SUP)

Se l’ oggetto selezionato e’ un link ad un sito, un requester vi
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dara’ la seguente proposta:

- Link to a document into this site

Questa azione consente di editare _MANUALMENTE_ il nome del
documento che dovra’ essere linkato una volta entrati nel sito.

Se le righe inizializzate e selezionate rappresentano l’ HEAD del
file, allora MWM aprira’ un differente requester con le seguenti
proposte:

- Attaccare un BANNER.
Con questa azione, creando il file HTML, MWM inserisce all’
interno della sezione HEAD una linea simile alla seguente:

<LINK REL=Banner HREF=mypath:mybanner.HTML>

che dovra’ rappresentare un logo, una scritta fissa o qualcosa del
genere.

Nel secondo caso, se si sta lavorando con la finestra per la singlola linea
e solo se c’e’ un oggetto del tipo TEXT creato e selezionato, MWM dara’ le
seguenti possibilita’ di scelta:

- E’ una citazione. (CITE)
- E’ un’ enfasi. (EM)
- E’ una forte enfasi. (STRONG)
- E’ un codice. (CODE)
- E’ il nome di un autore. (AU)
- E’ una persona generica. (PERSON)
- E’ una sequenza di caratteri. (SAMP)
- E’ un testo inserito manualmente. (KBD)
- E’ un nome di variabile. (VAR)
- E’ una definizione . (DFN)
- E’ una piccola citazione. (Q)
- E’ un acronimo. (ACRONYM)
- E’ una abbreviazione. (ABBREV)
- E’ un testo inserito. (INS)
- E’ un testo cancellato. (DEL)
- E’ un testo in neretto. (B)
- E’ un testo in corsivo. (I)
- E’ un testo in modo typewriter. (TT)
- E’ un testo sottolineato. (U)
- E’ un testo con una linea. (S)
- E’ un testo scritto in grande. (BIG)
- E’ un testo scritto in piccolo. (SMALL)
- Ancora lo devo capire (;-)). (SUB)
- Ancora lo devo capire (;-)) (SUP)

Se l’ oggetto selezionato e’ un link ad un sito, un requester vi
dara’ la seguente proposta:

- Link to a document into this site

Questa azione consente di editare _MANUALMENTE_ il nome del
documento che dovra’ essere linkato una volta entrati nel sito.
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1.9 MWM.guide/Sesto gadget HEAD

HEAD gadget

Con questa azione si intende specificare che la parte di testo selezionata
e’ l’ HEAD (la testa) del file HTML.

Nell’ HEAD e’ contenuto essenzialmente il titolo del file ed alcune altre
informazioni, nonche’ il testo selezionato.

Con l’ azione MORE e’ possibile inserire un banner.

1.10 MWM.guide/Settimo gadget SIZE

SIZE gadget

Il formato HTML permette una visualizzazione del testo in 6 differenti
grandezze tecnicamente rappresentate da:

- <H1> Font larghissimo, in neretto.
- <H2> Font largo, in neretto.
- <H3> Font largo, in corsivo.
- <H4> Font normale, in neretto.
- <H5> Font normale, in corsivo.
- <H6> Font piccolo.

C’e’ da dire che queste definizioni sono solo un’ indicazione, dipende da
come il browser e il suo sistema e’ settato, percui il testo puo’ apparire
diverso in ciascun sistema.

Per default, MWM imposta a 5 (H5) tale valore che puo’ essere modificato
selezionando il gadget "PREFS" alla voce "HTML defaults".

Con questa azione si intende quindi modificare le dimensioni del testo
linea per linea ed un requester vi aiutera’ nel lavoro.

Scelto il valore, vi verra’ chiesto l’ allineamento:

- LEFT (default)
- CENTER
- LEFT
- JUSTIFY

1.11 MWM.guide/Ottavo gadget VIEW

VIEW gadget

Questa azione vi permette di chiamare un programma tipo Mosaic per vedere
in qualunque momento il lavoro finale.
Il programma da chiamare e’ definito usando il gadget
"PREFS" alla voce "Browser"
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1.12 MWM.guide/Nono gadget PREFS

PREFS gadget

Questa azione mostrera’ la seguente lista di possibilita’:

- Texts path
Per definire un path comune a tutti i testi.

- Images path
Per definire un path comune a tutte le immagini.

- Work dir
Per definire la directory di lavoro (ex: RAM:T).

- Browser
Per scegliere il programma che dovra’ effettuare il preview.

- Sites list
Per scegliere il file contenente la lista dei siti.

- Screen prefs
Per cambiare il modo grafico dello schermo di MWM.
Se si sceglie il modo WORKBENCH, MWM aprira’ tutte le sue
finestre sullo schermo del Workbench.
Se si sceglie il modo CUSTOM, MWM vi chiedera’ con un
requester il tipo di risoluzione.
Io preferisco utilizzare il modo custom.

- Select new font
Cambia il font della finestra principale.

- Edit Log Window
Permette di personalizzare la finestra di aiuto.

- HTML defaults
Per personalizzare alcuni valori standard del formato HTML
generato da MWM.

In questa versione, questa azione vi dara’ il seguente
requester:

- Headings size;

Quando viene caricato un normale file di testo ASCII, MWM
assegna ad ogni linea un valore pari a zero (default)
percui, se c’e’ bisogno di cambiare il valore di default
per gli headings, MWM salvera’ il valore selezionato al
posto di zero.

Per cambiare questo valore standard e’ necessario
scegliere uno fra

H1 H2 H3 H4 H5 H6

nella listview.
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1.13 MWM.guide/La finestra per la singola linea

LA FINESTRA PER LA SINGOLA LINEA.

Selezionando con un doppio click una qualsiasi linea del testo nella finestra
principale, si aprira’ la finestra per la singola linea che permettera’
all’ utente di MWM di editare piu’ in dettaglio il testo.

1.14 MWM.guide/La finestra di aiuto

LA FINESTRA DI AIUTO.

Selezionando un oggetto nella finestra principale si notano dei dati che
vengono visualizzati in un’ altra finestra: la finestra di aiuto.

Questa finestra vi dara’ tutte le informazioni contenute negli oggetti:
il numero, il tipo, il path di immagini e testi, le label a cui punta
ed altro ancora.

1.15 MWM.guide/La finestra ” What is? ”

LA FINESTRA "What Is ?".

Questa finestra e’ un supplemento alla finestra di aiuto e si trova alla ←↩
immediata
sinistra della finestra principale.

La funzione di questa finestra e’ essenzialmente quella di dare un immediato ←↩
commento
a tutti gli oggetti creati collaborando con la differenziazione dei colori del
testo per ognuno di essi.

Esempio:

*-----------**--------------------------------------------*
| What is ? || MWM Edit Window |
------------- --------------------------------------------
| ........ || Testo non inizializzato |
| Text Hn X || Testo inizializzato |
| Head || Testo del blocco <HEAD> |
| Form ABC_1|| Testo del blocco <FORM> |
| Preformat || Testo preformattato <PRE> |
| Address || Testo del blocco <ADDRESS> |
| Paragraph || Testo di un paragrafo <P> |
| List XL || Testo del blocco di una lista <LIST> |
| Image || Testo che sara’ sostituito da un’ immagine |
| To site || Hyperlink ad un sito |
| Multi obj || Testo che include uno o piu’ oggetti |
| Label || C’e’ un’ etichetta <ID> |
| Comment || C’e’ un commento <!-- ... --> |
| Lab & Com || C’e’ una label e un commento |
|___________||____________________________________________|
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Descrizione:

Hn = Heading <H1> to <H6>, <HD> per il valore di default.

X = Allineamento: L = LEFT C = CENTER R = RIGHT J = JUSTIFY

XL = Tipo di lista: UL = Unnumbered OL = Numbered DL = Definition

ABC_1 = Method per il form: Get o Post.

1.16 MWM.guide/Il menu

IL MENU

Nella finestra principale e’ possibile usare un menu con le seguenti voci:

Project Edit Special Action

Load Text

Cut
Go to label

Text

Save HTML

Copy
Mark location 1

Image

Load saved work

Paste
Mark location 2

List

Save work

Search new
Mark location 3

Form

Delete all

Search again
Jump to mark 1

More

Help keys

Adjust sel lines
Jump to mark 2

Head
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About
Jump to mark 3

Size

Quit

Preview

Prefs

1.17 MWM.guide/Project->Load text

Delete all

Cancella tutto il lavoro o solo tutti gli oggetti.
(Usare con cautela!)

1.18 MWM.guide/Project->Load text

Load text

Permette di caricare un normale file di testo ASCII.

Se un testo e’ gia’ stato caricato, MWM vi chiedera’ se cancellare il
precedente o accodare il nuovo al vecchio.

Nel primo caso tutti i dati verranno persi.

Nel secondo caso verra’ chiesto il tipo di inserzione:

- All’ inizio;
- Alla fine;
- Dalla prima linea selezionata.

1.19 MWM.guide/Project->keys

Tasti speciali

Se il testo e’ piu’ lungo o piu’ largo della capacita’ della finestra, lo si
puo’ scrollare sia con i gadget della finestra, sia con i tasti frecce.

I tasti frecce, da soli, scrollano di una linea o di una colonna. Se
sciftati, scrollano una pagina su / giu’ / destra / sinistra. Premendo il
tasto alt con i tasti frecce il testo si posizionera’ a inizio / fine oppure
tutto a sinistra / destra. Con il tasto control, invece, le frecce
serviranno per dimensionare la finestra principale.

Il tasto help apre o chiude la finestra di Log.
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Il tasto del apre o chiude la finestra "What is?".

Il tasto enter permette di editare la prima linea selezionata.

Il tasto return inserisce una linea vuota nel testo.

1.20 MWM.guide/Project->Save HTML

Save HTML

Permette di salvare il lavoro creando il desiderato file HTML.

MWM, come prima cosa, vi chiedera’ come comportarsi nel caso in cui ad
alcune porzioni di testo non sia stata applicata nessuna azione.

Se viene scelto di ignorare tale testo, il file salvato conterra’ SOLO
gli oggetti creati, le etichette ed i commenti.

Con l’ altra possibilita’ tutto il testo non inizializzato sara’ ←↩
salvato
nel file HTML come semplice testo e ogni riga sara’ terminata dalla
sequenza di caratteri <BR> per permettere la separazione delle ←↩

linee
a programmi tipo Mosaic.

Dopo questa prima richiesta, MWM verifichera’ l’ esistenza del titolo.
Se non lo si e’ definito, un altro requester vi aiutera’.

1.21 MWM.guide/Project->Load saved work

Load saved work

Carica un lavoro precedentemente salvato.

1.22 MWM.guide/Project->Save work

Save work

Salva l’ intero lavoro in un file in modo da poterlo richiamare e ←↩
continuare

a lavorare dal punto in cui lo si era lasciato.

1.23 MWM.guide/Project->About

About

Informazioni riguardanti l’ ideatore ed il creatore di MWM.
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1.24 MWM.guide/Project->Quit

Quit

Fine del lavoro.
MWM salvera’ le preferences e la posizione/dimensione della
finestra principale nel file "MWM.prefs" in ENV: ed in ENVARC:.

1.25 MWM.guide/Edit->Cut

Cut

Questa azione permette di eliminare completamente le linee selezionate
oppure solamente le informazioni create per esse.
Se le si eliminano completamente, allora il testo cancellato verra’
copiato in clipboard.

1.26 MWM.guide/Edit->Copy

Copy

Questa azione copia le linee selezionate in clipboard.

1.27 MWM.guide/Edit->Paste

Paste

per inserire il testo contenuto nella clipboard a partire dalla
prima linea selezionata.

Se state usando (per esempio) KCON: per la finestra di log,
potete scrivere cio’ che volete in questa finestra, selezionare
tutto il testo con il mouse e premere "Amiga+C" per copiare il
tutto in clipboard.
RICORDATE: premete return dopo l’ ultima riga altrimenti la

console rimarra’ occupata e MWM non potra’ mandare
messaggi.

Dopo, selezionate la finestra principale di MWM e premete
"Amiga+V".

Questo funzionera’ anche con le commodities ConClip e ConPaste.

1.28 MWM.guide/Edit->Search new

Search new

Cerca una nuova stringa nel testo.
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1.29 MWM.guide/Edit->Search again

Search again

Cerca la stessa stringa nel testo.

1.30 MWM.guide/Edit->Adjust selected lines

Edit selected lines

Questa azione permette di editare tutte le linee selezionate.
Se la linea selezionata non e’ un multi object, non verranno modificati
in alcun modo gli oggetti creati precedentemente.
Altrimenti, se c’e’ realmente il bisogno di modificarla, tutti gli
oggetti in essa contenuti dovranno essere cancellati.

1.31 MWM.guide/Preferences->Texts path

Texts path

Per definire un path comune a tutti i testi.

1.32 MWM.guide/Preferences->Images path

Images path

Per definire un path comune a tutte le immagini.

1.33 MWM.guide/Preferences->Work path

Work dir

Per definire la directory di lavoro (ex: RAM:T).

1.34 MWM.guide/Preferences->Browser

Browser

Per scegliere il programma che dovra’ effettuare il preview.
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1.35 MWM.guide/Preferences->Sites list

Sites list

Per scegliere il file contenente la lista dei siti.

1.36 MWM.guide/Preferences->Screen prefs

Screen prefs

Per cambiare il modo grafico dello schermo di MWM.
Se si sceglie il modo WORKBENCH, MWM aprira’ tutte le sue finestre
sullo schermo del Workbench.
Se si sceglie il modo CUSTOM, MWM vi chiedera’ con un requester
il tipo di risoluzione.
Io preferisco utilizzare il modo custom.

1.37 MWM.guide/Preferences->Select new font

Select new font

Cambia il font della finestra principale.

1.38 MWM.guide/Preferences->Edit log window

Edit Log Window

Permette di personalizzare la finestra di aiuto.

1.39 MWM.guide/Preferences->HTML defaults

HTML defaults

Per personalizzare alcuni valori standard del formato HTML generato
da MWM.

In questa versione, questa azione vi dara’ il seguente requester:

- Headings size;

Il valore standard di MWM per gli heading e’ H5 e tutto
il testo non inizializzato sara’ salvato come H5.

Per cambiare questo valore standard e’ necessario
scegliere uno fra

H1 H2 H3 H4 H5 H6
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nella listview.

1.40 MWM.guide/Cosa puo’ fare MWM ?

COSA PUO’ FARE MWM ?

MWM e’ in grado di gestire le seguenti cose:

- HEAD LINK REL=Banner
- TITLE
- BODY
- ADDRESS
- A HREF="...#..."
- A ID="..."
- IMG ISMAP ALIGN=TOP|MIDDLE|BOTTOM SRC="..." ALT="..."
- UL LI
- OL LI
- DL DT DD
- <!-- comment -->
- BR
- HR
- P ALIGN=LEFT|RIGHT|JUSTIFY
- CITE
- CODE
- EM
- STRONG
- AUTHOR
- PERSON
- SAMP
- KBD
- VAR
- DFN
- Q
- ACRONYM
- ABBREV
- INS
- DEL
- B
- I
- TT
- U
- S
- BIG
- SMALL
- SUB
- SUP
- &lt; &gt; &amp; &quot;

&Aacute; &Agrave; &Acirc; &Atilde; &Aring; &Auml; &AElig; &Ccedil;
&Eacute; &Egrave; &Ecirc; &Euml; &Iacute; &Igrave; &Icirc; &Iuml;
&ETH; &Ntilde; &Oacute; &Ograve; &Ocirc; &Otilde; &Ouml; &Oslash;
&Uacute; &Ugrave; &Ucirc; &Uuml; &Yacute; &THORN;
&szlig; &aacute; &agrave; &acirc; &atilde; &atilde; &auml; &aelig;
&ccedil; &eacute; &egrave; &ecirc; &euml; &iacute; &igrave; &icirc;
&iuml; &eth; &ntilde; &oacute; &ograve; &ocirc; &otilde; &ouml;
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&oslash; &uacute; &ugrave; &ucirc; &uuml; &yacute; &yuml; &thorn;
- URL per i link
- FORM METHOD=GET|POST
- INPUT TYPE=TEXT|PASSWORD|CHECKBOX|RADIO|RANGE|SCRIBBLE|

FILE|HIDDEN|SUBMIT|IMAGE|RESET
NAME,VALUE,SIZE,MAXLENGTH,CHECKED,MIN,MAX,SRC,ACCEPT

- Lista di INPUTs
- Headings: <H1|2|3|4|5|6 ALIGN=LEFT|CENTER|RIGHT|JUSTIFY>

1.41 MWM.guide/Informazioni generali

INFORMAZIONI GENERALI

MWM richiede un sistema operativo dal 3.0 in poi. (..Tanks Amiga!..)

Questo programma e’ stato studiato seguendo il piu’ possibile le
specifiche del formato HTML incluse nell’ archivio HTML30GU.LHA reperibile
in qualunque BBS.

Questa versione e’ assolutamente Copyright!

Se ti piace questo programma e hai bisogno di tutte le funzioni
disabilitate, puoi spedirmi 25 dollari americani al seguente indirizzo:

Massimo Baglione
Via Della Chiesa 1
67019 Civitatomassa
Scoppito L’ AQUILA (Italy)

specificando dove posso mandare il KEY file.

Per qualunque consiglio, critica o idea riguardo MWM, contattate subito:

Massimo Baglione Maurizio Fabiani
(MAUI for Amiga BBS)

39:102/1.5 AmigaNet 39:102/1
39:102/2.5 39:102/2

2:335/602.5 FidoNet 2:335/602
2:335/607.5 2:335/607

InterNet

(Maurizio Fabiani) maui@mbox.vol.it

1.42 MWM.guide/Ringraziamenti

RINGRAZIAMENTI

Devo ringraziare tutti i miei betatester per il loro ottimo bug report
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riguardo MWM. In particolare, voglio citare:

Troy Bouchard (Snowy Hill) e Mel Greer per le loro incredibili menti!

Alessandro Di Michele ....per i suoi consigli riguardo la GUI.

Kirk Strauser ............per il suo vario e dettagliato bug report.

Girish V Nath ............per il suo professionalissimo report.
(Sto ancora aspettando la birra...;-)

Paul Stevens .............(un altro birra-dipendente..(;-))

Arnold Schwarzenegger ... (Hey Arnie, sei veramente tu oppure e’ solo
l’effetto della birra ? (;-))

e, per tutto cio’ che riguarda il resto dello sviluppo di MWM:

Ross Delaforce per aver messo a disposizione il suo sito.

Jeff Lavin per il suo grande aiuto riguardo il doc inglese!

David Putzier per il suo fantastico MWMlogo.iff, guardatelo e basta!

Pierluigi Sferrella per il manuale italiano in formato amigaguide.

Mike Handley per il manuale inglese in formato amigaguide.

Poi, un grande bacio (!) lo mando al mio Boss (Maurizio Fabiani) per la
sua infinita pazienza!

L’ ultimo ringraziamento e’ riservato ad Amiga:
(tutti insieme) ...GRAZIE AMIGA!

-----+-----

-=> * \X/ Amiga! \X/ MAUI BBS! \X/ Love and Beer! * <=-

_The revenge of the italian products_

...enjoy this program!!!

1.43 MWM.guide/Storia di MWM

Storia di MWM:

-MWM v. 1.08 Jul 04 1996

- First amigaguide version of the english manual.
- Fixed a dangerous bug deleting multiobjects inside FORMs.
- Now you can specify a file to be linked into a site also for images and

multiobjects. (MORE gadget)
- Removed a little bug displaying actions gadgets for 4 colors screens.

-MWM v. 1.07 Jun 12 1996
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- Assigned ENTER key for "Edit first selected line".
- Assigned RETURN key for "Insert an empty line".
- Scrolling text if dragging vertical gadget (slow, but it works).
- Added "Prefs" gadget on action gadgets.
- Removed "Preferences" from menu.
- Optimized listviews:

UP/DOWN keys -> move desired option;
RETURN key -> make the choice;
ESC key -> exit from listview;

- Kirk Strauser suggestions:
Removed little bug writing multiobjects;
Remember drawers for load/save work and save HTML.
Now it is possible a link to a document into a site (see MORE gadget).

- Little bug freeng memory removed. (tanks to Sushi)
- First amigaguide version of the italian manual.

-MWM v. 1.06 May 29 1996

- New "About". Tanks to David Putzier for his wonderful logo!!
- Removed small bug defining lists.
- Adjustements for MWM’s texts.
- MWM adjusts position for tools gadgets just to fill upper space.
- Now MWM saves config during quit.
- Snapshot for main window and "What is?" window.
- I hope removed a bug saving prefs for screens.
- Now it’s possible to open/close "What is?" window (Del key).
- Improved "Special" menu:

"Go to label";
"Mark location 1";
"Mark location 2";
"Mark location 3";
"Jump to mark 1";
"Jump to mark 2";
"Jump to mark 3";

-MWM v. 1.05 May 15 1996

- Small bug deleting multiobjects for FORMs removed.
- Adjusted headings size writing lists.
- Improved "Delete all" in "project" menu.
- Adjustements in "Single line" window:

MWM shows infos about a single object when selected;
Now it is possible to delete a single object if previously created;
Better separation between multiobjects;

- Bug fixed version of the english doc! (;-)) Tanks to Jeff Lavin!

-MWM v. 1.04 May 03 1996

- Optimized some functions.
- Small bug removed.
- Adjusting width for lowres screens.
- Adjusted docs to 78 columns.
- Arranged depth between "Main Window" and "What is?" window.
- Improved autosizing for "Single Line" window.
- Now MWM shows all following ASCII value:

9 (TAB) as four spaces (ASCII 32);
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10 (LF) and 13 (CR) as end of lines;
32 to 126;
127 to 160 skipped because unused;
161 to 255;

- Added filter for:
&Aacute; &Agrave; &Acirc; &Atilde; &Aring; &Auml; &AElig; &Ccedil;
&Eacute; &Egrave; &Ecirc; &Euml; &Iacute; &Igrave; &Icirc; &Iuml;
&ETH; &Ntilde; &Oacute; &Ograve; &Ocirc; &Otilde; &Ouml; &Oslash;
&Uacute; &Ugrave; &Ucirc; &Uuml; &Yacute; &THORN;
&szlig; &aacute; &agrave; &acirc; &atilde; &atilde; &auml; &aelig;
&ccedil; &eacute; &egrave; &ecirc; &euml; &iacute; &igrave; &icirc;
&iuml; &eth; &ntilde; &oacute; &ograve; &ocirc; &otilde; &ouml;
&oslash; &uacute; &ugrave; &ucirc; &uuml; &yacute; &yuml; &thorn;

-MWM v. 1.03 Apr 12 1996

- Fixed a liiiittle bug for "Amiga + Q" (quit).
- Fixed a bug changing "heading size" default.

-MWM v. 1.02 (never released)

- New versions of the docs.
- Removed a dangerous bug deleting multiobjects.
- Now MWM uses Cut, Copy and Past via Clipboard.

-MWM v. 1.01 Apr 04 1996

- Now MWM works only on OS 3.0 or higher.
- Removed a bug in opening requesters.

I have never tested MWM without MCP! (;-))
I’m really sorry for this!

-MWM v. 1.00 Apr 01 1996

- ...FINALLY!!!
First release for all Amiga’s Web makers!!
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