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Section 1 - Installing Solaris and HP OpenView

1.0 Overview
GDC TEAM software requires the Solaris 2.7 or Solaris 2.8 operating system, and th
OpenView 6.1 presentation manager software and their patches. This section provid
installation instructions and release notes for these components. Complete instructio
installing TEAM Core are provided in later sections. For questions on any of the 
information provided here, contact your GDC field representative.

1.1 Software Requirements
The following table provides detailed information for all software modules relevant to
Solaris/HPOV installation. Throughout this manual, short forms of the software prod
names will be used. Although the minimum requirements are for Solaris 2.7, Solaris 2.
HP OpenView 6.1, this version of TEAM Core can also function with Solaris 2.51 an
HP OV 4.1.1 or HPOV 5.01. 

Note: Important: It is highly recommended that you download and install the latest SOLAR
PATCH CLUSTER from the following website: http://sunsolve.sun.com . 
This will ensure that you have updated the Operating System along with any current
to reported problems.

Note: Important: It is highly recommended that you download and install the latest HP 
OPENVIEW CUMULATIVE CONSOLIDATED PATCH from the following web site: 
http://ovweb.external.hp.com/cpe/patches . This will ensure that you 
have updated HP Open View along with any current fixes to reported problems.

Table 1:  Software Reference for Solaris/HPOV 

Item Part Number Version / Release

Solaris Software Product S-058U019-C01 Ver 2.7 / Nov 1999

S-058U020-001 Ver 2.8 / Feb 2000 (Ver A)

HPOV for Solaris Software 
Product

Enterprise (Full) 058U157-C01 Ver 6.1

250-node (Entry) 058U157-C02 Ver 6.1

Solaris/HPOV Patch 
Clusters

Ref: Sun / HPOV websites
e Notes for GDC Part No. 058U739-C01 Page 5
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1.2 Hardware Requirements for HP OpenView - Solaris
• SUN ULTRA 5 or greater with a minimum of 96 megabytes of RAM

• 2 GB of hard disk space with 350 MB of free disk space and 192 MB of swap sp

• Minimum disk space requirements:

/opt 150 megabytes

• The graphics card should support a resolution of 1152x900.

• CD ROM drive

2.0 Solaris Installation
The following installation instructions apply to networked stand-alone system type 
configurations only.

1. Login as root .

2. Insert Solaris CD into the CDROM drive.

3. Shut down the workstation by typing the following commands:

sync

halt

4. At the "OK" prompt type:

boot cdrom

5. In the Solaris Installation Program dialog box, click Continue . 

6. In the Identify this System dialog box, click Continue .

7. Enter the following information as prompted:

Hostname aurora

Networked Yes

IP Address 200.200.200.5

8. Click Continue  to confirm entries.

9. In the Name Service dialog box, select None, then click Continue .

10. In the Subnets dialog box, select Yes or No, depending on your network 
configuration.

11. Enter the netmask in the Netmask dialog box, then click Continue .

12. Specify the time zone in the Time Zone dialog box, the click Set . 
Otherwise, use Geographic Region dialog box to specify the region and time zo
then click Continue . 

13. Set Date and Time in the Date and Time dialog box, then click Continue . 

14. Click Continue  to confirm the entries.

15. In the Solaris Interactive Installation window, select initial  or upgrade , then 
click Continue . 

16. In the Allocate Client Services? window, click Continue . 

17. In the Language dialog box, select the desired language, then click Continue . 
Release Notes for GDC Part No. 058U739-C01
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18. In the Software dialog box, select End User System Support , then click 
Continue . 

19. In the Disk dialog box, select Disks , then click Continue . 

20. In the Preserve Data dialog box, click Continue  to overwrite.

21. In the Automatically Layout File Systems? dialog box, select Auto Layout  

22. Select /  and swap (ONLY) and then click Continue .

23. To change layout, press Customize  in the File System and Disk Layout dialog bo

24. Depending on disk size, enter the size for / in the Customize Disks dialog box. C
the free space and then enter the remaining space for swap. 
For example, for 2GB disks, delete every entry in the Customize Disks dialog bo
except for:

/ set to 1540 MB 
swapset to remaining MB

25. Select OK, then click Continue . 

26. In the Mount Remote File System? dialog box, click Continue .

27. In the Profile dialog box, click Begin Installation  and ignore warning.

28. Select Reboot  to set the system for an automatic reboot after installation.

29. When the installation is complete, a prompt appears, indicating the system is re

3.0 HP OpenView 6.1 Installation
The following instructions are for installing HP OpenView on a workstation that has not 
had OpenView installed previously. If your workstation already has a previous versio
HP OpenView, refer to HP OpenView Upgrade procedures later in this section.

1. At a shell prompt become super-user.

2. Insert the HPOV NNM CD into the CD ROM drive.

3. Edit the file /etc/system using your favorite editor and add the following lines:

forceload:sys/shmsys

forceload:sys/semsys

set semsys:seminfo_semaem=16384

set semsys:seminfo_semmap=66

set semsys:seminfo_semmni=70

set semsys:seminfo_semmns=200

set semsys:seminfo_semmnu=30

set semsys:seminfo_semume=10

set semsys:seminfo_semvmx=32767

set semsys:seminfo_semmsl=30

4. Save the file.

5. Reboot the workstation by typing reboot -- -r
e Notes for GDC Part No. 058U739-C01 Page 7
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6. Login as root .

7. At the prompt, type 

cd /cdrom/cdrom0

8. Type ./install

9. When prompted for language choice, type 1 for English 

10. Type 1 or 2 for the type of Network Node Manager Product you have.

11. Type y  to install man pages or n otherwise.

12. Type y  to continue installation.

13. Type cd /

14. Type eject

15. Remove the CD from the drive.

3.1 Upgrading from Previous Versions of HP OpenView
Do not remove previous versions of HP OpenView which are already installed on yo
workstation. Perform the following steps and then proceed to the HP OpenView 6.1 
Installation procedure described above. 

1. Log in as root  to the workstation on which you intend to install OpenView 6.1.

2. To make sure no one is running an HP OpenView product on the system in whic
intend to install OpenView 6.1, enter the command

ovstatus

3. If Openview is not running, the system will respond with ovstatus:ovspmd not 
running . Proceed to the HP OpenView 6.1 Installation procedure described ab

4. If OpenView is running, select Exit  from Map menu to stop OpenView. Execute th
ovstop  command to stop any OpenView processes that are running. Proceed 
HP OpenView 6.1 Installation procedure described above. 

4.0 Post-Installation Procedures

4.1 Solaris Patch Installation
The following procedure updates the Operating System along with any current fixes 
reported problems.

1. Download the latest SOLARIS PATCH CLUSTER along with any associated 
instructions from the following website: 

http://sunsolve.sun.com

2. Install the patch cluster according to the website instructions.

3. Reboot the system to complete the installation.
Release Notes for GDC Part No. 058U739-C01
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4.2 HPOV Patch Installation 
The following instructions are for a basic installation of the cumulative consolidated 
patches for HP OpenView 6.1. Refer to any detailed HP OpenView text files (*.text) 
each patch, which may be on the HP website. 

Note: IMPORTANT: It is highly recommended that the customer download and install the l
HP OPENVIEW CUMULATIVE CONSOLIDATED PATCH from the following HP 
OpenView web site: http://ovweb.external.hp.com/cpe/patches . 
Installing this Cumulative patch will ensure that you have updated HP Open View alo
with any current fixes to reported problems.

1. Back up your system before installing the patch.

2. Have all users exit ovw sessions.

3. To start installation login as root .

4. Source the universal environment: 

Borne shell:

.  /opt/OV/bin/ov.envvars.sh

Note: There must be a space between the initial period and the first slash.

Cshell:

source  /opt/OV/bin/ov.envvars.csh

$OV_BIN/ovstop

5. Access the drive where the patch software resides, then extract and install the p

6. When the cumulative consolidated patch installation is complete, restart the 
OpenView daemons as follows:

$OV_BIN/ovstart

7. If the OpenView License Manager does not start, preventing other HP OpenVie
applications from starting, make sure you are at super-user and then start HP 
OpenView and its license manager as follows: 

cd  $OV_LRF

/opt/OV/bin/ovaddobj  OVLicenseMgr.lrf

cd  /opt/OV/bin

./ovstop

./ovstart  -v
e Notes for GDC Part No. 058U739-C01 Page 9
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4.3 Upgrade Adjustments
When you upgrade from a previous version of HPOV to HPOV 6.1, the oid_to_sym  file 
is moved from $OV_CONF/C to $OV_CONF. Depending on what TEAM software is 
installed on your system, that move requires the user to make the following adjustm

For TEAM Core:

Copy the contents of $OV_CONF/C/oid_to_sym.SHELFBASE 
into oid_to_sym 

For TEAM 6000:

Copy the contents of $OV_CONF/C/oid_to_sym.SHELF6000BASE
into oid-to_sym

For TEAM 540:

Copy the contents of $OV_CONF/C/oid to sym.540 
into oid_to_sym

For TEAM 553:

Copy the contents of $OV_CONF/C/oid_to_sym.553 
into oid_to_sym

5.0 De-Installing HP OpenView 6.1
1. At a shell prompt become super-user.

2. Insert the HPOV NNM CD into the CDROM drive.

3. At the prompt type cd /cdrom/cdrom0

4. Type ./remove

5. Answer y  when asked to remove bundles.

6. Type cd  /

7. Type eject

8. Remove the CD from the drive.

6.0 HP OpenView Permanent License Installation
A Permanent Password Certificate is provided with the HP OpenView software, speci
the server on which the software is to be installed (License Server Target ID) and th
password that activates the license. This nodelock-type license activates the softwa
locally, rather than via communication with a license server. To activate the license on
workstation, perform the following steps:

1. To access the directory that contains the nodelock file, type

Type cd /var/netls

2. Make a backup of the nodelock file by entering the command:

cp nodelock nodelock.backup
0 Release Notes for GDC Part No. 058U739-C01
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3. Invoke the editor of your choice to append the password from the Permanent Pas
Certificate to the nodelock file. Do not press the Enter key until you have typed 
characters of the password (indicated by <return> on the certificate).

Note: Although its length causes it to wrap around when printed on the certificate or displa
on-screen, the password must be entered as a single line. 

4. You can check to make sure that you haven’t accidentally entered any non-displ
characters into the nodelock file by entering the command:

cat -vet nodelock

5. The license takes effect when you save your changes to the file.

7.0 Known Issues
• HP OpenView pops up a warning message indicating a corrupt line in the trapd.log

To prevent this, edit the trapd.log file and remove the line.
e Notes for GDC Part No. 058U739-C01 Page 11
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Section 2 - TEAM Core for Solaris

1.0 Overview
These installation and release notes provide new information relevant to this version 
TEAM CORE software product operating on the Sun Solaris platform. They update t
information supplied by the TEAM Core Operation Manual. If you require additional 
details please refer to that manual. For questions on any of the information provided
please contact your GDC field representative.

1.1 Software Reference
The following table provides the detailed information for all software modules relevan
TEAM Core for Solaris installation. Throughout this manual, short forms of the softw
product names will be used. 

The TEAM Core software is comprised of the following packages on the TEAM Core 
After installation, these packages should be present on the workstation at the versio
shown or greater. To verify the version of a package currently installed, type the follo
command:

/usr/bin/pkginfo -l < Package Name >

Table 2:  Software Reference for Solaris

Item Part Number /Description Version

TEAM Core Software Product 058U739-C01 Ver 4.2.0

TEAM Core Operation Manual 058R720-V420 Latest Version/Issue

Solaris Software Product S-058U019-C01 Ver 2.7 / Nov 1999

S-058U020-001 Ver 2.8 / Feb 2000 (Ver A)

HPOV for Solaris Software 
Product

Enterprise (Full) 058U157-C01 Ver 6.1

250-node (Entry) 058U157-C02 Ver 6.1

Solaris/HPOV Patch Clusters Ref: Sun / HPOV websites

HPOV Network Node Manager 
Installation Guide

HP J1136-9000

SCM for SpectraComm and 
V.34 Products

Firmware Version 5.3.0 
or greater

MIB Ver 3.10F

SCM for UAS and 
V.34 products

Firmware Version 7.2.0 
or greater

MIB Ver 3.10F

Package Name  Description Version

GDCTeam GDC TEAM Utilities Ver 4.2.0

GDCShelf5 GDC Shelf 5000 Ver 4.2.0
e Notes for GDC Part No. 058U739-C01 Page 13
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1.2 Improvements Since Last Release
TEAM Core software has been tested to be Year 2000 Compliant in accordance to G
ENG-STD-003. TEAM Core 4.2.0 differs from the preceding release as follows:

• Supports the SC 5516 DS0-DP product.

Preceding 
Versions

Description of Change

TEAM Core 4.1.0 Supports the SC 521A/S product.
Supports remote SCM IP address configuration in SC/UAS systems.
Supports the SC 521A and the SC 521A/S as remotes to the SC 5520 
through the TEAM 5520 Version 4.0.0 or higher

TEAM Core 4.0.0 Supports the SC 7723-MR and GT 1033 Multi-Rate products.
Approved for operation on Solaris 2.7, Solaris 2.8, HP Openview 6.1 and 
HPUX 11.0 upgrades

TEAM Core 3.1.0 Supports the SC 800 T3 product.

TEAM Core 3.0.5 Supports long host ID names, up to 50 characters (previously limited to 16), 
minor fixes, product compatibility additions.

TEAM Core 3.0.4 Minor fixes, product compatibility additions.

TEAM Core 3.0.3 Minor fixes, product compatibility additions.

TEAM Core 3.0.2 Addition of the Group Configuration feature, minor fixes.
4 Release Notes for GDC Part No. 058U739-C01



TEAM Core Version 4.2.0 Publication No. 058R957-V420
Issue 1 - January 2002

Releas

abytes 

n, 
ith 

ease 
EAM 

r to 

efore 
 
aris 
with 

IS 

 fixes 
2.0 Hardware Requirements for HP OpenView - Solaris
• SUN ULTRA 5 or greater with a minimum of 96 megabytes of RAM

• 2 gigabytes of hard disk space with 350 megabytes free disk space and 192 meg
of swap space

• Minimum disk space requirements:

/opt 40 megabytes

• The graphics card should support a resolution of 1152x900.

• SCM (SpectraComm Manager) card

• CD ROM drive

Note: 96 megabytes of RAM is sufficient to support 1 or 2 users logged into the workstatio
running individual OpenView Windows sessions. Reduced performance can occur w
additional users accessing the workstation for remote login. To avoid problems, incr
RAM based on the expected number of simultaneous users and on the number of T
applications in use. Allow 25 megabytes of RAM for each additional user, and 3 
megabytes for each TEAM application. You should also adjust swap space to be 
approximately twice the size of the RAM. 

Note: For hardware requirements of HP OpenView Network Node Manager products, refe
the HP OpenView Network Node Manager Products Installation Guide.

3.0 Software Requirements
The following Solaris and HP OpenView software must be installed and operational b
installing this version of TEAM Core. Refer to Table 1 for detailed identification of all
software products discussed below. Although the minimum requirements are for Sol
2.7, Solaris 2.8 and HP OpenView 6.1, this version of TEAM Core can also function 
Solaris 2.51 and HP OV 4.1.1 or HPOV 5.01.

• Solaris 

• HP OpenView for Solaris (250-Node or Enterprise)

• Solaris and HPOV patches

Note: Important: It is highly recommended that you download and install the latest SOLAR
PATCH CLUSTER from the following website: http://sunsolve.sun.com . 
This will ensure that you have updated the Operating System along with any current
to reported problems.

Note: Important: It is highly recommended that you download and install the latest HP 
OPENVIEW CUMULATIVE CONSOLIDATED PATCH from the following web site: 
http://ovweb.external.hp.com/cpe/patches . This will ensure that you 
have updated HP Open View along with any current fixes to reported problems.
e Notes for GDC Part No. 058U739-C01 Page 15
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4.0 TEAM Core Installation in Solaris Environments
TEAM Core software can be installed in one of three Solaris environments: 

• Common Desktop Environment (referred to as CDE or DT)

• Sun OpenWindows

• Distributed Environment

Installation includes loading TEAM software and updating user environments. The 
procedures vary depending on the type of environment. Some environment updating
procedures will require the use of vi or your favorite editor to change environment script
All procedures for each environment are provided below. Additional information abo
distributed environments is provided in Section 4.

Note: After an installation of TEAM software, the user must enable Discover New IP 
Nodes  from the shelf map options menu for IP discovery to occur. This is described i
Post-Installation Procedure For All Solaris Environments on page 25. 

Note: Some TEAM applications running on Solaris 2.7 or Solaris 2.8 may display meaning
characters in the application window headings. This is due to a font conflict which ca
resolved by typing the following on the command line before running ovw:
xrdb -merge /opt/OV/bin/gdc_load_resources

4.1 CDE and Sun OpenWindows Installation
6. Make sure all users exit HP OpenView for Solaris.

7. Insert the TEAM Core Compact Disk into the CD ROM drive.

8. At the shell prompt, become super user by typing

su root

9. Check /  to make sure there is a /cdrom  directory already present. If not, create it.

10. Stop HP OpenView processes by typing 

/opt/OV/bin/ovstop 

11. Start the installation process by typing:

cd /cdrom/cdrom0/solaris

12. If a version of the TEAM Core is already resident on the workstation, or if you are
sure if it is resident, enter the following command before attempting to install the 
version:

./remove.sh

Ignore any error messages that may appear on the monitor and answer y for the 
questions.

13. Continue the installation process by entering the following command:

./install.sh

14. Answer Y to the questions. 
6 Release Notes for GDC Part No. 058U739-C01
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15. When installation is complete, start HP OpenView processes by typing:

/opt/OV/bin/ovstart 

16. Type cd /

17. Type eject  

18. Exit super user by typing exit . Remove the CD from the CD ROM drive.

19. Proceed to the appropriate paragraphs below to update each user account for y
environment. 

4.1.1 Updating Common Desktop Environments
1. Open the $HOME/.dtprofile  file with your editor and read the lengthy commen

that are included in it. The comments provide information on:

A. how to use the C (csh), Bourne (sh), and Korn (ksh) shells in the CDE

B. which terminal commands should not be used because they can prevent logi
When using the csh shell, the commands are generally present in .login  and 
.cshrc files. When using the sh or ksh shells, they are in .login  and .pro-
file  files.

2. After reviewing the comments, edit the $HOME/.dtprofile  file to remove the 
leading pound sign(s) in the line that contains

### DTSOURCEPROFILE=true

3. If you are using C (csh) Shell you must add the following lines to $HOME/.cshrc :

source   /opt/OV/bin/ov.envvars.csh

set path=($path   $OV_BIN)

4. If you are using Bourne(sh) shell or Korn(ksh) shell you must add the following l
to $HOME/.profile :

. /opt/OV/bin/ov.envvars.sh

PATH=$PATH:$OV_BIN; export PATH

5. Add the following line to $HOME/.Xdefaults :

#include “/opt/OV/bin/gdc_load_resources”

6. The Common Desktop Environment is now updated for all users. Complete the
installation by typing:

ovw &

7. For the changes to take effect, you must now logout and login.
e Notes for GDC Part No. 058U739-C01 Page 17



Publication No. 058R957-V420 TEAM Core Version 4.2.0
Issue 1 - January 2002

Page 1

ines 

 

s 
g 

 the 
ion in 

e as 
warded 
llation 
4.1.2 Updating Sun OpenWindows Environments
1. If you are using C (csh) Shell you must add the following lines to $HOME/.cshrc :

source   /opt/OV/bin/ov.envvars.csh

set path=($path   $OV_BIN)

2. If you are using Bourne(sh) shell or Korn(ksh) shell you must add the following l
to $HOME/.profile :

. /opt/OV/bin/ov.envvars.sh

PATH=$PATH:$OV_BIN; export PATH

3. The Sun OpenWindows environment is now updated for all users. Complete the
installation by typing:

ovw &

4. You must now logout and login in order for the changes to take effect.

4.2 Installing in a Solaris Distributed Environment
A distributed environment consists of three types of workstations. Not all workstation
require installation of all software, but the workstations must be set up in the followin
order: 

A. Collection Station

B. Management Station

C. Management Console

The procedures for TEAM Core and product software installation vary depending on
type of workstation. Perform the installation and set up procedures for each workstat
your distributed environment. 

4.2.1 Setting up Collection Stations
On workstations that serve as collection stations, you must install the TEAM softwar
described in the previous paragraphs, and then configure events so that traps are for
to the management station. Refer to the event data in the table below during this insta
process. 

Table 3: Event Forwarding Data

Enterprise Name (Enterprise ID) Event Name (Enterprise Identifier)

gdc_cmnAlarm(.1.3.6.1.4.1.498.1.4) dmscmnAlarmTrap(.1.3.6.1.4.1.498.1.4.0.1)

gdc_scm(.1.3.6.1.4.1.498.3.6) dmsSCMPowerSupplyTrap(.1.3.6.1.4.1.498.3.6.0.3)

gdc_scm(.1.3.6.1.4.1.498.3.6) dmsSCMAliveTrap(.1.3.6.1.4.1.498.3.6.0.4)

gdc_scm(.1.3.6.1.4.1.498.3.6) dmsSCMcoldStart(.1.3.6.1.6.3.1.1.5.1)

gdc_scm(.1.3.6.1.4.1.498.3.6) dmsSCMwarmStart(.1.3.6.1.6.3.1.1.5.2)

gdc_scm(.1.3.6.1.4.1.498.3.6) dmsSCMAuthentication(.1.3.6.1.6.3.1.1.5.5)
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Note: Refer to Section 4 for detailed information on TEAM Applications in HPOV NNM 
Scalable and Distributed Environments. For detailed information on Event Forwardin
refer to the HP OpenView Guide to Scalability and Distribution for Network Node 
Manager, page 138. 

1. Become a super user by typing su  and suppling the super user password.

2. Perform the procedures for a Basic Installation as described above.

3. Set up environment variables by typing:

/usr/bin/sh

. /opt/OV/bin/ov.envvars.sh

4. Create a directory named /cdrom  if one doesn’t already exist in / . 

5. Insert the TEAM Core CD into the CDROM drive. 

6. Register GDC Trap format by typing:

$OV_BIN/xnmevents -merge 
/cdrom/cdrom0/solaris/shelftrapd.conf

7. Start the Event system configurator GUI by typing:

$OV_BIN/xnmtrap

8. From the Enterprise Identification pane, select an Enterprise Name

for example: gdc_cmnAlarm

9. From the Event Identification pane, select an Event Name

for example: dmscmnAlarmTrap

10. From the Event Configuration window menu bar, select Edit->Modify Event . 
The Event Configurator/Modify Event dialog box appears.

11. Click on the Forward Event check box to expand the dialog box. The Forwarded E
Destinations pane displays.

12. Type the hostname or IP Address for destination. Destinations are the manage
stations to which events will be forwarded. 

13. Repeat steps 5 through 9 for each of the events listed in Table 3.

14. When all events are forwarded, click OK in the Event Configurator/Modify Event 
dialog box.

15. At the Event Configuration window, click File->Save  to save the changes.

16. To cause Openview processes to re-read the trapd.conf file, generate Event by t

$OV_BIN/xnmtrap -event
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4.2.2 Installing TEAM Applications on the Management Station
To install TEAM Core software and TEAM product software on the Management Sta
perform the following steps:

1. Make sure all users exit HP OpenView for Solaris.

2. To install TEAM Core software, insert the TEAM Core CD into the CD ROM driv

3. At the shell prompt, become super user by typing

su root

4. Check /  to make sure there is a /cdrom  directory already present. If not, create it.

5. Stop HP OpenView processes by typing 

/opt/OV/bin/ovstop 

6. Start the installation process by typing:

cd /cdrom/cdrom0/solaris

7. If a version of the TEAM Core is already resident on the workstation, or if you are
sure if it is resident, enter the following command before attempting to install the 
version:

./remove.sh

Ignore any error messages that may appear on the monitor and answer y for the 
questions.

8. Continue the installation process by entering the following command:

./install.sh

9. Answer Y to the questions. 

10. When installation is complete, start HP OpenView processes by typing:

/opt/OV/bin/ovstart 

11. Type cd /

12. Type eject  

13. Exit super user by typing exit . Remove the CD from the CD ROM drive.

14. You must now install all card products of interest, (TEAMSC521, TEAMSC553, e
on the Management Station. Use the product’s media and accompanying release
for installation and any subsequent firmware downloads.
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4.2.3 Setting Up the Management Station
1. At the shell prompt, become super user by typing

su root

2. Type the following commands:

/opt/OV/bin/ovstop

/etc/init.d/nfs.client stop

/etc/init.d/nfs.server start

3. To ensure the NFS server daemon process nfsd  is running, type the following 
command and verify the results:

ps -ef | grep nfsd

4. To add all Management Consoles to the management station, edit the /etc/hosts 
file by typing each Console’s specific IP address and Hostname on a separate li
shown in the example:

###.###.###.### Console_Hostname

###.###.###.### Console_Hostname
5. Save and close the /etc/hosts file . 

Note: If using vi editor, use wq!  to save and close the file.

6. For the Management Console system to share the management station directori
NFS, edit  /etc/dfs/dfstab file as follows:

share -F nfs -o root= Console_Hostname /etc/opt/OV/share
share -F nfs -o root= Console_Hostname /var/opt/OV/share
share -F nfs -o root= Console_Hostname /usr/tmp

7. Save and close the /etc/dfs/dfstab  file.

8. To share the Management Station directories with the Consoles over NFS, type

share -F nfs -o root= Console_Hostname /etc/opt/OV/share
share -F nfs -o root= Console_Hostname /var/opt/OV/share
share -F nfs -o root= Console_Hostname /usr/tmp

9. Edit the /etc/opt/OV/share/conf/ovwdb.auth file as shown below to add
an entry for the Console, as shown in the example: 

Console_Hostname +

10. Edit the /etc/opt/OV/share/conf/ovw.auth file as shown below to add an
entry for the Console, as shown in the example: 

Console_Hostname +

Note: Repeat step 6 through step10 using the specific hostname for each additional Manag
Console in the system.

11. To start HP Openview processes, type:

/opt/OV/bin/ovstart
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12. Exit super user by typing exit .

13. Complete the setup by typing:

ovw &

4.2.4 Installing TEAM Applications on Management Consoles
To install TEAM Core software and TEAM product software on Management Conso
perform the following steps:

1. Make sure all users exit HP OpenView for Solaris.

2. Insert the TEAM Core Compact Disk into the CD ROM drive.

3. On the Management Console, become a super user by typing:

su root

If the Solaris distributed environment has been set up, perform steps 4- 8. 
Otherwise, skip to step 9.

4. Disconnect as a HP OpenView client by running:

/opt/OV/bin/ovwsetupclient -u

5. Open the file /etc/vfstab and type a # in the beginning of each line to commen
them out. Save and close the file.

6. On the Management Station, become a super user and open the /etc/dfs/dfstab  
file. Comment out each line which contains the Console hostname by typing a # in the 
beginning of each line. 

7. Save and close the /etc/dfs/dfstab file.

8. On the Management Console become a super user and enter the following comm

/etc/umount Station_Hostname:/etc/opt/OV/share

/etc/umount Station_Hostname:/var/opt/OV/share

/etc/umount Station_Hostname:/usr/tmp

9. Check /  to make sure there is a /cdrom  directory already present. If not, create it.

10. Stop HP OpenView processes by typing 

/opt/OV/bin/ovstop 

11. Start the installation process by typing:

cd /cdrom/cdrom0/solaris

12. If a version of the TEAM Core is already resident on the workstation, or if you are
sure if it is resident, enter the following command before attempting to install the 
version:

./remove.sh

Ignore any error messages that may appear on the monitor and answer y for the 
questions.

13. Continue the installation process by entering the following command:

./install.sh

14. Answer Y to the questions. 
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15. When installation is complete, start HP OpenView processes by typing:

/opt/OV/bin/ovstart 

16. Type cd /

17. Type eject  

18. Exit super user by typing exit . Remove the CD from the CD ROM drive.

19. You must now install all card products of interest (TEAMSC521, TEAMSC553, e
on the management station. Use the product’s media and accompanying release
for installation and any subsequent firmware downloads.

Perform steps 20 - 26 only if the Solaris distributed environment has been set
Otherwise, skip to step 27.

20. On the Management Station become a super user by typing:

su root

21. Open the /etc/dfs/dfstab  file. Remove the # in the beginning of each line 
which contains the Console hostname. 

22. Type the following commands:

share -F nfs -o root= Console_Host_Name /etc/opt/OV/share

share -F nfs -o root= Console_Host_Name /var/opt/OV/share

share -F nfs -o root= Console_Host_Name /usr/tmp

Note: You will now mount /usr/tmp  on the client from the server over nfs, since the TEAM
Shelf Discovery process stores the discovered shelf GUI images (gif files) in /usr/tm

23. On the Management Console become a super user by typing

su root

24. Open the file /etc/vfstab and restore each line by deleting the # in the beginning 
of each line. 

25. Save and close the file.

26. Type the following commands:

/etc/mount Station_Hostname:/etc/opt/OV/share

/etc/mount Station_Hostname:/var/opt/OV/share

/etc/mount Station_Hostname:/usr/tmp

/opt/OV/bin/ovsetupclient /opt/OV/nfs/ Station_Hostname

Note: The path many be different if automounter was used.

27. Exit super user and become a normal user. On the management console, bring
OpenView windows using the server database by typing:

ovw &
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4.2.5 Setting Up the Management Console
1. At the shell prompt, become super user by typing

su root

2. Type the following commands

/opt/OV/bin/ovstop

/etc/init.d/nfs.server stop

/etc/init.d/nfs.client start

3. To ensure that the NFS client daemon processes (statd and lockd) are running, ty
following command and verify its results:

ps -ef | grep statd

ps -ef | grep lockd

4. To add the Management Station to the Management Console, edit the /etc/hosts 
file by typing the Management Station’s specific IP address and Hostname, as s
in the example:

###.###.###.### Station_Hostname
5. Save and close the /etc/hosts file.

6. Type the following commands:

mkdir -p /opt/OV/nfs/ Station_Hostname/etc/opt/OV/share

mkdir -p /opt/OV/nfs/ Station_Hostname/var/opt/OV/share

rm /usr/tmp

mkdir -p /usr/tmp

chmod 777 /usr/tmp

7. To mount the Management Station directories on this Console over NFS, edit th 
/etc/vfstab file as shown in the example:

Station_Hostname:/etc/opt/OV/share - /opt/OV/nfs/ Station_Hostname/etc/opt/OV/share/ nfs - yes rw
Station_Hostname:/var/opt/OV/share - /opt/OV/nfs/ Station_Hostname/var/opt/OV/share/ nfs - yes rw
Station_Hostname:/usr/tmp - /usr/tmp nfs - yes rw

8. Save and close the /etc/vfstab file.

9. To mount the Management Station directories on this Console over NFS, type t
following commands:

/etc/mount Station_Hostname:/etc/opt/OV/share

/etc/mount Station_Hostname:/var/opt/OV/share

/etc/mount Station_Hostname:/usr/tmp

10. Set up the Management Console by typing:

/opt/OV/bin/ovwsetupclient /opt/OV/nfs/ Station_Hostname
11. Exit Super User by typing exit .

12. Complete the setup by typing:

ovw &
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Note: It is not necessary to start HP OpenView daemons using /opt/OV/bin/ovstart on the 
Management Console because the Console shares the same HP OpenView databa
present on the Management Station over NFS.

Note: If the Console OpenView windows does not start up properly, reboot the Manageme
Station and wait until it is UP completely. Then, reboot the Console.

5.0 Post-Installation Procedure For All Solaris Environments
Once the TEAM Core software has been installed in the desired environment, the follo
procedure must be performed to enable IP Discovery.

1. After completing installation and environment setup, open the root map.

2. At the Options menu, select Network Polling Configuration: IP .

3. At the Configuration Area, select IP Discovery . 

4. Enable the Discover New IP Nodes  option by selecting its checkbox.

5. Click OK. Discovery will begin at once and the Universe map will start to show th
discovered shelves.

6.0 TEAM Core De-Installation in Solaris
Procedures vary, depending on the type of environment. Refer to the appropriate 
procedures below. Additional information about distributed environments is provided
Section 4.

Note: TEAM Core shares the common utilities application package, GDCTeam, with other
TEAM controllers. Do not remove it unless you are certain no controllers requiring 
GDCTeam are installed on the workstation 

6.1 CDE and Sun OpenWindows De-Installation
1. In the OpenView Root map, click on the TEAM universe icon.

2. From the Edit menu of the Root map menu bar, select Delete , then select From 
All Submaps  to remove the TEAM icon from the Root map. 

3. Make sure that all users exit HP OpenView for Solaris.

4. Insert the TEAM Core CD into the CD ROM drive.

5. At the shell prompt, become super user by typing:

su root

6. Stop the HP OpenView processes by typing:

/opt/OV/bin/ovstop

7. Begin the removal process by entering the following command:

cd /cdrom/cdrom0/solaris
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8. Restart all HP OpenView processes by typing:

/opt/OV/bin/ovstart

9. Type cd /

10. Type eject  

11. Remove the CD from the CD ROM drive.

12. Set up environment variables by typing:

/usr/bin/sh

. /opt/OV/bin/ov.envvars.sh

13. Start the Event system configurator GUI by typing:

$OV_BIN/xnmtrap

14. Select an event and delete it by selecting Edit->Delete->Event . 
Refer to Table 1-2 for a listing of all events to be deleted.

15. Delete the enterprise by selecting: 

Edit->Delete->Enterprise Identifier

16. From the Event Configuration window, click File->Save  to save the changes.

17. Exit super user by typing exit . 
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6.2 De-Installing a Distributed Environment
De-installation of TEAM software in a distributed Solaris environment should be 
performed in the following order: 

A. Management Console

B. Management Station

C. Collection Station

6.2.1 De-Installing the Management Console 
To remove TEAM Core software or any other TEAM product software from a managem
console. perform the following steps:

Note: If the Solaris distributed environment has been set up, it must be disabled temporari
avoid sharing conflicts with the server. Additional steps for this are provided below.

1. Make sure that all users exit HP OpenView for Solaris.

2. Insert the TEAM Core (or other TEAM software) CD into the CD ROM drive.

3. At the shell prompt, become super user by typing:

su root

4. Disconnect as a HP OpenView client by running:

/opt/OV/bin/ovwsetupclient -u

5. Stop the HP OpenView processes by typing:

opt/OV/bin/ovstop

6. Open the file /etc/vfstab and type a # in the beginning of each line. 

7. Save and close the /etc/vfstab file.

8. On the Management Station, become a super user and open the /etc/dfs/dfstab 
file. Comment out each line which contains this Console by typing a # in the beginning 
of that line.

9. Save and close the /etc/dfs/dfstab file.

10. On the Management Console, become a super user and enter the following com

/etc/umount Station_Hostname:/etc/opt/OV/share

/etc/umount Station_Hostname:/var/opt/OV/share

/etc/umount Station_Hostname:/usr/tmp

11. Begin the removal process by entering the following command:

cd /cdrom/cdrom0/solaris

./remove.sh

12. Restart all HP OpenView processes by typing:

opt/OV/bin/ovstart

13. Type cd /

14. Type eject  
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15. Remove the CD from the CD ROM drive.

16. Use the media for the card product of interest (for example, TEAMSC521, 
TEAMSC533, etc., to de-install its software. Procedures are provided in each 
product’s accompanying release notes. 

17. Open the /etc/vfstab  file and remove the # from the beginning of each line that
contains a Console hostname.

18. On the Management Station, become a super user by typing:

su root

19. Open the /etc/dfs/dfstab file and remove the # from any lines which contain 
this Console’s name.

20. Type the following commands:

share -F nfs -o root= Console_Hostname /etc/opt/OV/share
share -F nfs -o root= Console_Hostname /var/opt/OV/share
share -F nfs -o root= Console_Hostname /usr/tmp

21. Exit super user by typing exit . 

22. On the Management Console, become a super user by typing su  and supplying the 
super user password.

23. Attach the NFS mounts to the management console, execute the following comm
using the management station’s host name:

/etc/mount Station_Hostname:/var/opt/OV/share

/etc/mount Station_Hostname:/etc/opt/OV/share

/etc/mount Station_Hostname:/usr/tmp

24. Exit super user login.

6.2.2 De-Installing the Management and Collection Stations 
1. In the OpenView Root map, click on the TEAM universe icon.

2. From the Edit menu of the Root map menu bar, select Delete , then select From 
All Submaps  to remove the TEAM icon from the Root map. 

3. Make sure that all users exit HP OpenView for Solaris.

4. Insert the TEAM Core CD into the CD ROM drive.

5. At the shell prompt, become super user by typing:

su root

6. Stop the HP OpenView processes by typing:

opt/OV/bin/ovstop

7. Begin the removal process by entering the following command:

cd /cdrom/cdrom0/solaris

./remove.sh

8. Restart all HP OpenView processes by typing:

opt/OV/bin/ovstart
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9. Type cd /

10. Type eject  

11. Exit super user by typing exit . 

12. Remove the CD from the CD ROM drive.

7.0 Known Issues
• Some TEAM applications may display meaningless characters in the application

window headings. This is due to a font conflict which can be resolved by typing t
following on the command line before running ovw:

xrdb -merge /opt/OV/bin/gdc_load_resources

• In some TEAM applications, the following display anomalies may occur which do
affect system or application operation:

On an Alarm application display, LED labels may appear off-center over their
associated LED. 

In a Report application display, the content window may overlap the last chara
of Y-axis labels for the window.

8.0 Operating Guidelines
• Pressing the keyboard “Num Lock” or “Caps Lock” key ON will make the mouse 

buttons and scroll bars inoperable.

• Due to the loading of shared libraries, TEAM applications may take up to one mi
to start up after an install of TEAM software or a reboot of the system. 

• When a new SpectraComm card is added to the shelf and if an X-TERMINAL is b
run on a server, the shelf map will not be automatically updated because the ma
read-only. To update the map, select Map->Refresh Map  from the shelf map menu
bar. The shelf map updates and submaps will close.

• A Line Terminating Unit (LTU) that is operating in CSU mode should not be selec
as the Shelf Timing source for other devices in its shelf. 

• Circuit submap creation is not applicable for a DSU or DSE that has an associat
remote. 

• Deleting a shelf from the TEAM Universe map does not delete associated remot
linked to the shelf. The recommended procedure, rather than deleting the shelf its
to select the SCM for the shelf and delete it from all submaps. 

• OpenView cannot Discover the SCM by means of a PPP or Ethernet connection 
SCM contains any entries in its /etc/hosts  table.

• Although the TEAM Core application is itself Year 2000 compliant, the License K
provided with the OpenView operating software may limit the range of dates that
system can recognize. 
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• When installing TEAM Core software with HPOV Network Node Manager, disreg
the following error messages as they occur. Installation will complete successful
despite these messages:

ovstart: ovspmd failed to start and no managers are running

ovw: Cannot open object database: Cannot connect to database

The ovwdb daemon is not running on the server <HostName>.

Ask the administrator of this server to run "ovstart ovwdb".

ovstop: ovspmd is not running

• Some hardware devices controlled by TEAM applications occupy two SpectraCo
shelf slots. Removing a two-slot device from its shelf and shifting it over one slot
results in a corrupted display with a double image of the device’s slot icon. To co
that condition delete the slot icon that is in error (red). When that is done the shelf
redisplays with its device population shown in the correct slots. 

• If the Event Log stops logging alarms coming in via the SCM, you must stop and 
start the shelf_discovery  daemon, as follows:

A. Log in as super user and then type:

/opt/OV/bin/ovstop shelf_discovery

B. Then type:

/opt/OV/bin/ovstart shelf_discovery

• Performance of the workstation CPU may be impaired following the discovery or
removal of TEAM shelves. The condition can be corrected by editing the 
$OV_LRF/ovwdb.lrf  file to limit the maximum number of objects in the ovwdb  
cache. Use the following procedure to edit the file: 

A. If HP OpenView Windows (ovw) is running, exit it by selecting the 
Map:Exit  menu item. 

B. Stop background processes by typing ovstop . 

C. Make a backup copy of the $OV_LRF/ovwdb.lrf  file. If the file does not exist, 
create it by copying from:

$OV_NEW_CONF/OVWIN/ovwdb.lrf to $OV_LRF/ovwdb.lrf

D. Load ovwdb.lrf  into a text editor. The default ovwdb.lrf  file consists of:

ovwdb:

ovwdb:OVs_YES_START::-0 -n5000:OVs_WELL_BEHAVED:15:

E. Modify -n <number of objects>

The value depends on the number of nodes to be managed and the amount 
memory resources on the system. With sufficient memory, performance is 
optimized when the -n  option is not used. Use the -n  option when memory 
capacity is limited.

F. Save the edited ovwdb.lrf  file under the name $OV_LRF/ovwdb.lrf 
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G. The ovaddobj tells the start-up processes what to start. Update the ovsuf  config-
uration file by typing: 

ovaddobj $OV_LRF/ovwdb.lrf

H. Restart the background processes by typing:

ovstart

• The TEAM Core application will cancel a firmware download if it detects 
incompatibility between the firmware and the circuit card that will run it. 
An error message will display.

• When using TEAM Core to download the SC 800 T3 firmware at the TEAM 
SpectraComm Firmware Download window, do not use the Select All  option if 
master and remote units appear together in the Target Equipment List. Doing so
erase the standby firmware in the remote units. Make sure to deselect any remote
before performing a broadcast download to master units. Then, select each remo
and download the firmware individually. 

• When using TEAM Core to download the SC 800 T3 firmware to a remote unit, it m
be necessary to adjust the timing to avoid a timeout.

• After an installation of TEAM software, the user must enable Discover New IP 
Nodes  from the root map Options menu in order for shelf discovery to occur. 
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Section 3 - TEAM Core for HPUX

1.0 Overview
These installation and release notes provide new information relevant to the TEAM C
software product operating on the HPUX platform. They update the information supp
by the TEAM Core Operation Manual. If you require additional details please refer to
that manual. For questions on information provided here, please contact your GDC f
representative.

2.0 Software Reference
The following table provides the detailed information for all software modules relevan
TEAM Core for HPUX installation. Throughout this manual, short forms of the softwa
product names will be used. 

The TEAM Core software is comprised of the following packages on the TEAM Core 
After installation these packages should be present on the workstation at the versions
or greater. To verify the version of a package currently installed, type the following 
command:

/usr/bin/pkginfo -l < Package Name >

Table 4: Software Reference for HPUX 

Item Part Number/Detail Version / Description

TEAM Core Software Product 058U739-C01 Ver 4.2.0

TEAM Core Operation Manual 058R720-V420 Latest Version/Issue

HPOV NNM Software Product Release 6.1

HPUX Ver 11.0 November 
1999

HPUX and HPOV Patches Ref: HP website

HPOV Network Node Manager Installation 
Guide

HP J1136-9000 Latest Release

SCM for SpectraComm and V.34 Products Firmware Version 5.3.0 
or greater

MIB Ver 3.10F

SCM for UAS products Firmware Version 7.2.0 
or greater

MIB Ver 3.10F

Package Name  Description Version

GDCTeam GDC TEAM Utilities Ver 4.2.0

GDCShelf5 GDC Shelf 5000 Ver 4.2.0
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2.1 Improvements Since Last Release
TEAM Core software has been tested to be Year 2000 Compliant in accordance to G
ENG-STD-003. TEAM Core 4.1.0 differs from the preceding release as follows:

• Supports the SC 5516 DS0-DP product.

Preceding 
Versions

Description of Change

TEAM Core 4.1.0 Supports the SC 521A/S product.
Supports remote SCM IP address configuration in SC/UAS systems.
Supports the SC 521A as a remote to the SC 5520

TEAM Core 4.0.0 Supports the SC 7723-MR and GT 1033 Multi-Rate products.
Approved for operation on Solaris 2.7, Solaris 2.8, HP Openview 6.1 and 
HPUX 11.0 upgrades

TEAM Core 3.1.0 Supports the SC 800 T3 product.

TEAM Core 3.0.5 Supports long host ID names, up to 50 characters (previously limited to 16), 
minor fixes, product compatibility additions.

TEAM Core 3.0.4 Minor fixes, product compatibility additions.

TEAM Core 3.0.3 Minor fixes, product compatibility additions.

TEAM Core 3.0.2 Addition of the Group Configuration feature, minor fixes.
4 Release Notes for GDCPart No. 058U739-C01
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3.0 Hardware Requirements on HP OpenView - HPUX
• HP 9000 series model 700 or greater

• Minimum of 96 Megabytes of RAM and 2 Gigabytes of hard disk space with 350
megabytes free disk space and 500 megabytes of swap space

• Minimum disk space requirements:

/opt 35 megabytes

/system less than 1 megabyte

• SCM card

• CD ROM drive

3.1 Determining Hard Disk Space
1. Login as root

2. Type sam

3. Select Disk & Filesystems

4. Select Filesystems

5. Type /  and select Actions ->View More Information  . 

Note: For information on memory, swap space, and hard disk requirements for OpenView 
HPUX, refer to the HP OpenView Network Node Manager Products Installation Guid

4.0 Software Requirements
The following HPUX and HP OpenView software must be installed and operational be
installing this version of TEAM Core. Refer to Table 4 for detailed identification of all
software products discussed below. 

• HP OpenView for HPUX NNM Release

• HP 9000 S700/S800 HPUX OpenView version 

• The most recent HPUX and HP OpenView patches for these versions

Note: IMPORTANT: It is highly recommended that the customer download and install the 
latest HP OPENVIEW CUMULATIVE CONSOLIDATED PATCH from the following H
OpenView web site: http://ovweb.external.hp.com/cpe/patches .
This will ensure that you have updated HP Open View along with any current fixes to
reported problems. Refer to the HPUX web site for HPUX 11.0 Operating System up

Note: It is the customer’s responsibility to install the listed HP software and patches, and en
they are fully operational before loading the General DataComm TEAM applications
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5.0 TEAM Core Installation in HPUX Environments
TEAM Core software can be installed in one of three HPUX environments. 

• Common Desktop Environment (referred to as CDE or DT)

• HP Visual User Environment (VUE)

• Distributed Environment

Installation includes loading TEAM software and updating user environments. The 
procedures vary depending on the type of environment. Some environment updating
procedures require you to use vi or your favorite editor to change your environment scrip
All procedures for each environment are provided below. Additional information abo
distributed environments is provided in Section 4.

Note: TEAM Core shares the common utilities application package, GDCTeam, with other
TEAM controllers. If a more recent version than the one being installed is already pre
on the workstation, the installation will be stopped and an error message will be 
displayed. If that occurs consult the first entry in the Log File to confirm the problem.
Click Cancel in the Install Analysis window. From the SD Install window menu bar se
Options -> Change Options . In the Options window, scroll to “Enforce dependenc
analysis errors in agent” and de-select it (click the selection box so that it goes dark),
click on OK. The new option setting permits you to install software packages selectiv
Resume the installation from step 9, selecting only GDCShelf5. Dismiss the resulting
Dependency Message window by clicking OK.

Note: For detailed information on Event Forwarding, refer to the HP OpenView Guide to 
Scalability and Distribution for Network Node Manager, page 138. 

Note: You can access the Logfile display by clicking the Logfile button in the SD Install win
This displays the version number of GDC_APPS as OV3.0.0, which is also the versi
number for every individual package installed.

5.1 TEAM Core Installation in CDE and VUE 
1. Make sure all users exit HP OpenView for HPUX.

2. Close all HP OpenView and TEAM application windows (if applicable). 

3. Insert the TEAM Core CD into the CD ROM drive.

4. At a shell prompt become super user by entering the following command:

su root

5. Check /  to make sure there is a /cdrom  directory already present. If not, create it.
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6. Start the installation process by entering the following commands:

csh

mount /dev/dsk/c0t2d0 /cdrom

cd /cdrom/HPUX

./INSTALL*

7. The install script will first run /opt/OV/bin/ovstop  to stop HP OpenView 
background processes. Then, the SD Install - Software Selection window appea
indicating swinstall  has begun.

8. Select GDC_APPS from the scroll box and double click on it. A list of the individua
TEAM applications appears.

9. Highlight one or both of the TEAM Core applications to be installed: 

GDCTeam 

GDCShelf5

10. Select Actions ->Mark for Install .

11. Select Actions ->Install (analysis) .

12. In the Install Analysis dialog box, click OK to proceed.

13. In the Confirmation window, click Yes to continue with the installation.

14. The following error message will appear: 

$HOME..sw/sessions/swinstall.last 

15. Click OK. TEAM Core software installation will now begin. 

16. When the process is complete, the Done button in the Install Window dialog box 
becomes “un-grayed”. Click Done. 

17. From the main SD Install window, select File->Exit  .

18. The install script then starts HP OpenView background processes by running:

/opt/OV/bin/ovstart

19. Confirm that the correct versions of software have been installed by typing:

/usr/sbin/swlist GDC_APPS

20. All GDC software packages installed on the workstation will be displayed along 
their version numbers. 

21. Unmount the CD ROM by typing:

cd /

umount /cdrom

exit

22. Remove the CD from the CD ROM drive.

23. Confirm HP OpenView and TEAM Core processes are running by typing:

/opt/OV/bin/ovstatus
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5.1.1 TEAM Core Installation in HPUX 10.20 and Higher
To allow the Notepad application under the HP OpenView window menu 
Misc->Notepad  to work properly, enter the following commands:

cd /usr/vue/bin

su root

ln -s /usr/bin/Xll/hpterm hpterm

5.2 Adding/Updating User Accounts in CDE and VUE
1. Type sam

2. Select Users and Groups .

3. Select Users .

4. Under the Actions menu, select Add. 

5. Enter Login name and select the shell you desire (prefer cshell)

6. Enter Password if desired

7. Exit sam

8. Log off and log back in under a user account. 

5.2.1 Common Desktop Environment Only
Following the TEAM Core installation, update each user account in a Common Desk
Environment as described below.

1. Open the $HOME/.dtprofile  file with your editor and read the lengthy commen
that are included in it. The comments provide information on:

A. how to use the C (csh), Bourne (sh), and Korn (ksh) shells in the CDE

B. terminal commands which should not be used because they can prevent logi
When using the csh shell, the commands are generally present in .login  and 
.cshrc files. When using the sh or ksh shells, they are in .login  and .pro-
file  files.

2. After reviewing the comments, edit the $HOME/.dtprofile  file to remove the 
leading pound sign(s) in the line that contains

###DTSOURCEPROFILE=true

3. If you are using C (csh) Shell you must add the following lines to $HOME/.cshrc :

source /opt/OV/bin/ov.envvars.csh

set path=($path $OV_BIN)

xhost + HostName

4. If you are using Bourne(sh) shell or Korn(ksh) shell you must add the following l
to $HOME/.profile :

.  /opt/OV/bin/ov.envvars.sh

PATH=$PATH:$OV_BIN; export PATH

5. Add the following line to $HOME/.Xdefaults :

#include “/opt/OV/bin/gdc_load_resources”
8 Release Notes for GDCPart No. 058U739-C01
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6. The Common Desktop Environment is now updated for all users. Complete the
installation by typing:

ovw &

7. You must now logout and login in order for the changes to take effect.

5.2.2 HP Visual User Environment Only
Following TEAM Core installation, update each user account in an HP Visual User 
Environment as described below:

1. Open the $HOME/.vueprofile  file to remove the leading pound sign(s) in the lin
that contains

###VUESOURCEPROFILE=”true”

2. If you are using C (csh) Shell you must add the following lines to $HOME/.cshrc :

source /opt/OV/bin/ov.envvars.csh

set path=($path $OV_BIN)

xhost + HostName

3. If you are using Bourne(sh) shell or Korn(ksh) shell you must add the following l
to $HOME/.profile :

.  /opt/OV/bin/ov.envvars.sh

PATH=$PATH:$OV_BIN; export PATH

4. At the command line, type:

xrdb -merge /opt/OV/bin/gdc_load_resources

5. To verify the success of the previous command, type:

xrdb - query | grep “OI\*FontSet”

6. The following response should appear:

*OI*FontSet: -misc-fixed-medium-r-semicondensed--13-
120-75-75-c-60-iso8859-1

7. The HP Usual User Environment is now updated for all users. Complete the 
installation by typing:

ovw &

8. You must now logout and login in order for the changes to take effect.

Note: Changes made to the window manager may cause this X resource to get lost. If that
happens, repeat the steps in this procedure. Refer to the HP Visual User Environme
(VUE) User’s Guide for more information on setting up resources.
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5.3 Installing in an HPUX Distributed Environment
A distributed environment consists of three types of workstations. Not all workstation
require installation of all software, but the workstations must be set up in the followin
order: 

A. Collection Station

B. Management Station

C. Management Console

The procedures for TEAM Core and product software installation vary depending on
type of workstation. Perform the installation and set up procedures for each workstat
your distributed environment. 

5.3.1 Setting Up Collection Stations
On workstations that serve as collection stations, you must install the TEAM software
then configure events so that traps are forwarded to the management station. Refer
event data in Table 5 during this installation process. 

1. Become a super user by typing su  and suppling the super user password.

2. Set up environment variables by typing:

/usr/bin/sh

. /opt/OV/bin/ov.envvars.sh

3. Insert the TEAM Core CD into the CDROM drive. 

4. Create a directory named /cdrom  if one doesn’t already exist in / . 

5. Mount the CD by typing:

mount/dev/dsk/c0t2d0 /cdrom

6. Register GDC Trap format by typing:

cd /cdrom/HPUX

$OV_BIN/xnmevents -merge “./SHELFTRAPD.CONF;1”

7. Start the Event system configurator GUI by typing:

$OV_BIN/xnmtrap

Table 5: Event Forwarding Data

Enterprise Name (Enterprise ID) Event Name (Enterprise Identifier)

gdc_cmnAlarm(.1.3.6.1.4.1.498.1.4) dmscmnAlarmTrap(.1.3.6.1.4.1.498.1.4.0.1)

gdc_scm(.1.3.6.1.4.1.498.3.6) dmsSCMPowerSupplyTrap(.1.3.6.1.4.1.498.3.6.0.3)

gdc_scm(.1.3.6.1.4.1.498.3.6) dmsSCMAliveTrap(.1.3.6.1.4.1.498.3.6.0.4)

gdc_scm(.1.3.6.1.4.1.498.3.6) dmsSCMcoldStart(.1.3.6.1.6.3.1.1.5.1)

gdc_scm(.1.3.6.1.4.1.498.3.6) dmsSCMwarmStart(.1.3.6.1.6.3.1.1.5.2)

gdc_scm(.1.3.6.1.4.1.498.3.6) dmsSCMAuthentication(.1.3.6.1.6.3.1.1.5.5)
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8. From the Enterprise Identification pane, select an Enterprise Name

for example: gdc_cmnAlarm

9. From the Event Identification pane, select an Event Name

for example: dmscmnAlarmTrap

10. From the Event Configuration window menu bar, select Edit->Modify Event . 
The Event Configurator/Modify Event dialog box appears.

11. Click on the Forward Event check box to expand the dialog box. 
The Forwarded Event Destinations pane displays.

12. Type the hostname or IP Address for destination. Click Add, then click OK.
Destinations are the managements stations to which events will be forwarded. 

13. Repeat steps 9 through 12 for each of the events listed in Table 5. When all eve
forwarded, click OK in the Event Configurator/Modify Event dialog box.

14. At the Event Configuration window, click File->Save  to save the changes.

15. To cause Openview processes to re-read the trapd.conf file, generate Event by t

$OV_BIN/xnmtrap -event

16. Unmount the cdrom by typing:

umount /cdrom

5.3.2 Installing TEAM Applications on the Management Station
To install TEAM Core software and TEAM product software on the Management Sta
perform the following steps:

1. Make sure all users exit HP OpenView for HPUX.

2. Close all HP OpenView and TEAM application windows (if applicable). 

3. Insert the TEAM Core CD into the CD ROM drive.

4. At a shell prompt become super user by entering the following command:

su root

5. Check /  to make sure there is a /cdrom  directory already present. If not, create it.

6. Start the installation process by entering the following commands:

csh

mount /dev/dsk/c0t2d0 /cdrom

cd /cdrom/HPUX

./INSTALL*

7. The install script will first run /opt/OV/bin/ovstop  to stop HP OpenView 
background processes. Then, the SD Install - Software Selection window appea
indicating swinstall  has begun.

8. Select GDC_APPS from the scroll box and double click on it. A list of the individua
TEAM applications appears.
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9. Highlight one or both of the TEAM Core applications to be installed: 

GDCTeam 

GDCShelf5

10. Select Actions ->Mark for Install .

11. Select Actions ->Install (analysis) .

12. In the Install Analysis dialog box, click OK to proceed.

13. In the Confirmation window, click Yes to continue with the installation.

14. The following error message will appear: 

$HOME..sw/sessions/swinstall.last 

15. Click OK. TEAM Core software installation will now begin. 

16. When the process is complete, the Done button in the Install Window dialog box 
becomes “un-grayed”. Click Done. 

17. From the main SD Install window, select File->Exit  .

18. The install script then starts HP OpenView background processes by running 
/opt/OV/bin/ovstart  .

19. Confirm that the correct versions of software have been installed by typing:

/usr/sbin/swlist GDC_APPS

20. All GDC software packages installed on the workstation will be displayed along 
their version numbers. 

21. Unmount the CD ROM by typing:

cd /

umount /cdrom

exit

22. Remove the CD from the CD ROM drive.

23. Confirm HP OpenView and TEAM Core processes are running by typing:

/opt/OV/bin/ovstatus

5.3.3 Setting Up the Management Station
1. At the shell prompt, become a super user by typing:

su root

2. Type the following commands:

/opt/OV/bin/ovstop

/sbin/init.d/nfs.client stop

/sbin/init.d/nfs.server start

3. To ensure the NFS server daemon process nfsd  is running, type the following 
command and verify the results:

ps -ef | grep nfsd
2 Release Notes for GDCPart No. 058U739-C01



TEAM Core Version 4.2.0 Publication No. 058R957-V420
Issue 1 - January 2002

Releas

ne, as 

tories 

:

Note: If the nsf is not running, edit the etc/rc.config.d/nfsconf file and change 
NFS_SERVER=0 to NFS_SERVER=1. Save the file, then repeat steps 1 through 3.

4. To add all Management Consoles to the Management Station, edit the /etc/hosts 
file by typing each Console’s specific IP address and Hostname on a separate li
shown in the example:

###.###.###.### Console_Hostname

###.###.###.### Console_Hostname
5. Save and close the /etc/hosts file . 

Note: If using vi editor, use wq!  to save and close the file.

6. To allow a single Management Console to share the Management Station direc
over NFS, edit the /etc/exports file as follows:

/etc/opt/OV/share -root= Console_Hostname 

/var/opt/OV/share -root= Console_Hostname 

/usr/tmp -root= Console_Hostname 

7. Save and close the /etc/exports  file.

8. To share the Management Station directories with the Consoles over NFS, type

usr/sbin/exportfs -au 

usr/sbin/exportfs -av

9. Edit the file /etc/opt/OV/share/conf/ovwdb.auth file as shown below to 
add an entry for the Console, as shown in the example: 

Console_Hostname +

10. Edit the file /etc/opt/OV/share/conf/ovw.auth file as shown below to 
add an entry for the Console, as shown in the example: 

Console_Hostname +

11. To start HP Openview processes, type:

/opt/OV/bin/ovstart

12. Exit super user by typing exit .

13. Complete the setup by typing:

ovw &
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5.3.4 Installing TEAM Applications on the Management Console

Note: If the HPUX distributed environment has been set up, it must be disabled temporaril
before loading any TEAM software to avoid sharing conflicts with the server. Additio
steps for this are provided below.

1. Make sure all users exit HP OpenView for HPUX.

2. Close all HP OpenView and TEAM application windows (if applicable). 

3. On the Management Console, become super user by typing:

su root

If the HPUX distributed environment has been set up, perform steps 4 - 9. 
Otherwise, skip to step 10.

4. Disconnect as a HP OpenView client by typing:

/opt/OV/bin/ovwsetupclient -u

5. Open the file /etc/fstab and type a # in the beginning of each line to commen
out each line with a Console hostname. 

6. Save and close the file.

7. On the Management Station, become a super user and open the file /etc/exports . 
Comment out each line with a Console hostname by typing a # in the beginning of 
each line. 

8. Save and close the file.

9. On the Management Console, become a super user and enter the following com

/etc/umount Station_Hostname:/etc/opt/OV/share

/etc/umount Station_Hostname:/var/opt/OV/share

/etc/umount Station_Hostname:/usr/tmp

10. Insert the TEAM application CD of interest (TEAM521A, TEAM800T3, etc.) into t
CD ROM drive.

11. At a shell prompt become super user by entering the following command:

su root

12. Check /  to make sure there is a /cdrom  directory already present. If not, create it.

13. Start the installation process by entering the following commands:

csh

mount /dev/dsk/c0t2d0 /cdrom

cd /cdrom/HPUX

./INSTALL*

14. The install script will first run /opt/OV/bin/ovstop  to stop HP OpenView 
background processes. Then, the SD Install - Software Selection window appea
indicating swinstall  has begun.
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15. Select GDC_APPS from the scroll box and double click on it. A list of the individua
TEAM applications appears.

16. Highlight one or both of the TEAM Core applications to be installed: 

GDCTeam 

GDCShelf5

17. Select Actions ->Mark for Install .

18. Select Actions ->Install (analysis) .

19. In the Install Analysis dialog box, click OK to proceed.

20. In the Confirmation window, click Yes to continue with the installation.

21. The following error message will appear: 

$HOME..sw/sessions/swinstall.last 

22. Click OK. TEAM Core software installation will now begin. 

23. When the process is complete, the Done button in the Install Window dialog box 
becomes “un-grayed”. Click Done. 

24. From the main SD Install window, select File->Exit  .

25. The install script then starts HP OpenView background processes by running 
/opt/OV/bin/ovstart  .

26. Confirm that the correct versions of software have been installed by typing:

/usr/sbin/swlist GDC_APPS

27. All GDC software packages installed on the workstation will be displayed along 
their version numbers. 

28. Unmount the CD ROM by typing:

cd /

umount /cdrom

exit

29. Remove the CD from the CD ROM drive.

30. Confirm that HP OpenView and TEAM Core processes are running by typing:

/opt/OV/bin/ovstatus

Perform steps 31 - 38 only if the HPUX distributed environment has been set 
Otherwise, skip to step 39.

31. On the Management Station, become a super user by typing:

su root

32. Open the file /etc/exports . Restore the Console hostnames by removing the# 
from the beginning of each line containing the Console hostname. 

33. Save and close the file /etc/exports . 

34. Type the following commands:

/usr/sbin/exportfs -au

/usr/sbin/exportfs -av
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35. On the Management Console, become a super user by typing:

su root

36. Open the file /etc/fstab and restore each line by deleting the # in the beginning 
of each line. 

37. Save and close the file.

38. Type the following commands: 

/etc/mount Station_Hostname:/etc/opt/OV/share

/etc/mount Station_Hostname:/var/opt/OV/share

/etc/mount Station_Hostname:/usr/tmp

/opt/OV/bin/ovsetupclient /opt/OV/nfs/ Station_Hostname

Note: The path many be different if automounter was used.

39. Exit super user and become a normal user. On the Management Console, bring
OpenView windows using the server database by typing:

ovw &

5.3.5 Setting Up the Management Console
1. At the shell prompt, become a super user by typing:

su root

2. Type the following commands:

/opt/OV/bin/ovstop

/sbin/init.d/nfs.server stop

/sbin/init.d/nfs.client start

3. To ensure the NFS client daemon process biod is running, type the following 
command and verify the results:

ps -ef | grep biod

Note: If the biod is not running, edit the /etc/rc.config.d/nfsconf file and change 
NFS_CLIENT=0 to NFS_CLIENT=1. Save the file, then repeat steps 2 and 3.

4. To add the Management Station to the Management Console, edit the /etc/hosts 
file by typing the specific Management Station IP address and Hostname, as sho
the example:

###.###.###.### Station_Hostname

###.###.###.### Station_Hostname
5. Save and close the /etc/hosts file. 

Note: If using vi editor, use wq!  to save and close the file.
6 Release Notes for GDCPart No. 058U739-C01



TEAM Core Version 4.2.0 Publication No. 058R957-V420
Issue 1 - January 2002

Releas

e

he 

se 

nt 
6. Type the following commands:

mkdir -p /opt/OV/nfs/ Station_Hostname/etc/opt/OV/share

mkdir -p /opt/OV/nfs/ Station_Hostname/var/opt/OV/share

rm /usr/tmp

mkdir -p /usr/tmp

chmod 777 /usr/tmp

7. To mount the Management Station directories on this Console over NFS, edit th 
/etc/fstab file as shown in the example:

Station_Hostname:/etc/opt/OV/share /opt/OV/nfs/ Station_Hostname/etc/opt/OV/share nfs rw 0 0
Station_Hostname:/var/opt/OV/share /opt/OV/nfs/ Station_Hostname/var/opt/OV/share nfs rw 0 0
Station_Hostname:/usr/tmp /usr/tmp nfs rw 0 0

8. Save and close the / etc/fstab file.

Note: If using vi editor, use wq!  to save and close the file.

9. To mount the Management Station directories on this Console over NFS, type t
following commands:

/etc/mount Station_Hostname:/etc/opt/OV/share

/etc/mount Station_Hostname:/var/opt/OV/share

/etc/mount Station_Hostname:/usr/tmp

10. Set up the Management Console by typing:

/opt/OV/bin/ovwsetupclient /opt/OV/nfs/ Station_Hostname
11. Exit Super User by typing exit .

12. Complete the setup by typing:

ovw &

Note: It is not necessary to start HP OpenView daemons using /opt/OV/bin/ovstart on the 
Management Console because the Console shares the same HP OpenView databa
present on the Management Station over NFS.

Note: If the Console OpenView windows does not start up properly, reboot the Manageme
Station and wait until it is UP completely. Then, reboot the Console.

5.3.6 Adding/Updating User Accounts in Distributed Environments
1. Type sam

2. Select Users and Groups .

3. Select Users .

4. Under the Actions menu, select Add. 

5. Enter Login name and select the shell you desire (prefer cshell)
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6. Enter Password if desired

7. Exit sam

8. Log off and log back in under a user account. 

6.0 TEAM Core De-Installation in HPUX Environments
1. In the OpenView Root map, click on the TEAM universe icon.

2. From the Edit menu of the Root map menu bar, select Delete , then select From 
All Submaps  to remove the TEAM icon from the Root map. 

3. Make sure that all users exit HP OpenView for HPUX.

4. Insert the TEAM Core CD into the CD ROM drive.

5. At the shell prompt, become super user by typing:

su root

6. Start the removal process by entering the following commands:

csh

mount /dev/dsk/c0t2d0 /cdrom

cd /cdrom/HPUX

./REMOVE*

7. The remove script will first run /opt/OV/bin/ovstop  to stop HP OpenView 
background processes. Then, the SD Remove - Software Selection window app
indicating swremove  has begun.

8. Select GDC_APPS from the scroll box and double click on it. A list of the individua
TEAM applications appears.

9. Highlight one or both of the TEAM Core applications to be removed: 

GDCTeam 

GDCShelf5

10. Select Actions->Mark for Remove .

11. Select Actions ->Remove (analysis) .

12. In the Remove Analysis dialog box, click OK to proceed.

13. In the Confirmation window, click Yes to continue with the removal. The following
error message will appear: 

$HOME..sw/sessions/swremove.last 

14. Click OK. TEAM Core software removal will now begin. 

15. When the process is complete, the Done button in the Remove Window dialog box 
becomes “un-grayed”. Click Done. 

16. From the main SD Remove window, select File->Exit  .

17. The remove script then starts HP OpenView background processes by typing:

/opt/OV/bin/ovstart 
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18. Unmount the CD ROM by typing:

cd /

umount /cdrom

exit

19. Remove the CD from the CD ROM drive.

20. Confirm HP OpenView processes are running by typing the command:

/opt/OV/bin/ovstatus

6.1 Distributed Environment De-Installation
De-installation of TEAM software in a distributed HPUX environment should be 
performed in the following order: 

A. Collection Station

B. Management Station

C. Management Console

Procedures vary, depending on the type of environment. Refer to the appropriate 
procedures below. Additional information about distributed environments is provided
Section 4.

Note: TEAM Core shares the common utilities application package, GDCTeam, with other
TEAM controllers. Do not remove it unless you are certain no controllers requiring 
GDCTeam are installed on the workstation 

6.1.1 De-Installing TEAM Core from the Collection Stations
1. Become a super user by typing su  and then supplying the super user password.

2. Setting up environment variables by typing:

/usr/bin/sh

.  /opt/OV/bin/ov.envvars.sh

3. Start the Event system configurator GUI by typing:

$OV_BIN/xnmtrap

4. Select an event and delete it by selecting Edit->Delete->Event . 
Refer to Table 5 for a listing of all events to be deleted.

5. Delete the enterprise by selecting: 

Edit->Delete->Enterprise Identifier

6. From the Event Configuration window, click File->Save  to save the changes.

6.1.2 De-Installing TEAM Applications from the Management Station
1. In the OpenView Root map, click on the TEAM universe icon.

2. From the Edit menu of the Root map menu bar, select Delete , then select From 
All Submaps  to remove the TEAM icon from the Root map. 

3. Make sure that all users exit HP OpenView for HPUX.
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4. Insert the TEAM Core CD into the CD ROM drive.

5. At the shell prompt, become super user by typing:

su root

6. Start the removal process by entering the following commands:

csh

mount /dev/dsk/c0t2d0 /cdrom

cd /cdrom/HPUX

./REMOVE*

7. The remove script will first run /opt/OV/bin/ovstop  to stop HP OpenView 
background processes. Then, the SD Remove - Software Selection window app
indicating swremove  has begun.

8. Select GDC_APPS from the scroll box and double click on it. A list of the individua
TEAM applications appears.

9. Highlight one or both of the TEAM Core applications to be removed: 

GDCTeam 

GDCShelf5

10. Select Actions->Mark for Remove .

11. Select Actions ->Remove (analysis) .

12. In the Remove Analysis dialog box, click OK to proceed.

13. In the Confirmation window, click Yes to continue with the removal. The following
error message will appear: $HOME..sw/sessions/swremove.last  

14. Click OK. TEAM Core software removal will now begin. 

15. When the process is complete, the Done button in the Remove Window dialog box 
becomes “un-grayed”. Click Done. 

16. From the main SD Remove window, select File->Exit .

17. The remove script then starts HP OpenView background processes by typing

/opt/OV/bin/ovstart 

18. Unmount the CD ROM by typing:

cd /

umount /cdrom

exit

19. Remove the CD from the CD ROM drive.

20. Confirm HP OpenView processes are running by typing the command:

/opt/OV/bin/ovstatus
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6.1.3 De-Installing TEAM Applications from the Management Consoles

Note: If the HPUX distributed environment has been set up, it must be disabled temporaril
avoid sharing conflicts with the server. Additional steps for this are provided below.

1. Make sure all users exit HP OpenView for HPUX.

2. Close all HP OpenView and TEAM application windows (if applicable). 

3. On the Management Console, become super user by entering:

su root

If the HPUX distributed environment has been set up, perform steps 4 - 8. 
Otherwise, skip to step 9.

4. Disconnect as a HP OpenView client by running:

/opt/OV/bin/ovwsetupclient -u

5. Open the /etc/fstab file and type a # in the beginning of each line which contain
the Console hostname. Save and close the /etc/fstab file.

6. On the Management Station, become a super user and open the file /etc/exports . 
Type a # in the beginning of each line which contains this Console hostname.

7. Save and close the /etc/exports file.

8. On the Management Console, become a super user and type the following comm

/etc/umount Station_Hostname:/etc/opt/OV/share

/etc/umount Station_Hostname:/var/opt/OV/share

/etc/umount Station_Hostname:/usr/tmp

9. Insert the TEAM Core or TEAM product software CD into the CD ROM drive.

10. Start the removal process by entering the following commands:

csh

mount /dev/dsk/c0t2d0 /cdrom

cd /cdrom/HPUX

./REMOVE*

11. The remove script will first run /opt/OV/bin/ovstop  to stop HP OpenView 
background processes. Then, the SD Remove - Software Selection window app
indicating swremove  has begun.

12. Select GDC_APPS from the scroll box and double click on it. A list of the individua
TEAM applications appears.

13. Highlight one or both of the TEAM Core applications to be removed: 

GDCTeam 

GDCShelf5

14. Select Actions ->Mark for Remove .

15. Select Actions ->Remove (analysis) .
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16. In the Remove Analysis dialog box, click OK to proceed.

17. In the Confirmation window, click Yes to continue with the removal.

18. The following error message will appear: 

$HOME..sw/sessions/swremove.last 

19. Click OK. TEAM Core software removal will now begin. 

20. When the process is complete, the Done button in the Remove Window dialog box 
becomes “un-grayed”. Click Done. 

21. From the main SD Remove window, select File->Exit  .

22. The remove script then starts HP OpenView background processes by running

/opt/OV/bin/ovstart

23. Unmount the CD ROM by typing:

cd /

umount /cdrom

exit

24. Remove the CD from the CD ROM drive.

Perform steps 25 - 31 only if the HPUX distributed environment has been set 
Otherwise, skip to step 32.

25. On the Management Station, become a super user by typing

su root

26. Open the file /etc/exports . Remove the # from the beginning of each line which
contains the Console hostname. The file should contain the following lines:

/etc/opt/OV/share -root=First_System: Console_Hostname

/var/opt/OV/share -root=First_System: Console_Hostname

/usr/tmp -root=First_System: Console_Hostname
27. Save and close the file /etc/exports . 

28. Run the following commands:

/usr/sbin/exportfs -au

/usr/sbin/exportfs -av

29. On the Management Console, become a super user by typing:

su root

30. Open the file /etc/fstab and restore each line by deleting the # in the beginning 
of each line. Save and close the file.

31. Type the following commands:

/etc/mount Station_Hostname:/etc/opt/OV/share

/etc/mount Station_Hostname:/var/opt/OV/share

/etc/mount Station_Hostname:/usr/tmp

/opt/OV/bin/ovwsetupclient /opt/OV/nfs/ Station_Hostname
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Note: The path many be different if automounter was used.

32. Exit super user and become a normal user. On the Management Console, bring
OpenView windows using the server database by typing:

ovw &

7.0 Known Issues
• Some TEAM applications may display meaningless characters in the application

window headings. This is due to a font conflict which can be resolved by typing t
following on the command line before running ovw:

xrdb -merge /opt/OV/bin/gdc_load_resources

• In some TEAM applications, the following display anomalies may occur which do
affect system or application operation:

On an Alarm application display, LED labels may appear off-center over their
associated LED. 

In a Report application display, the content window may overlap the last chara
of Y-axis labels for the window.

8.0 Operating Guidelines
• When a new SpectraComm card is added to the shelf and if an X-TERMINAL is b

run on a server, the shelf map will not be automatically updated because the ma
read-only. To update the map, select Map->Refresh Map  from the shelf map menu
bar. The shelf map updates and submaps will close.

• A Line Terminating Unit (LTU) that is operating in CSU mode should not be selec
as the Shelf Timing source for other devices in its shelf. 

• Due to the loading of shared libraries, TEAM applications may take up to one mi
to start up after an install of TEAM software or a reboot of the system. 

• Circuit submap creation is not applicable for a DSU or DSE that has an associat
remote. 

• Deleting a shelf from the TEAM Universe map does not delete associated remot
linked to the shelf. The recommended procedure, rather than deleting the shelf its
to select the SCM for the shelf and delete it from all submaps. 

• When installing TEAM Core software with HPOV Network Node Manager Releas
05.0.1, disregard the following error messages as they occur. Installation will com
successfully despite these messages:

ovstart: ovspmd failed to start and no managers are running

ovw: Cannot open object database: Cannot connect to database

The ovwdb daemon is not running on the server <Hostname>.

Ask the administrator of this server to run "ovstart ovwdb".

ovstop: ovspmd is not running
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• Some hardware devices controlled by TEAM applications occupy two SpectraCo
shelf slots. Removing a two-slot device from its shelf and shifting it over one slot
results in a corrupted display with a double image of the device’s slot icon. To co
that condition delete the slot icon that is in error (red). When that is done the shelf
redisplays with its device population shown in the correct slots. 

• Although the TEAM Core application is itself Year 2000 compliant, the License K
provided with the OpenView operating software may limit the range of dates that
system can recognize. 

• If the default for font size is set too large, the text in an application window’s title 
will not fit. To correct this, change the font size.

• With the SNMP 540 only, you may experience a delay of up to 30 seconds when
invoking application windows from its Front Panel display. To avoid delays, invok
application windows from the main window. 

• If the Event Log stops logging alarms coming in via the SCM, you must stop and 
start the shelf_discovery  daemon, as follows:

A. Log in as super user and then type:

/opt/OV/bin/ovstop shelf_discovery

B. Then type:

/opt/OV/bin/ovstart shelf_discovery

• Performance of the workstation CPU may be impaired following the discovery or
removal of TEAM shelves. The condition can be corrected by editing the 
$OV_LRF/ovwdb.lrf  file to limit the maximum number of objects in the ovwdb  
cache. Use the following procedure to edit the file: 

A. If HP OpenView Windows (ovw) is running, exit it by selecting the 
Map:Exit  menu item. 

B. Stop background processes by typing ovstop . 

C. Make a backup copy of the $OV_LRF/ovwdb.lrf  file. If the file does not exist, 
create it by copying from:

$OV_NEW_CONF/OVWIN/ovwdb.lrf to $OV_LRF/ovwdb.lrf

D. Load ovwdb.lrf  into a text editor. The default ovwdb.lrf  file consists of:

ovwdb:

ovwdb:OVs_YES_START::-0 -n5000:OVs_WELL_BEHAVED:15:

E. Modify -n <number of objects>

The value depends on the number of nodes to be managed and the amount 
memory resources on the system. With sufficient memory, performance is 
optimized when the -n  option is not used. Use the -n  option when memory 
capacity is limited.

F. Save the edited ovwdb.lrf  file under the name $OV_LRF/ovwdb.lrf 

G. The ovaddobj tells the start-up processes what to start. Update the ovsuf  config-
uration file by typing: 

ovaddobj $OV_LRF/ovwdb.lrf

H. Restart the background processes by typing ovstart
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• The TEAM Core application will cancel a firmware download if it detects 
incompatibility between the firmware and the circuit card that will run it. 
An error message will display.

• When using TEAM Core to download the SC 800 T3 firmware at the TEAM 
SpectraComm Firmware Download window, do not use the Select All  option if 
master and remote units appear together in the Target Equipment List. Doing so
erase the standby firmware in the remote units. Make sure to deselect any remote
before performing a broadcast download to master units. Then, select each remo
and download the firmware individually. 

• When using TEAM Core to download the SC 800 T3 firmware to a remote unit, it m
be necessary to adjust the timing to avoid a timeout.

• After an installation of TEAM software, the user must enable Discover New IP 
Nodes  from the shelf map Options menu in order for IP discovery to occur. 

• In some TEAM applications, the text label associated with the Help link does not
display. This does not affect the operation of the Help link.

• During installation of the TEAM software, the following error pop-up may appear
The xterm environment has not been set.  This error will prevent any 
windows from launching. To correct this, add the following the following comman
should be added to the $HOME/.cshrc  file:

xhost + HostName
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Section 4 - TEAM Applications and HP OpenView NNM
Scalable and Distributed Environments

1.0 Overview
This section briefly discusses the Scalability and Distribution features in NNM and ho
integrate/install TEAM applications in a Scalable and Distributed environment. Refer t
HP OpenView Manual, “A Guide to Scalability and Distribution for NNM” for more 
detailed understanding and concepts.

1.1 Features and Advantages
The Scalable and Distribution features of the HP OpenView NNM provide robust 
performance over a wide range of network sizes and degrees of complexity. 

The Scalable feature gives NNM the potential for handling networks of different size
both LAN and WAN environments. To make NNM scalable, the network manageme
work load must be distributed to multiple systems. Then, the Distribution feature impr
performance of NNM in large networks by reducing the amount of management traffic
network resources.

Advantages of these NNM features:

• The Scalable feature of NNM makes it easier to adapt network management for 
handling new networking landscapes.

• The Distribution feature minimizes the amount of network management traffic. 
Without this capability, it would be impractical to monitor thousands of nodes from
single workstation.

• Faster response times and better performance as work load is distributed to mul
workstations.

• Shared responsibilities reduces the risk of losing network management data in the
of an unexpected shutdown of the management station.

• One Common network management database (in most cases) for all users, so th
modifications of managed nodes would be reflected across the board.

Drawbacks/Trade-offs of these NNM features:

• Distribution of tasks requires an increased number of computing resources.

• Scalable and distributed environment requires added complexity in setup.
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1.2 Theory of Operation
In a Stand-alone environment, all network management tasks are done on a single 
workstation. In a Distributed environment tasks are handled by multiple workstations
Collection Station (CS), Management Station (MS), Management Console (MC). 
Depending on network size, structure, geography and trends, one of four deploymen
models should be chosen: Fully centralized, Centralized hierarchical, Hierarchical, o
operative independent.

• Figure 1 demonstrates a Centralized hierarchical model. Refer to the HP OpenV
manual for examples of other models and for choosing the model for your needs

• Figure 2 demonstrates the HP OpenView and TEAM processes and applications
run on the collection station, the management station, and the management con

1.2.1 The Collection Station
A collection station discovers nodes and forwards this information to the manageme
station. The collection station also monitors (the netmon process) the nodes in its do
and forwards any traps it receives from the managed node (IP device) to the manag
station. Depending on the number of managed nodes and network structure, there co
more than one collection station. The collection and management stations periodica
synchronize node and topology information. Figure 1 shows two collection stations fee
node and topology information to the management station. 

1.2.2 The Management Station
The management station processes the node and topology information it receives fro
collection stations and stores the information (via ovwdb) in a database. The manag
station also receives from collection stations the trap information for various manage
nodes (ovtrapd process) and stores it. There should only be one management statio
distributed setup so that the node information can be shared by all the users on vari
management consoles. 

1.2.3 The Management Console
The management console is where all the user processes are executed. User interfa
(application) processes like ovw, xnmevents, xnmsnmpconf are executed here in ord
manage the nodes in the management station’s database. The Management Console
be connected to the Management Station using an Ethernet LAN or a high speed ne
matching the speeds of LAN. Management Station and the Management Consoles w
share the same database by mounting the database over the Network Filing System 

1.2.4 Permissions
The first network operator to run ovw and launch OpenView screens will have read/w
permissions to the database. The rest of the operators will get read-only permissions
that read-only screens do not synchronize automatically with changes in network top
or with the addition or deletion of devices to the database. To resynchronize the enti
network map, network operators on the management console must manually perform 
Map -> Refresh Map  command. All network operators will be able to perform oth
TEAM Network Management operations, such as Configuration, Provisioning, 
Diagnostics. Operators must manage a unit in the shelf from only one workstation at a
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Figure 1: Example of the Centralized Hierarchical Model
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1.3 The Distribution of Processes and Applications
The sequence of events that occur end-to-end from the IP node to the management c
(Figures 1 and 2) is as follows:

Collection Station(s)

1. netmon  process begins IP discovery, and populates the local topology 
database(ovtopmdb ) with the help of ovtopmd  process.

2. After the completion of discovery, the topology information is accessible by the 
management station.

Management Station

3. The management station requests the collection station(s) for topology informatio
ovrepld  process.

4. Upon obtaining the topology information (from all collection stations), the 
management station merges the data into its topology database. 

5. Using the data in the topology database, the processes in the management sta
communicate with each node to update other information necessary to manage
node.

6. Periodically, the ovrepld processes on the collection station(s) and managemen
station synchronize the topology data. Once synchronization is complete, only 
changes in status and topology get sent to the management station.

Management Console and Management Console X Term Server

7. After the management station is ready with node information, the ovw process c
run.

8. Once ovw is up and running, network management on various nodes can be do

Note: When one of the management consoles is also designated as a X-Term Server, 
X-Terminals (such as Tektronics Graphics terminal) could be setup to display ovw 
sessions on these terminals. The ovw sessions are actually executed on the manag
console but displayed on the X-Terminals.
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2.0 Integrating the TEAM Application in a Distributed Environment
Due to distribution of tasks in a  distributed environment, TEAM software products m
be installed on the collection station, the management station and the management c
in the precise order as described in Sections 2 and 3 of these TEAM Core Release N
The following sections describe the dependency tree, discovery, and event handling
GDC devices for TEAM software products.

2.1 TEAM Software Product Dependency
To manage any GDC product using TEAM software, multiple software products are 
required. Figure 3 shows the dependencies among various products. In the example
SC521 and SC553 cards along with their associated packages are being managed b
TEAM521 and TEAM553. Both TEAM products are dependent upon TEAM Core. 
Because of this product dependency, TEAM Core must be installed on the workstati
before installing TEAMSC521, etc. 

. 

Figure 3: TEAM Software Product Dependencies
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TEAM553 TEAM521

GDCSC521
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2.2 Discovery in an HP OpenView Distributed Environment
Once TEAM software is installed and configured in an HP OpenView NNM distribute
environment, the system is ready for network management of GDC devices. This be
with the discovery of a GDC device on the management console where it is managed.
of the typical applications that are executed on the management console are shown
Figure 2. The sequence of events that occur end-to-end is as follows:

1. A GDC device is discovered by a collection station and gets stored in its topolog
database. 

2. This discovery information is requested by the management station in a 
synchronization cycle of ovrepld  process.

3. The management station adds the device into its database as a new node.

4. Once a new node gets added on the management station, the shelf_discovery  
gets notified of the change. 

5. The Shelf_discovery  process communicates with the SCM to get the shelf 
contents and other relevant information and stores the information.

6. After a GDC shelf is discovered, a new shelf gets added to the TEAM universe 
submap.

7. From this submap various GDC devices can be managed.

2.3 Event Handling
A trap generated from a GDC device arrives at the management console where it is up
The sequence of events that occur end-to-end is as follows:

A. When SCM is set up to do so, a GDC device sends a trap to the collection sta

B. The collection station then forwards the trap to the management station, whe
gets processed by shelf_discovery  process and notifies the shelfmap pro-
cess on the management console.

C. The shelfmap process updates the status of the device associated with the e
Note that one process runs for every ovw session.
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