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Starting Shorthand
Start Shorthand as you would any Windows applications by clicking its icon from within the 
Windows Program Manager.

Shorthand automatically loads the last dictionary file used.    If you wish to use another 
dictionary, select File | Open or File | New.



Running Shorthand in the Background
Run Shorthand in the background by clicking on the Hide button.    

Pressing ESC or clicking on the minimize button on the main window's title bar does the 
same thing as clicking on the Hide button.

Once Shorthand is in the background, it monitors every keystroke you make; when the hot 
key is detected, Shorthand will activate itself.



Activating Shorthand
Shorthand must be running in the background.

To activate Shorthand from within your word processor, type the hot key character.



Specifying The Text To Type
In the Keyword box, enter the keyword of the text you wish Shorthand to type for you.    The
text associated with the keyword appears in the Text to Type box.

Alternative Method:    In the Dictionary List box, highlight the desired text by clicking on it.    
The selected text appears in the Text to Type box.



Typing Text Into Your Word Processor
Shorthand must have been activated from within your word processor by the pressing the 
hot key.    

IMPORTANT!
Shorthand loses the ability to type text into your word processor if Shorthand loses the 
focus (that is, when it ceases to be the active application).    This can occur if you click on 
another application's window or request help.    To regain the ability to type text, reactivate 
Shorthand by sending it to the background and typing the hot key character.

The text that Shorthand will "type" into your word processor is displayed in the Text To Type
box (see "Specifying the Text to Type.")

To command Shorthand to type the text into your word processor:

Click the Type It button.

-OR-

With the focus in the Keyword box (the text caret must be blinking in the Keyword box), 
press ENTER.    (NOTE:    The Keyword box automatically receives the focus whenever 
Shorthand is activated.) 

-OR-

Double-click on the text item in the Dictionary list box.



Introduction
What is Shorthand?
Shorthand is a typing productivity tool designed to work concurrently with a Windows word 
processor or text editor application.    In the same way stenographers use shorthand 
symbols to quickly jot down text, Shorthand allows you to replace frequently used words or 
phrases with a much shorter abbreviation or keyword.      Instead of typing in the word or 
phrase, you type the shorter keyword and Shorthand will take care of inserting the longer 
word or phrase into your word processor.      Shorthand is not limited to word processors.    It 
works just as well with most Windows dialog boxes.    For example, do you have a file which 
you use a lot?    Enter its filename and a keyword into Shorthand's dictionary.    The next 
time you need to specify the filename in an application's File Open or File Save dialog box, 
just activate Shorthand, type the keyword and Shorthand will type the filename for you!

How does Shorthand work?
You execute Shorthand as you would any Windows application.    Shorthand waits in the 
background until you need it.    You start your word processor and begin typing normally.    
When you need to use Shorthand, you simply type a hot key and Shorthand pops up and 
takes control.    You specify the text you want Shorthand to type for you by entering a 
keyword or using the mouse to select the text from a list. 

What's the difference between Shorthand and my word processor's macros?
Shorthand and your word processor's macros have the same purpose--to reduce the 
number of keystrokes you need to type commonly used words.    Shorthand has the 
advantage that it is not tied to a single word processor--you can use it with just about every
Windows word processor, text editor, and even with text edit boxes within dialog boxes.    
Shorthand is designed to be much easier to use than the macro abilities of most word 
processors (which usually requires programming); much work has gone into designing a 
user interface that is readily usable by both touch typists and "hunt-and-peck" typists.    

What are the limitations of using Shorthand?
The only shortcoming of Shorthand is that you are limited to ASCII characters; Shorthand 
presently has no support for inserting function keys, numeric keypad keys, cursor keys, 
CTRL or ALT key combinations.



The hot key character is a special character you type from within your word processor to 
call Shorthand into action.    Shorthand must be running in the background for the hot key 
to work.



The keyword is a word up to 8 characters long used as an alias or abbreviation to a longer 
word or phrase.



In Windows, all mouse and keyboard input are sent to the window with the "focus."    Text 
edit boxes that have the focus have a blinking caret that specifies where the next character
is to be inserted.    The window that has the focus has its title bar highlighted.



You can highlight an entry in the Dictionary list box in one of three ways:    (1) Click the 
entry with the left mouse button.    (2) Press TAB until you are in the Dictionary list box, then
use the cursor up/down keys to scroll through the list.    (3) Enter the the entry's keyword in 
the Keyword box.
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The Main Window
The Main Menu
File Provides functions to create, open, and save dictionary files.    In addition the

change preference function is located here.
Dictionary Provides functions to add, modify or remove dictionary entries.
Help Provides help and program information functions.

Text Edit Boxes
Keyword Enter the keyword of a dictionary in this box.    The Keyword box is enabled 

only if Shorthand was activated from within your word processor.
Text To Type The text associated with the keyword you entered or selected in the 

Dictionary list box appears in the Text to Type box.    You cannot edit the text
in this box.    The Text to Type box is enabled only if Shorthand was activated
from within your word processor.

List Box
Dictionary Displays keywords and their associated text.

Buttons
Type It Click this button to command Shorthand to "type" the contents of the Text 

to Type box into your word processor.    This button is enabled only if 
Shorthand was activated from within your word processor.

Hide Click this button to tell Shorthand to minimize itself and wait in the 
background for the hot key character.



The Dictionary
Shorthand maintains a "dictionary" which is a list of keywords and their associated text.      
There is a limit to the number of entries (32 for Shorthand 1.0)    you can add to the 
dictionary.    Select "About Shorthand..." from the Help menu to display the amount of 
dictionary memory available to you.



The Status Bar
The Status Bar is located at the bottom of the Main Window.    It displays context sensitive 
help and the currently hot key character.



Using the Right Mouse Button
You can use the right mouse to button to bring up context-sensitive popup menus.

Clicking the right mouse button anywhere inside the Dictionary list box brings up a menu 
for adding, modifying or removing dictionary entries.



Effect of the CAPS LOCK, SHIFT, CTRL Keys
The text in the Text to Type box is inserted into your word processor as it appears in the 
Text to Type box, regardless of the state of the CAPS LOCK, SHIFT and CTRL keys.



Compatibility Issues
Shorthand is designed to work with Windows Version 3.1.    It does not make use of 
undocumented Windows features, so it should work as well with later Windows versions.

Shorthand works with any Windows application that uses the normal Windows keyboard 
messages as input.    Applications that takes its input directly from the keyboard hardware 
interrupt (such as DOS applications) will not work with Shorthand.

Shorthand uses the Windows hooks mechanism to insert characters into the keyboard 
message queue.    Shorthand may be incompatible with applications that use the Windows 
keyboard hooks to translate or playback keyboard characters.



Creating a New Dictionary
Selecting "New" from the File menu creates a new dictionary.



Opening a Dictionary File
Selecting "Open..." from the File menu opens and loads a dictionary file.



Saving the Dictionary
Selecting "Save" from the File menu saves the dictionary to a disk file.



Renaming the Dictionary
Selecting "Save As..." from the File menu saves the dictionary to another disk file.



Exiting Shorthand
Selecting "Exit" from the File menu terminates the Shorthand application.



Adding a New Dictionary Entry
Selecting "Add" from the Dictionary menu brings up the Add a New Dictionary Entry dialog 
box.



Modifying an Existing Dictionary Entry
Selecting "Modify" from the Dictionary menu brings up the Modify Dictionary Entry dialog 
box.



Removing an Existing Dictionary Entry
Selecting "Remove..." from the Dictionary menu will delete the selected (highlighted) entry 
in the Dictionary list box.

There are two alternate methods to delete an entry from the dictionary:

Highlight the desired entry to delete in the Dictionary list box then press CTRL+R from your
keyboard to delete it.

-OR-

Highlight the desired entry to delete in the Dictionary list box then click the right mouse 
button anywhere inside the Dictionary list box and select "Remove... " from the popup 
menu.



Editing the Dictionary
Adding a New Dictionary Entry
Modifying an Existing Dictionary Entry
Removing an Existing Dictionary Entry



Preferences
Selecting "Preferences..." from the File menu brings up the Preferences dialog box.



The About Shorthand Dialog Box
Selecting "About Shorthand..." from the Help menu brings up a dialog box that displays 
copyright information and the amount of resources available.



The Add a New Dictionary Entry Dialog Box
This dialog box allows you to add a new keyword and its associated text to the dictionary.

There are several ways to bring up the dialog box:
1. Select "Add..." from the Dictionary menu.

-OR-
2. Press CTRL+A from your keyboard.

-OR-
3. Click the right mouse button anywhere in the Dictionary list box, and select "Add... " 

from the popup menu.

Keyword
Enter a unique keyword (up to 8 characters) in the Keyword box.    If you enter a keyword 
that already exists in the dictionary, an error message will be displayed.

Text
Enter the text that is to be associated with the keyword in the Text box. You can enter up to 
80 characters for Shorthand Version 1.0.

Browse Button
Click this button to bring up the Select File dialog box.    The file you select will have its 
filename inserted in the Text box.



The Modify Dictionary Entry Dialog Box
This dialog box allows you to add a modify a keyword or its associated text in the 
dictionary.

There are several ways to bring up the dialog box:
1. Highlight the desired entry to modify in the Dictionary list box and then select 

"Modify..." from the Dictionary menu.
-OR-

2. Highlight the desired entry to modify in the Dictionary list box and then press CTRL+M
from your keyboard.

-OR-
3. Highlight the desired entry to modify in the Dictionary list box and then click the right 

mouse button anywhere inside the Dictionary list box and select "Modify... " from the 
popup menu.

Keyword
You can change the keyword in the Keyword box.    If you enter a keyword that already 
exists in the dictionary, a warning message will be displayed.

Text
Enter the text that is to be associated with the keyword in the Text box.    You can enter up 
to 80 characters for Shorthand Version 1.0.

Browse Button
Click this button to bring up the Select File dialog box.    The file you select will have its 
filename placed in the Text box.



The Preferences Dialog Box
Selecting "Preferences..." from the File menu brings up a dialog box that allows you to 
change the hot key character and edit sound options.

Hot Key Character
Select the hot key character from the list.

Beep When Hot Key Pressed
When this option is checked, the PC speaker will beep whenever you hit the hot key to 
activate Shorthand.

Beep When Typing Empty Text String
When this option is checked, the PC speaker will beep when Shorthand has nothing to type 
(that is, when there is no text in the Text to Type box; this can occur if you enter a non-
existent keyword and press the ENTER key).




