
Introduction

      The purpose of dtSearch is to quickly find the information you need from hundreds or
thousands of documents on a PC, network or CD-ROM. 

      Load dtSearch on your file server to give network users instant access to company 
archives, policy manuals, etc.    Or create your own instant database from downloaded 
text.    Fuzzy and phonic searching make dtSearch convenient for text with OCR or 
typographical errors. 

      dtSearch works by building an index that stores the location of words in your files.    
Once dtSearch has created an index, you can search through megabytes in a second.    
Since you will sometimes want to search files dtSearch has not indexed, dtSearch also 
does unindexed and "combination" searches across multiple directories, drives and 
indexes. 

      dtSearch has unlimited capacity.    You can create an unlimited number of indexes, 
each holding up to 15,000 files of any length.    dtSearch can search up to 25 indexes 
with a single search request.    A scrolling list shows the words in any index for easy 
search formation.    Search options include: 

Boolean (AND, OR, NOT); 
phrase (apple sauce or chocolate cake); 
wildcard (appl* sau?e and not cho*olate ca?e); 
proximity (appl* w/5 pear); 
segment (dear to sincerely contains John); 
macros (@ADDRESS contains elm street); 
file name/date; 
fuzzy (for text with typographical or scanning errors); 
phonic (to find similar-sounding words like principal for principle and Smythe for 
Smith); and 
stemming (to search for apply and find applies, applied and applying). 

      After a search, dtSearch provides a range of options for collecting and viewing 
retrieved documents.    dtSearch will sort search results by document name, date, or 
number of hits (relevance).    Users can browse retrieved files, jump directly to hits, or do
a "search within a search" for other text. 

      dtSearch also generates search reports displaying each hit with the amount of 
context you request.    dtSearch automatically inserts hypertext links so you can jump 
back and forth from your search report to the location of hits in the full documents. 

      dtSearch provides multiple options for using the information you find in a search.    
Cut, paste, annotate, edit or "launch" a file in its own word processor from within 
dtSearch.    Tag files to print, copy or include in a search report. 



      Advanced users can take advantage of dtSearch's DDE interface (Windows version) 
and extensive batch script language to integrate dtSearch with other software and 
automate indexing and searching.    dtSearch will even create a batch script.    Other 
advanced user options include the creation of hypertext-linked databases and archive 
indexing.    For developers interested in customizing dtSearch for CD-ROM or disk 
publication or for use as a front-end on a BBS, DT Software offers a    Developer's 
Toolkit for Electronic Publishers. 

      dtSearch automatically recognizes all major word processor file formats. 

      dtSearch provides extensive support for non-English text.    Users can customize the 
alphabet dtSearch uses to index and search files, the noise word list, and the stemming 
rules. 

      dtSearch's file server version runs on all major PC-based networks. 

      This manual covers both dtSearch for DOS and dtSearch for Windows.    As much as
possible, the menu options and dialog boxes in dtSearch for DOS and dtSearch for 
Windows are the same.    dtSearch for DOS and dtSearch for Windows use exactly the 
same file formats, so you can use the same indexes and setup files for both versions. 



System Requirements

 
      dtSearch for Windows requires Microsoft Windows version 3.1 or later, a 386 or 
higher processor, and at least 2 megabytes of memory (4 megabytes recommended). 

      dtSearch for DOS requires DOS version 3.3 or later, a 286 or higher processor, and 
at least 2 megabytes of memory.    dtSearch for DOS uses a DOS extender, which 
allows it to use memory above the lower 640k.    On systems with 2Mb of memory or 
more, this eliminates problems running dtSearch in low-memory environments. 

      The DOS extender used in dtSearch for DOS is compatible with nearly all DOS 
environments in use today.    Most users should be able to simply run dtSearch for DOS 
without altering their system configuration at all. If you experience problems, such as an
"Insufficient Memory" message, see the README file included with dtSearch for a 
detailed discussion of compatability issues.    The most common problems are 
discussed below: 

      2 Mb systems 
      If your system has exactly 2 Mb of memory and you are using a disk-caching 

program such as SMARTDRV or PC-CACHE, the cache may not leave enough 
memory for dtSearch to run.    Try reducing the cache size to 256k. 

      EMM386.EXE 
The DOS extender in dtSearch is incompatible with one specific EMM386 
setup: the version of EMM386 included with DOS 5.0 or Windows 3.1, when 
used with the NOEMS parameter.    If you encounter this problem, edit your 
CONFIG.SYS file and look for a line like the following: 

DEVICE=C:\DOS\EMM386.EXE NOEMS 

            Change NOEMS to FRAME=NONE, like this: 

DEVICE=C:\DOS\EMM386.EXE FRAME=NONE 

      This problem has not appeared in more recent versions of EMM386.EXE. 

      QEMM.SYS 
Some versions of QEMM have the same problem as the DOS 5 version of 
EMM386: "NOEMS" does not work with dtSearch, so just change "NOEMS" in 
your CONFIG.SYS to "FRAME=NONE." 





Using dtSearch on a Network

Running dtSearch from a Shared Directory 

      To run dtSearch from a shared directory, install dtSearch on a directory that each 
user will have read-only access to.    Use the DOS ATTRIB command to make each file 
read-only.    (This avoids sharing violations on some networks.) 

      Each user will need a private, writable directory that dtSearch can use for temporary 
files and to store the user's setup files.    This directory cannot be shared.    The easiest 
solution is for each user to use a directory on his or her own local hard disk (such as C:\
DTSEARCH) as a private dtSearch directory.    The private directory can be on a 
network drive, but each user must have a separate private directory. 

      You can tell dtSearch what the private directory for a user is either through a 
command-line switch (/DIR) or an environment variable (%DTSDIR%). 

1.    /DIR Command-line switch 

      To tell dtSearch to use C:\DTSEARCH as the private directory, execute dtSearch with
the /DIR switch, like this: 

DTSEARCH /DIR C:\DTSEARCH 

The /DIR switch also works with dtSearch for Windows.    In Program Manager, set up 
the dtSearch for Windows program item as follows: 

Description:                      dtSearch for Windows 
Command-line:                    DTSWIN /DIR C:\DTSEARCH 
Working directory:          C:\DTSEARCH 

      If you want private directories to reside on the network, and if your network is set up 
with an environment variable containing each user's name (%USER% or %USERNAME
%), you can use that environment variable with /DIR, like this: 

            DTSEARCH /DIR H:\%USER%\DTSEARCH 

This makes it possible for each user to have a private directory on the shared H: drive. 

2.    %DTSDIR% environment variable 

      An alternative to the /DIR command-line switch is to designate a private dtSearch 
directory by setting the %DTSDIR% environment variable in each user's 
AUTOEXEC.BAT file, like this: 

            SET DTSDIR=C:\DTSEARCH 



 Shared Setup Files 

      dtSearch looks for setup files in each user's private directory first and, if it does not 
find a file there, it checks the shared dtSearch directory.    When dtSearch saves a setup
file, it writes the file to the user's private directory. 

      This makes it easy to set up all users with a common initial configuration that they 
can then customize to suit individual preferences.    To set up the initial configuration, do 
the following: 

1. Run dtSearch directly from the shared network directory without the /DIR option, so 
all setup files will be stored in that directory. 

 2.Set up the configuration you want. 

3. Exit dtSearch. 

4. Use the DOS ATTRIB command to make the files in the dtSearch directory read-
only. 

      See "Setup Files" for a list of dtSearch setup files. 

      If your network stores user names in an environment variable such as %USER% or 
%USERNAME%, enter this variable under User Name in the Preferences dialog box.    
dtSearch uses the User Name for informational purposes (for error messages) and is 
not required for network operation. 

Shared indexes and documents 

      dtSearch can use network drives and supports multiuser access to indexes stored on
networks.    If an index is stored on a network drive, any user who has write access to 
the directory containing the index will be able to update the index in dtSearch.    Any 
user who has read access to the index will be able to search the index or perform other 
functions (such as Verify Index and Copy Index) that do not require write access. 

      Multiuser access is permitted only when no one is modifying an index. If one user is 
updating or compressing an index, other users will be locked out.    For this reason, write
access to shared indexes should be limited as much as possible, preferably to one or 
two users.    This will minimize locking out of other users while the index is being 
updated and will also protect the shared indexes from accidental erasure.    Write and 
read access to shared indexes is controlled completely by the network's access 
permission settings. 

      dtSearch stores directory information using relative paths rather than absolute paths. 
This makes it easy to avoid drive mapping problems: just keep each index on the same 
drive as the documents indexed.    See "Relative Paths" in the "Working with Indexes" 



chapter for more information about this feature. 





Quick Start -- Overview

      This section of the manual is intended to help you get started using dtSearch (either 
the DOS or the Windows version).    It explains very briefly how to search with and 
without a document index and how to build an index.    Each of these subjects is 
covered in more detail in the rest of the manual. 

      Before you begin, you should install dtSearch on your hard disk.    You should also 
have some documents on your hard disk to index and search. 

      dtSearch can perform three types of searches:    index, unindexed, and combination: 

* An index search uses a document index to quickly identify documents that satisfy a 
search request.    A document index is a type of database that dtSearch builds from 
a collection of documents.    The database tells dtSearch where each word appears 
in each document, so that dtSearch can find documents containing a particular word
or combination of words very quickly. 

* An unindexed search reads each file to be searched and checks whether it satisfies 
a search request.    Unindexed searches are much slower than index searches but 
are useful as a way to include recently-created documents in a search. 

* A combination search is a search that combines an index search with an unindexed 
search. 

Using menus, dialog boxes and help 

      When you start dtSearch, you will see the main menu bar at the top of the screen.    
The menu bar at the top of the screen lists:    File, Edit, Search, Index, Window, Options,
Help.    Each of these is the name of a menu.    To access a menu, move the cursor to 
the one you want and press ENTER or click on it with the mouse.    A "pull-down" menu 
will appear below the menu bar at the top of the screen.    To select an item from the 
menu, move the cursor to the one you want and press ENTER or click on it with the 
mouse.    As you move the cursor to each option in a menu, a line at the bottom of the 
screen will briefly describe what the menu option does. 

      If you are viewing a document or search results, you can get to the main menu in any
of the following ways: 

* Press F10. 

* Click on the main menu with the mouse. 

* Press ALT + the first letter of any of the menu options (for example, ALT-F to get into
the File menu). 



      Most actions in dtSearch involve a dialog box, which is simply a box that appears on 
the screen listing information dtSearch needs in order to perform an action.    Dialog 
boxes are explained in more detail below.    For now, here is all you need to know to use
dialog boxes in dtSearch (both the DOS and Windows versions): 

* If you have a mouse, you can select anything in a dialog box by clicking on it with 
the mouse. 

* To select or unselect something using the keyboard, press SPACEBAR. 

* To move to the next item in a dialog box, press TAB.    To move back to the previous 
item press Shift-TAB. 

* If an item in a dialog box has a highlighted letter in it, you can press ALT + the letter 
to get to that item quickly. 

* In a list of options, use the arrow keys to move the cursor. 

* Press ESCAPE (or choose the Cancel button) to get out of a dialog box without 
doing anything. 

* Choose the OK button to do whatever the dialog box does. 

      To get help, just press F1 and use the cursor keys to move around the help screen 
that appears.    See the manual section on help for more information. 



Quick Start -- Unindexed Search

1. Choose Search in the main menu. 

2. Choose Unindexed Search.    The "Unindexed Search" dialog box will appear.    This 
dialog box allows you to specify what you want to search for and where you want to 
search. 

3. Choose Search Request to enter your search request.    A basic search request 
consists of the words or phrases you want to search for, connected by: 

              AND both words must be present 
              OR at least one of the words must be present 
              NOT the next word must not be present (use with AND or OR) 
              W/5 the words must occur not more than 5 words apart (you can use other 

numbers, such as W/10, W/20, etc.) 

              Examples: 
              apple and pear 
              apple w/5 pear 
              apple sauce w/5 grape juice 
              apple and (pear w/5 banana) 
              apple and not pear 

4. Choose the Select Directories button to select the directories you want to search.    
A diagram of all of the directories on the current disk drive will appear.    To select a 
directory, press SPACEBAR or click on it with the mouse.    To select a directory and
its subdirectories, press the plus ("+") key on the numeric keypad or double-click it 
with the mouse. 

To see another disk drive, press CTRL + the letter of the drive you want, or use the 
mouse to click on the drive letter in the list of drives next to the directory tree.    After 
you are done selecting directories, choose OK to save your selections. 

5. Choose OK to start the search. 



Quick Start -- Viewing Search Results

1. After a search is complete, a short menu will appear listing options for sorting 
search results (sort by name, date, number of hits, etc.). Pick one of the options, 
and the results of your search will appear in a window. 

2. To view a document, move the cursor to the document you want and press ENTER, 
or double-click with the mouse on the name of the document.    The document will 
appear in another window, overlaying the first. 

3. To see the hits in a retrieved document, press F3.    (In dtSearch for Windows, you 
can also use the Hit button.) 

4. To close a window displaying a document or search results, press ESCAPE.    To 
leave the window open and switch to another window, press TAB or click on the 
other window with the mouse. 



Quick Start -- Indexing Documents

First, create an empty index: 

1. Choose Index in the main menu and then choose choose Create Index (Basic) in 
the Index menu. 

2. Enter the name of the index you want to create. 

3. Choose OK to create the index. 

Next, add documents to the index: 

1. Choose Index in the main menu and then choose Add Documents to Index in the 
Index menu. 

2. In the Select Index box, move the cursor to the index you want to add the 
documents to. 

3. Choose Select Directories to select the directories containing the files you want to 
index.    The directory selection box that appears works just like the one described 
above in "Searching without an index." 

4. Choose OK to start adding documents to the index. 



Quick Start -- Index Search

1. Choose Search in the main menu. 

2. Choose Index Search. 

3. Under Search Request, enter your search request. 

4. Choose Select Indexes and check off indexes to search. 

5. Choose OK to start your search. 

6. See "Viewing Search Results," above. 









Help on Help 

      When you are in a menu, a line of text at the bottom of the screen will briefly explain 
the purpose of each menu option as you move the cursor to it. 

      If you need more information about a dtSearch feature, you can access the hypertext
help system at any time by pressing the F1 key or by choosing Help from the main 
menu.    The help system provides a comprehensive manual, with an index and table of 
contents, that explains all of the features of dtSearch. 

      When you press F1, an explanation of the current function or menu option will 
appear.    You can use the cursor keys to scroll through the help message. 

      At the top of the help screen you will see a button bar listing the following options: 

Contents View help table of contents 
Search Search for a topic by keyword. 
Back Go back to a topic you were viewing earlier. 
History View list of topics you previously viewed. 
<< Go to the previous topic in the help file. 
>> Go to the next topic in the help file. 

      Some help topics contain hypertext links to other topics.    These links will appear as 
highlighted words.    To use a hypertext link, press TAB to move the cursor to the 
highlighted word and press ENTER, or click on the highlighted word with the mouse. 

      The help index is a list, in alphabetical order, of all of the help topics.    To see the 
help index, choose Index from the Help menu.    The table of contents is like the index 
except that it is organized like the table of contents of a book.    To see the table of 
contents, choose Contents in the Help menu.    In the index and table of contents, press 
TAB to see a highlighted bar marking the currently selected topic.    To move the bar, use
the TAB key.    Press ENTER or click with the mouse to see the selected topic. 



What is a Document Index?

      A document index is a database that stores the locations of all of the words in a 
group of documents, except for noise words such as "but" and "if."    Once you have built
an index for a group of documents, dtSearch can use it to perform very fast index 
searches on those documents. 

      A document index is usually about one fourth the size of the original documents, 
although this may vary considerably depending on the number and kinds of documents 
in the index.    However, to build an index, dtSearch needs free space (on the drive 
containing the index) at least equal to the size of the documents to index.    This is 
because dtSearch creates temporary files during indexing. 

      To build an index of a group of documents: 

1. Choose Create Index in the Index menu to create an empty index, and 

2. Choose Add Documents to Index in the Index menu to add documents to the index. 



Index Menu

Choose Index in the main menu to get into the Index menu.    This menu lists options to 

      * create an index, 
      * create an index using advanced options, 
      * add documents to an index, 
      * compress an index, 
      * create or execute a batch script 
      * rename, copy, delete, or recognize an index, 
      * display information about an index, 
      * verify that an index is not damaged, 
      * list the words in an index, and 
      * create or change index libraries. 



Creating an Index

      There are two ways to create an index in dtSearch:    a "basic" version and an 
"advanced" version. 

Create Index (Basic) 

      Choose Create Index (Basic) in the Index menu to create a new index. A dialog box 
will appear containing a single space to fill in for the name of the index.    Enter any 
combination of letters, numbers or punctuation up to 16 letters long.    Choose OK to 
create the index. 

Note:    If you "create" an index that already exists, you will clear the previously existing 
index (the documents will, of course, be unaffected).    dtSearch will ask you to confirm 
that you really want to do this. 

Create Index (Advanced) 

      Choose Create Index (Advanced) in the Index menu if you want to use the advanced
options listed below: 

Path 
This allows you to specify the directory where dtSearch will store the index.    If you 
leave this blank, dtSearch will create the index in a subdirectory of the dtSearch 
directory.    If you enter a directory name, the name should be different for each 
index.    dtSearch will create a new directory for the index using the name that you 
supply.    (The path does not have to be a subdirectory of your dtSearch directory.) 

Store text with index 
Set this checkbox if you want to create an archive index, which contains the text of 
indexed documents in compressed form.    (See "Archive Indexes," below, for 
additional information on this option.) 

Case sensitive index 
Set this checkbox if you want dtSearch to take capitalization into account in 
indexing words.    In a case sensitive index, "APPLE," "Apple," and "apple" would be
three different words.    For most users, this would be a very bad idea since most 
users would like to retrieve a document containing "Apple" in a search for "apple."    
This option is useful mainly for programmers who want to index case-sensitive 
source code. 

Accent sensitive index 
Set this checkbox if you want dtSearch to take accents into account in indexing 
words.    In an accent sensitive index, "eclair" and "eclair" are two different words.    
Again, for most users this is not a good idea, since this option increases the chance 
that you will miss retrieving a document because an accent was omitted in one 



letter.    In an accent insensitive index, accents are stripped from letters according to
the rules set up in your dtSearch alphabet file.    See the manual section on the 
dtSearch ALPHABET utility for more information on this feature. 



Adding Documents to an Index

      To add documents to an index, choose Add Documents to Index in the Index menu.    
The Add Documents to Index dialog box will appear.    In the upper left corner there will 
be a list of the indexes you have created. Pick the index you want to use from this list.    
Below is a brief summary of the options in the Add Documents to Index dialog box.    
These options are discussed in more detail in the rest of this chapter. 

Select Directories 
To select directories to be indexed, choose the Select Directories button.    The 
"Select Directories" dialog box will pop up.    Check off the directories you want to 
index and choose OK to save your selections.    The directories you selected will be 
displayed in the Add Documents to Index dialog box. 

Filename Filters 
Under Filename Filters, enter file name filters (e.g., *.DOC, *.TXT, etc.) to use to 
select documents to add.    If you leave this field blank, dtSearch will index all of the 
files in the directories you selected. 

 Under Exclude Filters, enter filters for any files you do not want to include in the 
index. 

Compress Index 
Check this box if you want dtSearch to compress the index after adding documents. 
Compressing an index can take a while, especially with very large indexes, but it 
makes searches much faster.    You can also compress an index using the 
Compress Index option in the Index menu. 

Update Files in Index 
Check this box if the index already contains some documents, and you want 
dtSearch to reindex any documents that have been changed.    dtSearch will check 
every document in the index and, if the document has been edited, will reindex the 
document.    If the document no longer exists, dtSearch will remove it from the 
index. 

Clear Index 
Check this box if you want dtSearch to "clear" the index before indexing.    "Clearing"
an index is essentially the same as re-creating it.    All information in the index will be
erased. 

      When you are ready to begin indexing, choose OK. 

      In most cases, you will not have to worry about the file format of the documents 
being indexed because dtSearch will detect the format of each document automatically. 
However, some older word processor formats cannot be detected automatically.    
XyWrite, WordPerfect 4.2 and WordStar versions before version 4.0 fall into this 
category.    To tell dtSearch how to recognize such documents, choose File Types in the 



Options menu. (See the section on "File Types" in the "Options" chapter for more 
information about this feature.) 

Tip:    If you are indexing documents stored on floppy disks, you may find it useful to 
store the documents on each disk in a subdirectory named after the disk.    For example,
if you have disks labelled "SMITH" and "JONES," move the documents on the SMITH 
disk into a directory called "SMITH," and move the documents on the JONES disk into a
directory called "JONES."    This will help you to locate the documents after a search.    
You can see which disk has the documents you want by looking at the directory name in
the search results window. 



Selecting Directories to Index

      The Select Directories to Index dialog box allows you to pick the directories you want
dtSearch to index from a list of all of the directories on your computer.    The left side of 
the dialog box displays all of the directories on one disk drive, with a check box next to 
each directory name.    The right side of the dialog box lists all of the disk drives you can
access. 

* To select a directory, click on it with the mouse, or move the cursor to it and press 
SPACEBAR. 

* To select a directory and its subdirectories, double-click it with the mouse, or move 
the cursor to it and press + (the plus sign). 

* To change disk drives, click on the drive letter with the mouse, or hold down the 
CTRL key and press the letter of the drive you want (for example, CTRL-D to switch
to drive D). 

* To clear all selections for the current drive, choose the Clear Drive button.    To clear 
all selections for all drives, choose the Clear All button. 

* To update the list of directories for a drive, choose the Reread Drive button.    
Reading the list of directories for a drive can be time-consuming.    To save time, 
dtSearch keeps a copy of the directory tree for each drive and only updates it when 
you tell it to (by choosing this button).    You should do this whenever you create a 
new directory and want to be able to index documents in that directory. 

When you are done selecting directories, choose OK to save your selections. 



Filename Filters

      A filename filter is a pattern, like *.*, *.DOC, or FILE??10.DAT, that you can use to tell
dtSearch which files you want it to search or index in a directory.    For example, if you 
have a directory of word processing files, and want to search all of the files beginning 
with SMITH and having the extension DOC, you would use the filter SMITH*.DOC. 

      A "?" matches any single character, so SMITH?.DOC would match SMITH1.DOC, 
but not SMITH123.DOC. 

      An asterisk ("*") in a file name filter matches any number of characters, so 
SMITH*.DOC would match SMITH001.DOC, SMITHAAA.DOC, etc. 

      To use more than one filter, just list the filters, separated by spaces.    Example: 

            SMITH*.DOC    JONES*.DOC    *.DAT 

      If you do not specify a filename filter, dtSearch will index all of the files in the 
directories selected. 

      "Exclude" filters work the same as ordinary filters.    They just specify files that you do
not want to include. 



Compressing an Index

      When you reindex a document that you have previously indexed, dtSearch marks the
information about the old version of the document as "obsolete" but does not remove it 
from the index.    Compressing an index removes this obsolete information from the 
index. 

      Even if you have not reindexed any documents, compressing an index may still be 
useful if you have built the index in several separate indexing jobs.    Compress will 
reorganize the index for faster searching.    If you have built an index in a single indexing
job, compressing it will have no effect. 

The major disadvantage of compressing an index is that it can take a long time, since 
dtSearch rebuilds the entire index when it compresses it. 

      There are two ways to compress an index. 

* First, you can tell dtSearch to compress an index after adding documents to it.    To 
do this, check the Compress Index option in the Add Documents to Index dialog 
box. 

* Second, you can choose Compress Index in the Index menu, select the index you 
want to compress, and choose OK. 

      When dtSearch is compressing an index, you can halt compression by pressing the 
Cancel button.    When you halt compression, dtSearch will restore the index to its 
uncompressed state. 



Index Capacity

      A document index can contain up to 15,000 documents.    If you try to add more than 
15,000 documents to an index, you will get an "Index is Full" message.      However, you 
will still be able to reindex documents that are already in the index.    When dtSearch 
reindexes a document that is already in the index, it treats the document as a new 
document and marks the old version of the document in the index as "obsolete."    When
you compress an index, obsolete documents are removed.    If the total number of 
documents, including obsolete documents, exceeds 30,000, then you will have to 
compress the index before you can update it. 

      An index library is a collection of up to 25 indexes.    Most people will only need a few
indexes and so will not have to learn about index libraries.    By default, dtSearch uses 
an index library called "IXLIB.ILB".    If you need to use more than 25 indexes, then you 
can create additional index libraries.    See the chapter on "Working with Indexes" for 
information about how to do this. 



Indexing Binary Files

      By default, dtSearch will index and search all files you have selected to be indexed.   
If a file is in a format that dtSearch does not recognize, dtSearch will index everything in
the file, character by character, as if it were text.    This can add a lot of garbage words 
to your indexes.    These garbage words will make the index larger and will slow 
indexing and searching. 

      There are four ways to avoid indexing garbage words in binary files: 

      (1) Keep text files in separate directories and only index files in those 
directories. 

When you are indexing files, use filename filters to selectively include text 
files or exclude binary files.    For example, if all of your WordPerfect 
documents have names ending in .DOC, you could index "*.DOC". 

      (3) Choose Preferences in the Options menu and check the Do not index 
binary files checkbox in the Preferences dialog box.    Files that dtSearch 
interprets as being binary will be ignored.    Files in a word processor format 
that dtSearch does not recognize will be interpreted as binary and ignored. 

      (4) Use the "Filtered Binary" file type.    A "Filtered Binary" file is indexed using 
an algorithm that attempts to distinguish text from non-text data.    The 
algorithm will greatly reduce the amount of garbage words indexed when 
you index a binary file.    It will also greatly improve the appearance of 
binary files when you view them in dtSearch. 

      To use the Filtered Binary file type, choose File Types from the Options menu and 
choose "Add new item".    The "Specify File Type" dialog box will appear.    Choose 
"Filtered Binary" and, under "Filename Pattern," enter "*.*".    This will tell dtSearch to 
interpret every document in a format that it does not recognize as a filtered binary file. 
      You can also enable the Filtered Binary format more selectively by entering a more 
specific pattern (such as *.DAT) under Filename Pattern. 

      To see the effect of the Filtered Binary format, use View File to view a binary file such
as C:\COMMAND.COM, enable the Filtered Binary file type as described above, and 
then view C:\COMMAND.COM again. 

      See "File Types" in the Options chapter for more information about setting up file 
type specifications. 



Archive Indexes

      dtSearch can build an index of a group of documents that contains, as part of the 
index, a copy of the text of the documents indexed.    The text is stored in compressed 
form.    This means that you can index the documents, remove them from your hard 
disk, and still search and browse the text that you indexed. 

      An index that contains a copy of the text of the indexed documents is called an 
"archive" index.    To create an archive index, choose Create Index (Advanced) in the 
Index menu and check the Store text with index checkbox. 

      An archive index does not compress and store the actual documents indexed.    
Instead, dtSearch extracts a copy of the text from each document and stores that text in
the index.    Thus, if you added a WordPerfect file called "SMITH.DOC" to an archive 
index, the text of SMITH.DOC would be stored in the index, but you could not extract 
SMITH.DOC itself from the index.    (SMITH.DOC would remain unchanged on your 
hard disk.) 

Note:    Archive indexes are not a safe place to store your only copy of a document.    If 
an archive index becomes damaged for any reason, you may not be able to extract the 
text from the index.    (And in any case the archive stores only the text; there is no way 
to get the original document from an archive.)    For this reason, you should always keep
another copy of any text stored in an archive index. 



Deleting an Index

      Deleting an index does not affect the original documents.    It just removes the index 
from your system.    To delete an index, choose Delete Index from the Index menu, 
select the index to delete, and choose OK. dtSearch will ask you to confirm that you 
really want to delete the index. 



Renaming an Index

To rename an index, 

* choose Rename Index from the Index menu, 

* select the index to be renamed, 

* enter the new name for the index, and 

* choose OK. 

Note that the name of the directory in which the index is stored will not be affected. 



Copying an Index

      To copy an index, 

* choose Copy Index from the Index menu, 

* select the index to be copied in the Copy Index dialog box, and 

* enter a new name and directory for the copy.    The name and directory of the copy 
must be different from the original index. 

      Like the directory specified in "Create Index (Advanced)," the directory that you copy 
an index to should not already exist.    If the directory that you specify already contains 
an index, dtSearch will ask you to confirm that you want the new index to overwrite the 
old index. (A directory can only contain one index.) 



Recognizing an Existing Index

      Although dtSearch provides a way to copy indexes, you may in some cases wish to 
copy indexes using another program and then use dtSearch to search the indexes.    For
example, if someone created an index and gave you a copy, you might want to just copy
the disk or disks using the DOS copy command.    However, if you then tried to search 
that index with dtSearch, the index that you copied would not appear in the "Indexes to 
Search" list because your copy of dtSearch would not know about the index. 

      The Recognize Index function solves this problem.    To recognize an index, select 
"Recognize Index" in the Index Menu.    A dialog box will appear listing the files in the 
current directory and other directories you can select.    Use the dialog box to locate one
of the files in the index you want to recognize and choose OK.    (dtSearch index files 
have names like "INDEX_R.IX" and "INDEX_F.IX".    They always begin with "INDEX_" 
and end with ".IX".)    dtSearch will look in the directory for the index, extract the 
information it needs to "recognize" the index, and add the index to the list of indexes in 
the current index library. 



Index Information

      To get information about an index, choose Index Information in the Index menu.    A 
dialog box will appear displaying the following information about the currently selected 
index: 

      * When it was created 
      * When it was last modified or compressed 
      * How much disk space it occupies 
      * How many words it contains 
      * How many documents it contains 

The Index Information screen also lists the number of "Obsolete" documents.    When 
dtSearch reindexes a document that is already in the index, it treats the document as a 
new document and marks the old version of the document in the index as "obsolete."    
When you compress an index, obsolete documents are removed. 



Verifying an Index

      To verify that an index is in good condition, choose Verify Index in the Index menu.    
As dtSearch examines the index, it will list every word, filename, and directory name in 
the index.    When dtSearch is done verifying the index, it will tell you whether the index 
has been damaged. 



List Words in Index

      Choose List Words in Index in the Index menu to generate a list of all of the words in 
an index.    Select the index you want to list and choose OK.    A second dialog box will 
appear asking for the name of a file to store the words in.    Enter the name of a file and 
choose OK or press ENTER. 



Index Libraries

      An index library is a collection of up to 25 indexes.    dtSearch uses index libraries to 
record the names and locations of the document indexes that you create.    When you 
select indexes to search, or pick an index to update, compress, etc., the list of indexes 
displayed comes from the current index library. 

      If you do not need to use more than 25 indexes, you do not need to worry about 
index libraries.    (25 indexes will hold up to 375,000 documents.)    dtSearch starts out 
with a library called "IXLIB.ILB" that will hold any indexes that you create. 

      If you need to use more than 25 indexes, choose Create Library in the Index menu to
create a new library.    A dialog box will appear allowing you to enter the name of the 
new library.    Enter a name for the new library and choose OK.    (The name of the 
library must end in ".ILB".    If the name you enter does not end in ".ILB", dtSearch will 
automatically add ".ILB" to the name.)    When you create a library, that library becomes 
your current library.    The new library will be empty.    To add indexes to the library, use 
Create Index, Copy Index or Recognize Index. 

      Use Change Library in the Index menu to change the current index library.    When 
you select Change Library, a dialog box will appear containing the name of the current 
index library.    To see the names of all of the index libraries you have created, enter 
"*.ILB" in the dialog box and press ENTER. 



Relative Paths

      By default, dtSearch uses relative, rather than absolute, paths in indexes and index 
libraries.    For example, suppose your documents are in I:\CHRON\DOCS and your 
index is in I:\CHRON\INDEX.    The absolute path for the documents would be I:\DOCS. 
The relative path from I:\CHRON\INDEX to I:\CHRON\DOCS would be ..\DOCS.    The 
relative path is more flexible because, if you move the entire I:\CHRON directory to 
another location, such as J:\CHRON or I:\SMITH\CHRON, the relative paths would 
remain valid. 

      Paths in an index are stored relative to the location of the index. The table of indexes
in an index library stores index directories relative to the location of the index library. 

      Relative paths are useful for shared indexes on networks when a physical drive uses
a different drive letter for different users.    (For example, if some users see it as S: drive 
and others see it as T: drive.)    As long as documents reside on the same drive as their 
index, dtSearch can use relative paths to avoid such drive mapping problems. 

      Relative paths are also useful for text database publishers who want to distribute a 
package with text and an index.    If the index is built using the Relative Paths option, 
users will be able to install the package on any drive and in any directory without 
affecting the validity of the index. 

      The only disadvantage to using relative paths is that, if you move an index to a 
different location and do not move the documents with the index, dtSearch may no 
longer be able to locate the documents because the relative path information will point 
to the wrong directories. 

      If you need to disable the Relative Paths option, edit your OPTIONS.DAT file to 
include the line "RelativePaths = No".    Indexes created with Relative Paths disabled will
store complete path information for every document. 



Search Menu

      Choose Search in the main menu to get into the Search menu.    The Search menu 
offers three ways to search for documents: 

 * Choose Index Search to search using one or more document indexes.    An index 
search is the fastest way to search for documents. Before you can do an index 
search, you must first build an index. 

* Choose Unindexed Search to directly search files in one or more directories. 

* Choose Combination Search to combine an index search with an unindexed search.

      The search menu also lists options to view previous search results or previous 
search reports.    To view an old search or search report, choose Previous Search or 
Previous Search Report in the Search Menu.    dtSearch will list all of the searches it has
saved.    Select the one you want to see and choose OK. 



Search Tools

      At the top of each search dialog box is a Search Tool box that can display any of the 
four search tools described below.    To select one of the tools, use the Select Tool radio 
buttons to the right of the Search Tool box.    The four search tools are described below: 

Word List A scrolling list of the words in the index you have selected. Next to each 
word is a number, which is the number of times the word occurs in the 
index. 

As you type in a search request, the scrolling list will display the words in 
the index that are closest to the word you are typing. 

If you have selected more than one index to be searched, the highlighted
index will be the one listed.    You can select the index displayed in the 
Word List by clicking on the index you want to see in the Indexes to 
Search box. 

Hints The basics of creating search requests. 

History A list of your most recent search requests. 

Next to each request is a pair of numbers, like "35/283," which tells you 
the number of files and hits that the request found. 

Macros A list of macros you have defined. 

      Next to the search tools is an "Insert" button.    Choose this button to insert a word, 
macro, or previous search request into the search request you are typing in. 



Index Search

      An index search uses one or more document indexes to do a search and is the 
fastest way to search for documents.    (Before you can do an index search, you must 
first build an index.    See the chapter on "Indexing Documents" for more information.) 

      To do an index search, choose Index Search in the Search menu.    The Index 
Search dialog box will appear. 

      At the top of the dialog box is the Search Tools panel, which displays one of the 
following: 

Word List A list of the words in the index you have selected. 

Hints The basics of creating search requests. 

History A list of your most recent search requests. 

Macros A list of macros you have defined. 

      Next to the Search Tools panel are two buttons:    Insert and Options    button.    
Choose Insert to insert something from the Search Tools panel into your search request.
Choose Options to access advanced searching options. 

      Just below the search tool panel is a box for you to type in your search request. 

      Choose the Select Indexes button at the bottom of the dialog box to select indexes to
search.      A dialog box will appear listing the indexes in your index library.    Select the 
indexes you want to search and choose OK.    The indexes you selected will appear in 
the Indexes to Search list. 

      Choose OK to start the search. 



Unindexed Searches

      In an unindexed search, dtSearch directly searches every file that you ask it to 
search, looking for documents that match your search request. Unindexed searches are
much slower than index searches. 

      To start an unindexed search, choose Unindexed Search from the Search menu.    
The Unindexed Search dialog box will appear. 

      At the top of the dialog box is the Search Tools panel, which displays one of the 
following: 

Hints The basics of creating search requests. 

History A list of your most recent search requests. 

Macros A list of macros you have defined. 

      Next to the Search Tools panel are two buttons:    Insert and Options button.    
Choose Insert to insert something from the Search Tools panel into your search request.
Choose Options to access advanced searching options. 

      Just below the search tool panel is a box for you to type in your search request. 

      Choose the Select Directories button at the bottom of the dialog box to select 
directories to search.    The Select Directories to Search dialog box will appear.    Select 
the directories you want to search and choose OK.    The indexes you selected will 
appear in the Directories to Search list. 

      Choose OK to start the search. 



Combination Searches

      A combination search is a search that combines an index search with an unindexed 
search. 

      To do a combination search, choose Combination Search in the Search menu.    The 
Combination Search dialog box will appear. 

      At the top of the dialog box is the Search Tools panel, which displays one of the 
following: 

Word List A list of the words in the index you have selected. 

Hints The basics of creating search requests. 

History A list of your most recent search requests. 

Macros A list of macros you have defined. 

      Next to the Search Tools panel are two buttons:    Insert and Options button.    
Choose Insert to insert something from the Search Tools panel into your search request.
Choose Options to access advanced searching options. 

      Just below the search tool panel is a box for you to type in your search request. 

      Choose the Select Indexes button at the bottom of the dialog box to select indexes to
search.      A dialog box will appear listing the indexes in your index library.    Select the 
indexes you want to search and choose OK.    The indexes you selected will appear in 
the Indexes to Search list. 

      Choose the Select Directories button at the bottom of the dialog box to select 
directories to search.    The Select Directories to Search dialog box will appear.    Select 
the directories you want to search and choose OK.    The indexes you selected will 
appear in the Directories to Search list. 

      Choose OK to start the search. 



Selecting Directories to Search

      The Select Directories to Search dialog box allows you to pick the directories you 
want dtSearch to search from a list of all of the directories on your computer.    The left 
side of the dialog box displays all of the directories on one disk drive, with a check box 
next to each directory name.    The right side of the dialog box lists all of the disk drives 
you can access. 

* To select a directory, click on it with the mouse, or move the cursor to it and press 
SPACEBAR. 

* To select a directory and its subdirectories, double-click it with the mouse, or move 
the cursor to it and press + (the plus sign). 

* To change disk drives, click on the drive letter with the mouse, or hold down the 
CTRL key and press the letter of the drive you want (for example, CTRL-D to switch
to drive D). 

* To clear all selections for the current drive, choose the Clear Drive button.    To clear 
all selections for all drives, choose the Clear All button. 

* To update the list of directories for a drive, choose the Reread Drive button.    
Reading the list of directories for a drive can be time-consuming.    To save time, 
dtSearch keeps a copy of the directory tree for each drive and only updates it when 
you tell it to (by choosing this button).    You should do this whenever you create a 
new directory and want to be able to search documents in that directory. 

When you are done selecting directories, choose OK to save your selections. 



Search Options

      Choose the Options button in a search dialog box, or choose Search Options in the 
Options menu, to access the Search Options dialog box. This dialog box allows you to 
specify the following options: 

Fuzzy Searching 
Check this box if you want all of your searches to be "fuzzy" searches.    Fill the the 
level of fuzziness you want (from 1 to 10) in the Fuzziness box.    If you want only 
some of your searches to be fuzzy, you can use the % character. 

Phonic Searching 
Check this box if you want all of your searches to be phonic searches.    If you want 
only some of your searches to be phonic, you can use the # character. 

Stemming 
Check this box if you want dtSearch to use stemming in all searches. If you want 
only some of your searches to use stemming, use the ~ character. 

If you have created your own stemming rules to replace the default rules provided with 
dtSearch, enter the name of the file containing the rules under Stemming Rules. 

Options for Unindexed Searches 

File name filters 
Leave this blank to include all files.    Otherwise, enter a list of filters (such as 
"*.DOC") separated by semicolons. 

Exclude filters 
If there are specific files you do not want included, enter a list of filters identifying 
those files. 

 Skip binary files 
Check this box if you do not want dtSearch to search "binary" files (files that use a 
format that dtSearch does not recognize). 

See "File Types" in the Options chapter for more information about handling 
unrecognized file formats. 

Case sensitive 
Check this box if you want the search to distinguish between lower and upper case 
letters, so that a search for "apple" would not find "Apple". 

Accent sensitive 
Check this box if you want the search to distinguish between accented and 
unaccented letters. 



Sorting Search Results

      After a search is complete, the "Display Search Results" dialog box will appear, 
listing several different ways to display the results of your search: 

Name: Sort by name, in alphabetical order 

Hits: Sort by number of hits (also called "relevance ranking") 

Date: Sort by date of the document 

Unsorted displays documents in the order they were found 

      Select the way you want to sort your search results and choose OK to display the 
results of your search.    Choose Cancel to return to the main menu without viewing 
search results. 



Search Requests (Overview)

      This chapter describes the rules for composing search requests in dtSearch.    The 
next chapter describes how to perform index and unindexed searches. 

      A search request consists of a group of words, phrases, or macros linked by 
connectors such as "AND" and "OR" that indicate the relationship between them. 

      If you use more than one connector, you should use parentheses to indicate 
precisely what you want to search for.    For example, 

                    apple and pear or orange 

could mean "(apple and pear) or orange," or it could mean "apple and (pear or orange)."
Here are some more examples: 

* apple and pear:    both words must be present. 
* apple or pear:    either word can be present. 
* apple w/5 pear:    apple must occur within 5 words of pear. 
* apple and not pear:    only apple must be present. 
* @addr contains 123:    the segment @addr must contain 123. 
* xname "SMITH*.DOC":    filename matches SMITH*.DOC. 
* xdate is 11/92:    file was modified in November 1992. 
* apple w/5 xfirstword:    "apple" must occur in the first five words. 
* apple w/5 xlastword:    "apple" must occur in the last five words. 

      Noise words, such as "if" and "the" may not be included in searches. 

      Search terms may include the following special characters: 

      ? match any character 
      * match any number of characters 
      % fuzzy search 
      # phonetic search 
      ~ stemming 

Stemming and fuzzy and phonic searching can be enabled globally for all searches 
using the Search Options dialog box. 



Words and Phrases

      You do not need to use any special punctuation or commands to search for a phrase.
Simply enter the phrase the way it ordinarily appears. You can use a phrase anywhere 
in a search request.    Examples: 

      apple w/5 fruit salad 

      If a phrase contains a noise word, then you cannot search for it as a phrase, since 
the noise word will not be found.    For example, you could not search for the phrase 
statue of liberty, since the noise word "of" will not be in the index.    Instead, use the W/N
connector to search for statue w/2 liberty. 

      Punctuation inside of a search word is treated as a space.    Thus, "can't" would be 
treated as "can t," a phrase consisting of two words: "can" and "t".    "1843(c)(8)(ii)" 
would become "1843 c 8 ii" (four words).    (You can customize the way dtSearch 
handles punctuation in text by using the dtSearch ALPHABET utility.) 

      dtSearch uses two built in search words to mark the beginning and end of a file -- 
XFIRSTWORD and XLASTWORD.    The terms are useful if you want to limit a search 
to the beginning or end of a file.    For example, "apple w/10 XLASTWORD" would 
search for the word "apple" within 10 words of the end of a document. 



Wildcards (* and ?)

      A search word can contain the "wildcard" characters "*" and "?".    A "?" in a word 
matches any single character, and a "*" matches any number of characters.    The 
wildcard characters can be in any position in a word.    For example: 

      appl*      would match apple, application, etc. 
      *cipl*    would match principle, participle, etc. 
      appl?      would match apply and apple but not apples. 

Use of the "*" wildcard character near the beginning of a word will slow searches 
somewhat. 



Fuzzy Searching

      Fuzzy searching will find a word even if it contains typos.    For example, a fuzzy 
search for "apple" will find "appple."    Fuzzy searching can be useful when you are 
searching text that may contain misspelled words.    It is especially helpful when 
searching text that has been scanned using optical character recognition (OCR). 

      There are two ways to add "fuzziness" to your searches. 

* To make all of your searches fuzzy searches, check the Fuzzy searching checkbox 
in the Search Options dialog box and indicate the level of fuzziness (from 1 to 10) 
that you want. 

* You can also add fuzziness selectively using the % character.    The number of % 
characters you add determines the number of differences dtSearch will ignore when
searching for a word.    The position of the % characters determines how many 
letters at the start of the word have to match exactly.    Examples: 

        ba%nana Word must begin with "ba" and have at most one difference 
between it and "banana." 

        b%%anana Word must begin with "b" and have at most two differences 
between it and "banana." 



Phonic Searching

      Phonic searching looks for a word that sounds like the word you are searching for 
and begins with the same letter.    For example, a phonic search for "Smith" will also find
"Smithe" and "Smythe." 

      To ask dtSearch to search for a word phonically, put a # in front of the word in your 
search request.    Examples: #smith, #johnson. 

      To make all of your searches phonic, check the "Phonic Searching" checkbox in the 
Search Options dialog box.    Phonic searching is somewhat slower than other types of 
searching and tends to make searches excessively over-inclusive, so it is usually better 
to use the # symbol to selectively do phonic searches. 



Stemming

      "Stemming" tells dtSearch to find words with the same "stem" as the search word.    
For example, a search for "fish" would also find "fishing."    A search for "applied" would 
also find "applying," "applies," and "apply." 

      If you want to use stemming in all of your searches, check the Stemming box in the 
Search Options dialog box.    (By default, the box is checked.)    Stemming does not slow
searches noticeably and is almost always helpful in making sure you find what you 
want. 

      If you want to add stemming selectively, add a ~ at the end of words that you want 
stemmed in a search. 

      The stemming rules included with dtSearch are designed to work with the English 
language.    These rules are in the file STEMMING.DAT.    If you need to implement 
stemming for a different language, or if you want to modify the English stemming rules 
that dtSearch uses, you can create a new set of stemming rules to be used in place of 
STEMMING.DAT.    See the STEMMING.DAT file for more information about how to do 
this. 



Noise Words

      A "noise" word is a word such as the or if that is so common that it is not useful in 
searches.    To save space and time, such words are ignored in index searches.    You 
can modify the list of words defined as noise words by editing the file 
"DTSEARCH.NOI."    You can use the Edit File function (in the File Menu) to edit 
DTSEARCH.NOI, or you can use your word processor.    If you use your word 
processor, make sure that you save the file as a DOS text file (with the name name, 
DTSEARCH.NOI, in the directory where dtSearch is installed) so that dtSearch can read
it. 

      The words in DTSEARCH.NOI do not have to be in any particular order, and can 
include "wild card" characters such as * and ?.    However, noise words may not begin 
with wild card characters. 

      Search connectors, such as AND, OR, etc., should always be listed as noise words 
since it is not possible to search for them. 

      When you create an index, the index will store its own copy of the noise word list.    
Changes you make to DTSEARCH.NOI will be reflected in future indexes you create but
will not affect existing indexes. 



AND Connector

      Use the AND connector in a search request to connect two expressions, both of 
which must be found in any document retrieved.    For example: 

* apple and pear would retrieve any document that contained both words. 

* (apple or banana) and (pear w/5 grape) would retrieve any document that (1) 
contained either the word apple or the word banana, and (2) contained the word 
pear within 5 words of the word grape. 



OR Connector

      Use the OR connector in a search request to connect two expressions, at least one 
of which must be found in any document retrieved.    For example, "apple or pear" would
retrieve any document that contained apple, pear, or both words. 



W/N Connector

      Use the W/N connector in a search request to specify that one word or phrase must 
occur within N words of the other.    For example, "apple w/5 pear" would retrieve any 
document that contained the word apple within 5 words of pear. 

      The following are some examples of search requests using the W/N connector: 

* (apple or pear) w/5 banana:    either apple or pear must occur within 5 words of 
"banana." 

* (apple w/5 banana) w/10 pear:    apple must occur within 5 words of banana, and 
pear must occur within 10 words of both. 

* (apple and banana) w/10 pear:    both apple and banana must occur within 10 words
of pear. 

      Some types of complex expressions using the W/N connector will produce 
ambiguous results and should not be used.    In general, at least one of the two 
expressions connected by W/N must be a single word or phrase or a group of words 
and phrases connected by the "OR" connector.    For example: 

* (apple and banana) w/10 (pear or grape):    both apple and banana must occur 
within 10 words of either pear or grape. 

* (apple and banana) w/10 orange tree:    both apple and banana must occur within 
10 words of the phrase "orange tree." 

The following are examples of ambiguous search requests: 

* (apple and banana) w/10 (pear and grape) 

* (apple w/10 banana) w/10 (pear and grape) 

If you enter an ambiguous search request, dtSearch will display a message warning you
of the error. 



NOT and NOT W/N

      Use NOT in front of any search expression to reverse its meaning. This allows you to
exclude documents from a search.    For example, 

apple sauce and not pear 

would retrieve documents containing the phrase "apple sauce" and not containing the 
word "pear."    Note the need for an AND to connect the NOT to the rest of the search 
request.    NOT standing alone can be the start of a search request.    For example, 

      not pear 

would retrieve all documents that did not contain the word "pear."    If NOT is not the first
connector in a request, you need to use either AND or OR with NOT.    Here are two 
more examples: 

apple or not pear:    retrieve documents that either (1) contain the word "apple," or 
(2) do not contain the word "pear." 

not (apple w/5 pear):    retrieve documents that do not contain the word "apple" 
within 5 words of the word "pear." 

      The NOT W/ ("not within") operator allows you to search for a word or phrase not in 
association with another word or phrase.    For example, 

apple not w/20 pear 

would search for instances of the word "apple" more than 20 words away from the word 
"pear."    It will also retrieve files containing "apple" with no instances of "pear." 

      Unlike the W/ operator, NOT W/ is not symmetrical.    That is, "apple NOT W/20 pear"
is not the same as "pear NOT w/20 apple."    In the "apple NOT W/20 pear" request, 
dtSearch searches for the word "apple" and excludes cases where "apple" is too close 
to the word "pear."    In the "pear NOT W/20 apple" request, dtSearch searches for the 
word "pear" and excludes cases where "pear" is too close to "apple." 



Search Macros

      Macros can be useful for: 

      * abbreviating long names or phrases that you use frequently, or 
      * abbreviating segment definitions in segment searches. 

      A macro may contain anything that can be part of a search request.    A macro has 
two parts:    a name, which you use to refer to the macro in search requests, and the 
expansion, which is what the macro is expanded to.    For example, if you defined the 
macro "@IRC" to mean "internal revenue code," and then searched for "standard 
deduction w/3 @IRC," dtSearch would search for "standard deduction w/3 internal 
revenue code." 

      A macro name must begin with the "@" character (shift-2).    This is how dtSearch 
distinguishes macro names from ordinary words in a search request. 

      Choose Macros in the Options menu to create or edit a macro.    A dialog box will 
appear listing all of the macros you have created. To create a new macro, move the 
cursor to "<add new item>" and choose Edit.    Move the cursor to an existing macro and
select Edit to edit the macro. 

      When you choose Edit, a dialog box will appear with two spaces in it: one for the 
"Name" of the macro, and one for the "Expansion."    Under Name, enter a single word 
(8 letters or less, beginning with "@") that you will use for this macro.    Under 
Expansion, enter the meaning you want to assign to this macro.    Choose OK to save 
your changes. 



Segment Searches

      A segment search is a search request that must be satisfied within a certain defined 
segment of a document.    The segment is defined by words or phrases at the beginning 
and end of the segment. 

      The form of a segment definition is:    beginning TO end, where beginning is the word
or phrase that defines the start of the segment, and end is the word or phrase that 
defines the end of the segment.    The only connector allowed in the beginning and end 
expressions in a segment definition is OR.    Examples: 

name to address 
the segment begins with the word "name" and ends with the word "address." 

name to (address or xlastword) 
the segment begins with the word "name" and ends with the word "address" or the 
end of the file. 

      To search for an expression within a segment, use the CONTAINS connector.    The 
expression in front of CONTAINS is the segment definition, and the expression following
CONTAINS is what you are searching for.    Examples: 

* (name to address) contains john smith 

* (address to phone) contains (oak w/10 lane) 

      If a document contains more than one instance of a segment, dtSearch will search 
each instance separately for text matching the search request. 

      Segment searches work well with documents that are broken into standardized 
segments.    For example, a group of employee records might be in standardized 
documents formatted like this: 

      NAME:    John Doe 
      ADDRESS: 123 Oak Lane 
      PHONE NUMBER:    555-1234 
      SOCIAL SECURITY NUMBER 000-00-0000 
      etc. 

      You can name segments using macros.    In the above example, you could use the 
following macros: 

@name: (name to address) 
@addr: (address to phone number) 
@phone: (phone number to social security number) 



Then you could do a segment search like this: 

(@name contains John Doe) and (@addr contains Oak) 

      The words in a segment definition ("name," "address," etc.) will not appear as hits 
after a search.    Only the words being searched for in the segments ("John Doe," "Oak")
will be highlighted. 



Date and Filename Searches

      To search for a file with a specific name, use XNAME.    For example, if you want to 
find a file called FILENAME.EXT, search for: 

      xname "filename.ext" 

The filename, like other search terms, can include wildcard characters ("*.TXT," 
"SMITH??.*," etc.)    Unlike other search terms, a filename must be in quotation marks.    
This enables dtSearch to recognize special characters in the filename (such as the dot) 
that are treated as spaces in other search words.    The filename cannot include a 
directory name or disk drive. 

      To search for a file that was last modified on, before, or after a certain date, use the 
XDATE search command, like this: 

      xdate is January 1, 1991 
      xdate before January 1, 1991 
      xdate after January 1, 1991 

dtSearch can recognize a variety of date formats, such as: 1/1/91; 1/91; January 1, 
1991; and Jan 1 91 (two-digit years are assumed to be in the twentieth century). 

      You can combine name and date searches with other types of searches using the 
usual search connectors.    For example: 

(xname "*.doc") and (xdate after 1/1/91) and (apple w/5 pear) 

This would retrieve documents whose names end in .DOC, that were last modified after 
January 1, 1991, and that contain the word apple within 5 words of the word pear. 



Viewing Search Results

      After you do a search, a Search Results window will appear listing the documents 
that were retrieved by your search. 

      In dtSearch for DOS, a list of function keys will appear at the bottom of the screen 
when you are in a Search Results window.    These function keys will work in dtSearch 
for Windows, but dtSearch for Windows also provides a button bar at the top of the 
Search Results window. 

      Choose Local Menu in the Window menu (F9) to pop up the Local menu for a search
results window.    This menu provides quick access to all commands that work with 
search results.    All of the options listed below are available in the Local menu. 

Finding Text 
To search the list of files for something, choose Find in the Edit menu (F2).    (Note:   
In a Search Results window, Find searches the list of documents, not the 
documents themselves.) 

Copying Text 
Choose Mark in the Edit menu (F6) to start marking text to copy to a file. 
Choose Copy in the Edit menu (F7) to copy the marked text. 

Printing Text 
Choose Print in the File menu to print the list of files.    (To print multiple files, see 
"Selecting Files" below.) 

Search Report 
Choose Search Report in the Search menu to generate a search report listing all 
hits found in every retrieved document with a few lines of context.    (To select 
specific documents for a search report, see "Selecting Files" below.) 

KWIC 
Choose KWIC in the Search menu to generate a "KWIC" view of a document listing 
all hits in the document with a few lines of context. 

Selecting Files 
If you want to print or copy multiple files, or see a search report, based on a few 
selected files rather than all of the files in the list, use SPACEBAR to select the files 
you want.    A * (asterisk) will appear next to the file.    To clear the *, press 
SPACEBAR again.    To select all of the documents in the list, choose Select All Files
in the Edit menu. To clear all selection marks from the list, choose Clear Selections 
in the Edit menu. 

After selecting files, you can print, copy, or prepare a search report based on your 
selections. 



Launching Files 
Choose Launch to "launch" a document.    If you have set up an application for the 
type of document you are viewing (for example, WordPerfect for a WordPerfect 
document), dtSearch will execute that application with the file you are viewing. 

Cursor commands for the Search Results window 

      Top of list Home,Home,Up 
      End of list Home,Home,Dn 
      Page up PgUp 
      Page down PgDn 

Menu and Window Commands 

* To get into the main menu, press F10 or click on the main menu with the mouse. 

* To get back to the Search Results window from the main menu or the local menu, 
press ESCAPE or click on the window with the mouse. 

* ESCAPE closes the Search Results window. 
 * To view one of the documents in the list, move the cursor to it and press ENTER or 

double-click on the document with the mouse.    The document you select will 
appear in a window overlaying the Search Results window. 



Viewing a Retrieved Document

      To view a file retrieved in a search, move the cursor to the file you want to see in the 
search results window and press ENTER.    The document will appear in a new window 
overlaying the search results window.    Hits from your search will be highlighted. 

      When you are viewing a retrieved document, you will see a list of function keys (in 
DOS) or a button bar (in Windows) similar to the one displayed in a Search Results 
window. 

        Choose Local Menu in the Window menu (F9) to pop up the Local menu for a 
retrieved document window.    This menu provides quick access to all commands that 
work with retrieved document windows.    All of the options listed below are available in 
the Local menu. 

Finding Text 
To search a document for a word or sequence of characters, choose Find in the 
Edit menu (F2). 

Copying Text 
Choose Mark in the Edit menu (F6) to start marking text to copy to a file. 
Choose Copy in the Edit menu (F7) to copy the marked text. 

Printing Text 
Choose Print in the File menu to print the document. 

Finding Hits 
Choose Hit (F3) to search the document for the next hit from your search request.  
Choose Next (F5) to see the next document retrieved in the search.    Prev (Shift-
F5) displays the previous document retrieved in the search. 

Launching Files 
Choose Launch (F8) to "launch" the document.    If you have set up an application 
for the type of document you are viewing (for example, WordPerfect for a 
WordPerfect document), dtSearch will execute that application with the file you are
viewing. 

Cursor commands 

      Top of document Home,Home,Up 
      End of document Home,Home,Dn 
      Beginning of line Home,Left 
      End of line Home,Right or End 
      Page up PgUp 
      Page down PgDn 



Menu and Window Commands 

* To get into the main menu, press F10 or click on the main menu with the mouse. 

* To get back to this window from the main menu or from the local menu, press 
ESCAPE or click on the window with the mouse. 

* To close a window, press ESCAPE.    To leave the window open and switch to 
another window, press TAB. 

* See "Viewing Multiple Windows" for more information on viewing documents and 
search results in overlapping windows. 



Local Menu

          When you are viewing or editing a file or viewing search results, a retrieved 
document, a search report, or a Kwic view, press F9 (or click on the word "Local") to 
pop up the "Local" menu for the window you are in.    You can also get into the Local 
menu by choosing "Local" in the Window menu. 

          The Local menu lists all of the things you can do with the window you are in.    The 
Local menu is different for each type of window.    For example, the Local menu for a 
search results window includes an option to generate a search report.    The Local menu
for a retrieved document includes an option to skip to the next document retrieved in the
search. In the Local menu, you can move the cursor and select items just as you would 
in other dtSearch menus. 



Finding Text in a Window

      Choose Find (or press F2) to search for any text in a displayed document.    dtSearch
will ask you for the text to search for.    Type in the text you want to find and choose OK. 
Find is like the search function in your word processor -- you can search for words, 
spaces, punctuation, etc.    Capitalization is ignored, and the * and ? characters are 
searchable like any other characters (they are not treated as wildcards).    If you use 
Find in a Search Results window, it will search the list of filenames, modification dates, 
etc., as it appears on the screen. 

      Find starts searching after the line that the cursor is on, so you may wish to move to 
the top of the document before beginning a search.    Find will bring you to the beginning
of the line containing the text searched for. 



Finding Hits

      After you have done a search and you have a retrieved document on the screen, 
choose Hit (or press F3) to quickly find the next hit from your search request in the 
document.    For example, if you had searched for "apple and (pear w/5 banana)," 
pressing the F3 key while viewing a document would cause dtSearch to locate the next 
occurrence of one of the words "apple," "pear," or "banana" in the document you are 
viewing. 

      Find Hit will only find words that match a search request.    In the above example, Hit 
would only find instances of "pear" within five words of "banana." 



Kwic View

      The "KWIC" ("Key word in context") function will display only the part of a document 
that contains terms matching your search request.    When you are in a search results 
window, move the cursor to the name of the document that you want to see and choose 
KWIC in the Search menu. dtSearch will ask how many lines of context you want.    This
is the number of lines surrounding each hit that you want to see.    Enter the number of 
lines that you want and choose OK. 

      A window will pop up over the search results window displaying a KWIC view of the 
document you selected.    You can use most of the same browsing and menu 
commands in a KWIC window as you can in a retrieved document. Press F9 to pop up 
the local menu. 

      You can also see all of the document by moving the cursor to the name of the 
document and pressing ENTER or by double-clicking on the document name with the 
mouse.    In addition, a file displayed in KWIC mode contains highlighted line and page 
markers to show where in the document the text appeared.    These highlighted markers
act as hypertext links into the full text of the document. 

      For example, suppose that you are viewing a document in KWIC mode and see a 
block of text with a marker "[Page 10 Line 15]."    If you move the cursor to the marker 
and press ENTER (or double-click with the mouse), a window displaying the full 
document will pop up over your KWIC view, positioned to line 15 of page 10.    To return 
to the KWIC view, press ESCAPE. 



Search Reports

      A search report lists each hit found in each of the documents retrieved in a search 
with a few lines of context surrounding it.    It is like a combined KWIC view of every 
document retrieved in a your search. To create a search report, you must be in a Search
Results window. 

* Choose Search Report from the Search menu. 

* The Search Report dialog box will pop up.    In this dialog box, enter the number of 
lines of context you want surrounding each hit and choose OK. 

      You can create a search report including only a few selected files in a search results 
list.    To do this, press SPACEBAR to mark the files you want included before you create
the search report.    A * (asterisk) will appear next to each selected file. 

      Search report windows use the same commands and function keys as KWIC 
windows. 



Viewing Multiple Windows

      In dtSearch, the space between the menu bar at the top of the screen and the bar at 
the bottom of the screen describing the current menu option is a workspace, like a 
desktop, that you can use for searching and browsing documents.    As with a desk 
surface, you can place several documents on the surface and move them around so 
you can see the one that you want to read.    Menus and dialog boxes will pop up over 
the desktop, but the underlying documents will remain until you remove them. 

      You can add search results windows, document windows, KWIC views, and search 
reports to the desktop. 

* Use TAB or the mouse to switch from one window to the next.    (Use SHIFT-TAB to 
switch back.) 

* To close the window you are in, press ESCAPE. 

* To "cascade" your windows (rearrange them so that they overlap), choose Cascade 
from the Window menu. 

* To "tile" your windows (rearrange them so that they do not overlap), choose Tile 
from the Window menu. 

Example 

For an example of how to use multiple windows in dtSearch, try the following: 

* Do a search, then move the cursor to the name of a document and press 
SPACEBAR.    The document you selected will appear. 

* Now press TAB.    The search results window will appear, overlaying the document 
you were viewing. 

* Move the cursor to a different document and press SPACEBAR again.    The new 
document will appear on top of the search results and the other document. 

* Press TAB repeatedly and each of the three windows will appear on top of the 
others in turn. 

* Press ALT-W to get into the Window menu and choose Tile.    You will see all of the 
windows you have created arranged so that they do not overlap.    Press TAB to 
move among the windows. 

* Press ALT-W again and this time choose Cascade.    Now your windows will be 
arranged so that they do overlap.    (To move or resize the windows, see below.) 



* Finally, press ESCAPE three times to close each of the windows. 

NOTE:    Cascade and Tile rearrange only the windows existing on the desktop when 
these options are selected.    If you add additional windows, you must choose Cascade 
or Tile again if you want to rearrange the new windows. 

Resizing and Moving Windows 

      Click on the square in the upper left corner of the window (or press ALT-hyphen, e.g.,
ALT + the hyphen ("-") key) to pop up the Control menu.    Choose either Move or Size 
and use the cursor keys to move the window or resize the window.    Choose Maximize 
to "zoom" the window. 



Printing a File

      When you are viewing search results, a retrieved document, a KWIC view, or a 
search report, you can print the contents of the window you are viewing by choosing 
Print from the Local menu.    Print will print the entire document, not just what appears 
on the screen. 

      When you select Print, the Print dialog box will appear.    The Print dialog box allows 
you to set page length, width, and margins, headers, footers, and page numbering. 

      If you want to print to a file instead of to the printer, check the Print to File box.    
After you choose OK, dtSearch will ask for the name of the file to print to. 

      To select the printer to use, choose Printer Setup in the File menu. 

      In a Search Results window, you can select some or all of the files listed for printing.  
Use SPACEBAR to select the files you want.    A * (asterisk) will appear next to the file.    
To clear the *, press SPACEBAR again.    To select all of the documents in the list, 
choose Select All Files in the Edit menu.    To clear all selection marks from the list, 
choose Clear Selections in the Edit menu. 





Using the Mouse 

      In dtSearch for Windows, all document windows have the same basic structure.    
Surrounding the window is a frame.    When the window is on top, the top of the frame 
will be blue (if you have a color monitor); otherwise, it will be white. 

      In the upper left corner, there will be a small square.    Click on this square to activate
the standard Windows Control menu, which contains options for closing, moving, 
resizing, or maximizing the window. 

      In the upper right corner, there will be a triangle.    Click on this triangle to zoom the 
window, or to unzoom it if it is zoomed. 

      On the right edge will be a scroll bar.    Click on the arrows or on the bar itself to scroll
up and down in your document. 

      To resize a window, move the cursor to the bottom or one of the side edges of the 
window (the cursor will change to a double arrow), hold down the left mouse button and 
drag.    To move the window, click on the top and drag. 

      At the top of the window, there will be a button bar listing commonly used functions.    
Click on any of these buttons to activate the function indicated. 

      Click the right mouse button to pop up the local menu listing things you can do with 
the current window. 





Edit Menu

      Choose Edit in the main menu to get into the Edit menu.    The Edit menu lists 
options to mark and copy text. 

* To save a block of text from a file you are viewing, 
            choose Mark to start marking the text 
            choose Copy to copy it to a file. 

* To save an entire file, choose Copy File. 

* To copy (or print) multiple files in a Search Results list, use Select File, Select All, 
and Clear Selections to select the files you want to copy. 

* To search the file you are viewing for a word or other sequence of characters, 
choose Find Text. 



Marking and Copying Text

a.    Marking 

dtSearch provides three ways to mark text to be copied: 

* Choose Mark (F6) to start marking, then move the cursor to the end of the block. 

* Click on the start of a block and drag the mouse, holding the mouse button down, to
the end of the block. 

* Move the cursor to the start of the block, hold down the SHIFT key to start marking, 
and move the cursor to the end of the block 

b.    Copying 

      Once you have marked text, choose Copy (F7) to copy the text to a file or, in 
Windows, to the clipboard.    The Copy Text dialog box will appear, asking where you 
want to copy the text.    If you ask to copy the text to a file that already exists, dtSearch 
will ask whether you want to overwrite the file or append the text to it. 

      The Copy Text dialog box also contains options allowing you to annotate the text you 
are copying. 

Include filename 
Check this box if you want the name of the file the text is copied from to appear at 
the top of the text. 

Include page and line number 
Check this box to add the page and line where the text appeared in the original 
document. 

Annotation 
In this box, you can enter a brief note to be copied with the text. 

c.    Editing 

      After you have collected text using Mark and Copy, you can edit it using Edit File in 
the File menu.    Press ALT-F to get into the File menu (you do not have to close the 
window you are viewing) and choose Edit File. dtSearch will ask for the name of the file 
you want to edit.    Enter the name of the file you used to store the copied text.    An 
editor will then pop up allowing you to edit the text you copied.    See "Editing a File" in 
the "File Menu" chapter for information about editing files using this editor. 

      You can switch between the editor and your other windows.    In dtSearch for DOS, 
use TAB and SHIFT-TAB.    In dtSearch for Windows, the editor is a separate program 



(the Windows NOTEPAD editor) so use ALT-TAB to switch between the editor and 
dtSearch. 



Copying a File

      Choose Copy File in the Edit menu to copy the file you are viewing. The Copy File 
dialog box will appear.    At the top of the dialog box will be the name of the file you are 
viewing.    Below it will be a space where you can enter the name for the copy.    To copy 
the file, enter a name and choose OK. 

      If the filename you enter already exists, dtSearch will ask if you want to overwrite the 
existing file.    To suppress this message, clear the "Confirm Overwrites" check box. 

      To copy multiple files in a Search Results list, select the files you want to copy (press
SPACEBAR to select a file) and then choose Copy File.    Since you will be copying 
more than one file, enter a directory rather than a filename in the dialog box. 

      You can use Copy File to save search results or search reports for later viewing.    To 
save search results or a search report, use Copy File and enter a name for the file to 
create.    Then, when you want to see the search results or search report again, use 
View File to view the file you created.    dtSearch will recognize that the file is a search 
results or search report file. 



Selecting Files to Copy or Print

In a Search Results window, you can select multiple files to print, copy, or summarize in 
a search report. 

* To select a file, move the cursor to it and press SPACEBAR (or choose Select File 
in the Edit menu).    A * (asterisk) will appear next to the file.    To clear the *, press 
SPACEBAR again. 

* To select all of the documents in the list, choose Select All Files in the Edit menu. 

* To clear all selection marks from the list, choose Clear Selections in the Edit menu. 

After selecting files, you can print, copy, or prepare a search report based on your 
selections. 

* Choose Print in the File menu to print the selected files. 

* Choose Copy File in the Edit menu to copy the selected files to a directory, 

* Choose Search Report in the Search menu to prepare a search report containing 
hits found in the selected files,. 



Batch Indexing and Searching

 
      Batch mode indexing allows you to create, update, and compress a document index 
by running dtSearch from the DOS command line or from a DOS batch file.    Batch 
mode indexing can be useful if, for example, you want to perform a complex and time-
consuming series of tasks every night to update your indexes.    Batch mode indexing 
and searching is available in dtSearch for DOS only. 

      To set up a batch indexing job, first create a "script" that lists the tasks that you want 
dtSearch to perform.    A script is a text file that lists a series of indexing commands that 
dtSearch will carry out. 

      The easiest way to create a script is to use the Create Batch Script option in the 
Index menu.    When you select this option, a dialog box will appear that is almost 
identical to the "Add Documents to Index" dialog box. 

      Fill out the box exactly as you would if you were updating an index. See the section 
on "Adding Documents to an Index" in the "Indexing Documents" chapter for more 
information about the options in the Create Batch Script dialog box. 

      When you are done setting up the indexing job, choose OK to create a script.    A 
dialog box will pop up asking for the name of the script to create.    Enter a name for the 
script and choose OK.    dtSearch will then store all of the information you have provided
(the index to update, the directories to index, etc.) in a script file that you can run later. 

      To run the script that you created, choose Execute Batch Script in the Index menu, 
enter the name of the script to execute, and choose OK. 

      To run the script from the command-line, type the following at the DOS prompt: 

      DTSEARCH /SCRIPT MYSCRIPT.JOB 

where "MYSCRIPT.JOB" is the name of your script.    You should be in the directory 
where dtSearch is installed when you do this.    If you created the script in a different 
directory, you will need to supply the full pathname of the script, e.g., C:\WHATEVER\
MYSCRIPT.JOB.    dtSearch will then perform the indexing task you specified. 

      dtSearch will record any errors encountered during the job in a file called 
MYSCRIPT.LOG.    Errors and informational messages will not be displayed on the 
screen, since dtSearch assumes that batch jobs will run without someone watching 
them.    After a batch indexing job, you should check the log file to see if any errors 
occurred. 

      This is all that you need to know to set up basic batch indexing tasks.    For 
information on advanced script commands and the dtSearch DDE interface, see 



BATCH.DOC. 



The File Menu

Choose File in the main menu to get into the File menu.    The File menu lists options to 

      * view a file, 
      * edit a file, 
      * print a file, 
      * launch an application, 
      * create a DOS Shell (DOS version only), 
      or 
      * exit dtSearch. 



Viewing a File

      To view a file, choose View File in the File menu.    A dialog box will appear asking for
the name of the file you want to view.    Type in the name of the file and press ENTER.    
The file will appear in a window. 

      Choose Local Menu in the Window menu (F9) to pop up the Local menu for the 
document window.    This menu provides quick access to all commands that work with 
document windows.    All of the options listed below are available in the Local menu.    
Some are also available as function keys or, in dtSearch for Windows, the button bar at 
the top of the window. 

Finding Text 
To search a document for a word or sequence of characters, choose Find in the Edit
menu (F2). 

Copying Text 
Choose Mark in the Edit menu (F6) to start marking text to copy to a file. 
Choose Copy in the Edit menu (F7) to copy the marked text. 

Printing Text 
Choose Print in the File menu to print the document. 

Launching Files 
Choose Launch (F8) to "launch" the document.    If you have set up an application 
for the type of document you are viewing (for example, WordPerfect for a 
WordPerfect document), dtSearch will execute that application with the file you are 
viewing. 

Cursor commands 

      Top of document Home,Home,Up 
      End of document Home,Home,Dn 
      Beginning of line Home,Left 
      End of line Home,Right or End 
      Page up PgUp 
      Page down PgDn 

Menu and Window Commands 

* To get into the main menu, press F10 or click on the main menu with the mouse. 

* To get back to the window from the main menu, press ESCAPE or click on the 
window with the mouse. 



* To move from one window to the next (i.e., if you are viewing more than one file or if
there are search results on the screen), press TAB. SHIFT-TAB moves to the 
previous window. 

* ESCAPE closes a window. 

* See "Viewing Multiple Windows" for more information on viewing documents and 
search results in overlapping windows. 





Editing a File 

      dtSearch for Windows contains a built-in way to access the Windows NOTEPAD 
editor.    This editor cannot edit files in word processor formats such as WordPerfect or 
Ami Pro.    It will only edit DOS text files.    The editor provides limited editing capabilities,
intended mainly for jotting down notes to accompany text clipped from documents.    (To 
clip text from a document, use the Mark and Copy functions, which are explained in the 
chapter on "Viewing Search Results.") 

      To edit a file, choose Edit File from the File menu.    The Edit File dialog box will 
appear.    Enter the name of the file that you want to edit and choose Open.    The 
Windows NOTEPAD editor will pop up over dtSearch with the file you specified.    See 
your Windows documentation for information about using NOTEPAD. 



Printing a File

      When you are viewing a file, you can print the file you are viewing by choosing Print 
from the File menu.    Print will print the entire file, not just what appears on the screen. 

      When you select Print, the Print dialog box will appear.    The Print dialog box allows 
you to set page length, width, and margins, headers, footers, and page numbering.    
The dialog box is the same for DOS and Windows, with the following exceptions: 

      If you want to print to a file instead of to the printer, check the Print to File box.    
After you choose OK, dtSearch will ask for the name of the file to print to.    To select
the printer to use, choose Printer Setup in the File menu. 



DOS Shell

      Choose DOS Shell in the File menu to access DOS from within dtSearch.    When 
you start a DOS shell, dtSearch removes most of itself from memory to leave room for 
any programs you may want to run from DOS.    The dtSearch screen will disappear and
a DOS prompt will appear. 

      To return to dtSearch from a DOS shell, type "EXIT" at the DOS prompt and press 
ENTER.    The dtSearch screen will reappear, as it was before you entered the DOS 
shell. 



Launching Applications

      dtSearch provides an easy way to use dtSearch to edit a file that you have retrieved 
in a search, using the word processor that you used to create the file.    This is called 
"launching" a program. 

      When you launch a program in dtSearch for Windows, the program will appear in a 
window overlaying dtSearch.    You can return to dtSearch after you are done using the 
program, or you can leave both programs on the screen and switch back and forth 
between them using the mouse or ALT-TAB. 

      To launch a program from within dtSearch, you must first tell dtSearch about the 
program.    To do this, choose Applications in the Options menu. After you have set up 
an application in dtSearch, you can press F8 (or click on "Launch") while viewing a 
document belonging to the application, and dtSearch will launch the application with the 
document. 

      You can also launch an application directly.    To do this, choose Launch Application 
the File menu and choose the application you want to launch. 



Setting up an Application

      Choose Applications in the Options menu to associate groups of files with 
applications so that you can "launch" a retrieved document in the application that 
created it.    The Applications dialog box will appear. 

* To define a new application, select "<add new item>" and choose the Edit button. 

* To edit an application that you set up previously, move the cursor to it and choose 
the Edit button. 

      A dialog box will appear allowing you to specify the following for each application: 

Name 
The name that will appear in the list of applications. 

File to Execute 
The name of the file to run to start this application.    For example, if you have 
WordPerfect 5.1 in a directory called C:\WP51, you would enter C:\WP51\WP.EXE 
(the name of the WordPerfect program). 

Directory to Run in 
The "home" directory for this application.    Enter a directory here if you want 
dtSearch to run the application in a specific directory.    If you leave this blank, 
dtSearch will not change directories before running the application. 

Command Line Options 
Enter any command line switches (e.g., "/s", "-d", etc.) that you want dtSearch to 
use when launching this application.    This is optional. 

Run as 
Under "Run as" is a list of five different ways an application can be run: 

      DOS Normal:    dtSearch will remove itself from memory and run the program.    
dtSearch will return after the program is done. 

      DOS Quick:    dtSearch will attempt to run the program without removing itself 
from memory.    This will only work if the program requires very little memory. 

      Windows Normal:    dtSearch will launch the program in Windows. 

      Windows Minimized:    dtSearch will launch the program in Windows as an icon. 

      Windows Maximized:    dtSearch will launch the program in Windows, full-
screen. 



Filename Filter 
The filter to use to match files with this application.    If you leave this blank, all files 
will be included.    This filter is similar to the filters in the Add Documents to Index 
dialog box, except that it can include drive and directory specifications, such as: 

      *\WP42\* Matches anything in a directory named WP42 
      C:*.DOC Matches any filename ending in ".DOC" on drive C: 

File Type 
The file format that is associated with this application.    If you select "Any," all files 
will be included. 

      dtSearch matches files with applications using a combination of the file type and the 
filename filter.    If you specify both, both must match.    If you specify "Any" for the file 
type, only the filter is checked.    If you leave the filter blank, only the file type is checked.

      If more than one application could match a file, dtSearch will prefer the one that can 
run in the current environment (i.e., DOS or Windows). For example, if you defined 
"WordPerfect for DOS" and "WordPerfect for Windows" as two applications associated 
with WordPerfect files, dtSearch would launch WordPerfect for Windows under 
Windows and WordPerfect for DOS under DOS. 

      Here is an example of how to set up WordPerfect 5.1 for DOS as an application and 
launch it: 

* Choose Applications in the Options, move the cursor to "<add new item>" and 
choose OK. 

* Under Name, enter "WordPerfect" 
 * Under File to Execute, enter "C:\WP51\WP.EXE" (assuming that WordPerfect is 

installed in C:\WP51). 

* Under Directory to Run in, enter "C:\WP51". 

* Under Run as, choose DOS Normal. 

* Leave Filename Filter and Command Line Options blank. 

* Under File Type, choose WordPerfect. 

* Choose OK to get back to the Applications dialog box and then choose OK in that 
dialog box. 

      After you have done this, you can press F8 while viewing any WordPerfect document
and you will be able to edit the document in WordPerfect. 



The Options Menu

The Options menu lists options to: 

      * Create and edit macros. 
      * Define applications that you can launch. 
      * Define the file types for word processors that dtSearch cannot recognize 

automatically. 
      * Change the format for the display of search results. 
      * Select a new alphabet file. 
      * Specify other preferences. 



Screen Colors

      Choose Colors in the Options menu to change the way dtSearch displays documents
and menus.    The Colors dialog box will appear.    The first column will list types of 
screen objects that you can modify (Menus, Dialog Boxes, File Viewers, etc.).    When 
you select a screen object from the first column, the second column will list all of the 
parts of the object, such as the scroll bar, normal text, selected text, etc. 

      When you choose an item from the second column, a box to the right of that column 
will display the current color setting for the item.    On a monochrome monitor, a list of 
monochrome screen attributes (underline, highlight, etc.) will appear in this box.    On a 
color monitor, a sample of each possible foreground and background color will appear.   
Use the arrow keys or the mouse to select the color you want for the screen item, then 
press TAB (or use the mouse) to select another item to modify. 

      After you are done changing the colors, choose OK to save your changes.    To 
restore the default colors, choose Default Colors in the Options menu. 





File Types

      dtSearch recognizes most file formats automatically.    If you are indexing only word 
processing files that dtSearch supports and can automatically recognize, you can 
disregard this section.    These include: 

      * Ami Pro 
      * Ascii or DOS Text 
      * dBASE .DBF 
      * Microsoft Works 
      * Microsoft Word 
      * Microsoft Word for Windows through version 6.0 
      * Microsoft Rich Text Format 
      * Multimate Advantage II 
      * Multimate version 4 
      * WordPerfect 5.0, 5.1, and 6.0 
      * WordPerfect 5.1, 5.2, and 6.0 for Windows 
      * WordStar version 4.0 or later 
      * WordStar 2000 

      If you are indexing other types of files, dtSearch provides a way to specify, using 
filename filters, how you want dtSearch to process the files.    For each filter, you can 
specify a "File Type" that tells dtSearch how you want the file to be handled.    The file 
types fall into three groups: 

Older word processors 
If you are indexing files that use older file formats that cannot be recognized 
automatically, use these file types to tell dtSearch how to recognize the files.    
These formats are: WordPerfect 4.2, WordStar versions before 4.0, and XyWrite. 

ASCII and ANSI 
Windows programs use the "ANSI" character set instead of the "ASCII" character 
set used in DOS.    The two character sets are mostly the same but the ANSI 
character set handles accented letters differently from the ASCII character set.    
This is not a problem for word processor files because dtSearch can detect the file 
format and handle the file correctly.    However, for plain text files created with a 
Windows program such as Notepad, dtSearch has no way to know whether the file 
is ANSI or ASCII.    The ASCII and ANSI file types provide a way to specify this. 

Filtered Binary 
This File Type enables you to index files in formats that dtSearch does not 
recognize or that contain a lot of non-text data, such as .EXE files and 
spreadsheets.    "Filtered Binary" tells dtSearch to use an algorithm that attempts to 
extract just the text from the file.    To see the effect of the "filtered binary" format, 
use View File to view a binary file such as C:\COMMAND.COM, enable the filtered 
binary file type (with a filename filter that would include C:\COMMAND.COM), and 



then view C:\COMMAND.COM again. 

      To set up a file type specification, choose File Types in the Options menu.    The File 
Types dialog box will appear. 

* To set up a new file type, select "<add new item>" and choose the Edit button. 

* To edit a file type that you set up previously, move the cursor to it and choose the 
Edit button. 

 A dialog box will appear asking you to specify the following: 

* Type:    Choose the file type you want to set from the list in the dialog box.    The file 
types are explained above. 

* Filename Filter:    Enter a filename filter (i.e., "*.DOC") that will identify files having 
that format.    For example, you can tell dtSearch that any file whose name matches 
"*.W42" is a WordPerfect 4.2 document. 

      The filename filter used in this dialog box is similar to the filter in the Add Documents 
to Index dialog box, except that it can also include directory and disk drive 
specifications, such as: 

      *\WP42\* Matches anything in a directory named WP42 
      C:*.DOC Matches any filename ending in ".DOC" on drive C: 

      You must enter a filename filter for each file type you want to set up, even if the filter 
is just "*.*". 

      Before using the file type information, dtSearch will try to detect the format itself.    
Therefore, no matter what file type specifications you enter, dtSearch will recognize 
formats such as WordPerfect 5.1 that it can detect automatically. 

      dtSearch checks the filename filters in the order that you created them and uses the 
first one that matches. 



Search Results Format

      Choose Search Results Format in the Options menu to modify the format dtSearch 
uses to display search results.    A dialog box will appear listing all of the items that can 
be displayed in search results.    Select the ones you want to be displayed and choose 
OK to save your changes. The only limitation on your ability to customize search results 
is that either the name of the retrieved file or its "title" (the first few words in the file) 
must be displayed. 

      By default, dtSearch will display for each file the number of hits, name, directory, 
modification date, and title. 



Preferences

      Choose Preferences in the Options menu to change the following options: 

Tab size 
The is the width of a tab in a file displayed in a document window. For most word 
processors, this will be specified in the document. However, for ASCII text files, the 
value specified here will be used. 

Quiet mode 
Check this box if you do not want a "beep" every time dtSearch displays an 
information or error message. 

Do not Index binary files 
Check this box if you want dtSearch to skip binary files when indexing.    See the 
chapter on indexing documents for more information about this feature. 

ENTER key means... (DOS version only) 
Use this option to specify how you want the ENTER key to affect dialog boxes in 
dtSearch for DOS.    Under this item are two choices: "Go to next item" and "Select 
OK button." 

If you select the first choice, the ENTER key will take you to the next item in a dialog
box, unless the cursor is on a button.    If the cursor is on a button and you press 
ENTER, the button is pressed. 

If you select the second choice, the ENTER key will work the same way it works in 
Windows.    Pressing ENTER in a Windows dialog box is always the same as 
pressing the OK button.    Instead of using ENTER to get from one item to the next, 
Windows users have to use TAB or the mouse.    If you prefer this, choose the 
"Select OK button" option. 

User Name 
Enter your name here if you will be using dtSearch on a network.    If your network 
supports use of an environment variable such as %USER% or %USERNAME% to 
identify users, you can enter that environment variable here. 



Choose Font

      To change the font that dtSearch uses to display documents, search results, and 
search reports, choose Choose Font in the Options menu.    A dialog box will appear 
listing all of the fonts available on your system, attributes for each (bold, light, italics), 
and the available sizes. Select the font, attribute, and size you want and choose OK. 

      Choose font will not affect windows already on the screen. 



Setup Files

      dtSearch stores user setup information in the following files: 

APPS.DAT Table of applications (for launching) 
ANSI.DAT Table for converting between the WIndows (ANSI) and DOS 

(ASCII) character sets 
DESKTOP.DAT Window layout preferences (DOS version only) 
ENGLISH.ABC Alphabet definition file for English-language text 
FILETYPE.DAT Table of file type specifications 
MACROS.DAT Table of user-defined macros 
OPTIONS.DAT User-specified preferences. 
SRCHDIRS.DAT List of directories to search (unindexed search 
SRCHIX.DAT List of indexes to search (indexed search) 
STEMMING.DAT Stemming to rules to apply in stemming words for searches 

      OPTIONS.DAT is a file that dtSearch uses to store your preferences about screen 
colors, fonts, etc.    Most users will never need to access the file directly, but some 
advanced configuration options can only be changed by editing the OPTIONS.DAT file. 

      OPTIONS.DAT is in Ascii format (similar to the WIN.INI file) and is located in your 
dtSearch directory.    To edit it, you will need a program that can edit and save plain Ascii
text files. 

Note: dtSearch saves an internal copy of your setup information and saves it to 
OPTIONS.DAT when it exits.    If you edit OPTIONS.DAT while dtSearch is running and 
then exit dtSearch, dtSearch will save the old version of OPTIONS.DAT over the new 
version.    If you want to use the dtSearch Edit File option to edit OPTIONS.DAT, use 
Save As to save the edited version under a different name (such as OPTIONS.NEW) 
and then copy OPTIONS.NEW over OPTIONS.DAT after you exit dtSearch. 

      See OPTIONS.DOC for more information about the contents of the OPTIONS.DAT 
file. 



Alphabet Customization

      dtSearch includes a utility called ALPHABET.EXE that allows you to customize 
dtSearch to work with character sets other than U.S. English. ALPHABET works by 
editing tables that dtSearch uses to process text. ALPHABET is very flexible and allows 
you not only to designate characters as searchable or not searchable, but also to 
specify what the rules are for capitalization and for converting between accented and 
unaccented characters. 

      Most users should never have to use ALPHABET since they can work with the 
default alphabet file.    Unless you are using non-English text and need to customize the 
handling of accents, umlauts, etc., there is no reason for you to bother with ALPHABET. 

      If you do need to use ALPHABET to customize character set information for your 
system, please read the entire manual chapter on the ALPHABET utility you begin, 
especially if you have WordPerfect (you may save a lot of time by doing this). 

      To customize the way dtSearch handles characters, first set up a new alphabet file 
using ALPHABET and then choose Alphabet in the Options menu in dtSearch to make 
dtSearch use the new alphabet. 



Alphabet Files

      An alphabet file contains two tables: an alphabet and a WordPerfect table.    The 
alphabet contains general information about each character (whether it is a letter, 
space, hyphen, or ignore character, whether it has an accent or is lower case, and the 
unaccented and upper case equivalent).    The WordPerfect table contains the 
conversion table for WordPerfect characters.    Both of these are described in more 
detail below. 

Note:    dtSearch can only use one alphabet file at a time.    If you change the alphabet 
file after indexing some documents, you should delete the index and rebuild it since it 
will no longer be valid with the modified alphabet file. 



Character Types

      Every IBM PC compatible computer uses a character set containing 256 letters and 
symbols.    The first 128 characters in the set (numbered from 0 to 127) are called the 
ASCII character set and are the same for all PCs.    The 128 ASCII characters include 
the letters of the English alphabet (a-z and A-Z), the digits (0-9), punctuation, and 
certain other characters. 

      The other 128 characters (numbered from 128 to 255) differ from one PC to another, 
depending on the language that the PC is set up to use.    For example, on one PC, 
character number 150 might be an accented "e," while on another it could be an "O" 
with two dots above it. 

      A dtSearch alphabet table classifies each character into one of four types: "letter," 
"space," "hyphen," and "ignore." 

letter A "letter" is any character that you want to be able to search for.    All of the 
characters in the alphabet (a-z and (A-Z) and all of the digits (0-9) should 
be classified as letters. 

space A space is any character that you want to cause a word break. For 
example, if you classify the period (".") as a "space" character, then 
dtSearch would process "U.S.A." as three separate words: "U" "S" and "A". 

hyphen A hyphen causes special handling of the words surrounding it. Usually only 
two characters get classified as "hyphen": the ASCII hyphen ("-") and the 
underscore ("_").    dtSearch indexes a hyphenated word as four different 
words to cover all possible ways to search for the word. "Full-text" would be
indexed as "full," "text," "fulltext," and "full-text." 

ignore An ignored character is disregarded in processing text.    If you classify the 
period as "ignore" instead of "space," then dtSearch would process "U.S.A."
as one word: "USA". 



Windows Character Set

      Microsoft Windows uses its own character set, called the "ANSI" character set.    
Certain Windows word processors, such as Lotus Ami Pro, use the ANSI character set 
rather than the ASCII character set for storing text.    dtSearch handles ANSI characters 
in documents by converting them to their ASCII equivalents. 

      The default table dtSearch uses to convert documents using the ANSI character set 
is in a file called ANSI.DAT, which is included with dtSearch.    If you are working with 
non-English language text in Windows-based word processors, you will probably want 
to generate an ANSI.DAT table customized for your system.    To do this, remove 
ANSI.DAT from your dtSearch directory and then run dtSearch for Windows.    dtSearch 
for Windows will see that ANSI.DAT is missing and generate a new copy of the file using
information supplied by Windows. 



Letter Types

      dtSearch alphabet tables store additional information about characters that are 
classified as letters.    The table will indicate which letters are upper and lower case, and
it will also indicate which letters have accents.    For lower case letters, the table will 
contain an upper case equivalent.    For accented letters, the table will contain an 
unaccented equivalent. 

      dtSearch uses these equivalents when you build an index or do a search.    When 
you create an index, you can specify whether you want the index to be "case 
insensitive" and whether you want it to be "accent insensitive."    A case insensitive index
converts all text to upper case in the index, so that "Apple," "apple" and "ApPlE"    would 
all be treated the same as "APPLE."    If an index is case sensitive, "Apple," "apple," and
"APPLE" would be regarded as three different words.    If you are working with normal 
text, a case-sensitive index would be a very bad idea since, when you enter a search for
"apple," you would generally not want to miss a document containing "Apple."    Case 
sensitive indexes may be useful, however, for programmers indexing program code. 

      Similarly, an "accent insensitive" index strips the accents from text in the index, so 
that letters with cedillas, tildes, etc. are converted to their unaccented equivalents.    It is 
generally best to make indexes accent insensitive since this minimizes the chance that 
you will miss retrieving a document because of a forgotten accent. 



WordPerfect Conversion Tables

      WordPerfect documents can contain special characters from one of twelve different 
WordPerfect character sets.    This allows WordPerfect documents to contain 
characters, like accented letters, mathematical symbols, and Greek letters, that are not 
in the basic ASCII character set. 

      WordPerfect defines over 1500 special characters, which are divided into groups of 
up to 250 characters each.    The groups are called "Character Sets."    The WordPerfect
character sets are:    Ascii, Multinational 1 (accents and accented letters), Multinational 2
(more accents), Box Drawing, Typographic Symbols, Iconic Symbols, Math/Scientific, 
Math/Scientific Extension, Greek, Hebrew, Cyrillic, Hiragana and Katakana, and User 
Defined.    Take a look at the appendix of your WordPerfect manual to see what the 
character sets look like. 

      To handle WordPerfect characters, dtSearch needs to be able to tell how each 
WordPerfect character should be displayed on your system.    To do this, dtSearch uses 
a conversion table that allows you to specify how you want each of the WordPerfect 
special characters to be indexed and displayed in dtSearch.    This conversion table is 
separate from the alphabet table described above.    When dtSearch encounters a 
WordPerfect special character, it first uses the WordPerfect conversion table to 
determine what the character means, and then uses the alphabet table to determine 
how the character should be indexed.    For example, if dtSearch finds character number
62 from WordPerfect character set 1 in a document, it will look it up in the table and see 
that this corresponds to an "O" with two dots over it.    It will then look in the alphabet 
table to determine whether this character is a letter, whether it is upper or lower case, 
and whether it has an accent. 



Creating an Alphabet File

      The ALPHABET utility contains three top-level menus: File, Alphabet, and 
WordPerfect. The File menu allows you to open, close, save, or rename an alphabet 
file.    Once you have opened a file, you can use the Alphabet menu to modify the 
alphabet or use the WordPerfect menu to modify the WordPerfect table. 

Editing the Alphabet 

      When you open an alphabet file, a window will appear on the screen that allows you 
to edit the alphabet in the file.    Characters are divided into seven groups:    upper-case 
letters, lower-case letters, accented upper-case letters, unaccented lower-case letters, 
spaces, hyphens, and ignored characters. 

      To modify the characteristics of a character, move the cursor to it (or click the mouse 
on it).    A dialog box will appear allowing you to specify the following: 

* Whether the character is a letter, space, hyphen, or ignored character. 

* Whether the character is lower case or accented. 

* If the character is lower case or accented, what the upper case and unaccented 
equivalents would be for the character. 

Set Alphabet to Default 

      If you select "Set to default" in the Alphabet menu, ALPHABET will generate the 
default DOS alphabet for your computer.    Since DOS does not know whether a 
character is accented or not, most accented letters will be classified as unaccented in 
the default alphabet.    If you want dtSearch to be able to correctly handle accent-
insensitive indexes, you will need to edit the resulting alphabet to include information 
about accents. 

Generate using WordPerfect 

      This option is somewhat complicated to use, but it provides a very powerful shortcut 
to customizing an alphabet for your system. WordPerfect includes a file called 
CHARACTR.DOC, which lists every character in the WordPerfect character set.    This 
file is in WordPerfect format and you can edit it like any other WordPerfect document.    
To generate an alphabet using WordPerfect, you would do the following: 

1. Retrieve CHARACTR.DOC into WordPerfect. 

2. Press CTRL-F5 ("Text In/Out"), 1 ("DOS Text"), 1 ("Save").    This will allow you to 
save CHARACTR.DOC in DOS Text format. 



3. Enter a name that is not the same as CHARACTER.DOC.    Call it something else, 
like "CHARS.TXT".    (Otherwise you will overwrite your existing CHARACTR.DOC 
file.) 

4. Exit WordPerfect.    Do NOT save the file. (You have already saved it in CHARS.TXT
as a DOS Text file.) 

5. Run ALPHABET and open a file for the alphabet you want to create. 

6. Choose Generate using WordPerfect in the Alphabet menu and, under File to 
generate from, enter the name of the file you just created (i.e., CHARS.TXT).    
ALPHABET will analyze the CHARS.TXT file and produce an alphabet for your 
system based on the file. 

      How does this work?    When WordPerfect saves a file in DOS Text format, it converts
the WordPerfect special characters in the file to the appropriate equivalent characters 
for the your computer.    Thus, the resulting CHARS.TXT file is a table showing, for each 
of the special WordPerfect characters, what the is equivalent character on your 
computer.    ALPHABET knows how to read this table and use it to deduce which 
characters on your computer are letters, accented letters, upper case letters, etc.    The 
resulting alphabet is usually very close to what you will want (there may be one or two 
misplaced characters, which you can clean up by hand). 

Generate printable chart 

      This command simply generates a printable chart listing information about each 
character in an alphabet.    This is useful if you want to keep a record of the changes 
you have made. 



Creating a WordPerfect Table

      The ALPHABET utility allows you to modify the way dtSearch treats special 
characters in WordPerfect documents by editing the WordPerfect character conversion 
table in an alphabet file.    Note that the WordPerfect character table is separate from 
the alphabet table described above.    Changes to the WordPerfect character table do 
not affect the alphabet settings (i.e., which characters are "letters," "ignore," etc.). 

      To modify the WordPerfect character conversion table in an alphabet file, you must 
first open an alphabet file in the ALPHABET utility. (Choose Open in the File menu.)    
Then choose Edit Character Sets in the WordPerfect menu to edit the WordPerfect 
character conversion table.    A dialog box will appear with a list of the WordPerfect 
character sets on the bottom and a chart showing the currently selected set on the top. 

      The chart showing the currently selected character set is drawn in exactly the same 
format used in the appendix of the WordPerfect manual, so you can easily compare the 
appearance of the characters on the screen with the chart in the manual.    Characters 
that ALPHABET does not know how to display on your system will appear as a question
mark ("?"). 

      To see one of the character sets, press TAB to get into the list of character sets and 
then use the cursor to select the one you want, or just click on the name of the 
character set you want with the mouse.    The chart will display the character set you 
have selected. 

      To change the appearance of a character, move the cursor to it and press ENTER, or
click on the character with the mouse.    A dialog box will appear that will allow you to 
select a character to be used to represent the WordPerfect character you selected. 

      At any time, you may restore the default values for the WordPerfect Conversion table
by pressing the "Restore Default" button in the dialog box.    Any changes you have 
made will be lost. 

      As with alphabet customization, ALPHABET provides a powerful shortcut to 
customizing the WordPerfect table for your system, again using the WordPerfect 
CHARACTR.DOC file.    Follow the procedure described above to create a CHARS.TXT 
file, and then do the following: 

1. In the WordPerfect menu, choose Edit Character Sets. 

2. Choose Generate in the WordPerfect Character Tables dialog box. 

3. A dialog box will appear asking for the name of the file to generate from.    Enter the 
name of the CHARS.TXT file you created.    ALPHABET will deduce from the table 
in CHARS.TXT how each member of the WordPerfect character set should appear 
on your system. 



      After you have modified the WordPerfect table you can test it by viewing the 
CHARACTR.DOC file in dtSearch. 



Hypertext Documents

      A dtSearch hypertext document is an Ascii text file that begins with the words 
"dtSearch Hypertext" on the first line.    This text is not displayed in dtSearch and is used
only to signal that the rest of the document should be interpreted as hypertext. 

      dtSearch can view, index, and search hypertext documents like any other type of 
document.    Hypertext links will appear highlighted when a document is viewed.    
Hypertext links can point to another document, a particular point in another document, 
or can launch another program (such as a graphics viewer). 

15.1    Hypertext Links -- Basic 

Hypertext links have the following format: 

      Sample text. @Highlighted text@^other.doc^ More text 

In the example above, the text between the @ marks is highlighted and the text 
between the ^ marks is the hypertext link associated with the highlighted text.    Pressing
ENTER while the cursor is on the highlighted text would tell dtSearch to display 
other.doc. 

15.2    Hypertext Links -- Complex 

      A hypertext link can be a simple filename, as in the above example, or it can be more
complex.    More complex links contain a series of the following items: 

        *F name          Name of the file to view 

        *W count Position cursor after <count> words in the file. 

        *E command "Launch" the command 

        *C Close the current window.    If a link does not contain a *C, a 
new window will pop up over the current window when the user 
chooses the link. 

If a link does not supply a full pathname, dtSearch will assume that the file is in the 
same directory as the file being viewed.    For example, if C:\JOE\DOCS\FIRST.DOC 
contains a link to "SECOND.DOC", dtSearch will assume that SECOND.DOC is in C:\
JOE\DOCS. 

Examples: 

        ^*F smith.doc *W 500 **^ 
View smith.doc with the cursor positioned after the 500th word.    Do not close 



the current window when the user selects the link. 

        ^*F smith.doc *C **^ 
Close the current document and open a window displaying smith.doc. 

        ^*E c:\viewer\view.exe image1.pcx **^ 
Launch "view.exe" and have it display image1.pcx. 

15.3    Changing the marker characters 

Since dtSearch uses ^ and @ to recognize hypertext links, these characters cannot be 
used in document text.    If you need to use ^ or @ in document text, you can use the 
LinkMark and TargMark commands to specify different marker characters.    Example: 

        .LinkMark # 
        .TargMark ~ 

LinkMark is @, the character used to mark highlighted text.    TargMark is ^, the 
character used to indicate the "target" of a hypertext link. 

15.4    Titles 

The .title command in a document changes the way the title of the document is 
displayed in dtSearch.    Normally, the title of the window displaying a document is the 
filename.    If a hypertext document contains a .title command, the supplied title will 
replace the filename.    Example: 

      .title Instruction Manual -- Chapter 1 



Program Limits and Requirements

1.    Program limits:    Indexes 
      * A single index may contain up to 15,000 documents.    There is no limit on the 

number of indexes you can have. 
      * There is no limit on the number of words or paragraphs that a document can 

contain. 
      * An index library can hold up to 25 indexes, and there is no limit on the number 

of index libraries you can create. 

2.    Program limits:    Searches 
      * A search word can be up to 32 letters long. 
      * A search request can be up to 180 characters long. 
      * You can have up to 25 macro definitions. 

3.    System requirements: 
      * dtSearch for DOS will run on an IBM-compatible computer with a 286 or higher 

processor, at least 2 Mb of memory available, a hard disk, and DOS version 3.3 
or higher. 

      * dtSearch for Windows requires Windows version 3.1 and a 386 or higher 
processor.    It will not run under Windows version 3.0. 

      * dtSearch can use network drives and supports multiuser access to indexes 
stored on network drives. 

4.    Document Types 
dtSearch can index and search documents in the following formats: 

      * Ami Pro 
      * ASCII or DOS Text 
      * dBASE .DBF 
      * Microsoft Works 
      * Microsoft Word 
      * Microsoft Word for Windows through version 6.0 
      * Microsoft Rich Text Format 
      * Multimate Advantage II 
      * Multimate version 4 
      * WordPerfect 4.2, 5.0, 5.1, and 6.0 
      * WordPerfect 5.1, 5.2, and 6.0 for Windows 
      * WordStar through version 6 
      * WordStar 2000 
      * XyWrite 

      Using the Filtered Binary file type, dtSearch can index, search, and display text from 
spreadsheets and other unrecognized file formats. 



Error Messages (A-E)

"Application table is full" 

You can define up to 7 applications in dtSearch.    If you attempt to add more, this 
message will appear. 

"Cannot copy an index onto itself" 

You have asked dtSearch to copy an index, and either (1) the directory to copy it to 
is the same as the directory the index currently occupies, or (2) the name of the 
index to copy is the same as the new name for the copied index.    When you copy 
an index, the name and directory for the new index must be different from the name 
and directory of the existing index. 

"Cannot overwrite protected file type" 

This message will appear if you attempt to use Edit File to edit a document that 
dtSearch recognizes as a word processing document.    To protect against 
accidental destruction of original documents, dtSearch considers all files with 
special formatting codes that it recognizes (such as WordPerfect files) to be 
"protected."    dtSearch will not overwrite such files. 

"Directory xxx already contains index yyy" 

A directory can only hold one index.    If you try to use Create Index to create a 
second index using the same directory name, this message will appear. 

"Error launching application" 

dtSearch tried to execute a program and the program returned an error code.    This 
means that something when wrong in the launched program. 

"Error(s) in search request -- CONTAINS without a TO" 

A segment search has the form beginning TO end CONTAINS contents.    The 
beginning TO end part defines where dtSearch should search, and the contents part
is what dtSearch should look for.    If you leave out the "TO" part, dtSearch has no 
way to know what the segment to be searched is. 

"Error(s) in search request -- Illegal use of the TO connector" 

The TO connector is used to define a segment for a segment search. The format for
a segment definition is beginning TO end, where beginning marks the beginning of 
the segment and end marks the end.    Both parts of the segment definition may 
consist only of words, phrases, and the OR connector -- other connectors are not 



permitted in segment definitions. Thus, "(apple or pear) to (grape or fish)" is legal; 
"(apple and pear) to (grape or fish)" is not. 

"Error(s) in search request -- Illegal use of W/N connector" 

Some search requests using the W/N connector are ambiguous or impossible to 
evaluate.    See the manual section on the W/N connector for more details. 

"Error(s) in search request -- Invalid date" 

dtSearch will display this message if it finds XDATE in a search request without a 
valid date after it.    Likely causes of this error are a misspelled month, a missing 
year, or a missing BEFORE, AFTER, or IS connector.    A valid date search looks 
like one of the following: 

            XDATE IS date 
            XDATE BEFORE date 
            XDATE AFTER date 

"Error(s) in search request -- Missing words" 

This message appears when you have left one or more words out of a search 
request.    Example: "apple and pear and" 

"Error(s) in search request -- Parentheses do not balance" 
 This just means that you have left out an opening or closing parenthesis in a search

request. 

"Error reading WordPerfect file" 

WordPerfect files occasionally become corrupted due to disk problems or 
WordPerfect bugs.    When dtSearch reads a WordPerfect document, it checks for 
errors in the file and displays this message if it finds any. Note:    You can generally 
fix a corrupted WordPerfect document by (1) getting the most recent release of 
WordPerfect and (2) retrieving the document into WordPerfect, scrolling to the end 
of the file, and saving it. 

"Error running script" 

This message will appear after you have executed a batch script and errors 
occurred.    Check the log file created during execution of the script to see what 
happened.    (The log file will have the same name as the script file but it will end in 
".LOG".) 



Error Messages (F-M)

"File xxx is not a script file" 

You have attempted to execute a file using the /SCRIPT option, and dtSearch 
determined that the file was not a batch script.    All dtSearch batch scripts must 
begin with the words "DTSEARCH SCRIPT." 

"Index already exists" 

If you try to create an index that already exists in a different directory, this message 
will appear.    If you are trying to create a new index, try using a different name for 
the new index, or (if you do not want the old index) deleting the old index.    If you 
are trying to re-create an existing index, make sure the directory you have selected 
is the same one that you used to create the original index. 

"Index has version 1.x format" 
"Index has version 2.x format" 

You have asked dtSearch to search or update an index created by an old version of 
dtSearch.    dtSearch cannot use these indexes. 

"Index is full" 

An index can hold up to 15,000 documents.    If you try to add more than 15,000 
documents to an index, you will get this message.    (You can still reindex 
documents already in the index.) 

Even if you have less than 15,000 documents, you may still get this message if you 
have reindexed some documents without compressing the index.    When you 
reindex a document, dtSearch adds information about the new document to the 
index but does not remove information about the earlier version.    For example, if 
you have 10,000 documents in an index and you reindex them several times without
compressing the index, you may get an "Index is full" message because the index 
will still contain information about obsolete versions of the documents.    If you want 
to see how many obsolete documents are stored in an index, use the "Index 
Information" option in the Index menu.    Use Compress to clean obsolete 
documents from your index. 

"Index library is full" 

An index library can hold a maximum of 25 indexes.    If you try to create, copy, or 
recognize an index when you have reached this limit, you will get this error 
message.    Try either deleting any indexes that you do not need, or creating a new 
index library to use for the new index. 



"Index too large to fit on drive" 

You have asked dtSearch to copy an index and there is not enough space for the 
index on the drive where it is to be copied. 

"Indexing was interrupted.    Index is unusable." 

If dtSearch is interrupted while updating an index, the index becomes damaged and
cannot be used.    Delete the index and rebuild it. 

"Invalid disk drive" 

This means that you have asked dtSearch to access a disk drive that does not exist 
on your computer. 

"Macro is circular" 

A circular macro is one that references itself, directly or through other macros.    
Such a macro would expand infinitely if used in a search request. 

"Macro not found" 

dtSearch assumes that any search term beginning with the "@" character is a 
macro name.    If it does not find a macro with this name, this message appears. 

"Missing file" 

One of the files that dtSearch needs is missing.    Try re-installing dtSearch to 
restore the missing file. 



Error Messages (N-S)

"No application to launch" 

You have tried to "launch" an application with a file, and dtSearch was unable to 
match the file with an application.    When you launch an application with a file, 
dtSearch checks the type and name of the file you launched against the 
applications you set up in your applications table.    If dtSearch cannot find a match, 
this message will appear.    Try checking the application you intended to launch by 
choosing Applications in the Options menu to make sure the application was set up 
correctly. 

"No files retrieved" 

Your search did not retrieve any documents. 

"No files to index" 

This means that you tried to add some documents to an index, but either you did 
not specify any files to be added or all of the files were already in the index. 

"Noise word used in search request" 

A noise word is a word like "the" or "if" that is so common that it is not useful in 
searching.    This message will appear if one of the words in a search request is a 
noise word in the index you are searching.    See the manual section on noise words
for more information. 

"Not enough memory" 

dtSearch did not have enough memory to perform a requested action.    If you have 
a relatively small amount of memory available, you may get this message when you
try to do a search or update an index while you are viewing documents or search 
results on the screen. 

"Not enough space to compress or update index" 

dtSearch did not find enough disk space available to update or compress an index.   
dtSearch requires free space of about one-third the size of a group of files to index 
those files.    To compress an index, dtSearch requires free space at least equal to 
the size of the index to be compressed.    If you get this message, try removing 
some files from the disk or moving the index to a disk drive with more space 
available. Also, try indexing smaller groups of files. 

"Not found" 



You have used Find (F2) to search for text in a document, and the text was not 
found. 

"Printer error" 
"Printer out of paper" 
"Printer not responding" 
"Printer not selected" 
"Printer timeout" 

The printer did not respond correctly when dtSearch tried to print something.    
Check the cables and make sure the printer is turned on, selected, has paper in it, 
and is not jammed.    dtSearch reports the problem that DOS told it about, but 
sometimes either the printer or DOS does not report the problem correctly.    For 
example, you may get a "Printer out of paper" error message when the printer is not
turned on. 

"Search request is too long" 

It is possible, using macros, to generate search requests longer than the 180-
character maximum.    When this happens, you will get a "Search request is too 
long" error message. 



Error Messages (T-Z)

"To create an index, you must enter a name for the index" 

You have used Create Index to create a new index and did not enter a name for the 
index. 

"Too many files retrieved -- search halted" 

By default, dtSearch will halt a search after 99 files have been retrieved.    If you 
would like to change this number, choose Preferences in the Options menu and 
change the value for Search limit. 

"Too many words retrieved in index" 

Your search request contained extremely broad search terms, such as "(r* w/5 s*) 
and t*," that matched several hundred words in an index. Try using more specific 
search terms. 

"Unable to access drive" 

You have asked dtSearch to access a disk drive and there is some problem with the
disk drive.    If you were trying to access a floppy disk drive, make sure that there is 
a disk in the drive, that the disk is correctly inserted, and that the drive latch is 
closed.    If you were trying to access a hard disk drive, the drive you requested may
not exist or there may be a problem with your hard disk. 

"Unable to access ..." 
"Unable to read ..." 

dtSearch cannot find the file or directory you specified.    Check that the file or 
directory name is correct and that you are using the right disk or disk drive. 

"Unable to create ..." 
"Unable to write ..." 
"Unable to save ..." 

dtSearch cannot write to or create the file or directory you specified.    Check that 
the file or directory name is correct and that you are using the right disk or disk 
drive.    These messages may also appear when a disk is full. 

"Unable to access index" 

dtSearch was unable to find the index where it was supposed to be. The most likely 
cause for this message is that part or all of the index was accidentally deleted or 
moved. 



"Unable to use directory.    Use the /dir command-line option to specify a different 
directory." 

On a network, each user must have a private directory to use for temporary files.    
You have asked dtSearch to use a directory that another user is using.    See "Using
dtSearch on a Network." 

"You must create an index before using this command" 

You have tried to execute a command that cannot be used unless you already have 
an index to work with.    Choose Create Index (Basic) in the Index menu to create an
index. 

"You must have a document or search results window open to use this command" 

You have tried to use a command that works with one or more document or search 
results window (such as Print, Local Menu, Cascade Windows, or Tile Windows) 
and there are no windows currently open. 



Technical Support

For technical support on dtSearch, please contact the Advanced Support Group: 

Telephone: (314) 965-5630 
FAX: (314) 966-1833 
BBS: (314) 966-1833 
CompuServe: 70304,3642 

You can reach DT Software, Inc., at (703) 521-9427, by mail at 2101 Crystal Plaza 
Arcade, Suite 231, Arlington, Virginia 22202, or on CompuServe at 72607,3323. 



How to Order a Site License

Site licensing enables companies, departments, government agencies, etc., to equip 
their personnel with software at greatly reduced cost. The company purchasing a site 
license (the licensee) typically provides a single point of contact for shipping, technical 
support, upgrades, etc., and we (the licensor) provide a single master of the diskettes 
and manual. 

A site license for dtSearch for DOS or dtSearch for Windows costs $500 plus $75 per 
user.    A combined DOS/Windows site license is also available for $500 plus $100 per 
user.    This site license enables each licensed user to use both dtSearch for DOS and 
dtSearch for Windows. 

To order a dtSearch site license, please contact the Advanced Support Group: 

Telephone: (800) 788-0787 
FAX: (314) 966-1833 
BBS: (314) 966-1833 
CompuServe: 70304,3642 

You can reach DT Software, Inc., at (703) 521-9427, by mail at 2101 Crystal Plaza 
Arcade, Suite 231, Arlington, Virginia 22202, or on CompuServe at 72607,3323. 



How to Order dtSearch

To order dtSearch, please contact the Advanced Support Group: 
Telephone: (800) 788-0787 
FAX: (314) 966-1833 
BBS: (314) 966-1833 
CompuServe: 70304,3642 

Prices: 

    dtSearch for DOS: $149.00 
    dtSearch for Windows: $149.00 
    Both: $199.00 
    LAN -- 5 Concurrent Users 
          DOS only $650.00 
          Windows only $650.00 
          DOS and Windows $800.00 

You can reach DT Software, Inc., at (703) 521-9427, by mail at 2101 Crystal Plaza 
Arcade, Suite 231, Arlington, Virginia 22202, or on CompuServe at 72607,3323. 
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