314

Installation & neue Versionen
03.04.2004 15:18
> Fehlermeldung „oleacc.dll not found“
> Installer oder Programmdatei?
> Wie kann ich eine neue Version verwenden ohne meine Dateien zu verlieren?
> Wechsel von eDonkey / Overnet zu eMule ohne Download-Verlust
Spielt das Betriebssystem eine Rolle?
eMule läuft auf allen Windows Versionen ab Windows 98. Durch die vielen Verbindungen, die eine p2p Anwendung aufbaut sind jedoch neuere Betriebssysteme wie Windows 2000 oder XP besser geeignet als Windows 98 / ME.
Von der Verwendung von Registry Einträgen, die die Verbindungszahl unter Win 98 steigern sollen, wird abgeraten da diese meist nur das System instabil machen.
Top
Fehlermeldung „oleacc.dll not found“
Diese Fehlermeldung tritt u.U. bei Windows 98 auf. Das von Microsoft bereitgestellte System Update liefert die notwendige Datei.
Top
Installer oder Programmdatei?
Die Installer-Variante hat ein Setup Programm, welches alle notwendigen Dateien in das angegebene Verzeichnis kopiert.
Die Programmdatei ist ein Archiv, das alle Dateien mit Ausnahme der Hilfe enthält. Diese Datei muss in das gewünschte Verzeichnis entpackt werden.
Für die erste Verwendung ist der Installer empfohlen, bei einem Versionsupdate reicht die Programmdatei aus.
Top
Wie kann ich eine neue Version verwenden ohne meine Dateien zu verlieren?
Die neue eMule Version wird einfach in das alte eMule Verzeichnis entpackt oder installiert. Konfigurationsdateien, alle Einstellungen und Dateien im Download bleiben erhalten.
Wird eine neue Version installiert muss eMule vorher beendet werden! Taucht der Assistent bei einer neuen Version auf, es sollen aber alle Einstellungen erhalten bleiben, einfach aus Abbrechen klicken.
Top

Wechsel von eDonkey / Overnet zu eMule ohne Download-Verlust
eDonkey / Overnet hat in der Version .47 das System umgestellt in dem angefangene Downloads gespeichert werden. eMule benutzt ein System in dem ein unvollständiger Download an einem Stück gehandhabt wird, die neueren eDonkeys teilen ihn jedoch in mehrere kleine Bruchstücke auf.
Bei Versionen vor .47 reicht es aus in eMules Einstellungen den Pfad zu den unvollständigen eDonkey Downloads anzugeben, oder die angefangenen Downloads in das Tempverzeichnis von eMule zu verschieben (wenn eMule nicht gestartet).
Die neueren Versionen bieten zwar eine Option "old style format" an, welche die Downloads wieder an einem Stück speichert, jedoch sind die part.met (Downloadbeschreibungs-Datei) weiterhin in einem neuen Format und inkompatibel.
eMule v0.30c führt eine Import-Funktion ein, welche es erlaubt, Downloads im alten Format, im neuen gesplitteten und im erwähnten "old style format" zu eMule hinzuzufügen. Die Fremdformate werden konvertiert.
Die Download-Importierung kann über das Hotmenü (Alt+X) aufgerufen werden. Alles was dort zu tun ist, ist ein/mehrere Verzeichnisse mit begonnenen Downloads (part-Dateien) anzugeben. eMule versucht automatisch das Part-System zu erkennen und geeignet auszulesen. Nach erfolgreicher Konvertierung wird die Datei unmittelbar den Downloads hinzugefügt.
Top

Aktualisiert: 2003-02-27 by Monk


315

Server, Verbindung & ID
03.04.2004 16:14
> Woher bekomm ich eine Serverliste?
> Welcher Server ist der Beste / Schnellste?
> Wie oft muss ich meine Serverliste aktualisieren?
> Warum verbindet sich eMule nicht?
> Warum bekomme ich nur eine niedrige ID?
> eMule verliert die Serververbindung immer wieder
Wie verbinde ich zum Kademlia Netzwerk?
eMule versucht automatisch über andere Kademlia Teilnehmer eine Verbindung aufzubauen. Gelingt dies nicht, einfach normal zum eD2k Netzwerk, d.h. zu einem Server verbinden und einen Download starten. Kademlia wird kurz darauf selbständig verbinden.
Top
Woher bekomm ich eine Serverliste?
http://ed2k.has.it – Einfach auf Add to eMule klicken
Top
Welcher Server ist der Beste / Schnellste?
Der Server spielt kaum eine Rolle. Sie dienen nur zum Suchen und dem Finden von Quellen. Quellen findet eMule allerdings viel einfacher und schneller indem er sie mit anderen tauscht.
Top
Wie oft muss ich meine Serverliste aktualisieren?
Wird eMule regelmässig benutzt, aktualisiert er selbst die Serverliste ständig. Hierzu die Funktionen Einstellungen -> Server -> Server-Adressen vom verbundenen Server beziehen und -> Server-Adressen von verbundenen Clients beziehen aktivieren. Regelmässiges aktualisieren ist dann nicht mehr notwendig.
Top
Warum verbindet sich eMule nicht?
Manchmal dauert es ein Weilchen bis ein freier Server gefunden wird. Verbindet sich eMule hartnäckig nicht, kann das an einer leeren / veralteten Serverliste oder einer Firewall liegen. Im ersten Falle eine neue Serverliste herunterladen und überprüfen ob nicht eine Firewall den Internetzugriff von eMule blockiert.
Du solltest auch überprüfen ob die Funktion Automatisches Verbinden nur zu Servern aus statischer Liste in Einstellungen -> Server aktiviert ist. Ist dies der Fall müssen in dieser Liste auch funktionierende Server sein, sonst kann sich eMule nicht verbinden. Einfach deaktivieren - mehr Details hierzu im entsprechenden Hilfekapitel.
Top
Warum bekomme ich nur eine niedrige ID?
Für das reibungslose Funktionieren von eMule ist es notwendig dass folgende Ports für eingehende Verbindungen offen sind:
• 4662 TCP (niedrige ID beim Server)
• 4672 UDP (firewalled in Kademlia)
• 4711 TCP (kein Zugriff auf das Webinterface)
Folgende Punkte können für blockierte Ports verantwortlich sein:
• Firewalls - auch die in Windows XP integrierte (WinXP SP2 aktiviert diese stadardmässig!)
• Router
• Einwahlprogramme ins Internet, z.B. Fritz! Software
• Connection sharing software / Software routers, z.B. Windows XP Internetverbindungsfreigabe
• Netzwerke die NAT verwenden
• Port wird vom Internet Anbieter blockiert
Die verwendete Software sollte auf Firewall- oder Routingfunktionen überprüft und ggf. richtig konfiguriert werden, so dass eingehende Verbindungen auf diesen Ports möglich sind. Es können auch in Einstellungen -> Verbindungen ein andere Client Port angegeben werden, z.B. 6666, 80, 20, 21 Weitere Informationen in den Kapiteln Firewall und Router der Hilfe.
Top
Warum verliert eMule die Serververbindung immer wieder?
Es gibt mehrere Gründe warum Server die Verbindung trennen könnten:
• zu viele Dateien in der Transferliste (nur eMule vor v.30a)
• zu viele Dateien freigegeben (nur eMule vor v.29a)
• überlasteter Server
• allgemeiner Netzwerkfehler
Der Verlust der Serverbindung ist unkritisch da eMule sofort eine neue aufbaut.
Top

Aktualisiert: 2003-09-03 by Monk


316

Einstellung & Geschwindigkeit
03.04.2004 16:15
> Wovon hängt die Downloadgeschwindigkeit ab?
> Welche Einstellungen sind zu empfehlen?
> Kann ich meine Downloads schneller machen?
> Welche Downloadraten sind zu erwarten?
> Wie gross sollte die Warteschlange sein?
Ist eMule ein Programm, das ich kurz anwerfe, davor sitze und warte, dass das neueste Heimvideo fertig ist?
Nein, definitiv nicht. Im eMule Netzwerk werden hauptsächlich grosse Dateien mit anderen geteilt. Es gilt die einfache Regel „Gesamter Upload im Netzwerk = Gesamter Download im Netzwerk“ Bei den niedrigen durchschnittlichen Uploadraten der Internetanbietern ist eine gewisse Dauer für diese Downloads einfach gegeben.
Top
Wovon hängt die Downloadgeschwindigkeit ab?
Mehrere Faktoren beeinflussen die Geschwindigkeit der Downloads:
• Einstellungen in eMule
• Hohe ID (Firewall und Router Einstellungen)
• Onlinezeit von eMule
• Anzahl der Quellen für einen Download
• Verbreitung der Dateiteile
• Popularität des Downloads
Falsche Einstellungen in eMule (falsche Limits, zu viele Verbindungen), eine niedrige ID, nur kurze Onlinezeit wirken sich stark negativ auf die Downloadgeschwindigkeit aus. Sehr populäre (neu erschienene) Downloads mit geringer Verbreitung oder allgemein Downloads mit wenig Quellen (unter 100) haben auch meist nur geringe Downloadraten.
Top

Welche Einstellungen sind zu empfehlen?
Grundsätzlich sollte der Assistent benutzt werden um gute Grundeinstellungen zu erhalten. Wichtig sind besonders Angaben zur Verbindung und dem benutzten Betriebssystem.

Für das weit verbreitete T-DSL – 768/128, entspricht einem maximalen Download von 96 kB/s und einem Upload von 16 kB/s (man beachte den Unterschied zwischen Up und Down!) empfehlen sich folgende Einstellungen:

Windows XP
 | Download Kapazität: 96 (= 768 / 8)
 | Upload Kapazität: 16 (= 128 / 8)
 | Download Limit: kein Limit (Haken raus)
 | Upload Limit: 12
 | Hard Limit: 500
 | Max Verbindungen: 400
 | Max neue Verbindungen pro 5s: 30
 | Ca. 6 bis 20 Downloads in der Liste
Windows 98 / ME
 | Download Kapazität: 96 (= 768 / 8)
 | Upload Kapazität: 16 (= 128 / 8)
 | Download Limit: 92
 | Upload Limit: 12
 | Hard Limit: 300
 | Max Verbindungen: 200
 | Max neue Verbindungen pro 5s: 30
 | Maximal 12 Downloads in der Transferliste

Alternativ kann die beste Einstellung für die Up- und Download Limits eMule überlassen werden (Haken bei den Limits raus). Hierfür muss in den Einstellungen -> erweiterte Einstellungen die USS Funktion aktiviert werden. Dies stellt sicher dass ein optimaler Upload für das Sammeln von Kreditpunkten erreicht wird und auch Onlinespiele und Surfen flüssig laufen. eMule regelt die Geschwindigkeiten automatisch aus.
Top

Kann ich meine Downloads schneller machen?
Neben den richtigen Einstellungen in eMule entscheiden nur noch die Dateien in der Transferliste über die Geschwindigkeit. Für eine gleichmässige Geschwindigkeit:
• eMule möglichst lange laufen lassen – am besten immer
• nicht nur eine Datei runterladen
• Dateien mit 150 oder mehr Quellen bevorzugen
• Nicht die gerade neu erschienen Dateien runterladen
• Viel hochladen um Kredits zu sammeln
• eMule nicht beobachten. Mag er nämlich nicht.
Top
Welche Downloadraten sind zu erwarten?
Ein sinnvoll eingestellter eMule, der mit guten Downloads gefüttert wird kommt im Schnitt auf Downloadraten zwischen 20 kB/s – 30 kB/s.
Es wird Zeiten geben, da läd er weniger wie auch genauso das 2 bis 3 fache erreicht werden kann.
Top

Wie gross sollte die Warteschlange sein?
Eine lange Warteschlange erhöht die Wirksamkeit der Kreditpunkte. Sehr hohe QR Plätze bedeuten nicht, dass es unmöglich ist diese zu erreichen, da verschiedene Faktoren die Aufstiegsgeschwindigkeit in der Warteschlange stark beeinflussen.
Top

Aktualisiert: 2004-02-27 by Monk


317

Kredit-System
03.04.2004 16:16
> Wo kann ich sehen wie viel Kreditpunkte ich habe?
> Ich habe meine clients.met gelöscht / verloren. Sind meine Kredits weg?
> Sind diese Kredits sicher?
> Wie ich doch meine Credits verlieren kann.
Was sind Kreditpunkte und warum sollte ich diese sammeln?
Mit den Kreditpunkten belohnt eMule diejenigen, die etwas hochladen. Die übertragene Menge bestimmt wie viel Kredits Du bekommst. Die gesammelten Kredits können nur bei dem eingelöst werden von dem Du sie erhalten hast. Sie gelten nicht allgemein. Je mehr Kredits Du bei einem anderen User hast desto schneller rückst Du in dessen Warteschlange vor.
Top
Wo kann ich sehen wie viel Kreditpunkte ich habe?
Um Betrügereien an den Kreditpunkten zu verhindern werden diese nicht auf der eigenen Festplatte gespeichert, sondern bei demjenigen bei dem Du die Kreditpunkte hast.
Top
Ich habe meine clients.met gelöscht / verloren. Sind meine Kredits weg?
Nein, die Punkte anderer eMule Benutzer sind weg. Wie in der Frage darüber erläutert werden die eigenen Kredits nicht auf der eigenen Festplatte gespeichert.
eMule legt allerdings ein Backup an - clients.met.bak - welches Du wiederherstellen kannst.
Top
Sind diese Kredits sicher?
eMule meldet sich verschlüsselt bei anderen eMule Teilnehmern an. Erst wenn diese Anmeldung erfolgreich war, können Kreditpunkte in Anspruch genommen werden.
Top
Wie ich doch meine Kredits verlieren kann.
Wie beschrieben hängen die Kreditpunkte mit der verschlüsselten Anmeldung zusammen. Der geheime Schlüssel zu dieser Anmeldung wird aus den Dateien preferences.dat und cryptkey.dat gebildet. Geht eine dieser Dateien verloren kann eMule nicht mehr beweisen der rechtmässige Besitzer der Kredits zu sein.
Sollte nur die cryptkey.dat verloren gehen muss auch die preferences.dat gelöscht werden!
Top

Aktualisiert: 2003-09-03 by Monk


318

Downloads & Freigaben
02.05.2004 16:30
> Was bedeutet dieser Farbige Balken?
> Was bedeuten die Zahlen xx / yy (zz) hinter den Downloads?
> Was heisst QR?
> Was heisst Andere Datei angefordert?
> Was bedeutet Zuviele Verbindungen?
> Kann ich den Namen eines Downloads ändern?
> Was sind die grünen / roten Ausrufezeichen vor den Downloads?
> Wie kann ich einen Kommentar / eine Bewertung erstellen?
> Wie erkenne ich eine Fälschung (Fake)?
> Ein Download wird wochenlang nicht fertig
> Mein Download ist fertig, aber da steht „Fehlerhaft“
> Mein Download ist fertig, aber ich finde ihn nicht im Verzeichnis für eingehende Dateien
> Der Ordner für temporäre Dateien ist hässlich gross. Kann ich ihn löschen?
> Wie kann ich freigegebene Dateien löschen / nicht mehr freigeben

Aus irgendeinem Grund zeigt eMule meine Downloads nicht mehr an
Dies kann nach einer Neuinstallation oder nach einem üblen Absturz vorkommen. Abhilfe kann sein:

• | Im eMule Verzeichnis wird eine downloads.txt Datei angelegt. Diese enthält alle Dateien im Download mit ihrem zugehörigen eD2k-Link. Neu herunterladen oder die betreffenden .part Dateien mit Hilfe von MetMedic oder DonkeyDoctor neu verküpfen.
• | Das Verzeichnis für temporäre Dateien in den Einstellungen überprüfen, ggf. korrigieren und eMule neu starten.
• | Die .part.met Dateien im Verzeichnis für temporäre Dateien durch ihre Backups (.part.met.bak) ersetzen
• | Das Kapitel Fehlerbehebung in der Hilfe lesen.
Top
Was bedeutet dieser farbige Balken?
Die Farben zeigen die Verbreitung der Dateiteile an. Rot steht für nicht vorhandene Teile. Die genaue Bedeutung der einzelnen Farben wird hier erklärt.
Top
Was bedeuten die Zahlen xx / yy + aa (zz) hinter den Downloads?
Diese Zahlen zeigen wie viel Quellen eMule für diesen Download gefunden hat.
• xx - Anzahl der brauchbaren Quellen
• yy - Gesamt gefundene Quellen
• + aa - Quellen mit dem Status Andere Datei angefordert (nur wenn zusätzlich Kontrollen aktiviert)
• zz - Gerade aktive Quellen
Top
Was heisst QR?
QR bedeutet „queue rank“ und steht für Deinen Platz in der Warteschlange der Quelle. Bei Werten unter 20 kann in nächster Zeit ein Download von dieser Quelle erwartet werden. Kreditpunkte helfen in dieser Warteschlange schneller vorzurücken.
Der Warteschlangenplatz geht durch eine kurze Unterbrechung oder durch den Wechsel der IP nach der Zwangstrennung nicht verloren.
Top
Was heisst Andere Datei angefordert?
eMule stellt sich immer nur für eine Datei bei einem anderen Teilnehmer an. Falls dieser mehrere Dateien anbietet, die man selbst haben möchte, wird trotzdem nur ein Platz in der Warteschlange belegt. Dieselbe Quelle bekommt bei der anderen Datei dann diesen Vermerk. Viel verwendete Abkürzung: A4AF - Asked for another file
Top
Was bedeutet Zuviele Verbindungen?
Erscheint bei den Quellen dieser Status kann eMule bzw. die Internetverbindung nicht alle Quellen abarbeiten weil nicht genügend Verbindungen zur Verfügung sehen.
Diese Meldung bedeutet, dass entweder zu viele Dateien in der Transferliste sind oder das Hard Limit zu hoch ist und deswegen zu viele Quellen gefunden werden.
Top
Kann ich den Namen eines Downloads ändern?
Der Dateiname eines Downloads kann beliebig geändert werden. Rechtsklick (oder mittlere Maustaste) auf einen Download -> Zeige Dateidetails im Reiter Dateiname kann ein neuer Name angegeben werden oder automatisch von lästigen Sonderzeichen o.ä bereinigt werden.
Dateiendung beachten!
Top
Was sind die grünen / roten Ausrufezeichen vor den Downloads?
Die Ausrufezeichen zeigen an, dass für diese Datei eine Bewertung oder ein Kommentar abgegeben wurde.
• Grün = positive Bewertung
• Rot = negative Bewertung
Top
Wie kann ich einen Kommentar / eine Bewertung erstellen?
Ein Kommentar kann im Hauptfenster Dateien bei den freigegebenen Dateien eingetragen werden. Hierzu genügt ein Klick mit der mittleren Maustaste oder über Rechtsklick -> Datei-Kommentar ändern.
Bitte nicht gänzlich sinnfreie Kommentare eintragen!
Top
Wie erkenne ich eine gefälschte Datei (Fake)?
Rechtsklick auf einen Download -> Zeige Dateidetails -> Dateiname öffnet eine Liste aller bekannten Dateinamen für diesen Download. Sind hier widersprüchliche Namen eingetragen ist es wahrscheinlich eine Fälschung.
Erscheint bei einer Suche ein + vor dem Suchergebnis sind ebenfalls mehre Dateinamen gefunden worden. Hier gilt dasselbe.
Top
Ein Download wird wochenlang nicht fertig
Wird eine Datei über sehr lange Zeit nicht fertig kann dies zwei Gründe haben.
Keine vollständige Quelle:
Dies ist am Fortschrittsbalken zu erkennen. Hält sich dort über die gesamte Zeit ein roter Teil oder fehlt allen Quellen der gleiche Teil der Datei, ist diese sehr wahrscheinlich eine Leiche.
Genaue Auskunft wann für eine Datei alle Teile vorhanden waren gibt die Spalte zuletzt komplett entdeckt in der Downloadliste.
Beschädigte Datei:
Erscheint im Log Bereich im Hauptfenster Server immer wieder die Meldung, dass der gleiche Teile einer Datei korrupt sei, ist dieser Download vermutlich auch tot (eher selten).
Top
Mein Download ist fertig, aber es steht da „Fehlerhaft“
Dies kann passieren wenn sich die Verzeichnisse für temporäre Dateien und eingehende Dateien auf unterschiedlichen Festplatten / Partitionen befindet. Der Grund ist zuwenig freier Speicherplatz auf der Festplatte der fertig gestellten Dateien.
Top
Mein Download ist fertig, aber ich finde ihn nicht im Verzeichnis für eingehende Dateien
Wird ein Download den eMule als fertiggestellt anzeigt nicht ins Verzeichnis für eingehende Dateien verschoben, kann dies auch manuell erfolgen. Mit der rechten Maustaste die ->Dateidetails aufrufen und die .part Nummer des Downloads notieren und am besten seinen Dateinamen in die Zwischenablage kopieren. Dann im Explorer ins Temp Verzeichnis wechseln und die betreffende .part Datei ins Zielverzeichnis verschieben und zum passenden Dateinamen umbenennen. Solche fehlerhaften Downloads sind leicht zu erkennen, da sie oft keine zugehörige .part.met Datei mehr haben.
Top
Der Ordner für temporäre Dateien ist hässlich gross. Kann ich ihn löschen?
Der Ordner für temporäre Dateien beinhaltet alle noch nicht fertigestellten Downloads. Er sollte auf keinen Fall gelöscht werden oder die Downloads sind weg..
Aufgrund der Arbeitsweise von eMule kann es vorkommen dass eine der Originalgrösse entsprechende temporäre Datei angelegt wird auch wenn erst ein paar Kilobytes heruntergeladen sind.
Top

Wie kann ich freigegebene Dateien löschen / nicht mehr freigeben
eMule gibt Dateien zu hochladen frei sobald:

• | ein Teil (chunk/part) eines Downloads übertragen und auf Fehler geprüft ist
• | diese sich im Verzeichnis für eingehende Dateien befinden oder in einem Ordner der in Einstellungen -> Verzeichnisse -> freigegebene Verzeichnisse als solcher markiert wurde.

Um diese Freigabe wieder aufzuheben müssen die Dateien in einen nicht freigegebenen Ordner verschoben werden oder von der Festplatte gelöscht werden. In der Hauptfenster Dateien können Freigaben über die rechte Maustaste -> Löschen ganz entfernt werden.
Die Freigabe von gerade aktuellen Downloads lässt sich nicht aufheben.
Top

Aktualisiert: 2004-02-27 by Monk


319

Bedienung
03.04.2004 16:18
> Wie kann ich einen Anderen zu meinen Freunden hinzufügen?
> Wie kann ich einem Freund einen Uploadplatz geben?
> Wie kann ich die Autovervollständigung bei der Suche löschen?
> Was bedeuten die Symbole z.B. vor den Quellen etc.?
> Kann ich andere Benutzer bannen oder von einem Uploadplatz kicken?
> Warum bekomme ich höchstens 201 Ergebnisse bei einer Suche?
> Soll ich alle meine Dateien auf hohe Priorität oder Release Priorität setzen?
Allgemeine Tips
Viele Funktionen von eMule sind in Kontextmenüs enthalten. Dies sind Menüs, die sich bei bestimmten Objekten öffnen, klickst du diese mit der rechten Maustatste an. Auch reagieren verschiedene Bereiche auf Doppelklicks oder sogar auf die mittlere Maustatste. Ein Schnellmenü ist über die Tastenkombination ALT + x zu erreichen. Einfach mal durchprobieren.
Top
Wie kann ich einen Anderen zu meinen Freunden hinzufügen?
Freunde werden im Hauptfenster Nachrichten verwaltet. Ein Rechtsklick in dem Freundesbereich öffnet das Kontextmenü in dem der Eintag -> einen Freund hinzufügen gewählt wird. eMule fragt dann folgende Informationen ab:
• IP Adresse – zwingend erforderlich, muss bekannt sein
• Port – meist 4662; ebenfalls zwingend erforderlich
• Name – Auswahl eines beliebigen Namens; nicht erforderlich
Alternativ kann direkt aus der Quellenliste oder Warteschlange im Hauptfenster Transfer ein Freund hinzugefügt werden. Diese Option ist auch dort über das Kontextmenü erreichbar.
Top
Wie kann ich einem Freund einen Uploadplatz geben?
Der Freund-Uploadplatz kann durch Rechtsklick auf einen Freund -> Freund-Uploadplatz aufbauen zugewiesen werden. Er erlaubt dem Freund herunterzuladen sobald der nächste Platz frei ist. Ein Freund-Upload ist nicht schneller als sonstige Uploads. Nur der Platz wird vergeben.
Top
Wie kann ich die Autovervollständigung bei der Suche löschen?
In das Feld zur Eingabe des Suchbegriffs klicken und die Tastenkombination STRG oder ALT danach ENTF drücken oder Einstellungen -> Anzeige -> Autovervollständigung -> Reset
Top
Was bedeuten die Symbole z.B. vor den Quellen etc.?
Eine detaillierte Beschreibung bietet das Hilfekapitel Symbole.
Top
Kann ich andere Benutzer bannen oder von einem Uploadplatz kicken?
Nein. Diese Funktion wird es in eMule auch niemals geben.
Top
Warum bekomme ich höchstens 201 Ergebnisse bei einer Suche?
Suchen erzeugt eine hohe Last auf den Servern. Um diese zu schonen hat eMule ein Limit von maximal 201 Ergebnissen bei einer Suche. Willst du mehr Ergebnisse benutze die Websuche Filedonkey.
Top
Soll ich alle meine Dateien auf hohe Priorität oder Release Priorität setzen?
Nein. Die Prioritäten kannst Du benutzen um bestimmte Dateien zu bevorzugen. Diese verhalten sich relativ zueinander, d.h. setzt Du alle Dateien auf hohe Priorität ist es dasselbe wie alle auf niedrig oder normal.
Mit den Einstellungen für Downloads kannst du beeinflussen wie eMule diese Datei bei der Suche nach Quellen oder der Abarbeitung offener Verbindungen behandelt. Die Priorität für freigegebene Dateien bestimmt welche eMule bevorzugt wenn andere von Dir herunterladen wollen. Diejenigen die eine Datei mit hoher Priorität haben wollen rücken schneller in deiner Warteschlange voran.
Top

Aktualisiert: 2003-09-03 by Monk


320

Sonstiges
03.04.2004 16:19
> Was ist ein Mod?
> Sind Mods schneller / besser?
> Ich bekomme Nachrichten, dass meine eMule gebannt ist
> Wo bekomm ich sonst noch Hilfe?
> Ist eMule anonym?
> Meine Firewall meldet Angriffe durch eMule oder warum verschickt mein eMule Mails?
> Meine Firewall meldet Verbindungen obwohl ich eMule beendet habe
> Was ist der IP Filter?
> Darf ich die FAQ / Hilfe für meine eigene Seite kopieren?
Warum kann ich nicht surfen wenn eMule läuft?
eMule baut viele Verbindungen auf um Quellen zu finden oder zu suchen. Diese Verbindungen können die Geschwindigkeit beim Surfen negativ beeinflussen. Vor allem bei falschen Einstellungen, also zu hohe Verbindungswerte oder zu viele Dateien in der Transferliste, kann die Surf-Geschwindigkeit stark einbrechen.
Top
Was ist ein Mod?
Der Quellcode von eMule liegt offen, sodass jeder sich an seiner Entwicklung beteiligen kann. Dadurch entstehen modifizierte eMule Versionen – kurz Mods – die nicht vom offiziellen Team unterstützt werden.
Top
Sind Mods schneller / besser?
Meistens nein. Die offizielle eMule Version profitiert zum Teil sehr stark durch die Entwicklungen der Modder, doch können diese nichts an den zugrunde liegenden Protokoll und Netzwerkstrukturen ändern. Dies macht einen möglichen Geschwindigkeitsvorteil eher unwahrscheinlich.
Die meisten Mods bringen zusätzliche Funktionen, deren Nutzen wohl im Auge des Betrachters liegt, einige haben aber extrem netzwerkschädliche Funktionen und sollten keinesfalls genutzt werden.
Mod Versionen, die in unserem Forum geführt werden, halten sich an fair Play und die Regeln des Netzwerks.
Top
Ich bekomme Nachrichten, dass meine eMule gebannt ist
Dies Nachrichten stammen von Mods. Wird eine offizielle eMule Version benutzt können diese Nachrichten ignoriert werden da sie schlichtweg falsch sind.
Top

Wo bekomm ich sonst noch Hilfe?
Sollten die Informationen in der FAQ oder Hilfe nicht ausreichend sein, erhältst Du kompetente Hilfe im

• | Forum (bitte vorher nach bestehenden Lösungen suchen)
• | IRC - einfach in eMule auf IRC gehen und Verbinden drücken. Um zum deutschen Channel zu kommen noch /join #emule-german eintippen. Weiter Infos zu unserem Channel hier.
Top
Ist eMule anonym?
Ein p2p Netzwerk ist immer so aufgebaut, dass sich 2 Teilnehmer kennen müssen, um miteinander Dateien tauschen zu können. Hab ich einen anderen Teilnehmer gefunden, der die gewünschte Datei hat, muss ich auch seine IP kennen um mich mit ihm verbinden zu können. Diese eindeutige IP Zuordnung macht Teilnehmer auch identifizier- und nachverfolgbar.
Für dieses Problem gibt es nur zwei Lösungen: Der Einsatz von anonymisierenden Proxyservern oder das Weiterleiten der Daten über andere Teilnehmer des Netzwerks.
Proxyserver haben viele Nachteile. Sie können geschlossen werden, der Grad der Anonymität hängt vom Betreiber ab und es fallen für den Betreiber sehr hohe Kosten für die benutzte Bandbreite an. Nehmen wir einen durchschnittlichen eMule Server mit 100.000 Benutzern. Unter der Annahme, dass jeder Benutzer nur 10kB/s hoch- wie auch runterlädt ergibt das für den Proxy ein Datenvolumen von ca 2.000 MB (1.9GB) die Sekunde. Solche Server kann niemand bezahlen. Die zweite Möglichkeit, das Weiterleiten über andere Teilnehmer hat zur Folge, dass jeder ungefähr das doppelte hochladen müsste damit die jetzige Netzwerkleistung erhalten bleibt. Die Hälfte seines Uploads wird in diesem Falle nur für die Anonymisierung benutzt.
Unter den derzeitigen Gegebenheiten ist eine sinnvolle Anonymisierung nicht möglich!
Top
Meine Firewall meldet Angriffe durch eMule oder warum verschickt mein eMule Mails?
Software Firewalls bewerten Netzverkehr nach Ports auf diesen er stattfindet. Viele Ports werden standardmässig nur von bestimmten Anwendungen benutzt. So werden eMails z.B. hauptsächlich auf Port 110 empfangen und auf Port 25 gesendet. Auch gibt es für bestimmte Angriffsmuster häufig genutzte Ports.
Da die Ports in eMule frei einstellbar sind, setzten manche diese auf Ports die normalerweise für anderen Netzwerkverkehr genutzt werden. Manche Firewalls melden also Angriffe oder dass eMule Mails versendet nur weil dieser gerade eine Verbindung über einen bestimmten Port aufgebaut hat.
Wird die offizielle eMule Version genutzt sind alle Befürchtungen er würde unerlaubte Informationen aussenden unbegründet. Für die Version 30b sind momentan auch keine Sicherheitslücken bekannt.
Top
Meine Firewall meldet Verbindungen obwohl ich eMule beendet habe
Dein eMule dient ja auch anderen Benutzern als Quelle für ihre Dateien. Dadurch ist jeder eMule vielen anderen eMules bekannt und jeder Server verteilt auch die IP des verbundenen Clients. Beendest Du dein eMule fragen immernoch andere Teilnehmer an, ob noch eine Verbindung möglich ist. Dieser Effekt verschwindet nach einem Weilchen
Top
Was ist der IP Filter?
Der IP Filter wird benutzt um Adressen, die möglicherweise schädlich für das Netzwerk sind zu blockieren. Die grösste Seite für IP Filter ist PeerGuardian oder Lussnig's IP Filter. Einfach den Pfad zur IP Sammlung, z.B. http://www.peerguardian.net/pgipdb/guarding.p2p unter Einstellungen -> Sicherheit im Feld Aktualisiere von URL eintragen und Laden klicken.
Top
Darf ich die FAQ / Hilfe für meine eigene Seite kopieren?
Die FAQ und Hilfe dürfen frei kopiert werden solange der Autor weiterhin genannt wird und ein Verweis zu http://emule-project.net gesetzt wird. Eine kurze Nachricht an mich mit der Addresse der Seite ist höflich, falls ihr diese kopieren solltet.
Top

Aktualisiert: 2004-02-27 by Monk


79

Symbole
29.02.2004 17:48

von diesem Client wird heruntergeladen oder ein hash set empfangen

bei diesem Client steht man in der Warteschleife oder fragt gerade an

mit diesem Client wird gerade eine Verbindung hergestellt

Dieser Client hat entweder keine benötigten Teile bzw. wurde bereits nach einer anderen Datei gefragt. Oder mit diesem Client kann wegen einer niedrigen ID auf beiden Seiten nicht verbunden werden

bei diesem Client ist der Status unbekannt

Ihr habt eine neue Nachricht erhalten

steht für einen eDonkey- oder einen älteren eMule-Client ohne Kredit Punkte

dieser Client kann mit dem erweiterten eMule-Protokoll umgehen

dieser Client hat einen hohen Creditwert (das gibt ihm eine höhere Priorität)

dieser Client kann mit dem erweiterten eMule-Protokoll umgehen und hat einen hohen Creditwert

mlDonkey Client

mlDonkey mit Credits

eDonkey-Overnet-Hybrid Client

eDonkey-Overnet-Hybrid Client mit hohem Credit Wert

Shareaza Client ohne Credit Punkte

Shareaza Client mit Credit Punkte

Clients die sich über sichere Benutzeridentifikation identifiziert haben

verbunden, hohe ID sowohl im eD2k Netz (Server) als auch in Kademlia

verbunden, hohe ID in eD2k, niedrige in Kademlia

niedrige ID in eD2k, hohe ID in Kademlia

beide Netze niedrige ID

Kademlia nicht verbunden, hohe ID in eD2k

eD2k nicht verbunden, hohe ID in Kademlia

Kademlia nicht verbunden, niedrige ID in eD2k

eD2k nicht verbunden, low ID in Kademlia

keine Verbindung

Kademlia Kontakt - gut

Kademlia Kontakt - hat einmal nicht geantwortet

Kademlia Kontakt - vermutlich tot, wird bald entfernt

eMules Tasktray-Symbol verbunden, hohe ID

eMules Tasktray-Symbol verbunden, niedrige ID

eMules Tasktray-Symbol (nicht verbunden)

Dateien mit diesem Zeichen haben einen Kommentar / eine positive Bewertung

Diese Dateien haben die Bewertung Fake (Fälschung) oder Defekt

Gilt ab Version: .42a +
Aktualisiert: 2004-02-27 by Monk


80

Farben des Fortschrittbalkens
29.02.2004 17:48

Jeder Download hat eine eigene, farbige Fortschrittanzeige, die über die Verfügbarkeit einer Datei im Netzwerk sowie über den Fortschritt während des Downloads informiert:

(flache Ansicht) [image] (3D-Ansicht)

Schwarz zeigt die Teile einer Datei an, die bereits heruntergeladen wurden
Rot bedeutet, daß dieser Teil bei allen verfügbaren Quellen nicht vorhanden ist
Verschiedene Blauschattierungen stehen für die Verfügbarkeit eines Teiles innerhalb der gefundenen Quellen. Je dunkler das Blau, desto größer ist die Verfügbarkeit dieses Teils
Gelb bezeichnet den Teil, der gerade heruntergeladen oder angefordert wird
Der schmale, grüne Balken gibt über den Gesamtfortschritt dieses Downloads Auskunft.

(flache Ansicht) [image] (3D-Ansicht)
Die grünen Balken stehen für fertigestellte Downloads

(flache Ansicht) [image] (3D-Ansicht)
Ein dunklerer roter oder blauer Fortschrittsbalken zeigt einen gestoppten oder pausierten Download an.

Wenn Ihr die Anzeige eines Downloads erweitert, seht Ihr die einzelnen Quellen, die wiederum einen eigenen Balken haben und sich in der Bedeutung der Farben etwas unterscheiden:

(flache Ansicht) [image] (3D-Ansicht)

Schwarz bezeichnet die Teile, die bereits heruntergeladen wurden
Silber steht für Teile, die noch fehlen, aber diese Quelle auch nicht besitzt
Blau sind Dateiteile die Quelle besitzt, aber dem eigenen Download noch fehlen
Grün sind gerade aktive Downloads
Gelb bezeichnet wiederum den anstehenden Download eines Teils

Quellenanzeige
Die vier Zahlenwerte xx / yy + aa (zz) neben dem Fortschrittbalken informieren über die vorhandenen Quellen wie folgt:

• xx - Anzahl der brauchbaren Quellen
• yy - Gesamt gefundene Quellen
• + aa - Quellen mit dem Status Andere Datei angefordert (nur wenn zusätzlich Kontrollen aktiviert)
• zz - Gerade aktive Quellen

Obtained Parts (bereits erhaltene Dateiteile)
Dieser Fortschrittsbalken ist in der Warteliste zu sehen. Er gibt Auskunft über den Verbreitungsgrad und Fortschritt beim gerade herunterladenden User.

Schwarz steht für die Dateiteile, die dieser Benutzer bereits fertigestellt hat
Grau zeigt die Teile die ihm noch fehlen
Grün sind gerade aktive Uploads
Gelb bezeichnet einen bereits angeforderten Upload

Anzeige des Verbreitungsgrades von freigegebenen Dateien
Jede freigegebene Datei hat eine graphische Anzeige, welche analog zu den Farben des Fortschrittsbalkens, die Verbreitung der Datei anzeigt.

Rot bedeutet, daß dieser Teil bei allen bisher bekannten Kontakten nich vorhanden war
Verschiedene Blauschattierungen geben einen Eindruck von der Häufigkeit eines Dateiteils.

Aktualisiert: 2003-09-27 by Monk


81

Queue Ranking - QR
19.07.2003 17:42

Andere eMule-Clients zeigen in der Quellenansicht einen QR-Wert ( QR:[x]) an.

QR bedeutet Queue Ranking, also Eure Position in der Warteschlange der entsprechenden Quelle. Je niedriger dieser Wert, desto besser stehen die Aussichten für einen beginnenden Transfer.


42

Über die ID
29.02.2004 17:50

Die ID setzt sich aus der IP-Adresse des Clients zusammen und wird von einem Server nach einer erfolgreichen Verbindung vergeben. Sie dient der Überprüfung, ob Clients fehlerfrei untereinander kommunizieren können

Nach erfolgreicher Verbindung wird die ID im Logbereich des Serverfensters angezeigt:.

Weitere Anhaltspunkte auf die eigene ID wird man in eMule sonst nicht finden, außer bei den beiden Symbolen in der Statusleiste:

steht für eine hohe ID
steht für eine niedrige ID

Eine hohe ID bedeutet, das der unter Einstellungen -> Verbindung eingetragene Clientport (Standard: 4662) geöffnet und frei zugänglich ist.

Eine niedrige ID hingegen deutet auf einen blockierten oder nicht erreichbaren Port hin. Eine eindeutige IP-Adresse konnte dem Client nicht zugewiesen werden. Eine Ursache hierfür können Firewalls, Router oder Proxyserver sein.

Eine niedrige ID bedeutet nicht, das ein Download unmöglich ist - hat allerdings einige Nachteile:
> | Da die IP des Clients nicht bekannt ist, müssen sämtliche Anfragen anderer Clients über den Server geleitet werden, zu dem der Client mit der niedrigen ID verbunden ist. Dieser "Umweg" sorgt für eine erhebliche CPU-Belastung auf dem entsprechenden Server und verringert dadurch immens die maximale Anzahl an Benutzern, die durch diesen Server normalerweise hätten verwaltet werden können. Um dem entgegenzuwirken, begrenzen Lugdunum's Server die Anzahl der zugelassen Clients mit einer niedrigen ID oder lassen sie erst gar nicht verbinden.
> | Zwei Clients mit niedriger ID können nicht miteinander kommunizieren, da es keine Möglichkeit gibt, die Anfragen nach Quellen etc. über zwei Server umzuleiten. Dies führt u.a. zu weniger gefunden Quellen.
> | Auf ausgelasteten Servern kann es vorkommen, das wichtige Anfragen oder Informationen verloren gehen, z.B. über den Fortschritt in den Warteschlangen oder Downloadanfragen. Dies kann zu schlechteren Credits und dadurch zu niedrigeren Downloadraten führen.
Anmerkungen:
> | Das ID-Problem betrifft nur den Nachrichten-/Informationsaustausch zwischen den Clients. Der tatsächliche Transfer von Dateien ist immer noch möglich.
> | Sollte es aus bestimmten Gründen nicht möglich sein, eine hohe ID zu bekommen, so solltet Ihr versuchen, möglichst auf kleinere Server mit geringer Nutzerzahl zu verbinden. Diese sind in aller Regel eher in der Lage, die benötigten Ressourcen bereitzustellen als die "big ones" (wenn letztere Euch überhaupt verbinden lassen).
> | Es kann auch durchaus vorkommen, daß Ihr trotz perfekter Konfiguration hin und wieder niedrige IDs bekommt - dies liegt dann aber meist an überlasteten oder einfach schlecht konfigurierten Servern. Mit diesem test script (Danke an TheDonkeyNetwork) könnt ihr das überprüfen.
> | Wenn Ihr eine hohe ID habt, so hat das keinerlei Einfluß auf evtl. Geschwindigkeiten in eMule. Eine hohe ID ist einfach nur hoch - wie hoch, ist völlig irrelevant.
> | Gleiches gilt für die niedrige ID. Eine niedrige ID hat einen Wert kleiner als 16777216.
> | Um anhand der IP-Adresse die ID auszurechnen, gilt folgende Formel: IP = A.B.C.D / ID = A + 256*B + 256*256*C + 256*256*256*D.

Wichtig:
Seit der Version 0.23a werden Quellen mit einer niedrigen ID verworfen, um die Serverbelastung zu minimieren. Ausnahme: Quellen mit niedriger ID, die mit dem selben Server wie Euer Client verbunden sind und Quellen mit niedriger ID, die etwas von Euch herunterladen wollen. Weiterhin werden Quellen mit niedriger ID nicht beim Quellentausch unter einzelnen Clients berücksichtigt.

Aktualisiert: 10/12/02 by Monk


82

Bewertung & Punkte
02.05.2004 15:25

Die Warteliste von eMule kann durch Drücken auf On Queue im Transfer Fenster eingesehen werden. Bis auf Bewertung und Punkte erklären sich die dort angezeigten Angaben von selbst.

Bewertung
Die Bewertung gibt an, welche Modifikatoren ein Client in der Warteschlange erhalten hat. Bei jedem neuen Benutzer in der Warteliste wird von einem Startwert 100 ausgegangen. Verschiedene Faktoren werden mit dem Startwert multipliziert um die Bewertung zu errechnen:

> | Gebannt: Faktor: x0 Benutzer die aufgrund zu haüfigen Nachfragens gebannt werden erhalten gar keine Punkte.
> | Niderige ID Faktor: keiner [x0,8] Versionen vor .27x belegen Benutzer mit niedriger ID mit einem Faktor von 0,8.
> | Verbunden Faktor: keiner [x1,5] Versionen vor .27x geben einem schon verbunden Benutzer einen Bonus von x1,5.
> | Kreditpunkte Faktor: x1 - x10 Das Kredit System berechnet einen Bonus aus dem Verhältnis von Upload zu Download.
> | Dateipriorität für freigegebene Dateien Faktor: x1,8 - x0,2 Je nach Priorität der Datei bekommen Benutzer eine andere Bewertung wenn sie diese Datei anfordern. Versionen vor .27x haben andere Bewertungen. Diese sind in [ ] angegeben.
 | Release: | x1,8 [x5]
 | Hoch: | x0,9 [x2]
 | Normal: | x0,7 [x1]
 | Niedrieg: | x0,6 [x0,5]
 | Sehr niedrig: | x0,2 [x0,2]
> | eMule Version älter als v.20a Faktor: x0,5 Da alte Versionen eine ungleich höhere Netzbelastung verursachen, werden sie mit einem Straffaktor von x0,5 belegt.

Beispiel:
Ein Benutzer hat durch vieles Uploaden einen Kreditfaktor von x8 erreicht und fordert eine Datei mit hoher Priorität an. Seine Bewertung errechnet sich somit zu: 100 x 8 x 0,9 = 720.

Punkte
Der Punktewert wird mit den gleichen Faktoren wie die Bewertung errechnet nur zählt hier zusätzlich die Wartezeit des Benutzers in der Warteliste. Der Punktestand bestimmt die Reihenfolge in der die Uploadslots vergeben werden. *** hinter dem Punktewert bedeutet, dass dieser Benutzer als nächster einen Uploadplatz zugeteilt bekommt.
Die Punkte berechnen sich zu:

Punkte = Bewertung x Wartezeit [s] / 100

Jeder Benutzer dessen gesamt Faktor grösser 1 ist wird mit einem gelben Benutzer-Icon angezeigt.

Aktualisiert: 2003-04-13 by Monk


83

Listen
29.02.2004 17:52
eMules Transfer-Fenster enthält im oberen Bereich die Liste aller Downloads. In Klammern ( ) wird die momentane Anzahl der Downloads angezeigt.
Die untere Liste ist variabel und kann unterschiedlichen Inhalt anzeigen.

Der Name - Uploads, In Warteschleife und bekannte Clients - ist eine Schaltfläche mit der zwischen den einzelnen Listen gewechselt werden kann. Die dort angezeigten Informationen erklären sich selbst.

Gilt ab Version: 0.27a +
Aktualisiert: 2003-03-13 by Monk


84

Benutzte Dateien
02.05.2004 16:05

Während der Laufzeit von eMule werden im config Unterordner und dem Verzeichnis für temporäre Dateien verschiedene Dateien angelegt.

o | Known.met Diese Datei speichert Daten über alle freigegebenen Dateien und jener die sich gerade noch in der Downloadliste befinden. Zu jeder der eMule bekannten Dateien werden Dateigrösse, Ordner der Datei, Anzahl der Hashwerte und statistische Daten gespeichert.
o | Clients.met Die Clients.met enthält Informationen über diejenigen Benutzer, die Kreditpunkte bei diesem eMule haben.
o | Server.met Enthält die Liste der bekannten Server
o | Emfriends.met Speichert die in der Freundesliste aufgenommenen Benutzer.
o | Preferences.ini Alle Einstellungen von eMule werden in dieser Datei gespeichert.
o | Fileinfo.ini Speichert Kommentare oder Bewertungen die für freigegebene Dateien erstellt wurden
o | Category.ini Enthält die Download-Kategorien und die dazugehörigen Verzeichnisse und Farbeinstellungen
o | Ipfilter.dat Die in dieser Datei eingetragennen IP Bereiche werden nach den Regeln des IP Filters blockiert oder zugelassen. Siehe auch: Einstellungen -> Sicherheit
o | Onlinesig.dat Ist die Online Signatur Option in Einstellungen -> Allgemein aktiviert werden die aktuellen Verbindungswerte in dieser Datei abgelegt. Siehe auch Online Signatur.
o | Preferences.dat Speichert den sogenannten userhash. Dies ist ein Wert der beim ersten Start von eMule festgelegt wird und dazu dient diesen speziellen eMule im Netzwerk eindeutig identifizierbar zu machen. Wird insbesondere für das Kreditsystem benötigt.
o | Sharedir.dat Die Auflistung aller Verzeichnisse die in eMule freigegeben wurden
o | Staticservers.dat Zur besseren Verwaltung können Server deren IP sich nicht ändert in diese Datei eingetragen werden. Der Eintrag erfolgt über das Kontext-Menü (rechte Maustaste) der Serverliste. Siehe auch: Einstellungen -> Server
o | Adresses.dat In dieser Datei können, unter Einstellungen -> Server, Adressen zu Serverlisten eingetragen werden. Ist die die Option Serverliste beim Programmstart aktualisieren aktiviert, fragt eMule alle Adressen in dieser Liste ab, bis er eine gültige server.met empfangen hat. Die eingetragenen Adressen müssen direkt auf eine server.met verweisen. HTML Listen werden nicht verarbeitet.
o | AC_SearchStrings.dat Jeder verwendete Suchbegriff wird hier abgelegt und falls sich eine Suche wiederholt wird automatisch eine Autovervollständigung angeboten
o | AC_ServerMetURLs.dat Diese Datei erfüllt die gleich Funktion wie die obige nur für Adressen zu server.met Dateien. Vorsicht, da viele Betreiber dieser server.met Dienste regelmässig die Adresse zu diesen Dateien wechseln.
o | Cryptkey.dat Enthält den privaten RSA Schlüssel zur sicheren Benutzer Identifikation .
o | eMule.tmpl Die Vorlagendateien *.tmpl bestimmen des Aussehen des Webinterface .
o | xx.part Part Dateien sind unvollständige Downloads und werden in dem Verzeichnis für temporäre Dateien angelegt. Da eMule mehrere Dateiteile gleichzeitig herunterladen kann haben die *.part Dateien von Anfang an die Grösse des fertigen Downloads
o | xx.part.met Zu jeder *.part Datei gehört eine part.met Datei. In ihr sind die Informationen zur eindeutigen Identifikation des Downloads vorhanden. Jeder Download in eMule wird in ca. 9 MB grosse Stücke zerlegt. Zu jedem dieser Teile wird ein Hashwert errechnet und schliesslich nochmals einer für alle Hashwerte zusammen. Diese Informationen werden zusammen mit dem Dateinamen des Downloads in der *.part.met Datei gespeichert.
o | xx.part.met.BAK Backup der xx.part.met, um im Falle eines Verlustes die Downloads wiederherstellen zu können. Siehe Problembeseitigung für Hilfe bei verlorenen Downloads
o | eMule.log Speichert den Inhalt des Log Fensters falls die entsprechende Option in Einstellungen -> Erweiterte Einstellungen gewählt ist.
o | eMule_Debug.log Speichert den Inhalt des Debug Fensters falls die entsprechende Option in Einstellungen -> Erweiterte Einstellungen gewählt ist.

Gilt ab Version: .29b +
Aktualisiert: 2003-06-20 , Monk


321

Die Symbolleiste
03.05.2004 16:33
Zur Erklärung des Symbols Verbinden Zur Erklärung des Symbols Server Zur Erklärung des Symbols Transfer Zur Erklärung des Symbols Suche Zur Erklärung des Symbols Dateien Zur Erklärung des Symbols Nachrichten Zur Erklärung des Symbols IRC Zur Erklärung des Symbols Statistik Zur Erklärung des Symbols Einstellungen

Die Symbolleiste ist die Hauptnavigation von eMule. Sie unterteilt eMule in seine 9 Gruppen, die Funktionen wie Suche, eine Übersicht über freigegebene Dateien usw. unterteilt.
Verbinden
Mit einem klick auf dieses Symbol stellst Du eine Verbindung zum Server her. Anschließend verändert sich das Symbol zum Abbrechen- Symbol. Dieser Klick verändert nicht den Hauptteil.
Abbrechen
Mit einem klick auf dieses Symbol unterbrichst Du den Versuch zu einem Server zu verbinden. Anschließend verändert sich das Symbol zum Verbinden- Symbol. Dieser Klick verändert nicht den Hauptteil.
Trennen
Mit einem klick auf dieses Symbol trennst Du die bestehende Serververbindung. Anschließend verändert sich das Symbol zum Verbinden- Symbol. Dieser Klick verändert nicht den Hauptteil. 		Top

Wechsel zur Hauptansicht Server Server
Mit einem klick auf dieses Symbol wird dir im Hauptteil ein Bereich angezeigt wo Du deine Server verwalten kannst und Infos zu den vorhandenen Servern bekommst. Des Weiteren werden Dir dort Infos zu deiner Verbindung und zu den Verbindungshergängen gezeigt.
  • Serverliste
  • Neuer Server
  • Server.met von URL laden
  • Meine Info
  • Serverinfo, Log und Reset
 Top

Wechsel zur Hauptansicht Transfer Transfer
Mit einem klick auf dieses Symbol wird dir im Hauptteil ein Bereich angezeigt wo Du alles über den Down- und Upload erfährst.
  • Kategorien
  • Downloadliste
  • Wechselschaltfläche Uploads, In Warteschleife und Bekannte Clients
  • Liste Uploads
  • Liste In Warteschleife
  • Liste Bekannte Clients
 Top

Wechsel zur Hauptansicht Suche Suche
Mit einem klick auf dieses Symbol wird Dir im Hauptteil die eMule Suche angezeigt. Dort hast Du die Möglichkeit gezielt nach Dateien zu suchen wobei Du eine Menge an Einstellungen und Filtern benutzen kannst.
  • Suche
  • Direkt Downloaden
  • Start, Abbruch, Entferne alles
  • Fortschrittbalken
  • Ergebnisse
  • Auswahl Downloaden (in Kategorie)
 Top

Wechsel zur Hauptansicht Dateien Dateien
Mit einem klick auf dieses Symbol wird Dir im Hauptteil die Dateien, inklusiv vieler Informationen, angezeigt werden die Du den andern zum download anbietest.
  • Liste Freigegebene Dateien
  • Statistik
 Top

Wechsel zur Hauptansicht Nachrichten Nachrichten
Mit einem klick auf dieses Symbol werden Dir im Hauptteil zum einen deine Freunde- Liste angezeigt zum anderen der Nachrichtenteil der es Dir ermöglicht mit anderen Benutzern zu kommunizieren.
  • Freunde
  • Nachrichten
  • Nachrichten Senden
  • Schließen
 Top

Wechsel zur Hauptansicht IRC IRC
Mit einem klick auf dieses Symbol wird Dir im Hauptteil der in eMule integrierte Internet Relay Chat angezeigt. Es ist ein Mehrbenutzer - Kommunikationssystem, auf dem sich Leute auf so genannten "Kanälen" in Gruppen oder individuell unterhalten können.
  • Wechselschaltfläche Verbinden / Trennen
  • Nick
  • Status
  • Raumliste
  • Schließen
  • Senden
 Top

Wechsel zur Hauptansicht Statistik Statistik
Mit einem klick auf dieses Symbol werden Dir im Hauptteil die sehr informative Statistiken angezeigt.
  • Grafische Darstellung Download
  • Grafische Darstellung Upload
  • Grafische Darstellung Download, Upload und Verbindungen
  • Baumstruktur Statistiken
 Top

Wechsel zur Kategorie Einstellungen Einstellungen
sätzliches Fenster geöffnet im dem folgende Einstellungsbereiche zu finden sind.
    Mit einem klick auf dieses Symbol wird ein zu
  • Allgemein
  • Anzeige
  • Verbindung
  • Server
  • Verzeichnisse
  • Dateien
  • Benachrichtigung
  • Statistik
  • IRC
  • Webserver
  • Sicherheit
  • Erweiterte Einstellungen
 Top


322

Server
03.05.2004 16:36
Der Hauptbereich Server

Beschreibung Serverliste Beschreibung Serverliste Beschreibung Neuer Server Beschreibung Server.met von URL laden Beschreibung Meine Info Beschreibung Serverinfo und Log

Beschreibung der Serverliste

Beschreibung zum Wert in der Klammer
Hinter dem Wort Serverliste steht ein Wert in Klammern, im Beispiel ist es (265), das ist die Anzahl der Server die sich in deiner Liste befinden.

Die sich darunter befindende Tabelle ist die Serverliste.

Die sich darunter befindende Tabelle ist die Serverliste.
Die Tabelle lässt sich durch klick auf eine Spaltenname sortieren. Der Pfeil neben dem Spaltennamen zeigt euch an ob aufsteigend oder absteigend sortiert wurde.
Die Spalten lassen sich die einzeln aus- und einblenden und in ihrer Breite verändern.
Weitere Optionen werden dir nach einem Rechtsklick auf eine Serverzeile in einem Pull down Menü angezeigt.

In folgenden sind die Spalten und deren Inhalte beschrieben.
zum Themenanfang zum Seitenanfang

Servername
Sofern vom Serverbetreiber ein Name festgelegt wurde wird dieser Dir in dieser Spalte angezeigt. Wurde vom Serverbetreiber kein Name festgelegt so wird die IP- Adresse angezeigt.
zum Themenanfang zum Seitenanfang

IP
In dieser Spalte wird dir die IP- Adresse und, durch einen Doppelpunkt gegrenzt, der Port des Servers angezeigt.
zum Themenanfang zum Seitenanfang

Beschreibung
Der in dieser Spalte angezeigte Text wird frei Vom Serverbetreiber eingegeben. Häufig wird er dazu benutzt um auf eine Internetseite hinzuweisen die Informationen über den Server bereitstellt.
zum Themenanfang zum Seitenanfang

Ping
Der in dieser Spalte angezeigte Wert sind die Millisekunden die der Server braucht um auf eine Anfrage zu antworten. Dieser Wert sollte von Dir jedoch nicht zu hoch bewertet werden da weder ein hoher noch ein niedriger Wert Einfluss auf deine Downloadgeschwindigkeit hat sondern nur darauf wie lange es dauert bis alle Quelleninfos getauscht worden sind.
zum Themenanfang zum Seitenanfang

Benutzer
Die Anzahl der Benutzer die zurzeit mit diesem Server verbunden sind steht in dieser Spalte.
zum Themenanfang zum Seitenanfang

Nutzer Maximum
Die Anzahl der Benutzer die Maximal von dem Server verwaltet werden können siehst Du in dieser Spalte.
zum Themenanfang zum Seitenanfang

Dateien
In dieser Spalte wird dir angezeigt wie viele Dateien dem Server bekannt sind.
zum Themenanfang zum Seitenanfang

Präferenz
In dieser Spalte wird die Präferenz des Servers angezeigt. Es gibt die Präferenzen Hoch, Normal und Niedrig. Anhand der Präferenz verbindet eMule zu den Servern. Das heißt eMule versucht zuerst zu Servern zu verbinden, die in der Präferenz auf "Hoch" stehen danach versucht er zu den Servern zu verbinden die auf "Normal" stehen und erst dann die, die auf " Niedrig " stehen.
zum Themenanfang zum Seitenanfang

Fehlgeschlagen
In dieser Spalte wird angezeigt, wie oft es vorgekommen ist das zu diesem Server keine Verbindung hergestellt werden konnte.
zum Themenanfang zum Seitenanfang

fest
In dieser Spalte wird angezeigt, ob der Server zu Deiner festen Server-Liste gehört. Die "festen" Server werden auch nach mehrmaligen erfolglosen Verbindungsversuchen nicht aus der Server-Liste gelöscht.
zum Themenanfang zum Seitenanfang

Spalten aus- und einblenden
Um eine Spalte der Serverliste auszublenden oder auch wieder einzublenden klickst Du einfach mit der rechten Maustaste auf einen Spaltennamen. Dadurch wird dir dann das folgende Auswahlmenü angezeigt
Nun kannst du durch einen klick mit der linken Maustaste die Häkchen vor den Spaltennamen, und somit auch das Anzeigen der Spalten, verändern.
zum Themenanfang zum Seitenanfang

Spaltenbreite verändern
Wenn Du mit dem Mauszeiger auf die Trennlinie zwischen zwei Spaltennamen zeigst verändert sich das Mauszeigersymbol. Drücke nun die linke Maustaste und halte sie gedrückt nun kannst Du die Spalte breiter oder schmaler schieben.
zum Themenanfang zum Seitenanfang

Rechtsklick auf eine Serverzeile
Wenn Du mit der rechten Maustaste auf eine Zeile in der Serverliste klickst öffnet sich das folgende Servermenü.
Verbindung zum gewählten Server herstellen.
Wenn eine Verbindung besteht wird diese beendet und anschließend zum ausgewählten Server verbunden.
Priorität
Damit veränderst Du die Präferenz des Servers. Wenn Du mit dem Mauszeiger auf Priorität zeigst klappt ein seitliches Menü, mit den Einträgen Niedrig, Normal und Hoch, aus.
Zur Liste fester Server hinzufügen
Fügt den ausgewählten Server zu der Liste feste Server hinzu. Danach steht bei diesem Server in der Spalte fest der Wert Ja. Die "festen" Server werden auch nach mehrmaligen erfolglosen Verbindungsversuchen nicht aus der Server-Liste gelöscht.
Von der Liste fester Server Löschen
Dieser Eintrag kann nur ausgewählt werden wenn der markierte Server zu der Liste fester Server gehört. Danach steht bei diesem Server in der Spalte fest der Wert Nein.
Lösche ausgewählte(n) Server
Alle markierten Server werden aus deiner Liste gelöscht. Zum markieren von mehreren Servern benutzt Du die Strg- Taste oder die Umschalt- Taste (Großschreibtaste).
Lösche alle Server
Es werden alle Server aus deiner Liste gelöscht. Du kannst dich danach erst wieder Verbinden wenn Du einen neuen Server hinzugefügt hast.
Kopiere ed2k- Link in die Zwischenablage
Wenn Du einen Server an einem anderen User weiterleiten möchtest kannst Du damit den Wert erstellen der bei einem Tag zwischen den Anführungszeichen kommt. Der Link enthält die IP- Adresse sowie den Port des Servers.
zum Themenanfang zum Seitenanfang

Doppelklick auf eine Serverzeile
Wenn Du einen Doppelklick auf eine Serverzeile machst trennt eMule die Bestehende Verbindung und versucht zu dem ausgewählten Server zu verbinden.
zum Themenanfang zum Seitenanfang

Beschreibung des Bereichs Neue Server
Hiermit wird ein einzelner Server der Liste hinzugefügt.

IP oder Adresse
Hier gibst Du die aktuelle IP- Adresse des Servers oder die Internetadresse ein. Dieses Feld muss ausgefüllt werden.
zum Themenanfang zum Seitenanfang

Port
Hier gibst Du den Port ein den der Serverbetreiber freigegeben hat ein. Dieses Feld muss ausgefüllt werden.
zum Themenanfang zum Seitenanfang

Name
Hier kannst Du den Namen des Servers eingeben.
zum Themenanfang zum Seitenanfang

Hinzufügen
Wenn Du die Felder Ausgefüllt hast klickst Du auf Hinzufügen. Der Neue Server wird dann in der Serverliste aufgenommen und erhält die Präferenz Normal. Achte bitte auf Tippfehler da nicht geprüft wird ob es den Server wirklich gibt.
Erscheint im Logfenster die Meldung "Server wurde nicht hinzugefügt", so befindet sich dieser Server (evtl. unter einem anderen Namen) bereits in Deiner Liste.
zum Themenanfang zum Seitenanfang

Beschreibung Server.met von URL Laden

Tippe in das Feld eine gültige Internetadresse, die auf eine Server.met verweist, ein und klickt auf "Aktualisieren". Im Logfenster könnt Ihr sehen, wie viele Server hinzugefügt wurden.
zum Seitenanfang

Beschreibung zu Meine Info

Status IP:PORT ID
Status
Zeigt dir an ob Du mit einem Server verbunden bist oder nicht. (Verbunden / Getrennt) Ist der Status Getrennt werden Dir die Werte IP:Port und ID nicht angezeigt.
zum Themenanfang zum Seitenanfang

IP:Port
IP = Zeigt Dir deine aktuelle IP- Adresse an.
Port = Zeigt Dir den Clientport an den Du benutzt. (Der Port um von anderen Clients herunter zuladen)
zum Themenanfang zum Seitenanfang

ID
Zeigt Dir deine aktuelle ID an. Die ID setzt sich aus der IP- Adresse des Clients zusammen und wird von einem Server nach einer erfolgreichen Verbindung vergeben. Sie dient der Überprüfung, ob Clients fehlerfrei untereinander kommunizieren können.
Unter Deiner ID steht ob Du ein hohe ID oder niedrige ID bekommen hast.
Da dieses Thema sehr Wichtig ist gibt es dazu ein eigenes Thema welches Du unter Sonstiges / Über die ID findest.
zum Themenanfang zum Seitenanfang

Serverinfo, Log und Reset

Serverinfo und der Reset- Button

Die ersten beiden Zeilen sind von eMule vorgegeben und zeigen Dir die benutzte Version sowie einen Link an. Der Link führt Dich auf eine Seite die Dir anzeigt ob Du die aktuellste Version benutzt. Solltest Du diese Zeilen nicht mehr finden so liegt das daran das der Text in diesem Fenster zu lang war und die obersten Zeilen gelöscht wurden oder Du hast den Reset- Button benutzt.
Ansonsten siehst Du in diesem Fenster mit welchem Server Du verbunden bist, welche Serversoftware Version dieser Server benutzt, Werbung die der Serverbetreiber einsetzt sowie Links, und vieles mehr.
Mit dem Reset- Button löscht Du den gesamten Text.
zum Themenanfang zum Seitenanfang

Log und der Reset- Button

In diesem Fenster wird fast alles protokolliert was eMule macht.
Mit dem Reset- Button löscht Du den gesamten Text.
zum Themenanfang zum Seitenanfang

Debug und der Reset- Button
Solltest Du noch ein weiteres Fenster mit dem Namen Debug sehen so hast du in den Einstellungen ein Häkchen bei Verbose (zusätzliche Programmausgaben) gemacht. Dieses Fenster dient der Problembeseitigung und wird auch dort beschrieben.
Mit dem Reset- Button löscht Du den gesamten Text.
zum Themenanfang zum Seitenanfang


323

Suche
03.05.2004 16:07
    • Name

      • Hier gibt man den Namen oder eine Abkürzung des gesuchten Files ein.

    • Typ

      • In der eMulesuche kann man nach verschieden Arten von Dateien suchen lassen. Unter Typ kann man einstellen, nach was für eine Art von File man sucht. Die Aufteilung der Typenklassen ist wie folgt

      • Alle - Es wird nach allen verfügbaren Dateiformaten für die Suchanfrage gesucht
      • Archive - Es wird nur nach Archivedatein gesucht (z.B. rar, zip usw).
      • Audio - Es wird nach Audiodateien gesucht (z.B. mp3)
      • Bilder - Es wird nach Bilddateien gesucht (z.B. jpeg, gif, bmp usw)
      • CD-Images - Es wird nach CD-Images gesucht (z.B. nro, bin, cue usw)
      • Programme - Es wird nach Programmdateien gesucht (z.B. exe)
      • Video - Es wird nach Videodateien gesucht (z.B. mpeg, avi)
    • Methode

      • Mit dieser Funktion könnt ihr einstellen, wo eMule suchen soll.

      • Server - eMule sucht auf den Server, zu den ihr gerade verbunden seit.
      • Global (Server) - eMule sucht auf allen Servern in eurer Serverliste.
      • Filedonkey - Webbasierte Suche.
      • Jigle - Webbasierte Suche.

  • Filter
    • min. Größe

      • Hier gebt ihr ein, wieviel MB das gesuchte File mindestens haben muß.

    • max. Größe

      • Hier gebt ihr ein, wieviel MB das gesuchte File höchstens haben darf.

    • Verfügbarkeit

      • Wenn Du nach Dateien suchst, die eine Mindest-Verfügbarkeit haben sollten, z.B. mindestens 10 Quellen, dann werden Suchergebnisse unter 10 Quellen nicht angezeigt.

    • Dateiendungen

      • Wenn Du weißt, dass es eine *.avi, *.mpg oder *.bin Datei ist, kannst Du das hier angeben.

  • Start, Abbruch, Entferne alles
    • Start

      • Nachdem man unter Namen sein Suchwort eingetragen und seine spezifischen Suchoptionen eingestellt hat, klickt man auf Start. Nun wird die Suche gestartet.

    • Abbruch

      • Anklicken, um eine begonnene Suche zu stoppen.

    • Entferne alles

      • Entfernt alle Suchergebnisse (Diese Funktion steht erst nach der ersten Suche zur Verfügung)

  • Fortschrittbalken
    • Der Fortschrittbalken zeigt den Fortschritt der Suche durch grüne Balken an. (Funktioniert nur bei Globaler Suche)

  • Direkt downloaden
    • Mit dieser Option kann man Files anhand der ED2K-Links direkt downloaden. Man muß hier einfach nur den ED2K-Link einfügen und Enter drücken.

  • Ergebnisse
    • Das Suchergebnis-Fenster besteht aus folgenden Spalten:
      • Dateiname: Der Dateiname zu dem Suchbegriff, den Du eingegeben hast.
      • Grösse: Die Größe des Files.
      • Quellen: Die verfügbaren Quellen des Files, nach dem Du gesucht hast.
      • Typ: Der Dateityp des Files, nach dem Du gesucht hast.
      • Datei ID: Die Hash-ID des Files, der auch im ED2K-Link enthalten ist
      • Die Fortschrittsanzeige: Je nach Fortschritt der Suchanforderung, füllt sich die untere "Rinne" mit einem blauen Balken.
    • Die Farben, mit denen die Files markiert sind, haben folgende Bedeutung:
      • Schwarz: 1-2 Quellen
      • Schwarzblau: 3-4 Quellen
      • Dunkelblau: 5-6 Quellen
      • Mittelblau: 7-10 Quellen
      • Hellblau: 11- ?? Quellen
      • Rot: File wurde zum Download hinzugefügt und ist im Download aktiv
      • Dunkelrot: File wurde bereits hinzugefügt und steht auf stop/pause
      • Grün: Das File was Du hast und selbst released
    • Auswahl downloaden

      • Das/Die ausgewählt(n) File(s) wird/werden deinen Download hinzugefügt


324

Dateien
04.04.2004 8:12
  • Liste freigegebener Dateien

Im diesen Fenster findest Du alle Informationen über Deine freigegebenen Dateien.

freigegebene Dateien (xx)

Die Anzahl der Dateien, die Du freigegeben hast

Dateiname

Der Name der Datei

Größe

Die Größe der Datei.

Typ

Der Dateityp: CD-Image, Video-Datei, Bild-Datei usw.

Priorität

Die Priorität, die Du der Datei zugewiesen hast.

Erlaubnis

Die Erlaubnis ist immer Öffentlich

Datei ID

Die Hash ID der Datei, die das freigegebene File hat.

Anfragen xxxx(xxxx)

Die Zahl vor der Klammer ist die Zahl der Anfragen seit Start des eMule

Die Zahl in den Klammern, ist die Gesamtzahl der Anfragen seit die Datei in Deinem Share ist

akzeptierte Anfragen xxxx(xxxx)

Die Zahl vor der Klammer ist die Zahl der akzeptierten Anfragen seit Start des eMule

Die Zahl in den Klammern ist die Gesamtzahl der akzeptierten Anfagen seit die Datei in Deinem Share ist

Gesendet xxxx(xxxx)

Die Zahl vor der Klammer ist die Zahl der gesendeten MB seit Start des eMule

Die Zahl in den Klammern ist die Gesamtzahl der gesendeten MB seit die Datei in Deinem Share ist

bereits erhaltende Teile

Hier ist die Anzeige mit der Du kontrolieren kannst, wie verfügbar diese Datei im Netz ist.

Damit hast Du die Möglichkeit, besser zu entscheiden, wie lange Du das file noch im Share lässt, damit es besser verteilt wird, bzw. ob Du das file auf Release setzen solltest.
Bitte achte darauf, das bevor Du das file aus dem Share nimmst, es komplett verfügbar ist. Das erkennst Du an einem durchgehenden dunkelblauen Balken. Bitte lasse das File solange es Dir möglich ist im Share!

Verzeichnis

Hier siehst Du, in welchem Verzeichnis Dein shared File liegt.

Neu laden (unten rechts)

Wenn Du ?Neu laden? klickst, wird Deine Liste aktualisiert.

  • Statistikanzeige

    • Wenn Du in der ?Liste freigegebener Dateien? ein File markierst, dann bekommst Du in dieser Statistik eine grafische Übersicht des markierten Files angezeigt (Der Rest sollte sich von selbst erklären).

  • Datei-Priorität einstellen

    • Um die Priorität von einen File zu verändern mußt Du einfach nur mit der rechten Maustaste auf das jeweilige File klicken. Nun öffnet sich ein kleines Menüfenster. Hier fährst Du mit der Maus über ?Priorität?. Es öffnet sich ein kleines Extrafenster indem Du mehrere Auswahlmöglichkeiten zu sehen bekommst.

Sehr niedrig

Fast keine Chance, dass jemand jemals diese Datei bei Dir runterladen kann.

Niedrig

Geminderte Chance, dass jemand diese Datei bei Dir runterladen kann.

Normal

Gleiche Chance für alle.

Hoch

Bevorzugte Chance, dass jemand diese Datei bei Dir runterladen kann.

Release

Höchste Priorität, dass jemand diese Datei bei Dir runterladen kann. Diese Priorität ist zum Verbreiten eigener Dateien gedacht, die noch nicht oder kaum im Netzwerk vorhanden sind.

Auto

Hier regelt der eMule die Priorität nach Verfügbarkeit und Anfragen zu dieser Datei automatisch. Selten nachgefragte Dateien erhalten eine höhere Priorität als häufig nachgefragte. Auf diese Weise soll die Verfügbarkeit seltener Dateien im Netz erhöht werden.

  • Datei bewerten

    • Damit Du eine Datei bewerten kannst, mußt Du das jeweilige File markieren, dann klickst Du mit der rechten Maustaste auf die jeweilige Datei. Nun öffnet sich wieder das Menüfenster. Hier klickst Du auf ?Datei-Kommentar ändern?. Nun öffnet sich ein neues Fenster.
    Hier kannst Du nun einen 50 Zeichen langen Kommentar für diese Datei abgeben und die Datei bewerten.
    Danach klickst Du einfach auf Übernehmen.

    Dein eigener Kommentar ist für Dich nicht sichtbar, wenn im Transfer-Fenster für diese Datei ein Kommentar-Symbol zu sehen ist.


50

Allgemein
29.02.2004 18:52

Name
Tragt hier einen beliebigen Namen ein, der dann bei anderen Clients in der Quellenanzeige oder im Uploadfenster erscheint. Standardmäßig steht hier http://emule-project.net. Es wird darum gebeten, sich etwas kreativeres einfallen zu lassen.

Sprache
Wählt Euch eine Sprache aus der Liste aus.

Verschiedene Optionen

o Piepton bei Fehler
Gibt bei Fehlermeldungen zusätzlich noch einen Ton über den PC-Lautsprecher aus.

o In den Vordergrund beim Linkklick
Wenn aktiviert, erscheint beim Hinzufügen eines Downloads über einen Weblink (ed2k://) automatische das eMule-Programmfenster im Vordergrund auf Eurem Desktop. Bleibt diese Option deaktiviert, blinkt lediglich die Schaltfläche von eMule in Eurer Taskbar.

o Sicherheitsabfrage beim Verlassen
Blendet eine zusätzliche Sicherheitsabfrage beim Beenden von eMule ein.

o Online-Signatur erstellen
Wird diese Checkbox aktiviert, wird eine Datei mit dem Namen onlinesig.dat im eMule-Verzeichnis erstellt. Näheres dazu könnt Ihr in der Rubrik zur Online Signatur nachlesen.

Programmstart

o Auf neuere Version prüfen
Hiermit überprüft eMule bei jedem Programmstart, ob eine neuere Version vorhanden ist. Der Schieber bestimmt das Intervall, in dem auf eine neue Version geprüft wird.
Ist eine neuere Version vorhanden, diese auf www.eMule-project.net herunterladen. Bei einem Versionswechsel empfiehlt es sich die neue Version einfach in das selbe Verzeichnis wie die Alte zu entpacken bzw. zu installieren. Die Einstellungen und freigegeben Verzeichnisse, sowie die aktuellen Downloads werden damit automatisch übernommen.

o Logo beim Start anzeigen
Bewirkt, daß der Splashscreen beim Start angezeigt wird oder nicht.

o minimiert Starten
eMule wird nach dem Starten sofort minimiert und taucht als Symbol im Tray auf.

Webdienste ändern
Webdienste erlauben den Zugriff auf webbasierende Angebote direkt aus eMule heraus, wie z.B. Suchmaschienen für das Netztwerk im Internet.
Diese Dienste müssen in der webservices.dat eingetragen und konfiguriert werden. Mit dem Knopf Webdienste kann schnell Zugriff auf diese Datei genommen werden.

Besipiel einer WebServices.Dat:
#########################################
# Webservices Konfigurationsdatei
# nur ein Service oder eine URL pro Zeile
#
# Format: Name,URL
#
# Platzhalter:
# #filename -> Dateiname
# #hashid -> Hashid der Datei
# #filesize -> Grösse der Datei
#
# Beispiel:
# Fakecheck,http://www.eine bestimmte Suchmaschine.com/search?p=ed2k:#filesize:#hashid
# eMule Homepage,http://www.emule-project.net
# eMule FAQ,http://www.emule-project.net/faq/
#
# Kommentarzeilen fangen mit # oder / an

eMule Homepage,http://www.emule-project.net
eMule FAQ,http://www.emule-project.net/faq/

Dieses Besipiel fügt die Webdienste eMule Homepage und eMule FAQ in das Kontext Menu der Downloadliste ein.

Ed2k Links
Über diesen Knopf weist Ihr eMule an, standardmäßig Weblinks (ed2k-Links) zu verarbeiten. Erscheint dieser Knopf grau, so ist eMule bereits das Standardprogramm für diesen Linktyp.

Anmerkung:
Wenn Ihr nach eMule noch andere Filesharingprogramme installiert habt, kann es vorkommen, daß diese Programme sich automatisch als Standardprogramm für ed2k-Links eintragen. Ihr könnt dies im Registryeditor (Start -> Ausführen -> regedit) unter folgenden Schlüsseln überprüfen und korrigieren:

HKEY_CLASSES_ROOT\ed2k\shell\open\command
Name: (Standard)
Typ: REG_SZ
Data: "Pfad zur emule.exe (mit Anführungszeichen!)" %1

und

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\ed2k\shell\open\command
wie oben beschrieben.

Sollten unter ...\ed2k\shell\open\ noch andere Einträge vorhanden sein, so löscht alles folgende nach HKEY_CLASSES_ROOT\ed2k\.... bzw. nach HKEY_LOCAL_MACHINE\SOFTWARE\Classes\ed2k\.... .Sicherheitshalber solltet Ihr vor Änderungen ein Backup Eurer Registry anfertigen und nach den Änderungen Euren Rechner neustarten.

Gilt ab Version: .26a +
Aktualisiert: 02-02-03 by Monk


48

Anzeige
01.05.2004 20:19

o Statusbalken Stil
Über den Schieber kann gewählt werden wie stark der 3D Effekt des Statusbalkens ist.

o Tooltip Verzögerung (Sekunden)
Wenn Ihr die Maus über einen Down- oder Upload bewegt, erscheint nach einer gewissen Zeit ein kleines Popup-Fenster mit nützlichen Informationen zu dieser Datei oder die entsprechende Quelle. Hier könnt Ihr einstellen, nach wie viel Sekunden dieses Fenster erscheinen soll.

o Doppelklick öffnet Download
Wenn aktiviert, öffnet sich die Quellenanzeige im Downloadfenster nach einem Doppelklick, sonst genügt ein einfacher Klick mit der linken Maustaste.

o Icon für Downloads mit Kommentar/Rating anzeigen
Zeigt das [image] (Information, positive Bewertung) oder das [image] (negative Bewertung) in der Downloadliste an.

o Zeige Fortschrittsprozent von Downloads im Statusbalken
Blendet eine Angabe wieviel Prozent eines Downloads bereits heruntergeladen wurden in seinem Fortschrittsbalken ein.

o Zeige Transferraten im Titel
Zeigt die aktuelle Down- und Uploadgeschwindigkeit als Fenstertitel an.

o Zeige Downloadinformationen in den Kategorie Reitern
Neben jedem Namen einer Kategorie werden in (x/y) zwei Werte eingeblendet. Der erste (x) zeigt die Anzahl gerade aktiver Downloads, der zweite (y) die Gesamtzahl der Downloads in dieser Kategorie.

o Zum Systemicon minimieren
Wenn aktiviert, erscheint eMule nach dem Minimieren nur noch im System Tray und nicht mehr auf der Taskleiste.

o Beendete Downloads aus der Liste entfernen
Wird ein Download fertiggestellt, bleibt er in der Transferliste und wird durch einen grünen Fortschrittsbalken angezeigt. Diese Funktion entfernt die Downloads sofort nach Beendigung.

CPU & Speicher schonen

o Liste bekannter Clients deaktivieren
eMule führt Protokoll über alle Clients mit denen er Verbindung aufgenommen hat. Dies kostet Speicher. Bei Systemen mit wenig Hauptspeicher wird empfohlen diese Liste zu deaktivieren.

o Warteschlangenanzeige deaktivieren
Wie die obige Option deaktiviert diese die Anzeige der Wartenschlagenliste um den Speicher zu entlasten.

o Warteschlangenliste nicht in Echtzeit aktualisieren
Die Warteschlangenliste wird nicht so oft aktualisiert. Dies reduziert die CPU Nutzung.

o Statistikgraph bei Fensteränderung nicht neuberechnen
Wird die Fenstergrösse von eMule geändert müssen die Diagramme mit gespeicherten Daten neu berechnet werden. eMule hängt manchmal bei diesem Vorgang. Wird diese Option gewählt werden die Diagramme nicht neu gezeichnet sonder fangen von vorne an.

Schriftart wählen
Öffnet einen Dialog, in dem die Schriftart, Grösse, Stil und Farbe des Textes in den Fenstern für Nachrichten, IRC und Server bestimmt werden kann.

Autovervollständigung (History Funktion)
Die History speichert alle Eingaben in den Feldern Suche, Kademlia Bootstrap IP, Server Update Adresse und IP Filter Update Adresse und stellt beim erneuten Eintippen von etwas ähnlichem eine Autovervollständigung bereit.
Die Speicherung der Eingaben kann mit dem Häkchen bei aktiviert abgeschaltet werden und der Reset Knopf löscht alle bisherigen Einträge.

Gilt ab Version: .42a +
Aktualisiert: 2004-02-27 by Monk


45

Verbindung
01.05.2004 20:29

Zunächst einmal ist es wichtig zu wissen, mit welchen Geschwindigkeiten Euch Euer Provider ins Internet schickt.

Die Geschwindigkeit wird üblicherweise in Kilobits pro Sekunde [kb/s] angegeben, eMule benutzt allerdings Kilobytes pro Sekunde [kB/s].
Um in Kilobytes umzurechnen, teilt Ihr lediglich die Kilobits durch 8.

Beispiel:
Eure maximale Downloadgeschwindigkeit: 768kb/s ÷ 8 = 96 kB/s
Eure maximale Uploadgeschwindigkeit: 128kb/s ÷ 8 = 16 kB/s
Diese Werte gelten z.B. für T-DSL.

Am besten den Assistent benutzen in dem schon viele Verbindungen voreingestellt sind.

Kapazitäten
o Download / Upload
Für o.g. Beispiel müsstet Ihr bei Download 96 und bei Upload 16 eintragen. Diese Werte werden auch für die Verbindungsverwaltung verwendet und müssen korrekt angegeben werden.

Anmerkung:
Die Werte in Kapazitäten dürfen niemals niedriger sein, als die in Limits angegebenen Werte.

Limits
o Download
Hier gebt Ihr ein, mit welcher maximalen Geschwindigkeit eMule herunterladen darf. Empfohlen ist den Haken zu entferenen und damit kein Limit anzugeben.

o Upload
Dies ist eine sehr wichtige Einstellung. Hier gebt Ihr ein, mit welcher maximalen Geschwindigkeit Ihr Eure Dateien dem eDonkey-Netzwerk zur Verfügung stellen wollt. Ihr solltet darauf achten, diesen Wert auf ca. 75% Eures maximal möglichen Upstreams einzustellen. Für unser Beispiel bedeutet dies: 16 x 0.75 = 12.
Wird kein Upload Limit gesetzt (Haken raus) sollte unbedingt Upload Speed Sense aktiviert werden.

Anmerkungen:
Automatisches Upload Management mit Upload Speed Sense
Upload Speed Sense (USS) kann in Einstellungen -> Erweiterte Einstellungen aktiviert werden. Diese Funktion überwacht die Ping-Zeiten und regelt danach den Upload. Dies zusammen mit Abschalten des Upload Limits sorgt für eine optimale eMule Leistung und keinerlei Einbrüche der Geschwindigkeit beim Surfen oder Online spielen.

Zu hohes Upload-Limit
Jeder Download benötigt etwas zusätzliche Bandbreite, um Quellen abzufragen, den Erhalt von Packets zu bestätigen usw. Das nennt man Overhead oder Protokolldaten. Wenn Ihr Euren Upload also zu hoch ansetzt, kann sich Eure Downloadgeschwindigkeit vermindern, da eMule keine Bandbreite mehr übrig hat, um diesen Overhead ebenfalls zu erfüllen.

Zu niedriges Upload-Limit
Stellt Ihr Euren Upload auf einen Wert niedriger als 10, so wird auch automatisch Euer Download begrenzt. Erst ab einem Wert von 10 fällt diese Beschränkung weg. Dies wird Ratio genannt und beträgt 1:4 für Werte kleiner 10kB/s, d.h. ein Upload-Limit von 5kB/s hat einen maximalen Download von 20kB/s zur Folge.
Außerdem bedeutet ein niedrigerer Upload gleichzeitig weniger Credits, und dies bedeutet für Euch ein längeres Warten in den Downloadqueues (Wartelisten) anderer Clients.

Clientport
eMule nutzt als Standard den Port 4662, um von anderen Clients herunterzuladen. Normalerweise braucht Ihr diese Einstellung nicht zu ändern, es sei denn, Ihr seid durch bestimmte Firewall- oder Routereinstellungen dazu gezwungen (Port 4662 ist gesperrt). In diesem Fall erkennt Ihr das an der dauerhaften Zuteilung von niedrigen IDs. Mit diesem Test (Dank an TheDonkeyNetwork) könnt Ihr überprüfen, ob dieser Port bei Euch freigeschaltet ist.

UDP Port
Über diesen Port sendet eMule die Informationen seines erweiterten Protokolls, wie z.B. den Quellenaustausch zwischen den Clients oder die Quellenanfrage bei kompatiblen eMule-Clients. Dadurch wird der so genannte Overhead reduziert und gleichzeitig auch die Server entlastet. Dieser Port muß ebenfalls in Eurer Router- oder Firewallkonfiguration freigegeben sein. Sollte dies nicht möglich sein, könnt Ihr die UDP-Funktion deaktivieren; eMule nutzt dann den konventionellen Weg der Anfragen etc. über die Server (dies wird allerdings nicht empfohlen).

max. Quellen je Datei / Hard Limit
Hier tragt Ihr die maximal zulässigen Quellen für einen Download ein. Hat eMule die hier angegebene Anzahl an Quellen für einen Download gefunden, stellt es die Suche nach weiteren möglichen Quellen ein.

Netzwerk
eMule greift auf zwei unterschiedliche Netzwerkstruktur zurück um Quellen zu finden oder nach Dateien zu suchen. Das klassische eD2k Netzwerk, welches über die Server verwaltet wird und das serverlose Kademlia Netzwerk, benannt nach dem gleichnamigen Routing Konzept. Das Kapitel Netzwerkinformation beschreibt beide Konzepte detaillierter.
Hier kann festgelegt werden zu welchen Netzwerken sich eMule verbinden soll wenn der Verbinden Konpf gedrückt wird oder eMule automatisch die Verbindung beim Start aufbaut.

Verbindungs-Limits / Max. Verbindungen
Die maximal erlaubte Anzahl an TCP/IP- oder UDP-Verbindungen. Verbindungen werden nur bei tatsächlichen Downloads, der Suche, Wartelistenabfragen oder dem Quellenaustausch zwischen den Clients geöffnet.
Diese Einstellung dient zum Schutz des Betriebssystems, da die Win9x/ME Betriebssysteme nur ca. 80 Verbindungen gleichzeitig aufbauen können. Auch viele Router vertragen keine Werte höher 200.

Anmerkungen:
> | Unabhängig von den Einstellungen unter max. Verbindung öffnet eMule nicht mehr als 20 Verbindungen in 5 Sekunden.
> | (Zu viele Verbindungen) in der Quellenanzeige bedeutet, daß diese Grenze bereits überschritten wurde. Diese Quellen werden abgearbeitet, sobald wieder neue Verbindungen geöffnet werden können.

Automatisch verbinden beim Start
Aktiviert Ihr diese Option, so verbindet sich eMule direkt nach dem Start automatisch zu einem Server.

Wiederverbinden nach Trennung
Sollte immer aktiviert sein. Solltet Ihr einmal die Verbindung zu einem Server verlieren, so stellt eMule automatisch eine Verbindung zu einem anderen Servern her.

Zeige Overhead-Bandbreite an
Ist diese Option aktiviert, erscheinen im Statusbalken von eMule, jeweils neben der Anzeige für die momentane Up- und Downloadgeschwindigkeit, zwei weitere Werte in Klammern ( ). Diese Wert stehen für den so genannten Overhead. Als Overhead wird der Verwaltungsaufwand, der beim Öffnen von Verbindungen, beim Suchen von Quellen und bei jeder Form von Datentransfer entsteht, bezeichnet. Dieser Wert geht direkt von der für Up- und Downloads verwendbaren Bandbreite ab.

Wichtig:
Liegt der momentane Upload zuzüglich des Upload-Overheads nahe an dem eingestellten Upload Limit, so öffnet eMule zu viele Verbindungen oder muss zu viele Quellen verwalten. In diesem Fall muss der Wert für max Verbindungen oder max. Quellen je Datei reduziert werden oder es treten unerwünschte Effekte wie langsamer Download oder verminderter Upload auf.

Anmerkung:
Die Zahl der Benutzer in der Warteschlange hat keinerlei Effekt auf den Overhead und verursacht auch keinen zusätzlichen Verwaltungsaufwand.

Gilt ab Version: .42a +
Aktualisiert: 2004-02-27, Monk


56

Proxy
29.02.2004 18:04

Proxy-Server sind spezielle Rechner die als Puffer meist in großen Netzwerken eingesetzt werden. Auf ihnen läuft eine spezielle Software, die ein- und ausgehende Verbindungen zu ihren jeweiligen Zielen im Internet/Intranet weiterleitet. Proxies werden im Allgemeinen für 4 unterschiedliche Zwecke genutzt:

> | Firewall Proxy Server können so konfiguriert werden, dass sie nur bestimmt Adressen oder Ports erlauben. Sie schützen so die dahinterliegenden Computer oder LANs vor unbefugtem Zugriff.
> | Router Besonders in Firmennetzwerken werden Proxies eingesetzt um vielen Benutzern gleichzeitig Zugriff auf das Internet zu ermöglichen.
> | Daten Speicher (Cache) Diese Server enthalten oft große Datenbanken mit Inhalten die sehr oft zugegriffen werden. Ist eine Internetseite oder ein Dienst in diesem Cache enthalten kann sehr schnell darauf zugegriffen werden.
> | Anonymisierung Proxydienste werden auch genutzt um die Weiterleitung der IP oder sonstiger Informationen zu unterdrücken. Diese Server sind zum Teil frei im Internet verfügbar, es wird jedoch von der Benutzung eines solchen Servers dringend abgeraten. Diese anonymisierenden Proxies sind sehr instabil und haben meist eine sehr niedrige Bandbreite. Bei der Benutzung eines solchen Servers wird die Leistung von eMule stark einbrechen. Proxies die in einem lokalen Netz betrieben werden haben keine anonymisierende Funktion!

Wird eMule auf einem Computer betrieben, der nur über einen Proxyserver verbindet, so müssen in diesem Dialog die Einstellungen zu diesem Server vorgenommen werden oder eMule wird sich nicht mit dem Netzwerk verbinden können.

Wichtig:
Auf einem Heim PC bieten Proxies keine wirklichen Vorteile und werden in dieser Umgebung auch nur selten eingesetzt. Modems oder Router sind keine Proxies daher muss in diesem Dialog auch keine Einstellung vorgenommen werden.

Allgemein
Die Proxyunterstützung wird über die Checkbox Proxy aktivieren eingeschaltet. Folgende Informationen müssen über den zu verwendenden Proxy Server bekannt sein:

o Proxy Typ
Es existieren unterschiedliche Protokolle für Proxyserver. Das richtige Protokoll für den speziellen Server muss angegeben werden allerdings sind einige nur mit Einschränkungen für eMule verwendbar

> | SOCKS v4 / v4a Das SOCKS Protokoll ist anwendungsunabhängig und wird eingesetzt falls Verbindung zwischen zwei Computern hergestellt werden soll, ohne dass direkt die jeweilige IP erreichbar ist. Die Versionen 4 und 4a sind allerdings nur in der Lage das TCP Protokoll weiterzuleiten, nicht aber UDP. Kommt ein solcher Proxy zum Einsatz muss in Einstellungen -> Verbindungen der UDP Port über die entsprechende Schaltfläche deaktiviert werden.
> | SOCKS v5 Es gelten die selben Einschränkungen wie für SOCKS v4.
> | HTTP 1.1 Verwenden die Server das noch unflexiblere Hypertext Transfer Protocol - HTTP gelten die gleichen Einschränkungen wie beim SOCKS v4 Protokoll. Das HTTP Protokoll ist nicht in der Lage offene Ports bereitzustellen. Es ist keine Verbindung mit hoher ID möglich.

o Proxy Host
Der Name oder die IP Adresse des Proxies muss hier angegeben werden.

o Proxy Port
Normalerweise verwenden diese Server Port 1080, es können aber auch andere Konfigurationen auftreten.

Authentifizierung
Einige Proxies verlangen die Anmeldung per Benutzername und Passwort bevor eine Verbindung aufgebaut wird. Soll eine Anmeldung erfolgen muss die Authentifizierung aktiviert werden und die richtigen Angaben in den Feldern Name und Passwort eingetragen werden.

Automatisches Verbinden zu Serven ohne Proxy
Ist diese Option aktiv versucht eMule bei automatischen Verbindungsversuchen (Einstellungen -> Verbindung) den Proxy zu umgehen.

Gilt ab Version: .28a +
Aktualisiert: 2003-04-02 , Monk


51

Server
06.03.2004 8:52

Lösche tote Server nach x Versuchen
eMule löscht tote, nicht erreichbare Server automatisch. Wann ein Server für eMule als nicht mehr erreichbar gilt, könnt Ihr durch eine beliebige Zahl X einstellen. Der betreffende Server wird beim nächsten gescheiterten Versuch gelöscht nachdem die Zahl x erreicht wurde, d.h. steht dort 3 wird der Server beim 4 erfolglosen Versuch ihn zu kontaktieren gelöscht.

Serverliste beim Programmstart aktualisieren
In dem Verzeichnis, in das Ihr eMule entpackt oder installiert habt, findet Ihr eine Datei mit dem Namen adresses.dat. Dort könnt Ihr einen gültigen Link zu einer server.met (Serverliste) eintragen, die dann bei aktivierter Option bei jedem Neustart von eMule automatisch heruntergeladen und benutzt wird.
Um die adresses.dat zu bearbeiten, einfach den [image] Knopf drückenn, eine gültige URL zu einer server.met eintragen und die Liste abspeichern. Es können mehrere Addressen eingetragen werden, abgefragt wird allerdings nur solange bis eine gültige Liste erhalten wurde.

Anmerkung:
Der Standard-Editor (notepad) kann in der preferences.ini geändert werden. Der Variablen TxtEditor= muss hierzu der vollständige Pfad zu dem neuen ASCII Editor hinzugefügt werden.

Empfange aktuelle Serverliste vom verbundenen Server
eDonkey-Server kennen/verständigen sich bis zu einem gewissen Grad untereinander. Sobald diese Option aktiviert ist, erhält eMule bei erfolgreicher Verbindung zu einem Server eine Liste mit allen funktionierenden Servern, die diesem bekannt sind.

Empfange aktuelle Serverliste von verbundenen Nutzern
Nehmen zwei eMule Clients Verbindung auf, werden ihre Serverlisten verglichen und jeweils aktualisiert.

Benutze Prioritäts-System
Ist diese Option aktiviert, so versucht eMule bei einem erneuten Verbindungsversuch eine Verbindung zu den Servern in der Reihenfolge ihrer festgelegten Priorität (niedrig, normal, hoch) herzustellen. Wenn ausgeschaltet,erfolgt dies der Reihe nach, so wie die Server in der Liste aufgeführt sind.

Benutze Smart-LowID-Prüfung beim Verbinden
eMule merkt sich ob er schon einmal eine hohe ID erhalten hat. Wenn ja, sorgt diese Funktion dafür, dass eMule nochmals verbindet, falls ein Server fälschlicherweise eine niedrige ID vergibt. Erhält er allerdings 3 niedrige IDs in Folge wird angenommen, dass mit der Konfiguration etwas nicht stimmt und es wird die niedrige ID beibehalten. Erhält eMule dann eine hohe ID aktiviert sich die Funktion wieder.

Anmerkung:
Dies setzt voraus, daß Eure Firewall und/oder Router korrekt konfiguriert sind - es ist keine Lösung für allgemeine Probleme mit niedrigen IDs. Hiermit wird lediglich die Vergabe von niedrigen IDs durch überlastete oder falsch konfigurierte Server verhindert.

Sicheres / langsameres Verbinden zu Servern
Beim Verbinden zu einem Server fragt eMule 2 Server gleichzeitig an um schnell eine Verbindung herstellen zu können. In manchen Fällen führt dies zu einer unberechtigten Vergabe einer niedrigen ID. Safe Connect umgeht dieses Problem durch Anfragen nur eines Servers gleichzeitig.

Anmerkung:
Dies hat nur Gültigkeit während eMule noch nicht zu einem Server verbunden ist. Im Gegensatzt zu mlDonkey stellt eMule nur eine aktive Serververbindung her. Die Optionen dienen lediglich dazu, den Prozess des Verbinden abzukürzen.

Automatisches Verbinden nur zu statischen Servern
Im eMule Verzeichnis befindet sich die Datei staticservers.dat. Server aus der Liste können dieser hinzugefügt werden, damit sie nicht verloren gehen. Dies ist nur sinnvoll, wenn es sich dabei um Server mit einer statischen IP oder um Server die eMules DynDNS unterstützen handelt. Die Option sorgt dafür, dass eMule versucht beim Verbinden auf einen der Server in der staticservers.dat zu gelangen. Vorsicht, sind in der dieser keine gültigen Server eingetragen, verbindet sich eMule nicht!

Setze manuell hinzugefügte Server auf hohe Priorität
Werden Server nicht über eine Liste, sondern einzeln hinzugefügt, setzt diese Option die Server automatisch auf hohe Priorität

Gilt ab Version: .29c +
Aktualisiert: 2003-07-10 by Monk


52

Verzeichnisse
29.02.2004 18:07

Eingehende Dateien
Hier legt Ihr das Verzeichnis fest, in welches Eure fertiggestellten Downloads verschoben werden. Wird das voreingestellte Verzeichnis geändert, muss der neue Pfad auf einen existierenden Ordner verweisen. eMule legt diesen Ordner nicht selbstständig an!

Temporäre Dateien
Dieses Verzeichnis enthält Eure Downloads solange diese noch nicht fertiggestellt sind. Da eMule eine Datei von mehreren Quellen gleichzeitig laden kann, wird in diesem Verzeichnis eine .part Datei, in der Grösse des fertigen Downloads, angelegt. Es ist darauf zu achten, dass sowohl für die temporären wie auch die abgeschlossenen Downloads genügend Festplattenspeicher zur Verfügung steht.
Auch hier gilt, wird das voreingestellte Verzeichnis geändert, muss der neue Pfad auf einen existierenden Ordner verweisen. eMule legt diesen Ordner nicht selbstständig an! Nach einer Änderung muss eMule neu gestartet werden.

Freigegebene Verzeichnisse
Hier könnt Ihr weitere Verzeichnisse mit Dateien angeben, die Ihr tauschen möchtet. Dazu hakt Ihr das entsprechende Verzeichnis an. Wollt Ihr neben diesem Verzeichnis auch noch alle darin befindlichen Unterverzeichnisse freigeben, so haltet beim Anklicken die STRG-Taste gedrückt. Es können keine ganzen Festplatten (Partitionen) freigegeben werden.

o UNC Verzeichnisse (Netzwerk)
UNC steht für "Uniform Naming Convention" und ist ein Quasistandard für das Ansprechen von freigegebenen Ressourcen (Ordner oder ganze Laufwerke) in einem Netzwerk. Damit können Netzlaufwerke angesprochen werden ohne diese vorher verbinden (mapping) zu müssen. Ein solcher Netzwerkpfad hat folgendes Format:

\\server\resource\..

Beispiel:
\\test\LaufwerkD\eMule würde auf den Ordner eMule auf der Festplatte mit dem Freigabenamen LaufwerkD des Netzwerkrechners test verweisen.

Anmerkungen:
> | Immer, wenn Ihr mit Eurem Client zu einem Server verbindet, wird eine Liste mit Euren freigegebenen Dateien an diesen Server übermittelt. Dieser speichert die Liste und sorgt dafür, daß Eure Dateien bei einer Suche im Netzwerk auch gefunden werden und als Quelle für andere Clients zur Verfügung stehen. Diese Funktionalität hat den Nachteil, daß mit wachsender Anzahl an freigegebenen Dateien der Verwaltungsaufwand eines Servers enorm zunimmt; dies wirkt sich auf die CPU-Last des Servers aus und führt u.a. dazu, das dieser Server immer weniger Clients bedienen kann oder komplett zusammenbricht. Viele Server haben dafür ein Limit eingerichtet, wonach z.B. nur 120 Dateien von Euch verwaltet werden. Der Rest wird einfach nicht berücksichtigt. Weniger ist auch hier manchmal mehr.
> | Euer Verzeichnis für eingehende und temporäre Dateien ist automatisch freigegeben - Ihr braucht es nicht nochmal zusätzlich zu sharen.
> | Gebt wenige, große anstatt vieler kleiner Dateien frei. Wenn Ihr MP3s freigebt, packt sie vorher in ein Archiv.
> | Gebt keine kompletten Verzeichnisse wie \Programme, \Temp, oder \Windows und schon gar keine kompletten Laufwerke frei. Die irrige Meinung aus alten eDonkey-Tagen (je mehr ich freigebe, desto mehr bekomme ich auch) gilt hier nicht und bringt Euch absolut nichts.

Gilt ab Version: .29b +
Aktualisiert: 200-06-20 by Monk


49

Dateien
29.02.2004 18:08

Freigaben sichtbar für
Mit dieser Funktion legt Ihr fest, ob oder inwieweit andere Clients Eure freigegebenen Dateien einsehen dürfen. Ihr könnt wählen zwischen Alle, Niemanden oder nur Freunde (siehe Freundefunktion).

Intelligent Corruption Handling (ICH)
Intelligente Fehlerkorrektur
Datenübertragungen werden im eDonkey Netzwerk über so genannte Chunks abgewickelt. Ein Chunk ist ein 9 MB großes Datenpaket. Wenn ein solches Paket empfangen wurde, wird es daraufhin überprüft, ob es in Ordnung ist, oder schadhaft. In letzterem Falle (corruption found in...) wird der Chunk erneut angefordert und heruntergeladen. ICH versucht nun, statt des ganzen Chunks nur die beschädigten Teile erneut zu laden und dadurch die Zeit für den Gesamtdownload zu vermindern.
Anmerkungen:
> | Wir von einer Datei mehr übertragen als die eigentlich Grösse des Downloads, ist dies auf fehlerhafte Teile zurückzuführen, die von eMule erneut übertragen wurden.
> | Wird dagegen weniger Übertragen, konnte die Datei durch eMules Kompression verkleinert werden.

Initialisierung
o Neue Dateien zum Download starten im Pause-Modus
Hiermit werden alle neu hinzugefügten Downloads nicht sofort auf Warte gesetzt sondern als angehaltener Download hinzugefügt. Dies empfiehlt sich wenn sich mehr als 20 Dateien bereits in der Downloadliste befinden, da sonst oft der (zuviele Verbindungen) Effekt auftritt und die gesamte Internetverbindung unnötig belastet wird. Siehe auch bei fertigem Download, nächste Datei fortsetzen.

o neue freigegebene Datei auf Autopriorität stellen
Ist eine Datei fertig heruntergeladen oder werden neue Dateien freigegeben werden diese auf automatische Priorität gesetzt. eMule legt die Priorität an Hand der Nachfragen für diese Datei fest. Wird diese Datei nur sehr wenig nachgefragt vergibt eMule eine hohe Priorität bei sehr vielen Anfragen eine niedrige. Diese Funktion erhöht die Verfügbarkeit seltener Dateien im Netzwerk.

o neue Downloads auf Autopriorität stellen
Ähnlich der obigen Funktion gilt diese für neu hinzugefügte Downloads. Die Priorität der Datei wird je nach der Anzahl gefundener Quellen festgelegt.
Gefundene Quellen | Priorität
0 - 40 | Hoch
41 - 80 | Normal
ab 81 | Niedrig

o Dateinamen neuer Downloads bereinigen
Diese Option bereinigt alle Dateinamen sobald sie in die Downloadliste aufgenommen werden. Zeichen wie _ , . oder andere unnötige Sonderzeichen werden entfernt bzw. durch ein Leerzeichen ersetzt und die Gross- Kleinschreibung wird korrigiert. Über die Berabeiten-Schaltfläche können oft genutzte Zeichenketten definiert werden, die ebenfalls automatisch entfernt werden. Es sind bereits Zeichenketten vordefiniert, neue können durch | getrennt selbst hinzugefügt werden.

Warnung:
Speziell bei Image - Dateien von Brennprogrammen, wie z.B. *.cue/*.bin (CDRWin), *.mds/*.mdf (Alcohol120%), *.ccd/*.../files/help/1031/*.sub (CloneCD), *.bwt/*.bwi/*.bws (BlindWrite), sollte diese Option nicht verwendet werden. Diese Dateien enthalten auch den Dateinamen der zugehörigen Dateien. Wird dieser verändert kann das Brennprogramm die einzelnen Dateien des Images nicht mehr finden und meldet einen Fehler.
Wird der Dateiname dennoch geändert muss der neue Dateiname in den zugehörigen Steuerdateien des Images ebenfalls geändert werden. *.cue Dateien lass sich noch recht einfach im normalen Windows Editor (Notepad) bearbeiten. Bei den anderen Imageformaten sollte ein Hexeditor wie UltraEdit oder WinHex verwendet werden.

Versuche komplette Chunks hochzuladen
Ein Chunk wird erst zur Weiterverteilung freigegeben wenn eMule diesen Chunk vollständig heruntergeladen und auf Fehler überprüft hat. Solange steht dieser Chunk anderen Suchenden noch nicht zur Verfügung. Diese Option versucht solange hochzuladen, bis ein Chunk fertiggestellt wurde um die Verfügbarkeit im Netz zu erhöhen. Für neue Releases ist diese Option unbedingt einzuschalten, es wird jedoch auch generell empfohlen sie zu aktivieren.

möglichst (zuerst) die ersten und letzten Dateiteile herunterzuladen
Um die Vorschaufunktion für Dateien nutzen zu können, muss der erste und letzte Teil dieser Datei bereits heruntergeladen sein. Mit dieser Option wird versucht diese als erstes herunterzuladen. Es wird nicht empfohlen diese Option zu aktivieren, das sie sich nachteilig auf die Verfügbarkeit der einzelnen Chunks auswirkt.

Beobachte Zwischenablage auf eD2k-Dateilinks
Wird ein eD2k Link, z.B. per STRG+c oder von einer Webseite, in die Zwischenablage kopiert fragt eMule nach ob dieser zu den Downloads hinzugefügt werden soll.

Bei fertigem Download, nächste Datei fortsetzen
Befindet sich in der Downloadliste ein angehaltener Download wird dieser automatisch auf fortsetzten geschaltet wenn ein anderer Download fertiggestellt wurde.

o gleiche Kategorie bevorzugen
Diese Option kann nur aktiviert werden, wenn Bei fertigem Download, nächste Datei fortsetzen aktiviert ist. Sind die Downloads in Kategorien eingeteilt, wird aus der selben Kategorie ein gestoppter/pausierter Download fortgesetzt.

Videowiedergabe Programm
Ist dieses Feld leer, wird bei der Vorschau von Videodatein automatisch der Standardplayer für den entsprechenden Typ verwendet. Trägt man über Durchsuchen den Pfad zu einem anderen Player ein, wird stattdessen dieser verwendet.
Über das Kästchen Erstelle Kopie für die Vorschau kann festgelegt werden, ob eine temporäre Datei für die Vorschau verwendet werden soll. Dies empfiehlt sich für die meisten Player, da diese Probleme bekommen, wenn grosse Teile der Datei noch fehlen. Als Alternative kann hier zum Beispiel der VLC - VideoLAN Client verwendet werden, der auf keine temporäre Datei angewisen ist. Siehe auch Vorschau von Dateien.

Gilt ab Version: .28b +
Aktualisiert: 2003-05-04 by Monk


53

Benachrichtigungen
29.02.2004 18:10

Benachrichtigungen sind kleine PopUp-Fenster, die Euch über wichtige Statusmeldungen von eMule auf dem Laufenden halten, wenn das Programm im Tray minimiert ist oder Ihr z.B. spielt oder Filme anschaut.

Nachricht Popup
o mit Sound
Aktiviert Ihr diese Funktion, so wird zusätzlich zu dem PopUp-Fenster noch ein beliebiger Sound abgespielt. Der Pfad zu der entsprechenden Sounddatei muss in dem Kasten angegeben sein.

Einblenden wenn
o neuer Log-Eintrag
Jeder Entrag im Logbereich des Serverfensters wird mit einem neuen PopUp-Fenster signalisiert.

o neue Chatsitzung
Wenn eine neue Chatsession im Nachrichtenfenster gestartet wird.

o eine neue Nachricht empfangen
Wenn Ihr eine neue Nachricht erhaltet. Das [image] -Symbol zeigt dies ebenfalls an.

o ein Download beendet/hinzugefügt
Immer, wenn ein Download beendet oder mittels Web-/IRC-Links oder der Suchfunktion hinzugefügt wird.

o neue eMule Version gefunden
Nachrichten Popup wenn bei der Überprüfung der Version eine neuere gefunden wurde.

o Wichtiges: kein freier Platz auf Datenträger, Serververbindung verloren
Wenn Ihr keinen Platz auf der Festplatte mehr frei habt, werden Eure Downloads auf Pause gesetzt bzw. auf Fehlerhaft, wenn der Download bereits beendet war.

Gilt ab Version: .26a +
Aktualisiert: 2003-03-12 by Monk


54

Statistikanzeige
29.02.2004 18:09

Graphen
o Update Verzögerung
Hier wird festgelegt, wie oft die Anzeige der Graphen aktualisiert wird. Zu niedrige Werte (hohe Aktualisierungsfrequenz) können sich nachteilig auf die CPU-Last auswirken.

o Durchschnittsgraphen über X mins errechnen
Diese Einstellung bewirkt, das Daten der letzten X Minuten zur Berechnung der Durchschnittswerte herangezogen werden. Standardmäßig ist dies auf 5 Minuten eingestellt.

o Farben
Hier könnt Ihr die graphische Statistikanzeige mit anderen Farben versehen. Aus der Dropdown-Liste das zu verändernde Element wählen und über den Farbselektor die gewünschte Farbe einstellen. Es kann sogar die Farbe der Geschwindigkeitsanzeige des Tray-Icons geändert werden.

o Verbindungs-Statistiken, Y-Achse-Skala
Normalerweise ist der Bereich in dem die Anzahl der aktiven Verbindungen und die Anzahl der Up- bzw. Downloads dargestellt werden, bis 100 eingeteilt. Diese Einstellung erlaubt die Skalierung dieser Graphen frei zu wählen.

o Verhältnis aktiver Verbindungen
Der Bereich von 0 bis 100 ist normalerweise nicht ausreichend um die Anzahl der aktiven Verbindungen darzustellen. Der hier eingestellte Wert teilt die Anzahl der Verbindungen um den Darstellungsbereich zu erweitern. Ist beispielsweise ein Faktor 1 : 4 eingestellt wird die Anzahl der Verbindungen durch 4 geteilt bevor sie im Graphen zu Darstellung gebracht werden.

Hinweis:
Die zwei letzten Einstellungen können beispielsweise genutzt werden um die Auflösung des Graphen der Up- und Downloads zu erhöhen, indem der Wert Y-Skala verringert wird, gleichzeitig aber der Teiler der zweiten Einstellung erhöht wird um den gesamten Verbindungsgraphen darstellen zu können.

Statistik-Baum
o Update-Verzögerung
Aktualisierungsintervall der textbasierten Statistikanzeige. Im Sinne der CPU-Last gilt die selbe Anmerkung wie bereits ober erwähnt.

Gilt ab Version: .29a +
Aktualisiert: 2003-06-03 by Monk


55

IRC
02.05.2004 8:44

Einstellungen - IRC

Server
Standardmäßig ist dies irc.freshirc.com. Hier sind auch die offiziellen eMule-Channels zu finden.

Name
Hier legt Ihr Euch einen Spitznamen (Nick, Nickname) für das IRC-Netz zu. Dieser Name hat nichts mit dem unter Einstellungen | Allgemein zu tun.

Raumliste
o Benutze Raumlisten-Filter
Gefiltert wird hier entweder nach Namen oder Useranzahl. Die Channelliste zeigt dann nur noch Räume (Channels) mit einem passenden Namen oder einer Nutzeranzahl über dem eingegebenen Wert an.

Ausführen
o Führe die Zeichenkette beim Verbinden aus
Diese Funktion ermöglicht es, bestimmte IRC-Befehle bei Verbindung zum IRC-Netzwerk auszuführen. Dies können z.B. /join #[channel Name] oder /ns identify [Passwort] sein. Mehrere Befehle werden mit einem | getrennt.

Beispiel:
/ns identify [Passwort] | /join #emule

Verschiedene Optionen
o Verbinde zu Hilferäume
Mit dieser Option verbindet sich eMule automatisch zu den offiziellen Hilfe Chats.

o Klänge für Ereignisse zuweisen
-kommt noch-

o Lade beim Verbinden die Raumliste des Servers
Ist diese Option aktiviert werden alle verfügbaren Räume auf diesem Server in einer Liste dargestellt. Diese Liste kann mit dem Raumlistenfilter eingeschränkt werden.

o Stelle Zeitstempel den Nachrichten voran
Vor jeder Nachricht im IRC wird die aktuelle Zeit eingeblendet.

o Ignoriere Info-Nachrichten
Channel-Benachrichtigungen wie z.B. beim Betreten oder Verlassen eines Channels werden nicht angezeigt.

o Ignoriere eMule-IRC-Protokoll Nachrichten
Ähnlich wie bei den Info Nachrichten werden Statusmeldungen usw. nicht angezeigt um die Übersichtlichkeit des Channels zu wahren.

o Akzeptiere eD2k Links in IRC (Vorsicht!)
Ist diese Funktion aktiviert werden automatische alle eD2k Links, die im IRC gepostet werden als Download hinzugefügt. Diese Funktion sollte zusammen mit Nur von Freunden (From friends only) verwendet werden, um nicht unerwünschte Downloads in eMule mit aufzunehmen. Ist diese Zusatzfunktion aktiviert werden Links nur von Personen entgegen genommen die in eMule als Freunde eingetragen sind.

Gilt ab Version: .30a +
Aktualisiert: 2003-10-24 by Monk


57

Zeitplaner
02.05.2004 15:35

Der Zeitplaner dient der automatischen Änderung bestimmter Einstellungen in eMule abhängig von Zeit und Wochentag. So kann zu bestimmten Zeiten die Bandbreitennutzung eingeschränkt werden um anderen Internetanwendungen, die zu dieser Zeit aktiv sind, diese Bandbreite zur Verfügung zu stellen. Wird die Verbindung dann z.B. zu Nachtzeiten nicht anderweitig genutzt, können die Einstellungen automatisch wieder nach oben gefahren werden.

Das Konzept des Zeitplaner erlaubt, Aktionsprofile zu erstellen, die zu definierten Zeiten und Wochentagen ausgelöst werden. Jedes dieser Aktionsprofile kann mehrere unterschiedliche Einstellungsänderungen enthalten.

Die obere Liste zeigt die angelegten Aktionsprofile. Wird eines ausgewählt, zeigt der Details Bereich die vorgenommenen Einstellungen für das ausgewählte Aktionsprofil.

o aktiviert
Bestimmt die generelle Nutzung des Zeitplaners

o Entfernen
Löscht das ausgewählte Aktionsprofil

o Neu
Erstellt ein neues Aktionsprofil. Das neu erstellte Profil wird automatisch in der Details-Ansicht angezeigt um die Einstellungen vorzunehmen.

Details
Dieser Bereich zeigt die Einstellungen, die für das ausgewählte Profil eingetragen wurden. Jedes Profil wird über folgende Parameter definiert:

o aktiviert
Es ist möglich mehrere Profile parallel laufen zu haben. Über diese Checkbox kann das ausgewählte Profil aktiviert werden. Deaktivierte Profile werden nicht beachtet.

o Titel
Name des Aktionsprofils.

o Zeit
Bestimmt die Gültigkeit des Profils. Die angelegten Aktionen können wahlweise täglich oder nur an bestimmten Wochentagen in dem definierten Zeitintervall ausgelöst werden.
Ist die Gültigkeitsdauer abgelaufen werden automatisch die Einstellungen wiederhergestellt, die vor der Aktion gegolten haben.

Anlegen von Aktionen in einem Profil
Zuerst muss über die Schaltfläche Neu ein neues Aktionsprofil erstellt werden. Nach der Angabe von Titel und Zeiteinstellungen wird über die rechte Maustaste im Aktionenfeld eine neue Aktion angelegt oder eine bestehende geändert.

o Hinzufügen
Erstellt eine neue Aktion. Wird eine Aktion neu angelegt erscheint nach der Auswahl des Aktionstyps automatisch ein Eingabefeld. Hier muss der gewünschte Wert eingetragen werden. Zur Auswahl stehen diese Aktionen:

> | Upload Limit Setzt den maximalen Upload auf den eingegebenen Wert. Eingabe erfolgt in kB/s
> | Download Limit Verändert das global eingestellte Download Limit. Eingabe ebenfalls in kB/s
> | max. Quellen Maximal erlaubte Anzahl der Quellen (Hard Limit) für eine Datei
> | max. neue Verb./5sek Erlaubt die Änderung der Geschwindigkeit in der neue Verbindungen erstellt werden. Vorsicht mit dieser Einstellung. Nähere Informationen unter Einstellungen -> Erweitert.
> | Max. Verbindungen Überschreibt die eingestellte maximale Anzahl von Verbindungen aus Einstellungen -> Verbindungen.
> | Kat: Downloads stoppen Diese Aktion stoppt zu dem definierten Zeitpunkt alle Downloads in der angegeben Kategorie.
> | Kat: Downloads fortsetzen Setzt alle gestoppten Downloads in der gewählten Kategorie fort.

Jede Änderung an den Aktionseinstellungen oder Zeit muss mit Übernehmen bestätigt werden.

o Bearbeiten
Erlaubt die Werte für eine bereits angelegte Aktion zu ändern.

o Entfernen
Löscht die ausgewählte Aktion.

Gilt ab Version: .28a +
Aktualisiert: 2003-04-12 , Monk


88

Webinterface
29.02.2004 18:30

Das Webinterface erlaubt Zugriff auf eMule von jedem beliebigen Computer im Internet. Das Konzept des Webinterfaces wird in dem Kapitel Webinterface unter Features näher erklärt.

Vorlagen:
Damit das Webinterface richtig funktioniert muss sich die Datei eMule.tmpl vorhanden sein. Diese Vorlage enthält die Informationen über das Aussehen und Optionen der Webkontrolle. Die eMule.tmpl ist ab der Version v.27b mit in dem Release oder kann auf www.emule-project.net heruntergeladen werden.
Die notwendigen Bilddateien werden in dem Ordner Webserver abgelegt, der sich im eMule Installationsverzeichnis befinden muss.

Allgemein

o Aktiviert
Ist das Webinterface aktiviert erlaubt eMule den Zugriff auf seine Oberfläche aus dem Internet. Nach der Aktivierung muss die Vorlage über die Schaltfläche Vorlage neu laden aktualisiert werden.Wird keine gültige eMule.tmpl gefunden erscheint die Fehlermeldung Kann Vorlagendatei nicht laden: \...\eMule.tmpl in der Log-Ausgabe.
Der Webinterface sollte aus Sicherheitsgründen nur aktiviert werden wenn man seine Funktionen auch nutzt!

o Gzip Komprimierung
Um Bandbreite zu sparen wird die Kommunikation zum Webinterface mit Gzip komprimiert.

o Port
Diese Einstellung legt den Port fest auf dem eMule das Webinterface bereit stellt. Dieser Port ist ein Teil der Adresse mit der der Server in einem Browser angesprochen werden kann. Der Standard-Port 4711 muss normalerweise nicht geändert werden. Bei der Verwendung eines Routers muss dieser Port weitergeleitet werden.
Wird von dem zugreifenden Computer der Port 4711 geblockt, also z.B. durch eine Firewall oder ein Proxy, kann die Änderung des Ports auf 80 (Standard-Port für Zugriffe auf das Internetseiten) Abhilfe schaffen.

o Layout Vorlage
Normalerweise befindet sich die *.tmpl Datei im eMule Installationsverzeichnis. Über die Schaltfläche ... kann ein beliebiger Pfad zu dieser Datei angegeben werden.

Admin
Eingabefeld für das Passwort um sich am Webinterface anzumelden. Es sollte ein sicheres Passwort gewählt werden, da ein ungesichertes Webinterface die volle Kontrolle über eMule für jeden erlaubt. Ein eingegebenes Passwort wird immer mit 6 *** angezeigt. Es ist kein Passwort voreingestellt.

Gast

o Aktivieren
Neben dem Admin Zugang der die volle Kontrolle über eMule erlaubt kann ein Gastzugriff eingerichtet werden. Der Gastzugriff hat keine Berechtigung etwas an den Einstellungen oder den Dateien zu verändern. Wird er nicht benutzt empfiehlt es sich ihn zu deaktivieren.

o Passwort
Der Gastzugriff kann ebenfalls über ein Passwort abgesichert werden.

Anmerkung:
Falls sich, statt der gewählten Seite im Webinterface ein Downloadfenster öffnet, müssen Einstellungen im Internet Explorer angepasst werden. Die Optionen HTTP 1.1 verwenden und HTTP 1.1 über Proxyverbindung verwenden müssen in Extras -> Internetoptionen -> Erweitert -> Einstellungen für HTTP 1.1 ausgewählt sein.

MobileMule
MobileMule erlaubt es eMule von einem Java fähigen Handy aus fernzusteuern Es stehen ähnliche Funktionen wie im Webinterface zur Verfügung. Nähere Informationen über MobileMule find sich unter http://mobil.emule-project.net/.

o MobileMule aktivieren
Macht den Zugriff auf eMule von einem Mobiltelefon aus möglich.

o Passwort
Wie auch beim sonstigen Webinterface ist kein Standardpasswort vergeben. Aus Sicherheitsgründen sollte bei aktivierter Funktion immer ein Passwort vergeben werden.

o Port
Erlaubt die Einstellung des Zugriffsports. Ist der PC auf dem eMule läuft hinter einer Firewall oder einem Router muss dieser Port ebenfalls freigegeben / weitergeleitet werden, da sonst kein Zugriff möglich ist.

Gilt ab Version: .42a +
Aktualisiert: 2004-02-27 , Monk


87

Sicherheit
01.05.2004 20:18

IP-Filter
Der IP-Filter verweigert den IP-Bereichen, die in der ipfilter.dat eingetragen sind, die Verbindung mit eMule. Mit der Schaltfläche Bearbeiten kann diese Datei im Editor aufgerufen und bearbeitet werden. Nähere Informationen hierzu finden sich im Kapitel IP-Filter der FAQ.
Über die Schaltfläche Neu Laden muss die ipfilter.dat Datei nach einer Änderung neu eingelesen werden.

o Filterstufe
Jeder Eintrag in der ipfilter.dat hat einen Zugriffslevel. Dieser Zugriffslevel beschreibt die Vertrauenswürdigkeit des Eintrags. Hohe Werte gelten als Vertrauenswürdig und werden nicht gefiltert, wogegen niedrige Werte gefiltert werden. Die Filterstufe legt die Grenze zwischen vertrauenswürdig und unsicher fest. Jeder Eintrag mit einem Zugriffslevel kleiner der Filterstufe wird geblockt. Der eingetragene Wert sollte nicht verändert werden!

o Server anhand der IP filtern
Normalerweise werden die Filterregeln nur auf andere Teilnehmer im Netzwerk angewandt. Mit dieser Option können zusätzlich auch die Server mit diesen Regeln gefiltert werden.

o Aktualisiere von URL
Diverse Seiten bieten IP Filter an. Hier kann ein Link zu einer solchen Filter-Datei angegeben und automatisch in eMules ipfilter.dat heruntergeladen werden.

Nachrichten
Wiederholen sich unerwünschte Nachrichten können diese geblockt werden. Erhält eMule eine Nachricht, die mit dem Text in diesem Feld übereinstimmt, wird diese nicht angezeigt. Verschiedene Meldungen müssen mit | getrennt werden.

o Nur von Freunden akzeptieren
Blockiert alle Nachrichten, ausser sie stammen von einem Benutzer, der in der Freundesliste eingetragen ist.

o Nur von gültigen Clients akzeptieren
Diese Option sollte aktiviert sein. Sie bewirkt eine Prüfung des Absenders, ob dieser gültig erscheint.

o Advanced Spam Filter
Ist dieser Filter aktiv wird jede ankommende Nachricht auf folgende Kriterien hin überprüft:
> | Bei der ersten Kontaktaufnahme wird gleich eine Webaddresse gesendet
> | Dieser User hat schon 5 oder mehr Nachrichten gesendet, ohne dass eine Antwort gegeben wurde

Trifft einer dieser Fälle zu wird der entsprechende Benutzer ignoriert. Dies gilt bis zum nächsten Neustart von eMule.
Benutzer auf der Freundesliste werden nie gebannt.

Kommentar
Diese Funktion erfüllt den gleichen zweck wie der Nachrichtenblock nur wird sie auf Dateikommentare angewandt.

Hinweis:
Die Dateikommentare sind nicht dazu gedacht Werbung zu machen oder sich über das Wetter zu unterhalten. Dateikommentare sollen dem Benutzer eine Hilfe sein um sich über die Qualität des Downloads ein Bild zu machen. Bitte entsprechend sinnvolle Kommentare verwenden.

Verschiedene Optionen
o nutze sichere Identifikation
Mehr Informationen über die verschlüsselte Benutzeridentifikation sind im Kapitel Sichere Benutzer Identifikation zu finden.

o Run eMule as unpriviledged User (eMule unter einem sicheren Benutzer ausführen)
Diese Option ist nur in der Windows NT Reihe (2k, XP, 2003) verfügbar und erlaubt eine höhere Systemsicherheit durch Zuweisen spezifischer Nutzerrechte.
Normalerweise meldet sich ein Benutzer bei diesen Betriebsystem als Administrator an. Dieses Benutzerkonto erlaubt den vollständigen Systemzugriff des Benutzer und jeder Software, die unter diesem Benutzer ausgeführt wird. Wird schädlicher Programmcode unter Administratorrechten ausgeführt hat dieser also auch vollständigen Systemzugriff.
Wird die Option eMule unter einem sicheren Benutzer auszuführen aktiviert, legt eMule einen neues Benutzerkonto namens emule_secure an und erteilt diesem Benutzer die notwendigen Schreibzugriffsrechte auf die von eMule benötigten Ordner (Installationsverzeichnis und die Ordner für temporäre bzw. fertiggestellte Dateien). Dieser Benutzer hat ansonsten keine Rechte und damit auch keinen Zugriff auf das Windows System. eMule startet sich von nun an unter diesem emule_secure Benutzer, was es schädlichem Code, der in eMule von aussen eingeschleust wird, unmöglich macht, auf das System zuzugreifen und Schaden anzurichten. Dies ist eine präventive Funktion die das Betriebssystem und die Daten schützt, sollte eine Schwachstelle im Programmcode gefunden werden.
Anmerkungen:
o | eMule stellt sicher, dass es alle benötigten Berechtigungen besitzt. Um die Sicherheit weiter zu erhöhen, kann dem emule_secure Benutzer vollständig der Zugriff auf andere Ordner oder Festplatten verwehrt werden. Diese Funktion bietet Windows nur bei NTFS Laufwerken nicht bei bei FAT.
o | Der eigene Benutzer für eMule erlaubt auch alle weiteren modernen Zugriffs und Benutzerregeln wie Festplattenkontingente o.ä. zu benutzen.
o | Ein Fehler in Windows XP verhindert, dass ein Programm welches unter anderen Rechten ausgeführt wird den momentanen visuellen Stil des Betriebssystems benutzt, die Benutzeroberfläche wechselt zum standard Win98 Design
o | Die Option bietet keine Anonymität im Netzwerk sondern macht das Betriebssystem und Daten sicherer gegen Angriffe von aussen.

Gilt ab Version: .42f +
Aktualisiert: 2004-05-01 by Monk


86

erweiterte Einstellungen
01.03.2004 18:40

max. neue Verbindungen pro 5 Sek.
Hier wird die Anzahl erlaubter neuer Verbindungen alle 5 Sekunden festgelegt. Standard ist 20.

Wichtig:
> | Zu hohe Einstellungen können hier zu Abstürzen des gesamten Betriebssystems, Zusammenbruch der Internetverbindung oder eklatanten Einbrüchen in den Up- und/oder Downloadraten führen. Bevor Ihr hier irgendwelche Phantasiewerte eintragt, solltet Ihr Euch darüber informieren, wie viele Verbindungen Euere Internetanbindung und Euer Betriebssystem verkraften.
> | Wenn Ihr über eine Tx oder LAN-Anbindung verfügt, könnt Ihr diesen Wert langsam weiter erhöhen, bis Ihr die ersten nachteiligen Effekte bemerkt.

eD2k Links nur während der Laufzeit annehmen
Ist eMule beendet, startet er sich automatisch wenn im Browser ein eD2k Link aufgerufen wird. Diese Option bewirkt, dass ein beendeter eMule diese Links ignoriert. In diesem Fall werden keine permanenten Einträge der Registry hinzugefügt.

Kredit System benutzen (Uploader belohnen)
Siehe Kreditsystem für mehr Informationen über Kredits. Es wird dringend empfohlen dieses System zu benutzen, da es hilft sogenannte Leecher, also Leute die nur nehmen und nichts geben, abzuschrecken.

Gründe dieser Option:
> | Wird eine Datei neu ins Netzwerk gestellt - man spricht von einem Release - kann es vorkommen, dass andere Dateien durch Kredits höher bewertet werden als die eigentliche Neuveröffentlichung.
> | Ein gemischtes Netzwerk ist weniger anfällig für Ausbeutung eines bestimmten Systems
> | Seltene und populäre Dateien halt sich besser die Waage

Server- und Client LAN-IPs filtern
Dieser Filter verhindert dass Quellen die aus den LAN IP Bereichen der Klassen A (10.0.0.0 bis 10.255.255.255), B (172.16.0.0 bis 172.31.255.255), C (192.168.0.0 - 192.168.255.255), dem local host (127.0.0.1 bis 127.255.255.255) und alle IP Adressen die mit einer Null beginnen (0.x.x.x) aufgenommen werden. Dies sind private IP Adressbereiche und sind im Internet nicht gültig. Er gilt sowohl für Quellen die über den Quellentausch empfangen wurden als auch für solche von Servern.

Wichtig:
Soll eMule in einer Netzwerkumgebung betrieben werden, ist diese Option zu deaktivieren oder es können keine Quellen innerhalb des lokalen Netzwerks (LAN) gefunden werden.

Zusätzlich Kontrollen anzeigen (für Fortgeschrittene)
Diese Option blendet weitere Optionen / Funktionen ein, die normalerweise für den Betrieb von eMule nicht notwendig sind.

o Zeige Meta-Daten
Auf diese Funktion kann per Rechtsklick auf einen Download im Transfer Fenster zugegriffen werden. Meta-Daten sind zusätzliche Informationen die zu einem Download angegeben wurden, z.B. der mp3 ID Tag oder Autor, Jahr etc.

o Quellen-Kontrolle (A4AF)
eMule belegt bei einem anderen Teilnehmer immer nur einen Warteschlangenplatz für einen Download. Es ist nicht möglich für mehrere Dateien gleichzeitig bei einem anderen eMule anzustehen. Besitzt der andere Teilnehmer jedoch mehr Downloads die angefordert werden könnten, erscheint bei diesen der Hinweis Andere Datei angefragt.
Die manuelle Quellen-Kontrolle erlaubt es zu bestimmen welche Datei in der Warteschlange angefordert werden soll. Hierfür stehen, ebenfalls per Rechtsklick auf einen Download, drei Funktionen zur Verfügung:

alle Quellen zu dieser Datei
Verschiebt einmalig alle bekannten Quellen zu diesem Download. Bei diesem Download wandeln sich dann alle Quellen mit der Angabe Andere Datei angefragt in Quellen mit einer QR Angabe um. Natürlich erscheint dann dieser Vermerk bei den Downloads von denen die Quellen abgezogen wurden.

alle Quellen zu einer anderen Datei
Wird ein Downloads als im Moment nicht so wichtig erachtet können auch alle seine doppelt belegten Quellen abgezogen und den passenden anderen Downloads übertragen werden.

automatisches Zuweisen von Quellen zu dieser Datei
Ähnlich der Funktion alle Quellen zu dieser Datei, sorgt diese dafür dass jede möglich Quelle immer diesem Download zugeordnet wird.

o Anzeige von Andere Datei angefordert Quellen als +xx bei jedem Download
Zeigt zusätzlich bei den Angaben über Quellen für jeden Download die Zahl der Quellen mit dem Status Andere Datei angefordert.

Prüfe Festplattenplatz (min. freier Festplattenplatz [MB])
Die grösse der temporären Downloads wächst bei eMule, je nach Bedarf, dynamisch an. Ist die Option Prüfe Festplattenplatz aktiviert ohne das ein minimaler freier Festplattenplatz angegeben ist, stellt eMule sicher, dass genügend Platz für den gesamten Download vorhanden ist. Kann ein Download nicht komplett heruntergeladen werden wird dieser auf Pause gesetzt.
Wird eine minimaler freier Festplattenplatz angegeben, sorgt eMule lediglich dafür dass diese Menge frei bleibt und lädt von jedem Download bis diese Grenze erreicht ist.
Wird Platz auf der Festplatte frei, erkennt eMule dies und setzt pausierte Downloads gegebenenfalls wieder fort.

Hostname für eigene eD2k Links
eMule erlaubt es bei den freigegebenen Dateien einen eD2k Link mit der momentanen IP als Quelle zu generieren. Wird in dem Feld ein Hostname angegeben ist es auch möglich den Link mit diesem Namen auszugeben. Dies hat den Vorteil, dass bei einem Wechsel der IP die Quellenangabe im Link immer noch gültig ist.
Weitere Informationen zum Thema dynamische Hostnamen sind im Kapitel Webinterface zu finden.

Log-Ausgaben Speichern
Die Ausgaben der Log und Debug Fenster können jeweils als Datei eMule.log bzw. eMule_debug.log im eMule Verzeichnis abgespeichert werden. Diese Option sollte nur gewählt werden wenn die Daten anschliessend analysiert werden sollen.

Verbose (zusätzliche Programmausgaben)
Der Verbose Modus dient den Programmieren als Hilfe beim Aufspüren von möglichen Fehlern in eMule. Wird er aktiviert erscheint auf der Server-Seite ein zusätzliches Fenster, welches interne Informationen anzeigt. In diesem Modus verbraucht eMule mehr Rechenleistung und Hauptspeicher. Diese Option sollte im normalen Betrieb deaktiviert sein. Zu den angezeigten Informationen wird keine weitere Hilfestellung gegeben, da diese nur zur Entwicklung dienen.

sicheres Speichern von .met / .dat Dateien
Für moderne Betriebssysteme auf NTFS Basis ist es allgemein nicht notwendig diese Einstellung zu verändern. Treten wiederholt Probleme beim Beenden von eMule oder nach Crashes auf kann die Sicherheit beim Schreiben der .met und .dat Dateien mit dieser Option erhöht werden.
Abhängig von der Leistung des jeweiligen Computers kann diese Option allerdings zur Zunahme der Festplattenaktivität führen oder das Beenden von eMule verlangsamen. Wenn keine Probleme dieser Art auftreten, sollte die Grundeinstellung (Nie) beibehalten werden.

o beim Beenden
Das sichere Schreiben dieser Dateien wird nur beim Beenden von eMule angewendet.

o immer
Der erhöhte Aufwand wird bei jedem Schreibzugriff auf diese Dateien getrieben.

Serververbindung Auffrischintervall
Wird eMule hinter einem Router oder in einer komplexeren Netzwerkumgebung betrieben kann es vorkommen, dass er in regelmässigen Abständen die Serververbindung verliert und neu verbindet.
Router verwenden NAT - Network Address Translation um Verbindungen zwischen sich selbst und den anderen Rechner dahinter zu verwalten. Für diese Verbindungen haben die Router einen TimeOut, d.h. ist eine bestimmte Zeit abgelaufen in der eine Verbindung nicht benutzt wird, wird diese vom Router für tot gehalten und beendet. eMule überprüft die Verbindung zum Server in regelmässigen Intervallen. Ist dieses Intervall nun grösser als der TimeOut des Routers hat dieser die Verbindung beendet und eMule muss sich neu zu dem Server verbinden.
Sollte dieses Problem bestehen muss im Feld für das Serververbindung Auffrischintervall ein etwas geringerer Wert eingetragen werden als in den Router Einstellungen angegeben. Der Wert 0 ist Standard und eMule verwaltet die Server Kontakte.
Diese Einstellung sollte nur verändert werden wenn ein Router oder andere NAT Verbindungen benutzt werden. Ein zu geringer Wert kann zu dauerhaften Server-Banns führen!

Upload Speed Sense (USS)
USS überwacht die Ping Antwortzeiten der Internetverbindung und regelt das Upload Limit von eMule nach diesen. Damit versucht eMule immer eine optimale Upload Leistung zu bringen ohne die Pings zu verschlechtern was beim Surfen oder Online spielen stören kann. Bei den folgenden Einstellungen ist empfohlen die Standardwerte beizubehalten.

o Automatisch beste Upload Geschwindigkeit ermitteln
Aktiviert die USS Upload Kontrolle

o Upload Minimum
Dies ist die Minimalgeschwindigkeit die eMule einhalten muss. Es ist empfohlen diesen Wert auf ungefähr die Hälfte des maximalen Uploads zu stellen.

o Ping Toleranz (% des niedrigsten Pings)
Beim Start von USS werden die Pingzeiten der Internetverbindung ausgemessen. USS sorgt dann dafür, dass der Ping nicht über diesen Anfangswert multipliziert mit der Toleranz ansteigt. Bei einem Anfangsping von 50 ms und einer Toleranz von 800% würde USS also dafür sorgen, dass der Ping nicht über 400 ms steigt.

o Anstiegs- und Verringerungsgeschwindigkeiten
Diese zwei Werte bestimmen wie schnell das Upload Limit an Hand der gemessenen Pingzeiten nach oben oder unten angepasst wird. Flasche Werte können einen totalen Upload / Download Zusammenbruch erzeugen. Standardwerte lassen!

o Max Anzahl von Pings
Bestimmt wieviel Ping Antwortzeiten benutzt werden um den gültigen Durchschnitt zu bilden.

Dateipuffer Grösse
Sollte der Computer während des Betriebs von eMule zu "stottern" anfangen, d.h. regelmäßig kurz hängen zu bleiben, kann dies an der Art wie eMule Daten auf die Festplatte schreibt liegen. In diesem Fall kann ein kleinerer Dateipuffer das Problem beheben, dies führt aber zu einer erhöhten Festplattenaktivität durch eMule. Vorsicht, zu niedrige Werte haben negative Auswirkungen auf die Leistung von eMule!
Höhere Werte führen zu einer Reduzierung der Festplattenzugriffe bergen aber die Gefahr eines erhöhten Datenverlustes sollte es zu Problemen kommen.

Warteschlangengrösse
Mit dieser Einstellung kann die Grösse der Warteschlange beeinflusst werden. Damit das Kredit System von eMule effektive funktionieren kann, ist eine grosse Warteliste entscheidend. Ist die Warteschlange eines eMules voll, werden einem anderen Client auch sehr viele Kredits nichts nützen, da er diese nicht ausgegeben kann. Je grösser die Warteliste also ist, desto besser und gerechter kann das Kredit System arbeiten.

Wichtig:
Die Grösse der Warteschlange hat keinen Einfluss auf den Verwaltungsaufwand dieser. Mehr Benutzer in der Warteliste bedeutet nicht, dass dadurch ein Mehr an Verbindungen oder Verbindungs-Overhead entsteht. Eine grössere Warteschlange verbraucht etwas mehr Hauptspeicher.

Gilt ab Version: .42a +
Aktualisiert: 2004-02-27 by Monk


92

Preferences.ini
01.05.2004 20:27
Die wichtigen Einstellungen in eMule lassen sich im Programm selbst unter Einstellungen vornehmen. Diese werden in der Datei Preferences.ini abgespeichert. Einige Einstellungen lassen sich nur in dieser Datei selbst vornehmen, da sie unter der graphischen Oberfläche nicht zugänglich sind. Vorsicht, falsche Einstellungen in dieser Datei können unerwünschte Folgen haben und nur fortgeschrittene Benutzer sollten Änderungen hier vornehmen. eMule muss vor Bearbeiten der preferences.ini geschlossen werden.
o | TxtEditor=notepad.exe
Werden die Bearbeiten Schaltflächen für die Webdienste oder die IpFilter.dat verwendet öffnet eMule diese automatisch mit notepad. Soll ein anderes Programm zum Bearbeiten dieser Dateien verwendet werden, muss der vollständige Pfad zu diesem Programm angegeben werden.
o | DateTimeFormat=%A, %x, %X
Dieser Eintrag bestimmt das Format in dem eMule Datums und Zeitangaben darstellt. Dieser msn Artikel beschreibt alle gültigen Formatcodes.
o | MaxLogBuff=64 / 128 (v0.30a+)
Definiert die maximale Grösse des Speichers, den eMule für die log-Nachrichten (Log und Verbose Fenster) reserviert. Standard sind 64kB für Win98 / ME und 128kB für Win2k /XP. Der maximale Log Buffer für Win9x ist 64 kB
Der ini-Eintrag MaxLogMessages (v0.29) wurde durch diesen Eintag ersetzt.
o | MaxChatHistoryLines=100
Bestimmt die Anzahl der gespeicherten Zeilen eines IRC Chats. Ist der Wert erreicht wird bei einem neuen Eintrag der Älteste gelöscht.
o | ExtractMetaData=2 (v0.30a+)
Definiert ob und für welche Dateien Meta-Daten ausgelesen werden
0: deaktiviert
1: aktiviert für MP3 und AVI -Dateien
2: Standard, aktiviert für MP3, AVI, MPEG und weitere Dateien
o | ServerUDPPort=65535

Bestimmt den lokalen Port für die Quellen- und Dateisuche auf Servern. Normalerweise wird auch aus Sicherheitsgründen ein zufälliger Port gewählt, es kann aber bei komplizierteren Netzwerken (vorallem Proxy-Servern) notwendig sein diesen Port festzulegen oder gänzlich zu deaktivieren. Wird dieser Port deaktiviert kann eMule den Status der Server in der Serverliste nicht mehr aktualisieren und auch auf diesen keine Quellen mehr finden oder nach Dateien suchen (Globale Suche). Davon ausgenommen ist der Server zu dem der Client verbunden ist. Weitere Informationen im Kapitel Ports.
Mögliche Werte für den ServerUDPPort sind:

0 | Deaktiviert
1 - 65534 | festgelegter lokaler UDP Port
65535 | zufälliger Port (Standard)
o | PreviewSmallBlocks=0
Diese Funktion sollte nur zusammen mit VLC - VideoLAN Client aktiviert (=1) werden und erlaubt eine Vorschau wenn wenigstens 16kB von einer .mpeg Datei bzw. 256kB von anderen vorschaufähigen Dateien (.avi, CD-ROM Images mit Multimedia Inhalt). Siehe Einstellungen -> Dateien -> Videowiedergabeprogramm. In diesem Dialog muss auch die Option Erstelle Kopie für die Vorschau deaktiviert werden.
o | RestoreLastMainWndDlg=0/1
Wird RestoreLastMainWndDlg=1 der preferences.ini hinzugefügt, merkt sich eMule beim Beenden, welches der Hauptfenster (Kademlia, Server, Transfer, etc) als letztes dargestellt wurde und stellt es beim Start wieder her.
o | RestoreLastLogPane=0/1
Ähnlich der RestoreLastMainWndDlg Einstellung, nur wird das letzte Log-Fenster (Log, Verbose) gespeichert.
o | RemoveFilesToBin=1/0
Diese Einstellung beinflusst das Verhalten der Löschen Funktion im Kontextmenü des Hauptfensters Dateien. Wird diese deaktiviert (=0) werden so gelöschte Dateien nicht in den Papierkorb verschoben sondern sofort gänzlich gelöscht.


66

Allgemein
20.07.2003 10:57

Alle Ports, die hier aufgeführt werden, müssen in den Regeln (rules) der einzelnen Firewalls geöffnet werden. Da die meisten Firewalls für Windows programmbezogen arbeiten, könnt Ihr Euch viel Arbeit ersparen, indem Ihr Eurer Firewall eine Regel hinzufügt, die der emule.exe jeglichen UDP und TCP-Verkehr über alle Ports und in jede Richtung erlaubt. Dies schlägt sich nicht auf Eure Sicherheit nieder, da bei eMule bisher keine Sicherheitslücken bekannt sind.

Notes:
- ZoneAlarm ist bekannt dafür, beim Einsatz mit eMule für Probleme zu sorgen. Daher wird Zone Alarm nicht empfohlen. Gute und für den privaten Gebrauch kostenlose Firewalls sind Kerio Personal Firewall und Agnitum Outpost

- Ich werde weitere Konfigurationseinstellungen zu anderen Firewalls bereitstellen, wenn es die Zeit zulässt. Ihr könnt auch gerne selbst eine Anleitung erstellen (wenn Ihr wollt auch gerne mit Screenshots). Sendet sie an Monk@emule-project.net und sie werden hier veröffentlicht.


65

Win XP integrierte Firewall
20.07.2003 10:58

Generell sollte die in Windows XP integrierte Firewall nicht benutzt werden, da es sich nur um eine sehr einfache Firewall mit beschränkten Funktionen handelt. Wenn Ihr sie dennoch benutzen wollt oder müßt, seht Ihr hier, wie sie für eMule zu konfigurieren ist:

1. | Öffne eMule
2. | Wähle "Einstellungen > Verbindung"
3. | Notiert Euch den Client-Port (Standard 4662)
4. | Notiert Euch den UDP-Port (Standard 4672)
5. | Beendet eMule und trennt Eure Internetverbindung
6. | Öffnet das Startmenü und klickt auf Netzwerk
7. | Klickt auf Netzwerkverbindungen
8. | Klickt mit der rechten Maustaste auf Eure Internetverbindung, dann auf Eigenschaften
9. | Klickt auf Erweitert, dann auf Einstellungen. Wenn "Einstellungen" nicht angewählt werden kann, dann ist die Firewall bereits deaktiviert und Ihr braucht nichts zu ändern (alle Ports sind bereits offen).
10. | Klickt "Hinzufügen", um einen neuen Port einzutragen.
11. | Gebt eine Beschreibung ein, z.B. "eMule : TCP Incoming".
12. | Gebt 127.0.0.1 bei "Name oder IP-Adresse" ein.
13. | Gebt den Client-Port aus Schritt 3. bei "Externe und Interne Portnummer für diesen Dienst" ein.
14. | Wählt TCP und klickt anschließend auf "OK".
15. | Klickt wieder auf "Hinzufügen", um einen weiteren Port einzutragen.
16. | Diesmal gebt Ihr als Beschreibung z.B. "eMule : UDP Incoming" ein
17. | siehe 12.
18. | Gebt den Client-Port aus Schritt 4. bei "Externe und Interne Portnummer für diesen Dienst" ein.
19. | Wählt UDP und klickt anschließend auf "OK".
Wenn Ihr in eMule die Ports wieder ändert, müßt Ihr sie in der Firewall entsprechend anpassen. Weitere Informationen findet Ihr in der Microsoft Knowledge Base (Englisch): Q308127 How to Manually Open Ports in Internet Connection Firewall in Windows XP Q283673 How to Enable or Disable the Personal Firewall Feature in Windows XP Q307554 Programs Require Manual Port Configurations with Internet Connection Firewall Diese Beschreibung stammt von -nRoK-. Danke.


235

Norton Personal Firewall 2002/2003/2004
28.03.2004 7:19

Damit eMule in Verbindung mit der Norton Personal Firewall funktioniert ist eine richtige Konfiguration nötig. Dies sollte vor der ersten Benutzung mit eMule getan werden, da sonst noch alte eMule-Firewall-Regeln existieren, die evtl. Probleme machen und vorher gelöscht werden sollten.

ACHTUNG: Nach jedem Update der eMule.exe auf eine neue Version muss die Firewall erneut konfiguriert werden !

Schritt1: Öffne die Firewall, gehe dort auf "Persönliche Firewall" und wähle "Konfigurieren"

Schritt2: Daraufhin erscheint ein neues Fenster wo ihr in die Programmsteuerung geht und dort auf "hinzufügen" klickt.

Schritt3: Dann wählt ihr die entsprechende eMule.exe aus (z.B. aus C:\Programme\eMule\emule.exe ).
Jetzt öffnet sich ein Konfigurations-Fenster, in dem man zwischen 3 Optionen wählen kann, "Zulassen", "Blockieren"
und "Den Internetzugriff manuell konfigurieren". Um die Firewall korrekt zu konfigurieren wählt man hier die letztere Option.

Schritt4: Nun wird eine neue Regel angelegt, die dann greift,sobald die eMule.exe auf das Internet zugreifen will.
Hier wählt man einfach "Internetzugriff zulassen" und weiter geht's.

Schritt5: Im folgenden Fenster wählt man dann den Verbindungstyp "Verbindungen von und zu anderen Computern" aus.

Schritt6: Bei "Welche Computer oder Sites möchten Sie zulassen" die Einstellung auf "Alle Computer" stellen.
Standardmäßig ist dies schon ausgewählt.

Schritt7: Nun kommt man zu den Protokollen und den Anschlüssen. Für eine Hohe ID und optimale Leistung muss
hier "TCP und UDP" sowie "Alle Kommunikationstypen" ausgewählt sein!

Das wars dann schon, nur noch weiter klicken, die restlichen Optionen nach den eigenen Bedürfnissen einstellen
und der Regel einen Namen geben (z.B. Emule),damit man bei der Konfiguration anderer Programme nicht die eMule-Regel überschrieben wird.

Instruction by Resterampe


236

ZoneAlarm
01.03.2004 18:19

Damit eMule in Verbindung mit der ZoneAlarm-Firewall richtig funktioniert und eine High-ID zustande kommt, konfiguriere die Firewall nach folgender Anleitung

Schritt 1: Öffne die Firewall, gehe dort auf "Programmeinstellungen"

Schritt 2: Daraufhin erscheint ein neues Fenster wo du dort auf "Programmassistent" klickst.

Schritt 3: Im darauffolgenden Fenster klickst du "Erweitert.Ich will jetzt die Zugriffs-
und Serverrechte festlegen".

Schritt 4: Im neuen Fenster klickst Du erst auf "hinzufügen" und dann wählst du die entsprechende eMule.exe aus
(z.B. aus C:\Programme\eMule\emule.exe ).

Schritt 5: Nun wird die eMule.exe hinzugefügt und man hat nun die Möglichkeit den Zugriff von eMule zu steuern.
Damit eingehende wie auch abgehende Verbindungen erlaubt werden,setzt man jeweils einen Haken bei
"Zugriff" und "Server".

Danach klickt man nur noch "Fertig" und schon ist die Firewall für eMule konfiguriert.

Instruction by Resterampe


67

Allgemein
20.07.2003 11:01

Ist ein Router nicht für die Verwendung mit eMule konfiguriert, resultiert daraus automatisch eine niedrige ID. Ein Router "versteckt" (maskiert) die IP Adressen der an ihn angeschlossenen Computer. Versucht ein anderer Client eine Verbindung mit diesem maskierten Computer aufzunhemen, sieht er nur die IP Adresse des Routers, nicht aber die des Computers zu der er eigentlich verbinden möchte.
Um dennoch diese Verbindung herstellen zu können müssen der Client Port 4662 TCP, der Webserver Port 4711 und der UDP Port 4672 (dies sind die Standardeinstellung aus Einstellungen -> Verbindung) im Router zu der IP Adresse, auf der eMule läuft, weitergeleitet werden.
Im Handbuch des Routers steht dies normalerweise, unter den Stichworten DMZ – Demilitarized Zone, Filter, Regeln, Firewall oder Weiterleitung, beschrieben.
Da die meisten Router auch über eine Firewall Funktion verfügen, muss auch in dieser der Datenverkehr freigegeben werden. Nähere Angaben finden sich den den Kapiteln Firewall und Router.

Anmerkung:
Wird ein Rechner hinter einem Router betrieben empfiehlt es sich immer im Router die Option DHCP - Dynamic Host Configuration Protocol (automatisches Zuteilen von IP Adressen im Netzwerk) abzuschalten. Den einzelnen Rechnern im Netzwerk sollten feste IP Adressen zugewiesen werden. Die IP Adresse kann in den Netzwerkeinstellungen von Windows unter Eigenschaften von TCP/IP geändert werden. Hierzu den Punkt IP Adresse automatisch beziehen deaktivieren und eine IP in der Form 192.168.xxx.xxx eingeben. Router unterstützen meist unterschiedliche IP Adressbereiche als gültige Heimadressbereiche, dies ist im Handbuch beschrieben. Als letztes muss noch als Standardgateway die IP des Routers eingegeben werden.

Besitz Ihr einen Router und wisst wie dieses Modell für die Benutzung mit eMule konfiguriert wird, schreibt eine kleine Anleitung mit ein paar aussagekräftigen Screenshots (moderate Grösse, jpg) und sendet diese an Monk@emule-project.net. Andere User werden Eure Hilfe zu schätzen wissen.


89

Solwise SAR-7x5 + Allnet ALL129
03.04.2004 17:46

First navigate to your routers web configuration page in your browser. It defaults to http://192.168.7.1

Now click on Advanced Configuration on the left.

Press Security/NAT on the list of options that pops up.

Now on the page that loads, look for Security Interfaces.

Click Advanced NAT Configuration below the ppp-0 connection. A screen will load, look for Reserved Mappings.

In this section press Add Reserved Mapping.

Now comes the tricky part. Follow this screenshot and press Add Reserved Mapping when done.
You need to do this twice, once for port 4662 TCP and once for port 4672 UDP.

Important:
You must enter the IP of the machine eMule is running on. To verify your IP go to Windows Start Menu -> Settings -> Network Connection. Highlight your LAN connection click right mouse button and click Properties. Choose Internet protocol (TCP/IP) and click Properties. The dialogue shows your current IP address

Once you have done this simply save your configuration by pressing System on the left hand side menu , then Save config.

You have successfully configured your SAR7x5 router to use eMule.

This nice guide was done by aldo. Thanks a lot.


90

Lucent CellPipe 20A-GX-E
20.07.2003 11:28
Follow these simple steps to configure your Lucent CellPipe for eMule. This setup assumes you have a PPPOE connection like DSL running.
Start a telnet session with your routers IP. To do so
 | a) Use the Windows Hyper Terminal and type in a Name (does not matter which) for the new session, choose TCP/IP (Winsock) as connection type then enter your router's IP as the host address
 | or
 | b) Go to Start -> Run -> telnet router's IP
In the telent sessions that starts enter these commands each on a single line:
 | pat addpatin pppoe 4662/tcp client's IP pat addpatin pppoe 4672/udp client's IP save
Router's IP is the IP address of your CellPipe router and client's IP is the IP address of your computer running eMule.

Many thanks to Jarek for this how to.


60

SMC Barricade 7004
06.03.2004 12:06

Inhalt

Inhalt | Ein Inhaltsverzeichniss, was sonst?
Vorwort | Etwas, das du evtl. erstmal lesen solltest.
Login | So bekommst du Zugriff auf die Steuerzentrale deines Routers
IP | So findest du deine Netzwerk-IP heraus
Virtual Server | Konfiguration Schritt 1
Special Application | Konfiguration Schritt 2
The End | Schlusswort
FAQ | Frequently asked Questions

Vorwort

Das hier ist Version 2 meiner SMC-Anleitung, in der ich erklären werde, wie du fast jeden SMC-Router für eMule einstellst.
Ich möchte hier allen danken, die mir Hinweise und Tipps geschickt haben, aber ich muss euch leider mitteilen, dass alle eure Mails von vor dem 22.02.2004 wegen eines Festplattencrashs verloren gegangen sind.
Diese Anleitung wurde für meine SMC Barricade 7004ABR (eu) mit der Firmware V1.42.012 geschrieben, aber man kann ihn für viele SMC-Router sowie Kopien derer benutzen:

  • SMC Barricade 7004 ABR
  • Barricade 7004 ABR v2 (das Virtual Server Menü sieht ein wenig anders aus, aber man muss das selbe eintragen wie beim v1) (Thx to Tilube)
  • SMC Barricade 7004 VBR (Thx to Ulf)

Hinweis: Diese Liste war einmal länger, aber ich habe alle Mails von den netten Leuten verloren, die mich darauf hingewiesen haben, dass ihr Router die gleiche oder ähnliche Konfiguration hat. Wenn du einen Router mit der gleichen Konfiguration hast, schicke bitte eine kurze eMail an theurmel@arcor.de, danke. Wenn du Screenshots hinzufügen möchtest, benutze bitte ein verlustfreies Format wie PNG oder GIF.

Login

Auf die Steuerzentrale deines Routers zuzugreifen, ist sehr einfach. Du musst einfach nur seine IP in deinem Browser eingeben, und ENTER drücken.
Die Standart-IP ist 192.168.2.1, also musst du http://192.168.2.1/ in deinen Browser eingeben, oder einfach nur auf den Link klicken.
Du solltest nun etwa das hier sehen:
Login Fenster
Hier musst du das Passwort eingeben, und dann den [image] -Button drücken.

IP

Um deine IP herauszufinden, klicke bitte auf Status. In der Mitte deines Fensters solltest du nun einen kleinen Frame mit dem Namen "Security Log" sehen, der ungefähr so aussieht:
2004/03/06 10:32:38 192.168.2.30 login successful
Wenn du diese Zeile (oder eine ähnliche) nicht gleich siehst, scrolle den frame bis nach ganz unten. Der Eintrag den wir suchen sollte einer der Letzten sein.
In meinem Beispiel habe ich diese Zeile:
2004/03/06 10:32:38 192.168.2.30 login successful
also ist meine IP 192.168.2.30. Merke sie dir oder schreib sie auf, dass es weiter gehen kann.

Virtual Server

Klicke nun auf Setup.
Im linken Teil deines Fensters sollte nun eine Liste von Begriffen aufgetaucht sein. Unter Advanced Settings solltest du einen Punkt namens Virtual Server finden. Klick drauf.
Wenn du eine SMC Barricade 7004 ABR v2 hast, findest du die Punkte unter NAT.
Du solltest nun eine Art Liste vor dir haben, in die du das hier eingibst:
Virtual Server
Wie in meinem Beispiel benutze ich meine IP 192.168.2.30. Wenn deine IP eine andere ist (und das ist sehr warscheinlich), musst du ihren letzten Teil (in meinem Fall 30) in das Private IP Feld eingeben.
Ausserdem benutze ich den standart Client-Port 4662 und UDP-Port 4672. Wenn du andere Ports eingestellt hast, schau bitte in deiner eMule-Konfiguration nach.
Wenn du den Webserver nicht benutzen willst, muss du die Zeile mit dem Port 4711 nicht eingeben. Wenn du ihn benutzt, überprüfe in der Webserver-Konfiguration ob der Port auch korrekt ist.

Klicke nun auf den Enter -Button um ins Special Application Menu zu kommen.

Special Application

Hier musst du das eingeben:
Special Application
Ich benutze auch hier den standart Client-Port 4662 und UDP-Port 4672. Wenn du andere Ports eingestellt hast, schau bitte in deiner eMule-Konfiguration nach.
Wenn du den Webserver nicht benutzen willst, muss du die Zeile mit dem Port 4711 nicht eingeben. Wenn du ihn benutzt, überprüfe in der Webserver-Konfiguration ob der Port auch korrekt ist.

Jetzt nurnoch ein Klick auf den Enter -Button und dann auf Logout -Button.

The End

So, das wars. Du solltest jetzt von jedem Server eine HighID bekommen und in Kademlia den Status Offen haben.
Wenn du immernoch eine Frage hast, die nicht in der FAQ beantwortet wird, kannst du mir eine Mail an theurmel@arcor.de schreiben.
Ich kann jedoch nicht garantiern, dass ich sie auch beantworten werde, aber ich versuche es. Und schickt mir bitte keine Mails in andren Sprachen als Deutsch oder Englisch (Wenn es wirklich sein muss, geht auch Französisch, aber ich bin ziehmlich schlecht darin, also werde ich in Englisch antworten).

FAQ

"Ich hab alles so eingestellt und bekomme immernoch eine LowID. Was kann ich tun?"
Bitte überprüfe ob der Clientport auch der in der eMule-Configuration angegebene ist und dass du die richtigen Ports im Virtual Server und im Special Application Menü eingegeben hast.
Wenn das alles stimmt, versuche "Sicheres / langsameres Verbinden zu Servern" in der Server Configuration deines eMules anzumachen.
Und vergiss nicht, dass du jedes mal, wenn du überprüfen willst, ob du noch eine LowID bekommst, zu einem Server reconnecten musst.

"Ich benutze zwei eMules in meinem Netzwerk, aber obwohl ich den Router anhand der Anleitung richtig eingstellt habe, bekommt einer der eMules immer eine LowID."
Als allererstes, rate ich dir, nur einen eMule im Netzwerk zu nutzen, da es weniger Ärger für dich und weniger Overhead für die Server bedeutet. Zusätzlich wird, wenn du einen Upstream unter 20kb/sec hast, die Ratio aktiviert, die dann deinen Maximalen Download reduziert. Ich empfehle daher lieber das Webinterface anstatt des zweiten eMules zu benutzen.
Wenn du trotzdem zwei eMules benutzen willst, musst du ihnen verschiedene Ports zuweisen (zB. eMule1: Clientport 4662, UDPport 4672 - eMule2: Clientport 3662, UDPport 3672), und diese dann im Virtual Server Menü zum richtigen Computer weiterleiten und sie dann noch im Special Application Menü eintragen.


91

Linksys BEFSX41
03.05.2004 15:56

This guide assumes you have a Linksys BEFSR41 router. It will be fairly similar if you have another Linksys router like the 'wireless' or 'firewall' (BEFSX41) version but I'm not sure because I don't have these.

I'm running Windows XP Pro, but these instructions work fine with XP Home too. Windows98 users will want to look at the alternate instructions. The first two alternatives describe how to configure the router without using DHCP. Using DHCP sometimes makes things messy but Linksys offers a way to keep DHCP via Port Triggering

The aim of the guide is to show you how to setup your Linksys router so that you can use eMule. There are two ways to do this, either as below using UPnP, or by using a browser. These instructions are long and drawn out on purpose, hopefully so you don't get stuck! Realistically the whole thing is really very easy once you get the hang of it, so please don't be too intimidated by how long these instructions are.

Security Concerns with UPnP

There are some serious security issues with Universal Plug and Play. You should read about them here.
Thanks to Monk for letting me know about this.

To check your security you might want to try some of the tests at http://www.pcflank.com/ or this test at http://www.dslreports.com/scan/

If after reading / testing you decide to go ahead and disable UPnP then you'll need to follow my

alternate instructions for setting up port forwarding without UPnP.

Or, if you decide that you are perfectly secure then continue below.

Windows XP UPnP instructions

  1. The first step is to make sure you have a fairly recent firmware version for your router. Firmware is like the internal software inside the router. You can upgrade to the latest version by visiting the Linksys download page. Select your router from the drop down list, select the firmware link, save the file and follow the instructions. They make it fairly easy and straightforward to do, and it is quick.

  2. Once you've done the previous step... In Windows, click start>settings>control panel>network connections to open this page:

    Compare what you see to my picture, if you have the entry that says Internet Gateway enabled, you already have UPnP installed and this whole process will be easier. Windows XP should have already set all this up if you bought your router and it already had firmware version 1.42 (?) or later installed. If you do anyway then skip ahead to step number 4 below.

  3. To install UPnP:

    1. Click Start, click Control Panel, and then click Add or Remove Programs.

    2. In the Add or Remove Programs dialog box, click Add/Remove Windows Components.

    3. In the Windows Components Wizard, click Networking Services, click Details, and then select the 'Universal Plug and Play' check box. You should also see 'Internet Gateway Device Discovery and Control Client' listed, put a tick in the check box for this also - as I've done below.

    4. Click OK, and then click Next in the Windows Components Wizard. You may need to provide your Windows XP installation CD.

      ( I found this info at http://www.microsoft.com/windowsxp/expertzone/columns/crawford/02july22.asp)

    5. Using your browser, go to http://192.168.1.1/Passwd.htm and, as shown in the picture below, make sure that 'UPnP Services' are enabled:

    6. Click Start>Settings>Network Connections. Right click on 'Local Area Connection'. Select 'Properties'. A small window appears. At the top click on 'Advanced'. Make sure that the XP firewall is turned off as in the picture below:

    7. Now check back to step 2 above to make sure you have the UPnP working right. It seems to take a while for the internet gateway entry to appear so be patient, wait a couple of minutes perhaps and check again if it isn't showing when you first look, refreshing the window often makes it miraculously appear.

  4. Now that you have UPnP up and running setting up port forwarding is really quite simple...

    The first thing to do is to highlight the entry for the local area connection in the network connections page just like i'm doing in the picture below:

    On the left side in the details section you should now see your router assigned ip address as shown in the picture below:

    ...in this example it is 192.168.1.100, make a mental note of whatever yours happens to be.
  5. Back on the main section of the page, right click on 'Internet Connection' and then select 'Properties' from the menu that appears.

    You'll see this window:

    Click on settings, and then 'Add'. This is where you will specify which ports the router needs to forward to make eMule work. Fill in the blanks as below, except in the IP address field substitute your own router assigned IP address that you memorized from the previous step. The 'Description of Service' text field can be anything you like - it's just so you can identify it later... "eMule" works just fine:

  6. After clicking on 'OK' to save this new setting, click 'Add' once again to setup a second port forward. Once again fill in your own IP address, type "eMule" as the description of service, and copy the remaining details as they are shown below. Then click 'Ok' to save the settings:

  7. You'll notice that you now have two entries for eMule, as in the picture below:

    Click 'Ok' to save the settings you made and exit. That's pretty much all there is to it! You've told your router to forward incoming traffic to ports 4662 and 4672 on your computer. Run emule and everything should now work.

Windows98 / Alternate instructions / not using UPnP

There's another way of doing all this.
  1. Open up your web browser and type in the address: http://192.168.1.1 to access your router status pages. Enter your password, the username is an empty field on my machine and it doesn't seem to matter... you HAVE changed the default password right? If not then for your own sake read your linksys manual and do this now!

  2. Click on the DHCP tab at the top

    Then click on the button labelled 'DHCP Clients Table'. You'll see the window below appear:

    Look in the Client Hostname column, find your computer name and memorize the last three numbers of the IP address to the right of it. In this example the client hostname is 'Christopher', and the last three numbers of the IP address are 100. Once you've got those three numbers memorized then close the window.

  3. At the top of the screen, on the right hand side, click on the orange colored tab labelled 'Advanced'. You'll arrive on the 'filters' page - you don't want to do anything here, instead click on the second tab along labelled 'Forwarding'... and fill out the details as I have below. Except of course you need to fill out the last three numbers of your IP address that you memorized (it might well be 100 like mine is):

  4. At the bottom click on 'Apply' to save the settings you just typed in. Now your router is setup to forward incoming traffic to ports 4662, and 4672 on your computer. Close out the browser window, and run eMule, it should now work!

Configuration with DHCP via Port Triggering

  1. Open up your internet browser and type the IP Address of your router (default: 192.168.1.1). Enter in your password (default: admin - change it!). Click 'Advanced'. Click 'Forwarding'.
  2. In the Forwarding screen you will find the button Port Triggering. Click it and enter the configuration shown below. You can ignore the msn entry when configuring eMule.

  3. Press 'Apply'.This should now allow your router to forward eMule packets to your machine without the need for specific IP Addresses allowing for DHCP or multiple machines using eMule.

Big kudos to Violator for this very comprehensive guide. Thanks to ThRaShErUk for the Port Triggering how to.


27

Ports
02.05.2004 16:32

Hier findet Ihr jeder Ports, die eMule standardmäßig zum korrekten Betrieb benötigt. Solltet Ihr einen dieser Ports unter Einstellungen - Verbindung ändern, müßt Ihr dies bei der Konfiguration Eures Routers oder Eurer Firewall berücksichtigen:

1) | Local Port: | 4662
 | Remote Port: | jeder
 | Protokoll: | TCP
 | Richtung: | eingehend
 | Funktion: | Client Port / Verbindung von anderen Clients, Quellentausch zwischen Clients
 | Anmerkung: | Dieser Port kann in Einstellungen -> Verbindungen -> Client Port geändert werden. Dieser Port muss von einem Router weitergeleitet werden, oder Euer Client erhält eine niedrige IP. Wird er in den Einstellungen geändert muss dies auch im Router angepasst werden.
2) | Local Port: | jeder
 | Remote Port: | 4662
 | Protokoll: | TCP
 | Richtung: | ausgehend
 | Funktion: | Client Port / Verbindung zu anderen Clients, Quellentausch zwischen Clients
 | Anmerkung: | 4662 ist der Standard für diesen Port. Da andere Clients diesen Port umgestellt haben könnten, gilt für die Konfiguration einer Firewall bei Remote Port nicht mehr 4662 sondern jeder.
3) | Local Port: | 4672
 | Remote Port: | jeder
 | Protokoll: | UDP
 | Richtung: | eingehend
 | Funktion: | Quellentausch zwischen Clients / erweitertes eMule Protokoll, Queue Rating, File Reask Ping
 | Anmerkung: | Dieser Port kann in Einstellungen -> Verbindungen -> UDP Port geändert werden. Dieser Port muss von einem Router weitergeleitet werden. Ist eine Weiterleitung nicht möglich muss der Port in Einstellungen -> Verbindungen -> UDP Port deaktiviert werden. Wird er in den Einstellungen geändert muss dies auch im Router angepasst werden.
4) | Local Port: | jeder
 | Remote Port: | 4672
 | Protokoll: | UDP
 | Richtung: | ausgehend
 | Funktion: | Quellentausch zwischen Clients / erweitertes eMule Protokoll, Queue Rating, File Reask Ping
 | Anmerkung: | 4672 ist normalerweise eingestellt. Da dieser Port wie in #3 beschrieben geändert werden kann gilt für die Konfiguration einer Firewall für den Remote Port: jeder.
5) | Local Port: | jeder
 | Remote Port: | 4661
 | Protokoll: | TCP
 | Richtung: | ausgehend
 | Funktion: | Verbindung zum Server
 | Anmerkung: | 4661 ist der Standard Port für einen Server. Der Betreiber des Servers kann diesen Port ändern, was auch häufig geschieht. Für eine Firewall ist auch hier jeder Remote Port zu öffnen.
6) | Local Port: | jeder
 | Remote Port: | 4665
 | Protokoll: | UDP
 | Richtung: | ausgehend
 | Funktion: | Quellensuche auf Servern
 | Anmerkung: | Server die den Standard Port aus #5 benutzen, setzen den UDP Port für die Quellensuche automatisch auf 4665. Wird der Port in #5 vom Betreiber des Servers geändert, gilt für den UDP Port [(Port aus #5) + 4]. Für eine Firewall ist auch hier jeder Remote Port zu öffnen.
7) | Local Port: | 4711
 | Remote Port: | jeder
 | Protokoll: | TCP
 | Richtung: | eingehend
 | Funktion: | Verbindungsport des Webservers
 | Anmerkung: | Der interene Webserver, der die Webkontrolle zur Verfügung stellt wird auf diesem Port angesprochen. Dieser Port muss bei den Weiterleitungsregeln eines Routers angegeben werden oder der Webserver ist von aussen nicht erreichbar.


93

Serverliste aktualisieren
01.05.2004 20:21

eMule nutzt wie auch eDonkey die sogenannten Server, um Zugang zum eDonkey-Netzwerk zu bekommen. Man kann sie als Vermittlungsstellen bezeichnen, die Euren eigenen Client am Netz teilhaben lassen und Eure freigegebenen Dateien für andere zur Verfügung stellen.

Im Grunde genommen sind Server also nichts anderes als eine Art Index für alle Dateien, die die zu ihnen verbundenen Nutzer tauschen. Die Suche nach Dateien oder ihren Quellen wird ebenfalls von den Servern erledigt. Es befinden sich keine Dateien auf den Servern!

Ein Serverlisten-Update wird eigentlich nur für den ersten Zugang zum eDonkey-Netzwerk benötigt. Sobald eMule mit einem Server verbunden ist, bietet es eigene, intelligente Funktionen, um die Server zu entlasten - z.B. den Quellenaustausch mit anderen Clients oder das automatische Aktualisieren der vorhanden oder neu hinzugekommen Server.

Es gibt verschiedene Möglichkeiten, die Serverliste auf dem neuesten Stand zu halten:

Hilfreiche Einstellungen unter "Einstellungen | Server"
o Lösche tote Server nach X Versuchen
eMule löscht tote, nicht erreichbare Server automatisch. Wann ein Server für eMule als nicht mehr erreichbar gilt, könnt Ihr durch eine beliebige Zahl X einstellen. Setzt Ihr eine 3 ein, wird eMule diesen Server nach 4 erfolglosen Verbindungsversuch löschen.

o Filtere ungültige IPs
Als ungültige IPs werden in diesem Zusammenhang IPs wie der localhost 127.x.x.x oder der Heim-IP-Bereich 192.168.x.x betrachtet, da unter diesen IPs kein funktionierender Server laufen kann. Diese werden dann automatisch gelöscht.

o Serverliste beim Programmstart aktualisieren
In dem Verzeichnis, in das Ihr eMule entpackt oder installiert habt, findet Ihr eine Datei mit dem Namen adresses.dat. Dort könnt Ihr einen gültigen Link zu einer server.met (Serverliste) eintragen, die dann bei aktivierter Option bei jedem Neustart von eMule automatisch heruntergeladen und benutzt wird.
Um die adresses.dat zu bearbeiten, öffnet Ihr sie einfach mit einem einfachen Texteditor wie zum Beispiel dem Editor (Notepad) von Windows und tragt den Link dort ein. Es können mehrere Addressen eingetragen werden, abgefragt wird allerdings nur solange bis eine gültige Liste erhalten wurde.

o Empfange aktuelle Serverliste vom verbundenen Server
eDonkey-Server kennen/verständigen sich bis zu einem gewissen Grad untereinander. Sobald diese Option aktiviert ist, erhält eMule bei erfolgreicher Verbindung zu einem Server eine Liste mit allen funktionierenden Servern, die diesem bekannt sind.

o Empfange aktuelle Serverliste von verbundenen Nutzern
Nehmen zwei eMule Clients Verbindung auf, werden ihre Serverlisten verglichen und jeweils aktualisiert.

Anmerkung:
Die letzten beiden Punkte halten Eure Serverliste ständig aktuell - ein manuelles Einfügen einer server.met ist nicht mehr erforderlich.

server.met von URL laden

Hier tragt Ihr einen gültigen Link zu einer server.met ein und klickt auf "Aktualisieren". Im Logfensterkönnt Ihr sehen, wie viele Server hinzugefügt wurden.

Neuer Server (einzeln)

Um einen einzelnen Server zu Eurer Liste hinzuzufügen tragt Ihr hier die IP, den Port und einen Namen für den Server ein und klickt auf "Hinzufügen". Erscheint im Logfenster die Meldung "Server wurde nicht hinzugefügt", so befindet sich dieser Server (evtl. unter einem anderen Namen) bereits in Eurer Liste.

Server via IRC hinzufügen
Die offiziellen eMule-Channels stellen ein !serverlist - Kommando zur Verfügung, mit dem Euch mit einer privaten Nachricht eine aktuelle Liste mit Links zu server.mets geschickt wird. Wenn Ihr die in eMule eingebaute IRC-Chatfunktion nutzt, so braucht Ihr nur noch auf einen der Links zu klicken und die Serverliste wird direkt von eMule übernommen.

Server mit Hilfe von Weblinks hinzufügen
Das eDonkey-Netzwerk stellt spezielle Links nach dem Schema ed2k://|server|IP|port|/ zur Verfügung, um einzelne Server zu eMule hinzuzufügen. Ein Beispiel seht Ihr hier: TheDonkeyNetwork


94

Addressen für Serverlisten
20.07.2003 11:42

eMule nutzt die selben Server wie eDonkey. Alle Serverlisten für den eDonkey können ohne Probleme auch mit eMule genutzt werden. eMule aktualisiert automatisch die Serverliste während dem Betrieb. Läuft eMule sehr lange an einem Stück sind keine weiteren Updates über Serverlisten notwendig.

Webseiten mit Links zu Serverlisten:
 | TheDonkeyNetwork
 | Server List for eDonkey2000
 | Dreadzone

Direktlinks zu den Serverlisten von ocbMaurice:
 |  | Default
 |  | All servers
 |  | Working Servers
 |  | Long time proven servers
Anmerkungen:
> | Über Google findet Ihr noch viele andere Seiten, die gute Serverlisten anbieten.
> | Jeder der o.g. kann irgendwann einmal nicht mehr funktionieren. Dies soll nur eine Starthilfe sein.
> | Großen Dank an dieser Stelle an all die, die diese Listen pflegen und zur Verfügung stellen.


95

Dynamische DNS Auflösung
20.07.2003 11:43

Dynamische IP-Adressen dienen dazu, den Vorrat an begrenzten IP-Adressen im World Wide Web (theoretisch 2^32) zu erhöhen. Viele Provider nutzen dies, um nach einer bestimmten Zeitspanne durch Verbindungstrennung und anschließender Neueinwahl eine neue dynamische IP vergeben zu können.

Dies ist ein gravierender Nachteil für die Server, die bis zur Zwangstrennung nur durch Ihre IP im eDonkey-Netzwerk bekannt waren..

Viele kostenlose Anbieter ermöglichen die Vergabe eines statischen Hostnamens für dynamische IPs, um diesem Problem entgegenzuwirken.

Tragt [emDynIP: StaticHostName.host:Port] als Willkommensnachricht in Eurem dserver ein.
Für einen standardmäßig konfigurierten Server lautet der Port 4661.

Dadurch wird eMule bei der Verbindung zu diesem Server angewiesen, an Stelle der dynamischen IP den statischen Hostnamen zu benutzen; dies hat auch den Vorteil, daß man den Hostnamen in der staticservers.dat hinterlegen kann und dieser Server praktisch nicht mehr "verloren" gehen kann.

Anmerkungen:
> | Die Länge des statischen Hostnamens darf 51 Zeichen nicht überschreiten.
> | Dies gilt nur für diejenigen unter Euch, die einen Server betreiben oder betreiben wollen. Wenn Ihr nur den eMule-Client nutz, ist diese Rubrik für Euch uninteressant.
> | Großer Dank auch hier an alle Serverbetreiber. Sie sind die eigentliche Stütze des eDonkey-Netzwerkes..


96

Suche nach Dateien
29.02.2004 18:45

Eine Suche nach Downloads bei eMule bedeutet, dass jeder Server der sich in der Liste befindet, gefragt wird ob er Dateien mit den angegebenen Suchbegriffen hat. Ein Server stellt hierfür eine Liste aller Dateien bereit, die zu ihm verbundene Benutzer freigegeben haben. Auf dem Server selbst werden keinerlei Dateien gelagert.
Die Suchfunktion in eMule erlaubt es sehr genau nach den gewünschten Dateien zu suchen. Eine genaue Suche ist auch notwendig da eMule nur so lange sucht bis für den Suchbegriff insgesamt 201 Quellen gefunden wurden.

Suche
o Name
Gewünschter Suchbegriff. Es können mehrere Suchbegriffe eingegeben werden, wobei eMule dann nur Treffer anzeigt, die alle eingegebene Suchbegriffe enthalten. Zusätzlich können die Suchbegriffe noch über die bool'schen Operatoren NOT, AND und OR verknüpft werden. Siehe Bool'sche Suche diesem Kapitel.
Dieses Textfeld besitzt ein Autovervollständigung die frühere Suchbegriffe speichert. Um die Liste der gespeicherten Einträge zu löschen, die Taste STRG oder ALT drücken und dann ENTF drücken.
Um die Funktion der Autovervollständigung ganz zu deaktivieren gibt es den UseAutocompletion Schalter in Einstellungen -> Preferences.ini.

o Typ
Mit der Angabe eines bestimmten Typs kann die Suche auf Dateien einer bestimmten Art, wie Bilder oder Video, ect, eingeschränkt werden. Es werden dann nur Treffer mit den entsprechenden Dateiendungen gefunden.

Alle | keine Einschränkung
Archive | .ace, .arj, .gz, .hqx, .lha, .rar, .sea, .sit, .tar, .tgz, .uc2, .zip
Audio | ".669, .aac, .aif, .aiff, .amf, .ams, .ape, .au, .dbm, .dmf, .dsm, .far, .flac, .it, .mdl, .med, .mid, .midi, .mod, .mol, .mp1, .mp2, .mp3, .mp4, .mpa, .mpc, .mpp, .mtm, .nst, .ogg, .okt, .psm, .ptm, .ra, .rmi, .s3m, .stm, .ult, .umx, .wav, .wma, .wow, .xm."
Bilder | .bmp, .dcx, .emf, .gif, .ico, .jpeg, .png, .pct, .pcx, .pic, .pict, .png, .psd, .psp, .tga, .tif, .tiff, .wmf, .xif
CD-Images | .bin, .bwa, .bwi, .bws, .bwt, .ccd, .cue, .dmg, .dmz, .img, .iso, .mdf, .mds, .nrg, .sub, .toast
Programme | ..bat, .cmd, .com, .exe, .ace, .arj, .gz, .hqx, .lha, .rar, .sea, .sit, .tar, .tgz, .uc2, .zip, .bin, .bwa, .bwi, .bws, .bwt, .ccd, .cue, .dmg, .dmz, .img, .iso, .mdf, .mds, .nrg, .sub, .toast
Video | asf, .avi, .divx, .m1v, .m2v, .mov, .mp1v, .mp2v, .mpe, .mpeg, .mpg, .mps, .mpv, .mpv1, .mpv2, .ogm, .qt, .ram, .rm, .rv, .vivo, .vob, .wmv."

o Methode
eMule unterstützt unter Anderem auch die Suche über eD2k-Web-Suchdienste. Die Methode gibt an auf welche Weise gesucht werden soll

> | Server Es wird nur der gerade verbundene Server nach Treffer für die Suche gefragt
> | Global (Server) Alle in der Serverliste vorhandenen Server werden nacheinander abgefragt. Der grüne Balken im unteren Teil des Suchen Fensters zeigt den Fortschritt der globalen Suche.
> | Kademlia Diese Methode durchsucht nur das serverlose Kademlia Netzwerk. Es kann einige Zeit vergehen bis Treffer angezeigt werden. Wird selbst für ein populäres Suchwort kein Treffer angezeigt ist wahrscheinlich der UDP Port des Systems durch eine Firewall oder einen Router blockiert.
> | Jigle (Web) Webbasierte Suche mit der Suchmaschine Jigle. Die Exakte Suche erzwingt dass der Suchbegriff genau so gefunden werden muss und nicht in einer Kombination enthalten sein darf
 | Jigle eMule bietet direkten Zugriff auf die Jigle Datenbank mit dieser Suchmethode.
> | Filedonkey Webbasierte Suche mit der Suchmaschine Filedonkey (Beachte: Bei dieser Methode kann kein Bool'scher Suchausdruck benutzt werden)

Filter
o min Grösse / max Grösse
Einschränkung der Suche über die Dateigrösse. Es werden nur Treffer angezeigt die entweder über der eingegeben min Grösse bzw. unter der angegebenen max Grösse liegen. Die Eingabe der Grösse erfolgt normalerweise in MegaByte [MB] kann aber durch hinzufügen einer anderen Einheit beliebig geändert werden. Gültige Einheiten sind:

Einheit | Gültige Abkürzungen:
Bytes | b | byte | bytes
KiloBytes | k | kb | kbyte | kbytes
MegaBytes | m | mb | mbyte | mbytes
GigaBytes | g | gb | gbyte | gbytes

Beispiel:
Min Grösse = 200
ohne weitere Angaben findet diese Suche nur Dateien mit einer Grösse von mehr als 200MB
Max Grösse = 1gb
diese Suche würde nur Treffer finden, deren Dateigrösse kleiner als 1 Giga Byte ist.

o Verfügbarkeit
Angabe der minimalen Anzahl der Quellen, die der Server für einen bestimmten Suchbegriff haben muss, damit es als Treffer gilt.

Anmerkung:
Mit diesem Filter ist nicht die globale Anzahl der Quellen gemeint sondern nur die Anzahl die auf dem entsprechenden Server vorhanden ist. Wird hier ein zu hoher Wert eingestellt, ergibt die Suche unter Umständen keine Treffer weil keiner der Server auf einmal soviel Quellen für diese Suchanfrage hat.

o Dateiendung
Einschränkung der Suche auf Dateien mit genau der angegebenen Endung. Die Endung wird ohne . eingegeben, also nicht .avi sondern nur avi

Bool'sche Suche
Diese Funktion erlaubt es sehr komplexe Suchausdrücke zu formulieren. Gültige Operatoren sind OR, AND und NOT. Werden diese in einer Suche verwendet müssen sie gross geschrieben werden!

> | NOT Dieser Operator entspricht einem NAND = "Und Nicht". Er schliesst den folgenden Suchbegriff aus, d.h. der Dateiname darf diesen Begriff nicht enthalten. Höchste Wertigkeit Eingabe: Suchbegriff1 NOT Suchbegriff2
> | AND Die Und - Verknüpfung wird standardmäßig genutzt wenn keine Operatoren zwischen zwei Suchbegriffen verwendet werden. Und - verknüpfte Suchbegriffe müssen beide im Dateinamen vorkommen. Mittlere Wertigkeit Eingabe: Suchbegriff1 AND Suchbegriff2 (gleichwertig: Suchbegriff1 Suchbegriff2)
> | OR Oder - Verknüpfung. Dies bedeutet, dass Treffer entweder den einen oder der anderen Suchbegriff enthalten müssen. Die Oder - Verknüpfung hat die niedrigste Wertigkeit. Eingabe: Suchbegriff1 OR Suchbegriff2
Anmerkungen:
> | Jede Kademlia Suche muss mit einem Ausdruck beginnen, der mindestens 3 Zeichen lang ist. Nach diesem ersten Ausdruck darf nur AND als logischer Operator folgen, nicht aber NOT oder OR.
> | Für den webbasierten Suchdienst Filedonkey gilt die bool'sche Suche nicht. Sonst können alle Methoden, Typen und Filter mit der bool'schen Suche kombiniert werden.
> | Die Operatoren gewichten in der mathematischen Reihenfolge NOT -> AND -> OR. Soll eine andere Reihenfolge angewendet werden müssen die zu gruppierenden Suchbegriffe und Operatoren in ( ) eingeschlossen werden.
> | Um einen der Operatoren AND, NOT und OR nicht als solchen sondern als ganz normalen Suchbegriff zu werten muss das Argument in Anführungszeichen " " stehen. So gilt in der Anfrage Suchbegriff1 "OR" Suchbegriff2 das OR nicht als Operator sondern wird als Suchbegriff genutzt.
> | OR und NOT verknüpfte Suchen sind nicht so streng wie AND. AND liefert nur Treffer wenn das gesamte Wort übereinstimmt während OR und NOT auch auf das Vorkommen der gleichen Buchstabenkombination in einem anderen Wort reagieren.
> | OR und NOT werten auch eingebettete Meta-Daten wie mp3 Tags oder Zusatzinformationen wie Autor und Kommentar z.B. bei Videos oder Bildern.
Beispiele:
> | Sucheingabe | Suchbegriff1 Suchbegriff2 OR Suchbegriff3 Suchbegriff4
 | Bool'sche Interpretation | (Suchbegriff1 AND Suchbegriff2) OR (Suchbegriff3 AND Suchbegriff4)
 | Erklärung | Findet Dateien, in denen die Suchbegriffe 1 + 2 vorkommen müssen oder solche mit den Begriffen 3 + 4
> | Sucheingabe | Suchbegriff1 Suchbegriff2 OR Suchbegriff3 Suchbegriff4 NOT Suchbegriff5
 | Bool'sche Interpretation | (Suchbegriff1 AND Suchbegriff2) OR ((Suchbegriff3 AND Suchbegriff4) NAND Suchbegriff5)
 | Erklärung | Findet Dateien, in denen die Suchbegriffe 1 + 2 vorkommen müssen oder die Begriffe 3 + 4 doch darf Suchbegriff5 nicht bei 3 + 4 enthalten sein.
> | Sucheingabe | Suchbegriff1 Suchbegriff2 NOT Suchbegriff5 OR Suchbegriff3 Suchbegriff4 NOT Suchbegriff5
 | Bool'sche Interpretation | ((Suchbegriff1 AND Suchbegriff2) NAND Suchbegriff5) OR ((Suchbegriff3 AND Suchbegriff4) NAND Suchbegriff5)
 | Erklärung | Ähnlich wie das Beispiel darüber nur darf hier der Suchbegriff5 weder bei 1 + 2 noch bei 3 + 4 vorkommen
> | Sucheingabe | (Suchbegriff1 Suchbegriff2 OR Suchbegriff3 Suchbegriff4) NOT Suchbegriff5
 | Bool'sche Interpretation | ((Suchbegriff1 AND Suchbegriff2) OR (Suchbegriff3 Suchbegriff4)) NAND Suchbegriff5
 | Erklärung | Gleicher Ausdruck wie das Beispiel eins drüber, nur durch das Setzen von Klammern gekürzt.
> | Sucheingabe | (Suchbegriff1 "OR" Suchbegriff2) NOT Suchbegriff3
 | Bool'sche Interpretation | (Suchbegriff1 AND or AND Suchbegriff2) NAND Suchbegriff3
 | Erklärung | Durch die Benutzung der Anführungszeichen " " wird das OR jetzt nicht mehr wie ein Operator gewertet sondern wie ein Suchbegriff. Als Treffer gelten Begriffe die Suchbegriff 1 + 2 und das Wort "or" enthalten, nicht aber Suchbegriff3.

Interpretation der Ergebnisse
o Verfügbarkeit (Quellen)
Dieser Wert gibt an wie viele einzelne Quellen für diese Datei gefunden wurden. Damit lässt sich der Verbreitungsgrad einer Datei ableiten. Normalerweise sollte immer eine Datei mit vielen gefundenen Quellen, einer mit wenigen vorgezogen werden.
Steht nach der Anzahl der Quellen ein Wert in ( ) können diese Quellen dem Download direkt hinzugefügt werden, ohne dass eMule noch einmal nach ihnen suchen muss

o Unterschiedliche Farben der Ergebnisse

> | Schwarz, Dunkelblau, Hellblau Diese Farben geben schnell Auskunft über die Verfügbarkeit der Datei. Schwarz = 1 - 3 Quellen, Dunkelblau = 4 - 9 Quellen, Hellbalu = 10+ Quellen
> | Rot Dateien die sich bereits im Download befinden werden rot dargestellt.
> | Grün Treffer in grün sind bereits heruntergeladen und fertiggestellt.

o Suche in Ergebnissen
Mit der Tastenkombination STRG + f kann noch zusätzlich in den gefundenen Treffern gesucht werden. Die Funktionstaste F3 setzt die Suche mit dem gleichen Suchbegriff fort und springt zum nächsten Treffer (vorwärts) während die Kombination Shift+F3 zum vorherigen Treffer (rückwärts) geht.

o Mehrere unterschiedliche Namen für ein Suchergebniss
Findet eMule für ein bestimmtes Ergebniss mehrere unterschiedliche Namen, zeigt er dies im Suchdialog mit einem + (wie im Windows Explorer) an. Weichen die gefundenen Dateinamen stark voneinander ab, ist es sehr wahrscheinlich, dass es sich um eine Fälschung handet. Der Dateiname der am häufigsten gefunden wurde ist vermutlich der korrekte.

Gilt ab Version: .42a +
Aktualisiert: 2004-02-27, Monk


69

Kredit System
29.02.2004 18:47

Das Kredit System dient dazu Benutzer, die zum Netzwerk beitragen zu belohnen. eMule verwendet eine Warteschlange bei der nur die Zeit ein Rolle spielt, die ein Benutzer wartet. Insgesamt wird diese Wartezeit von verschiedenen Faktoren noch beeinflusst, wie im Kapitel Bewertung und Punkte erklärt. Der ausschlagebenste dieser Faktoren ist das Kredit System.
Er wird aus der Datenmenge berechnet die zwischen zwei Benutzern ausgetauscht wurde und ist umso grösser je mehr Daten hochgeladen wurden. Über das rechte-Maustaste-Menu -> Zeige Details kann bei einem beliebigen Benutzer in der Warteliste die zur Berechnung verwendeten Werte eingesehen werden.

Zuerst werden 2 verschiedene Verhältnisfaktoren berechnet:
 | Verhältnis1 = Uploaded gesamt x 2 / Downloaded gesamt
 | Verhältnis2 = WURZEL(Uploaded gesamt + 2)
Beide Werte werden verglichen und der niedrigere wird als gültiger Faktor genommen.
Weiterhin sind diese Rahmenbedingungen definiert:
 | > | Uploaded gesamt < 1 MB => Faktor = 1
 | > | Downloaded gesamt = 0 => Faktor = 10
 | > | Der Faktor kann nicht kleiner als 1 sein und nicht grösser als 10 werden.

Anmerkungen:
> | Das Kredit System gilt für jeden Benutzer, egal ob eDonkey, Lmule oder mldonkey.
> | Die Kredits gelten nur zwischen zwei definierten Clients also nicht global. Erhaltene Kredits können nur bei dem betreffenden "Schuldner" eingelöst werden.
> | Die Kredit Punkte werden in der Datei clients.met gespeichert
> | Die eigenen Kredits werden auf der Festplatte des "Schuldners" gespeichert. Manipulation an den eigenen Kredits ist somit ausgeschlossen
> | Die eigenen Kredits können nicht abgefragt werden.

Aktualisierung: 2003-04-13 by Monk


97

Sichere Benutzer Identifikation
18.03.2004 15:43

eMule identifiziert andere Teilnehmer im Netzwerk an Hand eines eindeutigen Zahlenwerts, dem User Hash. Dieser User Hash wird in der Datei preferences.dat gespeichert und dient der sicheren Zuordnung erworbener Kredit Punkte.
Um Manipulation und Ausnutzen des User Hashes zu verhindern kann eMule die Identifikation bei einem anderen Client über eine asymmetrische Verschlüsselung vornehmen. Das Verfahren nutzt ein Schlüsselpaar, bestehend aus einem öffentlichen Schlüssel (public key) und einem privaten Schlüssel (private key).

Die Sichere Benutzer Identifikation kann unter Einstellungen -> Sicherheit aktiviert werden. Es wird empfohlen diese zu benutzen.

Ablauf der sicheren Benutzer Anmeldung:

Teilnehmer A möchte sicherstellen, dass seine erworbenen Kredit Punkte nur von ihm genutzt werden. Hierzu erstellt er einen privaten 384 bit RSA Schlüssel und speichert diesen in der cryptkey.dat.
Dieser Schlüssel wird nur beim ersten Einsatz erzeugt und bleibt ab dahin für alle Identifikation erhalten. Sollte die Datei und damit der Schlüssel verloren gehen, verliert Teilnehmer A alle seine Kreditpunkte da er sich nichtmehr als der korrekte Besitzer ausweisen kann.

Verbinden sich zwei Teilnehmer, welche beide die Verschlüsselung benutzen, senden sie jeweils einen öffentlichen Schlüssel zusammen mit einer Zufallszahl an ihren Partner. Dieser speichert die Information in seiner clients.met Datei. Es wird nur der Schlüssel gespeichert, die Zufallszahl wird bei jeder folgenden Verbindung neu generiert.
Dies geschieht ebenfalls nur wenn sich die beiden Teilnehmer noch nicht kannten, d.h. noch keine Kredit Punkte ausgetauscht haben.

Will sich Teilnehmer A zu einem späteren Zeitpunkt erneut bei Teilnehmer B anmelden erzeugt er mit Hilfe seines privaten Schlüssels, dem öffentlichen Schlüssel von B und einer Zufallszahl seine digitale Signatur.
Diese Signatur ist gültig, bis sich die IP von Teilnehmer A ändert oder Teilnehmer B seinen eMule beendet.

Nachdem B die Signatur von A erhalten hat überprüft er ob diese aus seinem öffentlich Schlüssel und seiner Zufallszahl erzeugt wurde und ob sie zu dem öffentlichen Schlüssel von A passt.

Anmerkungen:
> | Sollte die cyptkey.dat verloren gehen, muss auch die preferences.dat gelöscht werden, oder es können keine weiteren Kredit Punkte bei bereits bekannten Clients erworben werden.
> | Bestehen beim Umstieg auf die sichere Benutzer Identifikation alte Kredit Punkte, verfallen diese. Es ist aus Sicherheitsgründen nicht möglich "unverschlüsselte Kredits" zu erhalten.

Gilt ab Version: .29b +
Aktualisierung: 2003-06-20 by Monk


70

Bannen von agressiven Clients
29.02.2004 18:53
Wenn ein anderer Client bei Euch etwas herunterladen möchte, so fragt er in der Regel alle 10-20 Minuten einmal bei Eurem Client nach, ob seine gefundene Quelle überhaupt noch gültig ist. Durch Modifizierung eines Clients ist es jedoch möglich, diese Zeitspanne herabzusetzen und sich da durch Vorteile bei der Vergabe von Uploadslots bei einem eDonkey-Client zu verschaffen. eMule-Clients betrifft dieses Problem nicht; die verkürzte Abfragezeit wirkt sich hier nicht auf eine schnellere Vergabe der Uploadslots aus. Allerdings werden durch dieses aggressive Verhalten wertvolle Ressourcen (Bandbreite und Verbindungen) vergeudet. Um dies zu vermeiden, werden derart modifizierte, aggressive Clients nach mehr als einer Anfrage innerhalb von 10 Minuten von eMule gebannt und sind nicht mehr in der Lage, von einem eMule-Client etwas herunter zu landen. Der Bann wird nach einem Neustart Eures Clients wieder aufgehoben.
Hier ein paar Beispiele, die Euch einen Bann bescheren können:
> | Ändern der Anfragefrequenz Eures Clients auf einen Wert unter 10 Minuten
> | Regelmäßiges pausieren und neu starten Eures Clients mit dem Ziel, die Downloadrate zu verbessern; dies führt jedes Mal zu einer neuen Anfrage (gilt nur für eDonkey-Clients)
> | Neustart Eures Clients alle 2 Minuten; auch dies führt jedes Mal zu einer neuen Anfrage.

Um es noch einmal zu verdeutlichen: eMule kümmert es nicht, welcher Client (eMule / eDonkey / mldonkey) zu häufig anfragt - ausschlaggebend ist allein die Häufigkeit der Anfragen innerhalb von 10 Minuten.

Aktualisierung: 14/12/02 Monk


71

Quellentausch
29.02.2004 19:00
eMule ist in der Lage, mit anderen eMule-Clients Quellen direkt auszutauschen. So muss nicht extra ein Server oder das Kademlia Netzwerk danach durchsucht werden. Die Mehrzahl seiner Quellen findet eMule über diesen Quellentausch.

Bei gut verbreiteten Dateien wird alle 10 Minuten ein zufällig ausgewählter Client aus den zur Verfügung stehenden Quellen nach weiteren Quellen gefragt. Ist eine Datei selten (weniger als 40 Quellen), so wird in diesem Intervall bei jedem Client nach seinen Quellen gefragt.

Nur die Quellen für noch fehlende Teile werden ausgetauscht. Dies geschieht mittels komprimierter Paketeüber TCP, um Bandbreite zu sparen.

Anmerkung:
> | Dieses Protokoll ist nicht kompatibel zu mlDonkey.
> | Der Quellentausch erfolgt über den Client Port 4662 im Protokoll TCP.
> | Quellen mit niedriger ID werden nicht getauscht
> | Passive Quellen sind eine Unterart des Quellentausches. Diese Quellen stammen aus Kontakten mit anderen eMules, welche z.B. eine ganz andere Datei laden wollten aber automatisch angefragt wurden ob sich nicht auch eine brauchbare Quelle wären.

Gilt für Version: 0.29a +
Aktualisiert: 2004-02-28 by Monk


72

Dateivorschau
02.05.2004 8:39

Einfache Dateivorschau
Dazu klickt Ihr mit der rechten Maustaste auf die Datei und wählt Vorschau aus. eMule erstellt daraufhin eine temporäre Datei im Temp-Ordner von eMule und öffnet sie im standardmäßig für diesen Dateityp definierten Programm.

Dies sind die momentan unterstützten Formate:

- *.avi
- *.mpg
- *.mpeg
- *.divx
- *.xvid
- *.zip
- *.rar
- *.ace

Anmerkungen:
> | Die Vorschaufunktion funktioniert nur, wenn der erste und letzte Teile (parts) bereits heruntergeladen sind und zudem noch genug Platz auf Eurem Laufwerk mit dem Temp-Ordner vorhanden ist.
> | Bei Multimedia-Dateien wird der richtige Codecs zwingend benötigt. Anzeichen für einen fehlenden Codecs sind z.B. eine .mpg - Datei, bei der Ihr zwar den Ton hört, aber kein Bild wiedergegeben wird. Schlimmstenfalls passiert jedoch außer einer entsprechenden Fehlermeldung gar nichts. Falls Ihr Euch nicht sicher seid, welcher Codecs denn nun zu verwenden ist, versucht es mit einem Codec Pack, der die wichtigsten Codecs bereitstellt.

Vorschau mit VLC
VLC ist ein Player, der es erlaubt auch unvollständige Multimedia-Dateien mit fast jedem Codec wiederzugeben. Ist VLC installiert muss der

Verwenden von VLC:
> | Download VideoLAN Client - VLC
> | Einstellungen -> Dateien -> Videowiedergabeprogramm den vollständige Pfad zur vlc.exe (Bsp.: C:\Programme\VideoLAN\VLC\vlc.exe) angeben
> | Im selben Dialog Erstelle Kopie für die Vorschau deaktivieren
> | In Einstellungen -> Preferences.ini den Wert PreviewSmallBlocks auf 1 setzen. Warnung: Diese Option kann zu Problemen mit anderen Playern ausser, VLC, führen

VLC und das eMule Part File Access Modul

Das eMule Part File Access Modul ist ein PlugIn für den VideoLAN Client. Es wertet die Informationen aus der .part.met Datei aus und erzeugt aus der dazugehörigen .part Datei einen Mediastream des unvollständigen Downloads. Dies erlaubt eine ruckelfreie Wiedergabe in VLC und spart das aufwendige Scannen nach verwertbaren Dateiteilen. Zusätzlich kann über "Seek" in dem Video an jede beliebige Stelle gesprungen werden oder der schnelle Vorlauf benutzt werden.

o Download und Installation des PlugIn

> | Der Plugin kann auf der eMule Project Homepage unter Downloads heruntergeladen werden.
> | Die .zip Datei entpacken und die libaccess_partfile_plugin.dll Datei in das VLC Plugin Verzeichnis (typisch: C:\Programme\VideoLAN\VLC\plugins) kopieren.
> | eMule wie im Abschnitt Vorschau mit VLC konfigurieren
> | Wichtig: Der PlugIn ist immer nur kompatibel zu einer bestimmten VLC Verion!
 |  | Part File Access Modul v1.1 <=> VLC v0.6.2
 |  | Part File Access Modul v1.2 <=> VLC v0.7.0

o Einstellungen des PlugIns

Nach dem Start von VLC sind die Einstellungen des PlugIns unter Einstellungen -> Einstellungen -> Plug-Ins -> access -> access_partfile zu erreichen.

Enable plugin for MPEG / AVI / non MPEG or AVI part files
Diese 3 Optionen bestimmen welche Multimedia-Dateitypen von dem PlugIn übernommen werden. Unter die "non MPEG or AVI part files" fallen Dateien wie .ogg, .ogm, .mp3, .mkv etc.
Ist eine der Optionen deaktiviert wird die entsprechende Datei falls möglich von dem Standardmodul für diese Datei übernommen statt von dem PlugIn.

Provide a seekable stream for MPEG / AVI / non MPEG or AVI part files
Diese Optionen können nur genutzt werden wenn der PlugIn auch für diesen Dateityp "enabled" ist. Unter "seekable stream" versteht man das Springen an beliebige Positionen im Video oder auch den schnellen Vorlauf.
Bei AVI oder anderen Dateitypen kann es vereinzelt vorkommen, dass diese "seekable streams" nicht korrekt funktionieren.

Enable plugin for all type of files (eMule part files and regular files)
Normalerweise gilt dieser PlugIn nur .part Dateien. Das Standardwiedergabemodul von VLC hat jedoch einen Fehler, der dazu führen kann, dass das gesamte System einfriert wenn eine defekte oder unvollständige Datei in VLC geöffnet wird.
Ist diese Option aktiviert werden alle Dateien für die VLC benutzt wird, egal von wo aus sie geöffnet werden (eMule, Explorer, Kommandozeile), von dem access_partfile PlugIn übernommen.
Für vollständige Videodateien ist der access_partfile PlugIn ein vollwertiger Ersatz zum Standardmodul des VideoLAN Clients.

Weitere Informationen zu diesem PlugIn (Englisch)

Verschiedene Programme zur Vorschau
Nicht alle Wiedergabeprogramme kommen gleich gut mit den unterschiedlichen Dateiformaten und noch nicht fertiggestellten Dateien klar. Eines der flexibelsten Programme ist sicher der Video LAN Client aber auch Media Player Classic oder Zoom Player eignen sich sehr gut. In eMule ist es möglich verschiedene Programme zur Vorschau anzulegen.
Hierzu muss im config Ordner von eMule eine Datei namens PreviewApps.dat angelegt werden. Dies ist eine normale Textdatei und kann z.B. mit dem Windows Editor angelegt werden. Die Vorschauprogramme müssen in folgendem Format angelegt werden.

<Menü Name> = <Pfad zur Anwendung> <optionale Kommandozeilen Parameter>
<Menü Name> | Name der Anwendung wie er im Vorschaumenü in eMule erscheint
<Pfad zur Anwendung> | Es muss der vollständige Pfad inclusive des Namens der .exe angegeben werden. Pfad mit Leerzeichen müssen in "" eingeschlossen werden.
<optionale Kommandozeilen Parameter> | Hier können zur weiteren Konfiguration noch Kommandos an das Programm übergeben werden.
Beispiele:
VideoLAN Client 0.6.2=C:\Programme\VideoLAN-0.6.2\VLC\vlc.exe
VideoLAN Client 0.7.1=C:\Programme\VideoLAN\VLC\vlc.exe --config "%USERPROFILE%\Applicationdata\vlc\vlcrc-0.7.1"
Media Player Classic="C:\Programme\Media Player Classic\mplayerc.exe"
Anmerkungen:
o | Wird eMule unter eingeschränkten Benutzerrechten ausgeführt kann es vorkommen das manche Programme nicht korrekt funktionieren, da sie mit den gleichen beschränkten Rechten ausgeführt werden.
o | Kommandozeilen Parameter können auch Systemvariablen wie %USERPROFILE% sein. In diesem Beispiel würde die Variable durch den "Dokumente und Einstellungen" Ordner mit dem entsprechenden Benutzernamen ersetzt. Dies ist nützlich um z.B. Konfigurationen für eingeschränkte Rechte anzulegen

Screenshot Vorschau von Video Dateien
Erlaubt ein Teilnehmer die Liste seiner freigegebenen Dateien abzurufen (Einstellungen -> Dateien -> Freigabe sichtbar für) kann die Vorschau Funktion auch für Video Dateien in dieser Liste eingesetzt werden.
Bei einem Rechtsklick auf eine freigegebene Video Datei -> Vorschau ruft eMule 5 Bilder aus den ersten 10 min dieser Datei ab. Diese Bilder werden sobald sie empfangen wurden in einem extra Fenster angezeigt. Es dauert meist ein Weilchen bis die Bilder eintreffen. Funktioniert nur zwischen eMules der Versionen .30b und höher.

Gilt ab Version: .42b +
Aktualisiert: 2004-05-01 by Monk


73

Online Signatur
29.02.2004 19:11

Wenn die Option Online-Signatur erstellen in den Einstellungen aktiviert ist, erstellt eMule eine regelmäßig aktualisierte Datei mit dem Namen onlinesig.dat in seinem Programmverzeichnis, mit deren Hilfe es möglich ist, bestimmte Informationen zur aktuellen eMule-Sitzung extern zu verarbeiten.

Die onlinesig.dat hat den folgenden Inhalt:

[Online status] | [verbundener Server] | [IP:port]
[momentane Downloadrate] | [momentane Uploadrate] | [Nutzer in der Warteschlange]

Zukünftig kann dieses Feature noch erweitert werden, aber in der Zwischenzeit könnt Ihr mit Hilfe des Programms Online Signature von Dra.:.god ein beliebiges Bild mit den Daten der onlinesig.dat versehen und mittels FTP auf Euren Webspace hochladen. Genauere Anleitungen gibt es hier:

http://home.pages.at/sputnikskiff/eMule1/onlinesig.htm
http://pinkfrog.netfirms.com/onlinesig.html

Großen Dank an drück-mich und Pink Frog für diese Anleitungen.

Gilt ab Version: .22a +
Aktualisiert: 14/12/02 by Monk


74

IRC - Chat
29.02.2004 19:14

Das IRC-Modul von eMule verbindet Euch standardmäßig mit folgendem IRC-Server:

irc.freshirc.com

Wenn Ihr weitere Hilfe benötigt oder einfach nur über eMule chatten wollt, besucht folgende Channel:

> #emule (englisch)
> #emule-german
> #emule-french
> #emule-spanish

Um mehr zu den Einstellung des IRC-Chats zu erfahren, lest bitte unter Einstellungen - IRC weiter.

Regeln:

> Keine privaten Nachrichten an die Ops (Channeloperator, zu erkennen an dem @ vor ihren Namen)
> Kein Fragen nach oder Anbieten von Warez oder sonstigem urheberrechtlich geschütztem Material
> Kein übermäßiger Einsatz von Scripts
> Keine Werbung

Gilt ab Version: 0.22b +
Aktualisiert: 14/12/02 by Monk


75

Freunde
29.02.2004 19:15

Das eDonkey-Netzwerk ist groß und bei der Masse an Nutzern ist es recht schwer, jemanden später noch einmal zu finden. Die Freundefunktion bietet hier eine einfache Möglichkeit, Nutzer mit den selben Interessen oder Tauschgewohnheiten zu verwalten und zu finden. Besonders für Releasergruppen ist dieses Feature von Vorteil.

Freunde hinzufügen

Freunde können aus dem Up- und Downloadbereich hinzugefügt werden, indem Ihr einfach mit der rechten Maustaste auf einen Nutzernamen klickt und dann "zur Freundesliste hinzufügen" wählt. Ein "Freund" wird anstatt des normalen Clientsymbols durch ein Freundesymbol angezeigt.

Funktionen
Eure Freunde werden im Nachrichtenfenster angezeigt. Hier könnt Ihr nach einem Klick mit der rechten Maustaste folgende Möglichkeiten nutzen:

o Zeige Details
Zeigt genauere Informationen über den Freund an. Dieses Fenster ist identisch mit dem, was Ihr mit "Zeige Details" im Up- oder Downloadfenster angezeigt bekommt.

o einen Freund hinzufügen
Einen weiteren Freund zur Liste hinzufügen.

o entferne Freund
Einen Freund von der Liste entfernen.

o Sende Nachricht
Startet eine private Chatsession mit dem betreffenden Freund.

o Dateien einsehen
Wenn der betreffende Freund seine Dateien für andere zur Einsicht freigegeben hat, so könnt Ihr sie Euch hier anschauen. Die Dateien werden im Suchfenster angezeigt.

o Freund-Uploadplatz aufbauen
Ein separater Uploadslot wird für den entsprechenden Freund geöffnet, und er kann ohne warten zu müssen direkt von Euch herunterladen. Dies funktioniert nur mit einem Freund, mehrere Freundeslots gleichzeitig sind nicht möglich.

Symbole eines Freundes

Freund ist gerade verbunden

Freund ist in der Liste der momentan bekannten Clients

Status ist offline oder unbekannt

Anmerkung:
Der Freunde-Status wird nicht regelmäßig aktualisiert, um Bandbreite zu sparen. Um den Status zu aktualisieren, müßt Ihr eine der o.g. Aktionen ausführen..

Gilt ab Version: .23a +
Aktualisiert: 2003-03-27 by Monk


76

IP Filter
29.02.2004 19:17

Im eMule-Netzwerk tauchen immer wieder Dateien auf, die Fehler enthalten oder gänzlich defekt sind. Dies wird zum Teil von Benutzern absichtlich oder unabsichtlich verursacht, führt jedoch zur Verbreitung dieser Fakes.
eMule versucht mit IP Filtern diese Belastung des Netzwerks zu minimieren. Zu filternde IP Adressen werden in der Datei ipfilter.dat festgelegt. Allen dort eingetragenen IP Bereichen wird der Zugriff auf eMule verwehrt.

# Beispiel-Datei ipfilter.dat
#
# Von diesen IP Bereichen kann weder Hoch- noch Heruntergeladen werden.
# Vorsicht, falsche Eintragungen können eMule jeglichen Zugriff auf das Netzwerk sperren!
#
# Format:
# IP-Bereich , Zugriffslevel , Beschreibung
#
# Zugrifflevels:
# <127 geblockt
# >=127 erlaubt

064.094.089.000 - 064.094.089.255 , 000 , Gator.com

Der beispielhafte Eintrag verhindert jegliche Verbindung mit IP Adressen im Bereich von 064.094.089.000 bis 064.094.089.255. Von diesen Adressen kann also weder heruntergeladen noch hochgeladen werden.

Warnung:
Dieses Beispiel würde jede Verbindungsanfrage von Clients aus diesem Bereich ignorieren & abbrechen.

Zugriffslevel:
Im Moment wird nur ein Zugriffslevel unterstützt. Jeder Zugriffslevel kleiner 127 (Standard in Einstellungen -> Sicherheit)unterbindet den Zugriff auf diesen IP-Bereich, alle anderen werden gestattet.

IP Filter aktualisieren
In Einstellungen -> Sicherheit steht die Option Aktualisiere von URL zur Verfügung. Seiten die Filterdateien zur Verfügung stellen sind z.B. PeerGuardian oder Lussnig's IP Filter. Einfach den Pfad zur IP Sammlung, z.B. http://www.peerguardian.net/pgipdb/guarding.p2p eintragen und Laden klicken.

IP Filter Werkzeug
Bei den Tools oder im Hotmenu (Alt+X) steht das IP-Filter Werkzeug. Damit ist es möglich weitere heruntergeladene Listen anzuhängen, Einträge zu entfernen etc. Zusätzlich wird eine Statistik angezeigt, welcher Filter wie oft getroffen wurden.

Gilt ab Version: .42a +
Aktualisiert: 2004-02-27 , Monk


77

Kategorien
29.02.2004 19:28

Die Dateien in der Transferliste können, zur besseren Übersicht, Kategorien zugeordnet werden. Jede Kategorie wird als eigenständige Liste mit eigenem Verzeichnis für fertig gestellte Dateien, geführt.
Die erste Kategorie ist "Alle". Diese kann nicht bearbeitet werden und stellt wahlweise alle Dateien dar oder nur diejenigen, die in der Ansichts-Auswahl gewählt wurde. Die Optionen für jede Kategorie können über einen Klick auf die rechte Maustaste bei der entsprechenden Kategorie erreicht werden.

Ansichts-Auswahl
Die Ansichts-Auswahl gilt nur für die erste Kategorie und erlaubt die Liste nach bestimmten Dateitypen zu filtern.

Alle | keine Filter, es werden alle Dateien angezeigt
Unkatalogisiert | Nur Dateien, die keiner anderen Kategorie zugeordnet sind, werden angezeigt
Unvollständig, Fertiggestellt, Warte, Ladend, Fehlerhaft, Angehalten, Gestoppt | Filtert die Dateiliste nach der Spalte "Status"
Video | Video Dateien der Endungen .mpg, .mpeg, .avi, .divx, .rm, .ram, .wmf, .asf, .vivo, .mov, .ogm, .vob
Audio | Audio Dateien: .wav, .mp3, .ogg, .mp4, .aac, .flac, .ape, .au, .wma, .mpc, .mp2
Archive | Archiv Dateien: .rar, .zip, .ace, .gz
CD-Images | .cue/.bin (CDRWin), .mds/.mdf (Alcohol120%), .ccd/.../files/help/1031/.sub (CloneCD), .bwa/.bwt/.bwi/.bws (BlindWrite), .nrg (Nero)

Kategorie hinzufügen
Erzeugt eine neue Kategorie und ruft anschließend den Eigenschaftsdialog auf um die Einstellungen zu bearbeiten.

o Titel
Der Name der neuen Kategorie

o Kommentar
Beschreibung oder beliebiger Kommentar für die neue Kategorie.

o Eingehende
Jeder Kategorie kann ein eigens Verzeichnis für eingehende, also fertig heruntergeladene, Dateien zugewiesen werden.

o Ändere Priorität für neu
Werden der Kategorie neue Dateien hinzugefügt, wird deren Priorität automatisch auf den hier angegebenen Level gesetzt.

o automatische Kategorien-Zuweisung
Hier können Dateinamen-Muster angegeben werden. Beim Starten neuer Downloads werden diese, sofern sie einem dieser Muster entsprechen, automatisch dieser Kategorie zugeordnet. Mehrere Schlüsselwörter können mit | getrennt angegeben werden und * dient als Platzhalter für einen beliebigen Ausdruck.

Beispiel: *.avi|a*.*|the*.*
Dieses Beispiel würde alle neuen Downloads die die Endung 'avi' haben oder mit 'a' oder 'the' anfangen dieser Kategorie zuordnen.

o Farben
Definiert die Farbe in denen Dateien dieser Kategorie angezeigt werden. In der Kategorie Alle wird diese Farbeinstellung ebenfalls übernommen.

Kategorie bearbeiten
Die in Kategorie hinzufügen getroffenen Einstellungen können hier nachträglich geändert werden

Kategorie entfernen
Löscht die betreffende Kategorie. Dies hat keine Auswirkung auf die Dateien die sich in dieser befinden.

Priorität, Abbruch, Stop, Pause, Fortsetzen
Diese Befehle wirken sich auf alle Dateien in der gewählten Kategorie aus.

Nächste Pausierte Datei fortsetzen
Ein Download aus dieser Kategorie wird fortgesetzt sobald ein anderer Download fertiggestellt wurde.

Hinzufügen von Dateien zu Kategorien
Dateien können wahlweise über das rechte-Maustaste-Menü eines Downloads -> Kategorie zuweisen oder per Drag & Drop den Kategorien hinzugefügt werden. Dazu die Dateien bei gedrückter linker Maustaste auf die entsprechende Kategorie ziehen und fallen lassen. Mehrere Dateien können mit der STRG-Taste oder Umschalttaste (Shift) markiert und so einer Kategorie hinzugefügt werden.
Zusätzlich kann ein Dateiauswahl auch über das Kontextmenü der Downloadliste einer Kategorie zugeordnet werden.
Im Suchen Fenster können gefundene Dateien auch durch Auswählen am unteren Rand direkt einer Kategorie zugeordnet werden.

Gilt ab Version: .30a +
Aktualisiert: 2003-08-24 , Monk


78

Webinterface
29.02.2004 19:20

Der Webserver dient der Kontrolle und Administration eMules von jedem beliebigen Rechner aus. Ist diese Option aktiviert kann über den Browser von jedem Rechner auf eMule zugegriffen werden, solange seine IP bekannt ist.

Um auf den Webserver zuzugreifen wird die IP des Rechners, auf dem eMule läuft, als Adresse in einem Browser eingetragen. Die IP Adresse muss in der Form http://xxx.xxx.xxx.xxx:port eingegeben werden. Der Port lautet in der Grundeinstellung 4711. Es besteht im Normalfall kein Anlass diesen Port zu ändern. Bei der Verwendung eines Routers muss der Port weitergeleitet werden. Nähere Informationen finden sich in dem Kapitel über Ports.
Um zu Testzwecken den Webserver auf dem gleichen Rechner wie eMule aufzurufen kann auf den Localhost zugegriffen werden. Hierzu als Adresse http://127.0.0.1:4711 eintragen.

DynDNS Hosts
Bei vielen Internetanbietern bekommt man spätestens nach 24 Stunden eine neue IP zugewiesen. Bei einem Zugriff auf die Webkontrolle von eMule muss jedoch die aktuelle IP des eMule Computers bekannt sein.
Das Internet bietet freie Dienste mit denen es möglich ist einem Computer der dynamische IP Adressen verwendet eine feste Adresse der Form http://meineAdresse.meinHost.com zu zuweisen. Ein kleines Programm, welches auf dem Rechner installiert werden muss, sendet bei jedem IP Wechsel die neue IP an den DynDNS Host und sie wird dort hinterlegt. Der Webserver ist somit immer über die eingerichteten Adresse http://meineAdresse.meinHost.com:4711 zu erreichen.

Nach der Anmeldung über den Browser stehen die selben Funktionen wie auf der Bedienoberfläche von eMule zur Verfügung.

Wichtig:
Es sollte auf alle Fälle ein Passwort verwendet werden um den Webserver zu sichern. Auf einen ungesicherten Webserver kann jeder von außen Eingreifen und Einstellungen vornehmen, Downloads hinzufügen bzw. löschen etc.

Gilt ab Version: .27b +
Aktualisiert: 2003-03-21 , Monk


340

Kommandozeilen-Paramter
01.05.2004 21:15

Verschiedene Funktionen in eMule lassen sich über die Eingabe von Kommandozeilen Befehlen steuern. Mit Hilfe dieser Befehle kann eMule z.B. mit einer Batch Datei aufgerufen werden oder man kann ihn über Telnet fernsteuern.

Syntax:
emule.exe status

• | status
Schreibt Informationen zu den Dateien die sich gerade im Download befinden in die Datei status.log
• | connect
Verbindet zu Servern
• | disconnect
Trennt die Verbindung zum Server
• | limits=up,down
Dieser Befehl setzt die Limits für Upload und Download. Gleiche Effekt wie Einstellungen -> Verbindungen -> Limits
• | resume
Setzt eine beliebige gestoppte oder pausierte Datei fort
• | restore
Stellt einen minimierten eMule Task wieder her
• | ignoreinstances
Erlaubt die Ausführung von mehr als einem eMule. Anmerkung: Weitere Instanzen müssen in einem eigenen Verzeichnis installiert sein und auf unterschiedliche Ordner für temporäre Dateien zugreifen. Auch die Ports in Einstellungen -> Verbindung müssen eindeutig sein.
• | exit
Beendet eMule
• | assertfile
Schreibt mögliche Debug Asserts in eine Textdatei statt das Programm zu unterbrechen. Reine Entwickler bzw Debug Option!


230

MuleMRTG
28.02.2004 19:35
MuleMRTG

Die Windows NT Reihe (NT, 2k, XP, 2003) von Microsoft kann Systemleistungsdaten aufzeichnen und in Log Dateien abspeichern. Ab v.42.1 nutzt eMule das selbe Log Format um Informationen über Down- und Upload sowie den erzeugten Overhead abzuspeichern

MRTG - Multi Router Traffic Grapher wird normalerweise dazu genutzt um die Auslastung und den Datenverkehr auf Routern oder Servern zu überwachen, eignet sich aber auch ausgezeichnet für Langzeitstatistiken in eMule. Hier ein Beispiel für MRTG Graphen.

Die Anleitungs beschreibt wie MRTG zur eMule Überwachung installiert wird. Die Erzeugung der Graphen erfolgt ohne CPU Belastung durch den NT Service MuleMRTG.
Funktioniert nur auf Windows NT, 2k, XP, 2003 nicht auf Win9x/ME

• | Active Perl herunterladen und mit den im Installationsprogramm vorgegebenen Parametern installieren.
• | Die Programme srvany.exe und intsrv.exe werden benötigt um den Service zu installieren. Sie sind entweder in den Windows Server 2003 Resource Kit Tools enthalten (Das Installationsprogramm dieser Tools funktioniert nur unter XP und 2003 nicht bei 2k) oder können über eine Google Suche gefunden werden. Die zwei Dateien können in einen beliebigen Ordner kopiert werden.
• | Das MuleMRTG Setupprogramm auf der Downloadseite herunterladen und ausführen. Es wird empfohlen die voreingestellten Setup Optionen beizubehalten. Nach Abfrage des Installationsvezeichnisses müssen noch einige Pfadangaben gemacht werden, damit der Installer alle notwendigen Komponenten für die Konfigurationsdateien findet.
• | Lief eMule während der Installation, muss nach Abschluss dieser neu gestartet werden.

eMule und MRTG zeichnen alle 5 Minuten neue Leistungswerte auf, die in den HTML Dateien angezeigt werden. Die Ausgabedateien werden in dem Ausgabevezeichnis erstellt und können durch Aufrufen der index.html im Browser dargestellt werden.

MRTG erstellt Langzeitstatistiken. Es dauert zwischen 5 und 10 Minuten bis die ersten Werte dargestellt werden.

Fehlersuche

  • Nach dem Neustart von eMule muss sein Leistungsprotokoll im angegebenen Pfad (Bsp.: C:\Programme\eMule\perflog.csv) angelegt werden
  • Systemsteuerung -> Verwaltung -> Ereignissanzeige -> Anwendungen. Es darf nur ein Eintrag für MRTG mit dem Inhalt "Started mrtg" vorhanden sein
  • Im Ausgabeverzeichnis werden insgesamt 21 Dateien (HTML, Bilder und Logs) erzeugt

Treffen die obigen Punkte nicht zu, ist ein Pfad falsch angegeben worden oder es sind nicht alle notwendigen Komponenten vorhanden. MuleMRTG sollte dann deinstalliert werden und die Installation sorgfältig nocheinmal durchgegangen werden.

Gilt ab: v.42a+
Aktualisiert: 2004-02-27, Monk


58

Fehlermeldungen
02.05.2004 16:40

Client Fehlerhaftes oder ungültiges Paket empfangen verursachte einen Fehler oder verhält sich ungewöhnlich. Verbindung wurde getrennt
Dies steht für einen Fehler, der bei einem mit Euch verbundenen Client aufgetreten ist und hat keinerlei Nachteile für Euch. Schlimmstenfalls bedeutet dies den Verlust dieses Clients als für Euch brauchbare Quelle.

Schwerer Fehler: An Port 4662 konnte kein Socket erstellt werden
Dieser Fehler tritt auf, wenn eine andere Anwendung versucht, über den Port 4662 eine Verbindung herzustellen. Meist ist diese Anwendung ein parallel laufender eDonkey- oder Overnet-Client (oder beide), bei denen die Ports nicht geändert wurden. Generell ist es möglich, diese Clients parallel laufen zu lassen, allerdings solltet Ihr ihnen verschiedene Ports zuweisen und niemals das selbe Temp-Verzeichnis benutzen (dies kann Eure begonnenen Downloads zerstören).

Fehler: Dein Port 4662 ist nicht erreichbar. Du hast eine LowID
Irgendetwas blockiert Euren Port 4662 und verhindert dadurch die Vergabe einer hohen ID; dies liegt meist an falsch/nicht ausreichend konfigurierten Routern und/oder Firewalls. Mehr dazu könnt Ihr in der Rubrik zu Firewalls und Routern lesen.

ERROR: Your port 4662 is not reachable. You have a LOWID http://www.edonkey2000.com/documentation/lowid.html! Please correct your network config !
Diese Fehlermeldung (sie erscheint immer auf Englisch) ähnelt der o.g., tritt jedoch nicht im Logbereich, sondern im Serverinfo-Fenster auf. Diese Fehlermeldungen stammen von den Lugdunum-Servern. Hier erfahrt Ihr mehr zu den Servern, die die Patches von Lugdunum nutzen.

Schwerer Fehler beim Verbindungsaufbau. Möglicherweise ist die Internetverbindung unterbrochen
Zunächst deutet dies auf eine tatsächlich unterbrochene Verbindung hin, kann aber auch durch eine stark ausgelastete Verbindung zu Stande kommen. Auch die Softwarefirewall Zone Alarm kann diesen Fehler verursachen.

Error: Invalid part.met fileversion! (x.part.met => (null))
Beim Schreiben in eine .part.met-Datei ist ein schwerwiegender Fehler aufgetreten. In diesen Dateien speichert eMule temporär die Dowloads. Die Ursache eines solchen Fehlers liegt in einem Absturz von Windows oder eMule, während gerade auf diese Dateien zugegriffen wurde. Um diese Dateien wiederherzustellen, könnt Ihr folgendes versuchen:

- Überprüfen, ob die Dateien noch in Eurem Temp-Verzeichnis vorhanden sind. Falls nicht, sind sie meist endgültig verloren.
- Known Metinator, DonkeyDoctor (Spanisch) oder eD2k RecoverMET benutzen, um eine Reparatur zu versuchen.
- Manchmal hilft auch der Versuch, ob eDonkey evtl. mit diesen Dateien noch etwas anfangen kann.
- Siehe auch Fehlerbehebung -> Downloads

Denkt daran, eMule zu beenden, bevor Ihr diese Tools einsetzt. Eine Garantie, daß Eure Dateien sich damit wiederherstellen lassen, gibt es nicht. Stellt Euch schonmal darauf ein, daß Ihr die verlorenen Dateien neu herunterladen müßt.

Statusmeldung "fehlerhaft" ("errorious")
Auch dieser Fehler hat etwas mit Dateizugriffen zu tun und kann auftreten, wenn

- eMule nicht auf eine .part-Datei zugreifen kann:
Überprüft Euer Temp-Verzeichnis, ob keine Dateifehler vorliegen.
Überprüft, ob nicht irgendeine Datei in Eurem Temp-Verzeichnis schreibgeschützt ist.
Anschließend eMule neustarten

- ein Download von eMule beendet oder in Euer Incoming-Verzeichnis verschoben wird:
Überprüft, ob die Angaben zu Eurem Incoming-Verzeichnis in den Einstellungen korrekt sind.
Überprüft den noch zur Verfügung stehenden Speicherplatz auf dem Laufwerk, auf dem sich Euer Incoming-Verzeichnis befindet.
Anschließend eMule neustarten

Wenn auch dies nicht hilft, beendet eMule und löscht die Dateien "preferences.ini" und "known.met" in Eurem Verzeichnis, in dem das eMule-Programm installiert ist. Anschließend müßt Ihr neustarten..

Client 'xxx' (IP:xxx.xxx.xxx.xxx) verursachte einen Fehler: beschädigtes oder ungültiges hashset empfangen. Verbindung wurde getrennt
Diese Meldung wurde durch einen anderen Client verursacht, der ein ungültiges Hashset einer Quelle übermittelt hat. Dieser Fehler hat nichts mit Eurem Client zu tun.

Fehler: geladener Teil der Datei konnte nicht geprüft werden - Hashset unvollständig (XXX). Dies sollte niemals vorkommen
Dieser Fehler tritt nur bei Dateien auf, die kleiner als 9 MB sind. eMule teilt Downloads in Chunks (Teile) zu jeweils 9 MB auf. Um diese Chunks eindeutig identifizieren zu können, gibt es das Hashset. Bei kleineren Dateien vermutet eMule, einen unvollständigen Chunk geladen zu haben, obwohl die Datei in Wirklichkeit korrekt übertragen wurde. Diese Fehlermeldung kann bei kleinen Dateien ignoriert werden.

FEHLER beim Speichern der part-Datei: .part Datei konnte nicht gefunden werden (xxx.part.met)
Während eMule versucht, eine Datei fertig zu stellen, ist ein Fehler aufgetreten. Mögliche Ursachen sind:

- ein versehentlich verschobenes Temp-Verzeichnis oder .part-Datei
- ein anderes Programm greift gerade auf diese Datei zu, z.B. ein Virenscanner oder ein anderes Filesharing-Programm.

Nachdem Ihr die möglichen Fehlerquellen beseitigt habt, müßt Ihr eMule neustarten.

Fehler: Konnte Abschnittsdatei nicht erstellen
Ein Problem beim Erstellen der temporären Datei ist aufgetreten. Meist ist ein ungültiges Verzeichnis für die temporären Dateien in Einstellungen -> Verzeichnisse Ursache dieses Fehlers. Das temporäre Verzeichnis muss ein bestehender Ordner sein und darf nicht schreibgeschützt werden. Auch müssen die nötigen Benutzerrechte (Schreib- und Leserechte) in den Betriebssystemen Win2k und XP vergeben sein.

Ungültiges Versionstag in server.met (0x3C)
Ein Link in der adresses.dat hat nicht funktioniert oder es wurde eine schadhafte server.met heruntergeladen. Einfach eine server.met von einer anderen Quelle laden. Eine weitere Fehlerursache ist die eigene server.met Datei im eMule Verzeichnis. Tritt der Fehler weiter auf ist diese zu löschen.

An attempt was made to access an unnamed file past its end
Dieser Fehler tritt in Versionen vor .28a auf. Manche Server oder andere Benutzer verschicken ungültige Pakete, die diese Meldung verursachen. Die Funktion von eMule wird dadurch nicht beeinträchtigt. In manchen Fällen kommt es zur Unterbrechung der Suche. Hier helfen ein Serverwechsel oder Websuchdienste weiter.


59

ED2K-Link
20.03.2004 17:43

eD2k Weblinks werden nicht übernommen. Der Browser bringt eine Fehlermeldung
eMule ist nicht mehr richtig mit dem speziellen Format für die Weblinks verknüpft. Zur Behebung dieses Problems als erstes überprüfen ob die Schaltfläche ED2K Links in Einstellungen -> Allgemein inaktiv, d.h. grau hinterlegt, ist.
Falls ja, liegt ein Fehler in den Verknüpfungen der Windows Registry vor. Dieses Programm (by Resterampe) löscht die betreffenden Verknüpfungen und sie können dann in eMules Einstellungen neu angelegt werden.

Diese Registry Einträge sind für das Öffnen der Links verantwortlich:
HKEY_CLASSES_ROOT\ed2k\shell\open\command
Name: (Standard)
Typ: REG_SZ
Data: "Pfad zur emule.exe (mit Anführungszeichen!)" %1

und

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\ed2k\shell\open\command
wie oben beschrieben.

Opera
Opera 7.2x und neuer
eMule starten und in Opera nach File -> Preferences -> Programs and paths -> Protocols wechseln und mit Add ein neues Protokoll hinzufügen. In dem Fenster unter Protocols muss ed2k eingetragen werden, dann sollte der Pfad zur emule.exe in dem Feld Open with default application automatisch eingetragen werden. Ist dies nicht der Falls muss der vollständige Pfad zur emule.exe bei Open with other application eingetragen werden.

Ältere Opera Versionen:
Damit in Opera die Weblinks funktionieren, muss ein Eintrag einer Konfigurationsdatei im Opera Installationsverzeichnis hinzugefügt werden. Vor Änderung der Datei muss Opera geschlossen werden.
Opera 6.x:
Datei Opera6.ini mit einem Editor öffnen. Unter [User Prefs] die Zeile TrustedExternalURLProtocols=ed2k hinzufügen und abspeichern.
Opera 7.x:
Bei Opera der Versionen 7.x ist der selbe Eintrag in der Datei OperaDef6.ini vorzunehmen.

Mozilla und Firefox
Bei diesen Browsern ist der PlugIn mozex (alternativer download link) notwendig um sie mit verschiedenen Linkformaten wie eD2k zu verknüpfen. Nach der Installation in die Einstellungen des Browsers wechseln und im eD2k Feld des mozex PlugIns folgenden Eintrag erstellen:
Pfad_zu_eMule\emule.exe %r

Bsp:
C:\Programme\eMule\emule.exe %r


61

Webinterface
21.07.2003 9:06
Webinterface: Satt der Seite öffnet sich ein Downloaddialog im Internet Explorer
Die Optionen HTTP 1.1 verwenden und HTTP 1.1 über Proxyverbindung verwenden müssen in Extras -> Internetoptionen -> Erweitert -> Einstellungen für HTTP 1.1 ausgewählt sein.


62

Downloads
02.05.2004 16:41

Downloads sind verschwunden
Nach einem Absturz von eMule oder Windows kann es vorkommen, dass ein/mehrere/alle Downloads plötzlich verschwunden sind. Vermutlich wurde eine oder mehrere *.part.met Dateien zerstört. Zur Wiederherstellung dieser Dateien können folgende Maßnahmen getroffen werden:

Allgemein
Vor jeder Operation an den Dateien muss eMule beendet werden.
Um falschen Einstellungen vorzubeugen vorher kontrollieren, ob in den Einstellungen unter Verzeichnisse auch der korrekte Pfad zum Ordner für temporäre Dateien angegeben ist. Nach einer Änderung dieses Verzeichnisses muss eMule neu gestartet werden.

Backups
eMule legt von den *.part.met Dateien automatisch Kopien (*.part.met.BAK) an. Hat das Backup eine andere Größe oder unterschiedliche Einträge in Geändert am: (Rechte Maustaste auf die Datei -> Eigenschaften) kann durch Löschen der betreffenden *.part.met Datei und Umbenennen der zugehörigen *.part.met.BAK in *.part.met der Download wieder hergestellt werden.

Recovery Tools
Der Tools Bereich enthält Links zu einigen Programmen, die zerstörte *.met Dateien wieder herstellen können. Es empfiehlt sich diese Tools nur auf Sicherheitskopien der entsprechenden *.part.met und *.part Dateien anzuwenden, da die Änderungen nicht rückgängig gemacht werden können.

Manuelles Verschieben der Dateien
Unter Umständen wird eine *.part.met derart zerstört, dass sogar fehlerfreie Dateien nicht mehr geladen werden. In diesem Fall kann durch einzelnes Hinzufügen der Downloads die fehlerhafte Datei identifiziert werden.

1. Alle Dateien aus dem Ordner für temporäre Dateien in einen anderen Ordner verschieben
2. Eine Datei-Kombination aus *.part und zugehöriger *.part.met zurück in den temporären Ordner verschieben
3. eMule starten und überprüfen ob die Datei korrekt zu der Downloadliste hinzugefügt wurde
4. eMule beenden
5. Schritte 2. - 4. solange wiederholen bis die defekte(n) Datei(en) gefunden wurden
6. Die defekten Dateien entweder löschen und neu herunterladen oder versuchen diese mit Recovery Tools wiederherzustellen


64

Seltsames Verhalten
21.07.2003 9:11
"Seltsames Verhalten"
Treten Probleme beim Aktualisieren der Serverliste auf oder bleiben Einstellungen nicht erhalten kann dies an falschen Einträgen in den Konfigurationsdatein von eMule liegen. Ein guter Ansatz ist hier eMule zu beenden dann alle Dateien mit den Endungen *.met, *.dat und *.ini zu löschen (nur im Installationsverzeichnis bzw. dem config Ordner von eMule, nicht die temporären Dateien!). Nach dem Neustart von eMule in den Einstellungen alle Optionen neu einrichten und eMule nochmals neu starten.


63

Serververbindung
21.07.2003 9:13
Serververbindung wird nach kurzer Zeit getrennt
Viele Server begrenzen die Zahl der Dateien, die ein Benutzer freigeben darf. Wird dieses Dateilimit überschritten trennt der Server die Verbindung wieder. eMule zeigt die Anzahl der freigegebenen Dateien in seinen Statistiken an. Wird ein Wert von 500 nicht überschritten treten im allgemeinen keine Probleme auf.
Ab v.28 zeigt eMule die Anzahl der Dateien an, die auf einem Server erlaubt sind. Der Soft Limit Wert ist die Anzahl der Dateien, die ein Server als freigegeben annimmt, überzählige werden ignoriert. Der Hard Limit Wert beschreibt die Obergrenze der erlaubten Dateien. Wird diese Anzahl überschritten, trennt der Server die Verbindung automatisch.
Um diese Trennung zu verhindern senden eMule Versionen ab v.29 nur noch die maximal erlaubte Anzahl (Soft Limit) an freigegebenen Dateien an den Server


85

Schnelleinstieg
04.04.2004 8:14
1. | Download und Installation Hier bekommt Ihr die jeweils aktuellsten Versionen von eMule. Ihr könnt wählen zwischen einer .exe-Datei, die ein Installationsprogramm beinhaltet oder einer .zip-Datei, die nur die nötigen Dateien enthält. Wenn Ihr die .exe-Datei wählt, braucht Ihr nur den Anweisungen des Installationsprogrammes zu folgen. Das .zip-Archiv entpackt Ihr einfach in ein neues Verzeichnis Eurer Wahl und erstellt Euch anschließend eine Verknüpfung auf dem Desktop.
 | Anmerkung: Wenn Ihr Windows 98 benutzt, kann es passieren, daß Ihr folgende Fehlermeldung bekommt: "oleacc.dll not found". Diese .dll ist Bestandteil des MS System Updates for Win98.
2. | Einstellungen Nachdem Ihr eMule zum ersten Mal gestartet habt, klickt Ihr oben rechts in der Buttonleiste auf Einstellungen. Hier werden zunächst nur die nötigsten Einstellungen beschrieben, wenn Ihr mehr darüber wissen wollt, schaut bitte in die entsprechenden Rubriken dieser FAQ.
 | - Allgemein
 |  | Name Standardmäßig steht hier http://www.emule-project.net, Ihr könnt dort allerdings jeden beliebigen Nickname eintragen. Bitte nicht einfach den vorgegebenen Namen lassen.
 |  | eMule als Standardprogramm für eD2k-Weblinks festlegen Um eMule dazu zu bewegen, alle mit ed2k:// beginnen Weblinks zu übernehmen, müßt Ihr diesen [image] Button anklicken. Erscheint dieser Button grau, so ist eMule bereits mit diesen Links verknüpft.
 |  | Verbindung Der Menüpunkt Verbindung ist der wichtigste unter allen anderen Einstellungsmöglichkeiten, die eMule bietet. Lest Euch bitte die genaue Beschreibung dazu durch.
 |  | Assistent Wenn Ihr einfach schnell loslegen wollt, dann benutzt den Verbindungsassistenten, der alle wichtigen Einstellungen anhand Eurer Verbindung für Euch vornimmt:
 | o | Betriebssystem
 |  | Zu empfehlen ist ein aktuelles Betriebssystem wie Windows 2000 oder Windows XP. Diese sind wesentlich besser auf die Arbeit in Netzwerken oder dem Internet ausgelegt und ermöglichen eine deutlich größere Anzahl an gleichzeitigen Verbindungen als Windows 98 oder Windows ME.
 | o | Gleichzeitige Downloads
 |  | Diese Einstellung wirkt sich auf die maximal erlaubte Anzahl gefundener Quellen aller Downloads aus. Hier tragt Ihr ein, wie viele Dateien Ihr in etwa später gleichzeitig herunterladen wollt. Anmerkung: Ladet nicht zu viele Dateien auf einmal herunter. Im Statistikbereich sollte die Anzahl gefundener Quellen ca. 3.000 nicht überschreiten. Durch zu viele gefundene Quellen ist eMule nur noch damit beschäftigt, diese Quellen zu überprüfen und nach weiteren Quellen zu fragen. Dadurch könnt Ihr Euch leicht die Leitung für Downloads verstopfen. Wenn Ihr im Transferfenster einen Download aufklappt und Ihr seht neben den einzelnen Quellen nur noch (zu viele Verbindungen), dann habt Ihr mehr Quellen gefunden als Eure Verbindung in der Lage ist, zu bearbeiten. In diesem Fall solltet Ihr Eure max. Quellen je Datei (hard limit) heruntersetzen.
 | o | Internetanbindung
 |  | Hier wählt Ihr aus der Liste den zu Eurer Internetanbindung passenden Punkt aus - achtet dabei unbedingt auf die korrekten Geschwindigkeitsangaben. Wenn für Euch nichts passendes dabei ist, wählt Ihr manuell aus und tragt Eure maximal möglichen Geschwindigkeiten unter Down- und Uploadbandbreite ein. Achtet auf die Unterscheidung zwischen kiloBits/s [kb/s] und kiloBytes/s [kB/s]. Ein Byte entspricht 8 Bits.
 | Um Eure Änderung zu speichern, müsst Ihr auf Übernehmen klicken.
 | - Verzeichnisse Hier können die Verzeichnisse für bereits heruntergeladene Dateien (eingehende Dateien) und die noch im Download befindlichen (temporäre Dateien) eingestellt werden. Auch können hier zusätzliche Verzeichnisse (z.B. mit Dateien, die Ihr tauschen möchtet) freigegeben werden - dazu hakt Ihr das entsprechende Verzeichnis unter freigegebene Dateien an. Wollt Ihr neben diesem Verzeichnis auch noch alle darin befindlichen Unterverzeichnisse freigeben, so haltet beim Anklicken die STRG-Taste gedrückt. Dies funktioniert allerdings nicht bei einer ganzen Partition (Festplatte). Anmerkung: Wenn Ihr von eDonkey zu eMule wechselt oder eine neue eMule Version aufspielt, braucht Ihr unter eingehende und temporäre Dateien nur Euer bereits vorhandenes incoming und temp-Verzeichnis angeben. Nach einem Neustart werden Eure bereits in eDonkey begonnenen Downloads in eMule übernommen und fortgesetzt.
3. | Server
 | Um sich überhaupt mit dem eDonkey-Netzwerk verbinden und Dateien herunterladen zu können, braucht man die so genannten Serverlisten.
 |  | Am einfachsten fügt man diese Serverlisten im Serverfenster unter server.met von URL laden in eMule ein. Siehe auch hier, um mehr darüber zu erfahren.
 |  | Es gibt unzählige Webseiten, die gute Serverlisten bereitstellen, aber für den Anfang kopiert Ihr einfach diese Adresse
 |  | http://ocbmaurice.dyns.net/pl/slist.pl?download/server-good.met
 |  | und fügt sie in die Eingabezeile unter server.met von URL laden ein. Nach einem Klick auf Aktualisieren wird eine server.met mit den aktuellsten Servern heruntergeladen. An dieser Stelle vielen Dank an Maurice, der diesen Service zur Verfügung stellt. Wie viele Server hinzugefügt wurden, seht Ihr im Serverfenster unten im Logbereich.
4. | Verbindung zu einem Server herstellen
 | Nun braucht Ihr nur noch auf den [image] Verbinden-Button oben links im Menü zu klicken, und Ihr werdet mit einem Server verbunden. Wenn es mal etwas länger dauert, bedeutet das nicht, das etwas nicht funktioniert - nicht alle Server sind immer an oder haben die gerade benötigten freien Kapazitäten.
 | Wenn Ihr mit einem Server verbunden seit, sollte die Statusleiste in etwa so aussehen:
 | Wichtig: steht für eine hohe ID. Alles läuft, wie es soll. erscheint bei jedem Verbindungsversuch dieses Icon, so habt Ihr eine niedrige ID und solltet unter ID, Firewall, und Router weiterlesen.
5. | Fertig!
 | Nun könnt Ihr Dateien zu Eurer Downloadliste hinzufügen und mit dem Download beginnen. Dateien findet Ihr über die eingebaute Suchfunktion (sollten zu wenig Suchergebnisse erscheinen, versucht es mal mit globaler Suche), über Suchdienste im Internet oder über die einschlägig bekannten Seiten.
6. | Was gibt es sonst noch?
 | o | eMules Symbole erklärt
 | o | Farben des Fortschrittsbalkens
 | o | QR - Queue Ranking (eigene Position in der Warteschleife eines anderen Clients)
 | o | Wenn Ihr relativ gute Downloadraten erzielen wollt, so achtet darauf, gut verbreitete Dateien mit möglichst vielen Quellen zu laden. Eine Datei mit weniger als 100 Quellen kann man schon als selten bezeichnen, also habt einfach etwas Geduld, wenn es mal nicht ganz so schnell vorwärts geht.
 | o | Erwartet keine extrem hohen Geschwindigkeiten unmittelbar nach dem Start von eMule - es braucht seine Zeit, um genügend Quellen zu finden und sich in den Wartelisten nach vorne zu arbeiten. Je länger eMule läuft, desto besser werden in der Regel auch die Downloadraten.
 | o | Das eDonkey-Netzwerk eignet sich am besten, um große Dateien zu tauschen. Kleinere Dateien, wie z.B. einzelne mp3s, belasten nur unnötig die Server und somit das Netzwerk. Also tauscht bitte möglichst große Files (z.B. mehrere .mp3s als Zip-Archiv) !
 | o | Ihr werdet für das Tauschen belohnt.
Und nun viel Spaß mit eMule!


233

Netzwerkinformation
29.02.2004 20:15

Ab v.42.1 unterstützt eMule zwei unterschiedliche Netzwerke. Das klassische eD2k Netzwerk und eine völlig neue, leistungsfähige Netzstruktur, genannt Kademlia.
Beide Netzwerke erfüllen die gleichen Aufgaben. Die Suche nach anderen Benutzern und nach Dateien. Der eigentliche Download von Dateien findet dann immer direkt zwischen zwei Benutzern statt.

Grundlagen
Dateiidentifikation
Alle Dateien die heruntergeladen werden können besitzen einen so genannten Hash-Wert. Dies ist eine Kombination aus Zahlen und Buchstaben die eine bestimmte Datei eindeutig identifizierbar macht. Ein Download kann unterschiedliche Dateinamen besitzen, dies ändert jedoch nichts an seinem Hash-Wert. Dadurch können Quellen für eine Datei unabhängig von ihrem Namen gefunden werden.
Zusätzlich wird jede Datei in 9,28 MB grosse Blöcke (Parts) unterteilt. Jeder dieser Blöcke erhält auch einen Hash-Wert. Eine z.B. 600 MB grosse Datei besitzt 65 Blöcke mit je einem eigenen Hash. Aus diesen einzelnen Hash-Werten wird dann der im Netzwerk verwendete Datei-Hash erstellt. Dieser Wert findet sich auch in den eD2k Downloadlinks.

Identifikation anderer Benutzer
Ähnlich dem Datei-Hash erhält auch jeder eMule eine eindeutige und einmalige Benutzerkennung. Um Missbrauch dieser Kennung zu verhindern wird diese mit einem speziellen Schlüsselverfahren gesichert.

Dateien herunterladen
Dateien die heruntergeladen werden können liegen immer auf Computern der Netzwerkteilnehmer. Es findet kein Herunterladen von Servern oder ähnlichem statt.
Die Aufgabe des Netzwerks ist es den Kontakt zwischen den Benutzern herzustellen und das Finden von Dateien bzw. Quellen für einen Download zu ermöglichen.
Sind Quellen gefunden wird bei diesen Teilnehmern ein Warteschlangenplatz reserviert. Erreicht eMule den ersten Platz wird eine Verbindung aufgebaut und der Download beginnt.

Das servergestützte eD2k Netz
Zum Netzwerk verbinden
Dieses Netzwerk basiert auf den eD2k Servern. Jeder Teilnehmer muss sich zu solch einem Server verbinden. Verbindet sich eMule zu einem Server, überprüft dieser ob eine freie Verbindung zu eMule möglich ist. Kann der Server eMule direkt auf seinem Client Port ansprechen bekommt er eine hohe ID wenn nicht eine niedrige.
Ist die Verbindungsprüfung beendet, sendet eMule dem Server eine Liste mit allen seinen freigegeben Dateien und den zugehörigen Hash-Werten. Der Server speichert diese Informationen in einer Datenbank zusammen mit denen anderer verbundener Teilnehmer.

Suche nach Dateien
Ist die Verbindung hergestellt, kann das Netzwerk nach bestimmten Schlüsselworten durchsucht werden. Es wird zwischen einer lokalen Suche, also nur auf dem verbundenen Server und der globalen Suche auf allen Servern in der Serverliste unterschieden. Eine lokale Suche ist schneller, hat aber unter Umständen weniger Treffer.
Bei jeder Suche werden die eingegebenen Schlüsselwörter an den Server gesandt und dieser vergleicht dann ob es eine Übereinstimmung mit Namen in seiner Datenbank gibt. Die Treffer werden zusammen mit ihren Hash-Werten als Ergebnis zurückgegeben.

Quellensuche für Downloads
Downloads können entweder direkt über die Suche oder über das spezielle eD2k Link Format zu eMule hinzugefügt werden.
Sind die Downloads in der Transferliste fragt eMule erst beim lokalen Server und dann auch bei allen Servern in der Serverliste nach Quellen zu diesem Download. Der Server überprüft an Hand des Hash-Wertes ob Teilnehmer zu ihm verbunden sind, die mindestens ein Block (9,28 MB) dieser Datei fertig heruntergeladen haben, wenn ja werden diese als Quellen für den betreffenden Download zurückgegeben.

Das serverlose Kademlia Netzwerk
Verbindung zum Netzwerk
Um eine Verbindung zu diesem Netzwerk aufzubauen, muss die IP Adresse und der Kademlia Port eines anderen bereits verbundenen eMule bekannt sein. Ist dieser gefunden wird, ähnlich der ID Vergabe bei den Servern, überprüft ob eine freie Verbindung zu dem neuen Teilnehmer möglich ist. Ist die möglich bekommt eMule eine Kademlia ID und erhält den Status "offen". Benutzer hinter einer Firewall oder einem Router werden zurzeit noch nicht unterstützt und erhalten den Status "firewalled". Diese müssen sich zu einem klassischen Server verbinden.

Suchen in Kademlia
In diesem Netzwerk ist es praktisch egal wonach gesucht wird. Suchen nach anderen Benutzern, nach Schlüsselworten oder nach Quellen werden gleich behandelt.
Da es keine Server gibt, die die Teilnehmer und deren freigegebenen Dateien verwalten, müssen diese Aufgaben von den eMules im Netzwerk selbst übernommen werden. Jeder verbundene eMule arbeitet also auch als Server für das Kademlianetz.
Jeder Benutzer bekommt an Hand seiner einmaligen Benutzerkennung ein Aufgabe zugewiesen. Diese besteht im Verwalten von bestimmten Schlüsselworten zur Suche und bestimmten Quellen für Downloads. Welche das sind hängt von seiner Kennung ab und ist nicht vorherseh- oder anzeigbar.
Das Ziel jeder Suche in diesem Netzwerk ist es also, diejenigen Teilnehmer zu finden, die die passenden Antworten auf die gestellte Anfrage haben. Dies wird erreicht in dem eine "Entfernung" zu diesem Ziel errechnet wird und andere bekannte Teilnehmer nach dem kürzesten Weg dorthin gefragt werden. Einen Eindruck dieser Entfernungsberechnung gibt die Anzahl der Nullen bei den Kontakten im Kademliafenster. Je mehr Nullen am Anfang desto "näher" befindet sich dieser Kontakt zum eigenen eMule.

Zusammenfassung
Beide Netzwerke verfolgen einen gänzlich unterschiedlichen Ansatz mit dem selben Ziel: Suchen nach Downloads und Suchen nach Quellen für diese Downloads.
Der Vorteil von Kademlia liegt in der Unabhängigkeit von Servern und der besseren Verwaltung vieler Netzteilnehmer. Server können nur eine begrenzte Anzahl von Benutzern verwalten und sollte ein grosser Server ausfallen hat dies schwere Auswirkungen auf das gesamte Netz.
Das Kademlianetz organisiert sich selbst und stellt sich automatisch auf die Anzahl der Benutzer und deren Leitungsqualität ein. Damit ist es besser gegen ausgedehnte Netzausfälle geschützt

Aktualisiert: 2004-02-27 , Monk


68

Tools
02.05.2004 16:37
eMule Programme & Tools
MetMedic | Umfassende .met Manipulationen und Wiederherstellung
DonkeyDoctor | Recovery Tool. Leicht zu bedienen
eD2k RecoverMET | Kommandozeilen Tool für .part.met Wiederherstellung (eD2k Link)
eD2k Link Killer | Entfernt ungültige eD2k Web Link Einträge in der Windows Registry.

Sonstiges:
Verbindungstest | Testscript von TheDonkeyNetwork , um Ports zu überprüfen
Online Signature | Signaturbilder mit Daten aus der onlinesig.dat versehen. Siehe auch: Online Signature
Neue Online Signatur | Weiterentwicklung des obigen Programms
FlatRate Steckdose | Automatische Wiedereinwahl nach Verbindungstrennung.
FlatRate Manager | Software zur Wiedereinwahl mit vielen Funktionen. Dank an Mario für diesen Tip
AutoDialRun | Auch ein Verbindungstool. Macht einen guten Eindruck. Tip von LordOfTheRings
VideoLAN Client | Alternativer Player für die Multimedia Vorschau. Siehe auch: Einstellungen -> Verzeichnisse
RASPPPOE | Alternativer PPPOE (DSL) Treiber von Robert Schlabbach
WinSockFix | Stellt durch den mod1.x zerstörte Winsock dlls wieder her
LSPFix | Stellt durch den mod1.x zerstörte Winsock dlls wieder her

Kennt Ihr noch andere gute Tools, die hier noch fehlen? Schickt eine kurze Email an Monk@emule-project.net und sie werden hier eingefügt.

Letzte Aktualisierung: 2004-03-20 by Monk