
Introduction 
 
Loutext permet de créer des textures, à savoir un dessin qui peut se juxtaposer à lui-
même sans qu’aucune “rupture” ne soit visible. 
 
Chaque mois, une nouvelle version sera disponible. Ces nouvelles versions peuvent être 
enrichies grâce à vos remarques et idées. 
 
Si vous avez besoin d’aide, si vous avez des idées d’améliorations ou des remarques à 
faire, n’hésitez pas à m’envoyer un email : 
 
luc.helie@wanadoo.fr 
 
LouText 0.4 est un GratosWare dont les textures peuvent être utilisées librement. 
 
 
Nouveautés Version 0.4 (Avril 2004) 
 
REMARQUE !!! La structure d’un fichier preset ainsi que la place des paramètres 
ont changé en version 0.4. Pour pouvoir utiliser vos anciens presets vous devez 
d’abord utiliser le programme PCStruct04.exe pour convertir la structure, puis 
utiliser le programme PCPrmtr04.exe pour changer la place des paramètres. Si vous 
avez un quelconque problème pour convertir vos anciens presets n’hésitez pas à 
m’envoyer un email …. 
 
OOPS !!! Je n’avais pas précisé que le module “Perlin Noise” de la version 0.3 ne 
produit pas de textures juxtaposables. Tous les modules comme le module “Perlin 
Noise” ou le module “Chaotic functions” qui ne produisent pas de textures 
juxtaposables apparaîtront en rouge dans la liste des modules. 



Nouveaux modules 
 
Functions>Chaotic Functions 
 

Les fonctions chaotiques produisent des images en nuances de gris qui au sens strict 
ne sont pas des textures (leurs descriptions apparaissent donc en rouge dans la liste 
des modules). Il est difficile de décrire ces fonctions dont les résultats, par nature, 
peuvent beaucoup varier en fonction des paramètres de départ. 

 
 
Functions>Shapes>Filled>Circles 

 
Génére des cercles de couleur variable et disposant d’un dégradé en luminosité et en 
saturation. 
 

 
Filters>Color Replacer>Gradient Fill 
 
 

"Gradient Fill" permet de remplacer une séquence de pixels ayant la même couleur par un dégradé. 
 
 
Filters>Color Replacer 
 

Les 2 filtres de remplacement de couleur “ Color Replacer ” et “ Replace Null Color ” ont été déplacés 
dans le menu “ Filters>Color Replacer ”. 

 
 
Effects>Emboss 
 

" Emboss" permet d’obtenir l’effet photographique de bas relief qui consiste à 
superposer avec un léger décalage une image et son propre négatif. 

 
Effects>Grey Scale Colorize>Colorize 1 
 

Le module “ Colorize 1 ” permet de colorer les modules produisant une image en 
nuance de gris. 

  



Effects>Offset Effects 
 

" Offset Effects" calcule pour chaque pixel une nouvelle valeur qui est basée sur le 
pixel lui même (coordonnées x,y) et un autre pixel dont les coordonnées sont X + 
‘Width Effect’ et Y + ‘Height Effect’. La version 0.4 comprend 5 algorithmes. 

 
 
Effects>Outline 
 

" Outline" fait apparaître un contour lumineux autour de certaines zones de l’image. 
L’effet est plus évident sur des images disposant de zones importantes ayant la 
même couleur. 

 
 
Adjust>Ligthness/Darkness 

 
 
Adjust>Levelling>HSL 
Adjust>Levelling>RGB 
 

“ Levelling ” permet de niveller chacun des canaux HSL ou RGB. 
 
Geometric>Shuffle 
 

Le module " Shuffle" intervertit des paires de pixels de façon aléatoire. 
  
 



Remarques générales 
 
 
Définition des couleurs 
 
Il existe en informatique différents moyens d’exprimer une couleur. LouText utilise deux 
d’entres eux : le mode RGB et le mode HSL.  
 
Le mode RGB consiste à “ mélanger ” du rouge (Red), du vert (Green) et du bleu (Blue) 
pour obtenir une couleur. La quantité de chacune de ces couleurs peut varier de 0 à 
255. 
 
Le mode HSL définit une couleur pas sa teinte (Hue), sa saturation et sa luminosité. La 
teinte peut varier de 0 à 359, la saturation de 0 à 255 et la luminosité de 0 à 255. 
 
Utilisation des modes RGB et HSL 
 
Vous pouvez mélanger dans LouText des modules utilisant le mode RGB à des modules 
utilisant le mode HSL. Module après module LouText conserve l’état de votre texture en 
RGB et en HSL. Cela étant, la convertion d’une couleur du mode HSL au mode RGB puis 
au mode HSL ne garantit pas le retour aux valeurs d’origine. Il est donc conseillé de 
rester homogène dans l’utilisation de l’un de ces modes. 
 
Saisie des paramètres 
 
Dans de nombreux modules vous aurez à définir pour un paramètre, une valeur 
minimale et une valeur maximale. Lors de la saisie LouText ne vérifie pas si la valeur 
minimale est ou non supérieure à la valeur maximale. Par contre, lors de la création de 
la texture, si LouText détecte une valeur minimale supérieure à une valeur maximale, il 
inverse ces deux valeurs avant de s’en servir. 



La forme principale 
 
 
La forme principale est constituée d’un menu et d’un espace de travail destiné aux 
formes “Image”. Les formes “Image” vous permettent de visualiser le résultat du calcul 
d’une texture. Vous pouvez créer plusieurs formes “Image” (Image>New), la forme 
active sera utilisée pour l’affichage de la texture courante. 
 

Le menu de la forme principale 
 

Image  
 

New Permet la création d’une nouvelle forme “Image” d’une taille quelconque 
et limitée à 1024 x 1024 pixels. 

 
Save Sauvegarde l’image active dans un fichier au format bmp. 
 
BMP Format Permet de choisir une profondeur de couleur entre 8, 16, 24 

et 32 bits. 
 

Texture 
 

New Ouvre la forme “Texture” et crée une nouvelle texture. 
 
Load Charge une texture à partir d’un fichier de texture (extension 

.lou) et ouvre la forme “Texture” 
 
Save Enregistre la texture courante dans un fichier de texture 

(extension .lou) 



La forme “Texture” 
 

La forme “Texture” permet de définir une texture par la combinaison de “modules” (200 
maximum). La forme “Texture” est composée d’un menu et de 4 panneaux de 
paramètres : “ Parameters ”, “ Colors ”, “ Modules ” et “ Blending ”.  
 
Le panneau “Modules” est constitué d’une liste de modules qui sont traités en haut en 
bas pour créer une texture. 
 
Les panneaux “Parameters” et “Colors” définissent les paramètres du module courant 
qui est identifié par une pastille beige dans la seconde colonne. Pour se déplacer d’un 
module à un autre il suffit de cliquer sur le nom du module. 
 
Le panneau “Blending” définit comment le module courant et le résultat obtenu au 
module précédent sont mélangés. 
 
En dessous du panneau “ Blending ” vous disposez de 5 boutons : 
 

Process   
Calcul de la texture du premier module jusqu’au module courant 

Fleche Haute/ Fleche Basse  
Déplace le module courant vers le haut ou vers le bas  

Activ  
Définit si le module courant est actif 

Remove   
Détruit le module courant 

 
Le menu de la forme “Texture” 

 
Les menus “Textures”, “Functions”, “Filters”, “Adjust”, “Geometric”, “Buffers” et 
“Layers”  permettent d’ajouter de nouveaux modules à la liste. Le menu “Color 
Channels” définit le canal (HSL or RGB) qui sera affiché dans la forme “Image”. 
 
Remarque : La fonction “Buffers>Move to buffer” permet de sauver l’état courant 
d’une texture dans une zone tampon et de rappeler ultérieurement cet état par la 
fonction “Buffers>Recall buffer”. Typiquement, cela permet de créer plusieurs 
textures puis de les mixer. Vous disposez de 3 zones tampon. 
 

Le panneau “Parameters” 
 

Chaque paramètre peut être défini par un “Scrolling Bar” ou une “ComboBox”. 
Vous pouvez aussi saisir directement une valeur numérique dans le champ situé à 
droite d’un “Scrolling Bar”. 



Le panneau “Colors” 
 

Certains modules nécessite des paramètres de type couleur (background, 
foreground …). Vous pouvez introduire ces paramètres dans le panneau “Colors”. 
Pour modifier une couleur cliquez sur cette couleur, cela ouvre une forme 
permettant la définition d’une couleur. 

 
Le panneau “Modules” 

 
Le panneau “Modules” est constitué de 3 colonnes. La première indique le nom du 
module. La seconde indique le module courant par un ‘X’. La troisième colonne. La 
troisième colonne spécifie si le module est actif ou pas. 
 

Le panneau “Blending” 
 
Le panneau “Blending” définit comment le module courant et le résultat du module 
précédent sont mélangés. Chaque canal (HSL ou RGB) peut avoir un paramètre 
différent de mélange qui est accessible par l’une des trois ComboBox (Red/Hue, 
Green/Saturation and Blue/Luminosity). Le bouton “Randomize” génére un choix 
aléatoire de paramètres de mélange pour les 3 canaux. 
 
La Combobox “Mode” Définit si le mélange est fait sur les canaux HSL ou RGB. 
 
Les ScrollBars “Result Laye” et “Current Layer” définissent l’opacité du module 
courant et du résultat du module précédent. 
 
Si la couleur de transparence est appliquée, tous les pixels de la couche courante 
correspondant à la couleur de transparence seront remplacés par la couche 
résultat, sans fonction de mélange. 
 
 
Le bouton “Rand. Blend.” génére un choix aléatoire de paramètres de mélange 
pour les 3 canaux de l’ensemble des modules. 
 
Le bouton “Rand. Opacity” génére un choix aléatoire de paramères d’opacité pour 
l’ensemble des modules. 
 
Le bouton “Rand. All” cumule la fonction des boutons “Rand. Blend.” et “Rand. 
Opacity”.   
 
Les 3 boutons “Rand. Blend.”, “Rand. Opacity” et “Rand. All” lancent 
automatiquement le calcul de la texture. 



Les menus de la forme “ Texture ” 
 
 
Functions 

 
Chaotic Functions 

 
Les fonctions chaotiques “ Fx 2 A” à “ Fx 2 F ” disposent des mêmes 
paramètres. Ces fonctions  produisent des images en nuances de gris qui au 
sens strict ne sont pas des textures. 
 
 
Remarque : 

 
Les valeurs par défaut des paramètres ‘Details’ et ‘Luminosity’ sont 
optimisées pour des images de 512 par 512 pixels.  

 
Paramètres : 
 

‘Width Effect 1’ / ‘Height Effect 1’  
Paramètre 1 des fonctions chaotiques (effet en largeur et en hauteur). 

 
‘Width Effect 2’ / ‘Height Effect 2’  

Paramètre 2 des fonctions chaotiques (effet en largeur et en hauteur). 
 

‘Details’ 
Niveau de détail de l’image finale. Attention, plus la valeur de ce paramètre est élevée, 
plus le temps de calcul est long tout en ne donnant pas forcément un meilleur résultat. 
Cela dépend des paramètres de la fonction. 

 
‘Luminosity’  

Niveau de luminosité de l’image finale.  
 

‘Random seed’  
Valeur initiale du générateur de nombres aléatoires. 

 
‘Width – Left Offset’ / ‘Width – Right Offset’ 
‘Height – Top Offset’ / ‘Height – Bottom Offset’  

Ce paramètres définissent le rectangle dans lequel s’inscrira la fonction chaotique. 



Noise 
Permet de créer une texture de points dont les couleurs sont aléatoires. Le bruit 
peut être contrôlé en limitant la plage de valeurs de chacun des canaux par les 
paramètres min et max. Le paramètre “ rate ” définit le pourcentage de point 
qui seront ainsi initialisés. Les points non initialisés seront de la couleur définie 
par le paramètre de couleur “ BckGrnd ”. 
 

Perlin Noise 
 

"Perlin Noise" génère une image en nuance de gris à partir d'un bruit de Perlin 
définissable par 6 fréquences. 
Le résultat final est le cumul des 6 fréquences chacune étant pondérée par son 
amplitude. Les fréquences dont le paramètre "Frequency" (ou le paramètre 
"Amplitude") est égal à 0 ne sont pas prises en compte. 
  
Les canaux R,G et B contiennent des valeurs égales comprises entre 0 et 255 et 
définissant un niveau de gris. En mode HSL, le canal L (Luminosité) contient les 
valeurs de la fonction, la saturation ainsi que la teinte sont à 0. 
 
Paramètres : 
 
'Frequency' :  Rapidité à laquelle les variations de gris s'effectuent.  
 
'Amplitude' :  Poids de la fréquence. 
 
'Scale' :  Echelle des valeurs en X et Y. Les valeurs par défaut sont 1,2,3,4 .... 

"Scale" sert de diviseur pour obtenir des valeurs plus fines, par exemple 
pour "Scale" = 5 on obtient : 0.2, 0.4, 0.6, 0.8 .... "Scale" peut-être aussi 
vu comme un paramètre de Zoom. 

 
'Random Seed' Valeur initiale du générateur de nombre aléatoire 

 
Periodic Functions 

La valeur des canaux (H,S,L ou R,G,B) est obtenue à partir des valeurs d’une 
fonction périodique (Sinus, Triangle, Dent de Scie, Carré). 



Shapes>Wire>HSL Variations>Polygons 
 

"Polygons" génère des polygones irréguliers dont les contours peuvent varier en 
teinte, saturation et luminosité. 

 
Paramètres : 
 
'Occurences' Nombre de lignes 
'Hue Range' Plage des teintes (+ ou - la teinte de la couleur 

'Foreground') 
'Hue Step'  Vitesse de variation de la teinte lors du dessin d'une ligne 
'Saturation Range' Plage des saturations (+ ou - la saturation de la couleur 

'Foreground')  
'Saturation Step'    Vitesse de variation de la saturation lors du dessin d'une 

ligne 
'Luminosity Range'   Plage des luminosités (+ ou - la luminosité de la couleur 

'Foreground')       
'Luminosity Step'     Vitesse de variation de la luminosité lors du dessin d'une 

ligne 
'Minimum Length'   Longueur minimum d'une ligne 
'Random Seed'     Valeur initiale du générateur de nombres aléatoires 
 
'Background color' Couleur d'arrière plan 
'Foreground color' Couleur de base des contours de polygones 
 

Shapes>Wire>HSL Variations>Rectangles 
 

"Shapes>Wire>HSL Variations>Rectangles" génère des rectangles en fil de fer 
dont les contours peuvent varier en teinte, saturation et luminosité. 

 
Paramètres : 
 
'Width Min' Largeur minimum des rectangles 
'Width Max' Largeur maximum des rectangles 
'Height Min' Hauteur minimum des rectangles 
'Height Max' Hauteur maximum des rectangles 
'Occurences' Nombre de rectangles 
'Hue Range' Plage des teintes (+ ou - la teinte de la couleur 

'Foreground') 
'Hue Step'  Vitesse de variation de la teinte lors du dessin d'une 

ligne 



'Saturation Range' Plage des saturations (+ ou - la saturation de la 
couleur 'Foreground')  

'Saturation Step'    Vitesse de variation de la saturation lors du dessin 
d'une ligne 

'Luminosity Range'    Plage des luminosités (+ ou - la luminosité de la 
couleur 'Foreground')       

'Luminosity Step'      Vitesse de variation de la luminosité lors du dessin 
d'une ligne 

'Random Seed'     Valeur initiale du générateur de nombres aléatoires 
 
'Background color' Couleur d'arrière plan 
'Foreground color' Couleur de base des contours de rectangles 
 

Shapes>Wire>Monochrome>Rectangles 
 

Génére des rectangles en fil de fer dont le contour est monochrome. 
 

Paramètres : 
 
'Width Min' Largeur minimum des rectangles 
'Width Max' Largeur maximum des rectangles 
'Height Min' Hauteur minimum des rectangles 
'Height Max'  Hauteur maximum des rectangles 
'Hue Min' Teinte minimum 
'Hue Max' Teinte maximum 
'Saturation Min' Saturation minimum 
'Saturation Max' Saturation maximum 
'Luminosity Min' Luminosité minimum 
'Luminosity Max' Luminosité maximum 
'Occurences' Nombre de rectangles 
'Random Seed'     Valeur initiale du générateur de nombres aléatoires 

 
'Background color' Couleur d'arrière plan 



Shapes>Filled>Rectangles 
 

"Shapes>Filled>Rectangles" génére des rectangles pleins avec des variations de 
saturation et de luminosité. 

 
Paramètres : 
 

'Width Min' Largeur minimum des rectangles 
'Width Max' Largeur maximum des rectangles 
'Height Min' Hauteur minimum des rectangles 
'Height Max' Hauteur maximum des rectangles 
'Hue Min' Teinte minimum 
'Hue Max' Teinte maximum 
'Saturation Min' Saturation minimum 
'Saturation Max' Saturation maximum 
'Luminosity Min' Luminosité minimum 
'Luminosity Max' Luminosité maximum 
'Occurences' Nombre de rectangles 
'Luminosity Gradient Mode' Orientation des dégradés 
'Saturation Gradient Mode' Orientation des dégradés 
'Random Seed'     Valeur initiale du générateur de nombres 

aléatoires 
 
'Background color' Couleur d'arrière plan 
 

 
Shapes>Filled>Circles 

 
Génére des cercles de couleur variable et disposant d’un dégradé en luminosité 
et en saturation. 

 
Paramètres : 

 
 
‘Radius Min’ / ‘Radius Max’   

Le rayon du cercle est généré aléatoirement entre les valeurs ‘Radius Min’ et 
‘Radius Max’. 

 
‘Thickness Min’ / ‘Thickness Max’  

L’épaisseur du cercle est générée aléatoirement entre les valeurs ‘Thickness 
Min’ et ‘Thickness Max’. 

  
'Hue Min' / 'Hue Max'  

La teinte du cercle est générée aléatoirement entre les valeurs ‘Hue Min’ et ‘Hue Max’. 
 



'Saturation Min' / 'Saturation Max'  
La saturation du cercle est générée aléatoirement entre les valeurs 
‘Saturation Min’ et ‘Saturation Max’. 

 
'Luminosity Min' / 'Luminosity Max'  

La luminosité du cercle est générée aléatoirement entre les valeurs 
'Luminosity Min' et 'Luminosity Max’. 

 
‘Occurences’ Nombre de cercles. 

 
‘Luminosity Gradient Mode’ Orientation du dégradé de la luminosité. 

 
‘Saturation Gradient Mode’ Orientation du dégradé de la saturation. 

 
‘Random seed’ Valeur initiale du générateur de nombre 

aléatoires. 
 

'Background color' Couleur d'arrière plan 
 

 
Twigs 

Permet de créer des “ brindilles ” dont les paramètres sont la longueur, 
l’orientation, la variation en teinte, saturation et luminosité. 
 



Filters 
 
 

Matrix Filters 
 

Remplace chaque pixel par une valeur issue d’une matrice centrée sur le pixel, 
par exemple la moyenne des points de cette matrice (Average). Si le paramètre 
“ Matrix Size ” est égal à 1,  la matrice sera de 3 x 3 pixels, de 5 x 5 pour une 
valeur de 2, de 7 x 7 pour une valeur de 3, de 9 x 9 pour une valeur de 4 et de 
11 x 11 pour une valeur de 5. Plus ce paramètre est grand, plus le temps de 
calcul est important. Pour une valeur de 5, chaque point est calculé à partir des 
120 points qui l’entourent. Pour une image de 512 x 512, cela signifie 
31.457.280 calculs élémentaires !!! 
 
 

Conditional Average 
 

Remplace la valeur d’un canal par la moyenne des points de la matrice 
entourant ce pixel. Ce remplacement est effectué si l’écart entre la valeur et la 
moyenne est supérieur au paramètre “ offset ”. La taille de la matrice est 
dépendante du paramètre “ Effect ” qui en fait équivalent au paramètre “ Matrix 
size ” du filtre “ Matrix Filter ”. 

 
 

Invert 
 

Permet d’inverser un ou plusieurs des canaux H,S et L (ou R,G et B) de chaque 
pixel en fonction d’une condiition qui limite les pixels qui seront inversés. 
L’inversion d’un canal consiste à prendre le complément à la valeur maximum 
du canal (255 pour les canaux S,L,R,G et B et 359 pour le canal H). En résumé : 
nouvelle valeur = 255 (ou 359) – valeur courante. L’inversion sans condition des 
3 canaux R,G et B aboutit à une image négative de la texture.  L’inversion d’un 
pixel est effectué si les valeurs courantes de H, de S et de L du pixel sont dans 
les plages définies par les paramètres min et max de chacun des canaux. Les 3 
valeurs doivent appartenir aux plages si la condition est “ and ” ou une seule 
des valeurs si la condition est “ or ”. 



Color Replacer>Gradient Fill 
 
 

"Gradient Fill" permet de remplacer une séquence de pixels ayant la même couleur par un 
dégradé commençant à la valeur du pixel précédent le premier pixel de la séquence et se 
terminant par la valeur du premier pixel suivant la séquence. Par exemple, si une ligne est 
constituée des valeurs : 

 
… 189 120 140 140 140 140 140 140 140 140 210 156 … 
 

Si la couleur à remplacer a une valeur de 140, l’algorithme du module “ Gradient Fill ” donnera 
le résultat suivant : 

 
… 189 120 130 140 150 160 170 180 190 200 210 156 … 

 
Paramètres : 
 

‘Algorithm’  Le seul algorithme disponible en version 0.4 est : “ Linear 
Morphing ” 

 
‘Orientation’ Quatres orientations sont disponibles (Horizontale, 

Verticale et les 2 diagonales) 
 
 
Color Replacer>Simple Color Replacer 
 

Permet de remplacer une couleur (paramètre de couleur “ Color ”) par une autre 
couleur (paramètre de couleur “ Replaced by ”). La couleur à remplacer est 
définie par la couleur de base plus une tolérance paramétrable sur chacun des 3 
canaux. 



Color Replacer>Replace Null Color>HSL 
Color Replacer>Replace Null Color>RGB 
 

Permet de remplacer une couleur (paramètre de couleur “ Null Color ”) par des 
variations dépendantes des autres couleurs, de l'algorithme choisi et des plages 
variations aléatoires autorisées pour les canaux H,S et L (ou R,G et B). 
 
'Negative Hue Variation'  plage de variation aléatoire de la teinte par 

rapport à la valeur calculée    
'Positive Hue Variation'  
'Negative Saturation Variation'  plage de variation aléatoire de la saturation par 

rapport à la valeur calculée  
'Positive Saturation Variation'  
'Negative Luminosity Variation'  plage de variation aléatoire de la luminosité 

par rapport à la valeur calculée  
'Positive Luminosity Variation'  
'Algorithm' : 2 algorithmes sont disponibles 
'Random seed' : Valeur initiale du générateur de nombres 

aléatoires 
'Null Color' : Couleur à remplacer 

 
 
Shapes>Rectangular Tiles 
 

"Rectangular Tiles"  permet la création de tuiles rectangulaires en modifiant le 
dernier module calculé. 
 
Paramètres : 
 
'Width Period'    Nombre de tuiles dans le sens de la largeur 
'Height Period'    Nombre de tuiles dans le sens de la hauteur 
'Thickness'    Epaisseur de la bordure 
'Luminosity'    La bordure est créée par une variation de la 

luminosité. Le paramètre 'Luminosity' est le point de 
départ de cette variation qui sera plus ou moins 
rapide en fonction du paramètre 'Luminosity 
Variation'. 

'Luminosity Variation'    Voir ci-dessus. 
'Tile Orientation'   4 orientations sont disponibles dans la ComboBox. 
'Luminosity Orientation'    Indique si la variation de luminosité est positive ou 

négative. 



Transfer Functions>Sine Fx 
 

Les fonctions de transfert calculent la valeur d'une fonction à partir de la valeur 
de chaque pixel sur un plusieurs canaux au choix. La valeur calculée remplace la 
valeur du pixel. 

  
Paramètres : 

 
'Channels' RGB ou HSL 
'Apply to Red / Hue' Filtre appliqué ou non au canal 'Red' (ou 'Hue' 

selon le choix du paramètre 'Channels') 
'Apply to Green / Saturation' Filtre appliqué ou non au canal 'Green' (ou 

'Saturation' selon le choix du paramètre 
'Channels') 

'Apply to Blue / Luminosity' Filtre appliqué ou non au canal 'Blue' (ou 
'Luminosity' selon le choix du paramètre 
'Channels') 

'Algorithm' 3 algorithmes basés sur des fonctions 
sinusoïdales 

'Parameter 1' Paramètre 1 de la fonction sinusoïdale 
'Parameter 2' Paramètre 2 de la fonction sinusoïdale 



Effects 
 

Emboss 
 

" Emboss" permet d’obtenir l’effet photographique de bas relief qui consiste à 
superposer avec un léger décalage une image et son propre négatif. 
 
Paramètres : 
 

‘Width effect’ Décalage dans le sens de la largeur 
‘Height effect’ Décalage dans le sens de la hauteur 
 
‘Stretch' Redistribue les valeurs des canaux RGB entre 0 et 255. 
 

 
Grey Scale Colorize>Colorize 1 

 
Le module “ Colorize 1 ” permet de coloriser les modules produisant une image 
en nuance de gris. Les algorithmes de ce module sont basés sur le canal 
luminosité du module à modifier. 
 
Remarque : 

 
Selon la valeur du paramètre ‘Base color’, différentes valeurs des paramètres 
“ variant ” peuvent donner le même résultat. 

  
 

Offset Effects 
 

" Offset Effects" calcule pour chaque pixel une nouvelle valeur qui est basée sur 
le pixel lui même (coordonnées x,y) et un autre pixel dont les coordonnées sont 
X + ‘Width Effect’ et Y + ‘Height Effect’. La version 0.4 comprend 5 algorithmes. 

 
 

Outline 
 

" Outline" fait apparaître un contour lumineux autour de certaines zones de 
l’image. L’effet est plus évident sur des images disposant de zones importantes 
ayant la même couleur. 

 



Adjust 
 

Contrast  
Permet d’augmenter ou de diminuer le contraste de la texture. 
 

Color Balance 
Modifie les couleurs par une balance entre le Cyan et le Rouge, le Magenta et le 
Vert, le Jaune et le Bleu.  

 
Levels 

Permet de répartir les valeurs de chaque canal (H, S et L ou R, G et B) entre 
une valeur minimum et une valeur maximum.  
 

 
 

Levelling>HSL ou RGB 
“ Levelling ” permet de remplacer pour chaque canal (RGB ou HSL) les valeurs 
qui sont supérieures à “ High value ” par “ High Value ”. “ Levelling ” permet 
aussi le remplacement des valeurs qui sont inférieures à “ Low value ” par “ Low 
Value ”. Après ce remplacement “ Levelling ” permet de redistribuer les valeurs 
(“ Strech ” = ‘yes’) entre 0 et 255 (ou 359 pour la teinte). 

 
 

Ligthness/Darkness 
Les valeurs négatives du paramètre “ Amount ” permettent de régler 
l’assombrissement de l’image, les paramètres positifs réglent la clarté. 

 



Geometric 
 

Mirror Effectue un miroir horizontal de la texture. 
 
Flip Effectue un miroir vertical de la texture. 
 
Offset Décale la texture en largeur et/ou en hauteur du nombre de 

pixels précisés.  
 
Shuffle 

 
Le module " Shuffle" intervertit des paires de pixels de façon aléatoire. Il est 
possible de limiter les inversions en fonction de deux critères : 
 
- La distance entre les deux pixels. 
- La différence de valeur pour chacun des 3 canaux des 2 pixels. 

 
 

Paramètres : 
 

'Apply To'  
Contrôle des inversions à partir des canaux HSL ou RGB 

 
'Hue/Red max diff'  

Les pixels dont la différence des canaux “ Hue ” (ou “ Red ”) est supérieure 
à ce paramètre ne sont pas intervertis. 

 
'Saturation/Green max diff'  

Les pixels dont la différence des canaux “ Saturation ” (ou “ Green”) est supérieure à ce 
paramètre ne sont pas intervertis. 

 
'Luminosity/Blue max diff'  

Les pixels dont la différence des canaux “ Luminosity” (ou “ Blue”) est 
supérieure à ce paramètre ne sont pas intervertis. 

 
'Width min distance'  
'Width max distance'  
'Height min distance' 
'Height max distance'  

Ces paramètres permettent de contrôler la distance minimale et maximale 
entre les pixels à intervertir.  

 
'Occurences'  

Nombre d’inversions 
 



'Random Seed'  
Valeur initiale du générateur de nombres aléatoires. 

 
 

Buffers 
 

Move to Buffer Sauvegarde de l’état courant d’une texture dans l’une des 3 
zones tampon. 

 
Recall Buffer Rappel d’une texture sauvegardée dans l’une des trois zones 

tampons. 
 

Layers 
 
Invert Channels Permet d’inverser pour l’ensemble des pixels de la texture, un 

canal avec un autre.  
 
Move Channels Permet de remplacer pour l’ensemble des pixels de la texture, 

un canal par un autre. 
 

Color Channels 
 

Le menu “Color Channels” définit le canal (H, S ou L or R, G ou B) qui sera affiché 
dans la forme “Image”. 
 

 


	Functions>Shapes>Filled>Circles
	Filters>Color Replacer>Gradient Fill
	
	
	
	
	
	
	Chaotic Functions
	‘Width Effect 1’ / ‘Height Effect 1’
	‘Width Effect 2’ / ‘Height Effect 2’








	‘Details’
	Niveau de détail de l’image finale. Attention, p�
	‘Luminosity’
	Niveau de luminosité de l’image finale.
	
	
	
	
	
	
	
	‘Random seed’






	'Hue Min'Teinte minimum
	'Hue Max'Teinte maximum
	'Width Min'Largeur minimum des rectangles
	'Saturation Gradient Mode'Orientation des dégrad�



	Shapes>Filled>Circles

	‘Occurences’Nombre de cercles.
	‘Luminosity Gradient Mode’Orientation du dégradé
	‘Saturation Gradient Mode’Orientation du dégradé
	
	
	
	'Channels'RGB ou HSL
	
	
	
	'Luminosity/Blue max diff'
	'Random Seed'









