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Introduction

Anim8or is a 3D computer animation program that is designed to allow straightforward 
creation of animations.    You interactively create and edit objects, figures, and scenes 
directly on the computers screen. The basic interface is similar to most 3D animation and 
CAD programs, as shown in the following screen shot:

You control various aspects of your work using an ordinary computer mouse or tablet. You 
select and drag, rotate, scale and place objects by clicking in the various views of your 
work.    There are two toolbars that you can use for common tasks. The one at the top of the
has buttons for general commands that are used throughout Anim8or, while the one on the 
left allows you to change your mode of operation for common tasks in the current that you 
are using. The usual menu is there for less frequently used tasks.
 
You can control the view of your objects to see how they appear from the front, side, top, 
perspective, etc., and you can show either multiple views or a single view on your screen.
 
There are four main working modes, and an object-browsing mode. First, there is an object 
editor that is used to build (mostly) static objects.
 
Second, there is a figure or character editor. You use it to define the structure of a character
that you want to animate by connecting jointed bones together, and objects to them. You 
can give each joint different ways in which they are allowed to move and restrict the range, 
just like your elbow or shoulder can move only in certain ways.
 
Third, there is a movement or sequence editor. Here you can define segments of motion as 
one cycle of a walk. These can then be linked together in chains in the scene editor for 
longer sequences.
 
Fourth, you put together your final scenes in a scene editor. Here you place the objects and 
built in the other parts of Anim8or into their final 'world'. You can control how they move, 



and where the camera is located. You can also give the scene various kinds of lights.
 
Once you have created a model or scene you can render high quality .jpg and .bmp images 
and .avi movies and save them to disk for later use.
 
Finally, there is an object browser to help you view and organize your Anim8or objects. You 
can also search your disk for objects in other formats.

Related topics

 Common Button Meanings

 Object Editor

 Figure Editor

 Sequence Editor

 Scene Editor



Mouse Usage

Anim8or requires the use of a mouse with two buttons. You use the left one most of the 
time to select, move, and change objects. When you are selecting things, the left button 
always deselects everything beforehand, so that only a single item remains selected. The 
right button, on the other hand, allows you to select multiple items by adding newly 
selected items to those already so. As of version 0.7 you can use the middle button to 
deselect the selection of anything. If you don't have a middle button, press and hold the alt 
key and the right button can be used for these functions instead.
 
When moving, rotating, or non-uniformly scaling something, the left button changes the X 
and Y-axes. Moving to the left or right affect the X-axis, and up and down the Y. The right 
button changes the Z-axis.
 
You can often double click on something to bring up an edit dialog for that item.

Related topics

 Common Button Meanings

 Arc Rotate



Where's Undo?

As of version 0.7, Anim8or has a complete undo command for the Object, Figure, Sequence 
and Scene Editors. As long as you stay in either Editor you can undo and redo multiple 
editing commands. A history is kept of as many changes as can fit in the undo buffer, about 
1 MB of memory. So unless you're editing large models, you will be able to undo more than 
one operation.
 
You use the Edit->Undo and Edit->Redo menu commands to apply undo's and redo's. Or 
you can use the keyboard shortcuts of Ctrl-Z and Ctrl-Y.
 
As an alternate to Undo, you can still use the original (rather simplistic, and to some people 
annoying) substitute. When you are dragging a mouse in the main window to change 
something, say an object's orientation, and you think "Oops! I didn't want to do that!" just 
keep on dragging the mouse until it's outside the active view window and release the 
button. This will cancel the operation.
 
Still, when using this and any other computer program, I still offer the same advice: "Save 
Early, Save Often!". And don't always save to the same file. Keep a recent backup handy.

Related topics

 Top Toolbar



Toolbars and Menus

Here is a portion of a typical toolbar. It has several sections in it that control different 
aspects of its behavior. The first thing that you will notice is that markings on some of the 
buttons are in White, some are in Black, and a few are in Gray. The white ones indicate that 
the associated mode or option is currently selected or in effect. The black ones indicate a 
state that is not selected. The gray buttons show options that are not currently available.

The top group of buttons on each toolbar act as a radio set indicating the current editing 
mode of the active view. When you click on any one of them, it becomes highlighted and 
that mode is selected. All of the others are deselected. The meanings of the various buttons 
in this group, and the other common buttons, are described below.

Tool Tips

You can turn tool tips on with the Options->Tool Tips menu command. Then if you pause the
mouse cursor over a toolbar button it function will be shown in the status bar.

Related topics

 Common Button Meanings



Common Button Meanings

The topmost group can have up to 4 buttons in it. When you click on one it set the indicated
mode, and changes the lower part of the toolbar to show the functions that are present in 
your new mode. The different modes are:

This button indicates that you are in the most basic select-and-edit mode for the editor that 
you are currently using. You will use it for most operations, such as selecting things and 
common editing actions.

This button is used for changing your view or views of your workspace. With it you can pan, 
zoom, tilt, and scale each view independently.

In this mode you can move and rotate the pivot for objects in your workspace. A pivot is the
point and orientation that are used when you scale and rotate each object.

You use this button to move into point edit mode. It allows you to add, move, and modify 
individual points, edges, and faces on editable mesh objects.

The next row of three small buttons shows the three axis of the 3D world. They indicate 
which axes are "unlocked', allowing you to move and rotate things in each direction. You can
individually select or deselect them, and thus restrict the movement of objects that you are 
changing.

Below these buttons you will find three more small buttons    that form a radio group. They 
show the current coordinate system you are using. You can use use world, object or screen 
coordinates when you manipulate things.

You will find that there are several common toolbar buttons that have the same or similar 
meanings in more than one editing mode. They are described next.

You use the arrow button to select individual components. When you click on an object 
using the left mouse button, you select it and deselect any previously selected objects. 
When you use the right mouse button, you leave any currently selected objects selected, 
and select additional ones.



With this button you can click and drag to show the corners of a selection rectangle. Any 
and all objects that fall within that area are then selected. Again, the left mouse deselects 
any previously selection items, while the right mouse does not.

This is the move function. You set it when you want to move your objects around on the 
screen. When you press the left mouse button within a view window you can drag anything 
that is currently selected in the X and Y directions by moving the mouse to the left and 
right, or up and down. The objects will move along with your mouse. Similarly, the right 
mouse button will move them along the Z-axis, which is usually into the screen.

This is the rotate button, used for rotating things. When you click and drag the left mouse 
button, any selected objects will rotate around the X and Y-axes along with your mouse. You
can use the right button to rotate them around the Z-axis.

This is the non-uniform scaling button. With it you can scale most objects independently in 
the X any Y directions using the left mouse button, and in the Z direction with the right 
mouse button.

This button scales objects in all dimensions simultaneously.

There is also a VCR style set of buttons for controlling the playback of your animations. You 
use its buttons in the same manner as those on a standard VCR or tape player.

Related topics

 Toolbars and Menus

 Object/Edit Operations



Top Toolbar

This is a toolbar that's at the top of the window. You can use for several tasks common 
throughout Anim8or.

The buttons on the top toolbar do the following things:

Undo - If this button is enabled you can use it to undo the most recent edit command.

Redo - Reapply a command that you have un-done.

Cut - Deletes any selected components.

Wireframe - Changes the working views of your object to Wireframe.

Flat - Changes the views to Flat or Faceted.

Smooth - View objects as smooth.

Material - Toggles the Material toolbar.

Arc Rotate - Enables the Arc Rotate tool. You can easily pan, zoom, and rotate any view with
Arc Rotate. It is described in detail later on in this chapter.

Grid Snap - You can toggle Snap to Grid mode with this button.

Related topics

 Grid Control



 Arc Rotate

 Materials



Keyboard Shortcuts

You can use keyboard shortcuts for several common operations. Some are shortcuts for 
menu commands, and they are shown to the right of the command name in the menu.

 Ctrl-X - Cut any selected objects and copy to the Anim8or clipboard.

 Ctrl-C - Copy any selected objects onto the Anim8or clipboard.

 Ctrl-V - Paste Anim8or objects from the clipboard into the current object.

 Ctrl-A - Select all objects in the current view.

 Ctrl-Z - Undo the last editing command.

 Ctrl-Y - Reapply an Undo command.

 Ctrl-W - Wireframe view. Show objects as lines instead of solids.

 Ctrl-F - Show objects as Filled instead of as a wireframe made out of lines.

 Ctrl-R - Enter and leave Arc Rotate mode.

 1 - Convert multiple working views to a single large view.

 4 - Split the screen into 4 different views.

 A - Change into Select mode.

 D - Change into Drag Select mode.

 M - Change into Move mode.

 N - Change into Non-uniform Scale mode.

 R - Change into Rotate mode.

 S - Change into Scale mode.

 Delete - This key deletes the currently selected items.

 Esc - The Escape key stops along Scene from rendering.



 Ctrl-Shift - Temporarily change into select mode. This allows you to quickly select a new 
object by pressing the Control and Shift keys simultaneously and clicking on the object, and 
return to your previous mode when you release the keys.

 Arrow Keys - You can use the arrow keys to move, rotate, and scale objects by small 
amounts in the Object editor, and advance the view by one frame in the Sequence and 
Scene editors.

 Alt - When pressed and held before using the right mouse button, it simulates a middle 
mouse button.

Related topics

 Top Toolbar

 Arc Rotate

 Common Button Meanings

 Mouse Usage



Arc Rotate

 When you press the Arc Rotate button in the top toolbar Anim8or displays a special 
overlay over the focus window. You can then use the mouse to pan, scale and rotate your 
view. It may take you a try or two to get used to how it works, but once you have it can 
save you a lot of time over other methods. 

To the right is a view of the arc rotate screen. There are six different regions on the screen, 
separated by the green overlay: the inner, outer, top and bottom, and left and right. Each 
behaves differently when you click your mouse in them, and each mouse button controls a 
different function.

 Left button - Rotate the view. Clicking in the center rotates it around the X and Y-axis. 
The outer region rotates around the Z-axis. Clicking inside one of the four little squares 
rotates in the X-axis (for the top and bottom) or the Y-axis (for the left and right) only. 

 Right button - Move the view. The center area moves your view left and right, and the 
outer region moves into and out of the screen. You may not seen any change when moving 
into the screen in orthogonal views but they will be apparent in a perspective view. 

 Middle button - Scale the view. The different areas all behave the same when you are 
scaling a view. Note: If you have a two-button mouse you can press and hold the Alt key 
and your right button will act like the middle button.

Related topics

 Common Button Meanings

 Object Editor

 Figure Editor



 Sequence Basics



Grid Control

You can set the size of the background grid used in the editing views, or you can let 
Anim8or pick a default size that changes with how much you zoom the view so that it 
always shows a reasonable number of grid lines. Use the Options->Grid command to show 
the grid dialog:

There are two grid sizes that you can set. One is used in the Object, Figure, and Sequence 
Editors, and the other is used in the Scene Editor. 

You can also set snap-to-grid for the Object editor by checking the Enable box in the Snap 
to Grid section, or with the    snap to grid button in the top toolbar. This will position objects 
you move at locations on a grid, making it easy to align them. 

Snap-to-grid also controls the size and rotation for many operations to give you more 
control on other aspects of modeling. You set the size of the grid snap in the Spacing entry.

Related topics

 Common Button Meanings

 Basic Objects

 Splines

 Adding Points and Edges

 Face Extrusion and Manipulation Tools



Material Editor Basics

The material editor is used whenever you need to design the color, texture, transparency, 
and other visual properties of an objects appearance. An example is shown below.

Materials are a complex topic. This dialog has are several sub-dialogs for certain function. 
There is an entire chapter devoted to describing how to use the Material dialogs.

Related topics

 Materials

 Material Editor



Visual Quality

You can control the quality of the images shown when you edit, as well as the quality of the 
images output to files. These are controlled through the Viewport Parameters dialog that is 
found under the View->Preferences menu. It looks like:

OpenGL Workspace

This section controls the appearance of your interactive workspace. You can view your 
objects as wireframe models, as flat faceted solid objects, or as smooth shaded solid 
objects. 

Most graphics cards display smooth shaded images at the same speed as flat shaded ones, 
so you might think that flat shading wouldn't be very useful. But it is sometimes helpful to 
see individual facets on a model.

Texturing, and mipmaps, can sometimes slow the response of your computer, so use the 
check boxes to enable or disable them as you see fit. Also, texturing can hide the structure 
of your models, so you don't always want to see it.



You can add a general fog to Anim8or Scenes. Objects beyond a certain distance gradually 
fade into the color of the fog. Fog is only visible in the camera view of the Scene editor.

File Output

This section controls the appearance of your interactive workspace. File images are 
rendered using a software renderer instead of an OpenGL accelerator, so the speed of your 
file renderings can be effected quite severely by the settings that you choose.

Gouraud shading is faster that Phong, but isn't nearly as good at showing highlights. 
Similarly, anti-aliasing helps to remove jaggies but takes several times longer to do.

Frame Rate

The last area, Frame Rate, sets the number images used to make one second of animation. 
All .avi file output is generated with this frame rate. If you check the Limit Playback box, 
then Anim8or will limit the rate it plays animations in the Sequence and Scene Editors. 
Otherwise they will be played at the fastest possible speed.

Related topics

 Top Toolbar

 Material Editor

 Texture Selector

 Environment Settings



Saving Images, Object Libraries

Anim8or Object Libraries

You can use any Anim8or .an8 project file as a library. Objects, Figures, Sequences, and 
Scenes can all be imported to another Anim8or project with the Object->Import, Figure-
>Import, etc. menu commands. You can also export individual Objects and such with similar
Object->Export commands.

Saving Images as .jpg and .bmp Files

You can make a quick preview image of any view that you are working on with the File-
>RenderPreview command. You can also save this image to a .jpg or .bmp file, or print it, 
from within this command.

Related topics

 Configuration

 Basic Objects

 Saved .an8 File Won't Load



Printing

Anim8or has the usual Print and Print Preview options in the File menu. But it offers one 
additional level of control of your printed images, by letting you control the size and other 
properties of the bitmap image used in printing. It is not at all uncommon for a color printer
to have a resolution of 1440 by 720 dpi. But generating an 8.5" by 11" image at this 
resolution is not practical! Instead Anim8or uses a default size of 1024x768 which you can 
adjust to suit your needs.



Configuration

Anim8or keeps track of 3 base working directories. One is used to store Anim8or project 
files (.an8) and the others are the default directories for keeping Textures and importing 
and exporting objects. You set these directories with Configuration dialog through the File-
>Configure command:

When you load or save a project file Anim8or uses the project directory as the initial default.
You can change this directory in the Configuration dialog.

When you load a project file, Anim8or looks for texture files in three directories. First it 
looks in the same directory as the .an8 file. If that fails it tries the Texture directory set in 
the Configuration dialog. As a last resort Anim8or uses the full path name stored in the 
project file, which is where the texture file was initially found.

The import directory is simply the default place for importing and exporting files of any 
format.

You can have Anim8or automatically load the last project you were using by checking the 
Start if Previous box.

If you check the Associate .3DS box then you will be able to start Anim8or by double 
clicking on .3ds files in Windows.

Related topics

 Saving Images, Object Libraries



Object Editor

The object editor is where you create and modify new 3D objects. You enter the object 
editor by default when you run Anim8or. You can enter it at any time by selecting Mode-
>Object in the menu.
 
The basic screen is shown below. On the left is a toolbar. It has icons that represent the 
most common operations that you will be doing. It allows you use to change the mode that 
you are working in, add basic primitives, etc. You use the menu at the top of the screen 
performs less commonly needed actions.

The object editor has four modes: edit, viewpoint, axis, and point edit. You change the 
mode you are currently working in by clicking one of the topmost four buttons on the 
toolbar. This will also change the lower part of the toolbar to display buttons appropriate for 
that mode:

Object/Edit mode. This is the initial mode that the object editor starts in.

Object/Viewpoint mode allows you to pan, scale, rotate, and size-to-fit any or all of your 
views of your workspace.

Object/Axis mode lets you move an objects pivot or origin.

Object/Point Edit mode allows you to manipulate individual or groups of points, edges, and 
faces.

Related topics

 Common Button Meanings

 Object/Edit Operations

 Basic Objects



Object/Edit Operations

In Object/Edit mode there are some buttons just below the six small buttons on the toolbar 
that you use to manipulate components of your objects. Your actions only affect the 
selected parts of an object.

You can select something by clicking on it when you are in select mode. This button puts 
you in select mode. You can temporarily switch to select mode at any time by pressing the 
Control and Shift keys. You can also select components by dragging a rectangle around 
them in drag-select mode.

These buttons allow you to move, rotate, scale non-uniformly, and scale the selected 
components with your mouse.

You can also add and edit splines by adding straight and curved segments. Splines are also 
sometimes called paths since they can be used as a path for motion.

UV texture coordinate editing tool. You use this tool to interactively apply texture 
coordinates to selected objects. It adds an overlay to the screen that is similar to the arc-
rotate tool used for changing your viewpoint but for textures. 

The yellow square represents a texture's basic size. You can move the texture around on 
your objects with the right mouse button, and you can rotate its orientation with then left 
button. The middle button scales textures. Remember if you don't have a middle button you
can hold the Alt key down and use the right button instead.

Related topics



 Common Button Meanings

 Splines

 Arc Rotate

 Material Editor



Basic Objects

You can add new objects to Anim8or in two ways. The first is to import meshes for the 3ds, 
lwo, and obj file formats. You use the object->import menu item to do this. The second way
is to start with one or more built in primitives. The lower part of the Object/Edit toolbar has 
several icons for adding new primitives.

This button allows you add spheres to an object. First click on it. Then move the mouse to 
where you want the sphere to be added. Click and drag to create a sphere of the size you 
desire. If you want to add several spheres, use the right mouse button. Using the left button
returns to select mode after adding a single object. Double clicking on the sphere brings up 
a dialog where you can change the sphere's properties from the default.

This button adds blocks. You can divide them into as many subdivisions in each axis as you 
like by double clicking on a block to view its properties dialog.

This button adds cylinders. You can taper them, leave the ends open or closed, and set the 
number of divisions used to make them in their properties dialog.

Add various mesh solids and other built-in solids with this button. You can set the current 
solid type using the build->primitives menu.

This button adds unfilled polygons to an object. They are built as an editable spline so you 
can make a lot different shapes starting with the right polygon. Spline can be filled, 
extruded, lathed, edited, etc. 
To set the number of sides, use the build->primitives->n-gon menu item.

You create True Type text objects with this button. Just click somewhere in a window and 
start typing. If you want to change the properties, double click on the object. You can use 
any font and style. 

Each letter it a single spline (possible with multiple parts, like the hole in an O), and the 
whole string of characters is grouped together. You can extrude text objects directly using 
the Build->Extrude menu item. You can also convert a text object into a group of general-
purpose splines using the Build->Convert to Spline menu item.



This is the modifier button. Use it to add modifiers, which can bend, stretch, warp and twist 
another object into many new shapes. Modifiers are covered more fully in a later section of 
this chapter.

Each object in Anim8or has its own coordinate system. Its pivot is located origin. When you 
scale or rotate and object it is done using the pivot. When you are in wire frame mode, the 
pivots of selected objects are shown as red-green-blue axes as in:

You can move and rotate pivots by using Pivot Edit mode.

Related topics

 Mesh vs. Parametric Objects

 Extruding Text

 Modifiers



Mesh vs. Parametric Objects

There are two kinds of components in an Anim8or object, parametric and mesh. Parametric 
components are defined by a small set of numeric values. These values are used to build a 
viewable mesh whenever they are displayed. You can edit these parameters by double 
clicking on a parametric component, which will generate a new mesh for display. But you 
cannot modify the mesh directly. Some parametric components are the sphere and cylinders
described in the previous section.
 
Meshes however can be fully edited, smoothed, etc., even at the point or face level. You can
convert parametric components into meshes with the Build->Convert to Mesh menu item. 

It is easy to see if an object is a mesh or not by selecting it. In a filled view selected 
parametric components are enclosed in Yellow bounding box and meshes in White ones. In 
a wireframe view parametric components are shown in yellow lines and meshes in white or 
some other color lines. The four spheres below show the same geometry. The first and third 
are in their original parametric form, while the second and fourth have been converted into 
meshes.

Once a parametric component has been converted into a mesh it cannot be reverted.

Related topics

 Basic Objects

 Top Toolbar

 Subdivision



Object Materials

You can view the materials in an object by displaying the material toolbar from the Options-
>Materials menu. Each named material is shown applied to a small sphere. Double clicking 
on the sphere brings up the material editor dialog allowing you to change that material’s 
properties. 

The selected material is shown as a depressed button with a white name. You can set the 
basic material for any selected component by clicking the Apply button. 

The Object button shows the current object's materials. 

The File button shows the project's global materials, those that are shared among all 
objects in an entire project. You should add materials that are common to several different 
objects to the global list to help manage them easier. 

If you want to define a new material, simply double click on the New button at the bottom 
of the list. 



If there are more materials that can be shown, you can left click in the material toolbar and 
drag up or down to scroll the list.

Materials are discussed in more detail in chapter 10, Materials.

Related topics

 Materials

 Material Editor



Splines

 

 You use the spline and line buttons to manipulate splines. To add a new spline, you 
must first deselect everything. Then select either the spline or line button and click and drag
to place the first segment. The spline will be drawn with a white pick box at its root and a 
red one at its head like this:

The red box also indicates that the spline is extendable. You can left click on it and drag to 
add more segments:

Once you have built all of the segments you need, go back to select mode and double click 
on the spline to bring up its property dialog and uncheck the extendable check box. This 
prevents the accidental extension of your spline when you are trying to modify it in some 
other way. Go back to spline mode and your spline will look like this:

Now if you reselect the spline button you can click on knots and display their control points:

You can drag the knots to new locations, and change the positions of the control points to 
alter the shape the spline. Double clicking on a knot will show the knot dialog where you can
change the knot into either a smooth knot or a corner.

Double clicking on a segment will highlight that segment and let you set the number of 
straight lines used to draw it:

Related topics

 Object/Edit Operations

 Extruding



 Filling



True Type Fonts

When you click on the text button you can add text to an object. Click in a view window and
a text cursor will appear. Type some text and it will appear as an outline in the window. 
Double click on the text and the text dialog appears. You can change the font, make it bold 
or italic, and set its size. You can always resize a text object but this isn't always the same 
as changing its initial size with the font properties dialog. Larger fonts are sometimes 
generated with more detail.

You can also fill and extrude text. Use the Build->Fill and Build->Extrude menu items:

When they're filled or extruded, text objects are converted into meshes. Afterwards, you 
can do anything to them that you can to an ordinary mesh.

Related topics

 Filling

 Extruding

 Extruding Text



Filling

You can convert any closed spline into a flat, filled mesh. Just select that spline and apply 
the fill operator using the Build->Fill menu item. The spline should not cross over itself or it 
will not fill. To fill a spline, simply select it and the select the Build->Fill menu item.

You can also build complex splines consisting of multiple independent curves. Interior closed
areas are filled as cutouts. To build complex splines, select several basic splines and apply 
the Build->Join Splines menu item. For example:

Since text items are actually a group of (possibly) complex splines, text can also be 
combined with splines and filled. First select the text and convert it to splines with the Build-
>Convert to Spline menu. Then ungroup the string of characters with Build->Ungroup. 
Finally select the spline along with all of the individual characters and combine them into a 
single multiple spline with Build->Join Splines. Then fill the result:

Related topics

 Splines

 True Type Fonts



Extruding

Two more operations you can do on splines are extrusion and lathing. Both create a three-
dimensional mesh out of a spline, but each in a different way. An extrusion sweeps the 
edges of the spline along a path (straight or curved) while lathing spins them around an 
axis.

To extrude a spline simple select it and choose the Build->Extrude menu item. 

This will display a dialog with several parameters that you can set, such as whether to cap 
the ends and which direction to extrude. One option is to extrude along another spline. 
When you choose this option, you will be prompted to choose the spline after you leave the 
dialog. Some extrusions are shown below:

Note: The "center point" for the extrusion is the initial origin of your spline. Make sure that 
you create the spline around the origin or the results won't be what you expect.
 
You can also extrude text. Just select it and choose Build->Extrude:



Related topics

 Extruding Text

 Basic Objects



Extruding Text

To make 3D (extruded) text:

1. Select the text.
2. Click Build->Convert to Spline.

This creates a Group of Splines, one for each letter.

3. Click Build->Ungroup.
4. Click Build->Join Splines.

Now you have a single Spline object that contains multiple paths. It is also possible to 
extrude letters one at a time.

5. Click Build->Extrude.

Related topics

 Filling

 Extruding

 True Type Fonts



Lathing

Lathing creates a solid surface from a spline by spinning it around an axis and converting 
the area it sweeps into a mesh surface. It can produce a variety of different objects 
depending on the shape of the spline that you lathe. If you lathe a closed spline you can 
create wheels and donuts. If you lathe an open spline, you can build wine glasses, pots, and
vases:

Since you can apply UV texture coordinates at the same time that you are lathing a spline, 
it is easy to build things with detailed colorings.

You use the Build->Lathe command to lathe a spline. This displays the dialog:

The Axis section selects which axis will be used to do the rotation. You can control the 
behavior of the end points of an open spline with the settings in the Start and End sections. 

The three objects below are all lathed from the same spline, but the starting point (the one 
at the top, not the red one) is handled differently in each case. Open leaves the points at 
the beginning and end in their original place. Closed adds a new point on the axis at the 



same level as the end point and connects to all the end points creating a flat top or bottom. 
Point moves the splines end point precisely to the axis and then lathes the spline.

Open, Closed, and Point modes used at the Start.

Related topics

 Object/Edit Operations

 Grid Control

 Splines



Modifiers

Modifiers allow you to stretch, bend, twist, and warp meshes into an endless variety of 
alternate shapes. To use them you create a modifier object and bind it to an existing mesh 
with the Build->Modifiers->Bind menu item. You can double click on the modifier to bring up
its property dialog and change its behavior. The effect it has on the target mesh is shown in 
your object views. When you are satisfied with the shape, select the Build->Modifiers-
>Effect menu item and the mesh will be transformed into its new shape.

Here is an example of a cylinder modified by a twist, taper, skew, curvature, and a bend 
modifier. Modifiers preserve texture coordinates and other properties bound to points on the
object.

Related topics

 Mesh vs. Parametric Objects

 Basic Objects

 Object/Edit Operations





Mirroring

You can also mirror an object using the Build->Mirror menu item. This builds a mirror image
of the original object, a duplicate with the points reflected to the opposite side of the X, Y, or
X-axis. These hands are simple mirrors of each other:

You often can model one half of a symmetric object easier that the whole. To build the 
whole, mirror the half model and join the two together.

Related topics

 Connecting Meshes

 Merge Points

 Mesh vs. Parametric Objects



Subdivision

You use subdivision to round the corners of basic shapes and to give more detail to the 
model. Anim8or can subdivide any mesh. Just select the objects that you want subdivided, 
and select Build->Subdivide from the menu. Each time you do this you will round the 
corners a bit more, and multiply the number of facets by four. So be careful, or you'll create 
a very large model to manipulate!

Note: Subdivision used to be called smoothing in earlier versions of Anim8or.

There is a technique called box modeling that you can use to model complex objects that 
begins with a simple box. You bevel, extrude, resize, and warp a few flat faces until you 
make a rough form of your desired object. Then you apply subdivision, and viola! You have 
a nice model. The following models were made in Anim8or using box modeling:

 

Not a bad hand considering it was modeled by 24 simple cubes! You can learn more about 
building the box shapes in the section on Object/Point Editing.

Related topics

 Point Editing

 Subdivision Objects



Subdivision Objects

You can convert a Mesh into a subdivision object with the Build->Convert to Subdivided 
command. You edit Subdivision objects just like regular meshes, but they are automatically 
subdivided as you work. This is a far easier way to model than to continually apply 
subdivision operations to try and see what your model will eventually look like. Selected 
faces are shown as transparent windows revealing a further refined model inside:

When you resize or extrude a face the internal smoothed view changes shape to follow. (You
only see this view in the Point Editor. All other places your model will be shown as fully 
subdivided images.)

You can convert a Subdivision object into a Mesh with the Build->Convert to Mesh 
command. It will be converted at the subdivision level that you are using to view it in the 
working views.

Another very important advantage to Subdivision objects is size. Subdivision objects are 
stored in the undivided format that is many times smaller than the final fully divided model. 



You can control the level of subdivision used on the screen and in the final image by double 
clicking and editing the properties dialog.

Note: The default Convert to Subdivided value is two, as this is the most commonly required
amount. If you set the Division value to zero there will be no subdivisions at all.

Related topics

 Subdivision

 Mesh vs. Parametric Objects



Object Point Editor

The Object/Point button    on the toolbar changes Anim8or into Object/Point editing mode. 
Here you can modify individual points Edges and faces of any mesh object. You can move 
Scale rotate Add and delete them. You can extrude Twist and scale faces weld close points 
together etc. When you enter Object/Point mode the display automatically switches to 
wireframe. If you want to view your objects as solids use the View->Full menu item.

Just below the coordinate axis button row there is a new row of three buttons. You use 
these to change the selection mode to point, edge or face in order to select different parts 
of your model. The select and drag select modes will then select the corresponding items.

Related topics

 Point Editing

 Edge Editing

 Face Editing

 Common Button Meanings



Point Editing

You use point edit mode to modify the shape of an object, and to add and delete unwanted 
parts of an object.

You can manipulate selected points by using any of the move, rotate, and scale buttons. The
rotate and scale operations are done relative to the objects pivot.

If you delete any points using the cut button, any edges and faces that contain that point 
are also deleted. For example, to delete the bottom of a sphere, first select all of the points 
below but not including the equator using drag select mode, and cut.

If you move these same points, scale them non-uniformly, or scale them, you can make 
objects like these:

You can use the Arrow Keys on the keyboard to make tiny moves, rotations, and scales to 
selected points as well when the corresponding toolbar button is enabled.



Edge Editing

You use edge edit mode in a similar manner to Point Edit mode. When you select an edge, 
both of its end points are also selected. Thus all operations from point mode are enabled as 
described in the previous section.

If you delete using the scissors in edge mode, however, only the selected edges and any 
faces that contain them are deleted. All points are saved. This allows you to change the 
tessellation of an object more easily, without having to add back previously deleted points.

You can also set various edge properties for selected edges. Select the edges you want to 
effect, and then select the Edit->Edge Properties menu item. The default setting for edges is
smooth. This means that if the solid angle defined by the two faces is less than a certain 
threshold, the edge will be smooth. Otherwise it will be creased. You can change the value 
of this angle by double clicking on a mesh when in Object/Edit mode to bring up its 
parameter dialog.

You can mark an edge as creased, so that won't be drawn as a smooth surface but will show
as a sharp crease. This does not change the geometry of the model in any way; just the 
way normals are computer so that it appears smooth or creased. The following sphere has 
the lower half of its edges set to creased:

Another property that you can set in this dialog is how rounded an edge will be after it has 
been smoothed. Normally when a mesh is smoothed, all edges become smoother. Each 
application of smoothing increases the number of faces in a mesh, and smoothes all edges. 
You can mark any edge so that it will not be smoothed, but will retain a sharp crease, for 
one or more cycles of smoothing. The following shows a cube and several possible 
smoothings of it:



The sphere-like ball is the result of a simple cube being smoothed several times. The top 
two rounded cubes are the results of smoothing a cube with all of its edges set to a rounded
level of 1 and 2. The bottom two rounded cylinders are from a cube with only the top 4 and 
bottom 4 edges set to a rounding level of 1 and 2.



Face Editing

You use face edit mode to select and manipulate the faces of a mesh. You can delete 
selected faces with the scissors button, but points and edges remain unchanged. You cannot
move, rotate or scale selected faces. You can only make these changes to selected points 
(and lines). This is because it is somewhat ambiguous as to what you intend to do when 
several adjacent faces are selected. There are, however, some alternate ways of 
manipulating faces that are described below.

Selected faces are shown as filled even in wireframe mode. The front side is shaded Yellow 
and the backside Blue to help you see what faces are selected. This is also the case in filled 
mode, but you usually only see the yellow front sides.

A Note on Selecting Faces

It can sometimes be rather tedious to select the exact faces that you want, especially in a 
complex model. But there are several tricks that can help out.

The select mode selects faces that are facing the viewer over those facing the other way. So
changing views of an object, or temporarily switching to Object/Edit mode and rotating the 
object so that different faces are in front, can help. This is one reason that selected faces 
are shown in Yellow even in normal views where you can't really do anything to individual 
faces.

The drag select mode only selects faces that are entirely within the selection rectangle. So 
you can often add faces one-by-one until you've selected what you need.



Applying Multiple Materials

You can also apply different material properties to individual faces. Simply select the faces 
that you want to change, display the Materials toolbar (use Options->Materials if it isn't 
already visible), select the material to apply, and click the Apply button in the toolbar.

You can use as many materials on a mesh as you want. With a little more imaginations you 
can make objects like these:

The UV Texture tool is also available in Point Edit mode. You first select the faces that you 
want to texture, and then use the UV Texture tool to interactively apply the coordinates. It 
helps if you already have a textured material applied to those faces.



Adding Points and Edges

You can add new points and edges to a model with the Add Edge button in the toolbar. To 
add things to an existing object, click on one of it's points and drag the mouse out. A new 
edge and point will be added where you release the mouse. If you move it over another 
existing point, then the end of the edge will snap to the existing point, and an edge will be 
added between the two points. You can build complex meshes quickly using this method:

If you want to add a point that is close to another one but not make it the same point, hold 
down the Shift key after you click the mouse button down and hold it until you release the 
mouse.

If you want to start a new mesh, press the Shift key before you press the mouse button. A 
new mesh will be created with a single edge and 2 points.

Note: This command only adds Points and Edges, not Faces. You use the Edit->Fill Holes 
command to add faces.

If you enable grid snap when you add points you can make objects with exact 
measurements more easily.

Related topics

 Adding Faces



Adding Faces

When new edges are added to a mesh, the gaps can be filled in with new faces. To do this 
click the Edge Select button in the Point Edit mode, then select all the edges around the 
gap/gaps and use the Edit->Fill Holes command.

If you need to add new edges to a gap, use the Add Edge button on the Point Edit toolbar.

There are a few things to note before you can add a face:

 Faces can only be added to complete connected loops of edges. If there are any gaps, no 
face will be added.

 You can tell how many faces an edge participates in by its color when selected. The color 
code for edges and the number of faces attached to them is: red 0, green 1, white 2, violet 
3+. They must be red or green to get filled. If an edge is white then it already has two faces
connected to it and can't get a third. 

 You can apply the Edit->Flip Normals and Edit->Fix Normals commands if you need to 
orient new faces properly.

 You can select a lot of edges and do a fill of the whole batch at once. Anim8or will start 
by filling any selected edge loops of length 3. Then it will fill those of length 4, etc. until no 
more faces can be added. This will sometimes create undesirable results and you will have 
to try again in smaller batches. 

 You may have to delete some faces in a mesh before adding new ones.



Connecting Meshes

Attach two separate meshes to create a single, connected mesh using the Join Solids, Add 
Edge and Fill Holes commands.

 First position the two meshes with the parts you want to attach near each other. Leave a 
small gap for the new faces that will connect them.

 In Object/Edit mode, select both meshes and apply the Build->Join Solids command. This
doesn't add any new connecting faces but combines them into a single Mesh allowing you to
do so. 

 Next in Point Edit mode, add the edges between the points you want to attach. 

 Select the new edges and those on the boundaries around them.

 Use the Edit->Fill Holes command to add the connecting faces. If the edge is red or green
new faces can be added but if it is white it can't add any more.

Related topics

 Merge Points

 Object Point Editor



Merge Points

You can merge several points into a single point with the Merge Points command. In Point 
Edit mode, select the points to be merged (it helps if they are very close together) and 
apply the Edit->Merge Points command. 

The dialog shown here appears. This sets the maximum merge distance allowed between 
two points. Click OK to merge all eligible points.

Connecting Meshes

You can also use this technique to connect two meshes. It is most effective when the points 
to merge are similar in position and number. For example, connecting half of a sphere with 
12 longitude lines and a cylinder with 12 lines around is a snap.

If you build one half of a symmetrical object, mirror it with Build->Mirror and make the two 
meshes into a single mesh with Build->Join Solids you can then position the two halves 
close together, select the adjacent points and use Edit->Merge Points to make a seamless 
connection. This merged object was further subdivided once to round off its corners.

Related topics

 Connecting Meshes

 Object Point Editor



Point and Line Parameters

When you are in Point mode you can double click on a point to bring up a dialog box that 
let's you assign it's position numerically.

When you and in Edge mode you can similarly double click on an edge to edit it's properties.



Face Extrusion and Manipulation Tools

You can manipulate selected faces in a variety of ways using the lowest buttons on the Point
Edit toolbar. They can be used to build very complex models from a small number of cubeish
shapes using the box modeling method.

This button extrudes faces that are selected. Each face is translated in the direction that it 
faces, either out or in, and new edge polygons are added to connect the face to its original 
edges.

Similar to the extrude faces tool, the extrude-connected faces tool extrudes selected faces 
in a mesh. However adjacent selected faces remain connected. New faces are only added to
the edges between a selected and an unselected face.

The six faces of the solid on the left are shown extruded and extrude connected below.

        

This button rotates selected faces around its center. It is most useful when the selected 
faces aren't adjacent.

      



This button scales faces that are selected.

        

This button will replace faces with a peak.

The bevel tool is used to add faced corners to a surface. It can bevel both faces and edges 
of any mesh. Selected edges are turned into new faces, cutting the corners off a model: 

Selected faces are handled as a group. Edges between a selected face and an unselected 



face are beveled but edges between two adjacent selected faces are left alone:

The inset tool is also useful for adding faces to surfaces. Each selected face is replaced by a 
smaller version of itself with new faces connected to the original edges. This is an easy way 
to add more detail to a particular part of a model, or to make a hole for a door, window or 
eyes:

These face manipulation operations are often followed by one or several applications of the 
Subdivide operation to build more complex shapes. For example, start with an extruded 
pentagon, select all 5 outer faces and extrude them, finally smooth to make a starfish:

Related topics

 Subdivision

 Subdivision Objects



Face Editing Commands

Anim8or has several other useful face editing commands. They are activated within the Edit 
menu in Point Edit mode.

The Bridge command allows you to do several useful operations. To use it you first select 
two different faces. They have to have the same number of edges but can belong to 
different meshes. The Edit->Bridge command then will connect the two selected faces with 
new faces connecting each edge of one face with the corresponding edge on the other face. 
You can poke holes through a Mesh:

You can connect two parts of a Mesh to form a bridge:

And you can join two different Meshes into a single mesh:

The Flatten command does just what it's name suggests: it flattens groups of selected 
faces. All the vertices of each group are projected onto a flat plain. You can choose the 
group's average face direction or the X, Y, or Z-axis. Flattening is quite useful when you 
need a level base for a model, and can be use with the Merge Faces command to help 
simplify your models.



The Merge Faces command combines groups of selected faces into a single face. You can 
simplify areas of models that are too detailed this way.

You have to be careful to keep the faces convex and relatively flat or they may not render 
properly. Convex faces are those that don't have any points inside their outer boundary. 
Faces with interior points are called concave and can cause rendering errors:

In the example below, three pentagonal faces are merged into one big face with 9 sides. It 
is concave and doesn't draw properly as a result. It's easy to see in this example because of
the stray back facing part is blue when it is selected. Other times it may not be as obvious 
what is wrong.

If you are working with a Subdivision object this is not as important. The faces that you are 
editing aren't drawn in your final object. Subdivision will smooth the mesh making it much 
better formed along the way.

The Detach Faces command detaches groups of selected faces from unselected faces. You 
can remove parts of a model this way.



Figure Editor

The Figure Editor is where you design animated characters to put into animation Scenes. 
The main difference between a figure and an ordinary object is that a figure contains a bone
structure or skeleton, that you use to bend and shape the object into different poses. By 
setting the pose of a character in a few key frames of an animation, you can bring it to life. 
Anim8or will smoothly fill in the in-between poses by bending the joints of a skeleton by the
right amount. You can enter the figure editor at any time by selecting Mode->Figure in the 
menu.

The basic screen is similar to the Object Editor and is shown below. You can also view 
multiple viewpoints at the same time, like the other editors.

Notice the faintly visible bones inside the character's body and legs. You can control the 
visibility of bones, body parts and other aspects to help design the skeleton. The character 
doesn't have many bones in its body, but it has animatable legs and feet.

The figure editor has two modes: edit and viewpoint. You click on one of the icons to switch 
between these two modes.

Figure/Edit mode. This is the initial mode that the figure editor starts in. Use it for designing
a character.

Figure/Viewpoint mode allows you to pan, scale, rotate and size-to-fit any or all of the views
in your workspace.



Figure Basics

There are two different parts used to build a figure: the Body, which are the visible parts of 
a character that appear in the final scene, and the Bones or skeleton which are used to pose
and animate it.

The character's body parts are designed in the Object Editor as different objects. When 
adding body parts to a character it only makes a reference to the original object. This 
means that an object added several times doesn't increase the working file's size. You can 
also make changes to all instances by editing a single object.

There are also several pre-built shapes in the figure editor to help with preliminary design 
and motion tests. The "ball and stick" legs shown here are made from cylinders and 
spheres.

Once you have made the character's body, you switch to the Figure Editor and build the 
skeleton. Starting at the initial root bone, add bones one at a time to make the character's 
movable structure. For example, to make human-like legs you need to add a bone for each 
thigh, lower leg and foot. You can set each joint's range of motion to make animation easier.



When the skeleton is designed you can add the character's body parts. Each part is linked to
a specific bone, so when the bone moves the part will too. You can move, scale and rotate 
each body part within the coordinate space of its bone.

Related topics

 Flexible Joints



Figure/Edit Operations

The first group of buttons are used to select various body parts of a character and place the 
visible parts on the bones in a similar manner to the ones in the Object Editor.

Use this mode to select individual character bones and body parts. As usual, you can use 
the right mouse button to select additional things while keeping the original ones selected.

Use this mode to select all objects you drag a rectangle over. Again, using the right mouse 
button adds selections without deselecting anything.

The next three buttons apply to the objects that you have attached to the skeleton, not to 
the bones themselves. 

This button Moves an object around in relation to the bone it is attached to.

    

These buttons are used to Rotate or Scale an object. Objects have to be selected before you
can modify them.

Use the next set of buttons to edit the bones of your character's skeleton once it has been 
built.

This mode allows you to rotate your characters joints into their nominal position. This 
position defines the zero value for all rotations that this joint can perform. It is not the same
as the default position of the joint, which is where the joint is when it's "relaxed", but is 
used to define the bone's coordinate system.

You use this button to change the length of a bone. When it is pushed, you can click on the 
end of a selected bone and stretch or shorten it with the mouse. You have to be sure that 
you click directly on the end of the bone or it will not change. You can also double click on a 
bone and set the length directly with a dialog box.

You use this mode to add new bones to a skeleton. To add a new connecting bone, you click 
on the end of a bone and drag to set the bone's length. It will always align in the same 
direction of its parent. So if you want it oriented in another direction, you must use the 
rotate button shown above. 

Note: You have to click on the tip of the bone or nothing will happen. If you want to attach a



new bone to the end of an unselected bone, click on the tip and it will become selected. 
Then click a second time on the tip, and drag until your new bone is the right length. You 
can also double click on a bone to bring up it's parameter dialog and set the length 
manually.

This button allows you to skin part or all of a skeleton with a single Object. Then when the 
joints of a bone bend the object deforms and bends seamlessly along with the skeleton. 
There is more detail on how to use this skinning tool later on.

You use the final group of buttons to control what is visible in the edit window. You may find
it easier to manipulate your character's skeleton without its body getting in the way, or want
to see the final, solid look without the bones showing. These controls will do just that.

You use these two buttons to toggle the visibility of bones and body parts. If both of them 
are enabled then your character's body will be shown in a sort of transparent view with the 
bones visible inside. You will find this indispensable when arranging your character's parts. 
If only one is enabled, the components are shown as solid objects.

This shows a character with a simple skeleton. Only the legs have bones, so you could only 
animate the legs. The face would be frozen in that silly look unless you added additional 
bones to animate the eyes, wings, beak, etc.

This button toggles a visible axis for any selected bones. It also shows you the range of 
movement for their joints.



Building a Skeleton

Each figure's skeleton starts with a Root bone. By adding a child bone to the root, and then 
to successive bones, you construct a skeleton one bone at a time. Each bone is owned by its
parent, and any movement of a parent bone also moves its children.

When you add a bone it is aligned in the same direction as its parent. So you will normally 
have to rotate it to its proper orientation.

If you want to delete a bone, first select it and then choose Edit->Cut from the menu bar. 
This will delete the bone and all objects attached to it. Any lower bones will be moved up 
and attached to the deleted bone's parent.

This is a simple skeleton. It is made out of 9 bones plus the root. This skeleton is built with 
two symmetrical hips and legs. The lower two bones in the right leg are selected and shown 
is white.

The foot has an extra diamond  visible on the end. This gives you an easier target to grab 
onto when you are manipulating the bone. The lower leg has one as well, but it is hidden 
inside the foot bone and isn't visible.



Flexible Joints

In Anim8or you decide which joints are flexible and which ones are frozen in a fixed 
position. By default they are all fixed. You add flexibility in the bone editor dialog that 
appears when you double click on a bone. 

You control the rotation of a joint around each axis independently. Clicking on the Free box 
for an axis allows it to rotate around that axis. You can set the minimum, default, and 
maximum allowable angles as well.

Angle values are limited to values between -359 and 359 degrees with a maximum 
difference of 359 degrees.

You use the X and Z axis to control the bending of a joint, and the Y axis to twist around. 
Clicking the single Locked box will prevent any changes to a bone's length or position in the 
basic skeleton. It's a good idea to lock your bones once you've got things set up. This 
prevents their accidental alteration. You can still change all the joint parameters, but since 
this is done in a dialog instead of with the mouse, it is less likely that you will do something 
accidentally. The Lckd box for each axis is used to animate a character and doesn't apply to 
the figure editor.

If you check the No Limits box then you will be able to rotate the bone freely on that axis. 
This kind of joint is called a free or unconstrained joint because there are no restrictions on 
its position.



  This is a side view of a skeleton. The show axis button is selected so you can see the 
joint rotation limits of any selected bones. The X axis is shown in green, the Y axis in blue 
and the Z axis in violet.

The bone selected here is the lower part of the right leg and forms the right knee. It can 
only bend in the X axis and like a human knee can only bend backwards in this case a 
maximum of 135 degrees backwards.



Adding Body Parts

Once you have built a skeleton, you need to add the visible body parts that will appear in 
your final images. Each body part is an object that you add to a specific bone's local 
coordinate system. First select the bone that you want to add your object to, then use the 
Build->Add Object menu command to add it. Your object then behaves like that bone. When
the bone rotates, so does the object. 

You can also add simple cylinders and spheres. They aren't very sophisticated, they just 
look like sticks and balls, but they do allow you to do quick tests to see how your skeleton 
behaves. Add them using the Build->Add Cylinder and Build->Add Sphere menus.

If needed you can change a few simple properties for these shapes. Double click on one to 
display it's property dialog box, as shown below. You can also use the Settings-
>Component->Material menu command to set their color.

These basic shapes are called parametrics and aren't as flexible as mesh objects you build 
yourself. They have some fairly restrictive limits and aren't meant for any kind of final 
rendering. For complete control of objects you have to build them as meshes in the Object 
Editor.



Skinning

In the previous section you learned how to add a body part as the offspring of a specific 
bone. It follows all of its parent bone's movements, but remains a rigid, inflexible object. 
This is what you want when making a robot. It's not exactly what a living human or animal 
does. You want them to be flexible, to change shape and bend along with their skeleton. 
This is exactly what Skinning does.

Once you've built an object and its skeleton, you can attach the object to several bones at 
the same time with the Skinning tool. 

In this mode each bone has an area of influence that is strongest close to the bone and 
diminishes further away. Each point in an object moves proportional to the strength of that 
bone's influence on it. 

The two bones here show their ranges of influence. The inner yellow area is where the bone 
exerts maximum control. This does not mean that other bones can't also control points that 
fall within this region, just that the bone is a strong influence. The outer orange area is the 
limit of the bone's control. A bone does not affect points that lie beyond this boundary at all.
The only exception is that if a point lies outside all bones' area of influence, it is simply 
controlled by its base bone, the one it was initially attached to.

To skin an object you first attach it to the base bone. It should be chosen carefully, since 
only the base bone's descendents will be able to bend the object. Now enter the Skinning 
mode and select your object by clicking on it. This adds the object to its base bone 
influence, enabling the bone to alter the object's shape. To add other bones simply click on 
them and confirm that you want to add them in the dialog that appears.



You can adjust the size of a bone's Influence in two ways: double click on it and enter 
numeric values, or edit the influence regions directly on the screen. 

You can set the size of the Inner and Outer Range for each end of a bone here. The Offset 
sets the start and end influence positions along the bone as a percentage of the bone's 
length. 

Changing sizes directly on the screen is often more effective but it can be tricky to do as 
figures are often cluttered with several overlapping regions.

There are six control points on each bone, three at each end. If you turn off the visibility of 
both bones and objects by clicking on the buttons at the bottom of the toolbar you will get a
clearer picture of what's there. You use the one at the tip of the orange area adjust the size 
of the outer region, and the one at the tip of the yellow area for the inner one. The inner 
yellow point adjusts the offset.

One final note: Don't attempt to adjust your bone's positions in the Figure Editor and expect
to see your mesh bend! It doesn't work that way. You will only be adjusting the bone's 
position, and area of influence, relative to your object. You must go to the Sequence editor 
to start animating your character.

Now you're ready to go to the Sequence Editor to make some animated sequences. Then on
to the Scene Editor for your final movie!



Sequence Editor

The Sequence Editor is where you create most of the movement that gives personality and 
style to your characters. A sequence is a short block of key frame poses, such as one cycle 
of a walk. The easiest way to animate a figure is by placing it in a scene and adding one or 
more sequences.

Longer animations can be built from several short sequences, such a building a long walk 
out of multiple applications of a walk cycle. Anim8or automatically joins the adjacent 
sequences into a single, smooth movement using the key frame positions as guides. A view 
of the sequence editor is shown below:



Time Track

The Time Track at the base of the Sequence Editor indicates the current frame shown in the 
viewports. The frames that have one or more joints set in key positions are marked with 
small black squares  in them. The numbers :01 show the time in seconds since the start of 
the Sequence of a position on the track. The current frame is highlighted with a dark gray 
background.

You can expand the track to see a tree view showing details of individual joint's keys by 
clicking on the plus symbol  next to the title.

Key positions are shown for each joint/angle with a small black square in the frame. You can
also select a joint by clicking on it in the expanded track. Resize the expanded track view by
clicking and dragging the horizontal resize bar  at the bottom of the toolbar up or 
down.

The track will automatically scroll to keep the current frame visible when a sequence is too 
long to show all at once. If you want to see a frame that is off the window you can either 
use the Settings->Sequence command to set the frame numerically, or the left/right arrow 
keys to play the sequence forwards or backwards until you reach the frame.

You can move to a particular frame in a sequence by clicking on that frame in the track. If 
you click and drag the mouse it selects a range of frames. Clicking on the name of a bone 
selects that bone and highlights it in the track window. Clicking on the title of the sequence 
selects all bones. Mouse buttons have their usual meaning on the bone names: the right 
button adds to the selection, while the middle button subtracts. Use Shift-Click to select a 
new frame range while still keeping the same current frame.



Sequence Basics

You can't Animate a character before you have one! So it isn't surprising that you must first 
design a character in the Figure Editor before you can give it any movement. Once you have
one, you switch into the Sequence Editor and a new, blank sequence is created. Select the 
Settings->Sequence menu command to show the Sequence's settings dialog:

Click on the browse button and select your figure from the list. You can also set the number 
of frames in the sequence here. Now the figure will appear in the viewports and you can 
start animating. You can also set the Sequence's current view to a particular frame here.

The sequence editor has two modes: Edit and Viewpoint. Click one of these icons to switch 
between them:

Sequence/Edit mode is the initial mode that the sequence editor starts in. It is used it to set
all the poses and to view any motion created.

Sequence/Viewpoint mode allows you to pan, scale, rotate and size-to-fit any or all of the 
views in your workspace.



Edit Operations

This button is used to select bones of a character. The right mouse button allows you to 
select multiple bones.

This mode allows you to rotate the angle of a character's joints to new positions for key 
frames.

This is the button for Inverse Kinematics, a neat way to pose and animate your characters. 
Unfortunately it's grayed out and disabled because it isn't quite ready for prime time. Sorry!
It should be in a later release...



Visibility Options, Animate Button

Visibility Options

These controls allow you to show different aspects of your character on the screen when you
are working.

This button toggles the Axis visibility and the range of motion of any selected joints.

    

These buttons control the visibility of the bones and body parts of your character, like in the 
Figure Editor.

Use the Ghost View button to show multiple key frames of a sequence simultaneously. 
Compare the previous key poses and in-betweens that Anim8or creates with other frames to
see how they fit.

Animate Button

The animate button is the magic wand for making things move. Use it to add and change 
key positions. When rotating the angle of a bone you sometimes need to do it for all frames 
in a sequence and sometimes just for the current frame. The animate button controls this 
option. If not selected, changes are applied to the entire sequence. If selected, only the 
current frame is changed. The next sections explain this in more detail.

Related topics

 What is a Key?

 Making a Key Pose

 Making a Sequence



What is a Key?

If you had to set the position of each joint in a figure in each frame of an animation that's 
about all you'd get done! Fortunately, there is an easy way to animate called Key Frames. 
With this method you pose a character in a few frames, to represent what it should do in 
those frames, and Anim8or smoothly fills in the in-between frames. You get better results, 
naturally, if the key frames represent the most significant points in a character's movement,
hence the name "key".

There is no need for all joints to be keys in a frame. If a character is walking forward and 
slowly turning his head, you may need dozens of key positions in the legs but only a couple 
for the head turn.



Making a Key Pose

When you create a sequence the character is shown in its default position. You change its 
position by bending the joints, but only the ones made flexible in the Figure Editor, and only 
in the ways they could bend. 

To make a Key Pose you must first select the joint or joints that you want to bend. Showing 
the axis and even hiding the body parts can be helpful. 

Enter Rotate Angle mode, then enable the Animate button. Click on the tip of the joint  
and drag the mouse to rotate it. You have to pick a joint that can be rotated, and use the 
correct mouse button for the axis you want to rotate.

To rotate around the X-axis, shown in green, use the left mouse button. The joint will try to 
follow the mouse.

To rotate around the Y axis, shown in blue, use the right button. Since the Y-axis rolls the 
joint around the bone's length, and doesn't change the direction it's pointing, you have to 
move the mouse to the left or right to move the joint.



To rotate around the Z-axis, shown in violet, you have two choices. You can use the middle 
button, if you have a 3-button mouse, or the left button. If the joint can rotate around both 
the X and Z-axis, you have to disable the X-axis first. Double click on the bone and Lock the
X-axis by checking the Lckd box in the X row, as shown below:

That's all there is to it! You've created a key position for a joint. 

To make the character move, go to another frame (click the track window) and make a 
second key position. Click on the play button  to see it move.

Continue setting the positions of any joints that need changing until you are satisfied with 
the pose.

Related topics

 Flexible Joints

 Making a Sequence



Editing Key Frames

You can edit key frame values for individual joints. Double click on the joint's track in the 
expanded view of the track and the Key Joint Editor dialog will appear:

The current joint angle value is shown in Value and the current frame in Frame No. If it is a 
key frame for the joint you will be able to enter a new value for the key and you can delete 
the key with the Delete Key button. 

If it's not a key frame you can make it one with the Add Key button. 

The plus + and minus - buttons advance the current frame by one in either direction.



A Circle Has 720 Degrees

Sometimes rotation is not quite a simple as giving the first and last positions and letting the
computer figure out what to do in-between. For constrained joints (those with limits on how 
they can be rotated) like the one below, things are simple. Moving from position A to 
position B simply rotates to the right.

However, for free or unconstrained rotations this doesn't quite work. There are two 
directions that the joint can move: clockwise or counter clockwise.

Anim8or resolves this dilemma by expanding the range of angles that you can use to be 
from -360 degrees to +360 degrees. There are then two values that represent the same 
position. One-quarter turn to the right is either +90 or -270. If the difference between the 
angles is less than 360 degrees, the joint simply moves between the two. If it's greater than
360 degrees then the joint moves the opposite way. It's not really as confusing as it seems 
when you try it out.



Making a Sequence

A Sequence can be thought of as several Key Poses played back in order. Every joint 
position in a key frame is linked to the previous and following positions. Anim8or fills in joint
positions for the in-between key poses. When viewing an animation, characters appear to 
make a continuous motion. The smoothness and speed of this motion depends on how fast 
and in what ways the key poses change. A large part of the work in animation concerns 
getting the motion just right.

After making a key pose, set the sequence to a later frame by clicking the appropriate part 
on the track or with the left/right arrow keys. Then make another key pose. You don't have 
to set the position of every joint, just the ones needed. If one part of your character is 
moving at a slow pace, or needs less detailed control, save yourself some work. You can 
always go back and add more keys if you find you need them.

If you enable Ghost View you can see the relative positions of other frames. This makes it 
easier to adjust things relative to one another. Ghost view can get rather confusing at times,
so it helps to hide the body parts and just animate the skeleton.

Change the frames to be ghosted with the Options->Ghost Settings command. They can be 
limited to just key frames, or be a fixed step of frames apart. You can also adjust the 
number of ghosts with count:



Related topics

 What is a Key?

 Making a Key Pose



Scene Editor

The Scene Editor is where you build sets, adding objects and figures, cameras and lights, 
and construct your final scenes. Everything can be animated; cameras, lights, and 
characters. And you can save the output as a sequence of still images, or as an .avi movie 
file. You can even generate stereo views! You enter the Scene Editor from the Mode->Scene
menu item.

The basic scene editor is shown below. You can configure it to show either four views (front,
top, side, and perspective), a single view from one of these views, and orthographic view, or
from the camera view. The usual menu, toolbar, and status bar are there, and a track bar 
that shows the current frame.

In addition to the normal select, move, rotate, and scale buttons in the toolbar, there are 
several more that perform functions specific to the scene editor.

Use the VCR style block of buttons to control the playback of your scenes. They work in the 
usual fashion.

The Axis button makes a joint's rotational limits and axis visible when you are animating 
joint positions

You can show or hide your figures' bodies with the Figure Objects button. This can make 
editing joints much easier.



The Camera button controls the visibility of your camera and lights. They aren't shown in 
the camera's view, the one that you normally use to render scenes.

The Path button sets the visibility of object's paths. Any object that you select will display its
path as an editable spline.

The key or Animate button enables animation. When it's pressed, the changes you make to 
the location, orientation, size and other aspects of objects in your scene will be animated 
when you play the scene.



Elements of a Scene

An element is a part of a scene. A new scene contains two default elements, the world and 
the camera. The world is the global coordinate system. The location and orientation of 
everything in a scene is, ultimately, relative to the world. The camera is the viewpoint for 
the movies you make. You cannot delete either the world or the camera.

Everything that you can add to a scene, including lights, objects, figures, and targets, are 
also called elements.



Adding Objects and Figures

Adding Objects 

You add objects to a scene by selecting the Build->Add Object menu item. This brings up a 
dialog showing all of the objects in your project. Select the one that you want and click OK. 
It will be added to the center of the scene. This is not the actual object; you cannot edit it 
from within the scene editor. Instead it is a link to the object. But you can scale the view of 
it within the scene, and add multiple copies of it. The screen shot of the scene above has 
three instances of the seaweed object in it.

It is often more useful to select world coordinates when adding objects to a scene. They are 
"dropped" into the scene at the center, at coordinates <0,0,0>, and are selected. 

Making sure that the move button is set, you can use the left mouse button to drag the new
object along the ground plane within any viewport. The right mouse button will raise and 
lower it.

You can also scale and rotate an object's size and orientation, and animate them by 
specifying a series of key frames.

Adding Figures

You add figures in the same manner with the Build->Add Figure menu item. They are 
dropped at the center of the scene. You must move them to their proper place. You can 
animate the position of a figure with key frames, and you can also attach predefined 
sequences of motion, as described in the Animation chapter.

Related topics

Animating Figures with Sequences



The Camera, Targets

The Camera

The camera is the reference point for a final animation. It's fully animatable. You can change
its position, field of view, direction, etc. You can also animate it for any variety of pans, tilts,
or dollies. You can attach a camera to another moving object for fluid tracking shots, lock a 
camera's direction on a moving target, and even move right through "solid" objects. To see 
what the camera sees, select the View->Camera menu item.

Targets

A target is a dummy point of reference. You use them as points of interest for the camera to
follow, or as a parent of a group of objects that you want to move. They are fully 
animatable, and do not appear in the final scene. You add a target with the Build->Add 
Target menu item.



Lights

When you first create a scene, there are two default lights in it. They give the scene an 
overall level of illumination so that you can see what you are doing. You can't move them 
about or change their properties. In general you should add your own user lights for better 
results. When you do the default lights are automatically deleted.

You add lights to a scene with the Build->Add Light menu item. This adds a light directly 
overhead with default properties. Double click on the light to change its color or other 
attribute, and drag it around the scene to change its position or direction.

Like other kinds of objects, lights are fully animatable, including their color.

There are three kinds of lights that you can use in Anim8or:

Infinite or directional lights cast an even light on all objects in a scene, with all of the rays 
parallel, like the sun. Close and far things are illuminated with the same level of light.

Local lights emit light that radiates out in all direction from a particular point in the scene, 
like the bulb in a lamp. Objects between the camera and the light are backlit, while those 
behind the light are front lit. The further an object is from a local light, the less illumination 
it receives from that light.

Spotlights are similar to local lights, but they only illuminate objects that lie within a 
particular cone. Things in the center are fully illuminated, while things near to the edge of 
the code are gradually lit with less light.

Lights do not appear in the final scene, or rather in any perspective or camera view. If you 
want an object to appear to emit light, then you must add a light in the same location as 
the object. 

You can also toggle the visibility of lights in the other views with the Show Camera button.



Object Properties Dialog

You can edit various properties of any kind of element by double clicking on it. This brings 
up a dialog like the Object Element Editor shown on the right. 

You can animate any value that has a controller button next to it, changing its value 
throughout a scene. Values with white backgrounds are fixed for the scene. You can edit 
them directly in this dialog. Values that are grayed out are animated. You edit their values 
by clicking on the adjacent button.

If you want to animate a fixed value, click on the button to add a controller. Controllers are 
explained in more detail later in this chapter.

There are several common fields to all element types:

Name

The element's name within this scene. Remember, an object element in a scene is only a 



reference to the actual object. There can be more than one occurrence of the same actual 
object in the same scene. If you change the original object in the Object editor then all of 
the references to it in your scenes will change as well.

Object

The actual element's name. You can select any object in your current project with the drop 
down dialog.

Location

The location of an object in <x,y,z> coordinates is shown here. This is the location relative 
to its parent's location and in it's parent's coordinate system. You can animate the location.

Parent

Any element can have another element for its parent. Then when the parent's position 
changes the element's position will change as well. With a parent, the location is a relative 
position. To specify a parent for an element, enter the parent's name in this box. To remove 
an element's parent entirely, clear the box or use the default world parent.

Orientation

This value shows you element's orientation in degrees of pitch, yaw, and roll. Pitch is a 
rotation around the X-axis, yaw the Y-axis, and roll the Z-axis. The values shown are a 
relative orientation to one of several coordinate systems. It can be either relative to its 
parent, to its path or direction of movement, to the orientation of another element's, or it 
can always facing a particular element. You can animate the relative orientation.

Enable Roll

You can disable an element's roll, keeping it "upright". You normally what to keep your 
camera upright so by default the camera cannot roll, but everything else can. Enable Roll 
can be animated.

Visible

You can animate the visibility of elements too so that they appear or disappear during your 
scene.

Shadows

Shadows add realism to your scenes but are very expensive to compute. You can decide 
which elements cause shadows and which ones show shadows on them. If you want an 
element to cast a shadow you must enable it with the casts checkbox. If you want it to show
shadows check the receives checkbox. 

Editing Properties



The Editing Properties values are useful when editing you scene. You can hide an element by
checking the "hide" box. This is useful to allow you to see what's behind something, or to 
simplify a scene for faster drawing. To show a hidden element, either uncheck the "hide" 
box, or select the Edit->Show All menu item.

You can lock an element by checking the "locked" box. This prevents any changes to any of 
its properties within the scene, such as location or orientation. This does not mean that it 
cannot move. If it is initially animated, it will stay that way. Locking only prevents you from 
accidentally changing that animation. 

Note: This does not mean that the element cannot be changed in any way. For example, if it
has a parent, then when the parent's location changes, so will the element's position, since 
it's definition of location is relative to the parents.

These values are only present for certain kinds of elements:

Scale: An element's size can be animated. However you do not use a dialog to do it. Instead
you simply select scaling , enable animation , and change the size.

FOV: You can set and animate the camera's field of view, the angle of the width of the 
image the camera shows on the screen. This value is in degrees.

Color: You can also animate the color or brightness of a light.



Light Properties Dialog

Lights have some unique settings that you can use. You access these from the Light Editor 
dialog by double clicking on a light.

 Change the color of a light by entering the numeric value directly, or by clicking the 
browse button next to the color sample. You can animate its color with the next to the 
numeric color values. 

 You can change your light into an infinite, local, or spot light in the Fixed 
Properties area. To access more advanced settings click on the Advanced button.

Advanced Light Properties Dialog



You can set several important lighting properties in the Advanced Light Parameters dialog. 
For Local and Spot lights you can set the light's range. These lights have a steady 
brightness out to a certain distance called the Inner Radius. Beyond that distance the light's
strength gradually diminishes until at the Outer Radius the light has no effect at all.

Spot lights are basically cones of light projecting from a point. You can set the angle of the 
cone and how sharply it falls off to the edge. Within the Inner Angle the spotlight has full 
brightness. Outside that angle the light's illumination gradually weakens until the Outer 
Angle where it had no further effect.

Shadow Properties of Lights

By default, lights do not cast shadows. You enable shadow casting by checking a light's Cast
Shadows checkbox.

Shadows in the real world are not totally dark. Some light is scattered off of nearby objects 
into these areas. You can illuminate the shadows in Anim8or as well with the Percent Dark 
parameter. This only allows diffuse light into shadows so that there are no shiny highlights, 
which would appear unrealistic.

There are two main kinds of shadows, volume and ray traced. You select which kind you 
want you light to cast in this dialog. Ray Traced shadows can cast soft edges. You control 
how soft the shadow is with the Size parameter. For infinite lights this is the angle that the 
shadow spreads from the edge of an object. For local and spotlights this is the physical size 
of the light. Objects closer to these lights will cast softer shadows than those further away. 



You can set the minimum and maximum number of samples used to calculate soft shadows 
in this dialog as well. The section on Shadows has more information on using shadows.

Related topics

 Shadows



Shadows

Shadows are a very important part of an image. They can also consume an enormous 
amount of computer time. It's important that you understand how they work or you may 
waste a lot of time waiting for your images to render.

Shadows are only visible in rendered images made from the Scene Editor. They are only 
cast from Lights that are added to a Scene, and are only cast by a chosen Object. 

To add shadows to your Scene:

1. Switch to the Scene Editor.
2. Add your own light and check the Casts Shadows box in the Advanced Properties dialog. 
3. Set the objects to Cast and Receive Shadows in their Properties dialogs.
4. Enable Shadows in the View->Preferences dialog.
5. Render an image or a movie. Shadows are not visible in the working views, only in a 
rendered image.

Volume Shadows

Volume shadows are usually much faster to render than ray traced shadows but they have 
some limitations. They have hard edges and you cannot use them to cast soft shadows. This
tends to make your images look unrealistic.

A bigger limitation is that you cannot use volume shadows to cast shadows from within an 
enclosed object such as a jack-o-lantern. While this is not a problem in most scenes it can 
cause you some unwanted "surprises" if one of your lights moves into an area enclosed by a
single object. You can work around this problem by splitting the object into two or more 
pieces, or by using a ray-traced shadow for the offending light. 

Ray Traced Shadows

Ray traced shadows are the most versatile. They can also consume a very substantial 
amount of time to render. 

Ray traced shadows can be either hard or soft. Hard shadows have a very distinct boundary 
between what is inside the shadow and what is outside. Your shadow form the sun on the 
ground is an example of a hard shadow.

Soft shadows don't have a distinct boundary. Instead the amount of light gradually lessens 
until the shadow reaches its maximum darkness. The shadow cast by a florescent light is an
example of a soft shadow. Such shadows are soft because the apparent size of the light 
casting them is large. As shown below soft shadows can be much more realistic:



Soft shadows are costly to computer. Many individual shadow samples are used to make a 
soft shadow. Anim8or therefore limits soft shadows to Anti-Aliased images where multiple 
image samples are used for each pixel. High quality soft shadows often require even more 
samples than Anim8or uses for anti-aliasing. To limit the total cost of these computations, 
Anim8or adapts the number of samples to the image as it is being rendered. If there is 
nothing "interesting" in an area then only a few samples are taken. If a shadow edge is 
detected, however, more samples are taken to improve the image. You can set the minimum
and maximum number of samples used for each light in the Advanced Light Properties 
dialog.

In general, you will need to set the number of samples higher for larger sized lights that 
cast soft shadows. You will also have to increase the number when a light is very close to an
object since this will magnify it's shadow's soft part.

Related topics

 Light Properties Dialog



Environment Settings

You can use the Environment Settings dialog to control several things in a Scene. You can 
add a background image which can either be a fixed image, or a panorama that moves as 
the camera pans. You can also add fog effects. Open it with the Settings->Environment 
menu command.

 In the Background Area you can set the background for your scene several ways. By 
default it is a Solid color. You can change the color with the browse button next to the color 
sample.

 You can also use a Fixed image for the background. To do this select the Image option
and load an image to the File field with the Load button.

You can also use an image as a Panorama. The image is wrapped around a scene in a big 
arc. When the camera moves it will pan across the background.



Set the area that your background fills in the Panorama Angle area. Be careful not to aim 
the camera past the edges of the panorama or the background color will show. The diagram 
below shows how this works.

Note: backgrounds only appear in the Camera View.

You can remove the default ground grid from a scene by unchecking the Ground Grid box.

Distant fog can add realism to a scene. It is useful for underwater shots as well as distant 
outdoor views. To allow it check the Enable box in the Fog area. You can set fog color, the 
distance from the camera at which fog will Start to appear, and the End distance where it 
has maximum saturation. You can also limit the Maximum effect of fog so objects won't 
disappear entirely in the distance.

Shadow Bias is an advanced technique used to hide ugly rendering artifacts that can appear
when shadows are used. These artifacts are caused because the lighting computations 
assume that your models have smoothly curved surfaces. In reality they are made of flat 
faces. Shadow computations are based on these flat faces and don't always get along with 
the lighting computations. 

To overcome this discrepancy, a shadow bias is used to push shadows slightly back away 
from the viewer, then everything looks fine. Normally the shadow bias shouldn't have to be 
changed.



Scene Time Track

At the bottom of the window is the Scene Time Track. If it isn't visible on the screen, select 
the Options->Track Window menu item:

On the left is the scene's title. It is the top of a tree description of the elements that make 
up your scene. If you click on the "open" box  you can expand the window to show the 
objects contained in the scene. 

You can change height of the expanded track window by dragging the horizontal resize bar 
 up or down, and the width of the name field by dragging the vertical resize bar to the 

right or left.

The right part of the track is a time line for the scene. If you click on it, the display will 
switch to the time you selected. Each tick mark represents one frame. Seconds are marked 
with full vertical lines. Normally there are 24 frames/second but you can change this to 
other frame rates with the View->Preferences dialog. The current frame is highlighted in 
dark gray.

You can click and drag the mouse it will select a range of frames. Use Shift-Click to select a 
new frame range while still keeping the same current frame.

When expanded, the left part of the track shows the objects in your scene. There is a lot of 
useful information here. You can see what an object's parent is, what properties have been 
animated, which bones can be rotated, and such. In the view above the highlighted object 
shark1spot's parent is the world. Its location is animated and it has a child object called 
cookie. If you see an "open" box  by an item then it has more information that you can 
display by clicking on the box.

You can select and edit items shown in the name section of the track by clicking and double 
clicking on them. Mouse buttons have their normal meanings with the right one adding to 
the selection and the middle one subtracting. Double clicking is how you can edit the 
numeric value of animated properties like an element scale that does not appear in a dialog.

Related Topics



 Visual Quality



Previewing Images, Rendering AVI

Previewing Images

Preview a software rendered image of any view using the File->Preview command. The 
dialog shown on the right will allow you to set the size and background color of the image 
and set it to Anti-Aliased.

You can also use the Render->Preview command to do this in the Scene Editor.

Rendering an AVI Movie

To render an .avi movie, display the camera's view on the screen by selecting View-
>Camera and then Render->Render to File. Select AVI and any other settings you prefer, 
and Anim8or will render your movie.



The Alpha Channel

When you render an image, you can isolate the elements in your scene from the 
background. You can save both the images of your elements and a mask showing where 
they are. This mask is called an Alpha channel. It's really nothing more that a black-and-
white image in the shape of your elements. It has a value of 0 where your elements are 
drawn, and 1 where they aren't. Transparent parts and edged in anti-aliased images will 
have a value in-between representing how much of the pixel your elements "own". You can 
use the alpha channel to combine images made in Anim8or with other images in a paint-
program, as you will see below.

You make an alpha channel by selecting the "Alpha Channel" button in the preview dialog. 

You can also make two very useful images with one rendering by selecting the "Image + 
Alpha Channel" button. One is an ordinary alpha channel and the other is a special element 
image that has been pre-multiplied by the alpha channel. It shows your elements normally 
but is black where your elements are not. Partially transparent parts of your elements are 
dimmed to the degree that they are transparent. You can then use these two images to 
merge your Anim8or elements into another computer generated scene, or an ordinary 
photograph. You can see how this works in the following composted image example.

Step 1: Multiply photograph by alpha channel:

              

              

          Photograph                X                Alpha Channel            =      Masked Photograph

Step 2: Add Anim8or image to previous result:

              



              

Masked Photograph    +    Pre-multiplied by Alpha    =        Final Composite    

Using Alpha Masks

To mask an Anim8or generated image into an existing photo using the Alpha channel and 
Paint Shop Professional: 

1. Render an image with image+alpha channel selected. 
2. Save both the image and alpha image as .bmp or .jpg files. 
3. View them in PSP with your background image there as well. 
4. Use the Image->Arithmetic command as follows:

First multiple the mask with the background image. Set the divisor to 255 to make the lever
right. Call this Image A. Then add Image A to the 3D model with a black background. Set 
the divisor to 1 this time. The result should be what you want. 

Note: It's easier to do if all the images are the same size.



Animation

You can animate the elements of a Scene by setting their location, color, size, etc. in a few 
Key Frames. The computer supplies the remaining values between these Keys. You can take
more control of how things animate by adding more keys. Besides their basic value, some 
keys have additional properties that you can edit for further control.

A Segment is the values for a range of frames between two successive Keys. You can 
change how fast things move between key values by editing the properties of segments.



Animation with Key Frames

You can animate an element by simply moving it on the screen. First enable animation by 
clicking the Animate button. Its background turns green indicating that you are now 
animating. Change to a new frame by clicking on the frame in the Time Track. Then select 
an element and move it to a new location. Anim8or will add Key Frames for the element's 
location in these two frames and smoothly fill in the locations for all frames between these 
Keys. 

When you press the Play button your element will now move!

You will also notice that a Spline Path has been added to the scene. This is the element's 
path through space. You can add more points at different frames to build complex motion. 

You can also edit the shape of the splines by clicking on the Edit Path button on the toolbar.

Editing object positions is described in more detail in the Sequence Editor chapter. But there
are a few things to note:

When the Animate button is off (gray) any change made will apply to the entire scene. If 
you move the camera, for example, it will move the same amount in every frame. When the
Animate button is on (green) changes made will only apply to keys in the current frame. In-
between frames will reflect these changes.

When moving or rotating an element that is a child of another element, the change is 
relative to its parent. The same is true when you rotate an element that faces its path of 
movement. The change is relative.

You can edit individual key values by double clicking on the key in the Time Track. See the 
Animating Figures with Sequences section for more details.

Related topics

 Animating Figures with Sequences

 Time Track



Animating Figures with Sequences

You can animate a Figure by adding an entire Sequence of key positions. If you make a 
sequence that represents one cycle of a walk it can then be added to a scene several times 
to make a longer walk. Sequences are shown in the track bar by <---->. The track below 
shows a 31-frame sequence for three joints:

Sequences in a scene are linked to the Sequence Editor. Any change made to a sequence 
automatically appears in a Scene. So you can't modify keys that are part of a sequence in 
the Scene Editor. If you try Anim8or will ask if you want to convert that particular reference 
to the sequence into individual keys and continue. Converting a sequence in the Scene 
Editor will not alter the original sequence and the link between the sequence and scene will 
be lost, so further editing of the sequence will not affect these keys of a scene.



Controllers

Controllers manage Key Values for animation in the Scene Editor. When you move, rotate or
animate any aspect of an object that uses a key, a controller is created to hold that key. 
Each controller manages just one aspect of a scene. For example, one for the location of an 
object and another for the color of a light. Controllers contain all the keys regarding this 
value and any related data.

If an aspect of an object is constant for the scene, and not animated, it will not have a 
controller. The one exception is for bones. They always have a controller for each axis of a 
joint that can bend. This makes it easier to find the bones that can move when posing a 
figure.

Controller Types

There are several types of controllers. Each uses a different kind of data, or computes in-
between values in a different manner, depending on the needs of the property that is 
animating.

 Float: This is a ordinary number like 10.5 or -150. Like most controllers, in-between values 
are smoothly interpreted.

 Point3: Point3s return 3 numbers per frame. Each value is smoothly interpreted without 
regards to the others. Use these for positions and RGB colors.

 Orientation: An orientation controller returns a rotation per frame. They can set the 
orientation of an object or can be used for a rotational direction. When you edit these values
in a dialog you see the PYR (pitch, yaw, roll) equivalent to the orientation.

Orientation is more complicated than it seems. Interpreting angles smoothly does not result
in the smooth rotation of a model. The order in which pitch, yaw and roll are applied is also 
important. Anim8or uses PYR, because by applying roll last you can set it to 0 and the 
elements stay "upright". It is often easier to ignore the numeric values for orientation and 
simply orient it on the screen.

 Boolean: Boolean controllers return a "yes" or "no" value. You can use them for an object's 
visibility if you want it to suddenly disappear. There is no "maybe" value for a Boolean.



Editing Keys

Edit a key by double clicking its key indicator in the Track, or by clicking the button for its 
controller in an element's properties dialog.

You can edit a location key's X, Y, Z values and Add or Delete keys in the Key Position dialog
box. 

Entering a Frame number lets you move to any frame in a scene, and clicking on the + and 
- buttons move to the Previous and Next frames. In-between frame values can be viewed 
but not changed. Anim8or supplies these values. 

The Edit Seg button allows you to edit the segment next to the current frame.



Editing Segments

Oops! Segment properties didn't quite make it into this release. These values won't do 
anything ... yet. If I get them working soon I'll make a new release but in the mean time 
you'll just have to be patient. Sorry!

By default values vary at a consistent rate between keys. But this is not always what you 
want. How quickly a character reaches full speed when starting to move, or how long it 
takes to slow down when stopping, are important elements in animation. We normally think 
of small, lightweight objects as accelerating rapidly to full speed, but large or heavy ones as
taking a long time to build up steam. In animation terms something is said to ease out and 
ease in if it is slow to start and stop.

By editing the segment's properties you can change the speed a value changes in several 
ways. You can set the number of frames that it takes an object to change speeds, size, 
color, etc. at the start or end of a segment with the ease in and ease out settings. You can 
also select the opposite: hard out and hard in where you might want an object to accelerate
at the end just before it splats into a wall to increase the visual effect.



Materials

Every visible surface has a material. By changing their various properties you can set the 
look of figures and objects. Materials provide a richness and detail that adds considerably to
the realism of a scene. You can make them shiny, dull, transparent and opaque. You can 
texture a surface by using an image as the material's color or to lighten or darken its basic 
color. You can also use a texture to control the transparency.

You can't really design the look of a scene with materials alone thou. Its ultimate 
appearance also depends heavily on the lighting you choose.



Material Editor

Use the basic Material Editor when you need to design the color, texture, transparency and 
other visual properties of an objects appearance. You can open the material editor either by 
double clicking on a material in the material toolbar, or from a specific object's editor dialog.
An example is shown below.

Some of the entries should be fairly obvious to most of you. Others can probably use a bit 
of explanation, so there's a short description of them in the following table. You can see how
each property affects the look of the sample material shown below. Its parameters are all 
set to the defaults shown above with just a single value changed for each one. Ambient and 
diffuse are not locked together. The base colors are:

Ambient: R=0, G=92, B=224: 

Diffuse: R=0, G=255, B=128: 



Specular: R=255, G=255, B=255: 

Emissive: R=255, G=0, B=0: 

Name
The name of the material. This field can be left as the default "material00", but it is a good 
idea to give each material a useful name.

Ambient
The ambient component is the color of a material in a shadow. Normally you want it to be 
the same as the diffuse component. In fact this is so common that there is a button that will
lock all ambient and diffuse values together so you don't have update them both to make 
changes. 

The number to the left is how much ambient component adds to the final color. The normal 
range for the ambient weight is from 0.0 to 1.0. The row of materials below have an 
ambient value ranging from 0 on the left to 1 on the right:

Diffuse
The diffuse component is what you would normally call the "color" of a material. It is 
combined with the amount and color of light illuminating your model and added to the final 
color.

The normal range for the diffuse weight is from 0.0 to 1.0. These samples vary the diffuse 
value from 0 to 1:

Specular
The specular component is part of the "shininess" contribution. You normally set this color 
to white to reflect the light's color. For metallic surfaces you should change the color to 
something closer to the diffuse color.

The normal range for the specular weight is 0.0 to 1.0. These samples vary the specular 
value from 0 to 1:



Emissive
The emissive component represents light generated by a material. It is not affected by 
lighting. You use this for things like lava and eyes that glow in the dark.

The normal range for the emissive weight is 0.0 to 1.0. The default value is 0.0 to prevent 
glowing. These samples vary the emissive value from 0 to 1:

Rough
The roughness of the material. A higher value makes the surface look shinier. It is tempered
by the value of the Specular component. Values range from 1.0 (not at all shiny) to 100. 
These samples vary the value from 2 to 64 by multiples of 2, and have the specular weight 
increased from 0.2 to 0.6 to show the changes better:

Trans*
The transparency of the material. Actually, it's the opaqueness of the material. 1.0 is fully 
visible, while 0.0 is completely transparent (but still shows specular highlights). Low values 
like 0.1 and 0.2 make glass. You must enable Transparency in both the View->Preferences 
dialog in the OpenGL Workspace and the File Output areas for transparency to show. It also 
helps to enable Options->Backside visibility for the OpenGL Workspace.

Brilliance*
The brilliance factor. This setting changes the appearance of the diffuse component. Normal 
objects have a value of 1.0. If you increase it by a small amount to 1.5 or 2.0, the material 
takes on a sort of metallic sheen, or for brighter colors, a deeper, richer appearance. A value
less that one flattens the look of the material. Here the value of brilliance changes from 0 to
2.5 in steps of 0.5:

*Note: Transparency and some more advanced texture modes may only affects rendered 
images. Its final effect can only be partially shown in interactive sessions. Some graphics 
cards can show more than others, depending on which features they support. You can 
render a test image to see how the final model looks.

The texture button opens the general texture dialog for this material. You may use several 
textures on a single material, changing the diffuse color, transparency, emissive color, and 
more. You can also apply a bump-map texture. See the Texture Selector section for more 
details.



The Two Sided checkbox gives the material a different material for its front and back sides. 
The front and back buttons show which side's properties are currently displayed.

This button deletes a material. You will be notified if it is currently in use and given a chance
to cancel the delete.

These four color patches show the current value for the ambient, diffuse, specular, and 
emissive colors. The currently active one is outlined and the lower part of the window shows
its numeric value. You can change the active color to a different patch by clicking on it.

These buttons show you if a particular component uses a texture. If the button has a "T" on 
it then it uses a texture. If not then it doesn't. You can click on a button to set a particular 
texture.

Related topics

 Texture Selector



Material Settings

A few simple material images and their settings are shown in the table below. Notice that 
the values for Pearl are out of the normal range. The ambient weight is more than 1, the 
diffuse is negative (which means lights actually darken a surface), and the specular value is 
way more than 1. Don't be afraid to experiment!



Texture Selector

The texture selector allows you to load, view and manage the textures used in an 
animation. You open this dialog from within the material editor with one of the 4 property 
browse buttons. An example is shown below right:

You can change the name of the texture in the Name field and view the size of the image 
Anim8or uses to store it in the Texture Map area.

The File Image area gives information about the file containing the texture. The Type field 
can be either RGB for normal images, or RGBA for .gif files with a transparent color. If your 
texture is type RGBA then you have more flexibility in what you can do with it.



Advanced Textures

You can use textures for more than simple diffuse color maps. For example, you can map 
the transparency or shininess of a material to a texture. You can also use multiple textures 
on a material. 

Basic textures can be selected directly from the Material Editor but you need the more 
advanced Surface Texture Editor for more exotic uses. Open this dialog by clicking the 
Textures button in the Material Editor dialog:

The example shows a normal diffuse texture named "spots" and a bump-map texture 
named "noise". The net effect is a bump-mapped, spotty material. The following image 
shows some of the surfaces that you can make with a simple gray color and a single spotted
texture:



The top row shows the basic gray color and simple spotted texture used for all the spheres. 
The first sphere on the middle row simply uses the texture as the diffuse color. The next 
sphere uses it as the specular map. Notice the faint spots where the surface isn't shiny. The 
last has an emissive texture. Note that the emissive weight must be set to something other 
than 0.0.

The bottom row shows the same texture used as a transparency map, and a bump-map. In 
the final sphere as both the diffuse color and bump-map. You can often use the same 
texture in this was to create a bump-map. It doesn't always work, especially when there are
strong shadows on the image. Here are some more examples where it works:



Texture Mode

You can blend textures with the base color of a material in several ways. Textures with an 
alpha channel are even more versatile. You set the way textures behave in the texture 
mode dialog, which is reached through the mode button in the Surface Texture Editor.

Use the Blend Mode to control how the color of a texture changes the base material color. 
Decal simply replaces the color with the texture. Darken multiplies the value of each color 
component which tends to darken the image. Lighten adds the two values which can only 
make the image brighter.

If the texture has an alpha channel (like a transparent .gif) they you can use it in three 
different ways by setting the Alpha Mode. None simply ignores the alpha. Layer uses the 
alpha channel to blend between the texture's color and the material's color. Final uses the 
alpha channel as the material's final transparency value.

Here is an example of what can be done with one texture and one surface color. The cyan 
(light blue) color of the texture is the transparent color in a .gif file:



Note: These types of materials will not always look like this in your interactive viewports. 
Different graphics cards have different capabilities. If you want to be sure what your model 
will look like it's best to occasionally make a preview image. 

Some aspects of a texture mode are only meaningful for certain texture uses. For example 
bump-maps don't use an alpha channel so Alpha Mode doesn't have any effect on them.



Make .x Files

Anim8or cannot export directly to .x file format. But you can export objects as .3ds files and
use the Conv3ds program provided free by Microsoft to convert them into .x files.

Conv3ds is a utility to convert .3ds files to .x files. Export to .3ds and run this utility, then 
use in whatever Direct X fashion you want. It can do animations with the -A option, but 
Anim8or doesn't currently export .3ds animation keyframes.    You might need to specify the
-m option to get it to work.

Sometimes Conv3ds fails with strange error messages.    You can try setting the menu flag 
Options->Debug->Dummy 3DS KData which can help in some cases.

Conv3ds Options
 
 -m Output 3ds model as a single mesh and not a frame hierarchy
 -A Include animation data in X files
 -T Wrap all hierachies in a top level frame
 -e "extension" - Change extension of texture map files
 -M Don't include material data in X files
 -N Don't include normal data in X files
 -f Don't include frame transforms in X Files
 -h Don't try to resolve keyframe hierarchy
 -c Don't include texture coordinates in output
 -r reverse winding order for face and normal information
 -t Don't include texture mapping information in the X file.
 -z float - Specify a face color alpha delta between 0 and 1
 -Z float - Specify maximum alpha value to be affected by delta
 -C Don't change black textured faces to white textured faces
 -p Don't use the 3ds specular color for materials
 -o "filename" - Name output file.
 -s float - scale the meshes by the given factor
 -x - save out as text X file
 -X - save out templates in X files
 -v integer - Verbose mode



Particles

Anim8or doesn't support particles, yet :-). But rounder, an Anim8or user, has written a 
particle generator called Anitweak that outputs .an8 files that can be used by Anim8or. 

You can get a copy here:

 http://www.biederman.net/anitweak



wglMakeCurrent() Failed

This is caused by a failure in your graphics card's driver software. When you see this the 
OpenGL 3D graphics library did not run properly. There should be an error number 
beginning with "0x" and for common causes there will be an error name like 
ERROR_INVALID_PIXEL_FORMAT giving an indication of what failed. If the error shown is 
"ERROR_???" appears send me the error number if you like so I can add it to the error 
message table for future releases.

Normally the only way to fix these errors is to update your graphics card's driver. 
Sometimes you can get around the problem by changing the color depth, or "bits per pixel",
of your screen, etc. 

If you have a Voodoo card see:

 Voodoo Graphic Card Problems



Viewports Don't Draw Correctly

The most common cause of the viewports not properly drawing is your graphics card and it's
driver software.    The best thing you can do is to download and install the latest driver for 
your graphics card.

Anim8or uses many more features of the OpenGL graphics library than any game does.    
The primary focus for 3D cards is gamers so graphics card makers always make sure games
work before releasing their products.    Unfortunately they don't spend the same amount of 
effort on the rest of OpenGL.    They do keep improving and releasing newer drivers, 
however, so chances are there's a better one waiting for you now.



Voodoo Graphic Card Problems

The 3DFX series of Voodoo work with Anim8or if you have one of their good OpenGL drivers.
Many people have reported problems with the new 1.07 DX8 driver and Anim8or.    They 
have solved this by reverting to previous 1.06 DX7 driver.    I don't know when, or even if, 
this will be solved given the current state of 3DFX.    If you have a Voodoo, I suggest that 
you get a copy of both of these drivers and keep them in a safe place.



Missing Textures

1. The most likely reason that texture are not showing up is that they are disabled. This is 
true for both the working viewports and for any rendered images. To fix the problem, select 
the View->Preferences command from the menu. Make sure that Textures is checked in 
both the OpenGL Workspace area and the File Output area. You also probably want to check
the MipMaps box in the OpenGL area, too.

2. Your objects also have to have texture coordinates assigned for textures to work. Most 
things built in Anim8or will have default values assigned for you. If not, or if you import 
something that doesn't have texture coordinates, you can add them with the UV Texture 
tool. 

3. Another reason that your textures may be visible is your graphics card. Each card has a 
maximum size that it can use to store textures. On some, such as the VooDoo 3000, the 
limit is 256x256 textels. If you reduce the size of these images using any paint program you
can use then on such cards.

On rare occasions these boxes become un-checked for no apparent reason. I think the 
problem is in Anim8or but I have been unable to find the cause. So until I do, if it happens 
again just go back and check them again.



Saved .an8 File Won't Load

If you can't reload a .an8 file after you have saved it there are several things that you can 
do to try and save your work. The file is written as an ordinary text file so you can load it 
into any text editor and look at it. The most common problem is that the file has been 
truncated. When this happens you can delete the end of the file until the braces are paired 
(to the point where a closing brace is not indented) and the file might load.

Note: There was a bug in version 0.7 that could cause a file that is *exactly* one character 
longer than the input buffer to fail to read. In this case simply add an extra blank line at the
end to fix the problem. This has been fixed in v0.8.



Transparent Object Not Transparent

Make sure that the Transparency box is checked in both places in the View->Preferences 
dialog. The working views are only approximations of what your object will look like when 
rendered. Multiple layers of transparency is too computationally complex to do fast enough 
for the working views with current 3D hardware. To see the final result you need to make a 
test rendering with File->Render Preview.



Making AVI File Problems

There is a problem with the .avi compression library in Win98 that can cause Anim8or to 
report an error when you try to create an .avi movie file. You can usually solve this by 
choosing a different codec (image compressor). There are also some newer codecs available
for free on the web. Several people have reported that the Intel Indeo codec solves this 
problem. Anim8or should not crash but should catch any error and recover. If not let me 
know and I will see if I can fix it.

The following codecs should work with Anim8or v0.7 and later:

 
The Divx codecs are of particular high quality. They are available on the web at no charge 
from: 

 http://www.divx.com

The Indeo codecs are also fairly good. You can find them at:

 http://www.ligos.com






