Программа является экспериментальной. Автор не несет ответственности за возможный ущерб, причиненный этой программой. Если после запуска программы возникли проблемы, загрузитесь в VGA режиме, удалите из реестра ветки

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E968-E325-11CE-BFC1-08002BE10318}

HKEY_LOCAL_MACHINE\SOFTWARE\ATI Technologies

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ati2mtaa

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ati2mtag

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Video

и переустановите драйвера видеоадаптера. Желательно предварительно скопировать эти ветки в файл (кнопкой "Отчет") и послать мне.

Я могу тестировать эту программу только на нескольких картах, так что большая просьба послать мнеуказанные выше ветки(нажмите кнопку "Отчет", программа сама сохранит их в файл) даже если программа работает нормально. Это сильно поможет мне писать следующие версии ;).


NewTopic8

Для каждого разрешения программа запрещает все частоты развертки ниже определенных. Это делается с помощью ключа реестра DALRestrictedModesBCD ,программа не находится постоянно в оперативной памяти.
ВНИМАНИЕ!!! Запрещенные частоты развертки не могут быть установлены и в обычных 2D режимах, так что внимательно смотрите, чтовыставляете впрограмме. Рекомендуется проверить установки монитора в (Экран= >Настройка=>Дополнительно=> ATI Мониторы=> Монитор). Каждый из выставляемых видеорежимов рекомендуется проверить на работоспособность перед запуском программы.


NewTopic9

В реестре по адресу для
RADEON: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ati2mtaa\Device <цифра 0..9>
RAGE 128/128 PRO: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ati2mtag\Device <цифра 0..9>
В Windows XP этот ключ находится незавсисмо от карты по адресу

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Video{Classid}

Есть параметр типа REG_BINARY с жутким именем ;) DALRestrictedModesBCD. Этих параметров может быть и несколько, например DALRestrictedModesBCD, DALRestrictedModesBCD1 и.т.д. Этот параметр копируется при перезагрузке еще в несколько мест, но менять его надо именно здесь. Он запрещает определенные в нем особым образом видеорежимы.

Формат этого параметра:
xx1,xx1,yy1,yy1,bb1,bb1,rr1,rr1,xx2,xx2,yy2,yy2.....

Где xx,xx - разрешение по горизонтали, например 06,40

yy,yy - разрешение по горизонтали, например 04,80
bb,bb - разрядность цвета, например 00,24
rr,rr - запрещаемая частота развертки, например 00,60
Ключ получается: 06,40,04,80,00,24,00,60 - в разрешении 640x480 при 24Bpp запрещен режим 60Гц. Далее пишется следующий режим, и.т.д.
значение параметра 00,00 означает "для любого", например 00,00,00,00,00,24,00,00 означает запрет всех режимов 24Bpp.
Как вы, наверное, уже догадались, именно этот ключ программа и модифицирует.


NewTopic10

Q. После перезагрузки уменьшилось разрешение или включился "Виртуальный десктоп".
A. Выставлена слишком большая частота развертки или неверные параметры монитора, проверьте
Экран=> Настройка=> Дополнительно=> Монитор и
Экран=> Настройка=> Дополнительно=> ATI Мониторы=> Монитор

Q. Частота развертки не установилась.
A. Все изменения, сделанные программой работают только после перезагрузки WINDOWS. Если и после перезагрузки частота не установилась, то пошлите мне e-mail на адрес int13h@radeon2.ru , указав модель карты, версию драйверов, разрешение и частоты развертки, которые не отключила программа. Также крайне желательно прислать отчет, созданный программой.

Попробую исправить. (Такая ситуация может возникнуть на старых или новых драйверах,см. описание ключей , которые изменяет программа.)

Q. После переустановки драйверов частоты сбросились.

A. Установщик драйверов мог удалить те ключи, которые изменила программа. Установите частоты заново, или уберите удаление параметра DALRestrictedModesBCD из atixxxx.inf

Q. После запуска программы невозможен вывод изображения на TV выше, чем в 512x386.

Вывод изображения на TV возможен только при разрешенной для выбранног разрешения частоте развертки 60Hz


NewTopic12

"Форсировать анизотропную фильтрацию в Direct3D"

Работает только на драйверах 9008 XP/6006 (или выше), параметр AnisoDegree при увеличении значения улучшает качество, но уменьшает скорость.

"BlockWrite"

Включает блочную запись в видеопамять, сильно увеличивает FillRate. Включать только на картах с памятью SGRAM или DDR SGRAM.

"DrvStretchBLT"

Аппаратное ускорение копирования участков изображения с изменением размера.

"UCWC"

Включает для области линейного буфера кадра режим кэширования UnCachedWriteCombining. Ускоряет запись в видеопамять через линейный буфер кадра, особенно на PCI видеокартах.

"Включить LCD контроллер"

В некоторых версиях драйверов контроллер LCD может быть отключен. Этой настройкой его можно включить.

"Разрешить DDC2"

Разрешить опрос монитора по каналу DDC в формате DDC2. Попробуйте запретить, если ваш монитор не определяется корректно драйверами.

"Копирование в режиме DMA"

Разрешить копирование данных в видеопамять в режиме DMA. Разгружает центральный процессор.


NewTopic2

ATI Refresh Rate Fixer

Автор - Ворон К. А. aka int13H

Программа предназначена для изменения частот развертки на видеокартах ATI Rage 128/128 PRO/Radeon под Windows 2000/XP в Direct3D и OpenGL режимах.

Особая благодарность создателям сайта www.radeon2.ru , на котором и была найдена информация о ключах реестра.


NewTopic11

Программа позволяет включать отображение следующих закладок драйверов:

OpenGL - Параметры OpenGL. По умолчанию отображается.

Direct3D - Параметры Direct3D. По умолчанию отображается

Проектор - Настройки для подключения к карте проектора. По умолчанию не отображается

Поворот - Настройки ориентации изображения на дисплее. Применяется в основном для LCD мониторов с функцией поворота экрана. По умолчанию не отображается (в новых версиях, возможно, включен).


NewTopic5

Программа может включать и отключать отображение закладо к драйверов:

OpenGL - Закладка параметров OpenGL. По умолчанию включена

Direct3D - Заклкдка параметров Direct3D. По умолчанию включена

Проектор - Закладка для управления проекторами, подключенными к видеокарте. По умолчанию отключена

Поворто - Закладка управления ориентацией изображения на экране. Применяется, в основном, для LCD монитров с возможностью поворота. По умолчанию отключена.