NewTopic1

Author (Voron K.A. aka int13h) denies any responsibility for harm 2 your hardware which this program may cause. Program is EXPERIMENTAL.

If u have probs - reboot in VGA mode, delete these branches from registry:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E968-E325-11CE-BFC1-08002BE10318}

HKEY_LOCAL_MACHINE\SOFTWARE\ATI Technologies

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ati2mtaa

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ati2mtag

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Video

and reinstall video drivers. Author will greatly appreciate if you'll send to him ( int13h@radeon2.ru) that branches (just press "Report" button, program will save this brances in file) before deleting them (in compressed form as attachment please). This will help him modify program to avoid such probs in future.


NewTopic8

For every reslution this program disabling all refresh rates smaller than u set. It does with help of registry key DALRestrictedModesBCD ,program are not resident
Warning!!! Disabled refresh rates can't be set in 2D modes too.

Strongly recommendated to checksettings in(Control Panel= > Display= > Settings= > Advanced= >ATI Monitors= > Monitor) and check for workability all modes, that u set up in program.< /P>


NewTopic9

In windows registry at branch
for RADEON: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ati2mtaa\Device <0..9>
for RAGE 128/128 PRO: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ati2mtag\Device <0..9>
In Windows XP, independent of card model:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Video{ClassID}

Was plased key called DALRestrictedModesBCD (REG_BINARY type).

This key disables videomodes, defined in it.

Format:
xx1,xx1,yy1,yy1,bb1,bb1,rr1,rr1,xx2,xx2,yy2,yy2.....

Where xx,xx - horisontal resolution, for example 06,40
yy,yy - vertical resolution, for example 04,80
bb,bb - color depth, for example 00,24
rr,rr - disabling refresh rate, for example 00,60
Key looks as: 06,40,04,80,00,24,00,60 - in 640x480 resolution with 24Bpp disabling 60Hz mode.
Value 00,00 means "for any case", for example 00,00,00,00,00,24,00,00 means disabling of all 24Bpp modes.


NewTopic10

Q. Resolution changed after restart or turns on "Virtual Desktop".
A. Freqency is too high, check Control Panel=> Display=> Settings=> Advanced= > Monitor),checksettingsin(Control Panel=> Display= > Settings=> Advanced= >ATI Monitors= > Monitor

Q. Nothing happends.
A. All changes do not take effect until OS restart.If changes do not take effect until restart too, send me e-mail at int13h@radeon2.ru , where describe card model, driver version and problems. Please, attach with mail program's report (just press "Report" button, program will save it in "RefreshFix.rpt")

Q. Freqenses changes to default after installing new drivers.

A. Driver installator may delete keys, that program changed. Set up freqenses once more.

Q. Maximum TV-out resolution changed to 512x384.

A. For TV-out may be used only resolutions with enabled 60Hz refresh rate.


NewTopic12

"Force Anisotropic filtering in Direct3D"

Works only with 9008 XP/6006(or newer) drivers, increasing value of "AnisoDegree" will increase quality, but decrease speed

"BlockWrite"

Enable BlockWrite for videomemory, greatly increasing FillRate. Works only with SGRAM or DDR SGRAM videomemory.

"DrvStretchBLT"

Hardware accseleration of bit-block transferring with stretching.

"UCWC"

Enabling UnCachedWriteCombining caching mode for linear framebuffer. Increasing videomemory speed while writing trough linear framebuffer, especially on PCI videocards.

"Enable LCD controller"

Enabling LCD controller (may be disabled in some drivers).

"Enable DDC2"

Enabling querying of monitor in DDC2 mode. Try to disable, if yours monitior don't decetcting correctly.

"Enable DMA copy."

Enabling copying in videomemory in DMA mode. Decreasing CPU usage.


NewTopic2

ATI Refresh Rate Fixer

Author (Voron K.A. aka int13h) ( int13h@radeon2.ru )

Program main function - set refresh rates under Windows 2000 and XP in OpenGL and Direct3D modes. Supported videocards ATI RAGE 128/RAGE 128 PRO/RADEON (including LE,VE,7500,8500).

Thanks 2 radeon2.ru, where I have found information about registry keys.

Sorry for my awesome English ;)


NewTopic11

Progam let u switch on and off some tabs in drivers settings:

OpenGL - OpenGL parameters. On by default.

Direct3D - Direct3D parameters. On by default

Projector - Driver settings 4 plugging-in projector 2 your card. Off by default.

Rotation - Settings for changing orientation of display image. Could be used with LCD monitors with appropriate functionality. Off by default (in new drivers may be on) .


NewTopic5

Программа может включать и отключать отображение закладо к драйверов:

OpenGL - Закладка параметров OpenGL. По умолчанию включена

Direct3D - Заклкдка параметров Direct3D. По умолчанию включена

Проектор - Закладка для управления проекторами, подключенными к видеокарте. По умолчанию отключена

Поворто - Закладка управления ориентацией изображения на экране. Применяется, в основном, для LCD монитров с возможностью поворота. По умолчанию отключена.