Правила оформления новостей и регламентов версии

Инструкция по проведению репликации

После установки системы на Вашем рабочем столе появится папка ”Репликация”, содержащая следующие ярлыки (Рис 1):

  1. Входящая репликация (автомат)
  2. Исходящая репликация (автомат)
  3. Репликация полностью
  4. Входящая репликация (вручную)
  5. Исходящая репликация (вручную)

Рис 1

После запуска любого из этих ярлыков появится основное окно программы в режиме соответствующем выбранному ярлыку (Рис 2). Подробнее режимы работы программы рассмотрены ниже. Следует отметить, что ярлыки, в названии которых присутствует слово ”автомат” упрощают обмен репликационными файлами с Центральным Офисом. То есть если репликация запущена с помощью ярлыков “автомат”, файл репликации будет автоматически передан в ЦО после окончания исходящей репликации (скачан из ЦО перед проведением входящей репликации), обмен данными с ЦО ведется по каналу ftp. Если репликация была запущена в режиме “вручную”, то перед запуском входящей репликации пришедший из ЦО файл необходимо сохранить в папку D:\Agrobase\Repl\In, а после проведения исходящей репликации файл необходимо переслать в ЦО по почте или выложить на Ftp.

Рис 2

  1. Запуск и проведение автоматической входящей репликации.

Для проведения автоматической входящей репликации необходимо сделать исходящую репликацию и отправить пакет в Центральный Офис (ЦО).

В данном режиме репликационный пакет автоматически скачивается из ЦО, после этого проводится входящая репликация.

Данный режим может быть использован двумя способами –

А) После проведения исходящей репликации и отправки пакета репликации в ЦО запустив данный режим необходимо не закрывать свою сессию на сервере, после появления ответного пакета в ЦО он будет автоматически скачан, затем автоматически запустится входящая репликация. Будьте внимательны – необходимо оставить сервер и ваш компьютер включенными, и не закрывать сессию на сервере;

Б) Утром перед началом работы Вы запускаете данный режим, файл репликации скачивается из ЦО, автоматически проводится входящая репликация.

В случае А к началу рабочего дня в Вашем представительстве уже будет проведена входящая репликация, что позволит сразу приступить к работе. В случае Б нет необходимости оставлять на ночь включенными сервер и Вашу рабочую станцию.

Оператор, запустивший автоматическую репликацию в режиме А, ответственен за ее завершение. Если нет уверенности в возможности завершения автоматической репликации тем же оператором, запуск репликации в этом режиме запрещен.

Запустить ярлык “Входящая репликация (автомат)”. В появившемся окне начнет отображаться цикл чтения файла репликации с ftp сервера ЦО. При этом в окне программы будут чередоваться сообщения “Подключились к ftp” и “Файл не скачан”. Сообщение “Файл не скачан” появляющееся в вечернее время не является ошибкой, так как пакет для входящей репликации будет сформирован в ЦО ночью. После скачивания файла запустится Репликатор и будет проведена входящая репликация. Критерием успешного окончания репликации является надпись ”Входящая репликация успешно завершена” (Рис 3). Если утром файл не будет скачан из ЦО (будут продолжаться сообщения “Файл не скачан”), сохраните пришедший по почте файл в папке D:\Agrobase\Repl\In и проведите входящую репликацию с помощью ярлыка “ Входящая репликация (вручную)”, если письма с входящей репликацией не было – обратитесь на Поддержку Пользователей.

Рис 3

  2. Запуск и проведение автоматической исходящей репликации.

В данном режиме после успешного проведения исходящей репликации полученный файл автоматически передается в ЦО. Запускается ярлыком “Исходящая репликация (автомат)”. Критерием успешного завершения этого режима является появление сообщения ”Файл успешно передан в ЦО” (Рис 4). Необходимо дождаться подтверждения успешной передачи файла в ЦО, это займет от 15 до 30 минут с момента запуска исходящей репликации. Если при успешном завершении репликации файл в ЦО не передан, отошлите его в ЦО вручную (по почте на адрес repl@firm-august.ru или выложив на ftp сервер по ссылке ftp://august%5CLoader:2zx3Q!@ftp.firm-august.ru/repl/out/), файл исходящей репликации находится на сервере в папке D:\Agrobase\Repl\Out и имеет имя типа skladXXXX.rar , где вместо “sklad” будет имя Вашего представительства (например Kursk, Voronezh) а XXX – номер пакета.

Рис 4

  3. Запуск полного цикла автоматической репликации (ярлык ” Репликация полностью” ).

Данный режим является комбинацией второго и первого режимов – сначала запускается исходящая репликация, затем полученный пакет передается в ЦО, запускается цикл чтения фала из ЦО, после скачивания файла запускается входящая репликация. Этот режим предназначен для максимального упрощения проведения репликации.


Правила использования служебных каталогов репликатора

Каталог D:\Agrobase\REPL и его подкаталоги (D:\Agrobase\REPL\IN; D:\Agrobase\REPL\OUT; D:\Agrobase\REPL\LOG и другие) являются служебными каталогами репликатора и используются для проведения репликации.

Текущее назначение каталогов:

  • в каталог D:\Agrobase\REPL\IN помещается файл входящей репликации, полученный из ЦО
  • в каталог D:\Agrobase\REPL\OUT помещается файл исходящей репликации, отправляемый в ЦО
  • каталог D:\Agrobase\REPL\LOG служит для размещения в нем логов (журналов работы) репликатора. Логи (журналы работы) используются сотрудниками ИТ ЦО для анализа результата работы репликатора и поиска причин возникающих ошибок и проблем.

В процессе работы (входящей или исходящей репликации; а также в других случаях) репликатор может создавать в указаных выше каталогах свои файлы, которые могут иметь разные имена. В случае, если в каталоге D:\Agrobase\REPL и его подкаталогах будут находиться файлы, не относящиеся к процессу репликации, возможны как сбои в работе репликатора, так и порча этих файлов репликатором.

В связи с этим запрещается хранение в каталоге D:\Agrobase\REPL и его подкаталогах файлов, не относящихся к процессу репликации.


Регламент репликации

Репликация является процессом обмена и синхронизации данных между удаленными офисами (УО) и центральным офисом (ЦО) в обоих направлениях. Обмен данными осуществляется пакетами, передаваемыми по каналам компьютерной связи (FTP и электронная почта). Обработка (формирование) репликационных пакетов проводится с использованием специального программного обеспечения (Репликатор и средства автоматизации запуска репликации). Репликация в УО должна проводиться ежедневно, кроме выходных и праздничных дней. Проведение исходящей и входящей репликации в УО является обязанностью операторов Агробазы. Ответственность за организацию работы операторов по проведению входящей и исходящей репликации в УО несут главы представительств (в соответствии с приказом №230 от 28 мая 2003 г).

Репликация состоит из следующих этапов (подробнее - см. инструкцию по проведению репликации):

1. Формирование исходящего репликационного пакета в УО и отправка в ЦО (исходящая репликация в УО).

2. Обработка пакетов, поступивших из УО в ЦО.

3. Формирование ответных репликационных пакетов в ЦО и их отправка в УО

4. Прием и обработка пакета, поступившего из ЦО (входящая репликация в УО).

Если в УО не была проведена исходящая репликация, то в ЦО для данного УО не будет сформирован ответный репликационный пакет.

Входящая репликация в УО проводится в начале рабочего дня до начала работы с базой данных. Если к началу рабочего дня репликационный пакет из ЦО не поступил в представительство или при его обработке произошла ошибка – уведомите службу поддержки и получите инструкции о дальнейшей работе. Если уведомление службы поддержки невозможно, решение о начале работы без входящей репликации принимается оператором УО. Если работа со складской программой началась до проведения входящей репликации, и при этом вносились изменения в любые данные, входящую репликацию в этот день проводить запрещено. В таком случае (т.е. при изменении данных до выполнения входящей репликации) продолжайте работу с базой данных до конца рабочего дня, после чего проведите исходящую репликацию.

Исходящая репликация в УО должна быть проведена по окончании работы с Агробазой. Исходящий репликационный пакет должен быть доставлен в ЦО не позднее 19:30 по Московскому времени, т.к. обработка пакетов в ЦО, поступивших из УО начинается автоматически в 20:00. Если после отправки исходящего репликационного пакета возникла незапланированная необходимость работы в Агробазе, следует после ее завершения повторно провести исходящую репликацию (с отправкой исходящего пакета в ЦО). Если из-за работы в Агробазе после отправки первого исходящего пакета не удастся своевременно сформировать и доставить повторный пакет, повторную исходящую, а также входящую (на следующий день) репликации выполнять запрещено.