
Lateblight Help Index

This index contains all of the help topics available for Lateblight.    To select a topic, click 
on it with the mouse.    Topics are arranged according to the organization of the program.    
Use the scroll bar to see    entries that are not currently visible in the help window. 

For more information on how to use help, press F1 or choose Using Help from the Help 
menu.
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Introduction

Late blight is a disease of potatoes and tomatoes caused by the fungus Phytophthora 
infestans.    Under favorable environmental conditions, and in the absence of any control 
measures, this disease can destroy virtually 100% of the above-ground parts of susceptible
cultivars.    Inoculum produced on infected foliage can be disseminated to the tubers, 
where infections can also occur.    Losses include reduction of photosynthetic area resulting
in reduced bulking of tubers (yield loss), blighted tubers (quality loss), and decay of tubers 
in storage (postharvest loss).

Management of potato late blight begins with reducing the initial inoculum by:
 1. Keeping the numbers of infected seed tubers to very low levels by planting 
only certified seed
 2. Crop rotation to reduce the numbers of volunteer plants (which may be 
infected)
 3. Burying or composting cull piles, or at least keeping them far away from the
potato fields.

Control of late blight by means of potato varieties with a high degree of 
resistance to P. infestans has not proven to be very practical because of the 
rapid selection of virulent races of the pathogen.    Varieties with moderate 
levels of resistance, however, have been very useful when combined with 
other management tactics, particularly the use of fungicides.    In most potato 
growing areas, regular fungicide application is an essential component of late 
blight management.

Because of environmental concerns, the problem of fungicide resistance, and 
the high cost of fungicides and their application, potato growers have been 
forced to reduce their overall use of fungicides and to improve the efficiency of
the fungicides they apply.    One approach has been to improve the timing and 
adjust the dose of fungicide applications according to environmental 
conditions.    Various kinds of forecasting systems have been employed to help 
growers decide when and how much to spray.    By using potato varieties that 
are partially resistant to P. infestans, it is possible to markedly reduce the 
doses and/or frequencies of fungicide sprays.

This version of Lateblight was adapted from the simulation originally written 
by J. A. Bruhn et al. (1980) and modified in various ways over the years by 
different people working in the research program of W. E. Fry, Department of 
Plant Pathology, Cornell University.    We have retained the original structure of 
the model wherever possible, but some small modifications have been 
necessary to enhance its pedagogical value.    While the simulation is 
sufficiently realistic for teaching purposes, this version should not be trusted as
a research tool or a management decision making aid.



Weather

Weather plays an important role in the Lateblight simulation.    The necessary weather 
variables are read from disk at the beginning of each season.    When you select Runfrom 
the File menu, a dialog box will appear asking you to select a weather file.

If you save a Lateblight document to disk after the weather file has been read, the 
weather will be included in the document.    When such a document is opened, the season 
will be in progress, just as it was when the document was saved, and the same weather 
data will be used.

Five weather data files have been packaged with Lateblight:
COOLWET.LWX
HOTDRY.LWX
MODDRY.LWX
MODMOD.LWX
MODWET.LWX

Although these weather data sets are based on central New York weather data, they have 
been modified for pedagogical purposes.    The days on which rain occurs have been 
adjusted so that beginning with day 50, sprays can be applied at 5-, 7-, 10- or 14-day 
intervals without occurring on a rainy day.    The MODDRY, MODMOD, and MODWET, data 
sets have the same temperature data, representing a "typical" moderate season in upstate
New York, but they have data for rainfall and hours of relative humidity above 90% typical 
of dry, moderate, and wet seasons, respectively.    Since most seasons of high rainfall are 
also somewhat cooler than normal, and seasons of drought tend to be hotter than normal, 
data sets for cool, wet and hot, dry weather are also included.    You may also use your own
weather files, as long as they conform to the format given below.    Use of the .LWX 
extension is strongly recommended.

Although the system of measurement used for user interactions can be switched between 
American and metric, Lateblight expects its weather data files to use the units given 
below.    Each line of the file should contain the weather data for one day (a day for the 
model runs from noon to noon).    The first day corresponds to the day of median 
emergence of the potato vines.    The numbers on a line should be separated by spaces or 
tabs, and should represent the following, in order:

Rainfall (in inches)
Mean daily temperature (degrees Centigrade) - this is calculated as (maximum 

temperature + minimum temperature) / 2.
Period of relative humidity greater than or equal to 90% (hours)
Mean temperature during period of relative humidity >= 90% (degrees Centigrade)



Before Running

Before selecting Run, you will want to use the Potato menu to define the characteristics 
of the potato cultivar you want to simulate, the Inoculum menu to establish the levels of 
initial inoculum under which to run the simulation, the Management menu to initialize the
Blitecast forecasting system, and the Economics menu to define the values of the 
economic variables.    Otherwise, the simulation will run using the built-in default values, 
the values read from the STARTUP.LBT file, or the values assigned during the previous 
season.

To facilitate repeated simulations using the same values for these variables, the initial 
conditions can be saved in a disk file using the Save as... command prior to starting the 
simulation with Run.



During the Season

When you have selected Run from the File Menu and the graph has appeared, some of 
the menu commands will be disabled to prevent inappropriate changes in options and 
parameters.    Other items will be enabled to allow you to control how the simulation 
results are displayed and to control the program itself.    The most important control at this 
point is the scroll bar just below the x-axis.    Clicking on the arrow at the right end of this 
scroll bar will cause the simulation to advance by one day.    Clicking the page-up area will 
advance by one week; and dragging the thumb will allow you to go to an arbitrary date.    
Just as in the real world, you can't go back in time.

The Management menu allows you to spray systemic or protectant fungicides, or, if the 
epidemic gets out of control, kill the vines and thus immediately end the season.    If you 
chose to use Blitecast at the beginning of the season (before selecting Run), you can get 
a Blitecast report.    A weather report is always available from the Environment menu.

By browsing through the menu system and using the Help system, you can learn more 
about the other available options.



End of Season

At the end of the season, you can get an economic report by clicking on Show Report in 
the Economics menu.    You can also display other variables on the graph by selecting 
them in the View menu.    The entire state of the simulation (including the graphs and 
economic report) can be saved in a disk file using Save as....    A text summary of the key 
variables can be saved in a disk file using Log to Disk....    Start a new simulation using 
New (to initialize the simulation with the same parameters and options as in the previous 
run) or using Open... (to open a document containing different parameter values and 
options).



Run

Once you have decided on the appropriate options and parameters, select Run from the 
File Menu to begin the simulated season.    You will then be prompted to select a weather 
data file that will provide the season's weather.    To advance the progress of the simulation
during the season, use the scroll bar beneath the graph.



New

New allows you to begin a new simulation.    You may repeat the same problem or change 
parameters and/or options before running the new season.    Any parameters or options not
changed will be the same as in the last season.    You may want to use the SaveAs... 
command before selecting New so that you can recall the current season at a later time.



Open

Open allows you to open a saved Lateblight document in which is stored the state of the 
program at the moment you executed the Save As command in a previous run.    This 
includes all program options and parameter values.    If the season was in progress when 
the document was saved, opening it will return you to the day on which it was saved.    
(This is a good way to explore and compare different management strategies.)



Save As...

Save As creates a Lateblight document on disk using the name and extension you 
provide.    Use of the .LBT extension is strongly recommended to distinguish Lateblight 
documents from other types of files.    If you add a line for the .LBT extension to the 
[extensions] section of your WIN.INI file, you will be able to start Lateblight simply by 
double clicking a document.

A Lateblight document contains the complete state of the program at the time the 
document was saved.    If you save a document named STARTUP.LBT, Lateblight will load 
it automatically when you start the program.    In this way, you can override the default 
values provided for the various parameters and options.

A document saved before selecting Run will contain only the program options and initial 
parameter values and will take considerably less space on disk.    A document saved while 
a season is in progress will contain all information for that season up to the time when it 
was saved.



Log to Disk

A plain text record of all parameter values and day-by-day simulation results 
can be saved to disk using the Log to Disk... selection in the File menu.    This 
is especially useful for preparing printed reports.    Whether you choose Log to Disk before
a season is started, in the middle of a season, or at the end of a season, the log file will 
include all initial values and results from the beginning of the season onward.    If the log is 
closed before the end of the season, only the data up to the day when the log was closed 
will be saved.    A single log file can be used to record the results of several successive 
seasons.



Exit

This selection terminates Lateblight.    The same thing may be accomplished by double 
clicking the close box in the upper left corner of the Lateblight window.



Resistance Level

Different potato cultivars with differing levels of resistance to Phytophthora infestans can 
be simulated by selecting Low, Moderate, or High.



Harvest Season

To simulate different potato cultivars with differing rates of maturation, select Early, Mid, 
or Late season maturity.



Yield

To simulate different potato cultivars with different yield potentials, enter the maximum 
yield (in the absence of late blight) in cwt/acre or kg/hectare.



Length of Season

This variable is the number of days from median emergence of the potato vines to harvest.



Emergence Date

This is the calendar date on which median emergence of the vines occurs.    It is used as 
the basis for the labeling of the x-axis.



Weather Report

A weather report may be requested from the Environment menu for any day of the 
season.    The report includes actual temperature and rainfall data from the previous day as
well as a forecast of temperature and chance of rainfall for the current day and the next 
two days.    As in the real world, there is a degree of randomness in the forecasts.    They 
are based on the weather data that will actually be used in coming days, with a random 
component to reflect the inherent difficulty of predicting the weather.



Inoculum

In Lateblight, there are two independent sources of inoculum--sporangia and infections.    
Sporangia can be released all at once as initial inoculum or each day during the course of 
the epidemic.    Infections occur on the potato plants at the time of emergence.    Both 
Sporangia and Infections can be initialized either by designating the Number or by 
selecting the Source of inoculum.    Only the values in the checked item are used, and the 
values in the unchecked item are ignored.

To facilitate repeated simulations using the same values for Inoculum, the initial 
conditions can be saved in a disk file using the Save as... command prior to starting the 
season with Run.

See also:
Number of Sporangia
Sources of Sporangia
Number of Infections
Sources of Infections



Number of Sporangia

This is one of two alternative means of setting the number of initial sporangia.  
Enter the number of sporangia released per hectare or per acre.    The number 
of sporangia indicated will be released all at once on the day of plant 
emergence or each day of the season, depending on the alternative selected.   
Typical values are 250,000 sporangia/ha as initial inoculum or 25,000 
sporangia/ha each day.

Alternatively, the numbers of initial sporangia can be set by selecting the 
Sources of Sporangia.

See also:
Inoculum



Sources of Sporangia

As an alternative to setting the Number of Sporangia, you can set the 
quantities of sporangia contributed by two possible sources, a cull pile 
(potatoes discarded from a packing line) and a neighboring unsprayed field.    
To account for dispersal losses, the distance of the field being managed from 
each of these inoculum sources can be set.    Enter the maximum sporangia 
per day released at the source.    In the case of the cull pile, the number of 
sporangia released each day will decrease exponentially from this maximum 
as the season progresses.    A typical value for this maximum is 100 
sporangia/day.    In the case of the unsprayed field, the number of sporangia 
released per day will increase logistically from 0.001 to 1.0 times this 
maximum as the season progresses.    A typical value for this maximum is 5 
million sporangia/ha.    10 meters is a reasonable distance from the field for 
either of these sources.

See also:
Inoculum



Number of Infections

This is one of two alternative means of setting the number of initial infections. 
Enter the number of infections (per hectare or per acre) present at plant 
emergence.    A typical value is 10,000 infections/ha.

Alternatively, the numbers of initial infections can be set by selecting the 
Sources of Infections.

See also:
Inoculum



Sources of Infections

There are two possible sources of initial infections, infected seed tubers and 
volunteer potatoes in the field being managed.    Enter the numbers of 
infections per hectare or per acre present at plant emergence.    A typical value
is 10,000 infections/ha.

Alternatively, the numbers of initial infections can be set by selecting the 
Number of Infections.

See also:
Inoculum



Spray Systemic

There are two general types of fungicide available; a systemic and a 
protectant.    Spray Systemic... applies a fungicide that is absorbed by the 
plant tissues and is therefore not subject to weathering by subsequent rains.    
The systemic fungicide also acts to suppress infections that are already 
established.

Sprays are applied on the day on which the command was given and at the 
dose given in the Fungicide Application dialog box.    Enter the dose of the 
active ingredient in kg/hectare or lb/acre.    Click on OK to apply the fungicide 
on the date given at the top of the dialog box or on Cancel to exit the dialog 
box without applying the spray.

A warning is given if it is currently raining.    A spray applied in the rain will not 
leave the full residue of fungicide on the foliage.



Spray Protectant

There are two general types of fungicide available; a systemic and a 
protectant.    Spray Protectant... applies a fungicide that interacts with the 
fungus only on the plant surface.    To be effective, it must be applied prior to 
infection, and its residues must be maintained on plant surfaces by frequent 
applications.

Sprays are applied on the day on which the command was given and at the 
dose given in the Fungicide Application dialog box.    Enter the dose of the 
active ingredient in kg/hectare or lb/acre.    Click on OK to apply the fungicide 
on the date given at the top of the dialog box or on Cancel to exit the dialog 
box without applying the spray.

A warning is given if it is currently raining.    A spray applied in the rain will not 
leave the full residue of fungicide on the foliage.



Kill Vines

The order to kill vines immediately defoliates the crop and stops tuber 
development.



Blitecast

The Blitecast program will provide an advisory, based on the weather, of 
when protectant sprays are necessary.

The Blitecast forecasting system (Krause, et al., 1975) sums the "rain-
favorable" days and blight severity values for the past week and makes a 
spray recommendation for the current day.    Blitecast is invoked in the 
Management menu.



Costs

The costs of potato production can be established before the start of the 
season (before Run is selected) by selecting Costs...

For each of the items, enter the cost per acre or per hectare.    When all of the 
items show the desired values, click OK.



Price

Enter the market price per cwt. or per kg. for the current season's potato crop 
and click on OK.



Show/Hide Report

At the end of the season, a full accounting can be displayed by selecting Show
Report from the Economics menu.    Exit the economic report by double 
clicking the close box in the upper left corner of the window, or by selecting 
Hide Report from the Economics menu.



View Menu Check Items

The View menu allows you to select which of the simulation variables will be 
displayed on the graph as the season progresses.    A checked variable will be 
represented by a line of the same color as the check mark.    In this way, the 
View menu doubles as a legend for the graph.    In addition, the View menu 
also shows the current scaling factors for all variables.



American/Metric Measure

The American Measure and Metric Measure check items in the View Menu 
allow you to choose which system of units will be used throughout the 
program.    The American system expresses distances in feet and inches, areas 
in acres, weights in pounds (lbs.) or hundredweight (cwt., 100 lbs.), and 
temperatures in degrees Fahrenheit.    The metric system expresses distances 
in meters, areas in hectares, weights in kilograms, and temperatures in 
degrees Centigrade.

Whichever system of measurement you choose will be used consistently in all 
dialog boxes and other program displays.



Set Colors

The Set Colors command allows you to change the colors which are used to represent the
various simulation variables on the Lateblight graph.    In this way, you can be sure the 
different lines on the graph are readily distinguishable, regardless of what combination of 
variables you choose to display.    The Color Choices dialog box shows all of the variables 
which can be displayed on the graph, along with their currently assigned colors.    When 
the radio button next to a variable is checked, the color for that variable can be changed 
by clicking on the new color in the palette at the bottom of the dialog.    The line next to 
the variable name will change color immediately to reflect your choice.    When a variable 
is checked in the View menu, indicating that it is to be drawn on the graph, the check 
mark will be the same color as that variable's line on the graph.



Arrange

One of the benefits of the Microsoft Windows environment for a program such as 
Lateblight is that it allows multiple copies (or "instances") of a program to be run 
simultaneously.    In this way, it is possible to do side-by-side comparisons with each 
instance of Lateblight simulating a different situation.    The arrange command is 
intended to be used when more than one instance of Lateblight is running.    Selecting 
this command from the View menu will cause all non-iconic Lateblight windows to be 
arranged side-by-side to use the full screen without overlapping.    This command will 
arrange any number of Lateblight windows, but is really only practical with three or 
fewer.    If there are more than three Lateblight windows to be arranged, each gets only a 
very narrow slice of the display, making viewing very difficult.    Note that instances of 
Lateblight which have been minimized and are represented only by icons will not be 
arranged.    



Keyboard Actions

Like most Microsoft Windows applications, Lateblight is designed to use a mouse.    
Although a mouse is strongly recommended, it is not essential.    A keyboard interface has 
been provided for all of the essential features of the program.    Even when a mouse is 
present, there may be times when the keyboard interface is more convenient for certain 
actions.    Wherever possible, we have used the keystrokes that are standard among 
Windows applications.    The following is a brief summary of the keyboard interface of 
Lateblight.

The Main Window

The menu system uses the standard Windows keystrokes; underlined letters in menu items
represent hot keys.    The <Alt> key followed by the appropriate hot key provides access to
a popdown menu.    For example, <Alt>, F causes the File menu to pop down.    The arrow 
keys move the highlight to different items within the menu.    Pressing <Enter> with a 
menu item highlighted is the same as selecting that menu item with the mouse.    Pressing 
the hot key for a menu item has the same effect.    While the File menu is pulled down, 
pressing 'O' invokes the Open dialog box.

The window scroll bars also use the standard keystrokes.    <PgUp> and <PgDn> operate 
the vertical scroll bar, while <Ctrl>+<PgUp> and <Ctrl>+<PgDn> operate the horizontal 
scrollbar.    Note the distinction between the horizontal window scroll, which appears at the 
very bottom of the window when it is displaying a graph that is wider than the window, and
the simulation scrollbar, which appears below the x-axis when a season is in progress and 
is used to advance the date.    The simulation scrollbar uses the <+> key to advance one 
day, or <Ctrl>+<+> to advance one week.    <End> is equivalent to dragging the thumb 
all the way to the right, and advances the simulation to the end of the season.

Dialog Boxes

<Enter> and <Esc> operate the "OK" and "Cancel" buttons, respectively.    The <Tab> key 
shifts the input focus from one control to the next.    The control with the input focus is the 
one that will respond to keyboard actions (other than <Enter> or <Esc>).    The input focus
is indicated by highlighting of the text in an edit control, or a dotted rectangle around a 
radio button.    When a radio button has the input focus, the spacebar toggles its status.    If
the button is one of a mutually exclusive group, when it is deselected, the next button in 
the group will automatically be selected.

The Colors Dialog

The Colors dialog box allows you to reassign the colors that are used to represent the 
various simulation variables on the graph.    It is a little different from most of the other 
dialog boxes.    <Tab> cycles among the currently selected radio button, the color palette, 
the "OK" button and the "Cancel" button.    When the input focus is on a radio button, the 
spacebar or the arrow keys can be used to select a different button.    When the input focus
is in the color palette, it is represented by an inverted rectangle on the current color 
button.    The focus is moved from one color button to the next by using the arrow keys.    
Pressing the spacebar while the input focus is on a color button has the same effect as 
clicking that color with the mouse; that color is assigned to the variable whose radio 
button is selected.



Getting Help

Lateblight features a context sensitive help system which provides information about all 
aspects of the program,    To access the help system, press F1.    This will take you directly 
to the help item most appropriate for your current situation.    If no specific help item exists
you will be presented with the help index.    Selecting Index from the Help Menu will take 
you directly to the help index.

To get help on a menu command, pull down the menu and highlight the command using 
either the mouse or the arrow keys.    While the command is still highlighted (don't let up 
on the mouse button!), press F1.    The Help window will appear with the appropriate 
information.

To get help while in a dialog box. press F1.

If you need more general help with the Microsoft Windows ® environment, use the Help
Menu in either the Program Manager or File Manager window.

To learn more about the help system, press F1 while the Help window is active, or select 
Using Help from the Help window's Help Menu.



About Lateblight

Lateblight is based on the work of Bruhn   et al.  .    The simulation has been refined and 
adapted to the Microsoft Windows ® environment (ver. 3.0 or higher) by Barr Ticknor and
Phil Arneson , Department of Plant Pathology, Cornell University.    Lateblight is 
copyright © 1991 Cornell University; all rights reserved.    Microsoft is a registered 
trademark and Windows is a trademark of Microsoft Corporation.

Permission is hereby granted for this program to be freely copied and distributed subject to
the following terms and conditions:
1. All such copying and distribution must be done free of charge.
2. The program and all associated materials must not be modified in any way.
3. All of the following files must be distributed together :

LATEBLIT.EXE - the main program
KEYHOOK.DLL - the keyhook library which supports the context sensitive help 

system.
LATEBLIT.HLP - the help file
LATEBLIT.WRI - the manual in Microsoft Windows Write format
COOLWET.LWX - the sample weather files
HOTDRY.LWX
MODDRY.LWX
MODMOD.LWX
MODWET.LWX

4. If Lateblight is used in the teaching of any academic course, registration is 
required.  For each course and each semester in which Lateblight is used, a copy of 
the course registration form from the back of the manual must be completed and sent 
to the address given below before the program is used.    In addition, at the end of the 
course, or at the end of the module in which Lateblight is used, each student must be 
required to complete a copy of the Student Questionnaire at the back of the manual.    
These questionnaires must be returned promptly to the address below.    These 
requirements are in lieu of any other payment.

Registration forms, student questionnaires, and donations in any amount to 
support the development of other programs such as this should be sent to:

Department of Plant Pathology
Cornell University
Ithaca, NY    14853
Attn: B. E. Ticknor
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