
Adr_Book Version 2.0 Step by Step

This document serves as a hands on tutorial of how Adr_Book operates as well as a general 
reference manual. The best way to learn a new program is by example.  By following the steps 
listed here you will quickly learn the operation of Adr_Book and its features. 

If you have just loaded Adr_Book the sample database file sample.adr will be loaded when you 
first run the program. This file is required for using the step by step tutorial examples. 

NAVIGATION:  

1. Run the Adr_Book program. When first running the program the default database file 
sample.adr will be loaded.  If it is not loaded, select open from the file menu, and read this 
file. 

2. Place the mouse pointer on the black and yellow F tab and click the left mouse button. You 
should see the name Furter, Frank appear in the upper left quarter of the address book. The 
name and address will be highlighted in turquoise. Selecting any tab letter will take you to the 
first person whose last name begins with that letter. 

3. Using the mouse click single right pointer green arrow. This should cause the name, 
Gardner, Richard to be highlighted. Click the single arrow three more times and you will see 
the page turn with the name Marx, Groucho highlighted. The single green arrow keys move 
through the record names one at a time, while the double arrows move through the names 
four at a time. Play around with this for awhile.

4. Using the mouse on the list box to the right of the graphical address book,  scroll until you 
see the name Spaulding Roger.  click on it with the mouse. You will immediately see the 
name appear highlighted in the left hand corner of the address book. This method can be 
used to bring up any individual instantly.

5. Select the name at the top of the list box by clicking the mouse to the right of the name and 
then dragging it to the left until the entire name is highlighted. (What you are trying to do is 
erase everything in the list box title)  Type the letter M and you will see the name Main, Hugh 
appear highlighted in the upper left corner of the address book. Now type the letter A followed 
by an R.  The name selected will now be Marx, Groucho.  This is probably the fastest method
to locate a name in the database.

6. Move the mouse to click on any part of the address within the graphical address book for 
Ramuglia, Randy. Notice how it now becomes the highlighted name. This is the means for 
making active any name visible on the address book.

EDITING /ADDING /DELETING and COPY:

1. Click on the A tab letter. Aile, Ginger should appear highlighted in the upper left corner of 
the address book. Using the mouse double click in any part of the turquoise area. This should 
bring you to Entry Form window containing all attributes for this record. Change the home 
telephone number from 9833 to 9888. Now click on OK and when the address book is 
redisplayed you should see this new home phone number.

2. Select the Edit button from below the list box. This will once again bring you to the Entry 
Form window. Click Cancel to go back to the address book. Now double click on the name 
Chu, Chirk in the list box. This also gets you to the editing dialog box. Once again select  
Cancel.  Now click on Edit from the pull down menu at the top of the window and select Edit. 
This is yet another way to get to the Edit Dialog Box. Select Cancel.



3. Click on the A tab letter. Click on the Edit button to once again enter the Entry Form 
window. Click on the Add / Next button. This will cause the next record to be displayed, 
making it available for edit changes.  In this case, you will see the record for Chirk Chu.  Click
on the Add / Next button again and you will see the record for Scott Crevier appear. This is a
good way to go through all of your records making many modifications. Click on Cancel to get 
back to the address book display.

4. To add a new entry into the database click on the Add button below the list box. This will 
bring up an empty Entry Form. Enter your last name and first name and fields of interest. If 
this was the only name you wanted to add you would click OK, to get back to the address 
book.  If you wanted to add additional records you would select the Add / Next button. For our
example, click on the Add / Next button.  Notice how the form is cleared and is ready to 
receive data for the next record. Click on Cancel. You will now see the name you just entered 
highlighted in turquoise.  You could also get the Entry Form for adding by selecting the Add 
option under the Edit menu option. You might note that you do not need to enter a starting 
capital letter for either the First Name or Last Name. Adr_Book always forces the first 
character of these two fields to upper case when the form is saved.

5. To delete a record click on the Delete button below the list box. Do this now. You will get a 
pop up box asking if you really want to delete the record.  The record to be deleted is the one 
currently highlighted in turquoise. In this case it should be the name you just added. Respond  
by selecting Yes.  You could also Delete a record by selecting the Delete option under the 
Edit menu option.

6. The Copy selection under the Edit pull down menu will copy the name and address from 
the currently active record in to the clipboard. This allows you to easily move names and 
addresses into your favorite word processor. You could try this now by first selecting Copy 
from the pull down menu. Then go to the Microsoft supplied Write program and select Paste 
from the Edit pull down menu.  You will see the name and address that was lasted highlighted 
in turquoise appear in your Write document.

DISPLAY OPTIONS:

The display options control what record information will be shown on the graphical address 
book. They also control which records will be displayed.

1. Click on the Option menu item and then select Display.  From the dialog box presented 
click on the Work Phone check box, and the Birthday check box.  Now click on the OK box. 
You should see the work phone and birthday appear in the graphical address book. 
Experiment with different data items that can be displayed.

2. The ability to show the Notes free text was added in version 1.3. To demonstrate this check 
the Note check box in the Display dialog box. (This may already be checked)  Click on OK to 
get to the graphical address book. Click on the A tab letter so you can see the Ginger Aile 
record. Notice the  word Note.. is highlighted in red.  This means that there is some free text 
associated with this record. If there is no Note text you will not see the highlighted Note.. word
appear for the record. Now click anywhere in the red highlighted area.  A pop up list box will 
appear, and for Ginger Aile you will see three lines of text. You can now click anywhere in the 
window and the list box will disappear. This is an easy way to bring up a list of phone 
numbers, E-mail addresses, etc. for an Individual.

3. Let us say you would only like to see those people who have a birthday in July. Get to the 
Options dialog as described above. If the Birthday check box does not have an X in the box 
click on it. Also make sure there is an X in the Flags field. Now in the "Display records with 
selected flags", type in the word JULY. The word needs to be typed in capital letters. Click the 



(SEQ) must be in sequence check box. Click the OK button.  You should see only five 
names displayed. Notice that the birthdays for these five all fall in July.  Notice the flags for 
these five all contain the word JULY.  The Flags field is entered in the Add / Edit dialog box.

4. Lets say now that you are interested in listing people who play either racquetball or tennis. 
Get to the Options dialog as described above. In the flags area remove the text string JULY 
and replace it with the two lower case letters rt.  Click on the OR (Containing any) check box.
Click the OK button.  You will now see all records that contained either an r or  t in the flags 
field.

5. Now you are interested in people who play both tennis and racquetball.  Enter the Options 
dialog box. Click the AND (must contain all) check box.  This indicates to display only those 
records that contain both an r and a t. Click on the OK button. There should only be two 
records displayed. Notice that it doesn't matter where the letters are placed in the Flags field 
or the order in which they come.

6. And finally you want to know who the people are who play neither tennis or racquetball. 
Enter the Options dialog box. Click on the OR (containing any) check box. Click on the NOT 
(reverse sense of selection) check box. Click on OK. You now see the people who play 
neither tennis or racquetball.

7. Enter the Options dialog box. Click on the ALL (list all records) check box. Click on OK. All
of the records are now displayed. 

REPORT OPTIONS:

The report options controls the text used for report headers, and the return addresses to be 
used when printing envelopes.

1. Click on the Option menu item and then select Report Header.  The dialog box presented 
allows for two header lines to be printed on reports and two possible return addresses that can
be used when printing envelopes. At this time you can change these entries but they will not 
be used until later when printing is described.  If you make changes you must select either OK
or Cancel when you exit the dialog box.

MODE (USA/International) OPTION:

This option determines how the address portion of the record is formatted. USA mode has the 
address entry fields as two full lines of Address, a line for City, a place for State, and a place 
for Zip Code. International mode provides four full address lines, permitting the address to be
entered in any appropriate fashion. A single database file can accommodate both types of 
records.

1. Click on the Option menu item and then select Mode (USA/International).  This will bring 
up a dialog box that simply permits you to select a check box for USA or International mode. 
It also gives a rather winded explanation of the difference between the two modes. Click on 
the International mode check box. Then click on OK.

2. Click on the ADD button to create a new record.  When the Entry dialog box appears you 
will notice the Address entry block looks different. As described above, there are four full lines 
for entering the address. Go ahead and create a new record with any name. Then click on 
OK. 

3. Now you should see the new entry you created highlighted in turquoise. Get to the Edit 
entry screen by double clicking in the turquoise area. Notice that the address entry area still 
has four full lines (as you suspected).  Click on Cancel.



4. Now go to the entry screen of any of the other records in this sample database file. Notice 
how the Address lines have City, State, and Zip. Any new records that you add for now on will 
have the International style address mode. 

5. Click on the Option menu item and select Mode (USA/International). Click on the USA 
check box and then click on OK.  Now any new records that you add will have the USA 
addressing format.  Go ahead and select the Add button to see that this is true. Click on 
Cancel.

FILE EXPORTING / IMPORTING:

Import and Exporting is the process of exchanging data between application by way of text 
files. These text files are often referred to as ASCII files. These ASCII files contain separated 
text strings that correspond to individual record fields. i.e. Last Name, First Name, Phone 
Number, etc. Most database and spreadsheet programs are capable of producing ASCII files 
containing their record information in separated fields.

The Importing and Exporting capabilities have been greatly enhanced in Adr_Book version 
2.0. It is now possible to specify the ordering of the fields within the file, and what character or 
character sequence separates each field. By ordering we can say the fields in the file will be 
"Last Name", "First Name", "Birthday", "Home Phone" or "First Name", "Last Name",
"Home Phone", "Birthday". The field separator or delimiter indicates if a tab, comma, double 
quote comma, etc separates the fields within the file.

Importing data into Adr_Book implies merging data. If you already have 15 records in 
Adr_Book and you Import an ASCII file with 10 records you will end up with a database 
containing 25 records.

The Import command can also be used to merge two Adr_Book database files. Adr_Book 
database files end with a .ADR extension. This extension indicates that a database file rather 
than an ASCII file is to be merged. 

With that general introduction and overview behind us, lets step through some examples. The 
sample Import file, import.dmp, should have been included with your installation.

1. Start by selecting New from the File menu. If you a dialog box asks if you want to save 
changes, click on NO.

2. Select Import from the File menu. From the dialog box select Setup. We now need to 
describe this Import file. It has only four fields for each record and they are in the following 
order: First Name, Last Name, Work Phone, and Home Phone.  Each field is separated with a 
tab character. (Feel free to view import.dmp with any text editor)

3. Click on the Tab Radio Button to indicate this is our field separator. Since this is the default 
separator it is probably already selected. Click on the First_Name in the Adr_Book Fields List 
Box. It should become highlighted. Since this is the first field in our import file click on field 
<01> Skip of the Import File List Box. You should see First_Name copied into the Import File 
List Box. Next, click on Last_Name under the Adrbook List Box. Move this to the Import List 
Box by clicking on field <02> Skip. Move Work_Phone to field <03> Skip and Home_Phone to
field <04> Skip in a similar fashion. You have now described the format of the sample Import 
file. Click on OK.

4. You should now be back at the previous dialog box. Click on open. In the Open Dialog box 
that is presented you should see the file Import.dmp. Select this and click on OK. You should 
now see that four names have been added into Adr_Book.



Before leaving this section I want to demonstrate how database files can be imported. 
Database files are files like sample.adr. Files that have .adr extensions. As mentioned above 
Importing implies merging. This will demonstrate how you can merge multiple .adr files. 

5. From the File menu select Import. Next click on Open. Down by List Files of Type click on
the down arrow.  You will see an entry Database Files (*.ADR). Click on it. You should see the
database file sample.adr. Select this and click on OK. You should now see that the 
sample.adr database file has been loaded and merged with your previously  imported 
records. You can use this method to merge any number of database files. I should point out 
that this is a little bit of magic. The .adr file extension indicates to Adr_Book that a database 
file is being imported. Any setup for importing files is ignored. If interested there is also a 
section in the On-line Help titled Merging Database Files that also explains this process.

6. Lets clean everything. Simply reload the sample.adr file by selecting Open from the File 
Menu. Select No when asked if you want to save the changes. Click on sample.adr and then 
select open. 

I am not including a detailed description of the Export process but it is identical to Importing 
except that your database file will be written to an ASCII file based on fields that you select 
and the specified field separator. There is one thing that should be noted about this Export 
process. If you select a subset of your database using the Flags feature (described above), 
only those records currently selected will be written to your Export file.

DIALING:

Phone Dialing is a new feature to Adr_Book version 2.0. It is necessary to activate this 
feature before you can actually click and dial. Once you have set up this feature, clicking on 
any Yellow and Black phone number in the address book display will initiate a call.

1. Select Setup (currently your only choice) from the Dialing Menu. Select the radio button 
associated with the COM port of your modem.  Baud rate really shouldn't make any difference.

2. If you need to prefix all numbers with nine (9) or some other number to obtain an outside 
line you can enter this in the box provided. For purposes of demonstration enter a 9 of the 
prefix box.

3. To actually enable the click and dial feature you must select the Enable Dialing check box. 
Click on the Enable Box. Then click on OK.

4. You should be back at the Address Book display and all you need to do now is click on any 
Yellow and Black to activate dial. For a good example click on the "A" tab to get to good old 
Ginger Ale. Click on the (907) 673-9833 phone number.

5. A dialog box should appear with the number you selected. You should see that a 9 prefixes 
the telephone number. The number in the text box is the actual number that will be dialed 
once you select the Dial Number.  Should ever need to modify this number  for any reason 
you can do so in the text box. If this really was a long distance number that needed to be 
dialed it would need to be prefixed with a 1.  A method has been provided for this. Click on the
Add/Remove Long Distance check box. You should see the number 1 inserted after the 9 
but before the 907 area code. If you once again click on the Add/Remove Long Distance 
check box you will see that the number 1 is removed.

6. There is also a check box for International and Area Code. These operate in a similar 
fashion for inserting and removing numbers to appropriately form the number you need to dial.
You can select these to see how they work. The intention behind all of this is to allow you to 



keep your phone number in your database the way you would like it to print in reports or 
address booklet, and at the same time easily use the number for dialing. If the dialing feature 
is more important to you than printing reports, then simply store the number exactly as it 
should be dialed so no changes are needed when you dial.

7. Go ahead and click on the Dial Number button. Another dialog box will appear telling you 
that it is dialing the number. If you were dialing a real number you would wait until the number 
is dialed, then pick up your phone and click on Cancel.  For right now it might be wise to very 
quickly select Cancel. :-)

PRINTING:

The real test of this program working for you is how well it prints name lists, the address 
booklet, labels, and envelopes.  Before you consider registering this program run through all of
the printing options to see that all works well for you. Turn on your printer!

1. From the File menu select Print.  From the dialog box select Print List Two Columns. 
Then click on Print.  This report will only print individual names and a phone number. As in all 
reports you can use the Flags as described above to print only selected records. Also as in all 
reports you can specify how many copies and a header to be printed.  The unique option on 
this report is whether to print the home phone or work phone. Click on Print and see what 
happens.

2. From the File menu select Print.  From the dialog box select Phone List (condensed ..) 
Then click on Print. This report will print the name, address, and the home and work phone 
numbers. It will print both the home address and work address if present. Click on Print.

3. From the File menu select Print.  From the dialog box select Pocket Size Address Book. 
Then click on Print. The default setting is to print an address booklet with pages that are 4 
1/4"  x 5 1/2 ".  There are several other booklet sizes to choose from.  If you choose a smaller 
size, you will most likely need to choose a smaller font size to assure that all data is properly 
printed on your booklet.  The smallest size fits nicely in your shirt pocket. You also have the 
ability to select which fields of the record should be printed. The default is to print all fields, but
if you only wanted to print home and work phone numbers this can easily be accomplished.  
To work correctly you printer must be able to sheet feed since printing is two sided. Click on 
Print. For this example, one sheet will be printed and a dialog box will appear asking you to 
reload the paper to print on the reverse side. Do this and then click on OK.  Take the paper 
and cut it in half so you will have two sheets that are 4 1/4"  x  5 1/2".  Stack them so that the 
sheet with number 1 will be on top of the sheet with number 3. Fold it in half and you will have 
a small address book.  This address book will be created correctly for any number of records.

4. From the File menu select Print.  From the dialog box select either 2-UP Labels or  3-UP 
Labels. Then click on Print. You will then be presented with a dialog box permitting you to 
select whether the addresses should be home or work, in order by zip code, all capital letters. 
There is a Position ... button that will take you to a dialog box to allow positioning of labels for 
output. Click on Print.

5. From the File menu select Print.  From the dialog box select any of the three Envelope size
options. Then click on Print. Envelopes can be printed in Landscape or Portrait mode. 

The first thing you should notice in the dialog box is the Addressee contains the name that 
was highlighted in turquoise on the graphical address book.  There are a variety of options 
from this dialog box. From above, you had the opportunity to enter two return address in the 
Options  Report Header dialog box.  You can now toggle between these two preset return 
address by clicking on #1 or  #2.  You can also perform editing in the return address displayed 



to change it to any desired return address. ( You can also edit the addressee text). There are 
the usual options of fonts, point size, bold, and Italic. Have fun and create an attractive 
envelope. You can also choose to have the postnet barcode printed for the zip code.  To have 
a note text printed on the lower left of the envelope you will need to click on Note... to get to 
another dialog box for this purpose. When you are though click on Print to see the result.

Note: printing envelopes is actually a very tricky business. There are several check boxes that 
allow you to specify printing on the left, right or center of the print tray, and whether to print in 
the front or rear. Basically if you have a LaserJet the defaults of This side and Front should 
work fine. For a DeskJet select The Other Side and Rear.  You can also select whether to 
print in Portrait or Landscape. Hopefully you can find some combination that will work 
successfully with your printer.

If you have stepped through this document you will have tested most of the features of Adr_Book
and should know if this program will work for you. I hope that it will. If you have any questions or 
suggestions please send:

Internet E-mail to mikeg@ims.alaska.edu  or  mikeg@alaska.net
Alaska phone number (907) 278-1231

Michael Gardner
1231 Redwood Ct.
Anchorage AK 99508

June 5,  1995


