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Overview of IDate 4.05 for Windows

Shareware Notice & Registration
IDate is a Shareware personal organizer cum reminder which is designed to assist 

you remember important dates and events.

Messages will pop-up to your screen upon starting Windows when you put IDate in 
the StartUp group.    You can customize IDate so that messages will start popping-up from 
a specified period of time from the actual date intended, i.e. an Early Warning System.    
You may also choose to setup IDate such that it will not allow Windows to exit before you 
read all your messages for the day.

Perfect for reminders of birthdates, anniversaries, appointments, deadlines etc.    
Use IDate to generate reminders for the week, month or 
even year!

IDate has two main components, namely the Main program and the Editor.

The Main program displays the dates and messages that go with them when the pre-
defined warning period is reached.

The Editor enables you to build and manage the data bases that will contain your 
dates and messages. It allows you to set specific options for every individual record as well
as define default settings.

IDate supports files which use the Data Bank 2.x format. It converts these files with 
100% compatibility. IDate files are saved with an .IDT extension. IDate files have a unique 
format. Therefore you are advised against editing them using text editors or word 
processors.

See also:
Contents
The IDate Editor



IDate (TM) for Windows
Shareware Version 4.05
Serial Number: 0049-0-2-002-007-12
Copyright © 1993-1996 Chiam Yih Wei.
All Rights Reserved.

Shareware Notice & Registration
IDate is SHAREWARE. You may use it for an evaluation period of not more than 21 

days. After this period, you must register if you wish to continue using IDate. Upon 
registration, you will no longer have to tolerate the reminder screens which pop up every 
now and then. You will also receive free bug-fixes for IDate if they are any! Registered 
users will also be given a unique User ID and will receive technical support from the 
author.

To register, please print out the form in the file REGISTER.TXT and send it together 
with US$12.00 (payable to CHIAM YIH WEI) to the address below:

CHIAM YIH WEI,
1, JLN LANG PERUT PUTIH 10,

KEPONG BARU, 52100 KL, MALAYSIA.

Internet EMail:
peter-chiam@mailhost.net

PTLabs WWW Shareware Page:
http://137.132.20.132/~ptlabs

ftp://137.132.20.132/pub/ptlabs

Registered Users of IDate 2.01 need only to pay US$10.00.

Registered Users of IDate 3.00, IDate 3.00a and IDate 3.00b need only to pay 
US$8.00.

Registered Users of IDate 4.00 need only to pay US$5.00.

All registered users of IDate will be given discounts when registering for future new 
versions of IDate.

Site licensing is also available when purchasing multiple copies of IDate. Please 
contact the author for prices of site licenses.

The unregistered evaluation copy of IDate 4.05 is freely distributable as long as the 
file IDATE405.ZIP is distributed as a full package in its original state.

Disclaimer:

THE PROGRAM IS PROVIDED "AS-IS". NO WARRANTIES OF ANY KIND, EXPRESSED 
OR IMPLIED, ARE MADE AS TO IT OR ANY MEDIUM IT MAY BE ON. ANY REMEDY 
FOR INDIRECT, CONSEQUENTIAL, PUNITIVE OR INCIDENTAL DAMAGES ARISING 
FROM IT, INCLUDING SUCH FROM NEGLIGENCE, STRICT LIABILITY, OR BREACH OF 
WARRANTY OR CONTRACT, EVEN AFTER NOTICE OF THE POSSIBILITY OF SUCH 
DAMAGES WILL NOT BE PROVIDED.



The IDate 4.05 Editor
Overview

IDate comes with an internal Editor which is used for editing, creating and 
maintaining IDate files. It also supports files saved in Data Bank 2.x format. The IDate 
Editor allows you to set detailed options for each record of your data base. However, the 
IDate Editor can only be accessed if IDate is not password protected.

For more information on Data Bank 2.x Personal Address Book shareware, please 
contact the author, Chiam Yih Wei.

See also:
Constructing a Data Base
The File Menu
The Records Menu
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IDate 4.05
File Menu
The File Menu of the main program consists of:

Load
Loads up a file to be scanned in IDate. The file must be of IDate format. Files which 
are of Data Bank 2.x format can be converted with 100% accuracy using the IDate 
Editor.

Print to File
Prints out the messages that appear now into a text file of your choice. Useful for 
generating hard copies of appointments etc when preparing for travel.

Editor

Range
Specifies the range for IDate to scan forward. This option allows you to see all the 
messages for the events which will occur in the specified range of days.

Exit
Exits IDate.

See also:
The Options Menu
The Setup Menu

The IDate Editor
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IDate 4.05
Options Menu
AutoLoad

Allows you to specify the file that IDate    will load automatically every time it starts 
up. A tick will appear next to this option if the AutoLoad file has been set. To erase 
the AutoLoad setting, simply click Cancel when you are at the AutoLoad dialog box 
and answer Yes when IDate asks if you wish to delete the current AutoLoad file.

Font
Allows you to choose the default font name and size that IDate will use in the 
Message Box.

Sound
Toggles sound on or off. When the sound is set to on, IDate will beep when there are 
messages to be displayed.

Protection

Exit Pop Up
With this option set, IDate will prevent Windows from exiting whenever there is a 
message to be read. If there are messages to be read, IDate will automatically pop up
and stop Windows from exiting when the user tries to exit Windows.

If this option is not set, IDate will close unconditionally whenever Windows exits.

See also:
The File Menu
The Setup Menu

The IDate Editor
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IDate 4.05 Editor
Open Command
Performs the same function as the Open command in the File Menu.

Save Command
Performs the same function as the Save command in the File Menu.

Quit Command
Performs the same function as the Quit Editor command in the File Menu.

New Rec. Command
Creates a new record.

Del. Rec. Command
Deletes current record.

Dup. Rec. Command
Duplicates current record.

Update Command
Updates the current record. All changes will be updated into memory. This command    is 
automatically executed when you move within the data base.

See also:
Constructing a Data Base
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IDate 4.05 Editor
Current Record
This scroll bar is used to indicate the current record in the data base you are editing. Use it
to move around the data base.

See also:
Records Menu
Constructing a Data Base
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IDate 4.05 Editor
Activate
Tells IDate to activate the message every year, month, week, day, or simply once. Use this 
option for anniversaries, monthly events, weekly schedules and the likes.

If you select Yearly, IDate will remind you of this event every year.

If you select Monthly, you will be reminded every month, based on the day of the date 
entered.

If you select Weekly, IDate will remind you of the event based on the weekday (i.e. 
Monday, Tuesday, Wednesday, etc).

If you choose Daily, IDate will flag this event everyday, regardless of the date entered.

If you select Once, IDate will warn you of the event only once, at the specified date.

The Activate setting can be used together with the Warn in Advance setting to further 
enhance the flexibility of IDate.

Enabled
Determines whether the record is enabled. If a record is disabled, it will not show up on the
main program until you enable it. Use this option with extreme care as IDate will not 
inform you of the passing of the date of a disabled record. A default setting of Enabled is 
recommended.

Backdated Warning
Forces IDate to flag messages that are within the last 3 days from the current date. This 
acts as a safety net in case you do not launch IDate on the day the message should be 
flagged. It is recommended that you enable the Backdated Warning feature by default.

This option is not available for messages which are activated Daily.
Automatic Clean Up
This option can be used for messages that are one-off, meaning they are only meaningful 
for one particular day.

With this option turned on, messages which are activated Once and has the current    
system date will be removed from the data file upon loading it from the main window. Use 
this option together with the Confirm Clean Up feature from the main window for better 
automated management of your data files.

When used with Confirm Clean Up, you can purge events which only occur once, like 
meetings, appointments etc.

See also:
Constructing a Data Base
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IDate 4.05 Editor
Warn in Advance
Use this feature to tell IDate to flag the message a pre-defined of days before the actual 
date. This is especially useful for birthdates and important meetings or appointments. 
IDate will warn you of the event in advance every time it loads the file unless you disable 
the message by not checking the Enabled check box.

The valid values are from 0 to 49. Setting the Warn in Advance value to 0 means that IDate
will not flag the message before the actual date of the event. 

Using Warn in Advance with the Activate setting will give you enhanced flexibility in 
managing your reminders.

See also:
Backdated Warning
Constructing a Data Base
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IDate 4.05 Editor
Date
Type in the date you want the message to appear. This is the actual date that the event 
will occur. Coupled with the    Warn in Advance feature, IDate will be able to remind you of 
the event in advance.

Messages
Type in the messages that you want IDate to display when the specified date is reached. 
You have about 1kB of space in this text box.

See also:
Warn in Advance
Constructing a Data Base
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IDate 4.05 Editor
File Menu
The File Menu contains:

New
Creates a new data base.

Open
Opens a previously saved file. The file may be in IDate 2.01, 3.0 or 4.0, or Data Bank 
2.x. The default extension of IDate 2.01, 3.0, 4.00 and 4.05 files is .IDT and the 
default for    Data Bank 2.x files is .BNK.

If the file is of Data Bank 2.x format, IDate will extract the records that have valid 
birthday entries. All other information in the Data Bank 2.x file will be saved as 
Messages. Records without valid birthday entries will be ignored.

Save and Save As
Saves the current data base into a file. The file generated will be of IDate format.

Set As Default
Sets the current values for Warn in Advance, Activate Annually, Enabled and 
Backdated Warning as the default values for future records. Existing records will not 
be affected.

Quit Editor
Quits IDate Editor.

See also:
Constructing a Data Base
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IDate 4.05 Editor
Records Menu
New
Appends a new record to the existing data base or creates the first record in a new data 
base. The default values will apply to the newly created record.

Delete
Deletes the current record.

Find
Finds text specified by you. Any highlighted text in the text boxes will be used as the 
default search string.

Find Next
Finds the next matching text.

Duplicate
Duplicates the current record and places it at the end of the current data base.

See also:
Current Record
Constructing a Data Base
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IDate 4.05 Protection
What is Protection?

The Protection option is used to password-protect your IDate program from 
unauthorized users. It allows you to specify a password to lock up the Load, Editor 
and AutoLoad options as well as the Setup menu in the main program. Disabling the 
Editor will block any attempts made to corrupt your data files or program settings.

Enabling Protection
Close the Editor window if it is open. Protection cannot be used if the Editor is open.

Select the Options/Protection menu from the main program. If no password already 
exists, you will see a window with two text boxes. Enter your password and retype it 
to ensure you have not made a typing mistake. Then click OK to activate Protection. 
A tick will appear next to the Protection option when Protection is enabled.

Disabling Protection
Select the Options/Protection menu from the main program. Enter the existing 
password once and click OK. Protection will be removed if your password is valid.

See also:
Overview
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Constructing a Data Base using the IDate Editor
Starting the IDate Editor.

To launch the IDate Editor, the Protection feature in the main program must not be 
enabled. Dsable it if it is already set.

For more information on Protection, see
          Protection  

Launch the IDate Editor. To do that, click on the File/Editor menu in the main 
program or use the shortcut key of Ctrl+E. You may also click on the Editor button or the 
right mouse button to bring up a menu with the Editor choice. Once the Editor is launched,
you are ready to start.

Setting the Date.
Fill in the Date text box with the date that you want the record to be linked with. 

IDate will activate this record when the date is reached. Dates must be filled in using a 
valid format. It is recommended that you fill in the date using the format specified in the 
International settings in the Control Panel. Nonetheless, IDate Editor accepts several other 
formats. IDate Editor will give an error message should the format of the date you specify 
is invalid.

The Messages text box.
IDate will display the Messages in this box when flagging this record. Feel free to put

in any type of message. You have roughly 1kB of space to work on here.

Warn in Advance.
This feature is used to instruct IDate to flag this record in advance. That means that 

IDate will warn you when the date of the record approaches. Simply drag the scroll bar to 
whatever value desired and the corresponding value will be reflected just on top of the 
scroll bar.

Setting the other options.
It is recommended that you enable the Activate Annually, Enabled and Backdated 

Warning options. For further information on the functions of these options, see
          Records Options  

There, now you have a constructed a record for your data base. Repeat the 
procedure to append more records to your data base. Use the Records menu to create, 
delete and duplicate records.

See also:
The IDate Editor
File Menu
Records Menu
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IDate 4.05
Setup Menu
Minimize When Idle

When this option is checked, IDate will be a minimized icon when loaded if there is no
AutoLoad file or when there are no messages to display in the current AutoLoad file. 
IDate is said to be idle in this situation.

Exit TimeOut
This option determines if IDate will automatically exit after a preset amount of time 
when there are no messages upon load-up, or in other words, when IDate is idle. 
Useful if you wish to free memory and resources when there are no messages for you 
to read.
Any positive number is accepted as a valid value. However, a value of 5 or more 
seconds is recommended. This value should be increased when the computer is 
slower. IDate will not exit if idle when the Exit TimeOut value is zero.

To activate the program before it exits automatically, simply click on any part of the 
form when the form is not minimized. IDate will not stop the TimeOut countdown if 
you click on it when it is iconified (i.e. the Minimized When Idle option is set to true.)

You may never be launch IDate properly if you set this value to a value so small that 
IDate will exit almost immediately after it is launched. This may also be caused if 
your computer is too slow. If you are ever caught in this situation and wish to 
manually override the settings, change the TIMEOUT value in the ID405.INI file to 0. 
This will disable the Exit TimeOut function.

Confirm Clean Up
Tells IDate to confirm every clean up it attempts to perform. Clean ups are performed 
when a record satisfies all of the conditions below:

1. The Automatic Clean Up option is turned on for the record.
2. The current system date is the same as the Date of the record.
3. The record is enabled.
4. The record is Activated only Once.

Use this feature together with the Automatic Clean Up option from the IDate Editor 
for better automated management of your data files.

When used with Automatic Clean Up, you can purge events which only occur once, 
like meetings, appointments etc.

Save Settings on Exit
Tells IDate to save current settings on exit.

Save Settings Now
Saves all current settings now.

You may also force IDate to save the settings during the current session without 
exiting by holding down the Shift key and proceed as if you were going to exit the 
program. The current settings of the program will be saved without exiting.



See also:
The File Menu
The Options Menu

The IDate Editor
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