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Managing Documents (Archivist) — Installation
Installation starts automatically when you open document DZM_INST.DOC.

The installation adds macro Archivist to Microsoft Word's global template (NORMAL.DOT).
If you wish, the installation will also add Document Zip Manager to the File menu.
This is an option you may select during the installation.

If you wish, you may install Archivist manually. See “Manual Installation” below.

Please note:
You must have programs PKUNZIP.EXE and PKZIP.EXE installed on you computer.
The PATH command in your AUTOEXEC.BAT file should include the directory in which
these programs reside.
Shareware versions of these programs are available on many bulletin boards or from

PKWARE, Inc.
9025 N. Deerwood Drive
Brown Deer, WI 53223

Archivist is also available for Microsoft Excel 5.0.

WIN.COM
If you have more than one copy of this file on your computer, the installation will not 
succeed. It means that you have installed more than one copy of MS Windows. The Macro 
Installer would not know where to place certain files. You should temporarily rename the 
“unused” WIN.COM file(s) and restart the installation.
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What is Archivist
Microsoft Word’s document files may take a lot of space on the hard disk of your computer. Since
you  probably work with only a few documents at a time, you can recover half or even more of the
disk space by compressing the individual files into an archive. Of course, you could store your 
documents on diskettes but, compared to the hard disk, diskettes are less convenient to use.

Archivist is a macro for Microsoft Word 6.0. It allows you to compress files into archive, list the 
contents of an archive, and restore files with the ease of point-and-click, without leaving Word.

When you compress a document, you may expect 50% to 75% reduction in the amount of disk 
space it occupies. Please note that you may use Archivist to compress not only MS Word 
documents but other files as well.

The macro uses two well respected and widely used programs, PKZIP and PKUNZIP. These are 
available for downloading on virtually all bulletin boards (BBS) and on-line services.

Archivist is shareware. Archivist is not free. If you find Archivist useful and continue to use it, you
are encouraged to register your copy. Registration fee is $15 U.S., payable to:

Josef J. Polak
39 Greylock Road
Newton, MA 02165

Please include the name of the person to whom Word is licensed (as it appears in Help, 
About Microsoft Word…).

The user who registers receives several benefits:
· Technical support by telephone or mail. You can get help with any questions or problems you

encounter in using Archivist.
· The opportunity to order the latest version of Archivist and its upgrades on disk directly from 

the author.
· The opportunity to order the latest versions of macro source code.
· The satisfaction of knowing that you are supporting the development of affordable software.

Archivist is also available for Microsoft Excel 5.0.
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Managing Documents — Instructions
How to start Archivist
¨ From the File menu, choose Document Zip Manager. Archivist displays its main dialog box 

window.
If you did not add Document Zip Manager to the menu, choose Archivist in macro window 
(menu Tools, Macro…) and click on the Run button.

The macro automatically looks for archives (files with the extension .ZIP) in the current directory 
and selects the first one it finds. You may choose another archive (see “How to select another 
archive in the current directory” below). If it does not find any archive, it will inform you that 
archiving will create archive DOCS.ZIP.

How to move documents into archive (action Move…)
¨ Click on option button Move file(s) into archive. The list box shows all files in the directory.
¨ Select a file in list box Files Available:, click on the Select >> button. (Shortcut: double-click 

the left mouse button on the name of the file.) The macro adds the file on its list of files to
be moved, shows the name in list box Selected Files: and removes it from Files 
Available:. Select other files you wish to archive.
If you wish to change your selection, select a file in list box Selected Files. The button 
text “Select >>“ changes to “<< Remove.”  Clicking on this button removes the file from 
the list of files to be moved and places its name back into Files Available:.

¨ Click on the OK button and confirm the move. The macro moves the selected files into the 
archive, removes them from your disk and, when you add a new file to the archive, asks 
you “Would you like to generate contents list…?” You should click on the Yes button 
when you create a new archive. This list is a file with extension .Z_L, which contains the 
“table of contents” of the archive. Archivist uses this list when restoring and deleting files 
(see Restore below). Once you create the contents list, Archivist will maintain it for you 
automatically. You should keep this file on your disk.

¨ If you wish to move all files in the current directory into the archive, click on the All Files >> 
button, then on the OK button. Note, that archive files (*.ZIP) and list files (*.Z_L) will not be 
archived.

This action is available only if the current directory contains at least one file.

How to retrieve documents from archive (action Restore…)
¨ Click on option button Restore archived file(s). The list box now shows only the files on the 

list generated after the most recent move and/or delete (see Move and Delete).
¨ Select a file in list box Archived Files on List (.Z_L):, click on the Select >> button. The macro

displays the file in list box Selected Files:. Select other files you wish to restore.
¨ Click on the OK button and confirm the restore.
¨ If you wish to restore all files from the archive into the current directory, click on the 

All Files >> button, then on the OK button.
This action is available only if the current directory contains at least one archive and the selected 
archive has a corresponding list file. When there is no list file, the name of this action changes to 
“Restore all archived files."

How to remove documents from archive (action Delete…)
¨ Click on option button Delete…. The list box now shows only the files on the list generated 

after the most recent move and/or delete.
¨ Select a file in list box Archived Files on List (.Z_L):, click on the Select >> button. The macro

displays the file in list box Selected Files:. Select other files you wish to delete.
¨ Click on the OK button and confirm the delete.
This action is available only if the current directory contains at least one archive and the selected 
archive has a corresponding list file.
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How to update all documents in archive (action Update…)
¨ Click on option button Update…. List box Archived Files: is dimmed and shows only the files 

on the list.
¨ Click on the OK button and confirm the update. Archivist will move into the archive all files in 

the current directory that meet the following three conditions:
1. A file of the same name already is in the archive.
2. The file on you hard disk is newer than that in the archive.
3. The file is not being used by an application. For instance, Archivist cannot update 

a document which is open in Word.
This action is available only if the current directory contains at least one file.

What is the difference between “Update all files…” and moving all files
When you select all files for action “Move file into archive,” the macro moves all files in the 
current directory into the archive and removes them from your disk, excluding files with 
extensions .ZIP (archives) and .Z_L (list files).
Action “Update all files which already are in archive” replaces all files in the archive with newer 
ones from the current directory on your disk. The macro then removes from your disk only those 
files which are in the archive. In another words, the macro will not add new files to archive. It will 
move file into archive only if a file with the same name already exists in the archive.

How to name and change archives
Archivist uses the name DOCS.ZIP if the current directory does not contain an archive. You may 
select another name:
¨ Click on the Name Archive… button and enter a name for the archive.
This button is available only if the current directory contains at least one file.

How to select another archive in the current directory
Archivist automatically selects the first archive it finds in the current directory. If a directory 
contains several archives, you may select another archive:
¨ Select an archive in list box Archives (*.ZIP): and click on the OK button. (Shortcut: 

double-click the left mouse button on the name of the archive.)
You may also use the Name Archive… button to enter the name of an existing archive or name 
for a new archive.

How to change directory
¨ Click on the Change Directory button. The button text changes to “Show Files.”
¨ Choose another directory in list box Directories: and click on the OK button. Repeat until you 

reach the desired directory. (Shortcut: double-click the left mouse button on the name of 
the directory.) List box Archives (*.ZIP): will show names of all archives in each directory.

¨ Click on the Show Files button to return to the main dialog box window. Archivist 
automatically selects the first archive it finds in the new directory.

¨ You may also select an archive in list box Archives (*.ZIP): and click on the OK button (or . 
double-click the left mouse button on the name of the archive).

If you change to a directory in which there are no archives, archiving (Move…) will create one.

How to change drive
The macro itself cannot change drive. However, if you wish archive files located on another drive,
switch to that drive in Microsoft Word first, before running Archivist:
¨ From the File menu, choose Open….
¨ In drop-down list box Drives: select the drive you wish to use.
¨ Click on the Cancel button (or press the Esc key).

© 1995, 1996 Josef J. Polak. All rights reserved.
All other product names are copyright and trademarks/tradenames of their respective owners.



The check box “Restore Directory…”
Archivist’s dialog box contains check box labeled “Restore Directory Structure Stored in Archive.”
The check box and the text will be “grayed” (disabled). This option has no meaning for archives 
created by archivist. However, since you may have other archives (ZIP files) on your hard disk, it 
is included for you convenience.
Technical footnote:
This check box has meaning for archives created (PKZIP) with options -r, -p|P. If it is checked, 
Archivist will restore (PKUNZIP) files with the option -d.

Cautions
¨ Do not attempt to archive files while they are “open,” for example, a MS Word document file, 

while you are working with it.
¨ Do not attempt to archive any file whose name starts with the character “~” (tilde).
¨ Do not archive template NORMAL.DOT.  You may, however, archive templates which you 

seldom use.
¨ Do not archive any .INI file, unless you are certain that they will not be needed.  Same 

caution applies to .EXE, .COM, .DLL, .DRV, .REG, .386 and other system files.
¨ You may, however, archive some system files which you seldom use, for example, TrueType

font files (.TTF)
¨ Never   archive AUTOEXEC.BAT, CONFIG.SYS, WIN.INI and SYSTEM.INI.

How to remove Archivist
¨ Start MS Word.
¨ From the Tools menu, choose Macro…
¨ Delete macros Archivist, ArchivistPart2 and ArchivistPart3 (select the macro, choose the 

Delete button and confirm the deletion).
¨ Delete files WMM60UNZ.PIF and WMM60ZP.PIF from your Windows’ directory.
You may also let Archivist remove itself automatically:
¨ Open the installation document DZM_INST.DOC.
¨ Double-click the left mouse button on 

Remove Archivist

located at the end of the document.
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Manual Installation
How to install manually
¨ Open document DZM_INST.DOC.
¨ From the Tools menu, choose Macro… and click on the Organizer… button. The Organizer 

dialog box lists macros stored in INST_DZM and in the Normal document template.
¨ On the left side of the Macros tab select macros Archivist1, ArchivistPart2 and ArchivistPart3

and click on the Copy >> button.
¨ On the right side of the Macros tab, select macro Archivist1, click on the Rename… button, 

type in Archivist as the new name (that is, remove the trailing “1”) and then choose the 
OK button.

¨ Choose the Close button.

Archivist also needs files WMM60UNZ.PIF and WMM60ZP.PIF. They are included in 
ARCW6M.ZIP. Please copy those two files from the distribution diskette into your Windows 
directory (most likely C:\WINDOWS).

It is possible that the installation of Archivist will not find programs PKZIP.EXE and/or 
PKUNZIP.EXE even though they are on your computer. and the PATH command in your 
AUTOEXEC.BAT file includes the directory in which these programs reside. This is because they
might be marked as “hidden” and/or “system” files. You can remedy this either in File Manager or
in DOS.

In File Manager:
¨ From the File menu choose Search…
¨ In text box Search For: type PK*.EXE and press the Enter key.

Highlight both programs in the Search Window, e.g.,
c:\pkware\pkunzip.exe
c:\pkware\pkzip.exe

¨ From the File menu choose Properties…
¨ Clear the check boxes System and Hidden, click on the OK button.

In DOS, type the following:
· cd \pkware
· attrib -s -h pkunzip.exe
· attrib -s -h pkzip.exe
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Messages
The following table lists messages and problems you might encounter.

MESSAGE or PROBLEM CAUSE REMEDY
Archive x.ZIP is not present 
in…

No archives in the current directory. Archiving will create it.

There are no files to be 
archived.

The directory is empty. None

The name is not valid. You entered a name which is not a valid 
MS-DOS file name.

Choose another name.

Cannot archive into itself! Attempt to archive x.ZIP into itself. None
You have to wait
about x second(s).

The macro is completing some task. None

File(s) will not restore. Your disk might be full. Remove some files.
I moved a file into archive, but 
the file is still on my hard disk.

The archive may be damaged.

The file may be marked as “read-only.”

Your disk might be full.

Restore all files, then 
delete the archive.
Clear the attribute (use 
DOS command attrib).
Remove some files.

File x.Z_L is not a valid list. You removed all files from archive x.ZIP
The file is damaged (corrupted or lost 
data)
x.Z_L was created by another application.

Generate new after 
move.
Generate new.
Choose another name.

I asked for a new list, but I still 
get “…is not a valid list.”

The archive may be damaged. Restore all files, then 
delete the archive.

Distribution
The Archivist software, and the associated documentation are © 1995, 1996 Josef J. Polak.
You may distribute this software as long as the following files are included:

AREG.TXT
FILE_ID.DIZ
INST_DZM.DOC
PACKING.LST
READ_DZM DOC
README.TXT
WMM60ZP.PIF
WMM60UNZ.PIF

All of the above files must be combined into a single ZIP file (or other compression format) for 
distribution. Beyond a fee for the reproduction and media cost, no fee may be charged for 
distribution of this software.

Disclaimer
This software is provided on an “as is” basis without warranty of any kind, expressed or implied, including 
but not limited to the implied warranties of merchantability and fitness for a particular purpose. The person 
using the software bears all risk as to the quality and performance of the software. The author will not be 
liable for any special, incidental, consequential, indirect or similar damages due to loss of data or any other 
reason, even if the author or an agent of the author has been advised of the possibility of such damages. In 
no event shall the author’s liability for any damages ever exceed the price paid for the license to use the 
software, regardless of the form of the claim. This software remains the property of the author and may not 
be modified in any way.
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