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Overview

Exatech's Timelog is a windows 3.x application for personal time usage recording. It is 
written for the professional who turns on his or her personal computer as the first thing 
on reaching the office in the morning.
Timelog maintains a time usage Database .This database is useful in constructing 
monthly activity reports, filling out time cards, or simply reviewing ones own activity 
record.
You add projects to your Timelog database by using the Add Project item in the Edit 
pulldown menu. Then you add time usage data to your projects by Punching In and 
Punching Out.
You use the New item in the File menu to create a new empty database. Most of the 
time,    you will be using the same database. Therefore Timelog will open the database 
that you used last when it starts up. It knows to do this by reading the timelog.ini file that
it wrote into your windows directory the last time you selected or created a database.
If Timelog can not find a timelog.ini file, a dialog box will let you know and Timelog will 
start up without a database. You can then use either the New or Open items in the File 
menu to give Timelog a database to use.





Database
A database consists of a set of projects. Each project has a name and a set of work 
sessions. The List Box in the main window displays the names of the projects in the 
open database.
A work session has a start time and an ending time and an optional short comment 
identifying the activity or purpose of that work session. If the Check Box in the main 
window is checked, Timelog will ask for this comment when you    Punch In.
A Timelog database is kept in a file with the default .tim extension. For instance, you 
might choose to keep a database of projects in a file named C:\timelog\hobbies.tim. You
could also have another database of projects in c:\timelog\work.tim.
The name of the database file that is open is displayed in the title bar of the main 
window.





Comment Check Box

Above the Punch In Button in the main window, there is a check box labeled, 
"Comment". If this box has an X in it, you will be prompted for a short comment that 
describes the purpose or description of your work session when you punch in.    The 
comment that is entered will appear in several of the reports that can be generated from
the Report Menu.
If you do not want to enter this comment, click the mouse button on the X to make it go 
away before you punch in. Alternatively, you can press the tab key until the check box is
highlighted. Then press the space bar to achieve the same result.
If the check box does not have an X and you wish to enter comments describing your 
work sessions, click the box with the mouse button or tab to it and press the spacebar to
turn the X back on.





Main Window List Box

There is a list box in the main window that contains the names of the projects in the 
open database. It is to the left of the column of buttons in the main window.

One selects a project in the list box by clicking on it with the left mouse button or by 
tabbing to the list box and using the up and down arrow keys. Double clicking the left 
mouse button on a project is equivalent to selecting that project and clicking on the 
Punch In button. So don't double click to establish the selected project unless you also 
want to punch in.

One adds new projects to the Database    and therefore to the List Box by using the Add
Project in the Edit menu.



Punch In Button

There is a button in the main window labeled "Punch In". Clicking the left mouse button 
on this button causes a new work session to be added to the selected project ( see 
Main Window List Box for a description of the selected project). The start or punch in 
time for the work session is the system time when the button is clicked.
One can also punch in by double clicking on a project in the list box., or by tabbing to 
the "Punch In" button and pressing the enter key.
If the Comment Check Box is    checked, you will be prompted for a short descriptive 
comment that applies to the work session.
When you punch in, black smoke will appear above the chimney in the icon in the upper
right hand corner of the main window indicating that the database has been updated 
with an open session.    
If you wish, you are now free to quit the program using the "Quit" button, the Exit item in
the File menu or the Close item in the control menu box. It is not necessary to quit the 
program. But many people will want to free up the system resources used by Timelog 
for use by other programs. You could also reduce Timelog to an icon as a reminder to 
Punch Out when the work session is complete.
If you are "Punched In" when you exit windows and Timelog is active, it will remind you 
that you might wish to punch out. This might be a reason to keep timelog active and to 
establish a work routine of exiting windows before you turn off the computer.



Punch Out Button

The Punch Out Button appears below the    Punch In Button in the main window.    If the 
open Database has an open work session, clicking the left mouse button on the Punch 
Out Button ends the open session. The now completed session will be written to the 
database    and it will contain the system time at punch out as its ending time.
Punching out will stop the black smoke coming from the chimney in the icon in the 
upper right hand corner of the main window.





Status Button

The Status Button appears below the    Punch Out Button in the main window.    
Activating this button causes a dialog box to appear. This dialog box will show several 
items that include:
            The present date and time from the system clock.
            The name of the open database if any.
            The name of the open database's file.
            The name of the selected project.
              Whether there is an open work session.
None of these items can be edited from the status dialog box.They are for your 
information only. You should activate the "Cancel" button to dismiss this dialog.





File Menu
The File Menu is the first menu on the left hand side of the menu bar. It contains four 
menu items:
              New
              Open
              SaveAs
              Exit
The items in this menu can be chosen with the mouse or by pressing the Alt key 
followed by the "F" key followed by the underlined character in the menu item.





Edit Menu
The Edit Menu is the second menu on the left hand side of the menu bar. It contains 
three menu items:
              Add Project
              Delete Selected Project
              Edit Selected Project
The items in this menu can be chosen with the mouse or by pressing the Alt key 
followed by the "E" key followed by the underlined character in the menu item.





Report Menu
The Report Menu is the third menu on the left hand side of the menu bar. It contains 
three menu items:
              AggregateReport
              Detailed Project Report
              Dump Entire Database
Each    item on this menu allows you to either send a report to the printer or to a text file.
In each case, the data    is similar. The text file output is convenient when you wish to 
edit the data or import it into some other program such as a word processor. 
When you choose    an item from this menu, a dialog box will appear. You will be 
prompted as to whether you wish a printer output or a .txt file written. If you choose a 
text file , a file selection dialog box will appear in order for you to name the text file to be
written.





Help Menu
The Help Menu is on the right hand side of the menu bar. It contains three menu items:
              Using Timelog
              License Registration
              About Timelog
The first item is used to access the help system that you are using now. This can be 
done by selecting the menu item of pressing the F1 function key.
The second item provides information on how to obtain a license to use Timelog and the
third item is the usual copyright banner.





Data Security
Whenever Timelog processes a transaction such as punching in, punching out or 
several others, it updates the disk resident database. Consequently, you should lose no 
data if your computer goes down for any reason. 
If you should be so unlucky as to have lightning strike precisely at the time a transaction
in being committed to disk the database could be left in an unknown state. But even in 
this case, all is not lost. When Timelog commits a transaction it first copies the database
file. For instance if your database file was "projects.tim", Timelog first copies 
"projects.tim" to "projects.bak". Only then does it write out a new "projects.tim". So if 
lightning struck during the time Timelog was writing "projects.tim", you should have a 
valid database in "projects.bak" (except for the last transaction). If the strike took place 
while the copy was taking place then Timelog would never have gotten to the point of 
overwriting "projects.tim" and it should also be valid (except for the last transaction).





Dynamic Data Exchange
Timelog can be a Dynamic Data Exchange (DDE) server. This means that it can provide
data to other applications that are running under windows at the same time. 
The client application initiates a DDE conversation. The server application responds 
with requested data. This is a bit of an over simplification but it is adequate for our 
purposes here. For example Microsoft EXCEL can be a Timelog client. The only data 
items that Timelog is prepared to supply as a server are the total time for each project in
the open database.
For example, you can place a formula into an EXCEL cell that might look like the 
following:

 =TIMELOG|'C:\work\projects.tim'!'Final Report'

EXCEL uses the "TIMELOG" field from the formula to identify the server to ask for the 
data. So one or more instances of Timelog will have to be running. The second field, 
"C:\work\projects.tim" is the "topic" on which EXCEL will request the server to open a 
conversation. So at least one of the running instances of Timelog will have to have 
opened a database file named C:\work\projects.tim.
Finally, the item that EXCEL is requesting is the total hours worked on the project 
named, "Final Report". If the Timelog database has this project, it will add up the times 
of all the work sessions in this project and supply it to EXCEL. This number should then 
appear in the cell on the worksheet.
If any of the things required are not true then #NA will appear in the cell.
Other client applications will use this same three level scheme of service name, topic 
and item to request data. Their documentation will tell you how to use these same three 
items in their own context to get data from Timelog. There are also other ways for 
EXCEL    macros to initiate a DDE conversation.





Convenience Suggestions
Whenever you start Windows, programs that are in the Startup group in the Program 
Manager are automatically started. If you place Timelog in your Startup group, it will 
therefore be on the screen at the beginning of work reminding you to record what you 
will be working on. 
Another suggestion is to not let your database files get too large. On every transaction, 
Timelog writes the entire database file. If that file contains the record of five years work ,
transactions could become very slow. In addition, you are risking five years data on 
each transaction. Perhaps a good idea is to start a new database at the beginning of 
every month and archive away the previous month's data.
It was once suggested that Timelog provide a menu command for writing out a single 
project or group of projects to an archive database file. Timelog does not now have this 
facility. The concept for Timelog was to make it very simple and not to add any features 
to complicate it that could be achieved in other ways. We could change our minds 
depending on customer demand. If you desire to do this, just copy the database file that
contains the projects to be archived to another file, bring that new file into Timelog with 
the Open item on the File menu and then delete the projects that you don't want with the
Deleted Selected Project item on the Edit menu.
Exatech is always interested in hearing from users about new features that would 
increase the usefulness of Timelog.





File Menu Item - New

The "New" item    in the File Menu creates a new Database of projects. 
Choosing this item causes a dialog box to appear that prompts you for a database 
name. This name will be used in the various Reports that can be generated from the 
database.
Immediately after entering the database name a file dialog box will appear in order for 
you to enter the name of the file to contain the new database. 
The full pathname of the new database file will appear in the title bar of the main 
window when you press the OK button in the file selection dialog box. The ListBox 
should then be empty because a new database will not yet have any projects.
You can then use the Edit Menu Add Project item to add projects to the new database.





File Menu Item - Open

The "Open" item    in the File Menu reads in    an existing Database of projects. 
Choosing this item causes a file selection dialog box to appear that prompts you for the 
file name of the database file. The full pathname of the new database file will appear in 
the title bar of the main window when you press the OK button in the file selection dialog
box. The ListBox will then contain the names of the projects in the newly read database.
If the new database contains an open work session the icon in the upper left corner of 
the main menu will be belching black smoke.





File Menu Item -SaveAs

The "SaveAs" item    in the File Menu writes the Database of projects held byTimelog to 
a file that you are allowed to name. 
Choosing this item causes a file selection dialog box to appear that prompts you for the 
file name of the new database file. The full pathname of the new database file will 
appear in the title bar of the main window when you press the OK button in the file 
selection dialog box. 
Using SaveAs is equivalent to copying the Database file to a file with a different    name 
and then using the Open item in the File Menu    to bring that new file's contents into 
Timelog as the database.





File Menu Item -Exit

The "Exit" item    in the File Menu kills    Timelog. It is equivalent to clicking on the "Quit:" 
button in the main window or choosing the "Close" item in the Control Menu Box.
You are not prompted to save the    Database    when you quit the program since the disk
resident database is always updated whenever you    Punch In, Punch Out or Add a 
New Project.





Edit Menu Item -Add Project

The "Add Project" item    in the Edit Menu allows you to add a new project to the open 
Database. When you choose this menu item, a dialog box will appear to prompt you for 
the name of the new project. When you enter the name and click on the OK button, the 
new project is added to the open database on disk and the project name is added to the
list of projects displayed in the List Box.



Edit Menu Item -Delete Selected Project

The "Delete Selected Project" item    in the Edit Menu allows you to delete a project from
the open Database.    The project that will be deleted is the one selected in the    main 
window List Box.When you choose this menu item, a dialog box will appear to confirm 
that you want to delete the project. If you confirm by clicking the "Yes" button in the 
dialog box, the project and all of its sessions disappear from the open database's disk 
file and from the in memory representation of the database.
Occasionally you might go through this procedure and to your horror realize that it was 
a terrible mistake. You have one fallback. Don't do anything else. Quit Timelog. Then 
rename your database's ".tim" file to something you can remember in case of ultimate 
disaster. Then copy your database's .bak file to become a new version of your 
database's .tim file.
Whenever a transaction is commited to disk, Timelog is copies the previous database to
a ".bak" file. See Data Security. We hope this saves you. But sometimes the best layed 
plans ... You know how it goes.



Edit Menu Item -Edit Selected Project

The "Edit Selected Project" item    in the Edit Menu allows you to edit    a project from the
open Database.    The project that will be edited    is the one selected in the    main 
window List Box.
When you choose this menu item, a dialog box will appear. The first item at the top of 
this box, is the project name. You can change the project name by placing the cursor in 
the box containing the name and editing the name from the keyboard. When you 
choose the "Quit" button at the bottom of the dialog box, the project's name in the disk 
resident Database is updated to reflect your editing.
There are a number of items grouped together and labeled with the word "Session". 
This group allows you to edit the set of sessions owned by the project that you are 
editing. The group has three text entry boxes and four push buttons.
The text entry boxes will contain data for one of the sessions or they will be blank if the 
project has no sessions. You can delete the session that is displayed by choosing the 
"Delete" button". You can add a new session by choosing the    "Add New" button. The 
session added in this case will have the Punch In and Punch out times set to the system
time. You can then edit these to be what you require.
You can move through the sessions owned by the project by choosing either the "Back" 
or the "Next" buttons.
Finally you can change the data for any session by editing the text boxes showing that 
data. In the case of the Punch In and Punch Out times, the date and time format you 
use must rigidly match the one used by the program when it displays these items. In 
other words, your editing might change the month or the time of day. But the result 
should be in the same format. For instance, a 24 hour time format is used by the 
program. Therefore the program expects that you will also use that format. If you 
instead enter 10:00 PM, the program will probably ignore the PM and your time value 
will be off by 12 hours. Future versions of the program may get more clever.



Report Menu Item -Aggregate Report

The "Aggregate Report" item    in the Report Menu produces a report that    shows the 
total time for each project and the sum for all projects in the open Database.    This 
report suppresses the detailed punch in and punch out times for each session.



Report Menu Item -Detailed Project Report

The "Detailed Project Report" item    in the Report Menu produces a report that    shows 
the details of the session activity for the project selected in the main window List Box. It 
also rolls up the total time for all the work sessions in that project.



Report Menu Item -Dump Entire Database

The "Dump Entire Database" item    in the Report Menu produces a report that contains 
the complete contents of the open Database.



Product Registration
This program is copyrighted by Exatech Corporation. Exatech's    copyright is protected 
by the United States copyright laws and international treaty provisions.
A single user/single CPU license may be obtained from Exatech Corporation for    
$49.95 plus a $5.00 shipping and handling fee. The License Registration item on the 
Help menu will give you a way to have the program print out an order form. Please send
your license registration fee to:

Exatech Corporation
6547 N. Academy Blvd. Suite 527
Colorado Springs, Colorado 809l8

Please include your name, address and telephone number with your order. Upon receipt
of your order, Exatech will provide you with a diskette containing the latest version of the
program, a registration number that will also serve to deactivate the intial Registration 
Information dialog box ,a telephone support number and a copy of the license 
agreement.

EXATECH CORPORATION DISCLAIMS ALL WARRANTIES WITH RESPECT TO THIS
SOFTARE. THIS SOFTWARE IS PROVIDED FOR USE AS IS WITHOUT WARRANTY 
OF ANY KIND EITHER EXPRESS OR IMPLIED. ANY USE OF THIS SOFTWARE IS AT
YOUR OWN RISK. EXATECH CORPORATION DISCLAIMS ALL WARRANTIES OF 
MERCHANTABILITY AND FITNESS FOR A PARTICULAR USE.

No license to use this software for other than demonstration purposes exists until the 
registration fee is paid to Exatech Corporation. At that time, a copy of the license 
agreement will be supplied by Exatech.


