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Installation
To install for Windows:

1. From diskette, insert disk #1 into the proper floppy drive.

From hard disk, verify the location of the WebImage installation files.

2. Choose Run from the Windows Program Manager File menu.

3. Type a:install (designate the appropriate drive or path location) and select OK.

4. Follow the directions on the screen to navigate the Install program.

WebImage requires a minimum configuration of a 386/486 PC compatible, Windows 3.1, 4MB RAM, 3MB 
of hard disk space, and a Super VGA level (256 colors) display.



Main Window
WebImage loads images both in full-screen mode and in thumbnail mode. When loaded full-screen, 
images can be panned, zoomed, and edited in the main window. When in thumbnail mode, small 
thumbnail size images of graphics files are displayed in the main window. Thumbnails can be selected 
using the pointer. Double click on a thumbnail to launch it into full-screen viewing mode.



Menu Bar
The menu bar is the horizontal bar across the top of the WebImage window that lists the title of each pull 
down menu. Options include:

File - Includes New, Open, Close, Save, Display Thumbnails, Encode and Decode, Rename and Delete, 
Print, and Exit.

Edit - Includes Undo, Cut, Copy, Paste, and Clear.

View - Includes Refresh, Zooming, and Information.

Image - Includes Color Adjust, Color Reduction, Orientation, Resize, Invert, Swap Red & Blue, Equalize, 
Remove Noise, and Sharpness.

Effects - Border, Emboss, Add Text, and Text Options.

Area - Includes Mirror X, Mirror Y, Rotate-90, Crop, and Duplicate.

Mapping - Includes Map Mode, Open Map, Save Map, View List and the mapping Shapes.

Options - Includes Thumbnail Database, and Preferences.

Help - Includes Contents, Using Help, and About.



Tool Bar
The Tool Bar consists of a row of icons displayed directly below the Menu Bar.

The tools in the order of appearance are:
Open, Save, Display Thumbnails, Print, Undo, Zoom In, Zoom Out, Info, Color Adjust, Color Reduction, 
Orientation, Resize, Add Text, Help, and Exit.



Status Bar
A status bar appears at the bottom of the WebImage window.

The status bar displays a help prompt for each menu item or tool selected. In addition, the cursor 
coordinates, the zoom level, file format, compression, color count, and file size are shown for the full-
screen mode. A selected image's sequence number, file name, and format information is displayed when 
in thumbnail mode.



 Using the Pointer
The Pointer (cursor) is used to select menus, tools, and thumbnail images. The Pointer is also used to 
define areas for zooming, printing, moving, sizing, cutting, copying, pasting, duplicating, mirroring, 
rotating, bounded area manipulation, and mapping.

To define an area, Select and Drag the Bounding Box until an area is enclosed, then Release. Cancel to 
unselect. Press <Shift> or use the middle mouse button to produce an exact square.



 Accessing On-line Help
Select Help from the menu bar or Select the Help Tool. The Help menu includes the following help 
capabilities:

1. Contents. A dialog box containing the help topics is displayed. Select a topic from the list and its 
appropriate help message displays.

2. Using Help. Help is provided on using the help system.

3. About. The version number and copyright information is displayed.



 Exiting
Select Exit from the File menu or Select the Exit tool to end a WebImage session. A dialog box asks 
whether to save the image or to exit without saving if the current file has not been saved since the last 
change. 



 Opening a File
Select Open from the File menu or Select the Open tool. The File Selection dialog box is displayed. Use 
the pop-up List Files menu to select a filter extension. 

Use the Directories list box to select the path and the File Name list box to select the file name or 
manually type the name of the file in the input field. The specified file is loaded when the OK button is 
pressed.



 Displaying Thumbnails
Select Display Thumbnails from the File menu or Select the Display Thumbnails tool to display a list of the 
currently defined thumbnail catalogs. The Display Thumbnails dialog box is displayed. Use the Current 
Catalogs list box to select the desired thumbnail catalog.

To build a new catalog, Select the Build New Catalog button. Use the Directories list box to select the 
desired directory path. Use the Files list box to view the image file names located in the selected 
directory. Enter a name for the catalog in the Catalog Name input field and Select OK.

The Update Database? dialog will prompt you before adding images to the thumbnail database. Select 
Yes to add the images to the database, No to view the thumbnail images without adding them to the 
thumbnail database, or Cancel to discontinue the operation.

Once thumbnail images are loaded, double click on any thumbnail to launch the image into fullscreen 
editing mode.



 Area Manipulation
An area is defined by the Pointer. A rectangular area is bounded by a dotted line with a small black 
square at each vertex (Bounding Box). An area may be zoomed, printed, cut, copied, duplicated, moved, 
sized, rotated, and mirrored.

1. Zooming. Define an area and then select the Zoom In tool or Select Zoom In from the View 
menu.

2. Printing. Define an area and then select the Print tool or Select Print from the File menu.

3. Clear, Copy, Crop, and Cut. Define an area and then apply the appropriate function.

4. Paste. Apply the appropriate function and then move and size the pasted area.

5. Move. The cursor changes to a four-sided arrow when placed within the Bounding Box. Select 
anywhere the four-sided arrow is present, then Drag the outline to the new location, and Release. 
The Status Bar indicates the change in position as the outline is moved. 

6. Size. The cursor changes to a side pull bar or a corner pull bar when placed at the edges or on 
the black squares in the corners of the Bounding Box. Select a pull bar and Drag the side or 
corner to the desired size. Press <Shift> to size proportionately. The Status Bar indicates the 
change in scale as the outline is moved.

7. Duplicate. Ensure that the Duplicate check on the Area menu is On. Select an area using the 
Pointer, then Select and Drag from inside the bounded area to move a duplicate image of that 
area anywhere on the Canvas.

8. Mirror. Select an area using the Pointer. Select Mirror X or Mirror Y from the Area menu. The 
bounded area is inverted along the appropriate axis.

9. Rotate-90. Select an area using the Pointer. Select Rotate 90 from the Area menu. The bounded 
area is rotated 90 degrees around its center.



 Color Adjusting
To modify the brightness, contrast, or gamma of an image, Select Color Adjust from the Image menu or 
Select the Color Adjust tool. Select and Drag the appropriate slider to the desired value. Select the 
Channel pop-up to define the color channel as Red, Green, Blue, or All. Press View to interactively adjust 
the image, OK to accept the changes, or Cancel to discard the changes.



 Color Reduction
Select Color Reduction from the Image menu or Select the Color Reduction tool. Select the desired 
preset color reduction option or Select Custom and enter the number of colors to use in reducing the 
image.

Select a color reduction method. Dithering produces the highest quality color reduction by using 
combinations of colors and patterns to represent various colors. WebImage uses a high-quality diffusion 
routine for reducing color content. Matching selects the closest color value and reduces the image 
appropriately. Press View to interactively adjust the image, OK to accept the changes, or Cancel to 
discard the changes.

Images with a high color content (i.e. photographs) will reduce best with the dithering method. However, 
dithered images do not compress well. Images with a low color content (i.e. clip art) will reduce best with 
a matching method and produce maximum compression.

Color reductions can be performed using the Color Adjust dialog or during the saving process. By using 
the Color Adjust dialog, changes can be reviewed visually before saving a file. In addition, the Color 
Adjust dialog provides the option of reducing an image to a user-defined number of colors. Once a 
reduction is made via the Color Adjust method, the Save feature will auto-detect the color content and 
save in the appropriate format.



 Orientation
An image may be rotated 90, 180, or 270 degrees. Select Orientation from the Image menu or Select the 
Orientation tool. Select the desired orientation. Press OK to change the image.



 Resize
Select Resize from the Image menu or Select the Resize tool. Select a desired preset dimension or the 
Custom setting. Select Custom-Proportional to maintain the proportional ratio (aspect ratio) between 
Width and Height. Select Custom in order to enter non-proportional Width and Height values. WebImage 
provides a high quality algorithm for stretching and reducing an image; however, size increases will 
eventually blur any image. Maintain the original aspect ratio to produce the best results.

It is quite possible to define a combination of Width and Height which exceeds the memory capacity of the 
system. An error message indicates that the system is out of memory when such values are entered. 
Select a smaller size to reduce memory utilization.



 Undo
Select Undo from the Edit menu or Select the Undo tool to reverse the immediately previous action. 
WebImage provides one level of undo. An action consists of one iterative procedure and includes area 
manipulation, cut/paste, color/size change, orientation, filtering, or thumbnail display. It does not apply to 
the Delete, Rename, or Save functions.



 Zooming
Select a zoom level from the View menu or Select the desired Zoom tool. The Positive Zoom tool zooms 
in on the image, the Negative Zoom tool zooms out on the image. The View menu contains options for 
fitting the entire image in the window and for fitting the width of the image in the window.

To zoom on an area, define an area and then select the Zoom In tool or Select Zoom In from the View 
menu.



 Displaying File Information
Select Information from the View menu or Select the Info tool to display a dialog of information about the 
currently loaded or selected thumbnail image.

Information is displayed for file name, file size, and modification date. In addition, the graphics format type 
is defined, compression method used, width and height dimensions in pixel units, aspect ratio 
(height/width), color type, and number of color shades.



 Printing
Select Print from the File menu or Select the Print tool. Select Setup to change the target Printer or printer 
definitions. WebImage allows printing of a single image, a selected area, a selected thumbnail, a range of 
thumbnails, or an entire thumbnail catalog.

WebImage appropriately fits an image to the page when printing. Enter a Margin value in inches to define 
the amount of spacing between the image and the edge of the page. For thumbnail printing, define a 
Thumbnails Per Page value to define the thumbnail layout. To print a selected area, define an area using 
the pointer and then select the Print tool or Select Print from the File menu.



 Saving an Image
Select Save or Save As from the File menu or Select the Save tool. Save stores the image under its 
existing file name and native format. Save As allows a new file name to be entered or a new format or 
variation of the existing format to be defined.

The File Selection dialog box is displayed. Select a file format using the Files Type pop-up menu. Select 
the Options button to define color depth, compression, and options associated with the defined file type. 
Use the Directories list box to select the path and the File Name list box to select the file name or 
manually type the name of the file in the input field. The current image is saved under the specified file 
name when the OK button is pressed.

Related Topics:
Options



Options

Color Depth. Allows saving an image at any supported bit depth. When the defined bit depth contains 
fewer colors than that found in the current image, Select a color reduction method. Dithering produces the 
highest quality color reduction by using combinations of colors and patterns to represent various colors. 
WebImage uses a high-quality diffusion routine for reducing color content. Matching selects the closest 
color value and reduces the image appropriately.

Images with a high color content (i.e. photographs) will reduce best with the dithering method. However, 
dithered images do not compress well. Images with a low color content (i.e. clip art) will reduce best with 
a matching method and produce maximum compression.

WebImage will auto-detect the format and color content of an image and default to the appropriate 
settings. It is possible, however, to save an image in a different format. For example, a 1-bit TIF file can 
be saved in a 24-bit TIF format.

Compression. Some file formats support different compression methods or no compression at all. 
Possible options include None, RLE, LZW, Packbits, Group 3, Group 4, CCITT, JPEG, and Deflate.

JPEG Options. Quality, Q Factor, of JPEG images can be defined from 25 to 100. The Q Factor 
determines the amount of lossiness for an image inversely related to the amount of compression for an 
image. For example, a Q Factor of 25 would produce maximum image loss but the most compression. A 
Q Factor of 100 would produce a near lossless image but with almost no compression.

The JPEG Photograph option utilizes a number of subsampling methods in order to achieve maximum 
compression. These methods can often produce undesired results and blurring in images which contain 
sharp edges and high color contrasts. Select the Line Art option for such images.

Interlacing. Images that are interlaced provide a seemingly faster view time when displaying via an on-
line service. This is possible because it first displays a less detailed image followed by a display of the 
complete image.



Creating a New Image
Select New from the File menu. The New dialog box is displayed. To create an image, Select New Image, 
define the dimensions, and choose a color. To create an image from the Clipboard, Select Paste from 
Clipboard. Press OK to create the new file.



Enhancements
A number of filtering methods can be applied to an image to change and enhance it. Following are 
descriptions for each method and the purpose for using it.

Related Topics:
Equalize

Invert

Remove Noise

Sharpness

Swap Red & Blue



Equalize

When an image is too dark or too light and cannot be adequately adjusted using the brightness control, it 
is recommended to use the Equalize filter. This filter analyzes the image's histogram of luminosity and 
adjusts the colors so that an equal amount of luminosity exists throughout the image. To equalize the 
image, Select Equalize from the Image menu.



Invert

When importing image files from a variety of sources it is possible to run across an image that has been 
inverted. This is often true of monochrome files. To invert the image, Select Invert from the Image menu.



Remove Noise

Often a file comes from a source which has introduced noise to the image. For example, a video grab 
may include small white pixels (snow) or a fax file might contain a number of small black pixels. The 
Remove Noise filter can help clean such images.

This filter evaluates every pixel in an image, samples the surrounding pixel values, determines a median 
color value, and compares the original pixel value to that median. If the difference is greater than the 
defined threshold value, the pixel is replaced by the median color value. Threshold values can be defined 
from 1 to 128. A higher defined value results in less pixel replacement. Conversely, a lower value results 
in more pixel replacement. A value between 32-64 is recommended for effective noise reduction.

To remove noise from an image, Select Remove Noise from the Image menu. Select and Drag the slider 
to the desired value. Press View to interactively adjust the image, OK to accept the changes, or Cancel to 
discard the changes.



Sharpness

To modify the sharpness of an image, Select Sharpness from the Image menu. Select and Drag the slider 
to the desired value. Press View to interactively adjust the image, OK to accept the changes, or Cancel to 
discard the changes.



Swap Red & Blue

When importing image files from a variety of sources it is possible to run across an image with the red 
and blue pixels swapped. This is often true of Sun Raster files. To swap the red and blue pixels, Select 
Swap Red & Blue from the Image menu.



Effects
A number of effects can be applied to an image to change and enhance it. Following are descriptions for 
each method and the purpose for using it.

Related Topics:
Border

Emboss

Transparency

Add Text



Border

To apply a border or button effect to an image, Select Border from the Effects menu. Select and Drag the 
slider to define the width of the border effect in pixels. Select the desired color for the border effect. Select 
a border type of Basic, Raised Button, or Inverted Button. Press View to interactively adjust the image, 
OK to accept the changes, or Cancel to discard the changes.

The Basic border will add a standard border to the image of the desired width and color. The Raised 
Button option will create a 3D button effect on the image. The Inverted Button option will create a 
"pushed" button effect on the image. Selecting a color option of None, will incorporate the image into the 
button effect.



Emboss

To apply an embossed filtering effect to an image, Select Emboss from the Effects menu. Select and Drag 
the Light Angle slider to the desired value. Press View to interactively adjust the image, OK to accept the 
changes, or Cancel to discard the changes.



Transparency

To define a transparent color for GIF images, Select Transparency from the Effects menu. Select and 
Drag the Red, Green, and Blue sliders to define the desired color value or use the Pointer to directly 
select a color from the image. Press the Remove button to remove a previously defined transparency 
value. Press View to interactively view the transparency, OK to accept the changes, or Cancel to discard 
the changes. The transparent color of an image will then be displayed with a gray cross-hatched fill 
pattern.

Transparency is typically used to "turn off" a color in an image, making that color transparent. The effect is 
most often used when creating images for Web pages. Most Web browsers will read transparent images, 
allowing the appearance of a free-form image as opposed to a rectangular one. Transparency only 
applies to images saved in the GIF format.



Add Text

To add text to an image, Select Add Text from the Effects menu or Toggle On the Add Text tool. Select to 
place the text cursor anywhere on the image and begin entering text from the keyboard. Select another 
insert point to add additional text. Toggle Off the Add Text tool or Cancel to exit the Add Text mode.

To change the text options, Select Text Options from the Effects menu. Select the desired Font, Size, 
Style, Color, Justification, and Orientation for the inputted text. The text display will show a preview of the 
selected options. Press OK to accept the changes or Cancel to discard the changes.



Mapping Files
Mapping files is a procedure used to create click point regions in an image file for use on Web pages. 
WebImage provides the capability to create both NCSA and CERN compliant image maps. Contact your 
Web administrator to determine which format to use when saving image maps.

Related Topics:
Creating a Map File

Map List

Saving a Map File

Opening a Map File



Creating a Map File

Toggle On the mapping mode by Selecting Map Mode located in the Mapping menu. When in map mode, 
all other image editing functions are disabled. To return to image editing, Toggle Off the Map Mode. Make 
sure to complete final image sizing functions before creating the map file.

Select a shape to use as a mapping region, options include circle, point, polygon, and rectangle. To draw 
a circle or rectangle, Select and Drag the Bounding Box until the desired region is defined, then Release. 
To draw a polygon, Select the first point, then Select each additional point up to a maximum of 100 points. 
Cancel to close the polygon. To draw a point, Select the desired located on the image.

After each shape is completed, a prompt is displayed for entering a Uniform Resource Locator (URL) 
pointer and any desired comments to associate with the map entry. The URL is the click entry desired 
when someone selects that region of the image. Comments make it easier to identify map entry meaning 
in the Map List.

The status bar at the bottom of the WebImage window will display the XY location, zoom level, associated 
URL, and map file name. To verify and test the map entries, move the Pointer over the various mapping 
regions. The status bar will reflect the associated URL for each region.



Map List

To interactively display, select, and edit map entries, Select View List located in the Mapping menu. From 
the Map List, Select the desired map entry. The selected entry will be highlighted on the image. Select the 
Edit button to edit the URL or comments. Select the Delete button to remove the entry.

Image maps typically contain a default entry, which is called if a point is selected that is not defined by a 
mapping region. To enter a default entry, Select the Default button and input the appropriate URL and 
comments.



Saving a Map File

Select Save Map from the Mapping menu. The File Selection dialog box is displayed. Select either the 
NCSA or CERN format using the Files Type pop-up menu. Use the Directories list box to select the path 
and the File Name list box to select the file name or manually type the name of the file in the input field.

The current map is saved under the specified file name when the OK button is pressed. The current map 
name is reflected in the status bar.



Opening a Map File

Existing map files can be opened and edited, but be sure to open the appropriate map file associated with 
an image file.

To open an existing map file, Select Open Map from the Mapping menu. The File Selection dialog box is 
displayed. Use the pop-up List Files menu to select a filter extension. Use the Directories list box to select 
the path and the File Name list box to select the file name or manually type the name of the file in the 
input field.

The specified file is loaded when the OK button is pressed. The current map name is reflected in the 
status bar.



Renaming Files
While in thumbnail mode, Select the desired image or range of images to rename. Select Rename from 
the File menu. In the Rename dialog box, input the desired file name. Include both the suffix and prefix for 
the file name.



Deleting Files
While in thumbnail mode, Select the desired image or range of images to delete. Select Delete from the 
File menu. A warning dialog will prompt before deleting the file. Select OK to delete the file or Cancel to 
end the delete procedure.



File Encoding
File encoding is a method used to convert binary files into coded ASCII files. By doing this, it creates a file 
that is easier and more reliable to transfer via telecommunication lines. This method is most often used 
for mailing or posting binary files to the Internet. When transferring files between Unix and DOS systems, 
be sure the naming scheme of the original file and the encoded files are appropriate.

Related Topics:
Encoding

Decoding



Encoding

The encoder can encode any binary file including images and executable files. It provides options for the 
popular UUencoding technique or the XXencoding method. In addition, longer files can be separated into 
multiple parts using a variety of popular methods.

Select Encode from the File menu. A File Selection dialog box is displayed. Use the Directories list box to 
select the path and the File Name list box to select the file or manually type the name of the file in the 
input field. Select either the UU or XX encode method. Select the Multi-Part Format pop-up to define 
Single File or the desired multi-part method. If a multi-part format is selected, enter the maximum file size 
in bytes in the Max File Size input field. The default is 60,000.

The Encode File Name dialog is displayed when the OK button is pressed. By default, Single File format 
files are named with the original prefix and the appropriate UUE or XXE suffix. For example, image.gif 
would become image.uue. Multi-part format files have the prefix appended with the part number and are 
given the appropriate UUE or XXE suffix. For example, a 3-part image.gif file would become 
image01.uue, image02.uue, and image03.uue.



Decoding

The decoder can decode any UUencoded or XXencoded file. In addition, it can decode multi-part files 
without the user having to combine them into one file with a text editor.

Select Decode from the File menu. A File Selection dialog box is displayed. Specify a filter extension, then 
use the Directories list box to select the path and the File Name list box to select the file or manually type 
the name of the file in the input field. The specified file is decoded when the OK button is pressed.

The Save Decoded File dialog displays the decoded file name as defined the encoded file. Accept the file 
name or change appropriately.

For multi-part files, you will be prompted to define each part in sequence. The decoder will discard any 
message text or CUT remarks in the file and automatically construct the multiple parts into a single binary 
file. Be careful to define the files in order.



Considerations
Web pages can currently support in-line images in the GIF or JPG format. The PNG format is a recently 
introduced format that will soon become another supported file-type.

GIF images are limited to a maximum of 256 colors, but compress well and provide support for 
transparent regions and interlacing. JPG is a 24-bit, or 8-bit gray scale, "lossy" format, that provides 
excellent compression. However, the compression methods used do not make this format conducive to 
low-color content images or for distributing images for reuse. PNG provides the capability of defining 
paletted low color content images or 24-bit images, supports transparent regions and interlacing, and 
provides a better "lossless" compression than the GIF format.

The major considerations when optimizing images for a web page are color content, file size, and image 
size. Most computers today only have the capability of displaying 256 distinct colors (SVGA) on the 
screen at one time. This is the major factor to consider when designing images for a web page. Since 
most Internet users access the web via a modem (usually 14.4 or less), the next consideration is the 
actual file size. Lastly, most screen resolutions typically range between 640x480 to 800x600, making the 
size of the image (resolution) a key factor if viewing the entire image is critical to the content of the web 
page.



Color Content
When optimizing images for web pages, it is critical to test the web page with a variety of web browsers 
(Netscape, Mosaic, etc.) with the display set to 8-bit SVGA (256 colors). This will allow the visualization of 
the web page under a variety of circumstances, since each web browser deals with colors differently. 
Images in one browser may look very different in another.

When creating images that will be the main content of the web page it is best to keep colors simple, of a 
primary tone, and consistent across images. When multiple images of varied color content are provided 
on one web page, color reduce the images such that the sum of all the color counts is less than 256 
colors. For example, to include 4 photographic images and not have them dithered by the browser, 
reduce the color content to 50 colors per image, taking up only 200 of the available 256 colors. 

When an image is loaded in WebImage, the color count is displayed in the Status Bar at the bottom of the 
window. The Color Reduction tool allows for various and user-defined color reductions. WebImage' color 
reduction capabilities provide superior reduction of 24-bit images to as little as 50 colors. It is good 
protocol to perform all image editing before making a final color reduction since many functions like 
resizing and adjusting sharpness can actually add colors to an image.



File Size
With most Internet users accessing the web via a modem, image file size becomes critical to ensure 
reasonable load and view time for a web page. The most important factor in reducing the size of an image 
file is color content.

One way that WebImage may quickly reduce the size of a GIF file, is to resave a file and let WebImage 
auto-detect the number of colors in an image and save the file in the appropriate bit depth. For example, 
a 30 color GIF file will most likely have been saved as an 8-bit (256 colors) file. WebImage will auto-detect 
the color content of the image and save as a 5-bit (32 colors) file, effectively reducing the file size.

The content of the image is another consideration. Images with a wide array of colors do not compress as 
well as images with large areas of a single color. When color reducing an image, evaluate the difference 
between the matched and dithered methods, as dithered files do not compress well. Also consider using 
the JPG format for 24-bit images, carefully evaluating the size versus quality issue.



Image Dimensions
The dimensions of an image have an impact both on the visible area of a web page and the physical size 
of the resulting image file. If an image is critical to the content of a web page, it is probably important to 
view the entire image within the viewable area of the web browser. A good rule of thumb is to design for 
the web browser window to have a 640x480 dimension, and plan accordingly for the toolbar, etc.

Single image sizes should be kept to a minimum, as they will delay the time for a web page to load and 
display. In addition, the larger the dimensions for an image, the larger the file size is, and the longer it 
takes to download. If larger dimensions are required, try reducing the color count to help decrease the file 
size.



Interlacing
Both the GIF and PNG formats support a loading process called interlacing. Basically, this allows a less 
detailed version of the image to be loaded and displayed quickly, with the remaining detailed loaded after 
the rest of the web page is loaded. Most web browsers support the functionality of interlaced images, and 
those that don't will display the image normally. Interlacing can be turned on for an image in the Save 
Options dialog.



Files
WebImage requires the following files.

Delivered:

webimage.exe¾binary executable

webimage.hlp¾help file

webimage.ini¾located    in \windows

bwcc.dll¾located in \windows\system

ctl3dv2.dll¾located in \windows\system

Created by WebImage:

webimage.dat¾thumbnail database file



Thumbnail Database
WebImage maintains a database file called webimage.dat for all the defined image catalogs. This file, by 
default, is located in the WebImage directory. It can be located in a different directory as long as the path 
is modified for the DatPath definition located in the webimage.dat file. For users accessing WebImage on 
a network server or on a Windows NT server, it is important to define the DatPath variable to the local 
client.

When a new image catalog is defined, thumbnails are built and added to the webimage.dat file. Each 
thumbnail increases the size of the webimage.dat file by 10 KB. This database file provides fast thumbnail 
display of an image catalog. Images that have been deleted, renamed, or added are appropriately 
updated during the next catalog display.

Select Thumbnail Database from the Options menu. The Thumbnail Database dialog allows image 
catalogs and their associated thumbnails to be removed. This should be done when a directory has been 
removed, a thumbnail catalog is no longer desired, or the user wants to decrease the physical size of the 
webimage.dat file. Highlight the desired catalog and Select the Delete button to remove its entry.

Eventually the database will begin to develop "empty" slots after several catalog deletions. When the 
Percentage Used status drops below 90%, Compact Database will improve access time and reduce the 
webimage.dat file size. A minimum swap space equal to that of the webimage.dat file is required for a 
successful compression.



Preferences
Several options relating to the operation of the WebImage environment are included on the Preferences 
dialog box.

Select Preferences from the Options menu:

1. Image Display. On systems using less than a 24-bit display, WebImage can load images using a 
"best fit" to the currently defined system color map or can dither the image for the best possible 
display. Select Fast to have the images load, zoom, and scroll at optimum speed. Select Best to 
have images fully dithered when loading. Depending on the color content of an image, the 
difference between Fast and Best might not be detectable. However, the Fast option does 
improve speed considerably. All images retain their native color content regardless of the on-
screen display.

2. Thumbnail Display. The arrangement of thumbnails in the window may be defined by the user or 
set automatically by the system. Select Preferences from the Options menu, then Select Auto to 
allow the system to pick the best arrangement of thumbnail images. Select Custom and enter a 
numeric value in the input field to specify the number of thumbnails per row.

3. Save Settings. Select this button and the webimage.ini file is automatically updated with the 
current settings.



Mosaic and Netscape
WebImage can be defined as an external viewer or "helper" application in most common Web browsers 
including Mosaic and Netscape. Doing this extends the capabilities of viewing, editing, and saving images 
from the Internet.

To define WebImage as the image viewer, edit the browser's configuration for viewing image files. Define 
the WebImage executable as the viewer for all the supported image formats.

Related Topics:
Enhanced Mosaic 2.x

Netscape Navigator



Enhanced Mosaic 2.x

To configure WebImage in Enhanced Mosaic 2.x from Spyglass, Select Helpers located in the Edit menu. 
Change the viewer option for the formats JPEG, GIF, and TIFF. Input the WebImage executable in the 
Helper Application field making sure not to append this entry with %s. Input GViewer in the Service Name 
field. WebImage utilizes the Spyglass SDI for optimal communication.



Netscape Navigator

To configure WebImage in the Netscape Navigator, Select Preferences located in the Options menu. 
Change the settings for Helper Applications. Define the WebImage executable for the supported image 
formats.



BMP
OS/2 Bitmap: Similar to Windows BMP, the standard image format for use with OS/2. WebImage 
supports BMP files with no compression.    Color depths may be 1, 4, 8, or 24-bit.

Windows Bitmap: The image format created by Microsoft for use with Windows. WebImage supports 
BMP files with no compression.    Color depths may be 1, 4, 8, or 24-bit.



EPS/PS
Encapsulated PostScript: A PostScript output program file. PS files are typically sent directly to 
PostScript printers, while EPS files are created for importing into other products. WebImage exports EPS 
and PS files to PostScript Level 1 (8-bit gray scale) or PostScript Level 2 (24-bit color).



GIF
Graphics Interchange Format: The format created by CompuServe for the efficient exchange of 
graphics over modem lines. This format is commonly found on many on-line services and throughout the 
Internet. WebImage supports type 87a/89a, interlaced/non-interlaced, and transparent/non-transparent 
GIF files. Color depths may be 1, 2, 3, 4, 5, 6, 7, or 8-bit.



JPEG/JPG/JFIF
Joint Photographic Expert Group: 24-bit support and excellent compression make this format a new 
standard for on-line services. WebImage supports JPEG code version 5. Color depths may be 8-bit gray 
scale or 24-bit color. Export quality, Q factor, can be defined from 25 to 100.



PCX
ZSoft's PC Paintbrush: WebImage supports the import of PCX versions 2, 3, 4, and 5 and exports PCX 
version 5. Images must use standard PCX RLE compression. Color depths may be 1, 4, 8, or 24-bit.



PNG
Portable Network Graphics: The format created in response to the GIF licensing debacle. Developed for 
optimized graphics use on the Internet and other on-line services. WebImage supports interlaced/non-
interlaced and transparent/non-transparent PNG files. Color depths may be 1, 2, 4, 8, 16, 24, or 48-bit.



RAS
Sun Raster: The native bitmap file format for Sun workstations. WebImage supports Sun Raster files with 
color depths of 1, 8, or 24-bit and supports standard RLE compression.



TGA/TARGA
Truevision Advanced Raster Graphics Adapter: Introduced by AT&T to support their image capture 
boards and now supported by Truevision. WebImage supports TARGA Type 2 (no color map, 
uncompressed) and Type 10 (no color map, RLE compressed) files. Color depths may be 16, 24, or 32-
bit.



TIF/TIFF
Tagged Image File Format: The most widely used raster format, it is jointly developed and supported by 
Aldus and Microsoft. WebImage supports Type 1 (no compression), and Type 32773 (Packbits 
compression). Color depths may be 1, 4, 8, or 24-bit. WebImage also supports CCITT Group 3 and Group 
4 fax formats. Multi-page TIFF files display only the first image and there is no support for tiled or JTIF 
images. Imported TIFF files may be in either Intel or Motorola byte order. Exported TIFF files comply with 
the TIFF 6.0 specification.



XWD
X Window Dump: A screen dump raster format created by M.I.T. for use with the X Window utilities xwd 
and xwud. This format is also supported by many X Window applications and is an excellent means for 
creating image files from the X Window System. WebImage supports uncompressed XWD files in 1, 4, 8, 
or 24-bit color depths.



Contact and Ordering
To purchase Group 42 products, inquire about site licenses, or pursue OEM bundling arrangements, 
contact us at:

Orders: 800-520-0042
Telephone: (513) 831-3400
Internet: info@group42.com
Web: http://www.group42.com
CompuServe: 73441,305

Payment is accepted via Mastercard, Visa, COD, and prepay check.

Technical support is provided for registered users via Internet email, CompuServe, or snail mail.
Group 42, Inc.
228 Mill Street #102
Milford, OH 45150



Copyright Notification
WebImage is copyrighted Ó 1995 Group 42, Inc. Use, copy, and disclosure restricted by license 
agreement. JPEG format support is based in part on the work of the Independent JPEG Group. PNG 
format support is based in part on the work of the PNG Group.

WebImage is supplied "AS IS". Group 42, Inc. disclaims all warranties, expressed or implied, including, 
without limitation, the warranties of merchantability and of fitness for any purpose. Group 42, Inc. 
assumes no liability for damages, direct or consequential, which may result from the use of WebImage.

All packaging, manuals, and promotional materials are designed to minimize waste and encourage 
recycling. Please conserve, recycle, and purchase recycled products. Listen to the Lorax!




