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INntroduction

The night sky has fascinated mankind for millennia. How many times have you caught
yourself gazing upward, wondering which bright *“star” that was, setting just after sunset,
or what constellation was rising over the neighbor’s trees? Let First Light show you.

Using a core database of over 9,000 stars (expandable to over sixteen million with the
data included on the First Light CD ROM), First Light is a powerful tool for acquainting
you with the heavens. Indeed, its power rivals that of a small planetarium where, unhin-
dered by your location on the planet, time of day, or the weather, you can freely explore
different parts of the sky.

First Light was written to take full advantage of your computer’s configuration and
the Windows environment. Simply by pointing and clicking with the mouse, First Light
lets you discover a fascinating variety of celestial phenomena and, in the process, learn
the fundamentals of astronomy.

For information about installing First Light and a brief introduction to using the pro-
gram, see the next chapter Getting Started.

The Universe In Brief

In the book Hitchhiker’s Guide to the Galaxy, author Douglas Adams sums up the uni-
verse this way:

Space is big. Really big. You just won’t believe how vastly hugely mind-bogglingly
big it is. | mean, you may think it’s a long way down the road to the [phar-
macy], but that’s just peanuts to space.

And so it is. Consider a light beam traveling at 186,000 miles per second leaving the
surface of the Sun when your morning alarm clock rings. It is 6:00 am, Monday, February
5, 1996. By the time you’ve finally just started to consider rolling out of the sack at 6:08,
the beam is sweeping through the orbit of the Earth as it heads outward bound toward
the edge of the solar system. After you’re done showering and are ready to sit down to a
bowl of Rice Krispies, it’s 6:41 and Jupiter is catching sight of the ray. It’s mid-morning,
11:12, when the beam sweeps past the orbit of Pluto (and you thought that you had a
busy morning!). It won’t be until the following Saturday afternoon, five and a half days
later, when the beam finally reaches the hypothesized cloud of comets, the Oort Cloud,
said to surround the solar system. At this point, the beam leaves the solar system, but it is
only just beginning its long journey beyond infinity.

Now you won’t have to bother thinking about the ray until the next Presidential
election in the fall of 2000. However, after all this waiting, the beam has only reached the
nearest star next to the Sun, Proxima Centuri. In 2002, it reaches Barnard’s Star, followed by
tiny Wolf 359 just in time for the 2004 Olympics. By 2008, the beam will be racing by Tau
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Cetii with a full twenty stars behind it. In the following year it overtakes BD5-1668, L725-
32, Kapteyn’s Star and Kruger 60A. Looking back, our Sun would appear as a rather bland
yellowish star slowly receding into the galactic darkness.

Jump to the end of the next century. Your great-great-grandchildren will be alive as
the beam passes beyond the likes of Sharatan, Hamal, Algol and Aldebaran. Likewise it will
have overtaken Regulus, Talitha, Miaplacidus and Arcturus.

In 2227, the sun’s light would just be reaching the open cluster of the Pleiades, in the
constellation of Taurus. The starship Enterprise is just beginning its five year journey into
television history. Even after all of this, our journey is still beginning.

Many mysteries await in the vastness of space

Now, in your imagination, leave this age behind. Leave everything you’ve ever done
or known behind. Leave your CD collection behind. Were the beam directed toward the
constellation of Sagittarius, it would be headed to the center of our galaxy, the Milky Way.
However, it won’t reach this point until after the year 32,000 A.D. Yet there is still another
50,000 years before the ray can exit the other side of the galaxy. When it does, it will be
leaving over 100 billion stars behind. Yet this galaxy is an unremarkable one of unremark-
able size with many, many others beyond. And the journey is still beginning.
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By 200,000 A.D., the beam will be passing by the Magellanic Clouds in the constella-
tion Tucana, satellite galaxies to our own. After this is nothing. Nothing for the next 1.8
million years. Back on Earth, we would see the Sun as somewhat larger, turning a reddish
hue as it begins the process of burning out. But now, looming ahead is the Andromeda
galaxy, our “sister” galaxy and a member of the local group. Looking back toward the
Milky Way, you would see a view similar to what the Andromeda galaxy looks like on a fall
evening — a fuzzy elliptical patch. Another couple of million years will finally see this
beam escaping our corner of the universe, traveling out to the open regions of space.
Douglas Adams said it was big.

Now advance again, not another few million years, but a full twenty billion years
from the present. The light beam from the Sun has at last reached the edge of the known
universe. If the solar system still exists it will likely be a rather cold and uninviting place,
the Sun having burned itself out fifteen billion years previously. Out here, what the beam
would encounter is a giant unknown. Long ago however, scientists were able to see some
objects that they said were out here, quasars. But these too remain a mystery as are so
many other things.

HINN

One of the amazing things in the universe is the range of both times and distances.
For instance, in the above example we dealt with distances measured in trillions times
trillions of miles. Yet, at the same time, some of the most interesting objects, such as black
holes and neutron stars, may measure only five to ten miles in diameter. We commonly
measure stellar processes in terms of millions of years. Yet there are stars, pulsars, which
flash thirty times each second!

As you can see, the universe has no shortage of variety. It is my hope that First Light
will serve to introduce you to this variety, and perhaps encourage you to explore further
on your own.

R. Michael Smithwick
San Jose, California

The Development of First Light

First Light is the latest step in a series of planetarium software that has taken nine
years to develop. The process began with a program called Galileo for the Commodore-
Amiga in 1985. In 1989, Galileo evolved into Distant Suns for the Amiga. Distant Suns for
Windows followed in 1991 and Distant Suns for Macintosh in 1992. The evolution con-
tinues with First Light. First Light takes the power and functionality of Distant Suns and
gives it a fresh face, making the complex world of astronomy understandable to those
who are just beginning their exploration of the subject.

Distant Suns gave the universe to the user and expected him to find something inter-
esting. For an amateur astronomer, this is not a difficult task. For a newcomer to the
subject of astronomy it could be quite daunting. First Light is designed to lead beginners
to what is interesting while, at the same time, being a full-fledged planetarium program
for sophisticated amateur astronomers.

First Light « User Manual 9



First Light begins with the familiar and leads the user to the unfamiliar. The name
reflects this new approach. “First light” is the term used by astronomers when a new
telescope is christened and turned toward the sky for the first time.

First Light vs. Distant Suns

First Light is a fundamental redesign of Galileo and Distant Suns. It is the third genera-
tion, reflecting the increased power of personal computers and the increased expecta-
tions of users. It also takes advantage of the multi-media capabilities of current computer
hardware and software.

Two key elements of First Light are its navigational tools and methods for roaming
around the sky, and a new menu approach.

The new tools include a three dimensional star display, using the mouse to drag the
sky around, and a tool called the Navigator for a “you are here” display. There is also a
Novice mode for users who are new to astronomy and an Expert mode for those already
familiar with the sky.

The new menus take an “object-action” approach to astronomy in which the user
decides what object (planet, star, etc.) he wishes to explore and then decides how he wishes
to explore it. Contrast this with Distant Suns and most other astronomy program, which
used an “action-object” approach, in which the user must know what he wishes to do,
then decide upon an object to which to apply the action. The object-action model more
closely resembles the way the mind thinks, so it should feel much more natural.

There are also a host of great new features in First Light. They include 24 bit planetary
rendering, a flyby mode (duplicating the flyby trajectories of the NASA spacecraft), a
three dimensional local star display, support for creating movie files, fast real-time anima-
tion, and astronomical lessons for every day of the year.
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Getting Started

Using This Manual

This User Guide assumes that you are familiar with the Windows environment, in-
cluding using the mouse, menus, buttons and dialog boxes. If you are not, please refer to
the appropriate manuals that came with your Windows software.

The First Light User Guide is divided into four main sections. The first, Using First Light,
contains general information about the First Light program and basic astronomy concepts
that you should understand to use First Light most effectively. Use these chapters to famil-
larize yourself with First Light and get the feel of using it to explore the sky.

The next two sections, The Solar System and Beyond the Solar System, describe the dif-
ferent types of astronomical objects — Sun, Moon, planets, stars, etc. — that First Light can
show you. These general information chapters also contain tutorial material that shows
you how to use First Light to explore the universe.

The last section, First Light Reference, contains reference material that gives specific
details about each of First Light’s features.

Typographic Conventions

Throughout the manual, names of menu items, buttons and other interface elements
are shown in bold italic type. Settings and other information that you can change from
your keyboard are shown in bold type.

Installing First Light

In order for you to use First Light, the program and some of its data files must be
installed onto your hard disk from the CD ROM.

System Requirements

Before installing First Light onto your hard disk, make certain that your computer
system meets the following minimum requirements:

e 486-33 processor minimum, 486-66D X2 recommended, Pentium will perform even
better.

 Windows version 3.0 or later, except Windows NT — First Light does not run under
Windows NT.

e 8 MB RAM

e Sound card (optional)
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e 256 colors

e CD-ROM drive

First Light is optimized for 256 color graphics modes and looks best in 800x600 or
higher resolution. One major feature, fast texture mapping of the planets (Hover and
Flyby modes), works only in 256 color mode. If you are running with more colors, the fast
texture mapping menu items are disabled and planets are displayed as simple wire frames.
The slow texture mapping (24 bit rendering) will work with more colors.

Installing First Light from the CD ROM

Certain files, including the First Light program, must be installed from the CD ROM
onto your hard disk.

To install First Light from the CD ROM:
1. Insert the First Light CD into your CD ROM drive.
2. From the Windows Program Manager, select Run... from the File menu. Type

the appropriate drive reference for your CD drive followed by install, then
press the Enter key. For example, if your CD ROM is drive D, type

d: install

followed by Enter.

3. The installer next prompts you for the name of the directory you wish to
install First Light into. The default directory path is c:\f_light. Click on Con-
tinue to create the directory and start the installation.

4. After all necessary files have been copied onto your hard disk from the CD
ROM, an Installation Complete message is displayed and the data files are
automatically decompressed. Once the files have been decompressed, you
are ready to run First Light.

Exploring First Light

Now that First Light is properly installed on your computer, let’s take a quick tour and
explore some its many exciting and interesting capabilities. Informative and entertaining
for either an advanced astronomy buff or a newcomer, the concepts and skills used in
these easy to follow explorations will help you to gain an understanding of how to navi-
gate through the program and give you an overview of some of the important features.

First, we’ll transfer our viewpoint into space to observe our own solar system. We’ll
take a look at the Earth from the viewpoint of NASA’s Galileo space probe. Then we will set
the planets in motion around the Sun and observe their orbits by allowing time to ad-
vance at a faster than normal rate.
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Next we’ll visit Mars and learn more about our red neighbor as we hover near it. We’ll
explore its surface with photographs taken by space probes and read informative facts.
We’ll even experience what it would be like to fly over the surface when we view a com-
puter-generated landscape derived from real topographic data sent back to Earth from
satellites and probes.

Lastly, we’ll come back to Earth and take a look at what the night sky looks like from
your home tonight. We’ll examine First Light’s Calendar for information, including the
moon’s current phase, and see descriptions of upcoming astronomical events. Finally,
we’ll dip into the Nightly Grabbag for interesting photographs and thoughtful articles
about the heavens.

Are you ready? Let’s go out and explore space!

Viewing Our Solar System

If First Light is not already started, double click on the First Light icon in the Windows
Program Manager to start the program. After the title screen and music finish, the Sky
Tonight window is displayed. Click on the Planetarium button to open the Planetarium
window, First Light’s main sky display window. Your viewing location is displayed in flashing
text in the upper left corner of the Planetarium window. You are looking out into space
and seeing stars, and possibly planets, against the sky.

Notice the familiar Windows menu and tool bar across the top of the window. There
is also some information about the current view date, direction, and field of view dis-
played on the status bar at the bottom of the window.

The first thing we need to do in order to look at our solar system is to move our
viewpoint off Earth into space. Select Lookdown-middle planets from the Viewpoint sub-
menu in the View menu. Your viewpoint is moved into space (the text in the upper left
corner reflects this change).

Off Earth button

The Planetarium window changes its display to reflect our new position and we can
see the Sun, several planets closest to the Sun, and their orbital paths. Also displayed is a
series of lines laid out in a grid pattern, defining an imaginary plane. This plane is known
as the ecliptic. It is the plane of the earth’s orbit and approximates the plane of the other
planets’ orbits.

Let’s take a minute and explore some of the objects that we can see. Position the
mouse pointer on a planet or a star, and click with the left mouse button. First Light
verifies the object you have chosen by identifying it with a target sight, then displays its
information window. Information such as object attributes and position is displayed in
the window, along with other data that vary with the type of object selected. Try clicking
on a few planets and stars to learn more about them. When you are finished, close all the
information windows by clicking on the OK button in each one.
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Now we’ll open a multimedia information window for Earth and view some space-
based photographs. Click on Earth, and examine the information window that appeatrs.
Click on the explore button. A multimedia information window containing photos, short
films, and explanatory text opens. Clicking on the up and down arrows scrolls you through
a catalog of photos and descriptions. Try looking at a few of these now.

Notice the buttons next to the up and down arrows. These represent the Photo and
Film options (Film option is not available with every image). Clicking on the Photo but-
ton (the one on the far right) displays the current image on your full screen so that you
can examine it in more detail. Clicking once anywhere with the left mouse button returns
you to the previous screen.

Let’s take a look at a film of Earth that was taken by the Galileo space probe. Scroll to
the photo of Earth with the caption relating to the “Jupiter-bound Galileo probe...” (the
third image). Click on the Photo button and view the related short film. When you’re
finished, you can look through more of the available photos and films. Close the muilti-
media and information windows when you’re through and return to the view of the solar
system.

The first step for setting up our planetary orbit animation is to define First Light’s
clock settings. Select Settings from the Clock submenu in the Tools menu open the Clock
Control dialog box. If the Tools menu is not already displayed on the menu bar, select
Expert menus from the File menu.

‘- |i._;,1j|3hl| O I HGI&E + Step: |mlil|huurs 1#] |_ok | new |

Clock Control dialog box

The five buttons at the left of the Clock Control dialog box resemble the control
buttons on an audio CD or a video cassette player. These buttons are also on First Light’s
tool bar and can be used from there, also. They start and stop First Light’s clock. The
middle button is stop, the two buttons to either side of the stop button change time
forward or backward one step at a time (step forward and step back), and the two outer
buttons move time forward or backward by continuous steps until the stop button is
clicked (Rewind and Fast forward).

Use the drop-down list boxes at the right of the Clock Control dialog box to select 2
days as the Step interval, then click OK. The Clock Control dialog box closes. Using the
clock buttons on the tool bar, click on the step forward button (labeled with a right
pointing single arrow) to move time forward by one step. Repeat this several times, watching
the planets move along their orbits by steps of two days at a time. You can also make time
go backward a step at a time by clicking on the corresponding backward button.

To see the planets revolve around the Sun, click on the fast forward button (labeled
with a right pointing double arrow). The planets begin to revolve around the Sun at their
respective rates. Notice that each planet revolves at a different speed. Mercury completes
its orbit more than four times before the Earth completes its journey once. Stop the ani-
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mation by either clicking on the tool bar’s stop button or clicking on an object in the
Planetarium window (this will open that object’s information window). You can restart
the clock by clicking on the clock buttons, or go ahead to the next exploration.

Visiting Mars

In the previous exploration, we looked at the solar system from space and examined
Earth in detail. Now we’ll see how to hover near a planet, rotate it and look at features on
its surface.

From the Hover submenu located in the Planets menu, select the planet Mars. A
representation of the planet Mars is displayed, along with various data related to it. If
your system is set to 256 color mode, the planet’s surface is rendered using digital image
photograph information. Various features on the surface are labeled, such as geographic
landmarks and spacecraft landing sites.

Our viewpoint is set so that we are “hovering” near the planet. We can change the
position of the viewpoint relative to Mars by the holding down on the right mouse but-
ton and moving the pointer. The distance of our viewpoint from Mars remains the same,
but the planet rotates and moves according to the way you move the mouse. Try spinning
the planet around a bit until you get the hang of it.

You can open multimedia windows like the one we looked at for the Earth in the
previous exploration. Click with the left mouse button on any of the features on the
planet’s surface that are labeled with a diamond. The target symbol identifies the selected
feature and a related multimedia window opens. As with the window we used earlier, you
can scroll through photographs, read interesting facts in the captions and view short
films. Take some time to explore the surface of Mars in this way.

Now it’s time to take a flight over Mars and view a portion of its surface through a
computer-generated animation. Rotate the planet using the right mouse button until you
find the feature labeled Valles Marineris. Select this feature with the left mouse button,
opening the associated multimedia window. Click on the Film button and you will see an
animation that takes you on a flying tour of a portion of the Valles Marineris. The surface
of the planet has been rendered using topographic data and computer modeling. You can
explore other areas of Mars by opening other multimedia windows and looking for more
animated fly-overs. When you are finished, close the multimedia and information win-
dows and return to your original hover position near Mars. Select Return to earth from
the View menu’s Viewpoint submenu to return your viewpoint to the Earth.

The Sky Tonight

We’ve looked at the solar system from space and we’ve hovered near Mars. Now let’s
return to Earth and see what the sky looks right now from your location on Earth.

First we’ll have to set our location. Select When and where from the View menu. This
opens the When and where dialog box. Click on the now button to set the time on First
Light’s internal clock to match your computer’s date and time. Click on the location but-
ton to open the Location dialog box.
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Location dialog box

The Location dialog box displays a map of the entire surface of the Earth. You can
approximate your position by pointing to a location with the mouse and clicking on it
with the left mouse button, or you can select a nearby city from the scrolling list obtained
by clicking on the appropriate continent button. Select your position and click OK to
close the Location dialog box. Then click OK in the When and where dialog box.

Now that First Light knows where you are and what day it is, let’s take a look at
tonight’s sky. Select The Sky tonight from the View menu. This opens a view of the sky
from your location as it looks at the date and time displayed in the upper left corner of
the screen. You are looking at a 180° view of the sky (as if you stood in one spot and
turned completely around) laid out flat on your monitor. The directions of the compass
are shown along the simulated horizon. You should see stars and, possibly, the Moon,
planets and other objects, just as they appear in the sky from your location on Earth.

Clicking on the Now button displays the sky as it is right now. The Sunset and Sun-
rise buttons display the sky as it will be at the next sunset and sunrise, respectively.

Click on the Calendar button to open this month’s calendar with today’s date high-
lighted. The calendar shows you the phases of the Moon and upcoming astronomical
events. Clicking on today’s date displays an information window with the sunrise and
sunset times, and more information about any astronomical events that might be taking
place. Scroll through the past or upcoming months to look for interesting astronomical
phenomena and events, or change the date of the display. Click OK when you’re finished
to return to The Sky tonight display.

Another interesting feature of The Sky tonight display is the Nightly Grabbag. Click-
ing on this button opens a window with text and pictures of tidbits and trivia related to
the heavens. Each day has a different grabbag item, so there is always something new to
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discover. Terms in the text that are underlined can be clicked on to view their definitions.
Occasionally there are small buttons, labeled with the image of a telescope, that you can
click on to center your view on the object in question. Click on the Nightly Grabbag
button now to see today’s offering. When you are finished with the Nightly Grabbag,
close the window and return to The Sky tonight display.

Take some time and explore The Sky tonight display. When you are finished, you can
click on the Planetarium button to return to First Light’s main display.

Congratulations! You have taken a journey into space, watched the Earth move around
its orbit, looked down on the solar system, flown over the surface of Mars and returned to
look into the heavens from your hometown - all without leaving home. By doing so, you
have acquired skills with First Light that will enable you to go as far as your imagination
can carry you into the heavens. Now you are ready to take off on your own journey into
space. Enjoy!
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Basic Concepts

At this point, we will take a brief moment to explore some of the basic concepts of
visual astronomy. This will help you in working with First Light.

To begin, it is helpful to think of the sky in the same way the early astronomers did -
by imagining the stars and planets as being attached to the inside of a hollow sphere with
the Earth at the center. This sphere, in turn, revolves around the Earth, creating the stellar
motions.

Variations on this theme had each planet on a separate crystalline sphere revolving
on its own, which explained their independent movements. But for now, the single sphere
model will do.

Coordinate Systems

Another concept that is essential for understanding how astronomers describe the
locations of celestial objects is that of coordinate systems.

We are all familiar, in one way or another, with coordinate systems. A coordinate
system is a method of specifying the location of a particular place, whether it is on a piece
of paper, on the Earth or in the sky. Our home addresses, for example, represent one
coordinate system, the earth’s latitude and longitude lines are another.

In order locate stars, astronomers have developed a system, called the equatorial coor-
dinate system, for the sky which is analogous to latitude and longitude on Earth. Latitude
in the sky is called declination (or dec) and longitude is called right ascension (or RA).

Equatorial coordinate system

Declination is measured in degrees and ranges from —90° to +90°. Zero degrees (0°)
declination is called the celestial equator.

Right ascension, on the other hand, is measured, not in degrees, but in hours, min-
utes and seconds. Each hour of right ascension is equivalent to 15°. Right ascension in-
creases to the left (counter-clockwise).
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A second coordinate system that is important is the horizon or local coordinate system,
which is used to specify the location of objects in your local sky. In the horizon coordi-
nate system, locations are specified by azimuth, or compass heading, with north being 0°,
and altitude, or the angular elevation above the horizon. Both azimuth and altitude are
measured in degrees. Azimuth increases to the right (clockwise), in contrast to right as-
cension. Because of the earth’s rotation, the horizon coordinates of a given object are
constantly changing, while its equatorial coordinates remain constant.
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Local coordinate system

First Light can use either equatorial or horizon coordinates. Select the coordinate sys-
tem for First Light to use with the Mode submenu in the View menu. The default setting is
the equatorial coordinate system, or Equatorial mode, rather than your local coordinate
system, or Local mode. There are two reasons for this.

1. Equatorial mode calculates star positions and redraws the sky display somewhat faster
than Local mode, which makes navigating around the sky easier.

2. Equatorial mode removes the ambiguities introduced by using your local coordinate
system. That is, Altair’s equatorial coordinates are always the same, but its local hori-
zon coordinates change continuously.

Field of View

Another important concept is field of view, also referred to as either field or FOV. Field
of view describes how much of the sky is visible at any one time. That is, the magnifica-
tion of the display. Field of view is measured in degrees width. A 90° field means that 45°
of the sky is visible on either side of the screen’s center. The smaller the field, the larger
the displayed image. In other words, you zoom in for a smaller field of view and zoom out
for a larger field.
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Field of view

First Light’s field of view controls can be thought of as a zoom lens. You can zoom in
for a closer view, or zoom out to see more stars. Remember that as the number of objects
on the screen increases due to widening the field, the speed at which the sky is redrawn
when the view is changed, slows down. The field of view can be changed in two ways. You
can select a particular field of view from the Zoom submenu in the View menu or you can
use the right mouse button to drag around an area that you wish to zoom to in the
Planetarium window. Dragging diagonally from left to right zooms the view in for a
narrower field of view. Dragging diagonally from right to left zooms the view out for a
wider field of view. The current field of view is shown in the status bar at the bottom of
the Planetarium window.

The smallest field of view that First Light can display is 0.01°. The largest is 180°,
which shows half of the entire sky. The most comfortable and natural setting is between
40° and 65°.

Because First Light renders a three-dimensional curved surface on a flat, two-dimen-
sional screen, certain distortions occur, similar to what a wide angle camera lens shows.
The distortion is most noticeable along the edges of the display when the field of view is
greater than about 70°. The least distortion is in the center of the screen.
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First Light’s Main Windows

The Planetarium Window

The Planetarium window is First Light’s main sky display window and it shows the
sky and the objects in it, according to the location of First Light’s viewpoint, the Zoom
setting, and the state of First Light’s internal clock. The types of objects and the labels
displayed with them in the Planetarium window are selected through various menu items
and dialog boxes. See the Menus chapter for more information.

Using the Mouse

Aiming the View

The mouse can be used to change the direction of the view shown in thePlanetarium
window. Any point in the sky can be centered in the window by clicking on that point
with the right mouse button. This is called point and center. The sky display can also be
dragged within the Planetarium window by holding down the right mouse button while
dragging the mouse. The view in the Planetarium window can also be aimed with the
items in the Center submenus in the Planets and Stars, etc. menus.

The direction of the view in the Planetarium window can also be set using the Navi-
gator window. The Navigator window is opened by selecting Navigator from the View
menu. When the Earth button in the Navigator window is selected, the upper portion of
the window displays a wire-frame sphere. The sphere represents the sky, with your view-
Ing position in its center. The Sun, Moon and planets are marked on the surface of the
sphere. The red lines represent the field of view. Holding down the left mouse button and
dragging with the mouse over the sphere display rotates the field of view around the
sphere. Dragging to the left or right rotates the field around the vertical axis. Dragging up
or down rotates it around the horizontal axis. As soon as the mouse button is released, the
view in the Planetarium window is updated to show the change. Holding down the right
mouse button and dragging with the mouse rotates the sphere display so that you can
more clearly see the relationships between the objects.

When the Home button in the Navigator window is selected, First Light switches to
Local mode, using local coordinates to draw the sky (see the Basic Concepts chapter for an
explanation of coordinate systems). The display in the upper portion of the window is
similar to that with the Earth button selected. Instead of a sphere, the display is a half
sphere representing the portion of the sky that can be seen from your location on Earth.
See the Setting Your Location and Time chapter for information about how to set First Light’s
viewing location.

See the section on the Navigator window in the First Light Menus chapter for infor-
mation about the Navigator’s other features.
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Zooming the View

The view in the Planetarium window can be zoomed in to a smaller field of view by
holding down the left mouse button and dragging a box diagonally from left to right
around the area that you wish to magnify. Likewise, the view can be zoomed out, increas-
ing the field of view, by dragging the mouse diagonally from right to left. The view in the
Planetarium window can also be changed with the items in the Zoom submenu in the
View menu.

Changing Your Position in Space

When First Light is in Hover or Flyby mode, dragging the mouse with the right button
held down changes the position of your viewpoint rather than changing where the view
is aimed. This allows you to keep the view aimed at the same object while easily moving
around the object. Moving the mouse left and right rotates the your viewpoint around
the planet. Moving the mouse up and down moves your viewpoint north and south in
relation to the object, while keeping the object centered. See the Hover and Flying by the
Planets sections in the Setting Your Location and Time chapter for more information about
these features.

Information About Objects in the Sky

Clicking on any object in the Planetarium window with the left mouse button opens
an information window for the object. The information contained in the window varies,
depending on the type of object it describes. See the chapters about each of the various
types of objects for an explanation of the meaning of the information in the window.

Information windows for stars and deep sky objects (galaxies, nebulae and star clus-
ters) have two buttons labeled notes and center. Clicking on the notes button opens
another window containing additional information, such as historical notes, common
names, etc. The notes button is disabled if there are no notes for the selected object.
Clicking on the center button centers the object in the Planetarium window. Informa-
tion windows for stars also have two buttons labeled with up and down arrows. These
buttons cycle the window through the stars in First Light’s main star database. Informa-
tion windows for deep sky objects may include a small gray scale image of the object.

Information windows for planets have a button labeled explore. Clicking on this
button opens another window containing additional information about the planet. This
second window also gives you access to color images and movies of the planet.

The Tool Bar

First Light’s tool bar is located along the top of the Planetarium window below the
menu bar. The buttons on the tool bar duplicate the most commonly used menu items for
more convenient access.

Starting from the left end of the tool bar, the first several buttons control the display
of solar system objects and constellations.

Center the Sun in the Planetarium window.
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Center the Moon in the Planetarium window.

Center a planet - this button opens the Planets centering dialog box.

Toggle the names of the planets on or off.

Move your viewpoint off the Earth into the solar system.

Move your viewpoint back to Earth.

Toggle constellation outlines off or on in the Planetarium window.

Toggle constellation names off or on in the Planetarium window.

Center a constellation - this button opens the Center Constellation dia-
log.

The next buttons in the tool bar control First Light’s internal clock. They are styled to
resemble the buttons on a VCR control pad. With these controls, the clock can be ad-
vanced by increments, giving a “time lapse” effect that demonstrates the motions of the
planets and other solar system objects against the stars.

Rewind button. Continuously decrease the time by the increment set in
the Clock Control dialog. Clicking once on this button starts the clock
decreasing as fast as possible. Clicking the center button stops the clock.

Step back button. Decrease the time by one increment each time the
button is clicked. For example, if the increment is set to five hours, this
button subtracts five hours from the clock each time it is clicked.

Stop button. Stop First Light’s internal clock.

Step forward button. Increase the time by one increment each time the
button is clicked. For example, if the increment is set to five hours, this
button adds five hours to the clock each time it is clicked.

Fast forward button. Continuously increase the time by the increment set
in the Clock Control dialog. Clicking once on this button starts the clock
Increasing as fast as possible. Clicking the center button stops the clock.
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=
| C Settings button. Open the Clock Control dialog, through which the time
increment is set. The increment can be as short as one minute, useful for
animating eclipses, and as long as one hundred years.

The next set of buttons on the tool bar select First Light’s Quickview settings. They
turn on a number of features to show the sky from your home position looking toward
any of the four cardinal directions (north, east, south or west). Your home position is set
through the When and Where dialog box.

Quickview buttons

The next button controls display of deep sky objects.

Toggles display of selected objects from the NGC and Messier catalogs on
or off.

The zoom buttons set the field of view of the display to two commonly used settings.

&0
The first button sets the display to a width of 60°, which is close to what

the unaided human eye sees.

120
[ The second button sets the display to a width of 120° degrees, giving a

wider view — objects appear to be smaller but are shown in a broader con-
text. Remember that the wider the field of view, the slower the display,
since First Light has more objects to redraw whenever the view changes.

Iz

The last button on the tool bar resets the screen to a commonly used set of
options. It saves you the time that it would take to turn each feature on or
off individually. The Save cleanup item in the File menu’s Settings sub-
menu allows you to customize this feature.

The Sky Tonight

One of the more difficult tasks in observing the starry sky is to make sense of just
what you are looking at. The Sky Tonight window, opened by selecting The Sky Tonight
from the View menu, is designed to help you do that. It displays the sky as it is visible
from the location on Earth, and the date and time, for which First Light is currently set.
See the chapter on Setting Your Location and Time for more information about setting First
Light’s viewpoint location and clock. The Sun, Moon and planets are all displayed if they
are currently visible, along with a simulated horizon.

The buttons at the bottom of the Sky Tonight display set the viewing direction and
time of day. There are also buttons that give access to other windows.
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The Planetarium button closes the Sky Tonight window and takes you back to the
Planetarium window, First Light’s main sky display window.

The Calendar button opens the Calendar window, which shows interesting astro-
nomical events occurring in the current month.

The Nightly Grabbag button opens a window containing information about objects,
events and activities pertinent to First Light’s current date.

The Now button sets First Light’s internal clock to your computer’s current system
time. The Sunrise and Sunset buttons set First Light’s clock to the appropriate times for
the current date. The N and S buttons center the view in the Sky Tonight window on
either north or south.
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Setting Your Location and Time

Location

Exactly what the sky looks like depends on the viewpoint from which you are seeing
it. First Light can display the sky as seen from any point on Earth or from any point in the
solar system up to 400 astronomical units (AU - the average distance between the Earth
and the Sun) from the Sun.

Viewing the Sky from Earth

When First Light displays the sky in Local mode, using local coordinates (see the Basic
Concepts chapter), it uses the location set in the When and where dialog box to do so. First
Light also uses this location to calculate things like sunrise and sunset times, regardless of
whether it is in Local or Equatorial mode. The When and where dialog box is opened by
selecting When and where from the View menu.

Your viewing location directly effects just what you see and when. For example, in
viewing a solar eclipse, the area of totality is so narrow that the viewing position is criti-
cal. The situation for lunar occultations is the same. The positions of the stars and planets
in the sky change depending on your latitude. The further north you are, the higher in
the sky the north star, Polaris, is. Also, if your location is very far north of the equator,
constellations and objects in the southern hemisphere of the sky become impossible to
see, and vice versa.

Setting First Light’s Viewing Location

Using the When and where dialog box, you can specify your location on Earth in a
number of ways. You can specify it graphically using a world map, by selecting a city from
a list or by direct numerical entry of an exact longitude and latitude. To set your location,
open the When and where dialog box by selecting When and where from the View
menu. Click on the location button in the When and where dialog box to open the
Location dialog box.

The left half of the Location dialog box contains a map of the world. A flashing circle
on the map indicates your current location. Clicking with the left mouse button any-
where on the map changes the viewing location to the point on which you click. The
vertical and horizontal red lines mark 0° longitude and latitude, respectively.

The buttons in the upper right of the Location dialog box open dialogs with drop-
down lists of large cities in the corresponding region. That is, the N America button opens
a list of cities in North America. The Observatories button yields a list of major observato-
ries around the world. Selecting an item from any of these lists and clicking on the OK
button sets the viewing location to selected city or observatory.
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Location dialog box

If your location is not in any of the lists, you can set it precisely with the lat. and
long. items. Either use the up and down arrow buttons or type directly into the edit boxes
to change the settings. Once you’ve set the latitude and longitude, click on the show
button to update the map display to the indicate the proper viewing location.

The save button in the When and where dialog box saves First Light’s current viewing
location to be used as the default location the next time the program is started from the
Program Manager. This saves you from having to reset the viewing location from the
default every time you use First Light.

First Light offers many pre-set locations from which to choose. Should your loca-
tion not be among the pre-set locations, you can easily add your custom location
data to First Light’s location data list. Using the Notepad (in the Windows Acces-
sories group) is recommended, but any word processor will do.

1. Open Notepad. Select Open from Notepad’s File menu.

2. Navigate to the applicable continent file located in the following directory
path:
c:\f_light\data2\user
This is the default installation directory. If you have installed First Light to a
directory other than f_light, your directory path will be slightly different.

3. Select the appropriate continent file for your location. All location files are
named with a .dat extension. For example, selecting the af _loc.dat file opens
the Africa continent file, the na_loc.dat file is the continent file for North
America.
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4. Once the appropriate file has been opened, you will see a list of pre-loaded
locations. Each location has the following format:

dd:mm dd:mm h aaaaaaaaaaa
The first column is the location’s latitude (d for degrees, m for minutes).

The second column is the location’s longitude (d for degrees, m for min-
utes). Western longitudes have positive values (North America, South America,
Pacific). Eastern longitudes have negative values (most of Europe, Africa,
Asia).
The third column is the location’s time zone value. This value can be posi-
tive or negative.
The fourth column is the location’s name.

5. When you have finished adding your location to the list, select Save from

the File menu. Do not save the file in a special format specific to your word

processor. The continent location file must be saved as a generic ASCII text file,
otherwise First Light will not be able to read it.

Moving Your Viewpoint off Earth

Moving First Light’s viewpoint off the Earth can be accomplished in several ways. If
you are primarily interested in viewing our solar system, the easiest is to select one of the
Lookdown items from the Viewpoint submenu in the View menu. These items place the
viewpoint directly above the Sun, looking down on the solar system so that you can see
out to the inner planets (Mercury to Mars), the middle planets (out to Saturn) or the outer
planets (out to Pluto, showing all of the planets).

In addition to the Lookdown menu items, there are two ways to move the viewpoint
to any point in the solar system. The Navigator window provides an easy to use graphical
way of doing so. Fixed in the View menu’s Viewpoint submenu allows the viewpoint to
be set with precise numerical coordinates.

The Navigator window is opened by selecting Navigator from the View menu. To use
it to set the viewpoint out into the solar system, click on the Space button. The display in
the upper portion of the window changes to show a view of the solar system. The current
viewpoint is shown in this display as a green dot connected to the Sun with green lines.
Holding the left mouse button down and dragging the mouse over this display rotates the
viewpoint around the Sun. The view in the Planetarium window is updated to reflect the
new viewpoint as soon as the mouse button is released. Dragging with the right mouse
button changes the orientation of the display in the Navigator dialog box to make it
easier to see where the viewpoint is in relation to the solar system. When the Navigator is
used to move the viewpoint around the solar system, the distance of the viewpoint from
the Sun is changed by dragging the mouse with both buttons held down at the same time.
For information about the Navigator’s other features, see the section on the Navigator in
the First Light Menus chapter.
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Selecting Fixed from the Viewpoint submenu in the View menu opens the Set View-
point dialog box, which is used to set the coordinates of the viewpoint in terms of helio-
centric coordinates. Heliocentric coordinates describe the position of an object (or a view-
point) relative to the Sun. Heliocentric latitude and longitude are similar to the earth’s
latitude and longitude. Latitude ranges from -90° to 90°, with the plane of the earth’s
orbit being 0°. Longitude ranges from 0° to 360°, with 0° corresponding to 0° right ascen-
sion, also called the First Point of Aries. The last value in heliocentric coordinates is dis-
tance from the Sun, expressed in astronomical units (AU). One AU is the mean distance
from the Earth to the Sun, approximately 93 million miles.
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Set Viewpoint dialog box

The last item in the Viewpoint submenu, From a planet, opens a dialog box with a
drop-down list of planets. Selecting a planet from this list and clicking on the OK button
attaches First Light’s viewpoint to that planet.

The other two ways of moving the viewpoint off Earth, Hover and Flyby, each place
you in space near a selected planet, with the planet drawn realistically using artwork
based on images from NASA spacecraft.

Hover

Hover mode moves First Light’s viewpoint to a position near a selected planet, with
the view locked on the planet. If your system is set to 256 colors, the selected planet is
drawn (rendered) using images from NASA spacecraft so that it will look as real as pos-
sible. First Light slows considerably when rendering images at more than 256 colors, so if
your system is set at more than 256 colors, the planets are displayed as wire frame spheres.

To enter Hover mode, simply select a planet, the Sun or the Moon from the Hover
submenu in the Planets menu. While in Hover mode, the mouse is used to change the
position of the viewpoint rather than for changing the angle of view as it normally is. By
dragging the mouse with the right button held, down you can move the viewpoint around
the planet. Moving the mouse left and right rotates the viewpoint around the planet.
Moving the mouse up and down moves the viewpoint north and south in relation to the
planet. As the viewpoint is moved, the planet is kept centered in the view. The changed
view is shown as you drag the mouse.

When Hover mode is entered, constellation names, outlines and planetary orbit lines
are turned off in order to reduce clutter and make the display more comprehensible.
These options can be turn back on at any time after entering Hover.

The Hover dialog box, opened by selecting Settings from the Hover submenu in the
Planets menu, gives you additional control over the behavior of the Hover mode. The
object drop-down list can be used to select an object to hover near. The dist. (radii) value
determines the distance of the viewpoint from the selected object. The distance is in
terms of the radius of the planet. For instance if the distance is 50 and the object is Earth,
the real distance of the viewpoint from Earth is 50 times 4,000 miles (the radius of the
Earth), or 200,000 miles. Using a relative distance rather than an absolute distance allows
you to see comparable views of different objects with a minimum of confusion.
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When the landing sites check box is checked, the landing sites of NASA’s Viking
landers are marked on Mars and the sites of the Apollo landings are marked on the Moon.
When the attach check box is checked, the viewpoint is bound to the selected planet, so
that as it moves, you move with it. This is the default setting. When the features check
box is checked, major features are labeled, depending on the planet being viewed.

Clicking on the show button redraws the view in the Planetarium window using the
settings in the Hover dialog box without closing the Hover dialog box.

Selecting Orbit from the Hover submenu in the Planets menu sends the viewpoint
into orbit around the selected object. The characteristics of the orbit are determined by
the orbit options in the Hover dialog box. The shape setting specifies whether the orbit is
circular or elliptical. An elliptical orbit is roughly egg shaped, going from close to the
planet to far away and back to close. The elliptical setting has an eccentricity of 0.4 and
highly elliptical launches you far away from the planet with an eccentricity of 0.7. Eccen-
tricity determines how elongated the orbit is. The rate setting specifies how quickly the
view is updated. Fast updates your orbital position and refreshes the Planetarium win-
dow display every five seconds. Medium updates every ten seconds and slow updates
every thirty seconds. The step setting determines how far, in degrees, the viewpoint moves
around the orbit between each update. Small moves 1° at a time, medium moves 2° and
large moves 5°.

When you have finished exploring the solar system in Hover mode, select Return to
earth from the Planets menu’s Hover submenu to return the viewpoint to Earth and exit
from Hover mode.

Flying by the Planets

Few NASA programs are more highly regarded than the Voyager probes to the outer
planets. Because of these probes entire new worlds have been discovered, millions of high
quality images returned to us and our concept of the solar system was changed forever.
First Light gives you the opportunity to duplicate their historical and spectacular flybys of
Jupiter, Saturn, Uranus and Neptune.

Using a chance alignment of the planets, the spacecraft were able to use the gravity of
each planet to shoot it to the next one. This “gravity assist” method is a highly efficient
way of going great distances with very little fuel and, in the late 1970’s, the four gas giants
were aligned in such a way as to permit the Voyager missions to occur. Such an alignment
is possible only every 175 years.

Voyager 1 was launched on September 5, 1977. Voyager 2 was launched on August 20
of the same year. Voyager 1 was the first to encounter Jupiter in March of 1979 followed by
its sister spacecraft in July of that year. During that time, active volcanoes on Jupiter’s
moon lo were witnessed for the first time. Jupiter’s highly complex atmosphere was filmed
and photographed in astonishing clarity. All of the images of these planets that are in-
cluded with First Light are from the Voyagers. The probes were then redirected toward
Saturn, making their closest approaches to that planet in the early 1980s. During those
encounters, the mysterious “spokes” of Saturn’s rings were discovered, along with its tangled
outer ring, its shepherding moons and the deep atmosphere of the giant moon, Titan.

First Light « User Manual 32



After Saturn, Voyager 1 was flung out of the solar system, but Voyager 2 was sent on to
the blue planet Uranus, which it encountered in January of 1986. Here, it photographed
the enigmatic moon Miranda along with the faint Uranian rings. Another five years of
space travel brought the little spacecraft to Neptune, at that time the furthest planet from
the Sun. Neptune surprised scientists with its dynamic atmosphere after a relatively be-
nign Uranus. The Neptunian moon Triton hit the headlines with its tortured pinkish
surface and nitrogen geysers.

= Flyby
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Flyby dialog box

First Light’s Flyby mode gives you the opportunity to more closely investigate all six
of the Voyager planetary flybys. Open the Flyby dialog box by selecting Flyby from the
Planets menu then select a flyby mission from the dialog box’s drop-down list and click
on the show button. Your viepoint is set in the vicinity of the selected planet, looking
down on the path of the selected spacecraft. Blue dots form the part of the pathway
before the spacecraft’s closest approach to the planet. Red dots form the part of the path-
way after closest approach. Each dot represents a half hour of motion and the entire trail
begins at one day before closest approach and ends a day after.

The drop-down list in the Flyby dialog box allows you to select any of the six possible
flybys. The path of fragment Q of the Shoemaker-Levy 9 comet as it approached Jupiter is
also available.

Checking the attach viewpoint check box attaches the viewpoint to the spacecraft
(or comet fragment) so that you can see the encounter from its perspective.

In Flyby mode, the target planet is fixed in the center of the Planetarium window. By
holding down the right mouse button and dragging the mouse, you can reposition the
viewpoint to any location around the planet, as in Hover mode.

Note that Flyby mode is similar to Hover mode, but the two cannot be used together.

When you have finished exploring the Voyager flybys, select Return to earth from
the View menu’s Viewpoint submenu to return the viewpoint to Earth and exit from
Flyby mode.
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Traveling to the Stars
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Nearby Stars window

First Light can take your viewpoint up to one hundred light years from our Sun to
show you the stars closest to us. Selecting Nearby stars from the Tools menu opens the
Nearby stars window. This window has a three dimensional display of the stars up to one
hundred light years away from our Sun. Holding down the right mouse button and drag-
ging rotates the display. Holding down the left mouse button and dragging up or down
moves the viewpoint closer to or farther from the Sun.

When the labels button is selected, the scientific names of the major stars are dis-
played. When the names button is selected, the proper names of the more prominent
stars are displayed. When the no labels button is selected, the stars are displayed without
labeling. When the lines button is selected, lines are drawn from the Sun to some of the
other stars so that you can get a better sense of their distance from the Sun. Lines and
labels are displayed in bright colors for stars that are in front of the Sun and in dimmer
colors for stars that are behind the Sun.
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Time

Since objects in the sky and the Earth itself are moving through space, the locations
of objects in the sky change according to date and time. First Light uses its own internal
clock to keep track of the date and time of day for which the sky is displayed. First Light’s
clock is set through the When and where window and the rate at which it runs is con-
trolled through the Clock Control dialog box and the Clock submenu in the Tools menu.

Note that the date and time used by First Light are not necessarily the same as the date
and time on your computer’s system clock. However, whenever First Light is started from
the Program Manager, it automatically sets its internal clock to the current date and time
on your computer’s system clock.

Setting the Time

To set First Light’s clock, open the When and where dialog box by selecting When
and where from the View menu. The time and date are displayed in the top half of the
dialog box. They can be changed by clicking on the up and down arrow buttons. The
month is changed with a drop-down list box. You can type the date, year and time zone
directly in the appropriate edit box. The time of day can also be changed by clicking on
the hour or minutes portion of the time and using the up and down arrow keys on your
keyboard. The date can be set to any year from 4713 B.C. to 9999 A.D.

If the location set through the location button observes daylight savings time, click
on the DST check box.

The time zone value is the number of hours that need to be added to the specified
time to convert it from local time, or Standard Time, to Universal Time, or UTC. That is, if
the time zone value is 8.0, adding 8 hours to your local time gives you the Universal.
Universal time is the time at the Greenwich meridian, formerly referred to as Greenwich
Mean Time or GMT. First Light attempts to calculate the proper time zone based on your
location. However, the zonal boundaries do not always follow lines of longitude, but are
very irregular, often following political boundaries. You may want to check a map for the
proper time zone if the position of objects displayed in the Planetarium window seem to
be off by an hour.

The now button sets the date and time to the current date and time or your computer’s
system clock. This can be handy if you have been observing historical or future events
and wish to return to the present.

The Try button redraws the display in the Planetarium window using the date, time
and location in the When and where dialog box without closing the When and where
dialog box.
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= When and where
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When and where dialog box

The bottom portion of the When and where dialog box displays First Light’s current
date and time in terms of the Julian date and Universal Time (UT). The Julian date is an
absolute date used to pinpoint astronomical events. It is the number of days from January
1, 4713 B.C. The day of the current year is also displayed in the dialog box. January 1 is
day 1 and December 31 is day 365. The very bottom of the dialog box shows the latitude
and longitude of First Light’s current viewing location.

Controlling Time

First Light’s internal clock can be made to run at different rates in order to animate
astronomical events and show the motion of the solar system objects. The clock is con-
trolled through the Clock Control dialog box, opened by selecting Settings from the Clock
submenu in the Tools menu, or by clicking on the Settings button on the tool bar. The
Expert menus item in the File menu must be selected so that it has a check mark next to
it for the Tools menu to be available.

The five buttons at the left of the Clock Control dialog box control the passage of
time on First Light’s clock. These buttons are repeated on the tool bar at the top of the
Planetarium window, so you do not need to open the Clock Control dialog box to simply
start and stop the clock. The button at the left end marked with a double arrow pointing
left is like the rewind on a VCR. The button at the right end marked with a double arrow
pointing right is like fast forward. Clicking on either of them once starts the clock moving
continuously backward or forward. When the clock is moving, each update of the Plan-
etarium window display changes the clock by the Step increment set to the right of the
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control buttons. Clicking on the center button stops the clock. Clicking on the single
arrow buttons change the clock backward or forward by one Step increment each time
they are clicked.

The time increment for the clock is set by the two drop-down lists to the right of the
Step label. If 2 is selected from the left list and hours is selected from the right list, the
clock will change two hours at a time when any of the arrow buttons are used.

An increment of a single day is useful for studying the motions of the inner planets
and the Sun. A one week or greater increment is good for observing the slower moving
outer planets. Use an hour or less for lunar motions and a minute or so for animating
solar eclipses.
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Making Your Own Movies

One of First Light’s more powerful features is its ability to take an animation sequence
and package it in a file that can be played as a movie by any Windows based application.
In order to play these movies, you need to have the Windows Media Player utility in-
stalled on your computer. If this utility is not already installed (look in the Accessories
group in the Program manager), you can install it by running First Light’s Install program.

You can create and play a movie of, for example, the planets revolving around the
Sun. You can then insert the movie into a word processor, spreadsheet, database, or any
other Windows based application document, to be played from the application. This gives
you the ability to demonstrate astronomical phenomena, teach concepts, show planetary
motions and more, independent of First Light itself (once the movie file has been created).
The only limits are those of your imagination and the space available on your hard disk.

A mouvie file is a collection of consecutive frames. Each frame is an image of an event
at a given point in time, placed in proper sequence with the rest of the frames in the
movie. The amount of time that elapses between frames is set with the Step value set in
the Clock Control dialog box. The Clock Control dialog box is opened by selecting Set-
tings from the Clock submenu in the Tools menu. Creation of movies is accomplished by
setting up the beginning of the event or situation that you want to store as a movie file,
selecting the time increment between frames, choosing the start and stop points and
specifying other movie parameters.

The best way to illustrate the concepts involved is to lead you through an example.
Then you can apply these principles to any movie you wish to make. We’ll start with a
simple animation sequence showing Voyager 2 as it passed by Saturn.

Keep in mind that you are not limited to the Flyby animations that we are choosing
from in order to illustrate how to use the movie making capability of First Light. Any time-
incremented sequence can be made into a movie using the Create animation dialog box.
The Create animation dialog box is opened by selecting Create from the Movies sub-
menu in the Expert menu.

Setting up the First Frame

Select Flyby from the Planets menu to open the Flyby dialog box. Select the Voyager
2 at Saturn sequence from the drop-down list in the Flyby dialog box and click on the
show button. You can see Saturn and some of its moons. The flight path of the Voyager 2
is represented by a series of dots. Each dot represents the position of the Voyager 2 at a
different point in time, with a half hour between each dot. The blue dots represent the
flight path before Voyager 2 reached its closest point to Jupiter on its path and the red dots
represent the path after the closest approach. The dots show flight path one full day
before and one full day after Voyager 2’s closest approach to Jupiter. The view shows the
planet and the flight path from a viewpoint in space nearby. This view will be the first
frame of your movie.
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Setting the Clock

Before you start defining the movie, you can preview the animation. To do so, start
First Light’s clock moving forward and watch the resulting animation sequence.

Click once on the Fast forward button on the tool bar, labeled with a right pointing
double arrow. This continuously increases the time by the increment set in the Clock
Control dialog box. To stop the clock, click on the Stop button (labeled with a square, in
the center of the clock buttons on the tool bar).

When you start the clock forward, the Saturn’s moons move in their orbits around
Saturn, Saturn rotates and, depending on the time increment set in your Clock Control
dialog box, you may see the Voyager 2 probe as it passes by. To guarantee that you see it go
by, you may have to change the clock settings. Stop the animation by clicking on the Stop
button on the tool bar.

Find the Clock Control button on the tool bar. It is at the far right of the clock but-
tons group, labeled with the picture of the clock, without any arrows. Click once on it to
open the Clock Control dialog box.

The Clock Control dialog box contains the same clock control buttons as are on the
tool bar and a pair drop-down lists for setting the increment between consecutive time
steps. Use the drop-down lists to set the Step to 1 hour. Click OK to close the dialog box.

Before you test out your new clock settings, reload the Flyby sequence so that it starts
from the beginning. To do this, select Voyager 2 at Saturn again from Flyby dialog box’s
drop-down list.

Click on the Fast forward button on the tool bar to start the animation from the
beginning. As before, the moons orbit Saturn and Saturn rotates on its axis. As time ad-
vances, Voyager 2 appears at the right side of the window and moves along the path
described by the dots. It passes by Saturn and continues to the left side of the window.
This animation sequence will comprise your movie.

Stop the clock by clicking on the Stop button. Reload the Flyby sequence by again
selecting it from the drop-down list in the Flyby dialog box.

Creating an Animation

Select Create from the Movie submenu in the Expert menu to open the Create ani-
mation dialog box. This dialog box is used to specify various parameters for the movie.
Notice that some of the buttons are disabled. They will become enabled later. If you are
using a non-Windows-standard screen saver, such as After Dark by Berkely Systems or the
Delrina screen saver, you must turn it off before creating a movie. If your screen saver is
not controlled through the Control Panel in the Program Manager, it is non-standard.

The show data button toggles a textual display of information related to the date and
position of the elements in the animation in the movie frame border. The no rotation
button toggles the rotational motion of any planets in the movie. The 24 bit planets
button controls the way that planets are drawn (rendered). Turning 24 bit planets on
results in more accurate planet surfaces, but it makes creating movies considerably slower.
24 bit movies can only be made when your system is set to more than 256 colors.
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The frame rate drop-down list controls the number of frames per second to be played
in the finished movie. Leave the frame rate set to 5 for now. The size drop-down list is
used to set the size of the frames in the movie. Select 480 x 360 from the size list. A red
box, or frame border, appears in the center of the Planetarium window, showing the por-
tion of the display that will be included in the movie.

Since the clock controls were set in the previous steps, disregard the set clock button,
and click on the Create button to begin. This opens a Create file dialog. Select the drive
and directory where you would like your movie to be stored, then type the name of the
file that your movie will be saved as. Click on the OK button to return to the Create
movie dialog box. The dialog box’s title bar now reads ready, the create button is disabled
and the start and cancel buttons are enabled.

You are now ready to begin “filming” your movie. Click on the start button. The
animation sequence begins as time moves forward according to the step set in the Clock
Control dialog box. Each frame is recorded and saved to disk as a frame in your movie.
The movie will consist of the sequence of frames, showing all the activity within the
frame border. First Light’s title bar shows the number of frames that have been recorded.
When Voyager 2 passes by Saturn and moves out of the frame border, hold down the Esc
key on your keyboard to stop recording.

A dialog box opens, showing the name and location of the movie file, the number of
frames and the size of the file. Click on the test movie button to open a window in which
your movie is played. When the movie finishes playing, this window closes and you will
be returned to the ready dialog box. Click on the Done button.

That’s it! You have made a movie and saved it in a file format that is readable by any
Windows based application. Remember, you are not limited to flybys for your movies.
You can choose any time-incremented sequence of images. Orbits, eclipses, meteor show-
ers and many other events can be made into interesting and informative movies.

To create movies of events other than flyby’s, select Create from the Movies submenu
in the Expert menu. This opens the Create movie dialog box, allowing you to set up a
movie, specify a file name for it and begin “filming” it.
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The Solar System
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The Sun and the Moon

Without a doubt, the two most prominent objects in the sky are the Sun and the
Moon. In the past they have been seen as gods to be appeased or celestial lovers worthy of
numerous stories. Their influence on our lives are obvious. From control of the tides,
seasons and weather patterns, nearly everything we do can be tied to the Sun and, to a

lesser degree, the Moon.

The Sun

WARNING: If you value your eyesight, never look directly at the Sun without
the aid of a specially equipped telescope!

The Sun
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When we talk of the stars, most of us think of the night and the scintillating pin-
points of light scattered across the sky. But the Sun is also one of these pinpoints, only
much closer. An unremarkable star of average size (800,000 miles in diameter), the Sun
provides us a close up opportunity to study stellar processes.

The surface temperature of the Sun is approximately 10,000°F (as compared to the
interior which can reach millions of degrees! But it’s a dry heat.). Without special instru-
ments, there is very little observable detail on the solar surface except, perhaps, sunspots.
Sunspots are compact regions which are cooler, dipping down to a brisk 7,000° and which
are going through intense magnetic disturbances. Sunspots usually have a lighter fringe,
called a penumbra, surrounding a darker core, or umbra. Since the Sun rotates about once
every 27 days, it is possible to observe sunspots as they travel across the disk, disappear,
then return days later (if they haven’t vanished from the surface in the interim). Alto-
gether, sunspot activity follows an eleven year cycle. The current cycle, number 22 since
records have been kept, peaked in 1990. During the cycle minimum, days may go by with
no spots visible at all while, at the peak, dozens of patches may be seen.

The activity which causes sunspots directly affects the physical properties of our at-
mosphere. It is responsible for the aurora (Northern or Southern lights) and for the way
radio waves travel around the world. Shortwave listeners are familiar with this phenom-
enon which, on some days, brings their favorite radio station in loud and clear and, on
others, sends it down into static.

You can observe sunspots directly only through the use of specifically modified tele-
scopes, and only with filters placed over the end of the scope, never over the eyepiece (the
author almost lost his eyesight when, as a naive youngster an eyepiece filter cracked
under the heat of the Sun). For amateur telescopes, use a reflective filter, as opposed to the
absorption (“smoked glass”) variety which can still pass dangerous invisible ultraviolet
and infrared light.

The Midnight Sun

The maximum altitude that the Sun reaches in the sky depends on two things: 1) the
latitude of your location and 2) the tilt of the earth’s axis. By changing the latitude in First
Light while in Local mode, you can see how the sun’s altitude varies — the closer you are to
the equator, the higher the Sun is and vice versa. The earth’s tilt produces one of the more
disorienting phenomena - that of the midnight Sun. During the summer, the Sun never
sets for any observer within 23° of the north pole. Instead, it travels in a loop just above
the horizon. What has happened is that the observer has moved out of the region that
can be shaded by the Earth in its rotation.
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The Midnight Sun

You can use First Light to demonstrate the midnight Sun.

1.

10.

11.

Select When and where from the View menu to open the When and where
dialog box.

Click on the location button to open the Location dialog box. Type 67 in
the box just to the right of the lat. label and O in the box just to the right of
that. This sets the latitude to 67° (23° from the North Pole). Click on the OK
button to close the Location dialog box.

Change the date in the When and where dialog box to Jun 20, 1994 (the
first day of summer) and the time to 12:01 am.

Click on the OK button to close the When and where dialog box and change
First Light to the time and location on Earth that you just specified. Don’t
click on save unless you want First Light to use this location every time it
starts up.

Select Local from the Mode submenu of the View menu to activate the Local
coordinate mode.

Select Expert menus from the File menu so that it has a check mark next to
it and First Light’s expert menus are displayed on the menu bar.

Select Select object from the Lock view submenu in the Expert menu. Select
Sun from the drop-down list in the resulting select dialog box and click on
the OK button. This locks the view in the Planetarium window on the Sun.

Select both Horizon and Local altitude from the Markers submenu in the
Extras menu so that it has a check mark next to it. A yellow line appears just
below the Sun, representing the local horizon (i.e., relative to the 67° lati-
tude that you set in the When and where dialog).

Select Settings from the Clock submenu in the Tools menu to open the Clock
Control dialog box.

Select 20 from the first drop-down list to the right of the Step label and
select mins from the list to the right of that. This sets First Light’s clock to an
increment of twenty minutes for animating the sun’s movement.

To start the animation, click on the button labeled with a right pointing
double arrow in the Clock Control dialog box. First Light’s internal clock
begins to advance continuously, twenty minutes at a time. As this occurs,
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12.

the Sun moves around the horizon, just above it, but never quite dipping
below it. Click on the button labeled with a square in the Clock Control
dialog box to stop the animation.

Notice that, even though the Sun is moving, it remains in the center of the
window because the view is locked on it. To be able to look at other objects,
select Release from the Lock view submenu in the Expert menu.

Solar Eclipses

One of the most beautiful and rare of all celestial events is the solar eclipse. A solar
eclipse occurs whenever the Moon passes between the Sun and the Earth, casting its shadow
onto the surface of the Earth.

The illustration below shows the position of the Earth and Moon during a solar eclipse.
Point a is the point at which a total eclipse is visible. This is called the umbra. Point b is the
penumbra, which marks the range at which an observer can see partial eclipse.

b

earth moon -

Solar eclipse

First Light can be used to reproduce recent eclipses. Perhaps the finest eclipse of
the century occurred on July 11, 1991 when the moon’s shadow swept from
Hawalii to Central and South America.

1.

Select When and where from the View menu to open the When and where
dialog box.

In the When and where dialog box, set the date to July 11, 1991, the time to
7:30 am.
Click on the location button to open the Location dialog box. Set the lati-

tude to 19:30 and the longitude to 156. Click on the OK button to accept
the settings and close the Location dialog box.

Click on the OK button in the When and where dialog box to change the
date and location and close the dialog box.

Select Close up from the Zoom submenu in the View menu to set the field of
view to 10°.

Select Expert menus from the File menu so that it has a check mark next to
it and First Light’s expert menus are displayed on the menu bar.

Select Select object from the Lock view submenu in the Expert menu. Select
Sun from the drop-down list in the resulting select dialog box and click on
the OK button. This locks the view in the Planetarium window on the Sun.
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8. Select Settings from the Clock submenu in the Tools menu to open the Clock
Control dialog box. Set the Step to five minute increments and click on the
button labeled with a single right pointing arrow. Each time you click on the
button, First Light’s internal clock advances by five minutes and the display
shows the Moon approaching and then moving across the Sun.

9. Select Release from the Lock view submenu in the Expert menu to release
the lock on the Sun.

We recommend going to see an eclipse in person. One of the unfortunate facts about
solar eclipses is that the pathway of the lunar shadow is so narrow, being no more that 80
to 100 miles wide. Totality lasts from only a few seconds to a maximum of 7 minutes 40
seconds. The best way for a novice to see an eclipse is with one of the package eclipse
tours commonly advertised in the astronomy magazines.

There are between two and five solar eclipses per year and each is preceded or fol-
lowed by a lunar eclipse. Not all eclipses are total, however. If the Moon is at the furthest
point from the Earth in its orbit, it will fail to cover the Sun completely, leaving a thin
ring of light around the edge. This is called an annular eclipse. At other times, the center
of the shadow misses the Earth completely, resulting in a partial eclipse.
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The Moon

The earth’s Moon

The Moon orbits around the Earth at an approximate distance of 235,000 miles. Since
the Moon has a diameter of about 2,100 miles, over a quarter that of the Earth, the Earth-
Moon system has sometimes been called twin planets. The Moon orbits the Earth with a
period of 27.3 days, the same length as its day. As a result it always keeps the same face
toward the Earth.

The origin of the Moon is shrouded in mystery. Some scientists feel that it might
have been formed along with the Earth, others think that is was captured by the Earth
when it came too close. No matter where it came from, the Moon easily provides one of
the most dramatic views through any telescope, or even binoculars. The rough jagged
mountain ranges bordering the smooth maria (Latin for seas) provide a stunning sight
when lit from the side. Craters within craters, lava flows and lunar rilles (lava river beds)
can be seen through even the simplest of instruments.

As aresult of its orbiting around us, the Moon shows its familiar phases. As it grows in
size, it is said to be waxing until it is full. After that, as it decreases in size, it is said to be
waning. The phases are created by the varying angle at which we view the Moon. That is,
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if the Moon is to the earth’s side in its orbit, we see half of its face illuminated. If it is
between the Earth and the Sun, we are, in effect, behind it and see no part of it illumi-
nated. At its first quarter phase, the Moon is behind the Earth in its orbit around the Sun
and, looking back at the Moon, you see the point in space where the Earth was just three
and a half hours earlier.
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Lunar phases

To see the Moon change its phase:

1. Select Select object from the Lock view submenu in the Expert menu. Use
the resulting dialog box to lock First Light’s view on the Moon.

2. Select Close up from the Zoom submenu in the View menu to set the field of
view to 10°.

3. Select Settings from the Clock submenu in the Tools menu to open the Clock
Control dialog box.

4. Set the Step to one day increments and click on the button labeled with a
single right pointing arrow. The display advances by one day each time the
button is clicked and shows a different phase of the Moon.

5. To release the lock on the Moon, select Release from Lock view submenu in
the Expert menu.

You may be wondering why there is not an eclipse every time there is a new Moon.
The plane of the moon’s orbit is not exactly in line with the earth’s, it is tilted by about 5°.
The two intersection points of the moon’s orbit with the plane of the earth’s orbit are
called nodes. When the new Moon is near either one of these points, it is in line with the
Sun and, therefore, creates an eclipse. When a new Moon occurs at any other point, it is
too far above or below the plane of the earth’s orbit to block the Sun.
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The Planets and Their Motions

Jupiter — the largest planet in our solar system

The planets are believed to be composed of material left over from the formation of
the Sun. There are two main types of planets. They are the small rocky variety — Mercury,
Venus, Earth, Mars and Pluto — and the gas giants — Jupiter, Saturn, Uranus and Neptune. The
gas giants are known for their very dense, deep atmospheres and lack of any substantial
surface. Jupiter is an especially interesting case. It has been called a “protostar” because it
is actually radiating slightly more energy than it receives. If it were just a little more
massive, it might have become an actual star. (See Appendix E for general planetary data).

The planets were called “the wanderers” by the ancient astronomers, because they
were observed wandering about from evening to evening in relation to the stars. Unless
one were to observe the planets on a daily basis, their movements might not be noticed.
However, if we plot their motions over a period of several weeks, we can get an idea of just
what the ancients saw.
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You can use First Light’s Clock Control and Viewpoint features to gain a better grasp
of planetary motions.

To plot the motion of the planets against the stars:

1. Select Normal from the Zoom submenu in the View menu to set the field of
view to 60°.

2. Select Major planets from the Center submenu in the Planets menu to open
the Planets dialog box. Click on the Mars button in this dialog box. Mars,
represented by a red dot, is centered in the Planetarium window.

3. Ifthe label Mars is not displayed next to the planet’s dot, click on the Planet
names button on the tool bar (the fourth button from the left end of the
tool bar). The label Mars appears next to the planet.

4. Select Line trails from the Animation prefs submenu in the Preferences
menu so that it has a check mark next to it. Expert menus in the File menu
must be selected for the Preferences menu to be available.

5. Select Settings from the Clock submenu in the Tools menu to open the Clock
Control dialog box.

6. In the Clock Control dialog box, set the Step increment to 2 days for ani-
mating the motion of the planets.

7. Click on the Fast forward button, labeled with a right pointing double ar-
row. The clock starts moving and Mars moves across the star field, leaving a
red trail behind it along its path. Other planets will likely come into view,
also leaving trails behind them.

8. Click on the Stop button, labeled with a square, to stop the animation.

Conjunctions

From time to time, the planets appear to pass very close to each other, causing a
conjunction. While conjunctions have very little scientific value, they can be quite spec-
tacular.

For an example of a recent conjunction of note:

1. Select When and where from the View menu to open the When and where
dialog box.

2. In the When and where dialog box, set the date to June 10, 1991 and click
OK.

3. Select 20 from the Degrees submenu in the View menu’s Zoom submenu to
set the field of view to 20°.

4. Select Major planets from the Center submenu in the Planets menu to open
the Planets dialog box. Click on the Mars button in this dialog box. Mars,
represented by a red dot, is centered in the Planetarium window. Notice
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that three planets, Mars, Venus and Jupiter, are very close together. This is the
famous Triple Conjunction, a event which happens only once every couple of
hundred years.

Select Settings from the Clock submenu in the Tools menu to open the Clock
Control dialog box.

Use the drop-down lists to set the clock’s Step increment to 10 hours. Click
the button labeled with a single right pointing arrow to advance First Light’s
clock in ten hour increments. On June 17 you see the closest approach, when
all three planets were visible at the same time in a low power telescope.

Select Lookdown-middle planets from the Viewpoint submenu in the View
menu. The viewpoint shifts to above the solar system, looking down. Notice
that Venus, Mars and Jupiter form nearly a straight line from the Earth.

Select Return to earth from the Viewpoint submenu in the View menu to
return your viewpoint to Earth.

Alignments: The “Jupiter Effect”

Another event related to the positions of the planets has to do with the so-called
Jupiter Effect of several years ago. Every great while, all of the planets are aligned in a
narrow range of the sky. In the past, such alignments were believed to result in great
world catastrophes, causing global panic. A recent throwback to this belief happened in
early 1982, when all of the planets were visible in almost the same quadrant of the sky.
For years before that time, a popular book, called The Jupiter Effect, claimed that this
would trigger all sorts of natural disasters culminating in a major California earthquake.
This was supposed to be the result of the cumulative effect of the planets’ gravity pulling
on one side of the Earth.

To observe this alignment with First Light:

1.

Select Return to earth from the Viewpoint submenu in the View menu to
return your viewpoint to Earth.

Select When and where from the View menu to open the When and where
dialog box. Set the date to March 10, 1982 and click OK.

Select 90 from the Degrees submenu in the View menu’s Zoom submenu to
set the field of view to 90°.

Select Major planets from the Center submenu in the Planets menu to open
the Planets dialog box. Click on the Jupiter button in this dialog box. Jupi-
ter, represented by a yellow dot, is centered in the Planetarium window.

If the label Jupiter is not displayed next to the planet’s dot, click on the
Planet names button on the tool bar (the fourth button from the left end of
the tool bar). Labels appear next to each planet in the Planetarium window.
Notice that six of the eight planets are within the same 90° quadrant of the
sky.

First Light « User Manual

51



6. Select 180 from the Degrees submenu in the View menu’s Zoom submenu to
set the field of view to 180°. This reveals Venus and Mercury about 45° to the
left of Neptune.

7. Now select Lookdown-inner Planets, Lookdown-middle planets and Look-
down-outer planets in turn from the Viewpoint menu in the View menu.
You will see that if this was an alignment, it was marginal at best. Needless to
say, California is still here and a couple of authors got rich.

8. Select Return to earth from the Viewpoint submenu in the View menu to
return your viewpoint to Earth.

Another, more recent, alignment involved the four outer planets, from Saturn to
Neptune. Use the When and where dialog box to set the date to September, 1987 and you
will see that they are, indeed, in the same general area of the sky. This phenomenon
played an important part in the so-called harmonic convergence, which had hordes of be-
lievers heading towards the mountain tops to usher in the New Age.

Retrograde Motion

Another exercise with planetary pathways is to study the motions of Venus and Mer-
cury. Until the time of the astronomer Copernicus, common belief maintained that the
Earth was the center of the universe with the Sun, Moon, planets and stars all orbiting
around it. Unfortunately, a few inconsistencies crept in to upset this idyllic viewpoint.
For example, the planets would occasionally slow down and, of all things, move back-
wards.

In an effort to explain this phenomenon, astronomers of the day invented epicycles,
which forced the hapless orbs into making a small orbit on top of their main orbits,
causing them to back up every so often. This still did not explain all of the movements, so
more epicycles were stacked on top of the earlier ones. Eventually, some planets collected
up to fourteen levels of epicycles, but still refused to behave according to the model.
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We can see this mysterious behavior (now called retrograde motion) by observing
Venus and Mercury.

1.

Select When and where from the View menu to open the When and where
dialog box. Set the date to June 30, 1992 and click OK.

Select Major planets from the Center submenu in the Planets menu to open
the Planets dialog box. Click on the Mercury button in this dialog box.
Mercury, represented by a white dot, is centered in the Planetarium win-
dow.

Select Normal from the Zoom submenu in the View menu to set the field of
view to 60°. Venus should be on the right side of the Planetarium window.

If the label Mercury is not displayed next to the planet’s dot, click on the
Planet names button on the tool bar (the fourth button from the left end of
the tool bar). Labels appear next to each planet in the Planetarium window.

Select Line trails from the Animation prefs submenu in the Preferences
menu so that it has a check mark next to it. Expert menus in the File menu
must be selected for the Preferences menu to be available.

Select Settings from the Clock submenu in the Tools menu to open the Clock
Control dialog box. Set the Step increment to 1 day and click on the Fast
forward button, labeled with a right pointing double arrow. You will see a
rather unusual plot for Mercury. Click on the Stop button, labeled with a
square, to stop the animation.

Select Lookdown-inner planets from the Viewpoint submenu in the View
menu and use the When and where dialog box to set the date back to June
30.

As before, advance the time using the Clock Control dialog box. Notice that
Mercury is actually traveling in the opposite direction of Venus, as seen from
Earth, and faster than the Earth to create the loop in the sky.

Select Return to earth from the Viewpoint submenu in the View menu to
return your viewpoint to Earth.
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Retrograde motion

Another fine example of this can be seen by setting the date to September 1, 1990.
Center Mercury in the screen and use the same procedure as above.
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Orbital Speeds

By now, you may have noticed that some planets move faster than others. There are
many reasons for this. One reason is that the farther a planet is from the Sun, the slower
it must travel to remain in orbit. You can easily observe this by comparing the relative
orbital speeds of the inner planets. Select Lookdown-inner planets from the Viewpoint
submenu in the View menu. Use the Clock Control dialog box to watch Mercury, Venus,
Earth and Mars race each other around the Sun.

Planetary Eclipses

One of the rarest forms of eclipses is when one planet actually moves in front of
another. One such eclipse occurred on January 19, 1591, when Mars passed in front of
Jupiter.

To see this eclipse:

1. Select When and where from the View menu to open the When and where
dialog box. Set the date to Jan 19, 1591, the time to 7:00 am, and the time
zone to -1.00.

2. Click on the location button to open the Location dialog box and set the
latitude to 48 °and the longitude to 7 ° (near Stuttgart, Germany, where the
astronomer Johannes Kepler recorded this event).

3. Select Major planets from the Center submenu in the Planets menu to open
the Planets dialog box. Click on the Jupiter button in this dialog box. Jupi-
ter, represented by a yellow dot, is centered in the Planetarium window.
Both Mars and Jupiter are very nearly in the same location. Using the single
arrow buttons in the Clock Control dialog box, you can investigate their
motions more precisely.

4. Select Now from the Clock submenu in the Tools menu to return First Light’s
clock to the present.

Which Is the Farthest Planet?

No doubt, you grew up learning that the farthest planet from the Sun is Pluto. Not so,
at least for the moment. Pluto’s orbit is the most eccentric and the most highly inclined
of any of the planets. Because of this, Pluto crossed inside the orbit of Neptune in 1980
and will remain so until 1999. You can verify this by selecting Lookdown-outer planets
from the Viewpoint submenu of the View menu.
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Ecliptic

Imagine a flat surface extending out from the Sun through the earth’s orbit, heading
out toward infinity. This forms the plane of the solar system. When projected against the
sky, it is known as the ecliptic.

To see the ecliptic:
1. Select Ecliptic from the Markers submenu in the Extras menu. The ecliptic

is displayed in the Planetarium window as a yellow line. Expert menus in
the File menu must be selected for the Extras menu to be available.

2. Select 180 from the Degrees submenu in the View menu’s Zoom submenu to
set the field of view to 180°.
3. Click on the first button on the left end of the Planetarium window’s tool

bar to center the Sun in the Planetarium window. Notice that each of the
planets (and the Sun) roughly follows the ecliptic through the sky.

The planet Uranus is closest to the ecliptic, being inclined only 0° 46', while Pluto’s
eccentric orbit is tilted a whopping 17°. See Appendix E for the inclinations of the other
planets’ orbits.
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Comets and Asteroids

In addition to the nine major planets and untold moons in the solar system, there
reside a number of lesser objects, namely comets and asteroids. As with the planets, First
Light can also display these objects, showing their locations and complex motions.

Comets

Perhaps the most visually interesting of these objects are the comets. Composed mainly
of frozen water and particles of other material, comets are often thought of as “dirty
snowballs” and are believed to represent the most pristine material in the solar system.
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Some comets, such as Halley’s, are very well known, but most tend to live their lives
Iin relative obscurity far from the Sun in what is called the Oort Cloud. The Oort Cloud is
believed to be located between 30,000 and 100,000 astronomical units from the Sun (an
astronomical unit, or AU, is the distance between the Earth and the Sun). Occasionally, a
passing star or planetary body might disturb the comets, driving some toward the Sun.
Near the Sun, solar heating causes the outer layers of the body to evaporate, creating a
fuzzy halo, or coma, which can be hundreds of miles across. As it draws closer to the Sun,
the comet’s distinctive tail begins to form as the electrically charged solar wind sends the
gases millions of miles behind the main body. This is why the tail always points away
from the Sun. These gases are extremely rarefied, making a comet “the closest thing to
nothing which can be called something.”

Comets are typically discovered only two or three months before their greatest vis-
ibility. Most are found by dedicated amateur astronomers and are named after their dis-
coverers.

Halley’s Comet

What makes Halley’s Comet so unique among the more than 700 plus known comets
Is that it was the first comet whose return was predicted. Sir Edmund Halley, the second
English Astronomer Royal realized that bright comets seen in 1531, 1607 and 1682 were,
in fact, the same object. From this information he predicted that a bright comet would be
visible in 1759. His prediction proved correct and the comet was named after him in his
honor. It is now known that Halley’s Comet has formed a rich thread through history,
being recorded since 240 B.C. in both literature and art. Because of this, its 1986 appari-
tion was eagerly awaited by astronomers and laymen alike. Unfortunately 1986 was a bit
of a disappointment due to the fact that, even at its closest approach to Earth, the comet
was still 36 million miles away. Compare this to the apparition in 837 A.D. when Halley’s
was a mere 3.7 million miles distant (only fifteen times the distance of the Moon).!

To view Halley’s Comet with First Light:

1. Select Fixed... from the Viewpoint submenu in the View menu to open the
Set Viewpoint dialog box. Type 90 for heliocentric latitude, O for heliocen-
tric longitude and 20 for solar distance. Click on OK. First Light moves your
viewpoint to a point 20 astronomical units (AU) directly above the Sun.

2. If the planets are not labeled with their names, click on the Planet names
button on the tool bar (the fourth button from the left end of the tool bar).
Labels appear next to each planet in the Planetarium window.

3. Select 75 from the Degrees submenu in the View menu’s Zoom submenu to
set the field of view to 75°.

4. Select Comets from the Load submenu in the Planets menu and open the
orbit file named halley.cmt. First Light loads Halley’s orbit and centers the
comet in the Planetarium window.

1. Due to the complex gravitational effects of the other planets, a comet’s orbit changes over time so that
the farther away you are from the present date, the less accurate the current orbital elements become. In
fact, Halley’s current period is stated to be 75.99 years, but it may actually vary between 74 and 79 years.
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10.

11.

12.

Click on the first button at the left end of the tool bar to center the Sun in
the Planetarium window.

Select When and where from the View menu to open the When and where
dialog box. Move the dialog box to a corner of the monitor so that it doesn’t
obscure the view of Halley’s orbit in the Planetarium window. Set the date
to Dec 1982 and click on try. Why 1982? This was when the comet was first
seen since 1911, recovered by astronomer G. Edward Danielson of Caltech.
Halley’s was then just outside the orbit of Saturn. Over the next three years
the comet gradually brightened until it was finally visible in medium sized
telescopes by the fall of 1985.

Set the date to Oct 1, 1985 in the When and where dialog box and click on
try. The comet is sweeping toward the orbit of Mars with a small tail just
starting to show. Now things begin to get really busy.

Select Settings from the Clock submenu in the Tools menu to open the Clock
Control dialog box. Set the Step increment to 1 day. Click on the Fast for-
ward button, labeled with a right pointing double arrow, to advance the
date to Dec. 1 in one day increments (watch the date at the left end of the
status bar at the bottom of the Planetarium window). Click on the Stop
button, labeled with a square, to stop the clock. The comet has brightened to
the point that it is just on the edge of visibility for the naked eye for the first
time in nearly 76 years. Notice that the comet moves in the opposite direc-
tion of the Earth. As Halley’s gets closer to the Sun, the Earth moves farther
away. Advance the date to Jan. 15, 1986. Now the comet fades from view as
it heads into the evening twilight toward its closest approach to the Sun on
February 9.

Jump ahead to March 15 as Halley’s emerges from behind the Sun. At this
time it is visible in the early morning hours, rising slowly in the sky. Halley’s
closest approach to Earth is on April 10. Notice that the geometry is such
that the comet is viewed nearly front on, making the tail appear to be ex-
tremely short. This is one reason why this apparition was so poor. By con-
trast, in 1910 the Earth actually passed through the tail.

May 25 began the last period to see the comet with the naked eye as it headed
outbound.

Select Return to earth from the Viewpoint submenu in the View menu to
return your viewpoint to Earth.
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Asteroids

Asteroid Gaspra as seen from NASA’s Galileo spacecraft

In the eighteenth century, an interesting mathematical relationship, popularized by
German astronomer Johann Bode, appeared to predict the relative distances of the known
planets from the Sun. Bode’s Law?, as it was known, pointed out that there was a large gap
between Mars and Jupiter where a planet “should” be, at a distance of 2.5 astronomical
units (AU) from the Sun. Therefore, astronomers around the world began searching that
gap for the missing planet. On the first day of the nineteenth century, January 1, 1801,
the Italian astronomer-monk Guiseppe Piazzi discovered a small body later named Ceres.

Ceres was the first known asteroid. Since its discovery, over 3,500 have been cata-
logued. Besides being the first, Ceres is also the largest, with a diameter of about 600 miles
(a quarter that of the Moon).

2. Bode’s Law was later proven invalid by the discovery of the planet Neptune which, according to the law,
should not have existed.
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To view Ceres as Piazzi saw it:

1. Select Lookdown-middle planets from the Viewpoint submenu in the View
menu to set your viewpoint looking down on the solar system.

2. Select Asteroids from the Load submenu in the Planets menu and open the
orbit file named ceres.ast.

3. Select When and where from the View menu to open the When and where
dialog box. Set the date to Jan 1, 1801, the night of discovery, and click on
OK.

4. Select Return to the Earth from the Viewpoint submenu in the View menu.

5. Select Comets and things from the Center submenu in the Planets menu,
select ceres from the drop-down list in the resulting dialog and click on OK.
You will see the asteroid between the constellations Cetus and Pisces.

Planetary geologists and space visionaries alike see asteroids as an enormously valu-
able source of raw materials for man’s expansion into the solar system. But there is a
darker side. Arthur C. Clarke speaks of it so well in his classic book Rendezvous with Rama
when, in the opening chapters, he describes the potential of a stray asteroid striking the
Earth. In Rama, the Earth of the future establishes an organization called SPACEGUARD
to predict such an event. Even now, scientists are working on programs similar to
SPACEGUARD in order to discover and track potentially dangerous asteroids and, if pos-
sible, destroy or deflect them to prevent an impact.

While most asteroids stay in their place, snugly between the orbits of Mars and Jupi-
ter, a few venture in closer to the Sun, giving rise to fears that someday we may in fact
witness a collision. At this time, only about thirty of these Apollo asteroids are known. But
the threat became all the more real when, in 1989, a small Apollo asteroid, 1989-FC,
made what was determined to have been the closest known approach of any known
comet or asteroid in history.

You can witness this event with First Light.
1. Use the When and Where dialog box to set the date to Feb 15, 1989.

2. Select Asteroids from the Load submenu in the Planets menu and open the
orbit file named 1989 fc.orb.

3. Select Fixed... from the Viewpoint submenu in the View menu. Type 90 for
heliocentric latitude, O for heliocentric longitude and 5 for solar distance.
Click OK to set First Light’s viewpoint to those coordinates.

4. Select 30 from the Degrees submenu in the View menu’s Zoom submenu to
set the field of view to 30°. The 1,000 foot diameter 1989-FC is just outside
the orbit of Venus heading toward an Earth crossing.

5. Select Settings from the Clock submenu in the Tools menu to open the Clock
Control dialog box. Set the Step increment to 1 day. Click on the right
pointing double arrow button and watch what happens. On March 22, aster-
oid 1989-FC passed within 400,000 miles of the Earth. A little closer and it
would have been inside the orbit of the Moon. Notice how it is coming from
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the sunward side as seen from Earth. This is why it wasn’t discovered until
March 31, a full nine days after closest approach. Fortunately, such events are
exceedingly rare, and the chance of a head on collision even more so. But,
had it happened, it could have created a crater over four miles wide. Note
also that 1989-FC passed through the point in space that the Earth had been
a mere six hours earlier!

6. Use the When and where dialog box to set the date back to mid-March, but
watch the asteroid from the Earth by selecting Return to earth from the
Viewpoint submenu in the View menu. Set the clock increment to 5 or 10
hours. Watch how fast 1989 FC moves at its closest approach to Earth, hit-
ting rates of over 70° in a single day — crossing nearly a quarter of the sky!

Asteroid and Comet Magnitudes

First Light does not display comets or asteroids at realistic magnitudes. Cometary
magnitudes are wildly unpredictable, and both asteroids and comets are typically much
too dim to be visible to the naked eye.

Adding a New Orbit

First Light allows you to create new orbits for solar system objects which can then be
displayed along with any of the other solar system objects. With this feature, you can add
data for any comet, asteroid or satellite. (Note that this applies only to objects in orbit
around the Sun, and cannot be applied to Earth orbiting satellites or planetary moons.)

To add a new orbit to First Light:

1. Select Create a new orbit from the Expert menu to open the New object
dialog box.

2. Fill in the appropriate information (described below) for the orbit that you
are adding.

3. Click on save to add the orbit to First Light.

Orbital data can be found in various astronomical books and catalogs or on astronomy
computer bulletin boards.

Orbits are typically quite complex and must be defined by several values. An under-
standing of these values is not really necessary, as the published tables typically have all
of the necessary information. Also, not all of the fields are used. Asteroids use a slightly
different set of data than comets.

In the following list, the name of the orbital element is given, followed by the Greek
or Roman letter most likely to be used in any tables you find.

label: The name of the new object.

color: The color that you wish to have First Light display the object with in the Plan-

etarium window.
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epoch date: (sometimes called T) The date that either the data was taken or of the
closest approach to the Sun, called the perihelion epoch.

eccentricity: (e) Eccentricity serves as a measure of the flattening of an orbit. A value
of 0 indicates a perfectly circular orbit. Values between 0 and 1.0 indicate an
elliptical orbit. Values of 1.0 or larger indicate a parabolic or hyperbolic trajec-
tory. Hyperbolic orbits are not supported in First Light. Objects in parabolic orbits
are not bound to the Sun and, once having swept by, proceed out of the solar
system never to return. Most naked eye comets seem to be of this variety, called
non-periodic comets, meaning that they come by only once. The recently discov-
ered Comet Mueller appears to be in this category. It made its closest approach in
March 1992.

perihelion longitude: (w) The longitude of the perihelion, the closest approach to the
Sun. Given in degrees.

longitude of ascending node: (Q) This is the longitude of the point at which the orbit
ascends from below the plane of the solar system (the ecliptic) to above the plane.
Given in degrees.

period: (P) The time required to complete one full orbit, not used for non-periodic
objects. Given in years.

inclination: (i) The angle at which the orbit is tilted to the plane of the ecliptic.
Inclination is between 0° and 180°.

mean anomaly: (M) The angle used to describe the current position of the object.
Typically used only for asteroids. Given in degrees.

argument of perihelion: (w) Sometimes used in lieu of the perihelion longitude, the
argument of perihelion is the perihelion longitude minus the longitude of as-
cending node. Typically used only for asteroids. Given in degrees.

size: (a, ¢) The size of the orbit is determined by one of three possible values. The
semi-major axis (a) is a direct measurement of the orbit in astronomical units,
generally used for periodic comets. Mean daily motion (n) describes an average
motion in degrees/day the object moves. Perihelion (q) is the distance of the clos-
est approach to the Sun in AU and is used for non-periodic comets with parabolic
orbits.

Orbits for several asteroids and comets are provided with First Light.
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Meteors

Meteors are small solid particles in orbit around the Sun and, in many cases, are
believed to be debris left by passing comets. For this reason, meteors tend to be grouped
together in comet-like orbits and often have been linked to known comets. When the
Earth passes through one of these streams, a meteor shower occurs as the particles burn
up in our atmosphere. On any given night, the average observer should be able to see
about five stray meteors per hour. The typical shower generally triples that rate, while the
best showers (such as the Perseids in August and Geminids in December) may have fifty or
more per hour (see Appendix F).

First Light keeps track of the next meteor shower.

1. Select Summary from the View menu to open the What’s Up? window. The
dates of the next shower are displayed at the bottom of the window.

2. For more information about the shower, click on the next meteor shower
button and a window containing information is opened.

The distribution of meteors along their orbits is not uniform. So what may have been
a bland shower one year might be a memorable event the next. The most notable shower
of this sort is the Leonids in November. The Leonids usually produce about fifteen to twenty
streakers per hour. But early one morning in November 1966 along the western coast of
the United States, rates approaching 150,000 per hour were reported. This was a repeat of
the famous 1833 shower which prompted one nineteenth century writer to exclaim, “Never
did rain fall much thicker than the meteors fell to the Earth....”

Occasionally, meteors the size of small rocks join the fray, producing what is referred
to as a fireball. The bigger ones may be seen to break apart forming two or more fiery trails.
The biggest of these might survive their entry into the atmosphere and strike the Earth.
Meteors which make it to Earth are then called meteorites. The 4,000 foot wide Barranger
Crater in Arizona is a dramatic example of this.

The names of the showers are derived from the area of the sky from which the mete-
ors appear to radiate (hence the name radiant), like spokes in a wheel. For example, the
Leonids appear to be coming from the constellation of Leo.

The best time to observe a meteor shower is from about 2:00 a.m. local time until
dawn. Since the meteors can appear in any part of the sky, a telescope or pair of binocu-
lars only hinders viewing.

First Light « User Manual 63



Traveling with Galileo

In addition to planets, comets and asteroids, First Light also lets you track the progress
of the Galileo Jupiter probe from launch to Jovian intercept.

Few spacecraft have had to endure what Galileo has. Starting in the 1970’s, Galileo’s
journey to the launch pad was as perilous as its actual mission. Thanks to numerous
delays from redesigns, funding threats from politics and technical challenges, it looked
like the probe would never get off the ground. Many scientists were betting their entire
careers on the success of the probe. Finally, all of the obstacles were overcome and the
launch date was set for May, 1986 from the space shuttle Atlantis. But, once again, the
beleaguered probe would have to sit and wait, due to the explosion of the Challenger in
January of that year.

The original mission called for a flight time of three years, with arrival at Jupiter in
1989. However, due to extra safety measures, the powerful booster originally intended for
use in 1986 was scrapped in favor of a less powerful but “safer” rocket. This had the effect
of stretching out the flight time from three years to more than six years. Finally, on Octo-
ber 18, 1989, Galileo received its space wings and headed off, not to Jupiter, but to Venus
first.

Using a complex technique known as gravitational assist, the probe stole a small amount
of energy from both Venus and the Earth to increase its speed. This “slingshot effect” is
commonly used to extend flights or change trajectories with little or no additional fuel
use.

To see the path of Galileo’s flight:

1. Select When and where from the View menu to open the When and where
dialog box. Set the date to Oct 1, 1989 and click on OK.

2. Select Spacecraft from the Load submenu in the Planets menu. Open the
orbit file named galileo.orb. A dialog box appears telling you that “the cur-
rent date is before launch, do you want the date changed?” Click the No
button in the dialog box to keep the date unchanged.

3. Select Lookdown-inner planets from the Viewpoint submenu in the View
menu. Note the odd spiral flight path of Galileo. The probe itself is not vis-
ible because, on October 1, 1989, it is still in the shuttle’s payload bay on the
launch pad.

4. Select Settings from the Clock submenu in the Tools menu to open the Clock
Control dialog box. Set the Step increment to 2 days and click on the Fast
forward button, labeled with a right pointing double arrow, to start the clock.
On October 18, the probe is deployed from the space shuttle and heads to-
ward Venus.

1. Interestingly enough, for a Jupiter probe, Galileo taught us a lot about the moon when it sent back pic-
tures during a camera test that revealed a massive crater that had never before been photographed.
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5. Continue advancing the time to see the Venus fly-by take place three months

later, in February of 1990. Gaining new energy from Venus, the probe heads
out, not to Jupiter yet, but back home to Earth for a visit. After flying by the
Earth in December of 1990, Galileo’s orbit is increased and it is shot out well
beyond the orbit of Mars. At this point, click on the button labeled with a
square to stop the clock.
As you may recall, most asteroids are found between the orbits of Mars and
Jupiter, so in order to take advantage of the spacecraft’s extended voyage,
the project scientists changed its pathway to take it by one of those mysteri-
ous specks of light.

6. Select Asteroids from the Load submenu in the Planets menu and open the
orbit file named for the asteroid Gaspra.

7. Select Lookdown-middle planets from the Viewpoint submenu in the View
menu to widen the view in the Planetarium window.

8. Advance the date to October 29, 1991. On this date, Galileo flew by Gaspra
with a closest approach of a mere 990 miles, taking many highly detailed
pictures.

After Gaspra, Galileo dives back toward Earth for a second encounter exactly two
years later. Here, it finally gains enough energy to make it out to Jupiter, where it arrives
December 7, 1995. At this point a small probe will be dropped into the atmosphere while
the larger orbiter swings around the giant planet sending data back to Earth for two years.

Similar flight procedures were used for the Voyager probes and others. Their orbits are
also provided with First Light.
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Beyond the Solar System

First Light « User Manual

66



Stars

First Light Star Databases

First Light can use two stellar databases, one based on NASA’s SkyMap star catalog and
the other based on the Hubble Guide Star Catalog.

Core Star Database

First Light’s primary or core database contains the stars that are kept in your computer’s
memory as long as First Light is running. First Light uses the SkyMap star catalog as its
primary database. The core database contains all of the SkyMap stars down to magnitude
6.7 for a total of 9,824 stars.

Hubble Guide Star Catalog

In addition to the SkyMap catalog, First Light can display stars from the Hubble Guide
Star Catalog. The Guide Star Catalog (GSC) was prepared to aid astronomers in research
using the Hubble Space Telescope. It is used to find stars near an object being observed that
the telescope’s guidance system can lock on, holding it in place for the duration of the
observation. The Guide Star Catalog contains sixteen million stars, down to magnitude 16.
The GSC contains positional and magnitude data only, so double clicking on a GSC star
with the left mouse button does not produce an information window for the star. The
GSC stars are displayed by selecting More stars from the Stars submenu in the Expert
menu. Expert menus in the File menu must be selected for the Expert menu to be avail-
able. The field of view in the Planetarium window must be 5° or less in order for First
Light to display the GSC stars. The entire Guide Star Catalog is included with First Light.

Star Information

The SkyMap catalog stars have data associated with them in addition to the position
and magnitude data used to draw them in the Planetarium window. You can access the
following data fields in the database either by clicking on a star with the left mouse
button or by using the Data submenu in the Expert menu’s Stars submenu.

Magnitudes

The brightness of a star or other object in the sky is given by a value called its magni-
tude. The brighter the object, the lower its magnitude. Each magnitude represents an
intensity about 2.5 times less than the next lower value. The dimmest stars visible to the
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unaided eye are about magnitude 6.5.* This means that, under the best stargazing condi-
tions, approximately 3000 stars can be seen from horizon to horizon out of a possible
6,000 stars.

It would make sense that the brightest stars would be magnitude 0, but when mea-
surements of stellar brightness were refined, it became necessary to indicate even greater
luminosity. Thus, some of the brightest objects are actually given negative magnitudes.
For example, the Sun blazes away at a magnitude of —26.3, while the next brightest star,
Sirius, shines at —-1.46.

Absolute Magnitude

In order to rate the stars’ luminosities according to some known baseline, astrono-
mers created absolute magnitude. This is what the magnitude of a star would be if it were
placed at distance of ten parsecs (32.6 light years). With this in mind, our Sun would
shine at an unimpressive magnitude 4.79. By comparison, Sirius would be 1.5, Polaris -4.6
and Canopus would blaze away at a searing -8.1.

B-V

B-V (pronounced “B minus V”’) color is an index of the actual color of the star. Hot-
ter, bluer stars have negative values and cooler, redder stars have positive values. The
range of B-V goes from about -0.5 to 2.0, with 0.0 being pure white.

Double Stars

Frequently, what looks like a single star can be resolved into two or more stars through
a telescope. These are commonly called double stars or binary star systems, although many
are actually multiple systems containing several stars. Physical binaries form an actual
system, orbiting around some common gravitational center. Optical binaries are two stars
which happen to be along the same line of sight.

The orbital periods of binaries range from a few days to several thousands of years or
more. Unfortunately, the faster period systems are so close to each other that they cannot
be seen with the human eye. Such systems are usually detectable by spectroscopic means
and are called spectroscopic binaries. In many cases, the stars may actually be so close as to
be physically touching each other.

Although most double stars have periods much too long to observe any motion, a
few are short enough to show movement within the lifetime of the average astronomer.

Some of the better known double stars include Polaris (the north star) and Sirius (the
brightest star, in Canis Major).

Mizar, the bend in the Big Dipper’s handle, is perhaps the best known double star and
Is easily visible with First Light. With a period of several thousand years, Mizar is said to
have been used as an eye test by American Indians.

1. By comparison, an inexpensive set of binoculars will show you stars as faint as magnitude 8; small home
telescopes go down to 11 or 12. Large home scopes can show 14th magnitude objects, such as Pluto,
while your local observatory can show one or two magnitudes dimmer. The largest observatories can see
in excess of magnitude 22 and the Hubble Space Telescope can see stars below 28th magnitude.
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Selecting Binary stars from the Data submenu in the Expert menu’s Stars submenu
labels any multiple stars in the Planetarium window with a bi. Clicking on a double star
with the left mouse button brings up further information. The first number in the binary
specs section of the star’s information window is the angular separation (in arc seconds)
between the farthest components of the system. The second value is the difference in
magnitudes between the two brightest members of the system.

Names

Each star has several different designators. First Light supplies up to five of them. The
brightest stars have proper names, handed down to us through thousands of years of
tradition and myth. To have First Light display these, select Stars from the Names sub-
menu in the Stars, etc. menu. A somewhat more practical method of naming stars was
developed in 1603, in which the main stars in each constellation were assigned a Greek
letter. In general the brightest star is termed Alpha, the next brightest, Beta, and so on.
Since then, numerous other cataloging systems have been developed — usually to classify
the stars according to some specific characteristic. First Light supplies three catalog ID
numbers, the Henry Draper (HD) catalog number, the Smithsonian Astrophysical Observa-
tory (SAO) catalog number and the SkyMap (SMAP) catalog number.

Variable stars

Another class of stars is the variable, which actually change brightness over time.
There are two main varieties: binary variables and physical variables. Binary variables are
nothing more than double star systems, described above, which we view edge on. The
variations in brightness are caused when one star eclipses the other. Such variables have
long steady light curves with short dips every few days.

Physical variables fluctuate by a physical process which is not clearly understood.
There is great variety among physical variables. Some vary with a precise, regular period,
while others behave erratically. Many will change several magnitudes in brightness, while
others change only a few hundredths of a magnitude. Some have long periods of several
years while others have periods of a few hundredths of a second, as in the case of pulsars.
One variety, the nova, varies its brightness by exploding. The supernova of 1987, in a
matter of only hours, released 1,000 times the amount of energy that our Sun will release
over its entire ten billion year life span.

Magnitude \/ V \/

Time

Light curve for a binary variable
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One particular type of variable star that has become very useful is the cepheid variety,
of which about 500 examples are known. Cepheids are unusual, in that their fluctuations
follow a very precise set of rules, the most notable being that there is a close relationship
between the period and luminosity of the stars. Knowing the period, you can determine
the luminosity, and knowing the luminosity, you can determine the distance when com-
pared to their visual magnitude. Using this method astronomers are able to determine the
distances to nearby galaxies.

Pulsars are one of the most interesting types of variable stars. The first discovered (in
1968 by the Cambridge University Observatory) had a period of only 1.337 seconds. Its
rapid rate is amazing considering that most processes in the universe are measured in
terms of thousands to millions of years. Another pulsar, known as Tau X-1, has a period of
only .033 seconds! Current theories explain pulsars as neutron stars, rotating very rapidly.
Their energy is focused by a strong magnetic field into a beam which is directed outward
along the rotational equator, much like a lighthouse. Each time a beam crosses our line of
sight, we receive a flash. The precision of pulsar flashes had astronomers at first thinking
that they had discovered an artifact from some alien civilization.

Stellar Classes

Stars are most commonly subdivided into many different classes by chemical makeup
as derived by their spectra. The spectra is the finger print of a star, revealed using a spec-
troscope. A stellar spectra looks like the rainbow band of light that a common prism
reveals when placed in the sunlight. By spreading out this band, dark absorption lines,
caused by different chemical elements in the star absorbing a particular color of light, are
revealed. For example, helium shows up as one set of bands and hydrogen as another.

Table 1: The Chief Spectral Classes

O Very hot (35,000 K) blue-white stars with large mass and high luminosity. Spectral lines include ionized
helium, nitrogen, oxygen, and hydrogen. Lambda Orionis, Zeta Puppis and O type stars.

B  Hot (20,000 K) blue-white stars with large mass. Spectral lines include prominent helium bands with
highest intensity at B2 and disappearing at AO. Alpha Eridani, Rigel, Spica and Regulus are B type stars.

A Hot (10,000 K) white stars with luminosities 50 to 100 times that of the Sun. Spectral lines contain
strong bands of hydrogen, while helium is missing. Altair, Sirius and Vega are A type stars.

F  Warm (7,000 K) yellow-white stars. Strong calcium lines in spectrum with other metals present, and
weaker hydrogen lines. Alpha Persei, Procyon and Canopus are F type stars.

G Warm (6,000 K) yellow stars. Metals are prominent in spectrum, with weaker hydrogen lines. The Sun,
Alpha Centauri, and Capella are G type stars.

K Warm (4,000 K — 4,700 K) orange stars. The spectrum contains many strong metal lines, weak hydrogen
lines and the appearance of hydrocarbon lines. Alpha Ursa Majoris, Pollux and Arcturus are K type stars.

M Cooler (2,500 K — 3,000 K) red stars. Wide spectral bands from titanium oxide, with many other strong
metallic lines. Many show bright hydrogen lines. Betelgeuse, Mira and Antares are type M stars.

N Deep red cool (2,500 K) giants. Carbon spectral lines appear. Mostly variable stars. Y Canum Venaticorum,
R Leporis and S Cephei are type N stars.

R  Orange red stars similar to type N, but warmer. Carbon bands are weaker. May be path through which
type G become type N. RU Virginis and S Camelopardi are type R stars.

S Red stars similar to type M but with zirconium oxide bands replacing titanium oxide. Complex spectra,
usually variable, with hydrogen emission lines. R Cygni is a type S star.

W Hot (50,000 K+) blue giants, known as Wolf-Rayet stars. High luminosities, similar to type O but with
expanding gaseous shell and extremely turbulent atmosphere. Gamma Velorum is a type W star.
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The illustration below shows the distribution of the stars in terms of luminosity ver-
sus spectral class. It is the H-R (Hertzsprung-Russell) diagram, developed in 1913. The
strong central band is called the Main Sequence, describing about 90% of all stars. The Sun
Is in almost the exact center of the chart. In the upper right are the red giant stars, large
cool stars several hundred times the size of the Sun. Stretching across the top are the
massive supergiant stars which may be as much as 50,000 times as luminous as the Sun,
such as Rigel in Orion. In the lower left corner are very hot, small stars such as white dwarfs.
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color-magnitude graph shows the various types of stars
which exist within a few hundred light years of the sun. (For
explanation, refer to the text.)

The letters O, B, A, F, G, Kand M are used to identify the main spectral classes (Table
1). Finer distinctions are marked by the numbers 0 to 9 following the letter. For instance,
our Sun is spectral class G2, Rigel is B8. Still finer classifications are required due to differ-
ences in luminosities within a particular spectral type. These are given by the MK identi-
fiers shown in Table 2. So, the complete class of the Sun is G2 V, while Rigel is B8 la.
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Table 2: Stellar classes

la. Most Luminous Supergiants
Ib. Least Luminous Supergiants
II. Bright Giants

I11. Normal Giants

IV. Subgiants

V. Main Sequence

VI. Subdwarfs

Stellar Motions

While they appear unmoving to us, the stars, along with everything else in the uni-
verse, never stand still. The two kinds of stellar motions that First Light can show are radial
velocity (the speed at which a star moves toward or away from us) and proper motion (move-
ment against a fixed background).

Radial velocity, measured in kilometers/second, is determined from the star’s all im-
portant spectra. As a star varies its distance from us, the Doppler effect takes hold and
shifts the spectral lines described above. If a star is receding, or moving away from us, the
lines move toward the red end of the spectrum, hence the term red shift. If it is approach-
ing us, the lines move toward the violet end of the spectrum. The red shift has indicated
that the entire universe is expanding, much like spots on the surface of an inflating bal-
loon.

Proper motion is measured in arc-seconds per year of angular motion against fixed
objects in the sky. Naturally, the closest stars are seen to have the fastest proper motions.
Barnard’s Star (the third closest star at six light years) in Ophiuchus is the champ. It can
easily be seen zipping through the heavens at the breakneck speed of 1° every 351 years.

Precession

There is yet another stellar motion, called precession, which has the unfortunate ef-
fect of making all star atlases in the world obsolete every hundred years or so. This phe-
nomenon is due to a subtle motion, or wobble, of the earth’s axis, where one complete
wobble takes about 25,800 years. All stellar positions gradually shift as a result of this.
This is why stellar data is prefaced by an epoch, or the year for which it is most valid. For
instance, First Light’s database is epoch 2000, meaning that the positions of the stars are
correct for the year 2000 A.D. This doesn’t make the data useless for the current year,
however. Since the motions are so slow, new epochs are calculated only every fifty years
or so. First Light can demonstrate precession with the items in the Precession submenu in
the Expert menu.
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One result of precession is that our current north star, Polaris, is only temporary.
In the year 4145 A.D., the star Gamma Cephei will hold the honor.

1. Select By name from the Center submenu in the Stars, etc. menu to open
the Center dialog. Type Polaris and click OK. The north star is centered in
the Planetarium window.

2. Select Normal from the Zoom submenu in the View menu to set the field of
view to 60°

3. Select Grid from the Markers submenu in the Extras menu to display a RA/
dec grid in the Planetarium window. Expert menus must be selected in the
File menu for the Extras menu to be available. Note how close Polaris is to
the 90° declination point.

4. Select Names and Outlines from the Constellations submenu in the Stars,
etc. menu so that they have check marks next to them.

5. Select When and where from the View menu and set the year to 4145 A.D.
in the When and where dialog box.

6. Select Stars from the Precession submenu in the Expert menu to calculate
the precession for the year 4145 A.D. The constellation outlines remain in
their original position so that you can compare the stars’ new positions with
their original positions. The star Gamma Cephei is near the north pole (90°
dec). Click on it with the left mouse button to verify this. Polaris is now at a
declination of about 79°.

Distance

Stellar distances are rarely measured in miles because of the enormous values in-
volved. Astronomers have adopted the unit of the light year, which is the distance that
light travels in a year. The closest star, Alpha Centauri, is a mere 4.34 light years away.

At 4.34 LY distance, the light that you see from Alpha Centauri originated from the
star four years and four months ago. By comparison, the light you see from the Sun is
only eight minutes old and the light from the furthest visible objects is literally billions of
years old.

Sometimes a unit called a parsec is used instead of light years. A parsec is equal to 3.26
light years.
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Deep SKky Objects

Deep sky objects are non-stellar objects outside of our solar system. These include such
things as star clusters, galaxies and nebulae. The Messier and NGC items in the Galaxies,
etc. submenu of the Star, etc. menu control whether First Light displays deep sky objects.

Star Clusters

A globular cluster

Star clusters are groupings of stars which are gravitationally dependent on each other.
Open clusters are loosely formed groupings. The Pleiades (M45 in Taurus) and The Hyadies
(the head of Taurus) are fine examples of open clusters. Some open clusters contain fewer
than a dozen stars. Another type of star clusters, globular clusters, which are very tight
spherical formations containing hundreds of thousands of stars. M13 in Hercules is one of
the most notable examples.
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Galaxies

The Andromeda Galaxy — our own galaxy’s closest neighbor

Galaxies are often referred to as “cities of stars,” the most famous being our own Milky
Way. Galaxies typically contain billions of stars.

Galaxies such as the Milky Way and the Andromeda galaxy (M31) are classified as spiral
galaxies because of their strong disk shaped appearance. In fact, many spirals show dis-
tinct arms curving out from the core, looking much like a giant celestial whirlpool.

Elliptical galaxies have no strong disk shape but still maintain a rounded form.

Irregular galaxies have no recognizable form whatsoever. The Small Magellanic Cloud
In the southern sky is an example of an irregular galaxy.

Nebulae

Nebulae are interstellar dust and gas clouds which provide raw materials for new stars.
It is believed that over a third of our galaxy’s mass is in this form. The best known ex-
ample is the beautiful M42 in the constellation of Orion. It is called a diffuse nebula be-
cause of its loose, irregular shape.
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Planetary nebulae have a rounded planet-like appearance. They usually result from a
star which, at one time, became unstable and exploded (a nova), shedding its outer layers.
The Ring Nebula in Lyra (M57) and the Rosette Nebula in Monoceros (NGC2237) are fine
examples of such objects. Visible in even the smallest telescopes, the Ring Nebula looks
like an intergalactic smoke ring blown there by a relaxing deity.

The Orion Nebula

Nebulae can be either dark or bright. The dark ones, such as the famous Horsehead
Nebula in Orion, look much like “holes in the sky,” obscuring everything behind them.
This is because they have no stars near enough to illuminate them. For this reason, some
astronomers feel that dark nebulae represent the original matter left over from the cre-
ation of the universe.

On the other hand, the bright nebulae have frequently been called “stellar nurser-
ies.” In the center of the 30 light year wide Orion Nebula, for instance, objects have been
observed which are believed to be stars in the process of forming.

Nebulae are typically composed of hydrogen and helium, with traces of carbon, oxy-
gen and nitrogen.
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Deep sky catalogues

Messier Catalog

First Light makes use of two of the main catalogs of deep sky objects. The first is called
the Messier catalog, named after the French astronomer Charles Messier, which contains
110 entries. Compiled in 1781, the catalog was developed as an aid to comet hunters who
might mistake the faint smudge of a galaxy or nebula for a comet. This listing contains
the most famous objects in the northern skies. Appendix C lists the objects included in the
Messier catalog.

To display objects from the Messier catalog in the Planetarium window, select Messier
from the Galaxies, etc. submenu in the Stars, etc. menu.

NGC Catalog

The other catalog used by First Light is the New General Catalogue, or NGC, which
comprises over 7,500 entries. First Light displays the best 1,500 or so of these. Appendix D
lists the NGC objects included with First Light.

To display objects from the New General Catalog in the Planetarium window, select
NGC from the Galaxies, etc. submenu in the Stars, etc. menu.
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First Light Menus

File Menu

Printer Setup...

Selecting Printer Setup... from the File menu opens a Print Setup dialog box with
which you can change your printer options.

Set Page Title...

Set Page Title... opens a dialog box in which you can enter a title to be printed at the
top of printout pages.

Print

Selecting Print from the File menu prints the Planetarium window to your printer as
a star chart that can be used when you are away from your computer. You might, for
example, print a star chart to be used for an observation session in the field. Star charts are
printed with black stars on a white sky in order to save printer ink or toner.

Expert menus

When Expert menus is selected (checked), First Light adds four menus to the menu
bar. The added menus are Extras, Tools, Preferences and Expert. They contain items use-
ful to more advanced users.

Startup preferences...

Selecting Startup preferences... opens a dialog box with which you can select some
basic settings to be used each time First Light is started from the Windows Program Man-
ager.

Navigator open

When Navigator open is checked, First Light’s Navigator window is open when First
Light starts up.

Expert menus

When Expert menus is checked, four new menus (Extras, Tools, Preferences and
Expert) are included on the menu bar when First Light starts up.
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Sky Tonight display

When Sky Tonight display is checked, First Light starts up with the Sky Tonight dis-
play rather than the main Planetarium display window.

Use km for distances

When Use km for distances is checked, First Light shows distances between solar
system objects in kilometers rather than miles. You must exit First Light and restart it from
the Program Manager for this change to take effect.

Planet selector open

When Planet selector open is checked, the Planets selection dialog box is open when
First Light starts up. The Planets dialog box can also be opened by selecting Major planets
from the Planets menu’s Center submenu.

Save settings on exit

When Save settings on exit is checked, First Light saves the current settings into an
event file when you exit and uses those settings when you start First Light again. See the
section on the Settings submenu for an explanation of event files.

Quickview uses profile

When Quickview uses profile is checked, the Quickview feature (View menu) loads
the all settings from a selected event file except for the date and time (First Light’s current
date and time are used).

Splash Music
When Splash Music is checked, First Light plays music when it starts up.

Settings

The Settings submenu gives you several options for changing a variety of First Light’s
settings through event files. An event file represents the *“state” of First Light at a given
time. For instance, you might set up First Light to display an upcoming eclipse and then
save it as an event file. When the event file is loaded back into First Light, the date, time
and all of the program’s features are changed to those settings.

Load profile...

Load profile... opens a load settings dialog box with which you can select an event
file to load. Once an event file is selected and the OK button is clicked, First Light loads all
of the settings from the selected file except for the date and time (First Light’s current date
and time are used). You might have an event file to highlight the constellations only
using their names, outlines and borders, while another one is used to highlight the plan-
ets while turning off the stars.
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Load event...

Load event is like Load Profile, except that First Light loads the entire file, including
the date and time saved with the settings. Use this when you wish to load a specific event,
such as an eclipse.

Save...

Save opens a Save events dialog box with which you can name and save First Light’s
current settings, including the program’s internal date and time, to an event file.
Save startup...

Save startup is like Save, but it saves an event file that is used automatically when-
ever First Light is started from the Program Manager. Startup settings include the direction
of the view in addition to the settings of other features.

Save quickview...

Save quickview... saves an event file that is used when any of the items in the View
menu’s Quickview submenu are selected or any of the Quickview buttons on the tool bar
are used.

Save cleanup...

Save cleanup saves an event file that is used when Cleanup is selected from the View
menu or the Reset button on the toolbar is used. For instance, if you want the constella-
tion outlines to always be displayed, set up the star display with only constellation out-
lines turned on and select Save cleanup.

Exit

Exit quits First Light and returns you to the Windows Program Manager.

View Menu

The view menu contains items that control First Light’s view of the sky.

Tutorials

Selecting Tutorials opens a series of interactive tutorials designed to teach you about
both First Light and astronomy in general. It is recommended that the tutorials be com-
pleted in order, since they take you from the familiar to the unfamiliar and beyond.

Buttons appear throughout these tutorials. Clicking on them demonstrates events
that are being described or shows a short film about the topic being discussed.
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Quickview

The items in the Quickview submenu set up the star display inlocal coordinate mode,
looking toward any of nine directions. Options saved with theFile menu’s Save quickview...
item are also turned on. The Quickview items save the time that it would otherwise take
to turn features on or off individually while waiting through several screen refreshes.

Selecting up from the Quickview submenu displays the entire sky as seen from the
selected location with a 180° field of view (simulating a “fish-eye” lens). Because of the
wide field, constellations near the edge of the display are distorted, or scrunched up. The
display is drawn as if you are facing north and looking straight up. So north is below your
chin, or down, relative to your face.

The Sky tonight

The Sky tonight displays a screen that shows an overview of your local sky at the
current time, according to your computer’s system clock. The sky is displayed as seen
from the location set in the When and where dialog box. Three buttons at the bottom of
the Sky tonight screen give you access to different features.

The Calendar button opens the Calendar window. When it is first opened, this win-
dow displays a calendar for the current month according to the date in the When and
where dialog box. The current day is highlighted with a flashing yellow border. The phase
of the Moon and notes of astronomical events are displayed for each day of the month.
The left and right arrow buttons at the bottom of the Calendar window change the month
backward and forward, respectively. The now button takes the calendar back to the cur-
rent month and day according to the date in the When and where dialog box.

Clicking on any particular day with the left mouse button opens a window contain-
ing more detailed notes for that day. Clicking the use date button in this window changes
First Light’s When and where date to the selected day.

The Nightly Grabbag button opens a window displaying interesting information about
a phenomenon, object, or event. You can read through the text, examine the pictures,
click on highlighted words or phrases to learn more, or see short films on the subject
presented. Items change daily.

The Planetarium button returns you to the Planetarium window.

Summary

Selecting Summary displays the What’s up? window. The What’s up? window con-
tains a text summary of the planets, Sun and Moon. The summary includes the objects’
current locations in both equatorial and local coordinates, whether or not they are visible
from the location set in the When and where dialog box, distance in astronomical units
from your current viewpoint, rise and set times at the location set in the When and where
dialog box, and the time in minutes that it takes for light to travel from the object to your
current viewpoint.

If an object has an asterisk to the left of its name in the summary, it is currently
visible from the location set in the When and where dialog box.
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The column labeled diam. shows the angular diameter of each object in degrees. For
comparison, both the Sun and Moon are about 0.5° in diameter. These values vary through-
out the year depending on how far away the object is from the Earth.

The light distance, in the column labeled time, plays an important part in how space-
craft such as Galileo or Voyager are controlled. For instance, when Voyager flew by Neptune
in August of 1989, it took radio signals over four hours to reach it. So, when a command
was sent to the spacecraft by ground control, it took a full eight hours to find out whether
or not the spacecraft carried out the command.

The next meteor shower button in the What’s up? window opens another window
containing a description of any upcoming meteor showers. Meteor showers are best viewed
after midnight when the Moon is not visible.

Mode

The items in the Mode submenu toggle between First Light’s two main display modes,
Local and Equatorial. In Local mode, the sky is displayed from Earth using local coordi-
nates. In Equatorial mode, the sky is displayed from Earth using equatorial coordinates.
When First Light’s viewpoint is off the Earth, out in the solar system, equatorial coordi-
nates are used, regardless of the mode selected in the Mode submenu. See the Basic Con-
cepts chapter for an explanation of the local and equatorial coordinate systems.

Local

In Local mode, the sky is displayed, using local coordinates, as seen from the time
and location on the Earth given in the When and where dialog box. Another way of
entering Local mode is to use the Quickview submenu in the View menu. Since the
Quickview items change several settings at once, they save time in setting up the Plan-
etarium display. In Local mode, the sky changes from night to night and from one loca-
tion on the Earth to another. This is because the local coordinates of the stars, their alti-
tude and azimuth, change as the Earth rotates. If you view the sky from the northern
hemisphere, you will notice that the north star, Polaris is at an altitude above the north-
ern horizon equal to your latitude. If you are exactly at the pole, the sky resembles Equa-
torial mode.

Equatorial

In Equatorial mode (the default), the sky is displayed, using equatorial coordinates,
as if there were no Earth beneath you to distort your perspective. This removes any ambi-
guities introduced by your location and is, therefore, the mode used in star charts and by
astronomers. Equatorial mode is slightly faster than Local mode, since fewer calculations
are required to position the stars.

Navigator

The Navigator is perhaps the single most powerful tool in First Light. The Navigator
window gives you a visual overview of where you are or what you’re viewing. The Naviga-
tor is also used to graphically move First Light’s viewpoint and direction of view.
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You Are Here

The top portion of the Navigator window is the You are here display. It varies, de-
pending on the location of the viewpoint and the viewing mode. Beneath this display are
three buttons that are used to select the viewing mode. Selecting the Earth button puts
First Light into Equatorial mode, where the sky is viewed from the Earth, but the view-
point is not bound to any particular location on the Earth. It is as if you are in the center
of the planet looking out. Selecting the Home button puts First Light into Local mode,
where the sky is viewed from the location specified in the When and where dialog box.
Selecting the Space button moves the viewpoint off the Earth into the solar system.

When the Earth button is selected, the You are here display shows a three dimen-
sional diagram of the way man has historically tended to visualize the sky. That is, a globe
with the observer at the center and the various celestial objects on the surface of the
globe. This sky globe is displayed from the outside the globe so that you can see the entire
sky. The red lines radiating from the center of the globe are a view cone that represents the
portion of the sky that is being displayed in the Planetarium window. The sky globe
display also shows how much of the sky can’t be seen in the Planetarium window - i.e.,
the portion of the globe that is outside of the view cone. The planets, Moon and Sun are
shown on the surface of the sky globe. If you center the Sun in the Planetarium window,
the view cone moves to center on the yellow ball on the surface of the globe. If you move
the sky in the Planetarium window by dragging with the right mouse button, the view
cone also moves to keeping track of the view. In equatorial coordinates, the sky is mea-
sured in right ascension, so there are right ascension labels on the equator of the sky globe
every six hours.

The sky globe can be rotated to any angle by dragging the mouse over the globe with
the right mouse button held down. The view cone can be rotated, changing the view in
the Planetarium window, by dragging the mouse over the globe with the left mouse
button held down. The size of the view cone, i.e. the field of view, can be changed by
holding down both mouse buttons at the same time and dragging the mouse up and
down.

When the Home button is selected, only half the sky globe is displayed. This is be-
cause the other half is below the local horizon and is, therefore, not visible. Other than
that, the Home display is identical to the Earth display.

The You are here display is quite a bit different when the Space button is selected.
First Light’s viewpoint is moved off the Earth and out into the solar system. The circles are
the orbits of the planets, the bright dots on the circles are the planets themselves and the
yellow dot at the center is the Sun.
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First Light’s viewpoint is marked by the green dot. This is the point in the solar system
from which the view in the Planetarium window is seen. The lines drawn from the green
dot show the relative distance of the viewpoint from the plane of the solar system (the
ecliptic) and from the Sun. If the lines are green, the viewpoint is above the ecliptic. If they
are red, the viewpoint is below the ecliptic. The blue line radiating out from the Sun
points to 0° right ascension, also referred to as the first point of Aries. It is an arbitrary point
that is the origin of the equatorial coordinate system.
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As with the Earth and Home displays, dragging with the right mouse button rotates
the display to any angle. Dragging with the left mouse button moves the viewpoint.
Dragging left or right rotates the viewpoint around the Sun. Dragging up or down moves
the viewpoint up or down in relation to the ecliptic. Dragging the mouse up or down
with both buttons held down at the same time moves the viewpoint further from or
closer to the Sun. This may take some practice, as duplicating three dimensional space on
a flat surface like a computer monitor is not always completely intuitive.

Status Display

The area below the Earth, Space and Home buttons displays some basic information
about the current view in text form. This status display shows the viewpoint’s precise
location in space and other information about the view, such as zoom value, view angle,
date, time, etc.

Button Panel

The Planets button opens the Planets dialog box, allowing you to quickly aim the
view at any planet you wish. See Major planets in the section on the Planets Menu for more
information.

The Constellations button opens the Center Constellation dialog box, so that you
can center the view on any of the constellations.

The Lines/names button toggles on or off several of the common markers in the
Planetarium window, such as constellation outlines and names.

The Date/time button opens the When and where dialog box so that you can set First
Light’s date, time and viewing location. See the section on the When and where for more
information about it.

The Find button opens a dialog box that lets you locate any object in First Light’s
database by name. It is most useful for centering deep sky objects.

Cleanup

The Cleanup menu item resets the display in the Planetarium window to a pre-
defined set of basic options, removing identifiers and markers that may be cluttering the
view. Typically, it can be used to turn off several display options at once and return to a
plain display with no identifiers of any kind. If you want some identifiers left on when
you use the Cleanup feature, set up the display the way you wish it to appear and select
Save cleanup... from the Settings submenu in the File menu.

Viewpoint

The items in the Viewpoint submenu set First Light’s viewpoint off the Earth into the
solar system.

Return to earth

Return to earth returns the viewpoint to Earth from a location in the solar system.
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Lookdown-inner planets

Lookdown-inner planets places the viewpoint directly above the Sun, looking down
on the orbits of the inner planets, from Mercury to Mars.
Lookdown-middle planets

Lookdown-middle planets places the viewpoint directly above the Sun, looking down
on the orbits of the planets out to Saturn.
Lookdown-outer planets

Lookdown-middle planets places the viewpoint directly above the Sun, looking down
on the entire solar system, out to Pluto.
Fixed...

Fixed opens the Set Viewpoint dialog box, with which you can specify the location
of the viewpoint in heliocentric coordinates. Heliocentric coordinates describe the position
of an object (or a viewpoint) relative to the Sun. Heliocentric latitude and longitude are
similar to the earth’s latitude and longitude. Latitude ranges from -90° to 90°, with the
plane of the earth’s orbit being 0°. Longitude ranges from 0° to 360°, with 0° correspond-
ing to 0° right ascension, also called the First Point of Aries. The last value in heliocentric
coordinates is distance from the Sun, expressed in astronomical units (AU).

helocentric latitude : |[0.00

cancel

heliocentric longitude : |163.32

solar distance (aAl): |0.99

Set Viewpoint dialog box

From a planet...

From a planet opens a dialog box with a drop down list of planets. Selecting a planet
from the list and clicking on the OK button attaches First Light’s viewpoint to that planet.

Zoom

The items in the Zoom submenu set the “magnification” of the display in the Plan-
etarium window. This is usually called field of view and is measured in degrees width. The
first four items are general selections which represent the most commonly used fields of
view. Wide angle sets the field of view to 120°. Normal sets it to 60°, Close up sets it to
10°, and Telescope sets it to 2°.
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The Degrees submenu gives a set of specific choices for the field of view. As a compari-
son to physical viewing instruments, fields of view between 45° and 60° are close to that
seen by the unaided eye. A pair of binoculars gives a field of about 5° and a low power
telescope gives a field of 1° or less. A field of 0.5° is small enough to cause the Moon to fill

the eyepiece.

When and where...

Selecting When and where... opens the When and where dialog box, with which
you can set the date and location on Earth from which First Light displays the sky. The
first time you use First Light, you should set the location to your own home. See the Setting
Your Location and Time chapter for more information about using the When and where

dialog box.

long : 120°39"

time zone : 7.00

Julian day : 2444841.56 day : 236
UTC : 1:31

lat :35™7T

= YWhen and where
time: |06:3pm |§| o DST Summer)

date: [aug|s] 24[3] 1981]3] | BC

cancel

location

Planets Menu

Center

When and where dialog box

The items in the Center submenu change the view in the Planetarium window to

center on specific objects.
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Major planets...

Major planets opens the Planets dialog box, which contains a button for each of the
major planets in the solar system and for the Sun and Moon. Clicking on any of these
buttons centers the planet for which it is labeled in the Planetarium window.

The other button in the Planets dialog box opens another dialog box with a drop-
down list of any solar system objects other than the planets whose orbits have been loaded
with the Load submenu in the Planets menu.

The hover button in the Planets dialog box opens the Hover dialog box. See the
section on the Settings item in the Planets menu’s Hover submenu for a description of
the Hover dialog box.

The OK button closes the Planets dialog box.

Comets and things...

Comets and things opens the center other dialog box. The center other dialog box
contains a drop-down list of comets, asteroids and other non-planetary solar system ob-
jects whose orbits have been loaded with the Load submenu in the Planets menu. To
center the Planetarium window on an object in the drop-down list, select the object’s
name from the list and click on the OK button.

Look behind

Selecting Look behind centers the view in the Planetarium window on the point
directly opposite to the current view, or its antipode. This is equivalent to turning around
to look behind you. Look behind can be used to find the earth’s shadow - center the Sun
and select Look behind.

Zenith

Zenith centers the point in the sky that is directly overhead from the current location
set in the When and where dialog box.

Load...

The items in the Load submenu allow you to add solar system objects other than the
planets, Sun and Moon to First Light’s display of the sky. Objects that can be loaded are all
objects that orbit the Sun (rather than orbiting a planet). They are divided into three
categories: asteroids, comets and spacecraft. For more information about these objects,
see the Comets and Asteroids chapter.

Asteroids..., Comets..., and Spacecraft...

In First Light, solar system objects are defined by their orbits. For each object, there is
a file that specifies the object’s orbit. The first three items in the Load submenu - Aster-
oids, Comets and Spacecraft — each open a file dialog box that lists orbit files for the
appropriate type of object. Each file is named after the object whose orbit it specifies.
Select the orbit file for an object you wish to display and click on OK. First Light loads the
orbit and displays the object, centering it in the Planetarium window.
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The orbits of several asteroids, comets and spacecraft are included with First Light.
You can also add solar system objects to First Light using Create a new orbit in the Expert
menu.

Unload...

Unload opens the unload object dialog box, which contains a drop-down list of solar
system objects that are currently loaded. Select an object from the list and click on OK to
unload its orbit from First Light’s memory and remove it from the sky display. The Unload
feature is useful because the more objects you have loaded into memory, the slower First
Light’s display is. So, you can use Unload to make sure that you only have those objects
that you are currently working with loaded.

Unload all...

Unload all unloads all currently loaded solar system objects fromFirst Light’s memory
and removes them from the star display.

Flyby...

First Light’s Flyby feature allows you to investigate the six Voyager planetary flybys
and the impact of the Shoemaker-Levy 9 comet with Jupiter. The Voyager flybys include
Voyager 1 at Jupiter and Saturn, and Voyager 2 at Jupiter, Saturn, Uranus and Neptune.
Selecting Flyby from the Planets menu opens the Flyby dialog box. Selecting a flyby
mission from the Flyby dialog box’s drop-down list and clicking on the show button sets
your viewpoint in the vicinity of the selected planet, looking down on the path of the
selected spacecraft. The spacecraft’s path is shown as a series of dots, with blue dots form-
ing the part of the path before closest approach to the planet, and red dots forming the
part of the path after closest approach. Each dot represents a half hour of motion and the
entire trail begins one day before closest approach and ends one day after. You may need
to zoom the view out in order to see the entire path.

In Flyby mode, the target planet is fixed in the center of the screen, remaining cen-
tered as the time changes. Holding down the right mouse button and dragging the mouse
repositions your viewpoint to any location around the planet. Dragging to the left or
right rotates the viewpoint around the planet, dragging up or down moves the viewpoint
north or south, respectively. Constellation names, outlines and planetary orbit lines are
turned off to remove clutter when Flyby mode is entered. These features can be turned
back on after entering Flyby mode. Flyby mode is similar to Hover mode, but the two
cannot be used together.

Flyby dialog box
The flyby dialog box has controls that govern the view of the target planet and space-
craft.

Use the drop-down list at the bottom of the flyby dialog box to select any of six
possible Voyager flybys or the path of Shoemaker-Levy 9 fragment Q.

The attach viewpoint button attaches your viewpoint to the spacecraft (or comet
fragment).
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Flyby dialog box

Hover

The items at the top of the Hover submenu are named for the Sun, planets and Moon.
Selecting one of these menu items moves your viewpoint to the vicinity of the corre-
sponding object and centers the view on that object. In Hover mode, the planets, Sun and
Moon are drawn (rendered) as three dimensional objects and images of the actual objects
are texture mapped onto them to make them appear as real as possible. The rendering
process is fastest when your system is set to 256 colors. If a planet that you are hovering
next to has moons, the moons are displayed in their current positions and labeled.

In Hover mode, as in Flyby mode, holding down the right mouse button and drag-
ging repositions your viewpoint around the planet, keeping the planet centered in the
view. Dragging to the left or right rotates the viewpoint around the planet, dragging up or
down moves the viewpoint north or south, respectively.

When you enter Hover mode, constellation names and outlines, and planetary orbit
lines are turned off in order to remove clutter. They can be turned back on at any time
after entering Hover mode.

Settings

Selecting Settings from the Hover submenu opens the Hover dialog box. Whenever
you change settings in the Hover dialog box, click on the show button for the changes to
be displayed in the Planetarium window.

The drop-down list labeled object is a list of the same objects at the top of Hover
submenu. Select an object from this list that you wish to view in Hover mode. The drop-
down list labeled distance specifies the distance of your viewpoint from the planet being
viewed. The distance is in units of the radius of the planet. For example, if you are view-
ing the Earth and you set your hover distance at 50, your viewpoint will be 50 times 4,000
miles, or 200,000 miles, away from the Earth.
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Hover dialog box

The items under the orbit label control the orbit mode. The shape drop-down list
controls the shape of the orbit. An elliptical orbit has an eccentricity of 0.4 and a highly
elliptical orbit has an eccentricity of 0.7. The rate drop-down list controls the rate at
which the display is updated: every thirty seconds, every ten seconds or every five sec-
onds. The step drop-down list controls how far the viewpoint moves around the orbit
between each update: 1°, 2° or 5°.

If you are viewing the Moon or Mars in Hover mode and the landing sites check box
is checked, the landing sites of NASA’s Apollo missions (on the Moon) and Viking landers
(on Mars) are labeled on the planet.

If the attach check box is checked, your viewpoint is bound to the object being
viewed so that it moves with the object as the object moves in its orbit.

If the features check box is checked, major features on the Moon and Mars are la-
beled.

Names

When the Names menu item is selected so that there is a check mark next to it, solar
system objects are labeled with their names in the Planetarium window. Selecting the
menu item again toggles this feature off.

Stars, etc. Menu

Center

The Center submenu in the Stars, etc. menu is similar to the Center submenu in the
Planets menu. It allows you to find and center stars and other objects that are not located
in the solar system.
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Constellations...

Selecting Constellations opens a dialog box with a drop-down list box containing
the names of the constellations. Select a constellation from the list and click the OK
button. The selected constellation is centered in the Planetarium window.

Galaxies and things...

Selecting Galaxies and things opens a dialog box with a drop-down list box contain-
ing the names of several of the more prominent galaxies, star clusters and nebulae. Select
an object from the list and click the OK button. The selected object’s location is centered
in the Planetarium window. For the object to be displayed, you must turn on the display
of deep sky objects by either clicking on the Galaxy button on the tool bar or by selecting
Messier and NGC from the Galaxies, etc. submenu in the Stars, etc. menu.

Custom...

Selecting Custom opens a dialog box with a drop-down list box containing a user-
editable list of objects. Select an object from the list and click the OK button. The selected
object is centered in the Planetarium window. You can add objects to the list by center-
INng an object that you wish to have listed and then select Add to center list from the
Extras menu.

By name...

Selecting By name opens a Find dialog box into which you can type the name of an
object you wish to center. Once you’ve typed the name of an object, click OK and the
object is centered in the Planetarium window.

Stars...

Selecting Stars opens a center dialog box into which you can type the identifier of a
star you wish to center. The identifier can be the star’s Greek identifier, its Henry Draper
(HD) catalog number, or its Smithsonian Astrophysical Observatory (SAO) catalog num-
ber. See the Stars chapter for a description of these identifiers. Once you’'ve typed an
identifier in the dialog, click the OK button to center the star.

Zenith

Zenith centers the point in the sky that is directly overhead from the current location
set in the When and where dialog box.
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Constellations

The items in the Constellations submenu control how constellations are displayed.

Borders

When Borders is selected so that it has a check mark next to it, lines are displayed in
the Planetarium window showing the internationally recognized boundaries of the
constellations. In other words, if an object is said to be “in” a particular constellation,
then it is within the boundaries of that constellation.

Names

When Names is selected so that it has a check mark next to it, the constellations are
labeled with their names in the Planetarium window.
Outlines

When Outlines is selected so that it has a check mark next to it, the traditional out-
lines of the constellations are displayed in the Planetarium window.

Galaxies, etc.

The items in the Galaxies, etc. submenu control the display of deep sky objects. A deep
sky object is an object that is not a star and is not located within our solar system. They
include galaxies, star clusters and nebulae. See the Deep Sky Objects chapter for more infor-
mation about these objects and the two catalogs of deep sky objects used by First Light.
Messier

When Messier is selected so that it has a check mark next to it, objects from the
Messier catalog are displayed in the Planetarium window.

NGC

When NGC is selected so that it has a check mark next to it, objects from the New
General Catalog are displayed in the Planetarium window.

Legend...

Selecting Legend opens a window containing a legend of the various symbols used to
display deep sky objects.

Names

Galaxies, etc.

When Galaxies, etc. is selected so that it has a check mark next to it, deep sky objects
are labeled with their catalog numbers.
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Stars

When Stars is selected so that it has a check mark next to it, stars that have common
names are labeled with those names.

Info Menu

The Info menu gives you access to a variety of information about objects in the sky
and astronomical events.

Calendar...

Calendar opens the Calendar window. When it is first opened, this window displays
a calendar for the current month according to the date in the When and where dialog
box. The current day is highlighted with a flashing yellow border. The phase of the Moon
and notes of astronomical events are displayed for each day of the month. The left and
right arrow buttons at the bottom of the Calendar window change the month backward
and forward, respectively. The now button takes the calendar back to the current month
and day according to the date in the When and where dialog box.

Clicking on any particular day with the left mouse button opens a window contain-
ing more detailed notes for that day. Clicking the use date button in this window changes
First Light’s When and where date to the selected day.

Next event...

Next event opens a window with details about the next major astronomical event
that is due to occur.

Nightly Grabbag...

Nightly Grabbag opens a window displaying interesting information about a phe-
nomenon, object, or event. Read through the text, examine the pictures, click on high-
lighted words or phrases to learn more, or see short films on the subject presented.Nightly
Grabbag items change daily.

Constellations...

Constellations opens a window containing the names, three-letter abbreviations and
meanings of the names of the constellations.
Planets...

Planets opens a window containing relevant planetary data.
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Stars...

Stars opens a window containing information about the fifteen nearest and fifteen
brightest stars.
Eclipses...

Eclipses opens a window containing the dates of and other information about up-
coming eclipses.
Meteor showers...

Meteor showers opens a window containing the dates of the major recurring meteor
showers.
Browse

The Browse submenu allows you to browse through the images and movies included
on the First Light CD.
Tables...

Tables opens a Help window that gives you access to various tables of astronomical
data.

Extras Menu

The Extras menu is only available when Expert menus is selected in the File menu.

Add to center list...

Add to center list allows you to add objects to the list of objects that can be centered
through Custom in the Stars, etc. menu’s Center submenu. To add an object to the list,
center the object in the Planetarium window. Set the Zoom angle to be used when the
object is centered using the Custom menu item. Select Add to center list from the Extras
menu and the view angle and zoom are added to the list.

Chart...

Chart opens a window that displays the entire sky at once. The check boxes at the
left edge of the window determine what objects are displayed.
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Earth’s shadow

When Earth’s shadow is selected so that it has a check mark next to it, the location
of the earth’s shadow is marked in the Planetarium window by two concentric red circles.
To find the shadow, center on the Sun by clicking on the Sun button on the tool bar and
then select Look behind from the Center submenu in the Planets menu. The Earth’s
shadow feature is useful for examining lunar eclipses — an eclipse occurs when the Moon
passes into the shadow.

Landscape

Landscape displays an artificial horizon that simulates mountains in the distance. It
is only available when viewing the sky in Local mode. When the landscape is being
displayed, the center of the view is limited to 20° above or below the horizon.

Magnitude Legend

Magnitude Legend opens a window that shows the symbols used to show star magni-
tudes in the Planetarium window.

Markers

The items in the Markers submenu add various lines and symbols to the sky display
that can be useful in finding objects and visualizing the sky. Selecting the items in the
Markers submenu toggles the markers on or off.

Crosshair

When Crosshair is selected so that it has a check mark next to it, a small red crosshair
Is added the center of the Planetarium window, marking the center of the window.

Ecliptic

When Ecliptic is selected so that it has a check mark next to it, a yellow line is added
to the sky display representing the ecliptic. The ecliptic is the sun’s path through the sky,
which defines the plane of the earth’s orbit and, thus, the plane of the solar system. This
is the region of the sky where the planets are found.

Equator

When Equator is selected so that it has a check mark next to it, a red line is added to
the sky display representing the celestial equator. The celestial equator is the line corre-
sponding to 0° declination in the equatorial coordinate system. It is analogous to the
earth’s equator, which corresponds to 0° latitude.

Horizon

When Horizon is selected so that it has a check mark next to it, a yellow line is added
to the sky display representing the horizon as seen from the location set in the When and
where dialog box. When the display is in Equatorial mode the horizon line will be tilted
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according to the latitude set in the When and where dialog box and it will move accord-
ing to the time of day, due to the earth’s rotation.

Grid

When Grid is selected so that it has a check mark next to it, a right ascension/declina-
tion grid is overlaid on the sky display. The grid is drawn in a medium gray color so that
It is not too distracting.

Local altitude

When Local altitude is selected so that it has a check mark next to it, tick marks
showing the altitude, in degrees, above the horizon are displayed on the sky display. The
feature is only available when the sky is being displayed in Local mode.

Redraw

With the many labels and other markers available with First Light, it is possible that
some display elements may occasionally obscure others. Redraw simply refreshes the
display to clean it up, if possible.

Star trails

Many people’s first experience with the art of astrophotography is through taking
stellar time exposures with a camera fixed on a tripod. The result is streaks, called star
trails, caused by the motion of the stars across the camera’s field of view. This effect is
simulated with First Light’s Star trails feature. To do so, change the mode to Local from
the Mode submenu in the View menu and turn on Star trails in the Extras menu. Ad-
vance the time in one or two minute increments. See the section on the clock control
dialog box for information about how to advance the time.

System

Close all windows

Close all windows closes all open windows except for the Planetarium window.

Twinkle

When Twinkle is selected so that it has a check mark next to it, the stars are displayed
with a twinkling effect that simulates the twinkling of stars in the real sky due to atmo-
spheric effects.
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Tools Menu

The Tools menu is only available when Expert menus is selected in the File menu.

Aim...

Aim opens a dialog box containing a chart of the full sky. The green circle in the chart
is centered on the same point as the view in the Planetarium window. To move the view,
hold down the right mouse button and drag the green circle in the chart dialog box. The
view in the Planetarium window changes dynamically as the green circle is dragged. The
outl. check box toggles constellation outlines on and off in the chart dialog box. The equ.
and local buttons switch the display mode between Equatorial and Local.

The controls at the bottom of the chart dialog box allow you to set the view to a
precise angle. Use the up and down arrow buttons to set the right ascension in hours and
minutes and the declination in degrees and minutes. Once you’ve set the correct angle,
click on the aim button to change the view in the Planetarium window.
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Aim dialog box

Clock

The items in the Clock submenu control First Light’s internal clock. The clock deter-
mines the time for which the sky is displayed.
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Settings...

Settings opens the Clock Control dialog box. The two drop-down lists in the center
of the dialog box set the increment for changing First Light’s clock.

‘- 4| w | M| "z|+  step: |mlil|huurs 1#] |_ok | new |

Clock Control dialog box

The five buttons at the left end of the Clock Control dialog box are exactly the same
as the clock buttons on the tool bar. Clicking on the left-most button continuously de-
creases the time by the increment selected by the drop-down lists. The next button de-
creases the time by one increment each time it is clicked. The middle button stops the
clock when it is set to Auto or Real-time through the Clock submenu in the Tools menu.
The next button to the right increases the time by one increment each time it is clicked.
The last button continuously increases the time by the selected increment.

Freeze
Freeze stops the clock when it is set to Auto or Real-time through the Clock submenu
in the Tools menu.

Auto

When Auto is selected so that it has a check mark next to it, First Light’s internal clock
is continuously updated as quickly as possible by the increment set in the Clock Control
dialog box (Settings in the Clock submenu). The speed of this process depends on the
speed of your computer.

Real-time

When Real-time is selected so that it has a check mark next to it, First Light’s internal
clock is continuously updated according to the computer’s system clock. That is, for every
minute of actual time that passes, the display is updated by a minute.
+1 Day

Selecting +1 Day adds one day (24 hours) to First Light’s clock.

Now

Now sets First Light’s clock to the current time according to your computer’s system
clock.

-1 Day
Selecting -1 Day subtracts a day (24 hours) from First Light’s clock.
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Sunrise

Sunrise sets First Light’s clock to the time of sunrise for the current day at the location
specified in the When and where dialog box.

Sunset

Sunset sets First Light’s clock to the time of sunset for the current day at the location
specified in the When and where dialog box.

Flashcard...

The Flashcard feature is provided as an aid to learning to identify the constellations.
Selecting Flashcard turns off all of the identifying markings in the Planetarium window
and centers the display on a random location. The challenge to you is to figure out just
what you are viewing. While in Flashcard mode, a small dialog box with four buttons is
displayed. Constellation names and outlines can be turned on and off with the hide and
show buttons. The flash button turns the identifiers off and moves the view to a new
random location. The cancel button exits the Flashcard mode and returns the display to
the state that it was in when Flashcard mode was entered.

Moon

Map...

Map opens an image of the Moon with major features labeled.

Phases...

Phases opens a chart that shows the moon’s phases for the current year. A value of
0.0 or 1.00 corresponds to a new Moon and a value of 0.50 corresponds to a full Moon.
For values between 0.0 and 0.50, the Moon is waxing (getting fuller) and for values be-
tween 0.50 and 1.00, the Moon is waning (getting smaller). The current day is marked
with ared vertical line. The small picture of the Moon in the lower left corner of the chart
shows the moon’s current phase.
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Nearby stars...

Nearby stars opens a window that shows a three dimensional display of the stars up
to one hundred light years away from our Sun. Holding down the right mouse button
and dragging rotates the display. Holding down the left mouse button and dragging up or
down moves the viewpoint closer to or farther from the Sun.

When the labels button is selected, the scientific names of the major stars are dis-
played. When the names button is selected, the proper names of the more prominent
stars are displayed. When the no labels button is selected, the stars are displayed without
labels. When the lines button is selected, lines are drawn from the Sun to some of the
other stars so that you can get a better sense of their distance from the Sun. Lines and
labels are displayed in bright colors for stars that are in front of the Sun and in dimmer
colors for stars that are behind the Sun.

Planets

Planet guide...

Planet guide opens a window with a small chart showing the planets that are cur-
rently visible from the location set in the When and where dialog box. This chart is
similar to but much simpler than the Sky Tonight display.
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Rise/set plot...

Rise/set plot opens a chart that shows the visibility of the planets from the location
set in the When and where dialog box during the current 24 hour period from noon to
noon. The period when each planet is visible is shown as blue bars on the chart. First
Light’s current time is shown as a vertical red line and sunset and sunrise are shown as
vertical yellow lines.

Jul, 4, 1995 AD

Rise/Set plot

Preferences Menu

The Preferences menu gives you control over various aspects of First Light. The Pref-
erences menu is only available when Expert menus is selected in the File menu.

Animation prefs

The items in the Animation prefs submenu control how the motion of solar system
objects against the star field is depicted when the sky is animated using the buttons in the
Clock Control dialog box or the clock control buttons on the tool bar.

Object droplines

When Object droplines is selected so that it has a check mark next to it and First
Light’s viewpoint is off the Earth, solar system objects leave trails of droplines. The drop-
lines are lines drawn from the planet to the plane of the ecliptic. Lines drawn from plan-
ets that are below the ecliptic are red, those from above the ecliptic are green.
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Date trails

When Date trails is selected so that it has a check mark next to it, the position of
each object at each clock increment is marked with the date of the clock increment. The
effect is that each solar system object leaves a trail of dates along its path.
Line trails

When Line trails is selected so that it has a check mark next to it, each solar system
object leaves a line behind it marking its path through the sky.
Dot trails

When Dot trails is selected so that it has a check mark next to it, the position of each
object at each clock increment is marked with a dot. The effect is that each solar system
object leaves a trail of dots along its path. This is slightly less obtrusive than line trails.

Colors

The Colors submenu gives you a choice of three color sets with which the stars can be
drawn. Only one set can be selected at any given time.
Bright

The Bright color set draws the stars brighter than normal. This is useful for displaying
the sky on a low contrast monitor or in a brightly lit room such as a lecture hall.
Colors

The Colors color set uses various colors to show different magnitudes, rather than
shades of gray.
Normal

Normal is the default color set of grays.

Distance units

The item selected in the Distance units submenu, either Miles or Km, determines
whether distances in information windows are displayed in miles or kilometers.

Sound effects

When Sound effects is selected so that it has a check mark next to it, First Light plays
sounds for various events such as zooming and getting info for an object.

Show...

Items in the Show submenu allow you to select what types of objects are displayed in
the Planetarium window. For example, you might wish to turn off the display of un-
needed planets to speed up the display in some circumstances.
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Planets...

Planets opens a dialog box with which you can select what planets and other solar
system objects are displayed in the Planetarium window.
Other...

Other opens a dialog box with which display of stars and various types of deep sky
objects can be turned on and off.
Magnitudes...

Magnitudes opens a dialog box with which you can set the minimum magnitude of
displayed stars. Use the up and down arrow buttons to set the magnitude limit. Stars
dimmer than the selected magnitude will not be displayed. The eye button sets the limit
to magnitude 6, which is about the limit of magnitudes that can be seen with the naked
eye. The all button sets the limit to magnitude 16 so that all stars in First Light’s star
databases will be displayed. The Try button sets the limit to the selected magnitude with-
out closing the Show magnitude dialog box.

Status bar

Status bar toggles on and off the display of the status bar at the bottom of the Plan-
etarium window.
Toolbar

Toolbar toggles on and off the display of the tool bar at the top of the Planetarium
window.

Viewpoint...

Viewpoint allows you to set various parameters, according your viewpoint prefer-
ences, related the way space and planet orbits are displayed. The Viewpoint menu item is
not available when First Light’s viewpoint is located on Earth.

Expert Menu

The Expert menu is only available when Expert menus is selected in the File menu.

Create a new orbit...

Create a new orbit opens the New object dialog box. This dialog is used to add the
orbits of solar system objects (asteroids, comets and spacecraft) to First Light so that they
can be displayed along with the other solar system objects. See the Adding a New Orbit
section of the Asteroids and Comets chapter for information about the various parameters
that must be entered into the New object dialog box to define an orbit.
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Lock view

The items in the Lock view submenu allow you to lock the Planetarium window’s
view on the Sun, Moon, or any of the planets. This is useful for keeping a particular object
centered while animating an event that involves the object. Such events include eclipses
and the changing phases of the Moon.

Select object...

Select object opens a dialog box with a drop-down list box containing the names of
the Sun, Moon and planets. Select an object and click OK to center and lock the view on
that object.

Release

When the view is locked on an object, selecting Release releases the lock and allows
you to move the view elsewhere.

Movies

Browse...

Browse opens an open file dialog with which you can select and open a movie file to
view.

Create...

Create opens the Create animation dialog box so that you can create movies of
astronomical events. See the Making Your Own Movies section for more information about
creating movies.

Observing

The Observing submenu gives you access to various planning aids for actual observa-
tion sessions.

Ephemeris...

Selecting Ephemeris opens the Ephemeris dialog box that allows you to generate
ephemeris tables. An ephemeris is a list of positions of a given object over a given range of
time. Click on the select button in the Ephemeris dialog box to open a dialog with which
to select a solar system object for which to create an ephemeris. Use the controls in the
top portion of the dialog box to specify the date range for the ephemeris and the time
increment for the entries. Clicking on the print button send the ephemeris to your printer.
Clicking on the save button saves the ephemeris to your hard disk as a text file.
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Planning guide...

Planning guide opens a dialog box that allows you to generate a list of objects that
will be visible from the location specified in the When and where dialog box during a
specified time interval. Use the items in the top portion of the dialog box to specify the
date, starting and ending times, types of objects and the minimum magnitude of objects
to be included in the list. Clicking on the save button saves the list to your hard disk as a
text file. Clicking on the print button to send the list to your printer.

Reticle

The Reticle feature displays a series of concentric circles, called a reticle, centered at a
selected point in the sky. The reticle allows you to measure the angular distances between
objects. To display a reticle, select Reticle from the Observing submenu. The mouse pointer
changes to a circle with a crosshair. Click on the point in the sky at which you want the
reticle centered. The reticle will continue to be displayed at that point, even if the view is
moved, until it is removed by again selecting Reticle from the Observing submenu.

Planet rendering

The items in the Planet rendering submenu control how the planets are drawn (ren-
dered) in First Light’s Hover and Flyby modes.

Draggable

Normally, when the sky is dragged with the right mouse button to reposition the
viewpoint in Hover or Flyby mode, the planets are animated as gridded spheres which
are drawn much faster than the more realistic texture mapped images. However, if you
have a fast enough computer (486-100 or Pentium), the textured mapped planets may be
drawn fast enough for you to use the Draggable option. When Draggable is selected so
that there is a check mark next to it, First Light uses the more realistic images even when
the sky is being dragged. This feature only works when 24 bit rendering in the Planet
rendering submenu is not selected. Otherwise, the Draggable menu item is disabled.

Sharp shadows

When Sharp shadows is selected so that it has a check mark next to it, the edge of the
terminator is sharpened on rendered planets. The terminator of a planet is the twilight line
that separates the day side from the night side. Use of the Sharp shadows feature is left to
your own tastes. Leaving it turned off results in more realistic images.

Show clouds

When Show clouds is selected so that it has a check mark next to it, clouds are drawn
on images of Earth and Venus. With Show clouds turned off, you can see what Venus
would look like if stripped of her thick veil.
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Show feature names

When Show feature names is selected so that it has a check mark next to it, major
features on several of the planets are labeled. You can click on these labeled features to get
further information about them.

24 bit rendering

In First Light’s Hover and Flyby modes, the planets are normally drawn using a rela-
tively quick 256 color (8 bit) process. This default process trades some image quality for
speed, typically taking a second or less per image. The resulting images of the planets are
relatively coarse at larger sizes. When 24 bit rendering is selected so that it has a check
mark next to it, First Light uses another method that uses millions of colors (24 bit render-
ing) and produces more realistic images of the planets. Use this slower method once a
view has been set up using the faster 8 bit method. The larger the image, the more time 24
bit rendering will take, but the results should be worth the wait. On slower computers,
expect to wait thirty seconds or more for basic images. However, many subtle lighting
and shading effects can be included in 24 bit images, such as clouds, atmospheres and
surface shadows.

Precession

The items in the Precession submenu introduce precession into First Light’s calcula-
tion of the star’s positions. Precession is a slow wobbling of the earth’s axis, much like a
child’s top, where one “wobble” takes about 25,800 years. Because of this motion, the
apparent positions of the stars change over time. This is why star charts are typically
assigned a year or epoch to show what date was used for the stellar positions. Due to
precession, the star Polaris will cease being the north star in a few hundred years. See the
section on Precession in the Stars chapter for more information.

Auto

Selecting Auto from the Precession submenu causes First Light to calculate and dis-
play the precession of all stars and markers in the Planetarium window for the current
date of First Light’s internal clock.

Stars

Selecting Stars from the Precession submenu causes First Light to calculate and dis-
play the precession for stars only in the Planetarium window for the current date of First
Light’s internal clock. Constellation outlines are not precessed so that you can compare
the stars’ new positions with their original positions.

Outlines

Selecting Outlines from the Precession submenu causes First Light to calculate and
display the precession for constellation outlines only in the Planetarium window for the
current date of First Light’s internal clock.
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Show custom data

When Show custom data is selected so that it has a check mark next to it, user-
defined custom objects are displayed in the Planetarium window. See the chapter on User
Data for information about adding custom objects to First Light.

Stars

The items in the Stars submenu modify how stars are displayed in the Planetarium
window.

Data

When any item in the Data submenu is selected so that it has a check mark next to
it, the corresponding information is displayed next to each star shown in thePlanetarium
window. Only one item at a time can be selected in the Data submenu. Select None to
removed any data being displayed. See the Stars chapter for explanations of what each
item means.

More stars

When the Zoom value of the view in the Planetarium window is 5° or less, selecting
More stars displays stars from the Hubble Guide Star Catalog (GSC). Data for the GSC
stars consists of position and magnitude only, so clicking on one of them with the left
mouse button does not open an information window. For more information about the
GSC and the star databases used by First Light, see the Stars chapter.

Proper motion

Stars move through the sky just as planets do. This effect, proper motion, is so slow
that it is virtually impossible to see, until now. When Proper motion is selected so that it
has a check mark next to it, a line is drawn through each star in the direction that the star
is moving. The lines represent 50,000 years of movement, +25,000 years from the star’s
current position. The red dot is the end point. See the Stars chapter for more information
about proper motion.

Help Menu

The items in the Help menu give you access to First Light’s online help system. First
Light uses the standard Windows Help feature. Select Using help for more information
about using the help system. The rest of the items in the Help menu give specific informa-
tion about using First Light.
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User Data

Adding Your Own Objects

If the millions of objects that First Light offers aren’t enough, you can always add
your own!

Using the Notepad (in the Windows Accessories group) is recommended, but
any word processor will do.

1.
2.

Open Notepad. Then select Open from the File menu.
Navigate to the following directory path:
c:\f_light\data2\user

This is the default installation directory. If you have installed First Light to a
different directory, your directory path will be slightly different.

To view the entire list of available files, select All Files (*.*) from the List
Files of Type field (found below the File Name list). Select the file user_obj.dat
from the list.

Once the file has been opened, you will see a list of existing objects. Scroll to
the end of the list. Information for each object is contained in the following
format:

id ra dec clr name

where:

id = the object’s unique identification number

ra = the object’s right ascension (dd.mm in degrees, minutes)
dec = the object’s declination (dd.mm in degrees, minutes)
clr = the object’s color designation

name = the object’s name

At the end of the object list, type a unique identification number, right as-
cension, declination, color number, and the object’s name, separating the
elements with spaces. A typical entry might be:

30014 2030.18 57.38 65 Nova-Cygni

When you have finished adding your custom object to the list, select Save
from the File menu. Do not save the file in a special format specific to your
word processor. The file must be saved as a generic ASCII text file, otherwise
First Light will not be able to read it.
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The following are some of the colors available for customizing your objects:
10 = light yellow
32 through 64 = white to dark gray
65 = blue-green

66 = cyan
67 =red
68 = green
69 = blue
70 =gold
Do not change the first line of the user_obj.dat file. It must be:

51

to identify the file for First Light. Each subsequent line in the file forms one complete
entry. Entries may not span lines. Any line beginning with a semicolon (;) is a comment.

By default, object names are in the form xxxx where xxxx is the id number. The id
number is used for point and identify operations and it binds the object to a text file
whose name is USR\xxx.CMT.

A sample database of several objects is provided with First Light. Radio sources are
gold, pulsars are cyan, quasars are blue and the 1987 supernova is yellow. A maximum of
3,000 objects can be entered.
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Glossary

Altitude: The position of an object relative to the horizon in degrees. An object at 0° is
exactly on the horizon, and an object at 90° is directly overhead.

Asteroid: A chunk of rock left over from the formation of the solar system which can
range in size from only a few dozen feet to over 600 miles. Over 3,500 are now known.

Astronomical unit: A convenient unit used by astronomers instead of miles to state dis-
tances within the solar system. One astronomical unit (AU) is equal to the average
distance between the Sun and the Earth, or about 93 million miles.

Azimuth: The position of an object relative to north in degrees. An object at an azimuth
of 0° is directly north; at 90° it is to the east; at 180°, to the south; and at 270°, to the
west.

Comets: Chunks of ice and other matter that move in highly elliptical orbits. When
comets are close to the Sun, the ice evaporates and leaves lengthy trails known as
streamers or tails. Comets are thought to contain some of the most pristine material
left over from the formation of the solar system.

Declination: The sky’s “latitude,” measured in degrees. Declination, or Dec., is combined
with right ascension to describe where an object is located in the sky. Declination
ranges from -90° to +90° where the north star, Polaris, is located.

Deep sky objects: Anything outside our solar system that is not classified as a star, such as
galaxies, star clusters and nebulae.

Ecliptic: The plane of the solar system as defined by the earth’s orbit. Most planets stay
very close to this plane. Only Pluto goes very far above or below it. Comets are noto-
rious for their oddball orbits, straying far away from the plane of the ecliptic.

Gas Giants: The term given to the planets Jupiter, Saturn, Uranus and Neptune due to
their size and the fact that they composed primarily of gas with no substantial sur-
face.

Greek ID: A star’s Greek identifier is a Greek letter followed by the name of the constella-
tion in which the star is found. The brightest stars are designated by the first letters in
the alphabet, so a star designated as “alpha” is usually the brightest in its constella-
tion. Since the letters are limited in number, few stars actually have formal Greek
identifiers.

Hubble Guide Star Catalog: A catalog of all stars down to 16th magnitude used by Hubble
Space Telescope researchers to guide the telescope during long photographic expo-
sures. A star near the object of interest is chosen as a reference point on which the
telescope locks.

Julian Date: An absolute date used to pinpoint astronomical events. The Julian date is
the number of days from January 1, 4713 B.C.

Light Year: The distance that light travels in a single year, about 5.86 trillion miles. The
nearest star, Alpha Centauri, is a mere 4.34 light years away. Compare this to our Sun
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which is only eight light minutes away from us.

Magnitude: A measure of the brightness of stars and other objects in the sky, the smaller
the number the brighter the object. The brightest star after the Sun is Sirius, which
shines at a magnitude of -1.46 while the Sun itself shines at —26.3. The unaided eye
can see object as dim as a magnitude of about 6.5.

Messier Catalogue: A catalogue of 110 of the most spectacular deep sky objects (galaxies,
nebulae, etc.) compiled by Charles Messier in 1781.

Multiple stars: Two or more stars orbiting around each other. Sometimes called double or
binary stars.

Neutron stars: The smallest and densest stars known, typically the final remnant of a
supernova which has collapsed so tightly on itself that it, in effect, becomes a single
atomic nucleus measuring only a few miles in diameter. Its density is so great that a
single teaspoon full of its material would weigh on the order of 1,000 million tons.

NGC: The New General Catalog (“NGC”) of deep-sky objects (galaxies, nebulae, etc.) which,
contains over 7,500 objects. First Light can display the 1,500 most important entries.

Occultation: An occultation occurs when the Moon moves in from of and obscures, or
eclipses, a star or other object.

Precession: A slow wobbling of the Earth’s axis, much like a child’s top, that changes the
apparent positions of the stars. Due to precession, the north star will cease being the
north star in a few hundred years. One “wobble” takes about 25,800 years. This is
why star charts are typically assigned a year, or epoch, to show the date that was used
for the stellar positions.

Right Ascension: The sky’s “longitude”, measured in hours, minutes and seconds, each
hour being equivalent to 15°. Right ascension, or RA, is combined with declination to
describe where and object is located in the sky. Right ascension ranges from 0 to 24
hours.

Supernova: The destructive explosion of a star, one of the most spectacular and dramatic
events in the universe. When the balance between a star’s gravity and the pressure
created by heated material in the star is upset, the star’s size can increase to that of
our solar system in only a day or two. It will shine brilliantly for a couple of weeks,
then collapse back on itself to die a slow and invisible death.

Totality: The time during a solar eclipse when the Moon completely covers the Sun. This
usually lasts for only a few minutes at best.

Universal Time: The standard way that time is stated for scientific and technical pur-
poses. It is based on the time at 0° longitude (Western Europe), the Greenwich merid-
ian. Universal Time was formerly referred to as Greenwich Mean Time, or GMT.

Variable star: A star which varies in brightness (magnitude) due to either internal physi-
cal processes or eclipses of other nearby stars.
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Appendix A

Buying a Telescope

If First Light has done its job, you may be saying to yourself, “Self, | wonder if | should
get a small telescope?” Well, what’s stopping you?

When you first consider buying a telescope, figure out what exactly you want to do.
If you are only interested in casual peeks at the planets, there is no need to get a $6,700
Compustar 11. Or, if you want something really portable for backpacking, don’t geta 17
inch Dobsonian when a good pair of binoculars might do the job.

No doubt your first thought is “but | want to see everything!” Unfortunately, there
are always going to be drawbacks to accept and choices to be made. Telescopes are mea-
sured in the size of their objective (either lenses or mirrors). So, a 17 inch Dobsonian
contains a mirror 17 inches in diameter (in other words, big). Of course, the larger the
diameter, the more you will see, but the drawback is that a 17-inch is large and heavy.
Such an instrument may quickly throw water on the enthusiasm of a novice observer if it
takes three people to move it out to the backyard. On the other end is a typical beginner
telescope, such as a 2.4 inch refractor or 6 inch reflector from your local Sears. While easy
to transport, deep sky objects will not be nearly as spectacular, although the planets and
the Moon most certainly will be. Other things to consider are the accessories available.
The more serious instruments naturally have more goodies to spend your money on,
while the simpler models might not.

As mentioned above, the aperture is the chief method of measuring the general per-
formance of a telescope. Scopes are simply light buckets, so, the larger the objective, the
more light it can capture and the sharper the image that it provides. Don’t be mislead by
advertisements for instruments costing only $200 but have 500 power. The power or en-
larging capability of the telescope is likewise connected to the aperture size. The higher
the power, the more spread out, or dimmer, the image is and the less distinct it will be. A
general rule of thumb is that the maximum usable power of a telescope is 50 times its
objective size in inches. So, a 2.4 inch refractor will be fine up to 120 power. After that
you’d be fighting a losing battle. Theoretically, the scope could be pushed to 500 power,
but the image would be too dim and fuzzy to be usable. By the way, 50 to 75 power is just
right for most solar system observations, so magnification isn’t everything.

A Refractor

eyepiece objective
47

«  light
47

Perhaps the most familiar kind if scope is the good old refractor, not much different
than Galileo’s original instrument. In its simplest form, a refractor combines a set of
lenses at the front of a long tube with an eyepiece at the other end. The standard scope of
this type has a lens 60 millimeters in diameter (2.4 inches) and a tube about three feet
long. Refractors are the most common small telescopes made, mass produced by several
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large volume vendors and usually sold in the toy sections of major stores. We recommend
staying away from these mass market instruments. While inexpensive, the optical quality
is usually so poor as to make them nearly useless for anything but the largest and bright-
est objects. Quality manufacturers such as Meade, Unitron and Pentax all make similar
small refractors, but of much higher quality. These are perfect for casual viewing of the
solar system and some of the brighter deep sky objects, but they just don’t have the light
gathering power to support astrophotography or serious deep sky observations. Larger
refractors are available, but once you get above three inch models, the prices become
astronomical (grin), not to mention the weight.

A

mirror

<,7
light

«i

Newtonian Reflector

Besides the refractors there are reflectors which, as the name suggests, use mirrors
instead of lenses. The most common of these, the Newtonian, was developed by Sir Isaac
himself. Light enters through the front, reflects off of the primary mirror, into the sec-
ondary mirror back at the front, then out to the eyepiece. A variation of this is the increas-
ingly popular Dobsonian-Newtonian, which sacrifices some general convenience for very
low cost instruments. Most telescopes are mounted on an equatorial mount, which permits
it to be tilted parallel to the earth’s equator. This allows the scope to track the motion of
the stars in only one movement around the central axis of the mount (the diurnal motion
is very significant — even at low powers an object can drift out of view in only a minute).
The Dobsonian opts for the much simpler fork alt-azimuth mount which sits parallel to
the ground. This means that tracking objects requires two motions instead of one. Not
much effort in and of itself, but it makes the automatic motor drives required for astro-
photography next to impossible. If you don’t think you’ll try photography, a Dobsonian
might just be the scope for you. The no frills Odyssey 8 and 10 inch scopes by Coulter
Optical have been highly regarded by some, and cost less than $300. Fancier Newtonian
scopes by Meade or Celestron in the same sizes are nearly three times as much.

The most popular serious telescopes made today are the Catadioptrics, respected for
their utter compactness. Known as a Schmidt-Cassegrain (SCT), an eight inch instrument
might be only 16 inches long, a third the length of a standard Newtonian of the same
diameter. The key is the folded optics as shown above. Light enters through a corrector
lens, reflects off of the primary to a secondary on the plate and back through a hole in the
primary. This places the eyepiece in the back of the scope, making for easy viewing. SCTs
come with a wide variety of lenses, camera mounts, tracking devices and computer con-
trols. The typical SCT is an eight inch model, going for around $1,000 to $1,300, although
sizes range from 3 1/2 inches to 14 inches. The most common manufacturers are the
Celestron, Meade and Bushnell.
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While you’re looking at all of these high powered instruments, don’t overlook the
richest field telescopes. These are deliberately lower power devices meant to give wider
sweeping views of the sky. Normal scopes are much too powerful to view the star clouds
of Sagittarius or the larger details of the Hyadies cluster (something like investigating the
Mona Lisa with an electron microscope). Richest field telescopes are very compact (the
Edmund Scientific Astroscan slips over the shoulder) and generally quite inexpensive.
Along the same line is a good pair of binoculars. While they don’t come close to the light
gathering power of an Astroscan, they can provide hours of enjoyment as you sweep
across the sky lying on your back munching popcorn and listening to Vivaldi tapes.

You may want to think about getting a used telescope. If it is a name brand, it has
already depreciated about as much as it will and, so, could easily be sold at virtually no
loss once you outgrow it or lose interest in the hobby. Prices will likely be 15% to 20% less
than new instruments.

Before buying, you should visit your local astronomy club. You can probably find out
how to get in touch with them through your local college observatory or astronomy
department. Astronomy clubs periodically have star parties in which the members and
any interested visitors spend all night observing at some remote site. From them, you
should be able to get hands on experience with every conceivable type and brand of
scope, as well as getting names of members who might have one for sale.

In addition to clubs, Sky and Telescope or Astronomy magazine provide excellent infor-
mation. Astronomy generally runs telescope buyer’s guides in the October issues which
should be available at your local library, or from Astro-Media (address in reference list).

If you are adventurous, you may want to try to make your own telescope. The as-
tronomy department of your local community college may offer telescope making classes
during the summer. The typical homemade instrument is either a six or eight inch reflec-
tor, and can offer a real sense of accomplishment that buying a scope never can.
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Appendix B

Location/Time Zones of Major Cities

Latitude Longitude Time
Name Deg Min Deg Min State/Country Zone
Accra 0533 N 015WwW Ghana, Africa 0
Albuquerque 3505N 106 38 W New Mexico, USA +7
Anchorage 61 10N 149 53 W Alaska, USA +10
Amsterdam 5221 N 454 E Netherlands, Europe -1
Ankara 3955N 3250E Turkey, Asia Minor -2
Asuncion 251585 5740 W Paraguay, S. Am. +4
Athens 3800 N 2344 E Greece, Europe -2
Atlanta 3345N 8423 W Georgia, USA +5
Baghdad 3320 N 44 26 E Iraq, Middle East -3
Baltimore 3917 N 76 37 W Maryland, USA +5
Bangkok 1344 N 10030 E Thailand, Asia -7
Beirut 3352 N 3530 E Lebanon, Mid East -2
Benghazi 3207 N 2005 E Libya, Africa -2
Berlin 5232 N 1325E W. Germany, Europe -1
Bern 46 57 N 726 E Switzerland, Europe -1
Bombay 1856 N 7251E India, Asia -5.5
Bonn 5044 N 706E W. Germany, Europe -1
Boston 42 20 N 7105 W Massachusetts, USA +5
Brussels 5050 N 421E Belgium, Europe -1
Bucharest 44 25N 26 07 E Romania, Europe -2
Buenos Aires 3440S 5830 W Argentina, S. Am. +3
Cairo 3003 N 3115E Egypt, Africa -2
Calgary 5103 N 114 05 W Alberta, Canada +7
Cape Town 3356 S 18 28 E South Africa, Africa -2
Caracas 1035N 66 56 W Venezuela, S. Am +4.5
Casablanca 3339N 735W Morocco, Africa 0
Chicago 4159 N 87 38 W Illinois, USA +6
Cincinnati 3906 N 8431W Ohio, USA +5
Cleveland 41 30 N 8141W Ohio, USA +5
Dakar 14 38 N 1727 W Senegal, Africa 0
Dallas 3247 N 96 48 W Texas, USA +6
Denver 3945 N 105 00 W Colorado, USA +7
Des Moines 45 35N 9335W lowa, USA +6
Detroit 42 20 N 8303 W Michigan, USA +5
Dublin 5320 N 615W Ireland, Europe 0
El Paso 3145N 106 29 W Texas, USA +7
Fairbanks 64 51 N 147 43 W Alaska, USA +10
Hanoi 2101 N 10552 E Vietnam, Asia -8
Havana 2307 N 8225W Cuba, Caribbean +5
Helsinki 6008 N 2500E Finland, Europe -2
Hiroshima 3423 N 13227 E Japan, Asia -9
Hong Kong 22 15N 114 11 E Asia -8
Honolulu 21 19N 157 52 W Hawaii, USA +10
Houston 2946 N 9522 W Texas, USA +6
Indianapolis 3946 N 86 09 W Indiana, USA +5
Istanbul 41 02 N 2857E Turkey, Asia Minor -3
Jerusalem 3147 N 3513E Israel, Middle East -2
Johannesburg 26 10N 2802 E South Africa, Africa -2
Kabul 3430N 69 10E Afghanistan, Asia -5
Kansas City 3905N 94 37 W Kansas/Missouri, USA +6
Karachi 2451 N 6702 E Pakistan, Asia -5
Kiev 5026 N 3031E USSR, Europe -3
Kyoto 3502 N 13545 E Japan, Asia -9
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Latitude Longitude Time
Name Deg Min Deg Min State/Country Zone
Lagos 6 27 N 328E Nigeria, Africa -1
Las Vegas 36 11 N 11508 W Nevada, USA +8
Leningrad 5955 N 3025E USSR, Europe -3
Lima 1206 S 7703 W Peru, S. America +5
Lisbon 3844 N 908 W Portugal, Europe 0
London 5130 N 010W England, Europe 0
Los Angeles 3400N 11815 W California, USA +8
Madrid 4025 N 343 W Spain, Europe -1
Manila 1437 N 12058 E Philippines -8
Marrakech 3149 N 800 W Morocco, Africa 0
Mecca 2126 N 3949 E Saudi Arabia, M.East -3
Melbourne 37458S 144 58 E Victoria, Australia -10
Mexico City 1925N 99 10 W Mexico +6
Miami 2545 N 80 15 W Florida, USA +5
Milwaukee 4302 N 87 55 W Wisconsin, USA +6
Minneapolis 4500 N 9315W Minnesota, USA +6
Montreal 4531 N 73 34 W Quebec, Canada +5
Moscow 5545 N 3742 E USSR, Europe -3
Nairobi 117S 3650 E Kenya, Africa -3
New Delhi 2837 N 77 13 E India, Asia -5.5
New Orleans 3000 N 90 03 W Louisiana, USA +6
New York 40 43 N 7401 W New York, USA +5
Oklahoma City 3528 N 97 32 W Oklahoma, USA +6
Omaha 41 15N 96 00 W Nebraska, USA +6
Oslo 5956 N 1045 E Norway, Europe -1
Paris 48 52 N 220E France, Europe -1
Perth 31588 11549 E West Australia -8
Philadelphia 4000 N 7510 W Pennsylvania, USA +5
Phoenix 3330N 112 03 W Arizona, USA +7
Pittsburgh 4026 N 80 00 W Pennsylvania, USA +5
Prague 5006 N 14 26 E Czechoslovakia, Eur. -1
Quebec 46 50 N 71 15W Quebec, Canada +5
Rangoon 16 46 N 96 10 E Burma, Asia -6.5
Reykjavik 64 09 N 2158 W Iceland +1
Rio de Janeiro 22538 4317 W Brazil, S. America +3
Rome 4153 N 1230 E Italy, Europe -1
Saigon 1046 N 106 43 E Vietnam, Asia -7
Salt Lake City 4045 N 11155 W Utah, USA +7
San Luis Obispo 3510N 13050 W California, USA +8
San Francisco 3745 N 122 27 W California, USA +8
San Juan 1829 N 66 08 W Puerto Rico, USA +4
Santiago 3330S 7040 W Chile, S. America +4
Seattle 47 36 N 12220 W Washington, USA +8
Seoul 3730 N 12700 E Korea, Asia -9
Singapore 117N 10551 E Malacca, Asia -7.5
Stockholm 5920 N 1805E Sweden, Europe -1
Sydney 33558 151 10E New S. Wales, Aus. -10
Taipei 2505 N 12132 E Taiwan, Asia -8
Tananarive 1852 S 47 30 E Madagascar -3
Thule 7730 N 6929 W Greenland +4
Timbuktu 16 49 N 259E Mali, Africa 0
Tokyo 3540 N 13945 E Japan, Asia -9
Toronto 43 39 N 7923 W Ontario, Canada +5
Tripoli 3258 N 1312E Libya, Africa -2
Tunis 36 50 N 10 13 E Tunisia, Africa -1
Vancouver 49 13 N 123 06 W Br. Columbia, Canada +8
Vienna 48 13 N 16 20 E Austria, Europe -1
Vladivostok 4309 N 13153 E USSR, Asia -10
Warsaw 52 15N 2100E Poland, Europe -1
Washington, DC 3855 N 7700 W USA +5
Wellington 41 17 S 174 47 E New Zealand -12
Winnipeg 4953 N 97 10 W Manitoba, Canada +6
Zanzibar 610S 3911E Tanzania, Africa -3
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Appendix C

Messier Catalogue

MESS  NGC CON TYPE R.A. DECL MAG DIST* COMMENTS
M1 1952 Tau PINeb 05315 +2159 8.2 6K Crab Nebula

M 2 7089 Agr GIbClI 2130.9 -0103 6.3 50K

M3 5272 CVn GIbCI 1339.9 +2838 6.3 30K

M4 6121 Sco GIbCl  1620.6 -2624 6.4 10K

M 5 5904 Ser GIbClI 1516.0 +0216 6.2 30K

M 6 6405 Sco OpClI 1736.8 -3211 53 2K

M7 6475 Sco OpClI 1750.7 -3448 41 K

M 8 6523 Sgr DfNeb 1801.6 -2420 6.0 6.5K Lagoon Nebula
M 9 6333 Oph GIbCl 1716.2 -1828 7.3 25K

M 10 6254 Oph GIbCl  1654.S -0402 6.7 16K

M 11 6705 Sct OpCI 1848.4 -0620 6.3 6K

M 12 6218 Oph GIbCl 1644.6 -0152 6.6 16K

M 13 6205 Her GIbClI 1639.9 +3633 5.7 25K

M 14 6402 Oph GIbCl 1735.0 -0313 7.7 23K

M 15 7078 Peg GIbClI 2127.6 +1157 6.0 40K

M 16 6611 Ser OpCI 1816.0 -1348 6.4 7K nebula & cluster
M 17 6618 Sgr DfNeb 1818.0 -1612 75 5K Omega Neb & cluster
M 18 6613 Sgr OpCl 1817.0 -1709 7.5 6K

M19 6273 Oph GIbCl 1659.5 -2611 6.6 20K

M 20 6514 Sgr DfNeb 1758.9 -2302 9.0 22K Trifid Nebula

M 21 6531 Sgr OpCl 1801.8 -2230 6.5 3K

M 22 6656 Sgr GIbCl 1833.3 -2358 5.9 10K

M 23 6494 Sgr OpCl 1754.0 -1901 6.9 45K

M 24 6603 Sgr OpCI 1815.5 -1827 4.6 10K star cloud

M 25 IC4725  Sgr OpClI 1828.8 -1917 6.5 2K open cloud

M 26 6694 Sct OpCI 1842.5 -0927 9.3 5K

M 27 6853 Vul PINeb 19574 +2235 7.6 1250 Dumbbell Nebula
M 28 6626 Sgr GIbCl 18215 -2454 7.3 15K

M29 6913 Cyg OpCI 2022.2 +3821 7.1 7.2K

M 30 7099 Cap GIbCl 21375 -2325 8.4 40K

M 31 224 And SpGal 0040.0 +4100 4.8 2,200K Andromeda Galaxy
M 32 221 And ElGal 0040.0 +4036 8.7 2,200K satellite of M31
M 33 598 Tri SpGal 0131.1 +3024 6.7 2,300K Sc

M 34 1039 Per OpCI 0238.8 +4234 5,5 1,400

M35 2168 Gem OpCl 0605.7 +2420 5.3 2,800

M 36 1960 Aur OpCl 0532.0 +3407 6.3 4,100

M 37 2099 Aur OpCI 0549.0 +3233 6.2 4,600

M 38 1912 Aur OpCI 0525.3 +3548 7.4 4,200

M 39 7092 Cyg OpCl 2130.4 +4813 5.2 900

M40 WNC4 UMa DS 1220.0 +5822 9.1 double star

M 41 2287 CMa OpCI 06449 -2042 4.6 2,400

M 42 1976 Ori DfNeb 0532.9 -0525 40 1K Great Orion Nebula
M 43 1982 Ori DfNeb 0533.1 -0518 9.1 IK part of Great Orion Neb
M 44 2632 Cnc OpCI 0837.5 +1952 3.7 500 Praesepe

M 45 Tau OpCI 0343.9 +2358 1.6 400 The Pleiades

M 46 2437 Pup OpClI 0739.6 -1442 6.0 5,400

M 47 2422 Pup OpCl 0734.3 -1422 45 1,600

M 48 2548 Hya OpCl 0811.2 -0538 5.3 1,500

M 49 4472 Vir EIGal 1227.3 +0816 8.5  70000K

M50 2323 Mon OpCI 0700.5 -0816 6.3 3K

M 51 5194 CVn SpGal 1327.8 +4727 8.1 15000K Whirlpool Galaxy
M 52 7654 Cas OpCl 2322.0 +6120 7.3 7K

M 53 5024 Com GIbCI  1310.5 +1826 7.6 60K

M54 6715 Sgr GIbClI  1852.0 -3032 8.0 50K
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MESS  NGC CON TYPE R.A. DECL MAG DIST*  COMMENTS

M55 6809 Sgr GIbClI  1936.9 -3103 0 20K

M56 6779 Lyr GIbCI 1914.6 +3005 .2 40K

M 57 6720 Lyr PINeb 1851.7 +3258 .3 4,100 Ring Nebula

M 58 4579 Vir SpGal 1235.1 +1205 .2 70000K Sb-barred spiral galaxy
M59 4621 Vir EIGal 1239.5 +1155 6 70000K

M 60 4649 Vir ElGal 12411 +1149 .9  70000K

M 61 4303 Vir SpGal 1219.4 +0445 0.1 70000K Sc-barred spiral galaxy
M 62 6266 Oph GIbCI  1658.1 -3003 6 26K

M 63 5055 CVn SpGal 13135 +4217 5 14500K Sb

M 64 4826 Com SpGal 1254.3 +2157 8 12000K Sb

M 65 3623 Leo SpGal 1116.3 +1323 3 35000K Sa

M 66 3627 Leo SpGal 1117.6 +1317 .2 35000K Sb

M 67 2682 Cnc OpCI 0848.3 +1200 .1 2,250 Alternate decl: 0847.8
M 68 4590 Hya GIbCI  1236.8 -2629 .0 40K

M 69 6637 Sgr GIbCI  1828.1 -3223 9 25K

M70 6681 Sgr GIbCI  1840.0 -3221 .6 65K

M 71 6838 Sge GIbCl 19514 +1839 0 8,500

M 72 6981 Agr GIbCI  2050.7 -1244 8 60K

M 73 6994 Aqr OpCI 2056.4 -1250 0 cluster of 4 stars

M74 628 Psc SpGal 0134.0 +1532 0.2 20000K Sc

M 75 6864 Sgr GIbCI  2003.2 -2204 .0 100K

M 76 650 Per PINeb 0138.8 +5119 0.2 3,400

M 77 1068 Cet SpGal 0240.1 -0014 9 30000K Sb-Seyfert galaxy

M 78 2068 Ori DfNeb 0544.2 +0002 0.3 1,600 emission nebula

M 79 1904 Lep GIbCI 0522.2 -2434 4 54K

M 80 6093 Sco GIbCl 1614.1 -2252 .7 36K

M 81 3031 UMa SpGal 09515 +6918 .9 7000K Sb
8 7000K

M 82 6341 Her GIbCI 1715.6 +4312 1 28K

M 83 5236 Hya SpGal 1334.3 -2937 0.1 8000K Sc

5
8
9
9
9
8
1
6
9
8
9
8
6
8
8
9
9
9
9
1
8
1
8
1
8
I
I
M 82 3034 UMa IrGal 0951.9 +6956 8.
6
1
9
9
9
9
1
9
1
9
6
7
1
9
1
1
1
1
9
9
7
8
9
8
9
1
1
9

M 84 4374 Vir ElGal 1222.6 +1310 3  70000K

M85 4382 Com EIGal 1222.8 +1828 .3 70000K SO

M 86 4406 Vir ElGal 1223.7 +1313 .7 70000K giant elliptical galaxy
M87 4486 Vir ElGal 1228.3 +1240 .2 70000K giant elliptical galaxy
M88 4501 Com SpGal 1229.5 +1442 0.2 40000K Sb

M89 4552 Vir ElGal 12331 +1250 .5 70000K

M90 4569 Vir SpGal 1234.3 +1326 0.0 70000K Sb

M91 4548 Com SpGal 1232.9 +1446 .5 40000K barred spiral galaxy
M93 2447 Pup OpCl 0742.4 -2345 .0 36K

M94 4736 CVn SpGal 1248.6 +4123 .9 14500K Sb

M95 3351 Leo SpGal 1041.3 +1158 0.4 25000K barred spiral galaxy
M96 3368 Leo SpGal 1044.2 +1205 .1 25000K Sa

M97 3587 UMa PINeb 112.0 +5518 2.0 2,600 Owl Nebula

M98 4192 Com SpGal 1211.3 +1511 1.7 70000K Sb

M99 4254 Com SpGal 1216.3 +1442 0.1 70000K Sc

M100 4321 Com SpGal 1220.4 +1606 0.6 70000K Sc

M101 5457 UMa SpGal 1401.4 +5435 .6 15000K Sc-same as M102
M102 5457 UMa SpGal 1401.4 +5435 .6 15000K Sc-same as M101
M103 581 Cas OpClI 0129.9 +6027 4 8K

M104 4594 Vir SpGal 1237.3 -1121 .7 50000K Sombrero Galaxy
M105 3379 Leo ElGal 1045.2 +1251 .2 25000K

M106 4258 CVn SpGal 1216.5 +4735 .6 25000K Sb

M107 6171 Oph CIbClI  1629.7 -1257 2 10K

M108 3556 UMa SpGal 1108.7 +5557 0.7 25000K Sb

M109 3992 UMa  SpGal 1155.0 +5339 0.8 25000K barred spiral galxy
MIIO 205 And EIGal 0037.6 +4125 .4 2200K satellite of M31

OpCl = Open Cluster
GIbCl = Globular Cluster
PINeb = Planetary Nebula
DfNeb = Diffuse Nebula
SpGal = Spiral Galaxy
ElGal = Elliptical Galaxy
IrGal = Irregular Galaxy

1. Distance is measured in light years
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Appendix D
Supplied NGC Catalogue

NGC CON CONST R.A. DECL MAG REMARKS

40 Cas PINeb 0010.2 +7215 10.2 central star mag:11.4
55 Scl SpGal 0012.5 -3930

104 Tuc GIbCI 00219 -7221 4.5

129 Cas OpCI 0027.6  +5957 10.0 number:50
133 Cas OpCI 0028.4 +6304 9.1 number:50
134 Scl SpGal 00279 -3332

157 Cet SpGal 0032.3 -0840 11.2

185 Cas ElGal 0036.1 +4804 11.7

188 Cep OpCI 0039.4  +8503 9.3 number:70
205 And ElGal 0037.6 +4125 9.4

225 Cas OpCl 0040.5 +6131 9.1 number:20
246 Cet PINeb 0044.6 -1209 8.5 central star mag:11.3
247 Cet SpGal 0044.6 -2101

253 Scl SpGal 0045.1 -2534 8.9

278 Cas ElGal 0049.2 +4718 11.3

281 Cas DfNeb 0050.4  +5919 8.6 spectrum:05e
288 Scl GIbCI 0050.2 -2652

300 Scl SpGal 0052.6 -3758

404 And ElGal 0106.6 +3527 10.7

457 Cas OpCI 0115.9 +5804 7.5 number:100
488 Psc SpGal 0119.1  +0500 111

524 Psc ElGal 0122.1 +0916 11.1

584 Cet ElGal 0128.8 -0707 10.8

596 Cet ElGal 0130.3 -0717 115

613 Scl SpGal 0132.0 -2940 10.2

659 Cas OpCl 0140.8 +6028 9.8 number:30
663 Cas OpCI 0142.6 +6101 7.1 number:80
720 Cet ElGal 0150.6 +1359 10.5

752 And OpCl 0154.7 +3725 7.0 number:70
772 Ari SpGal 0156.6 +1846 10.9

779 Cet SpGal 0157.2 -0612 11.3

821 Ari ElGal 0205.6 +1046 11.2

869 Per OpCI 0215.5 +5655 4.4 number:350-half dbl clus
884 Per OpCl 0218.9 +5653 4.7 number:300-half dbl clus
925 Tri SpGal 0224.3 +3322

936 Cet SpGat 0225.1 -0122 10.7

1022 Cet SpGal 0236.1 -0653 11.2

1023 Per ElGal 0237.2 +3852

1052 Cet ElGal 0238.6 -0828 11.2

1084 En SpGal 0243.5 -0747 11.0

1097 For SpGal 0244.3 -3029

1232 Eri SpGal 0307.5 -2046

1245 Per OpCI 0311.2 +4703 6.9 number:40
1261 Hor GIbC1 0310.9 -552S

1316 For SpGal 0320.7 -372S

1332 Eri ElGal 0324.1 -2131 10.4

1342 Per OpCI 0328.4  +3709 7.1 number:40
136S For SpGal 0331.8 -3618

1395 Eri EIGal 0336.3 -2311

1398 For SpGal 0336.8 -2630

1399 For ElGal 0336.6 -3537

1407 Eri ElGal 0337.9 -1844  10.6

1499 Pcr DfNeb 0400.1 +3617 4.1 California
1501 Cam PINeb 0402.6 +6047 13.3 central star mag:13.4
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NGC CON CONST R.A. DECL MAG REMARKS

1502 Cam OpCl 0403.0 +6211 5.3 number:15

1514 Tau PINeb 0406.1 +3038 10.8 central star mag:9.7
1528 Per OpCI 0411.4  +5107 6.2 number:80

1532 Eri SpGal 0410.2 -3300 edge—on barred spiral
1535 Eri PINcb 0412.1 -1252 9.3 central star mag:11.8
1545 Per OpCI 0417.1  +5008 8.0 number:25

1554 Tau DfNeb 0419.9 +1925 spectrum:Gpe/Hind’s Var.
1647 Tau OpCI 0443.2  +1859 6.3 number:30

1664 Aur OpCI 0447.4  +4337 7.5 number:40

1700 Eri EIGal 0454.4  -0456 11.9

1746 Tau OpCI 0500.6 +2344 6.0 number:60

1792 Col SpGal 0503.5 -3804

1817 Tau OpCI 0509.2 +1638 7.9 number:10

1851 Col GIbC1 0512.4 -4005 8.1

1857 Aur OpCI 0516.6 +3918 8.6 number:45

1893 Aur OpCI 0522.4  +3321 8.0 number:20

1907 Aur OpCI 0524.7 +3517 9.9 number:40

1977 Ori DfNeb 0533.0 -0454 4.6

1990 Ori DfNeb 0533.7 -0114 1.8 spcctrum:BOe

2023 Ori DfNeb 0539.2 -0215 7.9 spectrum:B2

2024 Ori DfNeb 0539.4 -0152 1.9 spectrum:BOne
2064 Ori DfNeb 0543.8 -0002 9.9

2112 Ori OpCI 0551.3 +0023 8.6 number:90

2141 Ori OpCI 0600.3 +1026 10.8 number:100

2158 Gem OpCl 0604.3 +2406 12.5 number:40

2169 Ori OpCI 0605.7 +1358 6.4 number:18

2174 Ori DfNeb 0606.7 +2031 7.4 spectrum:06e

2175 Ori OpCI 0606.8 +2020 6.7 number:15

2194 Ori OpCl 0611.0 +1250 9.2 number:100

2215 Mon OpCI 0618.4 -0716 8.6 number:20

2237 Mon DfNeb 0629.6  +0440 Rosetta

2244 Mon OpCI 0629.7 +0454 6.2 number:16

2261 Mon DfNeb 0636.4 +0846 8.0 spectrum:Bp/ Hubble’s Var
2264 Mon OpCI 0638.4  +0956 4.7 number:20

2264 Mon DfNeb 0638.2 +0957 4.7 spectr:07n-Cone Nebula
2266 Gem OpCI 0640.5 +2702 9.8 number:30

2281 Aur OpCl 0645.8 +4107 6.7 number:30

2286 Mon OpCI 0645.1 -0307 8.0 number:50

2298 Pup GIbC1 0647.2 -3557 10.5

2301 Mon OpCI 0649.2 +0031 5.8 number:60

2324 Mon OpCl 0700.4 +0108 8.8 number:30

2335 Mon OpCI 0704.2 -1000 9.1 number:35

2353 Mon OpCI 0712.3 -1012 5.3 number:25

2354 CMa OpCI 0712.2 -2538 8.9 number:60

2360 CMa OpCI 0715.4 -1533 9.5 number:50

2371 Gem PINeb 0722.4  +2935 13.0 central star mag:13.3
2392 Gem PINeb 0726.2 +2101 8.3 central star mag:10.5 Eskimo
2395 Gem OpCI 07243 +1341 9.4

2403 Cam SpGal 0732.0 +6543 8.9

2419 Lyn GIbC1 0734.8 +3900 115

2420 Gem OpCI 0735.4 +2141 10.2 number:20

2421 Pup OpCI 0734.1 -2030 9.4 number:50

2422 Pup OpCl 0734.3 -1422 4.5 number:50

2423 Pup OpCI 0734.8 -1345 6.9 number:60

2438 Pup PINeb 0739.6 -1436 11.3 central star mag:16.8
2439 Pup OpCI 0738.9 -3132 7.1 number:50

2451 Pup OpCl 0743.6 -3751 3.6 number:50

2477 Pup OpCI 0750.5 -3825 5.7 number:300

2482 Pup OpCI 0752.8 -2410 8.7 number:50

2489 Pup OpCI 0756.2 —-29S6 9.4 number:30

2506 Mon OpCl 0757.7 -1029 115 number:50

2509 Pup OpCI 0758.S -18S6 9.3 number:40

2516 Car OpCI 0759.7 -6044 3.0 number:80

2539 Pup OpCI 0808.4 -1241 8.2 number:150

2547 Vel OpCl 0808.9 -4907 51 number:50
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NGC CON CONST R.A. DECL MAG REMARKS
2548 Hya OpClI 0811.2 -0538 5.3 number:80
2567 Pup OpCI 0816.6 -3029 8.3 number:50
2571 Pup OpCI 0816.9 -2935 7.5 number:25
2587 Pup OpCI 0821.3 -2920 9.1 number:30
2610 Hya PINeb 0831.2 -1558 13.6 central star mag:15.7
2627 Pyx OpCI 0835.2 -2946 8.3 number:40
2655 Cam SpGal 0849.4  +7825 10.7

2658 Pyx OpCI 0841.4 -3229 9.2 number:30
2681 Lyn SpGal 0850.0 +5131 10.4

2683 Lyn SpGal 0849.6 +3338 9.6

2742 UMa SpGal 0903.7 +6041 11.2

2768 UMa EIGal 0907.8 +6016 10.5

2775 Cnc SpGal 0907.7 +0715 10.7

2787 UMa SpGal 09149 +6925 10.9

2841 UMa SpGal 0918.6 +5112 9.3

2859 LMi SpGal 0921.3 +3344 10.7

2903 Leo SpGal 0929.3 +2144 9.1

2950 UMa SpGal 0939.1  +5905 10.9

2964 Leo SpGal 0940.0 +3205 11.0

2976 UMa SpGal 0943.2 +6808 114

2985 UMa SpGal 0946.0 +7231 10.6

2997 Ant SpGal 0943.5 -3059

3003 LMi SpGal 0945.6  +3339 12.7 edge-on
3021 LMi SpGal 0948.0 +3347 11.7

3077 UMa ElGal 0959.4 +6858 10.9

3079 UMa SpGal 0958.6  +5557 11.2

3115 Sex ElGal 1002.8 -0728 9.3 Spindle Nebula
3132 Vel PINeb 1004.9 -4011 8.2 central starmag:10.6
3147 Dra SpGal 1012.8 +7339 10.9

3184 UMa SpGal 1015.2 +4140 12.1

3201 Vel GIbC1 1015.5 -4609

3242 Hya PINeb 1022.4 -1823 9.0 central starmag:11.4-Eye Neb.
3310 UMa RGal 1035.7 +5346 10.1

3344 LMi SpGal 1040.7 +2511 10.4

3372 Car DfNeb 1043.1 -5925 5.0 spcctrum:Pec—Keyhole Neb
3377 Leo EIGal 10451  +1415 10.5

3384 Leo ElGal 1045.7 +1254 10.2

3412 Leo ElGal 1048.3 +1341 10.4

3486 LMi SpGal 1057.8 +2915 11.2

3504 LMi SpGal 1100.5 +2815 10.9

3511 Crt SpGal 1100.8 +2250

3521 Leo SpGal 1103.2 +0014 9.5

3585 Hya ElGal 11109 -2629

3607 Leo EIGal 1114.3 +1820 9.6

3621 Hya SpGal 11159 -3232

3626 Leo SpGal 11175 +1838 10.5

3628 Leo SpGal 1117.7 +1353 10.9 edge-on
3631 UMa SpGal 1118.3 +5328 11.2

3646 Leo SpGal 1119.2 +2027

3675 UMa SpGal 11235 +4352 10.6

3810 Leo SpGal 1138.4 +1145 10.8

3877 UMa SpGal 11435 +4746 10.9

3893 UMa SpGal 1146.1  +4900 11.3

3923 Hya ElGal 11485 -2833

3941 UMa SpGal 1150.3 +3716 9.8

3945 UMa SpGal 1150.6  +6057 10.8

3949 UMa SpGal 1151.1 +4808 11.0

3953 UMa SpGal 1151.2 +5237 10.7

3962 Crt ElGal 1152.2 -1342 11.3

4026 UMa EIGal 1156.9 +5114 10.7

4030 Vir SpGal 1157.8 -0049 11.0

4036 UMa ElGal 11589 +6210 10.7

4038 Crv SpGal 1159.3 -1835

4041 UMa SpGal 1159.7 +6225 11.0

4051 DMa SpGal 1200.6  +4448 11.0
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NGC CON CONST R.A. DECL MAG REMARKS
4088 UMa SpGal 1203.0 +5049 10.9

4105 Hya ElGal 1204.1 -2930

4111 UMa ElGal 12045 +4321 9.7

4125 Dra ElGal 1205.7 +6527 10.2

4143 CVn EIGal 1207.1  +4249 11.0

4214 CVn IrGal 1213.0 +3636 10.3

4216 Vir SpGal 1213.4 +1325 10.4

4244 CVn SpGal 1215.0 +3805 11.9

4251 Com SpGal 1215.7 +2827 10.2

4261 Vir ElGal 1216.8 +0606 10.3

4274 Com SpGal 1217.4  +2953 10.8

4278 Com EIGal 1217.7 +2934 10.3

4314 Com SpGal 1220.0 +3010 10.8

4361 Crv PINeb 12219 -1829 10.8 central star mag:12.8
4365 Vir ElGal 1222.0 +0736 11.1

4395 CVn SpGal 1223.4  +3349

4414 Com SpGal 12240 +3130 9.7

4429 Vir SpGal 12249 +1123 11.2

4438 Vir SpGal 1225.3 +1317 10.8

4449 CVn IrGal 1225.8 +4422 9.2

4450 Com SpGal 12259 +1721 10.0

4459 Com ElGal 12265 +1514 10.9

4465 Vir ElGal 12252 +1321 10.3

4473 Com EIGal 1227.3 +1342 10.1

4477 Vir SpGal 12276 +1355 10.7

4490 CVn SpGal 1228.3  +4155 9.7

4494 Com ElGal 1228.9 +2603 9.6

4526 Vir EIGal 12316 +0758 10.9

4535 Vir SpGal 1231.8 +0828

4536 Vir SpGal 1231.9 +0228 11.9

4546 Vir ElGal 12329 -0331 10.0

4565 Com SpGal 1233.9 +2616 10.2 edge-on
4631 CVn SpGal 1239.8 +3249 9.3 edge-on
4636 Vir ElGal 1240.3 +0257 10.4

4643 Vir SpGal 1240.8 +0215 10.6

4656 CVn SpGal 12416 +3226 11.2

4660 Vir ElGal 1242.0 +1126 10.9

4666 Vir SpGal 1242.6 -0012 11.4

4697 Vir ElGal 1246.0 -0532 9.6

4699 Vir SpGal 1246.5 -0824 9.3

4725 Com SpGal 1248.1 +2546 8.9

4753 Vir SpGal 1249.8 -0055 10.8

4754 Vir ElGal 1249.7 +1135 10.5

4762 Vir SpGal 1250.4 +1131 11.0

4775 Vir SpGal 1251.1 -0621

4781 Vir SpGal 1251.8 -1016 11.2

4800 CVn SpGal 1252.4  +4648 111

4826 Vir SpGal 1254.3  +2157 8.8

4856 Vir ElGal 1256.7 -1446

4900 Vir SpGal 1258.2 +0246 11.3

4945 Cen SpGal 1302.4 -4901

4958 Vir EIGal 1303.1 -0745 10.9

4995 Vir SpGal 1307.0 -0734 11.2

5005 CVn SpGal 1308.5 +3719 9.8

5033 CVn SpGal 1311.2 +3651 10.3

5044 Vir EIGal 1312.8 -1608 11.2

5053 Com GIbClI 13139 +1757

5068 Vir SpGal 1316.2 -2047

5102 Cen ElGal 1319.1 -3623

5128 Cen IrGal 1322.4 4245 7.2 Centaurus-A
5139 Cen GIbClI 1323.8 -4703 3.7 Omega Centauri
5195 CVn IrGal 1327.9 +4731 8.4 Pec—companion to MSI
5248 Boo SpGal 1335.1 +0908 11.3

5322 UMa EIGal 13476 +6026 10.0

5363 Vir ElGal 1353.6 +0529 10.7
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5377 CVn SpGal 1354.3  +4727 11.2

5427 Vir SpGal 1400.8 -0547

5466 Boo GIbClI 1403.2 +2846 8.5

5566 Vir SpGal 1417.8 +0411 10.4

5746 Vir SpGal 1442.3 +0210 10.1

5775 Vir SpGal 14515 +0345

5824 Lup GIbClI 1500.9 -3253 10.1

5846 Vir ElGal 1504.0 +0148 10.5 EO

5873 Lup PINeb 1509.4 -3754 9.7

5897 Lib GIbCI 15145 -2050 10.9

5982 Dra ElGal 1537.6 +5932 10.9

5986 Lup GIbCI 1542.8 -3737 8.7

6058 Her PINeb 1602.8 +4049 12.3 central star mag:13.4
6139 Sco GIbCI 1524.3 -3844

6144 Sco GIbClI 1624.2 -2556

6210 Oph PINeb 16425 +2353 9.7 central star mag:12.5
6268 Sco OpCI 1658.6 -3939 9.5 number:30

6281 Sco OpCI 1701.4 -3749 8.6 number:25

6284 Oph GIbClI 17015 -2441 9.7

6293 Oph GIbCI 1707.1 -2630 8.4

6304 Oph GIbCI 1711.4 -2924 9.8

6316 Oph GIbCI 1713.4 -2805

6352 Ara GIbClI 1721.6 -4826

6356 Oph GIbCI 1720.7 -1746 8.7

6369 Oph PINeb 1726.3 -2344 9.9 central star mag:16.6
6383 Sco OpCI 1731.4 -3233 5.5 number r:12

6388 Sco GIbClI 1732.6 4443

6397 Ara GIbCI 1736.8 5339

6400 Sco OpCl 1736.1 -3655 8.9 number:25

6441 Sco C,IbCl 1746.8 -3702

6445 Sgr PINeb 1746.3 -2000 13.2 central star mag:19.1
6503 Dra SpGal 1549.9 +7010 9.6

6528 Sgr GIbClI 1801.6 -3004

6541 CrA GIbClI 1804.4 -4344

6543 Dra PINeb 1758.8 +6638 8.8 central star mag:ll.|
6572 Oph PINeb 1809.7 +0650 9.6 central star mag:12.0
6584 Tel GIbClI 1814.6 5214

6620 Sgr PINeb 1818.7 -2652 15.0 central star mag:15.8
6624 Sgr GIbClI 1820.5 -3023

6629 Sgr PINeb 1822.7 -2314 10.6 central star mag:13.6
6638 Sgr GIbClI 18279 2532 9.8

6652 Sgr GIbClI 18325 -3302

6664 Sct OpCI 1734.0 -0816 8.9 number:25

6709 Aql OpCI 1749.1 +1017 8.1 number:40

6712 Sct GIbClI 1850.3 0847 8.9

6723 Sgr GIbClI 1856.2 -3642

6755 Aql OpCI 1905.3 +0409 8.3 number:50

6760 Aql GIbCI 1908.6  +0057 10.7

6790 Aql PINeb 19204 +0124 11.4 central star mag:18.4
6803 Aql PINeb 1928.9 +0958 114 central star mag:14.1
6811 Cyg OpCI 1936.7 +4627 9.2 number:50

6818 Sgr PINeb 19411  -1417 9.9 central starmag:15.0
6819 Cyg OpCl 1939.6 +4006 10.1 number:150

6822 Sgr TrGal 19421 -1453 10.0

6826 Cyg PINeb 1943.4 +5024 8.8 central starmag:10.8
6830 Vul OpCI 1948.9 +2258 9.0 number:20

6842 Vul PINeb 1953.0 +2909 13.6 central star mag:14.1
6871 Cyg OpCI 2004.0 +3538 5.6 number:60

6879 Sge PINeb 2008.1 +1646 12.1 central star mag:15.2
6885 Vul OpCI 2009.9 +2620 9.1 number:35

6886 Sge PINeb 2010.5 +1950 12.2 central star mag:16.6
6891 Aql PINeb 2012.8 +1235 114 central star mag:11.6
6894 Cyg PINeb 2014.4  +3025 14.4 central star mag:17.0
6905 Del PINeb 2020.2  +1957 11.9 central star mag:14.2
6910 Cyg OpCl 2021.3  +4037 6.7 number:40
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6934 Del GIbCl 2031.7 +0714 9.2

6939 Cep OpCI 2030.4 +6028 10.0 number:80

6940 wul OpCI 20325 +2808 8.2 number:100

6946 Cep SpGal 2033.9 +5958

6960 Cyg DfNeb 2043.6  +3032 8.0 Cirrus, Veil Nebula

7000 Cyg DfNeb 2057.0 +4408 1.3 spectrum:cA2e/ No. America
7006 Del GIbCl 2059.1 +1600 10.3

7009 Aqr PINeb 2101.4 -1134 8.4 central star mag:12-Saturn Neb
7023 Cep DfNeb 2101.4  +6758 7.2 spectrum B5a

7026 Cyg PINeb 2104.6  +4739 12.7 central star mag:14.8

7027 Cyg PINeb 2105.1 +4202 10.4 central star mag:17.1

7086 Cyg OpCI 2129.8 +5122 9.4 number:50

7128 Cyg OpCI 2142.4  +5329 11.2 number:20

7209 Lac OpCI 2201.8 +4616 7.6 number:50

7217 Peg SpGal 2205.6 +3107

7243 Lac OpCI 2213.2  +4938 7.4 number:40

7293 Aqr PINeb 2227.0 -2106 6.5 central star mag:13—-Helix Neb.
7331 Peg SpGal 22347 43410 9.7

7448 Peg SpGal 2257.6  +1543 11.2

7541 Psc SpGal 2312.2  +0415 12.1

7635 Cas PINeb 2318.5 +6054 8.5 central star mag:8.5

7662 And PINeb 23235 +4214 8.9 central star mag:12.5

7723 Aqr SpGal 2336.4 -1314 11.1

7727 Agr SpGal 2337.3 -1234 10.7

7789 Cas OpCl 22545 +5626 9.6 number:200

7790 Cas OpCI 22545 +6056 7.1 number:25

7793 Scl SpGal 2355.3 -3251 9.7

OpCl = Open Cluster
GIbClI = Globular Cluster
PINeb = Planetary Nebula
DfNeb = Diffuse Nebula
SpGal = Spiral Galaxy
ElGal = Elliptical Galaxy
IrGal = Irregular Galaxy
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Appendix E

Planetary Data

Mean
distance
from Period
Sunin revolution Inclination Period of
millions around the  to ecliptic Diameter rotation on
of miles Sun ° ! (miles) axis
Mercury 36.0 87.9d 7 0 3,100 58.66d
Venus 67.2 224.7d 3 24 7,700 243.2d
Earth 93.0 365.2d 0O 0 7,927 23h56m
Mars 141.7 .8y 1 51 4,200 24h37m
Jupiter 483.8 118y 1 18 88,700 9h50m
Saturn 887.1 29.4y 2 29 75,100 16h39m
Uranus 1783.9 84.0y 0 46 32,000 12.8h
Neptune 2795.4 164.7y 1 46 27,700 15.8h
Pluto 3675.2 248.4y 17 9 1,500(?) 6d8h(?)
Inclination Mean
of equator Surface Number velocity Max.
to orbit gravity Density of in orbit stellar
plane (°) (Earth=1.0) (H,0=1) satellites (mi/sec) mag.
Mercury 7 0.28 3.8 0 30 -1.2
Venus — 0.85 5.1 0 22 -4.4
Earth 23.4 1.00 55 1 18.5 —
Mars 25.2 0.38 4.0 2 15 -2.8
Jupiter 3.1 2.6 1.3 16 8 -2.5
Saturn 26.8 1.2 0.7 17 6 -0.4
Uranus 98.0 1.1 1.3 15 4 +5.7
Neptune 29.0 14 2.2 2 3 +7.8
Pluto — >1.0 1 <3 +14
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Appendix F

Major Visual Meteor Showers

Normal
Position at Single Duration to
Max Observer  1/4 Strength
R.A. Dec Hourly of Max.
Shower Date! (hr)  (min) ) Rate (days)
Quadrantids Jan. 4 15 28 +50 40 1.1
Lyrids Apr. 22 18 16 +34 15 2.3
T Aquarids May 5 22 22 -01 20 3
s. d Aquarids July 29 22 36 -17 20 7
Perseids Aug. 12 03 04 +58 50 4.5
Orionids Oct. 21 06 20 +15 25 2
S. Taurids Nov. 3 03 32 +14 15 —
Leonids Nov. 18 10 08 +22 15 —
Geminids Dec. 14 07 32 +32 50 2.5
Ursids Dec. 23 14 28 +78 15 2.2

1. Peak dates may vary 1 day from year to year. Call your local planetarium or university astronomy
department for more timely information.
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Appendix G

Supplementary Reading

“Scientific Reports on Viking Missions (Mars),” Science, Vol. 193, No. 4255, August 1976,
pp. 75-815; Vol. 194, No. 4260, October1976, pp. 57-110; Vol. 194, No. 4271, Decem-
ber 1976, pp. 1274-1353.

“Scientific Reports on Voyager Missions (Jupiter),” Science, Vol. 204, No. 4396, June 1979,
pp. 945-1008; Vol. 206, No. 4421, pp. 925-996.

Abell, George O., Exploration of the Universe, New York, Holt, Rienhart and Winston, 3rd
Ed. 1975.

Anon., The Earth and Man, New York, Rand McNally & Company, 1972.

Anon., Space Exploration (Merit Badge Library #3354), Boys Scouts of America, Scout Equip-
ment Center 289 Park Avenue South, New York City.

Ashbrook, Joseph, “Astronomical Scrapbook: Some Bunchings of Planets,” Sky and Tele-
scope, November 1973, pp. 300 & 305.

Asimov, Issac, Asimov on Astronomy, New York, Doubleday, 1975.
Asimov, Issac, Exploring the Earth and the Cosmos, New York, Crown Publishers, 1982.

Beatty, J. Kelly, Brian O’Leary, Andrew Chaikin (Ed), The New Solar System, 2nd Ed., Cam-
bridge, Massachusetts, Cambridge Univ. Press.

Bergamini, David et al, The Universe, New York/Chicago, Time Inc., 1962. (Life Nature
Library)

Breed, Joseph B. Ill, Stars for the Space Age, New York, World Publishing/Times Mirror,
1971.

Clarke, Arthur C., The Exploration of Space, Revised Ed., 1979.
Duffet-Smith, Peter, Practical Astronomy With Your Calculator, Cambridge Univ. Press, 1981.

Ernst, Br., TJ. E. De Vries, Atlas of the Universe, London/New York, Thomas Nelson and
Sons Ltd., 1961.

Friedman, H., The Amazing Universe, Washington D.C., National Geographic Society, 1975.

Gardner, Martin, The Relativity Explosion: A Lucid Account of Why Quasars, Pulsars, Black
Holes & the New Atomic Clocks Are Vindicating Einstein’s Revolutionary Theory, Random,
1976.

Hirschfeld, Alan, Roger Sinnott (Ed.) Catalogue 2000.0, Vol. 1: Stars to Magnitude 8.0,
Cambridge, Mass., Cambridge University Press, 1982.

Hughes David, The Star of Bethlehem: An Astronomer’s Confirmation, Walker & Co., 1979.
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Krupp, E.C., Echoes of the Ancient Skies, New York, Harper & Row, 1983.
Neugebauer, Otto, A History of Ancient Mathematical Astronomy, Berlin, Springer, 1975.

Neugebauer, Otto, H.B. Van Hoesen, “Greek Horoscopes,” Memoirs of the American Philo-
sophical Society, Vol. 48, Philadelphia, 1959.

Newton, Robert R., Ancient Astronomical Observations & the Accelerations of the Earth &
Moon, Baltimore/London, Johns Hopkins Press, 1970 Norville, Warren, Celestial Navi-
gations Step by Step, New York, Association Press, 1973.

Pournelle, Jerry (Ed.), Black Holes, New York, Fawcett, 1979.
Sagan, Carl, Cosmos, New York, Random House, 1980

Stephenson, F. Richard, David H. Clark, “Ancient Astronomical Records from the Orient,”
Sky and Telescope, February 1977, pp. 84-91.

Vehrenberg, Hans, Atlas of Deep Sky Splendors, 4th Ed., Cambridge, Massachuetts, Cam-
bridge University Press., 1983

Warner, L., Astronomy for the Southern Hemisphere, Wellington, New Zealand, A. H. & A. W.
Reed, 1975.

Periodicals

“Astronomical Calendar,” Astronomical Workshop, Furman University, Greenville, South
Carolina.

Astronomy, Astro Media Corporation, Milwaukee, Wisconsin.

Mercury, Astronomical Society of the Pacific, San Francisco, CA

Observer’s Handbook, Royal Astronomical Society of Canada, Toronto, Ontario.
Scientific American, Scientific American, New York, N.Y.

Sky and Telescope, Sky Publishing Corporation, Harvard College Observatory, Cambridge,
Massachusetts

Sources

Astronomical Society of the Pacific, 1290 24th Ave., San Francisco, CA 94122

Willman-Bell, Inc., PO Box 35025, Richmond, VA 23235 (major supplier of astronomical
books and charts).

First Light « User Manual 130



A

alignment 51

altitude 20, 112

asteroids 56, 59, 112
astronomical units 30, 112
azimuth 20, 112

B
binary star 68
C

Calendar 13, 16, 26, 82, 95
Ceres 59

Clock Control dialog 14, 35, 36, 38, 39, 48, 50,

51, 53, 54, 58, 64, 100, 103
comets 56, 112
conjunction 50
coordinate systems 19

D

declination 19, 112
deep sky objects 23, 74, 93, 112
Doppler effect 72

E

eclipse 48

eclipse, lunar 46

eclipse, planetary 54

eclipse, solar 27, 45

ecliptic 13, 55, 85, 97, 112
epicycles 52

equatorial coordinate system 19, 85
Equatorial mode 20, 27, 83

F

field of view 20, 23

Film 14, 15

Flyby mode 23, 32, 33, 90, 108
making a flyby movie 38

G

galaxies 23, 74, 75

Galileo 12, 59, 64

Gaspra 65

GSC. See Hubble Guide Star Catalog

INndex

H

Halley’s Comet 57

heliocentric coordinates 30

Hover 15, 23

Hover mode 31, 91, 108

Hubble Guide Star Catalog 67, 112

Identifying objects 13, 23
information window 13, 23
Installing First Light 11

J
Jupiter 38, 49, 51, 54, 59, 64
L

light year 73, 112

local coordinate system 20
Local mode 20, 27, 45, 83
Location 27

Location dialog 16, 27, 44, 54

M

magnitude 67, 105, 113
Mars 13, 15, 50, 54, 58, 59, 92
fly-over animation 15
Mercury 53
Messier catalog 77, 93, 94, 113
meteor showers 83
Meteors 63
Moon 47
phases 48, 101

N

Navigator 22, 29, 80, 84

Nearby stars window 34, 102
nebulae 23, 74, 75

Neptune 52, 54

neutron stars 70

NGC catalog 77, 93, 94, 113
Nightly Grabbag 13, 16, 26, 82, 95
nova 69

O
Oort Cloud 57
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P

parsec 73

Photo 14

Piazzi, Guiseppe 59
Pluto 54

precession 72, 108, 113
proper motion 72, 109
pulsars 69, 70

R

radial velocity 72

red shift 72

retrograde motion 52

right ascension 19, 30, 85, 113

S

Saturn 38, 39, 52, 58
Sky Tonight 25, 80
Sky tonight 16, 82
SkyMap 67, 69

star clusters 23, 74
star names 69

Sun 42

sunspots 44

T

time zone 35

U

Uranus 55

\/

Valles Marineris 15

variable stars 69

Viewpoint 51, 57, 86, 105

viewpoint 23, 27, 85, 91
off earth 29

W

When and where dialog 15, 27, 35, 45, 50, 51,
53, 54, 58, 60, 64, 73, 82, 83, 84, 88, 95

Z
Zoom 21, 23, 87
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