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Photoshop

How to

CREATE A
NEON OBJECT.

Photoshop sports a basic set of path tools. While they are
no rival to dedicated programs like Adobe Illustrator or
Macromedia FreeHand, they do service a great many tasks.
In future issues, we will be using paths to create complex
silhouettes.

In this issue, we will be introducing paths to create a special
neon effect. This will provide a foundation for understanding
paths and their functions.

Neon effects created in Adobe Photoshop can quickly brighten
up existing graphics or logos. Glowing neon signs have a
distinctive look. They can vary from a flickering sign in the
window of a local pub to the spectacle of a Vegas casino. This
is not a technique you will use every day, but it is nice to know
how to get it when you need it.




Creating a neon glow

Step 1

Create a colored canvas for your image

Although this effect can work on any color background, the
neon glow shows up best on darker background colors. This
effect also works equally well on top of background photos.

Step 1 Step 2

Draw a shape using Photoshop’s Pen tool.

The pen tool in Photoshop is similar to the pen tools in either
Adobe Illustrator or Macromedia FreeHand. This path will
become the shape for your neon tubing. At the end of this
technique are two other approaches to building your path.

A: Make sure the Paths palette is visible.
If the Paths palette is not already visible, choose “Show paths”
from the Window menu.
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] & : Select the pen tool.

Shortcut: Press the T key to select the pen tool.

C: Draw asimple path with the pen tool.
Simple shapes work best for this type of effect. Keep in mind
that the completed neon tubes will be much thicker than the
lines you create with the pen tool.

Step 3

Create the neon “glow.”

The neon effect is created by stroking the path shape with
brushes set at three different thicknesses. This first stroke lays
in a light glow of the final neon color.

A: Choose a color for your neon light.
Bright, light colors work best. Click on the foreground color box
to pick a new color, or use the Colors palette.
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Step 3

B: Choose the airbrush in the toolbox.
Shortcut: Press the A key to select the airbrush tool.
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C: Choose a large, soft brush from the Brushes palette.
A soft brush creates the glow’s soft fade at the edges. If the

S Brushes palette is not already visible, choose “Show Brushes”
gleln] from the Window menu.
xls . .
EE il D: Set the Opacity slider to 20%
o] 5 o % Shortcut: Press the 2 key to set 20% opacity.

E: Click the Stroke Path icon in the Paths palette.
Shortcut: Press the Enter key to quickly apply the stroke.

The Stroke Path command automatically strokes your path with
the selected brush.
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Step 4

Create the neon “tube.”

To create the neon tubing, we select a smaller brush with a
hard edge. This brush is set to 100% of the neon color. This
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stroke will form the actual neon tube.
A: Choose asmaller, hard brush from the Brushes palette

Step 5

Shortcut: Move between brushes by pressing the [ and ] keys.
Use a hard-edged brush to create a clear edge to the neon tube.

Set the Opacity slider to 100%
Shortcut: Press the 0 key to set 100% opacity.

Click the Stroke Path icon in the Paths pallet.
Shortcut: Press the Enter key to quickly apply the stroke.

Create the neon “highlight.”

The final stroke will add a fine white highlight to the center
of our bright neon tube. To create the neon tubing, we select a
tiny brush with a hard edge and stroke the path with a
percentage of white.

A: Change the foreground color to white.

D:

Shortcut: Press the D key to reset default colors (B/W);
Then Press the X key to switch the foreground and background color.

Choose a small brush from the Brushes palette.
Shortcut: Move between brushes by pressing the [ and ] keys.

Note: Using the smallest brush will sometimes create a highlight with
rough edges. Pick the second-smallest brush.

Set the Opacity slider to 50%
Shortcut: Press the 5 key to set 50% opacity.

Click the Stroke Path icon in the Paths palette.

Option 1: Copying from paths from Illlustrator

(Use in Place of Step 2)

Option 1A-B (lllustrator) A
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Option 1C-E (Photoshop)

In Hlustrator, select a path using the arrow tool.

: Choose Copy from the Edit menu.

Switch to Photoshop.

: Choose Paste from the Edit menu.

You should get a dialog box asking you to chose between pasting
the path as pixels or as a path.

Choose “Paste As Paths”.

Your copied path should now appear  [[Taisrs [ crametz | Paths
as a new path in Photoshop’s Path’s glafeln]
pallet. [ | Wark Path &
]
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Option 2: Converting scanned/existing art

(Use in Place of Step 2)

A: Turn on Quick Mask mode.
Shortcut: Press the Q key to turn Quick Mask on (or off).
The Quick Mask controls are found at the bottom of
Photoshop’s tool palette (see left). For an introduction to the
Quick Mask controls, refer to Photoshop Techniques 001.

B: Place or Paste in the source artwork.
Artwork can be copied from another Photoshop file, placed
from an existing EPS, or even created with the type tool.

C: Turn off Quick Mask mode.
Shortcut: Press the Q key to turn Quick Mask off (or on).
Click on the icon directly to the left of the Quick Mask icon.
This converts the graphic you pasted in the last step into a
selection outline. You should see a moving dotted outline where
your graphic used to be.

D: Choose Make Path from the Path submenu.
This will convert your selection outline into a drawing path.
After selecting the “Make path” command you will be presented
with the Tolerance dialog box.
Enter a Tolerance amount of 1 and press Return. Photoshop will
process for a moment or two and create a path from your
original selection.
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PASS IT ON!

Send a friend a free issue of Photoshop Techniques.

Name Title
Company

Address

City State ZIP
Phone Fax

Compliments of (Optional):

1) Fax to 206-525-5212.
or 2) Call voice-mail at 206-781-1984
or 3) E-Mail information to dresource@aol.com.

or 4) Mail Coupon to: Digital Resources
PO Box 77490
Seattle, WA 98177
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Register and Get your

FREE ISSUES!

Register as a reader of Photoshop Techniques and get a free sample packet of the
full printed edition. Let us know what you think and what we can do to make
this the strongest tool in your Photoshop library.

Every month four new issues are released covering production techniques for
novices and experts alike. And unlike any Photoshop resource out there, this
investment is never outdated. Your library continues to grow each month—
even as new software is released.

Because each issue stands alone as a complete technique, there is no need to
dig through piles of software manuals. No skipped steps. Each technique is
clearly and simply explained from beginning to end.

To get your free sample issue, print and fill out the coupon below and either:
Fax this whole page to 206-525-5212.
or
Mail to the address at the bottom of the page.

or
E-Mail the information to dresource@aol.com.
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City ZIP
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Comments/Suggestions:
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How to

SUBSCRIBE.

Subscribe to the full version today and each month you will get a packet of four
new issues covering production techniques and tricks for novices and

experts alike. Plus to start you off, we'll send you all the back issues

you’ve missed!

And there is no risk! If you ever decide to cancel Photoshop
Techniques, we'll refund your money in full. Print and mail back
your subscription coupon today to start your risk-free subscription.

[0 Yes, Sign me up for the printed version of Photoshop Techniques.

Name

Company

Address

City ZIP

Phone # E-Mail

Fax # Where did you find us?

Comments/Suggestions:

O Volume #1: $75, Issues #001-#052. O 3-Ring Storage Binder: $10.
Canada: Add $15 US dollars.
International: Add $30 US dollars. TOTAL: $

PAYMENT: O Check Enclosed O VISA O MasterCard
Account number Exp. Date

Signature Date

Mail to:  Digital Resources or Fax:  206-525-5212
PO Box 77490 or Call: 206-781-1984
Seattle, WA 98177 or e-mail: dresource@aol.com
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Quotes from our

READERS.

“Publisher Craig Swanson touches upon one effect per issue and shows how to
achieve it, step by step. The presentation is excellent, brief and to the point. The
whole issue can be read and understood with a few glances. This publication
makes a useful reference to any electronic designer's shelf.”

-Tom Geller, Associate Editor, ZiffNet forum on eWorld.

“Looks like you've put a lot of work into developing and presenting these
Photoshop tips. Very Impressive.”

- Rob S. (Straittime@aol.com)

“I want to thank you for Photoshop Techniques. It is a real pleasure to read
and own. Not very often is there a “zine” available that is so knowledgable
and yet easy to use.”

- Kent Eichler

“I like your Photoshop Techniques Newsletter. ...I1 have an easier time digesting
just a few tips and tricks at a time than getting through a whole book at once.
...With your newsletter format getting mailed out once a month there is that
feeling of something new coming in all the time. It stimulates my motivation.”

- Rob Teutsch

“Great stuff!”
- D. Pepper, Federal Express, Media Production

“I'm impressed! ... They’re organized the way | comprehend information: Short,
succinct step-by-step directions.”

- Sue Ruff

“Fabulous! *bout time somebody did this!”
- Jeff Farmer

“Your publication is great! | teach Adobe Photoshop and your instructions
are so far the most understandable I have seen. | might include some of your
“How to’s” in my sessions and will certainly suggest my students to subscribe
to Photoshop Techniques.”

- lvana Starcevic




(As of January 1, 1995)

Answers to frequently asked

QUESTIONS...

Do you support the Windows platform?

Yes. My assistant editor works on a PC platform. Most techniques should work
the same regardless of the computer used. The reason you see Mac screen shots in
the newsletter is that | work on a Mac and I produce the final layouts.

Can | get my subscription through e-mail?

Right now we do not offer the full printed edition in an electronic format.

We are exploring several methods for electronically distributing the full editions.
Depending on the interest, we are also considering releasing a CD-ROM with
back issues and support files sometime in late 1996.

Can | get copies of the back issues?

When you subscribe to Volume #1 of Photoshop Techniques we start your
subscription off with all the back issues starting from issue #001. After that you
will receive a new packet of four issues each month through issue #052.

Will there be a Volume #2 of Photoshop Techniques?

We will be making that final decision sometime in late 1996. It will depend on
the interest of our readers, plus changes in technology. | expect we will continue
with Adobe Photoshop. However this is a growing market and other programs
could potential rise to the top of the industry. Regardless, we will be continuing
to develop and provide new tools for the digital imaging community.

What if I decide later that | don't want Photoshop Techniques?

Your subscription is fully guaranteed. If you decide to cancel for any reason, let us
know and we will gladly refund your full subscription amount.

Can | pass along this electronic file?

Absolutely, please do! But do not edit, change or remove anything. If you are
interested in reprinting Photoshop Techniques articles in other magazines or
newsletters, please contact me first.

-Craig Swanson, Editor and publisher of Photoshop Techniques.




(As of January 1, 1995)

An Index of

BACK ISSUES.

#001 - How to use Quick Mask to Create Photo Edges.
#002 - How to Create a Neon Object.

#003 - How to Build a Realistic Shadow for Postscript Art.
#004 - How to use Postscript Art as a Stencil in Photoshop.
#005 - How to Create an Embossed Object.

#006 - How to Create a Chiseled Object.

#007 - How to Wrap a Texture over an Object.

#008 - How to Create Quick Textures.

#009 - How to Cut-out an Object from it's Background.

#010 - How to Build Shadows for Cut-out Objects.

#011 - How to Overprint a Shadow. (In QuarkXPress or PageMaker)
#012 - How to Create Rough, Weathered Graphics.

#013 - A Visual Overview: Combining Photos.

#014 - How to Remove Objects from a Photo.

#015 - How to Extend a Photo's Background.

#016 - How to Add new Objects to a Photo.
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