
A2ZWare Word Puzzler

Word Puzzler generates crossword puzzles, word search puzzles, word-definition match puzzles, vocabulary 
quizzes, and vocabulary lists. It is designed to help grade school age children improve their vocabulary and 
spelling. It is appropriate for use in a classroom or at home. Word Puzzler uses the same word lists as 
A2ZWares popular Hangman game. With this version of Word Puzzler you can:

Use the word list of approximately 500 words included with Word Puzzler (WORDS.DAT)
Create your own word list
Transfer words and definitions from one word list to another
Control the number of words in the puzzle
Show a picture on the back of a crossword puzzle

Selecting a word list
Creating a Crossword Puzzle
Creating a Word Search Puzzle
Creating a Word-definition Match Puzzle
Creating a Vocabulary Quiz
Creating a Vocabulary List
Creating a Words Only List



Word List Menu

Use this menu edit a word list or transfer words from one word list to another.

Edit
Transfer



Open Word List - File Menu

Selects and loads a word list file. WORDS.DAT, a list of approximately 500 words, is provided with the Word Puzzler 
software. You can also create your own word lists using Create New Word List option in the File Menu. 



Create New Word List - File Menu

Select this option to create a new word list. Selecting Create by entering words will open the Word List Editor. 
Selecting Create by transferring words will open the Word Transfer Window.



Edit - Word List Menu

Opens the Word List Editor. The Word List Editor allows you to add, edit and delete words in a word list file. This 
allows students to use Word Puzzler to learn the vocabulary and spelling words assigned to them by their teacher, 
not just the words which come with Word Puzzlers WORDS.DAT.



Registration

Select How to Register from the Help menu for information about registering and to initiate the registration process. 
Before registering, verify that the software meets your needs on the computer you will be using it on. Registrations 
will not be refunded. Registration payments are processed by Kagi, not A2ZWare. Please contact Kagi at 
admin@kagi.com if you have questions about the status of a registration payment.

The first window which appears lists the license descriptions and pricing. Select OK to continue. Another window 
appears with instructions for filling out the registration form. Select OK to continue. If you do not want to register at 
this time, simply select Quit to exit the registration form. On the registration form, enter your name, address, and 
email address. Enter the quantity for the license type you are purchasing and your payment method. Then select 
Next. The next form will tell you how to send in your payment to Kagi. Select Quit to exit the registration form. 

After your payment is received, you will receive a registration code from A2ZWare. Enter this code by selecting Enter 
Registration Code from the Help menu. After your registration code is entered you will not be interrupted by 
shareware reminders anymore and shareware reminders will not appear on the puzzles when they are printed.



License Agreement

Word Puzzler Copyright © 1997 - 1999 by J. Szatkowski
All rights reserved.

License Agreement
You should carefully read the following terms and conditions before using this software.    This is your license 
agreement unless you have a different written license agreement authorized by A2ZWare. Your use of this software 
indicates your acceptance of this license agreement and warranty. Licenses are not transferable.

Unregistered Verision
You may use Word Puzzler free of charge for 30 days. After that you must register by purchasing a license.

Registered Versions

A single user license registers Word Puzzler on a single computer. This type of license is for individual use only. 
Schools, businesses, and other organizations should purchase a school license.

A school license registers all of the computers at one school. All teachers employed by the school are also licensed to 
use the software on their home computers for as long as they are employed by the school. School licenses DO NOT 
cover students. Students must purchase individual licenses. Single departments at UNIVERSITIES and COLLEGES 
should purchase a school license. COMPANIES using the software on multiple computers at a single site should also 
purchase a school license.

A district license registers all of the computers at all of the schools in one school district. All teachers employed by the 
district are also licensed to use the software on their home computers for as long as they are employed by the district. 
District licenses DO NOT cover students. Students must purchase individual licenses. UNIVERSITIES and 
COLLEGES should purchase a district license to cover the entire institution. COMPANIES using the software at 
multiple sites should also purchase a district license.

Disclaimer of Warranty
THIS SOFTWARE AND THE ACCOMPANYING FILES ARE SOLD "AS IS" AND WITHOUT WARRANTIES AS TO 
PERFORMANCE OF MERCHANTABILITY OR ANY OTHER WARRANTIES WHETHER EXPRESSED OR IMPLIED. 
Because of the various hardware and software environments into which Word Puzzler may be put, NO WARRANTY 
OF FITNESS FOR A PARTICULAR PURPOSE IS OFFERED.

Word Puzzler has been tested extensively. However it is not possible to test every possible situation. The user 
assumes the entire risk of using Word Puzzler.    ANY LIABILITY OF THE SELLER WILL BE LIMITED EXCLUSIVELY 
TO PRODUCT REPLACEMENT OR REFUND OF PURCHASE PRICE.



Creating a Crossword Puzzle

Word Puzzler builds each puzzle by selecting words from your word list at random. This means that each time you 
select Create Puzzle, a new puzzle is built, even if no options have been changed. These directions explain how to 
create a crossword puzzle and how to use the different options.

Select the Crossword Puzzle option. Enter a title for the puzzle, if desired.

 Select the maximum number of words for the puzzle. It is not always possible to fit all of the words in the puzzle. 
Word Puzzler will attempt to fit the number indicated in Maximum number of words in puzzle but sometimes it will be 
less. See the hints for using the maximum number of words for more information on fitting the maximum number of 
words in the puzzle.

 Select the number of cells across. The puzzle size is fixed, so a smaller number in this selection will result in bigger 
boxes in which to write the letters while a larger number will result in smaller boxes.

Check or uncheck Allow orphans. If Allow orphans is checked,    Word Puzzler will put a word in the puzzle which is 
not connected to any other words. These words could become connected to other words as more words are added, 
but this is not always the case. If Word Puzzler is unable to use some words with this box unchecked, checking the 
box will increase the number of words in the puzzle.

Select a background color, line color, and a picture (if desired). Select the Select Background Color command to 
choose the background color. Select the Select Line Color command to choose the line color . If your printer is black 
and white, remember that any color you select will be converted to grayscale during printing. Select the Select Picture 
command to select a bitmap for the puzzle background, if desired. Remember, if your printer is black and white, the 
picture will be converted to grayscale during printing. Select the position of the bitmap on the puzzle. The possible 
seletions are centered, upper left hand corner, or tiled. If Tile picture is selected the picture will be repeated to fill the 
background of the puzzle.

After all of the options have been determined, select the Create Puzzle command. Word Puzzler will build the puzzle. 
This could take a few minutes, depending on the number of words in the puzzle. After the puzzle is built, you will have 
the option of viewing the puzzle immediately. Select Yes to view the in the print preview window. You can print the 
quiz by selecting the Print command in the print preview window.

After viewing the puzzle, the background color, line color, picture, and title can be changed, if desired. Select Show 
Puzzle to see how these changes look on the puzzle. Other options can be changed as well, but they will not take 
effect until you select Create Puzzle again.

Select Show Key to preview the key for the puzzle in the print preview window. You can print the quiz by selecting the 
Print command in the print preview window.

To change the printer options, select Printer Setup from the File menu in the main window. For more information 
about crossword puzzles, see Printing Crossword Puzzles..



Hints for using the maximum number of    words

If Word Puzzler is not fitting the maximum number of words, there are a couple of adjustments which can be made to 
increase the number of words in the puzzle. First, increase the number of cells across. Second, for crossword 
puzzles, check the Allow Orphans check box.



Creating a Word Search Puzzle

Word Puzzler builds each puzzle by selecting words from your word list at random. This means that each time you 
select Create Puzzle, a new puzzle is built, even if no options have been changed. These directions explain how to 
create a word search puzzle and how to use the different options.

Select the Word Search Puzzle option. Enter a title for the puzzle, if desired.

 Select the maximum number of words for the puzzle. (It is not always possible to fit all of the words in the puzzle. 
Word Puzzler will attempt to fit the number indicated in Maximum number of words in puzzle but sometimes it will be 
less.) See the hints for using the maximum number of words for more information on fitting the maximum number of 
words in the puzzle.

 Select the number of cells (letters)    across. 

Check or uncheck Allow backwards orientation. If Allow backwards orientations is checked,    Word Puzzler will put 
some of the words in the puzzle with their letters in reverse order.

After all of the options have been determined, select the Create Puzzle command. Word Puzzler will build the puzzle. 
This could take a few minutes, depending on the number of words in the puzzle. After the puzzle is built, you will have 
the option of viewing the puzzle immediately. Select Yes to view the puzzle in the print preview window. You can print 
the quiz by selecting the Print command in the print preview window.

After viewing the puzzle, the title can be changed, if desired. Select Show Puzzle to see how these changes look on 
the puzzle. Other options can be changed as well, but they will not take effect until you select Create Puzzle again.

Select Show Key to preview the key for the puzzle in the print preview window. You can print the key by selecting the 
Print command in the print preview window.

To change the printer options, select Printer Setup from the File menu in the main window.



Creating a Word-defintion Match Puzzle

Word Puzzler builds each puzzle by selecting words from your word list at random. This means that each time you 
select Create Puzzle, a new puzzle is built, even if no options have been changed. These directions explain how to 
create a word-definition match puzzle and how to use the different options.

Select the Word-definition Match Puzzle option. Enter a title for the puzzle, if desired.

 Select the maximum number of words for the puzzle.

After all of the options have been determined, select the Create Puzzle command. Word Puzzler will build the puzzle. 
After the puzzle is built, you will have the option of viewing the puzzle immediately. Select Yes to view the puzzle in 
the print preview window. You can print the quiz by selecting the Print command in the print preview window.

After viewing the puzzle, the title can be changed, if desired. Select Show Puzzle to see how these changes look on 
the puzzle. The number of words in the puzzle can be changed as well, but this will not take effect until you select 
Create Puzzle again.

Select Show Key to preview the key for the puzzle in the print preview window. You can print the key by selecting the 
Print command in the print preview window.

To change the printer options, select Printer Setup from the File menu in the main window.



Creating a Vocabulary List

These directions explain how to create a vocabulary list.

Select theVocabulary List option. Enter a title for the list, if desired.

Select the Show List command to view the list in the print preview window. You can print the list by selecting the Print 
command in the print preview window.

To change the printer options, select Printer Setup from the File menu in the main window.



Creating a Words Only List

These directions explain how to create a words only list.

Select the Words Only List option. Enter a title for the list, if desired.

Select the Show List command to view the list in the print preview window. You can print the list by selecting the Print 
command in the print preview window.

To change the printer options, select Printer Setup from the File menu in the main window.



Creating a Vocabulary Quiz

Word Puzzler builds each quiz by selecting words from your word list at random. This means that each time you 
select Create Quiz, a new quiz is built, even if no options have been changed. These directions explain how to create 
a vocabulary quiz and how to use the different options.

Select theVocabulary Quiz option. Enter a title for the quiz, if desired.

 Select the maximum number of words for the quiz.

After all of the options have been determined, select the Create Quiz command. Word Puzzler will build the quiz. 
After the quiz has been built, you will have the option of viewing the quiz immediately. Select Yes to view the quiz in 
the print preview window. You can print the quiz by selecting the Print command in the print preview window.

After viewing the quiz, the title can be changed, if desired. Select Show Quiz to the new title on the quiz. The number 
of words in the quiz can be changed as well, but this will not take effect until you select Create Quiz again.

Select Show Key to preview the key for the quiz in the print preview window. You can print the key by selecting the 
Print command in the print preview window.

To change the printer options, select Printer Setup from the File menu in the main window.



Technical Support

Please contact A2ZWare Technical Support if you are having any technical problems with the software. Please do 
not contact A2ZWare for information about your registration payments. A2ZWare does not process 
payments. Contact Kagi at admin@kagi.com for questions concerning your payment. 

When contacting Technical support, please include the following information:

1. A complete description of the problem
2. Your registration name if registered (Registered to Registration Name    at the top of the screen)
3. The version number of the software. (Select About Word Puzzler from the Help menu)
4. Your Windows version (Windows 3.1, Windows 95, etc.)
5. Your processor type if you know it (486, Pentium, etc.)
6. Any other information which might be important

You can easily save the text of all error messages by checking the Log Errors option on the file menu. This will cause 
all errors to be logged to a file named LogFile.txt. If you are receiving error messages, check this option and then 
send the file to A2ZWare along with your other information.

A2ZWare Technical Support can be contacted in these ways
1. Send e-mail to a2zware@aol.com. 
2. Visit our web site at http://members.aol.com/a2zware/index.htm



Create New Word List

Select Create New Word List from the file menu to create a new word list. A dialog window will open with two 
options. If the Create by entering words option is selected, the Word List Editor will be opened. If the Create 
by transferring words option is selected, the Word Transfer Window will be opened.

Edit Word List
Transfer Words



Print Preview

The print preview window is opened after one of the Show commands is selected from the main window. Print 
preview is an approximation of how the printed document will appear. Occasionally, there will be formatting errors 
which appear in the print preview window, but not in the document itself. 

Use the Next Page and Previous Page commands to view the document in print preview. The Zoom In and Zoom out 
commands allow you to view the whole page at once or to view a detail on the page.

Use the Change Font command to change the font. Use the Number Font to change the font for the numbers drawn 
on crossword puzzles. Use the Format command to alternate bold and normal rows of text, draw boxes around word 
search letters, draw boxes around rows, change column widths, change margins, center or left justify crossword 
puzzles, select the number of columns for crossword puzzle clues, and select a language for the instructions on the 
puzzle/quiz. (If you would like to see another language added to the list, please contact A2ZWare.) Some of the 
format options do not affect some puzzle/quiz types so they might be disabled depending on the type of puzzle/quiz 
you have selected.

If you are satisfied with the document, use the Print command to send the document to your printer. Select the pages 
to print and the number of copies. You can change your printer setup by exiting print preview and selecting Printer 
Setup from the File menu in the main window. It is not recommended that you change your printer setup while in print 
preview because the document has been formatted for the printer which was selected when the print preview window 
was opened.

If you are not satisfied with a puzzle or quiz, exit print preview and select the Create command again. Word Puzzler 
generates puzzles and quizzes using random functions, so a different puzzle or quiz is created each time you select 
the Create command.

For more information about crossword puzzles in print preview, see Printing Crossword Puzzles. 



Printing Crossword Puzzles

Since the crossword puzzles must be printed as graphics, there are some special considerations for them.

If you are not satisfied with the quality of the crossword puzzle printout, you might have to change your printers 
graphics settings. The quality of the printout is highly dependant on these settings and your printers capabilities.    If 
all else fails, select no dithering in the printers graphics options and to use black or white as the background color for 
the puzzle and black as the line color for the puzzle.

On some systems (especially those with monitors which display 256 colors or less) putting pictures on the crossword 
puzzle might result in very poor resolution on the picture. If you experience this problem it is suggested that you do 
not use pictures on your crossword puzzles.

Occasionally, the background color of the puzzle may appear to be darker or lighter than it should in print preview. It 
might also appear to have a pattern in it, such as lines. It should print correctly anyway.



Welcome to the Word List Editor

The Word List Editor allows you to create and edit word lists. For more information on a topic, select a link below or 
search the Help Index.

File Menu - Open
Saving Files
Add Mode
Edit Mode



Word List Editor - File Menu 

Use this menu to open and save word lists. You can also choose whether lists will be saved in alphabetical or entry 
order from this menu. The File menu is not enabled in Edit Mode or Add Mode. You must exit these modes before 
selecting an item from the File menu

File Menu - Open
Saving Files
Add Mode
Edit Mode



Word List Editor - File Menu    - Open

Select Open from the file menu to open a file. The file dialog box appears. Enter the file name or locate the 
file. Select OK. The selected file will be opened. If the file does not exist it will be created.



Saving Files

There are four methods for saving files:
n select Save from the File menu

n select Save and Exit from the File menu
n select Ctrl-S
n select the Save and Exit command button. 

The save order can be selected from the File menu. If Save In Alphabetical Order is checked, the list will be saved in 
alphabetical. If Save In Entry Order is checked, the list will be saved in the order which it was last saved with any new 
list items added to the end in the order of entry. Selecting one of these save order options does not actually save the 
list. They just set the order for saving the list the next time one of the save commands is selected.

The list is always displayed in entry order. So if you add or edit the words and have Save In Alphabetical Order 
checked, the list will not be sorted into alphabetical order again until one of the save commands is selected.



Word List Editor - Edit Menu 

Use this menu for common editing functions when in Add Mode or Edit Mode.

Function Shortcut Action
Undo Ctrl U  undo the changes made to the word and definition
Cut Ctrl X  delete the selected text and copy it to the clipboard
Copy Ctrl C  copy the contents of the clipboard to the current cursor position
Paste Ctrl V  copy the selected text to the clipboard
Delete none  delete the selected text
Select All Ctrl A  select all of the text in the text box where the cursor is active



Add Mode

To add a word to the word list, enter Add Mode by selecting the Add button at the bottom of the Word List Editor. (If 
the Add button is not visible, you are already in Add Mode or Edit Mode.) Then enter the new word and definition. 
Select OK to add the word to the list. 

The list is always displayed in entry order, so the newly added word will be located at the bottom of the list. If the 
Save In Alphabetical Order option is checked, the word will be placed in alphabetical order in the list the next time the 
list is saved.



Edit Mode

To edit a word in the word list, enter Edit Mode by selecting the word from the list on the left side of the Word List 
Editor and then selecting Edit button at the bottom of the window. (If the Add button is not visible, you are already in 
Add Mode or Edit Mode.) Then edit the word and definition. Select OK to update the list.

The list is always displayed in entry order, so the newly edited word will be located in the same position it was before 
any editing took place. If the Save In Alphabetical Order option is checked, the word will be placed in alphabetical 
order in the list the next time the list is saved.



Definitions

In some cases, the software searches for the word in the definition and replaces it with blank spaces. Then the 
definition can be used as a clue, hint, or problem. If you want the software to replace the word correctly, care must be 
taken when writing definitions.

Examples of definitions which work:

Word: five Definition: I have five toes on each foot.
results in Hint: I have ____ toes on each foot.

Word: tree Definition: Trees are large plants with trunks and many leaves.
results in Hint:    ____s are large plants with trunks and many leaves.

Word: house Definition: a building in which a family lives
results in Hint: a building in which a family lives

Example of a definition which doesnt work:
Word: berry Definition: Berries are small, juicy fruits.
results in Hint: Berries are small, juicy fruits.
Since the plural form is berries (rather than berrys) the software cant find the word berry and replace it with spaces.



Transfer Words - File Menu

Use this menu to open and save word lists. You can also choose whether lists will be saved in alphabetical or entry 
order from this menu. 

File Menu - Open
Saving Files



Transfer Words - File Menu - Open

Select    the file menu to open a source file or a destination file. 

To open a source file, select Open Source File from the File Menu. The file dialog box appears. Enter the file name or 
locate the file. Select OK. The selected file will be opened.

To open a destination file, select Open Destination File from the File Menu. The file dialog box appears. Enter the file 
name or locate the file. Select OK. The selected file will be opened. If the file does not exist, it will be created.



Tranferring Words

Before transferring words, you must open a source file and a destination file. After both files are opened, select the 
word or words from the source list on the left which you want to transfer to the destination list. Then select the Add 
button at the bottom. This will add the words to the desitination list. The definitions will also be transfered to the 
destination file when the file is saved.

There are two ways to select multiple words from the source list. To select words which are positioned together in the 
list, click on the first word of the group and then, while holding down the shift key, click on the last word. This will 
select the two words plus all of the words in between.

To select words which are not positioned together, click on the first word. Then, while holding down the Ctrl key, click 
on any other words you want to select.



Add Math Functions To List 

Use this window to add math functions to a list.

At the top of the window, put a check next to the type of operations you would like to include. Then indicate the range 
of numbers for the operations. This is the range for the operators, not for the answers.    The entries for the range 
should be integers.

You can select whether to include all possible combinations of the operators or a random sampling of combination. 
Remember, if you select all possible combinations and your range is large, you will be adding quite a few equations.

Finally, if you have selected the subtraction operation at the top, indicate if you want to include equations which have 
negative answers. If you have selected the division operation at the top, indicate if you want to include equations with 
fractional answers. Fractional answers will not be reduced. For example 8 / 6 will have the answer 1 2/6, not 1 1/3.




