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Overview of The Spelling Voice

The Spelling Voice is an educational computer program that allows you to test and enhance your spelling 
skills in a fun and unique way.    The Spelling Voice uses both the sight and sound capabilities of your 
computer. It interfaces with you by commenting on the actions you perform when learning or spelling a list 
of words.    For example, as you spell, the program may display a score bar and also respond with a 
phrase.

Whether you are an advanced speller or a beginner, The Spelling Voice allows you to reach your spelling 
goals and enjoy spelling the words at the same time.    You can create your own list of words that you 
want to spell, or you may use a predefined word list that is provided by the program.    The spelling list is 
created by entering the words into a dialog box and recording them using a microphone.    When you type 
in and record the words, you can define whether they are to be spelled using mixed case characters 
(Abraham Lincoln) or with punctuation such as periods (Mr. Lincoln), commas, apostrophes, and 
hyphens.    You can also use numbers 0 to 9 and spaces (Apollo 1).

Once the spelling list is created, you may then practice spelling the words or go directly to testing your 
spelling skills.    When you practice spelling the words, the program displays the next word on the list for 
you to spell and guides you on spelling the word correctly.    When you select Spell, you instruct the 
program to measure your progress as you spell.    The Spell dialog can include a progress bar, timer, word 
count and score bar, which indicate how well you did at the completion of the test.

Features

There are four basic features you can use in The Spelling Voice.    They are:
- Create a spelling list or add words to an existing spelling list
- Save and load spelling lists
- Practice learning the words on the spelling list
- Spell the words on the list while measuring your progress

The person who defines the spelling list of words may be the same person who spells the words.    Or , 
you may want to have a student-teacher relationship where the person who creates the spelling list is 
different from the person who takes the test.    It's up to you and whichever setup best meets your needs.



The File Menu

 
The File menu contains the following menu commands from which you may choose:

New List - select this command to create a new, blank spelling list.

Load List - select this command to retrieve a spelling list that you previously saved. 

Save List - select this command to save a copy of the current spelling list for use again at another time.

Delete List - select this command to delete an entire spelling list.

Edit List - select this command to add words to the currently loaded spelling list, modify the words in the 
list, or delete words from the list.    If The Spelling Voice is registered, a spelling list can include up to 50 
words.

Learn - select this command when the spelling list is completed and you want to practice spelling the 
words on the list before actually taking the test.

Spell! - select this command when the spelling list is completed and you are ready to test your spelling 
skills using the list.

Exit - select this command to quit The Spelling Voice.



The Options Menu

 
The Options menu contains the following commands from which you can choose:

Spell Setup - select this command to define the Spell dialog. You can indicate whether you want the 
Smiley face, Timer, Progress Bar, Score Bar and Word Count to be displayed in the Spell dialog when 
testing your spelling. These controls are used in the Spell dialog to show your progress. You may select 
any one or all of the five setup checkboxes described below.    The default is to display all options on the 
Spell dialog.

Voice Setup - (Not available in the unregistered version) displays all of the responses the student will 
hear from the program when certain events occur, such as when you type a character or spell a word.    
The program provides a variety of predefined responses.    For example, when a student spells a word 
correctly, they will hear the response "Yes".    When the student types an incorrect letter, they will hear the 
response    "No".    You can also record your own voice to play back these responses by selecting the 
Record button.    To hear any of the responses in the Setup list, highlight the response from the list and 
select the Play button. 

Adjust Volume - select this command to change the playback volume in The Spelling Voice. There is a left 
and right speaker adjustment selection. You can set the volume of the left and right speakers at differing 
levels or balance them to be the same.    Move the vertical slide bar up to increase the volume or move 
the bar down to lower the volume.    As you move the vertical slide bar up and down you will hear the 
phrase "very good", which helps you identify the appropriate volume level for the application.    The 
volume levels range from 0 to 100%. 

Display Large Font - select this command to indicate that you want the largest font available displayed in 
the Spelling Voice dialogs. A checkmark appears in front of the command, indicating that it is in effect.

Show Log - select this command to display an event log that records such information as when the 
program started and closed, the date and time the program was in use, and a list of misspelled words. 
This command is useful for tracking and monitoring the speller's overall progress.



Prepare for using The Spelling Voice

1. Before you add words to a spelling list, make sure that you have a microphone connected to your 
computer and that it is in good working condition.

2. To record the words entered in your spelling list, use any standard microphone with a mini phono jack. 
Connect the microphone to your computer by plugging the mini phono jack into the Line In jack on the 
sound board. 

Note: If a microphone is not available, you can use a set of headphones instead by talking into the ear 
piece.

3. You are now ready to start The Spelling Voice and create or modify a spelling list.



Start The Spelling Voice

To start The Spelling Voice program, double click on the Spelling Voice icon from the Program Manager.    
The Spelling Voice window is displayed.

If this is the first time you are using the Spelling Voice, a predefined spelling list is automatically loaded 
but not displayed in the Spelling Voice window.    All of the menu commands and Toolbar buttons are 
selectable. Use the Options menu to set up voice responses, define the dialog in which you spell the 
words, change font size, and adjust the playback sound.    Create a new spelling list by selecting [File: 
New List] or access the predefined spelling list by selecting [File: Edit List].    Once you create a spelling 
list or open the predefined list, select [File: Save List]. This will assign a descriptive name for your list and 
store a copy of the list for use again at a later time.

Note:    Until you save the predefined spelling list provided with the Spelling Voice, you will not be able to 
open it using the Load List command.    Save this spelling list to make it available for selection from the 
Load List dialog. You may want to use the predefined list    in conjunction with the Help system as a 
practice list in learning how to use all of the features available to you in the program. 

Each time you open the Spelling Voice, the last spelling list you used is automatically loaded.    The status 
bar at the bottom of the screen shows the description title under which the list was saved. 



Use the Toolbar or Menu commands

The menu commands on the menu bar include the File Menu, the Options Menu, and the Help Menu.    
The File Menu and Options Menu contain a pull down list of commands from which you may choose to 
perform specific activities. For example, if you want to add words to a spelling list, select [File: Edit List]. 

As an alternative to using some of the menu commands, you may use the Toolbar displayed directly 
underneath the menu bar.    The buttons on the Toolbar include: New List, Load List, Save List, Edit List, 
Learn, Spell! and Exit. 

 

If you want to create a new blank spelling list, for example, you can select the New List button on the 
Toolbar instead of selecting [File: New List].

You can also use accelerator keys to select the toolbar commands and button commands in dialogs. 
Press the Alt key in combination with the underlined character in the button or command.



Create a New Spelling List

The Spelling Voice allows you to work with one spelling list at a time. The spelling list you create in the 
Registered Version may contain up to 100 words. In the Unregistered Version, a list may only contain up 
to 10 words.    An individual word can contain up to 100 characters.    Before you create a new spelling list, 
you may want to save the list currently in use.

Note:    If you are simply viewing the current list and did not make any changes to it, you do not need to 
save this list before creating a new one.    This version of the list is already available for selection from the 
Load List command.

When you create a new list, the spelling list is empty.    Use the Edit List command to add and record the 
words for the list.

To create a spelling list, follow these steps:

1. From the Spelling Voice window, select [File: New List] from the menu bar or, as an alternative, select 
the New List button from the Tool bar. 

The Spelling Voice replaces the previous list in use with a blank spelling list. The status bar at the bottom 
of the screen identifies the new list as "untitled".    Also, the Save List, Learn, and Spell! buttons are 
disabled until you add words to the list.

2. Select [File: Edit List] from the menu bar or the Edit List button from the Tool bar.    A dialog box displays 
which allows you to add and record words to your list. 

3. If you want the words you add here to be case sensitive (spelled correctly when using both upper and 
lowercase letters, such as "Abraham Lincoln"), select the [Mixed Case Characters] checkbox. The 
characters you type will be displayed in upper and lowercase letters. Leave this box deselected if you 
want the program to display the characters you type in all uppercase, even though you may have typed 
lowercase letters.

4. To add words to your list, select the New button. The cursor appears in the first text box. Type the word 
you want to add to the spelling list in this field.    You can enter letters, numbers (0 to 9), hyphens, 
apostrophes, periods, commas, and spaces. The Spelling Voice repeats each letter, number or 
punctuation as you type.

5. When you have entered the last character of the word, press the <Enter> key to add the word to the list 
box.

6. Select the New button again to add the next word. 

Note:    As you continue to add words to the spelling list, check the Total Words count shown at the top of 
the dialog. The Total Words indicator increments by 1 each time you press the <Enter> key. This allows 
you to keep track of the total number of words currently in the list. In the Registered Version of this 
program, the maximum number of words you can have in a list is 100.

7. When you have completed entering all of the words you want on the spelling list, you must record the 
words. 

        First, enter the recording time that you will need to record each word. Time the longest word on your 
list and enter the number of seconds it took for you to speak the word.    Type this number in the 
[Maximum Recording ___ Seconds] field.    You can set the maximum time up to 30 seconds. The default 
is 3 seconds.



Note: You do not need to keep changing this selection.    Simply enter a standard recording time once and 
leave this setting for all future spelling lists. 

        Next, select the word you wish to record and press the Record button.    Wait for the text in the button 
to show the word "Stop".    At this point you may begin speaking.    When you have finished saying the 
word, press this same button.    The word is recorded.      The text will once again display "Record". 

8. Press the Play button or double click on the word in the list to hear your recording. 

Note:    Getting the words to come out right will take a little practice, but you'll find that it is actually quite 
easy.    If you want to adjust the playback volume, use [Options: Adjust Volume].

9. Highlight the next word on the list and repeat step 7 for each word.

10. When all of the words in the list box are recorded, select the Done button.

11. If at any time you want to delete a word from the list, select the Delete button. 

12. If you want to work with a different list, save this current list before loading another one or creating a 
new one. If you do not, this version of the list is not made available for selection when you want to load it 
again for use at a later time.



Revise a Spelling List

You can revise the spelling list that is currently loaded by adding a new word, changing an existing word, 
or deleting a word.    If the list you want to edit is not the one currently in use, save the current list and 
load the list you want.

Note: All of your changes to the list are permanent.    You do not have to select the Save List command to 
save them.

To revise a spelling list, follow these steps:

1. Make sure that the list you want to edit is currently loaded.    View the descriptive name shown in the 
status bar at the bottom of the screen for the correct list.    If necessary, select [File: Load List] to load the 
spelling list you want to work with.

2. From the Spelling Voice window, select [File: Edit List] from the menu bar or, as an alternative, select 
the Edit List button from the Tool bar.    A dialog box is displayed. The list box displays all of the words in 
the spelling list. 

3. If you want the word you are adding or revising to be case sensitive (spelled correctly when using both 
upper and lowercase letters, such as "Abraham Lincoln"), select the [Mixed Case Characters] checkbox. 
Leave this box deselected if you want the program to display the characters you type in all uppercase, 
even though you may have typed lowercase letters.

4. To add a word to the list, select the New button. The cursor appears in the first text box. Type the word 
you want to add to the spelling list in this field.    You can enter letters, numbers (0 to 9), hyphens, 
apostrophes, periods, commas, and spaces. The Spelling Voice repeats each letter, number or 
punctuation as you type. The maximum length allowed for a word is 100 characters.

5. When you have entered the last letter of the word, press the <Enter> key to add    the word to the list 
box.

6. Select the New button again to add the next word.

Note:    As you continue to add words to the spelling list, check the Total Words count shown at the top of 
the dialog. The Total Words indicator increments by 1 each time you press the <Enter> key. This allows 
you to keep track of the total number of words currently in the list. The maximum number of words you 
can have in a list is 100.    In the Unregistered Version, a list may only contain up to 10 words.

7. To delete a word, highlight that word in the list and select the Delete button. 

8. To change an existing word in the list, highlight that word and retype the word in the text field.    You can 
append the word or enter a completely different word.    When you have finished, press the <Enter> key to 
add the word to the list.

9. When you have completed entering or changing all of the words you want on the spelling list, you must 
record the words. 

    First, enter the recording time you will need to record each word. Time the longest word on your list and 
enter the number of seconds it took for you to speak the word.    Type this number in the [Maximum 
Recording ___ Seconds] field.    You can set the maximum time up to 30 seconds. The default is 3 
seconds.

Note: You do not need to keep changing this selection.    Simply enter a standard recording time once and 



leave this setting for all future spelling lists. 

    Next, select the word you wish to record and press the Record button.    Wait for the text in the button to 
show the word "Stop".    At this point you may begin speaking.    When you have finished saying the word, 
press this same button.    The word is recorded.    The text will once again display "Record". 

10. Press the Play button or double click on the word in the list to hear your recording. 

Note:    Getting the words to come out right will take a little practice, but you'll find that it is actually quite 
easy.    If you want to adjust the playback volume, use [Options: Adjust Volume].

11. Highlight the next word on the list and repeat step 9 for each word.

12. When all of the words in the list box are recorded, select the Done button. 

13. If you want to work with a different list, save this list before loading another one or creating a new one. 
If you do not, this version of the list is not made available for selection when you want to load it again for 
use at a later time.



Save a Spelling List

Once you have created and modified a spelling list and are now ready to work with a different list, you 
should save the list.    When you save a spelling list, the Spelling Voice allows you to assign a unique 
name to the list and then saves a copy of it so that you can load the list again at another time.

Note:    There is no limit to the number of spelling lists you can save.

To save a spelling list, follow these steps:

1. From the Spelling Voice window, select [File: Save List] from the menu bar or, as an alternative, select 
the Save List button from the Tool bar.    The Save Spelling List dialog box is displayed.

2. Type a new description for the spelling list in the entry box.    You may want to identify the list with a 
person's name and the date on which the list was made. 

Note:    You must enter a unique description (the text you enter is not case sensitive). You may enter as 
many characters as you want.    However, the status bar at the bottom of the screen will only display up to 
80 characters of the description.

3. Select the OK button to save a copy of the spelling list under the new description.

The saved list is stored in a new directory and is now available for selection from the Load Spelling List 
dialog box (you can now load the list again at any time).

The program displays the new description of the list in the status bar at the bottom of the screen.    This 
spelling list is still in use until you load another one or create a new list. 
 
If you select the Cancel button, a copy of the list is not made and the description you entered is not 
applied.



Load a Spelling List

If you have saved a spelling list, you can load and work with that list again at any time. 

Note: If you did not save the edited list that is currently open when trying to load a different one, a 
message displays asking if you want to continue loading the list.    Select No to return to the Spelling 
Voice window and save the edited list.    If you do not save the current list, this version of the list will not 
be available for selection from the Load Spelling List box.    You will not be able to load this list at a later 
time.    In either case, the program continues to overwrite and replace the currently edited list with the list 
you want to load.

To load a spelling list, follow these steps:

1. From the Spelling Voice window, select [File: Load List] from the menu bar or, as    an alternative, select 
the Load List button from the Tool bar.    The Load Spelling List dialog box is displayed.    The descriptions 
of all of the saved spelling lists are listed in alphabetical order.

2. From the list of saved descriptions, select the spelling list you want to load and work with. 

Note:    If your description extends beyond the list box, you can use the horizontal scroll bars to view the 
rest of the description.

3. Select the Load button to make the spelling list available for use.    This list now replaces the previous 
list. You can go on to edit the list.

If you select the Cancel button, the current list remains in effect.



Delete a Spelling List

You can delete any spelling list that you have previously saved, at any time. The Delete List command 
displays only saved spelling lists from which you can choose to remove. 

When you delete a spelling list, the program deletes the saved copy only. The current list in use is still 
loaded and available to you.    If you then load another list or create a new list, the current list is also 
removed. 

Note: You cannot delete the spelling list currently loaded if it has never been saved. There is no saved 
copy to display and select in the Delete Spelling List box. 

To delete a spelling list, follow these steps:

1.    From the Spelling Voice window, select [File: Delete List] from the menu bar or, as an alternative, 
select the Delete List button from the Tool bar.    The Delete List dialog box is displayed.    The descriptions 
of all of the saved spelling lists are shown.

2.    Select the spelling list you want to delete from the list box.

3. Select the Delete button.    The saved copy of the spelling list is deleted and you are returned to the 
currently loaded spelling list. The spelling list is removed from the Load List dialog box as it no longer 
exists for loading.

Note: If you are trying to delete the currently loaded spelling list, the current list still exists for you to 
continue working with.    To remove the current list as well, either create a new list or load an existing list. 



Exit the Spelling Voice

To exit The Spelling Voice application, follow these steps:

1) From The Spelling Voice window, select [File: Exit].    The Exit message appears, asking you to confirm 
that you want to leave the application.

2) Select OK to exit the application.



Practice Spelling the Words

Before the student goes directly to testing their spelling, they can practice spelling the words on the list.

To practice your spelling of the words, follow these steps:

1. Select either the Learn button on the Toolbar or the Learn command from the File Menu.    The Learn 
dialog box appears. At the top of the box, the total number of words in the spelling list is displayed.

Note: If the Learn button is not selectable, the spelling list has been deleted.

 

2. Select [Start].    The Spelling Voice displays the first word on the list and the Start button changes to 
Next.

3. If you want, select the Say It button to hear the word.    Now you can hear the sound of the word as well 
as view it.

4. Type the word into the text field, which is directly under the word. The program repeats each letter as 
you type it.      If you type an incorrect letter, the program prevents you from continuing to type and gives 
the response "No".    When you spell the word correctly, the program gives the response "Yes".    Be 
careful to spell the word in both upper and lowercase letters.

5. Select the Next button (or the <Enter> key) to view the next word on the list.    After you select Next, 
The Spelling Voice updates the Progress bar, which shows the percentage of the list that has been 
completed.    It also increments the Completed field at the top of the box, which shows the number of 
words from the list whose spelling has been completed. 

Note:    To hide the Progress bar or the Completed and Total Words tally, select the Spell Setup command 
from the Options menu, and deselect those options. To adjust the volume or change the font size, select 
those commands from the Options menu.

6. Type the next word into the text field.    Repeat this process for every word on the list that you want to 
spell.    If you want to skip a word, simply select the Next button until you reach the word that you want to 
practice spelling.

7.    Select [Done] to exit.



Test your Spelling

When you are ready to measure your progress at spelling a list of words, select either the Spell button on 
the Toolbar or the Spell command from the File Menu.    This menu command is only available when a 
spelling list exists.

To test your spelling of the words, follow these steps:

1. Select the Spell Setup menu command from the Options menu to prepare the Spell dialog box.    If you 
want the timer, progress bar, score bar, smiley face, and/or the total number of words in the list to be 
displayed, select those checkboxes.    Also, in the "Auto Correct Misspelled Words After" field, enter the 
number of spelling attempts to occur before the program automatically corrects the misspelled word.

2. Select either the Spell button on the Toolbar or the Spell command from the File Menu.    The Spell 
dialog box appears. 

 

3. Select Start.    The Spelling Voice retrieves the list and displays a cursor in the text field. The program 
selects a word from the list at random and says it, which begins the test.    If you have the timer option 
selected from the Spell Setup menu command, the clock displayed begins to run. 

4. Type the word into the text field and press the <Enter> key. The program repeats each letter as you 
type it.      If you spell the word incorrectly, the program gives the response "No".    Depending on the 
number of spelling attempts you entered in the Spell Setup dialog, the program may move that word back 
into another location in the list, giving you a second opportunity to spell that word again, or automatically 
display the proper spelling. 

When you spell the word correctly, the progress bar shows the percent of the list completed so far and the 
score bar reflects the percent of the words on the list that you spelled correctly.    Also, the Completed field 
at the top of the dialog will increment its count by 1.

4. Select the Say It button to hear the next word on the list.    Repeat this process for every word on the 
list to be spelled. 

Note: To adjust the volume or change the font size, select those commands from the Options menu.

5. When you have completed spelling the entire list of words, and you incorrectly spelled at least one of 
the words, a message displays asking if you want to practice the words you missed.    Select Yes and the 
program opens the Learn box.    When the learning process is complete, you may retest the words you 
missed. 

If you spelled all of the words on the list correctly (score of 100%), the program generates a 
congratulations response and fireworks are displayed.



6.    You can select Start to take the test again or select Stop to end the spelling test and close the Spell 
box.



Set up the Spell Dialog

Use the Spell Setup command from the Options menu to determine what progress indicators to display 
when testing your spelling.    You may select one or all of the following checkboxes:

·     Smiley Face - select this checkbox if you want the smiley face symbol to display in the Spell 
box.    The smiley face will frown or smile depending on how low or high your score rate is for spelling 
the list of words.

·     Progress Bar - select this checkbox to display the horizontal bar that shows the number of 
words you have spelled out of the entire list.

·     Timer (clock) - select this checkbox to display the clock that keeps track of how long it takes 
you to spell the list.    It begins as soon as you press the Start button.

 ·     Score Bar - select this checkbox to display the vertical bar that shows the percentage rate (out 
of 100%) at which you are spelling the words correctly.

·            Word Count - select this checkbox to show a count of the total number of words in your 
spelling list and to indicate the number of words out of that list that have currently been spelled.    
This count displays at the top of the dialog. 

In addition, the Spell Setup command allows you to instruct the program to automatically correct a 
misspelled word after a certain number of attempts. You can set the automatic correction to be performed 
after 1 to 10 spelling attempts.    The default is 3 attempts. 

To use the Spell Setup command to display or not display options in the Spell box, follow these steps:

1. Select [Options: Spell Setup].    The Spell Setup box appears.

 

The Spell Setup box contains the checkboxes you can select to display options in the Spell box. 

2. To display the smiley face, the score bar, the progress bar, the timer (clock) and word count when 
spelling the list of words, make sure there is a check in the corresponding checkbox.    This indicates that 
the option or options are selected and will be displayed when you open the Spell dialog box.

3. To not display a particular option, make sure that the corresponding checkbox for that option is 
deselected.

4. Type a number from 1 to 10 in the "Auto-Correct Misspelled Words After _ Attempts" field.    This 
number indicates the number of spelling attempts to be completed before The Spelling Voice 
automatically corrects the misspelled word.    For example, if you want to try spelling a word 3 times 



before the program automatically corrects it for you, enter 3 in this field.

5. Select OK to apply your selections, or Cancel to cancel your changes.



Credit Card Payment

If you would like to register by using your credit card, use the following process. This is accessible 
through a toll-free phone call. In addition, you can access this service by postal mail, email or fax.    As 
always, you can register by check or money order through our PO Box.

Be sure to indicate that you are registering Product Number 11799. 

Your registration includes a code that you will enter into a registration dialog.    This will enable certain 
features and stop registration reminders from appearing when the program starts up.    You may use the 
code to upgrade to new versions that become available at no additional cost.    The code is sent to you 
within 24 hours of when we receive your registration.    You must provide an email address when you 
register to receive your registration code.      Otherwise the code will arrive by mail within 2 weeks.

Prices using this payment method:
US$ 15.00 (Extended),      US$35.00 (Professional)

You can order with MC, Visa, Amex, or Discover from Public (software) Library by calling:
1-800-2424-PsL 
713-524-6394 
between the hours of    7AM to 6PM CST (Monday-Thursday) and 7AM to 12:30PM CST (Friday)

By FAX to 713-524-6398

By CIS Email to 71355,470. 

You can mail credit card orders to:
PsL
at P.O.Box 35705, Houston, TX 77235-5705.

THE ABOVE NUMBERS ARE FOR CREDIT CARD ORDERS ONLY.
THE AUTHOR OF THIS PROGRAM CANNOT BE REACHED AT THESE NUMBERS.



Why Register?

Why should you register this product?    What's in it for you?    The topics listed below have more 
information on these questions:

The reasoning 
What you receive 
Registering The Spelling Voice 



Reasoning

Why should you register a Shareware product?    Since you already have the product, why should you pay 
for it?    The fact that many people using Shareware feel this way has a lot to do with the trend towards 
crippling and nagging.    Shareware authors are trying to create an incentive for those who use their 
products to actually pay for them.    In a perfect world, those who try Shareware realize that they only 
have a license to evaluate the product, and after a reasonable amount of time, will either pay for the right 
to continue using it, or remove it from their computer.

It isn't always a question of affordability.    I know folks with more money than you could imagine that 
would never pay for a Shareware package ("it's free software, isn't it?").    On the other hand, I know of 
people that barely make their bills each month that wouldn't think of using a Shareware product that they 
hadn't registered.

The only difference between this software and the software you buy at the store, is that shareware gives 
you the benefit of making sure that the product is of value to you.    If you are still using it after two weeks, 
then you should should consider registering.    Not doing so is no different than stealing a software 
package from your local computer store.

So much for the ethics of registering Shareware.    Understandably, some folks just aren't interested in 
this.      Even though it all makes sense, what they really want to know is: What do I get when I register? 



What You Get

This is what you get when you register one of my products:

· The ethics angle is covered.    You have done the Right Thing.
· Any nagging that is going on will stop.
· If there are features missing, they will be enabled.
· If you find a newer version later on, the registration number I send you will register that also.
· If you need to call me for help, you will have my undivided attention.
· I will send you a letter of heartfelt thanks, since you have acknowledged my hard work.

Granted, it's not a lot of material stuff.    But, most of my customers just want to tell me thanks, and I think 
that is what Shareware buyers are all about.



Display the Event Log

The Spelling Voice enables you to view and print a record of events that have occured since the program 
first started. This log is useful for monitoring a student's progress.    As long as there are no dialogs open, 
such as the Spell dialog, you can select this command at any time.

 To display or print the event log, follow these steps:

1. From the Spelling Voice window, select [Options: Show Log] from the menu bar.    The Log File window 
appears and shows a listing of all of the program's activities since it was first started (or since the log was 
last cleared).

        The Log shows a list of events such as the date and time the program started and closed, whether 
the Learn mode or Test mode was used, and what words were misspelled.

2. To print the log, select the Print button.

3. To reset the log file, select the Clear button. A confirmation message is displayed.    Select [Yes].    The 
program permanently removes the contents of the log and closes the Log File window.

4. To close the Log File without deleting its contents, select the Close button.



Change the Font Size

This command allows you to enlarge the size of the characters in the words to be spelled (in existing 
spelling lists and in lists yet to be created).    The size toggles between either a small or large font size.    
As long as there are no dialogs open, you can change the font size at any time.

 To enlarge the font size of the characters shown in the spelling lists, follow these steps:

1. From the Spelling Voice window, select [Options: Display Large Font] from the menu bar. A checkmark 
appears in front of this command indicating that it is in effect.

 2. Open either the Edit List dialog, the Spell dialog, or Learn dialog.    You will see the words in the 
currently loaded spelling list to be in the larger font size.

3.    To return the spelling words to the small font size, select [Options: Display Large Font] again. The 
checkmark is no longer shown indicating that this command is not in effect.    The words in the spelling 
lists will now display in the smaller font size.



Adjust the Playback Volume

This command allows you to adjust the volume level for playback sound only. If you want to adjust the 
recording volume, you must go into Control Panel in Windows or use the utility provided by your sound 
card manufacturer.

To change the playback volume in the Edit List dialog, the Spell dialog, the Learn dialog, and the Voice 
Setup dialog, follow these steps:

1. From the Spelling Voice window, select [Options: Adjust Volume] from the menu bar. The Volume dialog 
box is displayed.    The program displays the volume levels set in the Windows Control Panel (default).    
You can change the left speaker volume and the right speaker volume separately or together. The range 
is 0 to 100%.

2.    To change the left speaker volume only, make sure the Lock checkbox is deselected. Move the slider 
bar on the left (L) up to increase the volume or move the slider bar down to lower the volume. 

        Note:    As you move the slider bar up and down, you will hear the response phrase "Very Good".    
Hearing this response as you adjust the volume level helps you to set the playback volume you need.

3.    To change the right speaker volume only, make sure the Lock checkbox is deselected.    Move the 
slider bar on the right (R) up to increase the volume or move the slider bar down to lower the volume.

4.      To adjust both speakers simultaneously, select the Lock checkbox.    Whether the left and right 
volume bars are set at the same percentage or different percentages, moving one of the slider bars up or 
down will automatically move the other slider bar. For example, if you move the right slider bar up 10 
percent, the left slider bar will move up 10 percent.    The maximum percentage is 100%.

5.    To close the Volume dialog, select the Close button.    Your changes are automatically saved.



Change the Voice Setup

(Not available in the unregistered version)

Use the Voice Setup command to view and change the list of predefined responses in The Spelling Voice. 
You can also use this feature to customize the sound of the spoken letters.    To record your own voice for 
both the individual letters or the responses, follow these steps:

1. Select [Options: Voice Setup].    The Voice Setup box appears.

 

The Voice Setup box displays the entire list of responses already defined in the system that are 
generated when you perform a certain spelling activity.

2. To play back one of the responses in the list, highlight that response and select the Play button, or 
double click on the response.    You will hear that response.

3.    If you want to record your own voice over the one used currently for the response, highlight that 
response and press the Record button.    Wait for the text in the button to show the word "Stop".    Begin 
talking using a phrase that matches the description listed.    When you have finished speaking the phrase, 
press this same button.    The word is recorded.      The text will once again display "Record".

4. Press the Play button or double click on the word in the list to hear your recording.

Note:    Getting the phrases to come out right will take a little practice, but you'll find that it is actually quite 
easy.    Speak clearly and do not let your voice trail off, otherwise portions of the phrase or letter will get 
clipped off.

5. If you want to play or record a letter, select the letter by pressing the corresponding key or selecting the 
letter from the list box.      Continue as described above.

6. When you have finished recording your responses or letters, select Done. 



Contacting the Author

You may contact us electronically with the following email address:

Internet: info@overware.com

Or visit our WWW site at:
http://www.overware.com



Registration Form

To print this registration form, open the File menu and select Print Topic.

Mail to:
Overware Systems
P.O. Box 16514
Rochester, New York 14616-0514

Please register me as a satisfied user of The Spelling Voice    (ver 2.0) and send me the following product:

[      ]    Extended Version (allows customization of all voices in the program)    $15

[      ]    Professional Version (supports and tracks the progress of an entire classroom) $35 
[      ] Site license for ONE SCHOOL: $120
[      ] Site license for ONE DISTRICT: $1000

Please enclose US funds.    Make checks or money orders out to Overware. 

Name:_____________________________________________________

Address:___________________________________________________

City:______________________State:_______Zip:__________________

Phone(optional):_____________________________________________

Email address:______________________________________________

Where did you get this program?    Please include web page, address or phone number if possible.    This 
information is very helpful to us in terms of placing new versions of our software.

__________________________________________________

___________________________________________________________

Comments:_________________________________________________

___________________________________________________________

___________________________________________________________

___________________________________________________________

___________________________________________________________



Other Products from Overware Systems

Windows Shareware

Visit our web page at http://www.overware.com for the latest versions of these programs and much more.

WRackO -- A number strategy game that is easy and fun

WRackO is a challenging, card type strategy game that you can play against the computer or another 
person.    It is easy to learn, simple to master.    Quick thinking and risk taking are essential to being a 
winner in WRackO.

The Spelling Voice -- A learning program that makes spelling fun!

An educational program that is both fun and effective.    Students create and use spelling lists that are 
spoken to them in their own voice.    An easy to use interface guides spellers from the age of 5 to 50 in 
improving their spelling skills.    This program requires a sound card for proper usage.    A microphone is 
also suggested.

DeskMenu! --    A low profile, text based Program Manager for Windows

There is probably no other program you can add to your system that will make better use of its screen 
and disk space than DeskMenu!    This easily configured program manager and resource monitor speeds 
access to all your applications.    DeskMenu! places a menubar on your desktop and allows you to setup 
the menu headings to reflect how you categorize your applications. An optional InfoBar shows time, date 
and up to six different system resources. DeskMenu! can be used in addition to the Program Manager or 
it can replace it as the Windows shell.    All of this functionality in a good looking, easy to use package!

Yacht-Z    --    A dice strategy game for Windows

Yacht-Z is a version of the classic dice game.    You can play single or triple scoring varieties of the game. 
Up to four players can play at once. This is the original and most often reviewed of all Yacht-Z type dice 
games.    Several years of constant use and valuable input from users has honed this into one of the most 
enjoyable and challenging games available ( unless you prefer blowing up things! ).

WinGo! --    The classic Bingo for Windows

Finally, Bingo has arrived for Windows!    You match wits with Rosie, an alert and cunning adversary.    You 
can play with as many cards as you can handle at the speed you like.    Fully configurable to adapt to your 
playing style.    The registered version includes digitized voice calling for the most realistic Bingo play 
possible.

The Joker -- Jokes On Demand

The Joker gives you a laugh whenever you need it. Just as your day is getting completely boring, a 
window will appear with a joke to break the ice.    If one joke doesn't do it for you, then press the 
ANOTHER button for more.    The program is easy to use, and once setup to your liking, it will require no 



maintenance.    You can load different joke files, order more from the author, and even create your own.

BattleGrid -- War in a window -- Battleship for Windows 3.x

BattleGrid is a version of the classic board game.    Play against the computer or another person.    Watch 
the computer play against itself using different strategies.    Several levels of a computer opponent are 
available, from idiot to genius. 

SCAT -- A strategic and daring card game

Don't get stuck with the lowest hand!    SCAT is a card game involving four players that can be as simple 
or challenging as you want.    Features include defining strategy levels, setting the game speed, and 
leaving the cards face up or face down as you play.    This game even includes conversational chit chat 
between the players!    Very addicting and fun!

Mister Clean -- Clean up your hard drive

One of the most efficient ways to clean up those hidden but unwanted or unused files that take up needed 
space.    A slick Windows 3.x user interface makes this utility a must have for your toolbox.    Mister Clean 
finds files the you specify and sorts them by size.    You click on the ones you want deleted and then off 
they go, one-by-one (to be safe) or all at once.    Not sure what the file is?    Then run it right from Mister 
Clean and check it out before dumping it!    Truly a unique way of managing precious disk space.

InstallWare -- An application installer
InstallWare is a small, easy to use application installation program for Windows applications.    It costs 
nothing to use if you are distributing shareware or freeware.    Registration provides an extended version 
that enables automated construction of installation disks.

Windows Freeware

Check our web page (http://www.overware.com) to get these programs and other freeware.

16 Tons -- Drop your sound files here!
Simply plays WAV and MIDI files.    Accepts drag & drop operations from the file manager.    Most handy 
when used as an icon.

Random Saver -- Variety in savers
Make full use of that collection of screen savers you've got.    Now you can get them out of your 
WINDOWS directory.    This utility will run them at random from any location when you install it as the 
default screen saver in the Windows Control Panel.



Select the New button to indicate that you want to add a word to the spelling list.    When you select New, 
you can then type the word in the text field and press the <Enter> key to add the word to the list.    If you 
select New when the cursor is in the text field, the program clears all of the characters you entered in this 
field and allows you to enter another word.



Select the Record button to record the word you just added to the spelling list.    If you are in the Voice 
Setup box, select Record to record the response or letter you have selected using your own voice.    To 
record, select the letter or response you want and press the Record button. Speak into the microphone.    
The Record button changes to the Stop button.    Select the Stop button when you have finished.

Note:    For information on how to use The Spelling Voice with audio capabilities, refer to the How To 
section about preparing for using The Spelling Voice. 



Select the Play button to hear or play back the word in the spelling list that you just recorded.    If you are 
in the Voice Setup box, select Play to hear the predefined response or letter highlighted in the list.



Select the Delete button to remove a word from the spelling list.



Select the Start button to instruct The Spelling Voice to retrieve the spelling list.    The program displays 
the first word on that list.    After you spell the word currently displayed, the Start button shows as the Next 
button.    Select the Next button to view the next word on the list.



Select the Say It button to instruct the program to repeat the current word so you may hear it again. 



Select the Stop button to cancel the spelling test in progress or when completed, and to exit the Spell 
box.



Select the Done button to end the task you are doing and to close the box you are currently in.



Select the OK button to apply and save your selections for the Spell box.



Select the Cancel button to cancel your changes in the Spell Setup box, and not apply them to the Spell 
box.



Credits

The Spelling Voice was conceived, designed and written by
                Bob Dolan

The Spelling Voice Help system was written by
                Ginny Contestable

Valuable testing was performed by the following students (who improved their spelling in the process):
                Joan Dolan, 13 yrs. old
                Amanda Dolan, 14 yrs. old
                Shane Smith, 10 yrs. old
                Michael White, 7 yrs. old
                Michelle Contestable, 8 yrs.old
                Mrs. Bundy's second grade class at DeWitt Road school in Webster, NY

Matthew Erwin, age 10, Floyds Knobs, IN 



Opens the on-line Help and shows a topic related to the current task.



The list of words in the current test.



The word currently being defined.



The word that the student is learning is shown here.



This is where the student types the word that is being taught.



This is where the student types the word being tested.



The current letter to be defined is shown here.    Use the arrow buttons to change the letter.



This is a list of responses that The Spelling Voice will make while the program is running.    Select one 
with the mouse to change or hear it.



A brief description of the currently selected response or letter is shown here.    Any action (such as Play or 
Record) will act upon it.



Registering The Spelling Voice

If you have already registered and would like to validate your copy of The Spelling Voice, open the 
Register menu and select the Enter Registration Number item.    Enter the number that was provided on 
your registration letter.    The OK button will become enabled, and you can press it.    When the dialog 
closes, the program becomes the extended registered version.    You will no longer see registration 
reminders, and the Voice Setup option will become available in the Options menu.    Thank You for your 
support!

Otherwise...

The Spelling Voice is distributed as shareware.    This means that if you regularly use the product and 
benefit from it, you should register with the author (see name and address below).    The software you 
now have is only missing minor functionality.    This indicates a basic trust of the shareware concept by 
myself and other shareware authors who provide useful products with the hope of some type of return for 
their efforts.

When you register, the Voice Setup is enabled which allows you to customize all responses used in the 
program to whatever voice and phrase is best suited to your needs.    Also you will be able to create word 
lists up to 100 words in length.

For your convenience we have four different ways to register.    Use the method that works best for you.    
If you choose not to pay by mail (method 1), then you must choose between an electronic registration or a 
disk registration.    The four registration methods are:

1. Postal Mail
Please print the registration form and fill in the requested information.    This requires you to mail a check 
in US funds to us.    Click this link to access the form.

2. Credit Card
  

  

3. Compuserve SWREG

  

4. OnLine Registration

If you have an active Internet connection and a properly configured browser, you can use    the method 
described below to register and receive your registration code within 24 hours.

From your Web Browser
Start your browser and enter the following on your URL line: http://www.overware.com/spvreg.htm
        Your browser will open to the The Spelling Voice registration page.    Follow the instructions there to 
complete the transaction.



Registering Through Compuserve

If you have a Compuserve account, you may register instantly by using the SWREG service online.    As 
always, you can register by check or money order through our PO Box.

Your registration includes a code that you will enter into a registration dialog in the program's menubar.    
This code will enable certain features and stop registration reminders from appearing when the program 
starts up.    You may use the code to upgrade to new versions that become available at no additional cost. 
The code is sent to you within 24 hours of when we receive your registration.    You must provide an email 
address when you register to receive your registration code.          Otherwise the code will arrive by mail 
within 2 weeks.

This is SWREG Product Number 12450.

Prices using this payment method:
US$ 15.00 (Extended),      US$35.00 (Professional)

 To access this system, logon to Compuserve and enter "GO SWREG". Select Register 
Shareware. Then enter the information requested. They will add the fee to your bill and notify us. We will 
then e-mail a confirmation that will include your registration code



Disclaimer and Distribution

Distribution

If you distribute The Spelling Voice to friends, associates, a web page, or to a computer bulletin board 
system (BBS),    you may only distribute the compressed file including the copyright and disclaimer.

Disclaimer

The Copyright Owner hereby disclaims all warranties relating to this software, whether express or implied, 
including without limitation any implied warranties of merchantability or fitness for a particular purpose. 
The Copyright Owner will not be liable for any special, incidental, consequential, indirect or similar 
damages due to loss of data or any other reason, even if The Copyright owner or an agent of The 
Copyright Owner has been advised of the possibility of such damages.    In no event shall The Copyright 
Owner's liability for any damages ever exceed the price paid for the license to use the software, 
regardless of the form of the claim.    The person using the software bears all risk as to the quality and 
performance of the software.



Resolving Problems

Since The Spelling Voice creates and plays sounds you must have a functioning sound card and a 
working, good quality microphone to properly use this program.

Most of the problems that you will run into when trying to use The Spelling Voice have to do with making 
sure that your sound hardware is working properly.    If you do not hear a clear welcome message when 
you start the program, be sure that you are able to hear sounds from other programs.    The Spelling Voice 
uses standard Windows API calls to play and record sound.    If you are experiencing difficulty, refer to the 
manual that was provided with your sound card, and use the Control Panel to resolve the issues.

Here are a few hints to common problems:

Low level recordings: 

Problem      -      Recordings made by the user are much lower in volume than those built into the program.

Hints    -    Be sure that your microphone is not damaged and that it is of good quality.    If it is an electrolet 
microphone, it will have a battery inside that could be in need of replacing.    Radio Shack sells a very nice 
microphone of this type for about $25.

Also, you may find that on some sound cards you can increase the recording volume by going into the 
sound card setup and increasing the recording volume.    A problem exists however, in that the "AGC for 
Wave in" check box is not saved, requiring that you do this all over again when you next start your 
computer.    The following is a web page that provides a workaround for this problem: 
http://www.microsoft.com/kb/articles/q135/2/26.htm

My Word Lists dissapear:

Problem    -    After I use the program once, the word list is gone.

Hints    -    When you first run The Spelling Voice, it holds an unsaved default word list that you can 
practice with.    You should save this list right away so that it will be there when you run the program 
again.    The list is unsaved to give you an idea of what it is like to save a word list.    When you exit the 
program and the current list has not been saved, you will be alerted so that you may go back and save it. 
If you accidentally ignore this warning, you can restore the list by re-installing The Spelling Voice.

I can't enter my registration number:

Problem    -    "I type in the registration code that you sent me, but the OK button stays gray."

Hints    -    Make sure you have entered the letters in upper case.




