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Fixed It! ScoreBook Help Utility

Thank you for your interest in Fixed It! Basketball ScoreBook.    We hope the information 
provided in our help utility will answer most of your questions about our product.

The Screens in ScoreBook have been designed to make data entry as easy as 
possible.

In many cases you may find using the Tab and Alt keys easier and quicker that using a 
mouse or other pointing device:
      - Use the Tab key to jump from one field to another.
      - Also, whenever you see a button that has a letter underlined, you may use the Alt 
key in combination with that letter to select that button.    For example, the Print button 
may be chosen by selecting Alt-P.

We are constantly looking for ways to improve our products.    If you have any 
questions, comments, or suggestions, feel free to e-mail us at rcochran@fixedit.com 
or dturner@fixedit.com.

Thank you for your interest in our product and good luck with your game!



Teams & Rosters

Before you can use ScoreBook to score a game, you must first create at least two team 
files.

To create a team file:
    - Select Team from the File Menu
    - Select New
    - Enter a Team Name, Coach, and Assistant in the fields provided
    - Select a Team Logo by selecting the New Logo Button.    The Team Logo will be the 
background for that team's Scorecard Window and can be any .BMP file.    Use the 
Fade Up and Down Buttons to lighten the Team Logo so that the data in the Scorecard 
Window will be plainly visible.    Note: 256-color Bitmaps will work best with ScoreBook. 
Bitmaps with more colors may not fade.
    - Select the Edit Roster Button
    - To add a player, enter player information in the Name, Position, and Uniform Number 
fields, then select the Add Player Button.    Repeat this for each player on the team, then 
select the OK Button to return to the Edit Team Dialog.
    - Select the OK Button again, then enter a file name for your team.    NOTE: The team 
file should be given a .TEM extension.

To import a team file from an ASCII text file:
      - The text file must have the following format:
                  line 1: Team Name (max of 25 characters)
                  line 2: Coach Name (max of 25 characters)
                  line 3: Assistant Name (max of 25 characters)
                  line 4..n:Player Name (max of 25 characters), Position(0..3), Starter Index(0..5), Uniform 
Number(-1..99)

    Position: 0 - Bench     Starter Index: 0 - Not a Starter 
              1 - Guard                    1 - Guard #1 
              2 - Center                   2 - Guard #2
              3 - Forward                  3 - Center
                                           4 - Forward #1
                                           5 - Forward #2

    Note: Enter -1 for Uniform Number if Player' s Number is 00.

    - Select Team from the File Menu
    - Select Import
    - Select a Text file from the list provided
    - Enter a file name for your team

To edit a team file:
    - Select Team from the File Menu
    - Select Edit
    - Select a team from the list of *.TEM files provided
    - Change any Team fields (Team Name, Coach, or Assistant) if desired.
    - Select the Edit Roster Button if you wish to add, delete or change any player in the 



roster.
    - To Add a player, enter player information in the Name, Position, and Uniform 
Number fields, then select the Add Player Button.
    - To Remove a player from the roster, click on the player's name in the Current 
Roster List Box, then select the Delete Button.
    - To Edit a player in the roster, click on the player's name in the Current Roster List 
Box, then change the Name, Position, and Uniform Number fields as desired.    For 
these changes to take affect, either select the Update Player Button or click on any 
player name in the Current Roster List Box.

      See also:
      Lineups
      Games



Lineups

Lineups can be changed in three ways:

1) When creating or editing a Team, a default Starting Lineup can be defined.    There 
are Five Drop Down Lists provided to the right of the Current Roster:

   - Choose two  Guards  from the lists beside the letter G
   - Choose  a   Center  from the list  beside the letter C
   - Choose two Forwards from the lists beside the letter F

Whenever a game is created using this team, the game will use this Lineup information 
by default.    It is not necessary to explicitly define all or any Starting Lineup information 
when creating a Team Roster, because the Lineup can be modified when creating a 
game. 

2)  When creating a Game, all team information, including the Roster and Lineup can be 
changed.    Note that team changes made here, such as the Starters, apply only to this 
game and are not saved to the Team File.    Permanent team changes, such as new 
players, should be made via the Team Dialog prior to creating a game.

3)  To make a Lineup change during a Game:
      - Select a player from the Home Bench or Visitor Bench Combo box
      - Select the button of the player to be replaced

Note: When a player's name appears in red, that player is in foul trouble.

      See also:
      Teams & Rosters
      Games



Creating Games
After creating two Teams with complete Rosters, a new game can begin.

To create a new game:
      - Select Game from the Main Menu
      - Select New from the Game Menu
      - Input the game information (i.e. Date, Time, etc.)
      - Select the Home Team Select Team Button and choose one of the Team files 
(.TEM)
      - Make any necessary Home Team Roster and Starting Lineup changes by selecting 
the Edit RosterButton
    - Select the Visiting Team Select Team Button and choose a different Team files 
(.TEM)
      - Make any necessary Visiting Team Roster and Starting Lineup changes by 
selecting the Edit RosterButton
      - Select the Start Button if you wish to begin scoring.    Otherwise select OK to save 
any changes or select Cancel to abort changes to the Game file.

      See also:
      Game Play
      Teams & Rosters
      Lineups



Game Play

Once a game has begun, the Scorer:

- Enters data by selecting the buttons associated with each player on the court and 
selecting appropriate radio buttons.
- Makes substitutions (Select a player from the Home Bench or Visitor Bench Combo 
box, then select the button of the player to be replaced)
- Records Time Outs by selecting Home or Visitor Time Out Buttons
- Corrects errors via Edit Home Events or Edit Visitor Events Buttons 
- When each quarter/half is over, selects the Up Quarter/Half Button.
- Once a game is over, chooses the Stop Game Button
- Is prompted to save any changes.

Example 1:

Home Team Guard, Rob Cochran, gets the opening tip, dribbles down the court and 
misses a three point attempt.    Visiting Forward, Jim Jones, gets the rebound, but 
throws the ball out of bounds.

    - Select the Guard Button associated with the name, Rob Cochran
    - Choose Shot Missed, 3-Missed
    - Select the Location on the Court where the shot was taken (Only if the Prompt For 
Shot Location Option is chosen)
 ScoreBook automatically prompts for Rebounding Player on a missed shot
    - Select the Forward Button associated with the name Jim Jones
    - Again Select the Forward Button associated with the name Jim Jones
    - Choose Turnover, Bad Pass

On the Inbound Pass, the Home Team Center, Don Turner, Shoots a 10-footer good.
    - Select the Home Team Center Button
    - Choose Shot Made, 2-Made (Home Team Score increases by 2)
    - Select the Shot Location
     ScoreBook automatically prompts for Assisting Player on a made shot
    - Select a Player to award an Assist; or Select the Cancel Action Button or Right 
Mouse Button

After further review, the scorer realizes that the Shot Location was entered incorrectly.
  - Select the Edit Home Events Button
    - From the Events Drop Down List, select the Shot event
    - Select the Update Event Button
    - Select the proper Shot Location
    - Select OK

Example 2:



While guarding a player, Home Team Guard, Rob Cochran, is apparently called for a 
foul.
    - Select the Guard Button associated with the name Rob Cochran
    - Choose Foul, Defensive

After further review, the foul is determined to be on the Center, Don Turner.
    - Select the Edit Home Events Button.    The last event is automatically selected.
    - From the Player Drop Down List, select the name, Don Turner
    - Select OK or the Update Event Button

Note:    A foul is indicated by an X in the Team Window.    The Color indicates which 
quarter or half the foul occured:

Quarter Half Color
   1       1   Green
   2           Blue
   3       2   Purple
   4           Red
  OT      OT   Red 

Example 3:

At the end of the first quarter, Visiting Forward, Jim Jones makes a half-court shot.
    - Select the Forward Button associated with the name Jim Jones
    - Choose Shot Made, 3-Pointer
    - Select a Player to award an Assist, or Select the Cancel Action Button

After further review, it's determined that the shot was made after the buzzer.
    - Select the Edit Visitor Events Button.    The last event is automatically selected.
    - Select the Delete Event Button
    If an Assist was awarded:
        - From the Events Drop Down List, select the last event
        - Select the Delete Event Button again
    - Select OK



Internet Access

As of this release the Fixed It! ScoreBook Home Page URL is 
http://www.FixedIt.com/basketball.shtml.    Unregistered users can download the latest 
shareware version of Fixed It! ScoreBook and other Fixed It! products such as Win A 
Lotto!, Fixed It! Baseball ScoreBook, and Fixed It! Football ScoreBook from this 
site.

See also:
      Registration



Removing ScoreBook

Since ScoreBook is self-contained (i.e., nothing is written to your Windows directory), 
removing it from your system is as easy as removing the ScoreBook Directory.    This 
can be accomplished from an MS DOS prompt by simply performing the deltree 
instruction using the ScoreBook directory as a parameter (e.g., DELTREE C:\BKSB), 
which will remove all ScoreBook files and subdirectories.

This may also be accomplished through the Windows 95 interface:
- Select My Computer
- Select the Drive on which ScoreBook resides (default = C:)
- Select the ScoreBook Folder (default = BKSB)
- Press the Delete key on your keyboard or drag the Folder to the Recycle Bin

To remove the Fixed It! Folder your Windows 95 Start menu:
- Select Start
- Select Settings
- Select Taskbar
- Select the Start Menu Programs Tab
- Select the Fixed It! Software Folder
- Select Remove
- Select Yes when asked if you are sure you want to remove the folder and contents



Options

The Use Sound Effects option is enabled/disabled via the Options Menu.    Sounds are 
only available for systems with Sound Blaster compatible sound cards.

When the Prompt for Shot Location option is enabled, the scorer is prompted to select a 
location for all 2 and 3 point shot attempts during a game.    This information is used in 
the Shot Analysis Statistics option.

The League Options are provided to allow the user to set the following:
    - Quarters Versus Halves
    - Foul Trouble, Foul Out, and Bonus Limits
    - 3-Point Arc (None, College, or Pro)
    - Number of Time Outs

The Wallpaper option allows the scorer to select a bitmap (*.BMP) to be displayed as 
the main window background.    This bitmap can be centered in the window, tiled, or 
stretched to fit the entire window.

See also:
      Statistics



Printing

To Print Scoresheets for a Game:
    - Select Print from the File Menu
    - Select Game
    - Choose a Game file from the Files List
    - Select the desired Scoresheets using the Print Option Radio Buttons
    - Select the Print Button

Note: If you get insufficient memory error messages while printing a Game, try printing 
the Home & Visitor Scorecards one at a time. 

If you still have trouble, try selecting Printer Setup and changing the Orientation to 
Landscape.

To Print a Registration Form See:
        ScoreBook Registration
 
To Print Statistics See:
        Statistics



Statistics

To View and Print Player and Team Statistics:

 - Select Statistics from the File Menu

 - Select Player and Team Statistics

 If a game file is open:
 
- Choose a team to analyze, then press OK

If no game is currently open:

 - Choose a game file (*.GAM) to be analyzed from the Files List Box

 - Click on the Select Game Button to add this game to the Games To Analyze List Box.    Add as many 
games as you like in the same manner.    Shareware Note:    Only one game at a time is allowed for 
statistics evaluation in the Shareware version.

 - To remove a game from consideration, choose the game file in the Games To Analyze List Box, then 
click on the Remove Game Button.

 - Once all games are selected, you must choose a team from the Team To Analyze Drop Down List 
before you can proceed.

 - Once a Team is selected, choose OK.

 The following statistics will then be calculated and displayed:

  GP   Games Played            AS   Assists
  PP   Periods Played          APG  Assists Per Game
  TP   Total Points            OF   Offensive Fouls
  PPG  Points Per Game         DF   Defensive Fouls
  2M   Twos Made               FPG  Fouls Per Game
  2A   Twos Attempted          TECH Technical Fouls
  2%   Twos Percentage         OR   Offensive Rebounds
  3M   Threes Made             DR   Defensive Rebounds
  3A   Threes Attempted        RPG  Rebounds Per Game
  3%   Threes Percentage       ST   Steals
  FGM  Field Goals Made        SPG  Steals Per Game
  FGA  Field Goals Attempted   BS   Blocked Shots
  FG%  Field Goal Percentage   BPG  Blocked Shots Per Game
  FTM  Free Throws Made        TO   Turnovers
  FTA  Free Throws Attempted   TPG  Turnovers Per Game
  FT%  Free Throw Percentage

- The stats may be sorted by any of the fields above by selecting the desired method from the Sort By 
Drop Down List.
 
- To Export the statistics to an ASCII Text file, Choose the Export Button, then select a file name.    The file 
created will be comma-delimited and easily imported into your favorite spreadsheet or database 
application. 

 - To Print the statistics, Choose the Print Button



To View and Print Shot Analysis:

 - Select Statistics from the File Menu

 - Select Shot Analysis

 If a game file is open:
 
- Choose a team to analyze, then press OK

If no game is currently open:

 - Choose a game file (*.GAM) to be analyzed from the Files List Box

 - Click on the Select Game Button to add this game to the Games To Analyze List Box.    Add as many 
games as you like in the same manner.    Shareware Note:    Only one game at a time is allowed for 
statistics evaluation in the Shareware version.

 - To remove a game from consideration, choose the game file in the Games To Analyze List Box, then 
click on the Remove Game Button.

 - Once all games are selected, you must choose a team from the Team To Analyze Drop Down List 
before you can proceed.

 - Once a Team is selected, choose OK.

 - Make a selection from the Player Drop Down List.    Green Circles denote shots made.    Red X's denote 
shots missed.

 - To Print the Shot Analysis, Choose the Print Button



ScoreBook Registration

To receive a Registered copy of Fixed It! ScoreBook:

      - Select Print from the File Menu.
      - Select Registration Form...
      - Enter your name, mailing address, e-mail address and comments into the menu 
fields.    If you provide an e-mail address, we will status your order as soon as we 
receive it.    Also, please provide feedback in the Comments field, especially features 
you would like to see implemented in future releases of ScoreBook.
      - Select the OK Button.
      - Make out a check or money order to Fixed It! Software for $35 (U.S. Funds 
only!).
      - Mail your form and check to:

                  Fixed It! Software (Basketball ScoreBook)
                  P.O. Box 372
                  Capshaw, AL 35742

Registering has the following benefits:

      - Full-featured product with no nagware or other shareware limitations (such as 
printing game scorecards and statistics)
      - Three months of free technical support (via e-mail), support files, and minor 
upgrades (via the registered portion of the Fixed It! ScoreBook Home Page)




