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How to Get Started

This game is written as a MDI application. The game main window is divided into many child windows.
Each of the child windows (Strategic, Tactical, and Ship Status) is moveable and resizable. The
Strategic window is used to give the player an overall view of the quadrant. The buttons represent the
sectors of a quadrant. The Tactical window is the close-up view of a sector. The Ship Status window
displays the current status of the player's ship.

The menu commands are different depending on the currently selected child window. For instance, to
use the Strategic Scan command, the player must first select the Strategic window as the active window.
Then, the Control menu option will change to reflect the commands available for the Strategic window.
Each window has different Control commands.

Most of the menu commands have an accelerator keyboard command. For example, the Strategic Scan
command can be invoked by the "C" key. The accelerators are listed to the right of the menu command.



How to Use Strategic Display
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The player starts out a game in sector 0,0 (upper left corner of the Strategic window). The button is
depressed indicating the current sector being displayed by the tactical window. The Sector Color Code
for the sectors indicates the contents of the sector. The player can use the Strategic Scan command to
scan the sectors next to the current sector. To move to another sector, the player presses the button of
the sector to warp into. A maximum of two sectors can be jumped at a time.




How to Use Tactical Display

The Tactical window uses the mouse to control the player's ship. The left mouse button is double-
clicked at the location the ship is to move to. The right mouse button is used to activate the Tactical
Popup menu. The player places the cursor over the object to be acted upon. Then the right mouse
button is pressed. The player then selects the command to be performed on the object. For example,
clicking the right mouse button on an enemy ship and then selecting "Fire Lasers" will fire the lasers at the
ship. The player may also interact with some background objects such as a planet from the tactical
display, for example.



How to Use Ship Status Display
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The Ship Status window contains the current status of the systems for the player's ship. The status is
constantly updated. The player may change the order of the systems being repaired by using the Ship
Status Repair command. For example, if the player wishes to have the ion engines repaired, the player
would select the "Repair" command. The "lon Engine" button is then selected to be repaired next.




Background Objects

Background objects are seen on the Tactical Window. They are objects contained in the current sector.
The player can interact with some of the objects. Following is a list of the objects:

This is a derelict. The player can dock with it.

This is a gaseous planet. The player can orbit it.

This is an asteroid belt.

The number of derelicts and planets can be displayed from the Strategic Game Status command.

These are convoy ships.



Copyright and Licensing

IIE =

-

3FmM

Copyright © BFM Software 1992
Copyright © Brett McDonald 1992

Following are the system requirements:
1) 286 or higher processor
2) Windows 3.0 or higher
3) Windows operating in standard or enhanced mode
4) Mouse or other pointing device
5) Color monitor - High SVGA resolution recommended.

This game is shareware. This game is NOT free. If you like the game and continue to use it, you MUST
register the game. Registration Fee: $11.95 U.S.

BFM Software

Brett McDonald

20278 Old Homestead

Harper Woods, M| 48225

Compuserve ID 73770,1254

American On-line ID BrettMc

Please include your exact name as you want it registered and the generated key from the registration
dialog box.

You may distribute this software as long as the following files are included:
WBREADME.TXT
WB.EXE
WB.HLP
All the above files, must be combined into a single file ZIP or other compression format for distribution.

Beyond a fee for the reproduction and media cost, no fee may be charged for distribution of this software.
This software claims no warranty, implied or otherwise. This software is provided "AS IS". The author

claims no responsibility for any damages that might be caused by the use or abuse of this software. This
software remains the property of the author. This software may not be modified in any way.



Game Storyline

The Rolon Empire has just attacked the home worlds. The colonies have been completely destroyed.
The Rolons have vowed to annihilate all humanoids in the galaxy. Your battlestar is the only warship left
from the colonies. Your mission is to start a new colony far away from this quadrant. Commander, you
must search the quadrant for ships with colonists on them and have them join your convoy. You must
also destroy all Rolons in this quadrant. Only after these tasks are completed will you be assured of a
successful escape. The High Council wishes you good luck. The fate of our very existence depends on
you.



Game Levels

This game can be played at different levels. The three levels are Beginner, Normal and Advanced.
Below are the descriptions of the levels:

Beginner

This level is designed for new players. It is very easy and not very challenging.
* The 2 Command bubbles are automatically displayed at the beginning of the game.
* The player gets fewer missiles.

* The player gets fewer fighters.

* The lasers recharge faster.

* There are fewer sectors in the quadrant.

* There are fewer enemy ships in the quadrant.

* Natural disasters happen less frequently.

* Enemy ships fire slower.

* The player's score is penalized.

* One less Wild Weasel Shuttle is supplied.

Normal
This level is designed for a moderately paced, somewhat challenging game.

Advanced

This level is designed for players wanting a challenge. It is very fast paced.
* The player gets more missiles.

* The player gets more fighters.

* The lasers recharge slowly.

* Many sectors are in the quadrant.

* Many enemy ships are in the quadrant.

* Natural disasters happen more frequently.
* Enemy ships fire faster.

* The player's score is enhanced.

* One more Wild Weasel Shuttle is supplied.



Natural Disasters

Natural Disasters are just a few of the situations commanders must deal with. The situations are very
random and are not predicable. They are just a "fact of life" while being in space.

Some natural disasters will cause damage to any ship in the sector. Ships in a planet's orbit will be
protected by the atmosphere. These types of Natural Disasters can either work for or against a player.
If the player's ship is very damaged, it could finish the player off. On the other hand, it will damage all
the other ships in the sector the player is trying to defeat. Super Nova Bursts and lon Storms are

examples of these.

The other natural disaster is called a Worm Hole. It does not cause damage to a player's ship. It just
makes it more difficult to keep control of the ship. It moves the ship to another location in the guadrant.
This natural disaster can also work for or against a player, depending if the player wants to be moved
away or near a sector with enemy ships.



Races of Universe
There are only two races known in the universe. Below is a description of them.

The colonies are inhabited by humanoids. They were started by a small group intergalactic travelers
from a planet called Earth. All contact with the mother world was lost hundreds of years ago. The
colonists are a peace loving people.

The Rolons are a group of highly evolved cyborgs. The original Rolons were created to mine remote
planets. Some of the cyborgs were forgotten on a planet. After a hundred years, a colony expedition
stumbled onto the cyborgs. They identified themselves as the Rolons. Then they killed the colonists
and stole their ship. The Rolons have vowed to destroy all "inefficient" humanoids.



Scoring

Win Battle keeps track of the player's score throughout the game. Every time an enemy ship is
destroyed, the player's score is incremented. The current score can be displayed from the Strategic
Control Status command. The dialog box displayed will contain the current and high score for the player.

Scoring values are as follows for destroying objects:

Object Score Description

10 Baseship Class Ship
2 Raider Class Fighter

The score is multiplied by the game level. The levels are beginner - one, normal - two, and advanced -
three. For example, if an object's score is 10 and the player's level is normal the total score for
destroying the object is 20.

Recruiting a ship will add 50 points to the player's score.

The following will cause a player's score to be decreased:
* Launch Wild Weasel - decrease by 100.

A bonus is given to the player for destroying all enemy ships in the guadrant. The bonus is based on the
time taken to complete the game.



Sector Color Code

The Sector Color Code is the code for the notches in a scanned sector on the Strategic Display. Below
is an example of a sector display followed by an explanation.
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The gray button on the left is an unscanned sector. The bottom of the window has the color code as
follows:

Der - Derelict

Con - Convoy Ship from colonies

Bas- Rolon Baseship

Plan - Planet

For example, the second from the left button indicates that at least one convoy ship and a Rolon
Baseship is in the sector. More than one of a class could be present in a sector.



Ships

Each race has its own ship class and fighter class. They are all different in appearance and capabilities.
Below is the information on each ship:

Class: Battlestar

Type: Carrier

Race: Colonists

Weapon: Lasers, Fighters and Missiles

Speed: Average

Armor: Strong

Hull: Thick
This ship is an all around performer. It is very large and heavily armored. It uses fighters as its main
weapon. It is fast and very well designed. It will serve the player well.

.I*‘.

Class: Interceptor
Type: Fighter
Race: Colonists
Weapon: Lasers
Speed: Fast
Armor: Weak
Hull: Thin

This fighter is fast. It uses a small laser. This fighter is carried by battlestars.

L]

Class: Baseship

Type: Carrier

Race: Rolons

Weapon: Lasers and Fighters

Speed: Average

Armor: Strong

Hull: Thick
This ship uses fighters as its main weapon. It usually carries about one half the number of fighters as a
battlestar.

Class: Raider
Type: Fighter
Race: Rolons
Weapon: Lasers
Speed: Fast
Armor: Weak
Hull: Thin
This fighter is fast. It uses a small laser. This fighter is carried by baseships.



Tips on Playing
This topic will give a few tips on how to play Win Battle. The tips are as follows:

Strategic Display

* The player should use Scan Command to view sectors before entering. This will eliminate surprises.

* The player should move to every other sector and scan area. This way the player can map the entire
quadrant without entering every sector. The player must remember that if the scanners are
destroyed, all the sector displays will be reset.

Tactical Display

* To defeat Baseships class ships - the players launch a few fighters at the ship. Then, when the fighters
are half-way to the ship, the player should fire a few missiles. The fighters will attack the baseship's
fighters on the way there. The missiles will then destroy the baseship.

* The player can orbit a planet to hide from enemy ships. The enemy ships cannot fire at the player
while a ship is in orbit but, the player cannot fire either.

* The player can dock with a Derelict. The crew will be able to strip off the extra missiles and fighters left
onit. However, it can only be stripped once.

* Releasing a Wild Weasel Shuttle is a good way to get out of a critical situation. The enemy ships will
attack it and not the player!

* The player should try to get on the other side of an Asteroid Belt. The enemy ships will go through
them to get to the player's ship.

Ship Status Display

* The player must use the Repair command to indicate which damaged system to repair next. Damage
control repairs systems in a certain order. The order is listed on the repair screen. Damaged
systems are repaired in a top-down order.



Menu Commands
File Menu
xxx Control Menu
Option Menu
Window Menu
? Command
Help Menu
Tactical Popup Menu



File Menu
The File Menu includes commands that enable the player to control the game.

For more information, the user should select the File Menu Command Name:
New
Close
Register
Uninstall
Exit



New

Selecting the New Command from the File Menu will cause a dialog box to be displayed. The user can
then restart a game or cancel the new command. The user can select among three game levels that are
beginner, normal, and advanced. The sound may also be set on or off on the dialog box.



Close

Selecting the Close Command from the File Menu will cause the currently active window to close. The
windows of the game are hierarchically connected so closing a window may cause other windows to
close. The relationship is as follows:
Strategic Display owns:
Tactical Display
Ship Status Display

Also, windows may be closed by using the close command in the window's system menu.



Register

Selecting the Register Command from the File Menu will cause a dialog box to be displayed. The register
command is used to register the game.

The user should enter his/her name in the name fields. This is used in messages to the user. The user
must enter his/her first and last name.

The register dialog box has directions on the steps needed to register the game. This software must be
registered after the 15 day trial period.



Uninstall

Selecting the Uninstall Command from the File Menu will cause a message box to be displayed. The
user can select YES or NO to uninstall Win Battle.

The following files are removed from the user's system in the uninstall processing:
* WBREADME.TXT - text file with miscellaneous Win Battle information
* WB.HLP - Win Battle help file
* WB.INI - Win Battle parameter file
* WB.EXE - Win Battle program file

Note: If share is installed in the user's system, Win Battle will encounter an error in the uninstall process.
Share will not allow a program to access a file that another program is accessing. Windows is executing
WB.EXE so the program cannot access it to delete it. The error message can be ignored and the
WB.EXE file deleted by hand.



Exit

Selecting the Exit Command from the File Menu will terminate Win Battle.



xxx Control Menu

The Control Menu includes commands that enable a user to issue commands for the currently active
window. This game is an MDI windows application. Therefore, the control's command will have
different options based on the currently active window. To make a particular window active, the user
must either click in the windows or use the window command to select the window.

For more information, the user should select the Control Menu for the particular window:

Strategic Display Window
Scan
Game Status
Ship Status

Tactical Display Window
Launch Wild Weasel

Order Fighters Back
Doc

o
-
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—

Recruit Ship
Stop
Ship Status Display Window

Repair



Strategic Scan Command

The Scan Command will scan the sectors around the current sector. The sectors will lose the black null
indication on the button face for the scanned sectors. The sectors will indicate the contents by the color
of the notches in the button. The Sector Color Code allows a user to determine the contents of a sector
without entering the sector.




Strategic Game Status Command

The Game Status command will display a dialog box that contains information on the status of the current
game. It will display the following information:
Level of game - level of the current game
High Score - highest score yet obtained for the game
Current Score - score of the current game
Game time - length of current game
Current location - current sector of player's ship
Number in convoy - number of ships recruited for convoy
Derelicts - number of derelicts in quadrant
Planets - number of planets in all sectors
Asteroid belts - number of asteroid belts in quadrant
Enemy Ships - number of enemy ships still remaining




Strategic Ship Status Command

The Ship status command will start the Ship Status window. It will display all systems of the ship and
their condition. While the Ship Status window is active, this command is grayed.



Tactical Release Wild Weasel Command

One Wild Weasel shuttle is carried on all Battlestar class ships. This shuttle may be released at any
time. The shuttle will travel to the opposite end of the sector, hopefully leading the enemy away. The
shuttle will have enough fuel to operate for about one standard minute. Only a few Wild Weasels can be
carried on a ship. The number of Wild Weasels remaining is displayed on the Ship Status Display.



Tactical Order Fighters back Command

The Order Fighters Back Command will cause all the player's fighters to return to the ship.



Tactical Dock Command

The Dock Command will dock the ship at a derelict. The ship must be close to the derelict to dock.
Docking will restock the ship with Fighters and Missiles. The rate of repair will double in speed. Also,
the player can only dock with a derelict once.




Tactical Orbit Command

The Orbit command will cause the ship to orbit a planet. The ship must be close to the planet to orbit.
The ship will be protected from enemy fire by the planet's atmosphere.



Tactical Recruit Ship Command

The Recruit Ship command will ask the colonist ship to join the player's convoy. The ship leaves the
quadrant and waits for the player's ship after the Rolons are destroyed.



Tactical Stop Command

The Stop command will cause the ship to stop all movement.



Ship Status Repair Command

The Repair command is used to indicate which system the user would like repaired next. Damage
control will repair the systems in a top-down order. A dialog box is displayed with all the systems. The
undamaged systems are grayed. The next system to be repaired is selected. The user may select a
system to be repaired next by setting the button on the dialog box.



Options Menu
The Option Menu includes commands that enable the user to control options of the game.

For more information, the user should select the Option Menu Command Name:
Sound

Storyline
Pause



Sound Command

The Sound command will turn game sounds on or off. The state of the sound switch is saved from game
to game.



Storyline Command

The Storyline command will turn the playing of the game storyline on or off. The state of the storyline
switch is saved from game to game.



Pause Command

The Pause command will pause the current game. A help button is placed on the dialog box for the user
to access help.



Window Menu

The Window Menu includes commands that enable the user to control the windows of the MDI
application.

For more information, the user should select the Option Menu Command Name:
Cascade -- cause windows to be stacked on top of each other.
Tile -- cause windows to be fitted next to each other on the main window.
Arrange icons -- arrange iconic windows on the main window.
Close all -- close all windows on the main window.
Windows -- select a window to become active.



? Command

The ? Command will cause informational bubbles to be displayed on all open windows explaining the
window. The bubbles are a short and quick form of help. The bubbles will be erased in a short while.
The ? Command can be selected again to clear the bubbles.

A game started in beginner mode will automatically have the ? Command displayed at the beginning of
the game.



Help Menu
The Help Menu includes options that enable the user to get help for the game.

For more information, the user should select the Help Menu Command Name:

Help Index

Using Help
About




Help Index Command

The Help Index command is used to invoke the Windows Help engine. It will start up with the help index
for Win Battle.



Using Help Command

The Using Help command will invoke the Windows Help engine. It will start up with the help for the Help
engine.



About Command

The About command will display a short dialog box that displays copyright and registration information.
The More key may be pressed to display a picture of the development team for this software. The
Register Key may be pressed to register this software.



Tactical Popup Menu
The Tactical popup menu is used to perform commands on an object in the Tactical window.

For more information, the user should select the Tactical Popup Menu Command Name:
Fire Lasers
Launch Missile

Launch Fighter
Scan



Fire Lasers

The Fire Lasers command is selected from the Tactical Popup Menu. The player's ship will fire its lasers
at the enemy ship that is nearest to the cursor. The lasers require a short time to recharge. The lasers

may be fired as many times as desired. An enemy ship must be within a short distance from the cursor
to fire the lasers.




Launch Missiles

The Launch Missiles command is selected from the Tactical Popup Menu. The player's ship will launch a
missile at the enemy ship that is nearest to the cursor. The player only has a limited number of missiles.

They can be restocked by docking with a derelict.




Launch Fighters

The Launch Fighter command is selected from the Tactical Popup Menu. The player's ship will launch a
fighter at the enemy ship that is nearest to the cursor. The player has a limited number of fighters. They

can be restocked by docking with a derelict.




Scan

The Scan command is selected from the Tactical Popup Menu. It is used to scan objects in the sector.
An object must be within a short distance from the cursor to be scanned. A dialog box will be displayed
with information about the object and its status.



Keyboard
Keyboard commands are shortcuts to the menu options. All menu options that have keyboard shortcuts
have the shortcut key listed next to the menu command. The following is an example:

Scan 'C’ - Scan is the menu command. Pressing the 'C' key will invoke the Scan command.

Following are the keyboard shortcut commands:

Menu Command Short-cut Key
Strategic Scan 'C'
Strategic Game Status 'G'
Tactical Release Wild Weasel W'
Tactical Order Fighters Back '‘B'
Tactical Dock ‘D'
Tactical Orbit 'O’
Tactical Recruit Ship 'E'
Tactical Stop P
Tactical Popup Fire Lasers L'
Tactical Popup Launch Missiles ‘™'
Tactical Popup Launch Fighter '

Tactical Popup Scan 'S’



Mouse

The mouse has a few special functions in Win Battle. The functions are different for each window.

Following are the mouse functions for each window:

Strategic Window

* The left mouse button is used to select the sector the player wishes to warp into. The sector button is
single-clicked to activate the warp engines. Only two sectors can be jumped at a time.

Tactical Window

* The left mouse button is used to move the player's ship. The cursor is moved to the location the player
wishes to move. Then the left mouse button is double-clicked.

* The right mouse button is used to activate the Tactical Popup Menu. The player moves the cursor on
top of the object to be processed. The right mouse button is single-clicked. The Tactical Popup
Menu is displayed. The player may then select the command to be performed on the object.



Win Battle Definitions

Following are the defined terms of the game:
Armor

Strategic

Super Nova Burst
Tactical

Thrusters
Wild Weasel Shuttle
Win Battle
Wormhole



Armor

Armor is steal plating that surrounds a ship or fighter. It will protect the object from laser fire for a short
amount of time. It can be repaired. After the armor is destroyed, the hull will start to become damaged.



Asteroid Belt

An asteroid is a large rock floating in space. These rocks are sometimes as large as small moons. The
grouping of asteroids is called an asteroid belt. Starships can pass through asteroid belts using
navigational tractore beams to push the asteroids aside. Some asteroids will strike the ship causing

damage.



Carrier

Carriers are large ships that carry fighters. They are bases for the fighters. Carriers, themselves, are
almost defenseless. The fighters give the carrier a big punch. Carriers also sometimes have missiles.



Convoy

A convoy is a group of ships. A convoy operates on the theory that there is strength in numbers. Many
convoy ships are protected by a few warships.



Derelict

A derelict is a damaged ship. The ship is no longer maneuverable. The ship was "left for dead" by the
Rolons in a conflict. The ship may be docked with and stripped of extra fighters and missiles. After a
derelict is stripped, it cannot be stripped again.




Fighter

Fighters are small ships with a single crew member. They are carried by other ships. Fighters are
usually sent on a mission in groups. They carry greater fire power in numbers. After they complete a
mission they will return to the ship.



lon Engine

An lon Engine is used to travel around a quadrant. They function by super heating hydrogen gas until it
changes to plasma. Then a magnetic field is applied and a large amount of ions are emitted. These
ions are used to jump the ship to the speed of light.



lon Storm

An ion storm is caused by certain gases reacting. These gases cause an electromagnetic reaction that
will ionize an entire sector. The ionization of the sector will react with the electronics of a ship. The
effect is quite powerful. It will damage anything in the sector not protected by an atmosphere.



Jump

A Jump refers to the process of going the speed of light. An lon Engine is required to supply the large
amount of energy needed for a jump to light speed.



Lasers

Lasers emit a beam of concentrated coherent light of the same wavelength. They can travel over great
distances. They are very powerful. Lasers use a capacitor to store energy. The capacitor requires
time to recharge between firing. Beginner level players' capacitors recharge faster than advanced.



MDI

MDI stands for Multiple Document Interface. MDI windows applications have multiple windows contained
within one main window. Program Manager or SysEdit are examples of MDI applications.



Missile

A missile is a self propelled nuclear warhead. It is fast moving and very powerful. Missiles have a small
amount of armor to protect them from some laser fire. Multiple missiles should be fired at a target to
ensure a kill.



Quadrant

A quadrant is the section of the universe where a battlestar is assigned to. This is also the range of the
scanners. Quadrants are made up of sectors. The Strategic Display is the display of the quadrant.



Scanners

Scanners are a ship's long range sensing equipment. They are used to scan the surrounding sectors of
a ship's current location. Once a sector is scanned, its contents are recorded in the scanner's database.
This database of information is displayed on the Strategic Display. When scanners are destroyed, the
record of scanned sectors is lost.




Sector

A sector is the smallest subdivision of the universe. Sectors are the tactical portion of space. The
tactical display is the view of a sector. Quadrants are made up of sectors.



Sensors

Sensors are a ship's short range sensing equipment. They are used to scan objects within a sector.
They can be used to scan ships. The sensors also aid the fire control computers to lock-on to a target.
When the sensors are damaged, the effectiveness of weapons is reduced by 50%.



Strategic

Strategic is a term used to define an overall long range look at a situation or problem. In Win Battle the

Strategic Display window shows the sectors of the quadrant. From this display, the player can plan the
conquest of the sectors.



Super Nova Burst

A super nova is an unstable neutron star. The neutron star will contracts upon itself. The force of the
compression will cause the star to explode. The energy burst is quite powerful. It will damage anything
in the sector not protected by an atmosphere.



Tactical

Tactical is a term used to define a close-up or short range look at a situation or problem. In Win Battle

the Tactical Display window shows the current sector where the player's ship is located. This is where
the player does most of the "work". The enemy ships are engaged here. The player docks with
derelicts to restock and to take a rest.



Thrusters

Thrusters are a chemical engine. They use a chemical reaction from hydrogen and oxygen. The
stream produced moves the ship. Thrusters are used to move around sectors.



Wild Weasel Shuttle

A Wild Weasel shuttle is a decoy shuttle. This shuttle is very heavily loaded with electronic counter-
measure equipment. This equipment is used to create a simulation of the ship that launched the shuttle.
To any ship in the sector, the shuttle will appear to be the ship. The shuttle also has a large amount of
armor to protect it while operating. The shuttle uses an jon engine operating on overload to achieve the
level of energy needed. The ion engine will burn out in a short amount of time. The shuttle cannot be
recovered.



Win Battle

Win Battle is a copyrighted game created by BFM Software.
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Wormbhole

A wormhole is a time-space inter-dimensional connection. It will instantly transport an object great
distances. Wormholes are undetectable until they are encountered, then it is too late! They will move a
ship many sectors. Their appearance is random. They do not cause damage to the ship.




