
  

What is CCN Company Profiler?
The Tel-Me CCN Company Profiler allows you to individually reference the majority of UK-registered 
limited companies by name or company number. Available reports compiled by CCN are then 
downloaded to your system so that you may study them at length. 

A CCN report provides a textual description of the selected company interspersed with relevant charts 
and tables. The report includes informed comment about the background and context of the company in 
its marketplace and offers a credit reference. The CCN Profiler also allows a search to be made on a 
name by which a company has been known in the past. 

The returned report offers a high degree of flexibility and allows you to alter most aspects of the textual 
and graphical content to suit your requirements. 

See also
Making a CCN Company Profiler Enquiry
Retrieving Report Headings 
Retrieving a Report
Viewing a Report

Disclaimer
Neither CCN nor PhoneLink plc warrant the accuracy of information contained within the system, nor its 
use for any particular purpose. Information viewed and/or extracted from the system must not be used 
as the sole basis for any business decision. 

Copyright exists in the information and the form in which it is presented, and information viewed 
extracted from the system must not be divulged to other parties, whether for financial reward or not.
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Making a CCN Company Profiler Enquiry
Making a company profile enquiry is a two-stage process: 
      Firstly, you identify the required company using either its name or its Companies House registration 

number for which a list of available Report Headings is returned. 
      Secondly, you choose which items you wish to view from the Report Headings list and these are then 

retrieved in full. 



  

Retrieving a Report
Following a successful initial enquiry, the lower portion of the Product Area will display up to six Report 
Headings covering various company information aspects. 

Each of the headings is automatically tagged so that if you require all available information, you simply 
need to click on the Retrieve Items button.

If you wish to select particular headings, perform the following:

1. Click the Un-Tag All button.

2. Tag the headings that you wish to view. 

3. Click the Retrieve Items button to initiate the main enquiry.

As each report item is retrieved the corresponding greyed document icon against the tagged heading 
changes into a colour document. As soon as this happens, even while more information is being 
retrieved, you can begin viewing the report items. 

A Reference field is provided at the foot of the window so that you can alter the standard reference if 
required.

See also 
Retrieving Reports Immediately
Retrieving Report Items at a Later Time



  

Viewing a Report
In the Report Headings list, as soon as a greyed document icon becomes coloured you can view the 
associated report item by:

Double-clicking on the required heading, or
Moving the highlight bar to the required line and pressing the Space Bar, or
Moving the highlight bar to the required line and clicking the View button.

You can view all of the retrieved reports items as a sequential document by:
Clicking on the Magnifying Glass button in the lower left corner of the window.

The selected report item(s) are displayed in the CCN Company Profiler Extended Information Screen as 
an integrated text and graphic document.

Each report gives you complete control over how the information is presented. For more information 
refer to:
Text Formatting
Graph Formatting
Selecting/Deselecting Text, Graphs and Tables

See also
Risk Index Key
Special Credit Rating Codes
Transferring to and from the Extended Information Screen
CCN Company Profiler Menus and Toolbar



  

Risk Index Key
The Risk Index is an analytical tool designed to highlight the strength, performance and, ultimately, the 
"creditworthiness" of each company in a single score. The score is derived from a number of component 
parts that include the size of the business, the recent trading performance, the strength of the balance 
sheet and any negative credit information. The resulting Risk Index is expressed on a scale of 0 to 100 
with the highest value attracting the most confidence. 

The following provides a key to interpreting Risk Index scores:

0-10

11-25

26-40

41-50

51-60

61-80

81-100



  

Special Credit Rating Codes
For situations not covered by the normal Credit Rating figures, the following Special Codes are used:

GP (Parent involvement/dependency)
The subject's trading position is so interlinked with that of its Parent that an independent credit rating is 
not possible. For example, the subsidiary company may appear to be financially weak "on paper", or it 
may act in an agency, marketing or advisory capacity.

G0 (Inconclusive)
An average credit figure cannot be calculated with any accuracy at this time. For example, the company 
may be too new, opinions may conflict or there may be a shortage of up-to-date financial information.

GW (Company dissolved or Receiver/Liquidator appointed)
The GW code will be quoted in the above circumstances.

GX (Adverse)
This code is used to indicate an adverse trading situation of some kind. This might include cash-flow 
difficulties or trading reverses. 



  

CCN Company Profiler Menus and Toolbar
The menus and toolbar within the CCN Company Profiler Extended Information Screen are arranged as 
follows:

Click on the required item for more information.



Tagging Headings

You can tag any number of headings individually by:
Double-clicking on them, (double-click again to un-tag), or
Moving the highlight bar to the correct line and pressing the space bar (press again to un-tag), or
Moving the highlight bar to the correct line and clicking the Tag button.

You can select all of the headings by:
Clicking the Tag All button.

Conversely, when all entries are tagged, you can deselect them all by:
Clicking the Un-Tag All button.



Retrieving Items

When you click the Retrieve Items button, each of the tag icons against the selected headings changes 
into a greyed document icon to indicate that a request is in progress. As each item is returned, the 
greyed document icons become coloured to signal that the report item is ready for viewing.

 Tag Icon 

 Greyed Doc. Icon 

 Coloured Doc. Icon 



Retrieving Report Items at a Later Time

Additional or updated report items can be retrieved at any time for a given enquiry. To do this:

1. Ensure that the CCN product is currently selected.

2. Highlight the required enquiry within the library and press the F7 key. This will display the list of 
Report Headings and each will be tagged ready for retrieval. If you do not wish to retrieve all entries, 
select those that are required using the standard untagging/tagging methods. 

3. When all required headings are tagged, click the Retrieve Items button to initiate an enquiry. 



Retrieving Reports Immediately

If you look at the right hand side of the Status Bar at the foot of the window, you will see that the enquiry 
connection remains active for a short time after the information is received. This feature allows you to 
quickly select one or more headings (all are initially tagged) and retrieve the report items using the same 
enquiry. 



Report Headings

For a successful initial enquiry, one or more of the following headings will be returned so that you can 
choose which report items you wish to view.

Company Profile.    Details of Registered Office, Incorporation Activities, Capitalisation and Age of 
Accounts. 

Trading Performance and Capital Structure.    Textual and graphical analysis, including trends, of 
Profitability, Liquidity, Capital Structure and Gearing. 

Productivity.    Textual and graphical analysis of Employee Levels, Profitability and Remuneration. 

Mortgages and County Court Judgements.    A summary of Charges registered at Companies House, 
along with a summary of any County Court Judgements awarded against the company in the past 
twelve and twenty four months. 

Credit Opinion.    A Risk Assessment, evaluating the stability of the company, together with an average 
monthly trade credit amount that can be recommended. 

Director Information.    Names and Addresses of all current Directors and Company Secretary.

Note: The section headings may be subject to change and the number of sections available for a 
particular company will vary. 



Selecting/Deselecting Text, Graphs and Tables

Most reports comprise three main elements: Text, Graphs and Tables and all three are displayed as 
standard. If you wish to concentrate on a particular information element, you can deselect those that you 
are not using by accessing the View menu. The copy and print functions will use only the information 
that is displayed. 

Note: If all three elements are deselected, the report will appear empty.

Any changes made in the View menu will be reset when the current report is exited.



0-10 

Companies in this range are regarded as being in the highest risk category. They generally exhibit 
characteristics similar to those of many other failed companies, e.g. negative capital employed and/or 
massive trading loss.



11-25 

These companies are regarded as being very high risk in that they exhibit similar characteristics to the 
previous category, although these characteristics tend to be less severe. 



26-40 

High risk companies in this category may well have a credit rating but where such values exist, the 
rating should be considered as an absolute limit and may require some form of guarantee from the 
company applying for credit.



41-50 

These companies are above average risk and, therefore, assurances in the form of guarantees may be 
necessary especially if the credit rating assigned to the company is required to be exceeded.



51-60 

Companies in this category are regarded as having average risk status and should be treated with a 
degree of caution.



61-80 

These companies have a low risk status and, therefore, there is a high degree of confidence that they 
will prove good for the assigned credit figure. 



81-100 

These companies have a minimal risk status and, therefore, there is every confidence that they will be 
good for the assigned credit figure.



File 

Print...      Sends the displayed information to the currently selected printer for output. Press Ctrl and P 
as a shortcut for this option.

Print Preview    Displays a preview of how the information to be sent to the printer is expected to appear 
when it is output. Within the preview you can zoom in and out to view specific areas and move between 
the various pages to be printed.

Print Setup...    Selects the Windows Printer Setup dialog box so that you may configure a selected 
printer. 

Exit    Closes the Extended Information Screen and returns to the Tel-Me product area.



Edit 

Cut    This option is not available within this product and remains greyed-out.

Copy    Places a copy of the displayed report information into the Windows clipboard so that it can be 
transferred to another program. When graphical data is copied to the clipboard, it is automatically 
converted to text format. This is useful for extracting the numerical data from which the graph was built 
and for importing the data into a spreadsheet. Press Ctrl and C as a shortcut for this option. 

Paste    This option is not available within this product and remains greyed-out. 



View 

Text    Selects whether the text contents of the report are displayed. 

Graphs    Selects whether the graphs of the report are displayed.

Tables    Selects whether the tables of the report are displayed. 

All    Sets all elements to be displayed.



Options 

Text    Displays the Text Options dialog box. 

Graphs    Displays the Graph Options dialog box.



Help 

Contents    Displays the main contents page of this help program.

Help on CCN Company Profiler    Displays the initial page and contents of the CCN Company Profiler 
help. Press F1 as a shortcut for this option.

About CCN Company Profiler    Provides copyright and version details for the current version of this 
product and also indicates the system resources available.



Copy Button

Places a copy of the displayed information into the Windows clipboard so that it can be transferred to 
another program. Press Ctrl and C as a shortcut for this option. 

When graphical data is copied to the clipboard, it is automatically converted to text format. This is useful 
for extracting the numerical data from which the graph was built and for importing the data into a 
spreadsheet. 

This option is also selectable from the Edit menu.



Print Button

Sends the displayed information to the currently selected printer for output. Press Ctrl and P as a 
shortcut for this option. 

This option is also selectable from the File menu.



Print Preview Button

Displays a preview of how the information to be sent to the printer is expected to appear when it is 
output. Within the preview you can zoom in and out to view specific areas and move between the 
various pages to be printed.

This option is also selectable from the File menu.



Exit Button 

This is the same as using Alt-F4 and will close the Extended Information Screen to return control to the 
Product Area.    This action has no effect on the data which will still be available in the Library for re-
examination. 

This option is also selectable from the File menu.



Text Options Button 

Displays the Text Options dialog box.

This option is also selectable from the Options menu.



Graph Options Button 

Displays the Graph Options dialog box.

This option is also selectable from the Options menu.



Help Button

Displays the initial page and contents of the CCN Company Profiler help. Press F1 as a shortcut for this 
option.

This option is also selectable from the Help menu.




