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What is Retouch?

Retouch is an affordable, simple tool for transforming scanned images and bitmap art.
If you use:

¢ Paint programs like MacPaint™ or SuperPaint™
« Desktop publishing programs like PageMaker™ or Ready, Set, Go!™
¢ HyperCard™

then Retouch can make your current job easier and give you a range of new capabilities.

Retouch is similar to two well-known image-retouching programs (ImageStudio™ and Digital Darkroom™). It differs from them in a
few important ways:

¢ Retouch is ShareWare. It's much less expensive and you can “try before you buy.”

* Retouch is designed for the Mac 512KE, Mac Plus, and Mac SE. It's smaller and simpler than the other programs. You can
use it in concert with the applications you already own, on the Macintosh you already own.

* You can contact the author of Retouch directly, through CIS or Internet electronic mail. This gives you faster response for bug
fixes and for new features.

If you use your Macintosh to display or edit scanned photographs, clip-art, screen dumps, or original drawings, then look over the
next chapter to see what Retouch can do for you.
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What can | do with Retouch?

With Retouch you can:

* Manipulate both black-and-white (bitonal) and 8-bit gray-scale images.

¢ Open and save images in TIFF, compressed TIFF, and MacPaint formats.

« Convert images from one format to another, and convert PICTs to images.

« Print images on an ImageWriter™ or LaserWriter™ printer.

« Transfer images to or from other programs using the clipboard or TIFF files.
« Cut, copy, and paste selected areas.

< Blend multiple images with a large selection of special effects.

« Cut out selected areas, trim away unneeded background, or crop images to a given size.
« Enlarge or reduce images by percentage or to a given size.

« Rotate images to any angle.

« Flip images left-to-right or top-to-bottom.

« Fill selected areas with any of 63 shades of gray, as well as black and white.
« Change brightness and contrast of selected areas.

« Apply sophisticated image-processing techniques to enhance low-quality images.
* Smooth or sharpen selected areas.

« Trace edges.

« Magnify or shrink an image by any percentage.

« Choose from two levels of quality (fast or best).

¢ Choose from three halftoning methods.

« Change image resolution (dots per inch) to any value.

« Convert images from bitonal to gray-scale, or vice-versa.

If you'd like to use Retouch for any of the purposes listed above, read the next chapter to make sure your Macintosh will run
Retouch.
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What do | need to use Retouch?

Macintosh

Retouch will run on a Macintosh 512KE, Macintosh Plus, Macintosh SE, or Macintosh II.

Display

Since it's designed for the older machines, Retouch uses a two-color (bitonal) display. You can use Retouch on a Macintosh Il in
two-color mode, but Retouch cannot take advantage of a gray-scale display.

Memory

For full functionality, Retouch requires 256K of memory. Retouch will run in as little as 200K of memory, but will handle only small
(MacPaint-size) bitonal images. 512K of memory will give Retouch plenty of room to handle even very large images, because
Retouch dynamically loads the image portions it needs.

One exception to this rule is image rotation. For speed, Retouch requires that one copy of the entire image reside in memory. This
is rarely a problem with MacPaint-sized images (which require about 52KB of memory) but can cause trouble when you manipulate

gray-scale images. You may want to use the Finder’s Get Info dialog to increase the amount of memory assigned to Retouch if you
often rotate images while using Switcher or MultiFinder.

Disk
Retouch will run from standard 800K floppy disks or from your choice of hard disk. A hard disk is extremely valuable if you work with

many images or with large images. Since Retouch stores images on disk if there’s not enough room in memory, you should reserve
enough disk space for two or three images.

System File

Retouch uses hierarchical menus and other features that are only available in System File version 4.1 and later. You should use the
Finder’s About the Finder command to determine the version of the System you're using. If it's earlier than 4.1, you will need to
obtain an upgrade from your user group or authorized Apple dealer before you can use Retouch.

Printer

Retouch supports the ImageWriter and LaserWriter families, with the exception of the ImageWriter LQ.

Scanner

Retouch won't drive a scanner directly. However, Retouch will handle images produced by your favorite scanning software if you
save the images in TIFF format. Retouch handles uncompressed TIFF, PackBits-compressed TIFF, and ThunderScan TIFF in either
1-bit or 8-bit mode. Retouch can also be used with MacPaint files.
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How do | use Retouch?

In this chapter you'll learn how to use Retouch. Retouch follows Apple's User Interface Guidelines, so if you've used the Macintosh
before you'll learn to use Retouch very quickly. If you're not familiar with the Macintosh and terms like “clicking” and “dragging”, you
should read your Macintosh Owner’s Guide or practice with a well-documented application program like MacPaint.

Starting and Stopping Retouch
Feel free to copy Retouch to a disk of your choice.

Start Retouch by double-clicking its icon or by selecting the icon and choosing Open from the Finder’s File menu. You can also
double-click any image document previously saved by Retouch to start Retouch and reopen that image.

When you're done, stop Retouch by selecting Quit from the File menu.

Creating New Images and Opening Existing Ones
Before you can use Retouch you must create a new image or open one that already exists.

To create a new MacPaint image, choose New from the File menu. (Later you'll see how to customize the characteristics of an
image.)

To open an existing image, choose Open from the File menu. Retouch will present the standard file-selection dialog. You can then
double-click on the name of an image or click once on the name and once on the Open button.

You can open up to ten images. Each image is presented in its own window. Feel free to move image windows around the screen
by dragging their title bars. As with other Macintosh applications, you can bring a window to the front by clicking on it; you can
alternate between large and small sizes by clicking the “zoom” box in the upper-right corner; and you can resize manually by
dragging the “grow” box in the lower-right corner. As a shortcut, you can bring any image window to the front by choosing its name
from the Images menu.

At any point in a session with Retouch, one window is frontmost and “active.” This window is distinguished by horizontal stripes in its
title bar. Any image operation you select from a menu applies only to the active image.

Duplicating Images

To duplicate the active image, just choose Duplicate from the File menu. Retouch will create a new window and place a copy of the
active image in it.

Saving Images

To save the active image, choose Save from the File menu. If you're saving the image for the first time, Retouch will display the
standard file selection dialog so you can choose a name for the image.
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You can always save a copy of an image under a new name by choosing Save As from the File menu. Retouch will display the file
selection dialog so you can enter the new name.

Closing Images

When you're through modifying an image you may want to close it to save memory or reduce clutter on your display. To close the
active image, choose Close from the File menu or click the “close” box in the upper-left corner of the frontmost window.

Reverting to a Previously-Saved Image

Sometimes you make a series of changes to an image and don't like the result. Rather than reversing all the effects of the changes,
you may want to start over with the most-recently-saved version of the image. To do so, just choose Revert to Saved from the File
menu.

Printing an Image

Before printing an image, you may need to inform Retouch of the type of paper in your printer. Choose Page Setup from the File
menu and select your paper type from the resulting dialog. In addition, when you're printing on a LaserWriter you'll get the best
results by turning off the “Bitmap Smoothing” and “Faster Bitmap Printing” options in the Page Setup dialog.

When you're ready to print the active image, just choose Print from the File menu. Select options from the resulting dialog box and
click the “OK” button. Retouch will match the resolutions of your image and your printer, then send the image to the printer.

The resolution of the LaserWriter is fairly high, so it takes a long time to convert a large image for printing. For example, printing a
MacPaint image on a LaserWriter using a Macintosh SE takes about 15 minutes. To reduce printing time, use Trim Away

Background from theCrop submenu of the Effects menu before printing. This will dispose of any unused space outside the core of
the image.

A Tool for Viewing Portions of an Image

If an image is fairly small, it will fit in its window and be completely visible. If the image is too large for its window, there is a way to
view any part of it that will fit.

Choose the grabber from the Tools menu. (It's the item shaped like an open hand.)
The cursor will change to a grasping hand. When you press the mouse button and drag the cursor over the active image, the image
will move to follow. If you move the cursor outside the active window, the image will autoscroll (continue moving) at roughly the

same rate until you move the cursor back into the window or release the mouse button.

As a shortcut, holding down the Option key on the keyboard will temporarily convert the cursor to the grabber. When you release
the mouse button, the cursor will return to its former state.

Tools for Selecting Portions of an Image
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Most of the special image effects (discussed later) can be restricted to a small area. You use the first three items in the Tools menu
to select the area you want to affect.

To select rectangular areas from the image, choose the selection rectangle from the Tools menu.

The cursor will change to a small cross. Move the cursor to the top left-corner of the area you wish to select, press the mouse
button, and drag the cursor to the lower-right corner of the area. A moving, dashed line will surround your selection:

Tools Effects Images

Test Patterns

Making a selection this way replaces any previous selection you made. By holding down one of the Shift keys on the keyboard
before pressing the mouse button, you can add a rectangle to the previous selection, rather than replacing it.

To select odd-shaped areas of an image, choose the selection lasso rather than the selection rectangle.

As you drag the cursor, a dashed line will surround the selected area. As with the selection rectangle, holding down the Shift key
before you press the mouse button will cause the new selection to be added to the old one, rather than replacing it.

Tools Effects Images

Test Patterns

i
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The final selection tool, the scissors, allows you to cut away a portion of a selection. The scissors work just like the selection lasso,
but everything inside the path of the scissors is cut out of the selection:

Tools Effects Images

Test Patterns

Using the Clipboard
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Retouch supports the standard Macintosh commands for cutting, copying, pasting, clearing, and undoing the last operation.; just
choose the appropriate command from the Edit menu. You can use these commands to transfer images or drawings between
Retouch and other application programs.

When you choose the Paste command, Retouch displays a selection rectangle in the upper-left corner of the image. The rectangle
shows where the new image will be pasted. You can move this rectangle by placing the cursor in it, pressing the mouse button, and
dragging the mouse. (While the cursor is in the selection, it will have the form of a cross with arrowheads.) To complete the paste,
click anywhere outside the selection rectangle. Note that the pasted image will be clipped to the bounds of the image into which
you're pasting.

Tools Effects Images

Test Patterns

All three selection tools will autoscroll if you move the cursor outside the bounds of the active window.

Blending Images

Blending is similar to pasting, but allows the old and new images to be combined in interesting ways. When you choose the Blend
command from the Edit menu, the following dialog box will appear. Select the blending operations you want and click the “OK”
button.

(@ Transparent overlay

¢ 1 Darkest in front

I < Lightest in front

3 Etch clipboard contents from image

_) Squeegee image through clipboard contents
{| > Blend % of clipboard contents

; | (1] 4 &;l [ Cancel ]

A selection rectangle showing the position of the blend will appear in the upper-left corner. Drag it into place in the same way you
drag the selection rectangle for pasting. Click outside the selection to complete the blend.

Here is a sample image and the various effects obtained by blending it with a 50% gray background. (Note the screen effects
caused by the particular halftoning method used.)
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Original

Overlay Dark in Front Light in Front

Etch Squeegee Blend 50%

Cropping Images

Retouch provides three ways to crop an image: trim away the excess white background, cut out everything except the selected
area, and crop to a specific size rectangle. You use the commands in the Crop submenu of the Effects menu to control cropping.

Trim Away Background is most useful for cutting away the blank portion of a MacPaint image. It's also valuable for removing a white
border from a scanned gray-scale image.

Note that Crop Selection differs from the Cut command in the Edit menu. Cut moves the selected area to the clipboard and clears
the original image; Crop Selection removes everything except the selected area and leaves the clipboard unchanged.

When you choose Crop to Size, Retouch will present a dialog box like the following:
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Crop Height to |p&] 6}

Crop Width to |4.6389

Use Units of: (@ inches > centimeters
{» points ) pixels

ok ) » (CConeer )

Choose the units you prefer and type the size into the “Height” and “Width” fields of the dialog box. When you click the “OK” button,
Retouch will present a selection rectangle at the upper-left corner of the image. You can move the rectangle as described above for
Paste and Blend. Click anywhere outside the selection rectangle to complete the cropping operation.

Reducing and Enlarging Images

Retouch provides two ways to reduce or enlarge images: by percentage and to a specified size. The appropriate commands are in
the Reduce/Enlarge submenu in the Effects menu.

When you choose By Percentage, Retouch displays the following dialog box:

Multiply Height by ([0

Multiply Width by 100 %

[ 1] 4 ] [ Cancel ]

h

You should enter the appropriate percentages in the “Height” and “Width” fields. For example, scaling the image by 50% makes it
half its original size. Note that you can scale height and width independently.

When you choose To Size, Retouch presents a dialog box like this one:
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Change Height to ENiEL}

Change Width to (6.5139

Use Units of: @ inches > centimeters
{» points 0 pinels

o)y (Ctence
ok )y [ cencer )

Just choose the units that you prefer, type the height and width, and click the “OK” button.

Cropping to size and reducing to size are both useful when you must fit an image into a predetermined space. Cropping is most
valuable when you can eliminate some portions of the image, and reduction is most valuable when you need to make the entire
image fit.

Rotating Images

Retouch can rotate images by any angle, in one-degree increments. To rotate an image, choose one of the commands in the Rotate
submenu of the Effects menu.

The Rotate submenu includes commands for rotating 90° in either direction, 180°, and arbitrary angles specified in a dialog.

Here’s a sample image in its original form and rotated counterclockwise by 30°:

Rotation requires more memory than any other image effect, so be sure to allocate plenty of memory to Retouch if you're rotating
images under Multifinder.

If you're rotating bitmaps containing line-art or MacPaint-style patterns, you should try all the different halftoning methods to see
which gives the best results.

Flipping (Mirroring) Images
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To flip an image from left-to-right or from top-to-bottom, use the commands in the Flip submenu of the Effects menu.

Flipping only works on rectangular selections; Retouch cannot flip arbitrarily-shaped areas.

Filling Areas

To fill an area with black, white, or any of 63 shades of gray in between, just select the area with the selection tools and choose a
shade from the Fill submenu of the Effects menu.

Changing Brightness

Often scanned images are incorrectly exposed: too bright or too dim. With the commands in the Change Brightness submenu of
the Effects menu, you can correct these problems.

There are two special commands (Increase 10% and Decrease 10% ) that allow you to make small adjustments in brightness.

There is also a general command (By Percentage ) that allows you to specify a change more precisely. When you choose this
command, Retouch displays the following dialog box:

Change Brightness [ =

[ 0K ]h:[ Cancel ]

Enter a number between -100 and 100. -100% makes the image completely dark; 0% leaves it unchanged; and 100% makes it
completely bright (white). Click the “OK” button to complete the brightness change.

Changing Contrast

In addition to brightness problems, scanned images often have poor contrast. Retouch provides simple contrast controls, as well as
several more sophisticated image-processing operations that can enhance an image.

The operations in the Change Contrast submenu of the Effects menu are as follows:
Increase 10% increases contrast by 10%.
Decrease 10% decreases contrast by 10%.
By Percentage brings up a dialog box that allows you to specify a percentage change in contrast. Unlike brightness, which is

additive, contrast is multiplicative; to reduce contrast you must specify a number between 0 and 99%, while to increase
contrast you must specify a number greater than 100%.
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Maximize increases contrast as much as possible without losing information. That is, the darkest gray in the image will be
darkened to black, the lightest gray will be brightened to white, and all the shades in-between will be accentuated in
proportion. (This isn’'t of much use for bitonal images. However, you can convert bitonal images to gray-scale, blur them
lightly, and then maximize contrast.)

Equalize changes contrast so as to distribute the range of grays equally across all the pixels (dots) in the image. After
equalization, each shade of gray will be present in roughly equal numbers of pixels. This transformation can help bring out
detail in areas of poor contrast.

Invert turns an image into its negative: black becomes white, dark gray becomes light gray, and so forth.

Enhance 1 Sigma and Enhance 2 Sigma perform a simple image-enhancement operation. First Retouch takes a census of the
gray values present in the image. It then determines the average pixel shade and a range of shades on either side of the
average. (For 2 Sigma the range is twice as wide as for 1 Sigma.) Finally, Retouch compresses the shades on either end
of the range and stretches those in the range to maximize their contrast. Like equalization, this technique often brings out
features that would otherwise be invisible.

Here is a sample image with each of the contrast changes applied. The original was a glossy, slightly wrinkled ThunderScan
advertisement; it was scanned with ThunderScan.

Original
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Increase 10% Decrease 10% 125% Maximize

ERELH

Equalize ' Invert ' Enhace 1 Enhance 2

These operations can have complex or surprising effects. For example, in the samples above the equalization operation exposed
the wrinkles in the original image. Only the 1-sigma enhancement clearly exposes the ring in the model’s left ear. It's always
worthwhile to experiment.

Don't forget that you can apply a contrast change to a selected area, as well as to an entire image. The Undo command is always
available if you decide you don't like a particular change.
Changing Focus

Within limits, Retouch can change the focus of an image after it's scanned. There are six focus transformations ranging from heavy
blur to heavy sharpen in the Focus submenu of the Effects menu. The following six samples show how a single image changes as
the focus varies.
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Heavy Blur | Medium Blur Light Blur

Light Sharpen . Medium Sharpen o Heavy Sharpen

Blurring is also useful for converting bitonal images to gray-scale. See below for more information.

Tracing Edges

Retouch can trace the edges in an image. This is not the same as Digital Darkroom'’s autotrace feature; whereas Digital Darkroom
produces splines for object-oriented drawing programs, Version 1.2 of Retouch produces a bitmap image.

Here’s an example of edge tracing:

Retouch's technique for edge-tracing works on both bitonal and gray-scale images, but tends to find more edges in bitonal images.
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Changing the Viewing Magnification

Retouch provides a way to change the apparent size of the image without actually altering the image. By changing the viewing
magnification, you can zoom in on individual pixels (like “fatbits” mode in MacPaint) or you can back away to see a large image in its
entirety.

The Magnification submenu of the Images menu contains a humber of options for setting the magnification:

2X doubles the magnification factor. Applying this command repeatedly scales the image by factors of 2, 4, 8, 16, etc. up to a
(fairly large) limit on maximum image size.

1/2 X halves the magnification factor.

By Percentage allows you to set the magnification factor to any percentage. For example, you could use 300% magnification to
triple the apparent dimensions of an image.

Fit Selection increases or decreases the magnification factor as needed to make the currently-selected area fit in the window.
This is especially useful for finding a particular feature in a large image.

Normal Size returns the magnification factor to 100%, making the apparent size of the image match its actual size.

Changing the Transformation Quality

Whenever Retouch scales an image or changes its resolution, it can use one of two methods: a fast method that produces slightly
lower-quality results, or a slower method that produces very high quality results. You can use the Fast and Best commands in the
Set Quality submenu of the Images menu to select one of the two methods.

For most purposes, the “fast” method is sufficient. The “best” method is particularly useful with high-resolution images.

Changing the Halftoning Method

Since the early Macintoshes can display only black and white, some halftoning method must be used to display gray-scale images.
Retouch offers three halftoning methods that vary in speed, realism, and suitability for particular images. You can select a halftoning
method by choosing one of the icons in the Set Halftoning submenu of the Images menu.

Thresholding, represented by a black-and-white icon, reduces all shades of gray to black or white.

Ordered Dither, represented by an icon with orderly rows of intermixed dots, converts shades of gray to patterns over small areas.
The lighter the shade of gray, the more white pixels will be present in the patterns. Ordered dither is almost as fast as thresholding,
and produces excellent results for images with large fields of a single shade.

Floyd-Steinberg Dither, represented by an icon with randomly intermixed dots, distributes the error at each pixel to some of the
surrounding pixels. As with ordered dither, lighter shades result in more white pixels. Floyd-Steinberg dither is not quite as fast as
ordered dither, but produces much better results for most natural images. It sometimes produces streaks in fields of a single shade.
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Changing the Image Resolution

Digitized images are produce by sampling continuous-tone scenes at many discrete points. The greater the number of points per
inch, the smoother the image appears. As the resolution (number of points per inch) increases, the image also becomes much larger
and more difficult to manipulate.

In the Macintosh world, the two most common image resolutions are 72 dots per inch (roughly the resolution of the Macintosh
screen) and 300 dots per inch (the resolution of the LaserWriter printers). In other computing environments, still more resolutions are
popular. In many cases, the resolution in the vertical direction differs from that in the horizontal direction.

Retouch allows you to convert images from one resolution to another. The 72 DP/ command in the Set Resolution submenu of the
Images menu converts the active image to 72 dots per inch in both the horizontal and the vertical directions. The 300 DPI/
command converts the active image to 300 dots per inch. The Custom command brings up a dialog box that allows you to set the
horizontal and vertical resolutions independently.

Note that 300 DPI images consume vast quantities of memory and disk space. Rather than using 300 DPI, you may be better off
using gray-scale images at a lower resolution.

Changing the Image Type

Retouch can manipulate both bitonal (black-and-white) and 8-bit gray-scale images. To convert an image from one type to another,
just choose the appropriate command from the Set Image Type submenu of the Images menu.

When converting from gray-scale to bitonal, be sure to set the halftoning method you prefer before starting the conversion. Once the
conversion is complete, you can'’t re-halftone the image without undoing the conversion.

When converting from bitonal to gray-scale, it's best to follow this procedure: First convert the image. Next apply a light to medium
blur. Finally apply a light to medium sharpen. This allows neighboring pixels to be “averaged” a bit and makes subsequent
halftoning operations more effective.
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How can | get a copy of Retouch?

Distribution

In general, Retouch is available from bulletin boards, user groups, USENET, and commercial information services such as
Compuserve. You may also obtain a copy from a friend or business associate. You cannot obtain Retouch directly from the author.

Retouch is provided under the “Shareware” system. You may make as many copies as you wish and you may distribute them freely.
If you redistribute the program, you must also provide this documentation (in either electronic or printed form), because it contains
essential licensing information.

You may use Retouch for a period of two weeks without fee. To continue to use Retouch after this trial period, you must send a
registration and support fee of $20 by check to Allen Akin, 784 Palo Alto Avenue, Palo Alto, CA 94301. If you elect not to send the
fee, you must erase or redistribute all your copies of Retouch. You are entitled to exactly one two-week trial period. Once you have
paid the registration and support fee, you need never pay the fee again, even for major upgrades of the program or documentation.

Retouch is not public-domain. You may not include it as part of any commercial product without express written permission from the
author. You may not remove or alter any of the copyright notices or non-warranty statements in the program itself or in this
documentation. You may not continue to use the program past the two-week trial period without submitting the shareware fee to the
author.

The Shareware system benefits you by giving you a chance to evaluate a product before paying for it, and by giving you high-quality
software at the lowest possible price. Shareware benefits its authors by eliminating the need for traditional marketing and
distribution. However, Shareware only works if YOU take the time to send the registration and support fees for the Shareware
programs you use. Without those fees, the authors can't support their products.

NO WARRANTY

Retouch is provided with absolutely no warranty, to the extent permitted by applicable state law.

Retouch is provided “as-is” without warranty of any kind, either expressed or implied, including, but not limited to, the
implied warranties of merchantability and fitness for a particular purpose. The entire risk as to the quality and performance
of the program is with you. Should Retouch prove defective, you assume the cost of all necessary servicing, repair, or
correction.

In no event unless required by applicable law will Allen Akin and/or any other party who may redistribute Retouch be liable
to you for damages, including any lost profits, lost monies, or other special, incidental, or consequential damages arising
out of the use or inability to use (including but not limited to loss of data or data being rendered inaccurate or losses
sustained by third parties or a failure of the program to operate with programs distributed by other vendors) the program,
even if you have been advised of the possibility of such damages, or for any claim by any other party.
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What about improvements to Retouch?

The original version of Retouch was V1.0, released in July 1988.

Versions 1.1 and 1.2 were released in August 1988. V1.1 included a small fix to handle a bug in MacScan TIFF files, and V1.2
included a fix for a LaserWriter printing problem.

What improvements would you like to see in future versions? Send a message to Allen Akin on Compuserve at 72247,2635 or on
the Internet at allen-akin@cup.portal.com. Here are some possibilities:

« Painting tools.

« Support for more image and picture formats.

« Gray-scale display on the Mac Il.

« Improved speed.

« More sophisticated image-processing operations, especially better sampling and filtering.
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