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Introduction

VSamp is a powerful program that turns the Macintosh into an OMS, FreeMIDI, OS X MIDI,
AudioUnits and VST-compatible multitimbral sample playback module. Configured like a
hardware sampler, VSamp can play samples on 16 MIDI channels with up to 128 samples per
channel, mapped and enveloped to user-defined configurations. This can then be controlled by a
MIDI keyboard or a sequencer running on the same computer. VSamp also includes a VST plugin
‘VSamp VST’ and an AudioUnits plugin ‘Vsamp AU’, both of which can play VSamp instruments
and banks. VSamp VST enables you to have access to 8 channels of audio output from VSamp
within your VST-2 compatible sequencer. VSamp AU allows two channel access.
Without registration, this program and plugin will stop playing samples four minutes from when the
samples are loaded. The sound can be restarted with a single command. See the section
‘Registration’ on how to obtain a fully operational version.
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Installation

Installing the VSamp application
• Uncompress VSamp: drag the downloaded file VSamp.sit or VSampClassic.sit onto Stuffit

Expander version 5 or later (available free from Aladdin Systems (http://www.aladdinsys.com)
• Copy the VSamp application: drag the folder VSamp Folder to the Applications folder on your

hard disk.

Installing VSamp VST (MacOS 7-9)
If you have a VST-2 compatible sequencer running under MacOS 7, 8 or 9 (e.g. Logic 4.1 or later
or Cubase 4.1 or later), drag the file VSamp VST to the VstPlugIns folder in the sequencer's
folder.

Installing VSamp VST Carbon (MacOS X)
If you have a VST-2 compatible sequencer running under MacOS X (e.g. Cubase SX), drag the file
VSamp VST Carbon to the folder /Library/Audio/Plug-Ins/VST.

Installing VSamp AU (MacOS X)
If you have an AudioUnits compatible sequencer running under MacOS X (e.g. Logic 5.5 or later),
drag the file VSamp AU to the folder /Library/Audio/Plug-Ins/Components.
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Quick Demos

Very Quick Demo
• Double-click on the file ‘Acoustic Guitar Instrument’ in the folder ‘Demo Instrument’ in the

VSamp folder.
• Choose Load Instrument->MIDI Channel 1 from the Play menu.
• Choose Play Scale->MIDI Channel 1 from the Play menu. You should hear a C Major scale

played on a sampled acoustic guitar.
• Choose Window->Keyboard to bring up an onscreen keyboard where you can play the

instrument either with a mouse or the computer keyboard.

Quick Demo with MIDI and Keyboard

MacOS X:
• Choose Load Instrument->MIDI Channel 1 from the Play menu.
• Select MIDI Inputs from the Window menu.
• Click in the checkbox OS X MIDI Input and select your keyboard from the popup menu.
• Set your keyboard to transmit on MIDI channel 1 and play - you now have a sampled acoustic

guitar!

MacOS 7, 8 and 9:
• If you don’t yet have OMS 2.0 or later installed, download it free from www.opcode.com and

install it. No specific setup of OMS is required for VSamp but you will need to configure it for
any keyboards in your setup.

• Double-click on the file ‘Acoustic Guitar Instrument’ in the folder ‘Demo Instrument’ in the
VSamp folder.

• Choose Load Instrument->MIDI Channel 1 from the Play menu.
• Select MIDI Inputs from the Window menu.
• Click in the checkbox OMS Input and select your keyboard from the popup menu.
• Set your keyboard to transmit on MIDI channel 1 and play - you now have a sampled acoustic

guitar!
• If you have on OMS compatible sequencer, see the VSamp home page on using VSamp with

your sequencer.
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Registration
The version of VSamp included with this package requires a registration number; otherwise it will
stop playing samples four minutes after being loaded. The sound can be reloaded with a single
command.

To obtain a registration number:
Visit the VSamp Home Page (www.VSamp.com) for online registration if you have a credit card.
Or
• Launch the enclosed program ‘Register’.
• Type your name and e-mail address in the upper left spaces provided.
• Type how many single user licenses you require and if you’d like a site license or world license

in the spaces provided.
• Choose your payment method from the popup menu in the lower left area. The quickest way is

to pay by credit card then e-mail or fax the details. All credit card details are encoded when you
e-mail them.
For credit card: enter your credit card details then click the Copy... button. Go to your e-mail
program and paste into a new message. Send this to sales@kagi.com - NOT TO
smaug@kagi.com.
For cash, check and invoice click the Print... button and send the form with your payment to the
address on the printed form.

• The company Kagi will e-mail a registration number as soon as they have processed your
payment. Kagi handles payments only and does not provide technical support for VSamp.
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Overview

General:
• Output resolution:

VSamp application: 8 or 16-bit.
VSamp VST and VSamp AU: 8, 16 or 24-bit.

• Output frequency:
VSamp application: 11025 to 48000 Hz.
VSamp VST and VSamp AU: at least 11025 to 96000 Hz.

• Sample Resolution: 8, 16 or 24-bit.
• Sample Frequency: at least 11025 to 96000 Hz.
• Sample Format: AIFF, Sound Designer II (SDII) or Macintosh Sound Resource.
• Import: SampleCell 2.x and SoundFont 2 samples and instrument keymaps.
• Polyphony: up to 64 (computer dependent) stereo voices dynamically allocated.
• Sample mapping: 128 samples per instrument.
• Sample Memory: Depends on memory of computer. Set preferred memory in ‘Get Info’ in

Finder (MacOS 7, 8 and 9 only).
• Filters: 128 resonant lowpass filters.
• LFO: 64 oscillators 0.1–10 Hz.
• Multitimbral: 64 instruments per bank assigned to 16 unique or shared MIDI channels.
• Outputs:

VSamp application: 1 stereo output.
VSamp VST: 4 stereo outputs assignable by instrument.
VSamp AU: 1 stereo output.

• MIDI Implementation: note on, note on velocity, note off (0x9X or 0x8X with 0 velocity),
dynamic filter control (ctrl 2), dynamic volume (ctrl 7 or ctrl 107), dynamic pan (ctrl 10 or ctrl
110), dynamic expression (ctrl 11), channel sustain pedal (ctrl 64), channel pitch bend, all sound
off (ctrl 120), reset all controllers (ctrl 121) and all notes off (ctrl 123).

• MIDI compatibility:
• MacOS X: supports MacOS X built-in MIDI services.
• MacOS 7, 8 and 9: Requires OMS 2.0 or greater (free from www.opcode.com) or

FreeMIDI 1.34 or later (free from www.motu.com). Use FreeMIDI if you want to use with
VSamp with Performer, otherwise use OMS.

System Requirements
• Any Macintosh with a PowerPC processor (all Macs made since 1996). Best with a Macintosh

with a G3 or G4 processor (e.g. iMac, iBook).
• At least 16MB available RAM.
• At least 10MB available hard disk space.
• MacOS 7.5 to MacOS X.
• Sound Manager 3.1 or later strongly recommended (included with System 7.5.3 and later).

For MIDI functionality:
• MacOS X: supports MacOS X built-in MIDI services. An OS X compatible sequencer is

required.
• MacOS 7, 8 and 9: Requires OMS 2.0 or greater (free from www.opcode.com) or

FreeMIDI 1.34 or later (free from www.motu.com). Use FreeMIDI if you want to use with
VSamp with Performer, otherwise use OMS. An OMS or FreeMIDI sequencer is required.
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For VST functionality:
• A VST-2 compatible sequencer for using VSamp VST.

For AudioUnits functionality:
• An AudioUnits compatible sequencer for using VSamp AU.

Polyphony
Polyphony is user-defined and depends on the processor speed. The benchmark Macs with which I
have run this on are a Powermac 7200/90 (PPC 601 processor) which gives 9-voice polyphony. A
7600/132 (PPC 604e) gives 32 voices. A G4/400 gives al least 64 voices at 44100Hz. If the
polyphony is set too high, a disjointed sound will be heard. These figures are without filters. Using
filters will reduce the number of voices.

Sample Management
The three limitations imposed by the program on sample management are the number of samples
that can be loaded, the total amount of memory which all samples occupy, and, if you use sound
resources to store samples, the length of any one sample. Samples are stored as AIFF files, Sound
Designer II files or Macintosh sound resources. Shareware programs such as the excellent D-
SoundPro can be used to record and edit samples on your Macintosh.
The maximum number of samples that can be loaded is 128 samples per instrument for each of the
64 instruments (8192 samples) in a bank.
The memory available to the samples is limited by the size of the application’s heap. This value is
set in the program’s Get Info window accessed in the Finder (MacOS 7, 8 and 9 only). VSamp
samples contain a header as well as the sample data, but the header size is insignificant with regard
to memory allocation. The program has been used with 128Mb of samples loaded without a
problem and theoretically it could go much higher if more computer RAM were available.
The reliance on sound resources for the sample format limits the maximum size of any one sample.
Resources should be kept below about 5 MB, but as this represents almost a minute of 16-bit
44.1kHz mono sound, it is not really a concern unless the program is to be used primarily for
triggering long samples. In this case a digital sequencer would be a more appropriate tool, as long
samples do not have to be resident in RAM and allows complete synchronisation between MIDI
and digital audio. If you use AIFF or SDII files for sample storage there is no limitation on sample
size.

MIDI Compatibility
The integration of this program into currently existing systems has been an important consideration
in its design, and for this reason it was decided that the best MIDI systems to use would be Apple's
OS X MIDI on OS X and the ‘Open Music System’ (formerly ‘Opcode MIDI System’) or OMS and
MOTU’s FreeMIDI on MacOS 7,8 and 9. OMS and FreeMIDI were written by Opcode and Mark
of the Unicorn to control the MIDI routing for their various hardware and software products.
VSamp’s MIDI routing operates by opening a virtual MIDI destination which is recognised by
other MacOS X, OMS or FreeMIDI-compatible applications running concurrently. VSamp has been
successfully used with OMS compatible sequencers such as Opcode’s Vision, Steinberg’s Cubase,
Coda’s Finale and Emagic’s Logic family of sequencer programs. Sequencers that support
FreeMIDI include MOTU’s Performer family.
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Using the VSamp Application
VSamp is a stand-alone application that can be launched from the Macintosh Finder. As stated
earlier, the memory available to VSamp for storage of samples can be set from the program’s Get
Info box (MacOS 7,8 and 9 only). Set the ‘preferred size’ to the size of all the samples you wish to
work with at once with 5MB extra for the program. For example, if you have a piano instrument
that uses 2MB of samples and a trumpet that uses 1.5MB, set the ‘preferred size’ of VSamp to
2+1.5+5=8.5MB.
The VSamp interface is very simple to use in that it contains only five menus. The first is the File
menu, which allows the user to configure instruments and banks and import other formats. The
second menu is the Edit menu, containing the standard edit commands. The Options menu contains
several items for configuring VSamp as well as the Preferences item where the polyphony, output
resolution, sample rate, headroom and Middle C value are set. The fourth menu is the Play menu,
which is used for loading and unloading instruments and banks into RAM as well as testing the
currently loaded instrument or bank. The Window menu allows you to select currently open files or
the instrument editing windows.

Setting the Sound Format
The type of sound output by VSamp needs to agree with the values set in the sound control panel
for maximum efficiency. VSamp is capable of outputting sound as 8 or 16-bit numbers at various
sample rates from 11 to 48 kHz.
Under MacOS 7, 8 or 9 go to the Sound control panel for your Macintosh and select a sample
resolution and rate, preferably the highest values. Then go to VSamp and set the same value in the
Preferences item.
The sample rate has a big effect on the polyphony and in general halving the sample rate will
double the available polyphony. With a fast computer (G3 or G4 processor) 44.1kHz is fine but
with a slower computer, if you can make do with 22kHz sound, do so. The sample resolution has a
much smaller impact on speed so if you have 16-bit sound available, use it.

Arranging Samples
The arrangement of sounds in VSamp is very straightforward. The most basic unit is the sample,
stored as a Macintosh sound resource, Sound Designer II file (SDII) or AIFF file. These files
contain all the necessary information about the sample, including pitch, sample rate and loops. Note
that SDII files cannot store the sample’s pitch so this value must be set in the instrument. These
values are set using either a commercial digital waveform editor such as Macromedia’s ‘SoundEdit
16’, Passport’s ‘Alchemy’ or Digidesign’s ‘Sound Designer’ software. Alternatively you can use
such shareware programs as the excellent ‘D-SoundPRO’, ‘Sound Effects’, ‘SndSampler’ and
‘SoundHack’ available online. For accurately setting loops a waveform editor is recommended.
The organisation of a group of samples (e.g. several piano samples) across the keyboard is called an
instrument. A VSamp instrument is created or edited with the commands New->Instrument and
Open respectively, chosen from the File menu.
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Each line of this instrument is used to select a sample for this instrument and define its lower and
upper notes on the keyboard. Click a box in the column labelled Sample to select the sample file.
The next column is a pop-up menu of all the sound resources in the selected file. If the sample is an
AIFF or SDII file this column will display ‘AIFF’ or ‘SDII’ and cannot be altered. The resources
are listed by ID number and name, and selecting a resource displays its number in the Resource
box (3rd column). Next the lower and upper MIDI notes are entered in the Note Range columns.
You can use a MIDI keyboard to enter these values but you must have your keyboard selected in
the MIDI Inputs window or a sequencer running to route the MIDI from your keyboard to VSamp.
These values can be entered as either numbers or names. Up to four samples can share the same
note/velocity range.  The next column is where you can set the sample’s pitch. This will initially
show the pitch stored in the sample’s header. Note that SDII files cannot store pitch data and so
default to middle C.
The next column is where you can set the pan of the sample in the stereo output. The pan of the
sample is also influenced by the instrument’s overall pan when part of a bank and the MIDI
channel’s pan value (ctrl #10). If the instrument/channel pan is centre then the samples will pan as
set in the instrument window. As the channel pan is moved to the right the samples will all pan to
the right until all samples are heard from just the right channel. The same applies to panning left.
Enter a pan for the sample between -64 and 63.
The next two columns are where you can set the velocity range for which you want the sample to
trigger. Leave these values at 1 and 127 for all velocities. For cross switching samples assign two
samples to the same notes but different velocity ranges.
The final column is where you can set mute groups for samples. If you wish a sample to switch off
another sample when it is played, assign them the same number between 1 and 127. This is
particularly useful in drum kits where one hihat sample can mute another. A sample with a unique
group number will mute itself ie. if it has a note range of several notes then it will switch off any
other notes using the same sample.
An easier way to add samples is to drag them from the Finder onto an instrument window. If the
samples have their pitches set then VSamp will automatically arrange the samples is ascending
order and set their note ranges (AIFF files only).
If you wish to insert a line in an instrument, click in the first column (the sample number) on the
line where you wish to add a row to highlight the row and select Insert Row from the Edit menu. If
you wish to Cut, Copy, Paste or Clear a row, select the row by clicking in the first column and
select the appropriate command from the Edit menu. Rows can be deleted by selecting the row and
choosing Delete Row from the Edit menu.
Finally select Save from the File menu to save your instrument.
The instrument also contains a button marked Track. Activating this (so it is green) means VSamp
will use the sample’s pitch information to transpose the sample to the correct pitch. If you leave this
box unchecked, VSamp will just play back the sample without transposing it. You will usually
leave this box checked unless you are creating drum instruments where you don’t want the samples
transposed.
To quickly sort the samples in an instrument by any column, click the button header at the top of
each column.

The Amplitude Window
Clicking on the instrument’s Amplitude button (or selecting Amplitude from the Window menu)
brings up the window where you can enter the envelope characteristics for this instrument.
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You can set either a global envelope that applies to all samples or you can set each sample
individually. Note that all times are in 100ths of a second with a maximum of 9900 (99 secs). The
sustain value is in percent of maximum amplitude. The picture in the top of the Amplitude window
shows what the current envelope looks like. The Amplitude window is floating and applies to
whichever instrument is currently being edited if several are open. If you don’t wish to use an
envelope, uncheck Use Envelope and the sample will be played from beginning to end with no
envelope. This will disable any looping in the sample.
The two knobs at the bottom of the window control how the amplitude (loudness) of the instrument
responds to note-on velocity and MIDI control #11 (expression). A value of 0 means the
instruments will not respond to note-on velocity and MIDI control #11. A value of 100 will cause
the instrument to become louder with higher velocity or controller. A value of -100 causes the
instrument to become quieter with increasing velocity or controller.

The Filter Window
Clicking on the instrument’s Filter button (or selecting Filter from the Window menu) brings up
the filter window where you can configure the filter for this instrument.
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The filter settings apply to all samples in the instrument. To activate the filter, select the Use Filter
checkbox, which will enable the filter controls. The first dial is where you set the frequency for the
filter in Hz. The second dial is the resonance (Q). The next three controls adjust how the filter
frequency changes with various parameters. The Pitch Mod setting changes the frequency
depending on the pitch. A setting of 50 (default) means that the frequency will double every octave.
In this case the value of the frequency dial applies to Middle C. Higher values will increase the
frequency with pitch and negative values will reduce the frequency with pitch. The Velocity Mod
setting changes the filter frequency with the note-on velocity. A setting of 100 will double the
frequency for a velocity of 127 compared to 64. The Breath Mod enables you to modulate the
frequency with MIDI control #2. Finally the gain enables you to increase or decrease the gain of the
filter. You will usually need to reduce the gain when using resonance or the samples will
distort.

The Tuning Window
Clicking on the instrument’s Tuning button (or selecting Tuning from the Window menu) brings
up the tuning window where you can configure the tuning parameters for an instrument.
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The Pitch Bend popup sets the number of semitones that the pitch will move when the instrument
receives a full pitch bend command. The Instrument Tuning adjusts the tuning of all samples
equally. 1 cent = 1/100th of a semitone. The Sample Tuning adjusts the tuning of each sample
separately. Select the keygroup with popup menu for which you wish to adjust the tuning then set
the tuning in the cents box. You can use the Copy to All button if you want to set the tuning for all
keygroups to the same value.

The LFO Window
Clicking on the instrument’s LFO button (or selecting LFO from the Window menu) brings up the
LFO window where you can configure the low frequency oscillator for the instrument.

To activate the LFO, select the Use LFO checkbox, which will enable the controls. The first dial is
where you set the frequency for the LFO in Hz*10. A value of 10 is 1 Hz. The second dial controls
the degree to which the LFO adjusts the pitch of the instrument. A value of 0 does nothing while a
value of 100 alters the sound by one octave. Negative values reverse the phase of the oscillator. The
third dial controls the degree to which the LFO adjusts the frequency of the instrument’s filter. A
value of 0 does nothing while a value of 100 doubles the filter’s frequency. Negative values reverse
the phase of the oscillator. The fourth dial controls how much the mod wheel (MIDI ctrl #1)
changes the LFO’s effect on pitch. A value of 0 has no effect and a value of 100 means a full mod
wheel setting will change the pitch by one octave.
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Loading Instruments
You can load the current instrument only by selecting Load Instrument->Channel X. In this case
whenever you change a setting on the instrument, the change will be heard immediately i.e. you
don’t have to reload the instrument. If you add, remove or reorder a sample you will have to reload
the instrument to hear the changes.

Arranging Instruments
The manner in which instruments are assigned to MIDI channels and outputs constitutes a bank.
Using New->Bank or Open from the File menu to create or edit a bank respectively, brings up a
window with 64 lines, one for each instrument.

Each line is used to assign a VSamp instrument to a MIDI channel and output. Simply select the
instrument by clicking on one of the boxes in the column marked Instrument then type the MIDI
channel (1-16) in the Channel column. Up to four instruments can share the same MIDI channel.
Alternatively drag instruments from a Finder window onto a bank window and they will be added
with incremented MIDI channels.
The output refers to the VSamp VST or Vsamp AU output pair (1-4). All instruments go to the
same output in the VSamp application (VSamp AU currently only has one stereo output).
Instruments can also be assigned a level (0-127) or pan (-64 to 63). These apply to when the bank is
first loaded (or a Reset All Controllers MIDI message is received (ctrl #121).  Any MIDI volume or
pan commands will replace these values.
Finally select Save to save the bank.
You can open an instrument directly from the bank window by selecting the instrument so it is
highlighted, then selecting Open Instrument from the Edit menu.
As with the instrument window, clicking on the column header will sort instruments by that
column.

Loading a Bank
A VSamp bank is loaded into memory using the Load Bank command from the Play menu. This
command is only available when a bank is open and is the front document (chosen from the
Windows menu if needed). This command opens each of the files referenced by the various
instruments in the bank and loads the relevant samples into memory, assigning each to a range of
notes for it’s particular MIDI channel. Appropriate error messages are given for such problems as
not being able to find files or resources, or running out of memory. Note that the bank loaded is as
the window shows, not how the bank was last saved. Likewise, if a bank references an instrument
that is currently open, the instrument is loaded as it appears on the screen, not how it appears on
disk.

Unloading an Instrument or Bank
When a bank is loaded the processor will be doing much extra processing even when no sound is
playing. Choosing Unload Instrument/Bank prevents this when you need the processor for other
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tasks. A currently loaded instrument or bank is also unloaded when you choose Preferences… from
the Options menu.

Saving Output as a File
Enabling the menu item Save Output as File in the Options menu before selecting Load
Instrument or Load Bank saves the audio output to a stereo Sound Designer II file. You are
prompted for a name before the instrument or bank is loaded. Saving output starts as soon as the
bank is loaded.  Alternatively if you have the MIDI Start/Stop item in the Options menu enabled,
then VSamp will wait for a MIDI Start or Continue command before commencing writing to the
file. With this item enabled it will also stop writing when it receives a MIDI Stop command. To use
this option you will need to configure your sequencer to send MIDI Clock messages to VSamp.
Note that output files can be fairly large, for example at 44kHz 16-bit settings the output file will
take up about 10MB per minute.

Testing a Bank or Instrument
Choose Play Scale->Channel X from the Play menu to play a C Major scale on the selected MIDI
channel for the currently loaded bank or instrument. This item is only enabled when an instrument
bank is loaded.

Importing SampleCell and SoundFont Instruments
Using the Import command in the File menu you can convert SampleCell 2.x instruments and
SoundFont 2 instruments into VSamp instruments. Select Import->SampleCell Instrument to bring
up a window to select the SampleCell instrument. Then another window asks where you'd like to
save the translated instrument and samples. Similarly use Import->SoundFont for SoundFonts
except that you are prompted for a location to save the files rather than a file name. SoundFont files
can contain many instruments which will all be translated.
Note that only samples and keymaps are translated. Any modulation data needs to be set manually.

Resetting Sound
Choose Panic from the Options menu to stop all sound and reset all MIDI controllers. This item is
only enabled when an instrument or bank is loaded.

Accessing VSamp from Sequencer
Refer to your sequencer’s manual on using MacOS X MIDI, OMS or FreeMIDI. Directions for
each of the major sequencers can be found at the VSamp home page.

Setting the Polyphony
VSamp requires you to set the polyphony to avoid breaks in the audio signal. A simple test needs to
be carried out: Load an instrument into VSamp and with the sustain pedal down play up a scale,
counting the notes until the sound deteriorates. Set this number (minus two for safety) in the
polyphony field from the Preferences… item in the Options menu. Note that if you push the
computer too hard the computer is more likely to crash and there will not be enough power to run a
sequencer in the foreground. If you use the ‘Acoustic Guitar Instrument’ for this test you should
first set it’s envelope’s sustain value to 100. That way the sound will not fade when you sustain
notes. If you are using filters you should enable them for the test instrument before carrying out the
polyphony test.
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Fine Tuning the Program
The headroom setting sets the output level of VSamp and defaults to 6dB. Setting a value of 0dB
will give a stronger output and better quality sound but will more likely distort with multiple voices.
If you don’t use many voices you can set this to 0dB but beware - the distortion when it happens is
severe! For higher polyphony settings it is suggested you set this to 12dB or even 18dB.

The MIDI Input Window

Selecting MIDI Inputs from the Window menu enables you to connect VSamp directly to a
MacOS X, OMS or FreeMIDI device. This is only necessary when using VSamp without a
sequencer. To connect VSamp to a keyboard, click in the appropriate checkbox depending if you
are using MacOS X, OMS or FreeMIDI, then select your keyboard from the popup menu.

The Keyboard Window
Selecting Keyboard from the Window menu brings up the onscreen keyboard.

When a instrument or bank is loaded you can trigger samples either by using the clicking the mouse
on a key or by typing the corresponding key on the computer keyboard. Select the MIDi channel
you wish to play from the popup menu labelled MIDI Channel.
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Using VSamp with Soundcards
VSamp has been tested with the Pro Audio Spectrum 16 sound card, which doesn’t support
multichannel sound. Since VSamp only uses one sound channel this is not a problem as long as
other applications don’t require sound channels. I have found that Opcode’s Vision sequencer
allocates a sound channel during playback and record which stops VSamp playing. The way to
prevent this is as follows:
• Go to the Sound Out panel of the Sound control panel and select the output device that you want

VSamp to use (PAS16 card)
• Launch VSamp and load a bank. This is when VSamp opens its sound channel.
• Go to the Sound Out panel of the Sound control panel and select a different output device that

other applications can use (MAC internal).
• Launch the sequencer or other application.
The VSamp sound will then go to the sound card and other applications will send sound to the
Macintosh, which shouldn’t upset VSamp. Whenever you load a new bank you will have to change
the Sound Out panel of the Sound control panel to your soundcard before you load the bank, then
back again before you continue.
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Using VSamp VST and VSamp AU
For deciding which plugin to use with your sequencer refer to Installation.
VSamp VST and VSamp AU are plugins that can play VSamp instruments and banks from within a
sequencer. You will need to create and edit the instruments and banks with the VSamp application.
The plugins are controlled and configured from within the sequencer. You can only use VSamp
VST with a VST-2 compatible sequencer and VSamp AU with an AudioUnits compatible
sequencer.
VSamp VST has four stereo outputs and VSamp AU has one stereo output and can play both
VSamp instruments and banks. If you have loaded a VSamp instrument into one of the plugins then
it will respond to messages on any MIDI channel and send it’s output to the first stereo pair. If you
have loaded a bank then each instrument in the bank will respond to it’s assigned MIDI channel and
send it’s output to its assigned output pair.

To use VSamp VST with Cubase 4.1:
• Put the file ‘VSamp VST’ in the VstPlugIns folder, which is in the Cubase folder.
• Launch Cubase
• Select VST Instruments from the Panels menu.
• Select VSamp VST from the popup menu No VST Instr. on the Instruments window. This will

create a new VSamp VST instrument.
• Click on the power button on the left side of the VSamp VST Instrument.
• Each VSamp VST instrument can store up to 32 programs, which are a combination of a

VSamp Instrument or Bank with polyphony and voice settings. These programs are selected
with the program arrows.

• To edit a program select the program with the program arrow buttons then press the Edit
Button.

• Press the Select button and select your VSamp instrument or bank.
• Use the faders to set the number of voices that this instrument will play. A lower value will put

less strain on your computer’s processor. Select also the headroom. Leave this at 0dB unless the
sound starts to distort.

• Close the Editor window by clicking in the close box (top left of window).
• You can create more of these instruments if you wish provided you have enough processing

power. They will be called VSamp VST (1), VSamp VST (2) ....
• Assign a MIDI track to this instrument by selecting the instrument in the track’s output window.



19

To use VSamp VST with Logic 4.1:
• Put the file ‘VSamp VST’ in the VstPlugIns folder, which is in the Logic folder.
• Launch Logic
• Open an environment window and select New->Audio Object.
• Select Instrument 1 from the Channel setting in the parameter box.
• Hold down the mouse on the FIRST insert of the audio object and select VSamp VST.
• Double-click the insert laballed VSamp VST to open the editor.
• Press the Select button and select your VSamp instrument or bank.
• Use the faders to set the number of voices that this instrument will play. A lower value will put

less strain on your computer’s processor. Select also the headroom. Leave this at 0dB unless the
sound starts to distort.

• Close the Editor window by clicking in the close box (top left of window).
• You can create more of these instruments provided you have enough processing power.
• Assign a MIDI track to this instrument by selecting the instrument in the arrange window.

To use VSamp AU with Logic 5.5 (MacOS X):
• Using VSamp AU with Logic 5.5 is similar to using VSamp VST with Logic 4.1 (see above).

Select VSamp AU in the audio object’s insert slot.
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Recent Version History:

3.3.0, 30th January 2003:
• 2nd beta release of VSamp VST Carbon and VSamp AU
• Improved filter processor efficiency
• Improved latency response
• Added Level and Pan columns to bank window
• Added ability to sort by columns in instruments and banks
• Minor bug fixes.

3.2.7, 13th August 2002:
• Smoother envelopes
• Fixed crash when opening an instrument or bank whose children could not be found.
• Fixed problem whereby program quitted with type 3 error when using FreeMIDI in OMS Mode.
• Added command to open an instrument from the bank window.
• Fixed problem with VSamp VST and hanging notes in Logic.
• Fixed problem with incorrect velocity ranges and looping when importing some SoundFonts.

3.2.6, 1st March 2002:
• Floating windows no longer have to be clicked twice to select a control when not the current

active window.
• Status of floating windows now restored after quitting.
• Up and down arrows now increment/decrement keygroup in Amplitude and Tuning windows.
• SampleCell 1.x instruments correctly identified when trying to import and error message given.
• Fixed problem with hanging notes under OS X.

3.2.5, 3rd December 2001:
• Fixed problem with importing some SampleCell instruments.

3.2.4, 12th November 2001:
• Removed need for all samples in an instrument to reside in the same folder.
• Increased range of filter modulation.

3.2.3, 4th September 2001:
• Fixed problem whereby double-clicking on a VSamp file in MacOS 9 Finder gave an error -39

(launched OS X VSamp instead of OS 9).

3.2.2, 20th August 2001:
• Support for MacOS X, including OS X CoreMIDI services.
• Fixed minor problem whereby shift key was needed to release some notes in MIDI Input

window.
• Fixed problem whereby LFO window appeared incorrectly if old preferences file was present.
• Changed behaviour after an "All Notes Off" MIDI command to improve compatibility with

some keyboards.
• Moved registration data to a file in the Application Support folder now shared by VSamp

application and VSamp VST.

3.2.1, 28th June 2001:
• Fixed problem whereby keys in keyboard window were sticking when using computer

keyboard.
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• Floating windows now hide when VSamp is moved to background.

3.2.0, 16th June 2001:
• Added importing of SampleCell 2.x and SoundFont2 samples and instrument keymaps.
• Added onscreen keyboard for triggering samples by mouse or computer keyboard.
• Increased samples per instrument to 128.
• Added controllable amplitude modulation by note-on velocity and MIDI controller #11.
• Added commands to register VSamp and VSamp VST.
• Minor interface changes and bug fixes.

3.1.4, 9th April 2001:
• Fixed compatibility problem between VSamp VST and Logic Audio under MacOS 9.1.
• Fixed problem whereby VSamp VST window enlarged after registration dialog under Logic.

3.1.3, 26th March 2001:
• Fixed problem whereby under some circumstances the message “Your demo time has

expired…”  appeared even though a valid serial number had been entered.

3.1.2, 19th March 2001:
• Fixed problem whereby some valid serial numbers were reported as having expired.
• Improved timing of Play Scale command.

3.1.1, 18th March 2001:
• Increased performance(~20%).

3.1.0, 1st March 2001:
• Added LFO with own editor window.
• Added MIDI Inputs window.
• Added assignable output to bank window.
• Reorganised menus
• Minor bug fixes
• Added Reload button to VSamp VST
• VSamp VST can now play VSamp banks with 4 assignable stereo outputs.

3.0.3, 22nd September 2000:
• Fixed problem loading files from locked volumes (e.g. CDs).
• Smoother envelopes.

3.0.2, 3rd September 2000:
• Added Tuning window.
• Fixed problems with opening locked files.
• Fixed problem whereby changing an instrument setting for a currently loaded instrument would

cause the instrument to be loaded on top of currently loaded settings, usually resulting in
distorted output.

• Increased pitch bend range to 4 octaves and smoothed response.

3.0.1, 22nd August 2000:
• Fixed bug whereby instruments accessing more than one sound resource from same file would

only use first resource.
• Opening a bank or VST instrument that can’t find an instrument now prompts to locate the

instrument.
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3.0, 7th August 2000:
• Added resonant filters with real-time control.
• Improved tuning.
• Last location of envelope window now remembered correctly.

3.0b2, 1st July 2000:
• Dragging a group of samples all with pitch set to middle C (MIDI 60) now adds them to

successive notes from middle C and sets pitch accordingly.
• Clicking on a text field now selects entire field as in version 2.
• VSamp VST no longer loads an instrument when cancelling a selection after pressing ‘select’

button.
• Revert command now works as expected.
• Menu enable/disable status when envelope window is open now works as expected.
• Problem fixed whereby a window wouldn’t close if the file it refers to had been moved or

changed.

3.0b1, 1st June 2000:
• Major rewrite to update interface and program control for future MacOS.
• New floating envelope window.
• Separate envelope for each sample, if desired.
• Play a sample with no enveloping.
• Up to 4 samples sharing same MIDI Channel/Note/Velocity combination.
• Support for 24-bit/96 kHz samples (VST and program) and output (VST only).
• Added ‘Insert Row’ and ‘Delete Row’ commands for instrument and bank windows.
• Added ability to load an instrument directly.
• New VST interface for better compatibility with Logic.
• Louder output for samples panned centre with more even response across panorama.
• More natural velocity response.
• Removed ‘HiQ’ switch in bank (always on).
• Removed ‘pitch bend’ setting in bank (set in instrument).

2.7.0, 28th December 1999:
• First release of VSamp VST.
• VSamp bank now can locate instruments that have moved or been renamed.
• Minor fixes to instrument window so that clicking on a blank box then pressing return does not

give an error about an invalid value.
• Loading a bank that refers to a non-existent file no longer creates the file but instead gives an

error message.


