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Introduction to Surfer Central
This section introduces you to Surfer Central. Included here is an explanation of the program, some 
reasons why you should use it, and a list of features.

Please note that the words "site" and "address" are used interchangeably; that is, each refers to an entity 
which is stored within the database

To learn more about Surfer Central and what it can do for you, select one of the following links.

What is Surfer Central?

Why should you use Surfer Central?

List of Features

Conventions



What is Surfer Central?
Surfer Central is a useful tool for Microsoft Windows 3.1 (and later) that allows the user to manage all 
Internet addresses, including E-Mail, WWW, FTP, FSP, Gopher, Archie and Telnet, in a convenient and 
simple fashion. Each address contains fields that are unique to that site type. For example, E-Mail 
addresses contain a person's name, e-mail address, alias, snail mail address, etc. Field names are 
completely customizable and need not be displayed if the field is of no personal use.

The site database is split into 7 categories according to the various types of addresses that may be 
entered. In addition, each address may be accessed from a global list of all sites in the database. Each 
site may be assigned one of 32 user-definable subcategories according to personal tastes. For example, 
a list of e-mail addresses could be separated into personal, business, and support contacts.

Site lists may be generated at the click of a button which is an excellent feature if you manage some sort 
of mailing list. The text header of each section of the site list is fully customizable.

Surfer Central also acts as an excellent shell for maintaining Winsock connections. At the touch of a 
button, you can launch your Winsock session manager (for example, TCPIPMan.EXE) as well as the 
client software associated with the site you have selected. TCP/IP Manager can also be loaded in a 
minimized state and unloaded on exit of Surfer Central.

Netscape bookmark files and Mosaic hotlist files can be imported into the database saving you countless 
hours of retyping!!! In addition, each URL to be imported may be assigned to a particular category.

As of version 1.20, site types are also user-definable. Don't like the FSP site type? Change it to 
something else such as 'News'!!



Why should you use Surfer Central?

The number of people using the Internet is growing at an alarming rate. Obviously, each user has some 
sort of address associated with him/her. For example, every Internet user possesses an e-mail address 
and possibly (soon) a home page on the World Wide Web. This makes for a horrendous number of 
addresses to manage. Surfer Central is tailored towards helping you keep track of all of your sites and 
addresses in a convenient and logical way.

Some of the advantages of Surfer Central over conventional methods of managing your Internet 
addresses include:

· you can have all your sites in one handy dandy place

· you can organize addresses by name instead of cryptic addresses

· you can do searches for text

· sites can be arranged in categories for logical storage

· generate quick lists of addresses so you have hard copies

· generate quick lists of addresses so you can trade with other people

· all of your Winsock programs are accessible in one place

Surfer Central is for you if you are an Internet surfer, either a newbie or a guru. Surfer Central will help 
you manage your WWW, E-Mail, FTP, FSP, Gopher, Archie and Telnet addresses so that locating a 
needed contact, FTP site, home page, archie server, etc. is a painless process.



List of Features
Given below is a summary of some of the useful features provided by Surf Central. Feel free to copy and 
paste this list and pass it on to your friends!!

· allow the user to store and retrieve a wide variety of Internet site addresses in a simple fashion

· contain custom fields for WWW sites, E-Mail addresses, FTP, FSP, Telnet, Archie, and Gopher... 
or create your own site types!! 

· site information boxes that DO NOT display information that is unnecessary (ie. dynamic fields)

· custom fields for each of the Internet sites described above

· import Netscape bookmark files and Mosaic hotlist files and place each URL into a particular 
category.

· have Netscape automatically connect to a URL from within Surfer Central.

· automatically grab a URL from Netscape to ease the creation of a new address record.

· act as a command shell for using a Winsock connection. A dynamic toolbar on the right side of 
the main window contains buttons for all Winsock tools the user has currently configured.

· automatically load TCP/IP manager in a minimized state and unload it on exit of Surfer Central

· generate an organized, customizable site list at the click of a button. This list may contain full 
details about the addresses in the database or simply your addresses (great for a mailing list)

· a screen that lists all of the sites in the database (with scrollbar) and allows the user to click on a 
site to get full details.

· use a notebook metaphor for assigning each site a category

· full 3-D interface

· toolbars (with descriptions) for most activities

· check for a valid winsock connection and if none is found, launch the appropriate Winsock 
connection manager and close it when complete.

· allow the user to define the WWW, FTP, etc. clients which are used in his/her system

· when a FTP, WWW, site is on the screen, with the press of a button the client software is 
launched and the user is connected to that site.

· simple copy operation to copy a site name to the clipboard. Addresses may be copied as URLs if 
desired.

· context sensitive menus available by clicking the right mouse button

· password option for each of the site list files

· modem status window with LEDs for all you internal modem users

· many user customizable features, including screen colors, fonts, toolbars displayed, desktop 
window position and others.



Conventions
There are several typographical conventions used within this help file:

Primary Mouse Button: is usually, by default, the left button of the mouse. This button is used 
for most operations such as selecting text or choosing a menu item.

Secondary Mouse Button: is usually, by default, the opposite button to the primary mouse 
button (i.e. the right mouse button). This button is typically used for accessing pop-up menus. 

Menu Items: menu items are indicated by black boldface text. For example, the File menu.

Buttons: are indicated by italicized text.

Select: this word usually implies that the primary mouse button should be clicked on a particular 
object on the screen. For example, select Open from the File menu implies that the primary 
mouse button should be first clicked on File followed by the Open menu item.



Getting Started
Here is some information to help you get you started running Surfer Central. Given below are the system 
requirements, steps involved in installing the program, how to run it and explanations and solutions to 
some common problems.

System Requirements

Installation

Running Surfer Central

Common Questions



System Requirements
To use Surf Central, you will require:

· at least an 80386 processor
· Windows 3.1 (or later)
· a screen resolution of 640x480 (256 colors recommended) or greater
· a mouse
· at least 2 Meg of memory (more depending on the size of the database file)
· approx. 2.5 Meg of disk space



Installation
Installation of Surfer Central couldn't be simpler!! An installation program called INSTALL.EXE has been 
included to automatically configure Surfer Central for your machine. Assuming you are using Program 
Manager, click on the File menu and select Run. Next type:

a:install

Follow the on screen instructions and when you are complete, Surfer Central can be run by double-
clicking on the icon that was placed in the group of your choice.



Running Surfer Central
Running Surfer Central is very straightforward. Simply locate the Surfer Central icon in your Windows 
shell (usually Program Manager) and double-click the left mouse button on this icon.

Hint: the Surfer Central icon will be located in the program group that you selected during the install 
process.



Common Questions
Listed below are some common problems that users of Surfer Central have experienced. Before 
contacting the author for technical support, please review these problems to see if any apply to your 
situation.

Problems Registering

General Protection Faults

Winsock Programs

Main Window

Help Window

Importing Netscape Bookmarks or Mosaic Hotlists



· I registered my copy of Surfer Central but since then I've made significant changes to my system. 
Now the program says I'm not registered. What should I do?

The registration program uses your system information to generate the program lock 
number. When you change part of your system a new key number is required that 
corresponds to your new lock number. Simply contact the author providing your new and 
old lock number in the correspondence. Your registration status will be verified and you 
will be given a new key number (at least until I come up with a better system).



· I get a General Protection Fault (GPF) when the program is started - something to do with not being 
able to find a bitmap or other type of file. What is wrong?

Make sure that the icon you are using to run the program has its working directory set to 
the same directory that contains the SURFRCEN.EXE file. If the working directory is not 
correct, the program will not be able to find some of its files that are necessary for 
initialization. Better error checking will be incorporated into future versions of Surfer 
Central.



· When I launch one of the Winsock client programs a message box appears indicating there was an 
error.

Do you use a TCP/IP Manager? The most common instance of this error is Error Code: 2. 
This error indicates that a file was not found. If you don't have the TCP/IP Manager setup 
correctly and the Winsock program you are launching is set up to first launch the TCP/IP 
Manager followed by itself, you will get this error which indicates that Surfer Central tried 
to execute TCP/IP Manager but was unsuccessful. If you don't use any sort of Winsock 
manager, then make sure the associated checkbox for each Winsock tool is unchecked. 
See Using the Winsock Tools for more information. Also, here is a list of error codes.

· I have checked the minimize TCP/IP Manager checkbox and the unload TCP/IP Manager 
checkbox in the Configure Winsock Tools dialog. However, when I run the TCP/IP Manager it 
is not minimized and when I exit Surfer Central the TCP/IP Manager is not closed. What is 
wrong?

For the TCP/IP Manager, you must have the description field in the Configure Winsock 
Tools dialog box set to the exact name of the Window (given in the title bar) of the 
TCP/IP Manager you use. For example, a heavily used manager is called Trumpet 
Winsock. You'll notice that the title of the main window when Trumpet Winsock is loaded 
is indeed 'Trumpet Winsock'. Thus, you must have this string as the description. Why? 
Because Surfer Central can't find the Window to minimize/close if it doesn't know the 
name of it.



· After importing a Netscape bookmark or Mosaic hotlist file, the columns in the sites listbox seem all 
messed up. Some URLs are displayed on the screen but the URLs with sites that have long site 
names are not displayed. How can I fix this?

The site names of the sites in the bookmark file or hotlist file are extraordinarily long. To 
clean up the sites listbox you should shorten the long site names. To do this, select the 
site with the long name, shorten the name in the site entry area, and insert the new site. 
Finally, delete the old site that had the long name. Note that you cannot just change the 
name of the site - when a site name or address is changed Surfer Central requires that 
you perform an insert operation.



· When I invoke Surfer Central help that pesky little window displaying the contents tree is always on 
top of other windows. How do I fix that???

To prevent the contents tree from staying on top of other windows, click on the Help menu 
of the HWA Contents Tree window and select the menu item 'Always On Top'. This 
actions will have the effect of disabling the always on top feature causing the contents 
tree to behave like all other windows. Note that this need only be done once. The 
contents tree window remembers its state between executions, thus, the next time it is 
invoked, the always on top feature will remain disabled.



· I am trying to import a Netscape bookmark file (or a Mosaic hotlist file) and when I choose the file 
nameto import in the open dialog box, the list of sites to be imported is blank. I know there are sites in 
that bookmark file. What is wrong?

This problem is commonly encountered when trying to import a bookmark or hotlist file 
that was originally used in a UNIX environment. UNIX files do not use the same carriage 
return / line feed combinations to break lines in a file as DOS does. As a result, when 
Surfer Central attempts to read the bookmark or hotlist file and that file was created in a 
UNIX environment, it thinks there is just one long line in the file and your sites are read 
incorrectly. The solution is to give the command 'unix2dos -ascii <file> <file>' (without the 
quotes) in the UNIX environment before bring the bookmark file over to your PC. This 
command converts the file to use the DOS carriage return / line feed convention. Surfer 
Central should then read your file correctly. If you have any questions on this process, 
please feel free to e-mail me.



Using Surfer Central
This section explains how to make productive use of Surfer Central. The main window is described, as 
well as the general procedures required to create an address database.

The Main Window
{ a description of the various parts of the main window }

Procedures
{ descriptions of common procedures }

Note: Some sections of the help file contain screenshots which were captured while running Windows 95. 
Therefore, the title bars of the windows, and possibly other elements may look different than on your 
system. Don't worry about it...



The Main Window
This section describes the various sections of the main window (the window that is visible when you load 
Surfer Central). Click on one of the links below for further information on a particular area of the window. 
You may also click here for a screenshot.

The Main Menu

The Sites Listbox

The Site Entry Area

The Toolbar

The Winsock Toolbar

The Sites Toolbar

The Status Bar



Note #1: Your main window may not look exactly like this - it depends on your video mode, how your 
system colors are configured, and the configuration of your Winsock tools.

Note #2: For information on a particular area of the main window, move over the desired area (the cursor 
should turn into a hand) and click the primary mouse button to jump to the appropriate topic.



The Main Menu

A picture of the main menu for Surfer Central is provided below. For further information on any of the 
menu items, click on the appropriate menu item in the illustration.



The Sites Listbox

The sites listbox provides a bird's-eye view of the sites in the current database. The list is divided into 
several (up to 8) categories as indicated by the tabs at the bottom of the listbox. Only the sites belonging 
to the currently selected category are displayed. A screenshot of the sites listbox is given below.
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Each site in the list is represented by two fields of text - the first field (leftmost column) identifies the name 
of the site; the second field (rightmost column) indicates either the hostname or the IP address of that 
site. The hostname is given a higher priority than the IP address (since it is more meaningful) but if no 
hostname was provided when the site was entered into the database, the IP address is displayed.

Each site in the list can be selected by clicking the primary mouse button on it. A selected site is 
highlighted in blue in the example above, but this color may be different depending on your system 
configuration.

To change categories, simply click on the desired category tab. There are actually 8 categories in total, 
although all 8 will not be visible on the screen simultaneously. To view hidden tabs, press the right and left 
arrows at the far right of the tab set.

Hint: To configure the color and font of the listbox, please see Configuring the Program.

Hint: To manipulate a site in some fashion (such as delete or cut it), check out the sections Deleting a Site 
and Cutting and Pasting Sites

Hint: To change the names and order of the categories, please see Dealing with Categories



The Site Entry Area

The site entry area is where you will enter the information for all of your Internet addresses. A screenshot 
of the site entry area for an FTP site is shown below.
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All of the fields for each site type are shown in this box. Note that the field labels (to the left of each edit 
box or scroll bar) are user configurable, so your labels may look slightly different. Also, each site type 
contains different fields - the site entry area changes dynamically corresponding to the currently selected 
site type. For example, it wouldn't make sense to have a field for a person's snail mail address in a WWW 
record.

The site entry contains several fields by default:

· Category Name - shown in brackets beside the Site Entry label

· Site Name - a text string describing the site

· Host Name (URL for WWW) - the hostname of the site

· IP Address - the Internet Protocol address in numeric form

· URL Type (WWW Only) - the type of URL in the URL box

· Login Name - the name you use to login to the site

· Password - the password used to login to the site

· Description - any text that you wish

· Rating - 0 (scrollbar at left edge) indicates a poor site and 5 (scrollbar at right edge) indicates 
an excellent site

· Port - port number of the site (e.g. for FTP, the port is always 21)

· User Field #1 - any text you wish (the label for this field in the above example has been 
changed to Directory)

· User Field #2 - any text you wish (this field is not displayed in the above example)

The buttons are (from left to right):

· Previous Site - go to the previous site in the list. If the first site is the one displayed in the site 
entry information area then this button is disabled

· Clear - Clear all the edit boxes. This button is used when a new site (starting from scratch) is 
to be entered

· Update - Press this button when you have made a change to one of the fields of the currently 
displayed site. You cannot update a site in which the site name, host name or IP address 
has been changed. In this case the Insert button must be used. (see Updating an Existing 
Site)

· Insert - Once all of the information for a new site has been entered, the Insert button must be 
used to submit the site to the database and display it in the sites listbox (see Entering a New Site)

· Next Site - go to the next site in the list. If the last site is the one displayed in the site entry 
information area then this button is disabled



Hint: To quickly move between edit boxes, press the Tab key to move forward and Shift + Tab to 
move backward

Hint: If all of the information for a particular field is not visible in an edit box, simply click on the edit 
box to activate it and use the cursor keys to view the hidden text

Hint: For information on changing the label descriptions for each field, please see Changing Site Field 
Labels



The Toolbar

The sole purpose of the toolbar is to make commonly used menu items available with one click of the 
mouse. You will find that you will rarely need to use the main menu since almost all commands are 
available via a toolbar on the main window. Another purpose of the toolbar is to display hints for various 
buttons and menu items in the program. The gray window on the right side of the toolbar displays context-
sensitive hints when the mouse is over a hint-enabled button or menu item.

For your reference a brief description of each toolbar button is given below. For further information on a 
toolbar button simply click the primary mouse button on the appropriate toolbar button in the diagram 
below.

Hint: to determine the purpose of a toolbar button, move the mouse over the button in question.



The Winsock Toolbar

The Winsock toolbar is located on the left side of the main window. Included on this bar are various 
buttons that are used to launch the Winsock client programs.

This toolbar will look different for every user since not everyone will use the same client programs. In all 
probability, the Winsock toolbar buttons will be disabled (i.e. are not pressable) when Surfer 
Central is run for the first time. Once configured, the toolbar buttons take the form of the icon assigned 
to the client program. As shown in the example toolbar below, the WWW browser icon contains a bitmap 
of the Netscape icon since Netscape is the browser that I use.

Note: If the toolbar buttons are disabled (contain a text description and cannot be pressed) you must 
setup the paths to the client programs you use. For further information see Using the Winsock Tools

To get more information on a particular toolbar button, click the mouse on the appropriate icon in the 
picture below.

Hint: For help on what the various icons represent, simply move the mouse over an icon to view its 
associated "balloon" help.



Button Purpose: To launch the TCP/IP manager tool

Description: The TCP/IP manager is used to coordinate and manage the SLIP or PPP connection on 
your machine. If you have a direct connection to the Internet and do not make use of SLIP or PPP then 
this tool will not be of use to you. Feel free to reconfigure this button to launch another program of your 
choosing.

A common TCP/IP Manager is called Trumpet Winsock.

See Using the Winsock Tools for more information.



Button Purpose: To launch your World Wide Web browser program

Description: The World Wide Web (WWW) is a tool whose use is exploding on the Internet. It allows you 
to view hypertext documents which take you to various other links on the Internet. The amount of 
information available on the Web is astounding! This button allows you to launch your WWW browser. 
You may also configure the program in such a way as to first launch the TCP/IP manager before 
launching the browser.

Common WWW browsers are Mosaic and Netscape.

For more information on configuring the Winsock toolbar, please see Using the Winsock Tools



Button Purpose: To launch your e-mail client program

Description: Once you have looked up an e-mail address using Surfer Central, the next logical step is to 
launch your e-mail client program so that you may send this person some mail. Pressing this button loads 
up your e-mail program as well as the TCP/IP manager if desired.

Common e-mail programs are    Eudora and Pegasus Mail.

For more information on configuring the Winsock toolbar, please see Using the Winsock Tools



Button Purpose: To launch the FTP client program that is configured on your system

Description: Press this button once you have looked up a site that possibly contains a file you are after. 
The File Transfer Protocol client will be launched as well as the TCP/IP manager if so desired.

A common FTP client is WS_FTP.

For more information on configuring the Winsock toolbar, please see Using the Winsock Tools



Button Purpose: To launch the FSP client

Description: FSP is actually a rarely used file transfer system but I have used it somewhat in the past so 
I decided to include it in Surfer Central. Pressing this button launches the FSP client program as well as 
the TCP/IP manager if desired.

Common FSP clients are WINFSP and FSP4WIN.

For more information on configuring the Winsock toolbar, please see Using the Winsock Tools



Button Purpose: Launch the Gopher client program

Description: Gopher is a hierarchical system of information retrieval first launched by The University of 
Minnesota. It's use is dwindling at the present time due to the advent of the World Wide Web. However, 
many gopher sites are still in existence. To launch the Gopher client program, as well as the TCP/IP 
manager if desired, press this button.

A common gopher client is WS_GOPHER.

For more information on configuring the Winsock toolbar, please see Using the Winsock Tools



Button Purpose: To launch the Archie search tool

Description: Archie is a useful tool on the Internet allowing you to search thousands of FTP sites for a 
particular string. It is perfect if you are searching for a particular file and don't know where to look. Press 
this toolbar button to launch the archie tool, as well as the TCP/IP manager if desired.

A common archie client program is WS_ARCHIE.

For more information on configuring the Winsock toolbar, please see Using the Winsock Tools



Button Purpose: To launch the Telnet or rlogin tool configured on your system

Description: Many internet users have accounts on more than one system - sometimes a second or third 
account may lie halfway across the world!! To get to these 'extra' accounts, a Telnet tool is used which is 
accessible via this button.

A common telnet program is EWAN.

For more information on configuring the Winsock toolbar, please see Using the Winsock Tools



Button Purpose: To launch a previously configured program of your choice

Description: You may configure this button to launch any program of your choosing. For example, if you 
like to take notes while on an archie site, you may want to launch NotePad via this button.

Good uses for this button are NotePad (for taking notes) or File Manager (for manipulating your retrieved 
files). But feel free to use this button however you want!!

For more information on configuring the Winsock toolbar, please see Using the Winsock Tools



The Sites Toolbar

The sites toolbar is located at the bottom of the main window and allows the user to navigate between the 
various site types. Clicking on a site type will change the current focus of the database to that site type.

The diagram below is only a sample of what the sites toolbar may look like. As of v1.20 of Surfer Central, 
site types are now user-definable!!! You may place any text or graphic on a button! For details, please see 
User-Definable Site Types.

Note: only one site type (toolbar button) can be active (in a pressed state) at any given time.



The Status Bar

The status bar contains 3 areas: the progress bar, the number of sites indicator, and the current file 
indicator.

progress bar: indicates the progress of loading a file or searching for a text string.

modified indicator: is set to "Modified" if the database has been changed since the last save. 
This indicator is blank if no save is required.

number of sites indicator: indicates the total number of sites in the current database.

current file indicator: indicates the name of the sites database being editted.



Procedures
This section (and its associated topics) will explain everything that is needed to develop and maintain a 
database of Internet addresses. Given below are topics that will cover everything from starting a new 
address database to exiting the program. If this is your first time using Surfer Central, it's probably a good 
idea to browse through these sections in order.

Starting a New Sites Database

Loading an Existing Sites Database

Saving the Current Sites Database

Importing Files

Encrypting the Current Sites Database

Printing the Sites Database

Selecting a Site Type

User-Definable Site Types

Entering a New Site

Updating an Existing Site

Deleting a Site

Cutting and Pasting Sites

Cutting, Copying, and Pasting Text

Copying and Pasting Addresses to Client Programs

Dealing with Categories <updated!>

Displaying a Summary of Categories

Searching for Text Strings

Displaying a Summary of All Sites

Changing Site Field Labels

Hiding and Displaying Fields

Generating a List of Sites

Using the Winsock Tools

Automatically Loading URLs into Netscape <new!>

Grabbing URLs from Netscape <new!>



Configuring the Program

Getting Help

Quitting the Program

Tips and Shortcuts <updated!>



Starting a New Sites Database

To begin a new sites database, choose New from the File menu.

If you are prompted to save the existing database and wish to do so, select Yes  and follow the 
instructions in Saving the Current Sites Database. Otherwise, select No and continue.



Loading an Existing Sites Database

If a database exists on disk that you wish to retrieve, you may do so by selecting Open from the File 
menu.

If you are prompted to save the existing database and wish to do so, select Yes and follow the 
instructions in Saving the Current Sites Database. Otherwise, select No and continue.

Once the open dialog box appears, change to the appropriate directory that contains your site database 
file. You can change directories by double-clicking the left mouse button on the appropriate directory in 
the box containing the directory tree.

After navigating to the correct directory, click on the file you wish to load and press the Ok  button.

To abort the Open procedure and return to the current database, select the Cancel button.

If the database file has been previously encrypted using a password you will need to enter the correct 
password in the dialog box that appears. Enter the password and press Ok. If the password is correct the 
file will properly load, otherwise you will receive an error message.

The evaluation version of Surfer Central only allows you to load databases consisting of 50 sites 
or less.



Saving the Current Sites Database

If this is your first time saving a new database:

· Select Save As from the File menu

· Select a directory for the file to reside by double clicking on the branches in the directory tree 
(right side of save dialog box)

· Choose a filename for the database in the edit box in the top-left corner of the dialog

· Press Ok.

If you would like to save the database using the same name as used previously:

· Select Save from the File menu

· The previous version of the file will have been overwritten

If you have saved your database before but would now like to use a different name:

· Select Save As from the File menu

· Follow the instructions in saving a new database above

For details on encrypting the database using a password, please see the section Encrypting the Current 
Sites Database



Importing Files

As of v1.20 of Surfer Central, you can import Netscape bookmark files and Mosaic 
hotlist files and choose to which category each site belongs!!!

To import a Netscape bookmark file into Surfer Central:

· Select Import from the File menu followed by the Netscape pop-up menu item

· A dialog box will appear prompting you for the name of the bookmark file. Enter the name of 
the file in the edit box or select the file with the mouse. Note that bookmark files usually end 
with the extension .HTM since these files are actually HTML documents.

· Now that you have chosen the file to be imported, proceed to Choosing Site Categories for 
Imported Sites

To import a Mosaic hotlist file into Surfer Central:

· Select Import from the File menu followed by the Mosaic pop-up menu item

· A dialog box will appear prompting you for the name of the hotlist    file. Enter the name of the 
file in the edit box or select the file with the mouse.

· Now that you have chosen the file to be imported, proceed to Choosing Site Categories for 
Imported Sites



Hyper-Text Mark-up Language:

The 'programming language' that is interpretted by a web browser (such as Netscape or Mosaic) to 
produce all those wonderful web pages. To see an example of an HTML document using Netscape, 
connect to your favorite site and choose the View menu followed by the Source menu item.



Choosing Site Categories for Imported Sites

Once the file to be imported has been read by Surfer Central, you will be presented with this dialog box:
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The listbox contains the sites that were read from the bookmark or hotlist file. To import a all or selected 
sites from this list:

· Select a site to be imported by clicking the primary mouse button on that site. To select a 
range of sites, click the primary button on the first site, hold down the shift key, and click the 
primary button on the last site in the range. To select multiple, non-contiguous (separate) 
sites, hold down the Ctrl key and select a group of sites by clicking on them with the primary 
mouse button.

· Once you have selected a set of sites to be imported, choose a category to which these sites 
should belong by clicking on the 'down arrow' of the combobox at the right side of the dialog 
box. Choose a category from the list that appears by clicking the primary mouse button on the 
desired category.

· Next, press the button labelled 'Import Selected Sites'. The sites that you have selected will 
disappear from the listbox and be moved to the Surfer Central database.

· When you are finished importing sites, press the button labelled 'Done' to complete the 
procedure.

Hint: If you would like to import all of the sites in the bookmark or hotlist file to the same category, press 
the button labelled 'Select All' to select all sites in the listbox with one mouse click. Alternatively, if you 
have several sites selected but would like to start over in your selection process, you may press the 
button labelled 'Select None' to deselect all sites.

Note: If the columns in the sites listbox appear distorted after importing a file, you may perform some 
minor changes to the sites to correct the look of the list. Please see Common Problems - Main Window 
for details.



Encrypting the Current Sites Database

If you have some addresses that you would rather keep secret you may choose to encrypt the database 
file to prevent prying eyes from sneaking a peek. Encryption makes the database file unreadable to a 
person who does not know the password that was originally used to scramble the file. Encrypting a 
database in Surfer Central is a fairly straightforward process:

· First, select the Password menu item from the File menu. This action brings up a dialog box 
containing two edit boxes. Type in your password into both boxes. The second edit box is 
simply used to verify the correct password.

· After entering the passwords, press the Ok button. If the passwords match the dialog box will 
close. Otherwise, enter the passwords again ensuring that the same password is present in 
both edit boxes.

· Now that the program knows the password you want to use, simply save the file using the 
usual procedure. The database will be automatically encrypted using your password.

· To retrieve your file later, simply open the database in the normal way and when prompted for 
a password, enter the password you used to originally save the database. If the correct 
password is entered, the database will appear and be ready for use.

WARNING: The encryption process used for Surf Central is fairly simplistic and can be cracked by 
any experienced and knowledgable hacker/cracker. If the data being stored in the database is 
extremely personal, please consider using another encryption scheme (such as DES or PGP) on 
top of the Surf Central method for added security.

This feature is only available in the registered version of Surfer Central.



Printing the Sites Database

Unfortunately, the printing feature is not available in version 1.1 (and earlier) of Surfer Central. There is, 
however, a convenient workaround for printing your database. When you are ready to print your 
addresses, select Generate Site List from the Tools menu. This has the effect of creating a text file 
containing all of your sites in an easily readable manner. After generating the list, simply print it using the 
DOS print command or through File Manager.

For further info, please see Generating a List of Sites.



Selecting a Site Type

Before entering or viewing a site in the database, you should first select the appropriate site type. 'Site 
Types' consist of WWW, E-Mail, FTP, FSP, Gopher, Archie and Telnet addresses. To select a site type, 
either:

(a) press the appropriate button on the The Sites Toolbar
 or select the site type from the Sites menu

Once a site type has been selected the Sites Listbox will be updated with the current sites for that site 
type and category and the Site Entry Area will reflect the information from the first address for that site 
type and category. To change to another site type and category simply repeat the procedure above.



User-Definable Site Types

Don't have any use for the FSP site type in your database? Change it to something else!!!

As of v1.20 of Surfer Central, you can define your own site types!

To change the name and graphic of a particular site type, either:

· select Change Site Type Names from the Options menu; or

· press the secondary mouse button (usually the right button) anywhere on the sites toolbar. 
Next, select Change Site Type Names from the pop-up menu that appears.

You will be presented with the following dialog box:
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First, select the type of site to be changed by clicking the primary mouse button on one of the tabs at the 
bottom of the dialog box.

To change the name of the site type, click the mouse (or tab into) the edit box adjacent to the 'Site Type 
Name' label. Type in a new name for the site type.

To change the graphic associated with the selected site type, type in the filename of the graphic or press 
the button labelled 'Browse' to graphically select the filename via a browse dialog box. 

Once you have chosen a name and graphic for the site type, the button at the top of the dialog box will 
reflect your changes. This button serves no purpose other than previewing the corresponding site type 
button. 

When you have completed editing the site type names and graphics, press the button labelled 'Ok' to exit 
the dialog box.

Note: The recommended size for the button graphic is 16 x 16. Choosing a graphics that is larger or 
smaller than this size will have unpredictable effects.



Entering a New Site

Before entering information for a new site, you should select a site type and a category. Now the 
information for the new site is ready to be entered into the database. Before the entire procedure is given, 
please be aware that the meanings of the site fields in the Site Entry Area vary according to the currently 
selected site type. All fields need not be used and for the most part, the meanings of these fields is 
determined by you, the user. Also, to change the focus from site field to site field, simply click the mouse 
within the desired edit box and begin typing.

The example of entering a new FTP site is provided below, but this procedure is fairly generic to the other 
site types.

To enter a new address into the database:

· Select a site type and category

· Press the Clear button if information exists in the edit boxes

· Click in the edit box corresponding to the site name and enter a descriptive name for the site 
(e.g. Windows Shareware Site)

· Enter the hostname or URL (e.g. ftp.cica.indiana.edu)

· Enter an IP address (e.g. 128.134.2.12)

· Enter a login name (e.g. anonymous)

· Enter a password (e.g. your e-mail address)

· Enter a description for this site (e.g. Good site for Windows programs)

· Choose a rating using the slider (e.g. scroll bar completely to the right indicates an excellent 
site)

· Choose a port number (e.g. 21 for FTP sites)

· Enter any information you like into the user fields

When information entry is complete, simply press the Insert button to enter the site into the database. 
Once the site has been entered in to the database, the site entry box will be cleared in preparation for 
your next site entry.

The same process applies to other site types

Note: For the WWW site type, there is an extra group of radio button in the site entry area. These radio 
buttons allow you to choose the URL prefix for the site (such as http://, ftp://, etc.). By selecting a 
particular prefix, the prefix displayed for the site in the URL edit box is updated.

Note: For the FTP site type, the Login and Password fields may be setup to contain a default value for 
new sites. For details, see Setting Default Field Strings

The evaluation version of Surfer Central only allows insertion of up to 50 sites in the database.



Updating an Existing Site

Updating a site in the database is a similar process to adding a new one - just change the desired site 
fields in the Site Entry Area and press the Update button. There is one important rule that must be 
followed, however, when updating a site:

--> You cannot update the the site name, host name, or IP address of a site. To change one of these 
fields you must delete the site and reenter it. All other fields are updatable.

Note: A site may only be updated when the Update button is enabled.

Note: If you have made changes to a site and attempt to change site types without updating (or inserting) 
the information to the database a warning dialog box will appear asking if you would like to discard the 
changes or not. Answer Yes to discard the changes and change the site type and No to return to where 
you left off.



Deleting a Site

To permanently delete a site(s) from the database, select the site(s) to be deleted in the sites listbox by 
clicking on it with the primary mouse button. To select multiple sites for deletion, hold down the control key 
and press the primary mouse button on additional sites.

Now, click the secondary mouse button on the site to bring up the sites pop-up menu.
Select Delete Site Object  from the pop-up menu.

Hint: A shortcut for deleting a site is to click the primary mouse button on the site(s) to be deleted and 
press the key marked 'Delete'.



Cutting and Pasting Sites

Cutting Sites:

To Cut a site object(s) from the database, select the site(s) to be cut in the sites listbox by clicking on it 
with the left mouse button. To select multiple sites for cutting, hold down the control key and press the left 
mouse button on additional sites.

Now, click the right mouse button on the site to bring up the sites pop-up menu.
Select Cut  from the pop-up menu.

Pasting Sites:

Change to the category in which you would like to paste the site(s).

Press the right mouse button anywhere in the sites listbox to bring up the sites pop-up menu.

Select Paste from the pop-up menu.

Notes:

· You can only paste once! You must perform another cut operation in order to paste 
again.

· Pasting of addresses between site types is not allowed.    Pasting between site 
categories is allowed.

Hint: The keyboard shortcuts for cutting and pasting sites correspond to the usual Windows shortcuts (i.e. 
Shift+Delete for cutting; Shift+Insert for pasting.

Hint: You can select multiple sites for cutting by holding down the Ctrl key and clicking the primary mouse 
button on each site to be cut. To select a range of sites, click on the first site in the range, hold down the 
shift key, and click on the last site in the range.



Cutting, Copying, and Pasting Text

The Cut, Copy, and Paste  commands in the Edit menu refer to operations that may be performed on 
text - not on the sites themselves. For information on cutting and pasting sites, please refer to Cutting and 
Pasting Sites.

To cut or copy text in an edit box, select the text with the left mouse button (pressing and hold down while 
you move the mouse over the text) and select Cut or Copy from the Edit menu (or select the Cut or Copy 
toolbar button).

To paste text into an edit box, select the edit box to which the text will be transferred (by left-clicking on it) 
and choose Paste from the Edit menu (or select the Paste toolbar button).



Copying and Pasting Addresses to Client Programs

Surfer Central contains a neat feature that allows you to easily copy and paste addresses between 
programs. The long way to perform a copy and paste between, say, your FTP client and Surfer Central 
would be to click on the desired site in the sites listbox, check to see what field is provided that site (IP 
address or hostname), select the text in the appropriate edit box, and select Copy from the Edit menu.

The quick way to do the same action is to click the secondary mouse button on the desired site and the 
sites listbox to bring up the sites listbox pop-up menu, and choose one of the following actions:

· Copy Site Address: this will copy the hostname of the site (if it exists in the database) or 
alternatively the IP address to the clipboard.

· Copy Site Address As URL: this will copy the hostname of the site (if it exists in the database) 
or alternatively the IP address to the clipboard in URL format. For example, if you click on the 
FTP site with hostname ftp.cica.indiana.edu, selecting this command will copy 
ftp://ftp.cica.indiana.edu to the clipboard

Once your address has been copied, simply activate the desired application and paste the address.



Dealing with Categories

Site Categories are used to store your sites in a more manageable fashion. You may create up to 16 
categories in which your addresses may be stored. For example, you may have a set of FTP and WWW 
addresses relating to computer games. Thus, you may want to name a category Games to store these 
sites. You may also want to make one for shareware, business, and whatever else you heart desires!!!

Changing Category Names

The default category names provided with Surfer Central are Group 1, Group 2, ..., Group 16. Clearly, 
these names are not very descriptive. You should probably start a new database by altering the names of 
these categories. First, change to the category you would like to change by clicking the primary mouse 
button on the tab corresponding to that category. For example, to change to Group 2 you would click on 
the Group 2 tab. Next, click on the secondary mouse button anywhere within the sites listbox. This action 
will bring up the sites listbox pop-up menu. From this menu, select Change Category Name. Type in the 
new category name and press Ok. Voila! You have changed the name of the category!!!

You may repeat this procedure for each category tab. Having meaningful categories will go a long way in 
organizing your mountain of Internet addresses.

Changing the Order of the Category Tabs

You may also want to have the most frequently used categories situated at the far left of the tabset. For 
details on this process, please see Changing the Order of Site Categories.

Moving Sites Between Categories

There are a couple different ways to move sites between categories. The simplest way is drag & drop!! 
Simply select the sites you would like to move to a different category using the primary mouse button in 
the sites listbox and drag them to the desired category tab. Once you are over the tab, drop them. The 
sites will disappear from the sites listbox and reappear when you change to the category that you 
dropped them on.

Alternatively, see Cutting and Pasting Sites to cut and paste sites between categories.

Hint: If one of your tabs is not visible on the screen, click on the one of the double-arrows to the right of 
the category tabset. This will effectively scroll the tabset such that hidden tabs are now visible.



Displaying a Summary of Categories

As of v1.20 of Surfer Cental you are now allowed to split your sites into 32 categories in addition to the 7 
sites types. The categories are represented by the tabs on the bottom of the sites listbox. Since 32 
categories is a fairly large number, it is now possible to display a summary of all the categories in a dialog 
box to make changing categories easier!!

To view the category summary dialog box, choose Category Summary from Sites menu. Alternatively, 
press the secondary mouse button on the sites listbox to bring up the The Sites Listbox Pop-Up Menu 
and choose Category Summary from that menu.

A dialog box will appear listing all of the categories in your current database. You may change categories 
simply by clicking the primary mouse button on a category in the list. The appropriate category tab under 
the sites listbox will then reflect the category change.

To close the category summary dialog box, click the secondary mouse button anywhere in the dialog to 
bring up the category summary pop-up menu. Next, click on the menu item labelled Close. Also, to have 
the category summary dialog box remain on top of all other windows, choose On Top from that menu.

As with all other destop windows in Surfer Central, the size and position of the category summary dialog 
box is saved when you exit the program. Next time you load Surfer Central, the dialog will appear in the 
exact same spot you left it!!



Searching for Text Strings

To search for a text string within the address database, select Find Site from the Edit menu. The 
following dialog box will appear:
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The steps required to search for a text string are as follows:

· Type a string in the Text to Find edit box

· Select the types of sites that should be searched. Selecting a particular site type has the 
effect of speeding up the search since only a specific part of the database is examined. If you 
are unsure as to what type of site the text string belongs, select All.

· Now choose the type of fields to be searched. Selecting Site Name and Address ONLY 
speeds up the search since only those two fields will be searched. If you want to search all 
fields select All Fields. Start the search by pressing the Find button.

If the text string is found within the database, the current site type of the database will be changed to 
match the found site and that site will be selected in the sites listbox. If the text is not found, a dialog box 
will appear telling you so.

Note: If you have previously performed a search and wish to search for the same text again, press the 
Find Next button

Hint: To quickly bring up the Find dialog box, press the F2 key.



Displaying a Summary of All Sites

It is often handy to see a summary of all the addresses in the database on one page. By doing so you can 
do a quick scan of all your addresses and possibly quickly skip between sites via this summary.

Surfer Central allows you to do just that. Selecting Site Summary from the Sites menu brings up a dialog 
box containing the names of all sites currently stored in the database. By clicking on any one particular 
site in this list, you can bring up the details of the site in the sites listboxx and site entry area. Here is a 
screenshot of the site summary dialog box containing some of my favorite sites:
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You may also view a site summary for a particular site type by selecting the appropriate tab below the 
listbox. Selecting the WWW tab will display only WWW site names, selecting FTP will display only FTP 
addresses, and so on. Select the 'All' tab to view a global list of your database.

Ordering the Sites

An excellent use of this summary list is to order your sites such that the most frequently accessed 
addresses appear at the top of the list. Thus, in a large database, you can simply open the site summary 
list and choose your favorite site from near the top of the list. This could save quite a few mouse clicks!!

When you open the site summary list for the first time in a database, the ordering of the addresses may 
not be to your liking. It is easy to change this by pressing and holding the primary mouse button on a 
particular site and dragging it to its new location. You may change the order of as many sites as you 
desire. When you save the database, Surfer Central also saves the global position of the sites in the site 
summary list so next time you load the database, the ordering of the addresses is preserved.

Sorting the Sites

To sort the site summary list , press the primary mouse button on the "Sort" checkbox. This action will 
have the effect of keeping the listbox contents sorted. Warning: the positions of the sites will be lost if you 
have previously ordered them.

Stay on Top

If you would like the site summary dialog box to remain on top of the Surfer Central main window, press 
the primary mouse button on the checkbox labelled "On Top".

Hint: If you are searching for a site but have no idea what text string to search for, bring up the site 
summary box. Simply scroll down the list of site names until you find the one you want. Clicking on the 
site in the site summary dialog box is the easiest method of both finding sites and selecting frequently 
used sites.



Changing Site Field Labels

The names of the site fields in the site entry area are fully customizable. Since each person has different 
tastes, Surfer Central allows you to change the name of the site fields as desired. For example, for the E-
Mail site type, instead of having a field named User Field #1, you may want to change this to Company 
Name. 

Each site type in the database can have its own site labels, but labels between site types are 
mutually exclusive. This implies that if you change the name of the User Field #1 field in the E-Mail site 
type, this field will be still be called User Field #1 when you change to the FTP site type. This allows for 
full customizability between site types!!!

To Change a Site Field Label:

· Click the secondary mouse button on the label to be changed. This will bring up the labels 
pop-up menu.

· Enter the new name for the label in the edit box. Note that site labels look a little nicer if you 
follow them with a colon ':'.

· Press Ok

Site field labels are specific to each database file. Thus, if you start a new database and wish to keep the 
same field names, you will have to reenter them (or load the old database and delete all of the sites from 
it).



Hiding and Displaying Fields

Surfer Central provides the capability for hiding and displaying the various fields for each site type. Since 
all fields may not be of use to any particular user, the unused fields may be hidden from view to produce a 
less cluttered representation of each site. For example, User Field #1 and User Field #2 may not be of 
use for an archie site. The text below illustrates how to hide and display fields in the site entry area.

Hiding Fields

Surfer Central is configured in such a way that all fields for a particular site type are displayed in the site 
entry area. However, all fields for any one site type may not be of use. To hide a field label and its 
corresponding edit box from view, select Hide Field from the labels pop-up menu. 

Displaying Fields

To redisplay a field that has been previously hidden from view for a particular site type, select Display 
Fields from the Options menu. This brings up the following dialog box:
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To indicate which fields are to be displayed and which fields are to be hidden select the desired site type 
from the tabs at the bottom of the listbox. The field names used for that site type will be shown as check 
boxes. A check box containing an 'x' indicates that that field is currently displayed in the site entry area, 
while the absence of an 'x' indicates that that field is hidden. You may alter the state of the field 
(hidden/displayed) by selecting the appropriate check box. Note that fields that do not apply to the 
selected site type have their check boxes disabled and cannot be changed. When complete, simply press 
Ok and the site entry area will reflect the changes.

Note:  The state of all site fields is saved each time you save your database file. Thus, if you chose to 
hide the description field for WWW sites, this field will remain hidden the next time the database is 
loaded.

Hint: When generating a site list, if there are certain fields that you would like to omit from the list, hide 
these fields before generation.



In the context of the site entry area, the word field refers to a site label and its corresponding edit box (i.e. 
the field name and field contents).



Generating a List of Sites

There may often be times when you would like to have a list of addresses by your side but Surfer Central 
is nowhere to be found (for example you are logged into your UNIX shell account which is incapable of 
running Surfer Central). Or, perhaps you would like to share your list of sites via e-mail with users who do 
not yet have a copy of Surfer Central (make sure you recommend it!!). Fortunately, you may generate an 
ASCII text file containing a list of your sites for everyone to read.

To generate a well formatted site list, choose Generate Site List from the Tools menu. The following 
dialog box will appear:
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First, choose the site types you wish to include in the list to be generated. Any site types that are checked 
(with an 'x') in the leftmost group of check boxes will be included in the final list. If you only want to create 
a list of e-mail addresses, for example, make sure only the E-Mail site type has a check beside it. To 
enable/disable checks, click the primary mouse button the check box.

There are several options available for site list generation:

· Use address ONLY: check this option if you would like to generate a list containing only 
addresses. This option is useful if you would like to generate a very simple mailing list 
(especially for e-mail addresses) to import into another program

· Use defined headers: If you would like to have user defined headers included in the 
generated list, choose this option. If you select this option the site headers currently 
appearing in the site header dialog box will appear on the final generated list.

· Include addresses containing keyword: This option is very handy if you would like to 
generate a list relating to a specific topic. For example, if you have FTP, E-Mail, and WWW 
sites in your database relating to games, choose this option with a keyword of 'games' for list 
generation. Only those addresses containing the word 'games' in any field will be included in 
the list.

Now select a filename for your generated list. Any standard DOS compatible filename will do. If you would 
like to find a particular directory on your disk, click the Browse button to graphically navigate the drive.

Finally, press the Generate button to generate the site list. You may now pass this list on to your friends or 
print it out via the standard DOS print command.

Hint: When generating a site list, if there are certain fields that you would like to omit from the list, hide 
these fields before generation. See Hiding and Displaying Fields for more information.

Note: The 'override inclusion fields' checkbox in the above dialog is reserved for future versions of Surfer 
Central. It serves no purpose in this version.



A Site Header is a series of lines of text that appear before a list of sites for a particular site type. Instead 
of having a boring "WWW" appear prior to the actual site addresses themselves in the generated list, you 
may want to create an ASCII representation of WWW in 3-D, perhaps surrounded by some sort of box. 
Site headers have the sole purpose of making your generated site lists a little prettier.



Using the Winsock Tools
See also

In addition to managing and organizing your Internet addresses, Surfer Central is also a capable 
command shell for all of your Winsock-related applications. A handy toolbar is visible on the left side of 
the screen which allows you to launch any client program that you have previously configured.

Configuring the Winsock Toolbar

The first time you invoke Surfer Central you will need to configure the Winsock toolbar such that the icons 
for your client programs are visible as toolbar buttons. The configuration process is completed by 
selecting Configure Winsock Tools from the Tools menu. This action brings up the following dialog box:

To get information on the Preferences tab and the Modem tab, click the appropriate tab on the screenshot 
given below.

There is a tab at the bottom of the dialog box for each site type as well as a TCP/IP Manager tab. You 
should configure all tools that you use on a regular basis.

The meanings of the dialog box fields are as follows:

· Filename: is the filename of the Winsock tool corresponding to the currently selected tab. 
This is the file that will be launched when you press the appropriate toolbar button. In the 
example above, the program WS_FTP32 will be launched when the FTP button is depressed. 
To graphically browse the directory structure and select a file click the Browse button

· Description: You may place any text here that you wish. If you do not use an FTP client and 
want to use the FTP button, for example, to launch another program, you may change the 
description to match the program to be launched

· Launch TCP/IP Manager prior to program load: When this box is checked, pressing any 
toolbar button (except the TCP/IP Manager button) will first load the TCP/IP Manager followed 
by the requested program. For a program that does not require the TCP/IP Manager to be 
loaded, make sure that this box is unchecked



Launching the Winsock Tools

To launch (load) a program that you have configured to occupy the Winsock toolbar, simply press the 
appropriate button on the toolbar with the primary mouse button. If the Load TCP/IP Manager prior to 
program load box is checked, the TCP/IP Manager will load followed by the program you selected.

If you attempt to load a Winsock tool and receive an error such as Error Code: 2, check here for a list of 
codes if it is not immediately obvious what the error is.

List of Error Codes

Hint: if one of your Winsock client programs supports command-line arguments (Netscape does), then 
you may want to load the client and have it automatically open a particular site. To do this, select the site 
in the sites listbox and drag it over to the appropriate Winsock button. This one mouse action will load the 
TCP/IP Manager (if required), load the Winsock program, and open the site.



Automatically Loading URLs into Netscape



Here are the various error codes (straight from the Windows SDK help):

Value Meaning

0 System was out of memory, executable file was corrupt
2 File was not found. 
3 Path was not found. 
5 Attempt was made to dynamically link to a task
6 Library required separate data segments for each task. 
8 There was insufficient memory to start the application. 
10 Windows version was incorrect. 
11 Executable file was invalid. Nt a Windows application or error in the .EXE
12 Application was designed for a different operating system.
13 Application was designed for MS-DOS 4.0. 
14 Type of executable file was unknown. 
15 Attempt was developed for an earlier version of Windows.
16 Attempt was made to load a second instance of an executable file
19 Attempt was made to load a compressed executable file
20 Dynamic-link library (DLL) file was invalid (corrupt)
21 Application requires 32-bit extensions. 



Winsock Tool Preferences
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There are several available options for the determining the behaviour of the Winsock tools:

· Minimize Surfer Central when Winsock tool loaded: Check this option if you want Surfer 
Central to be iconified whenever a Winsock tool is loaded.

· Minimize TCP/IP Manager when loaded: Enable this option if you would like TCP/IP 
Manager iconified when it is loaded. It is generally a good idea to have this box checked if 
you have Trumpet Winsock set up to auto login. For this to occur properly, you must have the 
description field of the TCP/IP Manager set exactly to the name of the TCP/IP Manager 
window. For example, with Trumpet Winsock, the description field must be 'Trumpet Winsock' 
(without the quotes).

· Unload TCP/IP Manager on Surfer Central exit: Check this box to unload (close) TCP/IP 
Manager when you close Surfer Central. For this to occur properly, you must have the 
description field of the TCP/IP Manager set exactly to the name of the TCP/IP Manager 
window. For example, with Trumpet Winsock, the description field must be 'Trumpet Winsock' 
(without the quotes).



The Modem Status Window
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The modem status window displays the various LEDs present on most external modems. These LEDs 
are often handy in determining what is happening during a connection. However, there are many users 
with internal modems that do not have access to a tool that indicates connection state. The modem status 
window now gives you all the benefits that the external modem users have!!!

There are several available options associated with the modem status indicator:

· Show modem status window: Check this box to display the modem status indicator 
window. To close the status window, either (a) click the secondary mouse button on the 
modem status window and select 'Close' from the pop-up menu; (b) double-click the primary 
mouse button in the upper left corner of the window; or (c) uncheck the checkbox in the 
configure winsock tools dialog box as shown above.

· Modem status window always on top: To keep the modem status window permanently on 
top of the Surfer Central window, check the corresponding box as shown in the screenshot 
above.

· COM Port: Select the COM port that your modem is connected to so that the modem status 
window knows which port to monitor for changes.

The modem status window is displayed below:
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The LEDs are represented as rectangles in the above screenshot. For a detailed description of each of 
the LEDs, please see your modem manual. On a high level, the LEDs are:

· RING: turned on (or flashes) when someone is ringing your line.

· CTS: the modem is initialized and in a state where it ready to receive data (Clear to Send)

· DSR: the modem is in a state where it is ready to connect

· DCD: when the modem is connected to another modem, this light will be on (Data Carrier 
Detect)

· RTS: the modem is ready to send data to the remote end. This line is a request to send that 
data.

· DTR: data terminal ready indicator

· RxD: when this LED is on, the modem is receiving data from the remote end.

· TxD: when this LED is on, the modem is transmitting data to the remote end.



Automatically Loading URLs into Netscape

Note: The following discussion assumes that you are using Netscape Navigator as your WWW browser. If 
you do not have Netscape configured, you cannot automatically load a URL into your browser.

One of the great features of Surfer Central is that it can transparently communicate with Netscape 
Navigator and have it automatically load a URL from within Surfer Central!!!

The first time you double-click the primary mouse button in the sites listbox or drag and drop a site to the 
Netscape Winsock toolbar button (and Netscape is not running), Surfer Central will launch Netscape and 
connect you to the URL. The next time you double-click or drag and drop, obviously Netscape need not 
be loaded since it's already running. Surfer Central can figure this out on its own and simply tell Netscape 
to load the site!!! Easy!

So, to summarize how you can get Surfer Central to tell Netscape that a URL should be loaded:

· double-click the site you wish to have Netscape load

· click on the desired site in the sites listbox and drag it to the Netscape Winsock toolbar button

· click on the desired site in the sites listbox to select it. Now click the secondary mouse button 
to open the sites listbox pop-up menu. Select Open URL from the menu



Grabbing URLs from Netscape

Note: The following discussion assumes that you are using Netscape Navigator as your WWW browser. If 
you do not have Netscape configured, you cannot grab a URL from your browser.

Surfer Central contains a great time saver for entering new sites into the database when you are surfing 
the net using Netscape Naviagator.

Suppose you are surfing along and come across a site that you would like to add to your Surfer Central 
address database (assuming Surfer Central is already running and the URL you wish to add is loaded in 
Netscape). Just flip back to Surfer Central, press the secondary mouse button on the sites listbox to bring 
up the sites listbox pop-up menu. Now select Grab URL from the menu.

What just happened? Well, Surfer Central asked Netscape what site it was currently connected to and 
waited for the response. Once Netscape told Surfer Central what the URL to that site was, Surfer Central 
then placed that information in the site name and URL edit boxes. Cool! Now all you have to do is add 
any other information that you desire and press the Insert button.!!

Note: You must have Netscape running and a valid URL loaded for this feature to work correctly.



Configuring the Program

There are several options available in terms of configuring Surfer Central to meet your needs. For details 
on these options, please select one of the following links:

Sizing the Main Window

Setting Site Headers

Site Fields

Changing Fonts and Colors



Sizing the Main Window

Since Surfer Central appears differently in various video modes that Windows accommodates it would be 
useful to have the capability of saving the position of the main window such that upon every invocation of 
the program, the window is the same size. Surfer Central gives you this capability by automatically saving 
the size and position of the main window every time you exit the program. These values are saved to the 
file SURFRCEN.INI. Therefore, the next time you run the program, the main window will appear in the 
exact place that you left it. Handy!!



Setting Site Headers

Site headers are used by the site list generation routines to customize the site lists and ease the 
distinction between various site types in a large list. These headers are simply lines of ASCII text that are 
used to separate the various sections of a generated site list.

To customize the various headers for the list (if you choose to use site headers during site list generation), 
select Site Headers from the Options menu. This selection brings up the following dialog box:
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You may customize the headers for all site types plus add a title header which will be placed at the top of 
the site list. Use your imagination! Be creative! You can make some interesting looking lists. Click here to 
see an example of a site header used for FTP sites.

When you are done entering site headers, press the Ok button.

Note:  Site headers are saved to the SURFRCEN.INI file and are, thus, common to all databases. 
Therefore, if you change the site header while editing a particular database the same change will appear 
in all site lists generated - even from different database files.

For more information on site list generation, see the Generating a List of Sites help topic.



    _________________
   / ____/_  __/ __  /
  / __/   / / / ____/
 /_/     /_/ /_/
 ------------------



Site Fields

For information on configuring the site fields (changing the name of a field and hiding and displaying 
fields), please see the appropriate help topic by choosing one of the above links.



Changing Fonts and Colors

Many of the fonts and colors within the program are customizable to suit each individual user's tastes.

The dialog boxes used to change fonts and colors are common to most Windows applications. Therefore, 
a detailed description on their use will not be provided here. Given below is a brief summary of how to go 
about changing fonts and colors for various parts of the main window.

Changing the listbox fonts and colors:

To change either the font or color of the sites listbox click the secondary mouse button on the listbox. This 
action will bring up the sites listbox pop-up menu. Next, choose either the Listbox Color menu option or 
the Listbox Font menu option. Make your changes and then save the database.

Changing the site entry area fonts and colors:

To change the colors and fonts of the site field labels move the mouse over the desired field and press 
the secondary mouse button to bring up the labels pop-up menu. Select Change Font or Change Color 
to change just that label, or Change Font (ALL) or Change Color (ALL) to change the font or color for all 
site field labels.

Note: The fonts and colors currently on the screen are unique to each database. When you make a 
change to a font or color you must save the current database for the changes to be in effect next time you 
edit the database.

Hint: You could have a different listbox color for each address database in your collection. For example, 
you may want to have a database for the office colored purple and a database for home colored cyan.



Getting Help

Well, you are currently reading this help file so you must have some idea as to how to get help, right???

Tool Tips: You can determine the function of particular button or other control by moving the mouse over 
it and waiting a couple seconds. A small box with a description of the control will appear. These tips are 
commonly called balloon help.

Command Description Label: In addition to the tool tips, a more comprehensive description of a control 
appear in the toolbar panel on the right side of the window when you move the mouse over a control

This Help File: provides the most comprehensive help on any part of the program

For more details on the Surfer Central help facility, please see The Help Menu.

Hint: Help in Surfer Central is generally context sensitive. Selecting an item on the screen about which 
help is desired and pressing the F1 key invokes this help file with the current topic corresponding to the 
item on the screen that was selected. Help is also always available by pressing the Help button when it is 
visible (e.g. in the Register dialog box).



Quitting the Program

To exit Surfer Central, simply click on the File menu and choose Exit. If the database has been modified 
since the last save you will be prompted to save it. Also, the current state of Surfer Central is saved 
including the size and location of the main window. Thus, the next time the program is invoked, the main 
window will appear in the same position and with the same size.

For further information on saving the database, please see Saving the Current Sites Database.



Tips and Shortcuts
Here are some various tips and shortcuts to make your life with Surfer Central just a little bit easier. For 
details, please select one of the following links:

Saving the State of the Desktop

Changing the Order of Site Categories

Moving Sites Between Categories <new!>

Quickly Connecting to Sites

Drag and Drop from the Sites Listbox

Tailoring the site fields

Setting Default Field Strings

Automatically Loading a Database

Keyboard Shortcuts

Saving Disk Space



Saving the State of the Desktop
The state of the desktop is saved whenever you exit Surfer Central. By state of the desktop, it is implied 
that the sizes and positions of all windows and dialog boxes related to Surfer Central are saved. 
Therefore, if you place all the windows (e.g. Category summary dialog, modem status window, site 
summary window, main window) where you want them, the size and position will be restored the next time 
you load Surfer Central!!! 



Changing the Order of Site Categories
As an everyday user of Surfer Central, you will probably want to have the tabs representing the 
categories that are most frequently used at the beginning of the category tabset. To change the order of 
the tabs, simply left-click on the tab that you would like to move and drag it to its new position. The 
dragged tab will be inserted before the tab onto which you dropped it.



Moving Sites Between Categories
To quickly move a site or group of sites between categories, first select the desired sites in the sites 
listbox using the primary mouse button. Now click and hold down the primary mouse button on one of the 
selected sites. Drag the sites to the desired category tab and drop them by releasing the mouse button. 
The sites will disappear from the sites listbox and reappear when you change to the category onto which 
you just dropped the sites.

Hint: You can select multiple sites in the sites listbox by holding down either the Shift key or the Ctrl key 
while clicking on sites using the primary mouse button. Holding down Shift will select a range of sites, and 
holding down Ctrl will select individual, non-contiguous sites. Try it!



Quickly Connecting to Sites
The absolute quickest and easiest way to connect to a site of interest is to double-click (primary mouse 
button) the appropriate site in the sites listbox. This action has the effect of checking to see if the TCP/IP 
Manager has been (or should be) loaded, loading it if necessary, opening the client application 
corresponding to the site type of the site you double-clicked, and passing the address of that site as a 
command-line parameter to the client application.

Note: If your client application does not support command-line parameters (i.e. when the application is 
launched you can specify the site to directly connect to directly on the command-line) then you will not be 
directly connected to the requested site.

Hint: Even if you are not directly connected once the client application is launched, there is still a quick 
method of connecting. Whenever you double-click on a site the address of that site is copied to the 
clipboard as well. Simply open the dialog in your client that allows you to connect to a site and paste the 
address into the application (usually using Shift+Insert).



Drag and Drop from the Sites Listbox
To quickly launch a Winsock client program and have it automatically open a site which exists in the 
database (provided the client supports command-line arguments), click on the desired site in The Sites 
Listbox and drag it to the appropriate winsock toolbar button. This process will automatically launch the 
requested Winsock tool and open the site.

Note: If your client application does not support command-line parameters (i.e. when the application is 
launched you can specify the site to directly connect to directly on the command-line) then you will not be 
directly connected to the requested site (unless you are using Netscape Navigator - please see 
Automatically Loading URLs into Netscape).



Tailoring the site fields
Not everyone will like the names of the default site fields that I have provided with Surfer Central. For 
example, for an e-mail address, you may want to use one of the User fields to represent the job title of the 
person you are dealing with. Obviously, a field name of User Field #1 isn't very meaningful!!!

To change the name of a site field, click (and hold) the secondary mouse button (right mouse button in 
most cases) on the site field label you wish to change. This brings up the The Labels Pop-Up Menu. Now 
select Change Label once again using the secondary mouse button. A dialog box as shown below will be 
displayed.
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Now, enter the new name of the label and press the Ok button.

Note:  Site field labels are saved with the current database. If you wish to use the same field label on 
another database, you will have to load the second database and make the same change.



Setting Default Field Strings
If you enter a lot of sites into Surfer Central that have some fields that are entered but rarely change, it's 
nice to have these fields automatically filled in for you. The best example is with FTP sites - most of your 
sites will probably be anonymous which implies that the Login field will frequently contain 'anonymous' 
and the Password field will contain your e-mail address.

To save you some typing you can set the default value for the Login field and the Password field for the 
FTP site type. Unfortunately as of version 1.0 of Surfer Central there is no way to change these defaults 
via the user interface of the program. This will be improved in a later version.

To change these defaults, follow these steps:

· Execute (Run) your favorite Windows editor (e.g. NotePad)

· Open the file in the Surfer Central directory called SURFRCEN.INI

· Find the section of the file containing the text '[Default Fields]'

· Locate the text 'FTPLogin=Anonymous'. To change the default text that appears in the Login 
field for the FTP site type simply change the 'Anonymous' to whatever text you like (ignoring 
the quotes (') of course)

· Locate the text 'FTPPassword=<e-mail>' and change the '<e-mail>' to whatever text you like. 
For example, in my case that line would become 'FTPPassword=waletz@ee.umanitoba.ca' 
(minus the quotes)

· Save the file and run Surfer Central. Change to the FTP site type and if no sites exist in the 
sites listbox you will immediately notice the change.



Automatically Loading a Database

If you exclusively use the same database file and would like to have that file loaded automatically every 
time you load Surfer Central, then follow these steps:

· locate the icon for Surfer Central in the Windows Program Manager

· Hold down the Alt key and double click the primary mouse button on the Surfer Central icon 
(alternative, click the primary mouse button on the icon to select it, and select Properties from the 
File menu in Program Manager)

· Add the filename of the database you would like to load to the string (edit box) that is adjacent to 
the 'Comand Line' label. For example, if the command line is currently 'C:
\SURFRCEN\SURFRCEN.EXE' and we would like to load WORLD.SDB automatically, the new 
string should read 'C:\SURFRCEN\SURFRCEN.EXE WORLD.SDB'.

· Press Ok to save the changes. The next time you load Surfer Central, the specified file will be 
loaded automatically.



Keyboard Shortcuts

There are various keyboard shortcuts throughout the program which may be used in place of menu 
commands. All of those shortcuts will not be listed here, however. To find a shortcut for a particular 
command, examine the menu item corresponding to that command. You will notice that to the right of 
most menu items is a key combination that performs the identical task as the menu command.

For example, if you look at the Find Site command on the Sites menu, it's keyboard shortcut is Ctrl+F. 
This implies that you hold down the control key and press the letter F.



Saving Disk Space

If you are a Surfer Central expert and feel confident that you don't need to use the help, why not get rid of 
it? You'll save yourself almost 1 Meg of disk space!!! I am fairly proud of this help file (it's my first one!) but 
if you need to save space you can get rid of it :^(. 

Simply delete the following files from the Surfer Central directory:

· SURFRCEN.HLP

· HWACT.*

· OSHTOOLS.DLL

If you ever need to reference the help again, simply re-install it. To save time, the installation program 
allows you to install only the help if desired.

Also, feel free to nuke the sample database file and any files with a TXT extension if desired. But 
don't touch any of the other program files -- if you do, Surfer Central may not run and will need 
to be re-installed.



Reference

The reference section briefly describes all menu commands in Surf Central. Each menu item is given a 
one sentence description of its function, as well as a list of hypertext links to find further information.

The File Menu

The Edit Menu

The Sites Menu

The Tools Menu

The Options Menu

The Help Menu

The Sites Listbox Pop-Up Menu

The Labels Pop-Up Menu

The Winsock Tools Pop-Up Menu



The File Menu
The File menu contains commands used for manipulating site database files. Examples include saving 
your work to a file and setting a password for encrypting your file.

To obtain a description of each command, click on one of the pop-up links below:

New

Open

Save

Save As

Import

Password

Print

Print Setup

Exit



Function: To start a new sites database
Reference: Starting a New Sites Database

Shortcut: 



Function: To load an existing sites database from disk
Reference: Loading an Existing Sites Database

Shortcut: 



Function: To save the current database to the previously selected file
Reference: Saving the Current Sites Database

Shortcut: 



Function: To select a filename for the current database and save it to that file
Reference: Saving the Current Sites Database



Function: To import a browser bookmark list into Surfer Central
Reference: Importing Files



Function: To select a password for the current database
Reference: Encrypting the Current Sites Database



Function: To print the current sites database
Reference: Printing the Sites Database



Function: To setup the printer in preparation for printing the database
Reference: Printing the Sites Database



Function: To quit Surfer Central
Reference: Quitting the Program



The Edit Menu
The Edit Menu contains commands for manipulating text within the program. Examples include cutting a 
selected text item and finding text within the database.

To obtain a description of each command, click on one of the pop-up links below:

Cut

Copy

Paste

Find Site



Function: To cut the currently selected text to the clipboard
Reference: Cutting, Copying, and Pasting Text

Shortcut: 



Function: To copy the currently selected text to the clipboard
Reference: Cutting, Copying, and Pasting Text

Shortcut: 



Function: To paste the text sitting on the clipboard
Reference: Cutting, Copying, and Pasting Text

Shortcut: 



Function: To search the site database for a text string
Reference: Searching for Text Strings

ShortCut: F2 Key



The Sites Menu
The Sites menu contains commands for manipulating the sites within the database. Examples include 
changing the currently viewed site type and viewing a summary of all addresses within the database.

To obtain a description of each command, click on one of the pop-up links below:

WWW

E-Mail

FTP

FSP

Gopher

Archie

Telnet

Site Summary

Category Summary



Function: To view and edit the World Wide Web sites in the database
Reference: Selecting a Site Type

Shortcut: 



Function: To view and edit the E-Mail addresses in the database
Reference: Selecting a Site Type

Shortcut: 



Function: To view and edit the FTP sites in the database
Reference: Selecting a Site Type

Shortcut: 



Function: To view and edit the FSP sites in the database
Reference: Selecting a Site Type

Shortcut: 



Function: To view and edit the Gopher sites in the database
Reference: Selecting a Site Type

Shortcut: 



Function: To view and edit the Archie sites in the database
Reference: Selecting a Site Type

Shortcut: 



Function: To view and edit the Telnet sites in the database
Reference: Selecting a Site Type

Shortcut: 



Function: To display a dialog box containing a summary of all sites in the database
Reference: Displaying a Summary of All Sites

Shortcut: 



Function: To display a dialog box containing a summary of all categories in the database
Reference: Displaying a Summary of Categories

Shortcut: Ctrl+C



The Tools Menu
The Tools menu contains commands for configuring and using the included tools in the program. 
Examples include launching a Winsock client program and generating a site list for mailing.

To obtain a description of each command, click on one of the pop-up links below:

Launch Winsock Tool

Configure Winsock Tools

Generate Site List



Function: To run one of the programs available in the submenu to this item
Reference: Using the Winsock Tools



Function: To setup the client programs to be run by Surfer Central
Reference: Using the Winsock Tools

Shortcut: 



Function: To generate a text file containing all selected sites (suitable for mailing)
Reference: Generating a List of Sites

Shortcut: 



The Options Menu
The Options menu contains commands for setting the various program options. Examples include setting 
which fields are displayed for each site type and entering site headers for use by the site generation tool.

To obtain a description of each command, click on one of the pop-up links below:

Change Site Type Names

Fields Displayed

Site Headers



Function: To change the name and/or graphic associated with each site type.
Reference: User-Definable Site Types

Shortcut: None



Function: To select the fields to be displayed and hidden for each site type
Reference: Hiding and Displaying Fields

Shortcut: 



Function: To configure the headers for each site type to be used during site list generation
Reference: Generating a List of Sites

Shortcut: 



The Help Menu
The Help menu contains commands for getting help on various features of the program.

To obtain a description of each command, click on one of the pop-up links below:

Contents

Using Help

View Lock Number

Register

About



Function: To invoke the contents page of this help file
Reference: Getting Help



Function: To invoke the help tutorial (common to all Windows programs)
Reference: Getting Help



Function: To view the lock string that is required for registering Surfer Central
Reference: Registration Procedure



Function: To complete the registration process by entering your registration key
Reference: Registration Procedure



Function: To view a message about the version of the program and the author
Reference: Getting Help



The Sites Listbox Pop-Up Menu
The Sites Listbox Pop-up Menu contains commands for manipulating sites that are selected in the sites 
listbox 

Note 1: The Sites Listbox Pop-up Menu is invoked by pressing the right mouse button on the sites listbox.

Note 2: In the menu item descriptions below, the term site object  refers to a site and all of its associated 
information, such as name, address, descriptions, and all other fields.

To obtain a description of each command, click on one of the pop-up links below:

Open URL <new!>

Grab URL <new!>

Delete Site Object

Cut Site Object

Paste Site Object

Copy Site Address

Copy Site Address As URL

Listbox Color

Listbox Font

Change Category Name

Category Summary Popup



Function: To have your WWW ser automatically load a URL
Reference: Automatically Loading URLs into Netscape



Function: Grab the site name and URL from your WWW browser and place in Surfer Central
Reference: Grabbing URLs from Netscape



Function: To permanently delete a site from the database
Reference: Deleting a Site

WARNING: There is no 'undo' feature in Surfer Central v1.0.



Function: To cut an entire site object to the Surfer Central clipboard
Reference: Cutting and Pasting Sites



Function: To paste an entire site object from the Surfer Central clipboard
Reference: Cutting and Pasting Sites



Function: To copy the address of the site to the Windows clipboard for pasting into another 
application
Reference: Copying and Pasting Addresses to Client Programs



Function: To copy the address of the site as a URL to the Windows clipboard for pasting into 
another application
Reference: Copying and Pasting Addresses to Client Programs



Function: To change the background color of the sites listbox
Reference: Configuring the Program



Function: To change the font of the sites listbox
Reference: Configuring the Program



Function: To change the name of the currently selected category
Reference: Dealing with Categories



Function: To display a dialog box containing a summary of all categories in the database
Reference: Displaying a Summary of Categories

Shortcut: Ctrl+C



The Labels Pop-Up Menu
The Labels Pop-up Menu contains commands for manipulating the site record labels in the site entry 
group box. Examples include changing fonts and colors of labels.

Note: The labels pop-up menu is invoked by pressing the right mouse button on a site label

To obtain a description of each command, click on one of the pop-up links below:

Change Label

Change Font

Change Color

Change Font (ALL)

Change Color (ALL)

Hide Field



Function: To change the name of the selected site field
Reference: Changing Site Field Labels



Function: To change the font of the currently selected site field
Reference: Configuring the Program



Function: To change the background color of the currently selected site field
Reference: Configuring the Program



Function: To change the font of all  site fields
Reference: Configuring the Program



Function: To change the background color of all  site fields
Reference: Configuring the Program



Function: To hide the selected site field from view
Reference: Hiding and Displaying Fields



The Winsock Tools Pop-Up Menu
The Winsock Tools Pop-up Menu contains commands for configuring the external client programs used 
by Surf Central.

Note: The winsock tools pop-up menu is invoked by pressing the right mouse button on any of the 
Winsock toolbar buttons.

To obtain a description of each command, click on one of the pop-up links below:

Configure Winsock Tools



Function: To setup the client programs to be run by Surfer Central
Reference: Using the Winsock Tools



Glossary of Terms
Various definitions of terms used within this help file and the program itself are given below. To view the 
definitions, simply click on the desired definition. These terms are the author's own definition and have 
been tailored to suit the purposes of the Surfer Central program.

Site

Site Field

Site Field Label

Site Header

Site Object

Site Record

Winsock

Pop-Up Menu



A site in Surfer Central is an address or location on the Internet that one may access through some 
means. For the purposes of this program, the term site refers to an e-mail address, WWW URL, FTP 
address, FSP address, Gopher address, Archie location or Telnet location. The term site is, in most 
cases, synonymous with the word address.



A site field is one of the elements of information that makes up a site record field is the IP address - this is 
one piece of information that contributes to the definition of a particular site.



A site field label is a text string that describes a particular site field 



A site record is made up of a series of site fields and is the highest level at which to refer to a site. When 
a phrase refers to a site, really it is referring to a site record.



Synonymous with site record.



[portions of this definition taken from the help for Procomm Plus for Windows v2.11]

Winsock, short for Windows Sockets, implements the Transmission Control Protocol/Internet Protocol 
(TCP/IP). TCP/IP is a protocol which allows computers to communicate with each other and is 
implemented as a stack; TCP and IP are two separate components which work together to communicate 
information across network lines. Many Local Area Networks (LANs) use TCP/IP and the worlds largest 
network, the Internet, also uses this protocol. In all cases, you must install a TCP/IP stack to 
communicate across a network using TCP/IP.    For example, Novell offers a stack to communicate over a 
Novell network using TCP/IP. 

Windows users must also install Winsock compliant software, called client programs. This software is an 
additional    component which communicates to both Winsock applications such for Windows and the 
TCP/IP stack. In all cases, Winsock compliant software will install a dynamically linked library called 
WINSOCK.DLL on your system, and Winsock applications interact with this library to send and receive 
information.

Winsock applications offer graphical user interfaces which provide TCP/IP functionality for users. These 
applications interact with the underlying Winsock compliant software which handles all TCP/IP 
communication.



A pop-up menu is an invisible menu which only becomes visible when the secondary mouse button 
(usually the right button ) is pressed. Once the menu is visible, the user may interact with it just like any 
other menu.



Registration Information
This section of the file contains all the information you will need to register Surfer Central and enjoy the 
full capabilities of the program. Please see the following sections for detailed information:

Copying and License Information

Disclaimer of Warranty

Definition of Shareware

Benefits of Registration

Registration Procedure

Registering by Credit Card <new!>

Registration Form (Canada)

Registration Form (International - all except Canada)

About the author

Revision History

Future Features



Copying and License Information
Surfer Central is protected by copyright law and international treaty. This license agreement describes 
your rights and responsibilities as a user of this software.

The evaluation of Surfer Central supports all features contained in the full version, except that a reminder 
message is displayed upon invocation of the program and a maximum of 50 addresses are allowed within 
the database.

The evaluation version of Surfer Central is provided to the user for evaluation for 30 days without a 
license fee. At the end of the evaluation period, the user must either register the program or stop using it. 
The evaluation version may be copied freely and distributed to other users provided that no fee is 
charged. Anyone distributing Surfer Central for any kind of remuneration must have express written 
consent from James Waletzky.

Upon paying the registration fee, one copy of Surfer Central (full version) is licensed to the purchaser for 
use on one computer at any one time. You must treat the software just like a book. This software may be 
used by any number of people and may be freely moved from one computer location to another, so long 
as there is no possibility of it being used at one location while it's being used at another.

See Registration Procedure for details on registering.

NOTE: If you would like to include Surfer Central on a CD-ROM that you are developing containing 
various Internet-related or other shareware programs, please contact me at the address specified 
in Contacting the Author.



Disclaimer of Warranty
Users of Surfer Central must accept this disclaimer of warranty: 

SURFER CENTRAL IS SUPPLIED AS IS.    THE AUTHOR DISCLAIMS ALL WARRANTIES, 
EXPRESSED OR IMPLIED, INCLUDING, WITHOUT LIMITATION, THE WARRANTIES OF 
MERCHANTABILITY AND OF FITNESS FOR ANY PURPOSE. THE AUTHOR ASSUMES NO 
LIABILITY FOR DAMAGES, DIRECT OR CONSEQUENTIAL, WHICH MAY RESULT FROM 
THE USE OF SURFER CENTRAL.



Definition of Shareware
[Definition excerpts from Topdraw v2.0. Get it - it's a great little drawing program]

Shareware is actually not a type of software but a marketing method. Shareware is distributed via bulletin 
boards, the Internet and a host of other sources. Shareware gives you the opportunity to try software 
before you buy it - something all software should allow for. Prices are very low due to low marketing 
expenses. Obviously, I do not have the overhead of a large company.

Continuing to use a shareware program after the trial period has expired requires that you register the 
software. With most shareware, registering the program allows you to continue using, and possibly gain 
some incentives (such as allowing more than 50 records in a database). You may continue to distribute 
the shareware version of the program, but the license agreement for the registered version usually 
restricts copying and distribution. Also, note that the registration fee is a direct payment to the author and 
does not include phone bills, online connection fees and other tangibles.

"Shareware has the ultimate money-back guarantee - if you don't use the product, you don't pay 
for it."

Another big advantage of shareware is the personal technical support that you receive. In most cases 
communication takes place directly with the author of the program. This also ensures that requests for 
new features will not be ignored.

In conclusion, shareware is an excellent method of purchasing software - you can try before you buy and 
shareware authors frequently charge very little for their work.



Benefits of Registration
There are several benefits to registering Surfer Central:

· the program will allow more than 50 addresses in the database

· you will be able to password protect your database files

· it's the right thing to do

· to bypass the introductory message without having to press a key

· registration will remove all of the reminder screens

· technical support is provided for registered users

· you will be notified of program updates and bug fixes as they become available

· you will receive notice of future products (should I decide to design any!! If you have some 
ideas please, by all means, let me know)

· you will receive a special upgrade price when the Windows 95 version becomes available. 
Scratch that!!! All upgrades are FREE to registered users!!!

· make me happy!!!

Please register. I have kept the price extremely low and reasonable because I believe that software 
should be useful as well as cheap. Your registration will encourage me to improve Surfer Central and 
develop new ideas. Thanx.



Registration Procedure
Registering Surfer Central is a fairly straightforward process. Once you have decided to purchase the 
software you should take the following steps:

· Load Surfer Central and select View Lock Number from the Help menu. Make note of the 
lock string that appears.

· Fill out the registration form. For Canadian users, fill out the Canadian Registration Form. For 
American or other International users, fill out the International Registration Form. Make sure 
you include the lock number on the registration form or you cannot be registered.

· Once you have filled out the appropriate form send it, along with your payment, to the snail 
mail address listed on the form

· Once your form and payment have been processed you will receive a registration key (either 
through snail mail, fax, or e-mail) that can be used to unlock the program. I will make every 
effort to handle your registration as quickly as possible.

· Upon receipt of your registration key, load Surfer Central and choose Register from the Help 
menu. Your lock number will be listed along with an edit box asking for a key number. Type in 
the key number you received and press the Register button. If everything goes okay you will 
receive a thank you message and the program will work with full functionality from then on. If 
however, you have some sort of problem registering (see Common Questions) please contact 
the author (see Contacting the Author).

IMPORTANT: If you would like to register using your credit card, please see 
Registering by Credit Card



Registering by Credit Card
You may now register Surfer Central using your credit card!!!!

To register using any major credit card, simply connect to your Internet service provider and load up your 
WWW browser.
Then connect to http://206.109.101.6/cgi-win/psl_ord.exe/ITEM14354. This URL corresonds to the 
Public (software) Library. They handle the credit card registrations for Surfer Central. Alternatively, you 
can connect to PsL through the Surfer Central home page at http://www.ee.umanitoba.ca/~waletz/. 

Once the URL has been loaded, simply follow the instructions on the screen and fill-in the appropriate 
fields. Don't forget to include your Surfer Central lock number (on page 2 of the form) and your e-mail 
address or you cannot be registered!!. 

Once you have submitted your form and PsL has processed it, they will send me your personal 
information (i.e. program lock number) and I will send you your key number that unlocks the full features 
of Surfer Central.

A Note About the Cost for Credit Card Orders:

Due to the processing fees that are required for credit card registrations, you will be charged slightly more 
than if you registered via cheque or money order. The cost for registering Surfer Central via credit card is 
$21 (US). This price, however, is still very compared to a lot of software.



Registration Form (Canada)
Note: You may print this form by choosing Print Topic from the File menu of this help file.

Surfer Central v1.21

To order the full version of Surfer Central, please fill out the form below and mail it, along with a cheque or 
money order for $15 (Can. Funds), to:

James Waletzky
412-2990 Princess Crescent
Coquitlam, BC
V3B 7R3

ATTN: Surfer Central Registration

PROGRAM LOCK NUMBER: 
    (the program lock number can be found by selecting Lock Number from the Help menu)

Are you re-registering Surfer Central due to a significant change in your system?
o YES          o NO

If Yes, please provide your old key number: 
    (the old program key number can be found by viewing the file SURFRCEN.INI)

Purchaser Details:

Name:

Company (optional):
Title   (optional):

Address:

City:

Country: Canada

Postal Code:

Phone Number --> Home: (   ) -    - 
Business: (   ) -    - 

Fax Number  --> Home: (   ) -    - 
Business: (   ) -    - 

E-Mail Address:

How would you like to receive your registration key? Through:

o through e-mail (preferred)



o through snail mail at the above address (please include a self-
addressed, stamped envelope)

o by fax at the fax number given above

Please fill out the following information:

(1) Where did you find your evaluation copy of Surfer Central? If you found 
it on the Internet, please tell me the specific location where you got your 
copy.

(2) Do you have any suggestions for future improvements (features)?

(3) Please give any comments you may have about the program including your 
likes and dislikes:



Registration Form (International - all except Canada)
Note: You may print this form by choosing Print Topic from the File menu of this help file.

Surfer Central v1.21

To order the full version of Surfer Central, please fill out the form below and mail it, along with a cheque or 
money order for $15 (U.S. Funds), to:

James Waletzky
412-2990 Princess Crescent
Coquitlam, BC
Canada
V3B 7R3

ATTN: Surfer Central Registration

PROGRAM LOCK NUMBER: 
    (the program lock number can be found by selecting Lock Number from the Help menu)

Are you re-registering Surfer Central due to a significant change in your system?
o YES          o NO

If Yes, please provide your old key number: 
    (the old program key number can be found by viewing the file SURFRCEN.INI)

Purchaser Details:

Name:

Company (optional):
Title   (optional):

Address:

City:

Country:

Zip Code:

Phone Number --> Home:
Business:

Fax Number --> Home:
Business:

E-Mail Address:

How would you like to receive your registration key? Through:



o through e-mail (preferred)

o through snail mail at the above address (please include a self-
addressed, stamped envelope)

o by fax at the fax number given above

Please fill out the following information:

(1) Where did you find your evaluation copy of Surfer Central? If you found 
it on the Internet, please tell me the specific location where you got your 
copy.

(2) Do you have any suggestions for future improvements (features)?

(3) Please give any comments you may have about the program including your 
likes and dislikes:



About the author
Wow! You actually want to know something about me? 

Well, I have just graduated from the University of Manitoba with a MSc. in Computer Engineering. In case 
you are interested, my thesis title was Partially Supervised Fuzzy Clustering with Application to Software 
Reusability. This involves using unsupervised learning algorithms and artificial neural networks to 
organize a library of reusable software. It's actually more interesting than it sounds...

I just completed moving to Vancouver, British Columbia and am now working for a company called MPR 
Teltech Ltd designing Windows software for telecommunications applications. Although I have graduated, 
my account at the University shouldn't expire for a while so you can reach me there if required. 
Alternatively, you can get me at MPR at waletzky@mprgate.mpr.ca.

When I am not coding software in my spare time, I enjoy playing various sorts of computer games and 
taking in the great outdoors by playing baseball and cycling (my two favorites). I also love golf and 
bowling and a wide variety of music.

If you would like to chat sometime, drop me a line by way of e-mail - particularly if you have a suggestion 
for some software (or a small contract) or a feature for Surfer Central.

Thanx for checking out Surfer Central and I hope you enjoy using it as much as I enjoyed creating it!!!

This is my first 'official' piece of shareware so if you have any suggestions in general I would love to hear 
from you.



Revision History
v1.21 - Fourth Release December 20 1995

New Features in version 1.21

v1.20 - Third Release November 28 1995

New Features in version 1.20

v1.10 - Second Release September 13, 1995

New Features in version 1.10

v1.00 - Initial Release July 25, 1995

New features in version 1.0

Known Problems in the Latest Release



None of course!! This is the initial release!



New Features in version 1.10

Surfer Central Changes Notes
=-=-=-=-=-=-=-=-=-=-=-=-=-=-

VERSION: 1.10

Note: If this table looks funny, just resize this window to make it wider

Date Change
-------- -----------------------------------------------------------
- 
95/08/10 - Incorporated change from 8 to 16 categories

  Added statement for reading old database files (pre
  v1.10; for backwards compatibility)

95/08/10 - Increased Hostname field from 40 to 255 chars
95/08/10   - Fixed: GPF when several edit fields are filled to

  maximum capacity

95/08/12 - Added capability for loading a file automatically
  from the command line (e.g. 
  C:\SURFRCEN\SURFRCEN.EXE SAMPLE1.SDB)

95/08/12 - Added option to minimize Surfer Central when a 
  Winsock application is loaded

95/08/12 - New checkbox in generate site dialog box to allow for
  only addresses in a list of addresses (for mailing lists)

95/08/12 - Fixed: no error message displayed when a filename
  is not provided for site list generation

95/08/12 - Desktop state (current site type, current category, 
  state of site summary dialog) when program is exited.
  Thus, the next time you run Surfer Central, the last site
  type and current category will be restored.

95/08/14 - Added capability to generate a site list based on only
  those sites containing a specified keyword

95/08/14 - Added a button in the generate site dialog to toggle all
  check boxes in the include group

95/08/22 - Added option of closing TCP/IP Manager when Surfer
  Central exits

95/08/22 - Added option of executing TCP/IP Manager in a
  minimized state

95/08/23 - Updated help file to reflect above changes. Specifically:
 o  Contacting the Author

o  Generating a Site List
o  Using the Winsock Tools
o  List of New Features
o  Common Problems
o  Importing Netscape & Mosaic files

95/08/30 - Added an import facility to allow reading of Netscape bookmarks
95/08/30 - Added an import facility to allow reading of Mosaic hotlists

95/09/04 - Fixed: category name in site entry area not updated when a
  new file is opened



95/09/07           - Fixed: GPF when the site summary dialog box is invoked 
and

  two sites in the database (with different site types) have
  the same site name

95/09/12   - Removed Copy Site menu item from listbox pop-up menu



New Features in version 1.20

Surfer Central Changes Notes
=-=-=-=-=-=-=-=-=-=-=-=-=-=-

VERSION: 1.20

Note: If this table looks funny, just resize this window to make it wider

Date Change
-------- ------------------------------------------------------------ 
95/10/18        - Fixed: Address categories were all mixed up when order of

  category tabs were changed
95/10/18        - Database marked for save when category order is changed

95/10/23
    - Fixed: working directory is changed before a winsock tool 

is
executed so that the spawned app is started in required dir

95/10/23        - Added a sort button to the site summary dialog box
95/10/29        - Added tabs for site types to the site summary dialog box
95/10/29        - Added an exception handler for Winsock tools that point to 

invalid filenames
95/10/29        - Shrunk the size of the title panel above the sites listbox
95/10/29        - Fixed: When a site is clicked upon in the site summary box

  multiple sites are often selected in the sites listbox
95/10/29        - Changed: Tab key now changes focus from Description box

  instead of inserting a tab character
95/10/29        - Added: modem status dialog box
95/10/29        - Changed: Configure winsock tools dialog to add options for

  setting up modem status modeless dialog
95/10/29        - Added: multi-line hints
95/10/29        - Added: Window position of site summary box and modem

  status box are saved on exit and restored on launch
95/10/29        - Fixed: Misc. bugs with the site summary dialog box
95/11/01        - Fixed: IP Address field is too short
95/11/01        - Fixed: Field labels not redrawn when site type is changed

  via site summary dialog box
95/11/01        - Added: Radio buttons to select URL prefix for WWW site type 
95/11/01

          - Fixed: State of update button now set correctly
95/11/05        - Added: Checkbox allowing site summary to remain on top
95/11/08        - Fixed: Save toolbar button now permanently enabled and 

  will intelligently determine whether save of save as is
  needed

95/11/11        * Added: User-definable site types. Names and graphics of 
site

  types can be changed
95/11/12        - Misc. cosmetic changes
95/11/12        * Added: A GREAT new interface for importing Netscape 
bookmarks
   and Mosaic hotlists
95/11/15        - Added: Site Name edit box now gets focus after clear or 
insert
   button is pressed
95/11/15        - Fixed: Multiple, non-contiguous sites can now be selected 
in



   the sites listbox by holding down the Ctrl-key and pressing
  the left mouse button on the site to be selected

95/11/15        - Changed: Width of site entry area (and consequently site 
entry
   edit boxes) is now slightly larger 
95/11/15        - Changed: Extra space in front and behind tabs under site

  listbox has been removed to fit more tabs on the screen
95/11/18        - Fixed: GPF when a password protected file is loaded from 
the

  command-line when launching Surfer Central
95/11/18        * Changed: Surfer Central now uses fewer system resources
95/11/25        - Fixed: List index out of bounds error when importing sites

  after doing a cut and paste
95/11/25        - Changed: Edit boxes are now the default active control on
   most dialogs and windows
95/11/26     * Added: A category summary box to complement the category

  tabs (allows easier, one click changing of categories)



New Features in version 1.21

Surfer Central Changes Notes
=-=-=-=-=-=-=-=-=-=-=-=-=-=-

VERSION: 1.21

Note: If this table looks funny, just resize this window to make it wider

Date Change
-------- ------------------------------------------------------------ 
95/12/02        - Added: DDE communication with Netscape so URLs are 

  automatically loaded when a user drags & drops a site on
  he WWW button or double-clicks on a site (even if 
  Netscape is already running!). Will add this capability
  for Mosaic in the future

95/12/02        - Fixed: Mouse is in drag & drop state after double-clicking
on a site in the sites listbox

95/12/02        - Added: Grab URL which will take the window title and 
  URL from Netscape and populate the appropriate fields in
  Surfer Central to automatically create a new entry

95/12/09        - Changed: handling of loading TCP/IP Manager. Hopefully no
more random GPFs when loading TCP/IP Manager.

95/12/09        - Added: Drag and drop sites between categories using the
  category tabs

95/12/09        - Changed: Made quite a few coding optimizations
95/12/11        - Changed: Evaluation version now allows 50 addresses in

  database. Also updated evaluation messages.
95/12/18     - Changed: Improved the robustness of the Netscape import

  routines
95/12/18     - Fixed: Minor bug whereby sites listbox is not cleared after

  attempting to load a database with more than 50 sites in
  evaluation version

95/12/18     - Updated help file to reflect the above changes



Known Problems in the Latest Release

Here is a list of known problems in the latest release:

· Making a change to the site entry area and clicking either on the sites listbox or category tabs 
without first updating or inserting the changes may cause minor problems. The mouse seems 
to enter a dragging state where the mouse cursor changes to a circle with a line through it. If 
this occurs, move the mouse around until it's in a position where it remains as the circle and 
click the primary mouse button (usually the left button). In the case of the sites listbox, click 
the button anywhere within the listbox, and for the category tabs, click the button on the 
currently selected (gray) tab. The program will then function normally.



Future Features
I have several new features planned for upcoming versions of Surfer Central. Just to wet your appetite a 
little bit, some of the planned enhancements are:

· a 32-bit Windows 95 version!!!

· a hierarchical listbox that will replace the sites listbox to allow for greater 
customizability of the displaying of addresses

· speed optimizations

· printing capabilities

· more customizability and options for site list generation

· enhanced search functions

· an undo feature

· a floating Winsock toolbar

· possibly file compression for the site database files

· one button deletion of the entire database (useful when you want to start a new database but 
keep the same colors, field names, etc. of an existing database)

· bug fixes (of course)

Upgrade Information

I have not decided on the upgrade process for Surfer Central. Probably, upgrades to minor releases 
(e.g. to version 1.1) will be free and upgrades to new releases (e.g. to version 2.0) will be $5 or so. 
This upgrade info is tentative and subject to change without notice.

Scratch that!!! All upgrades to Surfer Central are FREE for registered users!!!! You just have to 
send me a postcard when you download a new version :^).

You may keep up-to-date with the enhancements and bug fixes to Surfer Central by checking out the 
Surfer Central home page at:

 http://www.ee.umanitoba.ca/~waletz



Uninstalling Surfer Central
To remove Surfer Central from your system, locate the Program Manager group containing the Surfer 
Central icon {ewc OSHTOOLS.DLL, OlsonSoftEWBitmap, SCICON.BMP}. Also in this group 
will be an icon labeled Uninstall Surfer Central {ewc OSHTOOLS.DLL, OlsonSoftEWBitmap, 
SCUIICON.BMP}. Double-click this icon with the primary mouse button and Surfer Central will be 
removed.

Note: Uninstalling Surfer Central removes the Surfer Central directory and its associated subdirectories 
from your hard drive. Please ensure that you have no data files that you wish to keep in any of these 
subdirectories as they will be deleted during uninstallation.



Technical Support
For non-registered users:

Technical support will be provided in a very limited fashion for non-registered users. Of course, help will 
be provided in cases where some problem is preventing you from doing a useful evaluation of the 
program.

For registered users:

Registered user receive unlimited technical support via e-mail. Being a small independent shareware 
developer I obviously cannot provide telephone support (unless you are willing to flip the bill). If you do 
not have access to e-mail, please feel free to write me at the address given on the registration form. Of 
course, support is a slow process when conducted in this manner.

For information on how to contact me, see Contacting the Author

Reporting Bugs:

If you are reporting a bug, please give a thorough description of the bug and how you encountered it. 
Please provide as much detail as possible including the SURFCEN.INI file as well as your database file 
that caused the bug (if applicable). Also include the version you are using (this is accessible via the Help 
menu by choosing About).



Credits
I would like to thank the following people for making this program possible:

· Tom Legal (legal@mprgate.mpr.ca) - for his ideas and BETA testing

· Kevin Truss (kevin.truss@canada.cdev.com) - for his invaluable testing and suggestions

· Paul Amonson (amonson@uidaho.edu) - for the copy of PInstall v1.01 (the installation 
program used by Surfer Central)

· Jeff Robinson - for the great artwork on the splash screen, help file and in the program

· Cheryl Bowman (cbowman@en.com) - for her great suggestions and BETA testing of v1.20

· Danielle DeGagne - for her support and for putting up with me while I designed and 
implemented this thing

and last but not least the great people of the Internet (Usenet in particular) who provided a helping hand 
when I needed it...

Also, thanx to all those people who registered version 1.00 and 1.10!!!!!



Contacting the Author
You can get ahold of me in several ways:

E-Mail:

This is my method of choice for communication. You can get me any time at:

waletzky@mprgate.mpr.ca

Snail Mail:

If you prefer to write and trust the postal service, send me a letter (or better yet a postcard) to the 
following address:

James Waletzky
412-2990 Princess Crescent

Coquitlam, BC
Canada
V3B 7R3

Phone:

You may give me a call at:

Home: (604)-552-9084
Work: (604)-473-5836

... but when e-mail is fast and cheap (or free in some cases), why bother??






