
Welcome to Surfbot

Surfbot is an Internet productivity tool that lets you create, schedule and publish Agents that surf the Web for you. 
With Surfbot, you can create Agents that monitor your bookmarks or Windows Favorites, deliver Web pages for 
offline browsing, operate overnight or at times you specify, or search for information using any Internet search 
engine.
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For the latest product information, be sure to visit Surflogic’s Web site at http://www.surflogic.com/



What's New?

Surfbot 2.0 includes many new features that save you time and money:

n Surfbot creates reports compatible with any Web browser, and provides special support for the popular 
Netscape Navigator and Microsoft Internet Explorer.

n You can create and publish your own portable Surfbot Agents, upload them to your Web site, or send them via 
e-mail to your colleagues.

n You can use Surfbot to interactively explore sites, drilling down through levels of Web sites, and “freezing” the 
list for your Agent to monitor.

n Enhanced program options and performance improvements let you control how Surfbot retrieves Web pages.

n You can now schedule Agents to run automatically with Surfbot’s built-in scheduler.

n Surfbot now delivers the entire range of multimedia Web documents: HTML, images, Acrobat files, animations, 
sounds, and more!

n Discovering Web sites is easy with the comprehensive new Internet Search  feature. You can query any Internet 
search engine, and even add your own favorite search resources.

n Easy-to-use Wizards guide you through the process of creating and publishing Surfbot Agents.

n Intelligent filtering options let you weed out unchanged documents to view only the most recently changed Web 
pages.
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Getting Started with Agents

What is an Agent?

An Agent is software program that acts on your behalf to save you time and effort. Surfbot makes it to create 
Agents that find, retrieve and filter collections of Web pages and return them in a variety of report styles. Surfbot 
Agents reside on your computer, and connect to Internet servers and Web sites to find information.

Running an Agent is as easy as opening a file on your computer:

1 In the Windows Explorer, open the Agents folder inside the Surfbot folder (by default, C:\Program 
Files\Surfbot\Agents\)

2 Select an Agent, such as the Newsfeed Agent, and double-click to open. Surfbot will display a description of the 
Agent, its current settings, and the time of its last report.

3 Click the Start Agent button, and sit back while it retrieves the pages listed in Contents. If you aren’t connected 
to the Internet, you will be asked to complete the connection.

4 After retrieving all the pages, Surfbot prepares a report and opens your Web browser to display the report’s 
Table of Contents.

5 See the instructions in the Table of Contents for help on moving between pages.

While Surfbot makes it easy to run an Agent with a few clicks of the mouse, you’ll find lots of help along the way 
as you learn more advanced ways to use Agents. 
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Sample Agents

When you install Surfbot for the first time, the program creates Agents to monitor your Netscape Bookmarks or 
Windows Favorites. Use these Agents to generate reports that highlight only the most recently changed locations 
in your bookmark files.

Surfbot also includes a selection of ready-to-run Agents that deliver the news, update your bookmarks, and 
conduct keyword searches. You’ll find examples in the Agents folder and online at the Surflogic Web site.
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Getting Around the Screen

Surfbot is designed for Windows 95, and implements many standard controls including a button bar, a status bar, 
an interactive table of contents, right-mouse menus, and a QuickView pane.

Click any region of the Surfbot screen to learn more:
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Menu Bar

In the File menu, you will find commands to:

n Create new Agents with the Agent Wizard; Open existing Agents from the Open… dialog or the Most Recently 
Used Agent list; Save and publish Agents; Exit Surfbot

In the Edit menu, you can:

n Cut, Copy and Paste text and URLs into the Address line or Contents; Open a selected URL in your Web 
browser; Export a selection of URLs as HTML or Internet Shortcuts; Explore links on Web page

In the View menu, you can:

n Customize your view of the screen; Change Program Options

In the Agent menu, you can:

n Start and Stop Agents; Change Agent Settings; Schedule an Agent



Toolbar

Toolbar shortcuts are provided for the main Surfbot commands. From left to right, these are:

n New Agent, Open Agent, and Save Agent

n Cut, Copy, and Paste

n Start Agent, Stop Agent, and Explore links

n Change Agent Settings, Schedule an Agent

To hide or display the Toolbar, choose Toolbar from the View menu.



Address Bar

From the Address Bar, you can select the type of locations to monitor:

n A simple Internet address (in the form of http:// ______)

n Internet Search keywords

n A file on your PC (either ______.url or ______.htm)

n A folder on your PC which contains Internet Shortcuts (.url files)

The address line provides a dropdown history list of your recently selected locations.



Activity indicator

The activity indicator provides an animated view of the program’s current state. When an Agent is running, you’ll 
see an animated display in this area. This is your indication that the Agent is retrieving documents, contacting Web 
sites, or formatting your report. You can stop a running Agent by clicking the activity indicator.



Status bar

The status bar is divided into three sections, which update dynamically as your Agent is running:

n The message area displays the status of currently-retrieved items.

n The progress area displays a graphical indicator the Agent’s overall progress.

n The counter reflects the number of retrieved documents, the number of retrieval retries or failures, and the 
overall number of documents to be retrieved.



Contents pane

Your Agent will retrieve Web pages listed in the Contents pane, which provides an interactive outline view of your 
report. The Contents pane updates while your Agent is running, showing you a current view of the Agent’s 
progress. You can browse through the items listed in Contents and preview the details of each item in the 
QuickView pane to the right of Contents.

There are five types of items you’ll find in the Contents:

n A Surfbot Agent

n A “parent” location (which can be an Internet address, a search term, or a local file or folder)

n A briefcase (indicating that the Agent is portable)

n Links to Web pages

n Folders that contain and organize links



QuickView pane

The QuickView pane displays the details of the item selected in Contents. When you first open an Agent in 
Surfbot, the QuickView area displays a description of the Agent and provides a few shortcut buttons. As you select 
other items in Contents, the QuickView pane displays details about that item.

While your Agent retrieves pages, try selecting links in Contents. You’ll see the status of the item (not retrieved, 
queued, loading, retrieved) and other details in the QuickView pane. You can view the text of retrieved pages 
directly in the this area, even before your Agent has completed its report.



What gets installed?

If you have not already installed Surfbot, create a new folder, move the self-extracting archive into this folder, run 
the .exe file, and double-click Setup. Once Setup is complete, you can delete the contents of the folder you 
created.

By default, Setup installs Surfbot into C;\Program Files\Surfbot and inserts settings into the Windows Registry. The 
included Uninstall utility removes these entries    so you can cleanly delete the program.

Default installation folders:

C:\Program Files\Surfbot

Program files, application extension, help, uninstall utilities

C:\Program Files\Surfbot\Agents

Sample Agents, including Agents for your Bookmarks and Windows Favorites

C:\Program Files\Surfbot\Graphics

GIF-format buttons used for navigation in Surfbot reports

C:\Windows\System\

Runtime libraries (mfc40.dll, msvcrt40.dll)
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Configuring your Internet connection

Surfbot uses your Windows 95 Internet configuration to access the World Wide Web. If you have already set up 
other Internet programs, such as a Web browser, then you should be able to run Surfbot. Be sure to read on if you 
access the Internet from behind a firewall.

You can further configure your Internet connection:

n If you need help with your basic Internet configuration, read through the system requirements.

n If you use Dial-Up Networking, you can configure Surfbot to store your user name and password so it 
automatically dials your Internet service provider.

n If your local network is protected by a proxy server or firewallUsing_Surfbot_with_a_proxy_server, you can 
provide Surfbot with the necessary information to access the Internet.

n If you are registered at password-protected Web sites, you can store these passwords so your Agents can log 
into these sites.

For step-by-step procedures, click Related Topics below.
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System Requirements

Surfbot requires:

n Windows 95

n 8 MB RAM, 2 MB hard disk space minimum, plus 5-10 MB for stored reports

n 32-bit Winsock 1.1-compliant networking 

n An Internet connection through your local area network or Dial-Up Networking

n Any Web browser for viewing HTML reports

Notes:

n To configure a PC for Internet access, consult Windows 95 Help or contact your system administrator.

n Surfbot has been tested with the standard Windows 95 TCP/IP stack. Trumpet, another popular stack, does not 
yet have a 32-bit Winsock implementation, although they are working on it.

n If you use an online service to connect to the Internet, you can run Surfbot if your service supports 32-bit 
applications. Contact your online service provider for more information.
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Connecting using Dial-Up Networking

If you connect to the Internet via Dial-Up you must supply a user name and password so Surfbot can dial the 
connection. Without this information, Surfbot will not be able to connect to the Internet.

1 On the View menu, click Program Options.

2 Click the Connection tab.

3 Click Connect using the modem.

4 Select the Dial-Up Networking connection you use to access the Internet.

5 Click Login as, and enter the user name and password required to access your Internet provider.

Notes:

n If you choose Connect using the network and you use a modem, Surfbot will always prompt you to complete the 
Dial-Up Networking connection. To prevent this from happening, switch to Connect using the modem and 
configure Dial-Up Networking as described above.

n To enable scheduled reports to run when you are not at your PC, you must configure Surfbot with your user 
name and password if you use Dial-Up Networking.
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Using Surfbot with a proxy server

If your local network is behind a firewall and you connect to the Internet through a proxy server, then you must 
supply Surfbot with the address and port number of the proxy.

1 Obtain the proxy address from your system administrator.

2 On the View menu, click Program Options.

3 Click the Proxy tab.

4 Enter the proxy address and port number supplied by your system administrator.

5 If your proxy requires authentication, click Password… and enter the realm name, user name and password in 
the provided fields. If you don’t know what a proxy password is, then you probably don’t need one.

Notes:

n If you access computers on your local area network without going through the proxy server, you can add these 
to the Bypass proxy on field. Type each domain, address, and port, separating each item with a comma.

n If you have already set up a Web browser on your PC, you may be able to copy the settings from that program 
into Surfbot. For Internet Explorer users, right-click on the Internet icon on the Windows 95 desktop, and click 
the Advanced tab. For Netscape users, click the Options menu, choose Network Preferences, and click the 
Proxies tab.
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Accessing password protected sites

Some Web sites require users to be registered: when you navigate to these sites with your Web browser, you are 
asked for a valid user name and password before you can access specific Web pages or resources. 

You can configure Surfbot to store a list of user names and passwords for Web sites requiring authentication. 
Agents that have been scheduled will attempt to use your stored passwords to access information on protected 
site.

To have Surfbot store authentication for a site:

1 Create or open an Agent that contains the location of the protected site, and click Start Agent.

2 Surfbot will prompt you for your user name and password. 

3 Enter this information to store it in the Surfbot password list.

Or, to manually store a user name and password:

1 On the View menu, click Program Options.

2 Click the Passwords tab.

3 Click Add… and enter the realm name, user name and password for the protected site.

Notes

n As your Agent runs, it will prompt you for a user name and password when it encounters a site requiring 
authentication. Once you are authenticated for this site, you won’t see these dialogs in subsequent runs of your 
Agent.

n User names and passwords are encrypted and stored on your PC and are never packaged with Agents you 
create.
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Choosing your Web browser

Surfbot Agents create reports that you can view with any Web browser. By default, Surfbot launches the browser 
you typically use to read Web pages. If you have more than one browser, you can change this setting in Program 
Options.

1 On the View menu, click Program Options.

2 Click the General tab.

3 Under Web Browser, select the program you want to use, or click Browse… for programs not listed here.

Tip

n If you don’t want Surfbot to launch your browser, clear the checkbox labeled “Automatically open reports in 
browser.” You can still open reports using the Open command in your browser’s File menu.
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Removing Surfbot

Surfbot includes an Uninstall utility that removes all of its entries from the Windows Registry, allowing you to safely 
delete the Surfbot program files.

1 In the Control Panel, choose Add/Remove Programs.

2 Click Surfbot.

3 Click Add/Remove to uninstall Surfbot.

Tip

n If you want to move the Surfbot folder to a different location on your computer, it’s a good idea to Uninstall first, 
then reinstall with the Surfbot Setup utility. Moving registered programs is not recommended under Windows 95.
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Opening an Agent from Windows

To run an Agent from Windows:

1 In the Windows Explorer, double-click an Agent file (indicated by the .sba file extension).

2 Click the Start Agent button. If you aren’t connected to the Internet, you will be asked to complete the 
connection.

3 After retrieving the last item, Surfbot will prepare a report and open your Web browser to display the report’s 
Table of Contents.

Tip:

n You can run an Agent directly from the Windows Explorer: with the right mouse button, click the Agent you wish 
to run, and choose Run from the context menu.
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Running an Agent from a Web page

You can run Agents directly from Web pages and e-mail messages. When you install Surfbot, support is 
automatically installed for programs such as Microsoft Internet Explorer and Exchange.

To run an Agent linked to a Web page or e-mail message:

1 With your Web browser or e-mail program, open the document containing the Agent you want to run.

2 Click the linked Agent to activate Surfbot and open your Agent.

3 In Surfbot, click Start Agent.

Notes:

n Many Web browsers and e-mail programs store data in temporary directories. To save an Agent for later use, be 
sure to store it in a permanent location on your computer.

n If you use Netscape, you may need to configure Surfbot as a “helper application”    to handle files with the .sba 
extension.

n Because Surfbot Agents are stored in binary format, your e-mail program may need to encode the Agent as 
plain text before you send the Agent as an attachment. Consult your e-mail documentation for more information, 
or visit the Virtual Shareware Library on the Web for Uuencode utilities (http://www.shareware.com/)
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Setting up Surfbot as a helper application

If Surfbot is established as a helper application for your browser, you will be able to automatically launch Surfbot 
Agents with a single click from Web pages.

For Netscape 2.x users (other browsers follow similar procedures):

1 In the Netscape Options menu, click General Preferences, and then choose the Helpers tab.

2 Click the Create New Type button.

3 For the Mime Type, enter application, and for the Mime SubType, enter x-surfbot. Click OK to close the dialog.

4 Back in the Helpers tab, enter sba in the File Extensions field.

5 In the Action list, check the radio button labeled Launch the Application.

6 Click Browse, and locate the Surfbot program on your PC.

7 Click OK to save your changes.

Surfbot will launch whenever you click on a link to a Surfbot Agent.
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Scheduling an Agent

Surfbot includes a built-in scheduler so you can easily schedule Agents for delivery.

1 Open the Surfbot Agent you wish to schedule, click the Agent menu, and then click Schedule. 

2 Check the box marked Schedule this Agent, and then fill in the frequency and time for your Agent to run.

3 If you want your Agent to automatically open the report in your Web browser, check the Open report when 
finished box.

4 Save your changes.

Tips:

n If you use the modem to connect to the Internet, be sure that your Dial-Up Networking options have been 
properly established in the Surfbot Program Options.

n If you plan to run Agents overnight, be sure to keep your computer running.
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Running an Agent from the System Agent

Microsoft Plus! For Windows 95 includes the System Agent, a scheduling utility which lets you set up times for 
programs to run automatically. Surfbot includes its own scheduler and supports the System Agent for scheduling.

1 Double-click the System Agent icon in the Windows 95 taskbar, or click the Start menu, and open the System 
Agent. By default, Windows installs the System Agent in Programs: Accessories: System Tools: 

2 In the System Agent, click the Program menu, and choose Schedule a New Program.

3 From the Program list, choose Surfbot Agent.

4 Click the Settings button, and select a Surfbot Agent from the Browse dialog.

5 To change your Agent’s schedule, click When to Run and make your settings.

6 Your Agent will run at the times you selected. 

Tips:

n You can edit the name of the Surfbot Agent that appears in the System Agent’s Schedule Program list. In the 
System Agent, click the Program menu, and choose Properties. In the Description field, type a short description 
of your Surfbot Agent.

n If you use the modem to connect to the Internet, be sure that your Dial-Up Networking options have been 
properly established in the Surfbot Program Options.



Viewing reports

Surfbot Agents create reports that are saved locally to your hard disk,. You can read these reports even when you 
aren’t connected to the Internet.

Surfbot can create three kinds of reports:

n Surfbot QuickView reports provide a simple text summary of the locations listed in the Surfbot contents pane. 
This report style is designed to help you preview the contents of Web pages while you are creating your Agents.

n Internet Shortcut reports are useful if you prefer to store Web locations in folders. Surfbot will report Internet 
Shortcuts with the time and date of the last change, and even include the text of the page which you can view in 
the Windows Explorer property sheet.

n HTML reports preserve the formatting, layout and graphics of Web pages. Your Agent can create a report as a 
single page, multiple pages, or as a Netscape frame set. A Table of Contents is automatically generated for each 
of these reports, providing full support for offline browsing.
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Unpacking an Agent

Agents that you download from the Internet or receive with Surfbot are often packaged. Packaging is the final step 
in creating a portable, ready-to-run file. Packaged Agents contain all the locations, settings, and extra information 
needed to run an Agent on any computer.

If an Agent is packaged, you must unpack it before you can edit it:

1 Click the File menu, and choose Unpack Agent.

2 Choose a location to save the Agent, and click OK to save the Agent.

3 Surfbot will save the Agent, and unpack the locations used by this Agent into a new folder. Check the address 
bar to see where these locations have been saved.

Notes:

n When an Agent is packaged, its author has the option of preventing other Surfbot users from editing it. If an 
Agent is protected, you won’t be able to unpack it. However, you can still open, run, and schedule these Agents.
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Editing locations

Surfbot Agents monitor Internet locations or perform keyword searches. A location is any URL, for example 
http://www.surflogic.com/products.html. Internet searches are based on keywords you type into Surfbot.

To edit locations, type directly into the Address Bar, or:

1 Click Settings… in the Address bar (or choose Agent Settings… from the View menu).

2 Click the Locations tab and select the source of the locations you’d like to monitor. The source can be a single 
URL, or a local file or folder containing locations.

3 Edit the locations in the box provided, or click the Browse button to find a file or folder on your disk.

4 Click OK to view the new locations in the Contents pane.

To edit keywords, type directly into the Address Bar, or:

1 Click Settings… in the Address bar (or choose Agent Settings… from the View menu).

2 Click the Locations tab, and click the Internet search radio button.

3 Enter the keywords in the box provided.

4 Click OK to view the new locations in the Contents pane.

Notes:

n You can easily enter a single URL by copying it from your Web browser and pasting it into the Address Bar.

n You can specify new locations by dragging a file or folder into Surfbot, or by dragging links from your Web 
browser into Surfbot.
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Setting retrieval options

You control how your Agent reports Web pages by setting retrieval options in Agent Settings. 

1 Click Settings… in the Address bar (or choose Agent Settings… from the View menu).

2 Click the Retrieval options tab, and select from one of following groups:

n You can specify how much data to report in Content retrieval. Agents can retrieve the time and date of a Web 
page, prepare a text preview, or retrieve the complete page, with or without images and other linked data.

n Select Date highlighting if you want your Agent to mark changed Web pages. This option, when combined with 
the Discard unchanged pages filter, limits your reports to changed Web pages only.

n  Use Filters to instruct your Agent to disregard unchanged pages, duplicates or pages without dates. 

Notes:

n Some Web servers don’t report the time and date when a Web page was modified. If you check the option to 
Discard pages with unknown dates, Surfbot eliminates these pages. If you uncheck this option, Surfbot will mark 
these pages as unknown.
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Changing report styles

Surfbot includes a variety of built-in report styles, from the text Quickview built into Surfbot to full HTML reports, 
including graphics. To select a report style:

1 Click Settings… in the Address bar (or choose Agent Settings… from the View menu).

2 Click the Report tab and select a report style.

3 In the box provided, enter a file name for the report, or click Browse to select a location.

4 Click OK to save the current settings.

5 Surfbot will create a report using the name you selected, and store additional report items, such as inline images 
or Web pages, in a folder with the same name as the report.
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Creating a new Agent

To create a new Agent, click the File menu and click New Agent. This displays the Agent Setup Wizard which will 
guide you through the process of creating a new Agent. Once you complete this Wizard, you will have an Agent 
that is ready to surf the Web for you.

Surfbot provides a number of other ways to edit and modify your Agent:

n Entering locations directly into the Address Bar

n Using the Agent Settings property sheet

n Using drag and drop to specify locations

n Building a table of contents interactively



Using the Agent Setup Wizard

The Agent Setup Wizard asks you questions about the purpose of your Agent, and uses your answers to build a 
new Agent or modify an existing Agent. The Wizard provides explanations of each of the main concepts in Surfbot, 
such as locations, retrieval options, date highlighting, filtering, link exploration, and reporting. For additional help, 
hit F1 while viewing any page.

The information gathered by this Wizard is also accessible via the Agent Settings property sheet.

1 About this Wizard

2 Specify locations

3 Content retrieval options

4 Date highlighting and filtering

5 Link exploration

6 Report styles

7 Report location

8 Finish



Saving your Agent

On the File menu, click Save. In the box provided, type a name for your Agent and click Save. While you are 
editing your Agent, you should save your changes periodically.

To save an Agent under a different name, click Save As on the File menu.



Packaging an Agent

Packaging is the final step in creating a portable, ready-to-run Agent that others can use. Packaged Agents 
contain all the locations, settings, and extra information needed to run an Agent on any computer. You may also 
find it useful to package Agents for your own use, since packaged Agents don’t require the local input files used to 
create the Agent.

To package an Agent:

1 On the File menu, click Package As.

2 Save your Agent by following the instructions in the Package Agent Wizard. This Wizard lets you add a 
description, author’s name and date to your Agent.

3 Distribute the new Agent to your colleagues (on disk, via e-mail, or by uploading to your Web site).
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QuickView report

Surfbot provides a built-in text QuickView report. Each location is listed in the Contents pane along the left side of 
the Surfbot window, and details are displayed in the QuickView pane. While Surfbot runs, a QuickView is 
automatically created, no matter what other kind of report you’ve selected.

Notes:
n Text QuickViews are not saved to disk. If you want to save the text provided in a QuickView, you must export the 

contents before you close Surfbot.

n QuickViews do not display graphics or HTML formatting. Choose one of the HTML report styles to see whole 
pages.

n You can preview pages while your Agent is running. Just select a location in the Contents pane, and view the 
text in the QuickView pane.
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Internet Shortcuts report

Surfbot can create reports consisting of folders of Internet Shortcuts that point to your favorite Web locations. Each 
Shortcut is stamped with the time and date when the Internet location last changed. You view Internet Shorctut 
reports in the Windows Explorer or My Computer.

Notes:
n Surfbot assumes that it “owns” the folders used to store the Internet Shortcuts. Depending on the options 

you’ve selected, Surfbot may update, modify or completely delete the contents of these folders while an Agent 
runs. Do not store any other information in these folders.

n To view the extra Surfbot information stores in an Internet Shortcut, click a shortcut with the right mouse button, 
choose Properties, and click the Surfbot tab in the property sheet.

n Internet Shortcut reports do not display graphics or HTML formatting. Choose one of the HTML report styles to 
see entire HTML pages.
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Single HTML file report

Surfbot can generate reports for Internet locations as a single HTML page. In this case, Surfbot appends each 
page and, optionally, all of the graphics, into one large report and creates a Table of Contents that lets you jump to 
different sections of the report. Surfbot also creates a folder with the same name as the report, and uses this folder 
to store retrieved graphics and other data.

Notes:
n Surfbot assumes that it “owns” the folder used to store the retrieved images. Depending on the options you’ve 

selected, Surfbot may update, modify or completely delete the contents of this folder while an Agent runs. Do 
not store any other information in these folders.

n This option is useful if your Agent doesn’t report a great deal of information. Try this style for bookmark and text 
preview reports.

n Some page-specific HTML formatting is not preserved with this report style. To see pages as they were 
designed, choose the Multiple HTML files style.
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Multiple HTML files report

If your Agent surfs to multiple locations, and you’d like to preserve the original appearance and function of each 
page, choose this report style. Your Agent will download entire pages, with or without graphics, and hook them 
together with local, offline navigation controls. The first page that appears in this report is a Table of Contents that 
displays links to the pages retrieved by your Agent. During retrieval, Surfbot also creates a folder with the same 
name as the report, and uses this folder to store retrieved graphics and other data.

Notes:
n Surfbot assumes that it “owns” the folder used to store HTML and retrieved images. Depending on the options 

you’ve selected, Surfbot may update, modify or completely delete the contents of this folder while an Agent 
runs. Do not store any other information in these folders.

n The name you give this report is used for the initial Table of Contents page. All of the other pages, graphics and 
linked files are saved into a folder that uses the report name.

n To navigate within a multiple-page report, just click the Next, Previous and Top buttons provided at the top and 
bottom of each page. Note that all other links point back out to the Internet.
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Netscape 2.x frame set report

Users of Netscape Navigator 2.0 and later can take advantage of this report style. Your Agent will display the Table 
of Contents in a Netscape frame along the left side of the screen, and show each page in the pane along the right. 
During retrieval, Surfbot also creates a folder with the same name as the report, and uses this folder to store 
retrieved graphics and other data.

Notes:
n Surfbot assumes that it “owns” the folder used to store the retrieved HTML and image files. Depending on the 

options you’ve selected, Surfbot may update, modify or completely delete the contents of this folder while an 
Agent runs. Do not store any valuable information in these folders.

n The name you give this report is used for the initial overall frame set. All of the other pages, graphics and linked 
files are saved into a folder that uses the report name.

n To navigate within a multiple-page report, just click the Next, Previous and Top buttons provided at the top and 
bottom of each page, or use the Table of Contents provided in the left pane. Note that all other links point back 
out to the Internet.

{button ,AL(`reports',0,`',`')} Related Topics



Navigating within reports

Surfbot retrieves and saves Web pages as HTML reports on your hard disk, allowing you to browse offline. Since 
your Web browser does not have to connect to the Internet to view these Web pages, offline reports load very 
quickly.

Surfbot provides a few basic navigation buttons to move between the pages that make up a Surfbot report:

n  The Jump to button takes you from the Surfbot-created Table of Contents to any page retrieved.

n The Next button takes you to the next page in the report.

n The Previous button takes you to the previous page in the report

n The Table of Contents button returns you to the first page of the report.

{button ,AL(`reports',0,`',`')} Related Topics



Building a table of contents interactively

The Contents pane presents a standard tree view control that you can use to interactively build a list of locations 
that your Agent will monitor. By expanding the locations listed, you’ll be able to construct a table of contents of any 
length, depth or structure.

1 Create a new Agent or open an existing Agent.

2 Select one of the locations listed, and click it with the right mouse button.

3 From the context menu, click Explore. Surfbot will connect to the selected location, follow each link, and retrieve 
the linked pages according to the current Agent Settings.

4 Continue exploring other locations, “drilling down” for more detail, and deleting those items you don’t wish to 
keep.

5 When you are satisfied with the list you’ve built, select the initial location at the top of the contents pane, and 
click Export As from the right menu.

6 In the Export As dialog, save the contents as either a single Web page or a folder of Internet Shortcuts.

7 Finally, create a new Agent, and select the exported locations as the Agent’s input source.

{button ,AL(`reference',0,`',`')} Related Topics



Using the contents pane

The Contents pane supports these standard editing operations:

n Expand and collapse the outline by clicking the (+) and (-) symbols next to each item

n Inspect any item by selecting it and viewing the information presented in the QuickView pane

n Double-click any item to open it in the default Web browser

n Drag and drop new items into the Contents pane, adding items (if the location is a local folder) or entirely 
replacing the locations listed

n Pop up context-sensitive menu commands by clicking the right mouse button on any item

n Select, copy and delete items from the Contents pane

{button ,AL(`reference',0,`',`')} Related Topics



Integrating with Windows

Surfbot includes an application extension which enhances the capabilities of the Windows Explorer file system 
viewer. Surfbot extensions include:

n The addition of Open and Run commands for Surfbot Agents in the Windows Explorer. To run an Agent, right-
click an Agent file (.sba extension) and choose Run from the shortcut menu.

n Surfbot properties added to Internet Shortcuts. When Surfbot creates an Internet Shortcut report, it stores the 
last modified date, retrieval status, size, and text (if available) for each location retrieved by your Agent. To 
access these additional properties, right-click on an Internet Shortcut (.url extension) and click the Surfbot tab.

n Support for scheduling via the System Agent, which is available as part of Plus! for Windows 95.

Tip:

The Surfbot application extension lets you reassign the default command invoked when you double-click on an 
Agent file. Normally, a double-click opens an Agent, but you can reassign this to Run the Agent from the Windows 
Explorer:

1 In the Windows Explorer, click the View menu, and choose Options.

2 Click File Types, and select Surfbot Agent from the list provided.

3 Click Edit, and select Run from the Actions list.

4 Click Set Default, and click OK twice to exit the dialog boxes.

Now Surfbot will Run an Agent when you double-click its icon or open it from the Start menu.

{button ,AL(`reference',0,`',`')} Related Topics



Using drag and drop to specify locations

Surfbot supports drag and drop as a way to specify locations that your Agent will monitor. Depending on the type 
of object you drag into Surfbot, the following action will occur:

You drag: Surfbot action:

Surfbot Agent Opens the Agent into Surfbot

HTML document Replaces the current location as the Agent’s input source

Windows Shortcut Replaces the current location as the Agent’s input source

Internet Shortcut Replaces the current location as the Agent’s input source

Folder Replaces the current location as the Agent’s input source

Selected URL from 
Web browser

If the current input source is a folder: Surfbot creates an 
Internet Shortcut and adds it into the folder

If the input source is not a folder, Surfbot replaces the 
current location with the URL you dragged in.

You can also drag any location out of Surfbot. If you drop it onto the desktop or into a folder, Surfbot will create an 
Internet Shortcut. If you drop it onto your Web browser, your browser will open the location.

{button ,AL(`settings;reference',0,`',`')} Related Topics



Reporting bugs

Before reporting a bug, first check the FAQ and known bugs listed at the Surflogic Web site. To report a bug, send 
e-mail to surfbot@surflogic.com with the word Bug at the beginning of the message title. If we cannot reply to 
your message immediately, look for updated information at the Surflogic Web site.

Here are some guidelines that will help us identify and reproduce the problem you experienced:

n Include the address of the site where you encountered the bug and all of the Agent’s settings (locations, 
retrieval options, filters, report style, etc.)

n Was the Agent packaged or unpackaged? Was this Agent scheduled, and ran unattended, or did the bug occur 
while you were interactively exploring with Surfbot?

n If you suspect the bug relates to presentation, such as improper HTML formatting, can you tell us your default 
browser, and, if different, the browser you used to view the report?

n Include any Program options that you might have set, for example the number of connections and whether you 
connect via the network or over a modem.

Thank you for your assistance!



About Surflogic LLC

Over the last few years, the Internet has grown to include millions of new users and thousands of new information 
sources. The growth of the World Wide Web has been particularly dramatic. Today, you can find just about 
anything on the Web: news, entertainment listings, personal home pages, useful software, and financial 
information. Many companies are now using the Web to conduct business, support customers and provide 
employees with up-to-date information.

This wealth of information has created its own set of problems: finding sites and staying on top of changes to the 
World Wide Web can take hours of unproductive Web surfing.

Surflogic LLC was formed in 1994 to develop Internet software to address these needs. We create tools that let 
Internet users spend less time managing the explosion of Internet content, while getting the most out of their 
favorite information sources.



Product registration

Surfbot is available for purchase from a variety of sources, including direct from Surflogic, via Compuserve, or with 
a credit card (including online forms at our Web site). Registration enables the full features of Surfbot, and entitles 
you to product support, upgrade notification and maintenance releases.

End user sales

The single-copy price for Sufbot 2.0 is $40.00. Discounts apply when you order more than 10 copies.

n Order via Compuserve

n Order with a credit card, online, by phone, by fax or by mail

n Order directly from Surflogic  with a check or purchase order

Corporate accounts and site licenses

Discounted pricing plans are available to corporate customers and qualifying educational instituions who order in 
volume. Site licensing information is available directly from Surflogic. For more information and an order form, 
send e-mail to sales@surflogic.com.



Compuserve Ordering

To have the $40 Surfbot registration fee added to your CompuServe bill use the CompuServe command GO 
SWREG and follow the menus. The registration ID for Surfbot 2.0 is 9962. Your registration key will be sent to you 
via e-mail.



Direct Ordering

To order by check, send this order form and a check payable to Surflogic LLC. To print this order form, click on 
Print Topic in the File menu. Payment must be in US dollars drawn on a US bank, or you can send international 
postal money orders in US dollars. Your registration key will be sent to you via e-mail.

Surflogic LLC

293 Downey Street

San Francisco, CA, 94117 USA

sales@surflogic.com

Product:         Surfbot 2.0
User Name:       _____________________________________
E-mail Address:  _____________________________________

           Quantity:        _______ x $40.00 = _______
           CA residents add 8.50% sales tax  + _______
           Total payment:                    $ _______

Name:         _______________________ Date: _________
Company:      _______________________________________
Address:      _______________________________________
City, State:  _________________________ Zip: ________
Country:      _______________________________________
Day Phone:    ________________ Eve: _________________

Comments about Surfbot:



Credit Card Ordering

Public (software) Library handles credit card orders for Surflogic LLC. To order Surfbot with your MasterCard, Visa, 
American Express, or Discover card, contact PsL through one of the methods listed below. Once your order is 
processed, Surflogic will send you a registration key via e-mail.

Online http://www.surflogic.com/sb20register.html

Phone 1-800-242-4775 or 1-713-524-6394 between 7:00 am and 6:00 pm CST Monday-Thursday and 
7:00 am to 12:30 pm CST on Fridays, except holidays.

Fax 1-713-524-6398

E-mail 71355.470@compuserve.com. 

Mail PsL at P.O. Box 35705, Houston, TX 77235 USA

THE ABOVE PHONE NUMBERS ARE FOR CREDIT CARD ORDERS ONLY. Surflogic LLC cannot be reached at 
the numbers listed above, and you will not be able to receive product information or support by calling PsL.

The following information is required for your order:

Product Code:       14476
User Name:          _____________________________________
E-mail Address:     _____________________________________

Credit Card: [ ] MasterCard   [ ] VISA   [ ] AMEX   [ ] Discover
Credit Card Number: _____________________________________
Expiration Date:    _____________________________________
Name On Card:       _____________________________________
Billing Address:    _____________________________________
                    _____________________________________
                    _____________________________________

Any questions about the status of the shipment of an order, refunds, registration options, product details, technical 
support, volume discounts, dealer pricing, site licenses, etc., must be directed to Surflogic LLC, 293 Downey 
Street, San Francisco, CA, 94117 USA, or by email to sales@surflogic.com.



What's an Agent?

An Agent is software program that acts on your behalf to save you time and effort. Surfbot Agents find, retrieve 
and filter collections of Web pages and return them to you in a variety of report styles. Surfbot Agents reside on 
your computer, and connect to Internet servers and Web sites to find information.



realm name

A realm is a name of the protected space on a Web server. Realm names are not necessarily the same as the 
Internet address of a Web site. For example, the realm for http://www.hotwired.com/ is Hotwired! (including the 
exclamation point).



Uniform Resource Locator

An address to an Internet site typically starts with a protocol name followed by the organization that maintains the 
site; the suffix identifies the kind of organization. For example, "http://www.yale.edu" identifies the web server at 
Yale University. "http://www" indicates that it is a web server, and ".edu" identifies Yale as an educational 
institution. Generally, commercial site addresses end with .com, and government site addresses end with .gov. 

If the address goes to a specific page, additional information, such as a port name, the directory in which the page 
is located, and the name of the page file is included. Web pages that are authored using HTML (hypertext mark-up 
language) often end with an .htm or .html extension. 



proxy server

A proxy server acts as a security barrier between your internal network and the Internet, keeping others on the 
Internet from accessing confidential information on your internal network and filtering all requests to and from the 
Internet.

The format for this address is the machine name or IP address, for example surflogic.com or 198.151.175.1. (No 
protocol is required, e.g. http://)
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File menu commands

The File menu manages Agents, and provides Wizards for creating and publishing your Agents:

New Creates a new Agent.

Open Opens an existing Agent.

Agent Wizard Invokes the Agent Setup Wizard to assist you in creating a new Agent.

Save Saves an opened Agent using the same file name.

Save As Saves an opened Agent to a specified file name.

Package As Invokes the Package Agent Wizard to assist you in creating a portable 
Agent for others to use.

Unpack Agent Unpacks the current Agent and its contents

Exit Exits Surfbot.



Edit menu commands

The Edit menu offers commands to manipulate items selected in the Contents pane:

Cut Deletes data from the document and moves it to the clipboard.

Copy Copies data from the document to the clipboard.

Paste Pastes data from the clipboard into the document.

Delete Deletes data from the document without affecting the contents of    the clipboard

Open Selection Opens the currently selected item in your browser

Explore Selection Explores all of the links on the currently selected page, retrieving items linked to the current 
page

Export As Exports the current item, and its children, as an HTML document or folder of Internet 
Shortcuts



View menu commands

The View menu provides commands to control the layout of the screen and change the settings of your Agent and 
the Surfbot program:

Toolbar Shows or hides the toolbar.

Address Bar Shows or hides the address bar.

Status Bar Shows or hides the status bar.

Refresh Refreshes the view of the current Agent.

Program Options Displays Surfbot Program Options.



Agent menu

Start Agent Starts the current Agent.

Stop Stops the current Agent.

Settings Displays the current settings for the opened Agent.

Schedule Displays the schedule for the current Agent.

Last Report Opens the last report created by the current Agent.



Help menu commands

The Help menu offers the following commands, which provide you assistance with Surfbot: 

Help Topics Offers you an index to topics on which you can get help.

Online Help Provides a link to the online documentation at the 
Surflogic LLC Web site.

Register Displays a dialog to enter your user name and 
registration key.

About Displays the version number of this program.



New command (File menu)

Use this command to create a new Agent in Surfbot.

You can open an existing Agents with the Open command.

Shortcuts

Keys: CTRL+N



Open command (File menu)

Use this command to open an existing Agent in a new window.

You can create new documents with the New command.

Shortcuts

Keys: CTRL+O



File Open dialog box

The following options allow you to specify which file to open:

File Name

Type or select the filename you want to open.    This box lists files with the extension you select in the List Files 
of Type box. 

Drives

Select the drive in which Surfbot stores the file that you want to open. 

Directories

Select the directory in which Surfbot stores the file that you want to open.

Network...

Choose this button to connect to a network location, assigning it a new drive letter.



Agent Wizard

Use this command to step through the process of creating an Agent with the assistance of the Agent Setup 
Wizard.



Agent Setup Wizard

This Wizard will guide you through the process of creating a Surfbot Agent. You can use this Agent to monitor 
Internet locations or search by keyword. All of the options that you set in this Wizard are also available in the 
Agent Settings property sheet.

{button ,AL(`Settings',0,`',`')} Related Topics



Agent Setup Wizard 1 of 7

Your Agent will monitor locations in the form of URLs, or perform keyword searches using the indexed information 
generated by Internet search engines. 

To edit locations:

1 Select the source of the locations you’d like to monitor. The source can be a single URL, or a file or folder of 
URLs stored on your hard disk.

2 Edit the locations in the box provided, or click the Browse button to find a file or folder on your disk.

To edit keywords:

1 Click the Internet search radio button.

2 Enter the keywords in the box provided.

3 For advanced settings, click the Search Engines button.

{button ,AL(`Settings',0,`',`')} Related Topics



Agent Setup Wizard 2 of 7

You control how much data to report in Content retrieval. Agents can retrieve the time and date of a Web page, 
prepare a text preview (of any length), or retrieve the complete page, with or without images and other linked data.

{button ,AL(`Settings',0,`',`')} Related Topics



Agent Setup Wizard 3 of 7

Select Date highlighting if you want your Agent to mark changed Web pages. This option, when combined with the 
Discard unchanged pages filter, limits your reports to changed Web pages only. 

Use Filters to instruct your Agent to disregard unchanged pages, duplicates or pages without dates. 

Note:

n Some Web servers don’t report the time and date when a Web page was modified. If you check the option to 
Discard pages with unknown dates, Surfbot eliminates these pages. If you uncheck this option, Surfbot will mark 
these pages as unknown.

{button ,AL(`Settings',0,`',`')} Related Topics



Agent Setup Wizard 4 of 7

Automatic link exploration, or “Web crawling,”    is an option that tells your Agent to follow each of the links it finds 
on a page, and retrieve these new pages according to the current Agent settings. For example, if your Agent 
monitors a home page such as http://www.surflogic.com/, this option will retrieve this location, and all of the other 
pages linked to the Surflogic LLC home page.

{button ,AL(`Settings',0,`',`')} Related Topics



Agent Setup Wizard 5 of 7

Surfbot includes a variety of built-in report styles, from the text Quickview built into Surfbot to full HTML reports, 
including graphics. Choose the report style from the radio buttons in this list:

n QuickView report 

n Internet Shortcuts report 

n Single HTML file report

n Multiple HTML files report 

n Netscape 2.x frame set report

{button ,AL(`reports',0,`',`')} Related Topics



Agent Setup Wizard 6 of 7

Enter a name for the report in the box provided. Your Agent will use this name for the first page of your report, and 
store any other downloaded files in a folder by the same name.

By default, Surfbot replaces the report each time your Agent runs, but you can choose to create new versions of 
the report. Surfbot will distinguish each time-stamped report by adding a date to the report title.



Agent Setup Wizard 7 of 7

To start your the Agent you just created, check the box provided and click Finish.



Package As

Use the Package As command to invoke the Package Agent Wizard, which steps you through the process of 
creating an Agent for others to use.

Use this Wizard to create a stand-alone, freely-distributable Agent for others to use. The Package Agent Wizard 
imports your Agent’s links, schedules, and settings and lets you add a description, author’s name, and company 
to the Agent.



Package Agent Wizard

Use this Agent to create a stand-alone, freely-distributable Agent for others to use. The Package Agent Wizard 
imports your Agent’s links, schedules, and settings and lets you add a description, author’s name, and company 
to the Agent.

{button ,AL(`agents',0,`',`')} Related Topics



Package Agent Wizard 1 of 3

Enter a short description of this Agent. This text appears in each report created by this Agent, and is also 
displayed in the Surfbot QuickView pane.

{button ,AL(`agents',0,`',`')} Related Topics



Package Agent Wizard 2 of 3

Enter your name/e-mail address and organization if you you’d like to include these with your Agent. This 
information 

{button ,AL(`agents',0,`',`')} Related Topics



Package Agent Wizard 3 of 3

Choose a name for your Agent. This name will be used for the file name, and will appear in each report created by 
this Agent. If you don’t want other users to be able to modify this Agent, clear the Allow users to unpack this Agent 
checkbox.

{button ,AL(`agents',0,`',`')} Related Topics



Unpack Agent

Unpacks a published Agent    so you can Edit the Agent’s locations, settings, or schedule. Disabled if the Agent’s 
author has protected the Agent from unpacking, or if the Agent is not currently packaged.

{button ,AL(`agents',0,`',`')} Related Topics



Unpack Agent dialog

Unpacks a published Agent    so you can Edit the Agent’s locations, settings, or schedule. Disabled if the Agent’s 
author has protected the Agent from unpacking, or if the Agent is not currently packaged.

{button ,AL(`agents',0,`',`')} Related Topics



Save command (File menu)

Use this command to save the active document to its current name and directory. When you save a document for 
the first time, Surfbot displays the Save As dialog box so you can name your document. If you want to change the 
name and directory of an existing document before you save it, choose the Save As command.

Shortcuts

Keys: CTRL+S



Save As command (File menu)

Use this command to save and name the active document. Surfbot displays the Save As dialog box so you can 
name your document. 

To save a document with its existing name and directory, use the Save command.



File Save As dialog box

The following options allow you to specify the name and location of the file you're about to save:

File Name

Type a new filename to save a document with a different name.    A filename can be of any length, although 
some require 8 character file names.    Surfbot adds the extension you specify in the Save File As Type box.

Drives

Select the drive in which you want to store the document.

Directories

Select the directory in which you want to store the document.

Network...

Choose this button to connect to a network location, assigning it a new drive letter. 



1, 2, 3, 4 command (File menu)

Use the numbers and filenames listed at the bottom of the File menu to open the last four Agents you used.    
Choose the number that corresponds with the document you want to open.



Exit command (File menu)

Use this command to end your Surfbot session. Surfbot prompts you to save documents with unsaved changes.

Shortcuts

Mouse: Double-click the application's Control menu button.

Keys: ALT+F4



Cut command (Edit menu)

Use this command to remove the currently selected data from the document and put it on the clipboard.    This 
command is unavailable if there is no data currently selected.

Cutting data to the clipboard replaces the contents previously stored there.

Shortcuts

Keys: CTRL+X



Copy command (Edit menu)

Use this command to copy selected data onto the clipboard. This command is unavailable if there is no data 
currently selected.

Copying data to the clipboard replaces the contents previously stored there.

Shortcuts

Keys: CTRL+C



Paste command (Edit menu)

Use this command to insert a copy of the clipboard contents at the insertion point. This command is unavailable if 
the clipboard is empty.

Shortcuts

Keys: CTRL+V



Delete command (Edit menu)

Deletes the currently selected item, without affecting the contents of the clipboard.



Open Selection

Opens the currently selected item in the default browser, either your Web browser or the Windows Explorer.



Explore Selection

Use this command to explore the links on a selected page, following each link. Surfbot will follow each link, and 
retrieve the pages according to the options you checked in Agent Settings.

As you “drill down” through Web pages, you can delete items you don’t want to see, and Export an part of the tree 
from the Export As menu. You can use the locations in the exported file as the source for a new Agent.



Export As

Exports the currently selected item, and all of its children, either as an HTML document or a folder of Internet 
Shortcuts.

{button ,AL(`agents',0,`',`')} Related Topics



Export Dialog

Exports the currently selected item, and all of its children, either as an HTML document or a folder of Internet 
Shortcuts.

{button ,AL(`agents',0,`',`')} Related Topics



Toolbar command (View menu)

Use this command to display and hide the Toolbar, which includes buttons for some of the most common 
commands in Surfbot, such as File Open. A check mark appears next to the menu item when the Toolbar is 
displayed.



Address Bar command (View menu)

The Address Bar is displayed beneath the too bar and toolbar provides quick access to the locations and settings 
used by your Agent.

To hide or display the Address Bar, choose Address Bar from the View menu.



Status Bar command (View menu)

Use this command to display and hide the Status Bar, which describes the action to be executed by the selected 
menu item or depressed toolbar button. A check mark appears next to the menu item when the Status Bar is 
displayed.

See Status Bar for help on using the status bar.



Refresh

Refreshes the view of the open Agent, redisplaying the Contents pane based on the current input source.

Shortcuts

Keys: F5



Program Options

Displays a property sheet with the Surfbot options: Connection, Passwords, Search Engines, Proxy and General.

{button ,AL(`Program options',0,`',`')} Related Topics



Program Options: Connection

For help on setting up a modem connection, see Connecting using Dial-Up Networking .

Connections

Surfbot is a multithreading program that uses multiple connections to retrieve Web pages. If you have a fast 
machine, with a fast connection to the Internet, you may want to increase the default setting of 5 connections. Use 
the default setting if you connect using the modem.

{button ,AL(`Program options',0,`',`')} Related Topics



Program Options: Login As

Enter your user name and password in the spaces provided. These should be the settings you use to access your 
Internet service provider.



Program Options: Search Engines

Check the names of the search engines you want to use for Agents that perform Internet searches. If an item is 
checked, then it will be used for each Internet search. If unchecked, it will not be used. 

These settings are program-wide, so if you change a setting for one of your search engines, all unpackaged 
Agents will use the new settings.

To delete or modify an entry, select the name of the search engine in the list, and click the appropriate button. For 
help on adding a new search engine, see Program Options: Add Search Engine .

{button ,AL(`Program options',0,`',`')} Related Topics



Program Options: Add Search Engine

You can customize Surfbot to store settings for any Internet Search engine. The format that Surfbot uses for 
search engines is:

Title

A display name for the search engine

Location

The URL for the search engine

Query

The sequence of parameters that this search engine accepts.

In the query segment, Surfbot replaces the sequence %KEY with the keywords that you enter in the Address Bar. 
The other parameters are specific for each search engine, and are kept up to date in documentation maintained at 
the Specter Web site.

{button ,AL(`Program options',0,`',`')} Related Topics



Program Options: Proxy

For information regarding proxy or firewall configuration, see Using Surfbot with a proxy server .

{button ,AL(`Program options',0,`',`')} Related Topics



Program Options: Bypass Proxy

This dialog provides a space for you to type the names of computers, domains, and ports on the Internet that you 
can gain access to without going through the proxy server. Separate each item you type with a comma.

For example, if you type microsoft.com,:80, you can gain access to computers inside the microsoft.com domain 
and to computers on port 80, without going through the proxy server.

This option is useful if you want to access Internet servers that are located on your local area network.

{button ,AL(`Program options',0,`',`')} Related Topics



Program Options: Passwords

For step-by-step procedures regarding authentication, see Accessing password protected sites. 

{button ,AL(`Program options',0,`',`')} Related Topics



Program Options: Add Password

This dialog provides a space for you to enter the realm name, user name and password for protectdd sites that 
you access.

For step-by-step procedures regarding authentication, see Accessing password protected sites. 

{button ,AL(`Program options',0,`',`')} Related Topics



Program Options: General

For instructions on configuring your Web browser, see Choosing your Web browser.

{button ,AL(`Program options',0,`',`')} Related Topics



Start Agent

Starts the current Agent, retrieving the locations listed in the Contents pane.



Stop

Halts the current Agent and prepares a report based on the information retrieved. It may take a few moments to 
stop an Agent, since Surfbot has to close each connection and format the previously-retrieved information.



Agent Settings

Displays a property sheet with the current Agent’s settings:

Agent Settings: Locations 

Agent Settings: Retrieval options 

Agent Settings: Report 

{button ,AL(`Settings',0,`',`')} Related Topics



Agent Settings: Locations

Locations to monitor

Your Agent will monitor locations in the form of URLs, or perform keyword searches using the indexed information 
generated by Internet search engines. 

To edit locations:

1 Select the source of the locations you’d like to monitor. The source can be a single URL, or a file or folder of 
URLs stored on your hard disk.

2 Edit the locations in the box provided, or click the Browse button to find a file or folder on your disk.

To edit keywords:

1 Click the Internet search radio button.

2 Enter the keywords in the box provided.

3 For advanced settings, click the Search Engines button.

Link exploration

Automatic link exploration, or “Web crawling,”    is an option that tells your Agent to follow each of the links it finds 
on a page, and retrieve these new pages according to the current Agent settings. For example, if your Agent 
monitors a home page such as http://www.surflogic.com/, this option will retrieve this location, and all of the other 
pages linked to the Surflogic LLC home page.

{button ,AL(`Settings',0,`',`')} Related Topics



Agent Settings: Retrieval options

Content retrieval

You control how much data to report in Content retrieval. Agents can retrieve the time and date of a Web page, 
prepare a text preview (of any length), or retrieve the complete page, with or without images and other linked data.

Date highlighting

Select Date highlighting if you want your Agent to mark changed Web pages. This option, when combined with the 
Discard unchanged pages filter, limits your reports to changed Web pages only. 

Filters

Use Filters to instruct your Agent to disregard unchanged pages, duplicates or pages without dates. Your Agent 
will only discard unchanged pages if you’ve turned on date highlighting.

Note:

n Some Web servers don’t report the time and date when a Web page was modified. If you check the option to 
Discard pages with unknown dates, Surfbot eliminates these pages. If you uncheck this option, Surfbot will mark 
these pages as unknown.
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Agent Settings: Report

Report style

Surfbot includes a variety of built-in report styles, from the text Quickview built into Surfbot to full HTML reports, 
including graphics. Choose the report style from the radio buttons in this list:

n QuickView report 

n Internet Shortcuts report 

n Single HTML file report

n Multiple HTML files report 

n Netscape 2.x frame set report

Enter a name for the report in the box provided. Your Agent will use this name for the first page of your report, and 
store any other downloaded files in a folder by the same name.

By default, Surfbot replaces the report each time your Agent runs, but you can choose to create new versions of 
the report. Surfbot will distinguish each time-stamped report by adding a date to the report title.
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Schedule

Displays a property sheet with the current Agent’s schedule.



Agent Schedule

Surfbot includes a built-in scheduler so you can easily schedule Agents for automated delivery.

1 Open the Surfbot Agent you wish to schedule, click the Agent menu, and then click Schedule. 

2 Check the box marked Schedule this Agent, and then fill in the frequency and time for your Agent to run.

3 If you want your Agent to automatically open the report in your Web browser, check the Open report when 
finished box.

4 Save your changes.

Tips:

n If you use the modem to connect to the Internet, be sure that your Dial-Up Networking options have been 
properly established in the Surfbot Program Options.

n For instructions on scheduling a report with the System Agent, see Running an Agent from the System Agent .

n If you plan to run Agents overnight, be sure to keep your computer running.
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Last Report

Opens the most recent report created by the current Agent, if any. A report is usually an HTML file stored on your 
disk.



Status Bar

The status bar is displayed at the bottom of the Surfbot window.    To show or hide the status bar, use the Status 
Bar command in the View menu.

The left area of the status bar describes actions of menu items as you use the arrow keys to navigate through 
menus.    This area similarly shows messages that describe the actions of toolbar buttons as you depress them, 
before releasing them.    If after viewing the description of the toolbar button command you wish not to execute the 
command, then release the mouse button while the pointer is off the toolbar button.

The right areas of the status bar indicate the progress of your Agent as it retrieves information from the Web and 
provides a counter of the documents to retrieve.



Help Topics    command (Help menu)

Use this command to display the opening screen of Help. From the opening screen, you can jump to step-by-step 
instructions for using Surfbot. 

Once you open Help, you can click the Contents button whenever you want to return to the opening screen.



Online Help

Surflogic LLC maintains additional product information at our World Wide Web site. Our Web address is 
http://www.surflogic.com/ Choosing Online Help from the Help menu will open your browser and take you to the 
online documentation at the Surflogic Web site.



Register

Displays a dialog to enter the user name and registration key you obtained from Surflogic.



About command (Help menu)

Use this command to display the copyright notice and version number of your copy of Surfbot.



About Surfbot

Displays the copyright notice and version number of your copy of Surfbot.



Context Help command 

Use the Context Help command to obtain help on some portion of Surfbot.    When you choose the Toolbar's 
Context Help button, the mouse pointer will change to an arrow and question mark.    Then click somewhere in the 
Surfbot window, such as another Toolbar button. The Help topic will be shown for the item you clicked.

Shortcut

Keys: SHIFT+F1



No Help Available

No help is available for this area of the window.



No Help Available

No help is available for this message box.




