
You have two options to create topic files for Windows Help: you can use Word 
for Windows and enter all the Help-specific coding and information manually, or 
you can use Microsoft Help Author and enter the information in dialog boxes. 
Help Author clearly makes creating Help files simpler and easier. 

This chapter explains how to use the Help Project Editor to create Help project 
files and to build Help files. It also describes the Windows Help Authoring 
Templates and explains how to use them to create topic files.

Note

The Help Author tools do not replace an understanding of the 
authoring process; they simply make it easier for you to perform many 
routine tasks used in creating Help files. To learn how to create a Help 
file using Help Author, see Chapter 2, “Getting Started with Help 
Authoring.” To learn how to use all the features in Help Author, keep 
reading this chapter, and refer to the other chapters in this authoring 
guide when you need to understand a particular Help feature.

Microsoft Help Author is an enhancement utility that makes it 
easier to create Help files for Windows versions 3.0 and 3.1. 
Help Author provides a way to do the most common Help tasks 
quickly and easily. 

Help Author divides the authoring process into two feature 
sets: the Help Project Editor and the Help Authoring Templates. 

The Help Project Editor makes it easy for you to:

n Create and edit Help project files.

n Add topic files to the project.

n Define and edit project file information.

n Compile Help files from Windows.

n Display error messages resulting during the build.

Using Help Author

______________________________________________________ Chapter 5

About Help 
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n View the built Help file.

The Help Authoring Templates modify Word for Windows so that you can easily:

n Create and edit Help topic files.

n Insert and edit topics, graphics, and hot spots.

n Format topic text and graphics.

n Save topic files in RTF format.

n View partial topic builds in Windows Help.

To install and use Help Author, you must have Windows 
version 3.0 or 3.1. Word for Windows version 1.1 or 
version 2.0 is highly recommended. If you do not have 
Word for Windows, please read the next section, 

“Installing Help Author Without Word for Windows,” to find out how to proceed.

To install Help Author on your hard disk drive

1. Insert the Microsoft Help Author Setup Disk into drive A.
2. From the File menu in Program Manager, choose Run.
The Run dialog box prompts you for a path and filename.
3. Type a:\setup.exe and choose OK.
The Welcome dialog box prompts you to select the files to install. The 
default selection is to install all the Help Author tools and the sample 
files.
4. Choose Continue. Or, if you do not want to install one of the tool sets 
or the sample files, clear its check box and then choose Continue.
If you select the Windows Help Project Editor check box, you are 
prompted for the directory where Help Author will be installed. The 
default path and directory is C:\HELPAUTH.
5. Choose Continue to accept the default directory. Or, to install the 
Help Author files in a different directory, use the BACKSPACE key to 
erase the default directory and type a new directory and path in the text 
box. Then choose Continue.
If you selected the Windows Help Authoring Templates check box in 
step 4, you are prompted to enter the path for Word for Windows. The 

Installing Help Author
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path can be either a local path (hard disk drive) or a network path. If 
you don’t have Word for Windows, you cannot install the Help 
Authoring Templates. In this case, please read “Installing Help Author 
Without Word for Windows.
Help Author supports Microsoft Word for Windows version 1.1x and 
2.0. The setup program installs the correct templates, depending on 
which version of Word for Windows it finds in the directory you 
specify. The version 1.1 Word for Windows templates do not have the 
toolbar icons but do have the same keyboard equivalents as the version 
2.0 templates. If you upgrade from Word for Windows 1.1 to 2.0, you 
must reinstall the Help Authoring Templates.
6. Ensure that the directory given in the text box is the one where you 
installed Word for Windows, and then choose Continue. If the given 
directory does not contain Word for Windows, use the BACKSPACE 
key to erase the current path. Type a new directory and path in the text 
box, and then choose Continue.
The setup program copies files and then creates a group in Program 
Manager for Help Author. A dialog box informs you that the installation 
is complete. Or, if necessary, a dialog box prompts you to restart 
Windows to complete the installation. In that case, choose Exit to quit 
the setup program and restart Windows. After Windows restarts, you 
can begin using Help Author.

Installing Help Author Without Word for Windows

If you do not have Microsoft Word for Windows, you can still use Help Author 
with any other editor that supports rich text format (RTF). You may also use it 
with any text editor, such as Notepad, to edit your Help project file and topic files 
by hand.

To install Help Author without Word for Windows

1. Insert the Microsoft Help Author Setup Disk into drive A.
2. From the File menu in Program Manager, choose Run.
The Run dialog box prompts you for a path and filename.
3. Type a:\setup.exe and choose OK.
The Welcome dialog box prompts you to select the files to install. The 
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default selection is to install all the Help Author tools and the sample 
files.
4. Clear the check box for the Windows Help Authoring Templates and 
choose Continue.
You are prompted for the directory where Help Author will be installed. 
The default path and directory is C:\HELPAUTH.
5. Choose Continue to accept the default directory. Or to install the 
Help Author files in a different directory, use the BACKSPACE key to 
erase the default directory and type a new directory and path in the text 
box. Then choose Continue.
The setup program copies files and then creates a group in Program 
Manager for Help Author. A dialog box informs you that the installation 
is complete. Or, if necessary, a dialog box prompts you to restart 
Windows to complete the installation. In that case, choose Exit to quit 
the setup program and restart Windows. After Windows restarts, you 
can begin using Help Author.
Now, follow the steps in the “Getting Started” section below. In step 4, 
you will be prompted to give the program you want to use to edit your 
RTF files. The default editor is NOTEPAD.EXE. Choose OK to edit 
your RTF files with Notepad. Or use the BACKSPACE key to erase the 
default editor and type a new editor in the text box. Or choose the 
Browse button to select an editor from a list box.

After you install the files on your hard disk drive, you can begin using 
Help Author. To use Help Author you simply choose menu commands 
and complete the dialog box options. Each option corresponds to a 
specific part of the authoring process. Although there is no fixed 
method for using Help Author, you can follow these general steps to 
get started.

1. Open the Help Author group in Program Manager and double-click 
the Help Project Editor icon.
2. Enter project information (Edit Project command).
3. Add topic files to the project (Add New Or Existing File command).
4. Edit the topic files (add text, graphics, and so on.) to create the 
content for the Help file (Edit File command).
Note     Because Windows Help versions 3.0 and 3.1 differ 
considerably, Microsoft provides a separate template for each version. 
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If you plan to create a Help system that uses Help version 3.1 features, 
use the 3.1 template (WHAT31.DOT). Otherwise, use the 3.0 template 
(WHAT30.DOT) as the authoring template. If you use the 3.1 template, 
your Help file will not work in Help version 3.0. When creating topic 
files, Help Author assigns the appropriate template based on your 
selection in the Project dialog box.
5. Save the topic files and close your editor. The Help Authoring 
Templates always save your documents in rich text format.
6. Define the Help build options (Edit menu commands).
7. Save the Help project file (Save or Save As command).
8. Build the Help file (Start command).
9. View the built Help file (Run Help On command).

10. Fix errors and make revisions, then rebuild the Help file.

Getting Help

The rest of this chapter explains both the Help Project Editor and the Help 
Authoring Templates in detail. If you have questions, refer to the appropriate 
section of this chapter. You can also complete the walkthrough in the following 
section to learn how to use Help Author. However, if you would rather get started 
using the software, both the Help Project Editor and the Help Authoring 
Templates have Help files that explain how to use their features. You can refer to 
the Help files on your computer rather than looking for the information in this 
guide.

To get Help on the Help Project Editor

1. Choose the menu command you want to learn about.
2. When the dialog box appears, choose the Help button.
You can also choose Contents from the Help menu in the Project Editor 
window (or press F1) and choose a topic from the Contents.

To get Help on the authoring templates in Word for Windows 1.1

1. Open the Help Author group window in Program Manager.
2. Double-click the Help On WHAT icon.
3. Choose a topic from Contents.
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To get Help on the authoring templates in Word for Windows 2.0

1. Open or create a topic file based on an authoring template.
2. From the Help menu in Word for Windows, choose the Help On 
WHAT command.
3. Choose a topic from Contents.

Windows Help Project Editor (WHPE) is 
the part of Microsoft Help Author that you 
use to create and edit Help project files 
and to compile Help files from within 

Windows. The Help Project Editor makes creating Help files easier for Help 
authors.

When you create a Help project file, you generally follow these steps:

n Enter project information

n Add the topic files to the project

n Specify Help project options

n Save your work

n Compile the Help file

n View the built Help file

Note     Although the Help Project Editor makes it much easier to create and edit 
Help project files, it does not directly support every option available in Windows 
Help version 3.1. The following sections describe the features that it does support. 
If you want to use a feature not supported directly by the Help Project Editor, you 
should use Word for Windows or another text editor to open the Help Project file 
and add the features you want. You can still use the Help Project Editor after that, 
and it will not change any of the features you add. (For detailed information on all 
the 3.1 Help Project file features, refer to Chapter 16, “The Help Project File.”)

Windows Help Project Editor
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The Help Project Editor Window

The Help Project Editor’s main window displays a list of topic files (.RTF) for the 
current project. Topic files are listed relative to the directory where the Help 
project file resides. Double-clicking a file in the list starts your RTF editor and 
opens that topic file so you can edit it.

When you first start the Help Project Editor, a blank, untitled Help Project Editor 
window opens. You create and edit the Help project file in the workspace in this 
window (Figure 5.1).

Graphic

The Help Project Editor Menus

The Help Project Editor has three menus: File, Edit, and Compile.

The File Menu

The File menu contains the following commands.

Command Description

New Project Creates a new, untitled project in the Help Project Editor 
window. The Help Project Editor lets you save changes to 
the current Help project file before opening a new project.

Open Help Project Opens an existing Help project file.

When you choose this command, the Help Project Editor 
lets you save changes to the current Help project file before 
opening a new project.

If opening the Help project file creates any warnings or 
errors, the Help Project Editor displays the errors and 
warnings in the View Errors window.
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Note     If the Help project file was created and saved using 
the Help Project Editor, it will not produce any errors.

Save Project Saves changes to the current Help project file.

If the Help project file is untitled, the Help Project Editor 
prompts you for a name.

Save Project As Saves the current Help project file under a new name.

Run Help On filename Starts Windows Help and opens the latest build of the 
current Help project file.

If the Help file did not build correctly, Windows Help 
displays an error message: either “File not found” or “Help 
file damaged. Rerun setup.”

If the current project is a new, untitled Help project file, 
this command is dimmed.

Exit Exits the Help Project Editor and closes the current Help 
project file.

If a project is currently open and has been edited, the Help 
Project Editor prompts you to save changes before closing 
the project.



   5-9

The Edit Menu

The Edit menu contains the following commands.

Command Description

Add New Or Existing File Adds topic files to the current Help project.

Remove File Removes from the Help project file the currently selected 
file in the project window.

Edit File Starts your RTF editor, if it is not already running, and 
opens the file currently selected in the project window.

Project Displays a dialog box where you can edit project-level 
information, including the title of the file, the context ID 
for the Contents topic, and the Help compiler 
(HC30.EXE or HC31.EXE) to use for the build.

Comments Displays a dialog box where you can enter comments 
that will appear at the beginning of the Help project file.

Compression Displays a dialog box where you can set the level of 
compression to use during the build.

Application Contexts Displays a dialog box where you can map context IDs 
used for context-sensitive Help.

Graphics Displays a dialog box where you can enter a bitmap 
directory or list bitmaps to include in the build.
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Window Definitions Displays a dialog box where you can enter main and 
secondary window definitions. This command is 
available only if you are using the 3.1 Help compiler for 
the build.

The Compile Menu

The Compile menu contains the following commands.

Command Description

Start Starts compiling the current Help project and shows the 
progress of the build in an MS-DOS box.

If the current Help project file includes unsaved changes, 
the Help Project Editor prompts you to save the changes 
before it begins compiling.

View Errors Displays or hides the View Errors dialog box.

A check mark appears next to this command when the 
View Errors dialog box is visible.

If you choose the View Errors command when you are not 
compiling, the Help Project Editor displays the errors from 
the most recent build of the current Help project, even if 
the build occurred in a previous session.
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Creating a New Help Project File

To create a new Help project file

n From the File menu, choose New Project.

Opening an Existing Help Project

You can open any Help project file, whether you used the Help Project Editor to 
create it or not.

To open a Help project file

1. From the File menu, choose Open Help Project.
The Open Help Project dialog box appears.
2. If the file is on a different drive, select the drive you want from the 
Drives box.
If the drive to which you want to change does not appear in the Drives 
box, it may be a network drive to which you are not connected. Connect 
to the drive, and then use this dialog box option.
3. In the Directories box, double-click the directory you want.
Or press the UP ARROW or DOWN ARROW key to select the directory, and 
then press ENTER.
The current directory initially is the same directory as the currently 
selected file in the Help Project Editor window.
4. In the File Name box, double-click the name of the file you want to 
open.
Or select the file, and then choose OK. (The default extension is .HPJ, 
so initially only files of that type will appear in the list box.)
Or type the filename in the box, and then choose OK. You can enter a 
full path in this box, including drive and directories.

Editing Project Information

You can edit project-level information, including the title of the Help project file, 
the context ID for the Contents topic, and the version of the compiler to use for 
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the build.

To edit project information

1. From the Edit menu, choose Project.
The Project dialog box appears.
2. Type the title you want to give to the Help file.
This title appears in the title bar of the Help window when this Help file 
is opened.
Note     The Title box defines the TITLE option for the Help project 
file.
3. Type the context string of the topic you want to designate as the 
Contents for your Help file.
Note     The Contents box defines the CONTENTS option for the Help 
project file.
4. To create a Help file for Windows Help version 3.1, select the 3.1 
option button.
If you do not select this option button, the Help Project Editor assumes 
you are building a version 3.0 Help file. This selection also determines 
which authoring template Help Author will use to create and edit your 
topic files.
5. Choose OK.

Adding Topic Files to the Help Project

When you create a Help project file, you add all the topic files that you want 
included in the build of the Help file.

To add a topic file to the Help project file

1. From the Edit menu, choose Add New Or Existing File.
The Add New Or Existing File dialog box appears.
Note     The Add New Or Existing File command defines the [FILES] 
section of the Help project file.
2. If the file is on a different drive, select the drive you want from the 
Drives box.
If the drive to which you want to change does not appear in the Drives 
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box, it may be a network drive to which you are not connected. Connect 
to the drive, and then use this dialog box option.
3. In the Directories box, double-click the directory you want.
Or press the UP ARROW or DOWN ARROW key to select the directory, and 
then press ENTER.
The current directory initially is the same directory as the currently 
selected file in the Help Project Editor window.
4. In the File Name box, double-click the name of the file you want to 
add.
Or select the file, and then choose OK. (The default extension is .RTF, 
so initially only files of that type will appear in the list box.)
Or type the filename in the box, and then choose OK. You can enter a 
full path in this box, including drive and directories.
The new file is added at the end of the list of files in the Help Project 
Editor window. If the selected file does not exist, the Help Project 
Editor asks you if you want to create a new, untitled RTF topic file 
based on the currently selected authoring template. Choose OK to create 
the file, or Cancel if you don’t want to create the file.

Choosing an RTF Editor

When you install the Help Project Editor, it installs Word for Windows or the 
word processor of your choice as the RTF editor. The editor you choose is saved 
as an entry in the WIN.INI file. The Help Project Editor uses this entry to open 
your RTF editor when you choose the Edit File command. 

To specify an RTF editor

1. From the Edit menu, choose Edit File.
Or double-click the file you want to edit.
The Specify RTF Editor dialog box appears if the Help Project Editor 
cannot find Word for Windows on your path.
2. Type the name and path (including drive and directory) of the RTF 
editor you want to use.
Or choose the Browse button to find and select an RTF editor.
If you do not have Word for Windows, the Help Project Editor 
recommends using Notepad, the accessory text editor that comes with 
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Windows.
3. Choose OK.

The Help Project Editor saves your choice in the rtf= line in the [EXTENSIONS] 
section of the WIN.INI file.

Changing Your RTF Editor

If you want to change the RTF editor you are using after you have installed Help 
Author, you can do so using one of two methods:

n Use the Change button in the Help Project Editor Help file.

n Edit your WIN.INI file by hand and remove the current editor.

Using a Custom Macro to Change Your RTF Editor

Ordinarily, to change your default RTF editor you must edit the WIN.INI file and 
restart Windows. To save you that trouble, the Help Project Editor’s Help file 
contains a custom macro that does it for you.

To change your RTF editor using the custom Help macro

1. Open the Help Project Editor.
2. From the Help menu, choose Contents to open the Project Editor’s 
Help file.
Or press F1 to open the Help file.
3. Choose the topic “Changing Your Default RTF Editor” from the Help 
Contents screen.
4. Follow the instructions in the Help topic.

Changing Your RTF Editor by Hand

To change your default RTF editor by hand, you must edit the WIN.INI file.

To change your RTF editor by hand

1. Open the WIN.INI file in Notepad or some other text editor.
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2. Go to the [EXTENSIONS] section.
3. Delete the filename following the rtf= option and type the new name 
(and full path if necessary) of the RTF editor you want to use.
Or delete the entire rtf= line from the WIN.INI file.
4. Save the WIN.INI file, and then exit the text editor.
5. Restart Windows.
6. After restarting Windows, restart the Help Project Editor.
If you typed a new editor in the WIN.INI file, your editor is ready to 
use. If you deleted the rtf= entry, you will be prompted to specify a new 
RTF editor when you choose the Edit File command.

Editing Topic Files

You can edit any topic file without quitting the Help Project Editor.

To edit a topic file

1. Select the file you want to edit.
2. From the Edit menu, choose Edit File.
Or double-click the file.
The Help Project Editor starts your RTF editor and opens the file you 
selected.

Removing Topic Files from the Help Project

If you no longer want to include a topic file in a Help project, you can remove it 
from the list of files.

To remove a topic file from the Help project file

1. Select the file you want to remove.
2. From the Edit menu, choose Remove File.
Or press DEL or SHIFT+DEL.
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Specifying a Location for Bitmap Files

If you use graphics in your Help file, you can use the Help Project Editor to 
provide a list of bitmaps to include in the build or to define the directory where 
the Help compiler can find bitmap files referenced in the Help topic files.

To include bitmaps in the Help file

1. From the Edit menu, choose Graphics.
The Graphics dialog box appears.
2. In the Directory box, type the name and full path (if necessary) of the 
directory that contains the bitmap files.
Note     The Directory box defines the BMROOT option for the Help 
project file (version 3.1 only).
3. In the File Names box, type the name of each bitmap file, including 
the drive and path if necessary.
If you are using the 3.1 Help compiler for the build, you need only list 
the filenames of bitmaps not residing in the bitmap directory.
Note     The File Names box is the equivalent of the [BITMAPS] 
section of the Help project file.
4. Choose OK.

Cutting or Copying Bitmap Filenames

You can copy the bitmap names listed in this dialog box and paste them into 
another document or application.

To cut or copy text in the Graphics dialog box

1. Select the text in the Graphics dialog box that you want to cut or 
copy.
2. Choose the Cut button to cut text.
Or choose the Copy button to copy the text to the Clipboard.

Pasting Bitmap Filenames into the Graphics Dialog Box

If you have a text file that lists all the bitmaps in your Help project, you can paste 
them into this dialog box using the Paste button.
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To paste text from the Clipboard into the Graphics dialog box

1. Place in the Clipboard the text that you want to paste into the 
Graphics dialog box.
2. Choose the Paste button.

Specifying the Level of Compression

To reduce the size of the built Help file, you can specify the level of compression, 
or you can use no compression during the build.

To specify the level of compression

1. From the Edit menu, choose Compression.
The Compression dialog box appears.
2. Select the level of compression you want.

Select To specify

None No compression

Medium Medium compression (approximately 40 percent)

High High compression (approximately 50 percent)

If you are using the 3.0 Help compiler to build the file, the Medium 
compression option is dimmed.

Note     The Compression option buttons define the COMPRESS 
option for the Help project file.
3. If you want the Help compiler to use the keyphrase table from a 



   Microsoft Windows Help Authoring Guide

previous build of the Help file, select the Use Old Keyphrase File check 
box.
Use an existing keyphrase file to speed up the build process; to achieve 
maximum compression, however, don’t reuse the old keyphrase file.
The check box for using the old keyphrase file is dimmed unless the 
compression level is set to High.
Note     This check box defines the OLDKEYPHRASE option for the 
Help project file.
4. Choose OK.

Mapping Application Context IDs

If you are including context-sensitive Help as a feature of your Help system, you 
can use the Help Project Editor to map context IDs in the application to context 
IDs in your topic files.

The Application Contexts dialog box displays all the context ID numbers, Help 
context strings, and application context strings entered for the current Help 
project file.

Note     The Application Contexts dialog box defines the [MAP] and [ALIAS] 
sections of the Help project file.

To map context IDs
1. From the Edit menu, choose Application Contexts.
The Application Contexts dialog box appears.
2. Define the context ID mappings for this Help file (see the following 
section).
Or enter the context ID mappings from an existing text file.
3. If you are using hexadecimal ID numbers, select the Display 
Numbers In Hexadecimal check box.
4. To save the changes without closing the dialog box, choose the 
Define button.
Or choose OK to save the changes and close the dialog box.
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Defining New Context IDs

To define a new context ID

1. From the Edit menu, choose Application Contexts.
The Application Contexts dialog box appears.
2. From the list box, select New Context.
3. In the Context Number box, type a context number.
If you are using hexadecimal ID numbers, select the Display Numbers 
In Hexadecimal check box.
4. In the Help Context String box, type a context string.
5. Choose the Define button.

You can add new context IDs to the Help project file by hand using the Define 
button. However, context IDs entered by hand do not have an application context 
string. Help context strings and context ID numbers entered by hand are saved in 
this format:

[MAP]
Help_Context                 0xFF

Help context strings entered by hand do not use #define.

Updating Context IDs from a File

If you or the application developers create a file containing the application 
context IDs and ID numbers, you can read this information into the Help project 
file rather than entering it by hand. It is usually preferable to use this option to 
enter context IDs if the IDs are generated by developers and maintained in one of 
the application’s resource files (an .H file, for example). Also, context IDs entered 
from a file have an application context string.

Context IDs are entered or updated from a file in this way:

n If the application context string does not appear in the [MAP] section 
of the Help project file, the Help context string matches the 
application context string.

n If the application context string appears in the [MAP] section of the 
Help project file, only the context ID number is updated.

n If the [MAP] section of the Help project file contains application 
context strings that do not appear in the resource file, they are deleted 
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along with their associated Help context strings.

To enter or update context IDs from a file

1. From the Edit menu, choose Application Contexts.
The Application Contexts dialog box appears.
2. Choose the Update button.
The Update Contents From Application File dialog box appears.
3. If the file is on a different drive, select the drive you want from the 
Drives box.
If the drive to which you want to change does not appear in the Drives 
box, it may be a network drive to which you are not connected. Connect 
to the drive, and then use this dialog box option.
4. In the Directories box, double-click the directory you want.
Or press the UP ARROW or DOWN ARROW key to select the directory, and 
then press ENTER.
Windows displays the names of all files in that directory that are the 
type selected in the List Files Of Type box. To display a different type 
of file, select the type you want from the List Files Of Type box.
5. In the File Name box, double-click the name of the file that has the 
context IDs.
Or select the file, and then choose OK.
Or type the filename in the text box, and then choose OK. You can enter 
a full path in this box, including drive and directories.
The context IDs are displayed in the list box.

Application context strings, Help context strings, and context ID numbers entered 
or updated from a file are saved in this format:

[ALIAS]
APPLICATION_CONTEXT=Help_Context

[MAP]
#define APPLICATION_CONTEXT      0xFF

If the Help context string is the same as the application context string, the entry in 
the [ALIAS] section is omitted. The #define directive appears with the 
application context ID in the [MAP] section because the ID was entered from a 
file.
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Updating Context IDs from More Than One File

If the context IDs you are mapping to the Help file are contained in more than one 
file, you can use the #include directive to update from all the files.

To enter or update context IDs from more than one file

1. Create a file that contains all the files you want to use in the update.
You can use the #include directive to include the extra files.
2. From the Edit menu, choose Application Contexts.
The Application Contexts dialog box appears.
3. Choose the Update button.
4. Follow steps 3 through 5 above to open the resource file.

Editing Context IDs

You can edit context ID numbers and Help context strings. The Help Project 
Editor also displays application strings so that you can correctly map your Help 
context strings to the appropriate application context strings. You cannot, 
however, edit or modify an application context string.

To edit a context ID number or Help context string

1. From the Edit menu, choose Application Contexts.
The Application Contexts dialog box appears.
2. Select the context ID you want to edit.
Or select New Context to define a new context ID for the Help project 
file.
3. Type a new context ID number or edit the current context number 
shown in this box.
If you are using hexadecimal ID numbers, select the Display Numbers 
In Hexadecimal check box.
4. Type a new context string or edit the current context string shown in 
this box.
5. Choose the Define button.

Deleting Context IDs

You can delete any context IDs from the Help project file when they are no 
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longer necessary or valid.

To delete a context ID

1. From the Edit menu, choose Application Contexts.
The Application Contexts dialog box appears.
2. Select the context ID you want to delete.
3. Choose the Delete button.
The Help Project Editor will display a dialog box to confirm the 
deletion if the context ID is not part of a resource file.

Specifying Window Definitions

To create a secondary window for your Help file or to modify the way the main 
Help window appears, use the Help Project Editor to define the window 
characteristics for your Help file.

The Window Definitions dialog box includes all the attributes that you can 
specify for the main window or for any secondary windows that you create.

Note     The Window Definitions dialog box defines the [WINDOWS] section of 
the Help project file.

Defining the Main Window

To define the main Help window

1. From the Edit menu, choose Window Definitions.
The Window Definitions dialog box appears only if you are building a 
3.1 Help file.
2. In the Window Names box, select “main.”
The name “main” is dimmed in the Name box because you cannot 
change the name of the primary Help window.
3. In the Caption box, type the caption you want to appear in the main 
window’s title bar.
If you entered a title in the Project dialog box, that title appears in this 
dialog box as the window caption. You can edit the caption here or in 
the Project dialog box.
4. Specify a background color for the topic and nonscrolling areas, if 
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desired.
5. To change the position of the main Help window, select the Set 
Window Position check box.
The window position options for the main window are not available 
unless you select this check box.
6. Specify the size and position of the main window, if desired.
7. To save the changes without closing the dialog box, choose the 
Define button.
Or choose OK to save the changes and close the dialog box.

Defining a Secondary Window

To define a secondary window

1. From the Edit menu, choose Window Definitions.
The Window Definitions dialog box appears.
2. In the Window Names box, select New Window.
3. In the Name box, type the name you want to give to the secondary 
window.
The default name “new” appears in the Name box when you select a 
New Window class. You can edit this name or type over it.
4. To create the window definition, choose the Define button.
5. In the Caption box, type the caption you want to appear in the 
window’s title bar.
The default caption “New Window” appears in the Caption box when 
you select a New Window class. You can edit this name or type over it.
6. If you want the secondary window to stay on top of other windows 
while the user has this Help window open, select the Stay On Top check 
box.
7. Specify a background color for the topic and nonscrolling areas, if 
desired.
8. Specify the size and position of the secondary window.
9. To save the changes without closing the dialog box, choose the 
Define button.
Or choose OK to save the changes and close the dialog box.
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Specifying Background Colors

You can specify the background color for the main topic area and the 
nonscrolling region of a window.

To specify background colors

1. From the Edit menu, choose Window Definitions.
The Window Definitions dialog box appears.
2. In the Window Names box, select a window name.
3. From the Background Colors drop-down box, choose the color you 
want.
Or choose Other to pick a custom color from the Windows Color dialog 
box.
4. From the Nonscrolling Region drop-down box, choose the color you 
want.
Or choose Other to pick a custom color from the Windows Color dialog 
box.

An example of your selection for each background color appears in the display 
box to the left of the color box.

The default selection means that Windows Help will match the user’s default 
screen color.

Setting the Window’s Position

You can indicate the exact size and location of any Help window.

To set a window’s size and position

1. From the Edit menu, choose Window Definitions.
The Window Definitions dialog box appears.
2. In the Window Names box, select a window name.
3. To manually set the size and position of the main window, select the 
Set Window Position check box, and then use the simulated window. 
(For more information, see the following sections.)
If you are setting the position of a secondary window, the Set Window 
Position check box is automatically chosen for you.
Or define the window’s size and placement by typing the coordinates in 
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the four boxes to the left of the Window Position control area. The 
simulated window adjusts dynamically as you type.

Using the Window Sizer

The Window Position control area consists of two rectangles: the large rectangle 
represents your total screen area, and the inside rectangle represents the window 
you are defining. The sizing handles let you change the window size directly by 
using the mouse.

Moving the Window

To move the simulated window

1. Position the mouse pointer inside the window, and then press and 
hold down the mouse button.
2. Drag the window where you want it.
As you move the simulated window or change its size, the coordinates 
to the left show the exact coordinates of the window placement.

Resizing the Window

To resize the simulated window

n Drag a sizing handle in the direction you want to change the window.

As you move the simulated window or change its size, the coordinates 
to the left show the exact coordinates of the window placement.

Deleting Window Definitions

You can delete any secondary window definition that you create.

To delete a window definition

1. From the Edit menu, choose Window Definitions.
The Window Definitions dialog box appears.
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2. In the Window Names box, select the name of the window you want 
to delete.
The Delete button will dim if you select the “main” or the “New 
Window” class because you cannot delete those definitions.
3. Choose the Delete button.

Adding Comments to the Help Project File

You can add your own comments at the beginning of the Help project file. These 
comments are for your use only; during the build, the Help compiler ignores any 
comments you enter.

Note     The Comments dialog box has the same purpose as adding comments by 
hand to the Help project file using semicolons (;) or C-style comments (/* and */).

To add comments to the Help project file

1. From the Edit menu, choose Comments.
The Comments dialog box appears.
2. Type your comments.
If you want more space to view and enter your comments, you can 
change the size of the Comments dialog box by dragging its window 
borders. You can also maximize it. Any changes you make to the size or 
position of this dialog box are saved from session to session.
3. When you finish typing your comments, choose OK.

Cutting or Copying Comment Text

You can copy text from this dialog box and paste it into another document or 
application.

To cut or copy text in the Comments dialog box

1. Select the text in the Comments dialog box that you want to cut or 
copy.
2. Choose the Cut button to cut text.
Or choose the Copy button to copy the text to the Clipboard.
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Pasting Text into the Comments Box

If you have a text file that has some text you want to include as comments in the 
Help project file, you can paste it into this dialog box using the Paste button.

To paste text from the Clipboard into the Comments edit box

1. Place in the Clipboard the text that you want to paste into the 
Comments dialog box.
2. Choose the Paste button.

Saving Help Project Files

Use the Save Project command to save changes to an existing Help project file, 
and use the Save Project As command to save a new (untitled) Help project file or 
to rename the current file.

To save changes to an existing Help project file

n From the File menu, choose Save Project.

To save a new Help project file or save the current file under a 
different name

1. From the File menu, choose Save Project As.
The Save Project As dialog box appears.
2. To save the file on a different drive, select the drive you want from 
the Drives box.
If the drive to which you want to change does not appear in the Drives 
box, it may be a network drive to which you are not connected. Connect 
to the drive, and then use this dialog box option.
3. In the Directories box, double-click the directory in which you want 
to save the file.
Or press the UP ARROW or DOWN ARROW key to select the directory, and 
then press ENTER.
4. In the File Name box, type a name for the file.
The .HPJ extension is automatically assigned to the filename if you 
don’t specify an extension. If you type an extension, be sure that it 
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is .HPJ.
5. Choose OK.

Building the Help File

You can use the Help Project Editor to start the Help compiler and build Help 
files from within Windows. During the build, the Compilation in Progress 
window displays the progress of the build as it occurs in MS-DOS. 

The Help compiler automatically turns on the REPORT option and sets the 
WARNING level to full-reporting. (These options are normally entered by hand 
in the [OPTIONS] section of the Help project file.)

If you are using the 3.1 Help compiler for the build, the Help Project Editor uses 
the ERRORLOG option to save to a file the errors displayed on the screen. If 
you are using the 3.0 Help compiler for the build, the error output must be 
directed to a file; you will not see the error output during the build.

To start a build

n From the Compile menu, choose Start.

The Compilation in Progress window appears, showing the progress of 
the build and any errors that occur.

Viewing Error Messages

The View Errors window displays the error messages that occur during a build or 
upon opening a Help project file, if the Help Project Editor detects errors. The 
displayed errors are also written to a file with the same base name as the Help 
project file but with an .ERR extension. You can show or hide this window by 
using the View Errors command on the Compile menu.

To show the View Errors window

n From the Compile menu, choose View Errors.

The View Errors window appears and displays the error messages from 
the most recent build of the Help file. A check mark appears to the left 
of the command on the menu to indicate that the window is open.
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Once displayed, you can change the size and position of the View 
Errors window. The Help Project Editor saves your changes between 
sessions.

To hide the View Errors window

n From the Compile menu, choose View Errors.

The View Errors window closes.

Displaying a Project’s Help File

After you compile a Help file, you can use the Help Project Editor to start 
Windows Help and open the Help file of the current Help project.

To display the current project’s Help file

n From the File menu, choose Run Help On.

The Help Project Editor displays the Help file in Windows Help.
If the Help file did not build correctly, Windows Help displays an error 
message: either “File not found” or “Help file damaged. Rerun setup.” 
If that happens, check the View Errors window to see what error 
messages the compiler encountered during the build. When you are 
ready, try building the Help file again.

Quitting the Help Project Editor

To quit the Help Project Editor

n From the File menu, choose Exit.

Or choose Close from the Control menu.
Or double-click the Control-menu box.
If you are working on a Help project file and haven’t saved your 
changes, the Help Project Editor prompts you to save the file.
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The Windows Help 
Authoring 
Templates 
(WHAT30.DOT 
and 
WHAT31.DOT) 

are document templates that modify Word for Windows. You can use the Help 
Authoring Templates to create and edit Help topic files. The Help Authoring 
Templates make creating Help files easier by providing dialog boxes to add Help 
features that would normally be created using specialized Help coding and word-
processing functions. For example, instead of entering footnotes for a topic’s 
context string and title, you can simply type the information in a dialog box. (The 
process for entering topic-level information by hand is discussed throughout this 
book but primarily in Chapters 6 through 10.)

Note

The information in this section is based on Word for Windows 
version 2.0, but the authoring templates also work with version 1.1. If 
you are using Word for Windows version 1.1, some of the commands 
and authoring steps may vary slightly from what’s in this section.

How the Help Authoring Templates Work

The Help Authoring Templates are similar to other Word for Windows templates: 
they contain a set of specialized macros and styles that become available when 
you open a document based on the template. The templates modify existing 
commands and add new commands to the Word for Windows menus. The result 
is a version of Word for Windows that has all the original word-processing 
functionality and yet is optimized for creating Help files.

Because Windows Help version 3.1 offers more features than version 3.0, 
Microsoft provides a separate template for each version of Windows Help. If you 
plan to create a Help system that runs under Windows Help version 3.1, use the 
3.1 template (WHAT31.DOT). Help version 3.0 files, on the other hand, use 
WHAT30.DOT as the authoring template.

If you are using the Help Project Editor along with the Help Authoring 
Templates, the document template applied to your topic files is determined by 
two things: the version of Word for Windows you have installed on your hard 
disk drive and the version of Help you are using to build this Help file. Based on 

The Windows Help Authoring 
Templates
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those choices, the Help Project Editor automatically applies the correct template 
to your topic files when you edit them using the Help Project Editor.

Note

If you start a Help project using one version and then switch to 
another version (from version 3.0 to 3.1, for example), you will have to 
open the RTF files in the project and change the templates manually in 
Word for Windows (the Format Document command in version 1.1 or 
the File Template command in version 2.0).

The Template Macros

The Help Authoring Templates include macros that modify the functionality of 
Word for Windows to improve its use as a Help authoring tool. To make the 
macros easy to use, they have been attached to menu commands. The primary 
objective in creating the macros is to provide new Help authors and software 
developers a faster and better way to create Help files. 

However, the macros included represent the minimum set necessary for creating 
Help files. They do not provide a shortcut method for authoring every available 
feature, nor do they replace an understanding of Windows Help functionality and 
how to author without using the templates. For that reason, Help authors are 
encouraged to modify the existing macros and create new macros to meet their 
specific authoring requirements.

To use the macros, create a new Help topic file and base it on WHAT30.DOT or 
WHAT31.DOT. The macros are then available as menu commands. When using 
the macros, the templates attempt to restore Word for Windows to its state before 
the macro executed. If the window was split, for example, the template attempts 
to restore the split panes after running the macro.

The following table shows the complete list of macros included in the templates 
and the menu commands that activate them.

Macro function Attached to command

Create new topic file File New
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Open topic file File Open

Save topic file File Save

Save topic file with new name File Save As

Edit topic footnotes Edit Topic

Edit hot-spot information Edit Hot Spot

Edit bitmap reference Edit Graphic

Build current topic View Topic

Build topic file View File

Build current selection View Selection

Add new topic Insert Topic
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Insert jump or pop-up Insert Jump or Pop-Up Hot Spot

Insert Help macro Insert Macro Hot Spot

Insert bitmap reference Insert Graphic

The Template Style Sheet

The style sheet included with the Help Authoring Templates contains the standard 
styles Microsoft recommends for creating Help files. They are provided to enable 
Help authors to format all the text and graphic elements of a Help file without 
having to go through the time and effort of creating a style sheet from scratch. Of 
course, the existing styles can be modified and additional styles can be created if 
your Help system requires those changes. But these styles should provide a good 
starting place for any style sheet, no matter how sophisticated. 

The following table describes each style included in the style sheet.

Style Definition Used for

bitmap Font: MS Sans Serif (or Helv) 10 Point, Indent: Left 
6pt Flush left, Line Spacing Auto, Space Before 6 pt 
After 6 pt, Next style: Normal

Bitmaps that occur alone 
in a paragraph

Ex Font: Courier (or Letter Gothic) 8 Point, Indent: Left 
6pt Flush left, Line Spacing: Exactly 12 pt, Space 
Before 3pt, Keep Lines Together, Tab stops: 26pt; 
46pt; 66pt; 86pt; 106pt, Next style: Ex

Programming code 
examples and ASCII text
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heading 1 Font: MS Sans Serif (or Helv) 12 Point, Bold, 

Indent: Left 6pt Flush left, Line Spacing: Exactly 
16pt, Space Before 14pt, After 6pt, Next style: 
Normal 2

Topic titles

heading 2 Font: MS Sans Serif (or Helv) 10 Point, Bold, 
Indent: Left 6pt Flush left, Line Spacing: Exactly 12 
pt, Space Before 6pt After 3pt, Next style: Normal

Bold subheadings 
(procedures, notes, 
comments, hints, tips, 
and examples)

heading 3 Font: MS Sans Serif (or Helv) 10 Point, Indent: Left 
6pt Flush left, Line Spacing: Exactly 12 pt, Space 
Before 6pt After 3pt, Next style: Normal

Plain subheadings 
(procedures, notes, 
comments, hints, tips, 
and examples)

heading 4 Font: MS Sans Serif (or Helv) 10 Point, Indent: Left 
18pt First -12.25 pt Flush left, Line Spacing: 
Exactly 12 pt, Space Before 6pt After 3pt, Next 
style: Normal

Plain subheadings

Jl Font: MS Sans Serif (or Helv) 10 Point, Indent: Left 
18pt First -12 pt Flush left, Line Spacing: Exactly 
12 pt, Space Before 3pt, Next style: Jl

Lists of jumps

Jli Font: MS Sans Serif (or Helv) 10 Point, Indent: Left 
30pt First -12pt Flush left, Line Spacing: Exactly 12 
pt, Space Before 3pt, Next style: Jli

Indented lists of jumps

Lb1 Font: MS Sans Serif (or Helv) 10 Point, Indent: Left 
18pt First -12pt Flush left, Line Spacing: Exactly 12 
pt, Tab stops: 18pt, Next style: Lb2

The first item in a 
bulleted or numbered list

Lb2 Font: MS Sans Serif (or Helv) 10 Point, Indent: Left 
18pt First -12pt Flush left, Line Spacing: Exactly 12 
pt, Space Before 3pt, Tab stops: 18pt, Next style: 
Lb2

Succeeding items in a 
bulleted or numbered list

Lp1 Font: MS Sans Serif (or Helv) 10 Point, Indent: Left Paragraphs within a 
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18pt Flush left, Line Spacing: Exactly 12 pt, Space 
Before 3pt, Next style: Lb2

bulleted or numbered list

Normal Font: MS Sans Serif (or Helv) 10 Point, Indent: Left 
6pt Flush left, Line Spacing: Exactly 12 pt, Space 
Before 4pt, Next style: Normal

Body text

Normal 2 Font: MS Sans Serif (or Helv) 10 Point, Indent: Left 
6pt Flush left, Line Spacing: Exactly 12 pt, Next 
style: Normal

Paragraphs following 
topic titles

Normal3 Font: MS Sans Serif (or Helv) 10 Point, Indent: Left 
5.75pt Flush left, Line Spacing: Exactly 12 pt, Space 
Before 10pt, Next style: Normal

Table text

Normal 
Indent

Font: MS Sans Serif (or Helv) 10 Point, Indent: Left 
18pt Flush left, Line Spacing: Exactly 12 pt, Space 
Before 4pt, Next style: Normal

Indented paragraphs

Sa1 Font: MS Sans Serif (or Helv) 10 Point, Indent: Left 
6pt Flush left, Line Spacing: Exactly 12 pt, Space 
Before 8pt, Next style: Jl

“See Also” subheadings

Sa2 Font: MS Sans Serif (or Helv) 10 Point, Indent: Left 
6pt Flush left, Line Spacing: Exactly 12 pt, Space 
Before 6pt, Next style: Jl

Subheadings below “See 
Also” subheading

Th Font: MS Sans Serif (or Helv) 10 Point, Bold, 
Indent: Left 5.75pt Flush left, Line Spacing: Exactly 
12 pt, Space Before 6pt After 2pt, Border: Bottom 
(Single), Next style: Tp

Table heading

Th2 Font: MS Sans Serif (or Helv) 10 Point, Indent: Left 
5.75pt Flush left, Line Spacing: Exactly 12 pt, Space 
Before 6pt After 2pt, Border: Bottom (Single), Next 
style: Tp

Table heading, not bold

Th3 Font: MS Sans Serif (or Helv) 8 Point, Bold, Indent: Table heading, 8-pt  font
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Left 5.75pt Flush left, Line Spacing: Exactly 12 pt, 
Space Before 6pt After 2pt, Border: Bottom 
(Single), Next style: Tp

Tp Font: MS Sans Serif (or Helv) 10 Point, Indent: Left 
5.75pt Flush left, Line Spacing: Exactly 12 pt, Space 
Before 3pt, Next style: Tp

Paragraphs within two-
column lists and 
hanging-indent tables

The Help Authoring Template Commands

The Help Authoring Templates do not have their own menus. Instead, they make 
use of the existing menus in Word for Windows by either modifying the 
functionality of a standard command or by adding a new command to a standard 
menu. The Help Authoring Templates modify four menus: the File menu, the Edit 
menu, the View menu, and the Insert menu.

The File Menu

The authoring templates modify four commands on the standard Word for 
Windows File menu: New, Open, Save, and Save As.

Command Description

New Creates, new, untitled topic file or template.

When you create a new topic file, it is based on one of the 
Help Authoring Templates instead of the Word for 
Windows NORMAL.DOT default template.

Open Opens an existing Help topic file or template.

When you choose this command, the Help Authoring 
Templates assume the file type is .RTF rather than the 
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Word for Windows standard .DOC format.

Save Saves changes to the current Help topic file.

If the Help topic file is untitled, the Help Authoring 
Templates prompt you for a name.

Note     The Help Authoring Templates save topic files 
in .RTF format rather than the Word for Windows standard 
.DOC format.

Save As Saves the current Help topic file under a new name.

Note     The Help Authoring Templates use the .RTF 
extension as the default extension rather than the Word for 
Windows standard .DOC extension.

The Edit Menu

The authoring templates add three commands to the standard Word for Windows 
Edit menu: Topic, Hotspot, and Graphic.

Command Description

Topic Displays Help topic information in a dialog box so you 
can edit it.

You can use this command whether the topic actually 
contains footnotes or if you used another editor to add the 
footnotes to the topic.
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Note     The Help Authoring Templates ignore any 
footnotes not at the beginning of the topic or not 
supported by the templates, including all MULTIKEY 
footnotes.

Hot Spot Displays information about a hot spot in a dialog box so 
you can edit it.

If you have not selected a hot spot before choosing this 
command, you will see an error message.

Graphic Displays information about a bitmap reference so you 
can edit it.

You can select all or part of the bitmap reference before 
you choose the command, but do not select any other text 
or you will create an error.

The View Menu

The authoring templates add three commands to the standard Word for Windows 
View menu: Topic, File, and Selection.

Command Description

Topic Builds the current topic as a Help file and then displays the 
resulting file in Windows Help.

File Builds the entire topic file as a Help file and then displays 
the resulting file in Windows Help.
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Selection Builds the text and graphics you selected and then displays 

the resulting Help file in Windows Help.

The Insert Menu

The authoring templates add four commands to the standard Word for Windows 
Insert menu: Topic, Jump or Popup Hotspot, Macro Hotspot, and Graphic.

Command Description

Topic Adds a new Help topic to the topic file.

The authoring templates add new topics at the end of the 
topic file, or immediately before the current topic. (The 
current topic is the topic where the insertion point is 
located, even if the insertion point is at the beginning of the 
file.) If you want to insert the new topic in a specific place, 
be sure the insertion point is positioned properly before 
you choose this command.

If this is the first topic you are adding to the file, no page 
break is inserted after the topic information.

Jump or Pop-Up Hot 
Spot

Inserts a jump or pop-up hot spot in the Help topic.

Note     In WHAT30.DOT this command is simply Insert 
Hot Spot.
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Macro Hot Spot Inserts a macro hot spot in the Help topic.

Note     This command is only in WHAT31.DOT.

Graphic Inserts a bitmap reference in the Help topic.

Creating New Help Topic Files

To create a new Help topic file

1. From the File menu, choose New.
2. In the Use Template box, select the authoring template to use for this 
topic file.
Note     The authoring template should correspond to the version of 
Help you want to build.
3. In the New box, select Document as the type of file.
4. Choose OK.
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You can open any Help topic file, whether or not you have used the Help 
Authoring Templates to create it.

To open a Help topic file

1. From the File menu, choose Open.
The Open dialog box appears.
2. If the file is on a different drive, select the drive you want from the 
Drives box.
If the drive you want to change to does not appear in the Drives list box, 
it may be a network drive to which you are not connected. First connect 
to the drive and then use this dialog box option.

3. In the Directories box, double-click the directory you want.

Or press the UP ARROW or DOWN ARROW key to select the directory, and 
then press ENTER.
Windows displays the names of all files in that directory that are the 
type selected in the List Files Of Type box. To select a different file 
type, use the List Files Of Type list box.

4. In the File Name box, double-click the name of the file you want to open.

Or select the file and choose OK. (The default extension is .RTF, so 
initially only files of that type will appear in the list box.)
The current directory is represented by the open folder icon.
Instead of using the File Name and Directories list boxes to add a file, 
you can type the complete path in the File Name box and click OK.

Adding New Topics

When you create a Help topic file, you add all the topics that you want included 
in the build of the Help file.

To add a topic to the Help topic file

1. From the Insert menu, choose Topic.
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The Insert Topic dialog box appears. The text boxes in the dialog box 
represent the topic footnotes supported by the Help compiler.
For an explanation of each of the entries in this dialog box, see Chapter 
6, “Creating Topics.”
2. In the Title box, type the title that you want to give this topic.
3. In the Context String box, type the context string that you want to 
assign to this topic.
4. In the Keywords box, type the keywords that you want users to use to 
find this topic in a keyword search.
Keywords must be entered in this text box exactly as they would be 
entered in a footnote window. You must separate each keyword with a 
semicolon.
5. In the Browse Sequence box, type the list name and/or sequence 
number if this topic is to be included in a browse sequence.
6. In the Build Tag box, type the build tags you want to assign to this 
topic, if you are using build tags. You must separate each build tag with 
a semicolon.
7. In the Entry Macro box, type the macro string that you want 
Windows Help to execute when the user jumps to this topic.
8. In the Comment box, type any optional comments that you want to 
include with this topic.
These comments are ignored by the Help compiler.
9. Choose OK.
Or if you want to add the new topic before the current topic, clear the 
Place New Topic At End Of File check box, and then choose OK.
Note     If you clear this check box, the template adds the new topic 
immediately before the current topic. (The current topic is the topic 
where the insertion point is located, even if the insertion point is at the 
beginning of the file.) If this is the first topic you are adding to the file, 
no page break is inserted after the topic information.

Editing Topic Information

You can edit any topic in the file whether or not you created it using the Help 
Authoring Templates.
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To edit a topic’s footnote information

1. Place the insertion point anywhere inside the boundaries of the topic 
you want to edit.
Note     Because Help topics are separated by page breaks, the current 
topic is defined by everything that appears between two page breaks.
2. From the Edit menu, choose Topic.
The Edit Topic dialog box appears; any information previously entered 
in the topic is displayed in the appropriate text boxes.
Note     Information in footnotes not at the beginning of the topic or not 
supported by the authoring templates do not appear in the dialog box.
3. Edit the information displayed in the Title, Context String, 
Keywords, Browse Sequence, Build Tag, Entry Macro, and Comment 
boxes.
Or type the appropriate information if the box is empty and you are 
adding the feature.
Note     Keywords must be entered in this text box exactly as they 
would be entered in a footnote window. You must separate each 
keyword with a semicolon.
4. Choose OK.

Adding Jumps and Pop-Up Windows to Help Topics

You can add hot spots to text or graphics in your Help topics.

To create a jump or pop-up hot spot

1. Select the text or graphic that you want to use to create the hot spot.
Be careful not to select any part of the topic that you do not want to 
include in the hot spot.
2. From the Insert menu, choose Jump Or Pop-Up Hot Spot.
The Insert Jump Or Pop-Up Hot Spot dialog box appears.
For a complete explanation of each of the entries in this dialog box, see 
Chapter 8, “Creating Links and Hot Spots.”
3. Edit the text in the Text box, if necessary.
If you select text or a bitmap reference before choosing the command, 
the selected text appears in the Text box when the dialog box opens. If 
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you select a picture that has been pasted into the topic, “–Picture Hot 
Spot–” replaces the Text box since the picture has no text and cannot be 
edited.
Note     Although this entry is required, the template does not check the 
text or bitmap name for correctness.
4. Type the context string of the destination topic.
Note     Although this entry is required, the template does not check for 
the existence of the context string or for correct syntax. It does check 
for illegal characters, however.
5. Select the type of hot spot you want to create.
6. Select the Unformatted check box if you want the hot spot to appear 
as authored (no underline, custom color) rather than the standard 
underlined-green text.
7. If the jump is to a topic in a separate Help file, type the name of the 
Help file in the File Name box.
Note     These jumps do not include jumps to topics in any topic file 
included in the current Help project file.
8. If the jump is to a topic that you want displayed in a secondary 
window, type the name of the secondary window in the Window Name 
box.
Note     A pop-up window cannot be displayed in a secondary window. 
If you choose Pop-Up as the hot-spot type and try to enter a name here, 
a dialog box appears and prompts you to choose between a pop-up or 
secondary window.
9. Choose OK.

Adding Macro Hot Spots to Help Topics

Windows Help version 3.1 offers the option of adding macro hot spots to Help 
topics, in addition to the standard jump or pop-up hot spots.

To create a macro hot spot

1. Select the text or graphic that you want to use to create the hot spot.
Be careful not to select any part of the topic that you do not want to 
include in the hot spot.
2. From the Insert menu, choose Macro Hot Spot.
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The Insert Macro Hot Spot dialog box appears.
Note     For a complete explanation of each of the entries in this dialog 
box, see Chapter 8, “Creating Links and Hot Spots.”
3. Edit the text in the Text box, if necessary.
If you select text or a bitmap reference before choosing the command, 
the selected text appears in the Text box when the dialog box opens. If 
you select a picture that has been pasted into the topic, “–Picture Hot 
Spot–” replaces the Text box since the picture has no text and cannot be 
edited.
4. Select the macro from the list box that you want Windows Help to 
execute when the user chooses the hot spot.
Or type the macro name in the Macro box.
Note     The list box includes all valid macro names, including 
abbreviations.
5. Type the appropriate parameters for the macro you selected.
Note     If you want to enter a complex macro string for this hot spot, 
you must type the additional macros and parameters by hand.
6. Select the Unformatted check box if you want the macro hot spot to 
appear as authored (no underline, custom color) rather than the standard 
underlined-green text.
7. Choose OK.

Editing Hot-Spot Information

You can edit hot-spot information for jumps, pop-up windows, and macros. 
Because this information is significantly different depending on the type of hot 
spot, the Help Authoring Templates use two dialog boxes: one for jump and pop-
up hot spots and one for macro hot spots.

To edit a jump or pop-up hot spot

1. Select the hot spot that you want to edit.
You can select all or part of the hot spot, or you can simply place the 
insertion point within the hot spot. But do not select any text outside the 
hot spot or you will create an error.
2. From the Edit menu, choose Hot Spot.
The Edit Jump Hot Spot or Edit Pop-Up Hot Spot dialog box appears.
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Note     The Help Authoring Templates determine which caption to 
display in the dialog box by the formatting of the text or graphic you 
selected. If the hot spot has single underlining, the template displays 
“Edit Pop-Up Hot Spot”; if it has double underlining, the template 
displays “Edit Jump Hot Spot.”
3. Edit the text in the Text box, if necessary.
If you select text or a bitmap reference before choosing the command, 
the selected text appears in the Text box when the dialog box opens. If 
you select a picture that has been pasted into the topic, “–Picture Hot 
Spot–” replaces the Text box since the picture has no text and cannot be 
edited.
Note     Although this entry is required, the template does not check the 
text or bitmap name for correctness.
4. Edit the context string of the destination topic.
Note     Although this entry is required, the template does not check for 
the existence of the context string or for correct syntax. It does check 
for illegal characters, however.
5. Select the type of hot spot you want.
6. Select the Unformatted check box if you want the hot spot to appear 
as authored (no underline, custom color) rather than the standard 
underlined-green text.
7. If the jump is to a topic in a separate Help file, type the name of the 
Help file in the File Name box.
8. If the jump is to a topic that you want displayed in a secondary 
window, type the name of the secondary window in the Window Name 
box.
Note     A pop-up window cannot be displayed in a secondary window. 
If you select Pop-Up as the hot-spot type and try to enter a name here, a 
dialog box appears and prompts you to choose between a pop-up or 
secondary window.
9. Choose OK.

To edit a macro hot spot

1. Select the macro hot spot that you want to edit.
You can select all or part of the macro hot spot, or you can simply place 
the insertion point within the macro hot spot. But do not select any text 
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outside the hot spot or you will create an error.
2. From the Edit menu, choose Hot Spot.
The Edit Macro Hot Spot dialog box appears.
Note     The Help Authoring Templates display this dialog box if the 
hidden text in the hot spot begins with an exclamation point (!), the 
symbol used to indicate a macro hot spot.
3. Edit the text in the Text box, if necessary.
If you select text or a bitmap reference before choosing the command, 
the selected text appears in the Text box when the dialog box opens. If 
you select a picture that has been pasted into the topic, the message “–
Picture Hot Spot–” replaces the Text box since the picture has no text 
and cannot be edited.
Note     Although this entry is required, the template does not check the 
text for correctness.
4. Edit the macro string in the Macro box.
Or select a different macro from the list box.
Note     Although this entry is required, the template does not check for 
the existence of the macro string or for correct syntax. It does check for 
illegal characters, however.
Note     If you want to enter a complex macro string for this hot spot, 
you must type the additional macros and parameters by hand.
5. Select the Unformatted check box if you want the hot spot to appear 
as authored (no underline, custom color) rather than the standard 
underlined-green text.
6. Choose OK.

Adding Graphics to Help Topics

To use graphics in your Help file, you can paste the graphics directly into the 
topic or use a bitmap reference that tells the Help compiler which graphic to 
display and how to align it in the topic. The Help Authoring Templates make it 
easy to add graphics as bitmap references.

To insert a picture

1. Place the insertion point in the topic where you want to include the 
picture.
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2. From the Insert menu, choose Graphic.
The Insert Graphic dialog box appears.
For a complete explanation of each of the entries in this dialog box, see 
Chapter 10, “Adding Graphics.”
3. Type the name of the bitmap file in the File Name box.
Note     Although this entry is required, the template does not check for 
the existence of the bitmap name or for correct syntax.
4. Choose the type of alignment you want to use for the graphic.
5. If you want this graphic to function as a hot spot, choose the hot-spot 
type.
6. Choose OK.
If you choose any hot-spot type other than Not A Hot Spot, you will see 
the appropriate hot-spot dialog box.

Editing Graphic Information

If you added graphics to your Help topics using bitmap references, you can edit 
this information.

To edit a bitmap reference

1. Select the bitmap reference that you want to edit.
You can select all or part of the bitmap reference, or you can simply 
place the insertion point within the bitmap reference. But do not select 
any other text or you will create an error.
2. From the Edit menu, choose Graphic.
The Edit Graphic dialog box appears.
3. Edit the name of the bitmap file in the File Name box, if necessary.
The text of the bitmap reference you selected before choosing this 
command appears in the File Name box when the dialog box opens.
Note     Although this entry is required, the template does not check for 
the existence of the bitmap name or for correct syntax.
4. Select the type of alignment you want to use for the graphic.
5. If you want this graphic to function as a hot spot, select the hot-spot 
type.
6. Choose OK.
If you change the graphic from not hot to hot or from one hot-spot type 
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to another, the template displays the appropriate hot-spot dialog box so 
you can enter hot-spot information. If you change the graphic from hot 
to not hot, the hot-spot formatting is removed from the bitmap 
reference.

Saving Topic Files

Use the Save command to save changes to an existing topic file. Use the Save As 
command to save a new (untitled) topic file or to rename the current file under a 
new name.

To save changes to an existing topic file

n From the File menu, choose Save.

Note     The templates save topic files in .RTF format rather than the 
Word for Windows standard .DOC format.

To save a new topic file or save the current file under a different name

1. From the File menu, choose Save As.
The Save As dialog box appears.
2. If you want to save the file on a different drive, select the drive you 
want from the Drives box.
3. In the Directories box, double-click the directory in which you want 
to save the file.
Or press the UP ARROW or DOWN ARROW key to select the directory, and 
then press ENTER.
The current directory is represented by the open folder icon.
4. In the File Name box, type a name for the file.
Instead of using the File Name and Directories list boxes to save a file, 
you can type the complete path in the File Name box and click OK.
The .RTF extension is automatically assigned to the filename if you 
don’t specify an extension. If you specify an extension, it overrides any 
automatic extension.
5. Choose OK.
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Displaying Topics in Windows Help

If you want to check the progress of your work, you can use the Help Authoring 
Templates to create a Help file from the topics you are working on and display 
the built file in Windows Help. You can create a temporary Help file of the entire 
topic file, a portion of the topic file, a single topic, or a selection within a topic.

To build the file, the template creates the temporary files TEMP.RTF and 
TEMP.HPJ. After the file is built, the template starts Windows Help and opens 
TEMP.HLP, which contains the topic file, topic, or selection.

To view a compiled version of the current topic file

n From the View menu, choose File.

If the topic file includes graphics, you may be prompted to give the 
bitmap directory.

To view a compiled version of the current topic

1. Place the cursor within the topic you want to view.
2. From the View menu, choose Topic.
If the topic includes graphics, you may be prompted to give the bitmap 
directory.

To view a compiled version of a partial topic file

1. Select the portion of the topic file you want to view.
2. From the View menu, choose Selection.
If the selection includes graphics, you may be prompted to give the 
bitmap directory.

Help Authoring Template Keys

Use the following keys in the Help Authoring Templates.
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To Press

Open an existing topic file CTRL+F12

Save a topic file SHIFT+F12

Save a topic file under a new name F12
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