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Adobe Illustrator

 



 

 - Macintosh

 



Using Adobe Illustrator  Files with Other Applications

 

Before saving Adobe Illustrator documents for use in other applications, you should be familiar 
with the differences between the various Preview and Compatibility options. You can choose 
from seven formats, as described in the following sections, when you save a document in 
Adobe Illustrator 5.5. 

 

To select preview and compatibility options:

 

1 Choose Save or Save As from the File menu.

2 Choose a format from the Format pop-up menu, as described in the following sections, “Illus-
trator-Compatible Formats,” “Acrobat PDF Format,” and “EPS Format.” 

3 Click Save. If you chose the EPS format, you also specify additional options in the EPS Format 
dialog box. These options are described in “EPS Format” later in this technical note.

ILLUSTRATOR-COMPATIBLE FORMATS
There are five Adobe Illustrator “native” formats—that is, formats compatible with the given 
software version. The compatible formats include Illustrator 5, the default; Illustrator 4 (Win-
dows), compatible with Adobe Illustrator 4 for Windows; Illustrator 3, compatible with Adobe 
Illustrator 3; Illustrator 88, compatible with Adobe Illustrator 88; and Illustrator 1.1, compati-
ble with Adobe Illustrator 1.1. In Adobe Illustrator version 4.0 (Windows) and earlier, the Illus-
trator file format is equivalent to “None Omit EPSF Header.”

The Illustrator-compatible formats create the smallest file of any of the formats. An Illustrator-
format file can be reopened only in Adobe Illustrator or Adobe Photoshop , and is not saved as 
an Encapsulated PostScript (EPS) file. 

You should use an Illustrator-compatible format other than the default (Illustrator 5) when

• transferring Adobe Illustrator files between platforms, such as between Macintosh, Windows, 
and UNIX .

• sending a file to someone who doesn’t own the most recent release of the software or who has 
an application that accepts only one of the earlier formats. (For example, Aldus Freehand 4.0 
can open and edit up to Adobe Illustrator 3 format.)

Do not use these options when placing a file in another application or when separating a color 
file using the Adobe Separator  application.

When saving an Adobe Illustrator 5 file using an earlier Illustrator-compatible format, keep 
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in mind that 

 

•

 

Gradient fills will be converted to masked step blends as if they had been created in Adobe 
Illustrator 3.x. 

 

•

 

Layers will be removed

 

•

 

Some text features will be lost when saving in Illustrator 88 format or earlier

 

•

 

Custom colors will be converted to process when saving in earlier formats. 

 

•

 

Masks, compound paths, patterns, or custom colors won’t be saved in Illustrator 1.1 format 
because the version does not support them. 

  

ACROBAT (PDF) FORMAT

 

This format saves the Adobe Illustrator file as an Adobe Acrobat Portable Document Format 
(PDF) file. For more information about the PDF format, see the Adobe Illustrator 5.5 docu-
mentation and the Adobe Acrobat Help.

 

EPS FORMAT

 

You should use the Encapsulated PostScript format when saving a file to be placed in a page 
layout or other application. When you choose the EPS format and click Save, the EPS Format 
dialog box appears; you use this dialog box to choose the following four preview, four compati-
bility, and placed image options.

Regardless of which preview option you choose, the color information from your Adobe Illus-
trator document is retained. For example, an image saved with a 1-bit (black and white) 
Macintosh preview retains its color when printed on a PostScript device. This is because the 
PostScript information contained in the EPS file, not the PICT preview information, is sent to 
the printer. When printing to non-PostScript devices (such as QuickDraw

 



 

 printers), only the 
PICT information from the EPS file is sent to the printer.

 

Preview options

 

You can choose from four Preview options.

 

None 

 

This format saves an EPS file without a preview and is equivalent to the None Include EPSF 
Header format in previous Adobe Illustrator versions. When you place this file in other pro-
grams (on any platform), you won’t see a preview; only a gray box or a box with an X through it 
on-screen will appear. When you print the file from another application on a PostScript printer, 
the file will print with full detail and resolution. When you print the file from another applica-
tion on a non-PostScript

 



 

 printer, the file will print as a gray box or not at all. 
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1-bit IBM PC

 

This format attaches a 1-bit black-and-white TIF (tagged-image format) preview image to the 
Illustrator EPS file. This format is equivalent to the IBM

 



 

 PC format in previous Adobe 
Illustrator versions. Use this option if you plan to place your Adobe Illustrator file into an IBM 
PC-based program that accepts EPS files (Aldus

 



 

 PageMaker or QuarkXPress

 



 

 for Windows, for 
example). When naming the file, follow the DOS convention of eight characters followed by 
the appropriate file extension (for example, 

 

filename.ai

 

 to open the file in Adobe Illustrator for 
Windows, or 

 

filename.eps

 

 when saving EPS files to place in other PC applications.

When you print the file from another application on a PostScript printer, the file will print with 
full detail and resolution. When you print the file from another application on a non-Post-
Script

 



 

 printer, the file may print as the TIF preview or not at all, depending on the application.

 

1-bit Macintosh

 

This format attaches a 1-bit black-and-white PICT preview image to the Illustrator EPS file. 
This format is equivalent to the Black & White Macintosh format in previous Adobe Illustrator 
versions. The PICT preview has a resolution of 72 dots per inch (dpi) and is intended for pre-
viewing on-screen when the file is placed in another application. When you print the file from 
another application on a PostScript printer, the file will print with full detail and resolution. 
When you print the file from another application on a non-PostScript

 



 

 printer, the file may 
print as the 72-dpi PICT preview or not at all, depending on the application.

 

8-bit Macintosh

 

This option is equivalent to the 1-bit Macintosh format, except that the preview image is 8-bit 
color. This format attaches an 8-bit color PICT preview image to the Illustrator EPS file. This 
format is equivalent to the Color Macintosh format in previous Adobe Illustrator versions. 

 

Include Placed Images option

 

Select this option if your Adobe Illustrator file contains placed EPS images and you plan to 
place the file in another application. This option is selected by default if you select the EPS for-
mat and the file has a placed image; the option is dimmed if the document contains no placed 
images. Whether or not you select this option, if you save a file with placed images, you must 
have the placed image available on disk or on your hard drive to be able to reopen the file in 
Adobe Illustrator.

 

Compatibility options

 

You can choose from four compatibility options: Adobe Illustrator 5 (the default), Adobe Illus-
trator 4 (the Windows version), Adobe Illustrator 3, Adobe Illustrator 88, and Adobe Illustra-
tor 1.1. For more information on which option to choose, see “Illustrator-Compatible 
Formats” earlier in this technical note.
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SAVING ADOBE ILLUSTRATOR DOCUMENTS TO BE PLACED IN OTHER APPLICATIONS

 

This section discusses considerations when saving Adobe Illustrator documents that you plan 
to place in other applications.

 

Adobe Photoshop

 



 

If you have Adobe Illustrator 5.0 or later and Adobe Photoshop 2.5 or later, you can copy and 
paste images from Adobe Illustrator into Adobe Photoshop using the Cut, Copy, and Paste 
commands in the Edit menu. You can also use the following procedure.

 

To save an Adobe Illustrator document to be placed in Adobe Photoshop:

 

1

 

In Adobe Illustrator 5.5, choose Save or Save As from the File menu; in the Save dialog box, choose 
one of two options from the Format pop-up menu:

 

•

 

If the artwork does not contain gradient fills, choose Illustrator 5 and click Save. 

 

•

 

If the artwork contains gradient fills, choose Illustrator 3.0 and click Save. Adobe Photoshop 
2.5 does not recognize gradient fills created in Adobe Illustrator 5.0. Saving these files in the 
Illustrator 3 format will convert the gradient fills into shape blends. 

 

2

 

In Adobe Photoshop, choose Open from the File menu, and select the Adobe Illustrator file.

Either the EPS Rasterizer (version 2.5) or EPS Input Options (version 2.01) dialog box appears. 
These dialog boxes let you set the image dimensions and resolution. The default image dimen-
sions are the same as the Adobe Illustrator file. The default resolution is 72 dpi—the Macintosh 
screen resolution.

 

3

 

Accept the default size. 

 

4

 

Increase the resolution for the printer or output device you plan to use. As a rule of thumb, the 
pixels-per-inch resolution in Photoshop should be two times the lines-per-inch screen frequency 
(not dpi) of the printing device.

 

5

 

To maintain the hard edges typical of an Adobe Illustrator image, deselect the Anti-aliased box; to 
soften the edges of objects, for a more lifelike photographic effect, select the Anti-aliasing option.

 

6

 

Click OK.

 

Note:

 

 The Photoshop rasterizer cannot convert certain elements from Adobe Illustrator files such 
as patterns, gradient fills, stroked text, text used as a mask, and placed artwork.

 

Adobe Premiere

 



 

 

 

Follow this procedure if you plan to use Adobe Illustrator artwork in Adobe Premiere.

 

To save an Adobe Illustrator document to be placed in Adobe Premiere: 

 

1

 

In Adobe Illustrator 5.5, choose Save or Save As from the File menu; in the Save dialog box, choose 
one of two options from the Format pop-up menu:

 

•

 

If the artwork does not contain gradient fills, choose Illustrator 5 and click Save. 

 

•

 

If the artwork contains gradient fills, choose Illustrator 3.0 and click Save. Adobe Premiere 
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3.0 does not recognize gradient fills created in Adobe Illustrator 5.0. Saving these files in the 
Illustrator 3 format will convert the gradient fills into shape blends. 

 

2

 

In Adobe Premiere, choose Open from the File menu, and select the Adobe Illustrator file. The 
Import dialog box appears. 

 

3

 

Set the image dimensions for the movie you are creating.

 

4

 

Accept the default Anti-aliasing option to soften the edges of the video; to maintain the hard edges 
typical of an Adobe Illustrator image, deselect the Anti-aliased box.

 

5

 

Click OK.

 

Note:

 

 The Premiere rasterizer cannot convert certain elements from Adobe Illustrator files such 
as patterns, gradient fills, stroked text, text used as a mask, and placed artwork.

 

Adobe Dimensions

 



 

 

 

1.0

 

If you have Adobe Illustrator 5.0 or later, you can copy and paste images from Adobe Illustrator 
into Adobe Photoshop using the Cut, Copy, and Paste commands in the Edit menu. You can 
also follow this procedure.

 

To save an Adobe Illustrator document to be placed in Adobe Premiere:

 

1

 

If you are using Adobe Dimensions 1.0, in Adobe Illustrator, first convert any text to outlines. Also, 
your artwork cannot contain any placed images, pattern fills, or gradients. Custom colors will be 
converted to process colors.

 

2

 

In Adobe Illustrator 5.5, choose Save or Save As from the File menu; in the Save dialog box, choose 
Illustrator 5 and click Save. 

 

3

 

In Adobe Dimensions, choose either Open or Import from the File menu, and select the Adobe 
Illustrator file. Click Open.

 

Aldus

 



 

 PageMaker

 



 

 

 

and Aldus Persuasion

 



 

 

 

To save an Adobe Illustrator document to be placed in Aldus PageMaker or Aldus Persuasion, 
follow this procedure.

 

1

 

In Adobe Illustrator 5.5, choose Save or Save As from the File menu; in the Save dialog box, choose 
the EPS option from the Format pop-up menu. In the EPS Format dialog box, choose 1-bit Macin-
tosh, 8-bit Macintosh, or 1-bit IBM PC format, as described in “Preview Options” earlier in this 
technical note. 

These options provide a visible preview. All preview options print correctly on a PostScript 
printer. 

 

2

 

Choose one of two options depending on your application:

 

•

 

In Aldus PageMaker, choose Place from the File menu and select the Adobe Illustrator file.

 

•

 

In Persuasion, select either Slide or Note from the View menu. Choose Import from the File 
menu, and select the Adobe Illustrator file.
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For more information about importing EPS files into Aldus 

  

PageMaker or Aldus Persuasion, 
see your Aldus documentation.

 

Microsoft

 



 

 PowerPoint

 



 

 and Microsoft Word

 

To save an Adobe Illustrator document to be placed in Microsoft PowerPoint or Microsoft 
Word, follow this procedure.

 

1

 

In Adobe Illustrator 5.5, choose Save or Save As from the File menu; in the Save dialog box, choose 
the EPS option from the Format pop-up menu. In the EPS Format dialog box, choose 1-bit Macin-
tosh, 8-bit Macintosh, or 1-bit IBM PC format, as described in “Preview Options” earlier in this 
technical note. 

These options provide a visible preview in Microsoft PowerPoint and Word. All preview 
options print correctly on a PostScript printer. 

 

2

 

Choose one of two options depending on your application:

 

•

 

In Microsoft PowerPoint, choose Insert/Picture from the Edit menu, and select the Adobe 
Illustrator file. 

 

•

 

In Microsoft Word 5.x, choose Insert/Picture from the Edit menu and select the Adobe Illus-
trator file.

In Adobe Illustrator, you can also hold down the Option key while choosing Copy, (or press 
Command-Option-C); in Microsoft PowerPoint or Word 4.0 and earlier, choose Paste (Com-
mand-V) to paste the Illustrator file into PowerPoint or Word.

For more information about importing EPS files into Microsoft Persuasion or Word, see your 
Microsoft documentation.

 

QuarkXPress

 



 

To save an Adobe Illustrator document to be placed in Quark XPress, follow this procedure.

 

1

 

In Adobe Illustrator 5.5, choose Save or Save As from the File menu; in the Save dialog box, choose 
the EPS option from the Format pop-up menu. In the EPS Format dialog box, choose 1-bit Macin-
tosh, 8-bit Macintosh, or 1-bit IBM PC format, as described in “Preview Options” earlier in this 
technical note. 

These options provide a visible preview in Quark XPress. All preview options print correctly on 
a PostScript printer. 

 

2

 

In Quark XPress, create a picture box, choose Get Picture from the File menu, and select your 
Adobe Illustrator file.

For more information about importing EPS files into QuarkXpress, see your QuarkXpress 
documentation.
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
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