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Editing Text With BBEdit

Introduction

This section discusses BBEdit’s editing functionality, including:

• Basic Editing
• Window Anatomy
• Cursor Movement and Text Selection
• Text Transformation
• Wrapping
• “Paste File” and “Paste Folder Listing”
• Comparing Text Files

If you’re already familiar with another Macintosh text editor or word processor, you can skip the “Basic Editing” 
section.

Basic Editing

In terms of its basic editing functionality, BBEdit behaves like any other word processor or text editor on the 
Macintosh: any typed characters are inserted at the insertion point; if there is a selection present, the selection 
is replaced by the first typed character, and the insertion point is placed after the first typed character.

The insertion point is indicated by a blinking vertical bar; the rate at which this bar blinks is the same for all 
applications and can be set through the “General” control panel.

If there is any text selected, it is highlighted using black (on non-color machines) or the designated selection color:
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If there is text selected in a window that is inactive (not the front window), it is framed in the highlight color:

As you type, BBEdit scrolls the window’s contents so that the insertion point is visible. Note that since BBEdit 
doesn’t automatically wrap the text as you type, the text may scroll horizontally.

To move text from one place to another, select the text you wish to move, and choose the “Cut” command from the 
Edit menu. The selected text will be deleted, and placed in a special area called the “Clipboard”. (The Clipboard 
always contains the last text that you cut or copied.) You can then use the “Paste” command on the Edit menu to 
place the text elsewhere in the document you’re editing, or even in another window altogether. Also, any text that 
you cut or copy can be pasted into another application. You can place text in the Clipboard without deleting it by 
choosing “Copy” from the Edit menu.

Easter Egg: If you hold down the Option key while choosing “Cut” or “Copy”, the selected text is added to 
anything already in the Clipboard; “Cut” will change to “Cut & Append”, and “Copy” will change to “Copy & 
Append”.

When you Paste, the text that’s in the Clipboard will replace the current selection (if there is one), or be inserted at 
the insertion point (if there isn’t). Paste doesn’t remove text from the Clipboard, so you can Paste as many times as 
you wish.

To delete selected text, hit the “Delete” key on your keyboard, or choose “Clear” from the Edit menu. If you have 
an Apple Extended Keyboard or other keyboard with a numeric keypad on it, you can hit the “Clear” key on the 
keypad to delete the selected text.

To select all the text in the front editing window, choose “Select All” from the Edit menu. You can then cut, copy, 
or perform any other action that affects selected text.
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Window Anatomy

BBEdit editing windows look like normal Macintosh windows. However, they have additional visual components 
that are specifically designed to ease the task of working with files and text. These additional components are the 
status bar, the line number display, and the cursor position display.

Whether each of these additional components is visible depends on the settings in the “Global” section of the 
Preferences dialog. By default, the setting is so that only the status bar is visible. The line number display and cursor 
position display can be made visible by checking the “Show Line Numbers” and “Show Cursor Position” check 
boxes in the Preferences dialog. (The “Preferences” dialog is displayed by choosing “Preferences…” from the Edit 
menu.)

The Status Bar

The status bar appears at the top of each editing window; it provides basic information about the text in the window, 
and about the file representing the document (if the file has been saved to disk).

From left to right, the indicators in the status bar are:

• The Diamond. If there is a diamond visible, the document has been modified in some way. If the 
diamond is hollow, then some aspect of the document’s saved state (window position, selection range, 
and so forth) has been changed. If the diamond is black, then the text itself has been changed.

• The Pencil. The pencil is an indicator of whether the file is modifiable. If the pencil has a slash 
across it, then the document is read-only, and its contents cannot be changed in any substantive way. 
This will be the case if the file is locked, if the file was opened from a locked disk, a folder on an 
AppleShare volume to which you don’t have privileges to Make Changes, if the file is checked out 
read-only from a Projector project, or if the “Open Read Only” check box in the Open… or Open 
Several… dialog has been checked.
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If the Open Read Only check box was checked, or the file was checked out read-only from a Projector 
project, you can make the file modifiable by clicking on the pencil. If a file is modifiable, you can 
make it read-only by clicking on the pencil.

• The SmartQuotes. If the SmartQuotes icon has straight quotes in it, then single and double 
quotes are kept straight; this is desirable for programmers. If the SmartQuotes icon has curly quotes in 
it, then single and double quotes are made curly in a “smart” fashion; quotes typed after a space or 
other “quote-breaking” character become opening quotes; all others become closing quotes.

• The State Icon. The State Icon indicates which type of saved state is stored in the document. The 
State Icon is the same as the icon that appears next to the name of the saved state in the “Options…” 
dialog in the Save As… dialog.

• The Printer Icon. Click on this icon to print the document. This is a shortcut for choosing 
“Print…” from the File menu. Hold down the Shift key and click the Printer icon to bring up the 
“Page Setup…” dialog.

• The Get Info Icon. If you click on this icon, BBEdit displays a dialog that contains information 
about the document:

• The Date Last Saved. This is simply the date and time the file was last saved to disk.
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Newly created windows are very much the same; however, since the documents they represent don’t exist on disk, 
the State Icon is not present, and instead of the Date Last Saved, BBEdit places the indication (New 
Document) in the status bar.
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The Line Number Display

The line number display appears at the left-hand edge of every editing window when the “Show Line Numbers” 
check box is checked in the Preferences dialog. It simply shows the line numbers for the lines visible in the window. 
As you scroll, the line number display is updated.
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The Cursor Position Display

The cursor position display appears at the lower left-hand corner of every editing window when the “Show Cursor 
Position” check box is checked in the Preferences dialog. It shows the line number and column position of the 
insertion point, or of the last-changed end of the selection range. The display is updated as the selection changes or 
as the insertion point moves.
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Cursor Movement and Text Selection

You can change the placement of the insertion point and the range of the selection by clicking and dragging with the 
mouse in normal Macintosh fashion. You can also change the insertion point or selection range by using various 
keys on the keyboard.

Arrow Keys

The arrow keys, which are present on all Macintosh keyboards except the original 128K and 512K keyboards, are 
particularly useful for changing the location of the insertion point:

Key Action with Command key with Option key

Up Arrow moves up a line moves up a screenful moves to start  of document
Down Arrow moves down a line moves down a screenful moves to end of document
Left Arrow moves left one character moves to start of line moves left one word
Right Arrow moves right one character moves to end of line moves right one word

When the Shift key is held down, the arrow keys behave as described in the table above, except that the selection 
range is extended to include the new placement of the insertion point. (This is the same effect as typing the arrow-
key combination, and then holding down the Shift key and clicking at the original placement of the insertion point, 
or at the end of the original selection range.)

In the “Editing” section of the Preferences, there is a setting called “Exchange Command and Option”. When this 
option is turned on, the behavior of the left and right arrow keys when Command and Option are held down 
reverses:

Key with Command key with Option key

Left Arrow moves left one word moves to start of line
Right Arrow moves right one word moves to end of line

This option is mostly for people who are used to this behavior in the THINK C editor.

The Numeric Keypad

Most Macintosh keyboards have a numeric keypad on the right side of the keyboard. Normally, these keys behave 
the same as their counterparts on the main part of the keyboard; however, by means of a preference, you can utilize 
the numeric keypad for cursor control, just as in Microsoft Word. This preference is in the “Editing” section, and is 
called “Use Numeric Keypad for Cursor Control”. When this option is turned on, the numeric keypad behaves as 
follows:

• The “1” and “7” keys move to the beginning and end of line, respectively.
• The “3” and “9” keys move to the beginning and end of the document, respectively.
• The “8”, “2”, “4”, and “6” keys behave the same as up, down, left, and right arrow keys, respectively.
• The “5” key makes the current selection range visible, as does the Enter key.
• The “.” key deletes the character to the right of the insertion point.

When using any of the number keys on the numeric keypad, you can use the Shift key as described above to extend 
the selection range. When using the 8, 2, 4, and 6 keys, their behavior is the same as described for the up, down, left, 
and right arrow keys above.
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To change the behavior of the numeric keypad, hold down the Option key and hit the “Clear” key at the upper left-
hand corner of the numeric keypad. (This key is also labeled “num lock” on the Apple Extended Keyboard.)

Special Keys

The Apple Extended Keyboard has additional function keys on it, which are usable within BBEdit:

Key Action with Command key with Option key

F1 Undo (no change) (no change)
F2 Cut (no change) Cut & Append
F3 Copy (no change) Copy & Append
F4 Paste (no change) (no change)

“del” Forward Delete (no change) (no change)
Home scroll to start of document  (no change) move insertion point to start of doc
End scroll to end of document (no change) move insertion point to end of doc
Page Upscroll up a page (no change) (no change)
Page Down scroll down a page (no change) (no change)
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Clicking

You can select text in an editing window in the normal Macintosh fashion, by clicking and dragging.

When in BBEdit, use of the Command and Shift keys when clicking, and clicking multiple times will yield different 
results:

Action Result with Command key with Shift key

Click moves insertion point (no change) Extends selection
Double-Click selects word selects matching braces Extends selection to word
Triple-Click selects line selects paragraph (no change)

Command-Double-Click is the same as clicking once to place the insertion point and then choosing the “Balance” 
command; it selects the nearest pair of matching parentheses, braces, or brackets which encloses the insertion point.

Triple-Click is the same as clicking once to place the insertion point and then choosing the “Select Line” command 
from the Edit menu. Command-Triple-Click is the same as choosing the “Select Paragraph” command from the 
Edit menu (hold down the Option key while pulling down the Edit menu).

Note: In a word processor, a “paragraph” is a stream of characters with a carriage return at the end, wrapped into 
lines automatically. Because lines in plain text are separated by carriage returns, BBEdit defines a paragraph to be a 
collection of lines of text, with blank lines on either end of the text. (Paragraphs also occur at the very beginning and 
very end of the document, even though there are no blank lines there.)
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Text Transformation

BBEdit provides an assortment of facilities for transforming text in various ways. The commands to transform text 
are all found under the Text menu:

Balance locates the pair of parentheses, braces, or brackets which encloses the current selection range or 
insertion point. If there are unmatched parentheses, braces, or brackets, BBEdit will beep.

Twiddle transposes two characters  according to the following rules:

• If the selection range is of zero length (an insertion point), and not at the beginning or end of a line or 
document, the characters on either side of the insertion point will be transposed.

• If the insertion point is at the beginning of the line or document, the two characters following the 
insertion point will be transposed.

• If the insertion point is at the end of a line or document, the two characters preceding the insertion 
point will be transposed.

• If the selection range is of nonzero length, the characters at either end of the range will be transposed, 
regardless of where the selection range begins and ends.

If you hold down the Option key, Twiddle becomes Twiddle Words. Twiddle Words behaves in similar 
fashion to Twiddle, except that it acts on entire words, rather than individual characters.

Raise Case and Lower Case make the selected text all upper case or all lower case, respectively.

Shift Left and Shift Right indent the selected text by one tab stop (in the case of Shift Left), or outdent by 
one tab stop (for Shift Right). If you hold down the Shift key while choosing one of these commands, the selected 
text will be indented or outdented by one space instead of one tab stop.

The Wrap… command is used for wrapping long lines and filling paragraphs; it will be discussed in the next 
section.
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Zap Gremlins… is useful for finding and altering non-printing characters in your text files. When you choose 
this command, the following dialog is presented:

The check boxes in the left half of the dialog control what action the Zap Gremlins command will take:

• Filter Line Feeds, if checked, will cause Zap Gremlins to convert line feeds or carriage 
return/line feed pairs to carriage returns, in the same fashion that “LF Translation” does when opening 
files.

• Zap 8-bit Characters zaps special Macintosh characters, which are usually created by typing a 
letter or number with the Option and/or Shift key held down. The bullet (•) and curly quotes (“ and ”, ‘ 
and ’) are examples of eight-bit characters, though there are many more.

• Zap Control Characters zaps invisible ASCII characters, known as “Control Characters” 
because they were historically used to “control” the actions of terminals and printers. Control 
characters can cause compilers and other text-processing utilities to malfunction, and are therefore 
undesirable.

The radio buttons in the right half of the dialog determine what Zap Gremlins does to “zap” the offending characters. 
These actions only control the behavior of “Zap 8-bit Characters” and “Zap Control Characters”, and do not affect 
“Filter Line Feeds”.

• Delete removes the zapped character completely from the text. This option is useful if you are only 
interested in destroying gremlins, and you don’t care about where they were in the text.

• Replace with Code replaces the gremlin character with an escaped hexadecimal (base 16) code. 
The escape code is in the convention used by the C programming language and Apple’s “Rez” 
resource-description language, namely “\0x” followed by the character code in hex. This option is 
useful to identify both the value and location of gremlin characters; once you’ve done a Zap Gremlins, 
you can search for occurrences of \0x to locate the converted characters.

• Replace with (followed by an entry field) replaces the gremlin character with the character you 
type in the edit field next to the radio button. This option is useful for identifying the location of 
gremlins, but not their value.
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Easter Egg: If you hold down the Option key when pulling down the Text menu, “Zap Gremlins…” becomes 
“Zap Gremlins”, and if you choose this command, BBEdit will zap gremlin characters and convert line feeds 
according to the current settings in the Zap Gremlins dialog box, without bringing up the dialog.

Entab converts runs of spaces into tabs, according to the current setting in the “Font and Tabs…” dialog. This 
transformation is useful when downloading text from a mainframe computer or on-line service which uses spaces to 
line up columns of text; when displaying the text in a monospaced font, columns will usually not line up unless you 
Entab the text.

Detab converts tabs into runs of spaces, according to the current setting in the “Font and Tabs…” dialog. This is 
useful when uploading text to a mainframe or on-line service which has no concept of tabs as column separators.
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Wrapping

BBEdit offers the capability to wrap text in a variety of ways. This wrapping is not the “live” word wrapping that 
word-processors provide; instead, it is useful when importing text files from word processors or other programs that 
do not use carriage returns to break lines on the screen. When opened, such files appear to have only a few lines in 
them, and these lines run far past the right-hand edge of the window.

To wrap text in the current document window, choose “Wrap…” from the Text menu. BBEdit presents the 
following dialog box:

The controls on the left half of the dialog control how much of the text is wrapped, and the maximum length of the 
lines after wrapping:

• The “Selection Only” check box controls how much of the document’s text will be wrapped. If there is 
a selection range in the window, then the “Selection Only” check box will be enabled. If this check box 
is checked, only the selected lines are affected. Otherwise, BBEdit will wrap all of the text in the front 
document.

The group of radio buttons controls the length of lines after they have been wrapped.

• The “Philip Bar” button will break lines of text at the philip bar. (To see the location of the philip bar, 
turn on “Show Philip Bar” in the Global section of the Preferences dialog.) The philip bar indicates the 
maximum usable width of a document window when the window is zoomed to full size on a nine-inch 
“classic” Macintosh screen. For this reason, you’re guaranteed that text wrapped to the philip bar will 
be readable without horizontal scrolling by anyone on any Macintosh.

• If “Window Width” is selected, no wrapped line will be longer than the current width of the window. 
This option is useful if you’d like the lines to be a little longer or a little shorter than is provided for by 
the philip bar; just size the window appropriately and wrap.

• If “Character Width” is selected, the number in the text field designates the maximum number of 
characters allowed on any line; a line that exceeds this number of characters in length will be wrapped. 
The “Character Width” setting is useful for preparing postings to on-line services, which can break 
lines in an unattractive fashion if they’re longer than a fixed number of characters (usually 80).
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The controls on the right half of the dialog control paragraph wrapping. If the “Paragraph Fill” check box is turned 
off, long lines will be wrapped. Short lines will be left untouched. The results would look something like this:

Before Wrapping:

This is a short line.
This is a very long line of text, which is preceded by a much shorter line of 
text.

After Wrapping, Paragraph Fill Off:

This is a short line.
This is a very long line of text, which is
preceded by a much shorter
line of text.

With Paragraph Fill turned on, short lines are integrated smoothly into the rest of the paragraph.

After Wrapping, Paragraph Fill On:

This is a short line. This is a very 
long line of text, which is preceded
by a much shorter line of text.

The radio buttons under “Indentation:” control the manner in which paragraphs are indented after they’re wrapped:

• None places the text in the paragraph flush against the left edge of the window.

• First Line Only indents the first line by one tab stop, and place the rest of the paragraph flush 
against the left edge of the window.

• Indent All Lines indents all lines in the paragraph by one tab stop.

• Reverse Indent places the first line in the paragraph flush against the left edge of the window, 
and will indent all other lines in the paragraph by one tab stop.

Note: If you hold down the Option key while choosing “Wrap…”, the dialog will not be presented, and the text 
will be wrapped according to the current settings in the dialog. If you’ve never chosen “Wrap…”, the text will be 
wrapped according to the settings in the “Wrapping” section of the Preferences dialog. It’s handy to set the 
preference so that “Selection Only” is turned on; this allows you to simply triple-click to select a long unwrapped 
line, or command-triple-click to select a paragraph, and then type Command-Option-Return. You can also perform 
the whole maneuver without lifting your hands from the keyboard, by using Command-L to select a line, and 
Command-Option-L to select a paragraph, then typing Command-Option-Return.
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“Paste File” and “Paste Folder Listing”

Paste File is a convenient way to insert the contents of a specified text file into a document that you’re editing. 
When you choose “Paste File” from the Edit menu, BBEdit puts up a file-selection dialog so that you can choose 
the file to be inserted:

Once you choose a file, its contents will replace the selection range (if there is one) or be inserted at the insertion 
point (if there isn’t).

Paste Folder Listing is used for generating a textual listing of a given folder hierarchy. To insert a folder listing in a 
document, choose “Paste Folder Listing” from the Edit menu:
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Click the large button at the bottom of the dialog to choose the folder. BBEdit scans the folder and generates a text 
listing of its contents. This listing replaces the selection range (if there is one), or is inserted at the insertion point (if 
there isn’t).

Note: The folder listing will include invisible files, such as the desktop database files. Also, if you paste a listing 
of an AppleShare volume that you don’t have total access to, some folders can’t be scanned. These folders will have 
“(access denied)” under their names in the listing.
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Comparing Text Files

The “Compare Files…” command is used to determine the nature of the differences between two text files. To 
compare any two files files, choose “Compare Files…” from the Edit menu:

Click the “New…” button to choose the newer of the two files, and “Old…” to choose the older. When you’ve 
chosen both files to compare, click the “Compare” button to compare the two files.

Note: It doesn’t actually matter which files you specify with “New…” and “Old…”, but it’s a bit easier to view the 
differences if you select the newer file with “New…”.

If the files are different, BBEdit opens the two files, and tiles them side-by-side, with the Compare Results window 
beneath them.

To view a particular difference, double-click on a line in the Compare Results window.
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Note: To avoid the possibility of modifying the files while you’re trying to view the differences between them, 
BBEdit opens both files read-only. If you wish to edit either file, click on the pencil icon in the status bar.

If you re-arrange windows so that the Compare Results window gets hidden, chooser “Show Compare Results” from 
the Edit menu to bring the Compare Results window to the front.


