
MacLux™ User Manual    1                                                                              

MacLux™

User Manual
version 1.6.3

©1991 by Claude Heintz
All Rights Reserved

Table Of Contents

MacLux™ User Manual    1                                                                              



MacLux™ User Manual    2                                                                              

General Information  ................ 3
Introduction .............................. 4
Quick Tour  ...............................5
Using MacLux  .........................6

The Apple  Menu  ................... 7
The File Menu  .......................... 8
The Edit Menu  .........................10
The Selection Menu  ................. 13
The Tools Menu  .......................16
The Lights Menu  ...................... 17
The Lines Menu  ....................... 17
The Options Menu  ...................18
The Window Menu  ..................21
Keyboard Commands  .............. 22

PaperWork  ............................... 23
MacLux File Types  ................... 26

Notice:  Product names contained in this document are for identification

purposes only and may be trademarks of their respective companies.General Information

• MacLux™ •
• Copyright ©1990-1991 by Claude Heintz.•

•  All Rights Reserved •

• MacLux was created using Symantec's THINK Pascal 3.01
and the THINK Class Library. •

•Special Thanks To: Sandi Bonn, Craig Hickman and Janet Rose.•

      MacLux is MultiFinder compatible.  MacLux will run on a minimum Mac Plus with System 6.0.x.  MacLux is 
compatible with system 7.0.  Color portions of MacLux are only available on Macs with color QuickDraw.  This includes an 
SE/30, LC or any Mac II.  For color to work properly, 32 bit QuickDraw must be installed.  Sound notes are available on 
Macs running system 6.07 and later.  To record notes, sound input hardware is required.
     On a monochrome Mac, as little as 400K is required to run.  With 8 bit color, 800-1000k; 24 bit color, 1800k-2000k or 
more.  Multiple monitors eat up more memory, especially in 24 bit mode!!  Not enough memory can, in severe cases, cause 
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MacLux to lock up when it is first launched.

    MacLux is shareware.  If you use MacLux and want to keep it, please pay for it.  (only $50, students $25)  Paying the fee 
and becoming a registered user will help insure future updates and support.  Also available to registered users is PaperWork, 
which allows you to compile reports such as channel lists and instrument schedules from your plots.
   Unlike MacLux, PaperWork is not shareware.  Registered  users of MacLux are licensed to use one copy of PaperWork.  It 
may be used only on one computer at a time.  Permission to make backups is, of course, granted.

You may give MacLux away to your friends and colleagues.
Registered users MAY NOT give the full version of PaperWork away.

Any re-distribution MUST be non-commercial and include all documentation.
PLEASE, if you give MacLux to a friend, give them the manual and other files.

I would like to hear your comments, questions, etc. about MacLux.  If you are not a registered user, enclose SASE if you 
want a reply.

My current address is:
Claude Heintz
29621 Gimpl Hill Rd.
Eugene, Oregon  97402.

I can also be reached via Compuserve, 76120,1220 or: 

Claude Heintz
133 Broad St.

Plattsburgh, NY 12901Introduction

    MacLux is more than a specialized drawing application.  In MacLux, lights and lines are objects 
which have data associated with them.  For a designer this has a great advantage.  The designer can think 
in terms of the function of each light, entering data graphically as the design takes shape.  At any point 
the computer can do what it does best—manipulate and sort the data and produce the required paper 
work.

    MacLux works in several ways that are analogous to traditional methods of drafting a light plot.  
Instead of using a plastic template to draw a symbol, you select the one you want from a palette and drag 
it into place.  Unlike the paper version, the MacLux symbol can be moved or even changed to a different 
type.  MacLux allows you to create a plot over the top of an existing ground plan, similar to using 
tracing paper on top of the scene designer's drawings.  When drafting on paper, there are templates 
available that allow you to get an idea of the size of beam that a light of a given type will produce.  
MacLux has a similar feature that will show the oval of the beam on the floor.

  MacLux includes features which go beyond  traditional methods.  Light plots can be created in color.  
The instruments and displayed beams are colored.  MacLux even shows how the colors from different 
lights will mix.  MacLux will also display a cube placed on the stage so that you can see how beams fall 
on a three dimensional object.  

    MacLux works by taking advantage of the computer's ability to manipulate relational data.  For 
example, when MacLux calculates the beam of a light, it uses the beam spread from the key for the type 
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of instrument represented by the light's symbol.  MacLux also looks to find what position the light is 
hanging on and enters the height of that position for you.  Similarly, when creating an instrument 
schedule, the program looks at all the lights hanging on a position and assigns them numbers based on 
rules like, "count from SL to SR."

Note
This manual assumes the reader is familiar with the terms and conventions of the standard Macintosh 
interface.  For more information, refer to the Macintosh Reference, or System Software User’s Guide that 
came with your Macintosh.

Quick Tour
Open MacLux—the program starts up with a blank plot.

  Select the Draw tool  from the Tools menu. The cursor will change to a pencil.  Choose a spot and 
press the mouse.  The cursor becomes a light.  You can position the light before you release the mouse.

  You may want to ‘tear off’ the Tools menu and place it in a corner of the window for easy access.
  Choose the Select tool .  Double click on the light and you will see the info dialog box with data 
such as the light’s channel and color.  Enter a color and a channel.  When you hit OK, you are returned 
to the plot.   In addition to the light, its color and channel are displayed.

  Suppose you want to move your light.  Select the Grab tool .  Use it to drag the light to a new 
location.  Notice that the channel and color move along.  Now, click on the color and drag it to the side 
of the instrument.  If you move the light again, the color remains in its new relationship to the light.

  If you want to change the type of light, click once on the light with the Select tool.  Choose a new 
symbol from the Lights menu.  If you want to change the light’s direction, use one of the arrow keys or 
N,S,E or W.  You will notice that the color and channel return to their default positions when you change 
the light’s symbol.     If you choose Key... from the Options menu, you will see information about the 
type of light you selected.

  Use the Line tool  to draw a line.  When you double click on the line with the Select tool, you will 
find that it is a lighting position.  Like the light, it has data associated with it.  The Grab tool works with 
a line the same way it does with does with a light except that by clicking near the end of the line, you 
can change its length.

Bells & Whistles
  Select your light.  ( If you are using a Mac with a color monitor, choose Set Color from the Edit menu 
or press command-K.  This allows you to pick a color for the light.)  Next, choose BeamSpread from the 
Selection menu.  Click the Add button, then OK.  You will see the beam from your light displayed.
  Click with the select tool inside the oval of the beam.  Choose Show Cube from the Selection menu.  
You will see a cube as it would appear at the point you chose with the select tool.  (you can only do this 
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on a Mac with color QuickDraw.)Using MacLux
This is the way I set up my files to create a light plot with MacLux:

    First, I create an outline of the theatre including the major architectural details.  I sometimes prefer to 
make a separate file for each printed page.  This allows me to control how the laser printed output will 
fit together.  (and to jump around the plot faster)  This is not necessary, you can set the document size to 
be as big as you want.
    The outline of the theatre can be created many ways.  Any program that can output a PICT file will 
work.  This plan can then be used with  my light plot (Use PICT...). 
    To make the initial skeleton of the theatre, I sometimes even use MacLux because of its scale grid and 
'Set Line' capabilities.  I save the outline I've created as a PICT file. (Save As...), which I import into 
MacDraw® to jazz it up.  (adding fill patterns and text)  I save the resulting file in PICT format, ready to 
use under my plot.    
    Next, I begin my plot by drawing in all of the hanging positions with MacLux's line tool.  Double 
clicking on a line with the selection tool allows me to access the data about that position including its 
name and height.  Finally, I set the title of the plot (The Show...) and arrange my key (Key...) for each 
symbol that I'm going to use.
   I usually save my blank plot as a MacLux stationary document which allows me to use it over again.  I 
also save the ground plan PICT file as MacDraw II stationary (in addition to the PICT I’m going to use 
with my plot) which allows me to re-use it, adding only the ground plan of the set for the production I'm 
working on.  
    From here on, I can simply start drawing lights.  Like a line, double clicking on a light with the Select 
tool allows me to enter an instrument's color, channel, etc.  When I'm ready, the utility PaperWork 
creates the instrument schedule, channel list, color cut list, etc.

The  Menu
About MacLux... presents a window that displays the copyright notice and shareware information.  The 
version of MacLux is shown under the logo.  It is important to include the version number if you write 
to ask a question about MacLux.  Clicking the mouse in the About window returns you to MacLux.

Help...  shows the help dialog which has buttons for various topics.  The topics are generally grouped 
by menu.  Clicking a button shows a window with information about that topic.  The information 
presented is intended to provide a brief explanation that can be used as a quick reference.  Clicking the 
mouse in an information window returns you to the help dialog.  When you are finished, click Done.
    Under system 7.0, MacLux Help will be found in the help menu instead of the apple menu.  Balloon 
help is also available for menu items.  Choose show balloons from the help menu.   Then place the 
cursor on the menu selection you want to know about. 
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DAs the rest of the items in the Apple Menu are desk accessories.  Some of the DAs affect MacLux.
    The Chooser selects a printer.  MacLux uses information about the chosen printer to determine page 
and document sizes.
    The Control Panel sets many parameters that determine basic operations such as how fast the mouse 
moves.  The monitor configuration is also set through the control panel.  Changing the monitor setting 
while MacLux is running is not a good idea.
    The Scrapbook can be used to cut and paste information between applications.  You can use the 

scrapbook to import your own symbols into MacLux.The File Menu
New (cmd-N) creates a new untitled MacLux light plot.  A plot is a MacLux document (or file) which 
contains lights and positions and the data attached to them.  The document also contains information 
about the general setup of the plot.
  When MacLux is first launched, it automatically opens a new plot.  Any new plot is created with the 
following defaults:

•The Document's size is the chosen printer's page size.
•The Scale is set to 1/4”.
•Text fonts are Times and Geneva.

Open... (cmd-O) allows you to open a previously saved plot or stationary document.  The number of 
plots you can have open at a time is limited only by available memory.  MacLux will inform you if there 
is not enough memory to open a requested file.

Close (cmd-W) should be selected when you are done with the plot in the top, active window.  You can 
also close a plot by clicking the box in the upper left hand corner of the window.  If you have made any 
changes to the plot since it was last saved, MacLux will ask if you would like to save it.  

Save (cmd-S) saves the current plot to disk.  If the plot has not been previously saved, MacLux will 
give you a chance to name it and to specify its location.  Otherwise, Save replaces the old file with the 
new contents.
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Save As... gives the option of saving the current document as a Plot, Stationary,
or PICT file.
  Stationary is a plot file that can be reused, the original remaining unaltered.  MacLux prevents you 
from accidentally saving over the top of a stationary document.  You must use Save As to explicitly alter 
stationary.  This is useful for a "house plot" for a particular venue or if you desire to open new 
documents with a key or fonts other than the built-in defaults.  Under system 7.0, you may also create 
stationary by using the Finder’s Get Info command.
  PICT files can be imported into many Macintosh applications.  If color is turned on in the preferences, 
exported PICT files will be bit mapped with a resolution equal to the setting of the main monitor.  (This 
is true even if you are working on a black and white monitor.)  Otherwise, the PICT is of the object type 
that can be edited in a drawing program.

Revert To Saved discards any changes made to the current plot after the last time it was saved.  
MacLux asks you to confirm that you want to revert to the last version saved in case you selected this 
item by accident.Use PICT... allows you to place a drawing, such as a ground plan, under your light 
plot.  This can be any PICT file, the type created with a drawing program such as MacDraw®.  Some 
paint programs also save in PICT format.  The difference is that paintings are bit mapped while drawings 
are collections of objects.  Individual objects in a drawing can be edited.  Drawings can also take 
advantage of printers with a higher resolution than the screen because each object is stored as a 
mathematical description rather than a collection of dots.
   MacLux does not include this picture inside the plot document.  It only saves the name and location of 
the PICT file with the plot.  If the PICT file gets discarded or moved, MacLux will inform you that it 
can’t find the file and ask if you want to look for it.  Under system 7.0, you may use an alias rather than 
the actual PICT file.
  To remove a PICT from under a plot, choose Use PICT... and click cancel.  A separate PICT can also be 
used with the section view.

Document Size... is limited to 32767 x 32767 pixels.  To make the document the same size as the 
chosen printer's page, click the Page Size button.  Height and width are measured in pixels (1/72 of an 
inch) and are limited to multiples of 8.  A plot may take more than one page to print.  In which case, you 
can trim the pages and fasten them together.  The resulting plot can be Xeroxed onto a single piece of 
paper if desired.

Page Setup... controls printing on the chosen printer.  You can select the paper size and orientation, as 
well as a number of options for each printer.  The page setup is saved with the plot.  If the printer is of a 
different type than the one saved, MacLux will warn you to check the page setup when you select print.
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  The Color Printing box in the Preferences (Edit Menu) also affects how the plot is sent to the printer.  
See page 12 for more information.

Print... sends the current plot to the printer. 

Quit (cmd-Q) closes all open plots and exits MacLux.The Edit Menu
Undo (cmd-Z) cancels your last action.  Not every command is undoable.  Undo works with the draw, 
line and grab tools.  If you mistakenly draw a light or a line or move something to the wrong place by 
accident, undo will reverse your action.  Undo also works with the other commands in the edit menu, 
cut, copy, paste and clear.

MacLux’s Clipboard functions only within MacLux.  It stores only the information attached to an 
object.   This means that you cannot copy and paste between MacLux and another application.  The 
MacLux clipboard contains separate places for light and position information.  Copying the information 
for a line does not displace the information stored for a light.
  MacLux does use the desk scrap as a means of importing custom symbols.  (See Use Scrap under the 
Options menu)  MacLux can also export PICT files and PaperWork creates TEXT files that can be used 
with other applications.

Cut (cmd-X) removes a selected object and places its information on MacLux’s clipboard.

Copy (cmd-C) copies the selected object’s information to MacLux’s clipboard.

Paste (cmd-V) replaces the selected object’s information with the information of the same type on the 
clipboard.  A light receives light information and a line receives line information.

Clear (delete or backspace) removes the object without saving its information.

Color is available only on machines with color QuickDraw.  This includes the Macintosh SE/30, LC and 
any Macintosh II.  MacLux requires 32 bit QuickDraw.  Newer Macs have this built into their ROM.  
Others require an INIT (which comes with the system software from Apple) to be installed in the system 
folder.

  Each Light symbol can be displayed in color.  The symbol color is different than a light’s color name 
which is part of its info.  For example, a light may have the color r55 in the color field of its information. 
It may also be displayed on the screen in light purple.  MacLux allows you to create a library that 
associates color names with screen colors.
  Colors in MacLux look best when displayed with a 24 bit video board.  With 8 bit video, the color 
displayed is the closest match to the specified color in the system palette.
Set Color... (cmd-K) lets you choose a symbol color for the selected light.  This can be done with the 
standard Apple color picker or the MacLux picker. (see below)

Paste Color... (cmd-option-V)  The symbol color of a light is part of the data stored on the clipboard.  
Paste Color transfers only the symbol color from the clipboard to the selected light without disturbing its 
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other data.

Default Color... sets the color that new lights will be drawn with.

Remember Color saves the selected light's color name and symbol color to the Color Library in the 
prefs file.  If a color with that name already exists in the library, MacLux will ask if you want to replace 
it.  

Use Library Colors looks up every light's color name in the library.  If there is a match, MacLux uses 
the library color for the light’s symbol color.  If there is no entry for a light’s color name, Use Library 
Colors does nothing.

Preferences... are read from the MacLux Prefs file that must either be in the system folder (the 
preferences folder under system 7.0) or in the same folder as MacLux.  If there is no prefs file, MacLux 
creates one in the same folder as the application.
   The prefs file controls several options and contains the Color Library.  You can make several copies of 
the prefs file, each containing a different selection of colors.  MacLux only recognizes the one named 
‘MacLux Prefs’.

The default settings are shown.

  Outline    or Solid   symbols can be chosen.

  Colors can be chosen via the standard Apple Color Picker or the MacLux Picker.  Colors in MacLux 
are stored as full 24 bit values.   With less than 24 bit video, the color displayed is the closest match to 
the specified color in the system palette.
  The Apple Picker shows you the exact color you are picking even if the closest color will actually be 
displayed. It also lets you enter values directly for Red, Blue and Green or Hue, Saturation and 
Brightness.
  The MacLux Picker uses scroll bars to adjust Hue, Saturation and Value.  It also displays the 
complementary and triadic colors of the selected color.  Clicking on a complement or triadic color 
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makes that color the new selected color.  Thus, you can use the MacLux Picker to explore color 
relationships.  The MacLux Picker only shows  colors as they will appear on the screen. 

  Color can be turned Off and On.  Color is automatically turned off on machines without color 
QuickDraw in their ROMs.  If you are working on a monochrome monitor, you should turn Color off.
  With Color On, light symbols can be displayed in color and PICT files are exported as color bitmaps.  
Turning Color Off will speed up screen re-draw and will cause PICT files to exported as mathematical 
descriptions of the graphics like those created with MacDraw®.
 
  When Auto Color is On, MacLux checks the color library each time OK is clicked in the info dialog.  
If it finds a match for the selected light’s color name, MacLux uses the library color as the light’s symbol 
color.

  With Color Printing checked (and a color capable Mac), the plot will be sent to the printer as a color 
bitmap rather than a mathematical description of the graphics.  This requires a huge amount of memory. 
Unless you have a color printer, you should make sure this option is off.  This will speed up printing and 
take full advantage of the resolution of your printer.

  Play Note on Open will play a plot’s sound note when it is first opened.

The Sound Menu appears on machines running system 6.07 or greater.  It allows you to record sound 
notes that are attached to a light plot.

Play Note will play a sound note saved with the current plot.

Record Note allows you to record a note if you have a Mac equipped with a microphone or 
other sound input device.  A plot must be saved before a sound can be added.

Delete Note removes the sound note from the file.The Selection Menu
Info... (cmd-I) allows editing of the information attached to each object.
The check boxes determine if certain fields are to be drawn.  Double clicking on an object is the same as 
info.
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  This is the info dialog for a light.  In addition to entering data in the various fields, the dialog lets you 
specify if the channel and color fields are to be drawn.  If the Draw N.C. box is unchecked, a color 
named ‘N.C.’ will not be drawn, but all others will.

  This is the info dialog for a line.  Both the name and note fields may be drawn.  The height is used for 
beam spread calculations and for the section view.   The spacing dialog controls the action of Move, 
Duplicate Light, New Light, and Set Line.  The distance an object is moved, the spacing of lights or the 
length of a line can be set by specifying a distance and direction.  The buttons N,S,E and W are a quick 
way of entering a direction—0° (N) is the top of the screen.  MacLux calculates the number of pixels 
given the entered distance and current scale.  If desired, these X and Y coordinates may be entered 
directly.  The Duplicate and New Light commands allow multiple copies.  The number is determined by 
the 'Number of Units' field.
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Move (cmd-M) offsets the selected object by the distance and direction shown in the spacing dialog.
Duplicate Light clones the selected light, offsetting each new copy by the distance & direction shown.  
The number of copies is also determined by the spacing dialog.
New Light is similar to duplicate light except that new lights (of the current choice of type and 
direction) are created instead of clones.
Set Line offsets the line's second point the set distance from the first.

Dimension calculates the selected line's length in scale feet and inches and places it into the line's 'note' 
field.  This must be repeated if the line’s length changes.

BeamSpread (cmd-B) uses both the selected light's beam spread (out of the key) and the height of the 
position it is hanging on.  It calculates the size of the beam given a plan distance.  Beams can be added 
to a scratch layer of the drawing and displayed in scale.  The beam layer appears in both plan and section 
views.  The beams are not saved with the plot but will be included in an exported PICT file.
  If Color is on, the beams will be displayed in the light's symbol color.  A black symbol is assumed to be 
no color—only its outline is shown.
  Where beams intersect, the resulting mix of colors is calculated and displayed.  With less than 24 bit 
video, the color displayed is the closest match to the actual color that is found in the system palette.  You 
may be able to get a better idea of the actual color with Show Cube. (see below)
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The BeamSpread dialog also allows you to enter a value for candlepower in candelas.  It then calculates 
the horizontal  and vertical  illumination at the center of the beam in footcandles.

Clear Beam Layer disposes of the beams when you're finished.

Show Cube displays a cube shaded by the beams falling on the point where the select tool was last 
clicked.  The shading is calculated by the angle and color (not intensity or distance) of the beams 
striking the selected point and the color of the cube itself.  When an exact color cannot be displayed, 
MacLux uses a dithered pattern to give the impression of that color.  You can save the result as a PICT 
file.

Set Cube Color determines the base color of the cube, the default is white.The Tools 
Menu

 

The Tools menu can be ‘torn off’ and used as a palette.

The Grab Tool  moves objects and text. (g)

The Draw Tool  draws light symbols. (d)

The Select Tool  selects objects. (h)
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The Line Tool  draws hanging positions. (f)

• Each tool may also be selected by pressing the key indicated in parenthesis.

• With the option key held down, the Grab tool will move only text.

• With the command key held down, the Grab tool moves an object the same

  distance as the last object that was dragged.

• Clicking near the end of a line with the Grab tool allows you to change its length.

• Double clicking with the Select tool brings up the info dialog box, which

  allows editing of the information attached to an object.

The Lights Menu

The Lights menu can be ‘torn off’ and used as a palette.

• The Lights Menu selects the symbol that will be drawn with the draw tool.

• The direction a symbol points is selected using the arrow keys or N,S,E and W keys.

• If a light has been selected using the Select tool, choosing a symbol with the Lights Menu will change 
the symbol of that light.

• The Key... command (Options Menu) accesses information about the instrument type represented by 
the symbol selected with this menu.

• You can import your own symbols to replace the one selected with this menu.
(See Use Scrap under the Options menu)

The Lines Menu
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1 Pixel, 2 Pixels, 3 Pixels are the possible widths of hanging position lines drawn with the Line tool.

• Line widths may also be selected with the keys: 1, 2 and 3.

• If a line has been selected using the Select tool, choosing a new size with the Lines Menu will change 
the width of that line.

The Options Menu

Grid On/Off (cmd-G) places a 1 ft. (or 6” depending on the scale) grid under the plot to aid in laying 
out the plot.  Unlike some drawing programs, objects do not ‘snap’ to this grid.

Plan View/Section View switches between the two views of the plot.  The main view is Plan view.  
Section view is provided as a quick aid to visualization.
  No editing can be done in Section view.  Section view plots the location of positions using their 
heights.  All beams are also shown in section.  A separate PICT file may be used in under the section 
view.
  Section view automatically changes the document's size.   The height is the same as the current page 
size.  The width is equal to the length of the sectional cut.  You may change this with the Document Size 
command.  This will not change the plan view's size.

The Show... displays the show, venue, designer and date.

Key... allows editing of information about the symbol selected by the lights menu.  The beam spread 
field is used to calculate and display beams.  Because some lights have variable beams there is a way to 
store a note about the range of beam widths.  Information in the type field following an ∫ (option B) is 
ignored by PaperWork.
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Lights... controls the default info that is placed into a light's fields when it is drawn.  The check boxes 
Draw Color, Draw N.C. and Draw Channel affect ALL the lights in the plot.  To hide all channels, 
uncheck the Draw Chan box.
  The Lights dialog is identical to the Info dialog for an individual light.

Lines... controls the info that is placed into a position's fields when it is drawn.  This info also describes, 
by default, the location of any lights not hanging on (intersecting) a position.  The check boxes affect 
ALL the lines in the plot.  To hide all names, uncheck the box next to the position name.  
  The Lines dialog is identical to the Info dialog for an individual line.

Scale... controls the size of light symbols and how distances are calculated.  
The Document Scale dialog has three options for changing a plot’s scale.  The Set button changes the 
scale leaving existing symbols alone.  The Change All button  resets existing lights to the new scale.  
The Resize button acts like a zoom command because it alters size of the entire plot and temporarily 
changes how an associated PICT file is displayed.  However, the PICT file remains unaltered and will 
revert to its former size if the plot is closed and re-opened.

Sections... sets options for the display of the section view.  Show Line Names draws the name of each 
line next to its location.  Show Floor draws a line representing the floor. (height=0)
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Text Fonts... (cmd-F) controls which fonts are used when an objects' information fields are drawn.  
The defaults for a new document are shown.  Versions of MacLux before 1.6.1 did not support bold and 
italic.  Fonts may need to be adjusted to make a plot display properly with older versions of MacLux.

Use Scrap allows you to import your own symbols through the clipboard.  The change is permanent 
so it is advisable to work with a copy of MacLux.

  Use Scrap tells MacLux to look for a picture on the clipboard.  If it finds one, MacLux replaces the 
currently selected symbol with the scrap PICT.  The symbol replaced, is determined by several factors.  
The type of light and direction are chosen as if you wanted to draw the symbol. (Lights Menu & 
direction keys)  Whether the symbol is an outline or solid is set by the Preferences...  The symbol is 
always saved at 1/4" size.  All other sizes are created by scaling the 1/4” symbol larger or smaller.
  Each type of light has four separate symbols, one for each direction.  A symbol can also be either 
outline or solid.  This makes a total of eight pictures you need to create using a drawing or painting 
program.  If you use a painting program such as MacPaint®, the symbols will be bitmapped.   They will 
not scale or print as well as ones made with a drawing program like MacDraw®.  The maximum size is
64 x 64 pixels.  The size of the outline and solid versions of the same symbol must be identical.

  Save each view you create separately to the scrapbook.  Often you can draw a single direction and then 
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use your application’s rotate command to produce the others.
  Open MacLux and be sure that the type and direction selected as well as the settings in the Preferences 
are the way you want them.  Open the Scrapbook and scroll to the first picture.  Choose Copy from the 
Edit menu.  Click on a window belonging to MacLux or close the Scrapbook.  Choose Use Scrap from 
the Options menu.
  Use the Draw tool to be sure the transfer was successful.  You will note that the Lights Menu remains 
unchanged even though your symbols are installed.
  Repeat for the remaining pictures, changing the direction and Preferences setting for each. 

The Windows Menu

The windows menu displays a list of all open documents.  Selecting a plot from this menu brings it to 
the front.  The first nine plots have function keys associated with them.  Command-1 for the first, and 
so on.

Keyboard Controls

• Either the arrow keys or n,s,e,w can be used to select the direction of light symbols.

• The direction keys select the direction of lights drawn with the draw tool.
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• If a light is selected, pressing a direction key will change the direction of that light.

• Keys can also be shortcuts to selecting line sizes or tools.

• Like any standard Macintosh application, menu commands can be selected with a 
combination of the command key () and a letter.

• Delete or Backspace is the equivalent to selecting clear from the edit 

menu.PaperWork
    PaperWork reads the objects in a MacLux file or files into a relational database and sorts them to 
produce various reports and schedules.  Which MacLux plots are read and how they are sorted is 
controlled by a Show file.  The show file contains instructions about what order the lighting positions 
appear in the reports.  The show file also determines the report's format.
  The resulting reports can be saved as text files or displayed on the screen.  These files can be imported 
into a word processor and printed.  In fact, the creator type (information the Finder uses) can be set so 
that the file can be opened with the word processor from the Finder.
  PaperWork is MultiFinder compatible.  However, a plot cannot be open in both MacLux and 
PaperWork at the same time.  An open show will be re-loaded when you switch to PaperWork (in case 
any changes have been made to the plots).   The default memory setting (300k) is good for up to about 
350 lights.  You may need to increase this for larger shows.

Creating a Show
  1:  If you only have one plot file, choose Open from the File Menu.  Open your plot.  If you have more 
than one file, choose  New from the File Menu.  A dialog appears which allows you to add the files you 
wish to include.  You may designate which plot's key you want to use for the entire show.

  2:  You will want to choose the order that the positions will appear in your report.  Choose Positions... 
from the File Menu.  Only those positions that have lights on them will appear in this list.  You can set 
how the lights on each position will be numbered.  The default is from SL to SR (screen right to screen 
left) and from DS to US (screen bottom to screen top).

  3:  Choose the type of report you wish to create from the PaperWork Menu.  Additional options for 
reports can be found under Report Format... in the File Menu.

  4:  The setup you have just created can be saved as a Show file.  Opening a show file will 
automatically open all of its plots, ready to produce reports.

  5:  Save your reports as text files which you can open with your word processor to finish customizing. 
For best results, when you open the file in your word processor, choose Select All (usually found in the 
Edit menu) and then select a mono-spaced font such as Monaco or Courier.  This will insure that the 
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columns line up properly.

File Menu
  New (cmd-N) creates an empty show file and opens the Plots dialog so that you may specify which 
MacLux files you wish to compile.
  Open... (cmd-O) allows you to either open an existing show file or to open a MacLux file directly into 
a new show.  Only one Show may be open at a time.
  Close (cmd-W) should be selected when you are finished with the current show.
  Save (cmd-S) saves the current show to disk.  The show file will include the settings in the Plots, 
Positions and Report Format dialogs.  A show file does not make a copy of the plot(s), it only records 
their location(s).
  Save As... saves the current show with a new name.

  Plots... controls which MacLux files are included in the current show.  You may add, delete or change 
the order of files.  The replace button will exchange the selected Plot for another.  You may also 
designate which plot's key you want to use for the entire show.

  Positions... lets you specify both the order that the positions will appear in reports and how to number 
the lights hanging on each one.  The default for numbering is from SL to SR (screen right to screen left) 
and from DS to US (screen bottom to screen top).  Only those positions with lights on them will appear.
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  Report Format... lets you customize PaperWork's output.  The size of the position name, type of 
instrument and note fields may be altered.  If you prefer to do the formatting yourself, select Export with 
Tabs.
  Insert Circuit Blanks inserts "____" for each light without a specified circuit.  Uses Dimmers includes 
dimmers as well as circuits in reports.  Also, with Uses Dimmers checked, the Hookup will be a dimmer 
list instead of a circuit list.
  Reports can be shown on the screen or output to a text file.  Reports may be created with the signature 
of your word processor.  This means that the reports created by PaperWork will have the icon of your 
program and can be opened by double-clicking at the Finder.  To find the creator type of your word 
processor, use it to create a “TEXT” file.  (usually through the Save As... command)  Then use the Find: 
button to locate this file.  The signature of your program will appear automatically.

PaperWor

k Menu

   All reports in this menu can be shown on the screen or saved as a text file, depending on the setting in 
the Report Format dialog.  Reports shown on the screen can be viewed one page at a time.  Clicking the 
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mouse will advance to the next page, hitting a key will end the report.  Reports saved as text files can be 
opened with a word processor and printed.  For best results, when you open the file in your word 
processor, choose Select All (usually found in the Edit menu) and then select a mono-spaced font such 
as Monaco or Courier.  This will insure that the columns line up properly.  If you have selected 
Export with Tabs, you can use a proportionally spaced font such as Times or Geneva.  However, you 
will need to adjust the tab settings to make your columns line up.

Instrument Schedule sorts the lights by position and number.

Channel List sorts the lights by channel.

Hookup sorts the lights by either dimmer or circuit, depending on the setting of the Uses Dimmers box 
under Report Format.  The total wattage for each dimmer or circuit is calculated and included in the 
Hookup.

Lamp Count shows how many of each type of instrument are required.  This may be broken down for 
each position.

Color Lists show how many of each color and frame size are needed.  They may be generated either for 
the entire show or also broken down for each position.

MacLux File Types
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