
Welcome to Decision/pro. Decision/pro compares items against criteria and displays which is the best 
alternative. Items to be compared are displayed along the top of the window. Criteria display down the left 
side of the window.    The total score for each item, on a 0 to 10 scale, display along the bottom. 

 Index 
 Decision/pro Commands 
 Using Decision/pro 
 Contacting Jorgansen/Bliss 



What you are comparing.    For example, if you are deciding upon 3 restraunts, the ITEMS would be the 
names of the restraunts. 



How you are comparing the items.    For example, price, distance, and quality of food may be your criteria 
when comparing restraunts. 



Decision/pro Commands 

 Command Index 

 File Menu Commands 
 New command 
 Open command 
 Save command 
 Save As command 
 Print Setup command 
 Print command 

 Edit Menu Commands 
 Cut command 
 Copy command 
 Paste command 
 Preferences command 

 Items Menu Commands 
 Add command 
 Edit Selected command 

 Criteria Menu Commands 
 Add command 
 Edit Selected command 
 Equalize Weights command 

 Range Menu Commands 
 Add command 
 Edit command 
 Delete command 

 Windows Commands 
 Tile command 
 Cascade command 
 Arrange Icons command 
  The Document List 



 The New command 

 Clicking on the File menu then on New will open a blank worksheet. Items and Criteria may now be 
added or they may be copied in from another worksheet or other windows program. 



 The Open command 

 Clicking on File then on Open will ask for the name of the worksheet to open.    You may use the 
File,Open dialog box to change to other sub-directories if the worksheet is not stored in the same 
directory as the Decision/pro application. Click on the name of the file then click on the Open button or 
double-click on the name of the file and you won't have to click on the Open button. 



 The Save command 

 Clicking on the File menu then on Save will save the worksheet information to the filename on the 
worksheet's title bar.    If the title is Untitled, then a Save As dialog box will appear asking for a name for 
the new file. 



 The Save As command 

 Clicking on the File menu then on Save As will prompt for a name for this worksheet file. Use this to 
name an Untitled worksheet or to save your current worksheet under a different name. This will leave 
your original worksheet unchanged. 



 The Print Setup command 

 Print Setup, from the File menu, sets the printer options.    You may use Print Setup to alter the quality of 
the printing (draft or letter-quality, for example), and any other settings supported by your currently 
selected printer. 

 If you wish to change your current printer, use the Printer Icon found in the Control Panel.    "Main" is the 
name of the default Windows program group where the Control Panel is located. 



 The Print command 

 From the File menu, select Print to print the worksheet to your selected printer. The print font is specified 
under the Edit menu, Preferences.    The font and font size selected in the Preferences will be used for 
displaying to the screen and printing the worksheet. 



 The Cut command 

 Selecting Cut from the Edit menu will place the selected rows or columns into the clipboard and delete 
them from the worksheet.    Select rows or columns by clicking on the grey boxes that hold the item or 
criteria names. To select more than one row or column, first click on the first row or column you want to 
select. Then, hold the SHIFT key while clicking the last row or column in the group you want to select. 

 The information in the clipboard may then be pasted into another worksheet, into other rows or columns 
in the current worksheet or another application. 



 The Copy command 

 Selecting Copy from the Edit menu will place the selected rows or columns into the clipboard. Unlike the 
Cut command, the selected rows or columns are not deleted from the worksheet. Select rows or columns 
by clicking on the grey boxes that hold the item or criteria names. To select more than one row or column, 
first click on the first row or column you want to select. Then, hold the SHIFT key while clicking the last 
row or column in the group you want to select. 

 The information in the clipboard may then be pasted into another worksheet, into other rows or columns 
in the current worksheet or another application. 



 The Paste command 
 Selecting Paste from the Edit menu will take information from the Windows clipboard, and paste it into 
selected rows or columns. Pasted information will be inserted if the first selected row or column is before 
the last row or column. Select rows or columns by clicking on the grey boxes that hold the item or criteria 
names. To select more than one row or column, first click on the first row or column you want to select. 
Then, hold the SHIFT key while clicking the last row or column in the group you want to select. 

 If you are pasting information from another program, such as Microsoft Excel spreadsheet or Lotus Ami 
word processor, then the information you are copying (or cutting) should be in a standard format. 

  Pasting columns 
 All information, up to a Carriage Return, will be pasted into a column from the clipboard.    Each item to 
be pasted must be separated by a carriage return to prevent all items from being pasted into a single 
column. 

  Pasting rows 
 All information, up to a Carriage Return, will be pasted into a row from the clipboard.    Rows, 
representing your criteria, have three parts: the name of the critieria, the numeric weight of the criteria, 
and the name of the range of scoring values on how you are measuring this criteria. The 3 parts must be 
separated by a TAB character (or be in three different columns in a spreadsheet application). 

 For example: Criteria One<TAB>100<TAB>Yes or No<TAB> 

 If any information is not entered or understood when pasting, an edit dialog box will appear for you to fill 
in the missing information. 



 The Preferences command 

 Preferences, on the Edit menu, allows changing the look of the worksheet. The options are: 

  Number of spaces to turn into a tab. 
 The number of spaces to turn into one TAB character when pasting criteria information from another 
application such as a word processor.    Decision/pro uses the TAB character to split information in the 
clipboard into the three parts of a criteria: the criteria name, the numeric weight, and the range name that 
the criteria uses for scoring. 

  Include totals on copy 
 Check this box if you want to include the total item scores from the bottom of the worksheet when you 
copy information to another application. 

  Number of characters for Item names 
 How long, in characters, for the Item names.    This affects the width of the columns. 

  Number of characters for Criteria names 
 How long, in characters, for the criteria names.    This affects the width of the row buttons and the heighth 
of each row. 

  Font Type 
 Selects the screen and print font. The font names are those that are supported by both the screen and 
the printer. The selected font will be used for the display as well as when printing. 

  Font Size 
 Selects the screen and print font size in points. If the font is scalable (no fixed sizes) then the choices 
start at 8 points and increase by 2 points up to the maximum scalable size. 



Ranges are used to score each criteria.    If you wish to score a particular criteria on a Yes and No scale, 
you can create a range called "Yes or No" with 2 items in it: "No" and "Yes".    When creating ranges, the 
lowest scoring item is always entered first, then progressing to the highest value. 



 The Add command 
 Displays a dialog box for you to enter an Item name for the new item.    If there are criteria, then the 
scoring values for the new item will default to the highest score. 



 The Edit Selected command 
 Displays a dialog box for you to edit the item names of the selected columns.    If no columns were 
selected, by clicking once on the Item name(s), an error message will let you know. 



 The Add command 
 Displays a dialog box for you to add criteria. You must provide all three items: the name of the criteria, 
the numeric weight of the criteria (between 0 and 100), and the name of the range for how you wish to 
rate the criteria. 



 The Edit Selected command 
 Displays a dialog box for you to edit the criteria for the selected rows.    If no rows were selected, by 
clicking once on the Criteria name(s), an error message will let you know. 



 The Equalize Weights command 
 Sets all of the criteria weights to an equal amount. If there is any remainder, it is added to the first weight. 



 The Add command 
 Displays a dialog box for you to add a numeric or word range. Select Minimum/Maximum from the Add 
menu to add a numeric range or select Word to add a word range. 

 Numeric ranges have two numbers, the lowest scoring number and the highest scoring number.    If you 
were rating a person on a 1 to 10 scale, with 1 as the lowest value, then the minimum number would be 1 
and the maximum number would be 10.    However, if you were rating cars in which Cost was one of the 
criteria, you would enter the highest cost as the minimum and lowest cost as the maximum. 

 Word ranges are all scored on a 0 to 10 scale, no matter how many word items are within the range.    
For example, the "No to Yes" range has two items, "No" and "Yes".    Since "No" is the first item, it has the 
lowest score value and "Yes" has the highest score value. Remember to add word items in lowest to 
highest order. 



 The Edit command 
 First displays a selection box to pick which range name you want to edit.    Then displays the numeric 
range dialog box or the word range dialog box so you can change its name or values. Editing a range that 
is being used by a criteria will reset the rating values for that criteria to the highest value for the changed 
range. 



 The Delete command 
 Displays a selection box for you to pick the range to delete. If your selected range is being used by a 
criteria, you will be notified and the range will not be deleted. 



 The Tile Windows command 
 This command causes all open worksheet documents to be tiled, that is, placed one beside the other, so 
that all can be seen. No window will overlap the other. This only applys to windows that are not minimized 
to an icon. 



 The Cascade Windows command 
 This command causes all open worksheet documents to be cascaded, that is they will overlap each other 
and each will be offset a little bit below the one in back and a little bit to the right of the one in back. This 
command does not apply to windows that are minimized to an icon. 



 The Arrange Icons command 
 This command causes all windows that have been minimized to an icon to be arranged along the bottom 
of the main window in an orderly manner. They start from the bottom, left of the window and work to the 
right then go up a row (if you have that many windows open!). 



 The Window Document List 
 The document list shows the names of all open worksheets. A check mark appears in front of the 
worksheet that is the currently active one. If you want to work on another open worksheet, you can click 
on its title bar or select it from this document list. The desired worksheet will now become the active 
window. 



Using Decision/pro 
 Following are topics designed to lead you through developing a new worksheet, making changes to it 
then exchanging information with other Windows programs. 

 Starting a new worksheet 
 Changing a worksheet 
 Copying and Pasting to other applications 
 Pasting information into your worksheet 



Starting a new worksheet 

 The following topics will lead through building a worksheet.    You may, also, want to review some of the 
sample worksheets provided. Select Open from the File menu and pick a worksheet with a .DP 
extension. 

 Adding new ranges 
 Adding items to the worksheet 
 Adding criteria to the worksheet 
 Rating the items 
 Adding notes to the worksheet 
 Saving the worksheet 
 Printing the worksheet 



Adding New Ranges to the worksheet 

 You will need to add new rating ranges to the blank worksheet for criteria, as you will need the names 
when adding your criteria. Decision/pro has 4 default ranges: "No to Yes", "1 to 10", "1 to 5", and "Poor 
to Excellent". 

 Select Add from the Range menu then select either Minimum/Maximum (for numbers) or Word. 

 Minimum/Maximum Ranges 
 Selecting Minimum/Maximum from the Range, Add menu displays the dialog box for adding a new 
numeric range. Minimum/Maximum ranges are used when you wish to rate a criteria according to a 
range of numbers such as cost.    If you were comparing cars and one criteria was List Price, you would 
add a minimum/maximum range so that you could enter the price of the cars on the worksheet. The 
minimum value is always scored the lowest and the maximum value is always scored the highest.    In 
the cars example, you will put the price of the highest cost car in the minimum value and the price of 
the lowest cost car in the maximum value.    When you type in the price of the cars you are comparing, 
the lower the price, the higher will be the score value on the bottom of the worksheet. 

 Word Ranges 
 Selecting Word from the Range, Add menu displays the dialog box for adding a new word range to 
your worksheet. Word ranges can be used for just about anything. You can also enter numbers as 
items in a word range. The word items get their value from how they are entered in the list, shown on 
the left side of the dialog box. The first item scores the lowest value and the last item scores the 
highest. Keep this in mind when entering in word items. 

 Example: You need to rate a criteria by 3 different values: "Unsatisfactory", "Average", and "Good". 
Type a name to be used when referring to this range in the Range Name field in the Add Word dialog 
box.    Next, type "Unsatisfactory" in the Range Item field and click on the Add button to add the item to 
the list, shown on the left side of the dialog box.    You need to add "Unsatisfactory" first, since it has the 
lowest scoring value. Now, add "Average" then "Good", which has the highest value. Click on the OK 
button and you are ready to use this range when adding or editing criteria. 



Adding a new item to the worksheet 

 Items are the things you will be comparing in the worksheet.    If you were comparing 3 cars; a Dodge, 
a Ford, and a Honda, then the items would be the names of the 3 cars. Select Add from the Item menu 
to bring up the Add Item dialog box.    Type in a name for your item then click on OK. 



Adding a new criteria to the worksheet 

 Criteria define how you are comparing items.    For example, if you want to compare three cars and two 
considerations are the price of the car and the distance to the dealership for repairs, then you have 2 
criteria; Cost and Distance to Dealership.    Since these would be rated with numeric values (Cost in 
dollars and Distance in miles), you will need 2 new ranges; one for the minimum price of the cars and 
maximum price of the cars, and another range for the minimum distance to any of the dealerships and 
maximum distance to any of the dealerships. 

 Selecting Add from the Criteria menu will display the Criteria dialog box.    Fill in the Criteria Name 
(such as "Cost").    The Criteria Weight is a numeric field between 0 and 100. Use this field to take the 
relative importance of each criteria into account. The default is zero. If you leave the weight as zero, the 
rating that you select will have no weight, and so no score at the bottom. You can leave this at zero and 
edit the criteria after you have added all the criteria that you will use. If you try to exceed 100%, an error 
box will tell you how much weight out of 100% is left. Finally, you must specify the Name of the Range 
that will be used when rating the criteria. 



Changing the rating of a criteria for an item 

 Double-clicking on a cell (where the item columns meet the criteria rows) with the left mouse button 
lets you change the rating. If the range is numeric, then an Edit dialog box will appear with the current 
rating value. Type in a new number and press ENTER or click OK. If the new number is not within the 
range specified for the criteria (the minimum or maximum value), an error box will tell you what the 
minimum and maximum values are. If the range is a word range, then a list of word values will appear. 
Click on the value you want then click OK. The list box will go away and the rating will be changed to 
the new value you selected. 

 The total for the item column, on the bottom of the window, will update to reflect the change you made 
to the rating of the criteria. 



Adding notes to the worksheet 

 You can add a note to each cell (where the item columns meet the criteria rows) in the worksheet. 
Double-click on the cell with the right mouse button to bring up the Note dialog box. Type in your note 
or make changes to a note previously added. Click OK to finish. A number will appear after the rating 
value in the cell to let you know that a note is appended for this cell. 

 Any notes that you have added will be printed along with the rest of the worksheet.    Notes print sorted 
with the lowest number printing first then increasing down the page. 



Saving the worksheet 

 Selecting Save or Save As from the File menu will save the work you have done on the worksheet. If 
this is a new worksheet, then it has no filename.    Selecting either Save or Save As will bring up the 
Save As dialog box for you to enter a filename. If you select a filename that already exists, you will be 
asked if you want to replace the file. 



Printing the worksheet 

 Print, from the File menu, prints the worksheet on your currently selected printer. You can select a new 
printer in the Printers selection of the Control Panel icon, usually found in the MAIN program group in 
Program Manager.    The printer will use the font selected under the Edit, Preferences menu in 
Decision/pro, if your printer is capable of using the font and the font size. 

 Print Setup, under the File menu, lets you set different printing options that are supported by the 
selected printer.    For example, if you want to print the worksheet in landscape mode (sideways on the 
page), you would use Print Setup to change your printer from Portrait to Landscape. If your printer does 
not support landscape printing, then the option will not be displayed under Print Setup. 



Changing an existing worksheet 
 The following items give help on making any changes you need to your worksheet. 

  Editing and deleting Items 
  Editing and deleting Criteria 
  Editing and deleting Ranges 
  Deleting notes 



Editing and deleting items 

 Editing Items 
 Select    the item or columns of items to edit by clicking on the grey box that holds the item name. 
Choose Edit Selected from the Items menu. The Edit Item dialog box will display for each of the 
selected columns.    If you CANCEL the edit box, it cancels the rest of the editing. 

 Deleting Items 
 Select    the item or columns of items to delete by clicking on the grey box that holds the item or criteria 
name. Choose Cut from the Edit menu and the items will be cut from the worksheet. 



Editing and deleting criteria 

 Editing criteria 
 Select    the criteria or rows of criteria to edit. Choose Edit Selected from the Criteria menu. The Edit 
Criteria dialog box will display for each of the selected rows. If you CANCEL the edit box, it cancels the 
rest of the editing. 

 Deleting Criteria 
 Select    the criteria or rows of criteria to edit by clicking on the grey box that holds the criteria name. 
Choose Cut from the Edit menu and the criteria will be cut from the worksheet. 



Editing and deleting ranges 

 Editing ranges 
 Select Edit from the Ranges menu. Click on the range you wish to edit in the selection box and click 
OK. If you edit a range that is being used by a criteria, the rating value for that criteria will be reset to 
the highest value for the changed range. 

 Deleting ranges 
 Select Delete from the Ranges menu. Click on the range you wish to delete in the selection box and 
click OK. You cannot delete a range while it is being used by a criteria. 



Deleting notes 

 Double-click on the cell (where the column meets the row) of the rating value that has the note, using 
the right mouse button. When the dialog box appears with the note, select all of the note and delete it 
by pressing the backspace key. Click on OK and the note will have been deleted. 



Copying information from the worksheet 

 Select    the rows or columns that you want to copy. Choose Copy from the Edit menu and the rows or 
columns you selected will be copied to the clipboard. You can paste these items elsewhere in 
Decision/pro or paste them into another Windows application. 

 If you are copying row (criteria) information to another program, besides the criteria name and rating 
information, the weighting value for the criteria and the rating range name for the criteria will also be 
copied. This is to maintain consistency when pasting this information into Decision/pro. 



Pasting information to the worksheet 

 Select a row or column to start pasting information into Decision/pro. Rows or columns will be inserted 
automatically, if more than one item or criteria is to be pasted. 

 Pasting Item names 
 If you are pasting columns, all information up to a Carriage Return will be considered the item name. 
Any information after the first Carriage Return will be considered a new item name. Each item name 
must be seperated by a Carriage Return. Since items get their value from existing criteria, the highest 
rating value for the criteria will be assigned to the items that have been pasted.    You can then change 
the rating values as you require. 

 Pasting Criteria 
 If you are pasting rows, a full row consists of a Criteria name, a Criteria weight number (from 0 to 100), 
a Rating range name and the rating values ended with a Carriage Return. Each piece of information is 
seperated by at least 2 spaces or a tab. If you are pasting information created by a word processor, 
make sure that each piece of information for the row is seperated by a tab or at least 2 spaces. If the 
first 3 pieces of data you are pasting are not understood as being a valid name, numeric weight and 
existing rating range name, you will be presented with an Edit Criteria dialog box so you can fill in the 
"missing pieces". 

 EXAMPLE: 
 This is the way the data would look in a word processor program. The names between the brackets 
"<>" are the keys that are used, like <TAB> means that the tab key was pressed. The example 
illustrates a criteria to be pasted into Decision/pro with a name of "Criteria Name", a weight of "100" and 
being assigned a rating range name that already exists in Decision/pro called "No to Yes". There are 2 
columns in the Decision/pro worksheet that this data is to be pasted. This is why there are two rating 
values: "Yes" and "No". An <Enter> key was pressed after the line to tell Decision/pro that this is the 
end of the row to be pasted. In the second example, 2 spaces seperate each piece of data. 

 Criteria Name <TAB> 100 <TAB> No to Yes <TAB> Yes <TAB> No <ENTER> 

 Criteria Name <SPACE> <SPACE> 100 <SPACE> <SPACE> No to Yes <SPACE> <SPACE> Yes 
<SPACE> <SPACE> No <ENTER> 

 Decision/pro will fill in the rating values that are pasted into the rows.    If the rating values do not fill up 
the number of columns available then the highest rating value for that criteria will be used in the missing 
columns. 



To select one row or column, click on the grey box that holds the item name (for columns) or criteria 
name (for rows). 

 To select more than one row or column, click on the first row or column that will begin the selection. 
Move to the last row or columns that you want to select and, while holding down the SHIFT key, click on 
it. All of the rows or columns between the first and last one will be selected. 



Choosing Preferences from the Edit menu, brings up the Preferences dialog box. The first item is the 
number of spaces to convert to a tab when pasting rows into Decision/pro. The default is 2. This means 
that, when pasting criteria from another application, if 2 or more spaces are encountered, they will be 
replaced by a tab. This tab is used as a seperator for the pieces of data to be pasted into a row. You 
can change this number if you want to leave more than 1 space between words when you paste into 
Decision/pro from other programs such as word processors. 



How to contact us 

 If you need help, have a question, or run into any problems, we have multiple ways to contact us. We'd 
love to hear any comments or suggestions for improvement. 

 Remember, this program is Shareware. If you like it and continue to use it beyond the initial evaluation 
period, you must register it. For $39.95 U.S. (checks or money orders, please), you will receive the 
latest version and printed manual. Sorry, we cannot accept credit cards without significantly raising our 
prices, so out they go! 

 Send payment to: 
 Alan Johnson 
 124 Haywood Drive 
 E. Brookfield, MA 01515 

 CompuServe 
 Alan Johnson 
 CIS ID: 76120,556 

 GEnie 
 Alan Johnson 
 GEnie ID: XTH34420 




