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Chapter 1

AXlife

1.1 AXlife Guide

AXlife 1.1 Based on Xlife 2.0
© 1994 David Kinder © 1989 Jon Bennett

About Life

Xlife and AXlife
Running AXlife
Controlling AXlife
Life File Format
History

1.2 About Life

The Game of Life was invented by the mathematician John Horton Conway,
and has gone on to become the most famous example of a cellular automata.
The idea is to demonstrate that complex behaviour can result from the
application of very simple rules, which are:

The game is played on an infinite two-dimensional plane, composed of
squares (cells). At any time a cell can only be either alive or dead.
Time progresses in discrete steps, with the pattern of live and dead
cells at a given time being refered to as a generation. Each new
generation depends only on the previous generation. Given a generation,
the next generation is calculated by looking at each cell in turn. A
live cell will stay alive if surrounded by two or three neighbours,
otherwise it will die. A dead cell will be reborn only if surrounded by
exactly three neighbours.

To see this in effect, run AXlife and select "Open" from the Project
menu. Files to try include "acorn.life" and "rpentomino.life", both of
which start with only a few cells but rapidly produce a large pattern,
or "puffertrain.life" and "breeder.life", both of which produce an ever
growing pattern. Select "Generate" from the Cells menu to start the
generation process. Some of the files contain quite detailed comments
about the design and purpose of the pattern, which help to teach how to
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make new patterns.

Life can be used to generate objects of fantastic complexity. Logic
gates and even (in theory) a Turing machine (i.e. a completely general
computer) can be created. For example, in the included patterns (taken
from the Xlife distribution and Al Hensel’s IBM PC program "Life") are
a prime number sieve, a pseudo-random number generator and several
systems for implementing memory registers.

For more information, see:

William Poundstone’s "The Recursive Universe" (Oxford University Press)
Martin Gardner’s "Mathematical Games" column in Scientific American,
Octocber 1970 and February 1971.

1.3 Xlife and AXlife

AXlife is based on Xlife, the definitive life program, which runs under
the X-Windows graphical interface (which overlays UNIX). AXlife
incorporates an Amiga-specific interface, but the basic generation code
remains the same as in Xlife 2.0. AXlife can also read files produced
by Al Hensel’s IBM PC program "Life", which has a very similar format.

The most important feature of Xlife (and AXlife) is that, unlike

most life programs, it does not limit the pattern to the size of the
screen. Xlife does not think in terms of a rectangular grid, but instead
considers the pattern to be composed of 8x8 boxes containing active life
elements. This allows Xlife to cope with arbitrarily large patterns (up
to a maximum size of 2732 by 2732 (2732 = 4,294,967,296)). The best
demonstration of this is the "breeder.life" patterns, which all grow at
an ever increasing rate. On a fast computer, these patterns rapidly
become *veryx large.

From the Xlife distribution:
XLife Copyright 1989 Jon Bennett jb7m+@andrew.cmu.edu, jcrb@cs.cmu.edu

Permission to use, copy, modify, distribute, and sell this software
and its documentation for any purpose is hereby granted without
fee, provided that the above copyright notice appear in all copies
and that both that copyright notice and this permission notice
appear in supporting documentation, and that the name of the
copyright holders not be used in advertising or publicity
pertaining to distribution of the software without specific,
written prior permission. The copyright holders make no
representations about the suitability of this software for any
purpose. It is provided "as is" without express or implied
warranty.

THE COPYRIGHT HOLDERS DISCLAIM ALL WARRANTIES WITH REGARD TO THIS
SOFTWARE, INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND
FITNESS, IN NO EVENT SHALL THE COPYRIGHT HOLDERS BE LIABLE FOR ANY
SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN
AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING
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OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS
SOFTWARE .

1.4 Running AXlife

The most important thing you need to run AXlife is memory, and plenty of
it. AXlife will not load unless you have about 850K of free memory, and
as a pattern grows more memory is consumed. This is due to the method
used to calculate the next generation, which involves a huge lookup
table. For large patterns, this is by far the most efficient approach.
AXlife requires asl.library and, to be able to access the online

help, amigaguide.library. AXlife will also try to use textfield.gadget
to allow editing of comments. If this file cannot be found, comments can
only be viewed.

AXlife can take several arguments from the Shell or as ToolTypes in its
icon. In either case, the format is identical. The arguments are:

PUBSCREEN=<pubscreen name>
Specifies that AXlife is to open on the named public screen, e.qg.
PUBSCREEN=PowerPacker. If the screen is not available AXlife falls
back onto the default public screen. Note that the name of a public
screen 1s case sensitive.

FILREQ=<left/top/width/height>
Specifies the position and size of the file requester used for
loading and saving life patterns., e.g. FILEREQ=0/0/320/200. Out
of range values are ignored. If a value is negative, then the
default value will be used, e.g. FILEREQ=-1/0/-1/200 causes the
requester to be 200 pixels high and start at the top of the screen,
but with the default width and left position.

HIDE
Enables the "Hide Cells" item of the Options menu.

STATUS
Enables the "Show Status" item of the Options menu.

CELLS
Enables the "Cell Count" item of the Options menu.

CLROPEN
Enables the "Clear on Open" item of the Options menu.

MAG

Specifies the magnification to use, i.e. MAG=n, where n is one of
1, 2, 4, 8, or 16. When AXlife is running, the magnification is
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controlled by the "Magnification"

1.5 Controlling AXlife

The following menus are available in AXlife:

Project

Cells

Options

sub-menu of the Options menu.

The centre of the displayed area can be chosen by clicking on the

desired new centre square with the left mouse button. Also,
<Return> or <Enter> keys causes the next generation to be calculated and

displayed (i.e. single-step). The numeric keys of the keypad have the

following functions assigned to them:

Finally,

Move centre of
displayed area
up and left.

Move centre of
displayed area
left.

Move centre of
displayed area
down and left.

Move centre of
displayed area
up.

Centre display on

weighted centre
of the pattern.

Move centre of
displayed area
down.

6:

Move centre of
displayed area
up and right.

Move centre of
displayed area
right.

Move centre of
displayed area
down and right.

pressing the "Help" key gives access to the online help. If

a menu is currently selected, then this help file will open on the
appropriate section for that menu.

1.6 Project Menu

Open

pattern to be loaded.

"Set

Open"

A file requester opens to allow selection of a life

If the

If the file format is relative,
then the file will be loaded relative to the spot
Spot" item in the Options menu) .
item of the Options menu has been selected, then the
life pattern currently in memory will be lost,

(see the

"Clear on

otherwise

the new pattern will be overlayed on the current one.

Save As

save the current pattern under.
"Comments" requester will also be saved.

alre

overwriting of the file.

Comment

current pattern,

A file requester opens to allow the selection of a name to

Any information in the
If the file

ady exists, a requester will appear to confirm the

S A window opens which contains information about the

namely a descriptive name for the pattern

(which is unrelated to the name the file is saved as), the

owner of the pattern,

and any comments.

All these can be

pressing the
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edited by clicking on the appropriate gadgets (for more
information on the keys available while editing comments,
see textfield.gadget).

Help If amigaguide.library is available, displays this help
file.

About Some information about AXlife.

Quit Quits AXlife. Any unsaved patterns will be lost.

1.7 Cells Menu

Clear Clears the current life pattern from memory, leaving an
empty life plane.

Randomize Fills the area of the life plane on display with a random
pattern of live cells. Due to the way AXlife works, such
random patterns are very inefficient and will take a long
time to generate.

Centre Centres the displayed area on the weighted centre of the
complete pattern. The "5" key on the numeric keypad has
the same function.

Generate If this is checked, generations are calculated
continuously. If not, no calculating is done.

One Generation If the "Generate" option is not checked, this will cause
a single generation to be calculated and displayed,
giving a single-step method to observe the evolution of
a pattern. This can also be acheived by pressing either
of the <Return> or <Enter> keys.

New Rules The default rules for life are 23/3, which means that a
cell stays alive if surrounded by 2 or 3 neighbours, and
that a cell is reborn if surrounded by 3 other cells. If
you wish to try different rules, enter the new rules in
the string gadget and press <Return>, or click on
"Accept". The format must always be numbers representing
the possible numbers of neighbours when a cell stays
alive, a forward slash (/), and then numbers representing
when a cell will be reborn.

Benchmark This gives an indication of the raw speed of the life
generation engine. Enter the number of generations to time
over in the gadget and press <Return>, or click on "Time".
The generations will be calculated, but not displayed, as
displaying the pattern can use up a lot of cpu time (see
"Hide Cells" in the Options menu). When this is complete,

a requester will appear giving the total time taken and
the average generation rate.
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1.8 Options Menu

Edit Mode If this options is selected, the current pattern can be
edited. When the mouse pointer is over a specific cell,
clicking the left mouse button puts a live cell at that
point, while clicking the right mouse button clears the
cell (i.e. puts a dead cell). Note that in this mode the
menus are disabled (so that the right mouse button can be
used for cell editing), but keys are still functional.

Edit mode can be exited by pressing the <Esc> key.

Hide Cells The computer can spend almost all its time updating the
display rather than calculating the next generation. If
it is required that the generation engine runs as fast as
possible, select this option to avoid redrawing the
display. When this option is deselected, the pattern will
reappear. On a fast machine with this switch on, AXlife
runs *extrememly* quickly.

Show Status If selected, AXlife to print the number of generations
and of boxes (the generation engine treats the entire
pattern as composed of 8x8 boxes) in the window title bar.

Cell Count If this and the above "Show Status" options are selected,
then in addition to printing the number of generations and
boxes, AXlife will print the total number of live cells
for each generation. Note that this requires further
calculation and will cause a noticeable drop in generation
speed.

Clear on Open If this option in selected, then the current pattern is
erased before a new pattern is loaded (via the "Open" item
in the Project menu).

Set Spot Initially, relative files are loaded relative to the
centre of the display. If this item is selected, clicking
the left mouse button sets the spot to a new position, and
pressing <Esc> leaves this mode without setting the spot.

If the display is cleared or centred then the spot is
reset to the centre of the display.

Magnification This submenu determines the size of each cell on screen.
If 1 is selected, then each cell is represented by a
single pixel; if 2 is selected, then each cell is
represented by a 2x2 square; if 4 then by a 4x4 square,
and so on.

1.9 Life File Format

Life patterns are stored as ASCII files. A line beginning with a hash (#)
has a special meaning, depending on the next character:

#N The rest of the line is the descriptive name of the file, which
is not related to the actual file name the file is stored as.
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#0 The rest of the line gives the owner of the file.

#C The rest of the line is a comment (see the "Comment" item in the
or #D Project menu) .

#A This specifies that the data is in absolute xy coordinate pairs,

each pair specifying an active cell in the pattern. The data is
absolute in the sense that the loaded pattern appears in the
same place relative to the display as when it was saved.

#R This specifies that the data is in relative xy coordinate pairs,
each pair specifying an active cell in the pattern. The data is
loaded relative to the spot (see the "Set Spot" item in the

Options menu). The data can be offset by a coordinate pair

which optionally follows the #R, e.g. #R 10 11.

#P This specifies that the data is stored in picture format, with
an asterisk (%) representing a live cell and any other character

an empty cell. The data is loaded relative to the spot, as

above. The data can be offset by a coordinate pair which

optionally follows the #P. A file can contain more than one

picture element, each with its own #P.

#I The rest of the line specifies a file to be included, so that
Life patterns can be nested. Beware of including patterns not

in the same path as the parent pattern, as path conventions

differ between the Amiga and UNIX (This does not occur in any

of the supplied patterns). The data can be offset by a

coordinate pair which optionally follows the #I.

It is not necessary for a file to contain all (or indeed any) of the
above. If non of #A, #R or #P are specified, #A is assumed.

1.10 History

1.0 * First release.

1.1 * New "Help" menu item to call up this file.

* Pressing the "Help" key now also brings up this file. If a
menu is selected when the "Help" key is presses, help on
that menu is displayed.

* Better SysIHack compatibility.

x If available, textfield.gadget is used to provide a multi-
line string gadget for the "Comments" window.

* If the user attempts to save to a file which already exists,
a requester appears to confirm the save.

If you have any comments, bug reports, etc. direct them to

kinder@teaching.physics.ox.ac.uk
or david.kinder@physics.ox.ac.uk

I can also be reached (eventually) at
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2, Clwtt Cottages,
Bangor Road,
Gyfelia,

Clywd.

LL13 0YL

U.K.

1.11 Asl Library

"asl.library" provides standard file and font requesters and is part
of the normal Workbench 2.0+ distribution. It should be in the LIBS:

directory of your boot disk or partition.

1.12 AmigaGuide Library

"amigaguide.library" provides support for displaying AmigaGuide® format

documents and is part of the normal Workbench 3.0+

distribution. A

version released by Commodore for earlier systems is available in the

Fred Fish collection and on the Aminet archive.

1.13 TextField Gadget

"textfield.gadget" is a BOOPSI gadget which allows
multi-line string gadgets. "textfield.gadget" is ©

For Workbench 3.0 and higher, copy the file to SYS:

Although Workbench 2.0 and 2.1 support the gadget,
place in the system to install it. It is suggested
subdirectory "gadgets" in your LIBS: directory and
Alternatively, you can leave it with AXlife in the
subdirectory.

programs to use
1994 Mark Thomas.

classes/gadgets.
there is no standard
that you create a
copy it there.
"gadgets"

While using the gadget, the following keys are available (reproduced

from the "textfield.gadget" documentation):

Shift Cursor Up Move to the top line in the current page, or
scroll up one page if cursor is on the top line.

Shift Cursor Down Move to the bottom line in the

or scroll down one page if cursor is on the top

line.
Ctrl or
Shift Cursor Right Move to the far-right end of

Ctrl or

current page,

the current line.

Shift Cursor Left Move to the far-left end of the current line.

Shift Backspace Delete all the text to the left of cursor on

the current line.
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Shift Delete Delete all the text to the right of the cursor
on the current line, including the highlighted
character.

Ctrl Cursor Up Move to the top line of the text.

Ctrl Cursor Down Move to the bottom line of the text.

Alt Cursor Right Move to the next word.

Alt Cursor Left Move to the previous word.

Alt Cursor Up Move to the first character in the gadget.

Alt Cursor Down Move to the the last character in the gadget.

Alt Backspace Deletes the word to the left of the cursor,
starting at the current cursor position.

Alt Delete Deletes the word to the right of the cursor,
starting at the current cursor position.

Ctrl x Deletes the whole line that the cursor is on.

Right Amiga e Erase all text in the gadget, and store in the
undelete buffer.

Right Amiga v Paste text from the clipboard to the current
cursor position.

Right Amiga a Mark all text.

Right Amiga u Undelete the last block of text marked, or
recover from Right Amiga e.

When text is highlighted the following keys are available:

Delete or Erase marked text (saved in the undelete buffer).
Backspace

Right Amiga x Cut marked text to the clipboard.
Right Amiga c¢ Copy marked text to the clipboard.

Right Amiga v Replace marked text with text from the clipboard
(saving marked text in the undelete buffer).

Any text key Replace marked text with that character.

1.14 Index

About Life
AmigaGuide Library
Asl Library

AXlife Guide
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Cells Menu
Controlling AXlife
History

Life File Format
Options Menu
Project Menu
Running AXlife
TextField Gadget
Xlife and AXlife
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