
Help for PowWow

Overview
PowWow is an Internet chat, file transfer and Web Browser interface program that allows group cruising 
of the World Wide Web.    Version 1.3 allows two people to chat and cruise together. Group cruising works 
only with Netscape browser 1.1 or later. PowWow allows you to establish a connection to another person 
on the Internet who is using PowWow by specifying their email address.    You do not need to know their 
IP address.    Dynamic IP addresses are automatically resolved by PowWow.    The person to whom you 
wish to connect is alerted that a connection has been requested, provided their PowWow program is 
running.

Running PowWow
To allow other people to connect to you, you must have PowWow running.    After Winsock has been 
initialized, select the PowWow icon.    A dialog box will appear requesting your local user I.D. and 
password.    Enter your E-mail address as your user I.D.    You may choose any password.    Select OK.    
The PowWow main screen will appear.    At the bottom of the screen the message "attempting to register 
with PowWow server" will appear.    If your INTERNET connection is properly functioning, the message 
"Registration accepted by Server" will appear within a few seconds.    PowWow is now active and ready 
for connection to or from another PowWow user.    If you are not intending to immediately connect to 
someone, minimize the PowWow screen so that PowWow can remain active in case someone wishes to 
connect to you.
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Edit Menu

The Edit menu includes commands that enable you to change the text in the PowWow edit windows.

For more information, select the Edit menu command name.

Clear Deletes text without moving it to the clipboard.



File Menu

The File menu includes commands that enable you to send files, and exit PowWow.

For more information, select the File menu command name.

Send Send a file to the person you are currently chatting with.
Exit Shut down connections and exit PowWow application.



Glossary



Exiting

To exit PowWow select Exit from the File menu.



Edit Clear Command

The Clear command allows you to clear the send and receive windows of all text and moves the cursor to 
the top left hand corner of the send window.    All text currently in the window will be lost.



File Send Command

PowWow has a file transfer utility that allows you to send a file to the person you are chatting with.    Once 
you are connected and chatting with someone then the Send option will be enabled.    Use this to select a 
file to send.    The person you are chatting with will then be notified that you wish to send them a file.    
They can then accept the file or refuse it.    If accepted the file will be sent and a status window will show 
the progress of the file transfer.    When the receiver has finished receiving the file the status windows will 
automatically shut down.    The download file directory may be set by selecting the SETUP - FILES and 
DIRECTORIES option.

You may continue chatting while the file transfer is active.



File Exit Command

The Exit command will close all current connections to and from PowWow and will shut down the 
PowWow application.



Setup Menu

The Setup menu includes commands that enable you to configure PowWow and save the configuration 
for PowWow.

For more information, select the Setup menu command name.

Local Info
Font
PowWow Book
Runtime
Files and Directories
Save Settings
Save Window Info



Connect Menu

To connect to another person using PowWow select the connect option and either enter the email 
address of the person you wish to contact or select one of the email addresses from the list in your 
PowWow book by dropping down the list box.

If the email address you have entered allows for a direct connection (i.e. the person has a fixed, rather 
than dynamic IP address) you can select the direct connection option.    This avoids the PowWow IP 
lookup process and saves 15 or more seconds in the initial connect time.    If you do not know whether the 
person you wish to contact has a fixed IP address, then do not select the direct option.    The lookup 
function will still work.

To add a newly entered connection to your PowWow book check the Add Connection option prior to 
selecting OK.    This will also save your selection for the direct versus lookup setting for this connection.

For more information, select the Connect menu command name.

Connect
Disconnect



Cruise Menu

PowWow has the ability to communicate with the Netscape Web Browser version 1.1 or later.    This 
allows you to lead someone through the Internet with your browser.    In order to lead the person you are 
chatting with, select the Cruise-Launch option.    If your browser is not already running then it will be 
launched and a connection to it established.    Once the connection to the browser completes successfully 
the person you are chatting with will be notified that you would like to lead them in browsing the Internet. 
They can then accept or refuse the cruise request.    If accepted the browser will be launched, if need be, 
and a connection established to the browser.    Once the connections are established on both sides, 
whenever the 'leader' opens a new URL then the 'follower' will be routed to the same location.

If you stop cruising, the connections to the browser will be dropped but the browser will remain running.

If you are using your Netscape Browser and have PowWow running, then any URL's of type 
powwow:email@address can be used to initiate a chat connection to the specified user just as if you had 
done a connect to that email address from within PowWow.    This function may be used to allow Web site 
operators to communicate directly with a user who is viewing a given Web page.

For more information, select the Cruise menu command name.

Launch
Stop Cruising



Local Info

Use the local info setup to specify the email address that can be used to contact you for chatting.    This 
should be in the form of name@host.address.    When someone attempts to connect to you for chat, 
PowWow will verify that the name being requested matches the name in the PowWow lookup table.

The password you select is saved with this email address on the PowWow lookup server, as is the 
method that can be used to connect to your email address.    On subsequent registrations to the PowWow 
lookup server, the registration will fail to change the IP address for this email address if the correct 
password is not used.

The save password option allows you to save the current password in the INI file so that you will not have 
to re-enter each time. 

The access method is also stored on the PowWow lookup server.    If the email host.address part of your 
email address is the machine name for the hostmachine that will be running PowWow, then you can 
select direct connection and thus notify those people that do a lookup on your email address that 
subsequent connections can be done by direct connect rather than lookup.



Font Setup

Select the font to use for the send and receive windows.



PowWow Book

The PowWow book setup allows you to manage your list of connection addresses.    You can highlight a 
connection and remove it or you can enter a new selection.

In the list of connections a ,',L' at the end of the email address specifies that a lookup should be 
performed when establishing a connection to this email address, whereas a ',D' specifies that the email 
address is a direct link to the person so no lookup is necessary.



Runtime Setup

The runtime setup allows you to set the defaults for request responses and window buffer sizes.

Each request type (talk, file transfer, and cruise) can be set to either prompt you when a request is 
received or to automatically refuse the request.

The buffer sizes can be set to your desired buffer size (providing your system has enough memory to 
accommodate your requested size buffer) in lines for the current width of the PowWow window.



Files and Directories

You can specify the download directory, sound file, and browser file to use in PowWow through the files 
and directories setup option.

The download directory specifies which directory will be used for files that are downloaded through 
PowWow.    The default is the directory from which PowWow is running.

The sound file is the sound that will be played when a request is received within PowWow.    If your 
system does not have support for wav files then a beep will be sounded instead.

The browser file is the name and directory path where your browser is located.    PowWow requires at 
least version 1.1b2 of the Netscape Web Browser in order to be able to utilize the cruise feature.



Save Settings

Saving the current settings will save the currently configured settings under the setup menu.



Save Window Info

Saving the current size and position of the PowWow window.



Connect

To connect to another person using PowWow select the connect option and either enter the email 
address of the person you wish to contact or select one of the email addresses from the list in your 
PowWow book by dropping down the list box.

If the email address you have entered allows for a direct connection (i.e. the person has a fixed, rather 
than dynamic IP address) you can select the direct connection option.    This avoids the PowWow IP 
lookup process and saves 15 or more seconds in the initial connect time.    If you do not know whether the 
person you wish to contact has a fixed IP address, then do not select the direct option.    The lookup 
function will still work.

To add a newly entered connection to your PowWow book check the Add Connection option prior to 
selecting OK.    This will also save your selection for the direct versus lookup setting for this connection.



Disconnect

Select disconnect to discontinue chatting with someone and stop all file transfer and cruise connections.    
This will break the connection to the person you were chatting or attempting to chat with.



Launch

PowWow has the ability to communicate with the Netscape Web Browser version 1.1 or later.    This 
allows you to lead someone through the Internet with your browser.    In order to lead the person you are 
chatting with, select the Cruise-Launch option.    If your browser is not already running then it will be 
launched and a connection to it established.    Once the connection to the browser completes successfully 
the person you are chatting with will be notified that you would like to lead them in browsing the Internet. 
They can then accept or refuse the cruise request.    If accepted the browser will be launched, if need be, 
and a connection established to the browser.    Once the connections are established on both sides, 
whenever the 'leader' opens a new URL then the 'follower' will be routed to the same location.

If you stop cruising, the connections to the browser will be dropped but the browser will remain running.

If you are using your Netscape Browser and have PowWow running, then any URL's of type 
powwow:email@address can be used to initiate a chat connection to the specified user just as if you had 
done a connect to that email address from within PowWow.    This function may be used to allow Web site 
operators to communicate directly with a user who is viewing a given Web page.



Stop Cruising

If you stop cruising the connections to the browser will be dropped, but the browser will remain running.



Support

Please email technical questions to support@tribal.com.    Comments and suggestions should be sent to 
powwow@tribal.com.



About Tribal Voice

Tribal Voice is an organization of Native Americans, from various tribes, dedicated to the development of 
a Native American technological presence in the world of information science. The source of all of Tribal 
Voice output is Native American in concept, architecture and implementation.    Tribal Voice is endowed by 
the Native American Trust and the McAfee Foundation.

PowWow version 1.3b is the copyrighted property of Tribal Voice.    It may be freely used and distributed, 
without charge, by anyone.

Tribal Voice
627 West Midland Avenue, Suite 210
Woodland Park, Colorado 80863-1100
phone: 719 687 0480
fax: 719 687 8176




