Overview of Using Internet Mail

The Internet is a worldwide collection of thousands of interconnected computers. You can use Internet Mail to communicate with
anyone on the Internet or any network with SMTP and POP3 services. With Internet Mail, you can establish a connection to the
Internet from your own personal computer, and send and receive mail over the Internet using Microsoft Exchange.
Tip

To view help for The Microsoft Network, click The Microsoft Network Help Topics from the Help menu in Microsoft

Exchange.

Connecting to the Internet Using a Modem

To connect to the Internet using a modem, you’ll need TCP/IP on your computer, Internet Mail, Dial-up Networking (installed
during Microsoft Windows 95 Setup or through Add/Remove Programs in Control Panel), and an Internet service provider that
supports PPP, SMTP, and POP3. Internet Mail receives mail from POP3 servers and sends mail using SMTP, so be sure that
the Internet provider supplies these services.

Local and regional providers can provide the connection for you, and the phone call charge is usually at local prices. If there
aren't any local services, check for providers with direct-dial long distance charges. Check your local listings, trade magazines, or
a local computer store for Internet providers.

Note
You also have the capability of using SLIP with Internet Mail.

Connecting to the Internet Using a Local Area Network (LAN)

To connect to the Internet using a LAN, you'll need TCP/IP on your computer, Internet Mail, a network adapter (installed during
Microsoft Windows 95 Setup or through Add/Remove Programs in Control Panel), and a server that provides a connection to the
Internet and supports TCP/IP, SMTP, and POP3. For more information, see your mail administrator.

Using Internet Mail

Internet Mail can be added to an existing Microsoft Exchange profile or can be used in a profile of its own. To create an Internet
Mail profile, you specify how your computer is connected to your Microsoft Exchange mailbox and indicate your preferences for
delivering and working with messages. If you want to have more than one type of connection, you need to create a profile for
each type.

Your profile indicates how messages are delivered to and from your mailbox. You can update your profile as needed, or when
you are working with Internet Mail, you can change the message settings for individual messages.

You can specify several transfer options. These include the type of message format for outbound and inbound messages, the
character set (depending on the message format you use), and the method for transferring messages. You can also choose to
record session events in a log file.



General Tab
Specifies how your personal computer is connected to Internet Mail.

Personal Information
Specifies the name that appears in your mail headings and specifies your e-mail address.
Full Name
Type your full name. This name (not your e-mail name) will appear in the mail headings that you send.
E-mail Address
Type the e-mail address of your mailbox. For example: cherylj@cowboys.com.
Mailbox Information

Specifies the location of your mailbox. If you do not know any of the following information, see your mail administrator. The
Internet service provider or public data network may also provide this information.
Internet Mail Server
Type the name or IP address of the mail server that is running POP3, for example, Magic.Com or 11.117.67.58. If this server
is different from the one that runs SMTP, type the POP3 server name here, and then type the SMTP server name in the
Advanced Options dialog box.

Account Name

Type your POP3 e-mail account name.

Password

Type your POP3 e-mail password. For security, the password is displayed as asterisks (*) when you type it.
Message Format
Click this option to specify message format and a character set for incoming and outgoing mail.
Advanced Options

Click this option if the POP3 server is different from the SMTP server. Internet Mail needs both of these programs, and they are
usually on the same server. To find out if they are on the same server, see your mail administrator or the Internet provider.

See Also

Message Format
Advanced Options



Message Format Dialog Box

Specifies a character set and message format for outgoing MIME (Multipurpose Internet Mail Extensions) messages, or for
incoming and outgoing UUENCODE messages.
Use MIME When Sending Messages

Click (check) the MIME check box to send messages that support extended 8-bit characters (IS0 8859-1, Swedish, Norwegian,
US ASCII) with or without embedded objects or inserted files. The structure of the attachments is maintained if the recipient of
the message is also using MIME.

Clear the MIME check box to send UUENCODE messages that support extended 8-bit characters (ISO 8859-1, Swedish,
Norwegian, US ASCII) with or without attachments.

Character Set

Click this option to select the outbound character set for MIME, or the incoming and outgoing character set for UUENCODE
messages.

Note
. The Character Set default selection that appears depends on whether you select or clear the Use MIME When Sending
Messages check box.

See Also

MIME Character Set dialog box
UUENCODE Character Set dialog box



MIME Character Set Dialog Box

Click the character set (ISO 8859-1, Norwegian, Swedish, or US-ASCII) to be used for MIME (Multipurpose Internet Mail
Extensions) messages. MIME messages support embedded objects and inserted files. The character set is for outgoing
messages only.

Note
- The Character Set default selection that appears depends on whether you select or clear the Use MIME When Sending
Messages check box in the Message Format dialog box.



UUENCODE Character Set Dialog Box

Click the character set (ISO 8859-1, Norwegian, Swedish, US-ASCII) to be used for UUENCODE messages. The character set
is for both incoming and outgoing messages.

Note

- The Character Set default selection that appears depends on whether you select or clear the Use MIME When Sending

Messages check box in the Message Format dialog box.



Advanced Options Dialog Box
Specifies an outbound SMTP host for sending messages if POP3 is on a different server from SMTP.

Forward All Outbound Mail To The Following Mail Server

Type an SMTP host name other than the mail server that outbound mail is sent through. This box is used only if the POP3 server
is different from the SMTP server. Otherwise, all outbound mail is sent to the POP3 mail server that you set in the Internet Mail
Server box on the General Tab. If you’re not sure, see your mail administrator or contact your Internet provider.

See Also

General Tab



Connection Tab
Specifies connection and delivery options.

Connecting To Internet Mail
Specifies how your computer is connected to the mailbox on the Internet Mail server.

Connect Using The Network

Connects your Internet mailbox through a local area network (LAN) connection. If you connect using the network, you can
retrieve, compose, and send messages from your mailbox.

Connect Using The Modem

Connects your Internet mailbox through Dial-Up Networking by a remote access connection. If you have remote access, you
use a modem to connect to your mailbox during remote sessions. To schedule the dial-up connection, clear the Work Off-line
And Use Remote Mail check box and click Schedule.

Note
. To use this option, you must have installed Dial-Up Networking during Microsoft Windows 95 Setup or through
Add/Remove Programs in the Control Panel.
Dial Using The Following Connection

If you connect using a modem, type your dial-up connection, or click the arrow to choose from the list.
Add Entry
Adds more Dial-Up Networking connections to the list.
Edit Entry
Edits existing Dial-up Networking connection properties.
Login As
Provides PPP user information.
Transferring Internet Mail
Specifies how messages are transferred.
Work Offline And Use Remote Mail

Click (check) this check box to initially display message headers. You can then scan the headers (using Remote Mail, which is
available from the Tools menu in Microsoft Exchange) to mark the messages you want to receive, copy, or delete. While using
Remote Mail, you can compose messages and send them to your Outbox at any time, and send and receive messages when
you connect to your mailbox.

Clear this check box to deliver all messages from the mail server.
Schedule

Click this option to set the time interval for message delivery and, if you connect using a modem, to set a schedule for dial-up
connections.

Log File
Click this option to create a file that records events during your mail sessions. A log file is useful for troubleshooting when you
have problems with Internet Mail.

See Also

Schedule

Log File



Login As Dialog Box

Specifies your name and password for remote PPP connections. If you do not know this information, see your Internet provider
or mail administrator.

User Name

Type your PPP account name.

Password

Type your PPP account password.

Tip
- Many applications can use the same remote connection. When you quit Internet Mail, the connection may be kept active
for another application.



Schedule Dialog Box

Specifies the time interval for checking for new mail. If you selected Connect Using The Modem on the Connection Tab, this
dialog box also provides a schedule for dial-up connections.

Check For New Messages Every _ Minute(s)

Specifies the length of time the system waits before checking for new mail. If you connect using a modem, the time you specify
also determines how often a remote connection is made.

Type the time interval, or click the arrows to select a new value.



Log File Dialog Box

Specifies options for recording events that occur during your mail sessions.
Specify The Level Of Logging You Would Like
Select an option from the list.

No Logging

Keeps no log file.

Basic

Records logon and logoff times and error messages.

Troubleshooting

Records complete protocol interactions. This information is useful for troubleshooting. Once you are through troubleshooting,
turn off the Troubleshooting log because the file can get very large.

Specify A Location For The Log File
Saves the log file as a text file with a .log extension (Imail.log). Click Browse to locate an existing log file, or type a name for the
log file and the location where you want to store it.



Internet (Read) Tab
Displays information about the message you are reading.

Internet Headers For This Message

Displays the full incoming Internet Mail headers. For example, some of the headers that can be displayed are Return-Path,
Message-ID, Date, To, and From. You can scroll through the list of headers.



Internet (Send) Tab
Specifies character set format and message format.

Character Set Selection
Specifies the character set format in the message.
Use Settings In Profile
Click this option if you want to use the profile settings.
Override The Profile Setting And Use
Click this option if you want to override the settings in the profile for this outgoing message. In the Character Set box, click the
character set to be used for text messages (ISO 8859-1, Norwegian, Swedish, or US-ASCII). Only this message is set to a
specific character set format.
Message Format Selection
Specifies the message format.
Use Settings In Profile
Click this option if you want to use the profile settings.
Override The Profile Setting And Use

Click this option if you want to override the settings in the profile for this outgoing message. You can override a UUENCODE
profile setting by changing this message option to MIME, or you can override a MIME setting by changing this message option
to UUENCODE. Only this message is set to a specific format.

See Also

Message Format Dialog Box



SMTP - Internet Tab

Sets up a new SMTP address. Internet mail is transported on the Internet using SMTP. If you do not know this information, see
your Internet provider or mail administrator.

Display Name

Type the display name. This is the name you want displayed in the From box of your messages.
E-mail Address

Type the SMTP e-mail address, for example, cherylj@cowboys.com.

Always Send Messages In Microsoft Exchange Rich Text Format

If you are sending messages with rich text format (such as colored text and attachment icons) to a recipient with a MAPI-
compatible mail client, click (check) this option to retain the formatting. Microsoft Exchange is a MAPI-compatible client.



Remote Access

The ability to connect to a service provider through a modem. You must have Dial-Up Networking set up in Microsoft Windows 95
to use Internet Mail with a modem. You can set this up when installing Windows 95, or you can go to Control Panel, double-click
Add/Remove Programs, click the Windows Setup tab, click Communications, click Details, and then click (check) Dial-Up

Networking.



Remote Session

The period of time you're connected to your mailbox by means of a modem.



POP3

Post Office Protocol (version 3). A protocol, or set of rules, used to download mail to your computer.



TCPIIP

Transport Control Protocol/Internet Protocol. A suite of protocols, or set of rules, used by computers to communicate with each
other. TCP/IP is the standard protocol used on the Internet.



SMTP

Simple Mail Transfer Protocol. A protocol, or set of rules, used to transfer Internet mail.



SLIP

Serial Line Internet Protocol. A protocol, or set of rules, that creates a direct connection from your computer to the Internet. Your
computer becomes a node on the Internet. SLIP information should be supplied by the Internet service provider or your mail
administrator.



UUENCODE

A program that converts binary format into text format, which can then be sent over the Internet. Once the text format reaches its
destination, UUDECODE converts it back to binary format.



PPP

Point-to-Point protocol. A protocol, or set of rules, for connecting computers over a phone line. PPP information should be
supplied by the Internet service provider or your mail administrator.



To change an Internet profile

1 Open the Internet Mail dialog box.

2 Select a tab to edit your profile:

To change your e-mail name, password, and address, and to set advanced options such as message formats and
character sets, click the General tab.

- To change the way you are connected to your mailbox or to change transfer options, click the Connection tab.

You can also use the Internet Setup Wizard to change your profile. To get to the Internet Setup Wizard, click Start, point to
Programs, point to Accessories, point to Internet Tools, and then click Internet Setup Wizard.

Note

. To add or change a MIME (Multipurpose Internet Mail Extensions) type, click Options from the Windows Explorer View

menu, and then click the File Type tab. MIME types let you associate an attachment in a message with an application.
See Also
General Tab

Connection Tab



To change your Internet user information

Open the Internet Mail dialog box.

Click the General tab.

In the Full Name box, type the name you want to use for your outgoing mail.

In the E-mail Address box, type the e-mail address of your mailbox.

In the Internet Mail Server box, type the network name or IP address of your mailbox.

In the Account Name box, type the POP3 account name given to you by your Internet provider or mail administrator.
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In the Password box, type the POP3 password for your mailbox.

See Also

General Tab



To change the outbound mail host

1 Open the Internet Mail dialog box.
2 Click the General tab.
3 Click Advanced Options.

4 In the Forward All Outbound Mail To The Following Mail Server box, type the name of the SMTP server where you send your
outbound messages.

Note
- Do this procedure only if POP3 and SMTP are running on two different servers.

See Also

General Tab

Advanced Options Dialog Box



To change transfer options

1 Open the Internet Mail dialog box.
2 Click the Connection tab.

3 Under Transferring Internet Mail, do one of the following:
To deliver mail using Remote Mail, click (check) the Work Offline And Use Remote Mail check box.
To have all messages delivered over the network, clear the Work Offline And Use Remote Mail check box.

4 If you are not using Remote Mail, click Schedule to select a time interval for checking for new messages or to schedule a dial-
up connection.

See Also

Connection Tab

Schedule Dialog Box



To set message format

1 Open the Internet Mail dialog box.
2 Click the General tab.
3 Click Message Format.

4 Select one of these options:
- To send MIME messages, click (check) the Use MIME When Sending Messages check box.
. To send UUENCODE messages, clear the Use MIME When Sending Messages check box.

5 To specify the character set format for messages, click Character Set.

See Also

General Tab

Message Format Dialog Box



To retrieve all messages

1 Open the Internet Mail dialog box.

2 Click the Connection tab.

3 Under Transferring Internet Mail, clear the Work Offline And Use Remote Mail check box.
See Also

Connection Tab



To view message headers before retrieving mail

1 Open the Internet Mail dialog box.
2 Click the Connection tab.
3 Under Transferring Internet Malil, click (check) the Work Offline And Use Remote Mail check box.

You can now use the Remote Mail command on the Tools menu in Microsoft Exchange to mark messages to move, copy, or
delete from the server.

See Also

Connection Tab



To record session events in a log file

1 Open the Internet Mail dialog box.
2 Click the Connection tab.
3 Click Log File.

4 Under Specify The Level Of Logging You Would Like, do one of the following:
- To record minimal information (time of logon and logoff and errors), click Basic.
. To record all session events, click Troubleshooting.

5 To specify a location and a filename for the log file that contains session events, click Browse.
6 Select a folder where you want to save the log file.
7 Type the filename of the log file in the File Name box.
8 Type or click the file type. This file is usually saved with a .log extension.
Tip
- To view the session log file, open it in Notepad.

See Also

Connection Tab

Log File Dialog Box



To view Internet properties of a message
1 Open the message.

2 On the File menu, click Properties.

3 Click the Internet tab.

See Also

Internet (Read) Tab

Internet (Send) Tab



To override a setting for a specific message

1 With the message open, click the File menu, and then click Properties.

2 Click the Internet tab.

3 To select a new character set, click Override The Profile Setting And Use, and then select a character set.

4 To select a new message format, click Override The Profile Setting And Use, and then select a message format.
See Also

Internet (Send) Tab

Message Format Dialog Box



To specify when to check for messages

1 Open the Internet Mail dialog box.
2 Click the Connection tab
3 Click Schedule.

4 Type the time interval for checking for new messages, or click the arrows to select a setting.

Note
- The Work Offline And Use Remote Mail check box must be clear to use the Schedule dialog box.

See Also
Connection Tab

Schedule Dialog Box



To schedule dial-up connections

1 Open the Internet Mail dialog box.

2 Click the Connection tab.

3 Under Connecting To Internet Mail, click Connect Using The Modem.
4 Click Schedule.

5 Type the time interval for checking for new messages, or click the arrows to select a setting.

Note
. The Work Offline And Use Remote Mail check box must be clear to use the Schedule dialog box.

See Also

Connection Tab

Schedule Dialog Box



To view or change file associations for attachments

1 Click Start, point to Programs, and then click Windows Explorer.
2 On the View Menu, click Options.

3 Click the File Types tab.

4 To add or edit a file type, click New Type or Edit.



To create an Internet Mail address

1 On the Tools Menu, click Address Book.

2 On the File Menu, click New Entry.

3 Click Internet Mail Address, and then click OK.

4 Type the display name and e-mail address.

5 If this recipient uses Microsoft Exchange Rich Text Format (the recipient must have a MAPI-compatible mail client), click
(check) the Always Send Messages In Microsoft Exchange Rich Text Format check box.

Note

. You can use one-off addresses to send mail to recipients who aren't in your Address Book, or if you want to bypass the
Address Book. One-off addresses are e-mail addresses that list the protocol type and full e-mail address, usually within brackets. An
example of an SMTP one-off address is [SMTP:cherylj@cowboys.com].

See Also

SMTP - Internet Tab



You can't send or receive mail

If you're unable to send or receive mail, check for the following:

. You have TCP/IP installed on your computer.
All cables are properly connected to your computer, modem, or LAN.
- Your Internet provider or LAN server supports PPP, SMTP, and POP3.

If you're still unable to send or receive mail after you've checked the items above, record the events of your mail session in a log
file, and then check it for errors.

Use this procedure to record the events of your mail session in a log file:

Open the Internet Mail dialog box.

Click the Connection tab.

Click Log File.

Under Specify The Level Of Logging You Would Like, click Troubleshooting.

To specify a location and a filename for the log file that contains session events, click Browse.

Choose a folder where you want to save the log file.

Type the filename of the log file.
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Type or click the file type. This file is saved as a text file, usually with a .log extension.

To view the session log file, open it in Notepad. Errors are marked by in the file by -err. If you are unsure of the meaning of the
error, see your mail administrator or Internet Provider.

See Also

Connection Tab

Log File Dialog Box



Messages or attachments are not readable

If a message or an attachment in a message is unreadable, the message may have been sent with content that Internet Mail
could not decode. Check the message headers for the Content Type character set and Content-Transfer-Encoding information.
To view the message headers:

1 Open the message.
2 On the File menu, click Properties.
3 Click the Internet tab.

Internet Mail supports these Content Type character sets:

- 1ISO 8859-1
- Norwegian
. Swedish
" US-ASCII
Internet Mail supports these Content-Transfer-Encoding formats:
. 7-bit
- Quoted-printable
. Base 64

The message or attachment is unreadable if the message header lists either a Content Type character set or a Content-Transfer-
Encoding format that is not supported by Internet Mail. Have the message resent in a format supported by Internet Mail, or read
the message using a decoder for that type of message format.

See Also
Internet (Read) Tab

Internet (Send) Tab



Frequently Asked Questions

These are frequently asked guestions about Internet Mail. Click the question to see the answer.

1 Why do | have to enter two different passwords?

2 Why does a service other than Internet Mail deliver my SMTP mail?

3 What is a one-off address?

4 What is the default for the Microsoft Exchange rich text format feature of an Internet Mail address?

5 When | have multiple services in my profile, how can | ensure that my SMTP mail is being delivered by the Internet Mail

service?

6 What do | need from my Internet provider?




To open the Internet Mail dialog box from Microsoft Exchange

1 On the Tools menu, click Services.

2 Click Internet Mail, and then click Properties.



Why do | have to enter two different passwords?

The password you enter on the Internet Mail General tab is a password for the POP3 (Post Office Protocol version 3) server,
which is the location of your mailbox. An Internet provider also supplies a PPP (Point to Point protocol) account, which connects
your computer to the Internet over a phone line. The provider sometimes gives you a password for that account. You enter this
password into the Login As dialog box.



Why does a service other than Internet Mail deliver my SMTP mail?

You may have other services in your profile that are delivering SMTP mail. To ensure that your SMTP mail is delivered by

Internet Mail, move Internet Mail to the top of your Delivery List (see question 5). You can also create a separate profile for the
Internet Mail information service.



What is a one-off address?

A one-off address is an e-mail address that lists the protocol type and full e-mail address, usually within brackets. You can use
one-off addresses to send mail to recipients who aren't in your Address Book, or if you want to bypass the Address Book.
Examples of SMTP one-off addresses are:

[SMTP:cherylj@cowboys.com]
loo@col.edu



What is the default for the Microsoft Exchange rich text format feature of an Internet Mail address?

The default for the Microsoft Exchange rich text format feature is off except when sending mail using a one-off SMTP address.



When | have multiple services in my profile, how can | ensure that my SMTP mail is being delivered by the Internet Mail
service?

When you have multiple services in your profile and want to ensure that Microsoft Internet Mail is the service that is delivering
your SMTP mail, go to the Microsoft Exchange Tools menu, click Options, and then click Delivery. Internet Mail should be the
service at the top of the box titled Recipient Addresses Are Processed By These Information Services In The Following Order. If it
isn't, select Internet Mail and click the up arrow button to move it to the top.

You can also create a separate profile for the Internet Mail information service.



What do | need from my Internet provider?

Your Internet provider must support PPP, SMTP, and POP3. In addition, ask your Internet provider for this information:
- Modem communication parameters
. Baud rate
- Type of protocol






