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PoVSB is a Windows based modeler for the Persistence of Vision Raytracer.  
The goal of PoVSB is to allow users of PoV to quickly and easily design scenes 
in the Windows environment with true camera preview of the scene so no guess 
work is involved.  PoVSB is continually being enhanced and new features added.

This manual does not give many details.  If some details are not covered, most 
likely the PoV manual will contain the needed information.

DISCLAIMER

Use at your own risk.  PoVSB is not gauranteed to be bug proof and therefore 
the author assumes no liability for damages which may result from the use of 
PoVSB.

CONTACTING THE AUTHOR

Please e-mail me if any bugs are found.  If you have any ideas or suggestions, 
please write me and I'll see what I can do.

E-mail me at-

jhauswir@carbon.denver.colorado.edu
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1. PoV Features (Future Hopes?)

PoVSB is a Windows based modeler for the Persistence of Vision Raytracer.  
The goal of PoVSB is to allow users of PoV to quickly and easily design scenes 
in the Windows environment with true camera preview of the scene so no guess 
work is involved.  PoVSB is continually being enhanced and new features added.

Features: 

• Four view of scene-
3 ISO views, 1 Camera view

• Objects supported-
Sphere, Box, Plane, Cone, Cylinder, Torus, Bézier Surfaces, Height 

Fields
CSG-

Union, Merge, Intersection, Difference
RAW-

Preview (Only flat triangles)
• Lights-

Point, Spot Light
• Multiple Layers
• Textures-

Customizable, Add your own textures

Future Hopes?

• Adding Cameras
• Be able to customize values like snap value and zoom factors for the ISO 

views.  (easy fix, but haven't got around to it)
• Lights- Area
• And ulitmately animation.  Preview camera/look at path and object 

animation.
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2. Registering PoVSB

PoVSB is now shareware.  Everything is functional except saving the Bezier 
surface objects.   Exporting Bezier surfaces to PoV is functional.

To register please read the file REGISTER.FRM for instructions.

PoVSB is $30 and the following two versions are free. Please send U.S. 
currency in the form of a money order.  After I receive the check I will e-mail you 
the registration number or send the information using postal mail.  In order to get 
the following two upgrades you must e-mail me or use postal mail to get the new 
registration number.  I will also try to notify people that registered PoVSB of new 
versions that are released and also give them the new registration number.

Please mail and make the checks out to:

       Jeff Hauswirth
       418 NE 7
       Ankeny, Iowa  50021   

After you register I will give you a registration number.  Under the Help menu 
there is a Register option that opens a registration window where you enter in the 
number.

3. Requirements
A math co-processor is a definate plus.  I tried a regular 386-40 and it was a 

sorry sight.  My 486-33 flies right along with no complaints from me.  As for 
memory, I don't know how hungry PoVSB is.  I made my program such that all 
common objects such as spheres, cones, cylinders, etc. share the same set of 
data points in memory.  But objects like RAW, Bezier and Lathe will each have to 
have their own data points.  I can easily create a Win32  to handle more memory 
intensive scenes if I recieve a number of requests for a 32-bit version of PoVSB.
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4. Installation

- Create a directory called povsb.
- Unzip files into the povsb directory. (You've obviously figured this one out.)
- Check to see if you have ctl3dv2.dll in your windows\system directory.  If
  you do, check the date with ctl3dv2.dll in the povsb directory and keep the 

  newest one and delete the other.  Then move ctl3dv2.dll into the
  windows/system directory.

NOTE:  ctl3dv2.dll must only be located in the windows\system
   directory.  If you don't do this you will get an error.

5. PoVSB Interface

PoVSB's interface consists of the main menu, button bar, status bar, and four 
scene views (3 ISO views, and 1 camera view).

5.1 Button Bar

The Button Bar contains buttons for quick access to selections available in the 
main menu.  The buttons perform the following tasks-

This button allows you to select visible objects with the mouse.  The cursor 
will change shape to a small square to indicate that you are in the select 
object mode.

This button allows you to interactively change the camera look at point .  
The cursor will change to an eye to indicate that you are in the change 
camera look at mode.

This button allows you to interactively change the camera location.
The cursor will change to a camera to indicate that you are in the change 

camera location mode.

This button opens the layers dialog box that allows you to change the layer 
names and also turn the layers on and off.

This button allows you to interactively scale the selected object.
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This button allows you to interactively rotate the selected object.

This button allows you to interactively translate the selected object.
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This button opens a dialog box where you can manually enter the scale, 
rotate, and translate values for the selected object.  This dialog also allows 
you to name the selected object, assign a texture, and edit specific 

attributes for the selected object.

This button turns the snap mode on/off.  

This button is used to enter the Bezier control point edit mode.

This button turns the Bezier control point mesh on/off.

This button turns the Bezier surface mesh on/off.

5.2 Status Bar

The status bar contains information on the following-

Snap: Indicates the current snap mode.
Cur  . Obj  : Indicates the currently selected object.

Scale: This number indictates the current scale factor used to draw
the window that the mouse is pointing to.  This can be 

adjusted by pressing the right mouse button in the 
window you want to change the scale factor in and 
selecting zoom.

Plane: The field next to scale is the view the cursor is currently 
pointing to.  This could be either an ISO plane view or 
camera view.

Cooridinates: The coordinates displayed cooresponde to the view plane 
the cursor is currently pointing to.

June 2, 1994 8



User Manual PoVSB v0.85

6. PoVSB General Procedures

6.1 Panning and Zooming

To Pan or Zoom an ISO view, click the right mouse button in the ISO view and 
select Pan or Zoom.  Moving the cursor will then Pan or Zoom the ISO view.  
When Zooming, the cursor may need to be moved very slowly to get small scale 
factors.  Watching the scaling factor in the status bar may help.  Clicking any 
mouse button will end the Panning or Zooming operation.

6.2 Making View Full Screen

To make one of the four views full screen, click the right mouse button and select 
full screen from the pop-up menu.  To return back to the four views, perform the 
same actions that were used to make a full screen view.

6.3  Freezing a View

Freezing a view is used for speeding up redraw time.  To freeze a view click the 
right mouse button and select freeze.  

6.4  Camera Settings

The current camera settings can be changed by selecting Edit->Camera...
in the main menu or by clicking the right mouse button in the camera view and 
selecting Camera Settings.

7. Objects
The objects in PoVSB are generally unit objects (dimensions of 
Length=Width=Heigth=1.0).  After the object is added, it can be scaled, rotated, 
and translated into position.  The operations are also performed in that order.

7.1 Sphere
Standard unit sphere.

7.2 Box
Standard unit box.

7.3 Plane
Standard plane.
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7.4 Cone
Standard unit cone.

7.5 Cylinder
Standard unit cylinder.

7.6 Torus

When creating a torus, a dialog box is displayed that allows the major and 
minor axis to be set.

7.7 Lights

7.7.1 Point
The Point light can be translated, but scale and rotation will not have any 
meaning in PoV, but in PoVSB they are allowed.  To change the color for a Point 
light, click on the SRT button and then select the Specific Attribute button.

7.7.2  Spot Light
The Spot Light's attributes- Radius, Falloff, Tightness, and Color can be changed 
by clicking the SRT button and selecting the Specific Attributes button.
PoVSB does not check at this time that Radius<Falloff.  So read the PoV 
documentation to find out the correct values for the Spot Light attributes.

7.8 CSG

Union, Merge, Intersection, and Difference are all supported.  To create a 
CSG object, make all the parts of the CSG object and then select the 

operation you want to perform on the objects from the main menu.  Then 
select all the objects with the mouse you want in the CSG object.  The 
objects will temporarily disapear as the objects are selected to indicate that 

they were selected.  When done selecting all the objects click the right 
mouse button.  The new CSG object will then appear.  If the Difference 
operation is being performed, then the first object that is selected is the main 
object that gets subtracted from.

NOTE: You should Zoom the ISO views before starting a CSG operation 
because if you try to click the right mouse button to get to 
Zoom, this will end the CSG operation.

NOTE: PoVSB does not check, at this time, if the objects selected
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can be used in a valid PoV CSG object.
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7.9 Height Fields

Height fields are displayed as a box with an arrow along the y-axis.  This arrow 
points in the direction of increasing elevation.  Since PoVSB uses the right hand 
cooridinate system, images may need to be mirrored.

7.10 Bézier Surfaces

Bézier surfaces can be edited by clicking the above button in the toolbar.
Just click and drag the control points with the left mouse button.  Do not 
transform the patches until they are the way you want them, otherwise editing the 
control points is totally unpredictable.

Some much better editting tools are needed and should be available in the 
next version.  If you have ideas on what kind of tools that should be added 
please e-mail me.

7.11 Lathe

(Not implemented yet)

7.12 RAW

PoVSB can read in standard RAW files and output regular flat triangles.  Smooth 
output is currently being worked on.

7.13  DXF

PoVSB can display DXF Polyline entities, but nothing else in terms of PoV is 
working at this time.  I am planning on using DXF2TRI to try to do 3D text.  
Cutting "slots" using Corel Draw isn't very much fun, so some thought is 

going into figuring out some easier way to make slots by the user.

8.  Textures
PoVSB supports many of the texture options as PoV.  To reduce explaining 
everything about textures in PoV, read the PoV documentation on textures.
To use textures in PoVSB, select Pigment, Normal, or Finish in the textures 
dialog box.  Next to each option will be a checkbox.  These checkboxs will turn 
on/off output of that texture item when exporting to PoV files. 
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9.  Selecting Objects

To select an object, click on the Select Object Button.
The pick algorithim searches the data points of the objects to see if they fall 

in the square cursor.  To successfully pick an object, click on the end 
points of the line segments.  For Bezier surfaces, pick the control points.

10.  Interactively Transforming Objects

To interactively transform an object, select the object to be transformed.  Click on 
button for the transformation desired.  Then press and drag the left mouse button 
to perform the transformation in any of the 3 ISO views.

10.1 Scaling

Scaling is equal for x, y, and z.  

10.2 Rotating

Rotation is done around the axis perpendicular to the view plane (rotation for the 
xy plane is around the z axis).  Interactively rotating an object is not intuitive.  
Rotating will be strange, just remember that rotations are calculated just as in 
PoV, rotations are first done about the x then the y and finally about the z axis.  
The object will also be difficult to see, sometimes, due to the drawing mode being 
XOR.

10.3 Translation

Translation can be performed in all 3 directions- x, y, and z.

11. Copying Objects

Copying objects is done by selecting the object to be copied and then selecting 
Export PoVSB Object under the File menu option.  Then just import the object.  
The object will be imported exactly as it was copied, so the new object will not be 
seen if the object that was copied is in the same position it was in when it was 
exported.
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12. Deleting Objects

To delete an object, select the object as described in Selecting Objects and 
then hit the Delete key or select Edit->Delete from the main menu.

When deleting CSG objects, the delete operation breaks apart the CSG 
object into the subobjects that made up the CSG object.

13. Editing Objects

13.1 Object Attributes Dialog Box

To edit the object's attributes, first select the object, then click on the SRT 
Button in the Button Bar.  In this dialog box, the name of the object, the 
Layer, transformations, and textures can be assigned.  If the object has any 
specialized attributes, such as Torus and Height Fields, then the Object Att.
button will open a dialog box to change these attributes.

13.2 Object Texture Dialog

This dialog box contains predefined textures and options to apply 
transformations to the texture.  Plans are in the works to allow custom 

texture defining.

14. Cameras

14.1 Interactively Placing Camera

The camera can interactively be placed in the scene.  The camera view will 
also change as the camera is moved.  The Location and Look At point can 
both be changed using the mouse.

14.1.1 Location

To change the Location of the camera, click the camera in the button bar.  
The cursor should change to a camera.  Now just go into one of the ISO 
views and hold down the left mouse button and drag the camera around.  

Releasing the left button will stop changing the camera Location.  
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14.1.2 Look At

To change the Look At point of the camera, click the eye in the button bar.  
The cursor should change to an eye.  Now just go into one of the ISO 
views and hold down the left mouse button and drag the camera Look At 

point around.  Releasing the left button will stop changing the camera Look 
At point.  

14.2 Camera Settings Dialog Box

Click the right mouse button in the Camera View and select Camera Settings.  
In this dialog box the camera Location, Look At point, viewing angle, and 

name can be set.

15. Layers

PoVSB supports up to 16 Layers.  The color of the layers are not able to be 
changed within PoVSB as of yet.

15.1 Changing Layer Names

Click the Layers button in the button bar.  Then select the layer you want to 
rename and then edit the name.

15.2 Turning On/Off Layers

Click the Layers button in the button bar.  Then select the layer you want to 
turn On/Off, then click the On/Off check box.
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Appendix:

Tips

To improve interactively adjusting the camera, make the first object added to 
the scene some simple object like a plane.  This will help because when 
iterating through the objects, the Windows message queue is checked to see 
if the mouse has moved, if it has, the rest of the objects in the scene are not 
drawn.

When creating CSG objects put all the objects that will be in the CSG object 
in a single layer.  Then turn off all the other layers.  This will help when the 
objects are being redrawn after each object is selected to be added to the 

CSG object.

Textures can be added to the list box by editing the textures.dat file.  So you 
can make your own textures and then be able to select the new textures from 

within PoVSB.
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