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OVERVIEW

ZIP files contain other files.    Typically the files in a ZIP file are compressed.    ZIP files make it easy to 
group files and makes transporting and copying these files faster.

WinZip(TM) is a ZIP file manager for Windows.    It provides an easy-to-use SAA/CUA compatible 
interface for quickly adding, deleting, extracting, and viewing members of a ZIP file. The program is easy 
to install, and extensive online help is always available.    All options (including screen size and position) 
can be saved and restored.

The main WinZip window includes a list of files in the open ZIP file. This list can be scrolled and sorted by 
name, extension, date, or size.    Files can be added, deleted, extracted, or viewed using pull-down menu 
entries and push buttons.    The window used to view files in a Zip file can be sized and scrolled.

WinZip supports the CUA "object-action process sequence" philosophy. This allows you to select objects 
(for example, files you want to extract or view) and then specify the action you want to perform. 
Alternately, you can use WinZip in a more traditional "action-object" style of interaction.

To start WinZip from the Program Manager, double click on the WinZip icon.    To open an existing ZIP file 
from the File Manager, simply double click on the ZIP file.

WinZip requires the Shareware PKZIP/PKUNZIP product from PKWARE, Inc.    It runs PKZIP and 
PKUNZIP in the background in Windows Enhanced (80386) mode, or as full-screen applications in 
Standard and Real modes.    For more information on this aspect of the program, see the section titled 
Enhanced, Standard, and Real modes.

WinZip is distributed as Shareware.    This means that users are encouraged, subject to restrictions 
described in the License Agreement, to share copies of this program with friends, associates and bulletin 
boards.    Please remember that if you use this software you are required to pay the registration fee of $29 
as described in the section titled Copyright/License Agreement/Warranty. 

This program is produced by a member of the Association of Shareware Professionals (ASP).    ASP 
wants to make sure that the shareware principle works for you.    If you are unable to resolve a 
shareware-related problem with an ASP member by contacting the member directly, ASP    may be able to 
help.    The ASP Ombudsman can help you resolve a dispute or problem with an ASP member, but does 
not provide technical support for members' products.    Please write to the ASP Ombudsman at P.O. Box 
545 Grover Road, Muskegon, MI 49442 or send a Compuserve message via easyplex to ASP 
Ombudsman 70007,3536.

              _______
         ____|__     |               (R)
      --|       |    |-------------------
        |   ____|__  |  Association of
        |  |       |_|  Shareware
        |__|   o   |    Professionals
      -----|   |   |---------------------
           |___|___|    MEMBER



PMZIP - An OS/2 Version of WinZip

PMZIP(TM) is an OS/2 Presentation Manager version of WinZip.    However, PMZIP makes use of some 
OS/2 features not available under Windows, including threads for faster execution, and support for the 
File Manager drag and drop facility.    It also features a file search facility to locate selected ZIP files 
anywhere on a disk.

PMZIP has been available as Shareware since January, 1991 for the same price as WinZip.    Orders for 
WinZip placed in 1991 will include a free registered copy of PMZIP version 1.0.    Similarly, orders for 
PMZIP placed in 1991 will include a free registered version of WinZip.

The shareware version of PMZIP can be downloaded from the IBMSYS forum on CompuServe, the 
IBM.OS2 conference on BIX, and many OS/2 bulletin board systems.

For ordering information, see the section Ordering Information/Order Form.



Copyright/License/Warranty

For ordering information, see the section Ordering Information/Order Form.
WinZip(TM) Copyright (c) 1991 by Nico Mak - All rights reserved.

License Agreement and Warranty Disclaimer

You should carefully read the following terms and conditions before using this software.    Use of this 
software indicates your acceptance of these terms and conditions.    If you do not agree with them, do not 
use the software.

Shareware Version

You are hereby licensed to:    use the Shareware Version of the software for a 21 day evaluation period; 
make as many copies of the Shareware version of this software and documentation as you wish; give 
exact copies of the original Shareware version to anyone; and distribute the Shareware version of the 
software and documentation in its unmodified form via electronic means.    There is no charge for any of 
the above.

You are specifically prohibited from charging, or requesting donations, for any such copies, however 
made; and from distributing the software and/or documentation with other products (commercial or 
otherwise) without prior written permission, with one exception: Disk Vendors approved by the Association 
of Shareware Professionals are 
permitted to redistribute WinZip, subject to the conditions in this license, without specific written 
permission.

Unregistered use of WinZip after the 21-day evaluation period is in violation of federal copyright laws.

Evaluation and Registration

This is not free software.    This license allows you to use this software for evaluation purposes without 
charge for a period of 21 days.    If you use this software after the 21 day evaluation period a registration 
fee of $29 (plus shipping and handling for orders outside USA) is required. Payments must be in US 
dollars drawn on a US bank, and should be sent to Nico Mak, P.O.    Box 919, Bristol, CT 06011-0919.    
Credit card ordering and quantity discounts are available, as described in the section Ordering 
Information/Order Form.    When payment is received you will be sent a registered copy of the latest 
version of WinZip.

One registered copy of WinZip may be dedicated to a single person who uses the software on one or 
more computers or to a single workstation used by multiple people.

You may access the registered version of WinZip through a network, provided that you have obtained 
individual licenses for the software covering all workstations that will access the software through the 
network.

Governing Law

This agreement shall be governed by the laws of the State of Connecticut.

Disclaimer of Warranty

This software and the accompanying files are sold "as is" and without warranties as to performance of 
merchantability or any other warranties whether expressed or implied.    Because of the various hardware 
and software environments into which this program may be put, no warranty of fitness for a particular 
purpose is offered.



Good data processing procedure dictates that any program be thoroughly tested with non-critical data 
before relying on it.    The user must assume the entire risk of using the program.    Any liability of the 
seller will be limited exclusively to product replacement or refund of purchase price.



Ordering Information/Order Form

WinZip(TM) Registration Form/Invoice.      Please remit to:

                        Nico Mak
                        P.O. Box 919
                        Bristol, CT 06011-0919

Ordering by check:    You can order by sending a check and this order form to the address above.    To 
print this order form, click on Print Topic in the File pull-down menu.    Alternately, you can print the 
ASCII text file ORDER.DOC (distributed along with WINZIP).

Credit card ordering:    You can order with MC, Visa, Amex, or Discover from the Public (software) 
Library by calling 1-800-2424-PsL or 713-524-6394 or by FAX to 1-713-524-6398 or by CIS Email to 
71355,470.    These numbers are for orders only.    Any questions about refunds, registration options, 
product details, technical support, volume discounts, dealer pricing, site licenses, etc, must be directed to 
the address above.    You can also mail credit card orders to PsL at P.O.Box 35705, Houston, TX 77235-
5705.

Site licenses: A site license for WinZip entitles an organization to receive ONE diskette, and ONE copy 
of the documentation.    For the specified license fee, the organization will be entitled to duplicate the 
diskette and documentation for the specified number of copies.

Please check one: 5.25" Disk Acceptable ____    3.5" Disk Required ____

    WinZip individual copy: quantity ___ @ $  29.00 ea. = ___________
    Site license for up to  9 copies:      $ 150.00     = ___________
    Site license for up to 49 copies:      $ 600.00     = ___________
    Site license for up to 99 copies:      $1000.00     = ___________
        (more than 100 copies are negotiable)

    Shipping & handling (outside USA)      $  10.00     + ___________
    Connecticut Residents Add 8% Sales Tax              + ___________
                                       Total payment      ___________

Payments must be in US dollars drawn on a US bank.    Prices guaranteed through 1991.
Orders received in 1991 will include a free registered copy of PMZIP(TM).

             Name:  ___________________________________________________

          Company:  ___________________________________________________

          Address:  ___________________________________________________

 City, State, Zip:  ___________________________________Country: _______

        Day Phone:  ____________________  Eve:  _______________________

        Signature:  ______________________Date:________________________

Electronic Mail address: ______________________________________________

Comments:



Support and questions

Technical support is available at no charge by sending electronic mail to 70056,241 on CompuServe, to 
Nico_Mak on BIX, or by sending US Mail to Nico Mak, P.O. Box 919, Bristol, CT 06011-0919. Registered 
users have priority but I will try to answer all questions.

When reporting problems with WinZip, please include the following information:

1) Is the problem recreatable?    If so, how?

2) Did the problem occur when running Windows in Enhanced, Standard, or Real mode?    You can 
determine which mode is active by choosing About in the Program Manager's Help pull-down menu.

3) If a dialog box with an error message was displayed, please include the text of the message.

Thank you!

Note: You can press F1 at any time while WinZip is active for context sensitive help.



Quick start information

Many people that have used other Presentation Manager or Windows applications will be able to use 
WinZip without reading all the documentation. However, the following sections should be reviewed before 
running the program:

 - Copyright/License Agreement/Warranty

 - Installation

 - WinZip Overview

I also suggest you read the section titled Notes and Background Information for miscellaneous 
information about the interface philosophy and background, as well as technical notes.    In addition you 
might be interested in the section PMZIP - An OS/2 PM version of WinZip.

To learn how to use Help press the F1 key or choose Using Help from the Help menu.



Installation and System Requirements

 System Requirements:

 - Windows 3.0 or later.

 - The PKWARE, Inc.    PKZIP(TM) and PKUNZIP(TM) Shareware programs must be in your path.    You 
can download these programs from most bulletin boards (the latest version is distributed in the self-
extracting ZIP file PKZ110.EXE), or order them directly from PKWARE (phone 414-352-3670).

WinZip-related files are:

 - README.1ST introductory information
 - WINZIP.DOC extracts from online documentation
 - WINZIP.HLP documentation in online hypertext help format
 - WINZIP.EXE required executable
 - WZ.COM required executable
 - WZ.PIF required Program Information File
 - ORDER.DOC order form
- VENDOR.DOC information for Shareware Distributors and Disk Vendors

Installation:

 Before running WinZip, follow this one time installation procedure:

1) If you already have installed a previous version of WinZip, delete all files in your WinZip directory.    
Otherwise create a directory to hold the WinZip related files.    For example, "C:\WINZIP".

2) Copy all WinZip-related files to this directory.    At a minimum you need the following files:    
WINZIP.EXE, WZ.COM, WZ.PIF, and WINZIP.HLP.

 3) Add WinZip to a group in the Program Manager.    This can be done as follows:

a. Open the Program Manager group window for the group you want to add WinZip to.

b. Choose New from the File menu.    The New Program Object dialog box appears.

c.    Select Program Item and choose OK.

d. Type WinZip in the Description text box.

e. Type the full filename of WINZIP.EXE in the Command Line text box.    For example, C:
\WINZIP\WINZIP.EXE.

f.    Choose OK.

You can then start WinZip by double clicking on the WinZip icon in the program manager.    You can open 
an existing ZIP file from the File Manager by simply double clicking on any ZIP file.

Note: a File Manager association for files with an extension of "zip" is set up automatically to make it 
possible to start WinZip by double clicking on a Zip file.



Menu Tree

File Menu

New Zip... - open a new Zip file.
Open Zip... - open an existing Zip file.
Close Zip -    close the open Zip file.
Select all - select all files in the Zip
Deselect all - deselect all files in the Zip
Exit - exit WinZip
About WinZip ... - display copyright notice

Actions Menu

Add... - add files to the open Zip file
Delete... - delete files from the open Zip file
Extract... - extract files from the open Zip file
View... - view files in the open Zip file

Options Menu

Sort by date - sort list of files in open ZIP file
Sort by extension - sort list of files in open ZIP file
Sort by name - sort list of files in open ZIP file
Sort by original order - sort list of files in open ZIP file
Configuration... - modify configuration options
Defaults... - save or restore configuration options
View last output... - view output from the last PKZIP or PKUNZIP command issued by WinZip

Help Menu

Help for WinZip - display main help index
Copyright/License Agreement/Warrantee - display license agreement
Ordering information - display order form
Keys help - display keyboard accelerators
Help for help - display instructions for using help system



The File Menu

You can open ZIP files with the standard New or Open entries on WinZip's File pull-down menu.    These 
functions work like those of most other Windows applications.    You can also open a ZIP file listed in the 
File Manager by double clicking on the ZIP file (this starts a new instance of WinZip).

You can close the current ZIP file with the Close entry on the File pull-down menu.    However, this menu 
entry is included primarily for completeness, since the New and Open dialog boxes automatically perform 
this action.

The Select all and Deselect all menu entries select and deselect files in the main window's list box.    
Selected files can be easily deleted, extracted, or viewed.

The Exit menu entry exits (closes) WinZip.



Adding files to a ZIP file

There are two ways to add files to a ZIP:

1) Click on the Add push button or select the Add entry from the Action pull-down menu to bring up the 
Add dialog box.    Then specify the file names you want to add.    Standard MS-DOS wildcards are 
accepted, and multiple file names can be specified.

2) Click on the Add push button or select the Add entry from the Action pull-down menu to bring up the 
Add dialog box.    Then click on the Select Files push button.    This expands the Add dialog box.    You can 
then select files from an Extended Selection List Box.    The expanded Add dialog box works much like a 
standard Windows Open dialog box.

If you would like WinZip to automatically expand the Add dialog box , click on the Unfold check box before 
clicking on the Add button, and save your current settings with the Defaults dialog box (available from the 
Options pull-down menu) before closing WinZip.

The Add dialog box provides the following options:

 - The Add, Freshen, and Update radio buttons correspond to the PKZIP -a, -f, and -u options

 - The "delete original after adding" check box corresponds to the PKZIP -m option

 - The Size and Speed radio buttons correspond to the PKZIP -ex and -es options

 - The "Recurse subdirectories" check box corresponds to the PKZIP -r option

 - The "Store recursed pathnames" check box    corresponds to the PKZIP -p option

 - The "Store specified pathnames" check box corresponds to the PKZIP -P option



Deleting files from a ZIP file 

There are two ways to delete files from a ZIP:

1) Object-action interface:    first select entries in the list box, then click on the Delete push button or select 
the Delete entry from the Action pull-down menu.

2) Action-object interface:    click on the Delete push button or select the Delete entry from the Action pull-
down to bring up the Delete dialog box.    You can then specify the file names you want to delete 
(standard MS-DOS wildcards are accepted).



Extracting files from a ZIP file

There are two ways to extract files from a ZIP:

1) Object-action interface:    first select entries in the list box, then click on the Extract push button or 
select the Extract entry from the Action pull-down menu to bring up the Extract dialog box.

2) Action-object interface:    click on the Extract push button or select the Extract entry from the Action pull-
down to bring up the Extract dialog box.    You can then specify the file names you want to extract 
(standard MS-DOS wildcards are accepted) or extract all files in the ZIP.

The Extract dialog box lets you specify the directory to contain the extracted files (note: the default 
directory for this prompt can be changed by selecting "Extract Directory..." in the Options pull-down 
menu).

The Extract dialog box provides the following options:

 - The "Overlay newer files only" check box corresponds to the PKUNZIP -n option

 - The "Use pathnames" check box corresponds to the PKUNZIP -d option

Note: the PKUNZIP -o option is always specified.



Viewing files in a ZIP file

There are three ways to view files in a ZIP file:

1) Double click on a file name in the list box listing files in the ZIP file.

2) Object-action interface:    first select entries in the list box, then click on the View push button or select 
the View entry from the Action pull-down menu.

3) Action-object interface:    click on the View push button or select the View entry from the Action pull-
down to bring up the View dialog box.    You can then specify the file name you want to view.

The View dialog box is used to view files in a ZIP file or view the results of the last PKZIP or PKUNZIP 
command issued by WinZip.    Unlike most dialog boxes, the View dialog box is sizeable and can be 
maximized.

If you've selected multiple files for viewing, click on the Next push button to view the next selected file.

Click on the Clipboard Copy push button to copy selected text to the system clipboard.    Note: this button 
is disabled when no text is selected.



Options

The WinZip option system consists of the following components:

The Option pull-down menu lets you specify whether the list of files in the ZIP file is sorted by date, 
extension, size, name, or whether the original ZIP file order should be used. It also lets you bring up the 
following dialog boxes described below.

The Configuration dialog box lets you specify

 - Whether the default directory in the Extract dialog box is the current directory or a directory of your 
choice.

 - Whether files in the ZIP file are listed in lowercase for the possibility of improved legibility.

 - Whether WinZip should maintain a log of all error messages and all PKZIP and PKUNZIP commands it 
issues. The log is written to the file C:\WINZIP.LOG.

The Defaults dialog box lets you save the current defaults for use next time WinZip is started, or restore 
the original distribution defaults.    Options that are saved and restored by this procedure include all the 
options in the "Options" pull-down menu, all options in the Add, Configuration, and Extract dialog boxes, 
and the current screen size. 

The View last output entry in the Options pull-down displays the results of the last PKZIP or PKUNZIP 
command issued by WinZip.



Enhanced, Standard, and Real Mode

In Windows Enhanced (386) mode PKZIP and PKUNZIP commands issued by WinZip to update your ZIP 
files are executed in the background in an iconized DOS session.    While these commands are running 
you can switch to another window.    An hourglass pointer is used to indicate that the WinZip window is 
busy.    You can double click on the icon titled "WinZip running PKZIP/PKUNZIP" to monitor the 
command's progress.

Unfortunately, it is impossible to execute the PKZIP and PKUNZIP commands in the background under 
Standard and Real modes.    In these modes your screen will be cleared, and PKZIP/PKUNZIP 
commands will be run in a full screen DOS session.

In all cases you can view the messages displayed by last PKZIP or PKUNZIP command issued by 
WinZip by selecting View Last Output in the Options pull-down menu.

Your Windows 3.00 User's Guide contains descriptions of Enhanced, Standard, and Real modes.    You 
can determine which mode is active by choosing About in the Program Manager's Help pull-down menu. 



Error Handling

WinZip does not manipulate ZIP files directly.    Instead it runs the PKZIP command for all operations that 
update ZIP files.    Thus it is highly unlikely that WinZip will ever cause a corrupted ZIP file.    If you suspect 
a corrupted ZIP file, issue following command from a DOS prompt:

pkunzip -t filename.ZIP
If PKUNZIP reports that your ZIP file is damaged, try the PKZIPFIX command, as documented in section 
5 of your PKZIP manual.

When a PKZIP or PKUNZIP command issued by WinZip returns a non-zero error level, a dialog box is 
displayed listing the error level and error level description.    Click on the "View last output" button to view 
all messages issued by the command that caused the error.

WinZip will optionally maintain a log of all error messages and all PKZIP and PKUNZIP commands it 
issues. The log is written to the file C:\WINZIP.LOG.

If you encounter errors in WinZip, please report them (see the section Support and questions for 
information).



Keyboard usage

WinZip is easier to use with a mouse, but you can also use the standard Windows keyboard interface.    
Keyboard accelerators defined for WinZip include:

Ctrl+N Open new Zip file.

Ctrl+O Open existing ZIP file.

Ctrl+A Add files to a ZIP file.

Ctrl+D Delete files from a ZIP file.

Ctrl+E Extract files from a ZIP file.

Ctrl+V View files in a ZIP file.

Ctrl+Slash (/) Select all items in the list box.

Ctrl+Backslash (\) Cancel the selection of all items in the list box.

Direction key(s) Move the cursor or    scroll to other items in the list box.

Shift+direction keys Select multiple items in list box.. 

Shift+F8 Toggle "add mode" on and off.    When add mode is on, you the selection cursor blinks.    In this 
mode you can use the Spacebar to select nonconsecutive items in the list box or to cancel the selections. 
Press Shift-F8 again to end add mode.



Using Extended Selection List Boxes

WinZip uses Extended Selection List Boxes for the list of files in a ZIP file and for the list of files in the Add 
dialog box.    You can select files from an Extended Selection List Boxes the same way as you select files 
in the File Manager, with one important difference: in an Extended Selection List Box you can select 
multiple files by clicking on the first file, and while holding down the mouse button, drag over other files 
you want to select. 

To select an individual file in an Extended Selection List Box, click on the file.    This cancels all previous 
selections.    To select additional files, hold down the Ctrl key while clicking on the files.    To select a group 
of files and cancel all previous selections, click on the first file, and while holding down the left mouse 
button, drag over other files you want to select.    To select additional groups of files, hold down the Ctrl 
key, click on the first file in the group, and while holding down the left mouse button, drag over the other 
files you want to select.    You can use the Select all and Deselect all entries in the File pull-down menu to 
select and deselect all files in a ZIP.

The keyboard interface for Extended Selection List Boxes is described in the section titled    Keyboard 
usage.



Ideas for future enhancements

Ideals for future enhancements include:

- Support for other file formats (e.g. ARC, ZOO, and LHZ)

 - Support for all ZIP options, including passwords and comments

 - Ability to run programs in a ZIP file

 - Optional hex and ASCII    dump mode when viewing files in a ZIP File

 Additional suggestions from all users are welcome!



Notes and Background Information

 - This version of WinZip was tested under Windows 3.00 with PKZIP and PKUNZIP versions 1.1.

 - PKZIP and PKUNZIP are registered trademarks of PKWARE, Inc.

- There is a bug in Windows 3.0 that can cause Windows to crash if you try to update a read-only disk.    
This can occur if you attempt to update a ZIP file on a read-only disk with WinZip.    Microsoft Online 
technical support has stated that this is a known problem, and that no workarounds are available for 
Windows 3.00.    You can demonstrate this problem in Enhanced mode without WinZip as follows (be sure 
to save your files first):

- Start a DOS session from the Program Manager.
- Try to delete a file on a read-only disk.    Reply Abort or Fail to the critical error message.
- Exit the DOS session.
- Try to access the read-only file from a Windows application (e.g. Notepad).

At this point Windows typically locks up or terminates.

- You can change the default WinZip icon as follows:

a. Open the Program Manager group window for the group containing WinZip.

b. Choose Program Properties from the File menu.    The Program Item Properties dialog box appears.

c. Click on Change Icon.    The Select Icon dialog box appears.

d. Click on View Next to cycle through the icons.    Choose OK when your preferred icon appears.

e.    Choose OK.

 - WinZip supports most commonly used PKZIP and PKUNZIP options but the current version does not 
include special support for comments, passwords, and file attribute masks.

 - WinZip uses temporary disk files to communicate with WZ.COM and the PKWARE, Inc. programs.    
WinZip uses a unique filenames for these files, and automatically erases them when they are no longer 
needed.    WinZip determines which disk to use by checking the value of the WZTMP=, TMP=, TEMP=, 
and PKTMP= environment variables.    If none of these environment variables is set WinZip uses the root 
directory of your C: drive.

- WZ.COM is used for two reasons: to obtain the error level (return code) from the PKZIP and PKUNZIP 
commands, and to capture the output from these commands for use by the "View last output" entry in the 
Options pull-down menu, 

 - WinZip is a Windows version of PMZIP.    I wrote PMZIP because I wanted an OS/2 Presentation 
Manager    interface to ZIP files, and no other programs provided this facility.    The first version was written 
in Digitalk's Smalltalk V/PM.    The result, like all V/PM programs, required over a megabyte of code to 
execute, and was rather slow.    Favorable response to the first version convinced me to rewrite the 
program in C and release it as Shareware.    I subsequently rewrote it for Windows, and this is the result.

- Special thanks to Steve Queen for his    feedback on the WinZip user interface.



Missing file(s)

A required file was not found.

PKZIP.EXE and PKUNZIP.EXE must both be in your path.    Also, WINZIP.HLP and WZ.COM must both 
be in the same directory as WINZIP.EXE.    The Installation section describes the complete installation 
procedure.



Invalid ZIP File

This dialog box is displayed if WinZip was unable to open the specified ZIP file, read the ZIP file directory, 
or if a fileid is invalid.    It is possible that the file is not a ZIP file.    Alternately, it is possible that the ZIP file 
has been corrupted.    For more information, see the section titled Error Handling.



Add files selected in list box?

This dialog box is displayed if you've updated the edit field in the expanded Add dialog box after selecting 
files from the list box.    WinZip isn't sure whether you want to add the selected files or add the files that 
match the names specified in the text field.    To add the selected files click on the OK button. 



Internal Error

This dialog box is displayed when an unexpected WinZip internal error occurs.    Please contact the 
author with as much information about the error as possible.    For a list of contact points, choose About 
from WinZip's Help pull-down menu.



Missing Input

This dialog box is displayed when a required edit field is empty.    For example, it is displayed if you don't 
specify which file you want to open in the Open dialog box.    Specify the required information and try 
again.



No files selected in list box

This dialog box is displayed if you click on the Add button in the expanded Add dialog box but haven't 
selected any files to add.    Select one or more files in the file list box, or click on the Cancel button.



File already exists

To view a file, WinZip normally extracts the file to disk, reads it, and erases the temporary disk file.    
WinZip determines which disk to extract to by checking the value of the WZTMP=, TMP=, TEMP=, and 
PKTMP= environment variables.    If none of these environment variables is set it extracts to the root 
directory of your C: drive.

The message The disk file "fileid" already exists.    Should WinZip overwrite it so that the file in the ZIP can 
be viewed? is issued if a file with the requested name already exists on disk.    If you choose Yes, the 
existing disk file will be overwritten, and processing will continue.    If you select No, WinZip will abort the 
view operation for this file.



Text truncated at first binary zero

This dialog box is displayed if WinZip cannot display the entire file you are viewing because it contains 
binary zeros.    WinZip uses a standard multi-line edit field to display files, and these controls truncate text 
at the first binary zero.



ZIP Directory Too Big For WinZip

This dialog box is displayed if you try to open a ZIP with a directory too large for WinZip 
to handle.      You will not be able to open the ZIP file with this version of WinZip.



ZIP Command Too Long

This dialog box is displayed if    a PKZIP or PKUNZIP command is over 128 characters long (the longest 
command allowed under MS-DOS is 128 characters).    The total command line length includes several 
components used internally by WinZip in addition to the PKZIP or PKUNZIP command.    There are a 
couple ways to reduce the length of the command line:

1) Move WINZIP.EXE (and the related files) to a directory near the root directory (for example, a directory 
like C:\WINZIP is better than C:\WINDOWS\UTILITIES\SHAREWARE\WINZIP).

2)    Move the ZIP file you are working with to a directory near the root directory.

3) If you are adding, deleting, extracting, or viewing multiple files at one time, specify them via a listbox 
rather than an edit field.    This causes WinZip to create a PKZIP/PKUNZIP response file, which usually 
takes less room on the command line than multiple file names.



Selected Text Successfully Copied To Clipboard

This dialog is displayed to let you know the text selected in the View dialog box has been copied to the 
system clipboard.    You can paste the text into another application (for example, Notepad) by choosing 
Paste from the application's Edit pull-down menu.



Could Not Create Temporary File

This dialog box is displayed when WinZip could not create a required temporary file on the    disk drive 
listed in the dialog box.    Possible causes are that the disk drive is invalid, or that the root directory of the 
disk is full.

WinZip determines which disk to use for temporary files by checking the values of the WZTMP=, TMP=, 
TEMP=, and PKTMP= environment variables.    If none of these environment variables is set, WinZip 
creates temporary files on your C: drive.


