
Customising

Resume

FirstClass provides every user with a resume, which is a special form designed to
contain personal information.

Other users (on the same server as yourself) can open this form if they want to see
information about you.

Your resume is blank until you update it.

In addition, conferences and calendars may have resumes to provide information
about them.

Creating a Resume

To add personal information to your resume:

From the Menu toolbar select File> Open> Resume,

alternatively click on the Resume icon on the toolbar

Type your name in the top field

If desired you can paste your picture from the clipboard into the top left corner

Type any information that you think would be useful to other users in the bottom field.
For ideas about what to write, look at other users' resumes

Close the resume to automatically save your changes

Viewing a Resume

You can view other users resumes and see the information they have written about
themselves.

Setting up a resume is optional.

If you try to view a resume that doesn't exist you will get an error message.

If however another user has opened a resume, but left it blank this would then open.



From the Menu toolbar select Collaborate> Directory,

alternatively click on the Directory icon on the toolbar

Untick the Conferences check box and untick the Remote check box

This will then list all users on the same server as yourself

Type in a few characters of the name of the person you want to view the resume of in
the Pattern field (in this example demo has been used).

The Directory listing will update to display the matching names, as shown in Figure 1

Figure 1 - Matching Names List

Highlight the name of the person in the list

Click on the Resume button

Close the resume when you have finished reading it

Close the directory

Address Books

Your address book gives you the ability to create a shorthand name for addressing
outgoing messages.

There are two types of entry



·
For an individual, referred to as a Personal Address or

·
For a group of people, referred to as a Personal Mail List

The address book may contain entries for people external to the FirstClass system.

The address book also allows you to store personal information and contact details
for the people you choose to include in your address book.

Opening your Address Book

You will automatically have an address book created for you on your desktop.

To open your address book either

·
From the Menu toolbar select File> Open> Address Book or

·
Double-click on the Address Book icon

Create a New Address

To Create a New Address:

From the Menu toolbar select File> New> New Address,

alternatively click on the New Address icon on the toolbar

The New Personal Address form will open, as shown in Figure 1



Figure 1 - New Personal Address

In the Name: field, type a 'shorthand name' such as Geoff

In the First, Middle, Last, and Title: fields, type in personal details if you wish

In the E-mail: field, type the FirstClass address of the recipient e.g.

·
Geoff Bloggs

or

·
Geoff Bloggs,oufcnt2.open.ac.uk

if the user is on a different FirstClass server to you

or

·
a person's Internet e-mail address, e.g. A.N.Other@Bumble.ac.uk

Click OK to save the New Personal Address entry

To send a message to Geoff Bloggs you will only need to type Geoff in the To: field
of the message and press the Return

On sending the message Geoff is converted into the appropriate full mail address.
This conversion is performed behind the scenes, FirstClass will automatically search
the Personal Address Book for a matching shorthand name.



Create a New Mail List

A Mail List allows you to send mail messages to a group of people. The message is
sent once and received by all.

To create a new Mail List:

From the Menu toolbar select File> New> New Mail List,

alternatively click the New Mail List icon on the toolbar

The new mail list form will open, as shown in Figure 1

Figure 1 - New Mail List

In the Name: field, type a 'shorthand name' such as Buddies

In the Members: field type either FirstClass addresses of the recipients for example

·
Elvis Elderberry

or

·
Their 'shorthand name' if they already have a Personal Address entry in your
address book

or

·
Type the Internet e-mail address A.N.Other@Bumble.ac.uk

·
Press the Enter or Return key after each name



An example Mail List is shown in Figure 2

Figure 2 - Example Mail List

Click OK to save the Mail List

Bookmarks

Your Bookmark area in FirstClass allows you to store shortcuts (links) to your
favourite web sites (URL's).

Your bookmarks folder is held on the LTS FirstClass servers so can be accessed
every time you login to FirstClass from any machine and any location. Once set up
this feature will be useful if you ever have to use different machines such as in a
Library or Internet Cafe.

To open your Bookmarks folder and create a new bookmark

From the Menu toolbar select File> Open> Bookmarks

·
A new Bookmarks icon will appear on your FirstClass desktop and your

Bookmarks folder will open

Open up a web browser (such as Internet Explorer or Netscape) and find a favourite
web site

Drag the icon e.g. for Internet Explorer or for Netscape (found next to the

location or address field of your web browser) into the Bookmarks folder

A new bookmark will appear in your Bookmarks folder, this bookmark will now act as
a shortcut or hyperlink to the website



Calendars

Your FirstClass calendar can be used in the same way as a paper calendar or a
personal diary/organiser.

You can also share your calendar with other users on the FirstClass system.

You can choose to view your calendar by Day, Week or Month using the View> View
by Month, View> View by Week or View> View by Day options on the Menu toolbar.

You can add Events (which can include a reminder) and Tasks (To Do's) to your
calendar.

You will automatically have had a Calendar created for you on your desktop.

To open your Calendar either

·
From the Menu toolbar select File> Open> Calendar or

·
Double-click on the Calendar icon

Creating a New Calendar Event

To Create a New Event:

From the Menu toolbar select either File> New > New Event,

alternatively click the New Event icon

The New Event form will open as shown in Figure 1



Figure 1 - New Event

Add the event details and set up any scheduling, repeats and reminder options if
necessary

Close the calendar event form to save your changes

The new event will appear in your FirstClass calendar on the date specified.

Creating a New Calendar Task

To Create a New Task:

From the Menu toolbar select either File> New > New Task,

alternatively click the New Task icon

The New Task form will open as shown in Figure 1



Figure 1 - New Task

Add the task details and set up reminders if necessary

Close the calendar task form to save your changes

The new task will appear in your FirstClass calendar on the date specified

View Properties

The View Properties in FirstClass relate to the way information in a particular
FirstClass window is displayed.

The window could be your FirstClass Desktop, a Conference or your Mailbox.

The options allow you to customise the sorting, display, icons and background of
FirstClass windows.

The default view for each conference is set by the conference controller (or
equivalent). You will not be able to make permanent changes to conference views



unless you are the conference controller.

There are four tabs Sorting, Display, Icons, Background, which you can use to
change the various view properties

To make changes to the View Properties of a particular window:

From the Menu toolbar select View> Change View Properties the view properties
window will open as shown in Figure 1

Figure 1 - Change View Properties

Sorting

Altering the sorting of your Mailbox will result in a permanent change, but you can
alter this again at a later date if you wish.

Altering the sorting of a Conference (unless you are the controller) will only be
temporary for the period of time you are logged on.

Click on the Sorting tab of the View Properties window

Select the options you require from the drop down menus

Click on Apply

Click on OK

Close the View Properties window

Display

Display can be used to change the font style, colour and size of the text



Altering the display of your Mailbox will result in a permanent change, but you can
alter this again at a later date if you wish.

Altering the display of a Conference (unless you are the controller) will only be
temporary for the period of time you are logged on.

Click on the Display tab of the View Properties window

Select the Font require from the drop down menu

Alter the Size

Change the Colour if desired by selecting one from the drop down menu

Check the Use Colour box

Click on Apply

Click on OK

Close the View Properties window

Icons

The icons tab allows you to lock icons so they cannot be dragged around your
Desktop, open them with a single click or hide the icon names.

Background

The background tab allows you to insert a background image into a FirstClass
window.

Adding a background image to your Desktop or Mailbox will result in this being
displayed permanently, but you can remove it or change it at a later date if you wish.

Adding a background image to a Conference (unless you are the controller) will only
be temporary for the period of time you are logged on.

Files that you would like to use for backgrounds need to be save as either .png or
.jpg files.

FirstClass comes with a default set of background images, but you can add in your
own by saving them to the Images subfolder found inside your FirstClass installation
location e.g. C:\Program Files\FirstClass\Images if you have installed using the
default.

Preferences



Preferences allow you to control the look and behaviour of your FirstClass Client.

The defaults should suit most people, but you may wish to make some alterations to
suit your individual needs.

There are six tabs General, Calendaring, Content, Viewing, Messaging and Web
which you can set Preferences on.

You can explore these tabs for changes, but the most commonly edited Preferences
are covered below.

To open the Preferences panel

From the Menu toolbar select Edit> Preferences from menu. The Preferences panel
will open as shown in Figure 1

Figure 1 - Preferences

·
Once you have altered any of the Preferences you want (some of these are
described below)

Click on Apply

Click on OK

Close the Preferences window



Content

The Content tab has two sub-sections Edit and View.

Edit

The Edit section allows you to set the Font, Size and text colour of mails you
compose, these options will be used on all mails whether addressed to a Conference
or other FirstClass Users.

It also contains the Spell Check options, including the option to automatically check
every message before sending by ticking the box.

View

The View section allows you to alter the display size of the messages, images etc. by
altering the Content zoom - increasing it above 100% will make everything appear
larger than the original and decreasing it will make everything smaller than the
original.

It also contains options relating to the display of Quoted text in message replies.
Further information about quoting text can be found in the Reply with Quote part of
the Private Mail section.

Viewing

The Viewing tab allows you to display only unread items.

It also allows you to change the view to appear similar to other e-mail systems using
the Client interface drop down menu.

Messaging

The Messaging tab has five sub-sections Mail Rules, Signature, Chat, Paging and
Voice.

Please note that the Voice section will not be available for most Users.



Mail Rules

The Mail Rules section allows you to set up an automatic reply to an item sent to your
maiklbox or an automatic forward of items from your mailbox to another e-mail
address.

Signature

The Signature section allows you to set up a signature with the option for this to be
automatically added to every message you send or as a manual process to certain
messages.

Chat

The Chat section allows you to refuse all chat invitations automatically and to turn off
chat sounds.

Paging

The Paging section allows you to forward items to an enabled paging system.


