
Add a new URL
If you know the complete URL for a site, you can type it into WebWhacker without having to access your browser. If you want to use 
the browser to add the URL to WebWhacker, use the Grab URL function.

Adding a new URL

1. From the URL menu select Add. WebWhacker displays the first page of the URL Subscription Wizard. 

2. WebWhacker already displays the text HTTP:// in the URL to Add text box for you. Press END to move the cursor to the end of 
the text, then type the complete URL address for the site you want to add.

3. In the tree window labeled Select the Category for this URL, double-click on the category to which you want to assign this 
URL 

NOTE:    If the category you want does not appear in the window you can to display your subcategories by clicking the plus sign 
next to the All.

4. When the URL and categories are set the way you want them, select Next. WebWhacker displays the second page of the URL 
Subscription Wizard.

5. Select the number of levels of this URL that you want to whack. 
If you only want this page, use 1. 
If you want all the links from this page, select All.

6. If you don't want WebWhacker to whack pages from other sites that are linked to this URL, select Remain on Site  .   YIf you 
choose to whack All levels, Remain on Site is selected automatically and the option is grayed out, making it unavailable. 

7. It the URL    you selected requires a user name and password, type your user name and the password. 

8. When you select Next, WebWhacker displays the third page of the URL Subscription Wizard.

9. Select the renewal frequency you want for this URL site. 

If you only want to whack this site one time and never renew it, select Just this Once.

If you want to update this site every day (or once every week, or once every month), choose Daily (or Weekly or 

Monthly).
If you select a daily, weekly or monthly update cycle WebWhacker automatically update the links according to the schedule you 
established in your Preferences. 

10. When you select Finish, WebWhacker adds the URL to your site list and marks it for whacking.
              Perform the whack  



Add new URLs
(in WebManager)

Most of the time you add new URL sites to WebWhacker by grabbing them from the main WebWhacker window. However, you can 
add Web sites directly into their relevant categories using the WebManager's Explorer-style window. To do so, you need to know the 
correct URL for the site. 

Adding a new URL from within WebManager

1. From within the WebManager window, double-click on the word All labeling the folder at the top of the tree pane in the left half 
of the window. A list of your current categories displays beneath the word All.

2. Click on the folder icon for the category to which you want to add this URL.

3. From the Edit menu, select Add and then select URL from the submenu.

4. In the URL to add text box type the complete name and path of the new URL.

5. After you click OK, your new URL appears in the right window pane whenever you select its category.

Your new URL appears in the right pane of your window. It has a Name and Date, but no Title. You can add the title through the 
URL's properties box using the procedure Naming a URL 

TIP:    Coordinating URL sites and categories

When you add a URL within WebWhacker, the site is added to WebManager as well. However, if you delete a URL from within 
WebManager, the site is deleted only from WebManager's categorization view; it is not deleted from your WebWhacker 
database of local sites.

              Related Topics  



Add or delete categories
(in WebManager)

You can sort your database of subscribed URLs into as many (or as few) categories as you want. You may even create 
subcategories within a category. Each category or subcategory is displayed as a folder in the WebManager's Explorer-style window.

Adding a new main category

1. From within the WebManager window, click on the word All labeling the folder at the top of the tree pane in the left half of the 
window. 

2. Click on the Edit menu, select Add and then select Folder from the submenu.

3. In the Add New Folder dialog box, type the name of the new category in the Folder Name text box. Click OK.

Adding a new subcategory

1. Click on the word labeling the folder that will contain the subcategory. 

2. Click on the Edit menu, select Add, and then select Folder from the submenu.

3. In the Add New Folder dialog box, type the name of the new category in the Folder Name text box. Click OK.

Deleting a main or subcategory

1. Click on the folder representing the category you want to delete. 

2. Click on the Edit menu and select Delete 

OR

Hit the Delete key on your keyboard.

TIP:    Managing categories

Categories are a function of WebManager, so when you add or delete categories from within WebManager, the categories are 
added or deleted across the board. However, if you delete a URL from within WebManager, the URL is deleted only from 
WebManager's categorization view; it is not deleted from your WebWhacker database of local sites.

              Related Topics  



App Bar
The App Bar gives you quick access to the most commonly used functions of WebWhacker. It appears as a toolbar—similar to the 
Windows 95 Taskbar or the taskbars for the major office suites—and can be docked along any edge of your screen. 

Click on any icon above for more information about its function.

Starting the App Bar

1. Go to the Windows Start button and click on Programs.

2. From the Programs submenu, choose the WebWhacker group. Slide over to the App Bar selection and click once.

You can also start the App Bar automatically with WebWhacker by choosing the Start App Bar automatically option (on the 
Tool menu, choose Preferences / General).

Adjusting the App Bar

1. Move your mouse over the edge of the screen where the App Bar last appeared. The App Bar comes to the front.

2. To relocate your App Bar, click once in a blank area of the App Bar, and drag it to a different screen edge.
OR
Right-click in a blank area of the App Bar, and then click to select whether you want the App Bar to dock at the Top, Bottom, 
Left, or Right edge.

3. To change the display properties of your App Bar, right-click in a blank area of the App Bar. Click to select whether to make 
sure the App Bar is Always on top or to choose to AutoHide the App Bar, when it is not in use.

TIP:    Using other dockable toolbars

If you have other programs or suites with dockable toolbars, you can dock multiple toolbars at any edge of the screen. 
However, only one of the toolbars docked at any given edge may be set for AutoHide. 

TIP:    Identifying the reserved area

The blank gray area on the right end of the App Bar is reserved for future development. Access to other products—such as 
WebSeeker, a multi-engine Internet search tool, and GrabNet, a browser companion for capturing and organizing URLs— will 
be added to the App Bar. 

The App Bar can be used to
              View headlines  

              Grab URLs  

              Change to the   WebManager   window  

              Search for a subscribed URL  

              Whack a URL  

              Renew (or update) a previously whacked URL  





Attribute properties
The Attribute Properties dialog shows basic information about a subscribed URL including its title, URL address, and current 
whacked status. All of this information is provided by WebWhacker and cannot be changed. 

Viewing the URL attributes

1. Select the URL whose properties you want to update.

2. Click on the Props button on the Toolbar, or go to the URL menu and select Properties. WebWhacker displays the URL 
Properties window. 

3. If necessary, click on Attributes. WebWhacker displays the attributes associated with the URL.

4. If you want to look at or update another preference, select the appropriate page.
If you are finished updating preferences, select OK. 



Back up your WebWhacker database
Be sure to include the WebWhacker database in your daily backup schedule. All databases rely on intricate linkages among the 
various pieces of information.    For this reason, databases are, by their very nature, more subject to corruption problems than are 
other file types and it is important to back them up regularly. 



Boolean logic
Boolean logic, named for 19th century English mathematician George Boole, uses AND, OR, and NOT as its primary operators, just 
as add, subtract, multiply, and divide are the primary operators in arithmetic.

A Boolean search requires that specific conditions must be met.    For example, a search using the terms "tropical" and "fruits" with 
the AND operator would find all occurrences that contained both the word "tropical" and the word "fruits".



Browse a site (URL)
You can quickly display a URL from the WebWhacker window. If you have whacked the URL, it is loaded directly from the 
WebWhacker database. If it is a new URL that has not yet been whacked (and you have the passthru function turned on), 
WebWhacker uses your browser to access the URL site.

Browsing a site

1. From the WebWhacker window, select the URL site you want to browse. Then from the URL menu, select Browse.
OR
From the WebWhacker window, double-click on the name of the URL site.

2. In either case WebWhacker displays the URL site in your Internet browser's window.

TIP:    Tracking the latest version of your subscribed URLs

The page that appears in your browser is the "whacked" version of the URL that resides on your local hard drive or network. If 
the URL is one that changes frequently, or if you just want to make sure you are viewing the latest version, click once on the 
Renew button on the App Bar or on the toolbar to update your version.



Browse whacked sites
(in WebManager)

You can use the categories in the WebManager to surf the Net. If the URL has been whacked by WebWhacker, it displays the copy 
of the page from its database. If the URL has not been whacked, your browser must be connected to the 'Net to view the page.

Using WebManager to browse sites

1. Start your browser. If you want to look at URLs that haven't been whacked by WebWhacker, connect to the 'Net.

2. From within the WebManager window, navigate the categories in the tree pane (on the left) to select the desired category.

3. In the right-hand pane, locate the URL you want to browse.

4. Double-click on the name of the URL. The whacked page appears in your Internet browser's window. 

TIP: Identifying local vs. remote sites

If the page that appears in your browser has been whacked by WebWhacker, it displays the version of the URL that resides on 
your local hard drive or network. If the URL is one that changes frequently, or if you just want to make sure you are viewing the 
latest version, rewhack it or use the Renew function to update it.

              Related Topics  



Browser preferences
Use the Browser/Mail preferences to specify your browser application and e-mail address.

Updating browser and mail preferences

1. From the Tools menu, select Preferences. Then select the Browser/Mail page.

2. Use the Locate button to find your Web browser.

3. Type your complete e-mail address in the Email Address text box 

4. If you want to update another preference, select the appropriate page.
If you are finished updating preferences, select OK. 

TIP:    Crossed preferences

If you have more than one browser on your system, you can only view your WebWhacker database from the browser set in the 
browser preferences.    For example, if you have set your browser preference to Microsoft's Internet Explorer,™ you cannot 
view your WebWhacker database with Netscape Navigator.™



Clear URLs
Use this function to remove URLs from your WebWhacker database.

Clearing URLs

1. To delete more than one URL, select the List view tab to switch to the List view.

2. Select the URLs you want to delete. 
To select all the URLs on the list, from the Edit menu choose Select All.
Hold down the CTRL key to select (or deselect) several non-contiguous URLs. 
Hold down the SHIFT key to select all the URLs between the two points.

3. When you have selected the URLs you want to delete, from the Edit menu select Clear. WebWhacker removes all the selected 
URLs from the database and from your list.

TIP: Removing URLs everywhere 

Removing URLs from the WebWhacker database does not remove them from the WebManager.



Configure your browser to use WebWhacker
Before you can use WebWhacker with your Web browser, you must tell your browser to use a proxy. This procedure varies with 
each Web browser. We have provided directions for the two most popular browsers. If you use another browser, contact your 
network administrator or the browser manufacturer for details.

To configure your browser to use a proxy:
              In Internet Explorer™  

              In Netscape Navigator™  
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Create a new URL subscription
WebWhacker works by creating a database of URLs which have been subscribed to and whacked.    Subscribing to a URL puts it 
into your database; sets the category, update frequency, and other properties for that particular URL; and then marks it for whacking. 
You can subscribe to a URL by typing in the complete URL of the Web page, or you can grab a site as you are browsing. Whacking 
a URL creates a copy of that site on your local hard drive or network server. Once you have whacked a site, you can view it again 
and again, without an online connection or additional charges. 

Creating a new URL subscription
              Make sure all settings are correct.  

              Subscribe to the desired URL  .

              Perform the whack  .



Cut, Copy, Paste
The standard Windows Cut, Copy, and Paste functions are not currently implemented.



Disable whacking
Before you can begin whacking, you have to tell WebWhacker what URLs you want to whack. Marked URLs have a whacking knife 
over their icon. If you don't want a URL whacked, you can unmark or disable it. A URL that has been added or grabbed but not 

whacked appears in the WebWhacker window with a small globe icon.  This indicates that the URL is still only on the Internet 
and has not yet been saved to your hard drive or local network server.

Disabling whacking

1. Click on the whack knife of each URL whose whacking you want to disable
OR
Select the URL, and then go to the URL Menu and select Disable Whack. WebWhacker removes the whacking knife from the 
icon.

2. When you begin whacking (either manually or according to the schedule), all unmarked URLs are excluded from the 
procedure.



Display headlines
You can use the Headline function to create a temporary Web page with links to all your URLs. 

To display the headlines page

1. Select Headlines from the Toolbar
OR
Go to the File menu and select View Headlines.

2. WebWhacker creates a temporary Web page with a listing of all your whacked URLs as links.    Click on any site name to 
view the appropriate page.



Display list of URLs
When you open WebWhacker, a list of all your subscribed URLs is shown in the upper portion of the window. You can display this 
list either as a tree structure (Tree View) or as a hierarchical list (List View). The list view can be sorted by URL or by page title.

You can also use the WebWhacker Headline function to create a temporary web page with links to all your URLs. 



Edit menu
The Edit menu gives you access to basic functions for manipulating your URL list.

              Cut, Copy, Paste  

              Clear   selected URLs

              Select     All   URLs



Enable whacking
Before you can begin whacking, you have to tell WebWhacker what URLs you want to whack. Marked URLs have a whacking knife 

over their icon. When you have subscribed to a URL by adding or grabbing it, a small globe icon.  appears next to the URL in 
the URL list. This indicates that the URL site is still only on the Internet and has not yet been saved to your hard drive or local 
network server.

Enabling Whacking

1. Click on the whack knife of each URL you want to whack
OR
Select the URL, go to the URL menu, and select Enable Whack. WebWhacker changes the icon to include the whacking 
knife.

2. When you are ready to begin whacking, the marked URLs are whacked based on the levels specified in their properties. You 
can perform the whack at once, or you can set WebWhacker to whack all enabled URLs at a later time (for example, after 
hours when connection rates are lower.). Use the Updating Scheduling Preferences    procedure to set WebWhacker to update 
your URLs according to a schedule.

              Perform the whack  



Error list
You can display a list of all the errors WebWhacker encountered in whacking or renewing subscribed URLs. The list is displayed in 
URL order. When you select a URL, WebWhacker displays the errors associated with that URL.

A red icon next to a URL indicates an error occurred while whacking that URL. The problem could be as simple as the user 
cancelling a whack, or it may indicate that a URL or subordinate file could not be found.    In general, if the red image is a globe, that 
indicates a problem with downloading the URL; if the red image is a smaller globe on a piece of paper, that indicates a problem with 
one of the subordinate files (usually an image that could not be found).

To get more information about the error, right-click on the site and select View Errors. You can also display the errors associated 
with a particular URL by using the URL properties function.

Displaying errors

1. From the Tools menu, select View Errors. WebWhacker displays the Errors listing of all URLs where difficulties were 
encountered.

2. Select the URL whose errors you want to review. WebWhacker displays the errors associated with that URL.

TIP: The persistence of errors in memory

Error conditions are not retained in memory when you exit the program. So today's error list shows only today's errors; you 
cannot wait and check them out next week.



Error properties
You can use the View Error list to review any errors encountered in whacking or renewing a URL You can't make any changes to 
this list but you can use it to analyze error conditions.

Viewing the error list

1. Select the URL whose properties you want to update.

2. Click on the Props button or from the URL menu select Properties. WebWhacker displays the URL Properties window.

3. Select the Error page. WebWhacker displays the Error List with all the error conditions associated with this URL.

4. If you want to look at or update another preference, select the appropriate page.
If you are finished updating preferences, select OK. 



Exit
Choosing Exit from the File menu closes your database and shuts down the program. WebWhacker conforms to the convention for 
databases of saving changes as you make them, so you will not be asked if you wish to save changes before exiting. Choosing exit 
does not shut down your Web browser or close any open online connections.



Export
How Exporting Works

The Export function allows you to save much of the information in your database of subscribed URLs to text and image files on your 
hard drive or local network. You can use these files if you want to recycle graphics from a Net page or to examine and edit the HTML 
code of a page you admire. 

WebWhacker's Export function works in a manner similar to the File/Save as function of your Web browser, except that it adds the 
ability to automatically save all image or other associated files referenced in the HTML code.    The exported files contain only raw 
HTML—the information you see when you choose to View Document Source in your Web browser.    If the HTML page references 
any images, movies, or other enhancements, the associated files will be saved in the appropriate format (for example, graphics are 
usually .GIFs or .JPGs). Unless the original Web page creator used relative URLs to reference embedded graphics, etc., these 
exported pages do not include any working links and thus do not function like typical Web pages. However, the text file of HTML 
code, the graphic file, or embedded movie file can be viewed with any application that can deal with that particular file type.    For 
example, you can view the HTML code with most word processors, including the WordPad applet that ships with Windows 95; you 
can view GIF or JPEG files with most photo-editing applications (such as PhotoShop). 

Note that exporting a large file or group of files may take a long time.    As when you are deleting or saving a large file to your hard 
drive, you CANNOT stop the export in the middle of the process. 

Exporting whacked pages

1. To export a particular page and its associated files, click to select the URL or particular file you want to export. In List 
view, you can select multiple pages by holding down the CTRL key while clicking on the various URLs. In Tree view, you 
may only select one file at a time. In either view, if you select an HTML file that contains images or other multimedia files, 
these associated files will be included in the export.
If you select a URL that is an HTML file, you will export the main file in HTML format and the included files in their native 

formats (usually GIF or JPG for images, AVI or MOV for movies, etc.)
If you select just an individual associated file (image, movie, etc.), it will be exported in its native format as above.

To export an entire site, go to List view and click on the word URL in the title bar to sort your list of sites by their location. 
Then, hold down the CTRL key while clicking on each of the files for that site. This will export all of the files at that 
particular location; references to pages not on the main site will be listed elsewhere and will not be exported unless you 
choose those files explicitly.

2. From the File menu or Toolbar, choose Export.

3. Navigate the Browse for Folder tree which appears to select the folder to which you want to export the selected file or 
files.    Click OK.

4. The selected files will be exported as marked.

TIP:    Dating exported files

Exported files carry the date on which they were saved to disk.    They do not reference the date on which the original Web 
page was created or the date on which it was last downloaded to your WebWhacker database.



FTP
FTP stands for File Transfer Protocol, 



File menu
The WebWhacker File menu contains the following functions:

              View     Headlines   on a Web page listing links to all subscribed URLs  

              Whack   all marked and subscribed URLs  

                  Renew   all whacked URLs  

                  Import  

                  Export  

                  Exit  



A tip for:

Accessing the Whacker database
You cannot access or manipulate the WebWhacker database of subscribed URLs with any other database management system; it 
is in a format that only WebWhacker can interpret.    However, you can export the information in raw HTML format. 



A tip for:

Backing up the WebWhacker database
All databases rely on intricate linkages among the various pieces of information.    For this reason, database are, by their very 
nature, more subject to corruption problems than are other file types.    Be sure to include the WebWhacker database in your daily 
backup schedule. 



A tip on:

The persistence of errors in memory
Check error conditions as soon as possible.    Error conditions are not retained in memory when you exit the program. So today's 
error list shows only today's errors; you cannot wait and check them out next week.



A tip for: 

Connecting through Windows 95 dial-up networking
If you want to use scheduling to have WebWhacker perform unattended whacks and renewals, you must have your Windows 95 
dial-up networking correctly configured. This connection must be set up so that it will automatically send your username and 
password to your Internet Servicer Provider. If you normally type your username and password into a dial-up window, the scheduled 
whack or renewal will not occur. When everything is correctly configured, WebWhacker will use this facility to dial up and connect to 
your Internet provider, download the scheduled whack and renewal URLs, and close the connection.



A tip for:

Coordinating scheduling preferences 
and update frequency properties
The Update Frequency property and the Scheduling preferences work together in performing your whacks and renewals. 
Remember that the URL Update Frequency is an individual property which must be set separately for each URL. The Scheduling 
preferences are global (within the context of WebWhacker), and apply to all URLs.Scheduling preferences can override Update 
Frequency properties because WebWhacker only looks at Update Frequencies when the Scheduling Preference request it. For 
instance, if your Scheduling preferences are set for weekly on a specific day (say, Sunday) but a particular URL's Update Frequency 
property is set to daily, that URL will only be updated once a week (on Sunday).



A tip for:

Coordinating sites and categories
When you add a URL within WebWhacker, the URL is added to WebManager as well. When you delete a URL WebWhacker, it is 
not deleted from from WebManager. However, if you add or delete a URL from within WebManager, the URL is deleted only from 
WebManager's categorization view; it is not deleted from your WebWhacker database of online sites.



A tip for

Crossed Web browser preferences
If you have more than one Web browser on your system, you can only view your WebWhacker database from the browser set in 
the browser preferences.    For example, if you have set your browser preference to Microsoft's Internet Explorer,™ you cannot view 
your WebWhacker database with Netscape Navigator.™



A tip for:

Dating exported site files
Exported files carry the date on which they were saved to disk.    They do not reference the date on which the original Web page was 
created or the date on which it was last downloaded to your hard drive or local network.



A tip for:

Identifying the App Bar's reserved area
The blank gray area on the right end of the App Bar is reserved for future development. Access to other products—such as 
WebSeeker, a multi-engine Internet search tool, and GrabNet, a browser companion for capturing and organizing URLs— will be 
added to the App Bar. 



A tip for:

Keeping local sites current
If the page that appears in your browser has been whacked by WebWhacker, it displays the version of the URL page that resides 
on your local hard drive or network. If the URL is one that changes frequently, or if you just want to make sure you are viewing the 
latest version, set the URL's Update Frequency to see if it is eligible for renewal and rewhack it or use the Renew function to update 
it.



A tip for:

Managing categories
Categories are a function of WebManager, so when you add or delete categories from within WebManager, the categories are 
added or deleted across the board (in WebManager, in the Add and Grab dialogs, and in the first screen of the URL Subscription 
Wizard). However, if you delete a URL from within WebManager, the URL is deleted only from WebManager's categorization view; it 
is not deleted from your WebWhacker database.



A tip for:

Removing URLs everywhere
Removing URLs from the WebWhacker database does not remove them from the WebManager.



A tip for:

Stopping a large whack
It may sometimes take WebWhacker a moment to respond to your request that it stop whacking. In particular, it will not pause 
during the extraction process (when it downloads a site and then unpacks the list of required files).    You can tell if you are in the 
extraction process by watching the messages in the Whack status window  .  



A tip against:

Undocking the Whack status bar
Dragging the Whack status bar out of its docked position in the WebWhacker window tends to de-stabilize the product, leading to 
unexpected crashes.    Feel free to re-size the relative space of the panes within the WebWhacker window, but avoid undocking the 
Whack status bar altogether.



A tip for:

Using multiple docking toolbars
If you have other programs or suites with dockable toolbars, you may dock multiple toolbars at any edge of the screen. However, 
only one of the toolbars docked at any given edge may be set for AutoHide. You have two ways to change the App Bar's location. 
Either click once in a blank area of the App Bar and drag it to a different screen edge, OR right-click in a blank area of the App Bar 
and then click to select whether you want the App Bar to dock at the Top, Bottom, Left, or Right edge.



A tip for:

Viewing properties in WebManager
If the properties of the URL you want to inspect do not appear in the right pane, be sure you have clicked on the appropriate 
category in the left pane.

If any of the properties are truncated, double-click on the column's separator bar (the bar between the names of each column, 
located at the top of the window pane.) 



A tip for:

Viewing the Whacker status bar
To toggle display of the status information on and off, go to the View menu and select Whacker Status Bar.



A tip for:

Whacking large sites
Avoid choosing All levels on large sites (or most commercial sites).    These URLs can be enormous, consuming many megabytes 
of your hard drive and great amounts of connection time. 

If you want to maintain some links but need to limit the size of the whack, choose 1 or 2 levels.



General preferences
Use the General Preference page of the Preferences dialog box to set basic preferences for your system.

Updating general preferences

1. From the Tools menu, select Preferences. Then select the General page. WebWhacker displays the General dialog.

2. If you want WebWhacker to ignore inline images when it whacks pages, select Ignore Inline Images. Ignoring inline images is 
the same as setting your browser to not display images. This makes the whacking and displaying of pages faster. 

3. If you want the App Bar to automatically load when you load WebWhacker, select Start App Bar automatically.

4. If you want to update another preference, select the appropriate page.
If you are finished updating preferences, select OK.
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Grab a new URL
You can easily add a new URL to your WebWhacker database by grabbing it from your Web browser.

Grabbing URLs

1. Using your Web browser, display the URL you want to grab.

2. Select Grab from the App Bar 
OR
Switch to WebWhacker. Then select Grab from the Toolbar or go to the URL menu and select Grab.

WebWhacker displays the first page of the URL Subscription Wizard with the URL for the page you grabbed in the URL to Add 
text box

3. In the tree window labeled Select the Category for this URL, double-click on the name of the category want to assign this 
URL. If the category you want does not appear in the window, you can to display your subcategories by clicking the plus sign 
next to the All.

4. When the URL and categories are set the way you want them, select Next. WebWhacker displays the second page of the URL 
Subscription Wizard.

5. Select the number of levels of this site you want to whack. 
If you only want this page, use 1. 
If you want all the links from this page, select All.

6. If you don't want WebWhacker to whack pages from other URLs that are linked to this URL site, select Remain on Site. If you 
chose to whack All levels in the previous step, Remain on Site is selected automatically and the option is grayed out, making it 
unavailable.

7. It the site you selected requires a user name and password, type your user name and the appropriate password. 

8. When you select Next, WebWhacker displays the third page of the URL Subscription Wizard.

9. Select the renewal frequency you want for this URL. 

If you only want to whack this URL one time and never renew it, select Just this Once.

If you want to update this URL every day (or once every week, or once every month), choose Daily 
(or Weekly or Monthly).
If you select a daily, weekly, or monthly update cycle, WebWhacker automatically updates the links according to the schedule you 
established in your Preferences. 

10. When you select Finish, WebWhacker grabs the URL, adds it to your list, and marks it for whacking.

Next step:

                  Perform the whack  



Help menu
The WebWhacker Help menu contains the following functions:

Contents listing all Help topics and giving you access to the topics.

Tip of the Day (not currently implemented).

About WebWhacker, giving the version and release date of the program.



Icons
The following table defines the meanings of icons that appear next to individual URLs in WebWhacker.

Icon Enabled Local Remote # Levels

?

1

>1

?

1

>1

Key:

Enabled:    the URL is ready to be whacked.

Local:    the URL has been whacked (saved to your hard drive or local network).

Remote:    the URL has been marked for whacking but has not yet been whacked.

# Levels: indicates whether only the top level of the URL site has been/will be saved locally (1) or whether additional levels 
have been/will be saved locally (>1). 

If any icon turns red (for example,  or 

), that indicates an error occurred while whacking that URL. The problem could be as simple as the user cancelling a whack, or 

it may indicate that a URL or subordinate file could not be found.    In general, if the red image is a globe, that indicates a problem 
with downloading the URL; if the red image is a smaller globe on a piece of paper, that indicates a problem with one of the 
subordinate files (usually an image that could not be found).
To get more information about the error, right-click on the site and select View Errors. 



Import
If you acquired a useful database in WebWhacker 1.0 that you want to use in the new version of the program, the Import function 
will allow you to import your previous groups of URLs.    This function does not import the content of the previously whacked pages; 
it only brings the site URLs and original level settings into the List view.    In order to access graphics and data from the site, you 
must rewhack each URL and, if desired, add it to the Tree view. 

NOTE:    The import function can only be used to import WebWhacker 1.0 database files.

To import a database from a previous version

1. Go to the File menu and choose Import.

2. Navigate the folder tree that appears to find the file containing the desired database. While WebWhacker 2.0 saves all 
whacked sites in a single web database (.WWDB file), WebWhacker 1.0, saved each group in a separate .WWD file. You 
must import each group file (*.WWD) separately.

3. Click on the name of the group file you want to import.

4. Click Open to import the individual file.    WebWhacker reads in the URLs contained in that file, closes the folder tree 
window, and switches you to the List View window. The imported URLs will be on the list, enabled for whacking.

5. Repeat steps 1-4 for each group you want to import.

6. When all desired groups have been imported, click on the Whack button to begin whacking the URLs, downloading their 
HTML and associated files into the WebWhacker database.



Installation step 1:
Install the WebWhacker program

Installing WebWhacker

1. If you have downloaded WebWhacker, copy your zipped (*.ZIP) or self-extracting executable (*.ZIP) file into an empty folder 
(or directory). Double-click on the .ZIP or .EXE file or open it from within your zip manager. 

OR

If you have acquired WebWhacker on disk, insert disk 1 in your floppy drive. 

2. Click on your Windows Start button, choose Settings, and then Control Panel. Double-click on Add/Remove Programs, and 
choose Install. Click Next to tell Windows 95 to find the setup file. When A:\SETUP.EXE appears in the Command Line for 
installation text box, click Finish to start the installation process.

3. In either case the Install Shield Wizard loads. When the Setup Welcome screen appears, you are advised to close down all 
currently running programs. Use Alt-Tab to switch to each running program in turn and then exit that program.

4. In the Choose Destination Location screen, you have the option of choosing the directory in which to install WebWhacker. By 
default, WebWhacker installs on your hard drive in C:\PROGRAM FILES\FOREFRONT\WEBWHACKER2, where c:\ is the 
name of your hard drive.

To install the program elsewhere, click the Browse button and navigate your directory structure to choose the desired directory. 
You may add a new directory by typing its full name and path in the Path: text box and responding Yes to the resulting dialog.

5. The Setup program copies and installs all necessary files to your hard drive. If you are installing from a floppy disk, insert disk 2 
when prompted and click OK.

6. At the end of the Setup program, a new WebWhacker group is added to the Programs section of your Start menu.

Next step:

                  Set up your preferences in   WebWhacker.  



Installation step 2:
Set preferences for WebWhacker
For best results, you must set up your Web browser's location and cache pass-thru status. You may also want to set up other 
preferences.

Setting preferences for WebWhacker

1. From the Tools menu, choose Preferences. 

2. Select the Browser/Mail page. Type the full path of your Web browser in the Web Browser text box. 

TIP: 
If you are using Microsoft Internet Explorer™, this path ends with IEXPLORE.EXE. (Do not choose EXPLORER.EXE, the file for 
Windows Explorer™)

3. Select the Proxy Server page. In the Local Proxy Cache section, click in the Allow passthru on cache misses check box if 
you want to be able to browse sites you have not yet whacked.

4. If your network system has a firewall, you must also fill in the correct DNS number and port in the Remote Proxy section of the 
Proxy Server page. See your network administrator for the correct numbers to enter in this section.

                  For more details on other preference settings, see   Setting   WebWhacker   Preferences.  

Next step:

                  Configure your browser to use   WebWhacker  .  



Installation step 3: 
Configure your browser to use WebWhacker.
Before you can use WebWhacker with your Web browser, you must tell your browser to use a proxy. This procedure varies with 
each Web browser. We have provided directions for the two most popular browsers. If you use another browser, contact your 
network administrator or the browser manufacturer for details.

Configuring your browser to use a proxy:

                  In Internet Explorer™  

                  In Netscape Navigator™  

Next step:

                  Add   WebWhacker   to your StartUp group  



Installation step 4:
Add WebWhacker to your StartUp group
WebWhacker is designed to make your Internet surfing easier as well as less expensive. To that end, you want its operation to be 
as transparent as possible. By adding WebWhacker to your StartUp group, you eliminate one more step separating you from the 
'Net.

Adding WebWhacker to your StartUp Group

1. Click on the Windows Start button, point to Settings, and then choose Taskbar.

2. Select the Start Menu Programs tab and click on Browse.

3. In the Command line edit box, type in the full path for WebWhacker. If you have chosen the default location, type

C:\PROGRAM FILES\FOREFRONT\WEBWHACKER2\PROGRAM\WEBWHACKER.EXE

Or use the Browse command button to locate the file.

4. Click Next, and then double-click the StartUp folder.

5. Type the name you want to appear on the StartUp menu, and then click Finish.



Installing WebWhacker 2.0
Before using WebWhacker, you must:

                  Install the     program.  

                  Set preferences for the program.  

                  Configure your Web browser to use   WebWhacker.  

                  For best results, add   WebWhacker   to your start-up group.   



Known problems & limitations
Browser Links

If your system loads a different program when you are expecting it to load your Web browser, you may have your browser 
improperly designated in the WebWhacker Preferences. Use the procedure Updating Browser and E-Mail Preferences to 
designate the correct browser.

CGI-Generated Scripts and Images

WebWhacker 2.0 does not support CGI-generated scripts and images.To view or navigate Web pages with CGI-generated 
items, turn off the proxy    function in your Web browser. 

We do, however, support client-side image maps. 

Database Compression

WebWhacker 2.0 does not currently compress its database when you delete sites; however, the program will reuse space 
recovered from the deleted information before using additional hard disk space.    A future release will support database 
compression.

Forms (Search Forms)

WebWhacker 2.0 does not support HTML forms (for example, search forms).    To use a search form, turn off the proxy    
function in your Web browser. 

FTP

When whacking files, be sure that your FTP path ends with a file name. (FTP only supports the transfer of files; it does not 
download directories.)

For example

FTP://SOMEWHERE.OUT.THERE/FILES/ 

does not work. The correct format is:

FTP://SOMEWHERE.OUT.THERE/FILES/FILE1.TXT

At the present time, WebWhacker 2.0 does not work as an FTP proxy. 

For more information, see the section on how to Use FTP with   WebWhacker.  

Interrupted Whacks

If your modem drops your Internet connection, your operating system may not be aware of the lost connection. In that case, 
WebWhacker may also be unaware of the lost connection and may hang. Use the End Task function (CTRL-ALT-DEL) to stop 
WebWhacker.

Whack status bar, undocking



Dragging the Whack status bar out of its docked position in the WebWhacker window tends to de-stabilize the product, leading 
to unexpected crashes.    Feel free to re-size the relative space of the panes within the WebWhacker window, but avoid 
undocking the Whack status bar altogether.

Unsupported protocols

WebWhacker 2.0 does not support file, gopher, mail, news, and nntp. When the program encounters references to these 
protocols in the HTML, the references are skipped.

Very Large Whacks

If a site is very large, we recommend that you do not whack the entire site at once because of the load this places on your 
computer's CPU and hard drive. Instead you should whack a few levels at a time. Even then, be aware that a very large 
database of sites may take a significant time to load.



Lesson 1: 
Using a WebWhacker database
WebWhacker is an advanced off-line browsing tool that allows you to re-create sections of the World Wide Web directly on your 
hard drive or local network. You can save particular pages, complete with text, links, graphics, Java™ applets, sound clips—even 
video clips if you have sufficient hard drive space. Once the Web pages are saved to your hard drive (that is, once you have 
"whacked" them), you can refer back to the information and clips at any time—without an online connection and additional 
connection charges.

You can begin using WebWhacker with the sample data included with the program.

1. First, open the program.

Go to the Windows 95 Start button.

Choose Programs / WebWhacker / WebWhacker 2.0

2. Now examine your screen.
When you open the program, WebWhacker displays a list of all your URLs in the upper portion of the window. If you are using 
the sample data, your screen should look like the image below:

The icon next to each URL alerts you to the status of that particular URL.

Icon Enabled Local Remote # Levels



?

1

>1

?

1

>1

Enabled:    the URL is ready to be whacked.

Local:    the URL has been whacked (saved to your hard drive or local network).

Remote:    the URL has been marked for whacking but has not yet been whacked.

# Levels: indicates whether only the top level of the URL site has been/will be saved locally (1) or whether additional levels 
have been/will be saved locally (>1). 

A red icon indicates an error pertaining to that URL.    To get more information about the error, right-click on the site and select 
View Errors. 

3. Change the way the data is displayed.
You can display your list of sites either in a tree structure (Tree View) or as a hierarchical list (List View).

Click on the Tree View tab. Tree View arranges your sites alphabetically by their URL. 

Click on the plus sign (+) next to a URL icon to display any pages linked to the top-level page.

Click on the List View tab. List View shows each page separately. 

Click on "URL" or "Title" in the gray bar at the top of the URL list to change the sorting order. You 
can sort the sites either by their URL or by their page title. You can also go to the View menu and select Sort by URL or Title to 
change the viewing order.

4. View sites locally or on the Web.
You can use the program to surf the Net, either directly or on your own hard drive.

Click on the Tree View and locate this entry in the site list:



HTTP://WWW.FFG.COM

Double-click on the URL to load this Web page into your browser. (You may have to click on your 
browser in the Taskbar to bring it into focus.)    This site is local, i.e., it has been saved to your hard drive.    You do not need an 
Internet connection to view it.

In the Tree View, locate    
HTTP://WWW.WHITEHOUSE.GOV/WH/WELCOME.HTML.
(You may have to move back to WebWhacker by clicking on any visible portion of its window or clicking on its name on your 
Taskbar.) 

Double-click on the URL to bring the page into your Web browser.    Note that since this URL is 
remote, you must have an active Internet connection to view it. 

NOTE:    If you are having any difficulty viewing these URLs, make sure you have set your program preferences and configured your 
browser correctly. 

Next lesson:

                  Adding and grabbing URLs  



Lesson 2: 
Adding and grabbing URLs
The real usefulness (and fun!) of using WebWhacker starts when you create your own collection of subscribed URLs. If you 
constantly refer back to the same sites—for information or enjoyment—why not save them to your own hard drive and eliminate 
connection charges? You can also assign your favorite URL sites to categories, making it even easier to find the information you 
want.

If you have memorized the URLs of your favorite Web sites, you can add these sites simply by typing them in an edit box. More 
relaxed 'Net surfers can grab sites on the fly as they find them.    Either way, you will have the opportunity to categorize the URLs 
and to define how often they will be updated.

1. First, we'll add a site with a known URL.

Go to the main WebWhacker window. 

From the URL menu, select Add. This starts the URL Subscription Wizard.

Click in the URL to Add text box, press the END key to position the cursor after the second slash, and 
type the URL for the Library of Congress:
WWW.LOC.GOV

Click on EDUCATION to put this URL into its appropriate category. Click Next.

Leave all settings as they are on step 2 of the URL Subscription Wizard. Since the Library of 
Congress maintains a huge site, going more than one level deep could decimate your free hard drive space. Since it is a public site, 
no user name or password is needed. Click Next.

Select DAILY to have the information on the Library of Congress Web site downloaded and updated 
every day. If you leave your computer on at night, WebWhacker will automatically dial into your Internet connection and update 
selected URLs every day. (The intricacies of setting update frequencies and scheduling provide you with numerous options.) 

Click Finish. 

The site has now been marked and enabled for whacking, but it has not yet been copied to your hard drive. Before actually 
whacking the URL we'll set up another one using the Grab facility.

2. Now we'll grab a site while browsing.

Open your favorite Web browser.



You can surf the Net to your favorite sites. If you're politically aware, you may want to check out the 
White House home page by typing its URL in the text box labeled Address (for Microsoft Internet Explorer™) or Location or 
Netsite (for Netscape Navigator™):
HTTP://WWW.WHITEHOUSE.GOV

Arrange your browser and WebWhacker windows onscreen so that you can see both.

Click the Grab button on WebWhacker's toolbar. This starts the URL Subscription Wizard.

Follow the same procedure that you used to add a site above.

3. Finally, perform the whack.

When you add or grab a site, it is added to your list but, as its icon shows, it has not yet been saved to 
your hard drive. 

Click the Whack button on WebWhacker's toolbar. This starts the actual whack, or download to disk. 

Watch the message areas in the bottom half of the screen for information as to how the whack is 
proceeding.

Now that you have used both approaches to subscribe to a URL, experiment on other sites with different settings.    You could also 
use the Grab and Whack buttons on the App Bar instead of those on WebWhacker's toolbar.

Next lesson:

                  Using categories to manage subscribed URLs  



Lesson 3: 
Using categories to manage subscribed URLs
As your list of subscribed URLs begins to grow, you may need help keeping it organized. When you added and grabbed URL sites in 
the last lesson, you assigned them to categories. The easiest place to work with your categorized URLs is within WebManager.

1. Use WebManager to browse.

Click the WebMgr button on the WebWhacker toolbar. 

Examine the Explorer-style window. 

Each folder (or directory) in the tree pane represents one category (such as Arts, Business, or Education). Double-click on 
any folder in the tree pane to bring up a list of the URLs assigned to that category.

Browse the categories until you find a URL you want to visit.    Double-click on the name of the URL. 
The whacked page appears in your Web browser's window. 

2. Customize your WebManager categories.
The categories that ship with WebManager may not precisely suit your needs.    For example, in the previous lesson we 
assigned the Library of Congress site to the Education category; it could also fit into a subcategory called Libraries. And you 
probably added the White House home page to the Misc category; wouldn't Government be a better choice?. We can add new 
categories and subcategories, and move our sites between categories.

Click on the word All labeling the folder at the top of WebManager's tree pane.



From the Edit menu, select Add and then Folder from the submenu.

In the Add New Folder dialog box, type GOVERNMENT in the Folder Name text box. Click OK.    The 
new category appears in the tree window.

To add a new Library subcategory, click on the Education folder.

From the Edit menu, select Add and then select Folder from the submenu.

In the Add New Folder dialog box, type LIBRARIES in the Folder Name text box. Click OK. Libraries 
appears as a subcategory of Education.

3. Now let's move sites into the new categories.

Click on the word MISC labeling a folder in the tree pane.

In the right-hand pane, click on the icon next to the White House URL. Keeping the mouse button 
depressed, drag the URL to the GOVERNMENT folder. Release the mouse button.

Click on the word EDUCATION labeling a folder in the tree pane. If necessary, click on the plus sign 
(+) next to the folder to display its LIBRARIES subcategory.

In the right-hand pane, click on the icon next to the Library of Congress URL. Keeping the mouse 
button depressed, drag the site to the LIBRARIES subcategory in the tree window. Release the mouse button.

Your whacked URLs are now located in their new categories.

TIP:    Using Categories

Since categories are a function of WebManager, when you add or delete categories from within WebManager, the 
categories are added or deleted across the board. However, if you delete a site from within WebManager, the site is 
deleted only from WebManager's categorization view; it is not deleted from your WebWhacker database of online sites.

Next lesson:



                  Keeping your subscribed URLs current  



Lesson 4: 
Keeping your subscribed URLs current
When we added and grabbed URLs in a previous lesson, the URL Subscription Wizard prompted us to choose a renewal or update 
schedule for the site. Some URLs are constant and you may never want to update them.    But others change frequently (some news 
sites change several times an hour), and you want to keep them current. WebWhacker will renew these URLs, either automatically 
at a pre-scheduled time, or manually when you request a renewal. 

1. First, check your Update Frequency setup.

In the main WebWhacker window, right-click on the White House URL we added in a previous lesson. Choose Properties 
from the shortcut menu. Select the Update Frequency page to check the current settings.

You could use the Update Frequency drop-down list box to change the frequency, if desired.

Click OK to close the Properties box.

2. Next, request a manual renewal. 
A manual renewal performs any updates that would normally occur if the automatic update facility were activated.    Since we 
set the site's update frequency to daily, this site is ready to update if you added it at least one day ago. 

Click the Renew 

button on the toolbar in WebWhacker or on the App Bar,
OR
Go to the File menu and select Renew.

Watch the bottom half of the WebWhacker window to determine the current status of your renewals. 
When the message says Done, your renewal is completed.

3. To perform renewals automatically, 
Your computer must be turned on and connected to a modem at the time set in the Scheduling section of the program 
Properties. (From the WebWhacker Tools menu, choose Preferences and then Scheduling to check your current renewal 
time.)    You do not have to have an active internet connection; WebWhacker's automatic dialing facility will make the 
connection for you.

For more information on how scheduling and renewals work, see:

                  Frequency Property  

                  Scheduling Preferences  

-



Menu bar
The program's Menu bar contains the various functions needed to use WebWhacker.

 

Click on any menu item above for more information about its functions.

Menu bar functions
               File   menu.   The File menu contains basic WebWhacker functions such as whack and renew, as well as the Import and 

Export functions.
               Edit   menu.   The Edit menu contains the standard functions to select and manipulate items.

               URL   menu.   The URL menu contains fucntions to add URLs, browse them, enable and disable whacking, set whacking 

levels, and change other URL properties..
               Tools   menu.   The Tools menu contains the functions required to view information about the WebWhacker database. You 

can look at the error report, find the URLs that have been whacked recently, and set system-wide preferences.
               View   menu.  The View menu allows you to sort the URLs on the list and change the elements displayed in the 

WebWhacker window.
               Help   menu.   The Help menu contains basic information about the program (version, date) as well as giving access to this 

Help information.



Move subscribed URLs to new categories 
(in WebManager)

From time to time, your category needs may change. If one category becomes too large, you may create subcategories or even new 
main categories. You can easily move URLs to new categories without any need to go online or to re-type the information. 

Moving a subscribed URL to a new category

1. From within the WebManager window, navigate the categories in the tree pane (on the left) to select the category currently 
holding the URL you want to move.

2. In the right-hand pane, click once to focus on the URL you want to move. It is usually best to click on the icon to the left of the 
URL name.

3. Keeping the mouse button depressed, drag the URL to its new category in the left-hand pane. When the site name is 
highlighted, release the mouse button.

4. Your URL is now located in its new category.

                  Related Topics  



Network preferences
Use the Network Preferences to specify basic network management options

Updating network preferences

1. From the Tools menu, select Preferences. Then select the Network page.

2. Enter the number of times you want WebWhacker to try to access a site if it is unsuccessful on the first attempt.

3. Enter the amount of time, in seconds, you want WebWhacker to wait before trying to access a URL a second if it is 
unsuccessful on the first attempt.

4. If you want to update another preference, select the appropriate page.
If you are finished updating preferences, select OK. 



Perform the whack
How Whacking Works

When you request a whack, WebWhacker looks at every URL that you have marked for whack. If the URL has been whacked 
before, WebWhacker queries its server to determine whether the page has changed since the previous whack date. If the server 
indicates that the page has been changed or if it's a new page, WebWhacker downloads the page.

If you have set your preferences to whack URLs according to a schedule, the URL must be marked for whack and the Whack 
checkbox in your preferences must be checked. 

Whacking a URL

1. To perform a whack, click the Whack button on the Toolbar or the App Bar.
OR
From the File menu, select Whack.

2. WebWhacker copies the current page and the specified number of link levels to your hard drive or local network. 

If, for some reason, you wish to stop a whack, click the Stop button on the Toolbar. Note that the Stop button may not 
engage immediately, but may take a second or two to engage.    In particular, a Whack will not be stopped during the 
extraction phase (which you can identify by watching the   Whack status pane   for the message "Extracting files...") 

3. The icon next to the URL changes to a globe on a sheet of paper .

Your URL is now whacked, and you can view it locally, without an Internet connection.

Why a whacked URL may not update

It hasn't changed since the last time it was downloaded by WebWhacker.

You expected to whack according to the schedule, but the preferences weren't set to include whacks.

It wasn't marked to whack. Use the procedure Enable Whacking to mark the URL for whacking.



Phone preferences
Use the Phone tab (accessed through the Preferences command on the Tools menu) to configure WebWhacker to perform 
scheduled whacks and renews automatically—even when you're not there. The program will use the preferences on this Phone tab, 
together with the Windows 95 Dial-Up Networking connections you have set up, to dial your Internet service provider, log on, 
download the URLs scheduled for whacking or renewal, and close the connection when it is finished.

TIP:    Connecting with Windows    95 dial-up networking

If you want to use scheduling to have WebWhacker perform unattended whacks and renewals, you must have your Windows 
95 dial-up networking correctly configured. This connection must be set up so that it will automatically send your username and 
password to your Internet Servicer Provider. If you normally type your username and password into a dial-up window, the 
scheduled whack or renewal will not occur. When everything is correctly configured, WebWhacker will use this facility to dial up 
and connect to your Internet provider, download the scheduled whack and renewal URLs, and close the connection.

Setting up Phone preferences:

1. From the Tools menu, choose the Preferences command and then the Phone page.

2. Put a check mark in the box labeled Use Modem if (1) you only have a modem on this machine and your dial-up 
connection is made through the modem; or (2) you have both a modem and a direct network connection, but you want to 
make your Internet connection through the modem.

3. In the box below Phone Book Entry, you will see a list of all the dial-up connections you have configured under Windows 
95 Dial-Up Networking.    Click on the name of the appropriate connection for your Internet provider, and that name will 
appear in the Phone Book Entry text box.

4. If you use a name and password to log onto your Windows 95 machine, and that name and password are the same as 
those you use to log onto the Internet, put a check mark in the box labeled Authenticate using current user name and 
password. 

If you use a different name and/or password to log onto the Internet than you use to log onto your local Windows 95 
machine (or if you do not use any name or password to log onto your local machine), do not put a check mark in the box 
labeled    Authenticate using current user name and password. In this situation, you must type into the appropriate 
boxes the User Name, Password, and Domain that you use in making your Internet connection.

The Domain edit box defaults to an asterisk (*) because you may not need to enter a domain. Check with your network 
administrator or Internet service provider.

5. When you have filled in all the blanks, click Apply and then choose another page to continue setting preferences or click 
OK to close the Preferences dialog if you are finished setting preferences.



Proxy server preferences
Use the Proxy server preferences to specify the information required to use WebWhacker as a proxy server for your Web 
browser. If your site has a firewall, you must give WebWhacker    information about the HTTP and FTP proxies.

TIP:    Controlling Web access with passthru

If you select Allow passthru on cache misses, any time you select a page that is available in its database, WebWhacker 
automatically accesses your Web browser and loads the page.

TIP:    Setting up behind a firewall

If your site is running behind a firewall, you must tell WebWhacker the name or IP address and port number of your HTTP 
proxy (FTP proxy is not currently supported). If you are not sure of this information, contact your network administrator.

If you are not running behind a firewall, you do not need to enter this information.

Updating proxy server preferences

1. From the Tools menu, select Preferences. Then select the Proxy Server page.

2. If you want WebWhacker to automatically access your Web browser when you request a page that is not available in its 
database, check Allow Passthru on cache misses.

3. By default, WebWhacker is set to listen to port 8080. If there is a conflict and you want it to listen a different port, enter the new 
port number.

4. If you are running behind a firewall, enter the name or IP address and port number for the HTTP and FTP proxies. Contact your 
network administrator for this information.

5. If you want to update another preference, select the appropriate page.
If you are finished updating preferences, select OK. 



Remain on site
When WebWhacker begins whacking a URL site, it whacks all links to the level you specify. If the page has links to another site, you 
might not want to whack those pages. Select Remain on Site in the Whack Levels dialog to keep WebWhacker from transversing 
and whacking links to other sites. You can only use the Remain on Site option if you are specifying a number of levels to whack; if 
you are whacking all the links from a page, Remain on Site is selected automatically and the option is grayed out, making it 
unavailable.



Renew your subscribed URLs
Change is probably the only constant on the World Wide Web. Pages change frequently—some news sites change every 15 
minutes! To keep your information up to date, you may want to renew your URLs by setting their update frequency. You can set 
WebWhacker to update URLs automatically daily, weekly, or monthly; or you may manually update your whacked URLs 

How It Works: Whacking and Renewing

When you request a renewal, WebWhacker looks at every URL in its database and compares its modified date to the current date. 
If, based on its update frequency property setting, the URL is scheduled for a renewal, WebWhacker then queries the site server to 
determine whether the page has changed. If the server indicates that the page has been changed, WebWhacker downloads the 
changed page.

On the other hand, when you request a whack, WebWhacker looks at every URL that you have marked for whack and queries their 
servers to determine whether the pages have changed. If a server indicates that a page has been changed, WebWhacker 
downloads the changed page (that is, rewhacks or updates the page).    If a particular page has never been whacked, it will, of 
course, be downloaded (whacked).

Manually renewing whacked sites

1. Open the main WebWhacker window.

2. Be sure you have set the Update Frequency properly for all whacked URLs.

3. Click the Renew button on the toolbar or the App Bar.
OR
Go to the File menu and select Renew.

4. Watch the window at the bottom of the WebWhacker window to determine the current status of your renewals. When the 
message says Done, your renewal is completed.

5. If you wish to stop a renewal before it has been completed, 

Click the Renew button (on the toolbar or the App Bar) again 
OR

Go to the File menu and choose Stop.

TIP:    Stopping large whacks

It may sometimes take WebWhacker a moment to respond to your request that it stop whacking.    In particular, it will not pause 
during the extraction process (when it downloads a site and then unpacks the list of required files).    You can tell if you are in 
the extraction process by watching the messages in the status window.

Reasons a renewed URL may not be re-downloaded

It hasn't changed since the last time it was downloaded by WebWhacker

It was updated within its update frequency period. For example, the URL is set to renew weekly, and it 
was renewed sometime in the past week.



You asked WebWhacker to renew the URL but the Renewal option in Preferences is unchecked. This 
prevents any URLs from being updated using the Renewal function.

You asked WebWhacker to renew a URL (or additional levels of links) that has never been whacked. 
A URL cannot be renewed if it has not been whacked in the first place. For example, if you whack a single level of a URL, then 
change its Properties to whack multiple levels, and finally perform a renew, the additional levels will not be downloaded to your hard 
drive or local network server.    To download the additional levels, you must perform a whack, not a renew.

If there is a problem, you may be able to use the Error Listing to determine what went wrong.



Schedule a whack or renewal
Scheduling a whack or renewal to take place requires you to coordinate a number of different settings. In addition to subscribing to 
the URL (by adding or grabbing it) and (if you want the whack to be unattended) enabling it, you must set up the correct URL update 
frequency and scheduling preferences. Finally, if you want the whacks and renewals performed in your absence, you must set up 
the correct phone preferences and remember to leave your computer on with WebWhacker running. You must also have a Web 
connection that does NOT require you to type your name and password into a dial-up window.    If your Internet Service Provider 
(ISP) requires you to enter your name and password manually each time (rather than with a script or a remembered password), you 
will not be able to perform scheduled, unattended whacks or renewals.

TIP:    Coordinating update frequencies and scheduling preferences.

The Update Frequency property and the Scheduling preferences work together in performing your whacks and renewals. 
Remember that the URL Update Frequency is an individual property which must be set separately for each URL.    The 
Scheduling preferences are global (within the context of WebWhacker), and apply to all URLs.Scheduling preferences can 
override Update Frequency properties because WebWhacker only looks at Update Frequencies when the Scheduling 
Preference requests it. For instance, if your Scheduling preferences are set for weekly on a specific day (say, Sunday) but a 
particular URL's Update Frequency property is set to daily, that URL will only be updated once a week (on Sunday).

To schedule a whack or renewal:

1. Subscribe to the desired URLs by adding or grabbing them.

2. For new whacks, be sure the subscribed URLs have been enabled.
For renewals, be sure the subscribed URLs have the appropriate update frequency set.

3. Be sure that you have set scheduling preferences correctly.

4. If you want to perform the whacks and renewals immediately, click the Whack button from your toolbar or App Bar, or 
choose Whack from the WebWhacker File menu. After the whacks have been performed, do the renewals by clicking the 
Renew button from your toolbar or App Bar, or choose Renew from the WebWhacker File menu

5. If you wish to have WebWhacker perform the whack in your absence, you must also set your Phone preferences correctly 
and have a Windows 95 Dial-Up network connection in place. This connection must be set up so that it will automatically 
send your username and password to your Internet Servicer Provider. If you normally type your username and password 
into a dial-up window, the scheduled whack or renewal will not occur.

When you leave, be sure your computer is running, plugged into a modem or network card, and has WebWhacker 
running.

TIP:    Coordinating whacks and renewals

If you set your scheduled whacks and renewals to occur during the middle of the night, be sure you do not also leave your 
machine running on a large whack. Ongoing whacks take precedence over scheduled whacks and renewals.    The scheduled 
whacks    and renewals are not reset; the scheduling cycle is simply skipped for that time.



Scheduling preferences
You can use the Scheduling tab (accessed through the Preferences command on the Tools menu) to specify the schedule for URL 
updates. Scheduling works in conjunction with the URL update frequency property. The Update Frequency tab (accessed through 
the Properties command on the URL menu) is set each time you add or grab a new URL or when you specifically change an 
existing URL's properties. This update frequency setting is stored separately for each URL.    The Scheduling setting, on the other 
hand, is set globally and determines how often WebWhacker attempts to deal with sites that may require updating. 

How It Works

Every time you subscribe to a new URL by adding or grabbing it, WebWhacker lets you establish the frequency with which your 
subscription will be renewed. Some URL subscriptions you may never want to renew; others you may want to update daily, weekly, 
or monthly. Based on the frequency schedule you establish in the system preferences, WebWhacker looks at each URL that is 
scheduled for update and then queries the server at that page's original site to determine whether the site has changed since the 
last time you downloaded it. If the site has changed, WebWhacker renews the site by reacquiring the page information. 

For example, if your preferences are set to renew daily at midnight, every night WebWhacker looks at all the URLs that have been 
assigned an update frequency. If the update criteria is met (the frequency is daily or today is a week or a month after the last 
update), WebWhacker queries the server at the page's original Internet location to determine the page's modification date on the 
server. The program then compares the two modification dates (on the server and on your local desktop). If the server-based 
modification date is later than your local modification date, the page has probably changed since your last update, so WebWhacker 
downloads the updated page.

Modifying scheduling preferences

1. From the Tools menu, select Preferences. Then select the Scheduling page.
OR
Click the Schedule button on the Toolbar.

2. Select the scheduling options you want:
If you want it to attempt updates every day, select Daily.
If you only want to updates on weekdays (not Saturday and Sunday), select Weekdays Only.
If you want to specify weekly updates on a particular day, select Specific Day. Then select the day from the pull-down menu.

3. Select the time you want the attempted updates to start. Many people prefer having WebWhacker attempt to update their sites 
around midnight when download rates may be cheaper and they aren't using their system.

4. If you want WebWhacker to whack all URLs that have been enabled, select Whack.

TIP: 
URLs that have been enabled for whacking include a knife symbol in their icon.

5. If you want WebWhacker to look at all subscribed URLs that are eligible for renewal (in their Update Frequency Property) and 
download any that have changed since the last time you whacked them, also select Renewal.

6. If you want to modify another preference, select the appropriate page.
If you are finished modifying preferences, select OK. 



Searching 
WebWhacker allows you to search for specific words or phrases contained in the title and/or body text of any of your subscribed 
URLs. 

You can initiate a search

in WebWhacker, by clicking the Search button in the toolbar.

from WebWhacker's Tools menu by choosing Search.

on the App Bar, by clicking on the Search button.

Any of the these actions leads you to the dialog box below.

Conducting a search

1. In the Look for box, type the word or words you want to find. This text is not case-sensitive (for example, WOMAN will find 
WOMAN, woman, Woman, even woMan.) You cannot search for punctuation marks unless you enclose them in quotes (for 
example, use "?" to find a question mark. There is no way to search for a quotation      mark; """ will not work).

2. The searching facility supports Boolean search expressions (AND, OR, NOT). Note that these search expressions are case-
sensitive and must be typed in all capital letters. 

To expand your search, use OR (or "|") between the search terms. You will then find all sites containing ANY ONE of the 



search terms.

To narrow your search, use AND (or "&") between the search terms. You will then find only those sites containing ALL of your 
search terms.

To eliminate all sites containing certain terms, use NOT (or "!") before the search term. You will then find only those sites that 
do NOT contain the negated search term. You may occasionally encounter a problem in parsing queries using the NOT 
function.    You can often sidestep these problems by using parentheses to group search terms.    For example, if "x NOT y" 
does not work as expected, try    "x AND (NOT y)".

To combine multiple levels of search terms, use parentheses to group each level together. If you do not use parentheses, the 
program will attempt to understand your request by assigning requests an order of precedence (from highest to lowest:    NOT, 
AND, OR).    If you are not well-versed in Boolean logic, this may lead to unexpected outcome. Using parentheses to be as 
specific as possible will help ensure that your request is interpreted as you want.

To search for punctuation marks, you must enclose them in quotation marks (that is, to search for a question mark, type "?"). 
You cannot search for quotation marks (that is, """ doesn't work).

3. Use the drop-down box labeled Look in to limit your search to whacked URL Titles only.    To conduct the search throughout 
the entire text of the whacked URL, select both Title and Body. Title searches are quicker; Title and Body searches are more 
complete.

4. Click on Find to initiate the search. 

5. A list of relevant URLs appears in the Results text box. 

6. When the URL title you want appears, double-click on it to load the page into your Web browser.



Security properties
The Security Properties allow you to update the user name and password associated with a particular URL. The password is not 
displayed. 

Updating security properties

1. Select the URL whose properties you want to update.

2. Click on the Props button
OR
Go to the URL menu and select Properties. WebWhacker displays the URL Properties window.

3. Select the Security page.

WebWhacker displays the user name or password assigned to this URL.

4. If you want to change your user name or password, enter the new information.

5. If you want to look at or update another preference, select the appropriate page.
If you want to apply your changes to the URL without closing the dialog, click on Apply.
If you are finished updating preferences, select OK. 



Select all URLs
Use this function to select all the URLs on your WebWhacker list. If you want to select most but not all of the URLs, use this 
function to select all URLs, then deselect the ones you don't want.

TIP:    When to use Select All

Select All works only in List View. 

Once you have selected a set of URLs, you can whack them, renew them, or clear them from the list. 

Selecting all URLs

1. Display the WebWhacker window.

2. Select the List View page on your display.

3. From the Edit menu, select Select All. WebWhacker highlights all the URLs.

Modifying the selection

If you hold down CTRL, you can use the mouse to select (or deselect) several URLs. 

If you hold down SHIFT, you can use the mouse to select (or deselect) all URLs between two 
selections.



Select the desired site:
adding and grabbing
Once you have made sure all your settings are correct for whacking, you can select the desired URL site by adding or grabbing it. 

If you know the full URL of the desired site, or if you are not connected to the Web and can look up the URL, you can add the URL 
directly by typing it into the URL Subscription Wizard. If your Web browser is running and you are connected to the Web, you can 
grab the URL site from the browser window. If you are not connected to the Web, you can only add the URL directly by typing it into 
the URL Subscription Wizard.

Adding a new URL

1. From the URL menu, select Add. WebWhacker displays the first page of the URL Subscription Wizard. 

2. WebWhacker already displays the text HTTP:// in the URL to Add text box for you. Press END to move the cursor to the end 
of the text, then type the complete URL for the site you want to add.

3. In the tree window labeled Select the Category for this URL, double-click on the name of the category you where you to 
assign this site. If the category you want does not appear in the window you can display your subcategories by clicking the plus 
sign next to the All.    Click Next.

4. Select the number of levels of this site you want to whack. 
If you only want the current page, use 1. 
If you want all the links from the current page, select All.

5. If you don't want WebWhacker to whack pages from other sites linked to the subscribed URL site, select Remain on Site. If 
you choose to whack All levels, Remain on Site will be selected automatically and the option will be grayed out.

6. If the URL you selected requires a user name and password, type your user name and the password. Click Next.

7. Select the renewal frequency you want for this URL 

If you only want to whack it one time and never renew it, select Just this Once.

If you want to update every day (or once every week, or once every month), choose Daily (or Weekly 
or Monthly).
If you select a daily, weekly or monthly update cycle WebWhacker automatically update the links according to the schedule you 
established in your Preferences.      Click Finish.

Grabbing URLs

1. Using your Web browser, display the page you want to grab.

2. Select Grab from the App Bar 
OR
Switch to WebWhacker. Then select Grab from the Toolbar or go to the URL menu and select Grab.

WebWhacker displays the first page of the URL Subscription Wizard with the URL for the page you grabbed in the URL to Add 
text box.

3. Follow steps 3 through 7 in Adding a new URL (above).

Next step

                  Perform the whack  





Preferences
The WebWhacker Preference functions allow you to set various system-wide preferences.

Setting your preferences

1. From the Tools menu, select Preferences. 

2. Select the page for the preference you want to change.

From the Preferences dialog, you can specify:

                  General Preferences   Lets you choose whether to download in-line graphics on whacked pages.

                  Browser/Mail Preferences  .      Identifies your Web browser and specifies your e-mail account.

                  Network Preferences.   Sets up network management options.

                  Proxy Server Preferences  .   Sets up WebWhacker as a proxy server for your Web browser. Also lets 
you set up preferences if your site has a firewall.



                  Scheduling Preferences  . Sets the schedule for site updates. This schedule is in connection with the 
URL update frequency property .

                  Phone Preferences  .    Sets up phone numbers, user names, and passwords for use with the   
automatic scheduling options..



URL properties
Every URL has a series of properties associated with it. You can update some of these properties; others are only displayed for your 
information.

Looking at and changing URL properties

1. Select the URL whose properties you want to change.

2. Click on the Props button
OR
Go to the URL menu and select Properties. 

3. Select the page for the properties you want to view or change.

In the Properties window, you can look at a URL's:

                  Attributes.   The basic information about the site, including its name, URL address and current status. 
Since WebWhacker loads all of this information for you, you can not change it.

                  Security  . Security settings include any user name and password associated with the site. (The 
password is not displayed.) You can update both the user name and password.

                  Update Frequency.   Determines how often this URL is scheduled for update. This property works in 
conjunction with your scheduling preference.



                  Errors  . List showing any errors encountered in whacking or renewing the URL.

                  Whack Levels.   Allows you to change the number of levels of links that you want to download from 
the particular URL.



Set up for whacking
Before you can begin to whack URLs you must have both WebWhacker and your Web browser set up correctly. You browser must 
recognize WebWhacker as a proxy server, and WebWhacker must be set up to passthru requests for pages not available on its 
database to the browser. When these setting are correct, the only time your browser needs to access the Web is when a page is not 
available in WebWhacker's data base. This makes it possible for you to review pages without actually being connected to the Web.

Setting up for whacking

1. In your Web browser, make sure you have configured your network preferences to use WebWhacker as a proxy. For details, 
see:

                  Using   WebWhacker   with Internet Explorer™  

                  Using   WebWhacker   with Netscape Navigator™  

2. In the WebWhacker window, make sure you have set your proxy server to allow passthru. 

On the Tools menu, choose Preferences, and then Proxy Server. 

Make sure there is a check in the text box labeled Allow passthru on cache misses in the Local 
Proxy Cache section.

When your connection settings are correct, you can mark the site for whacking, enable the whack, and perform the whack.

Next step

                  Select and mark the URL for whacking  



Site title
(in WebManager)

When you add a new URL through WebManager using the grab function, the site title is added to both the WebWhacker and 
WebManager lists. However, if you add a URL manually using either WebWhacker or the WebManager's add function, the title is 
not displayed. Although you cannot change the title displayed in WebWhacker, you can assign a different title to the site in the 
WebManager list. 

Assigning a site title

1. Click once on the name of the URL you want to title. This brings the URL site into focus. 

2. Click on the Edit menu and select Properties
OR
Right-click on the URL's icon and select Properties from the shortcut menu.

3. In the URL Properties text box, type the name you want to assign to this URL site. Most of the time, you want this name to be 
the one that appears in the title bar of the URL site, but you can assign any name that is meaningful to you.

4. Click OK to close the dialog box. The site now has a title in WebManager. 

                  Related Topics  



Sort the URL list view
You can sort the list of whacked URLs by either URL or page title. The URLs and titles are sorted in ascending order:    numbers 
followed by uppercase letters, then lowercase letters.

Sorting the URL list

1. Display the WebWhacker window.

2. Select the List view page.

3. To look at the headlines in URL order, click on URL in the title bar
OR
Go to the View menu and select Sort By, then URL.

4. To look at the headlines in title order, click on Title in the title bar
OR
Go to the View menu and select Sort By, then Title. 



Status bar
The Status Bar is located at the bottom of the program window. It displays basic information and messages.    It differs from the 
Whack Status Bar (also accessed through the View menu), which encompasses the a large portion of the middle of the screen, 
and which displays information regarding whacks and renewals in process.

 

TIP:    Viewing the status bar

To toggle the display of the status information on and off, go to the View menu and select or deselect Status Bar.



Subscribe to a URL
The process of selecting, customizing scheduling, and downloading a specific Web site is called Subscribing to a URL.    You can 
subscribe to a URL in two ways:

                  If you know the full URL name, you can   add the URL  .

                  If you are browsing the Web, you can   grab the URL  .  



System requirements
Required

486-SX or higher

Windows 95™ or Windows NT 4.0™ 
(Windows NT 3.5.1™ runs WebWhacker, but not the App Bar)

4 MB RAM. Additional memory makes WebWhacker run faster.

10 MB free hard drive space 
(2 MB for the program; 8 MB for whacked sites)

An active Internet connection with a Winsock-compliant network product
TCP/IP connection with SLIP, PPP, or direct connectivity

A correctly configured Windows 95 dial-up networking setup, if you wish to use scheduling to perform 
unattended downloading

A SpyGlass SDI standard-compliant Web browser; includes:
Internet Explorer™ version 2.0 or higher
Netscape Navigator™ version 1.1b3 or later
Enhanced Mosaic™ version 2.0 or later

TIP: A Web browser is required only for viewing whacked URLs. You may whack URLs from the Internet with any Web 
connection.

Recommended

486DX-33

8 MB RAM



Additional hard drive space



Tips & tricks

                  Accessing the   WebWhacker   database  

                  Backing up the   WebWhacker   database  

                  Checking errors quickly  

                  Connecting through Windows 95 dial-up networking  

                  Coordinating sites and categories  

                  Crossed browser preferences  

                  Identifying the App Bar's reserved area  

                  Keeping local sites current  

                  Managing categories  

                  Removing URLs everywhere  

                  Stopping a large whack  

                  Using multiple docking toolbars  



                  Viewing properties in   WebManager  

                  Viewing the   Whacker   status bar  

                  Whacking large sites  



Toolbar
The WebWhacker toolbar gives you quick access to the most commonly used program functions.

 

Click on any icon above for more information about its function.

You can use the toolbar to:

                  View headlines  .   When you select this option, WebWhacker creates a temporary Web page with 
links to all your whacked URLs.

                  Grab URLs  .   When you select this option, WebWhacker grabs the page currently displayed on your 
browser and adds it to your URL list. 

                  Switch to   WebManager.    When you select this option, WebWhacker switches you to the 
WebManager utility. You can use WebManager to categorize your URL sites.

                  Search   for a whacked page.   You can use this option to search for particular text in either the title or 
body of a whacked URL.

                  Start   whack  ing..   If you have URLs marked to whack, when you select this option, WebWhacker 
starts the whacking process.

                  Renew   (or update) previously whacked URLs.   When you select this option, WebWhacker uses the 
criteria you established in the URL properties and the preferences to update pages that have changed since the last update.

                  Set up your   schedule   preferences.   You can use this option to change your scheduling preferences. 
These preferences are used to determine which URLs are updated when you select Renew or during the scheduled update 
process.

                  Review and change URL   properties.   Use this option to review and change the properties of 
individual URLs.



                  Import   files.   This function imports WebWhacker 1.0    files into WebWhacker 2.0.

                  Export   file.   Use this function to export downloaded FTP files or Web pages.    FTP files export as 
local text files while Web pages export in raw HTML format, along with their associated images.



Tools menu
The Tools menu contains functions that apply to WebWhacker as a whole. 

Using this menu you can:

                  View     Error   List   

                  View Modified   sites  

                  Search   for a URL or title  

                  Set program   Preferences  



URL
A URL (or Uniform Resource Locator) is the standard address format used to identify and locate sites on the Internet.    World Wide 
Web site URLs begin with the prefix http:// (which stands for HyperText Transfer Protocol), generally followed by www (for World 
Wide Web).    After the standard prefixes, URLs use identifiers for different domains and subsections of domains, each separated by 
a period (.). The various levels of a site are separated by a forward slash (/); individual home pages are often preceeded by a tilde 
(~).



URL menu
The URL menu contains the functions needed to manipulate individual URLs. You can also access some of these functions by right-
clicking on a particular URL name. 

You can use this menu to:

                  Add   a URL to your list  

                  Grab   the URL currently displayed by your browser  

                  Browse   the Web (or local whacked sites) to view a particular URL in your Web browser  

                  Enable     whack  ing for a URL  

                  Disable     whack  ing for a URL  

                  Change the   whack levels   for a URL   

                  Look at or change the   properties   of a URL  



URL subscription
When you add or grab a URL, you create a subscription to that URL. It is called a subscription because, like a newspaper or 
magazine subscription, you can be scheduled to automatically receive a copy of the updated materials (in this case, the new Web 
page or pages). 



Uninstalling WebWhacker
In accordance with Windows 95™ standards, WebWhacker comes with an uninstall program. You can also use the Windows 
Add/Remove Programs utility.

To uninstall WebWhacker with the included program:

1. Click on the Windows Start button.

2. Select Programs/ WebWhacker/ Uninstall WebWhacker.

3. Answer Yes to the prompt:    Are you sure you want to completely remove the selected application and all its 
components?

To uninstall WebWhacker with the Add/Remove Programs utility:

1. Click on the Windows Start button.

2. Select Settings/Control Panel.

3. Double-click on the Add/Remove Programs icon.

4. Click on WebWhacker where it appears on the list in the bottom part of the window. 

5. Click on the Add/Remove command button.

6. Answer Yes to the prompt:    Are you sure you want to completely remove the selected application and all its 
components?

7. When the Uninstall Shield indicates that program removal is complete, click OK to close the dialog box.

Neither the included uninstall program nor the Windows Add/Remove Programs utility deletes your WebWhacker database. If you 
want to remove all whacked sites from your hard drive, you must delete the file manually.

To delete your WebWhacker database:

1. Open the Windows Explorer™ (On a standard Windows 95 installation, you can get to Explorer by clicking on the Windows 
Start button and choosing Programs/Windows Explorer.)

2. Navigate to your WebWhacker directory. (On a standard  installation, this is C:
\PROGRAM FILES\FOREFRONT\WEBWHACKER2\PROGRAM.)

3. Delete the files ending in .WWDB.
4. Close Explorer.



Update frequency property
Use the Update Frequency Property to establish how frequently a subscribed URL will be scheduled for update. This property 
works in conjunction with your scheduling preference.

Changing the update frequency

1. Select the URL whose properties you want to modify.

2. Click on the Props button
OR
Go to the URL menu and select Properties. 
WebWhacker displays the URL Properties window.

3. Select the Update Frequency page.

 WebWhacker displays the frequency you established for this site.

4. If you want to change how often the URL is updated, select the new frequency from the pull-down menu.

5. If you want to look at or modify another property, select the appropriate page.
If you want to apply your changes to the URL without closing the dialog, click Apply.
If you are finished modifying the URL's properties, select OK. 

-



Upgrade from WebWhacker 1.0
WebWhacker 2.0's Install Shield Wizard takes care of most of the work of upgrading from version 1.0 to version 2.0. 

DO NOT DELETE YOUR WEBWHACKER 1.0 DIRECTORY OR FILES if you want to retain your previously whacked webs.    To 
migrate earlier groups of subscribed URLs into the new product, you must also import the database group files and re-whack the 
sites.

Upgrading from WebWhacker 1.0

                  Install and configure     WebWhacker 2.0.  

                  Import   your earlier groups of subscribed URLs  .

                  Re-whack   the URLs you have just imported.  



Use FTP with WebWhacker
When you use WebWhacker to whack a site that includes ftp (File Transfer Protocol) pages, the ftp'd pages cannot be viewed using 
WebWhacker Web browser proxy.

If the downloaded pages are text files (usually ending in .txt; sometimes ending in .wri or .doc), you 
can view these pages if you    Export them and then view them with a text editor (such as the WordPad accessory that ships with 
Windows 95) or any word processor that can view text files. 

Other ftp'd files may be compressed files (usually ending in .zip).    These files must be uncompressed 
using a zip utility. If the uncompressed files are .txt, .doc, or .wri files, treat them as text files above.



Using WebManager
Use the WebManager to organize your URLs into categories and subcategories to make it easier to keep track of them. Although we 
deliver a set of categories, you can add your own categories and subcategories to make the WebManager work for you.

You might want the categories to be topics or areas of interest in a setup like the one that comes with the program. Or perhaps you 
want to categorize your URLs by business topics; for example, clients, vendors, and competitors. Or, if several people use a single 
machine, each person might want to set up their own set of subcategories.

For more information about using WebManager, see:

                  Adding new sites (URLs)  

                  Moving sites to new categories  

                  Selecting and browsing whacked URLs  



Using Internet Explorer™
with WebWhacker 
WebWhacker requires version 2.0 (or higher) of Microsoft Internet Explorer™. 

Configuring Internet Explorer for use with WebWhacker:

1. Open the Control Panel folder and double-click the Internet icon.

2. Select the Advanced page.

3. Check Use Proxy Server and enter 127.0.0.1:8080 in the Proxy Server text box. Click OK.

4. Restart Internet Explorer for the change to take effect.

If you want to browse remote URLs on the World Wide Web as well as local (downloaded) sites and , don't forget to set    
WebWhacker allow passthru on sites not in its database of cached sites.    You do this by selecting WebWhacker's Tools menu, 
the Preferences command, and then the Proxy Server page. In the Local Proxy Cache section, click in the Allow passthru on 
cache misses check box.

Switching back to normal network usage:

1. Open the Control Panel folder and double-click the Internet icon.

2. Select the Advanced page.

3. Uncheck Use Proxy Server.

4. Restart Internet Explorer for the change to take effect.



Using Netscape Navigator™
with WebWhacker 
WebWhacker requires version 1.1b (or higher) of Netscape Navigator™. 

Configuring Netscape Navigator for use with WebWhacker:

1. Go to Network Preference on the Options menu.

2. Choose the Proxies page.

3. Select the Manual Proxy Configuration radio button. Then select the View button.

4. Enter 127.0.0.1 into the HTTP Proxy edit box and 8080 into the Port: edit box. Click OK.

5. Click OK again. The change takes effect immediately.

If you want to browse remote URLs on the World Wide Web as well as local (downloaded) sites and , don't forget to set    
WebWhacker allow passthru on sites not in its database of cached sites.    You do this by selecting WebWhacker's Tools menu, 
the Preferences command, and then the Proxy Server page. In the Local Proxy Cache section, click in the Allow passthru on 
cache misses check box.

Switching back to your normal network usage:

1. Go to Network Preference on the Options menu.

2. Choose the Proxies page.

3. Select No Proxies.

4. Click OK. The change takes effect immediately.



View menu
The View menu contains functions that change the way WebWhacker displays in the window.

You can use this menu to:

                  Sort   the List View   by     URL   or   Title  

                  Toggle the   toolbar   display on and off  

                  Toggle the   Status Bar   display on and off  

                  Toggle the   Whack Status Bar   display on and off  



View modified
The View Modified tool displays a list of the URLs and Titles of all whacked URLs that have been modified recently. In this case, 
"modified" means that the site has been whacked, re-whacked, or renewed; that is, that it has been downloaded from the Web to 
your hard drive or local network. 

You can control how the program interprets "recently" by specifying a number of days previous to the current day.

Viewing modified sites

1. From the Tools menu, select View Modified. 

2. In the Modified in __ days text box, type the number of days (previous to today) during which the URLs may have been 
downloaded (whacked or renewed).

3. Click Query to begin the search of the whacked URLs.

4. WebWhacker will display a list of the URLs and Titles of all sites that have been modified within the specified number of days.

5. When you are finished examining the list, click Done to close the dialog box.



WebManager
WebManager is a utility applet shipped with WebWhacker which displays whacked Web sites according to categories such as Arts, 
Business, and Education, or any other categorizing system you want to use. Each category appears as a folder (or directory) 
containing the assigned sites and any subcategories you have created.

Use the WebManager to organize your URLs into categories and subcategories to make it easier for you to keep track of them. 
Although we deliver a set of categories, you can add your own categories and subcategories to make the WebManager work for 
you.

You might want the categories to be topics similar to those we've set up. Or perhaps you want to categorize your URLs by business 
topics; for example, clients, vendors, and competitors. Or, if several people use a single machine, each person might want to set up 
their own set of subcategories.

For more information about using WebManager, see:

                  WebManager   Window  

                  Add new URLs  

                  Assign titles to URLs in   WebManager  

                  Move subscribed URLs to new categories  

                  Select and browse subscribed URLs  



WebManager window
The WebManager window works just like the Windows Explorer.

Click once on any category folder in the pane on the left side of the window to display its contents in 
the right pane.

Click once on the plus sign (+) to display subcategories (subfolders) beneath the current category 
(folder).

Double-click on any category folder in the pane on the left side of the window to open the folder and 
display its contents in the right pane.

You can adjust the width of the two window panes or the columns in the right pane.

Drag the bar that separates the panes to change the size of the panes.

Drag the bar that separates the names of each column in the right pane to resize the columns. 
Double-click on the separator bar to automatically resize a column to the best fit for the items currently displayed.

The right-hand pane of the WebManager displays the three main properties of each subscribed URL:

Name:    the complete URL address of the site as it appears on the Internet

Title:    the name that appears in the title bar of the displayed Web site. Although this name is 
assigned to a page by its creator, you can change it in WebManager. However WebManager and WebWhacker are only lightly 
coupled and these changes are not reflected in WebWhacker or in your browser.

Date:    the date when the site was added to the WebWhacker database.

TIPS:    Viewing properties

If the properties of the URL you want to inspect do not appear in the right pane, be sure you have clicked on the appropriate 
category in the left pane.



If any of the properties are truncated, double-click on the column's separator bar (the bar between the names of each column, 
located at the top of the window pane.) 

                  Related Topics  



WebWhacker window
The WebWhacker window has three major parts:

The Menu bar and toolbar along the top of the window.

The list of all your subscribed URLs (whacked or unwhacked). You can display this list as a tree view 
or an alphabetical list view. 

The Whack Status bar showing the results as well as messages and other information about the 
latest whack.



Set whack levels properties
You can set the number of whack levels you want to download from a subscribed URL site. There are several different ways to do 
this. Normally whack levels are set when a site is grabbed or added. In addition, you can change the whack levels later using this 
procedure.

Changing whack levels

1. Select the URL whose whack levels you want to update.

2. Click on the Props button, 
OR
Go to the URL menu and select Properties
OR
Go to the File menu and select Whack Levels. 

3. If you are using the Properties function to change whack levels, WebWhacker displays the URL Properties window. Select the 
Whack Levels page. WebWhacker displays the levels assigned to this site.

Otherwise, WebWhacker displays the Whack Levels dialog.

4. Select the number of levels of this site you want to whack.

If you only want this page, use 1. 

If you want all the links from this page, select All Levels.

If you want some of the pages linked from this page, enter the number of levels down the links you 
want. You can enter up to 100 levels.



5. If you don't want WebWhacker to whack pages from other sites linked to this site, select Remain on Site. If you chose to 
whack All levels in the previous step, Remain on Site is automatically selected and the option is grayed out, making it 
unavailable.

6. If you are using the Properties and want to look at or update another preference, select the appropriate page.

If you are using the properties and want to apply your changes to the URL without closing the dialog, click Apply.

Otherwise, select OK.



Whack status bar
The middle portion of the WebWhacker window contains information about the status of a whack.    You can turn the display of the 
whack status bar on and off so there is more room at the top of the displays for your list of subscribed URLs.

 

TIP:    Undocking the Whack status bar

Dragging the status bar out of its docked position in the WebWhacker window tends to de-stabilize the product, leading to 
unexpected crashes.    Feel free to re-size the relative space of the panes within the WebWhacker window, but avoid 
undocking the Whack status bar altogether.

TIP:    Viewing the Whack status bar

To toggle display of the status information on and off, go to the View menu and select Whack Status Bar.



What can I do to minimize the space used by the App Bar?
Like most docking toolbars,      the App Bar has an AutoHide feature. When activated, AutoHide causes the App Bar to "disappear" 
until your cursor moves over the space occupied by the bar.

Using AutoHide on the App Bar:

1. Right-click on any blank gray area of the App Bar.

2. Select AutoHide from the shortcut menu which appears.



What is WebWhacker?
WebWhacker 2.0 enables you to save your favorite Web sites, organize them into categories, and use your favorite web browser to 
surf the Net offline—with faster loading and no additional online charges. Developed by the ForeFront Group, Inc., WebWhacker 
2.0 downloads entire Web pages or sites—including text (HTML), images, and other objects—and stores them on your local desktop 
machine or your company's server. By reducing your dependency on an Internet connection, WebWhacker 2.0 saves you time and 
money. 

For each of your favorite Web sites, you will subscribe to its URL, assigning it to a category and specifying how often your 
subscription will be renewed.    A renewed subscription is much like a magazine or newspaper subscription:    you receive a new copy 
whenever the text and graphics of the original page changes.    The "whacked" sites provide a locally stored mirror image of the 
original Web site which can be viewed and navigated locally with any Web browser. Besides being economical, this approach gives 
you more control.

                  Who can use   WebWhacker  ?  



What's new in 2.0?

WebWhacker 2.0 works as a proxy server for your Web browser. Once you have it set up, 
WebWhacker makes viewing local and online web pages transparent. Since WebWhacker keeps a database of all your whacked 
pages, it handles the loading of Web pages, automatically choosing whether the page comes from your local database of whacked 
sites or is retrieved from the Internet. You can even export the HTML and related files for a specified site.

WebWhacker 2.0 lets you view whacked Web pages in two different views. Tree View displays a 
hierarchical structure sorted by the interrelationships of the pages. List View can display whacked sites sorted either by location 
(URL) or page title. 

WebWhacker 2.0's new interactive interface incorporates Wizards for your most common tasks and 
allows you to schedule your whacks and updates. 

WebWhacker 2.0 lets you schedule updates to whacked pages. You can renew existing pages or 
whack new pages or both. You can schedule updates for individual pages on a daily, weekly or monthly basis. WebWhacker only 
downloads changed pages, saving you time and money.

WebWhacker 2.0 lets.you search the titles and text of your whacked pages for specific text.    You 
can even conduct complex Boolean searches.

A new WebManager utility applet lets you sort your whacked sites according to general categories 
(such as Business, Finance, Education) or by specific subdivisions (such as clients or projects) that you set up. This new 
management tool's use of categories makes it easier to manage large numbers of whacked sites.



What's the difference between whack and renew?
The simple answer is....

Whacking is performed on enabled URLs based on your specific request for a whack or according to the Scheduling 
preferences set in the Tools/Scheduling dialog. In the case of rewhacking a previously whacked URL, pages will be 
downloaded only if they have changed on their home server since the last time you downloaded them.

Renewing is performed under all the previous conditions (except that they do not need to be enabled), but also considers the 
individual URL's update frequency property set in the URL/Properties/Update frequency dialog. Before performing a renewal, 
WebWhacker looks at every URL in its database, checks its Update frequency property, and then, if the URL is eligible for 
update, compares its modified date to the current date.    The program then renews only those which are both scheduled for 
renewal and have changed since the last download.

The more technical answer is.... 

When you request a whack or re-whack, WebWhacker looks at every URL that you have enabled for whack and queries their 
servers to determine whether the pages have changed. If a server indicates that a page has been changed, WebWhacker 
downloads the changed page (that is, rewhacks or updates the page).    If a particular page has never been whacked before, it 
will, of course, be downloaded (whacked).

On the other hand, when you request a renewal, WebWhacker looks at every URL in its database and compares its modified 
date to the current date. If, based on its update frequency property setting, the site is scheduled for a renewal, WebWhacker 
queries the site server to determine whether the page has changed. If the server indicates that the page has been changed, 
WebWhacker downloads the changed page.



Who can use WebWhacker?
Corporations can use WebWhacker to: 

Create firewalls, helping to insulate the company server from illegal outside access.

Train employees in Web techniques without online access. 

Lower online costs by storing frequently accessed Web sites locally.

Limit recreational surfing by employees.

Keep information up-to-date by setting automatic renewals.

Schools can use WebWhacker to: 

Create focus sites on topics relevant to current curriculum.

Save teacher time by eliminating the need to monitor student choices.

Reduce connect charges by directing and speeding up searches to desired topics.

Limit liability by pre-censoring the available sites.

Individuals can use WebWhacker to: 

Create offline presentations to demonstrate products or sites without Web access

Store favorite sites to create a "super bookmark" file with free access!



Set automatic updates to ensure access to the latest version of Web sites.



Why can't I load my Headlines page?
Your headlines page reflects the list of URLs you have whacked to your hard drive or local network server. If you cannot load it from 
your Web browser, there are several possible causes:

Ca
use
:

WebWhacker is not running.

Sol
uti
on:

Double-click on your desktop 
WebWhacker icon. 
OR
Click on the Start button and 
choose 
Programs/WebWhacker/Web
Whacker 2.0.

Ca
use
:

Your Web browser is not 
running.

Sol
uti
on:

Turn on your browser.

Ca
use
:

Your Internet connection is 
faulty.

Sol
uti
on:

Contact your network 
administrator or Internet service 
provider.

Ca
use
:

Your browser may not be set to 
use WebWhacker as a proxy if 
you receive an error message 
that says:    "Netscape is unable 
to locate the server:    The 
server does not have a DNS 
entry. Check the server name in 
the Location (URL) and try 
again." 

Sol
uti
on:

Configure your browser to use a 
proxy. 
For details,see Using 
WebWhacker with Internet 
Explorer or
Using WebWhacker with 
Netscape Navigator.





Why didn't my renewal follow my whack?
If you set your scheduled whacks and renewals to occur during the middle of the night, be sure you do not also leave your machine 
running on a large whack. Ongoing whacks take precedence over scheduled whacks and renewals.    The scheduled whacks and 
renewals are not reset; the scheduling cycle is simply skipped for that time.



Why do I get the message "URL not found"?

Many different error conditions can result in this message, but the most common ones all have to do with user error—in this case, 
the user being the author or webmaster of the original page. Almost anyone can publish a home page on the World Wide Web, and 
there are no error-checking requirements. Therefore, most of the time this message refers to an error in the underlying HTML of the 
whacked page.    Contact the page author or webmaster if you need help tracking down lost URLs.



Why do remote Web pages seem to load slowly?
The simple answer is....

Your Web pages only appear to load more slowly. Because of the slightly different way Web browsers and WebWhacker 
handle page loading, you may notice a slight delay before your page begins loading. However, the total loading time does not 
change significantly.

The technical answer is....

Most Web browsers handle multiple information requests at once and begin processing the information as soon as they receive 
it. This leads to interlaced GIFs and partial screen drawing, so that a page draws incrementally. WebWhacker handles one 
request at a time and acquires all the page information before passing it on to your browser. This leads to a single, quicker 
screen draw although you may experience a slight delay before the page begins to draw.

Note that all fo this applies only when your browser is set to use WebWhacker as a manual proxy. If you set your browser to use no 
proxies, the problem will not apply.



Why doesn't my database get smaller when I delete sites?
WebWhacker's delete functions work much like the delete functions in DOS and Windows 95.    When you delete a site from 
WebWhacker, the site and its associated pages are marked for deletion but are not actually erased and the database is not 
compressed. However, as you add new sites, those sites are allowed to use the space marked for deletion and can overwrite the old 
information. (Similarly, PCs mark files for deletion in their File Allocation Table or FAT, but don't actually erase the old information 
until they need the space and new files overwrite the old ones.)    Future releases of will WebWhacker implement database 
compression.



Why don't my whacked pages change?

Why a page may not be updated:

It hasn't changed since the last time it was downloaded by WebWhacker.

The program preferences weren't set to include whacks.

The URL wasn't marked to whack. Use the procedure Enable Whacking to mark the page for 
whacking.

The subscribed URL had already been updated within its frequency period. For example, the URL is 
set to renew weekly and it was renewed sometime in the past week.

The Renewal option in program preferences is unchecked. This prevents any URLs from being 
automatically updated using the Renewal function.



Why is my Web browser unable to load new Web pages?
If your Web browser seems suddenly unable to access its network connection, you may have your proxy configuration set 
incorrectly:

When you have configured your browser to use WebWhacker as a proxy, you must load 
WebWhacker before your browser can access URLs on the Internet or stored in your WebWhacker database. You must also have 
set WebWhacker to allow passthru on cache misses or you will not be able to view Web pages that you have not downloaded into 
your WebWhacker database.

When you are not running WebWhacker, you must have configured your Web browser for no proxies
.

For details on configuring your web browser to use WebWhacker as a proxy, see:

                  Using WebWhacker with Internet Explorer™  

                  Using WebWhacker with Netscape Navigator™  



add (a URL)
To add a URL is to mark it for whacking by typing in its full Internet address. When you add    a URL (as opposed to grabbing it), you 
must manually enter the full URL address into the URL Subscription Wizard's URL to Add edit box.



category
WebWhacker lets you gather groups of URLs into sets or categories. Using the WebManager applet, you can organize the 
categories into groups that meet your needs. 

For example,

You can organize the URLs by topic: business, education, etc.

You can organize them according to your business needs: clients, prospects, vendors, etc. 

If several people use the same computer, you can organize sites by individual user names:    Mary, 
Steve, Jim. 



database
WebWhacker stores all of its information about the sites you have saved—including their URLs, Titles, scheduling and level 
preferences, and, if they have been whacked, the HTML pages and associated images—in a database. This database is presented 
in the WebWhacker tree and list views in an easy-to-use graphical format.

TIP:    Accessing the database.

You cannot access or manipulate this database with any other database management system; it is in a format that only 
WebWhacker can interpret.    However, you can export the information in raw HTML format. 

TIP:    Backing up the database.

All databases rely on intricate linkages among the various pieces of information.    For this reason, database are, by their very 
nature, more subject to corruption problems than are other file types.    Be sure to include the WebWhacker database in your 
daily backup schedule. 



grab
To grab a URL is to mark it for whacking while browsing the site. When you grab a URL (as opposed to adding it), the program picks 
up the URL for you and automatically enters it into the URL to Add text box.



headline
Within the context of WebWhacker, a headline is the title of a whacked URL displayed on a list in a special localized Web page. You 
can click on any of the headlines to load that whacked URL into your browser. 

Headlines generally reflect the title assigned to the page by its creator.



knife icons

One knife (  or 

) indicates that you only want to whack one level of the subscribed URL. 

Two knives (  or 

) indicate that you want to whack multiple levels of the subscribed URL.
The addition of red coloring to any icon adds the meaning that an error occurred when that URL was whacked.



passthru
The cache passthru function is used by WebWhacker to allow your browser to acquire pages from the Web that are not included in 
its database. 

If you want to "surf" the Web off-line using only the pages you have whacked, deselect the passthru option. Then, whenever you 
select a URL or link that is not in the WebWhacker database, it gives you a message indicating that it does not have access to that 
page.



properties
Properties are information about any subscribed URL, whether or not it has been whacked yet.    The URL Properties sheets will give 
you a URL's Atributes (Title, URL, Status, Creation Time, and Modified Time), Security.issues (username and password), Update 
Frequency, any Errors, and Whack Levels with remain on site setting.    For more information about specific properties, see the 
appropriate section of this Help file. 



proxy
For a Web browser, a proxy is a special kind of application which serves as an interface between the Web browser and the actual 
connection to the Internet.    WebWhacker is a proxy (or proxy server) which serves up information from Web sites to your Web 
browser.



red icons

A red icon (such as  or 

) next to a URL indicates an error occurred while whacking that URL. The problem could be as simple as the 
user cancelling a whack, or it may indicate that a URL or subordinate file could not be found.    In general, if the red image is a globe, 
that indicates a problem with downloading the URL; if the red image is a smaller globe on a piece of paper, that indicates a problem 
with one of the subordinate files (usually an image that could not be found).

To get more information about the error, right-click on the site and select View Errors. You can also display the errors associated 
with a particular URL by using the URL properties function.



whack
To whack a site is to download it from its location on the World Wide Web and copy it to your hard drive or local network.    
Depending upon how you have set up the whack (in the URL Subscription Wizard), your local copy can include all graphics, audio 
and video clips, Java™ applets, and links to other pages and/or sites. 



whack levels
The whack levels you specify in the URL properties determines the number of pages WebWhacker acquires when it whacks the 
site.

If you only want to whack the page, set the whack level to 1.

If you want the page and all the links from that page, but no additional links, set the whack level to 2. 
You can use the spin box controls to select up to 100 levels to whack; you can type in the edit box to select up to 999 levels, but we 
do not suggest whacking this many levels at once.

If you want the page and all the links from all the pages linked to that page, select All Levels. We do 
not recommend choosing All on large sites (or most commercial sites). If you want the current page to maintain some links but need 
to limit the size of the whack choose 1 or 2 levels.

If you don't want to whack pages that are on a site different from the original site, select Remain on 
site. If you choose to whack All levels, Remain on Site is selected automatically and the option is grayed out, making it unavailable.




