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1 Welcome 

1.1 Introducing ActiveSky Media Player for Pocket PC 

ActiveSky Media Player for Pocket PC plays the proprietary video format (.sky) developed by 
ActiveSky.  ActiveSky Media Player allows you to open, play, pause, and stop SKY files. 

This document explains how to download a copy of ActiveSky Media Player from the ActiveSky 
website.  It also explains how to obtain, install and play great video content on the ActiveSky 
Media Player. 

1.2 Features 

ActiveSky Media Player can: 

• Play, Pause/Next Frame, Stop, Zoom during playback mode. 

• Display elapsed time, total time, progress bar and audio state during playback mode. 

• Customize player options to set the Playback speed, Autoplay, Continuous play, Audio 
Mute, 2x Zoom and Show status bar. 

• Display File Properties about the open SKY file. 

1.3 ActiveSky Media Player Device Requirements 

The device requirements to run ActiveSky Media Player are: 

• Requires Windows Powered Pocket PC running Windows CE 3.0.  Compatible with MIPS, 
SH3 and StrongARM processors. 

• At least 1MB of available memory for the program plus additional memory for SKY files 
on the device or Storage Card. 

• Recommended 4096 color display or better. 

Check our web site at www.activesky.com for a complete list of specific supported Pocket PCs. 

2 Getting Started 

2.1 Downloading ActiveSky Media Player 

To download ActiveSky Media Player from our web site, go to the Pocket PC Download area at 
www.activesky.com and follow the instructions displayed. 
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2.2 Installing ActiveSky Media Player 

Once ActiveSky Media Player is downloaded onto the desktop PC it needs to be installed onto 
the Pocket PC, to do this: 

1. Ensure that the Pocket PC is connected to and communicating with the desktop PC via 
ActiveSync. 

NOTE: Microsoft ActiveSync is supplied with your Pocket PC, for instructions on how to 
connect the Pocket PC to the desktop PC and use ActiveSync, please refer to the User 
Guide supplied with the Pocket PC. 

Once the connection has been made, the Pocket PC is ready to install ActiveSky Media 
Player. 

2. Run the ActiveSky installation program that was downloaded onto the desktop PC. 

3. Follow the instructions displayed to install ActiveSky Media Player onto the Pocket PC. 

2.3 ActiveSky Media Player Registration 

ActiveSky Media Player for Pocket PC is limited 
to a 30-day trial period, after which you must 
register the program.  When the ActiveSky 
Media Player is first run you will be prompted to 
enter a Registration Code. 

Please note the DeviceID displayed on the 
Registration screen and visit our web site at 
www.activesky.com to obtain a Registration 
Code. 

NOTE: Ensure that the numerical zeros in the 
Registration Code are not misinterpreted as the 
alphabetical letter �O�.  Registration Codes do 
not contain the alphabetical letter �O�. 

Tapping File->Register� can also access the 
Registration screen on your Pocket PC. 
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2.4 Transferring SKY files to the Pocket PC 

SKY files can be found at www.activesky.com or at one of many content provider web sites.  
Visit www.activesky.com for a list of these sites. 

To transfer SKY files from the desktop PC to the Pocket PC: 

1. Download the SKY file to the desktop PC. 

2. Ensure that the Pocket PC is connected to and communicating with the desktop PC via 
ActiveSync. 

3. In ActiveSync, click the Explore button on the Toolbar.  The Mobile Device window 
will open. 

4. Using Windows Explorer on the desktop PC, select the SKY file(s) that were 
downloaded in Step 1, and copy them to the �My Documents� folder in the Mobile 
Device window. 

NOTE: SKY files MUST be stored in the �My Document� folder or an immediate sub-folder under 
the �My Documents� folder on the Pocket PC or Storage Card; otherwise the SKY files cannot be 
opened from within ActiveSky Media Player. 

3 Using ActiveSky Media Player 
Before getting started it is a good idea to be familiar with the functions of ActiveSky Media 
Player. 

3.1 Starting ActiveSky Media Player 

To start ActiveSky Media Player: 

1. Switch on the Pocket PC. 

2. Tap Start->Programs. 

3. Tap the ActiveSky icon. 

The Pocket PC is now ready to start playing SKY files. 
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3.2 Getting Familiar 

The application consists of a Title 
Bar, Main Window where the SKY 
videos are displayed, Status Bar 
and a combined Menu and Toolbar. 

 

3.2.1 Accessing the Menu 

Tapping File activates the File menu. 

 

The File menu contains the following options: 

Open� Opens a SKY file. 

Properties� Displays a list of properties about an open SKY file. 

Options� Displays a list of options that allow ActiveSky Media Player to be 
customized. 

About� Displays information about ActiveSky Media Player and ActiveSky. 

Register� Displays the Device ID to register ActiveSky Media Player. 

Exit� Closes and exits ActiveSky Media Player. 

3.2.2 Toolbar 

The functions of the Toolbar are: 

 Open 
Tap this button to browse for and open a SKY file. 

 Play 
Tap this button to Play the open SKY file. 
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 Pause 

 Next Frame 
Tapping the Pause button when the SKY file is in playback pauses at current position.  Once the 
SKY file is paused, this button changes to the Next Frame button.  Tap this button again to 
advance frame by frame.  This feature is useful for slide shows or viewing comic strips.  
Playback can be resumed at any time by tapping the Play button or stopped by tapping the 
Stop button. 

 Stop 
Tapping this button stops playback of the open SKY file and rewinds the file back to the 
beginning. 

 Options 
Tap this button to access the Options menu and customize ActiveSky Media Player. 

 Zoom 
Tapping this button doubles the display size of the SKY file.  If the SKY file is larger than the 
device display, then the SKY file will be centered and clipped or trimmed to size.  If the display 
size is already doubled and the zoom button is tapped, the display size will be reset to normal. 

3.2.3 Status Bar 

The status bar at the bottom of the screen shows: length of current playback time in seconds, 
length of total playback time in seconds, a progress bar and a speaker icon if the SKY file 
contains an audio stream. 

 

3.2.4 Playing SKY Files 

To play a SKY file: 

1. Tap File->Open�, or tap the Open button on the toolbar. 

2. Select the SKY file to be played. 

3. If Autoplay is enabled in the Options menu, the SKY file will begin to play 
automatically; otherwise, tap the Play button. 
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3.3 File Properties 

To view the file properties of the open SKY file: 

1. Tap File->Properties�. 

The Properties are divided into 3 sections: General, Details and Statistics. 

The General tab contains File name, Title, Author, Date Created and Copyright 
information. 

NOTE: Information will only be displayed if available. 

The Details tab contains File name, File type, File size (in kBytes), Media length 
(in mm:ss), Picture size (Width x Height in pixels), Total frames, Frame rate (per 
second) and the Audio format. 

The Statistics tab contains File name, Total time (milliseconds) and Average 
frame rate (frames per second). 

2. To exit the file properties, tap the OK button in the top right corner of the screen. 

3.4 Customizing ActiveSky Media Player (Options) 

To customize ActiveSky Media Player: 

1. Tap File->Options�, or tap the Options button. 

The following options can be modified: 

Playback speed: x0.5, x1, x2, Max (Default: x1). 

Sets the speed of the SKY file in playback.  Audio is only played during normal 
(x1) playback speed. 

Autoplay on open: On/Off (Default: On). 

Starts playing the SKY file as soon as it is opened. 

Continuous play: On/Off (Default: Off). 

Replays the SKY file in a continuous loop, until the Stop button is tapped. 

Audio mute: On/Off (Default: Off). 

Silences the audio stream, if one exists, of the SKY file. 

2x Zoom: On/Off (Default: Off). 

Doubles the display size of the SKY file. 

Direct screen access: On/Off (Default: On) 

Enables direct screen access for faster screen drawing. 

Show status bar: On/Off (Default: Off). 

Show or Hide the status bar. 

2. To exit the Options screen, tap OK in the top right corner of the screen. 
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3.5 About ActiveSky Media Player 

To view details about ActiveSky Media Player: 

1. Tap File->About�. 

This displays the ActiveSky Media Player version, copyright information and the 
ActiveSky web site address. 

2. To exit the About screen, tap OK in the top right corner of the screen. 

3.6 Register ActiveSky 

This option will only be displayed on the File menu if ActiveSky Media Player for Pocket PC has 
not been registered.  The Register ActiveSky screen contains the Device ID and a space to enter 
the Registration Code.  Please note the DeviceID displayed on the Registration screen and visit 
our web site at www.activesky.com to obtain a Registration Code. 

NOTE: Ensure that the numerical zeros in the Registration Code are not misinterpreted as the 
alphabetical letter �O�.  Registration Codes do not contain the alphabetical letter �O�. 

3.7 Help 

To access the help file: 

1. Ensure that ActiveSky Media Player is running. 

2. Tap on ActiveSky in the Title Bar. 

3. Select Help. 

4. To exit help, tap OK in the top right corner of the screen. 

3.8 To Exit ActiveSky Media Player 

To Exit ActiveSky Media Player: 

1. Tap File->Exit�. 

3.9 Deleting a SKY file 

Use File Explorer on the Pocket PC to locate and delete SKY files. 

3.10 Uninstalling ActiveSky Media Player 

To uninstall ActiveSky Media Player from the Pocket PC: 

1. Tap Start->Settings. 

2. Select the System tab. 

3. Tap the Remove Programs icon. 

4. Select ActiveSky Media Player, and then tap the Remove button. 
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FAQs 
Q: Where do I get files to play? 

A: SKY files can be found at www.activesky.com or at one of many content provider web sites.  
Visit www.activesky.com for a list of these sites. 

Q: Can I view SKY files on my desktop PC? 

A: Some of the content providers have content samples that can be viewed by standard desktop 
media players.  ActiveSky has not released a player for the desktop PC. 

Q: How do I transfer SKY files to my mobile device? 

A: Connect your mobile device to your desktop PC.  Copy the files from your desktop PC and 
paste them into the �My Documents� directory on your mobile device.  (Refer to Section 2.4 for 
more information.) 

Q: Where do I put my SKY video files? 

A: SKY files MUST be stored in the �My Document� folder or an immediate sub-folder under the 
�My Documents� folder on the Pocket PC or Storage Card; otherwise the SKY files cannot be 
opened from within ActiveSky Media Player. 

Q: I have transferred the SKY file(s) to my mobile device but there are no SKY files listed in the 
File->Open window, how do I locate the SKY file(s)? 

A: SKY files MUST be stored in the �My Document� folder or an immediate sub-folder under the 
�My Documents� folder on the Pocket PC or Storage Card; otherwise the SKY files cannot be 
opened from within ActiveSky Media Player. 

Q: I have selected a SKY file but it will not play, how do I play this file? 

A: The problem could be one or more of the following reasons: 

• The file you have selected may not be a �.sky� file.  ActiveSky Media Player only plays 
files with the �.sky� file extension. 

• The SKY file you downloaded may be corrupt.  Try downloading and transferring the 
SKY file again.  If it does not work again contact the content provider. 

Q: What is the largest file size I can play on my device? 

A: The largest file size you can use will depend on how much memory is available on the mobile 
device.  (Refer to the mobile device User Guide for information about memory size.) 

Q: Do I have to use ActiveSky proprietary video format (.sky) files? 

A: Yes.  At the moment you have to use ActiveSky files (which are identified with a �.sky� file 
extension).  In the future other file formats may be available. 

Q: How do I create my own SKY files? 

A: If you want to develop your own content, visit our Encoding Services page on our web site.  
There you will find creative media houses that fit your content format needs. 
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Q: I have downloaded ActiveSky Media Player but when I try to install the program it is corrupt, 
what do I do? 

A: The file may be corrupt because the download was not successful even though no error 
messages were displayed while downloading.  Try downloading the program again, if it is still 
corrupt contact Technical Support below to send the program to you via e-mail. 

Q: Can I use other Windows CE devices? 

A: This version of ActiveSky Media Player requires Windows Powered Pocket PC running 
Windows CE 3.0.  Compatible with MIPS, SH3 and StrongARM processors. 

Supported Devices include: 

• Casio E-115, E-125 & EM-500 

• HP Jornada 540 series 

• Compaq iPAQ H3630 

You are welcome to try to run the player on other devices.  You can let us know the results by 
sending an e-mail to Technical Support. 

Q: The video is running too slowly, how do I speed it up? 

A: You may have the Playback speed set to x0.5.  Tap File->Options and set the Playback 
speed to x1. 

Q: The video is running too fast, how do I slow it down? 

A: You may have the Playback speed set to x2 or max.  Tap File->Options and set the Playback 
speed to x1. 

Q: Only half the picture fits on the screen, how do I view the whole picture? 

A: You may have 2x zoom selected.  Tap File->Options and de-select 2x zoom, or tap the 
Zoom icon in the toolbar at the bottom of screen. 

Q: I do not hear any audio, how do I fix this? 

A: The problem could be one or more of the following reasons: 

• Ensure Audio mute is not selected in the Options menu. 

• Check that the Playback speed is set to x1 in the Options menu (audio is only available 
at this speed). 

• Check that the mobile device�s sound is not turned down (refer to your mobile device 
User Guide on how to adjust the audio volume). 

• Check that the SKY file contains audio (a speaker icon will be displayed in the Status 
Bar; refer to section 3.2.3). 

Q: My file keeps on playing, how do I stop it from repeating? 

A: De-select Continuous play from the Options menu. 
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Q: How do I get optimum performance playing my files? 

A: Tap File->Options and ensure you have Direct screen access selected.  Deselect all other 
options.  Your files will usually play better if they are played from the mobile device�s memory 
rather than from a Storage Card. 

Q: The video and/or audio is breaking up, how do I fix this? 

A: The problem could be one or more of the following reasons: 

• The most likely reason for the audio and/or video breaking up is that the device does 
not have a powerful enough processor.  It is also possible that the content may have 
been encoded at a frame rate and/or picture size that is not suitable for your device. 

• There is not enough memory to run the application properly. 

o Memory settings can be adjusted on the device (refer to the device user guide 
on how to adjust memory settings). 

o Files and/or programs can be deleted to free up more memory (refer to the 
device user guide on how to remove files and programs). 

o Other open applications running in the background can be closed to free up 
more memory (refer to the device user guide on how to close running 
applications). 

• The device may need to be reset (refer to the device user guide on how to reset your 
device). 

• The SKY file you downloaded may be corrupt.  Try downloading and transferring the 
SKY file again. 

Contact and Technical Support 
For ActiveSky technical support, please contact us by e-mail at 
pocketpc_support@activesky.com. 

ActiveSky support is limited to ActiveSky provided products only. 

For more information about ActiveSky, see our web site at www.activesky.com. 

Thank you for using ActiveSky technology! 

Copyright Notices 
Copyright ©2001 ActiveSky Inc. All Rights Reserved. 

Microsoft and Windows are registered trademarks of the Microsoft Corporation. 

All other products are trademarks of their respective owners. 

 


