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1 Welcome 

1.1 Introducing ActiveSky Media Player for Palm OS 

ActiveSky Media Player for Palm OS plays the proprietary video format (.sky.pdb) developed by 
ActiveSky.  ActiveSky Media Player allows you to open, play, pause, and stop SKY files.  
Included with some versions of the ActiveSky Media Player download (Windows) is ActiveSky 
Desktop Viewer.  ActiveSky Desktop Viewer is a Windows application that allows SKY files to be 
previewed before transferring them to the mobile device. 

This document explains how to download a copy of ActiveSky Media Player for Palm OS from 
our web site.  It also explains how to obtain, install and play great video content on ActiveSky 
Media Player. 

1.2 Features 

ActiveSky Media Player can: 

• View Previous SKY file, Stop, Play/Pause, Next frame, View Next SKY file during 
Playback mode. 

• Display File Information about the selected SKY file. 

• Customize player options to set the Screen Depth, Loop, Sound Effects, and Display 
Splash Screen. 

• Use built in Help file to explain the use of each screen. 

• Beam ActiveSky Media Player or SKY files to another Palm OS device. 

1.3 ActiveSky Media Player Mobile Device Requirements 

The requirements to run ActiveSky Media Player for Palm OS are: 

• Device running Palm OS Version 3.0 or higher. 

• At least 100kB of available memory for the program plus additional memory for SKY 
files. 

Minimum desktop PC requirements for ActiveSky Desktop Viewer: 

• Pentium PC with 32MB RAM running Windows 95, 98, NT 4.0 or 2000 (65536 color 
display or better). 
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2 Getting Started 

2.1 Downloading ActiveSky Media Player 

To download ActiveSky Media Player from our web site, go to the Palm OS Download area at 
www.activesky.com and follow the instructions displayed. 

2.2 Installing ActiveSky Media Player 

For PC users: 

Once ActiveSky Media Player is downloaded onto the desktop PC it needs to be installed on the 
mobile device. 

1. Connect the mobile device to the desktop PC. 

2. Run the ActiveSky installation program that was downloaded onto the desktop PC. 

3. Follow the instructions to install ActiveSky Media Player onto the mobile device. 

4. Tap the HotSync icon on the mobile device.  During HotSync, ActiveSky Media 
Player will be transferred from the desktop PC to the mobile device.  It will then 
be available on the mobile device from the Applications Launcher 

If there is a problem with the automatic installation then ActiveSky Media Player will need to 
be installed manually onto the mobile device.  To do this: 

1. Locate and start up the Install Tool program.  (Install Tool is provided with your 
Palm OS device.) 

2. Using the Install Tool program, locate and select the �.prc� file from the directory 
you specified during the installation process detailed above.  Ensure you have read 
the �license.txt� in this directory.  By installing ActiveSky Media Player on the 
mobile device you are agreeing to the terms and conditions outlined within this 
document. 

Optionally, the files named �APSplashVid.pdb� and �APAboutVid.pdb� can also be 
installed.  These are special splash screen videos that are used at different times 
in the interface.  If there is room on the mobile device for these videos, we 
recommend installing them. 

Click Done. 

3. Ensuring that the mobile device is connected to the desktop PC tap the HotSync 
icon on the mobile device.  During HotSync, ActiveSky Media Player will be 
transferred from the desktop PC to the mobile device.  It will then be available on 
the mobile device from the Applications Launcher. 
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For Mac users: 

Once ActiveSky Media Player is downloaded onto the Mac the downloaded �.sit� file needs to 
be extracted.  After extraction is complete, read the �license.txt� file.  By installing ActiveSky 
Media Player on the mobile device you are agreeing to the terms and conditions outlined within 
this document.  The �.prc� file then needs to be installed on the mobile device. 

1. Connect the mobile device to the Mac. 

2. Locate and start up the Install Tool program.  (Install Tool is provided with your 
Palm OS device.) 

3. Using the Install Tool program, locate and select the �.prc� file from the directory 
the downloaded �.sit� file was extracted to. 

Optionally, the files named �APSplashVid.pdb� and �APAboutVid.pdb� can also be 
installed.  These are special splash screen videos that are used at different times 
in the interface.  If there is room on the mobile device for these videos, we 
recommend installing them. 

Click Done. 

4. Tap the HotSync icon on the mobile device.  During HotSync, ActiveSky Media 
Player will be transferred from the Mac to the mobile device.  It will then be 
available on the mobile device from the Applications Launcher. 

2.3 ActiveSky Media Player Registration 

ActiveSky Media Player for Palm OS is limited to a 30 day trial version before the program must 
be registered.  When ActiveSky Media Player is installed onto a device it is given a unique 
Device ID.  A Registration Code for this Device ID must be given for the program to continue. 

To Register ActiveSky Media Player for Palm OS: 

1. From the Menu tap Register ActiveSky� to identify the Device ID.  (Refer to 
section 3.2.2 on how to access the menu.) 

2. Log on to our website at www.activesky.com, access the Registration section and 
follow the prompts. 

3. Once the Registration Code has been obtained, enter the code in the Registration 
screen on the Palm OS mobile device and tap the OK button. 

The ActiveSky Media Player for Palm OS is now registered. 

2.4 Installing SKY files 

Now that ActiveSky Media Player has been installed on the mobile device, SKY files can be 
installed to play. 

Please be aware that Palm OS devices will not play SKY files that contain only a ".sky" file 
extension.  Only SKY files that have been specifically encoded for the Palm OS can be used.  
These files can be identified by a ".sky.pdb" file extension.  Renaming ".sky" files to ".sky.pdb" 
will not work.   You must download the SKY files specifically encoded for the Palm OS. 
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SKY files can also be found at www.activesky.com or at one of many content provider web 
sites.  Visit www.activesky.com for a list of these sites.  Select a content provider then make 
sure you select the Palm OS files! 

Once the SKY files have been downloaded, they can be installed onto the mobile device.  To do 
this: 

1. Connect the mobile device to the desktop PC or Mac. 

2. Locate and start up the Install Tool program.  (Install Tool is provided with your 
Palm OS device.) 

3. Using the Install Tool program, locate and select the SKY files to be installed and 
click Done. 

4. Tap the HotSync icon on the mobile device.  These files will then be displayed on 
the Play List screen in ActiveSky Media Player. 

Alternatively SKY files can be beamed from another Palm OS mobile device with SKY files.  
Refer to Section 3.3 on how to beam SKY files from a Palm OS mobile device. 

3 Using ActiveSky Media Player 

3.1 Opening ActiveSky Media Player 

To open ActiveSky Media Player: 

1. Switch on the mobile device. 

2. Tap the Applications icon on the mobile device (refer to the mobile device user 
manual for location of this button). 

3. Tap the ActiveSky icon. 

This will open ActiveSky Media Player.  The mobile device is now ready to start playing. 

3.2 Getting Familiar 

Before getting started, it�s a good idea 
to be familiar with ActiveSky Media 
Player. 

The application consists of a Title bar 
and menu, Video display section and a 
Video Controller. 
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3.2.1 The Play List Screen 

The Play List screen appears automatically when ActiveSky Media Player is activated.  The Play 
List screen contains a list of SKY files available on the mobile device to play. 

3.2.2 Accessing the Menu 

The menu is activated from the Play List screen by using the 
Menu button on the mobile device (refer to the mobile device 
user manual for location of this button) or by tapping on 
ActiveSky in the Title bar. 

 

The menu contains the following options: 

File Info Displays a list of details about the selected SKY file. 

Video Options� Displays a list of options that allows the video player to be customized. 

Help Explains the use of each screen. 

Beam Player Beam ActiveSky Media Player to another Palm OS mobile device. 

About ActiveSky� Displays information about ActiveSky and ActiveSky Media Player. 

Register ActiveSky� Displays the Device ID for registration. 

3.2.3 Video Controller 

The Video Controller is displayed at the bottom of the screen 
and is used to control the video during playback.  

The functions of the Video Controller are: 

 Previous 
When a SKY file is in playback, tapping this button stops playback and selects and plays 
the previous SKY file in the Play List.  If the selected SKY file is the first in the Play List, 
this file continues to play as normal. 

 Stop 
Tapping this button stops playback of the open SKY file and displays the statistics screen if 
enabled. Otherwise it returns to the Play List screen. 

 Play 

 Pause 
To play the selected SKY file, tap the Play button.  Once the SKY file is in playback the 
Play button changes to a Pause button.  Tapping the Pause button pauses the open SKY 
file at the current position.  Once the SKY file is paused, the Pause button reverts back to 
the Play button.  Tap the Play button again to resume playback of the open SKY file. 
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 Frame Advance 
Tapping this button when the selected SKY file is in playback pauses at the current 
position.  Tap the button again to advance frame by frame.  This button can also be used 
after the Pause button has been tapped to advance the open SKY file frame by frame.  
This feature is useful for slide shows or viewing comic strips. 

 Next 
When a SKY file is in playback, tapping this button stops playback and selects and plays 
the next SKY file in the Play List.  If the selected SKY file is the last in the Play List, then 
this file continues to play as normal. 

3.2.4 Playing SKY Files 

To play a SKY file: 

1. Select the SKY file to be played from the Play List. 

2. Tap the Play button on the Video Controller. 

3.3 Viewing the SKY file Properties (File Info) 

To view the properties of a SKY file: 

1. Select the SKY file from the Play List screen. 

2. Tap the File Info button at the bottom of the Play List screen or select File Info 
from the menu. 

This will then display the following information, if available, about the selected 
SKY file: 

File Name: Name of the SKY file. 

Title: Title of the video. 

File Size: Size of the SKY file in kBytes. 

Date Created: Date the SKY file was created. 

Frame Size: Width and height of the display size of the SKY file in pixels. 

Content Rating: The rating of the SKY file, e.g. PG, AO, etc. There are many 
ratings that could be displayed. 

Author: Name of the person who created the SKY file. 

Copyright: Copyright details of the SKY file. 

3. To delete the selected SKY file, tap the Delete button.  A confirmation to delete 
the SKY file will be requested. 

4. To beam the selected SKY file to another Palm OS device, tap the Beam button. 

5. To exit File Info, tap the Done button. 
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3.4 Customizing ActiveSky Media Player (Video Options) 

To customize ActiveSky Media Player: 

1. Tap the Options button at the bottom of the Play List screen or select Video 
Options� from the menu. 

The following options are available for modification: 

Screen Depth: Black & White, 4 Gray, 16 Gray, 256 Color, 65535 Color 
(Default: Greatest depth supported by mobile device) 

This option affects the screen depth that a video is played back at.  Often 
choosing a lower screen depth will speed the video up.  Its default value is 
whatever the best screen depth is that the mobile device currently can 
handle.  If a mobile device is not able to display in any one of these depths, 
the depth will not be an available option. 

Loop: Off, Selected Video, Play List (Default: Off) 

If Loop is set to Selected Video, when the SKY file ends playback it is simply 
reset to the start and keeps playing until the stop button is pressed.  If Loop is 
set to Play List, when the current SKY file ends the next SKY file in the Play 
List is played.  When the last SKY file in the Play List has ended the first SKY 
file in the Play List is played.  This will continue to cycle until the stop button 
is pressed. 

Sound Effects: Off, Low, Medium, High (Default: High) 

Adjusts the sound level of the beeps, when buttons are pressed. 

Display Splash Screen: On/Off (Default: On) 

When switched On, the ActiveSky splash screen, if installed, will be displayed 
when starting the program. 

Upgrade Player Warning: On/Off (Default: On) 

When enabled and a SKY file is played that might contain new features not 
supported by the current version of ActiveSky Media Player, a warning 
message will be displayed recommending that ActiveSky Media Player be 
upgraded.  The SKY file will still be played, but may not look exactly as 
intended.  If switched Off, no warning will be given. 

2. Tap the OK button to exit with changes, or, tap the Cancel button to exit without 
changes. 
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3.5 Help 

1. The Help screen can be accessed from any screen, by tapping the ? button in the 
top right corner, to provide context-sensitive help on whatever the user may be 
doing.  Alternatively, help can be accessed by selecting Help from the menu. 

If there is more than one page on the selected Help subject, the Next and Previous 
buttons on the Video Controller or the Page Up and Page Down buttons on the mobile 
device can flip between the Help file pages. 

A help subject list is located on the Title Bar. 

2. To exit Help, tap the Done button.  (The user is returned to the screen from which 
they accessed Help.) 

3.6 Beam Player 

This function can be used to beam ActiveSky Media Player to another Palm OS mobile device.  
(Please refer to the mobile device user manual for tips on beaming applications.) 

3.7 About ActiveSky 

To view details about ActiveSky Media Player: 

1. Select About ActiveSky� from the menu. 

This displays the ActiveSky Media Player version, copyright information and the 
ActiveSky web site address. 

2. To exit screen, tap the OK button. 

3.8 Register ActiveSky 

This will only be displayed on the menu if ActiveSky Media Player for Palm OS has not been 
registered.  The screen contains the details of User Name, Device ID and a space to enter the 
Registration Code.  Please visit our website at www.activesky.com to obtain a Registration 
Code. 

3.9 Deleting a SKY file 

To delete a SKY file: 

1. Select the SKY file to be deleted from the Play List. 

2. Tap the File Info button at the bottom of the Play List screen, or select File Info 
from the menu. 

3. Tap the Delete button at the bottom of the File Info screen.  A confirmation to 
delete the SKY file will be requested. 

3.10 Uninstalling ActiveSky Media Player 

To uninstall ActiveSky Media Player from the Palm OS device we recommend referring to the 
mobile device user manual for precise instructions on deleting applications. 
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4 Using ActiveSky Desktop Viewer (Windows only) 
ActiveSky Desktop Viewer is a Windows application that allows SKY files to be previewed before 
transferring them to the Palm OS device.  ActiveSky Desktop Viewer is included with some 
versions of the ActiveSky Media Player download (Windows) and is installed on the desktop PC 
during the ActiveSky Media Player installation process. 

4.1 Opening ActiveSky Desktop Viewer 

To open ActiveSky Desktop Viewer: 

1. From the Start/Programs/ActiveSky Media Player (Palm) menu, select ActiveSky 
Desktop Viewer. 

4.2 Getting Familiar 

The application consists of a Title Bar, 
Menu, Toolbar, Main Window where the 
SKY videos are displayed and a Status 
Bar. 

 

4.2.1 Accessing the Menu 

Clicking File activates the File menu. 

 

The File menu contains the following options: 

Open� Opens a SKY file. 

Properties� Displays a list of properties about an open SKY file. 

Options� Displays a list of options that allow ActiveSky Desktop Viewer to be 
customized. 

About� Displays information about ActiveSky Desktop Viewer and ActiveSky. 

Exit� Closes and exits ActiveSky Desktop Viewer. 
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4.2.2 Toolbar 

The functions of the Toolbar are: 

 Open 
Click this button to browse for and open a SKY file. 

 Play 
Click this button to Play the open SKY file. 

 Pause 

 Next Frame 
Clicking the Pause button when the SKY file is in playback pauses at current position.  
Once the SKY file is paused this button changes to the Next Frame button.  Click this 
button again to advance frame by frame.  This feature is useful for slide shows or viewing 
comic strips.  Playback can be resumed at any time by clicking the Play button or Stopped 
by clicking the Stop button. 

 Stop 
Clicking this button stops playback of the open SKY file and rewinds the file back to the 
beginning. 

 Options 
Click this button to access the Options menu and customize ActiveSky Desktop Viewer. 

 Zoom 
Clicking this button doubles the display size of the SKY file.  If the display size is already 
doubled and the zoom button is clicked, this will reset the display size to normal. 

4.2.3 Status Bar 

The status bar at the bottom of the screen shows how long the SKY file has been playing, the 
total play time for the SKY file, a progress bar and a speaker icon if the SKY file contains an 
audio stream. 

 

4.2.4 Playing SKY Files 

To play a SKY file: 

1. Select Open� from the File menu, or click the Open button on the toolbar. 

2. Locate and select the SKY file to be played. 

3. If Autoplay is enabled in the Options menu, the SKY file will begin to play 
automatically.  Otherwise, click the Play button. 
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4.3 File Properties 

To view the file properties of the open SKY file: 

1. Select Properties� from the File menu. 

The Properties are divided into 3 sections: General, Details and Statistics. 

The General tab contains File name, Title, Author, Date Created and Copyright 
information.  Information will only be displayed if available. 

The Details tab contains File name, File type, File size (in kBytes), Media 
length (in mm:ss), Picture size (Width x Height in pixels), Total frames, Frame 
rate (per second) and the Audio format. 

The Statistics tab contains File name, Total time (milliseconds) and Average 
frame rate (per second). 

2. To exit screen, click the Close button. 

4.4 Customizing ActiveSky Desktop Viewer (Options) 

To customize ActiveSky Desktop Viewer: 

1. Select Options� from the File menu or click the Options button. 

The following options can be modified: 

Playback speed: x0.5, x1, x2, Max (Default: x1). 

Sets the speed of the SKY file in playback.  Audio is only played during normal 
(x1) playback speed. 

Autoplay on open: On/Off (Default: On). 

Starts playing the SKY file as soon as it is opened. 

Continuous play: On/Off (Default: Off). 

Replays the SKY file in a continuous loop, until the Stop button is tapped. 

Audio mute: On/Off (Default: Off). 

Silences the audio stream, if one exists, of the SKY file. 

2x Zoom: On/Off (Default: Off). 

Doubles the display size of the SKY file. 

Show status bar: On/Off (Default: Off). 

Show or Hide the status bar. 

2. Click the OK button to exit with new changes, or, click the Cancel button to exit 
without new changes. 
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4.5 About ActiveSky Desktop Viewer 

To view details about ActiveSky Desktop Viewer: 

1. Select About� from the File menu. 

This displays the ActiveSky Desktop Viewer version, copyright information and the 
ActiveSky web site address. 

2. To exit screen, click the  close button. 

4.6 To Exit ActiveSky Desktop Viewer 

To Exit ActiveSky Desktop Viewer: 

1. Select Exit� from the File menu. 

Contact and Technical Support 
For ActiveSky technical support, please contact us by e-mail at palm_support@activesky.com. 

ActiveSky support is limited to ActiveSky provided products only. 

For more information about ActiveSky, see our web site at www.activesky.com. 

Thank you for using ActiveSky technology! 

Copyright Notices 
Copyright ©2000 ActiveSky Inc. All Rights Reserved. 

Microsoft and Windows are registered trademarks of the Microsoft Corporation. 

Palm(tm) and Palm OS(r) are registered trademarks of Palm Inc. 

All other products are trademarks of their respective owners. 

 


