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Program Overview (General Information)
What is the Purpose of askSam?

Very often, the difference between mere data and useful information involves two basic considerations:
- The amount of time required to isolate the needed data; and
- The ability to present the results in a meaningful manner.

These two concepts are fundamental to askSam's overall design. By reducing the time you might
otherwise spend searching through files, notes, documents, reports, and other data, askSam frees you
to put your information to real use. askSam further increases the value of your information by allowing
you to present it in the manner most appropriate to your specific needs. Helping you take your data into
the realm of information -- that's what askSam is all about.

Data Versus Information Management

Traditionally, different programs have clouded the distinction between data and useful information. As
their name suggests, databases usually offer a very limited ability to go beyond the data (such as names
and addresses) which conform to their rigid structures. Word processors, on the other hand, present
data in single-purpose freeform documents but lack the flexibility needed to extract information on a
broad multiple Document basis. Personal Information Managers generally promise to combine both
freeform and structured data to yield useful information. However, when your data departs from the
usual meetings, addresses, and notes which these programs are designed to manage, they begin to
reveal their inherent limitations.

askSam recognizes that your data can become useful information only when it is being managed by a
system which places its priority on flexibility. The simple fact is you are faced with both structured and
freeform data every day. True information management must give you the ability to use this diverse
data in a manner which addresses your changing needs both now and in the future.

What is askSam?

As a Windows application, askSam provides you with a unique array o features that actually span
several software categories yet can be accessed from within a familiar intuitive environment. Whether
you choose to use the Tool Bar, the Pull-Down Menu System, Keyboard Commands, or the Command
Line, askSam for Windows is ready to redefine computerized Information Management in your terms.

Uses as a database, askSam manages structured information, sorts fields, and generates reports, but
without the usual limitations found in a traditional database. askSam never restricts you to a predefined
structure with fields of a specified length (a field can be one word, a paragraph, or ten pages of text).
asksam can then perform complex searches involving multiple words and fields -- even in memos or
notes. In addition, the Report Writer will enable you to present the results of your searches in a manner
which best suits your needs.

Uses as a Word Processor, askSam allows you to create and edit correspondence, faxes, memos, and
other documents taking full advantage of the Windows environment. Everything from the ability to use
a variety of fonts and alignment schemes to a full search and replace facility is available. Since you can
group related documents together within a single file, it is possible to go back later and extract
information from one or more documents and use it in a variety of ways. askSam also allows you to
import documents from other word processors and access them using the many features of askSam's
versatile search engine.

Used as a Text Retrieval system, askSam gives you the ability to conduct powerful Boolean or proximity
searches to locate very specific information within your documents. Since even freeform text has an
inherent structure (words, lines, sentences and paragraphs) which askSam can use in these queries,



you will be able to extract, sort and generate reports on data which other programs can only treat as
blocks of text.

Simple stated, askSam for Windows fulfills its purpose by offering a design which is as dynamic and
flexible as your information and management style.

Welcome to askSam -- Your personal window on Information Management.



askSam for Windows Network Version

Using askSam in a Network Environment
In order for multiple users to search, edit, and add to a database, you will require the network version
of askSam. You can contact our Customer Service Department at 800-800-1997 for information on
upgrading a single user version to a network version of askSam.

Using the network version of askSam is the same as using the single user version except that the
network version supports record locking, allowing users to work in the same database
simultaneously.

Opening Files in the askSam Network Version
In the askSam network version, you can open files either in a Shareable or an Exclusive mode.

Shareable mode allows multiple users to simultaneously search, edit and add information to a
database. When a user edits a document, that document is automatically locked, preventing other
users from editing that document at the same time. As a default, askSam opens files as
Shareable.

Exclusive mode limits access to a database to only one user. Other users are denied access
until the user who opened the database in Exclusive mode closes the database.

Certain functions require an Exclusive access level:

Packing a file

Creating or editing reports
Editing an Entry Form

Save As

Executing a Global Replace
Defining a Password for a file

If an attempt to perform one of these functions takes place while another user is accessing the
same file, an error message will occur.

Tip: When working with files that others will not be accessing, use the Exclusive access option.
When in Exclusive mode, askSam is faster.

Notes
" When creating a new file, it is created in Exclusive mode. The file must be closed before other
users can enter the file.

. A File Edit password can be defined to protect a file. This would only allow users with the
password to edit the file. Other users would only be able to access the file in a read-only mode.

" You can modify askSam to have the OPEN dialog default to an Exclusive option instead of
Shareable when opening askSam files. To set this option, open an askSam file and see the OPTIONS ->
GLOBAL PREFERENCES menu. Change the Default File Setting to Exclusive.

Exiting askSam (Important)
It is important to properly exit askSam by choosing FILE -> CLOSE. If a document is locked and the
computer is turned off without first exiting askSam, that document will remain locked the next time
you access the file. To remove any incorrectly locked documents, choose FILE -> PACK to pack the
file.






New command (File menu)

Use this command to create a new file in askSam. You can open an existing file with the Open
command.

Shortcut

Toolbar:

Key Stroke:  Ctrl+N
Dialog Box Options

File Name:
Enter a name for the new file.

Use Template:
Select a template to structure your new file. Select NONE to create an empty file.

NOTE: askSam comes with standard templates for a variety of tasks: contact management, writing
faxes, clippings, a calendar file. New templates will continually be added and existing ones updated. The
README file contains an up-to-date list of the templates and a brief description of each.

Directories and Drives
Select the Drive and Directory for the new file if it is not the currrent directory.

See also

Close command (File menu)
Open command (File menu)
Save command (File menu)
Save As command (File menu)




Open command (File menu)

Use this command to open an existing file in askSam. You can create a new file with the Ne
command.

Shortcut

Toolbar:

Key Stroke: Ctrl+O
Dialog Box Options

File Name
Type or select the name of the file you want to open.

List of File Type
Select the format of the file you want to open. Click the down arrow to view the available file formats.

Directories
Select the directory from which you want to open the file.

Drives
Select the drive from which you want to open the file.

Read Only
Click the box to open the file in Read Only Mode. Files opened as Read Only cannot be edited.

The following options appear only in the Network Version.

Exclusive
Click the button to open the file in an Exclusive Mode. Files are opened to allow access to only one user.
Other users are denied access until the file is closed.

Shareable
Click the button to open the file in a Shareable Mode. Files are opened to allow multiple users to
simultaneously search, edit and add information.

Note
As a default, files are opened as Shareable.

When working with files that others will not be accessing,
use the Exclusive access option. In exclusive mode, askSam is faster.

See also

Close command (File menu)
New command (File menu)
Save command (File menu)
Save As command (File menu)
Network Version




Save As command (File menu)
Use this command to save the current file with a new name, format or location.

Note: To save a file with its existing name, format, and location, use the Save Command.

Shortcut

Toolbar:

Dialog Box Options

File Name
Type or select the name of the file you want to save.

List of File Type
Select the format of the file you want to save. Click the down arrow to view the available file formats.

Directories
Select the directory in which you want to store the file.

Drives
Select the drive in which you want to store the file.

See also

Close command (File menu)

New command (File menu)
pen command (File menu)

Save command (File menu)

O




Save command (File menu)

Shortcut

Toolbar:

Key Stroke: Ctrl+S

Use this command to save the current file with its existing name, format, and location. If you are working
with a new file, you must specify the file name, format and location.

Note: To save an existing file with a specified name, format, and location, use the Save As command.
Dialog Box Options

File Name
Type or select the name of the file you want to save.

List of File Type
Select the format of the file you want to save. Click the down arrow to view the available file formats.

Directories
Select the directory in which you want to store the file.

Drives
Select the drive in which you want to store the file.

See also

Close command (File menu)
New command (File menu)
Open command (File menu)
Save As command (File menu)




OCR (File Menu)

The Readlris OCR Module is a powerful intelligent Optical Character Recognition (IOCR) system which
lets you scan documents directly into an askSam database.

To scan resumes, papers, articles, or other documents into askSam make sure you are in the document
where you want to scan the information. Choose File -> OCR.

Dialog Options
Scanner/File

Unformatted/Formatted

Auto Page Analysis

# of Pages to Scan

Learn Mode

Keep OCR Loaded

Change OCR Dictionary

Determines if you are scanning from your scanner or from a TIFF file.

Unformatted scans in texts without any formatting information. Formatted
scans in text with paragraph and indentation formats.

When Auto Page Analysis is checked, the text and graphics blocks are
automatically detected and sorted. If this option is not checked, you can
manually select the areas you wish to OCR and the order in which they
are scanned.

If you plan to scan more than a single page into an askSam document,
enter the number of pages you will scan in this field.

When checked, Readlris displays any doubtful characters for your
approval. This feature lets you teach Readlris to recognize unusual or
poorly printed characters.

After you finish scanning a document with the Readlris OCR Module,
askSam automatically removes Readlris from memory. If you plan to scan
many documents, you can check this option, and Readlris will remain
loaded after the text is scanned. This will save time when you scan the
next document.

If you run Readlris on many documents of the same type, you can define
specific font dictionaries for these documents. You can store learned
characters in these dictionaries. This will save you time when you scan
similar documents. The Append/New options let you choose whether you
will create a new dictionary or append entries to an existing dictionary. As
a default setting, the ASKSAM.DUS is loaded as your dictionary.

1. Choose the appropriate options and choose OK to begin scanning your document. The Readlris OCR
Module is loaded. Follow the instructions in the Readlris User's Guide for scanning information.

2. When you've completed scanning and recognizing the information, you return to askSam, and the
information is automatically inserted in your Document.



Page Setup command (File menu)

Use this command to change margins, paper source, paper size, and the direction the text appears on
the page for any section of your document or file.

Dialog Box Options

Options

Select the range for the Page Setup command.

File Settings Sets the default page setup settings for the current file.
Document Settings Sets the default page setup settings for the current document.
Margins

Displays the Margins options.

Top Specifies the distance between the top of the page and the top of the first line of the page.

Bottom Specifies the distance between the bottom of the page and the bottom of the last line on the
page.

Left Specifies the distance between the left edge of the page and the left end of each line.

Right Specifies the distance between the right edge of the page and the right end of each line.

Orientation

Displays the options for setting the direction you want the text to appear on the page.
Portrait

Landscape

Header
Use this option to insert text at the top of every page in a document or file.

Footer
Use this option to insert text at the bottom of every page in a document or file.



Print Setup command (File menu)

Use this command to select a printer and a printer connection. The default printer for askSam is the
printer defined in the Windows Control Panel.

Dialog Box Options

Printer Select the printer you want to use; only installed printers appear. You install printers
and configure ports through the Windows Control Panel.

Default Printer Selects the default printer as defined in the Windows Control Panel.

Specific Printer Selects a printer and printer connection other than the default printer. All installed
printers will appear in the Specific Printer list.

Orientation

Select the direction you want the text to appear on the page.
Portrait

Landscaped

Paper
Select the paper size you want to use.

Options

Select the dithering, intensity control and print quality for your print job.
Dithering

Intensity Control

Print Quality

See also
Print command (File menu)



Print command (File menu)

Use this command to print the current document, file, selected document(s), report, or pages of a
document.

Shortcut

Toolbar:

Key: Ctrl+P

Dialog Box Options

Print Range Select the range of the print job.

Current Document  Prints the current document. The default setting.

All Documents Prints all documents in the current file.

Selected Documents Prints documents selected using the Multiple Search Dialog Box.

Report Prints the output of a Report created with the askSam Report Writer. The Run
Report Dialog Box will appear. o

Pages Prints a range of pages of the current document. After selecting this option,

type the page numbers in the FROM and TO boxes.

Print Quality
Changes the quality of the graphic images.

Note: This option is printer dependent and is not available for all printers.

Copies
Use this option to prints multiple copies of the print job. The default setting is 1.

Setup
Use this option to select a printer and a printer connection. See the Print Setup command for more
information on the Print Setup Dialog Box.

See also
Print Setup command (File menu)



Import command (File menu)
Use this command to import text, documents or files into an askSam file.

Shortcut

H+
Toolbar:

Dialog Box Options

File Name
Type or select the name of the file you want to import.

File Type
Select the format of the file you want to import. Click the down arrow to view the available file formats.

Text Only (*. TXT)ASCI! text files. Imported without word wrap or tabs

Text Formatted (*. TXT)ASCII text files. Imported with word wrap and tabs.

askSam DOS (*.TXT)Format for exchanging data between the DOS and Windows
versions of askSam. Also useful for transferring information between
askSam for Windows files. This format retains Document Boundaries
between askSam Documents.

CompuServe Information Manager Files from the CompuServe Information Manager -
*ART, *.MSG, *.NWS, *.PLX, *.THD.

Comma Separated (*.TXT) Data separated by commas. Use this format to import data from
spreadsheets and other databases.

dBASE Files (*.DBF)dBASE llI, llI+ and IV files. This format allows the Importing of
structured information from dBASE compatible databases (including FoxPro
and Clipper). It also imports memo fields associated with these databases.

Fixed Position (*.TXT) Data stored in fixed column positions. Use this format to import data
from spreadsheets and other databases.

Lexis/Nexis (*.TXT) Files from Mead Data's On-Line systems Nexis (news articles) and
Lexis (legal rulings)

RTF Files (*.RTF)Rich Text Format files used to exchange formatted information
(including .BMP Graphics.)

Tab Delimited (*.TXT)Data separated by tabs. Use this format to import data from

spreadsheets and other databases.
Word for Windows (6.0) (*.DOC)Microsoft Word for Windows 6 files with formatting.

WordPerfect 5.X (*.*)WordPerfect version 5 files with formatting.
WordPerfect 6.0 (*.WPD)WordPerfect version 6 files with formatting.
Directories

Select the directory from which you want to import the file.

Drives
Select the drive from which you want to import the file.

Select all
Click on this option to import all the files of the specified type and in the specified location.

Set Options
Use this option to define a document delimiter and location within your askSam file.
Append Location Adds the imported text to a specified location within your askSam file.



End of File Adds the imported text to the end of the current file.

End of Current Document Adds the imported text to the end of the current document.

After Current Document Adds the imported text in a new document inserted located directly after
the current document in the current file.

After Tagged Document Adds the imported text in a new document located directly after the
tagged document in the current file.

Automatic Field Recognition

Auto Field Recognition recognizes fields in imported information. In the Import Dialog Box choose the
SET OPTIONS button and select the Auto Field Recognition option. Field Recognition takes place
immediately after your import is complete. You can also access Auto Field Recognition by choosing
TOOLS -> AUTO FIELD RECOGNITION.

Document Delimiter

Sets the delimiter for the imported text.

No Delimiter The entire file you import is stored in askSam as a single document.

Blank Line Each time askSam encounters a blank line in the imported text, a new askSam
document is created for the next block of imported text.

Character(s) Allows you to define one or two characters which askSam will use as a delimiter to
separate imported text into multiple documents.

Page Break Divides the file you import into askSam Documents wherever hard page breaks are

encountered.

Lines Lets you specify a number of lines as a delimiter. askSam creates a new Document each
time the specified number of lines is imported.

String Allows you to enter a string of characters which askSam will use to separate imported

information into multiple Documents. The character string can contain 256 characters.
Pressing ENTER inserts a CR/LF (carriage return / line feed) into the string. The Remove
Delimiter String option lets you remove the Delimiter String from the imported
information.

See also

Importing Information (Step-by-step Instructions)
Export command (File menu)



Export command (File menu)

Use this command to export the current document, entire file, tagged document, selected document(s),
or report.

Export sub-Menu Options

Current Document
Exports the current document.

Dialog Box Options

File Name
Type or select the name of the file into which you want the document exported.

File Type

Select the format of the document you want to export. Click the down arrow to view the available file

formats.

Text Files (*. TXT)ASCII text file.

askSam DOS (*.TXT)Format for exchanging data between the DOS and Windows
versions of askSam. It is also useful for transferring information between
askSam for Windows files. This format retains the Document boundaries
between askSam Documents.

askSam for Windows (*.ASK)Creates a new .ASK file from the Exported information.

Comma Separated Values (*.TXT)Comma separated values can be used to Export data for Mail
Merge with a word processor or for use with most database programs.

RTF Files (*.RTF)RTF files can be used to exchange formatted information
(including .BMP Graphics.)
Tab Delimited (*.TXT)Data separated by tabs. Use this format to export data for Mail

Merge with a word processor or for use with most database programs.
Word for Windows 6.0 (*.DOC)Microsoft Word for Windows version 6 with formatting.
WordPerfect 6.0 (*.DOC)WordPerfect version 6 with formatting.

Directories
Select the directory into which you want to export the document.

Drives
Select the drive into which you want to export the document.

Set Options - Document Delimiter
Use this option to define a document delimiter.

No Delimiter Exports the file without inserting a delimiter between Documents. This is the Default
Setting.

Blank Line Inserts a Blank Line after each Document that is Exported.

Page Break Outputs a Page Break after each Exported Document. If you are exporting to TXT an
ASCII 12 character is used as the page break character.

String Allows you to define a character string to output as a delimiter between Documents.

Entire File
Exports the current file.

Dialog Box Options



(See above)

Tagged Document
Exports the tagged document.

Dialog Box Options
(See above)

Select Document(s)

Exports documents you select using the askSam Multiple Search Request Dialog Box. See Multiple
Search Request command (Actions menu)

Dialog Box Options
(See above)

Report
Exports the output of a specified Report.

Dialog Box Options

Report Name
Type or select the name of the report you want to run.

See also

Exporting Information (Step-by-step Instructions)
Import command (File menu)



Pack command (File menu)

Use this command to permanently remove deleted documents and reclaim fragmented space. Packing
should be done periodically to decrease file size and speed searches.



Undelete command (Edit menu)
Use this command to restore deleted text to its original position in the current document.
Shortcut

Key: Ctri+Z



Cut command (Edit menu)

Use this command to remove selected text or a graphic from a document and put it in the Clipboard.
This command is not available if you have not selected text or graphics.

Note: Cutting text or graphics to the Clipboard replaces the contents previously stored in the Clipboard.
Shortcut:

Keys: Ctrl+X

Toolbar:

See also

Copy command (Edit menu)

mﬂ

Paste command (Edit menu)



Copy command (Edit menu)

Use this command to copy selected text or a graphic from a document and put it on the Clipboard. This
command is unavailable if you have no selected text or graphics.

Note: Copying text or graphics to the Clipboard replaces the contents previously stored there.

Shortcut:
Keys: Ctrl+C
Toolbar:

See also

Cut command (File menu)

Paste command (File menu)



Paste command (Edit menu)

Use this command to insert a copy of the Clipboard contents at the cursor position. This command in
unavailable if the Clipboard is empty.

Shortcut

Keys: Ctri+Vv

Toolbar:

See also
Cut command (Edit menu)
Copy command (Edit menu)



Delete command (Edit menu)

Use this command to remove the selected text or graphic from the document.

Note: To restore the deleted text to its original location, use the Undelete command.
Shortcut

Keys: Del

See also
Selecting Text (Using the askSam Word Processor)



Paste Special command (Edit menu)

Use this command to paste an existing object or graphic into the current document without having it
linked to a source file in a Server Application.

Note: To enable updating the object, use the Paste Link command.
Dialog Box Options

Data Type
Select the type of information you are pasting.

Paste
Inserts the object or graphic without creating a link to the source file in the server application.

Paste Link
Inserts a link to the server application and its data into the document.

See also
Paste Link command (Edit menu)



Paste Link command (Edit menu)

Use this command to insert an OLE Link in the current askSam document to information in another
application.

See also
Paste Special command (Edit menu)



Find command (Edit menu)

Use this command to search for a word or phrase in the current document.
Shortcut

Keys: Shift+F3

Dialog Box Options

Find What
Type or select the word or phrase you want to search for.

Match Case
Click on the box to define the Find search as case sensitive.

Find Next
Click on the Find Next Button to search for the next occurrence of the word or phrase in the current
document.

Cancel
Click on the Cancel Button to stop the Find search at the current position in the document.

Note: To reexecute the last Find search request, press F3.

See also

Boolean Search

Search in Field

Numeric Search
Proximity Search

Date Search

Multiple Search Request
Search Multiple Files
Hyper on Selected
Hyper on File

Repeat Last Find



Repeat Last Find command (Edit menu)
Executes the last Find search request. See the Find command (Edit menu)
Shortcut

Keys: F3

See also

Boolean Search

Search in Field

Numeric Search
Proximity Search

Date Search

Multiple Search Request
Search Multiple Files
Hyper on Selected
Hyper on File

Find
Repeat Last Find



Replace command (Edit menu)
Use this command to replace text in the current document with specified text.
Dialog Box Options

Find What
Type or select the word or phrase you want to replace.

Replace With
Type or select the word or phrase you want inserted in the document.

Match Case
Click the Box to define the Replace search as case sensitive.

Find Next
Click the Find Next Button to find the next occurrence of the word or phrase you want to replace.

Replace
Click the Replace Button to replace a single occurrence of the text in the document.

Replace All
Click the Replace All Button to replace every occurrence in the document.

See also
Global Replace command (Edit menu)



Global Replace command (Edit menu)

Use this command to change specified text to a newly specified text in the every document in the current
file.

Dialog Box Options

Find What
Type or select the text you want to replace in the file.

Replace With
Type or select the text you want inserted in file.

Match Case
Click the Box to define the Global Replace search as case sensitive.

All occurrences per document
Click the Box if you want to replace all occurrences of the text in each document in the current file.
askSam's default setting is to replace only the first occurrence of the text in each document in the file.

Replace
Click the Replace Button to replace a single occurrence of the text in the file.

Replace All
Click the Replace All Button to replace every occurrence in the file.

Only in Selected Documents
The Multiple Search Dialog will appear, and you can define a Search Request. The Global Replace will
only be executed in the Documents selected by the Search Request.

See also
Replace command (Edit menu)

Multiple Search Dialog



Stamp command (Edit menu)

Use this command to insert the time, date, and weekday in the current document.
To modify the time and date formats, use the Date/Time Formats command (Options menu).

Note: askSam uses the system time and date.
Shortcuts

Toolbar:

Time
Date

Keys:
Date  Ctrl+D
Time  Ctrl+T

Stamp sub-Menu Options

Date
Inserts the system date in the current document at the cursor position.

Time
Inserts the system time in the current document at the cursor position.

Weekday
Inserts the system weekday in the current document at the cursor position.



Insert Object command (Edit menu)

Use this command to insert a new object in the current document. To insert an existing object in the
current document, use the Paste or Paste Special commands.

Dialog Box Options

Object Type
Type or select the type of object you want to insert. The appropriate server application will open to
allow you to create the object.

See also
Links command (Edit menu)
Object command (Edit menu)




Entry Form command (Edit menu)

Use this command to turn the Entry Form Editor ON. This enables you to create an entry form for your
file, or to edit an existing entry form. To turn the Entry Form Editor OFF and save the Entry Form,
choose the Entry Form command again.

Note: If no Entry Form has been defined for the current file, a blank document will appear for you to
create the Entry Form. If an Entry Form exists for the current file, the Entry Form will appear for you to
edit.

Data Entry Mode

When you turn the Entry Form Editor you are prompted to save changes. In the save changes box is an
option to Turn On Data Entry Mode. If marked the current askSam file will default to data enrty mode. If
the data entry box is not marked the file will default to a word processing mode.

See also
Add w/Entry Form command (Document menu)



Display (View Menu)
Allows you to increase your Work Space by selectively hiding various sections of the screen.
Changing The askSam Screen
From the View Menu, you can choose to remove any of the following:
Tool Bar
Format Bar
Command Line
Status Bar
Ruler
To hide (or restore) the various sections of the askSam screen:

The dialog lists the removable sections of the askSam screen. Select the screen sections you want to
change and choose OK. The askSam screen changes to reflect your selection.

NOTE: askSam defaults to having all screen sections ON.



Hypertext Link (View menu)

If selected, this option will execute a hypertext link.

Shortcut
Keys: CTRL-ENTER

Move the cursor onto the Linked word or phrase (the green underlined text). Press CTRL+ENTER (or
choose VIEW -> HYPERTEXT LINK)

One of three things will happen depending on the type of link you defined:
1. You will jump to another location.

2. A Report will be run.
3. An askSam Menu Command will be executed.

See also
History command (View menu)
Backtrack command (View Menu)



History (View menu)
To Display a List of the Previous Hypertext Links (History):

The Hypertext History Dialog Box will appear. This dialog contains a list of the Hypertext Links you've
used during this session with askSam.

Select the name of a Hypertext Link and choose OK.
You will return to the Hypertext Link you selected.

See also
Hypertext link command (View menu)
Backtrack command (View Menu)



Backtrack (View menu)

If selected, you will return to the previous Hypertext Link.

See also
Hypertext link command (View menu)

History command (View Menu)



Bookmark (View menu)
Use this command to view a bookmark
Shortcut

Keys: Ctrl + F2

This dialog contains a list of all the Bookmarks in the active file. Select the name of the Bookmark you
wish to view and choose the OK button. You jump to the line containing the selected Bookmark.

See also
Set Bookmark command (Document menu)



Next command (View menu)

Use this command to move to the next document in the current file.

Shortcut

Toolbar: m

Keys: Alt + PgDn

See also
Previous command (View menu)
First command (View menu)

Last command (View menu)



Previous command (View menu)
Use this command to move to the previous document in the current file.

Shortcut

Toolbar: E

Keys: Alt + PgUp

See also
Next command (View menu)

First command (View menu)

ast command (View menu)



First command (View menu)
Use this command to move to the first document in the current file.

Shortcut

Toolbar: E

Keys: Alt + Home

See also

Next command (View menu)
Previous command (View menu)
Last command (View menu)



Last command (View menu)
Use this command to move to the last document in the current file.

Shortcut

Toolbar: E

Keys: Alt+ End

See also

Next command (View menu)
Previous command (View menu)
Eirst command (View menu)



Go to Tagged command (View menu)
Shortcuts

Toolbar:

Use this command to move to the tagged document in the file.

Note: To tag a document, use the Tag command (Documents menu).

See also
Tag command (Document menu)



Zoom Out (Tool Bar)

Reduces the document one level.

See Also
Zoom In (Tool Bar)
Zoom Command (View Menu)




Zoom In (Tool Bar)

Magnifies the document one level.

See Also
Zoom Out (Tool Bar)
Zoom Command (View Menu)



Zoom command (View menu)
Use this command to enlarge or reduce the current document on the screen.
Shortcuts

Toolbar:

Zoom In
Zoom Out

Dialog Box Options

Magnifications

Select the magnification you want for the document.

200% Magnifies the document 200 percent of its original size.

100% Returns the document to its original size. This is the default setting.

75% Reduces the document to 75 percent of its original size.

50% Reduces the document to 50 percent of its original size.

25% Reduces the document to 25 percent of its original size.

Custom Use this option to designate a specific magnification for the document. Type the magnification
level you want in the Box.



Search Multiple Files (Actions Menu)
Allows you to search a group of askSam files.
Dialog Options

Files to Search
Displays the selected files to be searched.

Search
Allows you to build a search using the Multiple Search Request Dialog Box

Add Files
Select the files to include in the search

Remove
Remove a file from the list of files to search

Remove All
Removes all files from the list of files to search

See Also

Boolean Search

Search in Field

Numeric Search
Proximity Search

Date Search

Multiple Search Request
Hyper on Selected
Hyper on File

Find
Repeat Last Find



Boolean Search command (Actions menu)

Use this command to construct a multiple word search request to search in the current file, using the
Boolean operators And, Or, Not.

Dialog Box Options

Word or Phrase
Type or select the word or phrase you want to search for in the current file.

Boolean Operators
Select the Boolean operator you want to use to connect the words or phrases in your search request.
Note: If no Boolean operator is selected, an implied And is used to connect the search request.

Search List

Displays the search request as you construct it.

Add Enters another word or phrase and the Boolean operator you want to use in the search
request.

Replace Replaces a word, phrase, or Boolean operator that you select in the Search List.

Clear Removes the word, phrase, or Boolean operator that you select in the Search List.

Clear All Removes all word, phrases, and boolean operators in the search list
Move Up Moves a word or phrase and its boolean operator up one line in the Search List
Move Dn Moves a word or phrase and its boolean operator down one line in the Search List

Priority in Boolean Searches

In both the Boolean Search Dialog and the Multiple Search Request Dialog the searches you define are
inserted in a Search List. The first item you define is first in the list, and the rest are added to the end of
the list. The entries in a Search List are executed from top to bottom. This means that the first item in
your search list is the first to be searched for when askSam executes the search.Complex searches
(searches containing AND and OR operators) at times require a way to denote priority. In askSam you
define how items in a search are grouped and prioritized by including or not including the Boolean
operator AND. Entries in your search list that do not contain an AND and are not followed in the next line
by an OR or AND are always required.

See also

Search in Field

Numeric Search
Proximity Search

Date Search

Multiple Search Request
Search Multiple Files
Hyper on Selected
Hyper on File

Find
Repeat Last Find



Search in Field command (Actions menu)

Use this command to search for documents in the current file that contain a specific word or phrase in a
specific field.

Dialog Box Options

Word or Phrase
Type or select the word or phrase you want to find in the current file.

in Field
Type or select the field in which you want to search for the word or phrase.

Multi-line Field
Click on this box if the field in which you are searching contains more than one line.

Empty
Lets you search for Documents where a field is empty.

Not Empty
Lets you search for Documents where a field is not empty.

Note: The default setting is that the field is a single line. The end of a multi-line field is a closing
bracket (] ) or the end of the document.

See also

Boolean Search
Numeric Search
Proximity Search

Date Search

Multiple Search Request
Search Multiple Files
Hyper on Selected
Hyper on File

ind
Repeat Last Find

n



Numeric Search command (Actions menu)

Use this command to search for documents in the current file based on a numeric comparison of fielded
information.

Dialog Box Options

Select Documents with Field
Type or select the field in which you want to search. It must be a field containing a numeric value.

Numeric Operator
Type or select the numeric operator that you want to use in your search request.

Numeric Value
Type the numeric value you want to use in your search request.

See also

Boolean Search

Search in Field
Proximity Search

Date Search

Multiple Search Request
Search Multiple Files
Hyper on Selected
Hyper on File

Find
Repeat L ast Find



Proximity Search command (Actions menu)

Use this command to search for two words or phrases occurring within a specified proximity of one
another in a document in the current file.

Dialog Box Options

Word or Phrase 1
Type or select the first word or phrase of the search.

Qty

Type a number in the quantity field to define the relationship between the words or phrases in the
search. Leave the Qty Box blank if you want the words or phrases to appear in the same Sentence,
Line, or Paragraph.

Structure

Select a structural unit for the search

Word(s) Defines the search unit as a specified number of Words.
Lines(s) Defines the search unit as a specified number of Lines.

Sentence(s) Defines the search unit as a specified number of Sentences.
Paragraph(s) Defines the search unit as a specified number of Paragraphs.

Direction

Select the direction for the search condition.

Before Searches for the first word or phrase to appear before the second word or
phrase, as defined by the search condition.

On either side of Searches for the first word or phrase to appear on either side of the
second word or phrase, as defined by the search condition.

After Searches for the first word or phrase to appear after the second word or

phrase, as defined by the search condition.

In the same structure as Searches for the first word or phrase to appear in the same specified
structure (ie. paragraph, sentence etc.) as the second word or phrase, as
defined by the search condition.

Word or Phrase 2
Type or select the second word or phrase of the search.

Options

Click on the Options Button to further modify the Proximity Search.

Proximity Type

Word or Phrase Searches the entire text of each document in the current file.

First word of each document Limits the search to a word or phrase in the first word, sentence, line,
or paragraph of a document in the current file.

Output Form

Document Output the the entire document matching the proximity selection. This is the
default.

Selected Structure Output only the structure containing the proximity selection.

See also



Boolean Search

Search in Field

Numeric Search
Proximity Search

Date Search

Multiple Search Request
Search Multiple Files
Hyper on Selected
Hyper on File

Find
Repeat Last Find



Sort command (Actions menu)

Use this command to arrange the documents in the current file in a specified order. You can Sort
alphabetically, by number, or by date.

Dialog Box Options

Field List
Type or select the name of field you want to use for the Sort.

Field Type

Select the field type.

Text Sorts text in alphanumeric order.
Date Sorts fields containing dates.
Numeric  Sorts fields containing numbers.

Modifiers
Defines a modifier for the Sort.
Ignore Upper/Lower Case If selected the sort will not be case sensetive.

Descending Places the Sort list in a descending order.
Ignore Articles Ignores the words "A", "An", and "The" when Sorting.
Sort on Last Word Sorts on the last word in a field.

Modifiers - Sort Order

List of the fields and modifiers for your sort as you build the sort.

Add Adds a field and modifier to the end of the Sort List.

Replace Replaces the selected field and modifier with the field and modifier you enter.
Move Up Moves a field and modifiers up one line

Move Dn Moves a field and modifiers down one line

Clear All Removes all fields and modifiers from the Sort List.

Sort by

Select the Sort criteria you want.

Multiple words in field Sorts a field with multiple words in the Sort field.

First word in field Sorts by the first word in the Sort field.

First word in doc Sorts by the first word in each document in the current file.



Word Search (Multiple Search Request Dialog)

Enter a word or phrase to search for in the current file.



Multiple Search Request command (Actions menu)

Use this command to combine all of askSam's search functions into a single request. The Multiple
Search Dialog Box links the various searches together with Boolean logic.

Dialog Box Options

Selection

Defines the search type you want to execute.

Word Defines a search for a word or phrase in the current file.

Field Defines a search for documents in the current file that contain a specific word or phrase in a
specified field.

Date Defines a search for a documents in the current file according to a Date in a field. The
categories of Date searches are Single Range, Dual Range, and Comparison.

Numeric Defines a search for documents in the current file based on a numeric comparison of fielded
information.

Proximity Defines a search for two words or phrases occurring within a specified proximity of one
another in a document in the current file.

Search List
List the search request as you construct it.

Boolean Operators
Use the Boolean operators, And, Or, Not, to construct a multiple word search request to search in the
current file.

Note: If no Boolean operator is selected, an implied And is used to connect the search request.

Move Up
Click the Move Up Box to move the selected item in the Search List to the position preceding it.

Delete
Removes the selected item in the Search List from the search request.

Clear All
Clears all items from the Search List.

Count selected documents
Counts the number of document in the current file that meet the search criteria.

See also

Boolean Search
Search in Field
Numeric Search
Proximity Search
Date Search

Search Multiple Files
Hyper on Selected
Hyper on File

Find
Repeat Last Find



Output Fields command (Actions menu)
Use this command to output the contents of any field in the current file.
Dialog Box Options

Field
Type or select the field which contains the information you want to output.



Total Field command (Actions menu)

Use this command to calculate the sum, count and average of numerical data contained within a specific
field in the current file.

Dialog Box Options

Field
Type or select the field which contains the numerical value you want to total.

Modifiers

Use the Total Field Modifiers to further define the Total Field command.

List Amounts  Outputs the total and the number from each field used to calculate the total.

First Value Only When a the specified numeric field occurs more than once in the current file, the
First Value Only options uses only the value in the first field to calculate the total.
The default setting for askSam is to use all the values in calculating the total.

See also
Multiple Search Request command (Actions menu)



Show command (Actions menu)
Use this command to output sentences, lines, and paragraphs which contain specific words or phrases.
Dialog Box Options

Word or Phrase
Type or select the word or phrase you want to locate.

Quantity
Type a number in the Box which determines how many words, sentences, lines, or paragraphs will be
output.

Structure

Select a structure for the output.

Word(s) Outputs the specified number of words in the direction you select.
Line(s) Outputs the specified number of lines in the direction you select.

Sentence(s) Outputs the specified number of sentences in the direction you select.
Paragraph(s) Outputs the specified number of paragraphs in the direction you select.

Direction
Determines the direction from the specified word or phrase that is output.
Before word or phrase Outputs the word or phrase immediately preceding the specified

word or phrase.

Either side of word or phrase Outputs either the word, line, sentence, or paragraph on either side
of the specified word or phrase.

After word or phrase Outputs either the word, line, sentence, or paragraph immediately
after the specified word or phrase.

Containing word or phrase Outputs the line, sentence, or paragraph containing the specified
word or phrase.

Options
Modifies the output from the Show command.
Reformat Output Click the Box to output the text formatted with the current margins.

The default setting is to output the text as it is stored in the document
from which it is retrieved.

First Structure of Document Click the Box to output only the first line, sentence, or paragraph of
the documents containing the specified word or phrase. The default
setting is to output all lines, sentences, or paragraphs of the
documents containing the specified word or phrase.



Count Word or Phrase command (Actions menu)
Use this command to count the number of times a specific word or phrase occurs in the current file.
Dialog Box Options

Word or Phrase
Type or select the word or phrase you want to count in the current file.

Count All occurrences of word/phrase
Select this option to count all occurrences of the specified word or phrase in the current file. The
default setting is to count only the first occurence of the word or phrase.

Count # of Documents with word/phrase.
Select this option to count the number of documents in the current file which contain the word or phrase.



Hyper on Selected command (Actions menu)

Use this command to select a word or group of words and execute a Hypertext Search through all the
documents in the current file for further occurrences of this text.

Shortcuts

Keys: Ctri+Y

See also

Boolean Search

Search in Field

Numeric Search
Proximity Search

Date Search

Multiple Search Request
Search Multiple Files
Hyper on File

Find
Repeat Last Find



Hyper on File command (Actions menu)

Use this command to select a word or group of words and execute a Hypertext Search in any open file
in askSam for documents containing these word(s).

Shortcuts:
Keys: CtrI+F
Dialog Box Options

Current Open File(s)
Select the open file in which you want to conduct the Hypertext Search.

See also

Boolean Search

Search in Field

Numeric Search
Proximity Search

Date Search

Multiple Search Request
Search Multiple Files
Hyper on Selected

Find
Repeat Last Find



Set Hypertext Link (Document Menu)

Hypertext links can be set to other documents, reports, files or commands. If you want to set a Hypertext
Link to jump to another location, you must define a Bookmark at this location. The Bookmark gives your

destination a name that Hypertext can link to. To set a Bookmark, you place the cursor in the line where

you want the Bookmark and choose DOCUMENT -> SET BOOKMARK. Enter a name for the Bookmark
and choose OK.

Shortcuts:

Keys: F4

Dialog Options

Link To:

Current Document Set a Link to a Bookmark in the current Document.

Current File Set a Link to a Bookmark in the current File

Other File Choose this option and then choose the Browse button to select another

askSam File. You can set a Link to a Bookmark in this File.

Reports in Current File  Set a Link to a Report in the current File.

Reports in Other File Choose this option and then choose the Browse button to select another
askSam File. You can set a Link to a Report in this File.

Menu Commands  Set a Link to any askSam Menu Command.

Bookmarks

Select a Bookmark, Report, or Menu Command and choose the OK Button.

The selected text turns green and underlined. It is now linked. By Double Clicking on it, you jump to the
Bookmark, run the Report, or execute the Menu Command.

NOTE: You can set multiple Hypertext Links to a single Bookmark. For example, if you have a Bookmark
called "Table of Contents", you can have Hypertext Links in several different places that jump back to
this Bookmark.

To edit an existing Hypertext Link, select the green underlined word or phrase and redefine the Link by
choosing DOCUMENT -> SET HYPERTEXT LINK.

Each askSam document is limited to 256 hypertext links.

See also
Set Bookmark (Documents Menu)
Bookmarks (View menu)

Hypertext Link (View Menu)



Set Bookmark (Document menu)
Shortcuts:
Keys: F2

Use this command to set a bookmark on a line of a document. Start by placing the cursor in the line
where you want the bookmark.

Bookmark Name:

Enter a name for the Bookmark.

Bookmark names can contain letters and numbers. A name may also consist of multiple words.
NOTE:A bookmark is set in the current line. A file may contain an unlimited number of Bookmarks. Each
Document in a file may contain up to 256 Bookmarks.

Current Bookmarks
Displays a list of current bookmarks.

Delete
Delete a bookmark

Note
Each askSam document is limited to 256 bookmarks.

See also
Bookmark (View menu)



View Deleted Documents command (Document menu)

Use this command to view the documents that were deleted from the current file. When a document
you want to restore to the file is on the screen, use the Undelete command (Document menu).

Note: Packing a file permanently deletes a document from the file.



Phone Dialer command (Tools menu)

Use this command to automatically dial the selected phone number in the current file.

Shortcut

Toolbar:

Keys: CtrI+R



Add command (Document menu)
Use this command to add a blank document to the current file.

Shortcuts

Toolbar:

Keys: Crtl+A



Add w/Entry Form command (Document menu)
Use this command to add a document with a predefined Entry Form to the current file.

Shortcuts

Toolbar:

Keys: F5



Delete command (Document menu)

Use this command to remove a document from the current file. To undelete a document, use the
Undelete command (Document menu).



Delete Selection command (Document menu)

Use this command to remove multiple documents from the current file. To undelete documents, use the
Undelete command (Document menu).

Dialog Box Options
See Multiple Search Request (Actions menu).

View Deleted Docs
If checked, askSam will provide a chance to view the documents. You can choose to delete or not delete

each document.



Delete Duplicates (Document Menu)

The Delete Duplicates command simplifies finding and deleting duplicate documents in your file. You
define which field or fields should not have duplicate entries, and askSam displays any documents
where duplication occurs. You then have the option of deleting the duplicate documents.

Dialog Options.

Select Fields

A Dialog Box will appear in which you define the field or fields which should not contain duplicate
information in any two documents (for example Name and Telephone fields, or the Title and Author
fields).

Field List List of fields available for comparison in the current file

Add Select the fields that should not contain duplicate information from the Field List and
choose the Add button after selecting each field.

Unique Fields List of fields selected that should not contain duplicate information.

Replace Replace a field from the field list with a field in the unique fields list
Move Up Move a field up one line in the Unique Fields list

Move Dn Move a field down one line in the Unique Fields list

Clear All Clear all fields from the Unique Fields list

Duplicates

askSam searches your file for duplicates. If duplicates are found, the first duplicate document will be
displayed. The Retrieval Dialog Box appears, and you can move through the duplicate documents by
choosing Next and Previous. Choose Delete to delete Documents from your file.

See Also

Delete

Delete Selection

View Deleted Documents
Undelete




Undelete command (Document menu)

Use this command to restore a deleted document to the current file. To view the documents deleted
from the current file, use the View Deleted Documents command (Actions menu).



Tag command (Document menu)
Use this command to remember a document in the current file for quick retrieval.

Note: To retrieve the tagged document, choose the Go to Tagged command (View menu).

Shortcuts

Toolbar:

See also
Go to Tagged command (View menu).



Data Entry command (Document menu)

Use this command to switch between Data Entry Mode and Word Processing Mode. When in Data Entry
Mode the word DATA will appear in the status bar.

Shortcut

Keys: Ctrl+E



Line Spacing (Format Menu)
Set the spacing between lines of text.
Options

Single Spacing

1.5 Spacing
Double Spacing



Tabs (Format Menu)

Use this command to define the tabs for the selected text or the line containing the cursor in the current
document. To remove a tab, select the tab measurement for this tab in the Tab Stop Position list and
Click the Clear Button from the Tab Dialog Box.

Shortcuts:

Left
Center
Right
Decimal

Dialog Box Options

Tab Stop Positions
Type a measurement for the tab you want to define in the current document.

Alignment

Select the justification for the tab.

Left Justifies the text on the left tab margin.
Center Center justifies the text.

Right Justifies the text on the right tab margin.
Decimal Justifies the numeric text on the decimal point.

Set
Defines the tab with the setting you selected.

Clear
Removes the selected text from the Tab Stop Position list.

Clear All
Removes all text from the Tab Stop Position list.

See Also

Setting Tabs (Step by Step Instructions
Left Tab

Center Tab

Right Tab
Decimal Tab




Indents (Format Menu)

Indents can be set on either the left or right side of the page. You can indent the first line of a paragraph,
or you can define a hanging indent. Indents may be set on a line-by-line basis.

Dialog Options

Left
Enter your left indent setting
Right
Enter your right indent setting
Type
None Indents all selected lines
First Line Indents only the first line
Hanging Indents all lines but the first line
By

Defines the number of inches for First Line or Hanging indents

NOTE: Margins and Indents are similar, but they serve different purposes. Margins are set for an entire
Document, whereas Indents can be set on a line-by-line basis. Indents are displayed on screen. Margins
are not displayed, they only affect printing. Generally, margins are used when you print on different size
paper, stationary, or labels. Indents are used to format documents.



Font command (Format menu)

Use this command to define the font type, font size, font style, and color for the selected text or the text
entered at the cursor position.

Dialog Box Options

Font
Type or select the Font that you want to use.

Font Style
Type or select the Font style that you want to use (bold, italic, bold italic).

Size
Type or select the size of the Font you want to use.

Effects
Type or select the Font effects you want to use (strikeout, underline).

Color
Type or select the color you want to use.

Sample
Displays an example the Font type, style, size, effect, and color that you selected.



Alignment command (Format menu)

Use this command to align the selected text or the text entered at the cursor position on either the left
margin, right margin, or centered between the two margins.

Shortcut

Toolbar:

Left
Center
Right

Sub-menu Options

Left
Aligns the text on the left margin of the current document.

Centered
Aligns the text between the left and right margins of the current document.

Right
Aligns the text on the right margin of the current document.



Subscript (Style Sub-menu)

Changes the highlighted text to a subscript.

See Also
Superscript (Style Sub Menu)



Superscript (Style Sub-menu)

Changes the highlighted text to a superscript.

See Also
Subscript (Style Sub Menu)



Style command (Format menu)

Use this command to define the font style for the selected text or the text entered at the cursor position.
Shortcut

Toolbar:

Sub-menu Options

Normal
Defines the text as normal script.

Bold
Defines the text as bold script.

Italic
Defines the text as italic script.

Underline
Underlines the text.

Strikeout
Strikes through the text.

Superscript
Makes the text a superscript

Subscript
Makes the text a subscript



Color command (Format menu)

Use this command to define the color for the selected text or the text entered at the cursor position.
Shortcut:

Mouse Menu:

Dialog Box Options

Color Bar
Select the color that you want to use.



Single Line Spacing command (Format menu)

Use this command to define the line spacing for the selected text or the text entered at the cursor
position in the current document (single, 1.5, and double). The default setting in askSam is single
spacing.

Shortcut

Toolbar: E

Sub-menu Options

Single
Defines the line spacing for the text as single space.

1.5 Lines
Defines the line spacing for the text as 1.5 lines.

Double
Defines the line spacing for the text as double.

See also
1.5 Line Spacing command (Format menu)
Double Line Spacing command (Format menu)



Set Page Break command (Format menu)

Use this command to set a manual page break in the current document at the cursor position. To
remove a manual page break, use the Remove Page Break command.



Remove Page Break command (Format menu)

Use this command to remove a manual page break. Remove a page break, position the cursor
immediately above the page break and select Remove Page Break from the Format menu.

Note: To insert a manual page break, use the Set Page Break command (Format menu).



Repaginate command (Format menu)

Use this command to insert automatic page breaks in the current document. To change the placement
of an automatic page break, insert a manual page break before the automatic page break and
repaginate the document.

Note: askSam does not automatically display page breaks before printing. To insure that the page
breaks on the screen match those in the actual printout, use the Repaginate command before printing.



Left Tab command (Format menu)

Use this command to define a left tab for the selected text or the line containing the cursor in the current
document. When set and the tab key is selected text is left justified at the tab position.

Shortcuts

.—|
Toolbar: B!

To set a left tab

Place the cursor on the line where you want a left tab. Click on the left tab button in the format bar. Click
on the position in the ruler where you want a left tab. The left tab is set for the line where the cursor is
currently located.

To remove a left tab setting
Select the left tab measurement on the ruler with a mouse and drag it off the ruler.

See also

Tabs (Format Menu)

Right Tab
Center Tab

Decimal Tab



Number Format (Global Preferences)
Customize the sort order of characters.

1000 Separator
Select the character to separate thousands (ie. select comma to have 1,000)

Decimal Separator
Select the character to separate decimals (ie. select a period to have 200.05)

See Also
Global Preferences (options menu)



Currency (Global Preferences)
Change currency symbol and placement.

Symbol Placement
Select style of currency display (ie. $1, 1$)

Symbol
Select currency symbol

See Also
Global Preferences (options menu)



Sort Table (Global Preferences)

Customize the sort order of characters.

Default
Use the default askSam sort table

User Defined
Use a customized sort order

See Also
Global Preferences (options menu)



Customize Button Bars (Options Menu)
Define the buttons you want to include in the format bar and tool bar.

Button Bar
Choose either Format Bar or Tool Bar. Buttons currently on the chosen button bar will appear below.

Available Commands
These are buttons available for you to add to the Format or Tool bar.

Add
Add selected available button to Format or Tool Bar.

Replace
Replace selected Button from Format or Tool Bar with selected button from the Available Commands.

Insert
Add button from available Commands to Format or Tool Bar above the selected button.

Delete
Remove a button from the Format or Tool Bar or from the Available Commands.

Default
Set the Format or Tool Bar back to its original appearance.



File Preferences command (Options menu)

The File Preferences Dialog Box contains options which can be defined for the current file. Defaults for
all files can be set using the Global Preferences.

Dialog Box Options

HIGHLIGHT COLORS
Foreground Color Allows you to set the default foreground color for the current file.
Background Color Allows you to set the default background color for the current file.

ADD NEW DOCS TO

End of File New documents will be added to the end of the current file.
Top of File New documents will be added to the front of the current file.
After Current Doc New documents will be added after the current document.

FILE FONT
Defines the default font used by all Documents contained in a file. (It will not affect fonts specified using
the FONT Dialog Box or the drop-down Font Menu.)

CASE SENSITIVE SEARCHES
If checked, all searches are case sensitive the case of the word or phrase you enter in a Search must
match the word or phrase in the Document.

SHOW ALL MATCHES

If checked, all occurrences of the word you searched for are highlighted. If unchecked, only the first
occurrence in a Document is highlighted. This setting also affects field output. If the same field occurs
multiple times in a Document, it will be output multiple times when this option is checked. (See the
"Output All Occurrences of A Field" in the Report Settings description.)

TURN ON DATA ENTRY
If checked, Data Entry Mode will be active for your file. See the chapter Working with Documents for a
description of Data Entry Mode.

SAVE AS DEFAULTS

Check this option if you want to save the current File Preference settings as default settings for new
files.

DOCUMENT COUNTER
The "N command can be inserted into an Entry Form to number Documents as they are added. The
Document Counter allows you to reset the number of the next Document added to your file.

FIELD CHAR

Defines which character designates a field. The default setting is the character [ (open square bracket).
Words ending with this character are treated like fields. For example, Name[ or Fax[. If your information
contains words ending in another character, and you wish to use these words as fields, define this
character as the Field Character. For example, if you have a file containing E-Mail and want to use
words such as To:, From:, and Date: as fields, enter a : (colon) as the Field Character.

RULER SETTINGS
Left Ruler Sets default values for the Left ruler (margin)
Right Ruler Sets default values for the Right ruler (margin)

Note: These settings will only affect New Documents added or imported to your file (not your existing



Documents).

INDENT SETTINGS
Indent Type Sets the type of indent to be used in the current file (First Line or Hanging)
Ruler Indent  Sets the indent distance in inches.

Note: These settings will only affect New Documents added or imported to your file (not your existing
Documents).

See also
Global Preferences



Password/Encrypt command (Options menu)

Use this command to prevent access to your files with password protection and text encryption. To
remove a password or text encryption, use the Password/Encrypt command.

Dialog Box Options

File Lock Password
Locks the current file to prevent unauthorized access with a password. Also allows you to edit or
remove an existing password. The Set Password Dialog Box will appear.

File Edit Password
Locks the current file to prevent editing, but allows read-only access. Also allows you to edit or remove
an existing password. The Set Password Dialog Box will appear (See above).

Encrypt File
Encrypts the text of the current file to prevent access. To remove the file encryption protection, reselect
the Encrypt File option in the Security Dialog Box.

Set Password
Click here to type new passwords or replace old password

Set Password Dialog Box

Old Password To edit an existing password, type the existing password to obtain
access to the file.

New Password Type in a new password to replace the existing password.

Retype Password Retype the password you want to define for the file, either the

existing password, or the new password. To verify the password



Date/Time Formats command (Options menu)

askSam allows you stamp the date, time, and weekday into your Documents. The Date/Time Format
Dialog Box lets you define the format to use for stamping this information into your Documents.

Dialog Box Options

Date Format
Defines the date format for the current file

Short If checked, you may select a short date format for the current file.
MDY 08-18-94
DMY 18-08-94
YMD 94-08-18

Separator Select a date separator: \ (08\18\94), - (08-18-94)

Long If checked, you may select a long date format for the current file.
Aug 18, 1994
August 18, 1994
18 Aug 94
18 August 1994

Day Select a day format for the current file.
Long Thursday
Short Thur

Time Format
Defines the time format for the current file.

12 Hour Defines the time format in hour and minute values (12:00 AM -11:59).

12 Hour w/Seconds Defines the time format in hour, minutes, and seconds values (12:00.00 AM -
11:59.59).

24 Hour Defines the time format in 24 hour values (00:00.00 - 23:59.59).

Save as Defaults
If checked, the settings specified for Date\Time formats will register as default settings.



Output Separator command (Options menu)

Use this command to define a separator that will be output between documents when generating
Reports in the current file. To define a separator for a specific report, use the Output Separator option
in the Report Settings Dialog Box.

Dialog Box Options

Defines the document separator you want to use.

Line(s) between Docs Select the Box to define a specified number of lines as the separator.
Enter the specific number of lines you want to use.
A line of the character Select the Box to define a character as the separator. Enter the

character you want to use.
A page break between Docs Select the Box to define a page break as the separator.
No separator Select the Box to not define a separator. This is the default setting.



Global Preferences command (Options menu)

The Global Preferences Dialog Box allows you to modify askSam's default system settings.
Specific settings can be set for each file by using the File Preferences command.

Dialog Box Options

Show Commands from Dialogs

The Search Requests generated by the Dialog Boxes in the Actions Menu can also be entered directly
on the Command Line. If you wish to see the Commands that the system generates, turn this option on.
The requests generated by reports are also displayed before the report is run. The default setting for this
option is OFF.

Warning Beep
Activates or deactivates the Warning Beep. The Warning Beep is heard in conjunction with various
messages. The Default setting is ON.

Save BackUp File Before Packing

When you pack a file, a copy is made of the file you are packing, and it receives the extension .BAK. If a
.BAK file already exists, the .BAK file is renamed to a .SAV file. If you do not want .SAV files, turn this
option off. The Default setting is ON.

Save document when adding with Entry Form.

This option controls whether the Current Document is automatically saved when you add another
Document containing an Entry Form. This simplifies entering data. The Default setting for this option is
ON.

Activate Text Drag and Drop
Controls whether Drag and Drop editing is active. Drag and Drop text offers a simple method for moving
and copying selected texts within a Document. The Default setting for this option is ON.

Automatic Save Every ?? Minutes
Automatically saves all open files at a specified interval.

Measurement Units
Sets the Ruler and all Measurements in either Inches or Centimeters.

Sort Table
Customize the sort order of characters.
Default Use the default askSam sort table

User Defined Use a customized sort order

Currency Format
Sets the currency symbol used in totals and subtotals.

Change:
Symbol Placement Select style of currency display (ie. $1, 1$)
Symbol Select currency symbol

Number Format

Sets the numeric format used in totals and subtotals.

Change:

1000 Separator Select the character to separate thousands (ie. select comma to have 1,000)
Decimal Separator Select the character to separate decimals (ie. select a period to have 200.05)




See also

File Preferences
Currency Format
Number Format
Sort Table
Network Version



Phone Dialer Setup command (Phone Dialer Options menu)
Use this command to setup the askSam phone dialer feature for your particular system.
Dialog Box Options

Modem Port
Select the proper modem port for your system

Dial Type

Select the proper dial type.

Tone Sets tone as the dial type. This is the default setting.
Pulse Sets pulse as the dial type.

Dialing Prefix
Type the long distance codes, international access number, or prefixes and suffices for outside lines that
must be added to the number you want to dial in the current file.

Add Adds the typed number to the end of the Dialing Prefix List.
Replace Replaces the selected item in the Dialing Prefix List with the item typed number.
Delete Deletes the selected item in the Dialing Prefix List.

Move to Top Moves the selected item in the Dialing Prefix List to the position immediately preceding
it.



Always on Top command (Options menu)

Use this command to keep the askSam window on top of the screen when you have several Windows
applications open at the same time.



Generate List (Auto Field Recognition)
This dialog displays a list of fields recognized in your file.

Selected Fields List of fields you choose to add to the Entry Form.
Available Fields List of possible fields found in the database.

Add Add a field from the Available list to the Selected List.

Add All Add all fields from Available List to the Selected List.

Replace Replace a field in the Selected List with a field from the Available List
Insert Insert a field from the Available List above a field in the Selected List

Remove Remove a field from the Selected List



Auto Field Recognition (Tools Menu)

Auto Field Recognition searches through an askSam file and displays a list of fields names. You choose
the valid field names from this list, and askSam inserts them into the Entry Form.

What Character Defines a Field
Enter the character which identifies fields in your file. This tells askSam that words ending with this
character may be fields.

List Field Recognized In

Choose the number of Documents askSam should scan looking for fields. If the fields in your file are the
same in all Documents, leave this option set for 2 Documents (it speeds up the process). If the field
structure varies in your Documents, choose the ALL DOCUMENTS option.

Generate List
This dialog displays a list of fields recognized in your file.

Selected Fields List of fields you decide to ad to the Entry Form.
Available Fields List of possible fields found in the database.

Add Add a field from the Available list to the Selected List.
Add All Add all fields from Available List to the Selected List.
Replace Replace a field in the Selected List with a field from the Available List
Insert Insert a field from the Available List above a field in the Selected List

Remove Remove a field from the Selected List



Spelling (Tools Menu)
Spell Check an Existing Document
Shortcut

Keys F7

RE!
Toolbar:u
To Spell Check an Existing Document:
Go to the Document you want to Spell Check. If you don't want to Spell Check the entire Document,
select the text you want checked. askSam will begin checking the spelling in your Document. If askSam
encounters a word it does not recognize, the Spelling Dialog Box will appear.

Spelling Dialog Options

Not In Dictionary Highlighted word was not found in thedictionary. Options follow.

Change To word entered here will be replaced over incorrect word

Suggestions a list of similar spelled words that serve as corrections to the incorrect word

Change Changes the spelling of the unrecognized word to the alternative that askSam
suggests or to an alternative that you enter.

Ignore Ignores this word (in this instance and any other instances encountered in this
Document) and continues with the Spell Check.

Add To Dict Adds the unrecognized word to your User Dictionary. When a word is added to the

User Dictionary, it will no longer be displayed as an incorrect spelling.

After askSam completes the spell check, a message will appear stating how many words were checked
and how many were spelled incorrectly.

See also
Auto Spell Check



Auto Spell Check (Tools Menu)

If checked, askSam will check your spelling as you type.

See also
Spelling



Print Mail Merge (Tools Menu)
Printing A Mail Merge Letter

Dialog Options

Selection

If you only want to send letters to a selected group of addresses. The Multiple Search dialog will appear.
Enter a Search request to select the addresses for this letter and choose OK.

Sort
If you want the letters in a particular order. The sort dialog will appear. Define a sort order and choose
OK.

Print the letter
Highlight a letter to Print and choose OK to view the letters.

See also

Create/Edit Mail Merge Letter
View Mail Merge



View Mail Merge (Tools Menu)
Previewing A Mail Merge Letter

Dialog Options

Selection

If you only want to send letters to a selected group of addresses. The Multiple Search dialog will appear.
Enter a Search request to select the addresses for this letter and choose OK.

Sort
If you want the letters in a particular order. The sort dialog will appear. Define a sort order and choose
OK.

View the letter
Highlight a letter to view and choose OK to view the letters.

NOTE: It may take a considerable amount of time to output all the letters to your screen. Often it makes
more sense to enter a restricted Selection criteria and preview only several letters.

See also

Create/Edit Mail Merge Letter
Print Mail Merge



Create/Edit Mail Merge Letter (Tools Menu)

Mail Merge allows you to choose a group of addresses (or other data) and merge it into a letter. For
each address selected, a letter is printed. In this way, Mail Merge automates the creation of customized
letters.

Create/Edit Mail Merge Letter (Tools Menu)

Enter a name for your Mail Merge Report and choose OK.

The askSam Report Layout Editor will appear.

Type your Letter. Drag fields from the Field List and place them in the appropriate positions in your letter.
(Field names can also be typed directly into the Letter).

NOTE: You can also use the Windows' Clipboard to paste a Letter from another askSam file or another
application.

Edit Letter

Select a previously entered Mail Merge Report and choose OK

The askSam Report Layout Editor will appear including the information from the selected mail merge.
Make desired corrections.

View Mail Merge (Tools Menu)

Previewing A Mail Merge Letter

Selection

If you only want to send letters to a selected group of addresses. The Multiple Search dialog will appear.
Enter a Search request to select the addresses for this letter and choose OK.

Sort

If you want the letters in a particular order. The sort dialog will appear. Define a sort order and choose
OK.

View the letter

Highlight a letter to view and choose OK to view the letters.

NOTE: It may take a considerable amount of time to output all the letters to your screen. Often it makes
more sense to enter a restricted Selection criteria and preview only several letters.

Print Mail Merge (Tools Menu)

Printing A Mail Merge Letter

Selection

If you only want to send letters to a selected group of addresses. The Multiple Search dialog will appear.
Enter a Search request to select the addresses for this letter and choose OK.

Sort

If you want the letters in a particular order. The sort dialog will appear. Define a sort order and choose
OK.

Print the letter

Highlight a letter to Print and choose OK to view the letters.

See also

View Mail Merge
Print Mail Merge



New Report command (Tools menu)
Use this command to create, layout, and run a Report in the current file in askSam.
Dialog Box Options

Report Name

Type or select the name for the report you want to create. The name can contain multiple words and
have a length of up to 80 characters. If you do not specify a name, askSam assigns the name Untitled
Report # to your Report.

Select the documents to include in your report
Select this Button to build a search request using the Multiple Search Request Dialog Box. See the
Multiple Search Request command (Actions menu) for more details about the Dialog Box.

Sort the documents to include in your report
Select this Button to Sort the documents that want included in your report using the Sort Dialog Box.
See the Sort command (Actions menu) for more details about the Sort Dialog Box.

Define the layout for your report

Select this Button to activate askSam's Report Layout Editor. From this Editor you can define the layout
of your Report. You can insert fields, define which fields will be totaled and grouped, as well as define
headers and footers.

ul
Place Field Selects a field and positions it in the Editor
Group Footer Add text to totals and subtotals from Total and Count commands.

=
Report Settings Defines settings specific to the current Report.
Coun

t Places the number of documents selected or grouped into your report.

Place Text Places text into your Report.

Spacing Defines the spacing method when placing fields in a Report.
+
Header Defines a header for the Report.

Footer - Defines a footer for the Report.

Reset Row Sets a Report up in multiple rows.

Close Closes the Report Layout Editor and lets you save or cancel your changes.

Run the current Report
Executes the Report settings defined for the current report.



Open/Edit Report command (Tools menu)
Use this command to edit, delete or run an existing report.
Dialog Box Options

Report Name
Type or select the name of the report you want to edit, delete, or run.

Selection

Select this Button to access the Multiple Search Request Dialog Box and edit the search criteria for the
designated report. See the Multiple Search Request (Actions menu) for more details about the Dialog
Box.

Sort
Select this Button to access the Sort Dialog Box and edit the Sort criteria for the designated report. See
the Sort command (Actions menu) for more details about the Dialog Box.

Edit Layout
Select this Button to edit the layout of the designated Report using the Report Layout Editor. See the
New Report command for more details about the Editor.

Run
Executes the Report as edited.

Delete
Removes the selected Report from the Report Name List.



Run Report (Tools menu)

Use this command to execute a specific Report in the current file.

Shortcut

Toolbar:

Dialog Box Options

Report Name
Type or select the report you want to execute.



Place Field command (Tools menu)
Use this command to select a field and position it in the Report Layout Editor.

Shortcut

Report Tools:

Dialog Box Options

Field Name
Type or select the name of the field you want to include in the Report.

Note: The list of field names displayed is generated from the fields listed in the Entry Form of the current
file. If no fields are displayed in the list, exit the Report Layout Editor and use the Entry Form command
(Edit menu) to enter the names of the fields in the current file.

Field Type

Defines the text in the specified field as single line or multiple line. The default setting is single line.

Single Line Outputs the text in a field until either askSam encounters the end of a line or a
field terminator character ("]").

Multi-line Outputs the text in a field until askSam encounters the designated field terminator

character. Enter the field terminator character you want to use.
Retain line breaks Outputs text in your multiple line field exactly as it is stored in your document

Column word wrap

Defines a column size for a field. This prevents the output of one field from overwriting the output of the
field that follows it. With the column size set, the contents of a field will wrap down to the next line if it
exceeds the column size.

Column Size Click the Box to define a column size. Enter the column size you want to use.

Actions

Groups, subtotals, and totals fields for inclusion in the Report.

Group Groups the text from the designated field. If the text is numeric, askSam calculates a subtotal
for the grouped field.

Total Totals the numeric text from the designated field.

Spacing

The fields you place using the Field Placement Dialog Box are output in the column where the first

letter of the field name is located. To place a field in a position relative to the preceding field use the

Spacing option.

Relative Spacing Click the Box to position a field relative to the preceding field in the Report layout.
Type or select the number of spaces you want to precede the designated field.

Options
Defines group and total modifiers for the Report.

Group Modifiers

Match Case Makes the grouping command case sensitive.
Last Word Groups and outputs only the last word in the designated field.
Date Specifies that the group field contains a date.

Blank Line between Groups Outputs a blank line between groups.
Page Break between Groups Outputs a page break between groups.



Field Length Lets you define the number of characters to group and output in your
report. The default value is 40.

Total Modifiers

Total with Commas Defines how the totaled value will be output. Without the total modifier
activated, one thousand is formatted as 1000.00. With the total modifier
activated, one thousand is formatted as 1,000.00.

Total with $s and commas Defines how the totaled value will be output. Without the total modifier
activated, one thousand dollars is formatted as 1000.00. With the total
modifier activated,one thousand dollars is formatted as $1,000.00.

Decimal Places Defines how many decimal places will output after a number. You can
choose between 0 and 9.



Group Footer command (Report Tools menu)

Use this command to add text to totals and subtotals from the Total in the Place Field Dialog Box and
the Count Documents command. You must be either creating or editing the layout of a Report.

Shortcut

Report Tools:
Dialog Box Options
Group Level
Type the group level that you want to include a group footer. Each group sort is a group level, the first

sort being the first level

Footer Text
Type the text of the footer that you want to include.



Report Settings command (Tools menu)

Shortcut

Report Tools:

Use this command to define whether the report will be case sensitive, will output the field names, output
more than one occurrence of the field in a document, and include an output separator.

Dialog Box Options

Match Case
Defines the selection made for the Report is case sensitive.

Output Field Names
Outputs the field name along with the contents of the field when you run the Report.

Output All Occurrences of a field
Outputs all occurrences of a field in a document. The default setting is to output only the first
occurrence of a field in a document.

Field Character
Defines per Report what character designates a field. Enter the character you want to use as the field
designator.

Set Output Separator
Defines a separator that will be output between documents. See the Output Separator command
(Options menu) for more details about the Output Separator Dialog Box.



Count Documents command (Tools menu)

Use this command to count the number of documents selected in a grouping. You must be in the
Report Layout Editor creating or editing a report layout.



Place Text command (Tools menu)
Use this command to place text into your Report.
Dialog Box Option

Text
Type the text you want to enter into the Report.



Spacing command (Tools menu)
Use this command to define the spacing method when placing fields in the Report.
Dialog Box Options

The fields you place using the Field Placement Dialog Box are output in the column where the first
letter of the field name is located. To place a field in a position relative to the preceding field use the
Spacing option.

Relative Spacing Click the Box to position a field relative to the preceding field in the Report
layout. Type or select the number of spaces you want to precede the
designated field.

Peceded w/a comma Click the Box if you want a comma to precede the designated field.



Header command (Tools menu)

Use this command to include a Header at the top of every page in the Report (titles, column headings,
page numbers, dates or any other information you want repeated on every page).

Shortcut

o
Report Tools:

Dialog Box Options

Header Icons options
Inserts the code command to execute a specific header function in the Report.
Inserts the current system date code in the Header text list to automatically stamp the current date in the
Header.

)
Inserts the current system time code in the Header text list to automatically stamp the current time in the
Header.

(B«
Inserts the total number of pages output code in the Header text list to automatically stamp the total
number of pages in Header.
Inserts the name of the current askSam file code in the Header text list to automatically stamp the current
askSam file name in the Header.
Inserts the name and path of the current askSam file code in the Header text list to automatically stamp
the name and path of the current askSam file in the Header..

Inserts the page number code in the Header text list to automatically stamp the page number in the
Header.

W
Inserts the center code in the Header text list to automatically center the Header between the left and

rii ht margins of the Report.
Inserts the left align code in the Header text list to automatically align the Header on the left

margin of the Report. This is the default setting.

W
Inserts the right align code in the Header text list to automatically align the Header on the right margin of
the Report.

Header Text List

Type the text you want to include in the Header. Click an icon (described above) to include the code
commands to automatically stamp information in the Header. Press Ctrl+Enter to move to the next line
in the Header text list.






Footer command (Tools menu)

Use this command to include a Footer at the bottom of every page in the Report (titles, column
headings, page numbers, dates or any other information you want repeated on every page).

Shortcut

Report Tools:
Dialog Box Options

Footer Icons
Inserts the code command to execute a specific Footer function in the Report.
Inserts the current system date code in the Footer text list to automatically stamp the current date in the
Footer.

)
Inserts the current system time code in the Footer text list to automatically stamp the current time in the
Footer.

(B«
Inserts the total number of pages output code in the Footer text list to automatically stamp the total
number of pages output in the Footer.
Inserts the name of the current askSam file code in the Footer text list to automatically stamp the name of
the current askSam file in the Footer.
Inserts the name and path of the current askSam file code in the Footer text list to automatically stamp
the name and path of the current askSam file in the Footer.

Inserts the page number code in the Footer text list to automatically stamp the page number of the Report
in the Footer.

W
Inserts the center code in the Footer text list to automatically center the Footer between the left and right
margins of the Report.
Inserts the left align code in the Footer text list to automatically align the Footer on the left margin of the
Report. This is the default setting.

)
Inserts the right align code in the Footer text list to automatically align the Footer on the right margin of
the Report.

Footer Text List

Type the text you want to include in the Footer. Click an icon (described above) to include the code
commands to automatically stamp information in the Footer. Press Ctrl+Enter to move to the next line
in the Footer Text List.



Reset Row command (Tools menu)

Use this command to set up a Report in multiple columns. This command is most commonly used
when you want to create 3 Wide Labels.

Shortcut

Report Tool Bar:



Tile command (Window menu)

When you open several askSam file windows at a time, some windows are hidden beneath others. Use
this command to rearrange all the open askSam file windows so that part of each window is visible.



Cascade command (Window menu)

When you open several askSam file windows at a time, some windows are hidden beneath others. Use
this command to rearrange all the open askSam file windows so that part of each window is visible.



Arrange lcons command (Window menu)

When you minimize an askSam open file window, it becomes an icon. Use this command to arrange
the icons in an order.



Close All command (Window menu)

Use this command to close all open askSam file windows.



Contents command (Help menu)

Use this command to display the opening screen of Help. From the opening screen, you can jump to
various reference information and to step-by-step instructions for using askSam.

Once you open Help, you can click the first button on the left in the Help window whenever you want to
return to the opening screen.

See Contents for askSam for Windows Help.



How to use Help command (Help menu)

Use this command to display an introduction to using Help. From this screen, you can jump to various
reference information and to step-by-step How to instructions for using Help.



Search for Help command (Help menu)

Use this command to enter a topic and search for specific relevant information in Help.



Keys Help (Help menu)
Use this command to display a listing and description of the keyboard shortcuts for askSam.

Keyboard Shortcuts

File Keys

Ctrl+N Create New File
Ctrl+O Open a File
Ctrl+F4 Close a File
Ctrl+S Save a File
Ctrl+P Print

Alt+F4 Exit askSam
Edit Keys

Ctrl+zZ Undelete

Ctrl+X Cut

Ctrl+C Copy

Ctrl+V Paste

Shift+F3 Eind

F3 Repeat Last Find
Ctrl+D Stamp Date
Ctrl+T Stamp Time
View Keys

Alt+PgDn Next Document
Alt+PgUp Previous Document
Alt+Home First Document
Alt+End Last Document
Ctrl+F2 View Bookmark

Ctrl+Enter View Hypertext Link

Actions Keys

Ctrl+Y Hypertext Search

Ctrl+F Hypertext Search On File
Document Keys

Ctrl+A Add a Document

F5 Add a Document with Entry Form
Ctrl+E Toggle Data Entry Mode
Ctrl+Q Tag Document

F2 Set Bookmark

F4 Set Hypertext Link
Format Keys

Ctrl+B Bold

Ctrl+l Italic

Ctrl+U Underline

Ctrl+K Strikeout

Ctrl+G Repaginate

Tools Keys

Ctrl+R Run Report

Ctrl+S Close Report

Alt+P Place Field



F7 Spelling

Ctrl+W Dial Phone Number
Help Keys
F1 Help

Shift+F1 Context Sensitive Help



Help Mode command (Help menu)

Use this command to activate the askSam context sensitive Help mode.  Once activated, clicking on
an icon or any other part of the askSam screen accesses Help for that item.

Shortcut

Toolbar:



About askSam command (Help menu)

Displays the version number and other information about askSam.




Add Information (Step-by-Step Instructions)

Creating a New askSam File

Creating a New askSam File with an Entry Form

Adding a Document to an askSam File

Adding Document to an askSam File with an Entry Form
Adding a Document with Data Entry Mode



Creating a New askSam File (Add Information Step-by-step
Instruction)

You can create an empty file with no structure, or you can create a file patterned after an existing File
Template.

Note: askSam comes with standard templates for a variety of tasks -- contact management, writing
faxes, clippings, a calendar file. New templates will continually be added and existing ones updated. The
README file contains an up-to-date list of the templates and a brief description of each.

To create an empty file with no structure
From the File menu, choose New (Ctrl+N).

Shortcut
Toolbar:

New File Dialog Box

Create an Empty File:
1. Choose FILE -> NEW (or press CTRL+N).
2. The NEW FILE Dialog Box will appear.
3. Enter a name for the file you are creating.
4. Choose OK.

Your screen will clear and you will be in an empty document. You can now either:

1. Immediately begin typing the information in the first document;
2. Import information into the file;
3. Design an Entry Form for the documents you want to enter in this file.

Create a New File from an Existing Template:

1. Choose FILE -> NEW (or press CTRL+N).

2. The NEW FILE Dialog Box will appear.

3. Enter a name for the file you are creating.

4. Choose the Template that best suits your needs in the USE TEMPLATE field.

5. Choose OK.

6. askSam will create a new file containing the settings from the Template you selected.

Your screen will clear and you will be looking at the first screen of the new document. On the first screen
will be instructions on how to use this file, its Entry Form and reports. This docment may be deleted at
any time. Press F5 to add a new document with the exsisting Entry Form.

See also
Create a New File with an Entry Form



Create a New File with an Entry Form (Add Information Step-by-step
Instruction)

You can create an empty file and define a customized structure for the documents you enter in the file
with an Entry Form. askSam allows only one Entry Form per file.

Shortcut
Toolbar:

Creating a New File:
1. Choose FILE -> NEW (or press CTRL+N).
2. The NEW FILE Dialog Box will appear.
3. Enter a name for the file you are creating.
4. Choose OK.

Your screen will clear and you will be in an empty document. You can now either:

1. Immediately begin typing the information in the first document;
2. Import information into the file;
3. Design an Entry Form for the documents you want to enter into this file.

To Create an Entry Form

1. From the Edit menu, choose Entry Form. This activates the Entry Form Editor. askSam brings up an
empty document to the screen.

2. Type the fields and text you want to include in the Entry Form. The standard features of the askSam
Word Processor are available.

3. From the Edit menu, choose Entry Form to save the Entry Form you just created. A message will
appear asking you if you want to save your changes.

4. Choose Yes.

Your Entry Form is saved and you will return to the first document in the file. To enter a document with

the Entry Form, press F5 (or from the Toolbar choose ).

To Edit an Entry Form
1. Open the file containing the Entry Form you want to edit
2. From the Edit menu, choose Entry Form. The Entry Form Editor is activated. The Entry Form appears
on the screen.
3. Edit the Entry Form as you want it to appear.
4. From the Edit menu, choose Entry Form to save the changes to the Entry Form.

askSam brings you back to the first document in the file.

See Also
Creating a New askSam File



Adding a Document to an askSam File (Add Information Step-by-step
Instruction)

You can add a new document to a file without structure, or add a new document to a file with a File Entry
Form.

To add a document to a file without structure

1. Open the file into which you want to add information. (See Open command (File menu). The first
document in the file appears on the screen.

2. From the Document menu, choose Add (Ctrl+A). A blank document will appear on the screen. Enter
the information you want included in the document.

Shortcut

Toolbar:

To add a document to a file with an File Entry Form.
1. Open the file into which you want to add information. See Open command (File menu). The first
document in the file appears on the screen.
2. From the Document menu, choose Add w/Entry Form (F5). A new document will appear on the
screen overlaid with the Entry Form. Enter the information you want to include in the document.

Shortcut

=
Toolbar: B!

Note: To save the document, from the File menu, choose Save (Ctrl+S). From the Toolbar, you can
click (icon).



Adding a Document to a File w/Entry Form (Add Information Step-by-
step Instruction)

You can add a new document with an Entry Form to a file.

1. Open the file into which you want to add information. (See Open command (File menu). The first
document in the file appears on the screen.

2. From the Document menu, choose Add w/Entry Form (F5). A document will appear on the screen
overlaid with the Entry Form. Enter the information you want included in the document.

Shortcut

=
Toolbar:

Note: To restrict the area on the screen that you can edit and prevent the overwriting of fields, add
information in Data Entry Mode.



Adding a Document in Data Entry Mode (Add Information Step-by-
step Instruction)

The Data Entry Mode is designed to simplify the entry of structured data by restricting the area on the
screen where you can edit. Data Entry Mode is only useful when activated in conjunction with an Entry
Form. When Data Entry Mode is activated, the word DATA appears in the Status Bar.

To activate Data Entry Mode
From the Document menu, choose Data Entry (Ctrl+E). The Data Entry Mode is activated, and the word
DATA appears in the Status Bar.

Note: To deactivate Data Entry Mode, choose Data Entry from the Document menu. The word DATA
will disappear from the Status Bar.

Data Entry Mode Restrictions

1. You can only enter data into Entry Form fields - the area between the beginning and closing brackets,
Example: ZIPCODE[ ] Here you would only be permitted to type between the brackets
(LD

2. If no closing bracket is used in the field, the text will not wrap to the next line, but continue past the
right margin. Place a closing bracket in a line following the field (before the next text or field) and
your text will wrap.

To Add a Document in Data Entry Mode

1. Open the file into which you want to add information. (See Open command (File menu). The first
document in the file appears on the screen.

2. From the Document menu, choose Data Entry (Ctrl+E). The Data Entry Mode is activated. DATA
appears in the Status Bar. Note: The Data Entry setting is stored with your file. Once you activate
Data Entry Mode the first time, your file remains in Data Entry Mode until you turn it off.

3. From the Document menu, choose Add w/Entry Form (F5). An Entry Form will appear with the cursor
in the first field position. Enter the information for the first field

4. Press Enter or Tab to move to the next field. Press Shift+Tab to return to the previous field.

Note: In certain cases you may want to switch to and from Data Entry Mode. For example, if you want
to add a field, or delete a field, you can switch off Data Entry Mode, modify the Entry Form, and then
switch Data Entry Mode back on again.

To quickly toggle the Data Entry Mode On and Off, press Ctrl+E.



Defining an Entry Form (Step-by-step Instruction)

You can create a customized data Entry Form to define structure for the documents you enter in a file in
askSam. Defining an Entry Form also assist you in organizing your information and simplifies data
entry. askSam is a very open information management system -- you can vary the degree of structure
from file to file or from document to document. Fixed field positions or predefined field lengths are not
required.

To define an Entry Form for the file

1. Open the file in which you want to create an Entry Form, see Open command (File menu).

2. From the File menu, choose Save (the Save Dialog Box will appear).

3. Type or select the name of the file you want to save.

4. Select the format of the file you want to save. Click the down arrow to view the available file formats.

5. Select the directory in which you want to store the file.

6. Select the drive in which you want to store the file.

7. Choose OK, and askSam returns you to your file.

8. From the Edit menu, choose Entry Form. This activates the Entry Form Editor. askSam brings up an
empty document to the screen.

9. Type the fields and text you want to include in the Entry Form. The standard features of the askSam

Word Processor are available.

10. From the Edit menu, choose Entry Form to save the Entry Form you just created. A message will
appear asking you if you want to save your changes.

11. Choose Yes.

Your Entry Form is saved and you will return to the first document in the file. To enter a document with
the Entry Form, press F5.

Note: To Edit an Entry Form

1. Open the file containing the Entry Form you want to edit

2. From the Edit menu, choose Entry Form. The Entry Form Editor is activated. The Entry Form appears
on the screen.

3. Edit the Entry Form as want it to appear.

4. From the Edit menu, choose Entry Form to save the changes to the Entry Form.

askSam brings you back to the first document in the file.



Export Information (Step-by-step Instruction)

You can export information in a variety of formats. Unstructured information can be exported as text or
RTF files. Structured information can be exported for use with other databases or for mail merge with
word processors (using the CSV format).

To export from askSam

1. Open the file containing the information you want to export. See the Open command (File menu).
2. From the File menu, choose Export. A Sub-menu is displayed.

-- To export the current document, choose Current Document.

-- To export the current file, choose Entire File.

-- To export the tagged document, choose Tagged Document.

-- To export a selected document, choose Select Document(s).

-- To export a report, choose Report.

Exporting the Current Document Dialog Box Options

File Name
Type or select the name of the file into which you want the document exported.

File Type

Select the format of the document you want to export. Click the down arrow to view the available file

formats.

Text Files (*. TXT)ASCII text file.

askSam DOS (*.TXT)Format for exchanging data between the DOS and Windows
versions of askSam. It is also useful for transferring information between
askSam for Windows files. This format retains the Document boundaries
between askSam Documents.

askSam for Windows (*.ASK)Creates a new .ASK file from the Exported information.

Comma Separated Values (*.TXT)Comma separated values can be used to Export data for Mail
Merge with a word processor or for use with most database programs.

RTF Files (*.RTF)RTF files can be used to exchange formatted information
(including .BMP Graphics.)
Tab Delimited (*.TXT)Data separated by tabs. Use this format to export data for Mail

Merge with a word processor or for use with most database programs.
Word for Windows 6.0 (*.DOC)Microsoft Word for Windows version 6 with formatting.
WordPerfect 6.0 (*.DOC)WordPerfect version 6 with formatting.

Directories
Select the directory into which you want to export the document.

Drives
Select the drive into which you want to export the document.

Set Options - Document Delimiter
Use this option to define a document delimiter.

No Delimiter Exports the file without inserting a delimiter between Documents. This is the Default
Setting.

Blank Line Inserts a Blank Line after each Document that is Exported.

Page Break Outputs a Page Break after each Exported Document. If you are exporting to TXT an
ASCII 12 character is used as the page break character.

String Allows you to define a character string to output as a delimiter between Documents.



Entire File Dialog Box Options
(See above)

Tagged Document Dialog Box Options
(See above)

Report Dialog Box Options
Report Name

Type or select the name of the report you want to run. The Run Dialog Box will appear. See Run
Report (Tools Menu).



Using Graphics and OLE (Step-by-step Instruction)

While askSam cannot create Graphics, it does allow you to insert graphics into your askSam
documents.  There are two methods for inserting Graphics:

-- Pasting graphics from the Clipboard

-- Using OLE (Object Linking and Embedding).

Pasting a Graphic Using the Clipboard

Since askSam doesn't create Graphics, you must copy your graphics from another program to the
Windows Clipboard and then Paste them into askSam. You can Paste these Graphics directly into
documents and Entry Forms.

To Paste a Graphic Using the Clipboard

. Go to the application that contains the Graphic you want to copy into the document or Entry Form.

. Use the mouse or cursor to Select the Graphic.

. From the Edit menu, choose Copy in the application.

. Go to askSam.

. Open the file containing the document or Entry Form into which you want to insert the Graphic. See
the Open command (File menu).

. Make the document into which you want to insert the Graphic the current document. See Searching.

. Position the cursor where you want to insert the Graphic.
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8. From the Edit menu, choose Paste (Ctrl+V or ). The Graphic is inserted at the cursor position.

To Deleting a Graphic

1. Go to the document containing the Graphic you want to delete.

2. Use the cursor keys or the mouse to Select the graphic. See Selecting Text (Word Processing).
3. From the Edit menu, choose Delete (Del). The Graphic is deleted.

OLE (Object Linking and Embedding)

OLE (Object Linking and Embedding) allows you to insert objects from other applications into your
information. Graphics, sounds, video clips, or worksheets can be inserted into your information and yet
still retain their connection to the application in which they were created.

What is OLE?

OLE is made up of two components: Object Linking and Object Embedding. Both allow you to insert
objects into an askSam document, but they do it in different ways.

When you Link an object, the object is stored in the application where it was created. askSam creates a
link to this object within your document. Any change made to the object in the source file is reflected in
the object in askSam.

When an object is Embedded, the object is actually stored in your askSam document. To edit this
object, you can Double Click on it in askSam and start the application in which it was created.

Various applications handle OLE in different ways. Some applications act as "OLE Servers", providing
objects to other applications. Other applications act as "OLE Clients", storing the objects from the
Servers. askSam acts as an OLE Client.

To Insert a Linked Object
1. Start the Server Application and create or open the Object you wish to insert into askSam.
2. Select the object in the Server Application.



3. From the Edit menu in the Server Application, choose Copy. The Selected object is copied to the
Clipboard.

4. Switch from the Server Application to askSam.

5. Open the file containing the document or Entry Form into which you want to insert the Graphic. See
the Open command (File menu).

6. Make the document into which you want to insert the Graphic the current document. See Searching.

7. From the Edit menu, choose Paste Link. The object is inserted, and a link is created between the
object and the Server Application.

To Edit a Linked Object

1. Open the file containing the graphic to edit. See the Open command (File menu).

2. Make the document, containing the Graphic to edit, the current document. See Searching.

3. Select the object you want to edit. See Selecting Text (Using the Word Processor).

4. From the Edit menu, choose Edit xxxx Object ("xxxx" represents the name of the Server Application
linked to this object). With a mouse, you can Double Click on the object. The Server Application is
started.

. Edit the object using the features of the Server Application.

. From the File menu of the Server Application, choose Save.

. From the File menu of the Server Application, choose Exit. The askSam document is displayed with
the object edited.
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To Break a Link

1. Open the file containing the graphic to edit. See the Open command (File menu).

2. Make the document, containing the graphic to edit, the current document. See Searching.

3. From the Edit menu, choose Links. See the Links command (Edit menu). The Links Dialog Box
appears.

4. Type or select the Link you want to break.

5. Choose the Cancel Link Button.

6. Choose OK. The object remains in the document, but the link to the Server Application is canceled.

To Delete a Object and a Link

1. Go to the document containing the linked object you want to delete.

2. Use the cursor keys or the mouse to Select the object. See Selecting Text (Word Processing).
3. From the Edit menu, choose Delete (Del). The object and the link are deleted.

To Embed an Object

1. Start the Server Application and create or open the Object you wish to insert into askSam.

2. Select the object in the Server Application.

3. From the Edit menu in the Server Application, choose Copy. The Selected object is copied to the
Clipboard.

4. Switch from the Server Application to askSam.

5. Open the file containing the document or Entry Form into which you want to insert the Graphic. See
the Open command (File menu).

6. Make the document into which you want to insert the Graphic the current document. See Searching.

7. Position the cursor at the position you want the object embedded in the document.

8. From the Edit menu, choose Paste Special. See the Paste Special command (Edit menu). The
Paste Special Dialog Box appears.

9. Choose the Paste Button. The object is embedded in the document at the cursor position.

To Edit an Embedded Object

1. Open the file containing the embeeded object you wish to edit. See the Open command (File menu).

2. Make the document, containing the embedded object to edit, the current document. See Searching.

3. Select the object you want to edit. See Selecting Text (Using the Word Processor).

4. From the Edit menu, choose Edit xxxx Object ("xxxx" represents the name of the Server Application
linked to this object). With a mouse, you can Double Click on the object. The Server Application is



started.
5. Edit the object using the features of the Server Application.
6. From the File menu of the Server Application, choose File Update.

7. From the File menu of the Server Application, choose Exit. The askSam document is displayed with
the object edited.



Importing Information (Step-by-step Instruction)

You can import information in a variety of formats. Unstructured information can be imported as text or
RTF files. Structured information can be imported from other databases or from word processors.

To import from askSam
1. Open the file where you want to import the information. See the Open command (File menu) or

.—|
choose button on the toolbar.
3|
From the File menu, choose Import, or from the toolbar.

Dialog Box Options

File Name
Type or select the name of the file you want to import.

File Type

Select the format of the file you want to import. Click the down arrow to view the available file formats.

Text Only (*.TXT)ASCI! text files. Imported without word wrap or tabs

Text Formatted (*. TXT)ASCII text files. Imported with word wrap and tabs.

askSam DOS (*.TXT)Format for exchanging data between the DOS and Windows
versions of askSam. Also useful for transferring information between
askSam for Windows files. This format retains Document Boundaries
between askSam Documents.

CompuServe Information Manager Files from the CompuServe Information Manager -
* ART, *.MSG, *.NWS, *.PLX, *.THD.

Comma Separated (*.TXT) Data separated by commas. Use this format to import data from
spreadsheets and other databases.

dBASE Files (*.DBF)dBASE llI, lll+ and IV files. This format allows the Importing of
structured information from dBASE compatible databases (including FoxPro
and Clipper). It also imports memo fields associated with these databases.

Fixed Position (*.TXT) Data stored in fixed column positions. Use this format to import data
from spreadsheets and other databases.

Lexis/Nexis (*.TXT) Files from Mead Data's On-Line systems Nexis (news articles) and
Lexis (legal rulings)

RTF Files (*.RTF)Rich Text Format files used to exchange formatted information
(including .BMP Graphics.)

Tab Delimited (*.TXT)Data separated by tabs. Use this format to import data from

spreadsheets and other databases.
Word for Windows (6.0) (*.DOC)Microsoft Word for Windows 6 files with formatting.

WordPerfect 5.X (*.*)WordPerfect version 5 files with formatting.
WordPerfect 6.0 (*.WPD)WordPerfect version 6 files with formatting.
Directories

Select the directory from which you want to import the file.

Drives
Select the drive from which you want to import the file.

Select all
Click on this option to import all the files of the specified type and in the specified location.

Set Options



Use this option to define a document delimiter and location within your askSam file.

Append Location Adds the imported text to a specified location within your askSam file.

End of File Adds the imported text to the end of the current file.

End of Current Document Adds the imported text to the end of the current document.

After Current Document Adds the imported text in a new document inserted located directly after
the current document in the current file.

After Tagged Document Adds the imported text in a new document located directly after the
tagged document in the current file.

Automatic Field Recognition

Auto Field Recognition recognizes fields in imported information. In the Import Dialog Box choose the
SET OPTIONS button and select the Auto Field Recognition option. Field Recognition takes place
immediately after your import is complete. You can also access Auto Field Recognition by choosing
TOOLS -> AUTO FIELD RECOGNITION.

Document Delimiter

Sets the delimiter for the imported text.

No Delimiter The entire file you import is stored in askSam as a single document.

Blank Line Each time askSam encounters a blank line in the imported text, a new askSam
document is created for the next block of imported text.

Character(s) Allows you to define one or two characters which askSam will use as a delimiter to
separate imported text into multiple documents.

Page Break Divides the file you import into askSam Documents wherever hard page breaks are

encountered.

Lines Lets you specify a number of lines as a delimiter. askSam creates a new Document each
time the specified number of lines is imported.

String Allows you to enter a string of characters which askSam will use to separate imported

information into multiple Documents. The character string can contain 256 characters.
Pressing ENTER inserts a CR/LF (carriage return / line feed) into the string. The Remove
Delimiter String option lets you remove the Delimiter String from the imported information



Create Mailing Labels (Step-by-step Instruction)
You can use the askSam Report Writer to design Mailing Labels which meet a variety of specifications.

To Print Continuous Labels

1. Open the file containing the addresses you want to include on the labels. See the Open command
(File menu).

2. From the Tools Menu, choose New Report.

New Report Dialog Box Options

Report Name

Type or select the name for the report you want to create. The name can contain multiple words and
have a length of up to 80 characters. If you do not specify a name, askSam assigns the name Untitled
Report # to your Report.

Select the documents to include in your report
Select this Button to build a search request using the Multiple Search Request Dialog Box. See the
Multiple Search Request command (Actions menu) for more details about the Dialog Box.

Sort the documents to include in your report
Select this Button to Sort the documents that want included in your report using the Sort Dialog Box.
See the Sort command (Actions menu) for more details about the Sort Dialog Box.

Define the layout for your report

Select this Button to activate askSam's Report Layout Editor. From this Editor you can define the layout
of your Report. You can insert fields, define which fields will be totaled and grouped, as well as define
headers and footers.

=

Place Field Selects a field and positions it in the Editor

Group Footer Add text to totals and subtotals from Total and Count commands.
Report Settings Defines settings specific to the current Report.

3
Count Places the number of documents selected or grouped into your report.

B .
Place Text Places text into your Report.

3
Spacing Defines the spacing method when placing fields in a Report.
=
Header Defines a header for the Report.

3
Footer Defines a footer for the Report.
&
Reset Row Sets a Report up in multiple rows.

3
Close Closes the Report Layout Editor and lets you save or cancel your changes.

Field List
Drag and drop fields fom this list and drop them into the label.

Example:

Name[

Company]
Address1]
Address2|



City[ "0, M State[ A2 Zip]

©ooNDO AW

From the Tools Menu, choose Report Settings. See the Report Settings command (Tools Menu).
Select the Output Separator Button.

In the Dialog Separator Dialog Box, select the Page Break between Docs option.

Choose OK.

Choose OK to exit the Report Settings Dialog Box and return to the Report Layout Editor.

From the Tools Menu, choose New Report. Choose Yes to save the report.

From the File menu, choose Page Setup. See the Page Setup command (File menu). Select the
File Settings option. Set the appropriate margins.

From the File menu, choose Print. See Print command (File menu). Select the Report option.
Type or select the name of the Report name.

To Print 3 Wide Labels

1
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From the Options menu, choose Word Wrap. This turns askSam's Word Wrap function Off (3 Wide
Labels require using the entire page width).

. Open the file containing the addresses you want to include on the labels. See the Open command

(File menu).

. From the Tools Menu, choose New Report (See above for description of Dialog Box Options).
. Type the name for your labels report.

. Choose the Select Button, enter a search request for the desired addresses, and choose OK.
. Choose the Sort Button, enter your sort request, and choose OK.

. Choose the Layout Design Button.

. Place the fields for your labels (start at column 1 row 1). Example

Name[

Company][

Address1]

Address2|

City[ *0, M State[ 2 Zip[

9.

10.

11.

12.

13.
14.
15.
16.

17.
18.
19.
20.

From the Tools Menu, choose Reset Row. askSam will return you to the Report Layout Editor. With
a Mouse, position the crosshair cursor after the last field (Zip[ in the example above) and click the
left mouse Button. With the Keyboard, Use the cursor keys, Space key, and the Enter key to
position the cursor after the last field (Zip[ in the example above). Press Ctrl+Enter to insert the
Reset Row Command. The Reset Row command,*R , is inserted in your report.

Place the fields for the second column of labels in the line under the Reset Row command, *R.
Make sure that you place the fields in the proper column (for standard 3 Wide Labels on a laser
printer, place your fields in column 36).

Repeat steps 3 through 5 for 3 Wide Labels (place your fields for the third column in column 71 if
you are using standard 3 Wide Labels).

From the Tools Menu, choose Report Settings and select the Set Output Separator Button. See
Report Settings command (Tools Menu). Select the Lines between Docs Button. Type or select 2
lines between each document. (The number of lines you set is determined by the number of lines
in your address. For standard 3 wide Labels on a laser printer, the number of lines in the address
plus the number of lines skipped must equal 7).

Choose OK to accept the Output Separator settings.

Choose OK to exit the Report Settings Dialog Box.

From the Tools Menu, choose New Report. Select the Yes Button to save the Report.

Before printing the labels, choose Page Setup from the File menu. See the Page Setup command
(File menu).

Select the File Settings Option.

Set the left, right, top, and bottom margins to 0.

From the File menu, choose Print. See the Print command (File menu). Select the Report option.
Type or select the 3 Wide Label Report name.






Creating Mail Merge Letters (Step-by-step Instruction)

You can use the askSam Mail Merge function to merge askSam database fields with a letter. For each
document selected, a letter is created, automating the creation of custom letters.

To Create a Mail Merge Letter
1. Open the file containihe fields you want to merge into a letter. See the Open command (File

2]
menu) or choose the . button from the toolbar.
2. From the Tools menu, choose Create/Edit Mail Merge Letter.

Create/Edit Mail Merge Dialog Box Options

Letter Name

Type or select the name for the report you want to create or edit. The name can contain
multiple words. If you do not specify a name, askSam assigns the name Untitled Mail
Merge # to your Report.

Choose OK.

You will now have a chance to write (or edit) your Mail Merge Letter. For more help on the
askSam report layout feature see: Reports.

Following is an Example:
Name][

Company]

Address|

City[ 20, M State[ 22 Zip[

Dear Salutation[ 20,

We would like to remind you that your account with us is past due. Please transfer
payment of Amount[ *2 immediately.

Thank you.

Miles Lowther

Note: You can also use the Windows' Clipboard to paste in a letter from another
askSam file or another application.

When you have completed your letter select TOOLS -> CLOSE REPORT. Choose OK at the Save
dialog. Your Mail Merge letter is now saved under the name given in the beginning of this procedure.

View Mail Merge Letter
Previewing A Mail Merge Letter

Dialog Options
Selection

If you only want to send letters to a selected group of addresses. The Multiple Search dialog will appear.
Enter a Search request to select the addresses for this letter and choose OK.



Sort
If you want the letters in a particular order. The sort dialog will appear. Define a sort order and choose
OK.

View the letter
Highlight a letter to view and choose OK to view the letters.

NOTE: It may take a considerable amount of time to output all the letters to your screen. Often it makes
more sense to enter a restricted Selection criteria and preview only several letters.

Print Mail Merge Letter
Printing A Mail Merge Letter

Dialog Options
Selection

If you only want to send letters to a selected group of addresses. The Multiple Search dialog will appear.
Enter a Search request to select the addresses for this letter and choose OK.

Sort
If you want the letters in a particular order. The sort dialog will appear. Define a sort order and choose
OK.

Print the letter
Highlight a letter to Print and choose OK to view the letters.



Reports (Step-by-step Instruction)

Creating a New Report

Creating a New Report from an Existing Report
Editing an Existing Report

Printing a Report



Creating a New Report (Reports Step-by-step Instruction)

You can use the askSam Report Writer to view information from multiple documents in a file in an
organized and summarized manner. The Report Writer also allows you to store frequently used
searches and requests.

Before you create a report, you need to know the purpose of the report. Are you saving a search
request? Creating a sorted list? Totaling and tallying data?

The Purpose of the Report determines:

A. What documents you select to include in your Report
B. How these documents are sorted

C. What fields are included in the Report

D. How the Report is laid out

Once you know this information, creating, editing, and running a report is simple.
To Create a New Report

Reports are created with the New Report command (Tools Menu). This New Report Dialog Box allows
you to execute the steps necessary to create a report:

1. Selecting documents to include in the Report

2. Sorting the documents

3. Defining a layout for the Report.

A Report does not require all three of these elements. In fact, a Report may consist of any one
element, any combination of elements, or all three elements combined.

1. Open the file containing the addresses you want to include on the labels. See the Open command
i
(File menu) or choose button on the toolbar.

2. From the Tools Menu, choose New Report.
3. Type or select the name for the report you want to create in the Report Name Box. The name

can contain multiple words and have a length of up to 80 characters. If you do not specify a name,

askSam assigns the name Untitled Report # to your Report.
é-%.

4. Choose the Select the documents to include in your Report Button to build a search
request using the Multiple Search Request Dialog Box. See the Multiple Search Request command
(Actions menu) for more details about the Dialog Box.

5. Choose OK to return to the New Report Dialog Box.

- |

6. Choose the Sort Button Select the fields you wish to Sort. The Sort Dialog box
will only sort the document you selected in the Multiple Search Request Dialog Box. See the Sort
command (Actions menu) for more details about the Sort Dialog Box.
7. Choose OK to return to the New Report Dialog Box.
8. Select the layout for your Report Button to activate askSam's Report Layout Editor. From this Editor
you can define the layout of your Report. You can insert fields, define which fields will be totaled and
grouped, as well as define headers and footers.

3|
Place Field Selects a field and positions it in the Editor



o
Group Footer Add text to totals and subtotals from Total and Count commands.

)
Report Settings Defines settings specific to the current Report.

3

Count Places the number of documents selected or grouped into your report.
&

Place Text Places text into your Report.

3
Spacing Defines the spacing method when placing fields in a Report.
=
Header Defines a header for the Report.

3
Footer Defines a footer for the Report.
&
Reset Row Sets a Report up in multiple rows.
3
Close Closes the Report Layout Editor and lets you save or cancel your changes.

10. From the Tools Menu, choose Close Report. A message will appear asking if you want to save the
Report. Choose Yes. You are returned to the New Report Dialog Box.

11. To run the Report, choose the Run Button. askSam opens a new window displaying the Report
output.



Editing an Existing Report (Reports Step-by-step Instruction)

Once a Report is created, you can Edit, Run, or Delete if from the Report Manager.

To Edit a Report

1

5.

6.

7.

. Open the file containing the report you want to edit. See the Open command (File menu).
2. From the Tools Menu, choose Open/Edit Report. The Report Manager Dialog Box appears.

3.

4. Choose the Selection Button to access the Multiple Search Request Dialog Box and edit the search

Type or select the name of the report you want to edit in the Report Name Box.

criteria for the designated report. See the Multiple Search Request (Actions menu) for more details
about the Dialog Box.

Select the Sort Button to access the Sort Dialog Box and edit the Sort criteria for the designated
report. See the Sort command (Actions menu) for more details about the Dialog Box.

Select the Edit Layout Button to edit the layout of the designated Report using the Report Layout
Editor. See the New Report command for more details about the Editor.

Select the Run Button to executes the Report as edited.

To Delete a Report

1.
2.
3.
4.
5.

Open the file containing the report you want to delete. See the Open command (File menu).
From the Tools Menu, choose Open/Edit Report. The Report Manager Dialog Box appears.
Type or select the name of the Report you want to delete in the Report Name Box.

Select the Delete Button. A message appears asking you to confirm your decision.

Choose Yes. The Report is deleted.



Creating a New Report from an Existing Report (Reports Step-by-
step)

Once you have created a Report, you can define new Reports using this existing Report as a basis.

To Create a New Report from an Existing Report

. Open the file containing the report you want to copy. See the Open command (File menu).

. From the Tools Menu, choose Open/Edit Report. The Report Manager Dialog Box appears.

. Type or select the name of the report you want to copy.

. Type the name of the new Report in place of the old report name.

. Select the Edit Layout Button, Sort button or Selection button. The Rename/Copy Report Dialog Box
appears.

. Choose the Copy Option.

. Choose OK. Make any changes necessary for the new report.
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See Also
Editing an Existing Report (Reports Step-by-step Instruction).



Printing a Report (Reports Step-by-step Instruction)

There are two ways to print a Report. You can either print it directly, or you can run a Report and then
print from the output file.

To Send a Report Directly to the Printer
1. Open the file containing the report you want to print. See the Open command (File menu).

2. From the File menu, choose Print or choose the button from the toolbar. See the Print
command (File menu). Select the Report option.

3. Type or select the Report name.

4. Choose OK. A Dialog Box appears telling you that askSam is printing.

To Send Report Output to the Printer
1. Once you have run the Report, choose Print from the File menu (Ctrl+P). The Print Dialog Box will

appear.
2. Choose OK. The Report is printed.



Running a Report (Reports Step-by-step Instruction)
Once you have defined a Report, you can easily run it at any time.

To Run a Report

1. Open the file containing the addresses you want to include on the labels. See the Open
command (File menu).

2. From the Tools Menu, choose Run Report. The Run Report Dialog Box will appear.
3. Type or select the name of the Report you want to run.
4, Choose OK.

Shortcut

.—|
Toolbar: m

The Report you selected is run and one of there things will happen:

1. If you have defined a layout for the Report, A new window is open and the Report is output. You can
Print, Edit, and Save the contents of the Report output.

2. If you have defined a Report containing a Search or Sort request without defining a Report layout, the
first selected document will be displayed and the Retrieval Dialog Box appears. You can move
through the retrieved documents by choosing Next, Previous, or Cancel.

3. If askSam is not finding any documents that meet you search criteria, a Message Box will appear
informing you that no matches were found. |If this happens, check your selection criteria.

Note: If a Report opens a window for output, you can return to your original document by
1. Closing the window containing the Report output. See the Close command (File menu).
2. Press Ctrl+Tab to switch back tot the previous window.




Searching in askSam (Step-by-step Instruction)

askSam's true strength is finding specific information when you need it and presenting it in a manner of
your choice. The list of possible searches is almost endless. The Actions menu contains the various
search options, as well as the Multiple Search Dialog Box, which allows you to form a request by linking
the other Search options. If you prefer, askSam's Command Line allows you to directly access
askSam's Search capabilities by entering Search commands.

Global Versus Local Searches

Because askSam allows you to create files which conceivably could span 4 GB (gigabytes) and
individual documents as long as 16,000 lines, finding all the information you want in the minimum
amount of time calls for defining the scope of a search which fits your needs. Basically, there are two
methods of looking for information

Global Most of askSam's searches are conducted at the Global Level -- this Search is conducted
through all the the documents in the current askSam file. The Command Line and the various
Searches in the Actions menu are all Global.

Local When a file contains long documents, it is possible to confine a Search to a single document.
This local search is called a Find and searches only for a single text string in the current document.
You can access the Find command from the Edit menu.

askSam Local Search Options
Eind

Repeat | ast Find

askSam Global Search Options
Boolean Search

Search in Field

Numeric Search

Proximity Search

Date Search

Multiple Search Request

Search Multiple Files

Hyper on Selected

Hyper on File



Using the askSam Word Processor (Step-by-step Instruction)

askSam for Windows offers you many powerful Word Processing capabilities which allow you to take full
advantage of the Windows' environment. The basics of askSam's Word Processing functions similar to
other Windows Word Processors and Text Editors.

Typing Text

Moving Around Within a Single Document
Deleting Text

Selecting Text

Transferring Information Using the Clipboard
Drag and Drop Editing

Using Fonts and Font Styles

Text Alignment

Line Spacing

Setting Tabs

Setting Margins and Indents

Breaking Documents into Pages

Using Headers and Footers




Typing Text (Word Processing Step-by-step Instruction)

To type text into a document, make sure that the text cursor is in the document and start typing. The
text you type is inserted at the cursor position. When you reach the end of a line, the text will
automatically wrap to the next line.

You can type text in either Insert or Overwrite mode.

Insert Mode Inserts the text you type at the cursor position. Any text to the right of the cursor
is shifted to the right.

Overwrite Mode Writes over any text to the right of the cursor when you type. When Overwrite
Mode is active, OVR appears in the Status Bar.

To toggle between Insert and Overwrite Mode, press the Ins (Insert) Button on the Key Board.



Moving Around Within a Single Document (Word Processing Step-by-
step Instruction)

You can use the mouse or the keyboard to move around in the current document.

To Move in the Document using the Mouse

1. You can use either the Vertical or Horizontal Scroll Bars to scroll through the current document. These
Scroll Bars function the same as those found in other Windows's applications.

2. To reposition the cursor in a screen, move to the desired position and Click the Left Mouse Button.

To Move in the Document using the Keyboard
askSam includes a number of Key combinations for moving quickly around the current document.

Left Arrow Previous Character

Right Arrow Next Character

Up Arrow Previous Line

Down Arrow Next Line

Home Beginning of the Current Line
End End of the Current Line
Page Up Previous Screen

Page Down Next Screen

Ctrl+Left Arrow Previous Word
CtrlI+Right Arrow Next Word

Ctrl+Home Beginning of Document
CtrlI+End End of Document
Ctrl+PgUp Scrolls Screen Left
Ctrl+PgDn Scrolls Screen Right

Ctrl+Up Arrow  Scrolls Screen Up
Ctrl+Down Arrow Scrolls Screen Down



Deleting Text (Word Processing Step-by-step Instruction)
If you make a mistake while typing, you can easily Delete the mistake and replace it with the correct text.

Del Delete the character to the right of the cursor or to Delete the Selected Text (See Selecting
Text).

Backspace Delete the character to the left of the cursor or the Selected text.

Any Key Delete the Selected text.



Selecting Text (Word Processing Step-by-step Instruction)
You can Select text for editing, deleting, or formatting using either the mouse or the keyboard.

To Select Text Using The Mouse

1. Position the mouse pointer at one end of the text you wish to Select.
2. Press and hold down the Left Mouse Button.

3. Move the mouse pointer over the text.

4. Release the Left Mouse Button. The text you Selected is highlighted.

Note: You can also Select an entire line by Clicking once on the Selection Area (the white margin to the
left of the left margin).

To Select Text Using The Keyboard
Use the Keys described in Moving Around Within A Document in combination with the Shift Key.

To Cancel A Selection
1. Move the mouse pointer to the Selected block of text.
2. Click the Left Mouse Button, or press any Arrow Key.



Transferring Information Using the Clipboard (Word Processing Step-
by-step Instruction)

The Windows Clipboard provides a temporary storage area for information which you want to transfer to
another location. You can Cut or Copy information from your document to the Clipboard, and then
transfer it to:

A. Another place in the same document.

B. Another askSam document.

C. Another askSam file.

D. Another Windows application.

To Cut or Copy Information to the Clipboard
1. Select the information you want to Cut or C

opy.
o
2. From the Edit menu, choose Cut (Ctrl+X or ) or Copy (Ctrl+C or

). If you choose

Cut The Selected Text is Deleted from the document when it is transferred to the Clipboard.
Copy The Selected text is left in the document and a copy is transferred to the Clipboard.

To Paste Information from the Clipboard
1. Position the cursor where you wish to insert the information from the Clipboard.

3
2. From the Edit menu, choose Paste (Ctrl+V or ). The information stored in the Clipboard is pasted
in the document at the cursor position.

Note: When you paste text into a document, the text and its formats (fonts, sizes, colors, etc.) are
pasted. If you want to paste text without any formats, use the Paste Special command (Edit menu) and
choose the unformatted Text option from the Dialog Box.



Drag and Drop Editing (Word Processing Step-by-step Instruction)

Drag and Drop Editing offer you a fast and easy way to edit information using the mouse.

To Move Text Using Drag and Drop

1

5.

. Select the text you want to Drag and Drop. (See Selecting Text)
2. Place the mouse pointer in the Selected Text.

3.

4. Move the mouse pointer and the blinking Text Bar to the location where you want to insert the text.

Press and hold the Left Mouse Button.

The blinking text bar shows you the exact location of where your text will be inserted.
Release the Left Mouse Button and you text is moved from where you marked it to where you placed
it. After inserting the text, askSam selects the newly inserted block

To Copy Text Using Drag and Drop
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. Select the text you wish to Drag and Drop. (See Selecting Text)

. Using the mouse, place your mouse pointer in the Selected Text.

. Press and hold the Citrl Key.

. Press and hold the Left Mouse Button.

. Using the mouse, move the mouse pointer and the blinking Copy Bar to the location where you wish

to insert a copy of the text. The blinking text bar shows you the exact location of where you text will be
inserted.

. Release the Left Mouse Button and your Ctrl Key. Your text will be copied from where you marked it to

where you placed it. The Selected text will Remain in its original location.



Using Font and Font Styles (Word Processing Step-by-step
Instruction)

When you begin entering text in a document, the text appears in the default font.

To Choose a Different Font, Font Size, or Color

1. From the Format menu, choose Font. The Font Dialog Box appears.

2. Choose the Font, Style, Size, Color, and Effects you want to use.

3. Choose OK. The settings you selected are activated. The next text you enter will appear in the new
Font.

To Change the Default Font for New Documents Added to a File

1. From the Options menu, choose File Preferences.

2. Select the File Font Button.

3. Choose the Font, Style, Size, Color, and Effects you want to set as the Default Font.

To Change the Font of Existing Text

1. Select the text you want to modify. See Selecting Text. The Selected text is highlighted on the
screen.

2. From the Format menu, choose Font.

3. Choose the Font, Font Style, Size, Color, and Effects you want to use.

4. Choose OK. The Selected text is changed to the new Font settings.

Shortcut

Changing the Font from the Format Bar

1. Click on the drop-down Font menu on the Format Bar. The drop-down Font Menu appears displaying
the fonts installed in your Windows system.

2. Type or select the Font you want to use. The drop-down Font Menu will close. The next text you enter
at the cursor position, or the selected text is displayed in the new Font.

Changing the Font Size from the Format Bar

1. Click on the drop-down Font Size menu on the Format Bar. A list of available Font Sizes is displayed.

2. Choose the Font Size you want to use. The drop-down Font Size Menu will close. The next text you
enter at the cursor position, or the Selected text is displayed in the new Font Size.

Changlng the Font Style from the Format Bar
Click on either the Font Style Icon you want to use.

Bold (Ctrl+B)
Italic (Ctrl+])

Underline E (Ctrl+u)

The next text you enter at the cursor position, or the Selected text is displayed in the new Font Style.



Text Alignment (Word Processing Step-by-step Instruction)

Text can be aligned in the following ways:
A. On the Left Margin

B. On the Right Margin

C. Centered between the two margins

To Change the Alignment Using the Menu Bar

1. Select the text you wish to modify or place the cursor in the line you wish to modify. See Selecting
Text.

2. From the Format menu, choose Alignment. A menu with the Alignment choices will be displayed.

3. Choose the Alignment command you want to use (Left, Centered, Right). The selected text or the line
containing the cursor is realigned.

To Change the Alignment Using the Format Bar

1. Select the text you want to modify or place the cursor in the line you wish to modify. See Selecting
Text.

2. Click on the Alignment Icon you want to use

Left

Center
Right Wl

W

The Selected text or the line containing the cursor is realigned.



Line Spacing (Word Processing Step-by-step Instruction)

Standard text is single spaced in askSam. But you can also define one and a half or double line
spacing.

To Change Line Spacing Using the Menu Bar

1. Select the text you wish to modify or place the cursor in the line you wish to modify. See Selecting
Text.

2. From the Format menu, choose Line Spacing. A menu with Spacing option appears.

3. Choose a the Spacing command you want to use. The Selected text or the text entered at the cursor
position is modified to the new Line Spacing setting.

To Change Line Spacing Using the Format Bar

1. Select the text you wish to modify or place the cursor in the line you wish to modify. See Selecting
Text.

2. Click on the Line Spacing lcon you want to use.

Single Space
1.5 Space

Double Space

The Selected text or the text entered at the cursor position is modified to the new Line Spacing
setting.



Setting Tabs (Word Processing Step-by-step Instruction)

Tab settings control where the cursor is placed each time the Tab key is pressed. As a default setting,
askSam places Tabs every half inch. You can use either the Ruler or the Tab menu to set your own
Tabs. These settings will override askSam's default settings.

To Set Tabs From the Tab Menu

1. From the Format menu, choose Tabs. See the Tabs command (Format menu). The Tabs Dialog Box
appears.

2. Enter a measurement (in inches).

3. Choose the Set Button. This defines where your Tab is set. Repeat steps 1 through 3 for all Tabs you
want to set.

4. Choose the OK Button to accept the Tab settings. The new Tab settings are in effect for the selected
text or the line containing the cursor.

To Delete a Tab Using the Tab Menu

1. From the Format menu, choose Tabs.

2. Highlight the measurement for the Tab you want to delete in the Tab Stop Position List.

3. Choose the Clear Button. Repeat this for any other Tabs you want to delete. If you want to delete all
Tabs, choose the Clear All Button.

To Set a Tab Using the Ruler Line

1. With the mouse, Click on the Ruler where you want to set a Tab. An arrow will appear in the Ruler
and a Tab is set where you Clicked.

2. Click again to set any other Tabs or Click and Drag any Tab whose position you wish to modify. The
new Tab Settings are in effect for the Selected text or the line containing the cursor.

To Delete Tabs Using the Ruler Line
1. Click and Drag the Tab you wish to delete from the Ruler Line into the Work Space. The Tab is
deleted.



Setting Margins and Indents (Word Processing Step-by-step
Instruction)

Margins and Indents affect the way your document prints. Margins are set for the entire document
while Indents may be set on a line-by-line basis.

To Set Margins for a Document
askSam's default Margins are one inch on the Top, Bottom, Left, and Right edges of the document page.
These can be changed to the settings you want to use.

1.

2.
3.
4.

5.

From the File menu, choose Page Setup. The Page Setup Dialog Box is displayed.

Type the settings you want to use for the Top, Bottom, Left, and Right Margins.

Choose Document Settings.

Choose OK to accept the settings. The new Margin settings are now active in the current document.
The appearance of the document on the screen is not altered to reflect the new settings. (Margin
settings are reflected only when printing.)

From the File menu, choose Save (Ctrl+S) to save the new Margin settings.

To Set Margins for a File

The settings entered when the File Settings Option is selected in the Page Setup Dialog Box will
override any Document specific settings already defined. The File Settings remain active until you
select the Document Setting Option in the Page Setup Dialog Box.

1.

2.
3.
4.

5.

From the File menu, choose Page Setup. The Page Setup Dialog Box is displayed.

Type the settings you want to use for the Top, Bottom, Left, and Right Margins.

Choose the File Setup Option.

Choose OK to accept the settings. The new Margin settings are now active in the current file. The
appearance of the document on the screen is not altered to reflect the new settings. (Margin settings
are reflected only when printing.)

From the File menu, choose Save (Ctrl+S) to save the new Margin settings.

To Indent Text in Documents
Indents can be set on either the left or right side of the page. You can indent the first line of a paragraph,
or you can define a hanging indent. Indents may be set on a line-by-line basis.

Indents may be set from the Ruler Line on a line-by-line basis in your document.

1.

Click and Drag the Left Indent Marker to a new position. (show marker). The Indent is set for the
Selected text or the line containing the cursor.

There are three types of indents:
None Indents all selected lines
First Line Indents only the first line
Hanging all lines but the first line

See: INDENTS (FORMAT MENU)

NOTE: Margins and Indents are similar, but they serve different purposes. Margins are set for an entire
Document, whereas Indents can be set on a line-by-line basis. Indents are displayed on screen. Margins
are not displayed, they only affect printing. Generally, margins are used when you print on different size
paper, stationary, or labels. Indents are used to format documents.



Breaking Documents into Pages (Word Processing Step-by-step
Instruction)

askSam can set your page breaks automatically, or you can manually define page breaks for specific
pages within your document.

To Automatically Set Page Breaks
1. From the Format menu, choose Repaginate. askSam goes through the document and divides it into
pages. Page Breaks are represented in the document by a dotted line across the screen.

Note: If you want to change the placement of an automatic Page Break, insert a Manual Page Break
before the automatic Page Break and Repaginate the document.

To Insert a Manual Page Break

1. Position the cursor where you want the Manual Page Break to occur.

2. From the Format, choose Set Page Break. A dotted and dashed line is displayed in the document to
show where the Page Break is inserted.

To Remove a Manual Page Break

1. Position the cursor in the line above the Manual Page Break in the document.

2. From the Format menu, choose Remove Page Break. The dotted and dashed line representing the
Manual Page Break is removed.



Using Headers and Footers (Word Processing Step-by-step
Instruction)

Headers and Footers are defined either for a document or for your entire file. They contain information
which will be printed at the beginning or end of each page of the document. They may contain

A. Text

B. Page numbers and Total Number of Pages

C. Date, Time, and Weekday

D. File Name (with or without the Path).

To define a Header or Footer for a Document

. From the File menu, choose Page Setup. The Page Setup Dialog Box is displayed.

. Choose Documents Settings option.

. Choose either the Header or Footer Button. The Header or Footer Dialog Box will appear.
. Enter the Header or Footer you want to include in the document.

. Choose OK. You will return to the Page Setup Dialog Box.

. Choose OK to close the Page Setup Dialog Box.

. From the File menu, choose Save (Ctrl+S) to save the Header or Footer for the document.
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Notes:
1. Headers and Footers are only displayed when a document is printed.
2. To define the Header or Footer for the current file, choose the File Settings option at step 2 above.



Close command (File menu)

Use this command to close the current askSam file.
Shortcut

Keys: Ctrl+F4

Note: If any changes have been made to the file since the last Save command, the Save Dialog Box is
displayed. See the Save command (File menu).




Exit command (File menu)
Use this command to exit askSam.
Shortcut

Keys: Ctrl+F4

Note: If any unsaved files are open when you execute the Exit command, the Save Dialog Box will
appear. See the Save command (File menu).




Current Document (Export Sub-menu)

Use this command to export the current document.

Dialog Box Options

File Name

Type or select the name of the file into which you want the document exported.

File Type

Select the format of the document you want to export. Click the down arrow to view the available file

formats.

Text Only (*.TXT)
Formatted Text (*.TXT)
askSam DOS (*.TXT)
DBASE Files (*.DBF)
RTF Files (*.RTF)
WordPerfect 5.X (*.DOC)

Directories

ASCII text files. Exported without word wrap or tabs.

ASCII text files. Exported with word wrap and tabs.

Format for exchanging data between the DOS and Windows
versions of askSam. This format retains the document
boundaries between asksam documents.

dBase Ill and IV files. This format allows the Exporting of
structured information to dBase compatible databases.

Rich Text Format files used to exchange formatted information
(including .BMP Graphics).

WordPerfect version 5 files with formatting.

Select the directory into which you want to export the document.

Drives

Select the drive into which you want to export the document.

Set Options

Use this option to define a document delimiter and location within your askSam file.

Append Location

End of File

End of Current Document

After Current Document

After Tagged Document
Document Delimiter

Sets the delimiter for the imported text.

No Delimiter

Blank Line

Character(s)

Page Break

Adds the imported text to a specified location within your
askSam file.

Adds the imported text to the end of the current file.

Adds the imported text to the end of the current document.
Adds the imported text in a new document inserted located
directly after the current document in the current file.

Adds the imported text in a new document located directly after
the tagged document in the current file.

The entire file you import is stored in askSam as a single
document.

Each time askSam encounters a blank line in the imported text, a
new askSam document is created for the next block of imported
text.

Allows you to define one or two characters which askSam wiill
use as a delimiter to separate imported text into multiple
documents.

Divides the file you import into askSam Documents wherever
hard page breaks are encountered.



See also
Export command (File menu).



Entire File command (Export Sub-menu)
Use this command to export the current askSam file.
Dialog Box Options

File Name
Type or select the name of the file into which you want the document exported.

File Type
Select the format of the document you want to export. Click the down arrow to view the available file
formats.

Text Only (*.TXT) ASCI! text files. Exported without word wrap or tabs.
Formatted Text (*.TXT) ASCII text files. Exported with word wrap and tabs.
askSam DOS (*.TXT) Format for exchanging data between the DOS and Windows

versions of askSam. This format retains the document
boundaries between asksam documents.

DBASE Files (*.DBF) dBase Ill and IV files. This format allows the Exporting of
structured information to dBase compatible databases.

RTF Files (*.RTF) Rich Text Format files used to exchange formatted information
(including .BMP Graphics).

WordPerfect 5.X (*.DOC) WordPerfect version 5 files with formatting.

Directories

Select the directory into which you want to export the document.

Drives
Select the drive into which you want to export the document.

Set Options

Use this option to define a document delimiter and location within your askSam file.

Append Location Adds the imported text to a specified location within your
askSam file.

End of File Adds the imported text to the end of the current file.

End of Current Document Adds the imported text to the end of the current
document.

After Current Document Adds the imported text in a new document inserted
located directly after the current document in the current
file.

After Tagged Document Adds the imported text in a new document located

directly after the tagged document in the current file.

Document Delimiter
Sets the delimiter for the imported text.

No Delimiter The entire file you import is stored in askSam as a single document.

Blank Line Each time askSam encounters a blank line in the imported text, a new
askSam document is created for the next block of imported text.

Character(s) Allows you to define one or two characters which askSam will use as a
delimiter to separate imported text into multiple documents.

Page Break Divides the file you import into askSam Documents wherever hard page

breaks are encountered.



Tagged Document command (Export Sub-menu)

Use this command to export the Tagged document in the current file. See the Tag command
(Document menu).

Dialog Box Options

File Name
Type or select the name of the file into which you want the document exported.

File Type
Select the format of the document you want to export. Click the down arrow to view the available file
formats.

Text Only (*.TXT) ASCII text files. Exported without word wrap or tabs.
Formatted Text (*.TXT) ASCII text files. Exported with word wrap and tabs.
askSam DOS (*.TXT) Format for exchanging data between the DOS and Windows

versions of askSam. This format retains the document
boundaries between asksam documents.

DBASE Files (*.DBF) dBase Ill and IV files. This format allows the Exporting of
structured information to dBase compatible databases.

RTF Files (*.RTF) Rich Text Format files used to exchange formatted information
(including .BMP Graphics).

WordPerfect 5.X (*.DOC) WordPerfect version 5 files with formatting.

Directories

Select the directory into which you want to export the document.

Drives
Select the drive into which you want to export the document.

Set Options

Use this option to define a document delimiter and location within your askSam file.

Append Location Adds the imported text to a specified location within your
askSam file.

End of File Adds the imported text to the end of the current file.

End of Current Document Adds the imported text to the end of the current
document.

After Current Document Adds the imported text in a new document inserted
located directly after the current document in the current
file.

After Tagged Document Adds the imported text in a new document located

directly after the tagged document in the current file.

Document Delimiter
Sets the delimiter for the imported text.

No Delimiter The entire file you import is stored in askSam as a single document.

Blank Line Each time askSam encounters a blank line in the imported text, a new
askSam document is created for the next block of imported text.

Character(s) Allows you to define one or two characters which askSam will use as a
delimiter to separate imported text into multiple documents.

Page Break Divides the file you import into askSam Documents wherever hard page

breaks are encountered.



Report command (Export Sub-menu)
Use this command to export the output of a specified Report.
Dialog Box Options

Report Name
Type or select the name of the report you want to run.



Date Stamp command (Edit menu)

Use this command to insert the system date in the current document at the cursor position.

Shortcuts

Toolbar:

Keys: Ctrl+D

See also
Time Stamp command (Edit menu)
Weekday Stamp command (Edit menu)



Time Stamp command (Edit menu)

Use this command to insert the system time in the current document at the cursor position.

Shortcuts

Toolbar:
Keys: Ctrl+T

See also
Date Stamp command (Edit menu)
Weekday Stamp command (Edit menu)



Weekday Stamp command (Edit menu)

Use this command to insert the system weekday in the current document at the cursor position.



Normal Style Command (Style Sub-menu)

Use this command to remove set styles for the selected text.

See also
Style command (Format menu)



Bold Style command (Style Sub-menu)

Use this command to define the Font Style for the selected text or the text entered at the cursor position
as bold text.

Shortcut

Toolbar:

Key: Ctrl+B

See also
Style command (Format menu)



Italic Style command (Style Sub-menu)

Use this command to define the selected text or the text entered at the cursor position as Italic text.

Shortcut

Toolbar:

Key:  Ctrl+l

See also
Style command (Format menu)



Underline Style command (Style Sub-menu)

Use this command to define the selected text or the text entered at the cursor position as Underlined
text.

Shortcut

Toolbar: E

Key: Ctrl+U

See also
Style command (Format menu)



Strikeout Style command (Format menu)

Use this command to define the selected text or the text entered at the cursor position as Strikeout text.

See also
Style command (Format menu)



Word Wrap command (Options menu)

Use this command to turn the askSam word wrap function ON or OFF. The default setting for word
wrap is ON.

Note: When the askSam Word Wrap function in ON, Wrap appears in the Status Bar.



Date Searching

The Date Search finds information according to a date contained in a field. The date search contains
three categories:

Single Range - "Find documents dated earlier than..."
Dual Range - "Find documents from 1970 to 1980"
Comparison - "Find documents dated later than 30 days from today"

See also
Boolean Search
Search in Field
Numeric Search

Proximity Search
Multiple Search Request
Search Multiple Files
Hyper on Selected
Hyper on File

Find
Repeat Last Find




Select Document(s) command (Export Sub-menu)

Use this command to export documents you select using the askSam Multiple Search Request Dialog
Box. See Multiple Search Reguest command (Actions menu).

Multiple Search Request Dialog Box Options
See the Multiple Search Request command (Actions menu).
Export Dialog Box Options

File Name
Type or select the name of the file into which you want the document exported.

File Type
Select the format of the document you want to export. Click the down arrow to view the available file
formats.

Text Only (*.TXT) ASCII text files. Exported without word wrap or tabs.
Formatted Text (*.TXT) ASCII text files. Exported with word wrap and tabs.
askSam DOS (*.TXT) Format for exchanging data between the DOS and Windows

versions of askSam. This format retains the document
boundaries between asksam documents.

DBASE Files (*.DBF) dBase Ill and IV files. This format allows the Exporting of
structured information to dBase compatible databases.

RTF Files (*.RTF) Rich Text Format files used to exchange formatted information
(including .BMP Graphics).

WordPerfect 5.X (*.DOC) WordPerfect version 5 files with formatting.

Directories

Select the directory into which you want to export the document.

Drives
Select the drive into which you want to export the document.

Set Options

Use this option to define a document delimiter and location within your askSam file.

Append Location Adds the imported text to a specified location within your
askSam file.

End of File Adds the imported text to the end of the current file.

End of Current Document Adds the imported text to the end of the current
document.

After Current Document Adds the imported text in a new document inserted
located directly after the current document in the current
file.

After Tagged Document Adds the imported text in a new document located

directly after the tagged document in the current file.

Document Delimiter

Sets the delimiter for the imported text.

No Delimiter The entire file you import is stored in askSam as a single document.

Blank Line Each time askSam encounters a blank line in the imported text, a new askSam
document is created for the next block of imported text.

Character(s) Allows you to define one or two characters which askSam will use as a delimiter



to separate imported text into multiple documents.
Page Break Divides the file you import into askSam Documents wherever hard page breaks
are encountered.



Single Range Date Search (Actions menu)

Use this command to search for documents in the current file where a field is less than, greater than, or
equal to a specific date or a date in another field.

Dialog Box Options

Date Field
Type or select the name of the field containing the Date you want to retrieve.

Logical Operator
Type or select a logical operator for the Date Search.

Second Date Field

There are three options for defining the second date variable.

1. Type or select the name of a second field containing a date you want to use to conduct a search
based on a comparison of two date fields.

2. Click the Date Box and enter a date to use.

3. Click the Current Date Box to conduct a search based on comparison of the current system date and
the date in the specified field.

See also

Dual Range Date Search
Comparison Date Search

Boolean Search

Search in Field

Numeric Search
Proximity Search

Date Search

Multiple Search Request
Search Multiple Files
Hyper on Selected
Hyper on File

Find
Repeat Last Find



Dual Range Date Search (Actions menu)

Use this command to search for documents in the current file where a field is less than, greater than or
equal to another date AND less than, greater than or equal to a secod date.

Dialog Box Options

Date Field
Type or select the name of the field containing the date you want to use in the Date Search.

Logical Operator

Type or select the logical operator you want to use in the Date Search
(<, >, =, <=, >=, <),

First Date
Click the Box to enter a date for the Date Search comparison.

Current Date
Click the Box if you want to use the current system date in the Date Search comparison.

And
Click the Box to enter a second date in the Date Search comparison.

Logical Operator
Type or select a logical operator for the Date Search comparison (<, >, =, <=, >=, <>),

Second Date
Click the Box to enter a second date in the Date Search comparison.

Current Date
Click the Box to use the current system date in the Date Search comparison.

See also

Single Range Date Search
Comparison Date Search

Boolean Search

Search in Field

Numeric Search
Proximity Search

Date Search

Multiple Search Request
Search Multiple Files
Hyper on Selected
Hyper on File

Find
Repeat Last Find



Prompt

When the Multiple Search Dialog Box appears in the report writer it contains an additional button.
This button allows you to stop a report and prompt the user for input. It allows the user to modify the
selection each time a report is run.




Comparison Date Search (Actions menu)

Use this command to search for documents in the current file where a date in a field compared to a date
in another field is greater than, less than or equal to a set number of days, months or years.

Dialog Box Options

Date Field
Type or select the name of the field containing the first date you want to use in the Date Search
comparison.

Second Date Field
Type or select the name of the field containing the second date you want to use in the Date Search
comparison, or enter a specific date.

Current Date
Click the Box to use the current system date in the Date Search comparison.

Logical Operator
Type or select a logical operator for the Date Search comparison (<, >, =, <=, >=, <>),

Qty of
Type a number to define the amount of time to use in the Date Search comparison.

Date Units
Select the date unit you want to use in the Date Search comparison (Days, Months, or Years).

See also

Single Range Date Search
Dual Range Date Search

Boolean Search

Search in Field

Numeric Search
Proximity Search

Date Search

Multiple Search Request
Search Multiple Files
Hyper on Selected
Hyper on File

Find
Repeat Last Find



Normal Style command (Format menu)

Use this command to remove styles for the selected text or the text entered at the cursor position.



Center Tab command (Format menu)

Use this command to define a center tab for the selected text or the line containing the cursor in the
current document. When set and the tab key is selected text is centered at the tab position.

Shortcuts

.—|
Toolbar: B!

To set a center tab

Place the cursor on the line where you want a center tab. Click on the center tab button in the format
bar. Click on the position in the ruler where you want a center tab. The center tab is set for the line
where the cursor is currently located.

To remove a center tab setting
Select the center tab measurement on the ruler with a mouse and drag it off the ruler.

See also

Tabs (Format Menu)

Right Tab
Left Tab

Decimal Tab




Right Tab command (Format menu)

Use this command to define a right tab for the selected text or the line containing the cursor in the
current document. When set and tab is selected text will be right aligned at the tab position.

Shortcuts

.—|
Toolbar: B!

To set a right tab

Place the cursor on the line where you want a right tab. Click on the right tab button in the format bar.
Click on the position in the ruler where you want a right tab. The right tab is set for the line where the
cursor is currently located.

To remove a right tab setting
Select the right tab measurement on the ruler with a mouse and drag it off the ruler.

See also

Tabs (Format Menu)
Left Tab

Center Tab

Decimal Tab




Decimal Tab command (Format menu)

Use this command to define a decimal tab for the selected text or the line containing the cursor in the
current document. When set and the tab key is selected text is justified on the decimal at the tab
position.

Shortcuts

.—|
Toolbar: N

To set a decimal tab

Place the cursor on the line where you want a decimal tab. Click on the decimal tab button in the format
bar. Click on the position in the ruler where you want a decimal tab. The decimal tab is set for the line
where the cursor is currently located.

To remove a decimal tab setting
Select the decimal tab measurement on the ruler with a mouse and drag it off the ruler.

See also

Tabs (Format Menu)

Right Tab
Center Tab

Left Tab



1.5 Line Spacing command (Format menu)

Use this command to define the line spacing for the selected text or the text entered at the cursor
position in the current document (single, 1.5, and double). The default setting in askSam is single
spacing.

Shortcut

Toolbar:

Sub-menu Options

Single
Defines the line spacing for the text as single space.

1.5 Lines
Defines the line spacing for the text as 1.5 lines.

Double
Defines the line spacing for the text as double.

See also
Single Line Spacing command (Format menu)
Double Line Spacing command (Format menu)



Double Line Spacing command (Format menu)

Use this command to define the line spacing for the selected text or the text entered at the cursor
position in the current document (single, 1.5, and double). The default setting in askSam is single
spacing.

Shortcut

Toolbar:

Sub-menu Options

Single
Defines the line spacing for the text as single space.

1.5 Lines
Defines the line spacing for the text as 1.5 lines.

Double
Defines the line spacing for the text as double.

See also
Single Line Spacing command (Format menu)
1.5 Line Spacing command (Format menu)



Menu Bar

The many features of askSam for Windows can be selected using the traditional Windows Menu Bar at
the top of the screen. You can choose a menu item either with your mouse or the keyboard (by using
ALT Key combinations).

Selecting Menu Iltems with a Mouse

You can choose Menu items with a mouse or other pointing device. Simply move the Mouse Cursor (it

will become an arrow) to the Menu item of your choice and Click. Options on the Pull-Down Menus can

be selected in a similar manner.

Selecting Menu Items with the Keyboard

1. To access a menu with the Keyboard, press the ALT key plus the underline letter in the Menu choice.
A Pull-Down menu appears. You can now choose the desired menu option by pressing the underlined
letter or number.

Alternate Keyboard Selection Method (Using the Arrow Keys)

1 Press the ALT Key to move the cursor to the Menu Bar.

2 Use the ARROW Keys to move to the desired option.
3 Press ENTER.



Status Bar

The bottom line of the askSam screen is the Status Bar. From the Status Bar, askSam give you
messages and other useful information.

1.

2.

The left most section of the Status Bar is where askSam displays messages. Descriptions of Menu
Iltems and Icons, as well as Prompts are shown here.

The next section of the Status Bar is the Document Counter. It tells you how many documents are in
the current file, and gives you the number of the current document. For example, "1 of 22" means
that you are currently at document number 1, and there are 22 documents in the file.

. The Column Number is the next section on the Status Bar. This can be a number from 1 to 255, and

gives you the horizontal cursor position in the Work Space.

. The Line Number follows the Column Number. It indicates the Line Number where the cursor

appears in the Work Space.

. The next five sections indicate the status of several modes:

Insert or Overwrite status. An OVR is displayed when askSam is in Overwrite Mode.
CAPS is displayed when Caps Lock mode is On.

When Num Lock is On, NUM is displayed.

The word DATA in the Status Bar indicates that Data Entry mode is On.

The word WRAP indicates that the Word Wrap setting is On.



Report Tools (Tools Menu)
Use these tools to design and edit the layout in the Report Layout Editor.
Note: Corresponding menu options are added to the Tools Menu.

Place Field Selects a field and positions it in the Report.
Group Footer  Adds text to totals and subtotals from the Total and Count commands.
Report Settings Defines settings specific to the current Report.

Count Places the number of Documents selected or grouped into your Report.
Place Text Places text into your Report.

Spacing Defines the spacing method when placing fields in a Report.

Header Defines a header for the Report.

Footer Defines a footer for the Report.

Reset Row Used to set a Report in multiple columns.

Close Closes the Report Layout Editor and lets you save or cancel your changes.



Title Bar

The askSam Title Bar contains the name of the active application (in this case askSam) and may also
contain the name of the current file when you have opened one or more askSam files.



Ruler

The Ruler displays (and allows you to modify) Margin and Tab settings for the current document.



Work Space

The Work Space in askSam is where you enter your information. Bring the cursor into the Work Space
with the mouse or ARROW Keys, and begin typing.



Left Align command (Format menu)

Use this command to align the selected text or the text entered at the cursor position on the left margin.

Shortcut
Toolbar:
Left

Center
Right



Center Aligh command (Format)

Use this command to align the selected text or the text entered at the cursor position in between the two
margins.

Shortcut
Toolbar:
Left

Center
Right



Right Align command (Format menu)

Use this command to align the selected text or the text entered at the cursor position on the right margin.

Shortcut
Toolbar:
Left 7
Center [y
B

Right



Close Report command (Tools Menu)

Use this command to close the Report Layout Editor. A Dialog Box will prompt you to save the Report
layout you created.

Shortcut CTRL-S

Report Tools



Links command (Edit menu)

Use this command to define whether a Link should be updated manually or automatically. You can also
use this command to break a Link between an Object in the Server Application and an Object in
askSam.

Dialog Box Options

Links
Lists the Links in the current document.

Options

AutomaticAutomatically updates the Linked object to display any changes made in the Server
Application.

Manual Requires you to manually request that the Linked Object be updated.



Object command (Edit menu)
Use this command to edit a Linked Object in askSam.

Note: By selecting the Linked Object you wish to edit and choosing this command, the Server
Application will open and the Object will be displayed. Edit the Object using the features of the Server

Application.



Case Sensitive command (Menu Bar)

Use this Icon to define an askSam search as Case Sensitive. Use this Icon to toggle the setting ON
and OFF.

Note: Normally, when askSam searches for a word, the case of the letters comprising the word is
irrelevant. For example, searching for WHO finds "Who", "who" and "WHO".

See also
File Preferences (Options menu)



Minimize Button

Using a mouse, you can click the Minimize Button to reduce the current application window to an Icon.

See also
Maximize Button



Maximize Button

Using a mouse, you can click on the Maximize Button to enlarge the current application window so that it
fills the entire desktop.

See also
Minimize Button



Scroll Bar

Using a mouse, you can click on the Scroll Bars to move the current document up and down (Vertical
Scroll Bar) and left and right (Horizontal Scroll Bar) to view parts of the document that cannot fit into the
desktop.



Control-Menu Box

The Control-menu Box is in the upper-left corner of each window. By using the Control Menu
commands, you can resize, move, maximize, minimize, and close windows, and switch to other
applications.



Background Color (Format Menu)
askSam lets you modify the background color of your text. To change the color of a text:

Select the text you wish to modify.

Choose FORMAT -> BACKGROUND COLOR

The Color Menu appears allowing you to choose a color for your the selected background.
Choose a color.

The color of the Selected Text background will be modified.

NOTE: The COLOR Commands can be accessed from the Mouse Menu. Click the Right Mouse Button
in the Work Space to display the Mouse Menu.

See Also
Foreground Color



Foreground Color (Format Menu)
askSam lets you modify the color of your text. To change the color of a text:

Select the text you wish to modify.

Choose FORMAT -> FOREGROUND COLOR

The Color Menu appears allowing you to choose a color for your text.
Choose a color.

The color of the Selected Text will be modified.

NOTE: The COLOR Commands can be accessed from the Mouse Menu. Click the Right Mouse Button
in the Work Space to display the Mouse Menu.

See Also
Background Color



Command Line

askSam's Command Line is the direct route to your information. When using the Command Line it is
never necessary to specify a field for searching. Simply type in a name, company, date or any other
word that you're looking for and askSam will find it in the Active File.

Shortcuts:
Keys: Esc
Mouse: Place cursor in blank area and click mouse button once

con: [

Searching from the Command Line:

Press ESC to move to the Command Line.
With a mouse, place the mouse pointer in the Command Line and Click.

Type the word or phrase for the Search or select a previous search from the drop down list E and
press ENTER (or Click the Search Button).
askSam searches from the beginning of the Active File and displays the first Document containing the
word or phrase you entered. The word or phrase is highlighted and the Retrieval Dialog Box will appear.
(See Using the Retrieval Dialog Box.)

Searching for Phrases

To Search for a phrase from the Command Line, the phrase must be enclosed in square brackets [].
Entering multiple words that are not enclosed in square brackets results in a Search for Documents
containing all the requested words but the words do not have to appear together as a phrase.

Example: Entering WORLD BANK in the command will find any Document containing the word "world"
and the word "bank". This means that a Document containing the sentence, "In today's world,
the bank is an important institution" would be selected. [WORLD BANK] Finds only Documents
where the actual phrase "world bank" appears.

Entering Commands on the Command Line

It is possible to conduct more than simple Searches from askSam's Command Line. More complex
Requests usually involve the use of askSam Commands. For certain Searches or Lists, you may find it
is faster to enter the Requests from the Command Line.

EXAMPLE: To search for all documents containing Ireland or England, you can enter the following
request in the Command Line: IRELAND {OR} ENGLAND. The "{or}" in the example above
is an askSam Command.

NOTE: If you prefer to enter Requests directly in the Command Line (instead of using Dialog Boxes), the
WIN_COM.ZIP file on our BBS contains a list of the commands and descriptions of their
functions. You can also turn on the "Show Commands from Dialogs" option in the
OPTIONS -> GLOBAL PREFERENCES Menu. This option activates a Command Message Box
which displays the Commands to enter in the Command Line to perform the function of any
Search. The Message Box is displayed after executing any Command from the Actions Menu or
when running a report.



Tool / Format Bar

Tool Bar
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ew ave

Print Pack Import

dd Blank Add Entry Form Cut
Copy Paste First
Previous ext Last
Tag Go Tagged Run Report
Zoom In Zoom Out Dial
Case Sensetive Help
Format Bar

Font

|

Select a font for higlighted text. Use the arrow to display a list of available fonts, or type the name of the
desired font.

Font Size

[ T[]

Select a font size for higlighted text. Use the arrow to display a list of available fonts, or type the name of
the desired font.

IBIIIHH;IéIEII BER  EEEIEEE
Bold Underline
Left Justify Center Justify Right Justify
Left Tab Center Tab Right Tab
Decimal Tab Single Spacing Half Spacing
Double Spacing Date Stamp Time Stamp

Spell Check



Color Bar2

Use this command to define the color for the selected text or the text entered at the cursor position.
Shortcut:

Mouse Menu:

Dialog Box Options

Color Bar
Select the color that you want to use.



Color Bar3

Use this command to define the color for the selected text or the text entered at the cursor position.
Shortcut:

Mouse Menu:

Dialog Box Options

Color Bar
Select the color that you want to use.



Color Bar4

Use this command to define the color for the selected text or the text entered at the cursor position.
Shortcut:

Mouse Menu:

Dialog Box Options

Color Bar
Select the color that you want to use.



Color Bar5

Use this command to define the color for the selected text or the text entered at the cursor position.
Shortcut:

Mouse Menu:

Dialog Box Options

Color Bar
Select the color that you want to use.



Color Bar6

Use this command to define the color for the selected text or the text entered at the cursor position.
Shortcut:

Mouse Menu:

Dialog Box Options

Color Bar
Select the color that you want to use.



Color Bar7

Use this command to define the color for the selected text or the text entered at the cursor position.
Shortcut:

Mouse Menu:

Dialog Box Options

Color Bar
Select the color that you want to use.



Color Bar 8

Use this command to define the color for the selected text or the text entered at the cursor position.
Shortcut:

Mouse Menu:

Dialog Box Options

Color Bar
Select the color that you want to use.



Color Bar 9

Use this command to define the color for the selected text or the text entered at the cursor position.
Shortcut:

Mouse Menu:

Dialog Box Options

Color Bar
Select the color that you want to use.



Color Bar 10

Use this command to define the color for the selected text or the text entered at the cursor position.
Shortcut:

Mouse Menu:

Dialog Box Options

Color Bar
Select the color that you want to use.



Color Bar 11

Use this command to define the color for the selected text or the text entered at the cursor position.
Shortcut:

Mouse Menu:

Dialog Box Options

Color Bar
Select the color that you want to use.



Color Bar 12

Use this command to define the color for the selected text or the text entered at the cursor position.
Shortcut:

Mouse Menu:

Dialog Box Options

Color Bar
Select the color that you want to use.



Color Bar 13

Use this command to define the color for the selected text or the text entered at the cursor position.
Shortcut:

Mouse Menu:

Dialog Box Options

Color Bar
Select the color that you want to use.



Color Bar 14

Use this command to define the color for the selected text or the text entered at the cursor position.
Shortcut:

Mouse Menu:

Dialog Box Options

Color Bar
Select the color that you want to use.



Color Bar 15

Use this command to define the color for the selected text or the text entered at the cursor position.
Shortcut:

Mouse Menu:

Dialog Box Options

Color Bar
Select the color that you want to use.



Color Bar 16

Use this command to define the color for the selected text or the text entered at the cursor position.
Shortcut:

Mouse Menu:

Dialog Box Options

Color Bar
Select the color that you want to use.









