
Welcome to the R:BASE for Windows Tutorial. Click on one of 
the following topics to learn about it.

Overview

Designing a Database

Creating a Database

Adding, Modifying, and Viewing Data

Importing Data

Analyzing Data

Printing Labels

Printing Reports

Printing the Contents of a Window

Making an Application



 

Welcome to R:BASE, a powerful relational database that makes your data very easy to access 
and analyze.



 

R:BASE is a powerful relational database. You can access your data with the Data Browser, query your data 
with Query By Example, enter and edit data using custom forms, and print your data using reports. You can 
create applications without having to program. R:BASE provides multi-user mode and embedded SQL. The 
menus and tool bar work just like your other Windows programs. In addition, the Object Manager puts all your 
database features just a mouse click away.



The R:BASE menu always has the options File, Tools, Utilities, Window and Help. This menu is dynamic; 
additional options are added depending on the action being performed. For example, when using the Data 
Browser, the options Edit, Sort, Calculate, and Layout are added.



The tool bar provides quick access to the most frequently used features in R:BASE; including all of the 
designers. For a description of each button, click the Help button and see the "Buttons" topic.



Help is always available. You can open Online Help by using the Help menu, or click the Help button. Online 
Help includes information about many topics, command syntax, and commonly used procedures.



Report
A report allows you to print data from a table. A report can be as simple as a customer listing or it can 
summarize and sub-total data.



Application
An application is a set of menus and menu options you define to perform specific actions on data in your 
database. The Application Designer makes it easy to build your own custom applications.



Multi-user mode
Multi-user mode allows two or more people to interact with the same network database. R:BASE ensures 
data integrity with automatic locking control.



SQL
SQL, Structured Query Language, is a standard methodology established by ANSI (American National 
Standards Institute) and recognized in the database industry as the optimal way to query data. R:BASE uses 
SQL commands to retrieve or manipulate your data.



 

The Object Manager quickly provides access to database features, such as applications, views, forms, reports, 
and labels.



Click on the tabs to work with specific features. The Object Manager lists everything defined for that area. 
For example, click the Forms tab and the Object Manager lists all the forms defined for the open database.



Click the buttons to perform specific actions and manage the database. For example, if forms are listed, click 
the Design button to modify the highlighted form, or click the Run button to use the form.



The area at the bottom of the Object Manager shows you a description of the selected item, or the current 
directory location for databases and applications.



The Help button provides context-sensitive help about the Object Manager.



Labels
Labels, like reports, allow you to print data from your database. Labels can be printed on standard label 
stock, or you can specify custom formats.



Views
A view is a query condition that you have saved.





 

Before you can put data in your database, you must first set up the structure for your database. 
A good database design makes your data easy to work with; use the following guidelines when 
creating your database.



 

Think of your data in terms of lists. The data in a relational database is organized in tables. Each table 
contains information about a particular group or type of data, and is made of up of columns and rows.

First, identify the groups of data and pieces of information to store in your database. Use a sheet of paper for 
each group of data. Across the top of each sheet, write the name of the group of data to track, then list the 
pieces of information. 



The pieces of information to store about customers.



The first step is to identify the different pieces of information and group them together. These lists can change 
as you continue to design the database, such as the order, number, and name of items.



Tables
Data is separated into groups according to the nature of the data. These groups are stored in tables. A table is 
like a list of things or events about one topic or group of information, such as lists of customers, products, 
employees, and invoices. 



Columns
Columns organize the data within a table. Each column contains one type of data. For instance, a table of 
customers might have a column for the name and a column for the address. 



Rows
A row in a table contains one set of data. For example, a table with customer information has one row of data 
for each customer. 



 

Create a unique identifying column for each group of data. In order to accurately access your data, each 
table must be able to uniquely identify each row. For instance, in a table of sales transactions, you must be able 
to tell each transaction apart. Although you can use names to identify rows, numbers are more reliable and you 
can guarantee that each number is unique. An "ID" column is an ideal way to uniquely identify rows. You can 
add an "ID" column to each table, such as a "Customer ID" to the table of customers, and "Employee ID" to the 
table of employees. A column that uniquely identifies rows is also called a primary key.



The ID number is used to uniquely identify a row of data about a customer.



Invoice numbers are unique---the invoice number is used to uniquely identify a row. An ID column is not 
needed. 



The ID number is used to uniquely identify a row of data about a product.



The ID number is used to uniquely identify a row of data about an employee.



Primary key
A primary key is a unique identifier for a row of data in a table. For example, a social security number 
uniquely identifies a person and can be thought of as a primary key. A name, however, cannot be a primary 
key because people can have the same name. 



 

Relate your data with linking columns. A basic concept in a relational database is that data from one table is 
related to data in another table. By relating data, you can ensure that the same data is not stored twice in the 
database. Tables are related by linking columns, which are sometimes called common columns.

For example, the table of customers is related to the table of invoices---each invoice is related to the customer 
who made the purchase. Rather than include customer information both in the Customers table and the Invoices 
table, you can relate the tables. An ID column is usually used as the linking column. The linking column is the 
"Customer ID" column--put this column in the Invoices table to relate the two tables.



The CustomerID column relates customer information from the Customers table to the Invoices table, 
identifying the customer who bought the merchandise.



Rather than storing the customer's name and address in the Invoices table, just the Customer ID is stored. By 
relating the tables with the Customer ID, you don't need to duplicate the customer information each time that 
customer makes a purchase. You reduce the amount of data that needs to be stored, making it easier to update 
customer information. 



The EmployeeID column relates employee information from the Employees table to the Invoices table, 
idenfifying the employee who made the sale.



Relating data
R:BASE links tables to eliminate redundant data and organize data more efficiently. 



Linking column
A linking column connects data in two different tables and defines a relationship between the tables. For 
example, the CustomerID column is in both the Customers table and the Invoices table, and it connects the 
customer information to the invoice information.
Linking columns do not have to have the same name in both tables. 



Common column
A common column is    a column that is used in more than one table, it has the same name in each table, and it 
should have the same information in each table. If columns from different tables have the same name but 
don't have the same information, the column names should be changed. For instance, the First Name column 
in the Customers table is different from the First Name column in the Employees table---one column lists 
customer names, the other lists employee names. Therefore, the First Name column in the Employees table 
has been changed to Emp First Name.



 

Maintain your data in "one-to-many" relationships. Customers are related to invoices because each invoice 
records which customer made the purchase. One customer can make many purchases, but each purchase is 
made by one customer. This relationship is called a "one-to-many" relationship. The Customers table is the 
"one" side, and the Invoices table is the "many" side---one customer to many invoices. 

Check the table lists to make sure the linking ID columns are relating the tables in one-to-many relationships. 



The Invoices table (the many side) links to the Customer table (the one side) using the Customer ID column.



The Invoices table (the many side) links to the Employee table (the one side) using the Employee ID column.



Relationship
A relationship defines the way one table is related another table. The most common relationship is one-to-
many. The other relationships between tables are one-to-one and many-to-many.



One-to-many
"One-to-many" indicates how data in one table is related to data in another table and is the most common 
type of relationship. The linking column between the tables defines the relationship. The column in the "one" 
side has no duplicate values. The column in the "many" side can have many rows of data for each distinct 
value in the "one" side. 



 

Keep your tables long and narrow.    A relational database is not like a spreadsheet; it works best with data 
stored in rows, not columns. For example, one invoice can have several detail lines. Instead of storing a 
transaction on one row with many columns that correspond to the number of detail lines, store general 
transaction data in one table, and store detail lines in another table, with one detail line per row. With this 
design, an invoice can have an unlimited number of detail lines.



A common design mistake is to put recurring elements into one row of data, rather than separate the elements 
into a "one-to-many" relationship. Recurring elements in one row, such as "Price 1", "Price 2", and "Price 
3", creates an inflexible design, inefficient use of storage, and is difficult to query.



The Invoice Number column is used to relate invoice header information (the "one" side) with the detail line 
item information (the "many" side). In other words, you can have many detail lines for one transaction.



When the data is stored vertically, not horizontally, it is easy to query the database. For example, you can 
easily find out how many widgets were sold in December if the product ID number is stored in one column, 
Product ID. It is hard to find the answer if you need to search 10 different columns to find the Product ID. 



 

Once you have designed the database and determined how to group and store the data, you are ready to begin 
creating tables and columns. The Database Designer, also known as RBDefine, lets you create or modify tables. 
From the Tools menu, choose Database Designer or click the Database Designer button on the tool bar.

             



Create a new table by entering a table name in the "Table Name" field. A table name can be up to 18 
characters and must be unique within your database. 



You can enter a description for the table, such as a description of the type of data stored in the table.



Click on the Columns button to add, modify or delete columns in a table.



Click the Keys/Indexes button to add indexes and constraints to a database. You can define an index to 
retrieve data faster. You can apply constraints to tables to ensure that the correct type of data is entered. 



Click the Rules button to add data entry rules---rules prevent invalid data from being entered in a table.



 

Once you have named the table, you are ready to define the columns---click the Columns button. For each 
column, specify the data type, description, and other attributes about each data element. A column name can be 
up to 18 characters long and is unique within a table. Different tables can use the same column name as linking 
columns.



Enter the name of each column on a separate line. If you want to relate two tables, you can use the same 
column name in both tables. R:BASE remembers the column attributes for the column name; you only have 
to define it once. 



Select the type of data to be stored in the column from the drop-down list. Refer to the Data Types topic in 
online Help for complete information about each data type.



A length must be specified for columns with the TEXT data type. 



Check the "Not Null" check box to indicate that the field must always have a value. Later during data entry, 
if a user tries to enter a null value in this column, a message is displayed to remind users to put a value in this 
field.



Check the "AutoNum" check box to automatically number new rows with unique values as they are added to 
the table during data entry. R:BASE enters values in this column, starting with the beginning value and 
increment you specify. An autonumbered column makes a good primary key---this column uniquely identifies 
each row.



Check the "Computed" check box to indicate that the value of this column is computed from the values 
contained in other columns. You can compute numbers, such as price times quantity, or text values, such as 
combining a first and last name to form one complete name.



Data types
A data type defines the type of data placed in a column. R:BASE only lets you enter data in this column if it 
matches its data type. For example, a DATE column would not accept the letters "ABCDE". 



 

Each column can have an optional description and default value. Autonumbered and computed columns require 
additional information to complete the column definition. 

When you have finished defining all the columns for one table, click the Tables button, click the Save button, 
then you can continue to define the next table and its columns.



You can enter a description for each column. The description provides more detailed information about the 
data stored in the column.



Enter the number at which to start the numbering sequence for an autonumbered column.



Enter the number by which to increment each value for an autonumbered column. Usually, the numbers are 
incremented by 1.



Click the "New Key" button to create an index or a constraint for the current column.



Default value
A default value is automatically entered in this column unless the user changes it. For example, in a data 
entry form for entering employee information, you might want to define default values for the area code and 
state. 



 

After defining the tables in your database, set up your indexes and constraints. An index is a cross reference to 
values in a table. It is used to find and sort data quickly. Constraints ensure data integrity by establishing 
automatic controls over data entry, deletion, and modification. The different types of constraintsare primary 
key, unique key, foreign key, and not null. 



A primary key is a unique identifier for a row of data in a table---each row in the column has a unique value 
and cannot be blank. Each table should have a primary key to uniquely identify each row. 



Unique Key
Ensures that a column or set of columns uniquely identifies a row; in other words, each value in a unique-key 
column is unique.



An index is used to quickly look up and sort data. Indexes are usually defined for columns with the 
INTEGER, DATE, and TEXT data types.



A foreign key refers to a primary key that is used in another table. For instance, customer information is in 
the Customers table---the primary key is the Customer ID. If you want sales transactions to refer back to the 
customer, you can have a Customer ID in the Invoices table to tell you who made the purchase without 
repeating the customer information. The Customer ID in the Invoices table is a foreign key. The foreign key 
refers to the information in the Customers table. 



Depending on whether you are defining a constraint or an index, you can specify Not Null, Case Sensitive, 
and Unique attributes. 



A column or set of columns that uniquely identify a row; in other words, each value in a unique-key column is 
unique. A unique-key constraint prevents duplicate (non-unique) and null values from being entered. The 
only difference between a unique key and a primary key is that you can define multiple unique keys per table.



Index
Similar to using an index in a book, R:BASE uses indexes to quickly locate rows that correspond to values 
you specify. 



Primary Key
Ensures that new values in a primary key column are unique. For example, you couldn't use the same invoice 
ID twice. 



Foreign Key
Ensures that values in this column match values in the primary key column. For example, you couldn't enter 
a customer ID for an invoice unless that customer ID exists already in the Customers table.



Not Null
Ensures that values are not blank. For example, you couldn't leave the product ID number blank while 
entering a transaction. 



 

In addition to constraints, rules can be defined to validate data entry. A rule ensures that data in a column meets 
certain specifications. Rules have a broader scope than constraints and allow definition of more varied data 
entry criteria. Rules are stored for each database and are enforced as you enter data.



Select the type of rule. In addition to the default rules, you can select "Custom rule" to define a rule to fit 
your particular data entry situation.



A rule is applied to a specified column in the table you are currently working with. 



Depending on the rule selected, additional parameters might be required. 





 

Once you have defined the database structure and set up the tables and columns for your database, you can 
begin adding information to the tables. You can use either the Data Browser or a form to enter data.



Data Browser
The Data Browser displays information in a tabular format, similar to a spread sheet. You can see many rows 
of data at a time this way.



Forms
You can create a form for entering data. A form has spaces (fields) that correspond to the columns in the 
database. For example, a form for entering customer information has fields that correspond to name, 
company, and address columns from the Customers table.



 

To open the Data Browser, choose Data Browser from the Tools menu, or click the Data Browser button on the 
tool bar. If the table has no data yet, R:BASE prompts you to insert a row (click the Insert button). The Data 
Browser opens in the browse mode. To add data, choose Edit from the Tools menu. The Data Browser changes 
to the Data Editor.

                                                  



Enter a value in the column. To move to the next field, press [Tab] or use the mouse. To add a new row, choose 
Insert Row from the Tools menu.



Options on the Edit menu allow you to add, delete, and modify data. You can also switch to the browse mode.



Options on the Layout menu allow you to reorder columns, change the size of the cells, and change the color 
of the text and background. Customizing the display can help you see and edit data easier.



 

To add data using a form, you must first create it using the Form Designer---choose Form Designer from the 
Tools menu, or click the Form Designer button on the tool bar. A dialog opens for you to define the form.

                                                  



Name the form---the name can be up to 18 characters long.



Enter a description of the form.



The form is associated with the table to which you want to add data---select the table from the drop-down list. 
For example, if you want to use the form to enter customer information, select the Customers table.



Select "Quick." R:BASE automatically places fields for the columns you select.



Select the fields' columns by clicking on the column names. For example, if you want to use the form to enter 
customer names, addresses, and company names, select the corresponding columns.



 

Next, the "Form Designer" window opens, where you 
can customize the form's layout. 

Options on the Layout menu allow you to change the 
text color and font. You can also add boxes and lines to 
the form, move and size fields, and include pictures 
using BLOBs. You can even add descriptive text. 

When you have finished the form, choose File: Save 
Form. 



BLOB (Binary Large Object)
A column with the BLOB data type stores binary data. You can store pictures, video, or audio data.



Click the right mouse 
button on a field for 
layout options.



Drag the handle bars to change the size of the field. Drag the entire field to change its location---field 
placement can make data entry easier.



You can also add descriptive text, such as a title or instructions. Choose Layout: Place Field, then select 
"Text" as the type of field to add, then enter the text. 



 

Once you have created a form, you can use it to enter data---choose Run Form from the File menu, or click the 
Forms Runtime button on the tool bar.

                                                  



Select the form to use.



To add new rows of data, select "Enter." 



 

The form is displayed, and you can start entering data. 
Custom prompts, if defined, indicate the type of data to 
enter. Colors, pop-up menus, field placement, and field 
order make data entry easier.



You can use pop-up menus to display data---users can select values from the menu to enter in the field. You 
can define these custom pop-up menus when you create the form.



Colors and fonts are used to highlight fields for special attention.



A form can display multiple rows (or tiers) of data in an area called a region.



 

Once you have entered data in the database, you can 
view it and modify it. As with adding data, you can use 
the Data Browser and custom forms to view and modify 
data. The Data Browser displays many rows of data at 
once; a form displays data in a customized format with 
fields. 



 

To view data in the Data Browser, choose Data Browser from the Tools menu. You can use the horizontal and 
vertical scroll bars to view all of the data. 

If you want to modify data, choose Edit from the Tools menu. The Data Browser changes to the Data Editor. 

                                                  



To modify data, simply type over the existing data.



Options on the Edit menu allow you to add, delete, and modify data. You can also switch to the browse mode.



Options on the Layout menu allow you to reorder columns, change the size of the cells, and change the color 
of the text and background. Customizing the display can help you see and edit data easier.



 

To view data in a form that you have already created, choose Run Form from the File menu, or click the Forms 
Runtime button on the tool bar.

                                                  



Select the form to use.



To edit or view data, select "Edit."



You can create an optional WHERE clause. This clause specifies the rows of data to display in the form. For 
instance, instead of displaying all invoice information, you could create a WHERE clause to display only those 
invoices over a certain amount.



 

Once the form is displayed, you can view and edit data.



You can use pop-up menus to display data---users can select values from the menu to enter in the field. You 
can define these custom pop-up menus when you create the form.



Colors and fonts are used to highlight fields for special attention.



A form can display multiple rows (or tiers) of data in an area called a region.



 

You can add data to your database tables by importing the data from another product. You can import data from 
other R:BASE databases and other software products such as Excel, Quattro Pro, Lotus, and dBASE. Standard 
ASCII files, delimited and fixed, and DIF files can also be imported. 

To import data, choose Import/Export Database from the Utilities menu, or click the Import/Export button on 
the tool bar. 

                      



You can import data (add data to tables in a database), or export data (copy data from a table into a file). 



Choose the type of data to import, which is determined by the program providing the data. If the data 
comes from a product other than Excel, Quattro Pro, Lotus, or dBASE, you must put the data in an 
ASCII file. You can then import the data using an ASCII option. 



The name of the file or worksheet containing the data. Use the Browse button to select the file.



You can add data to the end of a table, leaving the existing rows of data in the table, or you can replace all the 
data in the table with the data from the specified file.



Select the table to which you want to add data. 



Dates can be stored in many different formats. Usually data is stored in the sequence of month, day, year. You 
can choose the format for the dates you want to import.



Sometimes, rows of data do not match the definition of the specified table. These rows are placed in the 
file you name here. When the import is complete, examine the data in this exception file and correct the 
mismatched data.



ASCII file
An ASCII file is a file that is made up of readable characters, such as letters and numbers. ASCII files are 
often used to transfer data from one program to another. The standard types of ASCII files are delimited and 
fixed. 



DIF
DIF is a standard ASCII file format used for transferring data. This format stores a row of data on separate 
lines---one line for each item in the row. 



Delimited
Delimited is a standard ASCII file format used for transferring data. This format stores each row of data on a 
separate line in the file. Each item in the row is separated by a comma.



Fixed
Fixed is a standard ASCII file format used for transferring data. This format stores each row of data on a 
separate line in the file. Each item in the row is displayed in columns. 





 

The R:BASE relational database design makes it easy to ask different and complex questions about your data. 
Query By Example and the Data Browser work together to help you quickly and easily query your data. Query 
By Example lets you formulate the question, or query, to your database. The Data Browser displays the results 
of the query.

To start Query By Example, choose it from the Tools menu or click the QBE button on the tool bar. 

                                                                          



Query By Example
Query By Example (QBE) is a method of querying data. By defining a query, or question, you can join data 
from related tables and analyze the results in the Data Browser. 



 

You can create a query in the "Query By Example" window. The first step is thinking of the question, or query; 
what data do you want to see? Then, select the tables needed for the query. Next, you can specify what data you 
want to see---this part of the query is called the WHERE clause. Specify the query conditions using the 
WHERE Builder. For example, query conditions indicate the specific data you want to see, such as a list all the 
customers who made transactions over a certain amount. After you build the query, you can view the results in 
the Data Browser.

You can save the query and use it again---a saved query is called a view. You can also save the results of the 
query---the specific data---in a new table. 



Select the tables to see data from. For example, if you wanted to list all the transactions for one customer, you 
need to select the Customer table and the TransMaster table. 



The tables are joined automatically based on linking columns. For example, the linking columns between the 
Customer table and the TransMaster table is the Customer ID column, telling you which customers made the 
transactions. 



Click on a table name 
with the right mouse 
button to display more 
QBE options in a 
pop-up menu. 

 



As you construct the query, R:BASE builds the corresponding SQL statement used to retrieve your answer. 



 

Most applications and businesses make labels using the data stored in their database. You can print mailing 
labels using data from a customer list, or you can print product or shipping labels. You can print labels on 
standard label stock, including laser labels. 

To design a label, choose Label Designer from the Tools menu, or click the Label Designer button on the tool 
bar.

                                                    



Enter a one- to eighteen-character label name. 



You can enter a description of the labels, such as the purpose. 



Select the table from which the labels will retrieve data. For example, if you wanted to print mailing labels for 
customers, select the Customers table. 



Select Quick to have R:BASE automatically set up the labels with the fields you choose. 



The spaces (fields) on the label correspond to columns in the selected table---select the columns for which you 
want to display information. For example, for customer mailing labels, select the columns for the customer 
name, address, city, state, and zip. 



 

Next, specify the dimensions of the label. Choose Settings from the Layout menu, and select the type of label 
from the list of standard label templates. Then, in the "Label Designer" window, you can arrange the fields 
within the label boundaries. 



Select a standard label template to use. 



The label dimensions can be customized to fit any label stock. Select the template that fits your label the 
closest, then you can modify any of the dimensions as needed.



 

Once the label has been designed, print the labels. Select Print from the File menu or click the Print button on 
the tool bar.

                                                    



Optionally, you can specify the rows of data to print by creating a WHERE clause. For example, you might 
want to print labels only for those customers who made transactions in the past year. 



Select Labels. 



The labels that are defined for the current database are listed---select the label you want to print. 



 

Once you have selected the label and specified the data to print, choose where you want to print the labels.



Select the print destination(s). You can print the labels to the printer, to the screen as a preview, and to a text 
file. You can use text files in other programs such as a word processor.



The current printer setting is displayed---you can modify the printer setup if necessary. 



 

You can print data from a table or the results of a query; however, if you want to print data in a customized 
format, you can print a report. In addition to being able to include data from more than one table, reports allow 
you to compute totals, subtotals, and other calculations on your data.

To create a report, start the Report Designer by selecting it from the Tools menu, or click the Report Designer 
button on the tool bar.

                                    



Enter a one- to eighteen-character report name. 



Enter a description of the report. 



Select the table or view from which the report will retrieve data. For example, to print a sales report, select 
the Customer table. 



Select Quick to have R:BASE automatically set up the report with the fields you choose. 



The spaces (fields) on the report correspond to columns in the selected table---select the columns for which 
you want to display information. For example, to print a report on sales transactions, select the columns for 
the transaction ID, description, amount, and so on. 



For Quick reports, choose the format:
Column-wise places fields across the top of the page, displaying data in columns. 

Row-wise places fields along the side of the page, displaying data in rows. 



 

Next, the "Report Designer" window opens, where you can customize the report's layout. 

Options on the Layout menu allow you to change the text font. You can also add boxes and lines to the report, 
move and size fields, and add descriptive text. 

When you have finished the report, choose File: Save Report. 



Click the right mouse 
button on a field for 
layout options.



You can also add descriptive text, such as a title. Choose Layout: Place Field, then select "Text" as the type of 
field to add, and enter the text. 



 

To print the report, choose Print from the File menu, or click the Print button on the tool bar. 

                                    



Optionally, you can specify the rows of data to print by creating a WHERE clause. For example, you might 
want to print invoices for a specific month.



Select Reports.



The reports that are defined for the current database are listed---select the report you want to print. 



 

Once you have selected the report and specified the data to print, choose where you want to print the report.



The current printer setting is displayed---you can modify the printer setup if necessary. 



Select the print destination(s). You can print the reports to the printer, to the screen as a preview, and to a text 
file. You can use text files in other programs such as a word processor. 



 

The report can group data, print header and footer sections, include pictures and graphs through use of BLOB 
data types, and highlight areas of the report using different fonts. 



A page heading section prints at the top of every page. It can include data from a related table. A company 
logo or picture can be placed in the heading. Using the new BLOB data type, graphs, charts, pictures, or 
bitmaps can be printed in any report section.



The detail section of a report is the main part of the report; for instance, in a sales report, the transactions are 
listed here. 



A footer section can be used to print summary totals for a group of data (or breakpoint) that you define in the 
Report Designer. 



A report can have custom titles and descriptions for the columns. Different fonts can be used to highlight 
items or headings.



 

In addition to printing reports and labels, you can also print the contents of the Data Browser or Text Editor. 
For example, you can print the data in a specific table, the results of a query, or an open file in the Text Editor.



 

To print the contents of the current window---the Data Browser or Text Editor---choose Print from the File 
menu, or click the Print button on the tool bar.

                                                                



Select Active Window to print the contents of the current window.





 

An application is a set of custom menus you design to automate tasks you perform in your database. An 
application can print reports and labels, display a form for entering or editing data, and display data in the Data 
Browser. The Application Designer presents an easy, step-by-step approach to creating your own custom 
application.

To start the Application Designer, select it from the Tools menu, or click the Application Designer button on the 
tool bar.

                                                  



Enter a one- to eight-character name for the application. 



Select the type of application to create:
A pull-down menu application has a menu bar across the top with menu options. When you choose 

an option, a submenu drops down with more menu options. 
A pop-up menu application displays a single pop-up menu with menu options. When you choose an 

option, a pop-up menu opens with more options. 



 

In the "Application Designer" window, enter the menu options for the main menu. Then, define the menu 
options for the submenus. Next, define the actions for the menu choices---click on a menu option with the right 
mouse button and choose Menu Item Settings. 

Once you have finished the application, choose File: Save Application. 



Defines the action for the menu option when a user selects it. You can choose from the predefined menu 
actions, or you can create a custom action. 



Instead of an action, a menu option can open another submenu. This submenu can also have menu options 
with actions you assign. To assign a pop-up menu, choose Add Pop-up Menu.



You can place a separator bar on a menu to group items together---choose Separator.



You can assign hot keys to menus and menu options. Place an ampersand (&) before the letter you want to 
use as a hot key. When you run the application, press [Alt] + the hot key letter to open the menu or choose the 
menu option. 



 

To run an application, click the Apps tab in the Object Manager, select the application, and click the Run 
button. The R:BASE menu and tool bar are replaced by your custom menu. You can use your mouse or hot 
keys to open menus and choose menu options.



Menu actions defined to add and edit data.



Menu actions defined to print reports.



A menu option with a hot key. Press [Alt] + the hot key letter, which is underlined, to choose the menu option.






